Inspect IP of caller from server

I would like to inspect the IP address of the caller
to the object at the Server and deny service, besides
making a parameter which is passed with the RMI call of the host address. Is there a way which is part of the
workings of the RMI object.

java.rmi.server.ServerRef.getClientHost()Vlad.

Similar Messages

  • Loosing of object state when it is called from server to client side

    Hi,
    Iam loosing an object values when that object is returning from server side to client side.
    Even my server class implements serilizable interface, the object is not retaing its values..
    can any one suggest regarding this Issue..
    Regards,
    Dev

    got the solution

  • RFC with Multilevel Hierarchy call from Server Proxy

    Dear Experts,
    We would like to call BAPI inside a server proxy.
    PI has created an interface structure exactly identical as the BAPI structure, but while generating ABAP proxy, system has added additional controller structure for each hierarchy.
    Now our ABAP team is facing the difficulty to map Proxy structure with BAPI Structure as now the structures are not identical any more due to control structure .
    Also since the BAPI has multilevel hierarchy and to fill the bapi structure from proxy structure (which is having the same structure as bapi but with control records) there are lots of loops required.
    Please share your thoughts on how to get rid of looping on proxy structure when both the structure are identical but only control structure has been added to proxy structure.
    Also would like to know if we can restrict the control structure generation during proxy generation process.
    - Shri

    Yes, you have to read and map the abap proxy structure to bapi structure.
    Take a look here:
    http://help.sap.com/saphelp_nw04/helpdata/en/ab/585f3c482a7331e10000000a114084/content.htm

  • Web Service call from Documaker Server?

    Hi folks,
    We have a process where we'd like to create a document, and import (via AddMultiPageBitmap rule) an existing external document to send with the newly-created document. This external document is stored in FileNet. We could use a Java application to read our input file, call an Webservice utility to retreive the necessary documents and put them onto the server that we'd run the Documaker engines (GenData/GenPrint) on, where they could then find and import them from. However, rather than develope a new java application to do that, we're wondering whether we can call this webservice utility from within Documaker to retreive the documents from FileNet, and either do so within the AddMultiPageBitmap rule (eliminating the need to actually place the document on the server by just returning the bitstream to the Rule in lieu of telling it the file location), or whether we can at least do so prior to the AddMultiPageBitmap rule and put each document onto the server just before calling the AddMultiPageBitmap rule.
    So basically, Is it possible to do a Webservice call from GenData when running in batch on Linux? We're currently running 11.5.
    Thanks,
    Gregg

    Gendata does support custom code, so you could, in theory, write a custom rule that calls a WEB service and writes the TIFF(any supported bitmap) to disk. After this the base Add..Bitmap rule can just pick it up and work as usual.

  • Action link URL calling from another screen from the same web server not work

    Hi there,
    I have an action link URL calling from another screen from the same web server, used the following syntax:
    /analytics/saw.dll?Go&path=.....
    But it is not working, when open the page, it shows error message
              Oops! Google Chrome could not find analytics
    Any help? Thanks!
    Ling

    That's a +1 from me... same issue and yes, isn't inelegant or a shortcoming for some might be the cause of boldness as they rip their hair off their head so thanks in advance for keeping the refinement of the magic potions making the EA secret magic sauce... which may help stop hairloss
    Cheers!
    tfbkny

  • How to call BS Browser Script from Server Script

    I have a req. where a confirmation message need to be displayed to the user from Server Script.
    I have followed the steps described in bookshelf http://download.oracle.com/docs/cd/E05553_01/books/CommSrvAdm/CommSrvAdm_AdvConfig40.html
    and the same is not working. I am invoking the BS from Applet Server script.
    Please let me know if the above steps can be used in our context as it is not at all related to CTI.
    For the above config I have selected one of the existing Profiles in our system and am not sure about the role played by the same.
    Thanks in advance.

    You create a Business Service, then deploy the BS as described in the bookshelf and finally call it through Browser Scripts.
    You can't interact with the browser session from the server the way you describe your requirement.

  • Calling Report Builder From Server(aspx page ) With encrypted username and password

    Hi , 
    Our application needs to have a link to Report Builder which will open a report builder for that current report and user can modify it accordingly.
    Currently our approach is to use a client side(JavaScript) url link which is in form as follows
    http://username:password@domain/ReportServer_SQLDEVELOPER/ReportBuilder/ReportBuilder_3_0_0_0.application?/ReportName
    But we do not want to show username and password in clear text , SO we have tried to pass it through ajax call and call the url from server or pass username and password in Authorization headers . Unfortunately , this does not serve our purpose and we are
    getting Unauthorized in firebug Console .We are using REST Services .Below is screenshot:
    This is a kind of blocker issue for us , So any timely help would be highly appreciated.In case of any queries you can contact me at [email protected]
    Thanks & Regards
    Mohit Methi
    NGC

    Put the domain in the Intranet Zone instead, and try again. They should not be prompted for auth as long as they log in with cached Domain Creds.
    Is the SharePoint site configured to allow NTLM?
    Trevor Seward
    Follow or contact me at...
    &nbsp&nbsp
    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

  • Multiple pdf attachments from server folder using SO_DOCUMENT_SEND_API1

    Dears,
    I am trying to build a program able to send an email with multiple pdf attachments.
    The files are stored in a folder in SAP server.
    I am able to generate a pdf file from a spool and sucessfully attach it to the email using:
    CALL FUNCTION 'CONVERT_OTF_2_PDF'
          IMPORTING
            bin_filesize           = v_bin_filesize
          TABLES
            otf                    = job_output_info-otfdata
            doctab_archive         = it_docs
            lines                  = it_lines
          EXCEPTIONS
            err_conv_not_possible  = 1
            err_otf_mc_noendmarker = 2
            OTHERS                 = 3.
        IF sy-subrc = 0.
          LOOP AT it_lines.
            TRANSLATE it_lines USING ' ~'.
            CONCATENATE gd_buffer it_lines INTO gd_buffer.
          ENDLOOP.
          TRANSLATE gd_buffer USING '~ '.
          DO.
            it_mess_att_aux = gd_buffer.
            APPEND it_mess_att_aux.
            SHIFT gd_buffer LEFT BY 255 PLACES.
            IF gd_buffer IS INITIAL.
              EXIT.
            ENDIF.
          ENDDO.
        ENDIF.
    Internal table it_mess_att_aux is the parameter contents_bin of FM SO_DOCUMENT_SEND_API1.
    I have now 2 files on a server folder which I would like to include as well.
    I am reading the content of the pdf files in following way:
    DATA:   gd_buffer                 TYPE string,
          OPEN DATASET lv_fileserver FOR INPUT IN BINARY MODE.
          IF sy-subrc <> 0.
            MESSAGE e257(zmsgsd) WITH lv_fileserver.
          ELSE.
            CLEAR: it_mess_att_aux[], gd_buffer.
            DO.
              READ DATASET lv_fileserver INTO gd_buffer.
              IF sy-subrc <> 0.
                EXIT.
              ENDIF.
              APPEND gd_buffer TO it_mess_att_aux.
            ENDDO.
            APPEND LINES OF it_mess_att_aux TO it_mess_att.
    I do not understand the purpose of the statement:
            TRANSLATE it_lines USING ' ~'.
    in this context. Could anyone explain it?
    All the files are attached to email with the desired name but corrupted and with the wrong size.
    Can anyone help me build the logic to attach a pdf file from server in a email?
    Thank you in advance,
    Kind Regards,
    João Cabrita

    hi , try this ,it is working fine  .
      DATA: i_objbin LIKE solisti1 OCCURS 0 WITH HEADER LINE,
              i_objpack LIKE sopcklsti1 OCCURS 0 WITH HEADER LINE,
              i_reclist LIKE somlreci1 OCCURS 0 WITH HEADER LINE,
    *          wa_doc_chng LIKE sodocchgi1,
              i_objtxt LIKE solisti1 OCCURS 0 WITH HEADER LINE,
    *         i_objpack LIKE sopcklsti1 OCCURS 0 WITH HEADER LINE,
           i_objhead LIKE solisti1 OCCURS 0 WITH HEADER LINE,
          i_tline TYPE TABLE OF tline WITH HEADER LINE,
          i_record LIKE solisti1 OCCURS 0 WITH HEADER LINE,
          wa_doc_chng LIKE sodocchgi1,
          v_lines_txt TYPE i,
           l_lines TYPE I VALUE '20'.
      CALL FUNCTION 'CONVERT_OTF'
        EXPORTING
          format        = 'PDF'
          max_linewidth = 132
        IMPORTING
          bin_filesize  = bin_filesize
        TABLES
          otf           = int_tab_otf_final
          lines         = int_pdf_tab.
      IF sy-subrc <> 0.
    * MESSAGE ID SY-MSGID TYPE SY-MSGTY NUMBER SY-MSGNO
    *         WITH SY-MSGV1 SY-MSGV2 SY-MSGV3 SY-MSGV4.
      ENDIF.
    *****************soc ranjan***************************
    *  IF full_path IS INITIAL.
    *    CALL METHOD cl_gui_frontend_services=>file_save_dialog
    *      EXPORTING
    **    WINDOW_TITLE         =
    **           DEFAULT_EXTENSION    = 'PDF'
    **    DEFAULT_FILE_NAME    =
    *           file_filter          = 'Portable Document Format (.pdf)' " for restricting saving file only as pdf
    *      CHANGING
    *        filename             = file_name
    *        path                 = file_path
    *        fullpath             = full_path
    *    IF sy-subrc <> 0.
    ** MESSAGE ID SY-MSGID TYPE SY-MSGTY NUMBER SY-MSGNO
    **            WITH SY-MSGV1 SY-MSGV2 SY-MSGV3 SY-MSGV4.
    *    ENDIF.
    *  ENDIF.
    ******************eoc ranjan*****************
    *break-point.
      CONCATENATE full_path git_select_option-pernr INTO path SEPARATED BY '_'.
      CONCATENATE path 'PDF' INTO path SEPARATED BY '.'.
    **  **************************for downloading*********************************
    *  CALL FUNCTION 'GUI_DOWNLOAD'
    *    EXPORTING
    *      bin_filesize = bin_filesize
    *      filename     = path
    *      filetype     = 'BIN'
    *    IMPORTING
    *      filelength   = file_size
    *    TABLES
    *      data_tab     = int_pdf_tab.
    *  IF sy-subrc <> 0.
    ** MESSAGE ID SY-MSGID TYPE SY-MSGTY NUMBER SY-MSGNO
    **         WITH SY-MSGV1 SY-MSGV2 SY-MSGV3 SY-MSGV4.
    *  ENDIF.
      CLEAR : lop , el , sl , cl .
    *  ******************addeddd later  by ranjan  21.04.2011
    DATA : desc TYPE char40 ,
          desc1 TYPE char100 .
      CALL FUNCTION 'QCE1_CONVERT'
    TABLES
    t_source_tab = int_pdf_tab
    t_target_tab = i_record
    EXCEPTIONS
    convert_not_possible = 1
    OTHERS = 2.
    IF sy-subrc <> 0.
    WRITE : / 'Error in conversion of pdf lines'(015).
    ENDIF.
    APPEND LINES OF i_record TO i_objbin.
    *Creation of the entry for the compressed attachment
    DESCRIBE TABLE i_objbin LINES bin_filesize.
    i_objtxt = 'Hi'.
    APPEND i_objtxt.
    i_objtxt = '                                     '.
    APPEND i_objtxt.
    i_objtxt = 'Pls  find  the attached  salary slip ' .
    APPEND i_objtxt.
    i_objtxt = '  '.
    APPEND i_objtxt.
    i_objtxt = '  '.
    APPEND i_objtxt.
    i_objtxt = '  '.
    APPEND i_objtxt.
    i_objtxt = '  '.
    APPEND i_objtxt.
    i_objtxt = '  '.
    APPEND i_objtxt.
    i_objtxt = '         '.
    APPEND i_objtxt.
    i_objtxt = '  '.
    APPEND i_objtxt.
    i_objtxt = '  '.
    APPEND i_objtxt.
    i_objtxt = '        '.
    APPEND i_objtxt.
    i_objtxt = '  '.
    APPEND i_objtxt.
    i_objtxt = '         '.
    APPEND i_objtxt.
    i_objtxt = '  '.
    APPEND i_objtxt.
    i_objtxt = '  '.
    APPEND i_objtxt.
    i_objtxt = '         '.
    APPEND i_objtxt.
    i_objtxt = '  '.
    APPEND i_objtxt.
    i_objtxt = 'Regards:  '.
    APPEND i_objtxt.
    i_objtxt = 'Corporate HR  '.
    APPEND i_objtxt.
    DESCRIBE TABLE i_objtxt LINES L_LINES.
    READ TABLE i_objtxt INDEX L_LINES.
    wa_doc_chng-doc_size = ( L_LINES - 1 ) * 255 + STRLEN( i_objtxt ).
    *Creating the entry for the compressed document
    CLEAR i_objpack-transf_bin.
    i_objpack-head_start = 1.
    i_objpack-head_num = 0.
    i_objpack-body_start = 1.
    i_objpack-body_num = L_LINES.
    i_objpack-doc_type = 'RAW'.
    APPEND i_objpack.
    ***CLEAR:  i_objpack .
    ***i_objpack-transf_bin = ' '.
    **i_objpack-head_start = 1.
    **i_objpack-head_num = 0.
    **i_objpack-body_start = 1.
    **i_objpack-body_num = L_LINES.
    **i_objpack-doc_type = 'TXT'.
    **i_objpack-obj_descr = desc1 .
    **APPEND i_objpack.
    *CLEAR: i_objhead .
    *i_objhead = DESC.
    *APPEND i_objhead.
    *break-point .
    i_objpack-transf_bin = 'X'.
    i_objpack-head_start = 1.
    i_objpack-head_num = 1.
    i_objpack-body_start = 1.
    i_objpack-body_num = bin_filesize.
    i_objpack-obj_name = 'Employee Payslip'.
    i_objpack-obj_descr = 'Employee Payslip'.
    i_objpack-doc_size = bin_filesize  * 255 .
    i_objpack-doc_type = 'PDF'.
    APPEND i_objpack.
    CONCATENATE 'Salary Slip of Month' p_month INTO desc SEPARATED BY ' ' .
    *DESCRIBE TABLE i_objtxt LINES v_lines_txt.
    *READ TABLE i_objtxt INDEX v_lines_txt.
    ****wa_doc_chng-doc_size = ( v_lines_txt - 1 ) * 375 + STRLEN( i_objtxt ).
    wa_doc_chng-obj_name = 'Payslip'.
    wa_doc_chng-expiry_dat = sy-datum + 10.
    wa_doc_chng-obj_descr = desc.
    wa_doc_chng-sensitivty = 'F'.
    wa_doc_chng-doc_size = v_lines_txt * 255.
    CLEAR i_objpack.
    DATA: l_usrid_long TYPE pa0105-usrid_long.
    DATA : emessage(70) TYPE c.
    CLEAR : l_usrid_long.
    SELECT SINGLE usrid_long
    FROM pa0105
    INTO l_usrid_long
    WHERE pernr = git_pa0001-pernr
    AND subty = '0010'.
    *break-point.
    IF sy-subrc EQ 0.
    i_reclist-receiver = l_usrid_long.                     
    i_reclist-rec_type = 'U'.
    i_reclist-com_type = 'INT'.
    APPEND i_reclist.
    ELSE.
    WRITE:/ 'No email id is maintained for this personnel number' , git_pa0001-pernr.
    ENDIF.
    IF NOT i_reclist[] IS INITIAL.
    ***************************************for senders id *************************************
    CALL FUNCTION 'SO_DOCUMENT_SEND_API1'
      EXPORTING
        document_data                    = wa_doc_chng
      put_in_outbox = 'X'
       sender_address                   = 'xys'
       sender_address_type              = 'SMTP'
       commit_work                      = 'X'
    * IMPORTING
    *   SENT_TO_ALL                      =
    *   NEW_OBJECT_ID                    =
    *   SENDER_ID                        =
      TABLES
    packing_list = i_objpack
    object_header = i_objhead
    contents_bin = i_objbin
    contents_txt = i_objtxt
    receivers = i_reclist
    EXCEPTIONS
    too_many_receivers = 1
    document_not_sent = 2
    document_type_not_exist = 3
    operation_no_authorization = 4
    parameter_error = 5
    x_error = 6
    enqueue_error = 7
    OTHERS = 8.          .
    IF sy-subrc <> 0.
    * MESSAGE ID SY-MSGID TYPE SY-MSGTY NUMBER SY-MSGNO
    *         WITH SY-MSGV1 SY-MSGV2 SY-MSGV3 SY-MSGV4.
    ENDIF.

  • Emails to/from server always bounce to some domains

    Sorry if I'm posting this in the wrong place. I've wasted 2 full days and sporadic time throughout the last 3 weeks on this.
    I recently migrated a site from Server 2003 to a new Windows Server 2008 server. Ever since the move, my emails to and from my email address bounce from the server. I've spent 3 weeks with tech support on both ends getting nowhere.
    Here's a rundown of the problem and what I've done about it:
    Problem 1: Email from my domain (call it mydomain .tld) sent to the new server (call it serverdomain .tld) always bounces
    Emails sent from mydomain .tld to serverdomain .tld get bounced back INSTANTLY with the error "550-The mail server could not deliver mail to "user@ serverdomain .tld".  The account or domain may not exist, they may be blacklisted, or missing the proper
    dns entries."
    Problem 2: Email from serverdomain .tld sent to mydomain .tld always bounces
    Emails sent from serverdomain .tld directly to mydomain .tld always bounce back after a 5-10 second delay with the error "550 Sender verify failed."
    All emails were sent directly from server to server using webmail interfaces.
    Possible problems/solutions I've explored:
    Spam Filtering:
    The new server's mail server (SmarterMail 2010) has spam filter bouncing disabled. No blacklists or greylists are defined.
    The server hosting my email account is a shared hosted server, so I don't have access to its spam settings, but I have been assured by their technical support that the server's IP address is not blacklisted or blocked in any way.
    Blacklist tests at MXToolBox.org all come up clean.
    SPF Records:
    I have defined an SPF (TXT) record for the domain "v=spf1 ip4:xxx.xxx.xxx.xxx -all", which points to the IP address of the mail server / web server. I do not have a type (SPF) record as Windows Server doesn't have an option for this type of record.
    SPF test passes without errors at www . kitterman.com/spf/validate.html. Test email through spf-test@ openspf.net returns no errors.
    Reverse Lookup:
    I have a working reverse IP set up and is confirmed by checking it at ipadmin.junkemailfilter.com/rdns.php that points back to serverdomain .tld.
    Testing through Telnet actually works:
    I followed the steps at technet.microsoft.com/en-us/library/bb123686.aspx to log into the SMTP server on the new server's end and was able to successfully send an email manually to the new server, even using the same email address that keeps failing to send
    directly to the server.
    Some observations from the logs:
    When sending email from mydomain .tld to serverdomain .tld, NO LOG ENTRIES are created at serverdomain .tld. This leads me to believe something is blocking it before it ever connects to the server.
    When sending email from serverdomain .tld to mydomain .tld, the following log entries are created:
    13:02:50 [60055] Delivery started for user@ serverdomain .tld at 1:02:50 PM
    13:02:53 [60055] Skipping spam checks: No local recipients
    13:02:56 [60055] Sending remote mail for user@ serverdomain .tld
    13:02:56 [60055] Initiating connection to xxx.xxx.xxx.xxx
    13:02:56 [60055] Connecting to xxx.xxx.xxx.xxx:25 (Id: 1)
    13:02:56 [60055] Connection to xxx.xxx.xxx.xxx:25 from xxx.xxx.xxx.xxx:65260 succeeded (Id: 1)
    13:02:56 [60055] RSP: 220-mydomain-host.tld ESMTP Exim 4.77 #2 Wed, 24 Oct 2012 13:02:58 -0700
    13:02:56 [60055] RSP: 220-We do not authorize the use of this system to transport unsolicited,
    13:02:56 [60055] RSP: 220 and/or bulk e-mail.
    13:02:56 [60055] CMD: EHLO serverdomain .tld
    13:02:56 [60055] RSP: 250-mydomain-host.tld Hello serverdomain .tld [xxx.xxx.xxx.xxx]
    13:02:56 [60055] RSP: 250-SIZE 52428800
    13:02:56 [60055] RSP: 250-AUTH PLAIN LOGIN
    13:02:56 [60055] RSP: 250-STARTTLS
    13:02:56 [60055] RSP: 250 HELP
    13:02:56 [60055] CMD: MAIL FROM:<user@ serverdomain .tld> SIZE=951
    13:02:56 [60055] RSP: 250 OK
    13:02:56 [60055] CMD: RCPT TO:<user@ mydomain .tld>
    13:02:57 [60055] RSP: 550-Verification failed for <user@ serverdomain .tld>
    13:02:57 [60055] RSP: 550-The mail server could not deliver mail to user@ serverdomain .tld.  The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.
    13:02:57 [60055] RSP: 550 Sender verify failed
    13:02:57 [60055] CMD: QUIT
    13:02:57 [60055] RSP: 221 mydomain-host.tld closing connection
    13:02:57 [60055] Bounce email written to 851023860056.eml
    13:02:57 [60055] Delivery for user@ serverdomain .tld to user@ mydomain .tld has completed (Bounced)
    13:02:59 [60056] Delivery started for  at 1:02:59 PM
    13:02:59 [60055] Delivery finished for user@ serverdomain .tld at 1:02:59 PM    [id:851023860055]
    13:03:02 [60056] Skipping spam checks: Internally Generated Message
    13:03:05 [60056] Starting local delivery to user@ serverdomain .tld
    13:03:05 [60056] Delivery for  to user@ serverdomain .tld has completed (Delivered) Filter: None
    13:03:05 [60056] End delivery to user@ serverdomain .tld
    13:03:05 [60056] Delivery finished for  at 1:03:05 PM    [id:851023860056]
    Configuration:
    The new server uses Windows Server 2008 for DNS.
    The mail server is also hosted at the same IP as the DNS server.
    DNS Records for Serverdomain .tld:
    [All xxx.xxx.xxx.xxx IP addresses point to the server's IP address]
    Forward Lookup Zone: Serverdomain .tld
    (same as parent folder) (SOA) 57, servername., hostmaster.
    (same as parent folder) (NS) servername
    (same as parent folder) (MX) [10] xxx.xxx.xxx.xxx
    (same as parent folder) (TXT) v=spf1 ip4:xxx.xxx.xxx.xxx -all
    * (A) xxx.xxx.xxx.xxx
    mail (A) xxx.xxx.xxx.xxx
    mail (MX) [10] xxx.xxx.xxx.xxx
    mail (TXT) v=spf1 ip4:xxx.xxx.xxx.xxx -all
    ns1 (A) xxx.xxx.xxx.xxx
    ns2 (A) xxx.xxx.xxx.xxx
    www (A) xxx.xxx.xxx.xxx
    Reverse Lookup Zone: xxx.xxx.xxx.in-addr.arpa (syntax of IP is backwards, does not include last 3 digits)
    (same as parent folder) (SOA) 10, servername., hostmaster.
    (same as parent folder) (NS) servername
    xxx.xxx.xxx.xxx (PTR) Serverdomain .tld
    I'm totally at a loss. This is not just blocking email to/from me, but it has blocked email to at least one other domain name as well. I can get no useful help from tech support on either end.
    (I had to put spaces in all links in this post because it wouldn't let me post links. Also, this forum crashes every single time I try to post in IE9, but works fine in FireFox. How ironic is that...)

    I can only help with Exchange, but generally speaking, that line;
    13:02:57 [60055] RSP: 550-The mail server could not deliver mail to user@ serverdomain .tld.  The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.
    Mean the server checked the GAL (it's global adress book) and it refused it. It's usually a simple antispam and antirelay configuration. The strange thing is the log after, that the email is received...
    That lead me to think the antispam software/hardware is badly configured, and for a reason X, it does not block the email from passing by it's filter. So yes, their answer is correct, but that mean all email is filtered in some way, so it's not
    correct in some way too.
    Does they configured your domain alias correctly and such basic information ? I have a big doubth at this point.
    Run some wireshark to be sure the problem is not in your CIE, and after pass that to their IT's tech, if the email is sent correctly, and you receive a server answer back, then something in their config is not ok.
    Don't forget that if the packet X is sent on your WAN to their datacenter, they are responsable for the correct receiving when it enter their datacenter.
    (edited: A last point; don't forget they HAVE to run a antispam's box, as the MX is the same IP, so basicly the antispam box dispatch the email to the correct server (like check
    https://www.barracudanetworks.com/ns/downloads/Setup_Guides/Barracuda_Email_Security_Service_SG_US.pdf) you will see what I mean, a list of domain and server)
    MCP | MCTS 70-236: Exchange Server 2007, Configuring
    Want to follow me ?  |  Blog:
    http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

  • Flex application not working when deployed run from Server

    Hi,
    I have Flex application which takes a parameter from user, makes a web-service call and returns the message.
    This application is running perfectly when I launch from IDE.
    But when I copy the files from bin-release to server and launch it, it gives me no result.
    In the crossdomain file on the server which hosts web-service, I have added the my host IP in the
    allow-access-from domain tag.
    In the initialization method of the application I load crossdomain using following code:
        Security.allowDomain("remoteservername");
        Security.loadPolicyFile("http://remoteservername/crossdomain.xml");
        var request:URLRequest = new URLRequest("http://remoteservername/crossdomain.xml");
        var loader:URLLoader = new URLLoader();
        loader.load(request);
    Is there a way I can debug application when running from server?
    Please give me some pointer to solve this problem.
    Thank you.
    Chintan

    Alex thanks for reply
    The URL for the app is http://<some_IP>/flex_app
    <some_IP> is added in crossdomain.
    Also we have outbound IP's and of these are also added in the crossdomain file.
    This is the current content of crossdomain file:
    <cross-domain-policy>
    <site-control permitted-cross-domain-policies="master-only"/>
    <allow-access-from domain="<some_IP>"/>
    <allow-access-from domain="<outbound_IP1>"/>
    <allow-access-from domain="<outbound_IP2>"/>
    <allow-access-from domain="<outbound_IP3>"/>
    <allow-http-request-headers-from domain="<outbound_IP1>" headers="SOAPAction"/>
    <allow-http-request-headers-from domain="<outbound_IP2>" headers="SOAPAction"/>
    <allow-http-request-headers-from domain="<outbound_IP3>" headers="SOAPAction"/>
    </cross-domain-policy>
    App runs perfectly fine when launched from Flex Builder.

  • "Unable to load workflow actions from server. Please contact your server."

    I get the following error message when I want to create or open a workflow in SharePoint Designer 2007
    "unable to load workflow actions from server. Please contact your server
    administrator."
    I don't receive this error as a site collection administrator, but one of my contributors gets the error.

    What Chris mentioned is kind of abnormal situation described in
    http://office.microsoft.com/en-us/sharepointdesigner/HA102379121033.aspx#20.
    However, normally, you won’t be able to create SPD workflow if you only have Contribute permission level. I give the user Design permission level then he can
    create SPD workflow.
    There are other factors affecting permission to create SPD workflow:
    1.     
    According to
    http://office.microsoft.com/en-us/sharepointdesigner/HA101005871033.aspx#4
    , the SPD workflows are stored in a site-level hidden document library called Workflows. You should make sure that user have permission in this document library so that the created workflow can be saved successfully.
     http://blogs.msdn.com/sharepointdesigner/archive/2008/11/25/locking-down-sharepoint-designer.aspx
    describe the method to manage permission for this hidden Workflows document library: open the site in SharePoint Designer >> right-click the Workflows library >> click Properties >> click the Security tab >> click the link “Manage
    permissions using the browser”
    2.     
    SharePoint Designer contributor setting (http://office.microsoft.com/en-us/sharepointdesigner/HA101174691033.aspx
    ) can also block the user from being able to create workflows.

  • Reading text from server socket stream

    I have a basic cd input program i've been trying to figure out the following problem for a while now, the user enters the artist and title etc and then a DOM (XML) file is created in memory this is then sent to the server. The server then echos back the results which is later printed on a html page by reading the replys from the server line by line.
    The server must be run it listens for clients connecting the clients connect and send DOM documents through the following jsp code.
    <%@page import="java.io.*"%>
    <%@page import="java.net.*"%>
    <%@page import="javax.xml.parsers.*"%>
    <%@page import="org.w3c.dom.*"%>
    <%@page import="org.apache.xml.serialize.*"%>
    <%!
       public static final String serverHost = "cdserver";
       public static final int serverPort = 10151;
    %>
    <hr />
    <pre>
    <%
            Socket mySocket = null;          // socket object
            PrintWriter sockOut = null;      // to send data to the socket
            BufferedReader sockIn = null;    // to receive data from the socket
            try {
                //  #1 add line that creates a client socket
                mySocket = new Socket(serverHost, serverPort);
                // #2 add lines that create input and output streams
                //            attached to the socket you just created
                 sockOut = new PrintWriter(mySocket.getOutputStream(), true);
                 sockIn = new BufferedReader(new InputStreamReader(mySocket.getInputStream()));
            } catch (UnknownHostException e) {
                throw e; // This time the JSP can handle the exception, not us
            } catch (IOException e) {
                throw e; // This time the JSP can handle the exception, not us
    String cdTitle, cdArtist, track1Title, track1Time, track1Rating;
    // Retrieve the HTML form field values
    cdTitle = request.getParameter("cdtitle");
    cdArtist = request.getParameter("cdartist");
    track1Title = request.getParameter("track1title");
    track1Time = request.getParameter("track1time");
    track1Rating = request.getParameter("track1rating");
    // Create a new DOM factory, and from that a new DOM builder object
    DocumentBuilderFactory factory = DocumentBuilderFactory.newInstance();
    DocumentBuilder builder = factory.newDocumentBuilder();
    // Note that we are creating a new (empty) document
    Document document = builder.newDocument();
    // The root element of our document wil be <cd>
    // It gets stored as the child node of the whole document (it is the root)
    Element rootElement = document.createElement("cd");
    document.appendChild(rootElement);
    // Create an element for the CD title called <title>
    Element cdTitleElement = document.createElement("title");
    // Add a text code under the <title> element with the value that
    // the user entered into the title field of the web form (cdTitle)
    cdTitleElement.appendChild(document.createTextNode(cdTitle));
    // Place the <title> element underneath the <cd> element in the tree
    rootElement.appendChild(cdTitleElement);
    // Create an <artist> element with the form data, place underneath <cd>
    Element cdArtistElement = document.createElement("artist");
    cdArtistElement.appendChild(document.createTextNode(cdArtist));
    rootElement.appendChild(cdArtistElement);
    // Create a <tracklist> element and place it underneath <cd> in the tree
    // Note that it has no text node associated with it (it not a leaf node)
    Element trackListElement = document.createElement("tracklist");
    rootElement.appendChild(trackListElement);
    // In this example we only have one track, so it is not necessary to
    // use a loop (in fact it is quite silly)
    // But the code below is included to demonstrate how you could loop
    // through and add a set of different tracks one by one if you
    // needed to (although you would need to have the track data already
    // stored in an array or a java.util.Vector or similar
    int numTracks = 1;
    for (int i=0; i<numTracks; i++) {
      String trackNum = Integer.toString(i+1);
      Element trackElement = document.createElement("track");
      trackElement.setAttribute("id", trackNum);
      trackListElement.appendChild(trackElement);
      // Track title element called <title>, placed underneath <track>
      Element trackTitleElement = document.createElement("title");
      trackTitleElement.appendChild(document.createTextNode(track1Title));
      trackElement.appendChild(trackTitleElement);
      // Track time element called <time>, placed underneath <track>
      Element trackTimeElement = document.createElement("time");
      trackTimeElement.appendChild(document.createTextNode(track1Time));
      trackElement.appendChild(trackTimeElement);
      // Track rating element called <rating>, placed underneath <track>
      Element trackRatingElement = document.createElement("rating");
      trackRatingElement.appendChild(document.createTextNode(track1Rating));
      trackElement.appendChild(trackRatingElement);
    OutputFormat format = new OutputFormat();
    format.setIndenting(true);
    // Create a new XMLSerializer that will be used to write out the XML
    // This time we will serialize it to the socket
    // #3 change this line so that it serializes to the socket,
    // not to the "out" object
    XMLSerializer serializer = new XMLSerializer(writer, format);
    serializer.serialize(document);
            // Print out a message to indicate the end of the data, and
            // flush the stream so all the data gets sent now
            sockOut.println("<!--QUIT-->");
            sockOut.flush();
            BufferedReader stdIn = new BufferedReader(new InputStreamReader(System.in));
            String fromServer;
            String fromUser;
             #4 add a while loop that reads text from the
            server socket input stream, line by line, and prints
            it out to the web page, using out.println(...);
            Note that because the reply from the server will contain
            XML, you will need to call upon the toHTMLString() method
            defined below to escape the < and > symbols so that they
            will display correctly in the web browser.
            Also note that as you receive the reply back from the
            server, you should look out for the special <!--QUIT-->
            string that will indicate when there is no more data
            to receive.
            while ((fromServer = sockIn.readLine()) != null) {
            out.println(sockIn.readLine());
                // If the reply from the server said "QUIT", exit from the
                // while loop by using a break statement.
                if (fromServer.equals("QUIT")) {
                    out.println("Connection closed - good bye ...");
                // Print the text from the server out to the user's screen
                out.println("Reply from Server: " + fromServer);
                // Now read a line of text from the keyboard (typed by user)
                fromUser = stdIn.readLine();
                // If it wasn't null, print it out to the screen, and also
                // print a copy of it out to the socket
                if (fromUser != null) {
                    out.println("Client: " + fromUser);
                    sockOut.println(fromUser);
            // Close all the streams we have open, and then close the socket
            sockOut.close();
            sockIn.close();
            mySocket.close();
    %>
    I'm suppose to modify the commented sections labled with #.
    #1,2 are correct but i have doubts on the 3rd and 4th modification.
    for #3 i changed so i serializes to the socket not to the "out" object:
    from
    XMLSerializer serializer = new XMLSerializer(out, format);
    to
    XMLSerializer serializer = new XMLSerializer(writer, format);
    with "out" it prints out some of the results entered but it just hangs i'm thinking it might be the while loop that i added in #4. If i changed it to serialize the socket XMLSerializer serializer = new XMLSerializer(writer, format); it doesn't print out nothing at all; just a blank screen where it hangs.
    I can post the rest of the code (server thats in java and cdinput.html) but since i want to keep my post short and if required i'll post it later on i also omitted some of the code where it creates the DOM textnodes etc to keep my post short.

    On your previous thread, why did you say the server was using http POST and application/xml content type when it quite obviously isn't, but a direct socket communication that abuses XML comments for message end delimiters?
    The comments imply you need to wait for "<!--QUIT-->" on a line by itself, but your loop is waiting for "QUIT".
    Pete

  • How can i transfer more than one file from server to client

    Hi,
    our requirement is transfer more than one files from server to client using the
    webutil_file_transfer.as_to_client_with_progress.One file transfer is already working in our system.If anybody know the solution please inform
    regards
    mat

    just an idea ...
    for this purpose let us put aside security concerns and other potential problems....
    -- Get the content of a server directory with Filter and create zip file
    1) create a class that implements java.io.FilenameFilter ...
    2) define accept() method ...
    3) call File.list() with the filter as a parameter. The returned array of strings will have all the names that passed through the accept() filter
    4) use java.util.Zip to create ZIP file on the server side
    -- I think it is better to create this functionality as a separate Java class, put it in required folder and after it
    -- use Forms->Program->"Import Java class" to create pl/sql wrappers, than to create wrappers for all classes and code in pl/sql
    5) use webutil to transfer file on the client
    6) use Java on client side to unzip transferred file
    if you think this is not too complicated, you should try ...
    Regards,
    Vladimir

  • If i used the same apple id and email to set up both my ipad and ipod what can i do to be able to use face time to call from one device to the other

    if i used the same apple id and email to set up both my ipad and ipod what can i do to be able to use face time to call from one device to the other

    They can share an Apple ID, but each device must use a different email address when setting up FaceTime.  Create a gmail email (or hotmail, or ...) address and use that on one of the devices when you setup FaceTime.
    You don't actually have to use the 'new' email address, it is probably just used as an index to reference the correct device when initiating a call via the FaceTime server.

  • How can i transfer a call from SIP 9971 to PBX system on CME router

    hello everybody,
       I have a critical problem about interaction of transfering feature between CME router and pbx panasonic system in some status. let me explain more detail about this issue..i have a SIP 9971(CP-9971) registered on CME at the one site and a voice gateway that is connect with PBX system through a E1 pri trunk connection at the other site. totally the integration between CME and PBX is ok and there is no problem in two direction, i mean i can call pbx system from cp-9971 and vise versa but when i call from a phone  which is registered on PBX site to SIP 9971 which is registered on cisco CME call is connected,then when i try to transfer that call to another phone at PBX site, the session is open between two panasonic phones but no audio transmited in two direction. in addition every thing works fine about SCCP phones(transfer feature works fine). here is my configuration file. i hope someone could help me because i've searched a lot but no result help help help plz....
    cme router 3845 configuration
    VOIP-3845#show running-config
    Building configuration...
    Current configuration : 12657 bytes
    ! Last configuration change at 11:44:01 UTC Mon Oct 31 2011 by admin
    ! NVRAM config last updated at 11:44:02 UTC Mon Oct 31 2011 by admin
    ! NVRAM config last updated at 11:44:02 UTC Mon Oct 31 2011 by admin
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname VOIP-3845
    boot-start-marker
    boot-end-marker
    no aaa new-model
    clock calendar-valid
    dot11 syslog
    ip source-route
    ip cef
    no ipv6 cef
    multilink bundle-name authenticated
    voice-card 0
    voice service voip
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    supplementary-service h450.12
    sip
      bind control source-interface Loopback10
      bind media source-interface Loopback10
      registrar server
    voice register global
    mode cme
    source-address 192.168.2.1 port 5060
    max-dn 720
    max-pool 262
    load 9971 sip9971.9-1-1SR1.loads
    authenticate register
    authenticate realm cisco.com
    tftp-path flash:
    file text
    create profile sync 0063544528862458
    camera
    video
    voice register dn  1
    number 500
    voice register dn  2
    number 600
    voice register dn  3
    number 700
    name test
    voice register template  1
    softkeys idle  Newcall Redial Cfwdall
    softkeys connected  Confrn Endcall Hold Trnsfer
    voice register pool  1
    id mac B8BE.BF23.5242
    type 9971
    number 1 dn 1
    template 1
    username test password test
    camera
    video
    blf-speed-dial 4 600 label "test"
    voice register pool  2
    id mac B8BE.BF9C.5476
    type 9971
    number 1 dn 2
    template 1
    username bank password bank
    camera
    video
    voice register pool  3
    id mac B8BE.BF9C.51D4
    type 9971
    number 1 dn 3
    template 1
    username test1 password test1
    camera
    video
    voice register pool  4
    id mac B8BE.BF9C.4FA2
    number 1 dn 1
    camera
    video
    crypto pki token default removal timeout 0
    crypto pki trustpoint TP-self-signed-1576175886
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1576175886
    revocation-check none
    rsakeypair TP-self-signed-1576175886
    crypto pki certificate chain TP-self-signed-1576175886
    certificate self-signed 01
      30820241 308201AA A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 31353736 31373538 3836301E 170D3131 31303038 30393034
      34365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 35373631
      37353838 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100D6EC 47BCDC3C 82F43FF3 23522678 2616868D 9910DCD2 E36016B3 D7B40DA7
      53A6E339 4978D451 21F051BE B21F8AD5 86B952DC 1ECCE371 3E094B54 26A41E14
      A3055C06 AE860756 425E5C50 E62B3287 631B1E87 9BAC2E39 2810E120 DA3BF823
      947EA591 81CA5489 1B868239 E835EC7C 0AA7651A 22D6E47F 545EBEF3 A172C9A3
      5A0D0203 010001A3 69306730 0F060355 1D130101 FF040530 030101FF 30140603
      551D1104 0D300B82 09564F49 502D3338 3435301F 0603551D 23041830 1680146C
      934AD072 99DDC600 ECD6F389 8F71E0C2 18EC2E30 1D060355 1D0E0416 04146C93
      4AD07299 DDC600EC D6F3898F 71E0C218 EC2E300D 06092A86 4886F70D 01010405
      00038181 000E82F6 5FBB847C 49226955 6F7DECE7 0B093513 D57C35D5 4CD22FA7
      8144A080 B0D56C8D 86AF8156 0152443A A3FBE59F B1AEFFBC BEB43E09 35757BAD
      4C06FC4A 0F3695E0 B00FBD30 4E8F36CE 7748F39C F9602650 7A1D2D48 DBC31237
      AE3D63CE 593D31F5 62E4916F D20E30E8 30DC55C0 120FBD26 D2768DBC A67DDC34
      5BDB66B1 E3
            quit
    license udi pid CISCO3845-MB sn FOC14421Q1Y
    archive
    log config
      hidekeys
    username admin privilege 15 secret 5 $1$Zf7j$P93opukmmEBIioVpjmHB3.
    redundancy
    interface Loopback10
    ip address 192.168.2.1 255.255.255.0
    interface Tunnel1
    ip address 172.25.10.1 255.255.255.0
    no ip redirects
    ip nhrp map multicast dynamic
    ip nhrp network-id 10
    tunnel source GigabitEthernet0/1.1
    tunnel mode gre multipoint
    tunnel key 100
    interface Tunnel2
    ip address 172.25.11.1 255.255.255.0
    no ip redirects
    ip nhrp map multicast dynamic
    ip nhrp network-id 20
    tunnel source GigabitEthernet0/1.2
    tunnel mode gre multipoint
    interface Tunnel14
    ip address 192.168.13.129 255.255.255.252
    tunnel source GigabitEthernet0/1.1
    tunnel destination 10.2.68.25
    interface Tunnel18
    ip address 192.168.13.137 255.255.255.252
    tunnel source GigabitEthernet0/1.1
    tunnel destination 10.9.160.236
    interface GigabitEthernet0/0
    no ip address
    shutdown
    duplex auto
    speed auto
    media-type rj45
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    media-type rj45
    interface GigabitEthernet0/1.1
    encapsulation dot1Q 10
    ip address 10.9.160.25 255.255.255.0
    interface GigabitEthernet0/1.2
    encapsulation dot1Q 50
    ip address 10.10.9.25 255.255.255.0
    router eigrp 202
    network 172.25.11.0 0.0.0.255
    network 192.168.2.0 0.0.0.15
    redistribute static route-map MYMAP1
    router eigrp 201
    network 172.25.10.0 0.0.0.255
    network 192.168.2.0 0.0.0.15
    redistribute static route-map MYMAP1
    ip forward-protocol nd
    ip http server
    ip http secure-server
    ip http path flash:/gui
    ip route 10.2.68.0 255.255.255.0 10.9.160.1
    ip route 10.10.0.0 255.255.0.0 10.10.9.1
    ip route 10.64.164.30 255.255.255.255 10.9.160.1
    ip route 192.168.14.0 255.255.255.0 192.168.13.130
    ip route 192.168.17.0 255.255.255.0 Tunnel18
    ip access-list standard REDIS1
    permit 192.168.14.0
    permit 192.168.17.0
    route-map MYMAP1 permit 10
    match ip address REDIS1
    snmp-server community test RO
    tftp-server flash:term11.default.loads
    tftp-server flash:dkern9971.100609R2-9-0-3.sebn
    tftp-server flash:kern9971.9-0-3.sebn
    tftp-server flash:rootfs9971.9-0-3.sebn
    tftp-server flash:sboot9971.111909R1-9-0-3.sebn
    tftp-server flash:sip9971.9-0-3.loads
    tftp-server flash:skern9971.022809R2-9-0-3.sebn
    tftp-server flash:sccp11.9-0-2sr1s
    tftp-server flash:SCCP11.9-1-1SR1S.loads
    tftp-server flash:apps11.9-1-1TH1-16.sbn
    tftp-server flash:cnu11.9-1-1TH1-16.sbn
    tftp-server flash:cvm11sccp.9-1-1TH1-16.sbn
    tftp-server flash:dsp11.9-1-1TH1-16.sbn
    tftp-server flash:jar11sccp.9-1-1TH1-16.sbn
    tftp-server flash:term06.default.loads
    tftp-server flash:sip9971.9-1-1SR1.loads
    tftp-server system:cme/sipphone
    tftp-server flash:Desktops/320x212x12/NantucketFlowers.png
    tftp-server flash:Desktops/320x212x12/TN-CampusNight.png
    tftp-server flash:Desktops/320x212x12/TN-CiscoFountain.png
    tftp-server flash:Desktops/320x212x12/TN-Fountain.png
    tftp-server flash:Desktops/320x212x12/TN-MorroRock.png
    tftp-server flash:Desktops/320x212x12/TN-NantucketFlowers.png
    tftp-server flash:Desktops/320x212x12/Fountain.png
    tftp-server flash:Desktops/320x212x12/CiscoLogo.png
    tftp-server flash:Desktops/320x212x12/TN-CiscoLogo.png
    tftp-server flash:Desktops/320x212x12/List.xml
    tftp-server flash:Desktops/320x216x16/List.xml
    tftp-server flash:Desktops/320x212x16/List.xml
    tftp-server flash:gui/admin_user.html
    tftp-server flash:gui/admin_user.js
    tftp-server flash:gui/CiscoLogo.gif
    tftp-server flash:gui/Delete.gif
    tftp-server flash:gui/dom.js
    tftp-server flash:gui/downarrow.gif
    tftp-server flash:gui/ephone_admin.html
    tftp-server flash:gui/logohome.gif
    tftp-server flash:gui/normal_user.html
    tftp-server flash:gui/normal_user.js
    tftp-server flash:gui/Plus.gif
    tftp-server flash:gui/sxiconad.gif
    tftp-server flash:gui/Tab.gif
    tftp-server flash:gui/telephony_service.html
    tftp-server flash:gui/uparrow.gif
    tftp-server flash:gui/xml-test.html
    tftp-server flash:gui/xml.template
    tftp-server flash:ringtones/Analog1.raw
    tftp-server flash:ringtones/Analog2.raw
    tftp-server flash:ringtones/AreYouThere.raw
    tftp-server flash:ringtones/AreYouThereF.raw
    tftp-server flash:ringtones/Bass.raw
    tftp-server flash:ringtones/CallBack.raw
    tftp-server flash:ringtones/Chime.raw
    tftp-server flash:ringtones/Classic1.raw
    tftp-server flash:ringtones/Classic2.raw
    tftp-server flash:ringtones/ClockShop.raw
    tftp-server flash:ringtones/DistinctiveRingList.xml
    tftp-server flash:ringtones/Drums1.raw
    tftp-server flash:ringtones/Drums2.raw
    tftp-server flash:ringtones/FilmScore.raw
    tftp-server flash:ringtones/HarpSynth.raw
    tftp-server flash:ringtones/Jamaica.raw
    tftp-server flash:ringtones/KotoEffect.raw
    tftp-server flash:ringtones/MusicBox.raw
    tftp-server flash:ringtones/Piano1.raw
    tftp-server flash:ringtones/Piano2.raw
    tftp-server flash:ringtones/Pop.raw
    tftp-server flash:ringtones/Pulse1.raw
    tftp-server flash:ringtones/Ring1.raw
    tftp-server flash:ringtones/Ring2.raw
    tftp-server flash:ringtones/Ring3.raw
    tftp-server flash:ringtones/Ring4.raw
    tftp-server flash:ringtones/Ring5.raw
    tftp-server flash:ringtones/Ring6.raw
    tftp-server flash:ringtones/Ring7.raw
    tftp-server flash:ringtones/RingList.xml
    tftp-server flash:ringtones/Sax1.raw
    tftp-server flash:ringtones/Sax2.raw
    tftp-server flash:ringtones/Vibe.raw
    tftp-server flash:APPS-1.2.1.SBN
    tftp-server flash:SYS-1.2.1.SBN
    tftp-server flash:GUI-1.2.1.SBN
    tftp-server flash:CP7921G-1.2.1.LOADS
    tftp-server flash:TNUX-1.2.1.SBN
    tftp-server flash:TNUXR-1.2.1.SBN
    tftp-server flash:WLAN-1.2.1.SBN
    tftp-server flash:apps37sccp.1-2-1-0.bin
    tftp-server flash:APPSH-1.3.1.SBN
    tftp-server flash:GUIH-1.3.1.SBN
    tftp-server flash:CP7925G-1.3.1.LOADS
    tftp-server flash:SYSH-1.3.1.SBN
    tftp-server flash:TNUXH-1.3.1.SBN
    tftp-server flash:WLANH-1.3.1.SBN
    tftp-server flash:SCCP11.9-2-1S.loads
    tftp-server flash:Desktops/320x212x12/CampusNight.png
    tftp-server flash:Desktops/320x212x12/CiscoFountain.png
    tftp-server flash:Desktops/320x212x12/MorroRock.png
    tftp-server flash:skern9971.022809R2-9-2-1.sebn
    tftp-server flash:sip9971.9-2-1.loads
    tftp-server flash:sboot9971.031610R1-9-2-1.sebn
    tftp-server flash:rootfs9971.9-2-1.sebn
    tftp-server flash:dkern9971.100609R2-9-2-1.sebn
    tftp-server flash:kern9971.9-2-1.sebn
    tftp-server flash:United_States/g4-tones.xml
    tftp-server flash:English_United_States/gd-sip.jar
    tftp-server flash:sboot9971.031610R1-9-1-1SR1.sebn alias sboot9971.031610R1-9-1-1SR1.sebn
    tftp-server flash:rootfs9971.9-1-1SR1.sebn alias rootfs9971.9-1-1SR1.sebn
    tftp-server flash:kern9971.9-1-1SR1.sebn alias kern9971.9-1-1SR1.sebn
    tftp-server flash:dkern9971.100609R2-9-1-1SR1.sebn alias dkern9971.100609R2-9-1-1SR1.sebn
    tftp-server flash:skern9971.022809R2-9-1-1SR1.sebn alias skern9971.022809R2-9-1-1SR1.sebn
    control-plane
    mgcp profile default
    dial-peer voice 1 voip
    description connection-trough-PBX
    destination-pattern 0....
    session target ipv4:192.168.13.130
    dtmf-relay h245-alphanumeric
    no vad
    dial-peer voice 100 voip
    description K
    destination-pattern 9T
    session target ipv4:192.168.13.130
    dtmf-relay h245-alphanumeric
    no vad
    dial-peer voice 5 voip
    shutdown
    destination-pattern *3709
    session protocol sipv2
    session target ipv4:192.168.13.130
    session transport tcp
    dtmf-relay h245-alphanumeric
    codec g711ulaw
    no vad
    dial-peer voice 2 pots
    incoming called-number .
    dial-peer voice 10 voip
    gatekeeper
    shutdown
    telephony-service
    em logout 0:0 0:0 0:0
    max-ephones 262
    max-dn 400
    ip source-address 192.168.2.1 port 2000
    load 7911 SCCP11.9-2-1S
    max-conferences 12 gain -6
    web admin system name admin secret 5 $1$IKnn$tyKyuBcGqXFl6nhxCSu.z0
    dn-webedit
    time-webedit
    transfer-system full-consult
    transfer-pattern .T
    create cnf-files version-stamp 7960 Oct 29 2011 12:39:25
    ephone-template  1
    softkeys connected  Confrn Endcall Trnsfer Hold
    keep-conference endcall
    ephone-dn  1  dual-line
    number 200
    label test
    name test
    ephone-dn  2  dual-line
    number 300
    label Sepahbod
    name Sepahbod
    ephone-dn  4  dual-line
    number 666
    ephone-dn  5  dual-line
    number 660
    ephone-dn  6  dual-line
    number 670
    ephone-dn  7  dual-line
    number 770
    ephone-dn  8  dual-line
    number 770
    ephone-dn  9  dual-line
    number 999
    ephone  1
    device-security-mode none
    mac-address 18EF.639F.BCB0
    keep-conference endcall
    button  1:1
    ephone  2
    device-security-mode none
    mac-address 0025.8418.B017
    ephone-template 1
    keep-conference endcall
    button  1:2
    ephone  3
    device-security-mode none
    mac-address F04D.A243.3154
    keep-conference endcall
    button  1:4
    ephone  4
    device-security-mode none
    mac-address 6CF0.496A.69E9
    button  1:4
    ephone  5
    device-security-mode none
    mac-address 0015.E987.345F
    keep-conference endcall
    button  1:5
    ephone  6
    device-security-mode none
    mac-address 0024.1DEA.614A
    keep-conference endcall
    button  1:6
    ephone  9
    device-security-mode none
    mac-address 001D.7D4D.4DCB
    button  1:9
    line con 0
    line aux 0
    line vty 0 4
    login local
    transport input telnet
    scheduler allocate 20000 1000
    end
    and Voice Gateway connected two PBX system configuration
    Current configuration : 3486 bytes
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Voice-GW
    boot-start-marker
    boot-end-marker
    card type e1 0 2
    no aaa new-model
    network-clock-participate wic 2
    dot11 syslog
    ip source-route
    ip cef
    no ipv6 cef
    multilink bundle-name authenticated
    isdn switch-type primary-net5
    voice service voip
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    h323
    voice-card 0
    crypto pki token default removal timeout 0
    license udi pid CISCO2811 sn FHK1352F0E9
    username admin privilege 15 secret 5 $1$O6AN$1kvvqiLdIl3/ZTHoyYRy0/
    redundancy
    controller E1 0/2/0
    framing NO-CRC4
    pri-group timeslots 1-31
    controller E1 0/2/1
    interface Tunnel14
    ip address 192.168.13.130 255.255.255.252
    tunnel source FastEthernet0/1
    tunnel destination 10.9.160.25
    interface Tunnel17
    ip address 192.168.13.134 255.255.255.252
    tunnel source FastEthernet0/1
    tunnel destination 10.9.160.25
    interface FastEthernet0/0
    ip address 192.168.14.252 255.255.255.0
    duplex auto
    speed auto
    interface FastEthernet0/1
    ip address 10.2.68.25 255.255.255.0
    duplex auto
    speed auto
    interface Serial0/2/0:15
    no ip address
    encapsulation hdlc
    isdn switch-type primary-net5
    isdn overlap-receiving
    isdn incoming-voice voice
    no cdp enable
    router eigrp 201
    network 172.25.10.0 0.0.0.255
    network 192.168.14.0
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip route 10.9.160.0 255.255.255.0 10.2.68.1
    ip route 10.128.0.69 255.255.255.255 Tunnel14
    ip route 192.168.2.1 255.255.255.255 192.168.13.129
    ip route 192.168.17.0 255.255.255.0 Tunnel14
    tftp-server flash:SCCP11.9-2-1S.loads
    tftp-server flash:jar11sccp.9-2-1TH1-13.sbn
    tftp-server flash:dsp11.9-2-1TH1-13.sbn
    tftp-server flash:cvm11sccp.9-2-1TH1-13.sbn
    tftp-server flash:cnu11.9-2-1TH1-13.sbn
    tftp-server flash:apps11.9-2-1TH1-13.sbn
    control-plane
    voice-port 0/0/0
    caller-id enable
    voice-port 0/0/1
    voice-port 0/0/2
    supervisory disconnect dualtone mid-call
    dial-type pulse
    disc_pi_off
    output attenuation 1
    echo-cancel coverage 32
    timeouts call-disconnect 5
    timeouts wait-release 1
    timing hookflash-out 50
    timing sup-disconnect 50
    connection plar 600
    caller-id enable
    voice-port 0/0/3
    caller-id enable
    voice-port 0/2/0:15
    mgcp profile default
    dial-peer voice 1 pots
    description connection-to-PBX
    destination-pattern 0....
    direct-inward-dial
    port 0/2/0:15
    forward-digits 4
    dial-peer voice 10 voip
    destination-pattern ...
    session target ipv4:192.168.13.129
    dtmf-relay h245-alphanumeric
    no vad
    dial-peer voice 20 pots
    description FXO-K
    destination-pattern 9T
    progress_ind alert enable 8
    progress_ind progress enable 8
    progress_ind connect enable 8
    direct-inward-dial
    port 0/0/2
    prefix 9
    dial-peer voice 30 pots
    description FXO-K2
    destination-pattern 9T
    direct-inward-dial
    port 0/0/1
    prefix 9
    telephony-service
    max-ephones 20
    max-dn 100
    ip source-address 192.168.14.252 port 2000
    cnf-file location flash:
    load 7911 term11.default.loads
    max-conferences 8 gain -6
    transfer-system full-consult
    create cnf-files version-stamp Jan 01 2002 00:00:00
    ephone-dn  1
    number 770
    line con 0
    line aux 0
    line 1/0 1/15
    line vty 0 4
    login local
    transport input telnet
    scheduler allocate 20000 1000
    end

    Having looked at your spreadsheet I see you're failing H323 transfers back to your ISDN system, but only under certain circumstances. Quite why, I'm not sure, possibly because you haven't codec defined on your H323 dial peers. or it could be something else
    I think you may be able to work around the problem by adding
    " supplementary-service h450.12 " under voice service voip on your CME router as a quick fix.
    reference
    http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmetrans.html#wpxref44614
    worth a try
    Adam

Maybe you are looking for

  • What is Marketing Manager in OBIEE administrator??

    When to use OBIEE Marketing Manager and in which situations?? Thanks in advance

  • How to create 2 transaction codes for same report program with diff title

    Hi All -   I have created report program and create 2 transaction codes with different short description. I want to display the Tcodes decriptions instead of program attributes title. Can anyone pls tell me how to do this? Thanks, Kannan

  • How to stop the execution of a program

    greets folks i want to know if its possible to stop or let in stand by the execution (run) of a program while HttpService responds the request??

  • LiveCycle and Adobe Reader

    Is there an update to allow people to open LiveCycle Forms in Adobe Acrobat Reader 9? I have made a form but when I publish it, it can only be edited and saved in Reader 8.0 or later and all of the other people who need the form have been update to R

  • How to set inputZ for control inputs ie: strobe, pfix?

    RE: PXI-6551  Need to configure input control for inputZ (50/10k).  ex:  My app. requires strobe input and pfi 2 (input) to have 50 ohm input impedances. Default is 10k.  Property node for input impedance doesn't like "STROBE or PFI 2" etc.