ISchedulerTask - Access Resources

Hi guys,
does anyone of you know how to access a resource from an ISchedulerTask's "run" method?
I want to access an XML-file that contains some configuration data. The XML-file is in the same PAR-file as the ISchedulerTask. Although they are in different directories. The ISchedulerTask class is stored in /classes.api and the XML-file in /dist/conf.
I had the similar problem when I tried to access the XML-file from an iView. But I could solve it by using the method IPortalComponentRequest.getPublicResourcePath(). The getPublicResourcePath method provided me with the absolute path of a directory that contained my XML-File in an sub directory named "conf".
Unfortunately there is no IPortalComponentRequest object that I could use. Does anyone of you know how to find out the path to the XML file from within the "run" method of class ISchedulerTask?
I will appreciate any kind of help. Please advise me.
Martin
Message was edited by: Martin Kellermann

Hello,
actually, it is fairly simple to obtain the path to the resource file. See the code below.
IPortalRuntimeResources resources = PortalRuntime.getRuntimeResources();
String pathToResources = resources.getPathIPortalRuntimeResources.LT_PUBLIC_RESOURCES);
pathToResources = pathToResources + java.io.File.pathSeparator + <YOUR CLASS>.class.getPackage().getName();
The XML file I was looking for is stored in the directory specified by the variable "pathToResources".
Cheers
Martin

Similar Messages

  • Missing version field in response from server when accessing resource

    HY
    I have a problem to use the version option of the webstart. All files are included into a war file (created with jar cvf xx.war *). This file is in the webapps folder of the Tomcat 5. The jar files from the dev. kit (jnlp-servlet.jar, jaxp.jar, parser.jar are in the WEB-INF/lib folder).
    Every time I get the same message:
    Category: Download Error
    Missing version field in response from server when accessing resource: (http://localhost:8080/version/ademo.jar, 1.1)
    Do I need a aditional file or must Iwrite a servlet???
    Whats wrong
    my JNLP file
    <?xml version="1.0" encoding="utf-8"?>
    <!-- JNLP File fuer HJP3 WebStart Demo-Applikation -->
    <jnlp codebase="http://localhost:8080/version/" href="wstest.jnlp">
    <information>
    <title>HJP3 WebStart Demo Application</title>
    <vendor>Guido Krueger</vendor>
    <homepage href="http://www.javabuch.de"/>
    <description>HJP3 WebStart Demo Application</description>
    <icon href="wstest.gif"/>
    <offline-allowed/>
    </information>
    <information locale="de">
    <description>HJP3 WebStart Demo-Applikation</description>
    <offline-allowed/>
    </information>
    <security>
    <!-- <all-permissions/> //-->
    </security>
    <resources>
    <j2se version="1.4+"/>
    <jar href="ademo.jar" version="1.1"/>
    </resources>
    <application-desc main-class="Listing3813"/>
    </jnlp>
    my version.xml file
    <jnlp-versions>
    <resource>
    <pattern>
    <name>ademo.jar</name>
    <version-id>1.1</version-id>
    </pattern>
    <file>application.jar</file>
    </resource>
    </jnlp-versions>
    my web.xml file
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN" "http://java.sun.com/dtd/web-app_2_3.dtd">
    <web-app>
         <servlet>
              <servlet-name>JnlpDownloadServlet</servlet-name>
              <servlet-class>com.sun.javaws.servlet.JnlpDownloadServlet</servlet-class>
         </servlet>
         <servlet-mapping>
              <servlet-name>JnlpDownloadServlet</servlet-name>
              <url-pattern>*.jnlp</url-pattern>
         </servlet-mapping>
    </web-app>

    The log file (jnlpdownloadservlet.log) would show the calls for the jar files if the servlet is called for the jar files (did you correct the url mapping ?). Here are a few lines from a log file
    JnlpDownloadServlet(4): Initializing
    JnlpDownloadServlet(3): Request: /maportal/wfe/wfeguiv.jnlp
    JnlpDownloadServlet(3): User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
    JnlpDownloadServlet(4): DownloadRequest[path=/wfe/wfeguiv.jnlp isPlatformRequest=false]
    JnlpDownloadServlet(4): Basic Protocol lookup
    JnlpDownloadServlet(4): JnlpResource: JnlpResource[WAR Path: /wfe/wfeguiv.jnlp lastModified=Tue Mar 23 17:06:56 CET 2004]]
    JnlpDownloadServlet(3): Resource returned: /wfe/wfeguiv.jnlp
    JnlpDownloadServlet(4): lastModified: 1080058016000 Tue Mar 23 17:06:56 CET 2004
    JnlpDownloadServlet(3): Request: /maportal/wfe/wfegui.gif
    JnlpDownloadServlet(3): User-Agent: JNLP/1.0.1 javaws/1.4.2_03 (b02) J2SE/1.4.2_03
    JnlpDownloadServlet(4): DownloadRequest[path=/wfe/wfegui.gif isPlatformRequest=false]
    JnlpDownloadServlet(3): Request: /maportal/wfe/wfegui.jar
    JnlpDownloadServlet(3): User-Agent: JNLP/1.0.1 javaws/1.4.2_03 (b02) J2SE/1.4.2_03
    JnlpDownloadServlet(4): DownloadRequest[path=/wfe/wfegui.jar isPlatformRequest=false]
    JnlpDownloadServlet(4): Basic Protocol lookup
    JnlpDownloadServlet(4): JnlpResource: JnlpResource[WAR Path: /wfe/wfegui.jar lastModified=Tue Mar 23 17:06:30 CET 2004]]
    JnlpDownloadServlet(3): Resource returned: /wfe/wfegui.jarYou should see all the resources (including jar files) being requested, and whether a specific version was requested or not (in above sample, not).
    I put my problems down to my application server (Orion) as other people seem to have this working. The deployment in Orion keeps the original timestamps of the jars, so I explicitly set the timestamps in my build so that the unchanged jars do not have to be downloaded all the time. This is not really a good solution, so maybe someone else can give further advice.
    Brendan

  • Unable to Access Resource Error in AE CS6

    Hello,
    I'm running After Effects CS6 11.0 on MAC OSX  and everytime I attempt to apply text, either by creating a new text layer from the drop down menu or dragging open a text box I get
    "Unable to Access Resource    P_TextSmallCaps_Sm_N_D (type png)"
    Is this a png file missing from the program, a fixable bug or what?
    Any help at all would be greatly appreciated. Thank you.

    Run the Creative Cloud Cleaner Tool, reinstall the program. Something is damaged.
    Mylenium

  • Project Online - offline project plan prompts for date range to be entered when accessing Resource Usage view

    When I save a project plan to my local computer from Project Online and open it up in an offline mode and access Resource Usage view I get prompted with Date Range dialog boxes with the first one saying "Show resources/assignments that start or finish
    after:" and the second one with "And before:".
    I don't have any filters that are setup in Project Online that are not available in offline mode to trigger these prompts.
    Please let me know what could be causing the date range prompts. Thanks.

    Hi,
    You probably retrieve an enterprise filter into your local file. Just open the organizer from MS Project, go to the filter tab (be sure to have your project selected in the drop down menu at the top left of right of the organizer) and delete the date range
    filter.
    Hope this helps,
    Guillaume Rouyre, MBA, MCP, MCTS |

  • How to remove admin permissions AD DS when admin from one forests access resources in another forest?

    Hello Community
        A  forestA and 
    a forestB exists on the network.
        In forestA, active directory has an administrator.
        In forestB, activre directory also has an administrator.
        There is a trust reletionship between the 2 forests.
        When the administrator for forestA  accesses resources
    in forestB,  how can I make sure that the administrator in
    forestA does not have administrative permissions in foresB?
        Thank you
        Shabeaut

    They do not have access by default unless if you delegate that to them. For high secure environments, you might consider implementing a Selective Authentication: http://technet.microsoft.com/en-us/library/cc755844(v=ws.10).aspx
    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    Get Active Directory User Last Logon
    Create an Active Directory test domain similar to the production one
    Management of test accounts in an Active Directory production domain - Part I
    Management of test accounts in an Active Directory production domain - Part II
    Management of test accounts in an Active Directory production domain - Part III
    Reset Active Directory user password

  • Missing version filed in response from server when accessing resource

    Hello all,
    I am getting the following error when trying to do jar version download in webstart.
    Missing version field in response from server when accessing resource(http://lo alhost:8080/jdc/jnlp/new/SimpleGUI.jar,1.0)
    I am using Tomcat 5.5.
    My web.xml looks like this,
    <web-app>
    <display-name>Tomcat Examples</display-name>
    <description>
    Tomcat Example servlets and JSP pages.
    </description>
    <servlet>
    <servlet-name>
    JnlpDownloadServlet
    </servlet-name>
    <servlet-class>
    jnlp.sample.servlet.JnlpDownloadServlet
    </servlet-class>
    <init-param>
    <param-name>
    logLevel
    </param-name>
    <param-value>
    DEBUG
    </param-value>
    </init-param>
    <init-param>
    <param-name>
    logPath
    </param-name>
    <param-value>
    c:\logs\jnlpdownloadservlet.log
    </param-value>
    </init-param>
    </servlet>
    <servlet-mapping>
    <servlet-name>JnlpDownloadServlet</servlet-name>
    <url-pattern>/jdc/*</url-pattern>
    </servlet-mapping>
    <servlet-mapping>
    <servlet-name>JnlpDownloadServlet</servlet-name>
    <url-pattern>*.jnlp</url-pattern>
    </servlet-mapping>
    <servlet-mapping>
    <servlet-name>JnlpDownloadServlet</servlet-name>
    <url-pattern>*.jar</url-pattern>
    </servlet-mapping>
    </web-app>
    My version.xml file.
    <jnlp-versions>
    <resource>
    <pattern>
    <name>SimpleGUI_v1.0.jar</name>
    <version-id>1.0</version-id>
    <locale>en_US</locale>
    <locale>en</locale>
    </pattern>
    <file>SimpleGUI_v1.0.jar</file>
    </resource>
    <resource>
    <pattern>
    <name>SimpleGUI_v2.0.jar</name>
    <version-id>2.0</version-id>
    <locale>en_US</locale>
    <locale>en</locale>
    </pattern>
    <file>SimpleGUI_v2.0.jar</file>
    </resource>
    </jnlp-versions>
    My jnlp file is as follows,
    <?xml version="1.0" encoding="UTF-8"?>
    <jnlp spec="1.0+" codebase="http://localhost:8080/jdc/jnlp/new" href="SimpleGUI.jnlp">
    <information>
    <title>SimpleGUI</title>
    <vendor>Java Developer Connection</vendor>
    <homepage href="/jdc/jnlp/new/index.html" />
    <description>Demonstration of JNLP</description>
    </information>
    <offline-allowed/>
    <resources>
    <j2se href="http://java.sun.com/products/autodl/j2se" version="1.5+ " />
    <jar href="SimpleGUI_v1.0.jar" version="1.0"/>
    <jar href="AddLogic_v1.0.jar"/>
    <jar href="SimpleGUI_v2.0.jar" version="2.0"/>
    <jar href="AddLogic_v2.0.jar"/>
    </resources>
    <application-desc main-class="com.logic.SimpleGUI" />
    </jnlp>
    For the codebase if I use $$codebase then it reports an error showing,
    The field <jnlp> codebase has an invalid value:$$codebase
    I think the JnlpDpwnloadServlet is not getting invoked. I cant figure out my mistake. I am tired searching in forums and there is no proper answer to this problem. Any help is appreciated.
    Thanks in advance.
    Regards,
    robi

    Thanks for including all your code. I've ran into version download problems before also. In the jar reference don't include the actual __V.jar file name, just include all pre __V.jar. <jar href="AddLogic_v1.0.jar"/> would become <jar href="AddLogic.jar"/>. Now I haven't done it with the version.xml before I just did it with making file named *__V.jar.
    I just re-read all that you did, if you title your files with the __V.jar notation you don't need a version.xml file.
    <jar href="SimpleGUI_v1.0.jar" version="1.0"/>
    Should become
    <jar href="SimpleGUI.jar" version="1.0"/>
    And you would have SimpleGUI_v1.0.jar on your server. Also might need it to be a capital "V" not sure.
    Message was edited by:
    javaunixsolaris

  • Accessing Resource Central

    Pardon my asking this simple question as I suspect I am missing something obvious, (I did a search of the forum and did not find anything on it)
    Where and how do I access RESOURCE CENTRAL ?
    I want to look at the new scores as well as the sound effects
    Thank you

    Thnaks Jeff
    Knew it was something simple
    BUT it does not want to connect - the little circular arrow just goes round and round

  • Accessing resource files inside Jar using Fat Jar Eclipse plugin

    Hi,
    I want to develop single JAR file that uses a set of other JAR libraries. I am using Fat Jar Eclipse plugin. It works fine. However, I have problem to access resources files (i.e. rdf file) using relative path from my classes. Is there any idea how can I pack, set classpath and use relative path in order to make it works.
    Thanks
    Zoran

    I have solved this problem. The problem was in a way how I have trying to access it. It should be like:
    URL fileURL = this.getClass().getResource("resource/myFile.rdf");
    Zoran

  • Accessing resources on device

    How would you access resources, such as media (mp3) stored on the device (flash card), list available such resources, download and save (rather than to the record store) etc.?

    A little summery for future ref:
    Intro
    "The FileConnection API [JSR-075] gives access to file systems and support for file-oriented operations. The API assumes the existence of a file system in the device that can be located, for example, in removable memory cards, flash memory, or other types of persistent storage. This API is not meant to be a replacement for the Record Management System (RMS) but rather a complement to it allowing MIDlets to interact with native applications. For example, a MIDlet could access and manipulate images previously captured by a native application using a built-in digital camera. Those images are commonly stored in the device�s memory and with the FileConnection API they are made accessible to CLDC/CDC1 applications."
    "The API is very simple containing just one class, two interfaces, and two exceptions. The most important part is the FileConnection interface, which extends the Connection interface and gives access to directories and individual files. Implementations of FileConnection are created using the Connector.open() method. The argument of the open() method is a URL with the format file://<host>/<path>, as defined in RFC 1738 [RFC 1738] and RFC 2396 [RFC 2396], where host is normally left empty and path starts with the root of the file system down to a particular file or directory. An example of a typical file URL in a Symbian device looks like the following: file:///C:/Nokia/Images/Image(001).jpg The roots of the file system are device-specific and they don�t necessarily correspond to physical memory units since they are logically defined by the device�s operating system."
    "Since the FileConnection API is an optional extension, a system property has been added to indicate the API�s presence. The microedition.io.file.FileConnection.version system property contains the implemented version of the API. Currently this property should have the value 1.0 to indicate the current status of the API or null if the API is not present."
    supporting environments:
    IBM's J9, PalmOS 5, Windows Mobile 2003.
    Some mobile phones supporting FileConnection are listed here: http://www.benhui.net/modules.php?name=Midp2Phones
    Links:
    http://www-128.ibm.com/developerworks/library/j-pda-op/
    http://jcp.org/aboutJava/communityprocess/final/jsr075/index.html
    http://itpapers.techrepublic.com/abstract.aspx?docid=104503
    http://forum.java.sun.com/thread.jspa?threadID=524143&tstart=210

  • Authorization decision based on property of accessed resource?

    Hi everyone!
    Is it possible to base the decision of a policy service in AM based on a property of the accessed resource? I can specify the method and the resource name, but can I also specify a property of the resource, maybe using some plugin for AM? For example a doctor should only be allowed access to a patient's file if it's his patient, and the patient has a property naming the doctor in charge.
    And another question: How can I take things such as time into account of an authorization decision? I don't want to code this in the application. The application should only ask: May $Subject access $Resource using $Method? Everything else (time, role of subject etc) should be definable on the PDP.
    Thanks for comments!
    Chris
    PS Actually I'd need a PDP which can handle policies as powerful as those definable using XACML combined with the authentication capabilities of AM.

    Found it! First, of course, there are conditions which already cover simple cases. For more elaborate authorization one can add new conditions by extending a java interface, as described here:
    http://docs.sun.com/app/docs/doc/819-4675/6n6qfk0o3?a=view
    By writing a new xml-document you can add a new policy service with arbitrary methods. The process is described in the manual or here:
    http://developers.sun.com/identity/reference/techart/secureapps.html

  • Static PAT entry blocking Branch site from accessing resource on same port. How to get around this?

    Hello, I have a UC560 and UC540 connected using an IPSec Site to Site tunnel.
    There is a server on the main site they are trying to access (lets say IP is 192.168.1.252) and they need to access this server on ports 13000, 14000, and 15000.
    Unfortunately, since there are users from the internet and other places that need to access this server on these ports, these static pat entries are in the server (Lets say 99.99.99.99 is the WAN IP):
    ip nat inside source static tcp 192.168.1.252 13000 99.99.99.99 13000 extendable
    ip nat inside source static tcp 192.168.1.252 14000 99.99.99.99 14000 extendable
    ip nat inside source static tcp 192.168.1.252 15000 99.99.99.99 15000 extendable
    The users in the branch site that is connected via VPN can reach this server on all TCP ports(RDP, http, etc) so that's not the issue. When I remove these nat statements, the VPN users can access the resource via that port (I.e telnet 192.168.1.252 13000 ) whereas they are shut down and connection fails if the static pat entries are in there.
    I need to have outside users and VPN users be able to access this server whether they are coming in across the VPN goin to 192.168.1.252:13000 or coming in from the internet on 99.99.99.99:13000
    Is there a way around this other than forcing the VPN users to access this server via the WAN IP for these ports? And does anyone know the logic behind this? I'm curious. From what I've seen in other cases, this is expected behavior, I'd just like a better understanding of it.
    Any help on this would be GREATLY appreciated! Thank you

    I hope I explained this properly. If not, please let me know!
    Thanks

  • VPN connects but unable to access resources on remote network

    HI,
    I'm able to ping the ASA interface once  the VPN is connected but unable to access any of the resources located on the remote network such as shares and computers. The cisco vpn client shows data being sent and recieved when I ping the interface on the ASA but it doesn't recieve any data when I attempt to ping or access other resources on the network. 
    ASA Version 8.2(5)
    hostname HOST_NAME
    domain-name default.domain.invalid
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    speed 10
    duplex half
    interface Ethernet0/4
    speed 100
    duplex full
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 10.10.8.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 12.x.x.x x.x.x.x
    boot system disk0:/asa825-k8.bin
    ftp mode passive
    dns domain-lookup inside
    dns domain-lookup outside
    dns server-group DefaultDNS
    name-server 10.10.8.2
    domain-name default.domain.invalid
    same-security-traffic permit intra-interface
    object-group service Vipre tcp
    port-object range 18082 18082
    port-object range 18086 18086
    object-group network town
    network-object 192.168.0.0 255.255.0.0
    access-list outside_20_cryptomap extended permit ip 10.10.8.0 255.255.255.0 192.168.0.0 255.255.252.0
    access-list new extended permit ip host 192.168.0.1 any
    access-list new extended permit ip any host 192.168.0.1
    access-list outside_20_cryptomap_1 extended permit ip 10.10.8.0 255.255.255.0 192.168.0.0 255.255.252.0
    access-list townoffice_splitTunnelAcl standard permit 10.10.8.0 255.255.255.0
    access-list townremote_splitTunnelAcl standard permit 10.10.8.0 255.255.255.0
    access-list outside_access_in extended permit tcp any interface outside object-group Vipre
    access-list outside_access_in extended permit tcp any object-group Vipre interface inside object-group Vipre
    access-list outside_access_in extended permit tcp any eq 3389 10.10.8.0 255.255.255.0 eq 3389
    access-list test extended permit ip host 192.168.0.6 host 10.10.8.155
    access-list test extended permit ip host 10.10.8.155 host 192.168.0.6
    access-list test extended permit ip host 10.10.8.2 host 192.168.3.116
    access-list test extended permit ip host 192.168.3.116 host 10.10.8.2
    access-list test extended permit ip host 10.10.8.155 host 192.168.3.116
    access-list bypass extended permit ip host 10.10.8.155 host 192.168.3.116
    access-list bypass extended permit tcp 192.168.0.0 255.255.0.0 10.10.8.0 255.255.255.0
    access-list bypass extended permit tcp 10.10.8.0 255.255.255.0 192.168.0.0 255.255.0.0
    pager lines 24
    logging enable
    logging buffered debugging
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    ip local pool vpn 10.10.8.125-10.10.8.149 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-522.bin
    no asdm history enable
    arp timeout 14400
    global (inside) 1 interface
    global (outside) 1 interface
    nat (inside) 1 192.168.0.0 255.255.0.0
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp interface 18082 10.10.8.2 18082 netmask 255.255.255.255
    static (inside,outside) tcp interface 18086 10.10.8.2 18086 netmask 255.255.255.255
    static (inside,outside) tcp interface 3389 10.10.8.2 3389 netmask 255.255.255.255
    static (inside,inside) 192.168.0.0 192.168.0.0 netmask 255.255.0.0
    static (inside,inside) 10.10.8.0 10.10.8.0 netmask 255.255.255.0
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 12.70.119.65 1
    route inside 192.168.0.0 255.255.0.0 10.10.8.250 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication ssh console LOCAL
    aaa authentication telnet console LOCAL
    http server enable
    http  outside
    http  outside
    http  inside
    http  outside
    http inside
    http  outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    sysopt noproxyarp inside
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map outside_dyn_map 20 set pfs
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
    crypto dynamic-map outside_dyn_map 40 set pfs
    crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
    crypto dynamic-map outside_dyn_map 60 set pfs
    crypto dynamic-map outside_dyn_map 60 set transform-set ESP-3DES-SHA
    crypto dynamic-map outside_dyn_map 80 set pfs
    crypto dynamic-map outside_dyn_map 80 set transform-set ESP-3DES-SHA
    crypto dynamic-map outside_dyn_map 100 set pfs
    crypto dynamic-map outside_dyn_map 100 set transform-set ESP-3DES-SHA
    crypto map outside_map 20 match address outside_20_cryptomap_1
    crypto map outside_map 20 set pfs
    crypto map outside_map 20 set peer 69.87.150.118
    crypto map outside_map 20 set transform-set ESP-3DES-SHA ESP-3DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash md5
    group 2
    lifetime 86400
    crypto isakmp policy 30
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto isakmp nat-traversal 30
    telnet 10.10.8.0 255.255.255.0 inside
    telnet timeout 5
    ssh 63.161.207.0 255.255.255.0 outside
    ssh timeout 5
    console timeout 0
    dhcpd dns 10.8.8.2
    dhcpd address 10.10.8.150-10.10.8.200 inside
    dhcpd dns 10.10.8.2 interface inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    group-policy aaa internal
    group-policy aaa attributes
    dns-server value 10.10.8.2 4.2.2.2
    vpn-tunnel-protocol IPSec
    default-domain value domainname
    group-policy bbb internal
    group-policy bbb attributes
    wins-server value 10.10.8.2
    dns-server value 10.10.8.2
    vpn-tunnel-protocol IPSec l2tp-ipsec
    split-tunnel-policy tunnelall
    split-tunnel-network-list value townoffice_splitTunnelAcl
    default-domain value domainname.local
    group-policy townremote internal
    group-policy townremote attributes
    wins-server value 10.10.8.2
    dns-server value 10.10.8.2 4.2.2.2
    vpn-tunnel-protocol IPSec
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value townremote_splitTunnelAcl
    default-domain value domainanme
    group-policy remote internal
    group-policy remote attributes
    wins-server value 10.10.8.2
    dns-server value 10.10.8.2
    vpn-tunnel-protocol IPSec
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value townremote_splitTunnelAcl
    default-domain value dksecurity.local
    address-pools value vpn
    username xxxx password . encrypted privilege 15
    username xxxx attributes
    vpn-group-policy dksecurityremote
    username xxx password  encrypted privilege 15
    username xxx attributes
    vpn-group-policy dksecurityremote
    username xxxx password . encrypted privilege 15
    username xxx password  encrypted privilege 15
    username xxx attributes
    vpn-group-policy dksecurityremote
    username xxx password  encrypted privilege 15
    username xxxx attributes
    vpn-group-policy dksecurityremote
    username xxx password  encrypted privilege 15
    username xxx attributes
    vpn-group-policy dksecurityremote
    username xxx password  encrypted privilege 15
    username xxx attributes
    vpn-group-policy dksecurityremote
    username xxx password  encrypted privilege 15
    username xxx password  encrypted privilege 15
    username xxxx attributes
    vpn-group-policy remote
    username xxx password  encrypted privilege 15
    username xxx attributes
    vpn-group-policy remote
    username xxx password  encrypted privilege 15
    username xxx attributes
    vpn-group-policy remote
    username xxxx password  encrypted privilege 15
    username xxx password  encrypted privilege 15
    username xxx attributes
    vpn-group-policy remote
    tunnel-group 69.87.150.118 type ipsec-l2l
    tunnel-group 69.87.150.118 ipsec-attributes
    pre-shared-key *****
    tunnel-group remote type remote-access
    tunnel-group remote general-attributes
    address-pool vpn
    default-group-policy townremote
    tunnel-group townremote ipsec-attributes
    pre-shared-key *****
    isakmp keepalive disable
    tunnel-group townremote type remote-access
    tunnel-group townremote general-attributes
    address-pool vpn
    default-group-policy townremote
    tunnel-group lansingremote ipsec-attributes
    pre-shared-key *****
    class-map tcp-bypass
    match access-list bypass
    class-map test
    match access-list new
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
      no dns-guard
      no protocol-enforcement
      no nat-rewrite
    policy-map global_policy
    class test
    class inspection_default
    policy-map tcp
    class tcp-bypass
      set connection random-sequence-number disable
      set connection advanced-options tcp-state-bypass
    service-policy global_policy global
    service-policy tcp interface inside
    prompt hostname context
    call-home reporting anonymous prompt 2
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:c724d6744097760d94a7dcc79c39568a
    : end

    You need to change the VPN pool ip subnet to something other than the same ip range used on the inside interface.
    Sent from Cisco Technical Support iPad App

  • Accessing Resource file in a bundle from unit test case

    Hello All,
    Here is my problem . I have a plugin app that is loaded in of the host application. I have a resource plist file in the plugin. I access the resource using the api [[[NSBundle mainBundle[ bundleWithIdentifier:@"MyPluginIdentifier"] pathForResource@"Resource_Name" ofType:@"Resource_Type"]. This I get path of the resource file perfectily, but it fails when I do unit testing. I am using SenTest framework kit for unit testing. When I access the resource by using above api, I get null value. Since the running executable will be otest which is located at /Developer/Tools folder, So how to access my resource file in unit test. Should I need to hard code for the Path? Any inputs are highly appreciated.
    Thanks,
    Naveen

    So there is some important stuff realized by the UIKit UIApplicationMain function that has to be reproduced in the setup of the test.

  • Accessing resources in loaded/external SWFs

    I've been looking around for an effective way of solving this
    issue, but without much like. What I'm trying to accomplish is
    creating a container for my newest Flash site in main.swf and
    loading other swf files that provide resources that modify mcs,
    functions etc. of the main.swf. I plan to have main.swf hold my
    background, logo etc. then each subrelated page as contact.swf,
    index.swf to be placed on top of that swf.
    I did find this thread:
    http://www.kirupa.com/forum/archive/index.php/t-241538.html
    but all I managed to get from it is how to reference elements in
    the child from the parent using Loader.content. What I'm trying to
    figure out is how to reference from the child to the parent. ie. if
    I want to modify the background of the main.swf which is contained
    in a function called changeBackground().
    To add some more complexity I am trying to keep as much of my
    code in .as files that are placed in the Document class. So for
    each main.fla I have a main.as and index.fla is index.as. In my
    index.as script I need to determine how to access objects/functions
    contained in main.as.
    I HOPE that I've explained that all properly. If I'm being
    confusing or using inappropriate terms - apologies.

    First, you need a loadComplete function in your icMain class
    to get called after the swf is loaded. You set up that relationship
    already in this line:
    indexLoader.contentLoaderInfo.addEventListener(Event.COMPLETE,
    loadComplete);
    so you need this:
    private function loadComplete(event:Event):void
    then, move these functions into the loadComplete function as
    you have to wait until the swf is loaded before setting the
    reference:
    var indexPage:indexPage = indexLoader.content as indexPage;
    indexPage.icMain = this;
    In your indexPage class, you need to move your set mainSWF
    function outside of the indexPage function. Also, the type of
    object you are passing, according to your code, should be icMain.
    So, instead of this:
    public function indexPage():void
    public function set mainSWF(icMain:MainSWFDocumentClass):void
    _icMain = icMain;
    Do this (notice I changed the name of your variable to avoid
    name conflict. using the convention of starting class names with a
    Capital letter would help too):
    private var _mainSWF:icMain;
    public function indexPage():void
    public function set mainSWF(mainSWF:icMain):void {
    _mainSWF = mainSWF;
    Here is the rewritten icMain class:
    package
    public class icMain extends Sprite
    public function icMain():void
    var indexRequest:URLRequest = new
    URLRequest("index/index.swf");
    var indexLoader:Loader = new Loader();
    indexLoader.contentLoaderInfo.addEventListener(ProgressEvent.PROGRESS,
    loadProgress);
    indexLoader.contentLoaderInfo.addEventListener(Event.COMPLETE,
    loadComplete);
    indexLoader.load(indexRequest);
    private function loadComplete(event:Event):void
    var indexPage:indexPage = indexLoader.content as indexPage;
    indexPage.icMain = this;
    And here is your rewritten indexPage class:
    package {
    public class indexPage extends Sprite
    private var _mainSWF:icMain;
    public function indexPage():void
    public function set mainSWF(mainSWF:icMain):void {
    _mainSWF = mainSWF;

  • Access resources not present directly under web-inf

    hi,
    My web application needs access to resources (e.g XML files, Image resources), with the following constraints:
    1. Resources cannot be bundled into a jar file.
    2. Resources cannot be placed under the context root, i.e. under the WEB-INF/classes. i.e these resources are placed in some other directory
    It would be great help if somebody could throw more light on this topic.
    thanks in advance,
    java developer

    In the %CATALINA_HOME%\bin\catalina.bat (or catalina.sh) file you can add the path to these resoures to the CLASSPATH that is built for tomcat. This should make them available to your web-apps. Then use 'catalina start' or 'catalina run' to start tomcat. If not using tomcat you'll have to look for where the server creates it's classpath.

Maybe you are looking for