Learning native

actually i know java
but i never understood native system programming in java
i even tried the tutorial from java but i cannot understand it
what i want is that somebody please write the whole procedure
in his way , and try to explain me...
i will give him a nice gift for thanks...

Have a look at JNI++ (http://jnipp.sf.net or http://www.sf.net/projects/jnipp). JNI++ is a free, open-source toolkit that makes easy work of bi-directional Java <---> C++ integration -- it will even generate your makefile. Comes complete with a 100-page printable PDF User Guide and plenty of examples to get you started. Even if you don't use JNI++, the User Guide has much detail regarding JNI programming (the first chapter compares native JNI programming with the JNI++ approach). No gift required :).
Good luck with your project.
actually i know java
but i never understood native system programming in
java
i even tried the tutorial from java but i cannot
understand it
what i want is that somebody please write the whole
procedure
in his way , and try to explain me...
i will give him a nice gift for thanks...

Similar Messages

  • SWT_AWT mouse/keyboard event trouble

    Hello everyone,
    I have created an ActiveX Component with Visual C++ that uses a WEmbeddedFrame to contain a Swing based GUI. I have copied the code from the SWT_AWT class in the SWT toolkit and it worked fine up to JDK 1.5.0_03.
    Starting with JDK 1.5.0_04 the Swing GUI does no longer receive Mouse/keyboard events.
    I have read through all available material concerning this problem and I have tried the two possible solutions that these documents suggest:
    - called addNotify() on the embedded frame
    - inserted a heavyweight container (java.awt.Panel) between Embedded Frame and the Swing GUI
    However, no luck. The GUI displays fine but does not respond to user actions.
    Does anybody have an idea what might have changed from 1.5.0_03 to 1.5.0_04, that could help me solve this puzzle?
    Thank you very much in advance,
    Helmut

    SWT works up to 1 tree and two text components only. If you have more than that, you windows will get tainted. Basically it's useless to wirte any useful programs for Windows. You never get comaptible latest look from it both mac and windows. Don't waste time for learning it. You better spend time for learning other things. If AWT/Swing is not good enough, learn native languages such as Visual C++/Basic! I have to say SWT wasn't meant to give us better programming platform!

  • "Learn" no longer working with Euphonix?

    I've been messing around some more with Euphonix hardware. It seems that since there was 'native support' with Eucontrol 2.5.5 and with LP 9.1.1 there is no ability to assign values to the controls.
    This means that Command-L no longer appears to work with any Euphonix hardware.
    Likewise, the 'auto-assign' / 'contextual-assign' mode of Euphonix hardware that reassigns faders and knobs to the control surface when launching a software instrument or AU no longer works.
    Is this a mistake? Has Apple and Euphonix gone and shot themselves in the foot?
    Has anyone found a way of getting all of this to work again?

    Ben_G wrote:
    This means that Command-L no longer appears to work with any Euphonix hardware.
    Trash Logic preference files, boot Logic (a new song, not template) and try to learn some new assignments using Command+K to open the Controller Assignment advanced dialog for instance.
    !http://img59.imageshack.us/img59/4967/aglogo45.gif!

  • Query update on each iteration problem (MS SQL Sever / ODBC / Native Driver

    Hello,
    I�ve been working to learn some Java and now JDBC over the past 10 or so months.
    I think I have a general understanding of how to perform queries and work with data using JDBC. However, I�ve run into a problem. I�m trying to do a query of a set of data in a database based on the value of a status column. I want to loop over the messages and perform various functions with the data then update their status in the database. It�s preferable to do these 250 to 1000 rows at a time, but no more and no less.
    I�m connecting to MS SQL Server 2000, currently with ODBC. I�ve also tried it with the Java SQL Server 2000 drivers provided by Microsoft with the same results.
    I�ve found that I can do a one table query and loop though it with a while (rs.next()) {�} and run an Update statement with executeUpdate on each iteration without any problems, no matter the number of rows returned in query.
    I have not been able to use the updateString and updateRow inside the while loop. I keep getting errors like this at the line with the updateRow():
    Exception in thread "main" java.sql.SQLException: [Microsoft][SQLServer 2000 Driver for JDBC]Row update failed.
    This occurs no mater how many rows I select, 1 or more.
    The real problem I�ve been having is that the query I need to loop though joins across several tables and returns some rows from some of those tables. This only seems to work when I query for 38 or less selected rows and I use an Update statement with executeUpdate on each iteration. The updateString and updateRow methods never work. Any number of rows selected greater than 38 causes a deadlock where the Update is waiting for the select to compete on the server and the Update can�t proceed until the Select is complete.
    As I stated above I�ve tried both ODBC and the native SQL Server driver with the same results. I have not tried any other databases, but that�s moot as my data is already in MS SQL.
    Questions:
    How can I avoid or get around this 38 row limit without selecting each row, one at a time?
    What am I doing wrong with the updateString and updateRow?
    Is there a better approach that anyone can suggest?
    Here�s some sample code with the problem:
    import java.sql.*;
    public class db1{
         public static void main(String[] args) throws Exception{
              Class.forName("sun.jdbc.odbc.JdbcOdbcDriver");
              String url = "jdbc:odbc:eBrochure_live";
              Connection con = DriverManager.getConnection(url, "sa", "d3v3l0p");
              Class.forName("com.microsoft.jdbc.sqlserver.SQLServerDriver");
              Connection con = DriverManager.getConnection("jdbc:microsoft:sqlserver://dcm613u2\\dcm613u2_dev:1433", "sa", "d3v3l0p");
              Statement stmt = con.createStatement(ResultSet.TYPE_SCROLL_SENSITIVE, ResultSet.CONCUR_UPDATABLE);
              Statement stmt2 = con.createStatement(ResultSet.TYPE_SCROLL_SENSITIVE, ResultSet.CONCUR_UPDATABLE);
              stmt.executeUpdate("USE [myDatabase]");
              stmt2.executeUpdate("USE [myDatabase]");
              String qGetMessages = "SELECT TOP 250 t1.messageUUID, t1.subjectHeader, t2.emailAddress as toAddress " +
              "FROM APP_Messages as t1 JOIN APP_addressBook_contacts as t2 " +
              "     On t1.toContactID = t2.contactID " +
              "WHERE t1.statusID = 'queued'";
              ResultSet rs = stmt.executeQuery(qGetMessages);
              while (rs.next()) {
                   String messageUUID = rs.getString("messageUUID");
                   String subjectHeader = rs.getString("subjectHeader");
                   System.out.println(messageUUID + " " + subjectHeader);
                   String updateString = "UPDATE APP_Messages " +
                        "SET statusID = 'sent' " +
                        "WHERE messageUUID = '" + messageUUID + "' ";
                   stmt2.executeUpdate(updateString);
              con.close();
    Thanks for the help,
    Doug Hughes

    // sorry, ps.close() should be outside of if condition
    String sql = "UPDATE APP_Messages SET statusID = 'sent' WHERE messageUUID = ?";
    Statement statement = con.createStatement();
    PreparedStatement ps = con.prepareStatement(sql);
    ResultSet rs = statement.executeQuery("your select SQL");
    if ( rs.next() )
    ps.clearParameters();
    ps.setString(1, rs.getString("your column name"));
    ps.executeUpdate();
    ps.close();
    rs.close();
    statement.close();

  • FLV Playback and Seekbar on different native windows in one Air application

    Hello Everyone.  I'm trying to make a simple video playback AIR application that utilizes the initial native window to house a transport control with a seekbar on it.  Once the application launches, it creates a second (new) window on my second screen and places a FLVPlayback instance on that new window.  Everything works just like it want it to except for one thing.  When the seekbar and FLVplayback instance are not located on the same window stage, the seekbar handle sticks to the mouse when trying to scrub through the video.
    I've added both the transport control and the FLVPlayback instance to the original native window as children and I have also added both of them to the new window as children and everything works just fine.  It's only when they are separated and located on different stages that the seekbar acts up.  When they are on the same stage, I can click on a point on the seekbar and the video jumps to that spot and continues to play and I can also scrub the seekbar, the video updates as I scrub, and when I release the mouse, the seekbar handle stays where I released the mouse.  When they on separate stages, the seekbar handle continues to follow the mouse movement without releasing it.  The video updates as the seekbar handle is moved due to it sticking to the mouse, but if I release the mouse, the handle is still moving with the mouse and the video is still being scrubbed.  Like I said, everything works great except for this and I have reached my limit with time spent on this issue.  Does anyone have any insight into this?
    Here's my code for the project.  This is my first AIR application, so I am coding it as I am learning, please be kind.
    import fl.video.*;
    import flash.display.*;
    import flash.desktop.*;
    import flash.events.*;
    import fl.video.MetadataEvent;
    import flash.geom.*;
    import flash.ui.Mouse;
    import flash.text.*;
    GLOBAL SETUP
    var flvControl:FLVPlayback;
    var MasterWindow = stage.nativeWindow;
    var screen1:Screen = Screen.screens[0];
    var screen2:Screen = Screen.screens[1];
    MASTER WINDOW SETUP
    this.loaderInfo.addEventListener(Event.COMPLETE,maximize);
    transControl.playPauseButt2.addEventListener(MouseEvent.CLICK, PlayButton);
    if (Screen.screens.length > 1){
              createVideoBKG();
              createVideoPlayer();
    GENERAL FUNCTIONS
    //Maximize the initial screen
    function maximize(e:Event) {
              MasterWindow.x = screen1.bounds.left
              MasterWindow.maximize();
              MasterWindow.stage.scaleMode = StageScaleMode.EXACT_FIT;
    //Hide Mouse Behind Video Window On Roll-Over
    function MouseRollOver(e:MouseEvent):void
              {          Mouse.hide()          }
    function MouseRollOut(e:MouseEvent):void
              {          Mouse.show()          }
    //Play-Pause Button Control
    function PlayButton(event:MouseEvent):void
                        if(transControl.playPauseButt2.currentFrame==1 ){
                                  transControl.playPauseButt2.gotoAndPlay(2);
                                  flvControl.play();
                        else {
                                  transControl.playPauseButt2.gotoAndPlay(1);
                                  flvControl.pause();
    function CloseWindow(e:MouseEvent):void
                        NativeApplication.nativeApplication.openedWindows[2].close();
    VIDEO BKG SETUP
    function createVideoBKG(e:Event = null):void{
              var newOptions:NativeWindowInitOptions = new NativeWindowInitOptions();
              newOptions.type = NativeWindowType.LIGHTWEIGHT;
              newOptions.systemChrome = NativeWindowSystemChrome.NONE;
              newOptions.transparent = true;
              var videoBKG:NativeWindow = new NativeWindow(newOptions);
              if (Screen.screens.length > 1){
                        videoBKG.x = screen2.bounds.left;
              videoBKG.maximize();
              chromeSetup(videoBKG);
              videoBKG.activate();
    //Video BKG Chrome Setup
    function chromeSetup(currentWindow):void {
              var vidBKG = new video_bkg();
              vidBKG.name = "video_bkg2";
              vidBKG.addEventListener(MouseEvent.ROLL_OVER, MouseRollOver);
              vidBKG.addEventListener(MouseEvent.ROLL_OUT, MouseRollOut);
              currentWindow.stage.addChild(vidBKG);
    VIDEO Player SETUP
    function createVideoPlayer(e:Event = null):void{
              var newOptions:NativeWindowInitOptions = new NativeWindowInitOptions();
              newOptions.type = NativeWindowType.LIGHTWEIGHT;
              newOptions.systemChrome = NativeWindowSystemChrome.NONE;
              newOptions.transparent = true;
              var videoPlayer:NativeWindow = new NativeWindow(newOptions);
              if (Screen.screens.length > 1){
                        videoPlayer.x = screen2.bounds.left;
                        videoPlayer.y = screen2.bounds.top;
                        videoPlayer.width = screen2.bounds.width;
                        videoPlayer.height = screen2.bounds.height;
                        videoPlayer.stage.scaleMode = StageScaleMode.NO_SCALE;
              videoPlayer.alwaysInFront = true;
              var DVR = new DVR_Player();
              DVR.name = "DVR";
              DVR.x = 0;
              DVR.y = 0;
              DVR.addEventListener(MouseEvent.ROLL_OVER, MouseRollOver);
              DVR.addEventListener(MouseEvent.ROLL_OUT, MouseRollOut);
              videoPlayer.stage.addChild(DVR);
                flvControl = DVR.display2;
              flvControl.width = 1280;
              flvControl.height = 720;
              flvControl.skin = null;
              flvControl.autoPlay=false;   
              flvControl.isLive=false;
              flvControl.fullScreenTakeOver = false;
              flvControl.align = VideoAlign.CENTER;
              flvControl.scaleMode = VideoScaleMode.NO_SCALE;
              flvControl.source = "olympics.f4v";
              flvControl.seekBar = transControl.seekbarContainer2.seeker;
              videoPlayer.activate();

    Does anyone have any ideas about this?

  • How do I add these native iOS blue menu boxes to my apps?

    I would like to have these menus for various things in my apps, those that look like this:
    Although this example image I took from Google shows it on the home screen, I want to use them in my apps, not outside. I don't really know what they are called and all my attempts to find code for this on Google has failed. I have extensions which makes these pop-up, like Milkman Game's Push Notification extension, but there's no code for using these in an app manually, only way to make them pop-up is if Urban Airship sends out a push notification message to the phone.
    So, anyone know what the code would be to use these? Maybe an extension for just this sort of thing is needed as they are not included in Adobe Air. Only way I can think of is just faking it by just showing a vector/bitmap of this menu, but I don't want to do it that way.

    Thanks for taking your time (once again) to reply, and sorry for the time it took for me to reply, but better late than never right
    If you have all code in one place, you'll certainly have to search it with Ctrl+F to find the method you want. It's not very different if you have multiple classes.
    Yup, like I've said before, all in one place so I simply just search for what I want to work with, having // here and there for faster finding. So it doesn't make it more conventient to have the code in multiple classes, even if I can maybe search through them all with Ctrl+H or whatever, as having the code in one place as I have now yelds these benefits over classes: way less code, less files, all code in one place (and more for other various reasons).
    Even if you have it structured in sections using comments, it's looks pretty painful to me to scroll through such a big file (I know, because I've sometimes had to edit pretty long code files). Plus everything outside a method is in the global scope. It's pretty easy to mess up when all methods have access to all variables. That's what public/private/protected is for.
    I know what these public/private/protected things are for, and with my way I don't have to use them and never have any conficts anyway. I have no need for them and using them doesn't make coding easier for me. I have my simple and conventient way of handling all my variables and functions without conflicts, it's all very easy to not mess up, no need for these extra things, and once again, using them just means more code and the use of as files which also is not needed.
    Imports are still needed when coding in the Actions panel, as you said a few posts ago, where you were having problems importing with asterisk. Using other IDEs all imports are handled for you. And you can even add an import for a class under the cursor just by pressing Ctrl+1.
    Yup, but only maybe 5% of the imports needed if using classes is needed when doing it my way, so way less code. It's very rarely I need to import something other than some nifty as files I'm using, like one for hitTesting. They are single as files so np to import, was a bit different with those in com.folder.folder.etc, usually that's easy and works straight away every time, but not this time, but I figured it out, still no good reason to code in classes as the benefits of what I'm doing outweighs the other way by tons, as mentioned above.
    I also use the Flash IDE to create screens. I agree it's easier to do it in a WYSIWYG environment. But then I don't add any code to it, because it would be a nightmare to search code inside all those movieclips. The code belongs to separate AS classes, so there's good separation between code and design, and a graphic designer could edit the graphics without understanding a line of code.
    I don't add code inside movieclips, that's not very efficient and structurised if having code everywhere, hence why I do it all in one frame. Sure, a lot of times it's much easier if I just have some code inside movieclips, but I always try to have it in one and the same place anyway, but sometimes I can get lazy . There is no problem editing the graphics on my apps, I can even import them if needed, then the graphic designer just have to update the outside pictures and not touch anything inside Flash or anywhere. If I'm using vectors I can just import them from an swf, so the graphics designer just have to change the graphics in that without touching the game or movieclips or code etc. So, for an outsider to fiddle with the graphics is no problem, only if I made it all inside my Flash app with code everywhere on frames inside movieclips etc, which is not very organized.
    Well, I wrote the code like that for clarity, though maybe it was too many lines for such a simple piece of code, but I don't do it like that necessarily always. It depends on the length. If it's short, I do it in one line. If it's a lot of code, I prefer to break it in several lines for readability. I don't think less lines mean faster readability, but rather the opposite.
    For example. What code do you think it's more readable?
    This one? http://code.jquery.com/jquery-1.9.1.js
    Or this one? http://code.jquery.com/jquery-1.9.1.min.js
    They both do EXACTLY the same. The computer does not care
    Ok, maybe the example is a bit extreme, but you get the point
    Yup, like I said, it depends on the code if I would do something similar like you did or not, usually it's not needed and I do it as I showed earlier as it makes less code and still easy to read.
    For the example: of course http://code.jquery.com/jquery-1.9.1.js looks way better and is a bad example . No one would ever code like that, not me anyway, I follow my auto-formatting style: (copy/paste from Flash Auto-Format settings section)
    function f(x) {
      if (x <= 0) {
        return 1;
      } else {
        return x * f(x - 1);
    As that's the one I find best. Each thing has its own place. It's no problem getting fewer rows of code, but it has to look good and be structurized and not have tons of scrolling to the far left, like in your "bad" example . Eventhough http://code.jquery.com/jquery-1.9.1.js looks way better than the other one (of course), I would have done it a bit differently resulting in fewer rows, less code and still keeping my standard formatting of things.
    You're missing a lot of features this way. Just one example. You can create your own button class, with your own features, event listeners automatically added when added to stage and removed when removed from stage, a property that sets the text, pressed states, etc. And then you don't have to do that again ever in your app. Instead, now you have to add and remove event listeners each time you have to add a button. And this is just a tiny example. For more complex stuff, it would save even more time.
    You're just throwing away decades of programming, created by great minds, much better than you and me (combined ), just because you don't want to learn to do it the right way. And I'm by no means a great programmer. But still, I think you're shooting yourself in the foot by coding that way.
    No need to create button classes when I do it right on the "canvas?". I know I can do them dynamically and for that I don't need classes. I just make my buttons in Flash and then remove/add listeners to them as needed, np, tons less code. If I would need to be able to remove the entire button, to maybe save memory or whatever, then I could just create them with code, but it's not needed and creating them with code as you mentioned above doesn't need classes, but that's what it sounds like it does if I read your text correctly. I can do what you mentioned above without classes and less code. Even if I couldn't do exactly as you said, the way I can do it now is more than enough anyway, full control over what I need to do and it's less code and less complex.
    Yup, decades of programming by pros (and I'm far from being one, but I'm pretty good anyway, good enough for what I need to do and I like challenges when they arrive, coding ftw ), but that doesn't matter, because why do it the "right" way when my way suits me better as I get soooo many benefits from doing it my own way. I have yet to see any real benefits/advantages in doing it any other way than I'm doing right now, which sort of saddens me a bit , as I want to do it the right way, IF I found it make things faster, easier, more structurized etc etc etc, but it doesn't.
    You need just a few steps to get any of those IDEs working. Not something terribly difficult. Just download FDT Free, the Flex SDK and the latest AIR SDK. Unzip the Flex SDK in a folder, then unzip the AIR SDK in the same folder, overwriting files where needed. Then just configure FDT so it points to the Flex+AIR SDK folder. Finally, create a project and start experimenting . It has pretty good documentation to get started:
    Settings things up are no problem, but it's no use when it clearly doesn't make things "better" for me.
    OOP makes a lot of sense when working in teams. Having everyone working in the same single long sheet of code as you're doing now would be unthinkable. And here's where all those "private/public" thingies come into play. You create your class and the other developer leverages your class using only its public methods and properties. They don't need to know about the exact internals of the class, just the exposed methods and properties you chose to make public. That's how it works.
    I know, and that's what I've said , but I won't change my way of doing things as I'm a solo coder anyway, but like I said earlier (sort of), it would be nice knowing I could work with others if I just coded correctly. Changing my ways to the "right" way have too few benefits to me, and even if I did change my way, it would result in me having to learn a lot of new things, getting into a lot of problems etc till I know how it all works. What I mean is if I use the right way, I could get lots of problems where I'm not quite sure what's causing them, as I'm then using as files instead, with new code I've not needed before, problems with variables if I don't set the private/public etc right and stuff. Not worth it as I would be backtracked and have to relearn things. Now if I have a bug or problem, I can usually fix it very fast as I understand it all perfectly now (years of experience), but changing to the new way would add many new variables and take me time to solve problems (depending on what they are) as things have changed. But like I said, doing that has no real benefits to me anyway so I'm staying my my old ways.
    By that description (getting a notification after you quit the app), I think what you need are Push Notifications, which were added to AIR in version 3.4. You don't need a native extension for that. Take a look here:
    http://www.adobe.com/devnet/air/articles/ios-push-notifications.html
    If you just want notifications INSIDE your app, you can still use the NativeAlert / NativeDialogs extension to display the messages, and use getTimer() to get the time before and after (i.e: you get the value of getTimer() when you want to start counting, and then you get it again from time to time to check if enough time has passed. Not sure if the Timer class (as opposed to the getTimer() method) can do that as well while the app is inactive.
    Well, I hope any of this helped a bit
    I have Push Notifications (bought from Milkman Games) and it works, but only receiving them when sent from the Urban Airship (I can recieve them anywhere, even if the app is off). It didn't work like I was hoping, which is what I said in my earlier post. I wanted something that could send a Push Notification or some sort of alert message to the user when a certain time has passed, can't seem to do that with the Push Notification from Milkman Game. I know the consept and how to use the getTimer() of course, but it doesn't help me. Here's a scenario I would like to be able to do:
    * Player builds somehing, 1 hour remains till it's done, so the leave/quit the app
    * One hour has gone and a notification pops up telling the user that whatever they built in the app is now ready
    * The user starts the app and the thingy has been done
    I now have the Native Alert and Milkman Games extensions working, but none of these can do what I want. Of course I would use a getTimer() to check the time they start building the thingy, store it on the phone in one of those shared object files, then when the user returns, it checks if enough time has gone since he started building it as the starting time was stored and I can check current time either from their phone or the internet (internet is more secure or they can cheat, which I have in some games by chaning the iphone time). So, no problem there, the problem is how I can alert them about these things outside the app. Only way I can think of is if maybe they have to log into an account on a server I host which receives their timer stuff, so if the app is off and 1 hour has gone by, the server will send out a message to urban airship and tell it to send a notification to the user.... bleh... But that's not how other people have done it as I don't have to be logged into anything to recieve these things.
    So, unfortunately, there are still not even close to enough benefits for me to change my ways. Changing it to the "right" way would still just mean all the things mentioned before: more files, more code, more complications as I have to relearn things which will result in problems I can't that easily fix, unlike now as I understand everything...
    edit/ps: I haven't proof-read anything above, no idea if I explained myself properly or if there's tons of spelling errors, I just wrote away, posted and now I'm off, bit in a hurry....

  • Bug on native code of OJVM java.util.zip.CRC32.updateBytes(CRC32.java)

    I want to unzip OpenOffice 1.0 files inside the OJVM but it fails into the native method java.util.zip.CRC32.updateBytes(CRC32.java).
    The first execution of the code runs OK, but the second not.
    After a long wait it shutdown the connection and the oracle trace file shows an stack trace like this:
    *** 2003-04-18 11:31:31.926
    *** SESSION ID:(17.97) 2003-04-18 11:31:31.926
    java.lang.IllegalArgumentException
    at java.util.zip.CRC32.updateBytes(CRC32.java)
    at java.util.zip.CRC32.update(CRC32.java)
    at java.util.zip.ZipInputStream.read(ZipInputStream.java)
    at oracle.xml.parser.v2.XMLByteReader.fillByteBuffer(XMLByteReader.java:354)
    at oracle.xml.parser.v2.XMLUTF8Reader.fillBuffer(XMLUTF8Reader.java:142)
    at oracle.xml.parser.v2.XMLByteReader.saveBuffer(XMLByteReader.java:448)
    at oracle.xml.parser.v2.XMLReader.fillBuffer(XMLReader.java:2012)
    at oracle.xml.parser.v2.XMLReader.skipWhiteSpace(XMLReader.java:1800)
    at oracle.xml.parser.v2.NonValidatingParser.parseMisc(NonValidatingParser.java:305)
    at oracle.xml.parser.v2.NonValidatingParser.parseProlog(NonValidatingParser.java:274)
    at oracle.xml.parser.v2.NonValidatingParser.parseDocument(NonValidatingParser.java:254)
    at oracle.xml.parser.v2.XMLParser.parse(XMLParser.java:225)
    at com.prism.cms.frontend.EditPropertiesActions.processUpload(EditPropertiesActions.java:1901)
    Exception signal: 11 (SIGSEGV), code: 1 (Address not mapped to object), addr: 0x6d3a74a0, PC: [0x40263600, eomake_reference_to_eobjec
    t()+80]
    Registers:
    %eax: 0x54a54000 %ebx: 0x40429c20 %ecx: 0x54a546bf
    %edx: 0x6d3a7478 %edi: 0x402b27d0 %esi: 0x45c718ac
    %esp: 0xbfffbf20 %ebp: 0xbfffbf48 %eip: 0x40263600
    %efl: 0x00010206
    The code of the java method is:
    public static void processUpload(String id_page, String longname,
    String filename, String filetype,
    String s00)
    throws SQLException {
    Integer p_id = new Integer(id_page);
    String toSource;
    XMLDocument doc = null;
    DOMParser theParser = null;
    InputStream XSLStream = null;
    BufferedWriter out = null;
    #sql { select path||name||'.html' into :toSource from pages where id_page=:p_id };
    if ("Cancel".equalsIgnoreCase(s00)) {
    Jxtp.redirecUrl("/dbprism/ldoc/live/edit.html?p_source="+toSource);
    return;
    if ("no-file".equals(filename) && "no-contenttpye".equals(filetype)) {
    Jxtp.redirecUrl("/dbprism/ldoc/live/edit.html?p_source="+toSource);
    return;
    if ("xml".equalsIgnoreCase(filetype))
    #sql { call CMSj.moveFromUpload(:filename,:p_id) };
    else if ("sxw".equalsIgnoreCase(filetype)) {
    XSLProcessor processor = new XSLProcessor();
    XSLStylesheet theXSLStylesheet = null;
    BLOB locator = null;
    // open sxw file, it will be in zip format with a file named content.xml
    // then convert content.xml to document-v10.dtd with an stylesheet
    #sql { select blob_content into :locator from wpg_document where name = :filename for update };
    ZipInputStream zin = new ZipInputStream(locator.binaryStreamValue());
    ZipEntry entry;
    try {
    while((entry=zin.getNextEntry())!=null)
    if ("content.xml".equalsIgnoreCase(entry.getName())) {
    Integer newVersion;
    CLOB dstDoc;
    CMSDocURLStreamHandlerFactory.enableCMSDocURLs();
    try {
    URL inUrl = new URL("cms:/stylesheets/sxw2document-v10.xsl");
    XSLStream = inUrl.openStream();
    // Create the Stylesheet from the stream
    theXSLStylesheet = processor.newXSLStylesheet(XSLStream);
    // Stores the document processing it with the given stylesheet
    theParser = new DOMParser();
    theParser.setValidationMode(theParser.NONVALIDATING);
    theParser.setBaseURL(new URL("cms:/dtd/"));
    theParser.parse(zin);
    doc = theParser.getDocument();
    #sql { SELECT NVL(MAX(version),0)+1 INTO :newVersion FROM content
    WHERE cn_id_page = :p_id };
    #sql { INSERT INTO content( cn_id_page, version, owner, status, source_file,
    file_size, content, created, modified, created_by,
    modified_by)
    VALUES ( :p_id, :newVersion, sys_context('cms_context','user_id'),
    'Uploaded', :filename, 0 , EMPTY_CLOB(), SYSDATE, SYSDATE,
    sys_context('cms_context','user_id'),
    sys_context('cms_context','user_id')) };
    #sql { SELECT content INTO :dstDoc FROM content
    WHERE cn_id_page = :p_id AND version = :newVersion for update };
    #sql { call DBMS_LOB.trim(:inout dstDoc,0) };
    out = new BufferedWriter(dstDoc.getCharacterOutputStream(),dstDoc.getChunkSize());
    processor.processXSL(theXSLStylesheet, doc, new PrintWriter(out));
    #sql { delete from wpg_document where name=:filename };
    } catch (SAXParseException spe) {
    throw new SQLException("processUpload SAXParseException: "+xmlError(spe));
    } catch (SAXException se) {
    throw new SQLException("processUpload SAXException: "+se.getLocalizedMessage());
    } catch (XSLException xsle) {
    throw new SQLException("processUpload XSLException: "+xsle.getLocalizedMessage());
    } finally {
    if (XSLStream!=null)
    XSLStream.close();
    if (theParser!=null)
    theParser = null;
    if (out!=null) {
    out.flush();
    out.close();
    zin.close();
    } catch (IOException ioe) {
    throw new SQLException("processUpload IOException: "+ioe.getLocalizedMessage());
    } finally {
    if (XSLStream!=null)
    XSLStream = null;
    if (out!=null)
    out = null;
    if (zin!=null)
    zin = null;
    Jxtp.redirecUrl("/dbprism/ldoc/live/edit.html?p_source="+toSource);
    Basically it takes the content from a BLOB column of the wpg_document table, unzip it using java.util.zip package, look for the file content.xml and parse it using Oracle XML toolkit.
    Using an open source utility which replace java.util.package (http://jazzlib.sourceforge.net/) it works perfect because is a pure java application.
    Best regards, Marcelo.
    PD: I am using Oracle 9.2.0.2 on Linux.

    The cause of errors was a dying Westen Digital drive, specially the 48G partition reserved only for $ORACLE_BASE (/dev/sdb3 mounted on /opt/oracle).
    A simple quick scan of unmounted partition (badblocks -v /dev/sdb3) reported more than thousand new bad blocks (compared to the last scan six months ago). Although I strongly believe, specially in the case of WDC drives, that the best utility to "repair" bad blocks is the one that opens a window and prints the message: "Go to the nearest shop and buy a new drive", I was very curious to prove my suspicion just on this drive. After zero-filling the partition with dd, then formatting it (mke2fs -cc) and mounting again, the 11g installation and database creation (on the same partition) successfully completed, performing fast and smoothly. To make sure it was not a casual event, I repeated the installation once again with full success. The database itself is working fine (by now). Well, the whole procedure took me more than four hours, but I'm pretty satisfied. I learned once again - stay away from Western Digital. As Oracle cannot rely on dying drive, my friend is going tomorrow to spend a 150+ euro on two 250G Seagate Barracudas and replace both WDC drives, even though the first drive seems to be healthy.
    In general there is no difference between loading correct data from good disk into bad memory and loading the incorrect data from dying disk into good memory. In both cases the pattern is damaged. For everyone who runs into the problem similar to this, and the cause cannot be easily determined, the rule of thumb must be:
    1. test memory and, if it shows any error, check sockets and test memory modules individually
    2. check disks for bad blocks regardless of the result of memory testing
    Therefore I consider your answer being generally correct.
    Regards
    NJ

  • QoS / Native VLAN Issue - Please HELP! :)

    I've purchased 10 Cisco Aironet 2600 AP’s (AIR-SAP2602I-E-K9 standalone rather than controller based).
     I’ve configured the WAP’s (or the first WAP I’m going to configure and then pull the configuration from and push to the others) with 2 SSID’s. One providing access to our DATA VLAN (1000 – which I’ve set as native on the WAP) and one providing access to guest VLAN (1234). I’ve configured the connecting DELL switchport as a trunk and set the native VLAN to 1000 (DATA) and allowed trunk traffic for VLAN’s 1000 and 1234. Everything works fine, when connecting to the DATA SSID you get a DATA IP and when you connect to the GUEST SSID you lease a GUEST IP.
    The problem starts when I create a QoS policy on the WAP (for Lync traffic DSCP 40 / CS5) and try to attach it to my VLAN’s. It won’t let me attach the policy to VLAN 1000 as it’s the native VLAN. If I change VLAN 1000 on the WAP to NOT be the native VLAN I can attach the policies however wireless clients can no longer attach to either SSID properly as they fail to lease an IP address and instead get a 169.x.x.x address.
    I'm sure I'm missing something basic here so please forgive my ignorance.
    This is driving me insane!
    Thanks to anyone that provides assistance. Running config below and example of the error...
    User Access Verification
    Username: admin
    Password:
    LATHQWAP01#show run
    Building configuration...
    Current configuration : 3621 bytes
    ! Last configuration change at 02:37:59 UTC Mon Mar 1 1993 by admin
    version 15.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname LATHQWAP01
    logging rate-limit console 9
    aaa new-model
    aaa authentication login default local
    aaa authorization exec default local
    aaa session-id common
    no ip routing
    dot11 syslog
    dot11 vlan-name Data vlan 1000
    dot11 vlan-name Guest vlan 1234
    dot11 ssid LatitudeCorp
       vlan 1000
       authentication open
       authentication key-management wpa version 2
       wpa-psk ascii
    dot11 ssid LatitudeGuest
       vlan 1234
       authentication open
       authentication key-management wpa version 2
       guest-mode
       wpa-psk ascii
    crypto pki token default removal timeout 0
    username admin privilege 15 password!
    class-map match-all _class_Lync0
    match ip dscp cs5
    policy-map Lync
    class _class_Lync0
      set cos 6
    bridge irb
    interface Dot11Radio0
    no ip address
    no ip route-cache
    encryption vlan 1234 mode ciphers aes-ccm
    encryption vlan 1000 mode ciphers aes-ccm
    ssid LatitudeCorp
    ssid LatitudeGuest
    antenna gain 0
    stbc
    station-role root
    interface Dot11Radio0.1000
    encapsulation dot1Q 1000 native
    no ip route-cache
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    interface Dot11Radio0.1234
    encapsulation dot1Q 1234
    no ip route-cache
    bridge-group 255
    bridge-group 255 subscriber-loop-control
    bridge-group 255 spanning-disabled
    bridge-group 255 block-unknown-source
    no bridge-group 255 source-learning
    no bridge-group 255 unicast-flooding
    service-policy input Lync
    service-policy output Lync
    interface Dot11Radio1
    no ip address
    no ip route-cache
    encryption vlan 1234 mode ciphers aes-ccm
    encryption vlan 1000 mode ciphers aes-ccm
    ssid LatitudeCorp
    ssid LatitudeGuest
    antenna gain 0
    no dfs band block
    stbc
    channel dfs
    station-role root
    interface Dot11Radio1.1000
    encapsulation dot1Q 1000 native
    no ip route-cache
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    interface Dot11Radio1.1234
    encapsulation dot1Q 1234
    no ip route-cache
    bridge-group 255
    bridge-group 255 subscriber-loop-control
    bridge-group 255 spanning-disabled
    bridge-group 255 block-unknown-source
    no bridge-group 255 source-learning
    no bridge-group 255 unicast-flooding
    service-policy input Lync
    service-policy output Lync
    interface GigabitEthernet0
    no ip address
    no ip route-cache
    duplex auto
    speed auto
    interface GigabitEthernet0.1000
    encapsulation dot1Q 1000 native
    no ip route-cache
    bridge-group 1
    bridge-group 1 spanning-disabled
    no bridge-group 1 source-learning
    interface GigabitEthernet0.1234
    encapsulation dot1Q 1234
    no ip route-cache
    bridge-group 255
    bridge-group 255 spanning-disabled
    no bridge-group 255 source-learning
    service-policy input Lync
    service-policy output Lync
    interface BVI1
    ip address 10.10.1.190 255.255.254.0
    no ip route-cache
    ip default-gateway 10.10.1.202
    ip http server
    ip http authentication aaa
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    bridge 1 route ip
    line con 0
    line vty 0 4
    transport input all
    end
    LATHQWAP01#conf
    Configuring from terminal, memory, or network [terminal]? t
    Enter configuration commands, one per line.  End with CNTL/Z.
    LATHQWAP01(config)#int dot11radio1.1000
    LATHQWAP01(config-subif)#ser
    LATHQWAP01(config-subif)#service-policy in
    LATHQWAP01(config-subif)#service-policy input Lync
    set cos is not supported on native vlan interface
    LATHQWAP01(config-subif)#

    Hey Scott,
    Thank you (again) for your assistance.
    So I' ve done as instructed and reconfigured the WAP. I've added an additional VLAN (1200 our VOIP VLAN) and made this the native VLAN - so 1000 and 1234 are now tagged. I've configure the BVI interface with a VOIP IP address for management and can connect quite happily. I've configured the connecting Dell switchport as a trunk and to allow trunk vlans 1000 (my DATA SSID), 1200(native) and 1234 (MY GUEST SSID). I'm now back to the issue where when a wireless client attempts to connect to either of my SSID's (Guest or DATA) they are not getting a IP address / cannot connect.
    Any ideas guys? Forgive my ignorance - this is a learning curve and one i'm enjoying.
    LATHQWAP01#show run
    Building configuration...
    Current configuration : 4426 bytes
    ! Last configuration change at 20:33:19 UTC Mon Mar 1 1993 by Cisco
    version 15.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname LATHQWAP01
    logging rate-limit console 9
    enable secret 5
    no aaa new-model
    no ip source-route
    no ip cef
    dot11 syslog
    dot11 vlan-name DATA vlan 1000
    dot11 vlan-name GUEST vlan 1234
    dot11 vlan-name VOICE vlan 1200
    dot11 ssid LatitudeCorp
       vlan 1000
       authentication open
       authentication key-management wpa version 2
       mobility network-id 1000
       wpa-psk ascii
    dot11 ssid LatitudeGuest
       vlan 1234
       authentication open
       authentication key-management wpa version 2
       mbssid guest-mode
       mobility network-id 1234
       wpa-psk ascii
       no ids mfp client
    dot11 phone
    username CISCO password
    class-map match-all _class_Lync0
     match ip dscp cs5
    policy-map Lync
     class _class_Lync0
      set cos 6
    bridge irb
    interface Dot11Radio0
     no ip address
     encryption vlan 1000 mode ciphers aes-ccm
     encryption vlan 1234 mode ciphers aes-ccm
     ssid LatitudeCorp
     ssid LatitudeGuest
     antenna gain 0
     stbc
     mbssid
     station-role root
    interface Dot11Radio0.1000
     encapsulation dot1Q 1000
     bridge-group 255
     bridge-group 255 subscriber-loop-control
     bridge-group 255 spanning-disabled
     bridge-group 255 block-unknown-source
     no bridge-group 255 source-learning
     no bridge-group 255 unicast-flooding
     service-policy input Lync
     service-policy output Lync
    interface Dot11Radio0.1200
     encapsulation dot1Q 1200 native
     bridge-group 1
     bridge-group 1 subscriber-loop-control
     bridge-group 1 spanning-disabled
     bridge-group 1 block-unknown-source
     no bridge-group 1 source-learning
     no bridge-group 1 unicast-flooding
    interface Dot11Radio0.1234
     encapsulation dot1Q 1234
     bridge-group 254
     bridge-group 254 subscriber-loop-control
     bridge-group 254 spanning-disabled
     bridge-group 254 block-unknown-source
     no bridge-group 254 source-learning
     no bridge-group 254 unicast-flooding
     service-policy input Lync
     service-policy output Lync
    interface Dot11Radio1
     no ip address
     encryption vlan 1000 mode ciphers aes-ccm
     encryption vlan 1234 mode ciphers aes-ccm
     ssid LatitudeCorp
     ssid LatitudeGuest
     antenna gain 0
     peakdetect
     no dfs band block
     stbc
     mbssid
     channel dfs
     station-role root
    interface Dot11Radio1.1000
     encapsulation dot1Q 1000
     bridge-group 255
     bridge-group 255 subscriber-loop-control
     bridge-group 255 spanning-disabled
     bridge-group 255 block-unknown-source
     no bridge-group 255 source-learning
     no bridge-group 255 unicast-flooding
     service-policy input Lync
     service-policy output Lync
    interface Dot11Radio1.1200
     encapsulation dot1Q 1200 native
     bridge-group 1
     bridge-group 1 subscriber-loop-control
     bridge-group 1 spanning-disabled
     bridge-group 1 block-unknown-source
     no bridge-group 1 source-learning
     no bridge-group 1 unicast-flooding
    interface Dot11Radio1.1234
     encapsulation dot1Q 1234
     bridge-group 254
     bridge-group 254 subscriber-loop-control
     bridge-group 254 spanning-disabled
     bridge-group 254 block-unknown-source
     no bridge-group 254 source-learning
     no bridge-group 254 unicast-flooding
     service-policy input Lync
     service-policy output Lync
    interface GigabitEthernet0
     no ip address
     duplex full
     speed auto
    interface GigabitEthernet0.1000
     encapsulation dot1Q 1000
     bridge-group 255
     bridge-group 255 spanning-disabled
     no bridge-group 255 source-learning
     service-policy input Lync
     service-policy output Lync
    interface GigabitEthernet0.1200
     encapsulation dot1Q 1200 native
     bridge-group 1
     bridge-group 1 spanning-disabled
     no bridge-group 1 source-learning
    interface GigabitEthernet0.1234
     encapsulation dot1Q 1234
     bridge-group 254
     bridge-group 254 spanning-disabled
     no bridge-group 254 source-learning
     service-policy input Lync
     service-policy output Lync
    interface BVI1
     mac-address 881d.fc46.c865
     ip address 10.10. 255.255.254.0
    ip default-gateway 10.10.
    ip forward-protocol nd
    ip http server
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    bridge 1 route ip
    line con 0
    line vty 0 4
     login local
     transport input all
    sntp server ntp2c.mcc.ac.uk
    sntp broadcast client
    end
    LATHQWAP01#

  • Having problem in learning JDeveloper base on the tutorial

    Hi,
    I would say I'm new to J2EE and JDeveloper is the first IDE tool that I'm intend to use. I like the tutorial (http://www.oracle.com/technology/obe/obe11jdev/11/ejb/ejb.html) very much as it is easy to understand. I follow the tutorial steps by steps(Note: I create my own schema and tables instead of installing the schema as in the tutorial) and I found that my JDeveloper interfaces are different with the sample in the tutorial. The version that I downloaded is exacly JDeveloper 11g (Preview 2). Is the version different?
    When I trying to run HRFacadeClient I encounter errors.
    I wish that I can attach document as I have done screenshot of the interfaces. Pls advise how should I further explain my problem? I really need help in order for me to conitnue my learning.
    Wen Xi

    Hi,
    First, really thanks, now I can follow the tutorial with the exact sample interface.
    Before I paste my error, first I wish to say that instead of using thr HR Schema that as stated in the tutortial, I use my own schema (wenxi) with two new tables, there are Employee & Department.
    After that I just follow the tutorial steps by steps, I have no problem in compiling the classes. I encounter problem when run the HRFacadeClient. Below is my error message. For tracing, I did try to
    comment out the for loop corresponding to the queryEmployeeFindAll() method, FAILED. After that I tried to comment out the for loop corresponding to the hRFacade.queryEmployeesFindByName() method and so on. But all FAILED. Below is the message that display after I have commented out hRFacade.queryEmployeesFindByName() & queryEmployeeFindAll() methods.
    [EclipseLink/JPA Client] Adding Java options: -javaagent:D:\JDeveloper\Middleware\jdeveloper\modules\oracle.toplink_11.1.1\eclipselink.jar
    D:\JDeveloper\Middleware\jdk160_05\bin\javaw.exe -client -classpath C:\JDeveloper\mywork\HR_EJB_JPA_App\.adf;C:\JDeveloper\mywork\HR_EJB_JPA_App\EJBModel\classes;D:\JDeveloper\Middleware\jdeveloper\modules\oracle.toplink_11.1.1\toplink.jar;D:\JDeveloper\Middleware\jdeveloper\modules\oracle.toplink_11.1.1\antlr.jar;D:\JDeveloper\Middleware\modules\com.bea.core.antlr.runtime_2.7.7.jar;D:\JDeveloper\Middleware\modules\javax.persistence_1.0.0.0_1-0.jar;D:\JDeveloper\Middleware\jdeveloper\modules\oracle.toplink_11.1.1\eclipselink.jar;D:\JDeveloper\Middleware\jdeveloper\modules\oracle.xdk_11.1.1\xmlparserv2.jar;D:\JDeveloper\Middleware\jdeveloper\modules\oracle.xdk_11.1.1\xml.jar;D:\JDeveloper\Middleware\modules\javax.jsf_1.2.0.0.jar;D:\JDeveloper\Middleware\modules\javax.ejb_3.0.1.jar;D:\JDeveloper\Middleware\modules\javax.enterprise.deploy_1.2.jar;D:\JDeveloper\Middleware\modules\javax.interceptor_1.0.jar;D:\JDeveloper\Middleware\modules\javax.jms_1.1.1.jar;D:\JDeveloper\Middleware\modules\javax.jsp_1.1.0.0_2-1.jar;D:\JDeveloper\Middleware\modules\javax.jws_2.0.jar;D:\JDeveloper\Middleware\modules\javax.activation_1.1.0.0_1-1.jar;D:\JDeveloper\Middleware\modules\javax.mail_1.1.0.0_1-1.jar;D:\JDeveloper\Middleware\modules\javax.xml.soap_1.3.1.0.jar;D:\JDeveloper\Middleware\modules\javax.xml.rpc_1.2.1.jar;D:\JDeveloper\Middleware\modules\javax.xml.ws_2.1.1.jar;D:\JDeveloper\Middleware\modules\javax.management.j2ee_1.0.jar;D:\JDeveloper\Middleware\modules\javax.resource_1.5.1.jar;D:\JDeveloper\Middleware\modules\javax.servlet_1.0.0.0_2-5.jar;D:\JDeveloper\Middleware\modules\javax.transaction_1.0.0.0_1-1.jar;D:\JDeveloper\Middleware\modules\javax.xml.stream_1.1.1.0.jar;D:\JDeveloper\Middleware\modules\javax.security.jacc_1.0.0.0_1-1.jar;D:\JDeveloper\Middleware\modules\javax.xml.registry_1.0.0.0_1-0.jar;D:\JDeveloper\Middleware\wlserver_10.3\server\lib\weblogic.jar -javaagent:D:\JDeveloper\Middleware\jdeveloper\modules\oracle.toplink_11.1.1\eclipselink.jar oracle.HRFacadeClient
    javax.ejb.EJBException: EJB Exception: ; nested exception is:
         java.lang.IllegalArgumentException: NamedQuery of name: Department.findAll not found.
         at weblogic.ejb.container.internal.RemoteBusinessIntfProxy.unwrapRemoteException(RemoteBusinessIntfProxy.java:105)
         at weblogic.ejb.container.internal.RemoteBusinessIntfProxy.invoke(RemoteBusinessIntfProxy.java:87)
         at $Proxy8.queryDepartmentFindAll(Unknown Source)
         at oracle.HRFacadeClient.main(HRFacadeClient.java:25)
    Caused by: java.lang.IllegalArgumentException: NamedQuery of name: Department.findAll not found.
         at org.eclipse.persistence.internal.jpa.EJBQueryImpl.getDatabaseQuery(EJBQueryImpl.java:454)
         at org.eclipse.persistence.internal.jpa.EJBQueryImpl.setAsSQLReadQuery(EJBQueryImpl.java:117)
         at org.eclipse.persistence.internal.jpa.EJBQueryImpl.getResultList(EJBQueryImpl.java:503)
         at oracle.HRFacadeBean.queryDepartmentFindAll(HRFacadeBean.java:43)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:597)
         at com.bea.core.repackaged.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:281)
         at com.bea.core.repackaged.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:187)
         at com.bea.core.repackaged.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:154)
         at com.bea.core.repackaged.springframework.aop.support.DelegatingIntroductionInterceptor.doProceed(DelegatingIntroductionInterceptor.java:126)
         at com.bea.core.repackaged.springframework.aop.support.DelegatingIntroductionInterceptor.invoke(DelegatingIntroductionInterceptor.java:114)
         at com.bea.core.repackaged.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:176)
         at com.bea.core.repackaged.springframework.jee.spi.MethodInvocationVisitorImpl.visit(MethodInvocationVisitorImpl.java:15)
         at weblogic.ejb.container.injection.EnvironmentInterceptorCallbackImpl.callback(EnvironmentInterceptorCallbackImpl.java:54)
         at com.bea.core.repackaged.springframework.jee.spi.EnvironmentInterceptor.invoke(EnvironmentInterceptor.java:30)
         at com.bea.core.repackaged.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:176)
         at com.bea.core.repackaged.springframework.aop.interceptor.ExposeInvocationInterceptor.invoke(ExposeInvocationInterceptor.java:89)
         at com.bea.core.repackaged.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:176)
         at com.bea.core.repackaged.springframework.aop.support.DelegatingIntroductionInterceptor.doProceed(DelegatingIntroductionInterceptor.java:126)
         at com.bea.core.repackaged.springframework.aop.support.DelegatingIntroductionInterceptor.invoke(DelegatingIntroductionInterceptor.java:114)
         at com.bea.core.repackaged.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:176)
         at com.bea.core.repackaged.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:210)
         at $Proxy76.queryDepartmentFindAll(Unknown Source)
         at oracle.HRFacade_mg5i94_HRFacadeImpl.queryDepartmentFindAll(HRFacade_mg5i94_HRFacadeImpl.java:143)
         at oracle.HRFacade_mg5i94_HRFacadeImpl_WLSkel.invoke(Unknown Source)
         at weblogic.rmi.internal.BasicServerRef.invoke(BasicServerRef.java:589)
         at weblogic.rmi.cluster.ClusterableServerRef.invoke(ClusterableServerRef.java:230)
         at weblogic.rmi.internal.BasicServerRef$1.run(BasicServerRef.java:477)
         at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:363)
         at weblogic.security.service.SecurityManager.runAs(Unknown Source)
         at weblogic.rmi.internal.BasicServerRef.handleRequest(BasicServerRef.java:473)
         at weblogic.rmi.internal.wls.WLSExecuteRequest.run(WLSExecuteRequest.java:118)
         at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
         at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)
    Process exited with exit code 0.
    Please advise.
    Wen Xi

  • Is there a native app/software that will get my photos all the same size?

    I know how to do this with photoshop but I'm not sure if there is any Apple native app/software that will do this for me. 
    Lets say I have 5 photos of different sizes and I want them all the same size.  I know I could reduce them all in preview but that doesn't allow me to move the photo around and cut out stuff I don't want in it.  Or I could crop them in Preview but then they are not automatically all the same size. 
    The way it works in photoshop is:  I open up a new project that is the same size I want the photos to be.  Let say 900x644.  Then I copy one of the photos I want in that size (lets say it somewhat bigger) and when I paste it into that blank new project that is 900x644 I can move the pasted photo around to get it so what I want to fit into that newer smaller size is there.
    Is there any way to do this without special software on a regular Mac.  I'm trying to help a family member who doesn't really want to buy or learn a complicated graphics program.  They have iLife 11 BTW but I don't see a way to do it with iPhoto.
    Thanks for any ideas you may have!
    Susan

    Use the Automator app (it's in the app folder) to resize a batch of photos:
    http://osxdaily.com/2011/12/20/batch-resize-pictures-in-mac-os-x-using-automator /
    I just tried this and it works and is fast.

  • ExtensionContext error while creating Native Extension in Flex 3.6 SDK

    I'm creating native extension with Flex 3.6 . Coded native side then created Flex Library Project and then create .ane file. Finally imported .ane file to myFlex Project.
    Here is the problem I had. While I'm debugging app, "1046: Type was not found or was not a compile-time constant: ExtensionContext" error occurs. Attached the Library project .as class .
    Thanks in Advance
    package com.extension.samples
       import flash.events.EventDispatcher;
       import flash.events.IEventDispatcher;
       import flash.external.ExtensionContext;
       public class NetworkConnectionANE extends EventDispatcher
            public var _extContext : ExtensionContext;
            public function NetworkConnectionANE(target:IEventDispatcher=null)
                _extContext = ExtensionContext.createExtensionContext("com.extension.samples.NetworkConnectionANE", null);
                 super(target);
            public function Connect(path:String):int
                 return _extContext.call("nativeFunc", path);
            public function dispose():void
                _extContext.dispose();
    Edit: I tried to use .swc file that created from library project in another Flex Desktop app, but the same error
        Also tried with     _extContext = ExtensionContext.createExtensionContext("com.extension.samples.NetworkConnectionANE","");
    Edit: The problem about Flex SDK, there is no problem in SDK 4.6. Now the question is, How to use Extension in lib project in Flex 3.6 SDK ?

    I'm sure, I use Flex 3.6.0 SDK version. When I want to create a library project in 3.6.0, already I couldn't see  ExtensionContext class in flash.external package. If I create in v4.6, I'm having problem when I start to debug my v3.6 desktop application. Now I want to learn
    Does Flex v3.6.0 support NativeExtension ?
       if Yes ,
    which class is equal to ExtensionContext in v3.6.0
    or How can I import ExtensionContext class to v3.6.0
    Thanks

  • How do i make a pure actionscript as simple native window?

    Hello @all anythings,
    I ask about a sample pure framework by Flex for Adobe Air.
    An Example: Window with customizable buttons - If i use boolen  for visible or invisible buttons like this:
    http://livedocs.adobe.com/flex/3/html/help.html?content=Part6_ProgAS_1.html
    For Example:
    NativeWindowPanel:
    <sm:NativeAirWindow icon="true" closable="true" minimizable="true" resizable="false">
    </sm:NativeAirWindow>
    How do i know that code with AS3. I want to build custom window for native window - Non-FlexChrome?
    Sorry my Language is same problematy...
    But I want to learn about pure actionscript for creating sample frameworks & components.... That is new native Language for German?
    Thanks and best regards...
    Snake Media Inc

    <code>
    [http://example.com text]
    </code>

  • Dreamweaver CS5.5 - Creating a Native Mobile Application | CS5.5 Web Premium Feature Tour | Adobe TV

    In this video we'll explore how you can configure a Dreamweaver CS 5.5 site to build a native mobile application using the popular PhoneGap framework - and deliver rich native applications to iOS and Android without needing to learn new languages or tools.
    http://adobe.ly/xjc2Y9

    Hi, I have a question.
    (Quick explanation) I have dreamweaver cs6, I created an android app, a run the emulator and everything seems to be ok with the app, I download the .apk and everything ok so far, but when i wanted to upload it to Google Play i need to sign it, but I search all the web somehow to sign it and i did not find anything to sign an app made with dreamweaver and Phonegap, just those made with Eclipse.
    My question:
    Is there anyway to export driectly from Dreamweaver to Eclipse as a project? so i can export it and sign it...
    if Not, How can i convert those html files made with dreamweaver to Eclipse files, so I can use Eclipse to sign and generate the keystore file
    or, How can I generate a keystore file to sign an app made with Dreamweaver?
    Thakns.

  • Hi i have a learning HTML file with a data file include a swf files how can i open it in my ipad?

    hi i have a learning HTML file with a data file include a swf files how can i open it in my ipad?

    iPad do not support flash natively.
    Look in the app store, some browsers do support flash with limited functionality.

  • Lost native resolution!

    I had been very satisfied using an external LCD (22-in) monitor for months. For some unknown reasons, I can't seem to get the external monitor to display its native maximum resolution (1680x1050) any more.
    I run Bootcamp and switched back and forth with the stupid Windows XP. But yesterday when I reboot the machine to get back to Mac OS, the display went out of whack. I tried to reinstall Mac OS but still cannot get the desired resolution. The max I have as shown in the menu choices is 1600x1200, in which all displays are shown in distorted aspect ratio.
    Your help is much appreciated.

    Thanks for your feedback. Before reading your reply, I made several unsuccessful and frustrating attempts, including reinstalling the OS (I am a newbie with Mac OS). I finally installed SwitchResX, which helped considerably but the fonts (especially small ones) are still not displaying the same quality as I had before. With SwithResX installed I seem to get the aspect ratio fixed but the fonts are still having partial "fade section" (the color of the displaying character is not consistently solid). During the process of reinstalling the OS, I replaced the old system folder with a new one, the trashed the old system folder. Did this process effectively 'reset' (clean off) the corrupt display preference files?
    Any way, after wasting too much time on this issue, I've learned to live with the 'imperfection' of my Mac. I wonder if my graphic card is messed up?

Maybe you are looking for

  • SO Pricing User Exit - How to know which item is selected for re-pricing.

    Hello Experts, I have to modify material data when user does a update pricing in VA02, the problem is...How do I know which item is selected for re-pricing (in MV45AFZZ)? I am using user exit USEREXIT_PRICING_PREPARE_TKOMP. For Ex: If my order has 3

  • Is there a maximum program size for the AWM GUI?

    Is there a maximum program size for the AWM GUI? I have a program that I migrated from Oracle Exress to Oracle 9i. The program runs fine, but I get buffer errors whenever I edit it with the Analytic Workspace Manager GUI. Only my longest program has

  • Infospoke Status after Abnormal Termination

    We have discovered that if an infospoke terminates abnormally for any reason, the status of the spoke and the requests are not being updated in these control tables: 1) RSBSPOKESTAT field RQSTATE 2) RSBREQUIDRUN field RQSTATE 3) RSBREQUID field RQSTA

  • How to compile servlet with Edit Plus?

    Hi I am writing a Java servlet in EditPlus and am wondering how to include the servlet.jar file so that EditPlus knows where the javax.servlet.*, etc classes are. I suppose this is an EditPlus specific question so sorry about that but I didn't know w

  • System refresh in DB2 for zOS with dual stack

    Has anyone performed system refresh (Abap + J2ee) in DB2 for zOS. We are planning to do it but the homogeneous document outlined the database specific methods and it doesn't cover the j2ee part. Is there any specific methods to follow to bring up the