Load balancing - KeepAlive script

Has anyone any experience of load balancing 2 Nakisa (.NET) web servers?
Ideally I want to know which script I can use to test if the application is "alive".
Stephen

Stephen,
To tell what method of session state is being used you need to go to the ASP.NET settings for the virtual directory and check the State Management settings:
IIS > [virtual directory] > ASP.NET tab > ASP.NET Configuration Settings > State Management tab
There are 3 types available: InProc (in processing with the IIS worker process), StateServer (uses a seperate server to store the session) and SqlServer (use a SQL Server DB to store the session details).
I hope that helps!
Luke

Similar Messages

  • Load Balancer and Web Dispatcher "keepalive page"

    I would like our monitoring and load balancer to be able to perform http status check against SAP web dispatchers.
    Is there a built in "keepalive" page that can be queried within Web Dispatcher, or will a URL rule be needed?

    Dear Andrew,
    We need to provide access to our intranet to some outside companies for them to also use some of our portal applications. As per your answer, I understand that I can configure Web Disptacher to talk to the Cisco Load Balancer of our portal. In this case Web Dispatcher will work just as a reverse proxy. But when I discussed this with one of our basis resource, he told me that when we install and configure Web Dispatcher, it always ask for the Message Server URL and Port number, even if I just want to use Web Dispatcher as a Reverse Proxy. If his concerns are valid, I do not think I will be able to configure Web Dispatcher to access the cisco Load Balancer because I cannot put Cisco load banacer URL and port instead of the Message Server URL and Post Number. Can you kindly share your comment on the same?
    Now the second part of my question, if Web Dispatcher cannot be configured to talk to Load Balancer(as mentioned by our basis resource), I will have to use two load balancers. One web Dispatcher in DMZ as a Load Balancer *** Reverse Proxy for the external users. Second the internal Cisco Load Balancer for the intranet users. So the same portal will be accessed by two load balancers. My question here is, in this set up, can the portal work efficieintly here by distributing equal loads two both the server instances?
    Thank You,
    mansooralip1

  • Load balancing on an applicaton with multi-ports

    One of our application open 5 ports and other 4 management ports. the ports can not be ranged.
    to load balancing this, I did:
    make seperate contents rules for every port. and all of them use aca.
    Please advice me :
    1. how can I group all the ports into one contents rule?
    2. every rule for a port means the balancing in only by based on specialy port?
    3. Can I balance the load between ports?
    4. for administrator ports, what is the better balancing mothed?
    Any comments will be apprecaited
    Thanks in advance

    Gilles,
    What will be the best keepalive on the services to use in this case?
    I have had a problem where I tried the same setup you have suggested above but what happen is i get a black hole if the service port(s) goes down on one of the servers.
    At the beginning, I used the default ICMP keepalive and then tried the port xx keepalive but because the servers have multiple ports and if the port that is not monitored by keepalive goes down, the content rule still think that the service is still up and this is where I get i blackhole. To get around with the problem I have created multiple services, (one for each port) and configured the subsequent keepalive.
    1. is there a better way of doing it? i,e script
    2. is there any documentation on Cisco website on how to use the scripting tools on CSS?
    Thanks again,
    Ben

  • Load balance LDAP with the CSS 501

    I'm trying to setup a content rule to test load balancing LDAP traffic via the CSS but it doesn't seem to be working. Here's my configuration:
    service 10.125.5.56:389
    ip address 10.125.5.56
    protocol tcp
    port 389
    keepalive type script ap-kal-ldap "10.125.5.56"
    active
    content test-ldap:389
    vip address 10.124.155.50
    add service 10.125.5.56:389
    protocol tcp
    balance aca
    port 389
    advanced-balance sticky-srcip-dstport
    active
    Anything I'm doing wrong? I see somebody posted a similar issue but doesn't seem like a solution was provided (see below):
    http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Data%20Center&topic=Application%20Networking&topicID=.ee7814f&fromOutline=true&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.1dda3585/2

    What's the issue ?
    Get a sniffer trace simultanously on client and server and see what's going on.
    G.

  • How to set up load balancing with overload server on css

    can anyone tell me how to set up a load balancing config on css that will enable me to LB proxy caches and when they have too many connections then LB against an overload proxy-cache.
    Such that when the normal proxy-cache farm is under the ceiling of max connections then the overload server is not used ?
    I don't think redirect or sorry server will do this ?

    see the below configuration,any question,just tell me.
    service proxy-1
    ! below is the real ip of server
    ip address 10.1.1.1
    keepalive type icmp
    active
    service proxy-2
    ip address 10.1.1.2
    keepalive type icmp
    active
    ! enter owner config-mode
    owner proxy
    ! define a content rule,match what you want to load balancing
    content rule-proxy
    ! below is virtual ip,it can be another ip segment
    vip address 10.1.1.50
    add service proxy-1
    add service proxy-2
    protocol any
    advanced-balance sticky-srcip
    active

  • Load balancing host named site collection

    I am jumping into the realm of host named site collection. While the learning experience has been good, still there are some questions unanswered. Please bare patience since my questions are long.
    - I have a non host header site on port 80 that has https certificate added to IIS for supporting app store in https mode.
    - I tried to created the host name site collection using https in this default port 80 non host header web application and was greeted with error. Then i extended the web app to different  zone with port 443 . Then created the host header site collection
    with https with web application name for extended 443 one. Creation went in fine.
    - I tired to use IPs on now extended IIS site and bind certificates on that one. The site does not load. I do the same again in the default zone iss site, bind ips on that one and site loads. Now question is even though host header site collection was created
    using extended web application url , why binding had to be done on default zone IIS site?
    - Second test, i changed the authentication mode for extended, no effect on host named site collection but as soon as i changed it in default zone it reflected in host named site collection. I am confused why it needs extended zone url to create the https
    site but every change done in default zone is getting reflected on this host named site collection.
    Now for load balancing , it works fine with IP? But how to load balance these host named site collection using url. I talked with f5 team and they said i need to send some reply query string from each site. Where do i do that? Or is it even needed? 
    Accoring to this link : https://devcentral.f5.com/articles/name-based-virtual-hosting-with-ltm
    . If the site hosts an application, though, the monitor should request a dynamic page on each webserver which forces a transaction with the application to verify its health and returns a specific phrase upon success.
    For application monitoring, the recommended best practice is to create such a script specific to your application, configure the monitor Send string to call that script, and set the Receive string to match that phrase. 
    Has any one done this before? I tired to search for resource regarding this for iis or sharepoint but was not able to get anything.
    Thank you for your patience for reading such a long question. 
    Adit

    first part of question:
    Default Web Appliction in port 80: Creating https host named site collection fails.
    Extend default web application on port 443 : Https hostnamed site collection created when web application name is passed for extended web application on port 443. This means this site collection is associated with this extended web application correct? But
    all the changes made in IIS only reflect if it is made to port 80 web application. Also changing authentication scheme from Central Admin, only changes on default zone reflects on site collection not the one in extended web application? Why  if the site
    was only created on extended web application paremeter, changes on default are reflecting on it but not from extended.
    Second part of question:
    Each Hostnamed site collection when load balanced thorough f5 using IP for 3 WFE uses 3 IPs for each. This way we will run out of IPs pretty soon. I want to know if there is way to load balance these sites using Hostname or anyother paramenter through f5
    and if any body has done it? 
    https://devcentral.f5.com/articles/name-based-virtual-hosting-with-ltm link talks about sending reply string
    from application but i do not know where to set it up or how to do it? No resources in the net. Just asking if any one else has done it. 
    Adit

  • Load balancing server names

    My Application is handled by three load balanced servers.I have a functionality in which first i send a request for a document printing.This request is posted in Database.Then a backend script runs and takes each requets in DB and executes and creates a file and places in server space. This works fine when i have only one server.But when i have load balanced servers user can give request for print from one server(he does know where from he is giving) and backend shell scripts can take the OPEN record from DB and execute in another server.So user is not able to find the document thought his request is processed.I have tried to know the DNS names of teh server whose are taking the print request so that i can track. But when i check with ServletRequest.getServerName() but i always get the application URL not teh specific load balance server name. I am tryong my luck with java.net.InetAddress

    Hey i could solve this problem. i have used java.net.InetAddress class and its methods to know the system name on which my code is executing.
    Viswanath

  • Issue in setting Load balancing for Indesign Server CS5.5

    Hi All,
    I need to set up load balancing mechanism for Indesign Server CS5.5 on Windows Server 2008 R2(64 bit version).
    I have dutifully following all steps defined in "WORKING WITH LOAD BALANCING AND QUEUEING FOR ADOBE INDESIGN CS5 SERVER.pdf"
    After running Indesign server using batch file "startup-indesign-server-CORBA-4instances.bat" from "<ID_SDK>\samples\load-balancing-and-queuing-clients\indesignserver-startup-scripts", I get only one instance of Indesign Server running. How to run multiple instances of the INDD server ? Is running multiple instance has something to do with type of licensing ?
    Now I run Clover.cmd script, I get this screen. I have no idea why its not working. Please help. Please let me know, if the scenario is not clear and more information is required.
    Thnx,
    D

    This is the image after running clover.bat

  • How can I support a health check, from a load balancer?

    My company has load balancers which use health checks to determine if the end point is available for client traffic. The basic health check is a tcp ping, and will tell you if the device is on the network. The next level of health check is an http request. This request, and the response are static, you can’t create your own version of the request and response. The standard request is this:
         http://host:port/healthcheck/hc.html
    The standard response is this:
         “The server is available”
    I want to use the load balancer as part of my total deployment. The problem is that I am not seeing how to support this health check request and response in the MDEX engine. What I see is this request
         http://host:port/admin?op=ping
    Will return this response
         dgraph <host>: <port> responding at <day month year time>
    It is nice that there is a built in ping, but I am not able to make use of it. I am new to Endeca and still poking around. The dgraph process listens on a port set up in <…>/config/script/AppContext.xml
    <dgraph id="Dgraph1" host-id="MDEXHost" port="3281">
    <properties>
    <property name="restartGroup" value="A" />
    <property name="updateGroup" value="a" />
    </properties>
    <log-dir>./logs/dgraphs/Dgraph1</log-dir>
    <input-dir>./data/dgraphs/Dgraph1/dgraph_input</input-dir>
    <update-dir>./data/dgraphs/Dgraph1/dgraph_input/updates</update-dir>
    </dgraph>
    (I am not using the default port, as I only have an instance on a shared server and have to worry about port clashing. But that is a different thread.)
    In a standard tc Server install I can support this health check by doing this:
    * Create a directory named “healthcheck”, in the “webapps” directory.
    * Place a file name “hc.html” in that directory, which contains “The server is available”
    The one hack which comes to mind is to write a servlet which would be able to be a smart proxy for the load balancer health check. It would pass along any regular traffic to the MDEX engine. But if the request was a health check it would send “admin?op=ping” to the MDEX engine, and for a good response from the engine, create and pass back the correct response to the load balancer.
    Ideas, comments, flames, …
    Thanks

    Hi, we are using following String to test the MDEX ping response but we get the invalid version formation on dgraph.log -
    following is on F5
    GET /admin?op=ping HTTP/1.1/r/nHost:myhost.endeca.com:19000/r/nConnection:close/r/n/r/n
    Following gets logged on Dgraph.log
    WARN 09/05/12 05:30:03.799 UTC (1346823003799) DGRAPH {dgraph} Invalid version format in 'HTTP/1.1/r/nHost:myhost.endeca.com:19000/r/nConnection:close/r/n/r/n'
    Please let me know - if you have any suggestions to solve this issue.
    I know that it works from browser and wget from unix with following commands.
    wget http://myhost.endeca.com:19000/admin?op=ping - from unix command line
    from browser:
    http://myhost.endeca.com:19000/admin?op=ping
    Thanks,
    Ram

  • CSS11503 load balancing virtual server IP's

    Hi CSS experts,
    We have a Cisco Content Services Switch 11503 Load Balancer which seems to require Real Server NICs to be plugged in. When I plug a cable from our Cisco 3560 switch into the Cisco Load Balancer, it can't see the 2 web server IP's that I'm trying to load balance for HTTP/HTTPS. The virtual IP does not display the webpage of either web servers.
    On the otherhand, when I use two physically separate 1U web servers and physically plug 2 cables (1 for each server) into the CSS 8 port switch, the virtual IP is able to redirect the traffic to both web servers.
    How do I configure the CSS to load balance and actually see 2 IP's on the network which isn't plugged in physically per server into the CSS 8 port switch.
    Internet->CSS->1 cable plugged into Cisco switch which host 2 web servers.
    Thanks,
    Mike
    Configuration:
    circuit VLAN1
    ip address 192.168.1.10 255.255.255.0
    service Websrv1
    ip address 192.168.1.104
    protocol tcp
    port 80
    keepalive type http non-persistent
    active
    service Websrv1SSL
    ip address 192.168.1.104
    protocol tcp
    port 443
    keepalive type ssl
    active
    service Websrv2
    ip address 192.168.1.101
    protocol tcp
    port 80
    keepalive type http non-persistent
    active
    service Websrv2SSL
    ip address 192.168.1.101
    protocol tcp
    port 443
    keepalive type ssl
    active
    owner Web
    content NG
    add service Websrv1
    add service Websrv2
    vip address 192.168.1.7
    port 80
    protocol tcp
    advanced-balance arrowpoint-cookie
    url "/*"
    active
    content NGSSL
    add service Websrv1SSL
    add service Websrv2SSL
    vip address 192.168.1.7
    port 443
    protocol tcp
    advanced-balance sticky-srcip
    sticky-inact-timeout 60
    active

    I checked the connectivity to the servers form the CSS and it was good. I was able to ping, and the connection status in sh service summary incremented by 1 each time I tried to connect. From the server, I was able to ping back to the IP of the CSS and the VIP address as well. I have tried using only 1 server for 1 VIP. I have tried changing the default gateway on the server to the IP of the CSS and the VIP IP as well. It still doesn't seem to help. Anymore suggestions for me to try?
    Thanks
    Mike

  • Disabling load balancing in WebSphere

    Hello,
    We've come across this problem just after we deployed our application to a clustered environment (probably a short sight on our part while designing). This is our situation:
    Environment: WebSphere 6.1, EJB 2.1
    Problem: We use the EJB Timer service for executing some business logic periodically with in our stateless session bean application. We have multiple timers within the same EJB that do stuff dynamically with the same code based on the parameters. However, we don't want the timers to come up automatically when the EJB application (like doing it with in contextInitialized) comes up because we want to bring the timers up and down in a more controlled fashion (more of a business requirement) and so we expose the startTimer and stopTimer methods in our EJB, and we invoke those methods from scripts outside of the WebSphere context as and when needed. This model has worked perfectly in a stand-alone environment. When we switched to our clustered UAT environment and started testing, that's when we got this reality check.
    Our cluster consists of 2 nodes, with 4 clones per node, and our middle ware team worked on the horizontal scaling in this environment. So when we try to invoke the startTimer in each of these node clones, it automatically goes to a random clone, not necessarily the one that we are trying to invoke on. And the same happens when we are trying to stop the timer, it tries to stop it on a random clone and the timer might not even be up on the clone it is trying to stop.
    So my short question: is there any way to force the EJB invocation to go to a particular clone? In other words, can we disable this whole horizontal scaling and just let it go to the clone we want (not let Websphere come in between with its "smart" load balancing) in our request? Something like a magic parameter that can be passed to the java command while invoking the EJB?
    This might sound "impossible" to do it that way and probably better to look at other ways, but we are just looking for something that will not significantly change our architecture at this point in the game.
    Thanks in advance!

    Answer to my question: http://ieoc.com/forums/p/26385/218976.aspx#218976

  • ACE load-balancing-Cookie problem

    In our other load-balancing environments the load-balancer-cookie contains the encrypted (real) servername or ip-address.
    We think it's the same on the cisco, for that reason it's in theory not possible, that there are two 'green'-cookies with different values in the same request.
    There are only two possibilities how this could happen:
    a) The healthmonitor (http_probe) fails, the loadbalancer 'thinks' that the realserver is down and redistributes the traffic.
    But in that case we would expect, that the old cookie will be overwritten by the new one and not simply added to the http-header.
    b) The predictor in the serverfarm chooses a new realserver within the same request.
    If that is really the cause of that problem this would be bug in the cisco ace.
    What we found out, is that the loadbalancer performs a 'Set-Cookie'-Operation an every request even if the client submits the cookie correctly.
    For example:
    GET /ips-opdata/scripts/jquery.js HTTP/1.1
    Host: www.xxxxx.com
    User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.15) Gecko/20110303 Ubuntu/10.04 (lucid) Firefox/3.6.15
    Accept: */*
    Accept-Language: en-us,en;q=0.5
    Accept-Encoding: gzip,deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 115
    Connection: keep-alive
    Referer: http://www.xxxxx.com/
    Cookie: green=R339366665; JSESSIONID=28D91FC6FD62A3921354BB36826294C4
    HTTP/1.1 200 OK
    Set-Cookie: green=R339366665; path=/; expires=Tue, 29-Mar-2011 06:33:00 GMT
    Server: Apache-Coyote/1.1
    X-Powered-By: Servlet 2.4; JBoss-4.2.2.GA (build: SVNTag=JBoss_4_2_2_GA date=200710221139)/Tomcat-5.5
    ETag: W/"72181-1298537508000"
    Last-Modified: Thu, 24 Feb 2011 08:51:48 GMT
    Content-Type: text/javascript
    Content-Length: 72181
    Date: Mon, 28 Mar 2011 06:15:19 GMT
    As you can see the cookies: green=R339366665 is transmitted from the client, but the loadbalancer does a Set-Cookie Operation of the same cookie once again. This is an unexpected behaviour.
    We hope that this helps you to figure out the reason of the problem.

    The cookie is sent by the ACE on each response to refresh the timeout value on the client. The value of the cookie doesn't change. This is the expected behaviour and shouldn't break anything in the application / browser.
    For browser-based applications, don't forget to add the "browser-expire" parameter to your cookie-based stickyness config.

  • Cisco 886VA - Multiple PPPoE Line Load Balancing

    Dear Cisco Community,
    due to the need of increased bandwidth a customer ordered three ADSL6000/576Kbit lines from the same ISP. Dial-in is done with PPPoE and the IP is not static.
    - Is it possible to load balance between the three ISP lines with this router as the Cisco 886VA-K9 (Advanced IP Services) doesnt support PFR/OER I want to load balance per session, meaning each TCP session takes the same path, the next TCP session takes second path, next TCP session takes third path, then first path again and so on.
    - I did read the tutorials avaiable, but they don't discuss how the lines are used in round-robin fashion, just how to distribute different traffic on different lines. (https://supportforums.cisco.com/document/32186/dual-internet-links-nating-pbr-and-ip-sla?page=1) or (http://www.cisco.com/c/en/us/support/docs/ip/network-address-translation-nat/100658-ios-nat-load-balancing-2isp.html)
    - How would you solve this challenge?
    Relevant config so far:
    vlan 1
     name #LAN#
    vlan 2
     name #WAN-Uplink1#
    vlan 3
     name #WAN-Uplink2#
    interface FastEthernet0
     description #LAN#
     switchport access vlan 1
    interface FastEthernet2
     description #WAN-Uplink1#
     switchport access vlan 2
     no ip address
     pppoe enable
     pppoe-client dial-pool-number 20
    interface FastEthernet3
     description #WAN-Uplink2#
     switchport access vlan 3
     no ip address
     pppoe enable
     pppoe-client dial-pool-number 30
    interface ATM0
     description #WAN-Uplink3#
     no ip address
     logging event atm pvc state
     logging event atm pvc autoppp
     logging event subif-link-status
     no atm ilmi-keepalive
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     dsl enable-training-log delay 0
     dsl bitswap both
    interface ATM0.1 point-to-point
     bandwidth 550
     bandwidth receive 6000
     pvc pvc 1/32
      pppoe enable
      pppoe-client dial-pool-number 10
      vbr-nrt 500 500 1
      service-policy out WAN-Control1-Parent
    interface Vlan1
     description #LAN#
     ip address 172.16.1.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
    interface Dialer1
     description #WAN-Dialer1#
     bandwidth 550
     bandwidth receive 6000
     ip address negotiated
     ip mtu 1492
     ip nat outside
     ip virtual-reassembly in
     encapsulation ppp
     ip tcp adjust-mss 1452
     dialer pool 20
     dialer idle-timeout 0
     ppp authentication chap pap callin
     ppp chap hostname XXX
     ppp chap password XXX
     ppp pap sent-username XXX
     ppp ipcp dns request accept
     ppp ipcp route default
     ppp ipcp address accept
     no cdp enable
     service-policy output WAN-Control2-Parent
    interface Dialer2
     description #WAN-Dialer2#
     bandwidth 550
     bandwidth receive 6000
     ip address negotiated
     ip mtu 1492
     ip nat outside
     ip virtual-reassembly in
     encapsulation ppp
     ip tcp adjust-mss 1452
     dialer pool 30
     dialer idle-timeout 0
     ppp authentication chap pap callin
     ppp chap hostname XXX
     ppp chap password XXX
     ppp pap sent-username XXXX
     ppp ipcp dns request accept
     ppp ipcp route default
     ppp ipcp address accept
     no cdp enable
     service-policy output WAN-Control3-Parent
    interface Dialer3
     description #WAN-Dialer3-ATM#
     bandwidth 550
     bandwidth receive 6000
     ip address negotiated
     ip mtu 1492
     ip nat outside
     ip virtual-reassembly in
     encapsulation ppp
     ip tcp adjust-mss 1452
     dialer pool 10
     dialer idle-timeout 0
     ppp authentication chap pap callin
     ppp chap hostname XXX
     ppp chap password 7 XXX
     ppp pap sent-username xxx
     ppp ipcp dns request accept
     ppp ipcp route default
     ppp ipcp address accept
     no cdp enable
    ip nat inside source route-map ISP1 interface Dialer1 overload
    ip nat inside source route-map ISP2 interface Dialer2 overload
    ip nat inside source route-map ISP3 interface Dialer3 overload
    route-map ISP1 permit 10
     match ip address 100
     match interface Dialer1
    route-map ISP2 permit 10
     match ip address 100
     match interface Dialer2
    route-map ISP3 permit 10
     match ip address 100
     match interface Dialer3
    access-list 100 remark #NAT-LIST#
    access-list 100 permit ip 172.16.1.0 0.0.0.255 any
    Thank you for helping.

    Hey there,
    I managed to fulfill my requirement..
    If its a cluster on same machine or across machines, this should work
    1. Login to machine, cd $DOMAIN_HOME
    2. mkdir -p Apex_lsn_config/AdminServer Apex_lsn_config/<MS1> Apex_lsn_config/<MS2> # MS1 and MS2 are the Managed Server names as appropriate
    #If you are planning for cluster spawning MS's across machines, make sure you create the dir's on step 2 for each machine respectively. (in my case $DOMAIN_HOME is not shared)
    3. Copy apex-config.xml from the /tmp/apex or whatever location you have it currently to Apex_lsn_config/<MS1> Apex_lsn_config/<MS2>
    4. cd $DOMAIN_HOME/bin; cp -p SetDomainEnv.sh SetDomainEnv.sh.orig #Backup the file
    5. Append -Djava.io.tmpdir in SetDomainEnv.sh as below for JAVA_OPTIONS # Do it on both machine if you are not sharing DOMAIN_HOME and planning cluster across machines
    -Djava.io.tmpdir=$DOMAIN_HOME/APEX_CONFIG/${SERVER_NAME}
    Hint: Search for "iterativeDev" and append the same line with -Djava.jo.tmpdir
    6. Modify "java.io.tmpdir" from the web.xml file of apex.war as below and re-deploy the war
    <context-param>
         <param-name>config.dir</param-name>
         <param-value>${java.io.tmpdir}</param-value>
    </context-param>
    7. Bounce Weblogic Admin and Manged Servers. Make sure to tail the Managed Server log to see apex-config.xml is picked from the new location.
    8. Brew a Coffee for yourself :)
    - You find the instructions on creating a cluster from weblogic documentation, the steps mentioned above are only to overcome the bdb locking issue whilst creating a cluster.
    Did it help?
    Edited by: Oratime on Mar 25, 2013 2:44 AM

  • Load balancing 10g forms - Connection from new browser window not supported

    Load balancing 10g forms - Connection from new browser window not supported
    We're experimenting with using webcache to load balance between multiple applications servers running OC4J forms processes.
    We currently have one machine with infrastructure and mid-tier (BI & Forms) installed, which is being used for the webcache functionality, this is load balancing between 2 other servers each of which just have the mid-tier (BI & Forms) installation
    In order to get this to work, I had to follow the instructions in the Forms deployment guide : http://download-uk.oracle.com/docs/cd/B14099_11/web.1012/b14032/tuning.htm#sthref707
    The main gist of this is that you need to set the following in the orion-web.xml file in order that the sessions are maintained:
    <session-tracking
    cookies="enabled">
    </session-tracking>
    This all works fine in most cases.
    The problem I am having is if I do one of the following on the client machine:
    1) From IE6 / IE7 run a copy of a forms application. Then open a new window using the "New Window" menu option, and attempt to run another forms application.
    2) In IE7 or Firefox 2.0 open a copy of the forms application, and then open a new tab and try and open another forms application.
    If I try either of these I get a FRM-92101 error, and the following is displayed in the java console:
    oracle.forms.net.ConnectionException: Connection from new browser window not supported
    From trawling various forums (including metalink and otn) it looks like a problem with the way coockies are handled.
    Unfortunately the usual workaround is to ensure that the session tracking option in the orion-web.xml file is disabled.
    The problem is that I need this enabled in order for the load balancing to work.
    Does anyone know of any other workarounds or patches that might help resolve this?
    We're using Application server 10.1.2.0.2 running on windows 2003 servers.

    You were right. Carriage returns were stopping it from working (the document is laid out over separate lines, so I assumed it would make no difference...).
    I've now managed to get it so the forms at least run, but they are all being run in the forms OC4J instance on the same machine as the OHS.
    Has anyone actually managed to get this to work, or am I doing something wrong?
    I did wonder if using an OHS instance on a machine with no forms installation would make any difference?
    I had raised a support call via metalink on this subject, but they eventually came to the conclusion that the only way to do this is with a hardware load balancer (Despite several documents suggesting that webcache is the way to go (including the forms deployment manual)).
    I'm at the point now of giving up and writing some custom scripts to do the job instead...

  • Load balancing on older hardware for small business

    Hey Spiceheads!Im sure I am way over my head here but I like to swim so its all good. I am fairly new to IT and am enjoying the ride, so this one should be fun too.In my office we have 8 servers, 10 USB hard drives for.... stuff. I didnt set it up. So we have virtually no redundancy.We have one good server and 7 pretty old ones, so I had a thought to put in a SAN or NAS and Load balance all of the old servers together. Then we would have plenty of storage/ backups (Raid 6 probably or whatever the SAN does) and we could keep the old servers and use them as they would be needed.My system requirements are as follows:2 Windows VMs
    1-2 SQL servers
    2-Linux Servers one of which is high performance
    Backups.I know its a small list but if there is an economical way to do this I think we would have a very robust system, we do web development and are...
    This topic first appeared in the Spiceworks Community

    I'm not sure if this help you, but it's not that easy to join two networks together. If you take the reason why, it's because of different IP addresses. If you are downloading something from the Internet you would have to divide the data into two different IP addresses = two different computers. Thing you can do is auto-balance use of wlan0 and wlan1 according to the usage. So, script will forward for first user packets on wlan0 and if somebody else connects he will get forwarded to wlan1. If there are more people you need to divide network bandwidth in different way, but I don't see way how to get 20Mbps with a single computer on a single TCP connection working as normal. It's possible to ask server for portion of data with wlan0 and then for the second portion on wlan1, but it may be complicated for data downloads with server sessions attached to the IP.
    Last edited by frefyx (2009-11-25 20:45:44)

Maybe you are looking for

  • Getting error 8 during a file move with shortcuts

    Hello,    I am using the file move vi to move files and shortcuts from one folder to another. This works file when I am trying to move files. but when I try to move a shortcut (a file with a extension of *.lnk) the move vi fails and gets a error 8 (p

  • Solaris Cluter 3.2 for SAP

    Hello All, My SAP production environment needs to be running under Solaris Cluster 3.2. I am thinking of T5440 servers - 2 in number and StorageTek 6140. The agents available for SAP on Solaris Cluster 3.2 are: Sun Cluster HA for SAP (failover or sca

  • How do I know which version of iTunes store do I have?

    This is the one I have: http://www.apple.com/itunes/store/ Is that the latest one, If it is not can someone send me a link to download the newest store?

  • Performance/  Appraisal management

    Hi Hey Gurus,I need a understand how the performance management in SAP is carried out through ESS and MSS. Can any one please provide me the Relevent document which can help me to understand the process and implement the Performance management. Best

  • Just installed upgrade to CS5, now have both showing in Finder

    I installed the upgrade and assumed it would remove the irrelevant parts of CS4 and upgrade the rest to CS5 - now my Applications Folder has a CS4 and CS5 version of everything. Should I just drag the CS4s to the trash? Was I supposed to have uninsta