Make Web Server

Hello All,
I want to make a website but i want to host it on my own machine. So i want to use my machine as a webserver to host my site. I am using Windows as my operating system. Where do i start? Is there a web server software i can install on my machine. I do know how to make a website (using Dreamweaver). But just wanted to know about making my machine into a webserver....
thanks in advance,
deebz

Hi,
You should look into aliases / forums related to web
based developement.
You should check out Apache web server for handling your static content.
     http://httpd.apache.org/
You should install apache with Tomcat which is capable
to handle your content dynamically using jsps and
servlets.
     http://jakarta.apache.org/
These 2 will have enough info for you to set up a
webserver in your machine.
Amlan

Similar Messages

  • Port forwarding for the Web server for outside Internet (not working , help!!!!!!)

    Hello 
    I am trying to learn something new here. We have web server inside our organization its IP address is 172.16.0.35. We want outside Internet users to access web server, How is it possible? Please have a look at the running configuration. Web server is working inside the organization but not at outside. Our Static Public IP is 197.255.232.15 it is assigned to Inetrface Gigabit ATM0.1  and ISP default GW is 197.255.232.1. Let me know whats next? How do I make web server inside the organization available for outside Internet users. Thank you.
    Building configuration.
    Current configuration : 1983 bytes
    ! Last configuration change at 17:57:15 UTC Sat Jan 24 2015
    version 15.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname router_test
    boot-start-marker
    boot-end-marker
    no aaa new-model
    memory-size iomem 10
    ip dhcp excluded-address 172.16.0.34
    ip dhcp pool test
     network 172.16.0.32 255.255.255.224
     dns-server 197.255.224.18 197.255.224.66
     default-router 172.16.0.34
     lease 9
    ip cef
    no ipv6 cef
    license udi pid CISCO887VA-K9 sn FGL1818236L
    controller VDSL 0
    interface Ethernet0
     no ip address
     shutdown
    interface ATM0
     no ip address
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     no atm ilmi-keepalive
    interface ATM0.1 point-to-point
     description ATM Routed Bridge Encapsulation (RBE) Internet
     ip address 197.255.232.15 255.255.248.0
     ip access-group netin in
     ip access-group netout out
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip nat outside
     ip virtual-reassembly in
     atm route-bridged ip
     bridge-group 1
     bridge-group 1 spanning-disabled
     pvc 0/35
      encapsulation aal5snap
      protocol ip inarp
    interface FastEthernet0
     no ip address
    interface FastEthernet1
     no ip address
    interface FastEthernet2
     no ip address
    interface FastEthernet3
     no ip address
    interface Vlan1
     description Lan 
     ip address 172.16.0.34 255.255.255.224
     ip nat inside
     ip virtual-reassembly in
     ip tcp adjust-mss 1454
    interface Dialer1
     no ip address
    ip default-gateway 197.255.232.1
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip nat inside source list natlist interface ATM0.1 overload
    ip nat inside source static tcp 172.16.0.35 443 197.255.232.15 443 extendable
    ip route 0.0.0.0 0.0.0.0 ATM0.1 197.255.232.1
    ip access-list extended natlist
     permit ip 172.16.0.32 0.0.0.31 any
    line con 0
     no modem enable
    line aux 0
    line vty 0 4
     login
     transport input all
    end
    http://pastie.org/9858814

    Hi  Karsten Iwen
    I deleted ( ip access-group netin in and ip access-group netout out) but it still does not work
    my config : 
    Building configuration...
    Current configuration : 2267 bytes
    ! Last configuration change at 15:43:06 UTC Wed Jan 28 2015
    version 15.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname router
    boot-start-marker
    boot-end-marker
    no aaa new-model
    memory-size iomem 10
    ip dhcp excluded-address 172.16.0.34
    ip dhcp pool my
     network 172.16.0.32 255.255.255.224
     dns-server 197.255.224.18 197.255.224.66
     default-router 172.16.0.34
     lease 9
    ip cef
    no ipv6 cef
    license udi pid CISCO887VA-K9 sn FGL1818236L
    controller VDSL 0
    interface Ethernet0
     no ip address
     shutdown
    interface ATM0
     no ip address
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     no atm ilmi-keepalive
    interface ATM0.1 point-to-point
     description ATM Routed Bridge Encapsulation (RBE) Internet
     ip address 197.255.232.15 255.255.248.0
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip nat outside
     no ip virtual-reassembly in
     atm route-bridged ip
     pvc 0/35
      encapsulation aal5snap
      no protocol ip inarp
    interface FastEthernet0
     no ip address
    interface FastEthernet1
     no ip address
    interface FastEthernet2
     no ip address
    interface FastEthernet3
     no ip address
    interface Vlan1
     description 
     ip address 172.16.0.34 255.255.255.224
     ip nat inside
     no ip virtual-reassembly in
     ip tcp adjust-mss 1414
    interface Dialer1
     no ip address
    ip default-gateway 197.255.232.1
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip nat inside source list natlist interface ATM0.1 overload
    ip nat inside source static tcp 172.16.0.35 443 197.255.232.15 443 extendable
    ip route 0.0.0.0 0.0.0.0 ATM0.1 197.255.232.1
    ip access-list extended natlist
     permit ip 172.16.0.32 0.0.0.31 any
    line con 0
     no modem enable
    line aux 0
    line vty 0 4
    end
    Router#sh ip nat translations
    Pro Inside global         Inside local          Outside local         Outside global
    tcp 197.255.232.15:5183   172.16.0.33:5183      212.95.74.5:80        212.95.74.5:80
    tcp 197.255.232.15:5196   172.16.0.33:5196      212.95.74.5:80        212.95.74.5:80
    tcp 197.255.232.15:5602   172.16.0.33:5602      174.129.246.27:80     174.129.246.27:80
    tcp 197.255.232.15:5785   172.16.0.33:5785      31.13.93.3:443        31.13.93.3:443
    tcp 197.255.232.15:443    172.16.0.35:443       ---                   ---

  • Make Imac A Home Web Server

    Hello,
    Is there any sites that may explain on how to make my Imac into a home web server. I need to add mysql, php5 and apache. Any hlp or guidence would be greatly appreciated. My go is to work on my sites locally and not live on their servers.
    Thanks JR

    Hi, no from the internet, as your isp block the port.
    Can you ask your ISP to unblock it ? If a fee apply you could ask your boss to pay for it.
    Regards, Philippe

  • I have perl scripts that I want to be able to run with my iplanet web server 6.0. How can I make it work in Windows NT? (Because I have no problem when I use it with Linux).

     

    Hi Melanie,
    In order to run a PERL script under Windows NT the iPlanet Web Server needs to know where to find the PERL interpreter.
    follow these steps :
    1) Make sure Windows NT knows what a .pl file is. In file Manager click on file and choose associate from the menu. Check the "files with extension" drop-down list for pl - if it exists verify that it is pathed to your perl.exe. If it is not already on the list click the "New Type" button. In the Filetype box put pl. Choose open from the Action drop-down list. In the Command box specify the full path to your perl.exe interpreter (Make sure to use short filenames, rather than long filenames.) Click the OK button. Then click the Close button in the main Associate dialog box. Double click a .pl file to test - it should automatically launch the PERL interpreter and feed it your .pl file.
    2) Create a directory to contain your .pl scripts.
    ~server_root\shell-cgi is a good choice.
    or \cgi-bin\
    NOTE: Make very sure that this directory is NOT part of the document root, it should have it's own directory (preferably at the same level of the docroot).
    3) In the Admin Server select Programs.
    4) Choose CGI directory (normally) or WinCGI directory or ShellCGI Directory depending on ur choice from the Programs menu.
    5) Put the URL Prefix you would like to map to your Shell-CGI directory into the URL Prefix field.
    6) Put the full path to your Shell-CGI directory in the Shell CGI directory field.
    7) Click OK.
    8) The save and apply changes page will display your changes and give you the opportunity to verify them. If they are correct click the Save and Apply button. If not Click the Undo button and go back to step 4.
    (9)You can then call your .pl scripts directly by referencing the directory mapping that you have just created. For example:
    http://my.server.whatever/shell-cgi/ myscript.pl
    this should work now.
    If not Pls Mail me.
    regards
    T.Raghulan
    [email protected]

  • How do I make my imac into a web server it is nearly brand new and uses OSX 10.8.4

    How do I make my imac into a web server it is nearly brand new and uses OSX 10.8.4, if someone to point me towards instructions it would be most helpful.

    http://www.coolestguyplanettech.com/downtown/install-and-configure-apache-mysql- php-and-phpmyadmin-osx-108-mountain-lion
    Regards.

  • How to make weblogic proxy to work on Sun Java system web server 7?

    Hi Every one,
    I am working on upgrade our Sun one 6.1 webserver to Sun Java system web server 7. Our website uses weblogic server to process jsp, web server only send static pages. I did all configurations as on Sun one. But somehow, the webserver does not forward "get jsp page" request to weblogic. The log record is:
    for host 10.78.124.118 trying to GET /home.jsp, send-file reports: HTTP4142: can't find /www/a/WebServer7/docs/bmd9i/home.jsp (File not found)
    home.jsp is at weblogic server.
    And redirect "NameTrans fn="redirect" from="/" url="/home.jsp"" seems does not work. when I type on IE http://32.69.253.131/ (32.69.253.131 is http listener IP), it always shows index.html page under the document root.
    Could some on can help? I am the first time to configurate web server. Thanks in advance.
    The configuration files are like:
    1. magnus.conf
    # Copyright 2006 Sun Microsystems, Inc. All rights reserved.
    # Use is subject to license terms.
    Init fn="load-modules" funcs="wl_proxy,wl_init" shlib="/www/a/WebServer7/weblogic6.1sp6/libproxy.so"
    Init fn="wl_init"
    2. obj.conf
    # Copyright 2010 Sun Microsystems, Inc. All rights reserved.
    # Use is subject to license terms.
    # You can edit this file, but comments and formatting changes
    # might be lost when you use the administration GUI or CLI.
    #<Object name="weblogic">
    #Service fn="wl_proxy" WebLogicCluster="32.69.253.86:7210" ConnectTimeoutSecs="240" ConnectRetrySecs="60"
    #</Object>
    <Object name="default">
    <Client method="TRACE">
    AuthTrans fn="set-variable" remove-headers="transfer-encoding" set-headers="content-length: -1" error="501"
    </Client>
    #AuthTrans fn="match-browser" browser="*MSIE*" ssl-unclean-shutdown="true"
    NameTrans fn="strip-params"
    NameTrans fn="redirect" from="/" url="/home.jsp"
    NameTrans fn="redirect" from="/index.jsp" url="/home.jsp"
    NameTrans fn="redirect" from="/index.html" url="/home.jsp"
    NameTrans fn="document-root" root="$docroot"
    NameTrans fn="pfx2dir" from="/mc-icons" dir="/www/a/WebServer7/lib/icons" name="es-internal"
    NameTrans fn="home-page" path="index.html"
    <If $uri =~ "/*.jsp">
    Service method="(GET|HEAD|POST|PUT)" fn="wl_proxy" WebLogicCluster="32.69.253.86:7210" ConnectTimeoutSecs="240" ConnectRetrySecs="60"
    #Service method="(GET|HEAD|POST|PUT)" type="text/jsp" fn="wl_proxy" WebLogicCluster="32.69.253.86:7210" ConnectTimeoutSecs="240" ConnectRetrySecs="60"
    </If>
    PathCheck fn="unix-uri-clean"
    PathCheck fn="check-acl" acl="default"
    PathCheck fn="find-pathinfo"
    PathCheck fn="find-compressed" check-age="off" vary="on"
    ObjectType fn="type-by-extension"
    ObjectType fn="force-type" type="text/plain" charset="iso_8859-1"
    ObjectType fn="set-default-type" charset="iso_8859-1"
    Service method="(GET|HEAD)" type="magnus-internal/directory" fn="send-error"
    Service method="(GET|HEAD)" type="*~magnus-internal/*" fn="send-file"
    AddLog fn="flex-log" name="access"
    </Object>
    <Object name="es-internal">
    PathCheck fn="check-acl" acl="es-internal"
    </Object>
    <Object name="send-precompressed">
    PathCheck fn="find-compressed"
    </Object>
    <Object name="compress-on-demand">
    Output fn="insert-filter" filter="http-compression"
    </Object>
    3.mime.types
    I add one line: type=text/jsp exts=jsp

    Quick obvious question - Are you positive you're editing the correct obj.conf? Check the config directory and see if there is a second one called something like <instance>.obj.conf (where <instance> is the name of your configured instance).
    Alternatively you can grep for object-file in the server.xml to see which obj.conf the server is using:
    # grep object-file server.xml
        <object-file>bare-php.obj.conf</object-file>Assuming that you are editing the correct obj.conf file, are you making certain to restart Web Server after making your changes?

  • How can I make the web server work on port 80 and not 443. I can only access my website using https.

    On a Mac Mini server with OS X Lion 10.7.2, I am unalbe to get the web server working on port 80. It switches automatically to port 443 (https).
    This situation complicates the access to FileMaker Web publishing, as I don't want my clients having to use https.
    How can I change that? Does anyone know?
    Thanks for any reply

    in the server: I checked the SSL certificate. Tried several configuration.
    Well, that's a problem for a start.
    Your port 80 connection should NOT use SSL. Port 80 is the standard HTTP port, not HTTPS and most applications that connect to port 80 will not expect to use SSL
    If you want to run a site under both HTTP and HTTPS then you create two sites, one on port 80 without SSL and one on port 443 with SSL

  • Make Fusion Middleware document available on the web server

    I'd like to set up so that Fusion Middleware document that were shipped with the software is available on the local web server where Weblogic is running. What do I need to do?

    Only Pro owners get the disclosure triangle option to "Save" your files.
    If you use the kioskmode="true" html tag in your page code it will be turned off.
    http://docs.info.apple.com/article.html?artnum=61011
    This will not keep determined viewers from getting a copy of your file, however. Anything you view on the Web can be saved.

  • How do I use Sun Web Server 7.0u1 reverse proxy to change public URLs?

    Some of our installations use the Sun Web Server 7.0 (update 1, usually)
    for hosting some of the public resource and reverse-proxying other parts
    of the URI namespace from other backend servers (content, application
    and other types of servers).
    So far every type of backend server served a unique part of the namespace
    and there was no collision of names, and the backend resources were
    published in a one-to-one manner. That is, a backend resource like, say,
    http://appserver:8080/content/page.html would be published in the internet
    as http://www.publicsite.com/content/page.html
    I was recently asked to research whether we can rename some parts of
    the public URI namespace, to publish some or all resources as, say,
    http://www.publicsite.com/data/page.html while using the same backend
    resources.
    Another quest, possibly related in solution, was to make a tidy url for the
    first page the user opens of the site. That is, in the current solution when
    a visitor types the url "www.publicsite.com" in his or her browser, our web
    server returns an HTTP-302 redirect to the actual first page URL, so the
    browser sends a second request (and changes the URL in its location bar).
    One customer said that it is not "tidy". They don't want the URL to change
    right upon first rendering the page. They want the root page to be rendered
    instantly i the first HTTP request.
    So far I found that I can't solve these problems. I believe these problems
    share a solution because it relies on ability to control the actual URI strings
    requested by Sun Web Server from backend servers.
    Some details follow, now:
    It seems that the reverse proxy (Service fn="service-passthrough") takes
    only the $uri value which was originally requested by the browser. I didn't
    yet manage to override this value while processing a request, not even if
    I "restart" a request. Turning the error log up to "finest" I see that even
    when making the "service-passthrough" operation, the Sun Web Server
    still remembers that the request was for "/test" (in my test case below);
    it does indeed ask the backend server for an URI "/test" and that fails.
    [04/Mar/2009:21:45:34] finest (25095) www.publicsite.com: for host xx.xx.xx.83
    trying to GET /content/MainPage.html while trying to GET /test, func_exec reports:
    fn="service-passthrough" rewrite-host="true" rewrite-location="true"
    servers="http://10.16.2.127:8080" Directive="Service" DaemonPool="2b1348"
    returned 0 (REQ_PROCEED)My obj.conf file currently has simple clauses like this:
    # this causes /content/* to be taken from another (backend) server
    NameTrans fn="assign-name" from="/content" name="content-test" nostat="/content"
    # this causes requests to site root to be HTTP-redirected to a certain page URI
    <If $uri =~ '^/$'>
        NameTrans fn="redirect"
            url="http://www.publicsite.com/content/MainPage.html"
    </If>
    <Object name="content-test">
    ### This maps http://public/content/* to http://10.16.2.127:8080/content/*
    ### Somehow the desired solution should instead map http://public/data/* to http://10.16.2.127:8080/content/*
        Service fn="service-passthrough" rewrite-host="true" rewrite-location="true" servers="http://10.16.2.127:8080"
        Service fn="set-variable" set-srvhdrs="host=www.publicsite.com:80"
    </Object>
    I have also tried "restart"ing the request like this:
        NameTrans fn="restart" uri="/data"or desperately trying to set the new request uri like this:
        Service fn="set-variable"  uri="/magnoliaPublic/Main.html"Thanks for any ideas (including a statement whether this can be done at all
    in some version of Sun Web Server 7.0 or its opensourced siblings) ;)
    //Jim

    Some of our installations use the Sun Web Server 7.0 (update 1, usually)please plan on installing the latest service pack - 7.0 Update 4. these updates addresses potentially critical bug fixes.
    I was recently asked to research whether we can rename some parts of
    the public URI namespace, to publish some or all resources as, say,
    http://www.publicsite.com/data/page.html while using the same backend
    resources.> now, if all the resources are under say /data, then how will you know which pages need to be sent to which back end resources. i guess, you probably meant to check for /data/page.html should go to <back-end>/content/page.html
    yes, you could do something like
    - edit your corresponding obj.conf (<hostname>-obj.conf or obj.conf depending on your configuration)
    <Object name=¨default¨>
    <If $uri = ¨/page/¨>
    #move this nametrans SAF (for map directive - which is for reverse proxy within <if> clause)
    NameTrans.. fn=map
    </If
    </Object>
    and you could do https-<hostname>/bin/reconfig (dynamic reconfiguration) to check out if this is what you wanted. also, you might want to move config/server.xml <log-level> to finest and do your configuration . this way, you would get enough information on what is going on within your server logs.
    finally,when you are satisfied, you might have to run the following command to make your manual change into admin config repository.
    <install-root>/bin/wadm pull-config user=admin config=<hostname> <hostname>
    <install-root>/bin/wadm deploy-config --user=admin <hostname>
    you might want to check out this for more info on how you could use <if> else condition to handle your requirement.
    http://docs.sun.com/app/docs/doc/820-6599/gdaer?a=view
    finally, you might want to refer to this doc - which explains on ws7 request processing overview. this should provide you with some pointers as to what these different directives mean
    http://docs.sun.com/app/docs/doc/820-6599/gbysz?a=view
    >
    One customer said that it is not "tidy". They don't want the URL to change
    right upon first rendering the page. They want the root page to be rendered
    instantly i the first HTTP request.
    please check out the rewrite / restart SAF. this should help you.
    http://docs.sun.com/app/docs/doc/820-6599/gdada?a=view
    pl. understand that - like with more web servers - ordering of directives is very important within obj.conf. so, you might want to make sure that you verify the obj.conf directive ordering is what you want it to do..
    It seems that the reverse proxy (Service fn="service-passthrough") takes
    only the $uri value which was originally requested by the browser. I didn't
    yet manage to override this value while processing a request, not even if
    I "restart" a request. Turning the error log up to "finest" I see that even
    when making the "service-passthrough" operation, the Sun Web Server
    still remembers that the request was for "/test" (in my test case below);
    it does indeed ask the backend server for an URI "/test" and that fails.
    now, you are in the totally wrong direction. web server 7 includes a highly integrated reverse proxy solution compared to 6.1. unlike 6.1, you don´t have to download a separate plugin . however, you will need to manually migrate your 6.1 based reverse proxy settings into 7.0. please check out this blog link on how to set up a reverse proxy
    http://blogs.sun.com/amit/entry/setting_up_a_reverse_proxy
    feel free to post to us if you need any futher help
    you are probably better off - starting fresh
    - install ws7u4
    - use gui or CLI to create a reverse proxy and map one on one - say content
    http://docs.sun.com/app/docs/doc/820-6601/create-reverse-proxy-1?a=view
    if you don´t plan on using ws7 integrated web container (ability to process jsp/servlet), then you could disable java support as well. this should reduce your server memory footprint
    <install-root>/bin/wadm disable-java user=admin config=<hostname>
    <install-root>/bin/wadm create-reverse-proxy user=admin uri-prefix=/content server=<http://your back end server/ config=<hostname> --vs=<hostname>
    <install-root>/bin/wadm deploy-config --user=admin <hostname>
    now, you can check out the regular express processing and <if> syntax from our docs and try it out within <https-<hostname>/config/<hostname>-obj.conf> file and restart the server. pl. note that once you disable java, ws7 admin server creates <vs>-obj.conf and you need to edit this file and not default obj.conf for your changes to be read by server.
    >
    I have also tried "restart"ing the request like this:
    NameTrans fn="restart" uri="/data"
    ordering is very important here... you need to do this some thing like
    <Object name=default>
    <If not $restarted>
    NameTrans fn=restart uri from=/¨ uri=/foo.
    </If>

  • Setting Up a Java Web Server on Linux

    Greetings,
    After a lot of reading, I've decided to learn Java server-side technologies (I already know Java (desktop)
    but with little experience) in order to develop my database driven dynamic website projects.
    However, I'm completed lost between the hundreds of acronyms related to Java and the "thousands" of technologies involved.
    Google hadn't help me understand what they really are and how they relate with each other.
    Even though is easy to find what they stand for and some faqs/descriptions, it hasn't been enought to clear my mind.
    I want my webserver application to do, among other things, the following:
    Retrieve Data from a database, do generate dynamic html files.
    Story Data on the database, from html forms.
    Send automaticly emails for multiple users. (newsletter for example)
    E-Commerce.
    Html graber/parser (I don't know if this is the right word, I mean a program that for example, goes to a URL with an html
    table, and stores that information in a database table, as long as the format didn't change).
    Real Time Chat feature.
    Database connection pooling, caching, and other important optimizations.
    I'm not asking for how to develop or configure this features nor what components and programs, must be installed.
    At the moment, I only want to know how to set up a Java solution that will support them when they are needed.
    *** Linux ***
    I want to set up my webserver on a linux distribution.
    In that respect, I don't know if I should choose RedHat or Fedora Core.
    I've heard that fedora is better for a webserver (having in mind that Red Hat Enterprise AS/ES aren't free).
    But I've read in several sun turorials/webpages references to RedHat (on a J2EE context).
    So I'm wondering if is better to go for Fedora or RedHat. Are there pros & cons? They equally support Java?
    *** Technologies ***
    Then in starts the acronyms problem.
    What do I need to install, in what order, for what?
    Some aconyms and technologies, I have read about but don't fully understand are the following:
    Apache
    J2EE
    J2EE 1.4 SDK
    SUN Java System Application Server Platform Edition 8
    J2SE 1.4.2 SDK
    SUN Java Enterprise System
    Tomcat
    Struts
    Cocoon
    JBoss
    I already know J2EE is only a specification. What implements that specification? Sun Java System Application Server?
    J2SE SDK? or Tomcat?
    What is the role of each technology, namely Apache, Tomcat, Sun Application Server?
    What is the Sun Java Enterprise System?
    How do Struts, Cocoon, JBoss relate to Java?
    Which of these technologies are mutually exclusive (analogous)?
    *** Doubts ***
    Then, I have some doubts that are keeping me from starting to study seriously the important techonologies, because I don't
    want to lose lot's of time and effort learning them to after a dillusion start everything again with PHP (the language
    which make me think and read a lot before going for Java). To keep this from happening, I would like to know the following:
    I want to use Java for developing websites with commercial/profitable use for my company, in some throught e-commerce,
    and in other by banners. I want to do everything by the book, with required licenses.
    ------ Java is Free?
    Is Java Completely Free or it might be possible that at a certain point, when I need some component or library,
    multi-machine webserver, performance or security for high-traffic I will see "buy now" instead of "download now"?
    For what they may "ask for money"? and what are the disavantages if I can't buy?
    For example, "Java System Application Server Standard Edition 8.1 2005Q1" and
    "Java System Application Server Enterprise Edition 8.1 2005Q1" cost $2.000 and $10.000 respectively. That is money.
    (http://www.sun.com/software/products/appsrvr/index.xml). What are the disavantages if stick to the free edition?
    Features like (from sun site)
    Standard Edition:
    Extends the capabilities of the Platform Edition to provide secure, remote, multi-instance, multi-machine management.
    It is aimed at high-volume applications and Web services.
    Enterprise Edition:
    Further extends the capabilities of the Standard Edition to provide continuous availablity for applications and
    Web services. It is aimed at business critical, high value applications and Web services.
    Suppose I achive lots of traffic and I keep the free platform edition.
    I won't be able to have a multi-machine webserver set up correctly?
    What are the drawbacks? How big are the performance penalties?
    ------ Technologies Availability
    Finnaly, I have the idea (I don't know if it's accurate) that there are Sun versions and Open-Source Free versions
    of doing or supporting the same Java related thing.
    Despite the way I choose to set up a Java webserver, I will always have all J2EE techonolies like:
    Java API for XML-Based RPC (JAX-RPC), JavaServer Pages, Java Servlets, Enterprise JavaBeans components,
    J2EE Connector Architecture, J2EE Management Model, J2EE Deployment API, Java Management Extensions (JMX),
    J2EE Authorization Contract for Containers, Java API for XML Registries (JAXR), Java Message Service (JMS),
    Java Naming and Directory Interface (JNDI), Java Transaction API (JTA), CORBA, and JDBC data access API.
    I really appreciate some help. I could learn the basics of all this "stuff" before asking. But the point why I'm asking
    is precisely not starting to learn something I may won't use. Obviously, I will have to make a lot of reading during maybe
    months before writing the first line of code of my projects, but being certain that it will fit my needs.
    I will be very thankful if you can enlightme in my fedora/redhat, setup, free/cost and technologies avaibility issues.
    Thanks Beforehand,
    Pedro Vaz

    Apache is a free Web-server.
    Tomcat is a servlet (and JSP) container. It can be stand-alone or can be used together with a Web server (like Apache).
    J2EE's scope is much wider than the servlet stuff, but a standalone Tomcat is a good starting point to servlets and JSP.
    One of our "real-world" applications is run by a standalone Tomcat using POI and Velocity. I did not regret this architectural decision.

  • I want to remove the COnlineBank, OnlineBank and csample applications from my application and web server.

    How can I safely do this on Solaris? I've tried "iasdeploy removeapp" and "iasdeploy removemodule" with no luck. I want to clear all of this demo stuff out to make both the web and app server look more production like.
    Thanks
    Eric

    Eric,
    these applications are applogics which are not controlled by the
    iasdeploy tool. Unfortunately, there is no tool available to remove
    these applications for you. What you can do is to manually remove all
    their entries, but be careful if you do that. If you remove the wrong
    keys you might break your ias installation, so be warned and make sure
    you backup the whole ias registry before attempting to remove anything.
    Eric Coleman wrote:
    >
    I want to remove the COnlineBank, OnlineBank and csample applications
    from my application and web server.
    How can I safely do this on Solaris? I've tried "iasdeploy removeapp"
    and "iasdeploy removemodule" with no luck. I want to clear all of
    this demo stuff out to make both the web and app server look more
    production like.
    Thanks
    Eric
    Try our New Web Based Forum at http://softwareforum.sun.com
    Includes Access to our Product Knowledge Base!--
    Han-Dat Luc ([email protected])
    Senior Consultant
    SUN Professional Services (iPlanet)
    o .
    o .
    O _ ____ _ _
    (_) _ \| | __ _ _ __ ___| |_ TM
    | | |_) | |/ _` | '_ \ / _ \ __|
    | | __/| | (_| | | | | __/ |_
    |_|_| |_|\__,_|_| |_|\___|\__|
    e-commerce solutions
    Sun Microsystems Australia Pty Ltd

  • Using Sun Web Server 6.1 from the IDE

    Using JSE 8 with Sun Web Server 6.1 set as the target container, I have a SUNWS61deployment.xml file created.
    That didn't exist in JSE 7. Is it WS 6.1 SP4 or SP5 -related ?
    I also have ws61-sun-web.xml with a simple <sun-web-app/> tag (empty deployment descriptor).
    What should this file contain? Is it a replacement for sun-web.xml?
    Do I still need sun-web.xml? Its DTD declaration sounds like Sun
    App Server 7 (http://www.sun.com/software/sunone/appserver/dtds/sun-web-app_2_3-1.dtd)
    So you have plans to make "Sun Resources" (pools, JNDI resources, ...) created in the IDE be registerable directly in the Web Server just like it's possible with the sun app server?
    How safe is it to use JSE 8 with an older Web Server Service Pack (say 6.1SP1)?

    SUNWS61deployment.xml is created bythe IDE to be used internally and not to be used by the developer. This file wouldn't be sent to webserver after deployment.
    The ws61-sun-web.xml is sun-web.xml only and yes it is same as it is in Appserver7 as the webcontainer for both Webserver6.1 and Appserver7 are same. After deployment to webserver, ws61-sun-web.xml is renamed to Webserver as sun-web.xml by the IDE. When opened the developer can edit in the XML editor.
    The reason for having it as ws61-sun-web.xml in IDE is to avoid the clash between sun-web.xml of Appserver8.1 which is J2EE1.4 based whereas Webserver6.1 Web container is J2EE1.3 based.
    It should be okay to use any service pack of Webserver6.1 with JSE8
    Hope this helps

  • Unable to install web server 7.0U2 on linux

    hello,
    i am trying to install web server 7.0U2 on amd64 Debian Linux. however, the installer seems to think that not enough disk space is available, even though there is 18GB free space on /.
    this is the transcript of the installation:
    harmony:/usr/home/river/sws64# ./setup
    Welcome to the Sun Java System Web Server 7.0U2 (64-Bit) installation wizard.
    You will be asked to specify preferences that determine how Sun Java System Web
    Server 7.0U2 (64-Bit) is installed and configured.
    The installation program pauses as questions are presented so you can read the
    information and make your choice. When you are ready to continue, press Enter
    (Return on some keyboards).
    <Press ENTER to Continue>
    Some questions require that you provide more detailed information. Some
    questions also display default values in brackets []. For example, yes is the
    default answer to the following question:
    Are you sure? [yes]
    To accept the default, press Enter.
    To provide a different answer, type the information at the command prompt and
    then press Enter.
    <Press ENTER to Continue>
    Sun Microsystems, Inc. ("Sun") SOFTWARE LICENSE AGREEMENT ("SLA") and
    ENTITLEMENT for SOFTWARE
    A. ENTITLEMENT for SOFTWARE. Capitalized terms not defined in this
    Entitlement have the meanings ascribed to them in the SLA (attached below
    as Section B). These terms will supersede any inconsistent or conflicting
    terms in the SLA.
    Licensee ("You"): The entity receiving the Software from Sun.
    Effective Date: Date You receive the Software.
    Software: Sun Software Portfolio, which may include the following: Solaris
    10, Sun Java System Access Manager, Sun Java System Directory Server
    Enterprise Edition, Sun Java System Identity Manager, Sun Java System
    Identity Manager Resource Adapters: (a) Windows Gateway Script Resource
    Adapter, (b) SQL Script Resource Adapter, (c) Unix Script Resource
    Adapter, (d) Database Table Resource Adapter, (e) Host Mainframe Resource
    Adapter, (f) JMS Resource Adapter, (g) Simulated Resource Adapter, and (h)
    Resource Extension Facility (REF) kit, Sun Java System Federation Manager,
    Sun Java Identity Auditor, Sun Java System Application Server Enterprise
    Edition, Sun Java System Message Queue, Sun Java System Web Server, Sun
    Java System Web Proxy Server, Sun Java System Portal Server, Service
    Registry, Sun Java System Connector for Microsoft Outlook, Sun Java System
    <--[6%]--[ENTER To Continue]--[n To Finish]-->n
    Sun Java System Web Server 7.0 License
    If you have read and accept all terms of the Software License Agreement,
    answer 'yes' to continue with the installation.
    If you do not accept all terms, answer 'no' to stop the installation without
    installing the product. You cannot install the product without accepting the
    agreement.
    Have you read the Software License Agreement and do you accept all terms
    [no] {"<" goes back, "!" exits}? yes
    Sun Java System Web Server 7.0 components will be installed in the directory
    listed below, referred to as the installation directory. To use the specified
    directory, press Enter. To use a different directory, enter the full path of
    the directory and press Enter.
    Sun Java System Web Server 7.0 Installation Directory [sun/webserver7] {"<"
    goes back, "!" exits}: /opt/webserver7
    Select the Type of Installation
    1. Express
    2. Custom
    3. Exit
    What would you like to do [1] {"<" goes back, "!" exits}? 2
    Component Selection
    1. Server Core
    2. Administration Command Line Interface
    3. Sample Applications
    4. Language Pack
    Enter the comma-separated list [ 1,2,3,4,] {"<" goes back, "!" exits}: 1,2
    Based on component dependencies for your selection...
    The following components will be installed:
    Server Core
    Administration Command Line Interface
    Java Configuration
    Sun Java System Web Server 7.0 requires Java SE Development Kit (JDK). Provide
    the path to a JDK 1.5.0_12 or greater.
    1. Install Java SE Development Kit (JDK) 1.5.0_12
    2. Reuse existing Java SE Development Kit (JDK) 1.5.0_12 or greater
    3. Exit
    What would you like to do [1] {"<" goes back, "!" exits}? 2
    Enter the path to an existing, compatible Java SE Development Kit (JDK)
    installation. [usr/home/river/sws64/WebServer/jdk] {"<" goes back, "!"
    exits} /usr/lib/jvm/java-1.5.0-sun-1.5.0.14
    Insufficient Disk space. Total product size is 89 MB. The installer requires
    additional disk space of 89 MB. Free up some disk space and try again.
    <Press ENTER to continue> {"<" goes back, "!" exits} !

    Hi,
    I've tried to install web server 7.0U3 on Debian etch 64 today and ran into the same problem. The solution to that problem was to install those packages: ia32-libs libstdc++5 as discribed here in one of the comments -> http://blogs.sun.com/kkranz/entry/installing_sun_java_system_web
    Cheers,
    Alex

  • How do you switch between web server snapshot jpg and png modes?

    I read in another forum a posting by "NathanK" stating:
    "The snapshot feature of the web server can
    generate images either as png or jpg. In LabVIEW 8.6 and later, the
    default which is generated by the web publishing tool is the png
    format. In this mode everything happens in memory so there is no
    snapshot image file generated.
    In the jpg mode there is a
    temporary file, however it is not always the same file and the file is
    deleted after it is uploaded to the client. I would not recommend
    trying to use this programmatically.
    If you need more
    control over a snapshot of a front panel (and you are using 8.6), I
    would recommend making a custom web service that takes a picture of a
    VI's front panel and returns it to the client. Then you would have
    control over the image."
    I am currently using the web publishing tool snapshot feature with an EXE program written in LV8.6.  However, each time a browser accesses the html file, the EXE file's memory grows by 72KB (this happens with my custom EXE program and with LabVIEW.exe when running the VI in development mode).  I'm assuming this is the png that is generated each time a snapshot is taken, but the program never de-allocated the memory and the program eventually crashes.  I'm aslo assuming that if I switch to "JPG mode", the web server will generate a temporary file and eventually delete it, elminating the memory leak.  The problem is, I don't know how to change the modes from png (default) to jpg.

    I am and have been using the .snap function on many applications since LabVIEW 6.1.  It's very simple, easy to use, does exactly what I want it to do, and is still in the documentation of LabVIEW 8.6, 2009 and 2009 SP1 as being supported. 
    If I am not mistaken, don't you need to have the LabVIEW runtime engine on the target system to use embedded mode?  I don't want to have to try and keep everybody who wants to see a screenshot of my program to have to have a run-time engine installed.  For one reason, I don't know everybody who wants to monitor our system and they literally can be anywhere in the world if the VPN to our network.  Second, those who I do know would would have me install it for them.  Third, why go "backwards" in capability...everybody would ask me "Why do we have to do this now?..we never had to do it before", and I don't want to use my time/energy at work to explain why NI cannot fix a memory leak that has been identified in at least the last 3 versions of LabVIEW and is still not fixed. 
    I had been using either LV 6.1 or 7.1 for a good part of 10 years and had very few problems with them (BTW, DAQmx is the greatest thing every put on a computer EVER).  I finally make the transitioin and start using LV 8.6 on a major test platform last year, got to the very end of it and find this out.  <sigh!>
    It is funny (maybe not), but my work around feels like I just changed the floormats in my Toyota car to keep it from "crashing".
    However, if I am mistaken and you do NOT need to use LV runtime engine for embedded mode, ignore everything I wrote above and please let me know that this is the case and I will look into it.

  • Windows 7 Pro Client loses connectivity to internal Win2k8 web server

    1. affected workstation are Optiplex 380 running Win 7 pro sp1 with broadcom NICs.
    2. Internal users use a internal webserver for customer invoicing application. Users lose connectivity to this internal web server, all other networking works, network shares, internet, etc. If I try to ping the webserver IP I get no reply. XP
    machines are not affected. Not a DHCP issue as there are plenty of IPs.
    3. I have tried different internal NICs (3com) but still had issue. I have upgraded BIOS, nic drivers. etc.
    4. I rebuilt one of the machines using Windows XP pro sp3 and have had no issue with that workstation.
    the problem started a few months or so ago. I have not been able to determine the source. I tried running wireshark but nothing stuck out. I have changed the session settings on the IIS server from 15 minutes to 6 hours but did not make a difference.
    5. Today when client lost connectivity to the server I tried pinging from the server back to the client and the connection was restored. This issue really has me confused as I cannot find anything in the logs that sticks out.

    Hello,
    Thank you for your question.
    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.
    Thank you for your understanding and support.

Maybe you are looking for