ME3400E parent child policy map

I've pasted the output of the show policy-map that is applied to an interface that connected to an access layer switch - I want one customer to have 15MB and the other customers to share the remaining bandwidth of the 200MB of internet bandwidth we currently have.
Does it look like it is working?  It has only been applied for an hour or 2 - I dont' understand why under the Class-map:  cust1 is shows 0 packets, and under the service policy class-Map is shows 0 packets and 0 bytes, but it shows that packets are conforming under the police section . . .
ME.3400#sh policy-map int g0/11
GigabitEthernet0/11
  Service-policy input: IP_Parent
    Class-map: cust1 (match-any)
      0 packets
      Match: vlan  301
      Service-policy : cust1
Class-map: class-default (match-any)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
      police cir 15000000 bc 468750
         conform-action transmit
         exceed-action drop
      conform: 3354685 (packets) 596174238 (bytes)
      exceed: 0 (packets) 0 (bytes)
      conform: 1945694 bps, exceed: 0 bps
    Class-map: Shared_IP (match-any)
      0 packets
      Match: vlan  300
      Service-policy : Shared_IP
        Class-map: class-default (match-any)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
      police cir 80000000 bc 1000000
         conform-action transmit
         exceed-action drop
      conform: 878911 (packets) 145461269 (bytes)
      exceed: 0 (packets) 0 (bytes)
      conform: 409508 bps, exceed: 0 bps
    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any

Here is the output after letting it run for 6 days.  Does anyone have an opinion about if it is working correctly?
I'm still confused by the places where it says 0 packets, or 0 packets, 0 bytes.
ME.3400#sh policy-map int g0/11
GigabitEthernet0/11
  Service-policy input: IP_Parent
    Class-map: cust1 (match-any)
      0 packets
      Match: vlan  301
      Service-policy : cust1
        Class-map: class-default (match-any)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
      police cir 15000000 bc 468750
         conform-action transmit
         exceed-action drop
      conform: 911003596 (packets) 153048040973 (bytes)
      exceed: 445 (packets) 439435 (bytes)
      conform: 2501473 bps, exceed: 0 bps
    Class-map: Shared_IP (match-any)
      0 packets
      Match: vlan  300
      Service-policy : Shared_IP
        Class-map: class-default (match-any)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
      police cir 180000000 bc 1000000
         conform-action transmit
         exceed-action drop
      conform: 262737871 (packets) 42238049347 (bytes)
      exceed: 0 (packets) 0 (bytes)
      conform: 1005000 bps, exceed: 0 bps
    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any

Similar Messages

  • Policy map/ class map/ service policy for IOS xr

    Hi,
    I need to create a policy map and class map/service policy to limit the amount of bandwidth that can be used on one interface both in and out.
    I need the cap for the bandwidth to traverse this circuit to ne 10 Meg.
    the IOS xr version we are using is 4.3.4
    I was hoping someone could help me out by giving me a configuration example I could follow.
    Thank you.

    for instance like this:
    policy-map police-in
    class class-default
    police rate 10 mpbs <optionally set burst>
    policy-map shape-out-parent
    class class-default
    shape 10 mpbs <optional burst config>
    service-policy shape-out-child
    policy-map shape-out-child
    class class-default
    queue-limit 10 packets
    int g 0/0/0/0
    service-policy police-in in
    service-policy shape-out-parent out
    also have a look at CL 2013/2014 (orlando/sanfran) ID 2904 for more QOS details
    and the support forum article of "asr9000 quality of service architecture"
    xander

  • Class-Map and Policy-Map Configuration in CM Confusion

    Hi,
    I'm implementing a green field WAAS deployment for a customer. We currently have a Proof-of-Concept up and running.
    I've got some questions regarding custom class-map and policy-map configuration in the CM. I'd like to nail-down the custom class-map and policy-map configuration (and understanding) in the PoC before cutting over the PoC branches to the production WAAS environment.
    Assuming a typical WAAS Deployment using WCCP for off-path interception, branch to DC.
     ==> 61 in LAN (BRANCH ROUTER) <== 62 in WAN        (WAN CLOUD)        ==> 61 in WAN (DC ROUTER) <== 62 in LAN
    We are using two distinct device groups, BRANCH and DATA CENTER.
    If the customer has traffic that we need to classify in order to provide TFO only optimisation, should the single class-map include the traffic in both directions? Ie., (assume the SERVER is 10.1.1.1 TCP Port 443). Should the class-map be configured as:
    Class-Map
    Line 1: DST IP 10.1.1.1 DST Port 443
    Line 2: SRC IP 10.1.1.1 SRC Port 443
    Or in this case is only the DST line required? And in which Device Group should the custom policy be applied? Or should it be applied to both Device Groups? If it should be applied to both Device Groups, then would it make more sense to have the policy-map in the Branch DG configured to match the DST traffic, and on the Data Center DG have a different class-map match the SRC traffic?
    My confusion is how to classify the traffic (SRC or DST or Both - Separate classes for each or different lines within the same class-map), and where to apply the appropriate policy (both Device Groups, just Branch, just DC) and why...
    I tried to apply a custom policy and the impact in the PoC was that the TCP Summary report stopped reporting the individual traffic classes showed 'other traffic' only. Can anyone explain why this may have occurred?
    I hope this makes sense.

    for instance like this:
    policy-map police-in
    class class-default
    police rate 10 mpbs <optionally set burst>
    policy-map shape-out-parent
    class class-default
    shape 10 mpbs <optional burst config>
    service-policy shape-out-child
    policy-map shape-out-child
    class class-default
    queue-limit 10 packets
    int g 0/0/0/0
    service-policy police-in in
    service-policy shape-out-parent out
    also have a look at CL 2013/2014 (orlando/sanfran) ID 2904 for more QOS details
    and the support forum article of "asr9000 quality of service architecture"
    xander

  • EJB 3, OneToMany that Acts As Tree, or Parent Child relationship support?

    (Sorry for the RoR reference)
    I first searched the forum and found this post that came close, but not exactly what I'm needing since my table doesn't reference the PK:
    http://forum.java.sun.com/thread.jspa?forumID=13&threadID=767913
    I have a table called Folder that represents a folder hierarchy. It has a 'Path' field and a 'Parent' field, and of course 'ID'. Each Folder knows its parent by the 'Parent' field, which references 'Path', not* 'ID'. Both are Strings.
    To find all the children of a Folder, the sql for a PreparedStatment might look something like this (shared for clarity of the situation):
    SELECT * FROM Folder
    WHERE Parent = ?Question:
    What are the proper annotations in EJB 3 / JPA to allow this kind non-primary key parent/child relationship mapping?
    Can I specify a named query that handles the logic and then reference it in the OneToMany annotation? Other cool tricks?
    Here is what I am trying (no runtime errors, but no results either). (Example simplified)
    @Entity
    @Table(name = "Folder")
    @NamedQueries(value = {@NamedQuery(.......)})
    public class Folder implements Serializable {
        @Id
        @Column(name = "ID", nullable = false, updatable = false)
        private Integer folderID;
        @Column(name = "Path", nullable = false)
        private String path;
        @Column(name = "Parent")
        private String parent;
        // v Here's the kicker v
        @OneToMany(cascade={CascadeType.ALL}, fetch=FetchType.EAGER)
        @JoinTable(name="Folder",
            joinColumns={@JoinColumn(name="Parent")},
            inverseJoinColumns={@JoinColumn(name="Path")})
        private List<Folder> children;
        // getters and setters ....
    }Thanks!

    It looks like the relationship is bi-directional.
    Will this work...
    // Parent.java
    @Entity
    public class Parent implements java.io.Serializable {
    @Id
    public Long parentId;
    @OneToMany(cascade=CascadeType.PERSIST,mappedBy="parent")
    public Collection<Child> children;
    // Child.java
    @Entity
    public class Child implements java.io.Serializable {
    @Id
    public Long childId;
    @ManyToOne
    public Parent parent;  // target of mappedBy
    }Then, in your code (a session facade?), you'll create the parent first, create the children, then add the children to the parent. Your code is also responsible for maintaining the reference back to the parent.
    Parent p = new Parent();
    for(int i=0; i<10; i++) {
      Child c = new Child();
      p.children.add(c);
      c.parent = p;
    em.persist(p);

  • Parent - Child mapping - ODI

    Hi experts,
    I have source as a below format, in .xls, this is parent- child relationship..
    Gen1     Gen2     Gen3     Gen4
    9000000009 blank     blank     blank
    blank     910000000 blank     blank
    blank     blank     9110000000     blank
    blank     blank     9120000009     blank
    blank     blank     blank     9121100009
    And trying the data into Oracle table with the below format.
    Gen1     Gen2     Gen3     Gen4
    9000000009               
    9000000009     9100000009          
    9000000009     9100000009     9110000000     
    9000000009     9100000009     9120000009     
    9000000009     9100000009     9120000009     9121100009
    Please help me what is the workaround I can follow to achieve using ODI.
    regards,
    Preet
    Edited by: 914626 on Mar 4, 2012 10:13 PM
    Edited by: 914626 on Mar 4, 2012 10:14 PM
    Edited by: 914626 on Mar 4, 2012 10:15 PM
    Edited by: 914626 on Mar 4, 2012 10:15 PM
    Edited by: 914626 on Mar 4, 2012 10:17 PM

    Thanks for the thoroughness. There was a mistake in moving the code over for the forum. The field names are correct throughout the original source code.
    BASE_OBJECT_ID is used throughout.
    I suspect the problem lies in the one-to-many sampleItem(s) relationship that is based upon the subclassed item class. (The relationship is actually "sampleItems" in the real code and somehow got changed in the move over.)
    The problem may lie in the mapping of the attribute override in the child class to the referencing of the item class from the parent side of the relationship in the Sample class.
    I further suspect this may be specific to Eclipselink based upon other postings I've seen on the web that have similar problems...
    Any thoughts?
    Edited by: Chris-R on Mar 3, 2010 9:56 AM

  • Informatica parent child mapping

      down votefavorite I have a scenario where suppose saycountry      province      city      zip
    ind           ts           hyd       xyz
    ind          maha          mum       abc
    Desired output:id   name         parent-id
    1    india         1
    2    telengana     1
    3    hyderabad     2
    4    xyz           3
    5    mumbai        1
    6    abc           5
    I have to do it with informatica mapping any ideas how do I show this parent child relationship. I am not able to get the logic for thisThanksKumar

    Thanks for the thoroughness. There was a mistake in moving the code over for the forum. The field names are correct throughout the original source code.
    BASE_OBJECT_ID is used throughout.
    I suspect the problem lies in the one-to-many sampleItem(s) relationship that is based upon the subclassed item class. (The relationship is actually "sampleItems" in the real code and somehow got changed in the move over.)
    The problem may lie in the mapping of the attribute override in the child class to the referencing of the item class from the parent side of the relationship in the Sample class.
    I further suspect this may be specific to Eclipselink based upon other postings I've seen on the web that have similar problems...
    Any thoughts?
    Edited by: Chris-R on Mar 3, 2010 9:56 AM

  • JPA One-To-Many Parent-Child Mapping Problem

    I am trying to map an existing legacy Oracle schema that involves a base class table and two subclass tables that are related by a one-to-many relationship which is of a parent-child nature.
    The following exception is generated. Can anybody provide a suggestion to fix the problem?
    Exception [EclipseLink-45] (Eclipse Persistence Services - 2.0.0.v20091127-r5931): org.eclipse.persistence.exceptions.DescriptorException
    Exception Description: Missing mapping for field [BASE_OBJECT.SAMPLE_ID].
    Descriptor: RelationalDescriptor(domain.example.entity.Sample --> [DatabaseTable(BASE_OBJECT), DatabaseTable(SAMPLE)])
    The schema is as follows:
    CREATE TABLE BASE_OBJECT(
    "BASE_OBJECT_ID" INTEGER PRIMARY KEY NOT NULL,
    "NAME" VARCHAR2(128) NOT NULL,
    "DESCRIPTION" CLOB NOT NULL,
    "BASE_OBJECT_KIND" NUMBER(5,0) NOT NULL );
    CREATE TABLE SAMPLE(
    "SAMPLE_ID" INTEGER PRIMARY KEY NOT NULL,
    "SAMPLE_TEXT" VARCHAR2(128) NOT NULL )
    CREATE TABLE SAMPLE_ITEM(
    "SAMPLE_ITEM_ID" INTEGER PRIMARY KEY NOT NULL,
    "SAMPLE_ID" INTEGER NOT NULL,
    "QUANTITY" INTEGER NOT NULL )
    The entities are related as follows:
    SAMPLE.SAMPLE_ID -> BASE_OBJECT.BASE_OBJECT_ID - The PKs that are used to join the sample to the base class
    SAMPLE_ITEM.SAMPLE_ITEM_ID -> BASE_OBJECT.BASE_OBJECT_ID - The PKs that are used to join the sample item to the base class
    SAMPLE_ITEM.SAMPLE_ID -> SAMPLE.SAMPLE_ID - The FK that is used to join the sample item to the sample class as a child of the parent.
    SAMPLE is one to many SAMPLE_ITEM
    The entity classes are as follows:
    @Entity
    @Table( name = "BASE_OBJECT" )
    @Inheritance( strategy = InheritanceType.JOINED )
    @DiscriminatorColumn( name = "BASE_KIND", discriminatorType = DiscriminatorType.INTEGER )
    @DiscriminatorValue( "1" )
    public class BaseObject
    extends SoaEntity
    @Id
    @GeneratedValue( strategy = GenerationType.SEQUENCE, generator = "BaseObjectIdSeqGen" )
    @SequenceGenerator( name = "BaseObjectIdSeqGen", sequenceName = "BASE_OBJECT_PK_SEQ", allocationSize = 1 )
    @Column( name = "BASE_ID" )
    private long baseObjectId = 0;
    @Entity
    @Table( name = "SAMPLE" )
    @PrimaryKeyJoinColumn( name = "SAMPLE_ID" )
    @AttributeOverride(name="baseObjectId", column=@Column(name="SAMPLE_ID"))
    @DiscriminatorValue( "2" )
    public class Sample
    extends BaseObject
    @OneToMany( cascade = CascadeType.ALL )
    @JoinColumn(name="SAMPLE_ID",referencedColumnName="SAMPLE_ID")
    private List<SampleItem> sampleItem = new LinkedList<SampleItem>();
    @Entity
    @Table( name = "SAMPLE_ITEM" )
    @PrimaryKeyJoinColumn( name = "SAMPLE_ITEM_ID" )
    @AttributeOverride(name="baseObjectId", column=@Column(name="SAMPLE_ITEM_ID"))
    @DiscriminatorValue( "3" )
    public class SampleItem
    extends BaseObject
    @Basic( optional = false )
    @Column( name = "SAMPLE_ID" )
    private long sampleId = 0;
    Edited by: Chris-R on Mar 2, 2010 4:45 PM

    Thanks for the thoroughness. There was a mistake in moving the code over for the forum. The field names are correct throughout the original source code.
    BASE_OBJECT_ID is used throughout.
    I suspect the problem lies in the one-to-many sampleItem(s) relationship that is based upon the subclassed item class. (The relationship is actually "sampleItems" in the real code and somehow got changed in the move over.)
    The problem may lie in the mapping of the attribute override in the child class to the referencing of the item class from the parent side of the relationship in the Sample class.
    I further suspect this may be specific to Eclipselink based upon other postings I've seen on the web that have similar problems...
    Any thoughts?
    Edited by: Chris-R on Mar 3, 2010 9:56 AM

  • Policy-map based rate-limiting per vlan

    Hi
    I was thinking if someone could help me to come up with solution to a problem. Scenario as follow:
    I have a trunk interface with multiple vlans on:
    interface GigabitEthernet2/0/3
    description TRUNK-to-*********
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 415,416,610,1191-1193,1195
    switchport mode trunk
    duplex full
    storm-control broadcast level pps 1k
    storm-control multicast level pps 3k
    storm-control unicast level pps 250k
    storm-control action trap
    spanning-tree portfast trunk
    spanning-tree bpdufilter enable
    I'm trying to rate limit two of the vlans that are present on this trunk interface - vlan 415 and vlan 1192.
    So I'm putting the class-map (to be later applied under the policy-map which is not significant here):
    (config)#class-map match-any 120-mbps-class
    (config-cmap)#match input-interface vlan 415
    (config-cmap)#match input-interface vlan 1192
    Now, when you show the class-map I created, I can see this:
    sh class-map 120-mbps-class
    Class Map match-any 120-mbps-class (id 1)
       Match input-interface  Vlan415
       Match input-interface  FastEthernet0
    For some bizzare reason class-map is matching the Fa0. I have researched this, and this is most probably because you can only match 1 vlan instance under the class-map.
    And here's my problem - I can't police whole interface as the other vlans should not be policed - how can I police those two vlans ?
    Any thoughts ? All help appreciated as always.
    Rob.

    Hi Daniel,
    I have labed it and unfortuantely it does not work as expected. I have put 1x 3750 and 1x 2960 trunk between them, each box had an access port for laptop to create some traffic across. All vlan-based qos has been applied on 3750G.
    3750G config
    Interface g1/0/20
    descriprion trunk
    swicthport trunk encapsulation dot1q
    switchport mode trunk
    switchport trunk allowed vlan 100,120
    Interface g1/0/1
    description access
    switchport mode access
    switchport access vlan 100
    Interface vlan 100
    ip address 192.168.100.254
    service-policy input PARENT-POLICER
    Interface vlan 120
    ip address 10.10.10.1
    Policy-map PARENT-POLICER
    class PERMIT-ANY-CLASS
    trust COS
    service-policy CHILD-POLICER
    class-map match-any PERMIT-ANY-CLASS
    match access-group name POLICY-LIST
    Extended IP access list POLICY-LIST
        10 permit ip any any
    Policy-map CHILD-POLICER
    class INTERFACE-POLICE-CLASS
      police 100000 8000 exceed-action drop
    Class Map match-any INTERFACE-POLICE-CLASS
    Match input-interface  GigabitEthernet1/0/20
    2960 config:
    interface g0/20
    switchport mode trunk
    switchport trunk allowed vlan 100,120
    interface g0/1
    switchport mode access
    switchport access vlan 100
    interface vlan 100
    ip address 192.168.100.253
    interface vlan 120
    ip address 10.10.10.2
    So as you can see vlan 100 is the one it need to be rate limited (I have only rate limited to 100kbps just to see if it's working) and vlan 120 is only on the trunk ports to confirm if the traffic  for this one is not affected.
    Unfortunately when the policing is applied on 3750 vlan 100 (and policing is working fine) then I can see the packet loss while pinging between switches on vlan 120 suggesting that the policy is affecting the other vlan as well. When I take the policy out of the vlan 100 I cannot observe the packet loss on vlan 120 meaning is no longer affected.
    Not sure if I have explained this clear enough so far, if not let me know.
    Do you have any suggestions ?
    Thanks!

  • Regarding policy map

    HI Team,
    If we use the folowing comands for QOS, what is the effect of
       service-policy NIC-QOS-OUT, as i have studied service policy will be applied under physical interfaces. Here policy map has been defined and again it is referred under Parent-QoS-2.5GIG policy map. So please clarify
    policy-map NIC-QoS-OUT
    description #### Common Child Policy ####
      class VIDEO&VOICE-OUT
       police cir percent 20
        priority
      class NICNET-OUT
        bandwidth percent 20
        random-detect dscp-based
      class CONTROL-OUT
        bandwidth percent 10
        random-detect dscp-based
      class INTERNET-SURF-OUT
        bandwidth percent 10
        random-detect dscp-based
      class class-default
        random-detect
    policy-map Parent-QoS-2.5GIG
    description #### Parent QoS Policy for 2.5 GIG Link ####
      class class-default
        shape average 2300000000
       service-policy NIC-QoS-OUT
    policy-map NIC-QOS-OUT
    Thanks in advance,
    Naveen

    The two ASA syslogs you posted were both from an internal host to port 80 on an external host. This would indicate that a sucessful DNS resolution has occured in these two instances.
    If the cause of your problem is bad DNS lookups, you should see evidence in your AIP-SSM event log of the packets being dropped.
    - Bob

  • Parent-child relation between Activities

    Hello,
    Is it possible to give parent child relationship between Activities within single Project? The requirement is, parent Activity to take part in overall scheduling whereas the Dates for parent Activity are determined by the child Activities attached to it.
    Thank you,
    Hemant

    Hi,
    In PS we  can map through the network activity and activity elemnents. For scheduling the projects the start date and end date of all  the activity elements are included in the respective network activity. for better understanding refer the following link.
    http://help.sap.com/saphelp_erp60_sp/helpdata/en/a9/8a853488601e33e10000009b38f83b/frameset.htm
    http://help.sap.com/saphelp_erp60_sp/helpdata/en/a9/8a853488601e33e10000009b38f83b/frameset.htm
    Regards,
    Nag.

  • Parent Child relation in one transaction throws error... (

    In nutshell, I have a parent->child relation ship in DB and due to the UI requirement, I created view link as Child->parent, it is giving a hack a lot of problems.... (it sounds silly but looks like I am loosing my mind over this)
    Let me explain my situation,
    - I have a table A with col-a and col-b. I have another table B with col-a (primary key) and col-c. (This way table A is a parent table)
    - ON UI side i created relationship like table B is parent and Table A is child using col-a
    - I need to create parent-child (one record for each) record programatically.........
    I tried following thing:
    - from backing bean, as soon as i create Table-B row first, i get error saying too many objects with same key (which is understandable because of table design..... and associaion must be throwing that error)
    - from EOImpl file, it doesn't even find the child record being created... so during commit I can't send the foreign key value from Table-a to Table-b
    Any suggestion is greatly appreciated?
    Thank you,
    -Raj

    that depends on how you implement the multiple selection of orders.. you have to pass the selectedValues to the backend or store the values in a map or list and pass it..

  • Parent-Child relation total

    i have 2 tables;
    Table 1
    Parent ID
    Parent Name
    Amount
    table 2
    DPND_CODE             
    DPND_NAME             
    DPND_RELAT_CODE       
    DPND_DOB              
    DPND_YN               
    DPND_SHARE_AMOUNT     
    DPND_BANK_CODE        
    DPND_BANK_AC_NO       
    DPND_AGENT_CODE       
    the query should check for the WHERE condition that dpnd_yn "Y"
    Parent ID       Parent Name        Amount
    001                emp1                   200.000
        001_01       emp1_chld1     50.000
        001_02       emp1_chld2     50.000
        001_03       emp1_chld3     50.000
        001_04       emp1_chld4     50.000
    .

    i was totally confused n hasty..Sorry to post with so incomplete info.
    actually i have a table that stores the total amount paid to an employee.
    for that my Table1 above serves the purpose.
    Table 1
    Parent ID
    Parent Name
    Amount
    the IInd table stores the distribution of the above (TABLE 1) total amount,
    to his family in case he has died. so the correct child table 2 struc is;
    table 2
    DPND_CODE             
    DPND_NAME             
    DPND_RELAT_CODE       
    DPND_DOB              
    DPND_YN               
    DPND_SHARE_AMOUNT     
    DPND_BANK_CODE        
    DPND_BANK_AC_NO       
    DPND_AGENT_CODE
    dpnd_PARENT_id  (Foreign key)
    and therefore the result that m looking for is;
    PARENT ID      PARENT NAME      AMOUNT
    001                emp1                   200.000 <------FROM TABLE 1
        dpnd_code  dpnd_name     dpnd_share_amount
        001_01       emp1_chld1     50.000  |
        001_02       emp1_chld2     50.000  |__FROM TABLE 2
        001_03       emp1_chld3     50.000  |
        001_04       emp1_chld4     50.000  |
    a condition should check whether dpnd_YN field = "Y",
    as all the next-of-kin members details of the deceased family is entered in the system at the time of his death.
    where as per rule only few qualify to get the share from the deceased pension as per policy.
    therefore the query should pick up only child records whom dpnd_YN IS MARKED As 'Y'.
    You've provided (3), but I don't know if that's really a good illustration of your problem.
    Do you have just one root (001), or can you have multiple roots (001, 002, 003, etc.)?
    Does the parent-child relationship go beyond two levels? (Thta is, can you have 001_01_01 or 001_01_02_03?)
    Yes the ROOT is always one, it will never go beyond two levels. (Just 001_01, 001_02...002_01, 002_02...003_01, 003_02..)
    Hope i am much better than before.
    ty
    Edited by: user613563 on Oct 27, 2008 3:01 PM
    Edited by: user613563 on Oct 27, 2008 3:05 PM

  • Parent child deletion  in ODI

    Hi ,
    I am using ODI for data migration.
    I have created interface for that . i have done error handling . now i need to implement parent child deletion. that is i need to delete parent record if the child record is no there for a particular Policy. can any one help me in implementing this in ODI.

    Can you please provide me the steps/document for exception handling in ODI interfaces.. I am creating interfaces to load flat files into custom tables and I need to provide exception handling in each interface. I would appreciate.
    Thanks
    Ram

  • Cascading parent/child inserts while avoiding uniqueness constraints

    Assume that I have two classes that I'd like to persist: MyObject and
    InternalObject. MyObject has an InternalObject field. That is, MyObject is
    the parent, InternalObject is the child in this one-to-one relationship.
    Steps involved:
    1) Enable ForeignKeyConstraints property in kodo.properties. That is add
    the line,
    kodo.jdbc.ForeignKeyConstraints=true
    2) In package.jdo, add the following kodo extensions for MyObject's
    InternalObject field mapping, i.e., io in my case.
    <field name="io" default-fetch-group="false">
    <extension vendor-name="kodo" key="jdbc-delete-action"
    value="cascade"/>
    <extension vendor-name="kodo" key="dependent" value="true"/>
    </field>
    The reasons that we have done these steps: we'd like kodo to properly
    re-order the sql statements if necessary in order not to violate
    parent/child dependencies during insertion, and also force cascading
    deletes in case we delete the parent object.
    Now comes the bulk of the algorithm.
    String sKey // key of the object to insert
    String sValue //value of the object to insert
    MyObject o = new MyObject(sKey, sValue);
    InternalObject io = new InternalObject(sKey,sValue); //using same values :)
    o.setInternalObject(io); //parent-child relation
    Object id = ((PersistenceCapable) o).jdoNewObjectIdInstance();
    ((PersistenceCapable)o).jdoCopyKeyFieldsToObjectId(id);
    kpm.currentTransaction().begin();
    try {
    Object trio = kpm.getObjectById(id, true);
    kpm.deletePersistent(trio);
    kpm.flush(); //apply deletes on the datastore
    } catch (ObjectNotFoundException oe) {
    System.out.println("First time!");
    kpm.makePersistent(o);
    kpm.currentTransaction().commit();

    If this is a question, the extension you have is only a directive to
    mappingtool to create cascade foreign keys. However, at runtime Kodo
    will rely upon the foreign key definitions in the schema. You should
    verify that the foreign key exists as you like in the schema. If you
    want to have child relationships to be deleted, you should use the
    dependent and element-dependent extensions.
    Ahmet Bulut wrote:
    Assume that I have two classes that I'd like to persist: MyObject and
    InternalObject. MyObject has an InternalObject field. That is, MyObject is
    the parent, InternalObject is the child in this one-to-one relationship.
    Steps involved:
    1) Enable ForeignKeyConstraints property in kodo.properties. That is add
    the line,
    kodo.jdbc.ForeignKeyConstraints=true
    2) In package.jdo, add the following kodo extensions for MyObject's
    InternalObject field mapping, i.e., io in my case.
    <field name="io" default-fetch-group="false">
    <extension vendor-name="kodo" key="jdbc-delete-action"
    value="cascade"/>
    <extension vendor-name="kodo" key="dependent" value="true"/>
    </field>
    The reasons that we have done these steps: we'd like kodo to properly
    re-order the sql statements if necessary in order not to violate
    parent/child dependencies during insertion, and also force cascading
    deletes in case we delete the parent object.
    Now comes the bulk of the algorithm.
    String sKey // key of the object to insert
    String sValue //value of the object to insert
    MyObject o = new MyObject(sKey, sValue);
    InternalObject io = new InternalObject(sKey,sValue); //using same values :)
    o.setInternalObject(io); //parent-child relation
    Object id = ((PersistenceCapable) o).jdoNewObjectIdInstance();
    ((PersistenceCapable)o).jdoCopyKeyFieldsToObjectId(id);
    kpm.currentTransaction().begin();
    try {
    Object trio = kpm.getObjectById(id, true);
    kpm.deletePersistent(trio);
    kpm.flush(); //apply deletes on the datastore
    } catch (ObjectNotFoundException oe) {
    System.out.println("First time!");
    kpm.makePersistent(o);
    kpm.currentTransaction().commit();
    Steve Kim
    [email protected]
    SolarMetric Inc.
    http://www.solarmetric.com

  • How to handle parent-child dimension in OWB?????

    i have a dimension have many levels,and the amount of levels is varing,so i cannot use the wizard to define my dimension ,seems with OWB i can only define dimension with certain amount of levels.......
    my dimension data is stored with this format:
    child parent
    Los Angles US
    US WORLD
    it is called a parent-child relation ,how can i define dimension with parent-child relation witn OWB...
    Can OWB do it ?????

    i have a dimension have many levels,and the amount of levels is varing,so i cannot use the wizard to define my dimension ,seems with OWB i can only define dimension with certain amount of levels.......
    my dimension data is stored with this format:
    child parent
    Los Angles US
    US WORLD
    it is called a parent-child relation ,how can i define dimension with parent-child relation witn OWB...
    Can OWB do it ????? You must define a dimension, define the dimension levels and the hierarchy inside the dimension (a hierarchy can have as many levels as you want, parent-child relationship is a normal hierarchy concept - no rocket science here). Then you have to map the data source for the dimension levels appropriately. Please refer to the user manual, chapter 4 ("Defining dimensianal targets") for details.
    Regards:
    Igor

Maybe you are looking for

  • Partial payment to vendor through APP

    Hi all, Can any one tell me how to configure if I want do partial payment to one or two vendors through APP. I mean I need to pay only 50% of invoice amount to my vendor through APP how is it to be configured. Please give me full configuration step T

  • Can't use iphone4s in Taiwan

    I had been using my unlocked iPhone4s in Australia for few months and it worked with every carriers. Now I'm in Taiwan and I cannot use it. What should I do?

  • Conversion from Windows to iPhoto

    Before I import my photos from my old to my new iMAC, I will be waiting for Leopard before getting my new iMAC, I want to find out the best way to organize my photos on the pc so the import to iPhoto is optimal. I currently have 487 folders and 11,88

  • Illustrator Duplicated Tons of Layers

    I had a problem today working with a file and I was wondering if someone out there has had the same problem, and what I did wrong. I tried to delete an object and come to find out there were SO many identical duplicate layers underneath it. It wasn't

  • Playlist folders aren't showing.  Match issue.

    Hi all, I use iTunes Match which has usually worked pretty well.  I recently started sorting my playlists into folders, since I have about 30 playlists and would like to keep them somewhat organized. However I can't see any of my playlists on my iPad