Need help on parameters

Hi experts
I need help on following  requirement .
I have declared one parameter and if excecute the program and i have given some value for parameter .and i  press F3 and again excecute the program  .now if i press back space or space  the previously given value is  displaying in drop down list .
Now i have to  clear values of drop down .
can anybody help on this .

Hi, Kamesh.
if you don't want to save these values than Follow the Instruction from J@Y and if you only want to remove the value from your that screen and want to continue saving than press space or backspace and when you will see these values place a mouse pointer over value and press DEL button from keyboard in this way one by one you can delete these,
Hope above will solve out your issue,
Best Regards,
Faisal

Similar Messages

  • Need Help Adding Parameters to addWatermarkFromText using VBA

    After three days of banging my head on a wall, I got this to work:
    Public Sub AddText()
        Dim pdApp As Acrobat.AcroApp
        Dim pdDoc As Acrobat.AcroPDDoc
        Dim jso As Object
        Set pdDoc = CreateObject("AcroExch.PDDoc")
        pdDoc.Open ("c:\Test\Test.pdf")
        Set jso = pdDoc.GetJSObject
        jso.addWatermarkFromText ("Test")
        pdDoc.Save 1, "c:\Test\Test.pdf"
        pdDoc.Close
        Set pdDoc = Nothing
        MsgBox "Done"
    End Sub
    However, every time I try to add parameters to jso.addWatermarkFromText I get an error message - something is wrong with my syntax I suppose but i have tried every example I could find and nothing is working for me.  Please help - all of the default parameters are find, just need the text to be at the top of the page, not the center.

    Where did you get the impression that you can execute JavaScript in Acrobat
    using this method? You really (let me repeat that REALLY) have to read the
    SDK documentation. There no no way around that. Anything that is not
    described in the documentation will not work. There is only one way to
    execute JavaScript using the IAC API, and that is using this call:
    http://livedocs.adobe.com/acrobat_sdk/11/Acrobat11_HTMLHelp/IAC_API_FormsIntro.108.45.html
    However, in this case there is no need to use the executeThisJavaScript
    function, you can use the JSO to add your watermark. Everything you need is
    in the documentation, and as I mentioned before, there is no way around
    reading and understanding the docs. You cannot just google your way through
    a complex problem and try to piece together a solution based on bits and
    pieces you find online. Why do I know this? Because oftentimes I get called
    in after somebody tries that approach to save some money. I then get to
    clean up the mess they made, and then it's not going to be cheap... And
    this is one of the reasons why people are reluctant to provide code samples
    in this forum.
    Using a complex API as the Acrobat SDK requires you to climb a pretty steep
    learning curve, and you have to spend weeks and months (and sometimes
    years) reading and experimenting until you understand how things work. And
    that is why it's usually cheaper and faster to hire somebody to do that
    work for you.
    Back to  your  problem. What have you tried? I only remember seeing your
    call to addWatermarkFromText using just the text argument. BTW: There was
    no need to start a new thread, you should have kept everything in the first
    thread you started, this way everything is in one place. If you've posted
    more in the other thread, then you are making it much harder for us to
    provide help.
    So again, what have you tried and what results have you gotten? What error
    messages did the system produce? When? When you compiled the code, or when
    you tried to execute it?
    Karl Heinz Kremer
    PDF Acrobatics Without a Net
    PDF Software Development, Training and More...
    [email protected]
    http://www.khkonsulting.com
    On Sat, Jul 27, 2013 at 8:31 AM, I Love Mustangs

  • Need help on Parameterized mapping in PI 7.1

    Dear all,
      i had a requirement in which Username, password & client values should pass from interface determination and these values should call through the  java mapping. i had gone through some of the discussions in SCN , but i cant understand. So can any one  please explain   step by step with java mapping.
    thanks in advance.

    hi Shaik Samir,
        In this pic you can see the user is creating the parameter called  TAG_NAME with a value "TAG"
    Then the java mapping code reads this parameter here in this line
    String inParam = arg0.getInputParameters().getString("TAG_NAME");
    In the string inParam we will have the value "TAG". You can do whatever you want with this value.
    Similarly you can write your own java code in NWDS as given in this sample mapping here
    http://wiki.scn.sap.com/wiki/display/XI/Parametrized+Java+Mapping+in+PI+7.1?original_fqdn=wiki.sdn.sap.com
    In your case you need to add Username, password & client values as parameters and their values as shown above and use them in your mapping. Hope I could explain you the process.
    All the best.
    Regards
    Anupam

  • HR_BEN_GET_PLAN_COST - Need help with parameters

    function hr_ben_get_plan_cost.
    *"*"Local interface:
    *"  IMPORTING
    *"     VALUE(EE_BENEFIT_DATA) LIKE  RPBENEEDAT STRUCTURE  RPBENEEDAT
    *"     VALUE(BPLAN) LIKE  T5UBA-BPLAN
    *"     VALUE(BCOST) LIKE  T5UBH-BCOST
    *"     VALUE(DATUM) LIKE  SY-DATUM
    *"     VALUE(COVER) LIKE  T74FC-COVAM DEFAULT 0
    *"     VALUE(OUT_CURRE) LIKE  T5UD3-CURRE
    *"     VALUE(OUT_PERIOD) LIKE  T5UBH-PERIO
    *"     VALUE(PERIO_DATE) LIKE  T549Q-BEGDA OPTIONAL
    *"     VALUE(IS_COBRA) TYPE  C DEFAULT ' '
    *"     VALUE(REACTION) LIKE  SY-MSGTY
    *"  EXPORTING
    *"     VALUE(EECST) LIKE  T5UBI-EECST
    *"     VALUE(PTCST) LIKE  T5UBI-PTCST
    *"     VALUE(ERCST) LIKE  T5UBI-ERCST
    *"     VALUE(ACCST) LIKE  T5UBI-ACCST
    *"     VALUE(IMINC) LIKE  T5UBI-IMINC
    *"     VALUE(FLXCR) LIKE  T5UBA-FLXCR
    *"     VALUE(SUBRC) LIKE  SY-SUBRC
    *"  TABLES
    *"      ERROR_TABLE STRUCTURE  RPBENERR
    I'm not sure what to pass to the following parameters:
    DATUM
    OUT_CURRE
    OUT_PERIOD
    PERIO-DATE
    Your assistance is greatly appreciated!

    Hello,
    You can use the FM like example below:
    *& Report  YRA_HEALTH_PLAN_DETAILS
    report  yra_health_plan_details no standard page heading line-size 255..
    Type-pools declarations
    type-pools: slis.
    Declare the Logical Database Node ( Pernr )
    tables: pernr,
            t500p,
            t529u,
            t501t,
            q0167,
            t5ubb,              "Benefit health option/dependent coverage assignment
            rpbeneedat.    "Benefit reference structure for function modules
    Mention the various infotypes to be used .
    infotypes: 0000,
               0001,
               0002,
               0008,
               0041,
               0167.
    Declare the Structures
    types: begin of t_final,                      "Structure for final Alv display
           pernr type pernr_d,                    "Employee id
           nachn type pad_nachn,                  "Last name
           vorna type pad_vorna,                  "First name
           perid type prdni,                      "Social Security Number
           name1 type pbtxt,                      "Personal Area
           kostl type kostl,                      "Cost Center
           text1 type text40,                     "Employment Status
           ptext type pgtxt,                      "Employee Group
           divgv type divgv,                      "Working Hours
           gbdat type gbdat,                      "Birth Date
           dat01 type dardt,                      "Hire Date
           dat02 type dardt,                      "Re Hire Date
           pltyp type ben_type,                   "Benefit Plan Type
           bplan type ben_plan,                   "Benefit Plan
           depcv type ben_depcov,                 "Dependent Coverage
           eecst type ben_eecost,                 "Benefit Employee Cost Amount
           ptcst type ben_ptcst,                  "Benefits Additional Employee Post-Tax Costs
           iminc type ben_iminc,                  "Benefits Imputed Income
           end of t_final.
    data: ee_benefit_data    like rpbeneedat,
          error_table        like rpbenerr occurs 0,
          h5ubb              like t5ubb,
          subrc              like sy-subrc.
    constants: no_msg      type sy-msgty value 'N',
               error_msg   type sy-msgty value 'E'.  .
    Declare the internal tables
    data:  t_data type standard table of t_final with header line,     " Output Internal Table
           s_data type t_final.                                        " Workarea for output itab
    data : fieldcatalog type slis_t_fieldcat_alv with header line,     "Fieldcatalog itab
           i_fieldcatalog type slis_fieldcat_alv,                      " Fieldcatalog header
           i_event      type slis_t_event,                             " table for events
           t_event      type slis_alv_event,                           " structure for events
           i_header     type slis_t_listheader,                        " FOR HEADER
           t_header     type slis_listheader.
    Declare Variables
    data: v_repid type sy-repid.
    I N I T I A L I Z A T I O N
      v_repid = sy-repid.
    START  OF  SELECTION
    start-of-selection.
    get pernr.
    rp-provide-from-last p0000 space pn-begda pn-endda.
      if p0000-stat2 ne '3'.                                " Process only active employees
        reject.
      endif.
      rp-provide-from-last p0001 space pn-begda pn-endda.
      if pnp-sw-found = 1.
        s_data-pernr = p0001-pernr.
        s_data-kostl = p0001-kostl.
      endif.
      rp-provide-from-last p0002 space pn-begda pn-endda.
      if pnp-sw-found = 1.
        s_data-nachn = p0002-nachn.
        s_data-vorna = p0002-vorna.
        s_data-perid = p0002-perid.
        s_data-gbdat = p0002-gbdat.
      endif.
    select single name1 from t500p into s_data-name1 where persa = p0001-werks.
      select single text1 from t529u into s_data-text1 where statn = 2 and statv = p0000-stat2.
      select single ptext from t501t into s_data-ptext where persg = p0001-persg.
      rp-provide-from-last p0008 space pn-begda pn-endda.
      if pnp-sw-found = 1.
        s_data-divgv = p0008-divgv.
      endif.
      rp-provide-from-last p0041 space pn-begda pn-endda.
      if pnp-sw-found = 1.
        s_data-dat01 = p0041-dat01.
        s_data-dat02 = p0041-dat02.
      endif.
      rp-provide-from-last p0167 space pn-begda pn-endda.
      if pnp-sw-found = 1.
       s_data-begda = p0167-begda.
       s_data-endda = p0167-endda.
        s_data-pltyp = p0167-pltyp.
        s_data-bplan = p0167-bplan.
        s_data-depcv = p0167-depcv.
       endif.
    form dynpro_fields.
      data: eeper like q0167-eeper.                                         .
    get cost date
      if q0167-cstdt is initial.
        call function 'HR_BEN_GET_KEY_DATE'
             exporting
                  begda       = p0167-begda
                  endda       = p0167-endda
                  reaction    = no_msg
             importing
                  keydt       = q0167-cstdt
             tables
                  error_table = error_table.
      else.
        if q0167-cstdt < p0167-begda.
          q0167-cstdt = p0167-begda.
        endif.
        if q0167-cstdt > p0167-endda.
          q0167-cstdt = p0167-endda.
        endif.
      endif.
    get employees pay frequency
      call function 'HR_BEN_GET_PLAN_PERIOD'
           exporting
                pernr         = p0167-pernr
                barea         = p0167-barea
                bplan         = p0167-bplan
                validity_date = q0167-cstdt
                reaction      = no_msg
           importing
                plan_period   = eeper
                subrc         = subrc
           tables
                error_table   = error_table.
    get currency for calculated amounts
      call function 'HR_BEN_GET_CURRENCY'
           exporting
                barea       = p0167-barea
                datum       = q0167-cstdt
                reaction    = no_msg
           importing
                currency    = q0167-curr1
                subrc       = subrc
           tables
                error_table = error_table.
      move q0167-curr1 to q0167-curr2.
      move q0167-curr1 to q0167-curr3.
      move q0167-curr1 to q0167-curr6.
      move q0167-curr1 to q0167-curr7.
    get cost formula
      perform re5ubb(sapfben0) tables error_table
                                using p0167-barea
                                      p0167-bplan
                                      p0167-bopti
                                      p0167-depcv
                                      q0167-cstdt
                                      no_msg
                             changing h5ubb
                                      subrc.
    calculate benefit cost
      call function 'HR_BEN_GET_PLAN_COST'
           exporting
                ee_benefit_data = ee_benefit_data
                bplan           = p0167-bplan
                bcost           = h5ubb-bcost
                datum           = q0167-cstdt
                out_period      = q0167-eeper
                out_curre       = q0167-curr1
                reaction        = no_msg
           importing
                eecst           = q0167-eecst
                ptcst           = q0167-ptcst
                ercst           = q0167-ercst
                accst           = q0167-accst
                iminc           = q0167-iminc
                flxcr           = q0167-flxcr
                subrc           = subrc
           tables
                error_table     = error_table.
        s_data-eecst = q0167-eecst.
        s_data-ptcst = q0167-ptcst.
        s_data-iminc = q0167-iminc.
        append s_data to t_data.
        clear s_data.
    ENDIF.
      end-of-selection.
    PERFORM download.
      perform alv_display.
    *&      Form  ALV_DISPLAY
          text
    -->  p1        text
    <--  p2        text
    form alv_display .
    IF t_data IS NOT INITIAL.
      perform build_fieldcatalog.
      perform event_cat using i_event.
      perform define_alv.
    ENDIF.
    endform.                    " ALV_DISPLAY
    *&      Form  event_cat
          text
         -->P_I_EVENT  text
    form event_cat  using  p_i_event type slis_t_event.
      refresh p_i_event.
      data : s_i_event type slis_alv_event.
      call function 'REUSE_ALV_EVENTS_GET'
        importing
          et_events = p_i_event.
      if sy-subrc <> 0.
        message id sy-msgid type sy-msgty number sy-msgno
                with sy-msgv1 sy-msgv2 sy-msgv3 sy-msgv4.
      endif.
      read table p_i_event with key name = slis_ev_top_of_page into t_event.
      if sy-subrc = 0.
        move 'TOP_OF_PAGE' to t_event-form.
        modify p_i_event from t_event index sy-tabix transporting form.
      endif.
    endform.                    " event_cat
    *&      Form  build_fieldcatalog
          text
    -->  p1        text
    <--  p2        text
    form build_fieldcatalog .
      define m_fieldcat.
        clear i_fieldcatalog.
        i_fieldcatalog-tabname   = 'T_DATA'.
        i_fieldcatalog-fieldname = &1.
        i_fieldcatalog-just = 'L'.
        i_fieldcatalog-outputlen  = &2.
        i_fieldcatalog-seltext_l = &3.
       I_FIELDCATALOG-COL_POS = &4.
        append i_fieldcatalog to fieldcatalog.
        clear i_fieldcatalog.
      end-of-definition.
      m_fieldcat: 'PERNR'  '08' 'Personnel No'.
      m_fieldcat: 'NACHN'  '40' 'Last Name' .
      m_fieldcat: 'VORNA'  '40' 'First name' .
      m_fieldcat: 'PERID'  '20' 'Social Security No.' .
      m_fieldcat: 'NAME1'  '30' 'Personal Area ' .
      m_fieldcat: 'KOSTL'  '10' 'Cost Center' .
      m_fieldcat: 'TEXT1'  '20' 'Employment Status'.
      m_fieldcat: 'PTEXT'  '20' 'Employment Group' .
      m_fieldcat: 'DIVGV'  '04' 'Working Hours'.
      m_fieldcat: 'GBDAT'  '08' 'Birthdate' .
      m_fieldcat: 'DAT01'  '08' 'Hire Date'      .
      m_fieldcat: 'DAT02'  '08' 'Re-Hire Date'    .
      m_fieldcat: 'PLTYP'  '04' 'Plan Type'   .
      m_fieldcat: 'BPLAN'  '04' 'Benefit Plan'.
      m_fieldcat: 'DEPCV'  '10' 'Dependent Coverage'      .
      m_fieldcat: 'EECST'  '10' 'Benefit Employee Cost Amount'.
      m_fieldcat: 'PTCST'  '10' 'Benefits Additional Employee Post-Tax Costs'.
      m_fieldcat: 'IMINC'  '10' 'Benefits Imputed Income'      .
    endform.                    " build_fieldcatalog
    *&      Form  define_alv
          text
    form define_alv.
      call function 'REUSE_ALV_GRID_DISPLAY'
       exporting
         i_callback_program                = sy-repid
      I_CALLBACK_PF_STATUS_SET          = ' '
      I_CALLBACK_USER_COMMAND           = ' '
      I_CALLBACK_TOP_OF_PAGE            = ' '
      I_GRID_TITLE                      =
      IS_LAYOUT                         =
         it_fieldcat                       = fieldcatalog[]
         it_events                         = i_event[]
    IMPORTING
      E_EXIT_CAUSED_BY_CALLER           =
      ES_EXIT_CAUSED_BY_USER            =
        tables
          t_outtab                          = t_data
       exceptions
         program_error                     = 1
         others                            = 2
      if sy-subrc <> 0.
        message id sy-msgid type sy-msgty number sy-msgno
                with sy-msgv1 sy-msgv2 sy-msgv3 sy-msgv4.
      endif.
    endform.                    " define_alv
    *&      Form  TOP_OF_PAGE
          text
    form top_of_page  .
    LIST HEADING LINE: TYPE H
      clear t_header.
      t_header-typ  = 'H'.
      t_header-info = 'Health Plan Details'.
      append t_header to i_header.
    STATUS LINE: TYPE S
      clear t_header.
      t_header-typ  = 'S'.
      t_header-key  = 'Date Of Run'.
      t_header-info = sy-datum.
      append t_header to i_header.
    ACTION LINE: TYPE A
      clear t_header.
      t_header-typ  = 'A'.
    LS_LINE-KEY:  NOT USED FOR THIS TYPE
      t_header-info = text-002.
      append t_header to i_header.
      call function 'REUSE_ALV_COMMENTARY_WRITE'
        exporting
          it_list_commentary       = i_header
      I_LOGO                   =
      I_END_OF_LIST_GRID       =
    endform.                    "TOP_OF_PAGE
    Hope it helps.
    Thanks,
    Jayant Sahu.

  • Need help with parameterizing query

    Hello,
    Database Version: 11gR1
    I have created a materialized view in my database which stores the moving average of Amount and Cummulative Amount for different customers for different months. The moving average window period is 6 months..i.e., If my base table has data for a customer for a period of 1 year(JAN07-DEC07), then in the materialized view the average values will be stored for each customer as follows:
    JAN-07 --Avg(JAN-07)
    FEB-07 --Avg(JAN-07, FEB-07)
    MAR-07--Avg(JAN-07,FEB-07,MAR-07)
    APR-07--Avg(JAN-07,FEB-07,MAR-07,APR-07)
    MAY-07--Avg(JAN-07,FEB-07,MAR-07,APR-07,MAY-07)
    JUN-07--Avg(JAN-07,FEB-07,MAR-07,APR-07,MAY-07,JUN-07)
    JUL-07--Avg(FEB-07,MAR-07,APR-07,MAY-07,JUN-07,JUL-07)
    AUG-07--Avg(MAR-07,APR-07,MAY-07,JUN-07,JUL-07,AUG-07)
    SEP-07--Avg(APR-07,MAY-07,JUN-07,JUL-07,AUG-07,SEP-07)
    OCT-07--Avg(MAY-07,JUN-07,JUL-07,AUG-07,SEP-07,OCT-07)
    NOV-07--Avg(JUN-07,JUL-07,AUG-07,SEP-07,OCT-07,NOV-07)
    DEC-07--Avg(JUL-07,AUG-07,SEP-07,OCT-07,NOV-07,DEC-07)
    Actually i need the values only from the month of July...i.e., avg values for the month of July, Aug, Sep, Oct..and so..But i dont want to hard code the date value in my Materialized view Query..Because as of now the data in my base table is till Dec-07..but it may increase also..So if i hard code the value to what i require now, then in future i may again have to change the query..
    So my question is, Is there any way by which i can parameterize the date values in my materialized view query, so that my materialized view stores the data for date only which i require..
    One more problem is as and when my base table grows, my materialized table would also grow if i dont parameterize the date in the query. So i need to avoid that also..
    One solution what i thought of is to keep data in my base tables only for the required period.i.e., when i want the average values for the month of July, then the data in my base table will be only from Feb-07 to Jul-07, and for the month of Aug data will be only from Mar-07 to Aug-07 and so...So that when i refresh my MV, there will be only six months data, and the number of rows in my MV will be constant and hence the MV size also will be constant..
    Is there any way by which i can schedule to delete the data from my base table as when month changes..I want it to be done automatically when month gets changed..So if anybody knows of a way to do it, Please help me...
    It will be of great help..

    Hi,
    You're creating a materialized view with one row for every combination of customer_id and month, but you don't really want all those rows. What you really want are just the rows where month=target_month, and you (wisely) don't want to hard-code "month=target_month" into the WHERE-clause of the view definition. Is that right?
    If so, you can create a one-row table called param, which has a column for storing the target_month. Your view can do a scalar sub-query or a cross-join to get the value from the param table to use in its WHERE-clause.

  • Need help with drop down list in parameters

    Hi All,
    I have the following data set:
    DEPT1     DEPT2     DEPT3 DEPT4
    Commissioner's Office     Finance     Accounting     Accounts Payable
    Commissioner's Office     Finance     Accounting     Fiscal Analysis & Repo
    Commissioner's Office     Finance     Accounting     
    Commissioner's Office     Planning,Asset Mgt     Asset Management     Inventory & Tracking
    Commissioner's Office     Planning,Asset Mgt     Asset Management     Mobility & Congestion
    Commissioner's Office     Planning,Asset Mgt     Asset Management     Roadway Safety
    Commissioner's Office     Planning,Asset Mgt     Asset Management     
    Commissioner's Office     DesignProj Mgt & Tec     Bridge Dsgn Insp Hyd     
    In plus i have four parameters with searchlight options, the problem is when i select "Finance" from DEPT2 and in the next selection level i'm seeing all the departments "Accounting,Asset Management and Bridge Dsgn Insp Hyd" insted of just "Accounting". What i want is if i select a department in DEPT2, in the next drop down list(DEPT3) i want to see only the departement corresponding to the one i selected in dept2. Please need help.
    Thanks

    Hi
    First of all you need to be using Discoverer 10g or 11g Plus not 9.0.4. Assuming you have the right version you need to present the parameters in the correct order. You can change the order on the parameters screen by selecting Tools | Parameters from the toolbar. You then use the Move Up and Move Down buttons to place them in the right order so that DEPT1 is offered first, followed by DEPT2, then DEPT3 and then DEPT4.
    Next, you need to check the radion button on the bottom of the right-hand side that allows linking of parameters then you make DEPT2 dependent upon DEPT1, with DEPT3 dependent upon DEPT2 and so on.
    While this works without hierarchies it works best when you have a hierarchy in place and even better when there is a composite index on the 4 items.
    Best wishes
    Michael

  • Need help in modifying mapping parameters of out the box mapping

    Hi There,
    I am a new bee to dac.
    Need help in modifying mapping parameters of out the box mapping, which is invoked by DAC task.
    We got a requirement to edit mapping parameter. When I go and see parameter under mappings tab in a mapping, I could not see any values in it.
    But when I set any value, and validate it. It is successful.
    Is it right way to do it?
    What my concern is, When I initially go and see parameter values under maapings tab in a mapping, they are blank.
    Where is it storing these values?
    Thanks,
    Rag

    If you modify mapping then u have to create new task in dac and dac itself craete parameter file at run time. if you want to add more parameters then do it in dac system parameters tab.
    Thanks
    Jay.

  • I need help regarding measurement of "time domain parameters of Heart rate variability" using labview.

    I need help regarding measurement of "time domain parameters of Heart rate variability" using labview.
    I am using Labview 8 ... I  need to develop a software to accquire the ECG data (simulated enironment ) and compute the time domain parameters of Heart rate variability like "SDNN, SDANN...etc". Can some 1 plllzzzz help me out.Plzz help me if u can.Thanx in advance.

    Hi Andy,
      Thanx for responding.  The input is from a text file. SDNN, SDANN,etc are  the timedomain parameters of heart rate variability.
     SDNN: the standard deviation of the NN or RR interval  i.e. the square root of variance.
    SDANN:the standard deviation of the averageNN interval calculated over short periods, usually 5 min,which is an estimate of the changes in heart rate due tocycles longer than 5 min
    SDNN index, the meanof the 5-min standard deviation of the NN intervalcalculated over 24 h,
     RMSSD: the square root ofthe mean squared differences of successive NN intervals
    NN50: the number of interval differences of successiveNN intervals greater than 50 ms, and
    pNN50 the proportionderived by dividing NN50 by the total numberof NN intervals.
    The problem is dat I am a fresher to the world of Labview. I have jus recently started working on it. Can u please suggest me some some idea as soon as possible.
      As i said  I have the ECG data in the form of text files..I need to create sort of GUI to calculate the time domain parmeters....I need help urgently. Plzzz help me if u can. If u have and .vi example to calculate the RR interval plzz send it to me ASAP.
    Thanku

  • Need help in building a utility...?

    Gurus,
    I need to build a dynamic selection screen for a utility that will extract data from a legacy database. I am not sure how to do it....I have the design in mind but will need help from you experts in the implementation.
    So i need to have to twol radip buttons on the selection screen such that when one radio button is clicked then few other select options come on the screen and when the other radio button is selected then different select options come on the screen.
    Once the user any of these two radio buttons and fill in the respective values for the parameters, then i have to fire native SQL queries on the legacy SQL database.
    Any suggestions...
    First i need to code the dynamic selection screen ....Your help will be appreciated...
    Thanks

    Please have a look at below link. May be helpful to you...[Dynamic Selection Screen|https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/a07a330f-126c-2910-c684-d2a45f0f37dd]
    I hope it helps.
    Best Regards,
    Vibha

  • I need helping!!! configuring RDP access to my local server from a remote location on my Cisco ASA 5505 Firewall.

    I need helping configuring RDP access to my local server from a remote location on my Cisco ASA 5505 Firewall.
    I have attempted to configure rdp access but it does not seem to be working for me Could I please ask someone to help me modify my current configuration to allow this? Please do step by step as I could use all the help I could get.
    I need to allow the following IP addresses to have RDP access to my server:
    66.237.238.193-66.237.238.222
    69.195.249.177-69.195.249.190
    69.65.80.240-69.65.80.249
    My external WAN server info is - 99.89.69.333
    The internal IP address of my server is - 192.168.6.2
    The other server shows up as 99.89.69.334 but is working fine.
    I already added one server for Static route and RDP but when I try to put in same commands it doesnt allow me to for this new one. Please take a look at my configuration file and give me the commands i need in order to put this through. Also please tell me if there are any bad/conflicting entries.
    THE FOLLOWING IS MY CONFIGURATION FILE
    Also I have modified IP information so that its not the ACTUAL ip info for my server/network etc... lol for security reasons of course
    Also the bolded lines are the modifications I made but that arent working.
    ASA Version 7.2(4)
    hostname ciscoasa
    domain-name default.domain.invalid
    enable password DowJbZ7jrm5Nkm5B encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.6.254 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 99.89.69.233 255.255.255.248
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    object-group network EMRMC
    network-object 10.1.2.0 255.255.255.0
    network-object 192.168.10.0 255.255.255.0
    network-object 192.168.11.0 255.255.255.0
    network-object 172.16.0.0 255.255.0.0
    network-object 192.168.9.0 255.255.255.0
    object-group service RDP tcp
    description RDP
    port-object eq 3389
    object-group service GMED tcp
    description GMED
    port-object eq 3390
    object-group service MarsAccess tcp
    description MarsAccess
    port-object range pcanywhere-data 5632
    object-group service MarsFTP tcp
    description MarsFTP
    port-object range ftp-data ftp
    object-group service MarsSupportAppls tcp
    description MarsSupportAppls
    port-object eq 1972
    object-group service MarsUpdatePort tcp
    description MarsUpdatePort
    port-object eq 7835
    object-group service NM1503 tcp
    description NM1503
    port-object eq 1503
    object-group service NM1720 tcp
    description NM1720
    port-object eq h323
    object-group service NM1731 tcp
    description NM1731
    port-object eq 1731
    object-group service NM389 tcp
    description NM389
    port-object eq ldap
    object-group service NM522 tcp
    description NM522
    port-object eq 522
    object-group service SSL tcp
    description SSL
    port-object eq https
    object-group service rdp tcp
    port-object eq 3389
    access-list outside_1_cryptomap extended permit ip 192.168.6.0 255.255.255.0 object-group EMRMC
    access-list inside_nat0_outbound extended permit ip 192.168.6.0 255.255.255.0 192.168.0.0 255.255.0.0
    access-list inside_nat0_outbound extended permit ip 192.168.6.0 255.255.255.0 object-group EMRMC
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 host 99.89.69.334 eq pcanywhere-data
    access-list outside_access_in extended permit udp 69.16.158.128 255.255.255.128 host 99.89.69.334 eq pcanywhere-status
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 host 99.89.69.334 object-group RDP
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq ftp
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq ldap
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq h323
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq telnet
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq www
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 host 99.89.69.334 object-group SSL
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 object-group NM522
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 object-group NM1731
    access-list outside_access_in extended permit tcp 173.197.144.48 255.255.255.248 host 99.89.69.334 object-group RDP
    access-list outside_access_in extended permit tcp any interface outside eq 3389
    access-list outside_access_in extended permit tcp host 66.237.238.194 host 99.89.69.333
    access-list outside_access_in extended permit tcp host 66.237.238.194 host 99.89.69.333 object-group rdp
    access-list outside_access_in extended permit tcp any host 99.89.69.333 object-group rdp
    access-list out_in extended permit tcp any host 192.168.6.2 eq 3389
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-524.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp 99.89.69.334 3389 192.168.6.1 3389 netmask 255.255.255.255
    static (inside,outside) tcp interface 3389 192.168.6.2 3389 netmask 255.255.255.255
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 99.89.69.338 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    http server enable
    http 192.168.6.0 255.255.255.0 inside
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto map outside_map 1 match address outside_1_cryptomap
    crypto map outside_map 1 set peer 68.156.148.5
    crypto map outside_map 1 set transform-set ESP-3DES-MD5
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash md5
    group 1
    lifetime 86400
    crypto isakmp policy 30
    authentication pre-share
    encryption 3des
    hash md5
    group 2
    lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside
    tunnel-group 68.156.148.5 type ipsec-l2l
    tunnel-group 68.156.148.5 ipsec-attributes
    pre-shared-key *
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:f47dfb2cf91833f0366ff572eafefb1d
    : end
    ciscoasa(config-network)#

    Unclear what did not work.  In your original post you include said some commands were added but don't work:
    static (inside,outside) tcp interface 3389 192.168.6.2 3389 netmask 255.255.255.255
    and later you state you add another command that gets an error:
    static (inside,outside) tcp 99.89.69.333 3389 192.168.6.2 3389 netmask 255.255.255.255
    You also stated that 99.89.69.333 (actually 99.89.69.233, guessing from the rest of your config and other posts) is your WAN IP address.
    The first static statement matches Cisco's documentation, which states that a static statement must use the 'interface' directive when you are trying to do static PAT utilizing the IP address of the interface.  Since 99.89.69.333 is the assigned IP address of your WAN interface, that may explain why the second statement fails.
    Any reason why you are using static PAT (including the port number 3389) instead of just skipping that directive?  Static PAT usually makes sense when you need to change the TCP port number.  In your example, you are not changing the TCP port 3389.

  • Need help in using FM BAPI_MATERIAL_SAVEDATA

    Gurus,
    I need help in using the FM BAPI_MATERIAL_SAVEDATA. The FM is returning a message that says "The field MARA-MEINS/BAPI_MARA-BASE_UOM(_ISO) is defined as a required field; it does not contain an entry".
    I have supplied the necessary details and yet the FM won't push through.
    If possible, please post sample codes.
    Below is my sample code:
    ===============================================
    REPORT  zmm_materialupload.
    eject
    $$******************************************************************************
    $$    TYPES
    $$******************************************************************************
    eject
    $$******************************************************************************
    $$    INTERNAL TABLES (custom structure
    $$******************************************************************************
    eject
    $$******************************************************************************
    $$    RANGES
    $$******************************************************************************
    eject
    $$******************************************************************************
    $$    FIELD-SYMBOLS
    $$******************************************************************************
    eject
    $$******************************************************************************
    $$    PARAMETERS & SELECT-OPTIONS
    $$******************************************************************************
    SELECTION-SCREEN BEGIN OF BLOCK 1 WITH FRAME TITLE text-001.
    *SELECT-OPTIONS: s_matnr FOR mara-matnr.
    SELECT-OPTIONS: s_mtart FOR mara-mtart.
    SELECT-OPTIONS: s_mbrsh FOR mara-mbrsh DEFAULT 'P'.
    SELECT-OPTIONS: s_werks FOR marc-werks DEFAULT '1000' OBLIGATORY.
    SELECT-OPTIONS: s_lgort FOR marc-lgpro DEFAULT 'OPSL' OBLIGATORY.
    PARAMETERS: p_path  LIKE rlgrap-filename DEFAULT 'C:\Documents and Settings\training_11\Desktop\Book4 (2ITEMS).txt' OBLIGATORY.
    SELECTION-SCREEN END OF BLOCK 1.
    AT SELECTION-SCREEN ON VALUE-REQUEST FOR p_path.
      CALL FUNCTION 'F4_FILENAME'
        EXPORTING
          field_name = 'P_FNAME'
        IMPORTING
          file_name  = p_path.
    eject
    $$******************************************************************************
    $$    START-OF-SELECTION
    $$******************************************************************************
    START-OF-SELECTION.
      PERFORM check_input.
      PERFORM get_file.
      PERFORM filter_input.
    PERFORM populate_tabs.
      PERFORM bapi_mat.
    eject
    $$******************************************************************************
    $$    FORMS
    $$******************************************************************************
    FORM bapi_mat.
      LOOP AT it_tab INTO wa_tab.
        CALL FUNCTION 'BAPI_MATERIAL_GETINTNUMBER'
          EXPORTING
            material_type    = wa_tab-mtart
            industry_sector  = wa_tab-mbrsh
            required_numbers = 1
          TABLES
            material_number  = it_matnr.
      ENDLOOP.
      LOOP AT it_matnr INTO wa_matnr.
        READ TABLE it_tab INTO wa_tab INDEX sy-tabix.
        wa_tab-matnr = wa_matnr-material.
        MODIFY it_tab FROM wa_tab INDEX sy-tabix.
      ENDLOOP.
      PERFORM populate_tabs.
      CALL FUNCTION 'BAPI_MATERIAL_SAVEDATA'
        EXPORTING
         headdata                   = it_headdata
        clientdata                 = it_clientdata
        clientdatax                = it_clientdatax
        plantdata                  = it_plantdata
        plantdatax                 = it_plantdatax
        FORECASTPARAMETERS         =
        FORECASTPARAMETERSX        =
        PLANNINGDATA               =
        PLANNINGDATAX              =
        STORAGELOCATIONDATA        =
        STORAGELOCATIONDATAX       =
        valuationdata              = it_valuationdata
        valuationdatax             = it_valuationdatax
         WAREHOUSENUMBERDATA        =
        WAREHOUSENUMBERDATAX       =
        SALESDATA                  =
        SALESDATAX                 =
        STORAGETYPEDATA            =
        STORAGETYPEDATAX           =
        flag_online                = ' '
        flag_cad_call              = ' '
        NO_DEQUEUE                 = ' '
        NO_ROLLBACK_WORK           = ' '
       IMPORTING
         return                     = it_return
       TABLES
         materialdescription        = it_materialdescription
         unitsofmeasure             = it_unitsofmeasure
         unitsofmeasurex            = it_unitsofmeasurex
         internationalartnos        = it_internationalartnos
         materiallongtext           = it_materiallongtext
         taxclassifications         = it_taxclassifications
         returnmessages             = it_returnmessages
        PRTDATA                    =
        PRTDATAX                   =
        EXTENSIONIN                =
        EXTENSIONINX               =
      IF sy-subrc = 0.
      ENDIF.
      CALL FUNCTION 'BAPI_TRANSACTION_COMMIT'
        EXPORTING
          wait   = 'X'
        IMPORTING
          return = it_return.
    ENDFORM.                    "bapi_mat
    *&      Form  GET_FILE
          text
    FORM get_file.
      CALL FUNCTION 'SAPGUI_PROGRESS_INDICATOR'
        EXPORTING
          text = 'Getting data from file...'.
      MOVE: p_path TO gv_file.
      CALL FUNCTION 'GUI_UPLOAD'
        EXPORTING
          filename                = gv_file
          filetype                = 'ASC'
          has_field_separator     = 'X'
          read_by_line            = 'X'
        TABLES
          data_tab                = it_tab
        EXCEPTIONS
          file_open_error         = 1
          file_read_error         = 2
          no_batch                = 3
          gui_refuse_filetransfer = 4
          invalid_type            = 5
          no_authority            = 6
          unknown_error           = 7
          bad_data_format         = 8
          header_not_allowed      = 9
          separator_not_allowed   = 10
          header_too_long         = 11
          unknown_dp_error        = 12
          access_denied           = 13
          dp_out_of_memory        = 14
          disk_full               = 15
          dp_timeout              = 16
          OTHERS                  = 17.
      IF sy-subrc <> 0.
        MESSAGE ID sy-msgid TYPE sy-msgty NUMBER sy-msgno
                WITH sy-msgv1 sy-msgv2 sy-msgv3 sy-msgv4.
      ENDIF.
    ENDFORM.                    "GET_FILE
    *&      Form  check_input
          text
    FORM check_input.
    Material Type
      IF s_mtart-low IS INITIAL AND s_mtart-high IS INITIAL.
       s_mtart = 'IEQ'.
       s_mtart-low = 'ABF'.        "Waste
       s_mtart-high = 'ZTRD'.      "Stock Items
       APPEND s_mtart.
      ENDIF.
      IF s_mtart-low IS NOT INITIAL AND s_mtart-high IS INITIAL.
        MOVE: s_mtart-low TO s_mtart-high.
      ENDIF.
    Industry Sector
      IF s_mbrsh-low IS INITIAL AND s_mbrsh-high IS INITIAL.
       s_mbrsh = 'IEQ'.
       SELECT mbrsh
       FROM mara
       INTO TABLE it_mbrsh.
       s_mbrsh-low = wa_mbrsh-mbrsh.
       LOOP AT it_mbrsh INTO wa_mbrsh.
         s_mbrsh-high = wa_mbrsh-mbrsh.
       ENDLOOP.
       APPEND s_mbrsh.
      ENDIF.
      IF s_mbrsh-low IS NOT INITIAL AND s_mbrsh-high IS INITIAL.
        MOVE: s_mbrsh-low TO s_mbrsh-high.
      ENDIF.
    Plant
      IF s_werks-low IS INITIAL AND s_werks-high IS INITIAL.
        s_werks = 'IEQ'.
        s_werks-low = '1000'.
        s_werks-high = '2000'.
      ENDIF.
      IF s_werks-low IS NOT INITIAL AND s_werks-high IS INITIAL.
        MOVE: s_werks-low TO s_werks-high.
      ENDIF.
    Storage Location
      IF s_lgort-low IS NOT INITIAL AND s_lgort-high IS INITIAL.
        MOVE: s_lgort-low TO s_lgort-high.
      ENDIF.
    ENDFORM.                    "check_input
    *&      Form  Filter_input
          text
    FORM filter_input.
      SORT it_tab BY matnr mtart mbrsh werks lgort.
      LOOP AT it_tab INTO wa_tab.
       IF wa_tab-mtart NOT IN s_mtart.
         DELETE it_tab WHERE mtart NOT IN s_mtart.
       ENDIF.
       IF wa_tab-mbrsh NOT IN s_mbrsh.
         DELETE it_tab WHERE mbrsh NOT IN s_mbrsh.
       ENDIF.
        IF wa_tab-werks NOT IN s_werks.
          DELETE it_tab WHERE werks NOT IN s_werks.
        ENDIF.
        IF wa_tab-lgort NOT IN s_lgort.
          DELETE it_tab WHERE lgort NOT IN s_lgort.
        ENDIF.
      ENDLOOP.
    ENDFORM.                    "Filter_input
    *&      Form  populate_tabs
          text
    FORM    populate_tabs.
      LOOP AT it_tab INTO wa_tab.
        MOVE: wa_tab-matnr TO wa_headdata-material,
              wa_tab-mbrsh TO wa_headdata-ind_sector,
              wa_tab-mtart TO wa_headdata-matl_type,
                       'X' TO wa_headdata-basic_view,
                       'X' TO wa_headdata-sales_view,
                       'X' TO wa_headdata-purchase_view,
                       'X' TO wa_headdata-mrp_view,
                       'X' TO wa_headdata-account_view.
             wa_tab-matkl TO wa_clientdata-matl_group,
             wa_tab-meins TO wa_clientdata-base_uom,
             wa_tab-groes TO wa_clientdata-size_dim,
             wa_tab-gewei TO wa_clientdata-unit_of_wt,
             wa_tab-ntgew TO wa_clientdata-net_weight,
                      'X' TO wa_clientdatax-matl_group,
                      'X' TO wa_clientdatax-base_uom,
                      'X' TO wa_clientdata-size_dim,
                      'X' TO wa_clientdatax-unit_of_wt,
                      'X' TO wa_clientdatax-net_weight,
             wa_tab-werks TO wa_plantdata-plant,
             wa_tab-ekgrp TO wa_plantdata-pur_group,
             wa_tab-prctr TO wa_plantdata-profit_ctr,
             wa_tab-werks TO wa_plantdatax-plant,
                      'X' TO wa_plantdatax-pur_group,
                      'X' TO wa_plantdatax-profit_ctr,
             wa_tab-werks TO wa_valuationdata-val_area,
             wa_tab-bklas TO wa_valuationdata-val_class,
             wa_tab-peinh TO wa_valuationdata-price_unit,
             wa_tab-verpr TO wa_valuationdata-moving_pr,
             wa_tab-stprs TO wa_valuationdata-std_price,
             wa_tab-xlifo TO wa_valuationdata-lifo_fifo,
             wa_tab-werks TO wa_valuationdatax-val_area,
                      'X' TO wa_valuationdatax-val_class,
                      'X' TO wa_valuationdatax-price_unit,
                      'X' TO wa_valuationdatax-moving_pr,
                      'X' TO wa_valuationdatax-std_price,
                      'X' TO wa_valuationdatax-lifo_fifo.
        APPEND wa_headdata TO it_headdata.
       APPEND wa_clientdata TO it_clientdata.
       APPEND wa_plantdata TO it_plantdata.
       APPEND wa_valuationdata TO it_valuationdata.
       MODIFY it_tab FROM wa_tab TRANSPORTING matnr.
      ENDLOOP.
    ENDFORM.                    "populate_tabs
    $$******************************************************************************

    Hai.
    check the below example.
    REPORT z34332_bdc_create_material .
    data: la_headdata type BAPIMATHEAD,
    la_clientdata type BAPI_MARA,
    la_CLIENTDATAX type BAPI_MARAX,
    la_return type BAPIRET2.
    data: i_materialdescription type table of BAPI_MAKT,
    wa_materialdescription like line of i_materialdescription.
    la_headdata-MATERIAL = '000000000000000004'.
    la_headdata-IND_SECTOR = 'M'.
    la_headdata-MATL_TYPE = 'FERT'.
    la_clientdata-BASE_UOM = 'FT3'.
    la_CLIENTDATAX-BASE_UOM = 'X'.
    la_clientdata-MATL_GROUP = '01'.
    la_CLIENTDATAX-MATL_GROUP = 'X'.
    wa_materialdescription = 'TEST'.
    append wa_materialdescription to i_materialdescription.
    clear: wa_materialdescription.
    CALL FUNCTION 'BAPI_MATERIAL_SAVEDATA'
    EXPORTING
    headdata = la_headdata
    CLIENTDATA = la_clientdata
    CLIENTDATAX = la_CLIENTDATAX
    PLANTDATA =
    PLANTDATAX =
    FORECASTPARAMETERS =
    FORECASTPARAMETERSX =
    PLANNINGDATA =
    PLANNINGDATAX =
    STORAGELOCATIONDATA =
    STORAGELOCATIONDATAX =
    VALUATIONDATA =
    VALUATIONDATAX =
    WAREHOUSENUMBERDATA =
    WAREHOUSENUMBERDATAX =
    SALESDATA =
    SALESDATAX =
    STORAGETYPEDATA =
    STORAGETYPEDATAX =
    FLAG_ONLINE = ' '
    FLAG_CAD_CALL = ' '
    IMPORTING
    RETURN = la_return
    TABLES
    MATERIALDESCRIPTION = i_materialdescription
    UNITSOFMEASURE =
    UNITSOFMEASUREX =
    INTERNATIONALARTNOS =
    MATERIALLONGTEXT =
    TAXCLASSIFICATIONS =
    RETURNMESSAGES =
    PRTDATA =
    PRTDATAX =
    EXTENSIONIN =
    EXTENSIONINX =
    write: la_return-TYPE, ',', la_return-MESSAGE.
    clear: la_headdata, la_return, la_clientdata, la_clientdatax.
    regards.
    sowjanya.b.

  • I need help to modify my AS script

    I have the following script and I would like to modify it:
    1.On this file I need to type the name of some video Albums in order to be displayed in the SWF file.
    2. What I wanr is that this file read the specific folder and read the directories which they will be the names of the Albums
    How can I do this?
    One more thing is that this file was created to work with Flas CS3 and I am trying to test it with CS5.
    I really appreciate the whole help I can get.
    I don't know anything about AS2 nor AS3, I only know hoe to modify the files by following comments and other samples from all around the web.
    Thanks and I hope someone can help me, I've been trying few thing but I just stuck. So I really need help.
    //  Set the path to the External Parameters file relative to the *.swf file.
    //  If this file cannot be found or if it contains errors, the
    //  Internal Parameters(the parameters below) will be used.
    //var ParametersFile = "MyControls.xml";
    var ParametersFile = "XML_Files/MyControls.xml";
    //  Set the path to the Theme file relative to the *.swf file.
    //  If this file cannot be found or if it contains errors, the
    //  Default Grey skin will be used instead.
    //  To learn how to edit Themes, please refer to the 'Help' folder.
    // next line commented by SAMY
    //var ThemeFile = "Theme.xml";
    // NEXT LINE ADDED BY SAMY
    var ThemeFile = "FLASH_DIR/3D_GALLERY/BlueTheme.xml";
    //  To learn more about how to add albums, please refer to the
    //  'Help' folder. This line says that replace and modify the name of the title album and the xml file which is as shown here
    var AlbumLabel_1 = "Pastor Alejandro Bullon";//<-- This is the typical line that I want to be input from the external folder name *
    //var AlbumDataFile_1 = "Videos/Alejandro_B/Alejandro_Bullon.xml";
    // next line for website configuration typical
    //var AlbumDataFile_1 = "Media/Media.xml";
    //next line works fine locally
    //var AlbumDataFile_1 = "Videos/Videos_website.xml";
    var AlbumDataFile_1 = "FLASH_DIR/3D_GALLERY/Videos/Alejandro_B/Alejandro_B.xml";
    var AlbumLabel_2 = "Pastor Stephen Bohr";// <--  *
    // next line commented by samy
    var AlbumDataFile_2 = "FLASH_DIR/3D_GALLERY/Videos/Stephen_B/Stephen_Bohr.xml";
    // next line added by samy for website configuration typical for all albums
    //var AlbumDataFile_2 = "Videos/Videos.xml";
    var AlbumLabel_3 = "Pastor Caleb Jara";
    var AlbumDataFile_3 = "FLASH_DIR/3D_GALLERY/Videos/Caleb_Jara/Caleb_Jara.xml";
    //var AlbumDataFile_3 = "City/City.xml";
    var AlbumLabel_4 = "Pastor Doug_Batchellor";
    var AlbumDataFile_4 = "FLASH_DIR/3D_GALLERY/Videos/Doug_B/Doug_Batchellor.xml";
    //var AlbumDataFile_4 = "FLASH_DIR/3D_GALLERY/City/City.xml";
    var AlbumLabel_5 = "Musica";
    var AlbumDataFile_5 = "FLASH_DIR/3D_GALLERY/Musica/Musica.xml";
    //var AlbumDataFile_5 = "Landscape/Landscape.xml";
    var AlbumLabel_6 = "Powerpoint";
    var AlbumDataFile_6 = "FLASH_DIR/3D_GALLERY/Powerpoint/Powerpoint.xml";
    var AlbumLabel_7 = "Escuela Sabatica '10";
    var AlbumDataFile_7 = "FLASH_DIR/3D_GALLERY/Escuela_Sab/Esc_Sab_2010.xml";
    var AlbumLabel_8 = "Escuela Sabatica '11";
    var AlbumDataFile_8 = "FLASH_DIR/3D_GALLERY/Escuela_Sab/Esc_Sab_2011.xml";
    var AlbumLabel_9 = "Test Nature";
    var AlbumDataFile_9 = "Nature/Nature.xml";
    //  Select wether to enable or disable error messages created
    //  due to 'file not found' , 'format not supported' or 'corrupted
    //  XML files' type of errors.
    //  Note: There error messages are automatically disabled when you
    //  export your *.swf file.
    var EnableErrorMessages = "yes";//[Yes  , No]
    //  Set parameters for items.
    var ItemWidth = 170;
    var ItemHeight= 130;
    var ShowItemNumber = "yes";
    //var ShowItemNumber = "no";
    //  Select fitting technique , stretch the thumb picture to fit the item
    //  or crop it from the top left.
    var ThumbFittingMethod = "stretch";
    //  Select what to do when the file preview is clicked, either to enlarge
    //  the preview or navigate to the URL provided for the current item in
    //  the XML data file of the current album
    var WhenPreviewIsClicked = "Enlarge";//[Enlarge  , GetUrl]
    //  Select the window target, '_blank' to open a new window or '_self' to
    //  navigate to the URL in the same window
    var WindowTarget = "_blank";
    //  Select wether to show the information of the item or not
    var ShowItemInfo = "yes";
    //  Select wether to show the albums menu or not
    var ShowAlbumsMenu = "yes";
    //  Select wether to show the video controller or not
    var ShowVideoController = "yes";
    //  Select wether to show the autoplay option or not
    //var ShowAutoplayButton="no";
    var ShowAutoplayButton="yes";
    //  Set the delay time for autoplay, this will be used for pictures only
    var AutoplayDelayTime = 5;
    //  Set the spinning speed of a single wheel
    //var WheelSpinningSpeed = 5;
    var WheelSpinningSpeed = 2;
    //  Select direction of scrolling of pages
    var DefaultDirection = "LeftToRight";
    //  Select wether you want to disable one of the wheels
    var DisableWheel = "none";
    //  Set the maximum number of items to be loaded on a single wheel
    var MaximumLoadOnEachWheel = 10;
    //  Select how you want the wheel to interact with the mouse
    //  Refer to the 'Help' folder for more information.
    var ScrollingStyle = "2";
    //  Select wether to enable tool tips or not.
    var EnableToolTips = "yes";
    //  Set the delay time for the tool tips to appear
    var ToolTipsDelayTime = 1;
    //  This is like a shortcut, set this parameter to 'Name' to display
    //  the name of the item as a tool tip.......
    var ToolTipsContent = "tooltips";//[ToolTips , Name , FileType]
    //  Select wether to enable or disable visual effects.
    var EnableDepthOfField = "yes";
    var EnableMotionBlur = "yes";
    Message was edited by: samy4movies

    This is a web-based app. And the application is for a carrousel video gallery.
    I already figure out the auto XML generator with php, but I think I want to get all in one process. Meaning that I only want to upload my videos and run php codes by themselves and not to worry in adding or modifying the *.fla file everytime that I insert a new folder ("Album").
    This is the link for the project I am working 
    http://anaheimspanish.net/index.php?option=com_content&view=article&id=98&Itemid=124
    It's called 3D Video Gallery, I bought the component through a website for flash components, but their support is not very good, that's why I want to fix as much as I need.
    Thanks in advance for your help
    If you need a full zip project to test it, let me know.

  • Need help with java

    ok so i have a midterm and need help this question that is gonna be on the midterm. i dont know how to do it and its worth 16 marks!!!! here it is
    the UW Orchestra wants to produce a CD containing all the pieces of music
    from its upcoming concert. In order to do that, it needs to calculate the total length of time for the
    CD. In addition, the conductor wishes to know which piece of music has the longest duration.
    Sample output for the program.
    The Swan (3.88)
    The Bee (0.98)
    Claire de Lune (6.02)
    Liebesfreund (3.38)
    Ragtime (3.48)
    The total time for the CD is 18.74 minutes.
    The longest piece is Claire de Lune.
    Do not include the HTML that is required to embed the program into a Web page (that is, show
    only what you would write between <script> and </script> tags).
    [4 marks] In the following space, define a function, Print, that takes two parameters, Title and
    Length, and outputs a line of text such that Title appears in italics, followed by Length in
    parentheses. The function also returns the value of Length.
    For example, Print("My World",30) will output the line
    My World (30)
    and return the value 30.
    Put your JavaScript program for the remainder of this question in the space provided on the next
    two pages.
    [9 marks]. For each piece of music, your program should input the title of the piece and the
    duration (in minutes) for that piece, and it should output a line showing those values using the
    Print function just defined. After all pieces have been listed, the program should output the
    total length of time for the CD, adding in 0.25 minutes between each piece of music (which is
    needed on the CD to separate the pieces).
    [3 marks] The program should also output the name of the piece that has the longest playing
    time.
    Use reasonable variable names, indentation and good programming style. Documentation and
    comments are not required, but you may add them to explain any assumptions you might want to
    make. You need not check that the input is valid, and you may assume that no two pieces have the
    same duration.
    can anyone help me out! i would be indebt of ur kindness if u can help me out!

    This forum is for Java, not JavaScript. The two have nothing to do with each other.
    And anyway, this is your studying, so you should try to do it, put forth your best effort, and ask specific questions (on the proper fourm).

  • Urgent........need help in report

    hi all,
    i need help in a report.
    the requirement is ,
    i need to create a report that will display the SO number in alv grid with check box.
    from the list, if i select the check box, it should
    •     Perform VA02, go to the item detail (Sales) (RECORDING)
    •     Update the SO line item’s Pricing Date to PGI Date
    HOW TO DO THIS.
    PLEASE HELP ME
    •     Interactive Report
    o     Report will generate a list of SO based on selection parameters
    o     User is able to choose all or partial records from the list of SO
    o     For the selected SO, user is able to perform one of the two functions:
    &#61607;     New Pricing based on Batch ID from Production Order
    &#61607;     New Pricing based on PGI Date
    o     The result of the updating is displayed on the screen
    &#61607;     SO updated with success
    &#61607;     SO not updated due to error

    Hi,
    Check this SD MODULE alv intereactive report.
    Hope it may helps u.
    REPORT  YMS_ALVINTER.
    *& tables declaration
    TABLES: VBRK,VBRP.
    *& type-pools declaration
    TYPE-POOLS: SLIS.
    *& data declaration
    DATA: G_REPID TYPE SY-REPID.
    DATA : IT_FIELDCAT TYPE SLIS_T_FIELDCAT_ALV, "mara
    WA_FIELDCAT TYPE SLIS_FIELDCAT_ALV,
    WA_LAYOUT TYPE SLIS_LAYOUT_ALV,
    WA_EVENT TYPE SLIS_ALV_EVENT,
    T_EVENT TYPE SLIS_T_EVENT.
    DATA: V_VBELN LIKE VBRK-VBELN,
    V_MATNR LIKE VBRP-MATNR.
    DATA: BEGIN OF IT_VBRK OCCURS 0,
    VBELN LIKE VBRK-VBELN,
    WAERK LIKE VBRK-WAERK,
    VKORG LIKE VBRK-VKORG,
    FKDAT LIKE VBRK-FKDAT,
    BUKRS LIKE VBRK-BUKRS,
    NETWR LIKE VBRK-NETWR,
    END OF IT_VBRK.
    DATA: BEGIN OF IT_VBRP OCCURS 0,
    VBELN LIKE VBRP-VBELN,
    POSNR LIKE VBRP-POSNR,
    FKIMG LIKE VBRP-FKIMG,
    VRKME LIKE VBRP-VRKME,
    NETWR LIKE VBRP-NETWR,
    MATNR LIKE VBRP-MATNR,
    ARKTX LIKE VBRP-ARKTX,
    END OF IT_VBRP.
    *& selection screen
    SELECTION-SCREEN BEGIN OF BLOCK B WITH FRAME TITLE TEXT-001.
    SELECT-OPTIONS: S_VBELN FOR VBRK-VBELN,
    S_FKDAT FOR VBRK-FKDAT,
    S_MATNR FOR VBRP-MATNR.
    SELECTION-SCREEN END OF BLOCK B.
    **INITIALIZATION.
    INITIALIZATION.
      G_REPID = SY-REPID.
      S_FKDAT-LOW = SY-DATUM - 200.
      S_FKDAT-HIGH = SY-DATUM.
      APPEND S_FKDAT.
    ***AT SELECTION-SCREEN.
    AT SELECTION-SCREEN.
      IF NOT S_VBELN IS INITIAL.
        SELECT SINGLE VBELN FROM VBRK
        INTO V_VBELN
        WHERE VBELN IN S_VBELN.
        IF SY-SUBRC <> 0.
          MESSAGE E001(ZZ2).
        ENDIF.
      ENDIF.
      IF NOT S_MATNR IS INITIAL.
        SELECT SINGLE MATNR FROM MARA
        INTO V_MATNR
        WHERE MATNR IN S_MATNR.
        IF SY-SUBRC <> 0.
          MESSAGE E001(ZZ2).
        ENDIF.
      ENDIF.
    ***START-OF-SELECTION.
    START-OF-SELECTION.
      PERFORM GET_DATA_VBRK.
    *& Form GET_DATA_VBRK
    text
    --> p1 text
    <-- p2 text
    FORM GET_DATA_VBRK .
      SELECT VBELN
      WAERK
      VKORG
      FKDAT
      BUKRS
      NETWR
      INTO TABLE IT_VBRK
      FROM VBRK
      WHERE VBELN IN S_VBELN
      AND FKDAT IN S_FKDAT.
    ENDFORM. " GET_DATA_VBRK
    *& Form GET_DATA_VBRP
    text
    --> p1 text
    <-- p2 text
    FORM GET_DATA_VBRP .
      SELECT VBELN
      POSNR
      FKIMG
      VRKME
      NETWR
      MATNR
      ARKTX
      FROM VBRP
      INTO TABLE IT_VBRP
      WHERE VBELN = IT_VBRK-VBELN.
    ENDFORM. " GET_DATA_VBRP
    ***END-OF-SELECTION.
    END-OF-SELECTION.
      PERFORM EVENT_LIST.
      PERFORM GET_FIELD_CATALOG.
      PERFORM LIST_DISP .
    *&      Form  list_disp
          text
    FORM LIST_DISP .
      CALL FUNCTION 'REUSE_ALV_GRID_DISPLAY'
      EXPORTING
    I_INTERFACE_CHECK = ' '
    I_BYPASSING_BUFFER = ' '
    I_BUFFER_ACTIVE = ' '
      I_CALLBACK_PROGRAM = G_REPID
    I_CALLBACK_PF_STATUS_SET = 'POPUP'
      I_CALLBACK_USER_COMMAND = 'USER_COMMAND'
    I_CALLBACK_TOP_OF_PAGE = ' '
    I_CALLBACK_HTML_TOP_OF_PAGE = ' '
    I_CALLBACK_HTML_END_OF_LIST = ' '
    I_STRUCTURE_NAME =
    I_BACKGROUND_ID = ' '
    I_GRID_TITLE =
    I_GRID_SETTINGS =
    IS_LAYOUT = WA_LAYOUT
      IT_FIELDCAT = IT_FIELDCAT
    IT_EXCLUDING =
    IT_SPECIAL_GROUPS =
    IT_SORT =
    IT_FILTER =
    IS_SEL_HIDE =
    I_DEFAULT = 'X'
    I_SAVE = ' '
    IS_VARIANT =
    IT_EVENTS =
    IT_EVENT_EXIT =
    IS_PRINT =
    IS_REPREP_ID =
    I_SCREEN_START_COLUMN = 0
    I_SCREEN_START_LINE = 0
    I_SCREEN_END_COLUMN = 0
    I_SCREEN_END_LINE = 0
    IT_ALV_GRAPHICS =
    IT_HYPERLINK =
    IT_ADD_FIELDCAT =
    IT_EXCEPT_QINFO =
    I_HTML_HEIGHT_TOP =
    I_HTML_HEIGHT_END =
    IMPORTING
    E_EXIT_CAUSED_BY_CALLER =
    ES_EXIT_CAUSED_BY_USER =
      TABLES
      T_OUTTAB = IT_VBRK
      EXCEPTIONS
      PROGRAM_ERROR = 1
      OTHERS = 2
      IF SY-SUBRC <> 0.
        MESSAGE ID SY-MSGID TYPE SY-MSGTY NUMBER SY-MSGNO
        WITH SY-MSGV1 SY-MSGV2 SY-MSGV3 SY-MSGV4.
      ENDIF.
    ENDFORM. " LIST_DISP
    *& Form GET_FIELD_CATALOG
    text
    --> p1 text
    <-- p2 text
    FORM GET_FIELD_CATALOG .
      CALL FUNCTION 'REUSE_ALV_FIELDCATALOG_MERGE'
      EXPORTING
      I_PROGRAM_NAME = G_REPID
      I_INTERNAL_TABNAME = 'IT_VBRK'
    I_STRUCTURE_NAME =
    I_CLIENT_NEVER_DISPLAY = 'X'
      I_INCLNAME = G_REPID
    I_BYPASSING_BUFFER =
    I_BUFFER_ACTIVE =
      CHANGING
      CT_FIELDCAT = IT_FIELDCAT
      EXCEPTIONS
      INCONSISTENT_INTERFACE = 1
      PROGRAM_ERROR = 2
      OTHERS = 3
      IF SY-SUBRC <> 0.
        MESSAGE ID SY-MSGID TYPE SY-MSGTY NUMBER SY-MSGNO
        WITH SY-MSGV1 SY-MSGV2 SY-MSGV3 SY-MSGV4.
      ENDIF.
    ENDFORM. " GET_FIELD_CATALOG
    *& Form event_list
    text
    --> p1 text
    <-- p2 text
    FORM EVENT_LIST .
      CLEAR WA_EVENT.
      WA_EVENT-NAME = 'USER_COMMAND'.
      WA_EVENT-FORM = 'USER_COMMAND'.
      APPEND WA_EVENT TO T_EVENT.
      CLEAR WA_EVENT.
    ENDFORM. " event_list
    *&      Form  user_command
          text
         -->R_UCOMM    text
         -->RS_SELFIELDtext
    FORM USER_COMMAND USING R_UCOMM LIKE SY-UCOMM
    RS_SELFIELD TYPE SLIS_SELFIELD.
      CASE R_UCOMM.
        WHEN '&IC1'.
          READ TABLE IT_VBRK INDEX RS_SELFIELD-TABINDEX.
          PERFORM GET_DATA_VBRP.
          PERFORM BUILD_FIELDCATALOG_VBRP .
          PERFORM DISPLAY_ALV_VBRP.
      ENDCASE.
    ENDFORM.                    "user_command
    *& Form BUILD_FIELDCATALOG_VBRP
    text
    --> p1 text
    <-- p2 text
    FORM BUILD_FIELDCATALOG_VBRP .
      CALL FUNCTION 'REUSE_ALV_FIELDCATALOG_MERGE'
      EXPORTING
      I_PROGRAM_NAME = G_REPID
      I_INTERNAL_TABNAME = 'IT_VBRP'
    I_STRUCTURE_NAME =
    I_CLIENT_NEVER_DISPLAY = 'X'
      I_INCLNAME = G_REPID
    I_BYPASSING_BUFFER =
    I_BUFFER_ACTIVE =
      CHANGING
      CT_FIELDCAT = IT_FIELDCAT
      EXCEPTIONS
      INCONSISTENT_INTERFACE = 1
      PROGRAM_ERROR = 2
      OTHERS = 3
      IF SY-SUBRC <> 0.
        MESSAGE ID SY-MSGID TYPE SY-MSGTY NUMBER SY-MSGNO
        WITH SY-MSGV1 SY-MSGV2 SY-MSGV3 SY-MSGV4.
      ENDIF.
    ENDFORM. " BUILD_FIELDCATALOG_VBRP
    *& Form DISPLAY_ALV_VBRP
    text
    --> p1 text
    <-- p2 text
    FORM DISPLAY_ALV_VBRP .
      CALL FUNCTION 'REUSE_ALV_GRID_DISPLAY'
      EXPORTING
    I_INTERFACE_CHECK = ' '
    I_BYPASSING_BUFFER = ' '
    I_BUFFER_ACTIVE = ' '
      I_CALLBACK_PROGRAM = G_REPID
    I_CALLBACK_PF_STATUS_SET = ' '
    I_CALLBACK_USER_COMMAND = ' '
    I_CALLBACK_TOP_OF_PAGE = ' '
    I_CALLBACK_HTML_TOP_OF_PAGE = ' '
    I_CALLBACK_HTML_END_OF_LIST = ' '
    I_STRUCTURE_NAME =
    I_BACKGROUND_ID = ' '
    I_GRID_TITLE =
    I_GRID_SETTINGS =
    IS_LAYOUT =
      IT_FIELDCAT = IT_FIELDCAT
    IT_EXCLUDING =
    IT_SPECIAL_GROUPS =
    IT_SORT =
    IT_FILTER =
    IS_SEL_HIDE =
    I_DEFAULT = 'X'
    I_SAVE = ' '
    IS_VARIANT =
    IT_EVENTS =
    IT_EVENT_EXIT =
    IS_PRINT =
    IS_REPREP_ID =
    I_SCREEN_START_COLUMN = 0
    I_SCREEN_START_LINE = 0
    I_SCREEN_END_COLUMN = 0
    I_SCREEN_END_LINE = 0
    IT_ALV_GRAPHICS =
    IT_HYPERLINK =
    IT_ADD_FIELDCAT =
    IT_EXCEPT_QINFO =
    I_HTML_HEIGHT_TOP =
    I_HTML_HEIGHT_END =
    IMPORTING
    E_EXIT_CAUSED_BY_CALLER =
    ES_EXIT_CAUSED_BY_USER =
      TABLES
      T_OUTTAB = IT_VBRP
      EXCEPTIONS
      PROGRAM_ERROR = 1
      OTHERS = 2
      IF SY-SUBRC <> 0.
        MESSAGE ID SY-MSGID TYPE SY-MSGTY NUMBER SY-MSGNO
        WITH SY-MSGV1 SY-MSGV2 SY-MSGV3 SY-MSGV4.
      ENDIF.
    ENDFORM. " DISPLAY_ALV_VBRP
    Thanks,
    Shankar

  • Need Help in Replacement of Function Modules

    Hello all,
    I am working on Upgrade project from ECC 5.0 to ECC 6.0. I am facing problems for Replacement of two Obsolete Function Modules. Please give me a solution. FM's  are as follows.
    1) SET_AUTHORITY : This FM is obsolete in ECC 6.0 and there is not alternative FM present in help.sap.com or any other web portal.
    2) WS_QUERY : Here as per my knowledge we use class CL_GUI_FRONTEND_SERVICES and methods FILE_EXIST or DIRECTORY_EXIST as per the parameters in old FM. For parameter 'FS' we use 'FILE_EXIST' and 'DS' we use 'DIRECTORY EXIST'.
    But in our program prev. FM has parameter 'OS' i.e. Operating System.
    But there is not method called 'OS EXIST' or similar. Please suggest suitable method.
    Thanking you all in anticipation.
    Best Regards,
    Harish

    Hi Harish,
                       I too could not find any replacement for SET_AUTHORITY
    Obsolete Modules can be used in newer versions, but it is not supported by SAP in case of any technical issues.If you still need a replacement, you can replace it by the source code in the FM SET_AUTHORITY itself and modify according to your needs.
    Below is the source code of FM SET_AUTHORITY, so you can modify it according to your requirement.
      DATA: l_actvt  TYPE tact-actvt,
            l_hier   TYPE STANDARD TABLE OF sethier WITH HEADER LINE.
      CASE action.
        WHEN 'A    '.
          l_actvt = activity-add.
        WHEN 'C    '.
          l_actvt = activity-modify.
        WHEN 'D    '.
          l_actvt = activity-display.
        WHEN 'E    '.
          l_actvt = activity-delete.
        WHEN 'UD   '.
          l_actvt = activity-display.
      ENDCASE.
      CALL FUNCTION 'G_SET_TREE_IMPORT'
           EXPORTING
                no_descriptions  = 'X'
                no_rw_info       = 'X'
                setid            = set
                tabname          = table
                root_header_only = 'X'
           TABLES
                set_hierarchy    = l_hier
           EXCEPTIONS
                OTHERS           = 0.
      READ TABLE l_hier INDEX 1.
      IF sy-subrc <> 0.
        CLEAR l_hier.
        l_hier-shortname = set.
      ENDIF.
      CALL FUNCTION 'G_SET_AUTHORITY_CHECK'
           EXPORTING
                actvt  = l_actvt
                authgr = l_hier-authgr
           EXCEPTIONS
                OTHERS = 1.
      IF sy-subrc <> 0.
        CASE action.
          WHEN 'A    '.
            MESSAGE e827 WITH l_hier-shortname RAISING no_authority.
          WHEN 'C    '.
            MESSAGE e828 WITH l_hier-shortname RAISING no_authority.
          WHEN 'D    '.
            MESSAGE e829 WITH l_hier-shortname RAISING no_authority.
          WHEN 'E    '.
            MESSAGE e830 WITH l_hier-shortname RAISING no_authority.
          WHEN 'UD   '.
            MESSAGE e831 WITH l_hier-shortname RAISING no_authority.
        ENDCASE.
      ENDIF.
    If you need help in replacing in the above source code, please post your code here so that I can help you in modifying accordingly.
    Regards,
    Vasuki

Maybe you are looking for

  • How to configure letter of credit in SAP

    hi all,    how to configure letter of credits (LOC) in sap. regards srinivas

  • Scenario Execution in Sequence

    Hi Guys i have two scenarios 1) JDBC1--> XI --> RFC1 2) JDBC1--> XI --> RFC2 RFC business logic of both uses both creating document based on Movement Type My concern is both RFC1 and RFC2 should not work in same time there should be some time gap for

  • Oracle 10g R2 RAC - IP address Change

    We succsessfully installed Oracle 10gR2 single database on two node RAC on Windows 2003. I followed the Oracle RAC installation documentation and assigned a public IP for the machine and another Virtual Public IP and a Private IP. We have also change

  • MBAir inconsistent display detection

    Greetings, Apple Support, Using a brand new MacBook air with a relatively new - purchased new but slightly old - Vizio 24" monitor. At first it worked fine, and then after leaving with my machine and coming back to use the display again it simply wou

  • We need a test forum

    I could not find a test forum where we can do test postings to get familiar with the new forum tools. This would be useful to have and posts there could be cleared after a few days. Some points that are not clear: - I have not found a way to attach m