Networking Best Practices - Connecting Two Switches

Connecting two switches together is an easy task, which makes it so frustrating when it doesn’t work. Here we will outline a basic scenario of connecting two switches and achieving connectivity. In these scenarios we will be using commands and settings that will work for most modern PowerConnect switches. However this does not cover all possible scenarios and the commands may differ slightly from switch to switch.
For instance, in most cases you can use General or Trunk mode when connecting two switches. However, on the PowerConnect 62xx series switches, you must use General mode if you want to allow management traffic onto the switch over the PVID.  If you use Trunk mode, you will not have the default VLAN on those ports.  The ports will only allow tagged traffic.
For more details on the difference between Access, General, and Trunk modes, follow this link.
http://en.community.dell.com/support-forums/network-switches/f/866/p/19445142/20089157.aspx#20089157
It is always a good idea to have the user and CLI guide for your switch, to reference any possible changes in command syntax.
http://support.dell.com/support/edocs/network/
Layer 2
Layer 2 switches operate at the data link layer of the OSI model. Layer 2 is responsible for error checking and transmitting data across the physical media. MAC addressing sources and destination protocols are layer 2 protocols. Layer 2 switches use the MAC address of data packets to determine where those packets should go. It learns the MAC addresses of all devices and creates a segment/forwarding table.
When a switch receives a frame with a destination address that isn't in its forwarding table, the switch forwards the frame to all other ports. If the destination machine responds to the server, the switch will listen to the reply and learn which port the destination machine is attached to. It then adds that MAC address to the forwarding table.
The Dell PowerConnect Layer 2 switches have ports that all operate in VLAN 1 by default. If it is acceptable to have all traffic on the same broadcast domain, then you can simply leave the default alone, connect the two switches and traffic will flow.
 If you do not want all traffic on the same broadcast domain, then we need to look at adding additional broadcast domains through the use of VLANs.
 We will use 3 VLANs for the following scenario.
VLAN 1=Management
VLAN 2=Client
VLAN 3=Server
To create these VLANs we do the following commands (VLAN 1 is already created by default)
console(config)# vlan database
console(config-vlan)# VLAN 2
console(config-vlan)# VLAN 3
console(config-vlan)# exit
We can then name the VLANs to help keep things organized.
console(config)# interface vlan 2
console(config-vlan)# name Client
console(config-vlan)# exit
console(config)# interface vlan 3
console(config-vlan)# name Server
console(config-vlan)# exit
Once we have the VLANs created we can place a device in that VLAN by placing the port it plugs into, in access mode for the specific VLAN.
So we have a workstation on port e2 we want to be placed in VLAN 2, we would issue the following commands.
console(config)# interface ethernet 1/e2
console(config-if)# switchport mode access
console(config-if)# switchport access vlan 2
console(config-if)# exit
The next port plugs into a server on port e3 we want on VLAN 3, we would issue these commands.
console(config)# interface ethernet 1/e3
console(config-if)# switchport mode access
console(config-if)# switchport access vlan 3
console(config-if)# exit
For the ports connecting the two switches together, we place the ports in trunk mode and specify the native VLAN and allowed VLANs.
For the port e1 that connect the two switches to each other would be configured like this.
console(config)# interface ethernet 1/e1
console(config-if)# switchport mode general
console(config-if)# switchport general allowed vlan add 2,3 tagged
console(config-if)# switchport general pvid 1
console(config-if)# exit
Once these VLANs and port settings are made on both switches. A server connected to switch A on VLAN 3 should be able to communicate with another Server connected to switch B that is also in VLAN 3.  Without the use of a router the devices in VLAN 3 will not be able to communicate with devices that are outside of their broadcast domain (i.e. VLAN 2 devices could not reach VLAN 3 devices)
Layer 3 + Layer 2
 Until recently, routers were the only devices capable of layer 3 protocols. Switches capable of routing are now available and in widespread use. In most cases we will connect our layer 2 switches to a Layer 3 capable switch to perform our routing for us.
 On the layer 3 switches we will use the same VLANs and setup that we did with the layer 2 switches.  Then we will add to the configuration.
 We can assign an IP address to each switch with the following command.
Switch A
console(config)#ip address 172.16.1.1 255.255.255.0
Switch B
console(config)#ip address 172.16.2.1 255.255.255.0
Then we will enable routing only on Switch A
console(config)# ip routing
Switch A we assign an IP address to VLAN 2 and enabling routing on the VLAN.
console(config)# interface vlan 2
console(config-if-vlan2)# Routing
console(config-if-vlan2)# ip address 172.16.20.1 255.255.255.0
console(config-if-vlan2)# exit
Switch A we assign an IP address to VLAN 3 and enabling routing on the VLAN.
console(config)# interface vlan 3
console(config-if-vlan2)# Routing
console(config-if-vlan2)# ip address 172.16.30.1 255.255.255.0
console(config-if-vlan2)# exit
On both switch A and switch B we will keep things simple and use interface 1/e1 for the connection between each switch. Setting both switches 1/e1 to general mode, allowing the additional VLAN 2,3, and keeping the PVID of 1.
console(config)# interface ethernet 1/e1
console(config-if)# switchport mode general
console(config-if)# switchport general allowed vlan add 2,3 tagged
console(config-if)# switchport general pvid 1
console(config-if)# exit
We will have one client computer connect to switch A on port 1/e2 and one client connect to switch B on port 1/e2. These ports will be in access mode for VLAN 2, and the config should look like this on both switches.
console(config)# interface ethernet 1/e2
console(config-if)# switchport mode access
console(config-if)# switchport access vlan 2
console(config-if)# exit
We will have another client computer connect to switch A on port 1/e3 and one client connect to switch B on port 1/e3. These ports will be in access mode for VLAN 3, and the config should look like this on both switches.
console(config)# interface ethernet 1/e3
console(config-if)# switchport mode access
console(config-if)# switchport access vlan 3
console(config-if)# exit
On Clients connected to Switch A we will assign an IP address and gateway based on the VLAN they are in access mode for.
Client connected to access port for VLAN 2.
IP Address:172.16.20.11
Default Gateway:172.16.20.1
Client connected to access port for VLAN 3.
IP Address:172.16.30.11
Default Gateway:172.16.30.1
On Clients connected to Switch B we will assign an IP address and gateway based on the VLAN they are in access mode for.
Client connected to access port for VLAN 2.
IP Address:172.16.20.12
Default Gateway:172.16.20.1
Client connected to access port for VLAN 3.
IP Address:172.16.30.12
Default Gateway:172.16.30.1
External Connection
At some point we may want traffic to have an external connection. To do this we can create a new VLAN for our point to point connection from Switch A to our router. We will use VLAN 7 for this and assign an IP address.
console(config)# vlan database
console(config-vlan)# VLAN 7
console(config-vlan)# exit
console(config)# interface vlan 7
console(config-vlan)# name WAN
console(config-if-vlan2)# Routing
console(config-if-vlan2)# ip address 10.10.10.2 255.255.255.0
console(config-if-vlan2)# exit
On our router we will assign an IP address of 10.10.10.1
Then place the port connecting the switch and router into access mode for VLAN 7.  In this case we use port e4.
 console(config)# interface ethernet 1/e4
console(config-if)# switchport mode access
console(config-if)# switchport access vlan 7
console(config-if)# exit
We will then need to put in a default route with the next hop as the router IP address.  This allows the switch to know where to route traffic not destined for VLANs 2, 3, or 7.
console(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.1
Next on the router we’ll need to add a route back so the router knows about the networks attached to switch A.  Generally adding a static route on most routers is done with the following command: 
ip route {Network} {Wildcard Mask} {Next Hop-IP}
In our case here are the 2 static routes we could use.
Ip route 172.16.20.0 0.0.0.255 10.10.10.2
Ip route 172.16.30.0 0.0.0.255 10.10.10.2
The routing that we enabled on Switch A will enable traffic from the other VLANs to traverse over port 1/e4 to the router, connecting us to external traffic. The routes we added to the router allow the traffic to flow back to the switch over port 1/e4.
Layer 3 + Layer 3
In some situations we have two switches, each setup to route for its own broadcast domain, which we want to connect together. In this situation we no longer have a need to use Trunk or General mode between the switches. Instead we can create a common VLAN that will be used for the connection between the two switches.
To create this VLAN we will run the following commands on both switch A and B
console(config)# vlan database
console(config-vlan)# vlan 6
console(config-vlan)# exit
console(config)# interface vlan 6
console(config-vlan)# name Connection
console(config-vlan)# exit
On switch A we assign an IP address to VLAN 6 and enable routing on the VLAN.
console(config)# interface vlan 6
console(config-if-vlan2)# Routing
console(config-if-vlan2)# ip address 172.16.60.1 255.255.255.0
console(config-if-vlan2)# exit
On switch B we assign an IP address to VLAN 6 and enable routing on the VLAN.
console(config)# interface vlan 6
console(config-if-vlan2)# Routing
console(config-if-vlan2)# ip address 172.16.60.2 255.255.255.0
console(config-if-vlan2)# exit
On both switch A and B we place the connecting ports into Access mode for VLAN 6.
console(config)# interface ethernet 1/e1
console(config-if)# switchport mode access
console(config-if)# switchport access vlan 6
console(config-if)# exit
We then need to make some changes to switch B now that it is layer 3 and not layer 2 and has its own broadcast domain.
We will enable routing on Switch B
console(config)# ip routing
What used to be VLAN 2 and 3 will now be VLAN 4 and 5 for our separate broadcast domains.
Switch B we assign an IP address to VLAN 4 and enabling routing on the VLAN.
console(config)# interface vlan 4
console(config-if-vlan2)# Routing
console(config-if-vlan2)# ip address 172.16.40.1 255.255.255.0
console(config-if-vlan2)# exit
Switch B we assign an IP address to VLAN 5 and enabling routing on the VLAN.
console(config)# interface vlan 5
console(config-if-vlan2)# Routing
console(config-if-vlan2)# ip address 172.16.50.1 255.255.255.0
console(config-if-vlan2)# exit
On Clients connected to Switch B we will assign an IP address and gateway based on the VLAN they are in access mode for.
Client connected to access port for VLAN 4.
IP Address:172.16.40.11
Default Gateway:172.16.40.1
Client connected to access port for VLAN 5.
IP Address:172.16.50.11
Default Gateway:172.16.50.1
The end result should look like this.
 Troubleshooting
If we are having issues with connectivity, we may need to place some static routes in place to help traffic to the next hop in the network.
On switch A we configure a static route to help traffic to the next hop in the network, which is the router.
console(config)# ip route 0.0.0.0 0.0.0.0 10.10.10.1
The external router will also need a path defined back to all networks/VLANs.
To check the status of a port we can use the command. Show interfaces detail, this will help us see the port status. For example to check the status of port 48, we would run this command.
console# show interfaces detail ethernet 1/g48
 To check routing paths:
console# show ip route
The IP address of the network for each VLAN should be listed as C – Connected. Then also a path or default route to your upstream router.
We can use basic ping commands from a client to help test where connectivity is dropping off at. By doing this we can narrow down where in the network to start troubleshooting.
-Ping from client to default gateway, being the VLAN the client is in access mode for. If this fails then we may need to double check our client settings making sure the proper IP and gateway are being used.
-Ping from client to the ip address of the switch the client plugs into. If this fails we may not have VLAN routing enabled on the VLAN the client is in.
-Ping from client to another client on same VLAN, same switch. If this fails we need to check on client settings, IP address and gateway.
-ping from client to another client on different VLAN, same switch. If this fails we need to double check the VLAN routing commands are in place.
-ping from client to the ip address of the next switch in the network. If this fails then check Trunk port configuration from switch to switch, ensuring the VLAN is added to the Trunk port.
-ping from client to another client on same VLAN, different switch. If this fails, check Trunk port settings.
-ping from client to another client on different VLAN, different switch. If this fails then check trunk settings and VLAN routing configuration.

Derek,
I tried to draw my prefered setup for this network configuration.
I would create a Team with the two 1 GBit NICs and use it for Domain, DNS, Backup and any SystemCenter Agents.
I would also Team the two 10 GBit NICs and than assign it to a Hyper-V Switch for the VMs. In Windows Server 2012 it is posible to create vNICs for the Management OS that use this Hyper-V Switch (Converged Network Design). I would create two vNICs SMB1
and SMB2 to use them for Cluster and Livemigration traffic with SMB Multichannel. If your storage system supports SMB Multichannel you can also use both as storage NICs (but this depends wich vendor you have).
Hope this helps.
Grüße/Regards Carsten Rachfahl | MVP Virtual Machine | MCT | MCITP | MCSA | CCA | Husband and Papa |
www.hyper-v-server.de | First German Gold Virtualisation Kompetenz Partner ---- If my answer is helpful please mark it as answer or press the green arrow.

Similar Messages

  • 10Gb Networking best practices

    I'm looking for good guidance on Hyper-V 2012 R2 network configuration best practices for a converged server. Meaning, dual 10Gb NICs and using SMB 3.0 file shares for storage. The servers also have two 1Gb NICs. I'm very familiar with VMware, but ramping
    up on HV networking best practices.
    Blog: www.derekseaman.com, VMware vExpert 2012/2013

    Derek,
    I tried to draw my prefered setup for this network configuration.
    I would create a Team with the two 1 GBit NICs and use it for Domain, DNS, Backup and any SystemCenter Agents.
    I would also Team the two 10 GBit NICs and than assign it to a Hyper-V Switch for the VMs. In Windows Server 2012 it is posible to create vNICs for the Management OS that use this Hyper-V Switch (Converged Network Design). I would create two vNICs SMB1
    and SMB2 to use them for Cluster and Livemigration traffic with SMB Multichannel. If your storage system supports SMB Multichannel you can also use both as storage NICs (but this depends wich vendor you have).
    Hope this helps.
    Grüße/Regards Carsten Rachfahl | MVP Virtual Machine | MCT | MCITP | MCSA | CCA | Husband and Papa |
    www.hyper-v-server.de | First German Gold Virtualisation Kompetenz Partner ---- If my answer is helpful please mark it as answer or press the green arrow.

  • Networking "best practice" for setting up a farm

    Hi all.
    We would like to set an OracleVM farm, and I have a question about "best practice" for
    configuring the network. Some background:
    - The hardware I have is comprised of machines with 4 gig-eth NICs each.
    - The storage will be coming primarily from a backend NAS appliance (Netapp, FWIW).
    - We have already allocated a separate VLAN for management.
    - We would like to have HA capable VMs using OCFS2 (on top of NFS.)
    I'm trying to decide between 2 possible configurations. The first would keep physical separation
    between the mgt/storage networks and the DomU networks. The second would just trunk
    everything together across all 4 NICs, something like:
    Config 1:
    - eth0 - management/cluster-interconnect
    - eth1 - storage
    - eth2/eth3 => bond0 - 8021q trunked, bonded interfaces for DomUs
    Config 2:
    - eth0/1/2/3 => bond0
    Do people have experience or recommendation about the best configuration?
    I'm attracted to the first option (perhaps naively) because CI/storage would benefit
    from dedicated bandwidth and this configuration might also be more secure.
    Regards,
    Robert.

    user1070509 wrote:
    Option #4 (802.3ad) looks promising, but I don't know if this can be made to work across
    separate switches.It can, if your switches support cross-switch trunking. Essentially, 802.3ad (also known as LACP or EtherChannel on Cisco devices) requires your switch to be properly configured to allow trunking across the interfaces used for the bond. I know that the high-end Cisco and Juniper switches do support LACP across multiple switches. In the Cisco world, this is called MEC (Multichassis EtherChannel).
    If you're using low-end commodity-grade gear, you'll probably need to use active/passive bonds if you want to span switches. Alternatively, you could use one of the balance algorithms for some bandwitch increase. You'd have to run your own testing to determine which algorithm is best suited for your workload.
    The Linux Foundation's Net:Bonding article has some great information on bonding in general, particularly on the various bonding methods for high availability:
    http://www.linuxfoundation.org/en/Net:Bonding

  • Best Practices for multi-switch MDS 9124 Impelementations

    Hi,
    I was wondering if anyone had any links to best-practices guides, or any experience, building mutli-swtich fabrics with the Cisco MDS 9124 or similar (small) switches? I've read most of the FibreChannel books out there and they all seem pretty heavy on theory and FibreChannel protocol operations but lack when it comes to real-world deployment scenarios. Something akin to the Case Studies sections a lot of the CCIE literature has, but anything would be appreciated.
    Regards,
    Meredith Shaebanyan

    Hi Meridith
    www.Whitepapers.zdnet.com has links to good reading. It has links to items like:
    http://www.vmware.com/pdf/esx_san_cfg_technote.pdf is probably a typical SAN environment these days. It's basic and just put your 9124's in where the switches are.
    http://www.sun.com/bigadmin/features/hub_articles/san_fundamentals.pdf is for bigger SANs such as DR, etc.
    Things to consider with 9124's are:
    They can break so keep a good current backup on a tftp/ftp/scp server.
    Consider that if you have all the ports used, the two 8 port licences are not going to work on a replacement switch as they are bound to your hostid. The vendor that sold the switch should be able to get replacements quickly but you will lose time with them.
    Know exactly what the snmpserver command does as if you have your 9124 replaced and you load your backup config and you use Fabric Manager, it won't be able to manage the 9124 unless you change the admin password with snmpserver.
    9124/9134's don't have enough Buffer Credits to expand beyond about 10 km.
    Any ISL's used between switches should always be at least two and use Port Channels where possible.
    The 9124 or 9124e or 9134 are great value based switches. I keep a spare for training and emergencies. We use them in a core/edge solution and I am very satisfied with them. I have only had one failure with Cisco switches in the last 5 years and it was a 9140 that sat around for far too long doing nothing. The spare meant we were up and running in 30 minutes from the time we noticed the failure and got to the data centre. As there were two paths, no one actually noticed anything. My management system alerted me.
    Remember to make absolutely sure that any servers attached to the SAN have multipathing software. The storage array vendors (HDS, EMC, etc) can sell you the software such as HDLM or Powerpath. You can use an independent solution such as Veritas DMP. Just don't forget to use it.
    Follow the guidelines in the two documents and get some training as the MDS training is very good indeed. 5 days training and you will be confident about what to do in any sized SAN including Brocade and McData.
    A small SAN is just as satisfying as a large one. If in doubt, get a consultant to tell you what to do.
    Is that what you was after? I hope it was not too simple.
    Stephen

  • Can I connect two switches to a server?

    We share an office with another company but we currently have separate servers and networks.
    I'm looking into the possibility of us sharing their server.
    The thing is we both have our own switches and and I want to avoid any rewiring of the network. Will I be able to use two switches?
    It's a 2x 2.8 GHz quad core intel xeon (with dual ethernet). So is it just a matter of connecting both switches to the server and configuring them in some way?

    Hi Christiaan,
    I end up doing this quite often. You have a few options, the simplest is below...
    How many users and devices that require network connections does each company have? If it's under 254 which it sounds like it is and your happy to have the users on the same network, sharing the same ISP. Then the easiest option is going to be your company sharing their network. You'd save a bit of money on your internet connection which could be used to increase the bandwidth on the other companies line if needed.
    You would do following. Make sure all devices that need a fixed IP address such as printers/mfds'/switches/WiFI/phone system (if applicable) are changed to a fixed IP address with the relevant subnet mask, dns and gateway from the other companies network. You'd obviously need to get the relevant numbers from their IT guy.
    Then you could use your switch as extra capacity on their network by linking it with their switch. Obviously you'd want to use the fastest possible connection between the switches or look to buying something new with more ports. If you both have something like the HP 1810G ProCurve or a compatible switch you can buy two fibre transceivers and connect them with a fibre cable, this will free up more ports for users on the switch or simply connect them via an ethernet cable. On the 1800 series you can use LACP which allows you to use up to 4 ethernet ports to improve the bandwidth thus giving you a 4gigabit connection to their network. Depending on how much traffic there is going to be you might want to skip that as there might be no need.
    Then it's just a case of creating your users on their server and creating an area for your company that only you have the access rights to and creating a shared area inter-company area if you want to easily ping them over files.
    What do you both use for email? Are you going to look to share a server for it?
    Hope that helps
    Beatle

  • Cisco 2950 MT-RJ ports - Connect two switches?

    Hi Everyone,
    I'm wondering if I can connect two cisco 2950s together via the two MT-RJ ports they have?
    Basically, I'd like the fibre ports to be the trunk between the two switches if possible
    I have two of these: 
    Thanks!

    Hi,
    Yes, that is possible. As long as your fiber patch cable is good there should be no issues.
    HTH

  • UI Design - Best Practice when Two UIs Trigger Same Event

    I have an application that allows users to take actions using several methods - right-click context menu selection, menu bar selected, key strokes, etc. I was wondering if anyone had any suggestions as to teh best practices for handling this in Cairngorm...
    Is it best to dispatch the same Cairngorm event in several places? I know this is one of the major reasons to use MVC, but, I hate to create duplicate code - maintenance is pain.
    Would is be considered good practice to have the container that serves as a parent for the context menu, menu bar, etc. to listen for events from these components, and then dispatch the Cairngorm Event?
    Thanks.

    Would it be considered good practice to have the container that serves as a parent for the context menu, menu bar, etc. to listen for events from these components, and then dispatch the Cairngorm Event?
    Yes, this is described by Steven Webster in his series of articles on Cairngorm.
    Dispatching the same Cairngorm event from different locations is a perfectly regular practice. This is even an advantage. The same code (the command, the delegate) can be triggered from different places.

  • Best practice for two differing encryption types

    I'm using a Aironet 1232g and I want to use WPA2-PSK. I have the XP clients connected appropriately (via WPA2-AES CCMP), however I also have a Ricoh Digital Sender (copier) that only supports WEP. What is the best security practice in this scenario? Can I enable two SSID's one with WPA2-PSK and the other with WEP? If so, do I need to establish a VLAN on the AP? Any help is appreciated.

    Hi Scott,
    your thougts are right.
    You have to establish 2 seperate VLANs on the AP. In the "encryption Manager" you setup the VLAN to encryption type association.
    Then you need to define the VLANs to SSIDs in the "SSID Manager".
    If you have a WDS running setup the "Server groups" in the WDS Section of "Wireless Services"
    Do not forget to change the switchport (where the AP is connected to) to trunking mode.
    I hope that helps.
    Best regards,
    Frank
    P.S. Please rate helpful posts.

  • Best practice for unmanaged switch to cisco switch

     In our environment, I have to allow some users to have a unmanaged switch which is connected to access port. 
     I put this configuration for each port which is connected to unmanaged switch (Netgear 8 port)
     interface GigabitEthernet1/0/47
     switchport port-security maximum 3
     spanning-tree guard root
    end
     port-security maximum 3: only allow 3 mac
     spanning-tree guard root: just in case to protect root bridge if someone put managed switch with lower bridge ID. 
     I connected one cable from unmanaged switch to another port to make a loop for test. 
     It showed that switch got "Loop-back detected" and put err-disable port automatically. So I don' t need to worry about this.
    Apr  7 18:33:01.370: %ETHCNTR-3-LOOP_BACK_DETECTED: Loop-back detected on GigabitEthernet1/0/47.
    Apr  7 18:33:01.370: %PM-4-ERR_DISABLE: loopback error detected on Gi1/0/47, putting Gi1/0/47 in err-disable state
    Apr  7 18:33:02.373: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/47, changed state to down
    Apr  7 18:33:03.379: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/47, changed state to down
    LAB_HQ_Fiber(config-if)#
     What are the option do you use usually to protect from unmanaged switch? 
     I am not able to use "spanning-tree bpduguard" because it will block a port 
     I can use "spanning-tree bpdufilter" to protect a STP area, but I don't think this is a big matter. 

    Hello
    If you need to attached these kind of switches/hubs - Make sure you shutdown all unused ports on the managed switch so to limit any further unauthorized attachments looping back into the network from the unmanageable device, This way you can managed these unmanageable devices to a certain extent.
    As for the stp root, you should manually set your stp priority on the managed switch to a low level anyway so as to not allow any other new device negotiate its self to become the root, and for the ports you are aware of that will have these devices attached, i would disable portfast and also advise against using bpdufilter as this negates the stp process.
    Int range fa0/x -xxx
    description unmanaged devices
    no cdp enable
    On all managed switches and on all ports you DONT expect to have unmanaged hubs/switches I would suggest to apply
    spanning-tree loopguard default
    udld enable
    udld aggressive
    int range fa0/x -xxx
    description access ports
    switchport port-security
    switchport port-security aging type inactivity
    switchport port-security violation restrict/shutdown
    switchport port-security maximum 2
    spanning-tree portfast
    spanning-tree bpduguard enable
    spanning-tree guard root
    no cdp enable
    One last thing I also wouldn't enable error recover either, as you would want to know the reason why your ports are erroring and not go chasing your tail as the reason why your having intermittent network issues.
    res
    Paul

  • Home Networking Best Practice for Performance

    Hi there first time poster.  I have 3 wireless routers at home (Linksys WRT54G's) .  I have WEP password setup for security and everything works great.  My only question is, is there anything I can look for in the settings that may boost intranet and internet.  Just trying to make sure I have the settings set to get the best performance.  2 of the routers have a linksys firmware on it the other has something called talisman.  These were given to me.
    I know that one thing I can do is change the antennae on them to boost the wireless signal but I'm not sure if that improves the performance.  I assume that would come from settings.  Thanks in advance.

    So you need to improve the wireless signal on your computers. Here are some settings which you do it on your router, i think this might improve the wireless signal strength on your computers.
    Open an Internet Explorer browser page on your wired computer(desktop).In the address bar type - 192.168.1.1
    Leave username blank & in password use admin in lower case...
    For Wireless Settings, please do the following : -
    Click on the Wireless tab
    -Here select manual configuration...Wireless Network mode should be mixed...
    -Provide a unique name in the Wireless Network Name (SSID) box in order to differentiate your network from your neighbours network...
    - Set the Wireless channel to 11-2.462GHz...Wireless SSID broadcast should be Enabled and then click on Save Settings...
    Please make a note of Wireless Network Name (SSID) as this is the Network Identifier...
    For Wireless Security : -
    Click on the Sub tab under Wireless > Wireless Security...
    Change the Wireless security mode to WEP, Encryption should be 64 bits.Leave the passphrase blank, don't type in anything...
    Under WEP Key 1 type in any 10 numbers please(numbers only and no letters eg: your 10 digit phone number) and click on save settings...
    Please make a note of WEP Key 1 as this is the Security Key for the Wireless Network...
    Click on Advanced Wireless Settings
    Change the Beacon Interval to 75 >>Change the Fragmentation Threshold to 2304, Change the RTS Threshold to 2304 >>Click on "Save Settings"...
    Now see if you can locate your Wireless Network and attempt to connect... And check the signal strength on your computers.

  • WLC5508 connected two switches

    Dear All,
    I have a WLC 5508 and a brief connected like below.
    Internet->Router->2960G A-> (Port0)  WLC5508 (Port1) -> 2960G B-> Access Points <-> wireless clients
    My Question : Is the above topology work? The access points register to the controller via 2960B, and the data traffic ffrom wireless clients go through from 2960G B to WLC port 1, and WLC pass it to port 0 itself and then go to internet?
    Thanks.
    Mic

    As long as you don't have LAG enabled that will work. You do need to specify a dynamic interface in which the Internet traffic will egress. Your management will be primary port 1 and the your dynamic interface will be primary port 2. Of course port 1 and port 2 would have to be on a different subnet.
    If you have both on the same subnet, that will not work. You would trunk the ports and only allow the vlans for that port. Port 1 connected to the switch would only allow the vlan for the management. Port 2 connected on the switch will only allow the vlan for that dynamic interface.
    Sent from Cisco Technical Support iPhone App

  • Best Practice connecting VmWare ESX with a Channel

    Hello
    which methode (fix,pagp or lacp) should I use with an ESX server and what other interesting point should I care about it?
    The customer would like to connect the ESX Server to a WS-4006 Chassis with WS-X4013 supervisor.
    many thanks for any input
    Oliver

    Few server MFG's support PAGP, so you'll probably end up using LACP, which is fine (that's what we use). It's a straight forward setup.
    interface Port-channel11
    description ESX_Server 2
    switchport
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 402,403,541-544
    switchport mode trunk
    switchport nonegotiate
    no ip address
    end
    HTH and please rate.

  • Best Practice for Networking in UCS required

    Hi
    We are planning to deploy UCS n our environment. The Fabric Interconnects A and B will need to connect to pair of Catalyst 4900 M switch. Whats is the best practice to connect? How should the 4900 switch be configured? Can I do port channel in UCS?
    Appreciate your help.
    Regards
    Kumar

    I highly recommend you review Brad Hedlund's videos regarding UCS networking here:
    http://bradhedlund.com/2010/06/22/cisco-ucs-networking-best-practices/
    You may want to focus on Part 10 in particular, as this talks about running UCS in end-host mode without vPC or VSS.
    Regards,
    Matt

  • Network Services Best Practices

    Hello
    I've been using the Network Services Best Practices document  (27 Sep 2006) for some years now and I wonder if there has been actually an update to it. If not would you guys have any new Network Best Practices document you would suggest? Something that talks about Virutalization, etc.... would be great

    Hi Scott,
    Thank you for posting your issue in the forum.
    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.
    Thank you for your understanding and support.
    Best Regards,
    Justin Gu

  • Enable port security between Two switches

    Hi Everyone,
    I connected two switches together  via below config
    Switch A
    int gi0/1
    switch mode access
    switchport access vlan 10
    Switch B
    int gi0/1
    switch mode access
    switchport access vlan 10
    They work fine with above config.
    I did the Test below
    However when i changed Config of Switch B  as below
    int gi0/1
    switch mode access
    switchport access vlan 10
    switchport port-security  
    Switch B is unable to ping its default gateway.
    Also Switch B is not reachable via SSH.
    Port is up up and in STP forwarding state.
    Switch B can see Switch A as a neighbour.
    Also Switch B is not reachable via SSH.
    I know that switchport port-security we use only when connecting to PC.
    S does this mean that  on above scenario layer 1 and layer 2 are up but layers beyond 3 and above are not reachable like ping,ssh etc??
    Regards
    MAhesh

    I was just trying to see how the switches behave with this config.Nothing much just  exploring the options in the network world
    Ideally if you want to connect two switches together in Layer 2, Dot1Q trunking is the way to go.  You do not want to put port security because it is useless. 

Maybe you are looking for