Null entry in "sh ip route"

Hi All,
why am I getting the below, a null entry for 192.168.169.0.?
Roger#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
192.168.169.0/24 is variably subnetted, 2 subnets, 2 masks
D 192.168.169.0/24 is a summary, 00:03:25, Null0
C 192.168.169.0/30 is directly connected, FastEthernet0/0
Here is sh run
Roger#sh run
Building configuration...
Current configuration:
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname Roger
enable secret xxxx
enable password regor
ip subnet-zero
ip host tom 192.168.169.1
process-max-time 200
interface FastEthernet0/0
ip address 192.168.169.2 255.255.255.252
no ip directed-broadcast
speed 100
full-duplex
interface FastEthernet0/0.110
no ip directed-broadcast
interface FastEthernet0/1
ip address 192.168.168.1 255.255.255.0
no ip directed-broadcast
router eigrp 1
network 192.168.168.0
network 192.168.169.0
ip classless
no ip http server
line con 0
transport input none
line aux 0
line vty 0 4
password 1234
login
no scheduler allocate
end
Roger#
This is just a study device at home. 2 2600s connected via crossover and a switch on either router(1900 and 2900).
Cheers.
coolboarderguy...

Hi All,
the 2nd router, Tom, is showing similar.
Tom#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.167.0/24 is directly connected, FastEthernet0/1
192.168.169.0/24 is variably subnetted, 2 subnets, 2 masks
D 192.168.169.0/24 is a summary, 00:00:10, Null0
C 192.168.169.0/30 is directly connected, FastEthernet0/0
Tom#
and the sh run
Tom#sh run
Building configuration...
Current configuration:
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname Tom
enable secret 5 $1$pwJW$eRCDshGxVapccQPG8oG2U/
ip subnet-zero
ip host roger 192.168.169.2
process-max-time 200
interface FastEthernet0/0
ip address 192.168.169.1 255.255.255.252
no ip directed-broadcast
speed 100
full-duplex
interface FastEthernet0/1
ip address 192.168.167.1 255.255.255.0
no ip directed-broadcast
router eigrp 1
network 192.168.167.0
network 192.168.169.0
ip classless
no ip http server
line con 0
transport input none
line aux 0
line vty 0 4
password 1234
login
end
Tom#
Cheers.
coolboarderguy...

Similar Messages

  • How to delete the NULL entries in nest table

    Hi,
    After I used a loop and open/fetch cursor populated the object table
    I found there are random NULL entries in my object table (nest table)
    The data look like this
    NULL NULL           NULL
    NULL NULL           NULL
    123     03-MAY-04     ACTIVE
    NULL NULL           NULL
    NULL NULL           NULL
    234     21-MAY-04     ACTIVE
    NULL NULL           NULL
    345     11-MAY-04     ACTIVE
    NULL NULL           NULL
    How can I get rid of those NULL entries in my nest table? So it can become
    123     03-MAY-04     ACTIVE
    234     21-MAY-04     ACTIVE
    345     11-MAY-04     ACTIVE
    Additional info:
    create type myType as object
    (id NUMBER (10,0),
    eff_date date,
    status VARCHAR2(17)
    create type myNestTab as table of myType;
    I have tried Delete procedure in following two ways.
    Version 1:
    FOR i IN l_my_nest_tab.FIRST..l_my_nest_tab.LAST
    LOOP
    IF l_my_nest_tab(i).id IS NULL THEN
    l_curr_event_tb.DELETE(i);
                   END IF;                         
    END LOOP;
    Version 2:
    FOR i IN l_my_nest_tab.FIRST..l_my_nest_tab.LAST
    LOOP
    IF l_my_nest_tab(i) IS NULL THEN
    l_curr_event_tb.DELETE(i);
                   END IF;                         
    END LOOP;
    Both of them give me the error “no data found.” And only left me the first NOT NULL entry in the table.
    123     03-MAY-04     ACTIVE
    Thanks in avdance.

    Hi Vishnu,
    u can write a report program for this and in that use the event  :
    AT NEW <field-name> ( use primary key)
    your statements
    ENDAT
    for eg.
    loop at itab ( herfe itab must be of type of table for which u want to track new entries)
    at new matnr
    write:/ new record
    endat
    endloop.
    schedule this report in background to run in every 5 or 10 mins as per your requirement and hence changes can be tracked.
    regards
    Vinod

  • Adding a *Not* Null Entry to a Data-Bound Drop Down List

    How do I add a not null entry to a data-bound drop down list? I am supposed to have something like this:
    <html:select property="Korisnik1" >
    <html:option value="0000">
         (Not null value)
    </html:option>
    <html:option value="-1">
    (Null value)
    </html:option>
    <html:optionsCollection label="prompt" value="index" property="Korisnik1.displayData" />
    </html:select >
    In case the value 0000 is marked the value should be inserted in to the database. The code above displays the value but insert doesn't work.

    I think that in this case that article is not what's required Shay as the question related to a "No Null" entry. The answer would be to add it into the list that is used to populate the list in the first place - generally by adding a "union select from dual" to the query that generates the list values.

  • No entries in my Host Routing table

    I got the phone from Cincinnati Bell in USA and registered the phone with Etisalat Nigeria, it worked for about 7 months and stopped working and when i checked the Host routing Table i found no entries. My PIN:29BA62F7 and my IMEI No:358807040132108. Please help.

    On the handset, go to:
    For OS5 and 4.x
    Options - Advanced Options - Host Routing Table
    and click Register now, and escape back to the home page.
    For OS6 and higher
    in options, device , advanced, host routing table, click on menu and choose register now.
    Wait 2 minutes and see if registration to network happens.
    Resend your service books from your carrier BIS site:
    From your handheld device: http://www.blackberry.com/btsc/KB15402
    Go to the Personal Email Set Up icon and log in. Then under Help!, select Service Books, then select Send service Books.
    From your desktop PC: http://www.blackberry.com/btsc/KB02830
    North American Carriers - scroll down to select your carrier
    WorldWide Carriers - Find your carrier on the list
    3. With the BlackBerry device powered ON, remove the battery a few seconds and then reinsert the battery to reboot. This reboot, even if you have already done this, is often needed to install the service books.
    Click here to Backup the data on your BlackBerry Device! It's important, and FREE!
    Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
    Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals
    BESAdmin's, please make a signature with your BES environment info.
    SIM Free BlackBerry Unlocking FAQ
    Follow me on Twitter @knottyrope
    Want to thank me? Buy my KnottyRope App here
    BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V

  • Null entry (from portal webdynpro)  is not getting updated in R/3?

    Hi Gurus,
    I have a webdynpro application which has user input field where in which user can pass the data and it will get updated once user hit the update button in the view.
    But in some case if user don't enter any value in the above said input box it has to update the r/3 with the blank entry.
    But in my case r/3 system refers the value (which is passed from portal last time) instead of blank entry?
    How to overcome this problem.
    More detailed way:
    If user don't enter any value in the input box then R/3 record has to be updated with the blank entry
    else
    whatever the data user enters in the particular input it has to be updated the r/3 with that value.
    Right now If i pass some value in the input box it properly getting updated in r/3 but next time if I pass the blank entry in the input box it has to update the r/3 with this blank entry (as per the requirement)
    But its not happening like that it referring previously entered data.
    Please help me
    Thanks in Advance
    Dharani

    Hi,
    Suppose you are using a function Module X  which takes input "empno"  ..., and exports name, city , rcode
    Go to se37 ,  check the code ....it can be like this ...
    if empno = .... then
    update .......
    // updated
    else
    // not updated ........
    end if .
    if updated ... u will observer 0 else some other number say 4.
    Now when u  do modelling in your webdynpro application , u can find export parameters know..
    now u can check ...if rcoe = 0 ..updated else ...not updated ...
    by that u can know...
    Thanks,
    Srini

  • Do not accept Null entry in a Query

    I have this query that searches for an string within the description field and would like not to accept an empty entry, is there some code I can put to do this?
    Here is the query;
    SELECT T0.Comments,T0.DocNum, T0.DocDate, T1.ItemCode, T1.Dscription, T1.Quantity, T1.StockPrice FROM OPDN T0  INNER JOIN PDN1 T1 ON T0.DocEntry = T1.DocEntry WHERE (T1.Dscription Like '%[%0] %'  OR T1.Dscription LIKE '[%0]%' OR T1.Dscription LIKE '%[%0]')

    Morning M...
    You could try adding another condition at the end of your query like (outside of the conditions in the parenthesis)...
    T1.Dscription <> ' '
    or maybe T1.Dscription > ' '
    Hope that works...
    Zal

  • JDBC MS Access--- cannot extract entry with null value with data type Meta

    I'm trying to extract a data entry with null value by using JDBC. The database is MS Access.
    The question is how to extract null entry with data type memo? The following code works when the label has data type Text, but it throws sqlException when the data type is memo.
    Any advice will be appreciated! thanks!
    Following are the table description and JDBC code:
    test table has the following attributes:
    Field name Data Type
    name Text
    label Memo
    table contents:
    name label
    me null
    you gates
    Code:
    String query = "SELECT name, label FROM test where name like 'me' ";
    ResultSet rs = stmt.executeQuery(query);
    while (rs.next())
    String name = rs.getString("name");
    rs.getString("val");
    String label = rs.getString("label");
    System.out.println("\t"+name+"\t"+label);
    catch (SQLException ex)
    System.out.println(ex.getSQLState());
    System.out.println(ex.getErrorCode());
    System.out.println("in sqlexception");
    output:
    C:\Temp\SEFormExtractor>java DBTest
    yet SELECT name, label FROM test
    null
    0
    in sqlexception

    The question is how to extract null entry with data type memo?Okay, what you need to do is this:
    if (rs.getString("val") == null)
      // do something
    }This way, when it's a null value, you can check it first, and then handle it how you want, rather than getting an exception.

  • Advertise implicit-null label for static routes

    Hi, I want to ask if there is any way to change the label or stop adveritise label for an static route. Normally LDP advertises an Implicit Null label for directly connected routes. We want to do similar thing for static routes.
    We need to do this is because somehow we need to do rate-limit on the PE interface connecting to the core network instead of the interface connecting to CE. As the incoming packets still got labelled, the rate-limit is skipped. So we want to stop the PE creates label for the static routes or advertises them with implicit null label. Thanks in advance.

    Calvin,
    Bear in mind that if you only enter the "no mpls ldp advertise-label" command, LDP will stop propagating all labels, which might not ba what you want. If you selectively want to propagate certain labels, then you need to also use "mpls advertise label for " as Shivlu suggested.
    Regards,

  • [wiki][proposal] Rewrite of the "Router" wiki entry

    This is a proposal to establish rewrite and restructure the entire "Router" wiki article located at http://wiki.archlinux.org/index.php/NAT … connection (The wiki entry "Router" currently redirects here).
    There has been much discussion of a rewrite in the #archlinux irc channel and a small number of users, including myself, wish to heavily rewrite and reorganize the information located at http://wiki.archlinux.org/index.php/NAT … connection and http://wiki.archlinux.org/index.php/NAT … d_features.
    The current articles, while informative, are extremely lengthy and provide large amounts of unnecessary information when creating an Arch Linux router. Some of the steps provided in the entries above are hard to follow, are provided out of order, and require you to unnecessarily browse off-site links for one or two lines of additional text to be added to a configuration file instead of providing them for you. This can be very confusing or misleading to someone not familiar with setting up this type of system.
    The rewritten entries would be divided into the following wiki entries - Router: Basic (redirected from "Router"), Router: Advanced.
    The rewritten entries would contain similar information to the original entries, however with some sections removed, reorganized or relocated and easier to follow. This would be able to ensure accessibility and usability of the Router entry for novice users, and at the same time allow more advanced users to additionally tweak their router.
    Due to the large amount of information provided by both existing entries, a third "Draft" entry would be proposed - Router: Draft.
    This would be a public wiki entry where those who wish to contribute to the rewrite of these articles can join and provide feedback to the existing status of the rewrite project. This would allow the information currently present on the existing pages to still be usable while the rewrite is taking place. Once the draft has been deemed usable enough to replace the existing entries, the draft page will be removed and the existing entries will be replaced by the newly rewritten router entries.
    Note: It came to my attention that it may just be wiser creating the Router: Basic and Router: Advanced pages and doing the rewrite on each respective page instead. During the time of the rewrite, an "article in progress" notice can be displayed informing users that the article itself may not be ready and should be followed at their own risk. As it stands, Router: Draft will be unnecessary.
    Those of us who are adament about rewriting these entries are curious to hear the community response to this proposal. We are going to begin rewriting the entries very soon and would like others to contribute or review our works on a regular basis. Please let us know what you think, as we would like to hear the community suggestions and insight on this proposal.
    Last edited by roadmap (2009-04-14 10:36:42)

    u_no_hu wrote:
    @roadmap..
    Nice work guys...
    One suggestion... dont include unnecessary(ie details available on other parts of wiki) details...
    IMO you can nuke this whole part without any loss of content because anybody who is going to install arch on a router will already be familiar with pacman and upgrading etc.
    On a default installation, Arch Linux does not come with what you will need to configure an Arch Linux router. You will need to install some additional packages to make Arch Linux function how we intend to. For this task, we will be using the package manager pacman.
    Tip: If you want more information on pacman and its uses, please see the Pacman wiki page
    [edit] Upgrading Your Packages
    If you have not done so already, you should go ahead and update your installation to the latest packages. You can do this by running the following command from the command line.
    pacman -Syu
    Allow it to proceed and once it has finished, continue to the next part of this tutorial.
    This is just my opinion and people may differ, but i find lot of wiki pages (xorg/beginners guide to mention two) to be bloated with excess info instead of linking to relevant part of wiki.
    I have thought about your inquiry and my response is hard to put it in perspective. I do agree with your philosophy about the fact that the specific section is unnecessary. However, those who may be attempting to setup an Arch Router may not have any internet access, outside of the Arch Router machine itself,  at the time they are following the tutorial.
    You have to remember that this is a tutorial/howto, and a good tutorial should contain all information necessary to complete the desired task. If someone should desire more information about a particular application or have a differing situation to the one that the tutorial is trying to achieve, then linking them to more information about each application may provide additional help to their situation.
    That was one of my complaints with the previous Router entry: it would send you off site to find one or two lines of config that could have just very well been included into the original article. It expected you to have full internet access while telling you flat out to tear apart your network in the process, and by doing so destroyed parts of its usability.
    With that being said, you have to remember that the current state of Router: Basic is incomplete and if anything a "draft". Once its complete, it will probably end up going through a few more revisions to ensure all the information provided is correct and necessary. You are more than welcome to add your own changes and information to it. The more help and input the better the article will be. So if you do feel like that section should be removed, feel free to change it at your leisure.

  • Implicit null

    hai experts,
    just now stepped into mpls world.
    i am refering the book "MPLS Fundamentals" by Luc De Ghein.
    In the implicit null portion the author states that " PHP is the default mode in cisco IOS.In case of ipv4 over mpls ,cisco ios only advertise the implicit null label for directly connected routes and summarized routes."
    but some of them told me that it will send implicit null for all routes it learns.
    Which is true or is there any hidden meaning in connected and summarized routes???

    Hi,
    If the question is about IPv4 routes learned in a VRF, then implicit-null will not be used at all - neither for PE directly connected nor for summary routes. The reason is that a PE needs a VPN label to identify the VRF context, because the IP destination address alone can not do it as you might have overlapping IP addresses in different VRFs. If you have a look at the labels in a VRF (show mpls forwarding-table vrf ...) you will see "Aggregate" for VRF connected or VRF summary routes. This denotes, that the PE will use the VPN label to select the proper VRF context and then has to perform an additional IP lookup to figure out, who should get the packet. If a label is for a VRF connected network the IP packet could be for the PE or the CE sharing this network. A VPN label alone in this case will not be enough, a double lookup is needed.
    So implicit-null is used for summary routes or directly connected routes in the global IP routing table of a PE.
    Hope this helps!
    Regards, Martin

  • Implicit & Explicit Null Labels

    Hi..
    I am a bit confused in Implicit and Explicit null labels. The RFC Says as follows :
    IMPLICIT NULL LABEL:This label value is only legal at the bottom of the label stack. It indicates that the label stack must be popped,
    and the forwarding of the packet must then be based on the IPv4 header.
    EXPLICIT NULL LABEL : This is a label that an LSR may assign and distribute, but which never actually appears in the encapsulation. When an LSR would otherwise replace the label at the top of the stack with a new label, but the new label is "Implicit NULL", the LSR will pop the stack instead of doing the
    replacement. Although this value may never appear in the encapsulation, it needs to be specified in the Label Distribution Protocol, so a value is reserved.
    My question is, which one is used in PHP operation. Consider I have a scenario like this :
    CE1--PE1---P---PE2---CE2
    How do I make the P router as the PHP router in this case???I need to have a implicit null label set on P router????
    What about explicit null label then???
    Regards,
    RAJ

    by defaulf, the P router will use implicit null label. For you to use the explicit null label, use the command
    mpls ldp explicit-null.
    The explicit null label is often useful in QoS implementation scenarios.
    See the following url
    http://www.cisco.com/en/US/products/ps6350/products_command_reference_chapter09186a0080430c63.html#wp1020450

  • REG : Null Pointer Exception for RFC values

    Hi All,
    I am facing peculiar erro in code.I need to check the null entries in SAP server then it should be replaced by space and if not null then should be replaced by the value in backend.But it is throwing null pointer exception
    I am using equalsignore case(null) and trim for space.
    I am not getting why its is throwing null pointer  exception.Kindly advise
    Regards,
    Anupama

    Hi
    Use
    String f = null ;
    if(f!==null)
    Wdcomponent.getMessageManager.ReportException ("this will cause null pointer exception  "+ f.length());
    Better to give it any Constant like
    priveate static final String NULL_CHECK  = "DEL_VAL12";
    rather than space ,at the time of chceking see if it has  DEL_VAL12 if true then put the actual data else let it be there.
    Best Regards
    Satish Kumar

  • Java.util.zip.ZipException: invalid entry size error --  help required

    Hi all
    I am sure this error would have been posted many number of times, but I would really appreciate if someone could help me with my problem. I am working on reading data from a .zip file, which in it has ~5GB data. All I am performing is a read operation through the piece of code specified below. This code worked well for .zip files handling till ~2.5GB
    FileInputStream fis = new FileInputStream(filename);
    BufferedInputStream bis = new BufferedInputStream(fis);
    ZipInputStream zis = new ZipInputStream(bis);
    StreamTokenizer tok = new StreamTokenizer( zis );
    ZipEntry entry;
    while((entry = zis.getNextEntry()) != null)
    \\read from the zip file through the streamTokenizer
    I just print what I read through the program, on the console.
    But the error I get is
    java.util.zip.ZipException: invalid entry size (expected 4294967295 but got 2117536490 bytes)
    at java.util.zip.ZipInputStream.readEnd(Unknown Source)
    at java.util.zip.ZipInputStream.read(Unknown Source)
    at java.util.zip.InflaterInputStream.read(Unknown Source)
    at java.io.StreamTokenizer.read(Unknown Source)
    at java.io.StreamTokenizer.nextToken(Unknown Source)
    at ZipFileStreams.getMessages(ZipFileStreams.java:677)
    at ZipFileStreams.main(ZipFileStreams.java:814)
    Could anybody give me hints as to what am I missing and where am i going wrong. Any help would be appreciated.
    Thanks

    Hi,
    I get the same exception while reading a ZIP file. The size if the ZIP file is just 82KB but I am reading it over FTP not sure if it makes any difference. I am using JDK 1.4.2_05. Here is the code I am trying to execute.
    public class TestFTP {
    public static void main( String[] argv ) throws Exception {
    String inboundPath = "/transfer/inbound/";
    FTPClient ftp = new FTPClient();
    ftp.connect("123");
    ftp.login( "123", "123" );
    ftp.changeWorkingDirectory(inboundPath);
    FTPFile[] zipFiles = ftp.listFiles("*.zip");
    TelnetClient telnetClient;
    for(int i=0;i<zipFiles.length;i++){   
    System.out.println(zipFiles.getName());
    ZipInputStream zis = new ZipInputStream(ftp.retrieveFileStream(zipFiles[i].getName()));
    for (ZipEntry entry = zis.getNextEntry(); entry != null; entry = zis.getNextEntry()){           
    System.out.println(entry.getName());
    The error message is
    java.util.zip.ZipException: invalid entry size (expected 10291 but got 10233 bytes)
         at java.util.zip.ZipInputStream.readEnd(ZipInputStream.java:367)
         at java.util.zip.ZipInputStream.read(ZipInputStream.java:141)
         at java.util.zip.ZipInputStream.closeEntry(ZipInputStream.java:91)
         at java.util.zip.ZipInputStream.getNextEntry(ZipInputStream.java:69)
         at test.TestFTP.main(TestFTP.java:41)
    Exception in thread "main"
    Please let me know if you were able to fix the problem.
    Thanks

  • Error: java.util.zip.ZipException: missing entry name

    Does anybody know how to solve the following error? I got this error when I was trying to update files in my CVS.
    OracleJSP: oracle.jsp.parse.JspParseException: Line # 2, <%@ taglib uri="http://java.sun.com/jstl/core" prefix="c"%>
    Error: java.util.zip.ZipException: missing entry name
    Thanks

    Hi,
    I get the same exception while reading a ZIP file. The size if the ZIP file is just 82KB but I am reading it over FTP not sure if it makes any difference. I am using JDK 1.4.2_05. Here is the code I am trying to execute.
    public class TestFTP {
    public static void main( String[] argv ) throws Exception {
    String inboundPath = "/transfer/inbound/";
    FTPClient ftp = new FTPClient();
    ftp.connect("123");
    ftp.login( "123", "123" );
    ftp.changeWorkingDirectory(inboundPath);
    FTPFile[] zipFiles = ftp.listFiles("*.zip");
    TelnetClient telnetClient;
    for(int i=0;i<zipFiles.length;i++){   
    System.out.println(zipFiles.getName());
    ZipInputStream zis = new ZipInputStream(ftp.retrieveFileStream(zipFiles[i].getName()));
    for (ZipEntry entry = zis.getNextEntry(); entry != null; entry = zis.getNextEntry()){           
    System.out.println(entry.getName());
    The error message is
    java.util.zip.ZipException: invalid entry size (expected 10291 but got 10233 bytes)
         at java.util.zip.ZipInputStream.readEnd(ZipInputStream.java:367)
         at java.util.zip.ZipInputStream.read(ZipInputStream.java:141)
         at java.util.zip.ZipInputStream.closeEntry(ZipInputStream.java:91)
         at java.util.zip.ZipInputStream.getNextEntry(ZipInputStream.java:69)
         at test.TestFTP.main(TestFTP.java:41)
    Exception in thread "main"
    Please let me know if you were able to fix the problem.
    Thanks

  • JavaFX's null not allowed is a thorn in my side....

    Hi All,
    Rule: JavaFX's data types (i.e. Number, Double, String, Integer) can't be null.
    My JavaFX Application listen's for real time data updates. Since this is a listener, it won't have a value til it get's the first update. Sounds fair enough... but they can't be null! So, I must use java.lang.Double instead. But all binding's convert the java.lang.Double null value to a javafx Double value of 0.0. So now I have broken logic in my program as 0.0 is a legitimate value and certainly does not signify 'null'. So, then it looks like I am stuck entirely with java.lang.Double everywhere! But then I'd need to do my own java.lang.Double -> fx.Double casting class/function to handle the cast conversion of each binding in order to interact sensibly with the JavaFX API (as it like's the FX Double everywhere and won't throw a nullpointer exception when casting).
    Rule: JavaFX's sequences can't contain null entries.
    Further more, I could say "Nope, I don't have a value/update yet so I will just use an object placeholder/wrapper with null assignment". In my case, JavaFX object's are multiple and ordered. Perfect for a sequence! Except, you can't store null in a sequence! Thus, if you are looking for a team's sport's top batsman.. the 3rd batsman and they don't exist yet.. then 'team[2] = null' wont insert! So how can I find and bind to the 3rd batsman? We'll either I avoid sequences, which means native array's or java collections... but then I can't really bind to them! Or, everytime the sequence changes I need to search/iterate over the entire sequence to determine if there is a 3rd batsman in the sequence (and that won't necessarily be the 3rd entry).
    Both these 'null not allowed' rules cause significant problems and have huge flow on effects onto the code that uses them. I believe this is totally wrong and a bad feature of the language and completely contradicts autoboxing! The identification of a data type reference being null is extremely significant. It is the responsibility of the receiver of a null reference/argument to decided how they want to handle the null reference (see autoboxing nullpointer exceptions if you don't believe me and reasons not to use java primitives). Removing the ability for this to occur is a step backwards for functional programming. I know you will say that I could just use the java.lang.*, a fair claim... but don't forget this means more work! The very reason you might be considering JavaFX in the first place.
    Anyway my rant is over, I really love JavaFX.... just not these x2 rules.

    The technique PhiLho refers to is often called the "null object pattern". If done properly it needn't be hackish at all, and indeed it can simplify a lot of processing code. Even if the "primitive" values (Number, String, etc.) could be null, and even if you could put nulls into a sequence, you're probably better off putting in an actual object that represents the absence of a value. The reason is that when you go to process that data, instead of just processing it, you have to put in checks for nulls here and there, and do special-case processing for it.
    Consider displaying a list of, say, the top five batsmen. You'll want to have a sequence of five batsmen, and you'll want to put five CustomNodes or something into a VBox to display the names, statistics, etc., something like the following:
    VBox {
        content: [
            for (b in [0..<5]) {
                BatsmanNode {
                    name: bind batsmen.name
    innings: bind batsmen[i].innings
    notOuts: bind batsmen[i].notOuts
    visible: bind batsmen[i].valid
    You can't do this if there were a null in the sequence, even if it were allowed. Instead, you should put a "fake" batsman object into the sequence, and make its "valid" variable be false. This way the corresponding BatsmanNode will be invisible. Or, you could have it display "(no entry)" in grey text, or something like that.
    The point is that if you always have a real object there, even if it represents a "null" or the absence of a value, it removes special-case processing code and enables you to do things like bind to it.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           

Maybe you are looking for

  • Animated GIF with Flex

    Hi all,      I designed a animated GIF image by Photoshop. And now, I want to add it into my web application. I referenced from http://www.bytearray.org/?p=95 http://iamjosh.wordpress.com/2009/02/03/animated-gifs-in-flex/      Have I must to download

  • Script for saving/replacing .png´s

    For Photoshop CS5: Hi, I need a script, which allows me to take the .png file i am working on, and save and replace it in the existing location with the exact same name: Without creating the "copy.png" string and preferebly without have to choose "In

  • Error In execution of Webdynpro Program

    Hi when i execute my web dynpro application it open up the browser not showing my field but shows me the error "ErrorCode:ICF-NF-http-c:000-u:SAPSYS-l:E-i:sapr3dq_R3D_00-v:0-s:403-r:Forbidden" can you help me out Regards Saad Nisar

  • Problems installing Itunes 9

    I recently got an Ipod touch for christmas and decided instead of upgrading my itunes to just delete it and install itunes 9. However, whenever I install it an error message pops up: "An error occured during the installation of assembly 'microsoft.VC

  • Use cookie on client to save session authentication...how?

    I am calling a web service that has a login method. It sets a session id in a cookie. Every subsequent call fails and says I'm not logged in. How do I save their cookie or session ID such that the server thinks I'm logged in? Here's the client code (