Problem calling remote method

All the cirrus connection is working fine, I make one net  connection and get my key, then I make a net stream, do connection with  the other user, the problem happens when i send the remote method to  call on the other user application.
In the net status (using previuos created net  connection) event handler when the status get "Success" i make one  request like this:
myStream.send("myFunction"); (I don`t remember if is .send or .play, but i tested both for sure)
And i have a public function called myFunction() to be activated on the other side.
Everything looks fine, i got the connection but i can`t access the remote method myFunction().
If needed, i can send my code for you to see.
Sorry for my english.
Thanks a lot for helping!

you can only call NetStream.send() on a publishing stream (one on which you have called NetStream.publish(streamName)).  and that NetStream must either be a client-server one (if talking to FMS) or a P2P one (either a group NetStream or a 1:1 one created as NetStream.DIRECT_CONNECTIONS).
on the subscriber side, your "myFunction" must be a function property on the subscribing NetStream.client object.

Similar Messages

  • JNI newbie problem calling remote method

    I have written the class and used javah to gen the .h file;
    class CallNative.java
    public class CallNative {
    static {
    System.loadLibrary("nativeapi");
    public native boolean doSomething(String x, String y);
    in the implementation i have
    callNativeImpl.cpp
    #include "StdAfx.h"
    #include <windows.h>
    #include "CallNative.h"
    BOOL APIENTRY DllMain (HANDLE hModule, DWORD dwReason, void** lpReserved) {
    return TRUE;
    extern "C" {
    JNIEXPORT jboolean JNICALL
    Java_CallNative_doSomething
    (JNIEnv *env, jobject obj, jstring strX, jstring strY) {
    jboolean Result = doSomething(strX, strY);
    I get > error C2065: 'doSomething' : undeclared identifier
    when compiling.
    What is the correct way of calling the external (native) method?
    Thanks in advance!

    Just for a test, change the line:
    jboolean Result = doSomething(strX, strY);to:
      printf("This is a JNI example.\n");
      return;It seems like "doSomething" is the function you are already in...
    Don't forget to also add an include of <stdio.h> for the printf to work.
    Good luck,
    Alfredo

  • Problem calling a method in a servlet witch returns remote ejb

    Hi, I have a problem combining servlets ands ejbs, I expose my problem :
    What I have :
    1 . I have a User table into a SGBD with two attributes login and pass.
    2 . I have a UserBean linked to User table with a remote interface
    3 . I have a stateless UserSessionBean with a remote interface
    4 . I have a UserServlet linked to a jsp page which allows me to add users
    5 . I use Jboss
    What is working ?
    1 - I have a method newUser implemented in my UserSessionBean :
    public class UserSessionBean implements SessionBean {
      private SessionContext sessionContext;
      private UserRemoteHome userRemoteHome;
      public void ejbCreate() throws CreateException {
      // Initialize UserRemoteHome
      // Method to add a new user
      public UserRemote newUser(String login, String password) {
            UserRemote newUser = null;
            try {
                newUser = userRemoteHome.create(login, password);
            } catch (RemoteException ex) {
                System.err.println("Error: " + ex);
            } catch (CreateException ex) {
                System.err.println("Error: " + ex);
            return newUser;
    }2 - When I test this method with a simple client it works perfectly :
    public class TestEJB {
        public static void main(String[] args) {
            Context initialCtx;
            try {
                // Create JNDI context
                // Context initialization
                // Narrow UserSessionHome
                // Create UserSession
                UserSession session = sessionHome.create();
                // Test create
                UserRemote newUser = session.newUser("pierre", "hemici");
                if (newUser != null) {
                    System.out.println(newUser.printMe());
            } catch (Exception e) {
                System.err.println("Error: " + e);
                e.printStackTrace();
    Result : I got the newUser printed on STDOUT and I check in the User table (in the SGBD) if the new user has been created.
    What I want ?
    I want to call the newUser method from the UserServlet and use the RemoteUser returned by the method.
    What I do ?
    The jsp :
    1 - I have a jsp page where a get information about the new user to create
    2 - I put the login parameter and the password parameter into the request
    3 - I call the UserServlet when the button "add" is pressed on the jsp page.
    The Servlet :
    1 - I have a method doInsert which call the newUser method :
    public class UserServlet extends HttpServlet {
        private static final String CONTENT_TYPE = "text/html";
        // EJB Context
        InitialContext ejbCtx;
        // Session bean
        UserSession userSession;
        public void init() throws ServletException {
            try {
                // Open JNDI context (the same as TestClient context)
                // Get UserSession Home
                // Create UserSession
                userSession = userSessionHome.create();
            } catch (NamingException ex) {
                System.out.println("Error: " + ex);
            } catch (RemoteException ex) {
                System.out.println("Error: " + ex);
            } catch (CreateException ex) {
                System.out.println("Error: " + ex);
        protected void service(HttpServletRequest req, HttpServletResponse resp) throws
                ServletException, IOException {
         * Does insertion of the new user in the database.
        public void doInsert(HttpServletRequest req, HttpServletResponse resp) throws
                ServletException, IOException {
            try {
                // Get parameters to create the newUser
                String login = req.getParameter("login");
                String password = req.getParameter("password");
               // Create the newUser
                System.out.println("Calling newUser before");
                UserRemote user = userSession.newUser(login, password);
                System.out.println("Calling newUser after");
            } catch (Exception e) {
        // Clean up resources
        public void destroy() {
    Result :
    When I run my jsp page and click on the "add" button, I got the message "Calling newUser before" printed in STDOUT and the error message :
    ERROR [[userservlet]] Servlet.service() for servlet userservlet threw exception
    javax.servlet.ServletException: loader constraints violated when linking javax/ejb/Handle class
         at noumea.user.UserServlet.service(UserServlet.java:112)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
         at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
         at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
         at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:81)
         at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
         at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
         at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
         at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
         at org.jboss.web.tomcat.security.CustomPrincipalValve.invoke(CustomPrincipalValve.java:39)
         at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:153)
         at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:59)
         at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
         at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
         at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
         at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
         at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
         at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:744)
         at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
         at org.apache.tomcat.util.net.MasterSlaveWorkerThread.run(MasterSlaveWorkerThread.java:112)
         at java.lang.Thread.run(Thread.java:534)
    Constat :
    I checked into my SGBD and the new user has been created.
    The error appears only when the method return Remote ejbs, if I return simples objects (Strings, int..) it works.
    What can I do to resolve this problem ?
    Thank you.

    "Why do you want to servlet to gain access to another EJB through the stateless session bean. Why cant the servlet call it directly ?"
    Because I want to access to the informations included in the entity bean UserBean (which is remote).
    You said that it is a bad design, but how can I access to my UserBean ejbs from the session bean if I don't do that ?
    For example I want a List of all users to be seen in a jsp page :
    1 - I call the method getUserList which returnsan ArrayList of UserRemote.
    2 - I iterate over the ArrayList to get the users parameters to be seen.
    As the other example (newUser), when I do
    ArrayList users = (ArrayList) userSession.getUserList(); with the simple client it works, but in the servlet I got the same error.
    But, if I call directly the findAll method (as you'are saying) in the servlet
    ArrayList users = (ArrayList) userRemoteHome.findAll(); it works...
    I think that if my servlet calls directly entity ejbs, I don't need UserSession bean anymore. Is that right ?
    I precise that my design is this :
    jsp -> servlet -> session bean -> entity bean -> sgbd
    Is that a bad design ? Do I need the session bean anymore ?
    Thank you.

  • Problem Calling Remote Session Bean Method

    Need help. I am trying to call a method in a remote stateless session bean in an EJB in my web application from a stateless session bean in a different EJB in the web application. I am getting a run-time error that says,
    "java.lang.NoClassDefFoundError: dtpitb.common.sb.reports.CommonReportsHome"
    ref = ctx.lookup( jndiName );
    // Cast to Local Home Interface using RMI-IIOP
    commonReportsHome = (CommonReportsHome)
    PortableRemoteObject.narrow(ref, CommonReportsHome.class);
    If while in a session bean of an EJB, I want to call a public method in the session bean of a totally different EJB, is there something in particular I am missing. I can make the call from the web application code. I can make a remote call from this session bean to itself in the exact same fashion. I just can't call a session bean in another EJB. All thoughts are welcome.
    Thanks,
    Pete

    Thanks for replying. That could very well be the case I suppose. I'm using JBuilder and WebLogic, and JBuilder pretty much does all of the deployment descriptor code for me. However, maybe this is something I need to incorporate manually.
    One EJB is in the same project as the web application code. The other EJB (common_ejb) is in another project. The calling session bean is in the project with the web app, and the remote session bean method that I'm targeting is in the common EJB session bean. Both EJBs are included in the web app's WEB-INF\lib dir and in the war file.
    So theoretically, this isn't an unconventional practice I assume?
    Thanks,
    Pete

  • AbstractMethodError calling remote method

    Java student and rank RMI newbie here; please go easy on me. My subinterface, remote class, and client app all compile fine, but when I run the client app I get an error:
    Exception in thread "main" java.lang.AbstractMethodError: DatabaseUpdater_Stub.i
    nitCourseList()Lcom/sun/rowset/CachedRowSetImpl;
            at EnrollPanel.<init>(Enroll3.java:99)
            at Enroll3.main(Enroll3.java:25)Here is my subinterface:
    import com.sun.rowset.CachedRowSetImpl;
    import java.rmi.*;
    import java.sql.*;
    import javax.sql.*;
    public interface DbUpdaterInterface extends Remote
         public abstract CachedRowSetImpl initCourseList() throws RemoteException, SQLException;
         public abstract CachedRowSetImpl initStudentList() throws RemoteException, SQLException;
         public abstract CachedRowSetImpl initEnrollmentList() throws RemoteException, SQLException;
         public abstract void addNewCourseInDb() throws RemoteException;
         public abstract void addStudentToCourseInDb() throws RemoteException;
         public abstract void addNewStudentInDb() throws RemoteException;
         public abstract void enrollStudentInCourseInDb() throws RemoteException;
    }and the remote class that implements the interface:
    import com.sun.rowset.CachedRowSetImpl;
    import java.net.*;
    import java.rmi.*;
    import java.rmi.server.*;
    import java.sql.*;
    import javax.sql.*;
    public class DatabaseUpdater extends UnicastRemoteObject implements DbUpdaterInterface
         Connection dbConnection;
         public DatabaseUpdater(Connection dbConnection) throws RemoteException
              this.dbConnection = dbConnection;
         public CachedRowSetImpl initCourseList() throws RemoteException, SQLException
              CachedRowSetImpl rset = new CachedRowSetImpl();
              Statement courseStatement = dbConnection.createStatement();
              String courseQuery = "SELECT CourseID, MaxEnrollment, CurrentEnrollment FROM Courses";
              ResultSet courseResults = courseStatement.executeQuery(courseQuery);
              rset.populate(courseResults);
              courseStatement.close();
              return rset;
    // ... some more methods ...
         public static void main(String []args)
              try
                   Class.forName("sun.jdbc.odbc.JdbcOdbcDriver");
                   Connection dbConnection = DriverManager.getConnection("jdbc:odbc:DRIVER={Microsoft Access Driver (*.mdb)};DBQ=project3.mdb");
                   DatabaseUpdater x = new DatabaseUpdater(dbConnection);   // a remote object
                   Naming.rebind("DatabaseUpdater", x);   // the remote object is named as "DatabaseUpdater"
                   System.out.println("Database updater is running....");
              catch (Exception e)
                   System.err.println(e);
    }In my client app, here is the problem code, with the last line being the one that throws the error:
                   // invoke remote DatabaseUpdater object
                   DbUpdaterInterface dbUpdater = (DbUpdaterInterface) Naming.lookup("DatabaseUpdater");
                   // call remote object to get result set of all courses, students, enrollments
                   CachedRowSetImpl courseResults = dbUpdater.initCourseList();Any ideas? AbstractMethodError refers to trying to call an abstract method, but I have my subinterface's initCourseList() method implemented in my remote class just fine. I'd greatly appreciate some help!

    Oops, my mistake. I had made changes since last running rmic on my remote class. Nothing to see here, move along!

  • Exception data: java.lang.AbstractMethodError - Calling Remote Method.

    We recently changed some of our CMP fields from primative int's to integer's and now we are receiving Abstract Method Errors at runtime. We have fixed all the methods that use this CMP fields, well at least we think we got them all. Since this are remote methods the sever is setup to pull JAR files from a lib directory on the server. This JAR files have also been updated. Can anyone give me more information about this error or something I might be missing.
    ------------------------------------------------------------------------------------- Errors -------------------------------------------------------------------------------------
    [11/7/07 15:40:23:141 CST] 00000022 ExceptionUtil E CNTR0020E: EJB threw an unexpected (non-declared) exception during invocation of method "getPositionInfo" on bean "BeanId(hr-ear#hr-ejb.jar#PositionService, null)". Exception data: java.lang.AbstractMethodError: com/tgt/supply/pdd/ejb/entity/AmcOffice.getOfcI()Ljava/lang/Integer;
         at com.theamc.hr.ejb.session.PositionServiceBean.getPositionCollections(PositionServiceBean.java:1383)
         at com.theamc.hr.ejb.session.PositionServiceBean.getPositionInfo(PositionServiceBean.java:46)
         at com.theamc.hr.ejb.session.EJSRemoteStatelessPositionService_fae72574.getPositionInfo(EJSRemoteStatelessPositionService_fae72574.java:262)
         at com.theamc.hr.ejb.session._PositionService_Stub.getPositionInfo(_PositionService_Stub.java:272)
         at com.theamc.hr.web.servlet.PositionServlet.createPageObject(PositionServlet.java:153)
         at com.theamc.framework.servlet.ControllerServlet.doGet(ControllerServlet.java:221)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:743)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
         at com.ibm.ws.webcontainer.servlet.ServletWrapper.service(ServletWrapper.java:966)
         at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:478)
         at com.ibm.ws.wswebcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:463)
         at com.ibm.ws.webcontainer.servlet.CacheServletWrapper.handleRequest(CacheServletWrapper.java:92)
         at com.ibm.ws.webcontainer.WebContainer.handleRequest(WebContainer.java:744)
         at com.ibm.ws.wswebcontainer.WebContainer.handleRequest(WebContainer.java:1433)
         at com.ibm.ws.webcontainer.channel.WCChannelLink.ready(WCChannelLink.java:93)
         at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleDiscrimination(HttpInboundLink.java:465)
         at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleNewInformation(HttpInboundLink.java:394)
         at com.ibm.ws.http.channel.inbound.impl.HttpICLReadCallback.complete(HttpICLReadCallback.java:102)
         at com.ibm.ws.tcp.channel.impl.AioReadCompletionListener.futureCompleted(AioReadCompletionListener.java:152)
         at com.ibm.io.async.AbstractAsyncFuture.invokeCallback(AbstractAsyncFuture.java:213)
         at com.ibm.io.async.AbstractAsyncFuture.fireCompletionActions(AbstractAsyncFuture.java:195)
         at com.ibm.io.async.AsyncFuture.completed(AsyncFuture.java:136)
         at com.ibm.io.async.ResultHandler.complete(ResultHandler.java:194)
         at com.ibm.io.async.ResultHandler.runEventProcessingLoop(ResultHandler.java:741)
         at com.ibm.io.async.ResultHandler$2.run(ResultHandler.java:863)
         at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1510)
    [11/7/07 15:34:10:043 CST] 00000020 ExceptionUtil E CNTR0020E: EJB threw an unexpected (non-declared) exception during invocation of method "getUserOrgInfo" on bean "BeanId(userprofile-ear#userprofile-ejb.jar#UserOrgInfo, null)". Exception data: java.lang.AbstractMethodError: com/tgt/supply/pdd/ejb/entity/AmcOffice.getOfcI()Ljava/lang/Integer;
         at com.theamc.userprofile.ejb.session.UserOrgInfoBean.getUserOfficeValue(UserOrgInfoBean.java:536)
         at com.theamc.userprofile.ejb.session.UserOrgInfoBean.getUserOrgInfo(UserOrgInfoBean.java:84)
         at com.theamc.userprofile.ejb.session.EJSRemoteStatelessUserOrgInfo_13c2e095.getUserOrgInfo(EJSRemoteStatelessUserOrgInfo_13c2e095.java:194)
         at com.theamc.userprofile.ejb.session._UserOrgInfo_Stub.getUserOrgInfo(_UserOrgInfo_Stub.java:273)
         at com.theamc.userprofile.servlet.UserOrgInfoServlet.createPageObject(UserOrgInfoServlet.java:243)
         at com.theamc.framework.servlet.ControllerServlet.doGet(ControllerServlet.java:221)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:743)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
         at com.ibm.ws.webcontainer.servlet.ServletWrapper.service(ServletWrapper.java:966)
         at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:478)
         at com.ibm.ws.wswebcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:463)
         at com.ibm.ws.webcontainer.webapp.WebApp.handleRequest(WebApp.java:3129)
         at com.ibm.ws.webcontainer.webapp.WebGroup.handleRequest(WebGroup.java:238)
         at com.ibm.ws.webcontainer.WebContainer.handleRequest(WebContainer.java:811)
         at com.ibm.ws.wswebcontainer.WebContainer.handleRequest(WebContainer.java:1433)
         at com.ibm.ws.webcontainer.channel.WCChannelLink.ready(WCChannelLink.java:93)
         at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleDiscrimination(HttpInboundLink.java:465)
         at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleNewInformation(HttpInboundLink.java:394)
         at com.ibm.ws.http.channel.inbound.impl.HttpICLReadCallback.complete(HttpICLReadCallback.java:102)
         at com.ibm.ws.tcp.channel.impl.AioReadCompletionListener.futureCompleted(AioReadCompletionListener.java:152)
         at com.ibm.io.async.AbstractAsyncFuture.invokeCallback(AbstractAsyncFuture.java:213)
         at com.ibm.io.async.AbstractAsyncFuture.fireCompletionActions(AbstractAsyncFuture.java:195)
         at com.ibm.io.async.AsyncFuture.completed(AsyncFuture.java:136)
         at com.ibm.io.async.ResultHandler.complete(ResultHandler.java:194)
         at com.ibm.io.async.ResultHandler.runEventProcessingLoop(ResultHandler.java:741)
         at com.ibm.io.async.ResultHandler$2.run(ResultHandler.java:863)
         at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1510)
    ------------------------------------------------------------------------------------- Usage -------------------------------------------------------------------------------------
    HashMap ofcRegn = new HashMap();
    AmcOffice off = null;
    AmcOfficeHome offHome = com.tgt.supply.pdd.ejb.entity.EntityHomeFactory.getAmcOfficeHome();
    ArrayList ofcColl = new ArrayList();
    Iterator iter = offHome.findAll().iterator();
    while (iter.hasNext()) {
    off = (AmcOffice) PortableRemoteObject.narrow(iter.next(), AmcOffice.class);
    ofcColl.add(new GenericCode(""+off.getOfcI(),off.getOfcN())); line 1383
    ofcRegn.put(""+off.getOfcI(),""+off.getRegnI());
    The abstract method error is thrown when off.getOfcI() is called. OfcI is the field that was changed from a primative int to an integer.
    Any help is appreciated
    Chris

    I am pretty sure. I am using RAD locally so I have deleted all the generated AccessBean and Deployment code and rerun the deploy. My concern is that these remote methods are using an external JAR file which is loaded when the server is started. I have updated this JAR files, but I am not sure if maybe they are being cached some where.

  • Problems calling a method from a different class

    Like many programmers, I'm having a go at making my own chat room. All has been going well so far, however I am having trouble calling the method which connects the client to the server, from the method which actually starts the server.
    The method for starting the server:
    public static void serverStart () throws IOException {
            new Thread () {
            public void run() {
                try {
                    ServerSocket serverSock = new ServerSocket (client.serverPort);
                while (true) {
                    Socket serverClient = serverSock.accept ();
                    ChatHandler handler = new ChatHandler(serverClient);
                    handler.start ();
                } catch (IOException ex) {     
                    connectTo.handleIOException(ex);     
            }.start();
            try {
                connectTo.start();
            } catch (IOException ex) {
                connectTo.handleIOException(ex);
        }The part of interest is the "connectTo.start()" line, as this is the one which calls a method in the class connectToMethod which tells the client to connect to this newly started server. Now for the client connection code:
    public synchronized void start () throws IOException {
          if (listener == null) {
              Socket socket = new Socket (client.serverAddr, client.serverPort);
              try {
                  dataIn = new DataInputStream
                          (new BufferedInputStream (socket.getInputStream ()));
                  dataOut = new DataOutputStream
                          (new BufferedOutputStream (socket.getOutputStream ()));
              } catch (IOException ex) {
              socket.close ();
              throw ex;
          listener = new Thread (this);
          listener.start ();
      }Now when the server starts, it should automatically start the connection method "start()" and connect to itself. However I am getting a NullPointerException error at the line "connectTo.start();" from the server code. The server and connection client actually work separately, just not when I try to connect from the server itself. I have tried a few ways of getting around this problem, all without success. If anyone could give some input on what might be wrong, or a possible way to fix it, I'd be very grateful.

    Sorry, connectTo comes from:
    connectToMethod connectTo = new
    connectToMethod();
    That doesn't necessarily mean this variable reference is the same one as in the code where the NullPointerException was thrown though.
    Or the exception was thrown inside the start() method. The runtime isn't lying to you. You have a null reference (pointer) where it says you do.

  • Problem calling a method which takes a parameter from a table

    Hi guys,
    I'm very new to jsf and hope you can help me out.
    On my page i'm generating a list, which is working fine. now i want to add some commandLinks to the list entries. on click, i want to execute a bean method, which takes a parameter from the list, generates a picture and displays it on my page.
    here's a piece of code thats already working:
    <rich:dataTable var="data" value="#{pathwayBean.orgList}">
    <rich:columnGroup>     
            <rich:column>     
               <h:outputText value="#{data.name}" />
         </rich:column>
    </rich:columnGroup>
    </rich:dataTable>now, i want to replace the outputText with a commandLink, and execute a method with {data.id} as parameter. Unfortunately, the commandLink property "action" can only call bean methods with no parameter, or is that wrong?
    Thanks in advance,
    Alex

    use actionlistener.
    here a typical code that works fine for me:
    (JSF 1.2)
    //Java
    private Integer selectedItemId=null;
         public void selectItem(ActionEvent event) {
              // Find the UIParameter component by expression
              UIParameter component = (UIParameter) event.getComponent().findComponent("itemId");
              // parse the value of the UIParameter component
              try {
                   selectedItemId = Integer.parseInt(component.getValue().toString());
                   // find itemBean here using selectedItemId
              } catch (Exception e) {
                   logger.error(e, e);
              logger.info(" +++ selectedItemId =" + selectedItemId);
         public String viewItem() {
                 //create view beans here
                 return "itemView";//return appropriate view.
    //JSF
    <h:column>
                             <h:commandLink     id="View"
                                                 action="#{itemListBean.viewItem}"
                                                       actionListener="#{itemListBean.selectItem}">
                                  <h:outputText value="select"/>
                                  <f:param id="itemId" name="itemId" value="#{itemBean.id}"/>
                             </h:commandLink>
                     </h:column>

  • Problem calling Java method from JavaScript in JSP / ADF

    Hi all,
    In my JavaScript onMouseUp() function, I need to call a method on my Java backing bean. How is this done? Info on the web indicates a static Java method can be called by simply "package.class.staticMethod(...)". but when I put the statement
    "jsf.backing.GlobalRetriever.createBasemap(affectedLayer);"
    I get an error message "jsf is undefined".
    The functionality I'm trying to get is: I have a custom slider control and based on its value, I want to call oracle map viewer specifying a map extent of the (current extent / slider value) to do a zoom in/out. In addition, the slider uses a onMouseMove() function to change the size of the image display so it looks like a dynamic zoom in/out.
    Please assist or let me know if I can provide some additional information. Thanks in advance.
    Jim Greetham

    No. The Java and Javascript in a Faces application are really working in two different universes.
    Java is running on the server. It generates HTML (and sometimes even Javascript) and sends that to the client machine. That's where all your backing beans are.
    Javascript runs directly in the browser. There's no way anything on the server can have access to anything you define in Javascript, unless you explicitly send that information back to the server, either via standard form submission (which only works when someone presses a "Submit" button) or via an Ajax-type call. So otherwise, nothing you define in Javascript will ever be available to a backing bean.

  • Problems calling remote site

    I have a problem making a call from Isle of Man that has a 2900 router running CME 8.6 and a remote site Singapore that is on a UCS560, we have created a site to site VPN and can ping from either phone vlan to either phone vlan interfaces. The problem is that when I call from the Isle of Man site the call routes, rings on the remote phone and the user answers, they can hear the Isle of Man but the Isle of man cannot hear them... I hear you all say one way voice must be routing, well I cannot find where the error  and like I say we can ping. I have added the singapore config as a starting point and we are calling from 0977  Isle of Man to 3123 Singapore.
    version 15.1
    parser config cache interface
    no service pad
    no service timestamps debug uptime
    service timestamps log datetime msec localtime
    service internal
    service compress-config
    service sequence-numbers
    hostname SG_UC_560
    boot-start-marker
    boot system flash:/uc500-advipservicesk9-mz.151-4.M6
    boot-end-marker
    no logging buffered
    no logging rate-limit
    aaa new-model
    aaa authentication login default local
    aaa authentication login sdm_vpn_xauth_ml_1 local
    aaa session-id common
    clock timezone WST 8 0
    network-clock-participate wic 1
    network-clock-select 1 BRI0/1/0
    network-clock-select 2 BRI0/1/1
    dot11 syslog
    ip source-route
    ip cef
    ip dhcp relay information trust-all
    ip dhcp excluded-address 172.16.100.1 172.16.100.99
    ip dhcp excluded-address 172.16.100.200 172.16.100.255
    ip dhcp excluded-address 192.168.138.1 192.168.138.99
    ip dhcp excluded-address 192.168.138.200 192.168.138.255
    ip dhcp pool phone
    network 172.16.100.0 255.255.255.0
    default-router 172.16.100.1
    option 150 ip 172.16.100.1
    ip dhcp pool data
    import all
    network 192.168.138.0 255.255.255.0
    default-router 192.168.138.1
    dns-server 8.8.8.8 8.8.4.4
    ip dhcp pool DoorIntercom
    host 192.168.138.5 255.255.255.0
    hardware-address 7c1e.b3fe.09a8
    ip inspect WAAS flush-timeout 10
    ip dhcp-client update dns server both
    no ipv6 cef
    multilink bundle-name authenticated
    stcapp ccm-group 1
    stcapp
    isdn switch-type basic-net3
    trunk group ALL_BRI
    hunt-scheme longest-idle
    translation-profile outgoing PROFILE_ALL_BRI
    trunk group ALL_FXO
    max-retry 5
    voice-class cause-code 1
    hunt-scheme longest-idle
    voice call send-alert
    voice rtp send-recv
    voice service voip
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    supplementary-service h450.12
    sip
      registrar server expires max 600 min 60
      no update-callerid
    voice class codec 1
    codec preference 1 g711ulaw
    codec preference 2 g711alaw
    codec preference 3 g729r8
    codec preference 4 g729br8
    voice class cause-code 1
    no-circuit
    voice register global
    mode cme
    source-address 172.16.100.1 port 5060
    max-dn 120
    max-pool 30
    load 9971 sip9971.9-2-2
    load 9951 sip9951.9-2-2
    load 8961 sip8961.9-2-2
    authenticate register
    authenticate realm uc500.local
    timezone 42
    date-format D/M/Y
    hold-alert
    create profile sync 0002461994550035
    voice register dn  1
    number 199
    name Door Intercom
    no-reg
    label Door Intercom
    voice register pool  1
    registration-timer max 720 min 660
    id mac 7C1E.B3FE.09A8
    type CiscoMobile-iOS
    number 1 dn 1
    cor incoming user-internal default
    dtmf-relay rtp-nte
    username 199 password
    codec g711ulaw
    voice hunt-group 1 parallel
    final 399
    list 122,123
    timeout 16
    pilot 501
    voice translation-rule 4
    rule 15 /^...$/ /62223151/
    voice translation-rule 1000
    rule 1 /.*/ //
    voice translation-rule 1112
    rule 10 /^90[0123][1-9]\(.*\)/ /019\1/
    rule 15 /^9/ //
    voice translation-rule 2002
    rule 1 /^6/ //
    voice translation-rule 2222
    voice translation-rule 3119
    rule 1 /^3\(...\)/ /\1/
    voice translation-rule 3121
    rule 1 /3121/ /121/
    voice translation-profile CALLER_ID_TRANSLATION_PROFILE
    translate calling 1111
    voice translation-profile CallBlocking
    translate called 2222
    voice translation-profile IOM
    translate called 3119
    voice translation-profile OUTGOING_TRANSLATION_PROFILE
    translate called 1112
    voice translation-profile PROFILE_ALL_BRI
    translate calling 4
    voice translation-profile XFER_TO_VM_PROFILE
    translate redirect-called 2002
    voice translation-profile nondialable
    translate called 1000
    voice-card 0
    fax interface-type fax-mail
    license udi pid UC560-BRI-K9 sn FGL164912CA
    archive
    log config
      logging enable
      logging size 600
      hidekeys
    process-max-time 150
    ip tftp source-interface Vlan90
    crypto isakmp policy 10
    encr 3des
    hash md5
    authentication pre-share
    group 2
    lifetime 85400
    crypto isakmp key xxxxxxxxx address IP of Isle of Man no-xauth
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto map IOM-VPN 10 ipsec-isakmp
    set peer IP of Isle of Man
    set transform-set ESP-3DES-MD5
    match address 150
    interface Loopback0
    ip address xxxxxxxxx 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    interface GigabitEthernet0/0
    ip ddns update hostname xxxxxxxxx
    ip ddns update dyndns
    ip address dhcp client-id GigabitEthernet0/0
    ip nat outside
    ip virtual-reassembly in
    load-interval 30
    duplex auto
    speed auto
    crypto map IOM-VPN
    interface Integrated-Service-Engine0/0
    description Interface used to manage integrated application modulecue is initialized with default IMAP group
    ip unnumbered Vlan90
    ip nat inside
    ip virtual-reassembly in
    service-module ip address 10.1.10.1 255.255.255.252
    service-module ip default-gateway 10.1.10.2
    interface GigabitEthernet0/1/0
    switchport mode trunk
    switchport voice vlan 100
    no ip address
    macro description cisco-switch
    interface GigabitEthernet0/1/1
    switchport mode trunk
    switchport voice vlan 100
    no ip address
    macro description cisco-switch
    interface GigabitEthernet0/1/2
    no ip address
    macro description cisco-desktop
    spanning-tree portfast
    interface GigabitEthernet0/1/3
    description Interface used to communicate with integrated service module
    switchport access vlan 90
    no ip address
    service-module ip address 10.1.10.1 255.255.255.252
    service-module ip default-gateway 10.1.10.2
    interface BRI0/1/0
    no ip address
    isdn switch-type basic-net3
    isdn point-to-point-setup
    isdn incoming-voice voice
    isdn sending-complete
    trunk-group ALL_BRI 64
    interface BRI0/1/1
    no ip address
    isdn switch-type basic-net3
    isdn point-to-point-setup
    isdn incoming-voice voice
    isdn sending-complete
    trunk-group ALL_BRI 64
    interface Virtual-Template1
    ip unnumbered Loopback0
    ip nat inside
    ip virtual-reassembly in
    interface Virtual-Template200 type serial
    no ip address
    interface Vlan1
    ip address 192.168.138.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    interface Vlan90
    ip address 10.1.10.2 255.255.255.252
    ip nat inside
    ip virtual-reassembly in
    interface Vlan100
    ip address 172.16.100.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    ip local pool SDM_WEBVPN_POOL_1 192.168.138.20 192.168.138.29
    ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip http path flash:/gui
    ip dns server
    ip nat inside source route-map SDM_RMAP_1 interface GigabitEthernet0/0 overload
    ip route 10.1.10.1 255.255.255.255 Vlan90
    access-list 100 deny   ip 192.168.138.0 0.0.0.255 192.168.104.0 0.0.0.255
    access-list 100 deny   ip 172.16.100.0 0.0.0.255 172.16.105.0 0.0.0.255
    access-list 100 deny   ip 172.16.100.0 0.0.0.255 192.168.104.0 0.0.0.255
    access-list 100 deny   ip 192.168.138.0 0.0.0.255 172.16.105.0 0.0.0.255
    access-list 100 permit ip 10.1.10.0 0.0.0.3 any
    access-list 100 permit ip 192.168.138.0 0.0.0.255 any
    access-list 100 permit ip 172.16.100.0 0.0.0.255 any
    access-list 150 permit ip 192.168.138.0 0.0.0.255 192.168.104.0 0.0.0.255
    access-list 150 permit ip 172.16.100.0 0.0.0.255 172.16.105.0 0.0.0.255
    access-list 150 permit ip 172.16.100.0 0.0.0.255 192.168.104.0 0.0.0.255
    access-list 150 permit ip 192.168.138.0 0.0.0.255 172.16.105.0 0.0.0.255
    route-map SDM_RMAP_1 permit 1
    match ip address 100
    snmp-server community public RO
    tftp-server flash:/phones/6901_6911/SCCP6911.9-1-1-0.loads alias SCCP6911.9-1-1-0.loads
    tftp-server flash:/phones/6901_6911/SCCP6901.9-1-1-0.loads alias SCCP6901.9-1-1-0.loads
    tftp-server flash:/phones/6901_6911/KNL6911SCCP.9-1-1-0.zz.sgn alias KNL6911SCCP.9-1-1-0.zz.sgn
    tftp-server flash:/phones/6901_6911/KNL6901SCCP.9-1-1-0.zz.sgn alias KNL6901SCCP.9-1-1-0.zz.sgn
    tftp-server flash:/phones/6901_6911/BFS6911SCCP.9-1-1-0.zz.sgn alias BFS6911SCCP.9-1-1-0.zz.sgn
    tftp-server flash:/phones/6901_6911/APP6911SCCP.9-1-1-0.zz.sgn alias APP6911SCCP.9-1-1-0.zz.sgn
    tftp-server flash:/phones/6901_6911/APP6901SCCP.9-1-1-0.zz.sgn alias APP6901SCCP.9-1-1-0.zz.sgn
    tftp-server flash:/phones/69xx/SCCP69xx.9-1-1-2-sr.loads alias SCCP69xx.9-1-1-2-sr.loads
    tftp-server flash:/phones/69xx/BOOT69xx.0-0-0-14.zz.sgn alias BOOT69xx.0-0-0-14.zz.sgn
    tftp-server flash:/phones/69xx/DSP69xx.0-0-0-4.zz.sgn alias DSP69xx.0-0-0-4.zz.sgn
    tftp-server flash:/phones/69xx/SCCP69xx.9-1-1-2-sr.zz.sgn alias SCCP69xx.9-1-1-2-sr.zz.sgn
    tftp-server flash:/phones/521_524/cp524g-8-1-17.bin alias cp524g-8-1-17.bin
    tftp-server flash:/phones/525/spa525g-7-4-9c.bin alias spa525g-7-4-9c.bin
    tftp-server flash:/phones/50x-30x/spa50x-30x-7-4-9c.bin alias spa50x-30x-7-4-9c.bin
    tftp-server flash:/phones/7906_7911/apps11.9-2-1TH1-13.sbn alias apps11.9-2-1TH1-13.sbn
    tftp-server flash:/phones/7906_7911/cnu11.9-2-1TH1-13.sbn alias cnu11.9-2-1TH1-13.sbn
    tftp-server flash:/phones/7906_7911/cvm11sccp.9-2-1TH1-13.sbn alias cvm11sccp.9-2-1TH1-13.sbn
    tftp-server flash:/phones/7906_7911/dsp11.9-2-1TH1-13.sbn alias dsp11.9-2-1TH1-13.sbn
    tftp-server flash:/phones/7906_7911/jar11sccp.9-2-1TH1-13.sbn alias jar11sccp.9-2-1TH1-13.sbn
    tftp-server flash:/phones/7906_7911/SCCP11.9-2-1S.loads alias SCCP11.9-2-1S.loads
    tftp-server flash:/phones/7906_7911/term06.default.loads alias term06.default.loads
    tftp-server flash:/phones/7906_7911/term11.default.loads alias term11.default.loads
    tftp-server flash:/phones/7914/S00105000400.sbn alias S00105000400.sbn
    tftp-server flash:/phones/7915/B015-1-0-4.SBN alias B015-1-0-4.SBN
    tftp-server flash:/phones/7916/B016-1-0-4.SBN alias B016-1-0-4.SBN
    tftp-server flash:/phones/7921/APPS-1.4.1SR1.SBN alias APPS-1.4.1SR1.SBN
    tftp-server flash:/phones/7921/CP7921G-1.4.1SR1.LOADS alias CP7921G-1.4.1SR1.LOADS
    tftp-server flash:/phones/7921/GUI-1.4.1SR1.SBN alias GUI-1.4.1SR1.SBN
    tftp-server flash:/phones/7921/TNUXR-1.4.1SR1.SBN alias TNUXR-1.4.1SR1.SBN
    tftp-server flash:/phones/7921/SYS-1.4.1SR1.SBN alias SYS-1.4.1SR1.SBN
    tftp-server flash:/phones/7921/TNUX-1.4.1SR1.SBN alias TNUX-1.4.1SR1.SBN
    tftp-server flash:/phones/7921/WLAN-1.4.1SR1.SBN alias WLAN-1.4.1SR1.SBN
    tftp-server flash:/phones/7925/APPSH-1.4.1SR1.SBN alias APPSH-1.4.1SR1.SBN
    tftp-server flash:/phones/7925/CP7925G-1.4.1SR1.LOADS alias CP7925G-1.4.1SR1.LOADS
    tftp-server flash:/phones/7925/GUIH-1.4.1SR1.SBN alias GUIH-1.4.1SR1.SBN
    tftp-server flash:/phones/7925/JSYSH-1.4.1SR1.SBN alias JSYSH-1.4.1SR1.SBN
    tftp-server flash:/phones/7925/JUIH-1.4.1SR1.SBN alias JUIH-1.4.1SR1.SBN
    tftp-server flash:/phones/7925/SYSH-1.4.1SR1.SBN alias SYSH-1.4.1SR1.SBN
    tftp-server flash:/phones/7925/TNUXH-1.4.1SR1.SBN alias TNUXH-1.4.1SR1.SBN
    tftp-server flash:/phones/7925/TNUXRH-1.4.1SR1.SBN alias TNUXRH-1.4.1SR1.SBN
    tftp-server flash:/phones/7925/WLANH-1.4.1SR1.SBN alias WLANH-1.4.1SR1.SBN
    tftp-server flash:/phones/7931/apps31.9-1-1TH1-16.sbn alias apps31.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7931/cnu31.9-1-1TH1-16.sbn alias cnu31.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7931/cvm31sccp.9-1-1TH1-16.sbn alias cvm31sccp.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7931/dsp31.9-1-1TH1-16.sbn alias dsp31.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7931/jar31sccp.9-1-1TH1-16.sbn alias jar31sccp.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7931/SCCP31.9-1-1SR1S.loads alias SCCP31.9-1-1SR1S.loads
    tftp-server flash:/phones/7931/term31.default.loads alias term31.default.loads
    tftp-server flash:/phones/7936/cmterm_7936.3-3-21-0.bin alias cmterm_7936.3-3-21-0.bin
    tftp-server flash:/phones/7937/apps37sccp.1-4-4-0.bin alias apps37sccp.1-4-4-0.bin
    tftp-server flash:/phones/7940_7960/P00308010200.bin alias P00308010200.bin
    tftp-server flash:/phones/7940_7960/P00308010200.loads alias P00308010200.loads
    tftp-server flash:/phones/7940_7960/P00308010200.sb2 alias P00308010200.sb2
    tftp-server flash:/phones/7940_7960/P00308010200.sbn alias P00308010200.sbn
    tftp-server flash:/phones/7941_7961/apps41.9-1-1TH1-16.sbn alias apps41.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7941_7961/cnu41.9-1-1TH1-16.sbn alias cnu41.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7941_7961/cvm41sccp.9-1-1TH1-16.sbn alias cvm41sccp.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7941_7961/dsp41.9-1-1TH1-16.sbn alias dsp41.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7941_7961/jar41sccp.9-1-1TH1-16.sbn alias jar41sccp.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7941_7961/SCCP41.9-1-1SR1S.loads alias SCCP41.9-1-1SR1S.loads
    tftp-server flash:/phones/7941_7961/term41.default.loads alias term41.default.loads
    tftp-server flash:/phones/7941_7961/term61.default.loads alias term61.default.loads
    tftp-server flash:/phones/7942_7962/apps42.9-1-1TH1-16.sbn alias apps42.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7942_7962/cnu42.9-1-1TH1-16.sbn alias cnu42.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7942_7962/cvm42sccp.9-1-1TH1-16.sbn alias cvm42sccp.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7942_7962/dsp42.9-1-1TH1-16.sbn alias dsp42.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7942_7962/jar42sccp.9-1-1TH1-16.sbn alias jar42sccp.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7942_7962/SCCP42.9-1-1SR1S.loads alias SCCP42.9-1-1SR1S.loads
    tftp-server flash:/phones/7942_7962/term42.default.loads alias term42.default.loads
    tftp-server flash:/phones/7942_7962/term62.default.loads alias term62.default.loads
    tftp-server flash:/phones/7945_7965/apps45.9-1-1TH1-16.sbn alias apps45.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7945_7965/cnu45.9-1-1TH1-16.sbn alias cnu45.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7945_7965/cvm45sccp.9-1-1TH1-16.sbn alias cvm45sccp.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7945_7965/dsp45.9-1-1TH1-16.sbn alias dsp45.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7945_7965/jar45sccp.9-1-1TH1-16.sbn alias jar45sccp.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7945_7965/SCCP45.9-1-1SR1S.loads alias SCCP45.9-1-1SR1S.loads
    tftp-server flash:/phones/7945_7965/term45.default.loads alias term45.default.loads
    tftp-server flash:/phones/7945_7965/term65.default.loads alias term65.default.loads
    tftp-server flash:/phones/7970_7971/apps70.9-1-1TH1-16.sbn alias apps70.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7970_7971/cnu70.9-1-1TH1-16.sbn alias cnu70.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7970_7971/cvm70sccp.9-1-1TH1-16.sbn alias cvm70sccp.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7970_7971/dsp70.9-1-1TH1-16.sbn alias dsp70.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7970_7971/jar70sccp.9-1-1TH1-16.sbn alias jar70sccp.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7970_7971/SCCP70.9-1-1SR1S.loads alias SCCP70.9-1-1SR1S.loads
    tftp-server flash:/phones/7970_7971/term70.default.loads alias term70.default.loads
    tftp-server flash:/phones/7970_7971/term71.default.loads alias term71.default.loads
    tftp-server flash:/phones/7975/apps75.9-1-1TH1-16.sbn alias apps75.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7975/cnu75.9-1-1TH1-16.sbn alias cnu75.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7975/cvm75sccp.9-1-1TH1-16.sbn alias cvm75sccp.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7975/dsp75.9-1-1TH1-16.sbn alias dsp75.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7975/jar75sccp.9-1-1TH1-16.sbn alias jar75sccp.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7975/SCCP75.9-1-1SR1S.loads alias SCCP75.9-1-1SR1S.loads
    tftp-server flash:/phones/7975/term75.default.loads alias term75.default.loads
    tftp-server flash:/phones/8961/dkern8961.100609R2-9-2-2.sebn alias dkern8961.100609R2-9-2-2.sebn
    tftp-server flash:/phones/8961/kern8961.9-2-2.sebn alias kern8961.9-2-2.sebn
    tftp-server flash:/phones/8961/rootfs8961.9-2-2.sebn alias rootfs8961.9-2-2.sebn
    tftp-server flash:/phones/8961/sboot8961.031610R1-9-2-2.sebn alias sboot8961.031610R1-9-2-2.sebn
    tftp-server flash:/phones/8961/sip8961.9-2-2.loads alias sip8961.9-2-2.loads
    tftp-server flash:/phones/8961/skern8961.022809R2-9-2-2.sebn alias skern8961.022809R2-9-2-2.sebn
    tftp-server flash:/phones/9951/dkern9951.100609R2-9-2-2.sebn alias dkern9951.100609R2-9-2-2.sebn
    tftp-server flash:/phones/9951/kern9951.9-2-2.sebn alias kern9951.9-2-2.sebn
    tftp-server flash:/phones/9951/rootfs9951.9-2-2.sebn alias rootfs9951.9-2-2.sebn
    tftp-server flash:/phones/9951/sboot9951.031610R1-9-2-2.sebn alias sboot9951.031610R1-9-2-2.sebn
    tftp-server flash:/phones/9951/sip9951.9-2-2.loads alias sip9951.9-2-2.loads
    tftp-server flash:/phones/9951/skern9951.022809R2-9-2-2.sebn alias skern9951.022809R2-9-2-2.sebn
    tftp-server flash:/phones/9971/dkern9971.100609R2-9-2-2.sebn alias dkern9971.100609R2-9-2-2.sebn
    tftp-server flash:/phones/9971/kern9971.9-2-2.sebn alias kern9971.9-2-2.sebn
    tftp-server flash:/phones/9971/rootfs9971.9-2-2.sebn alias rootfs9971.9-2-2.sebn
    tftp-server flash:/phones/9971/sboot9971.031610R1-9-2-2.sebn alias sboot9971.031610R1-9-2-2.sebn
    tftp-server flash:/phones/9971/sip9971.9-2-2.loads alias sip9971.9-2-2.loads
    tftp-server flash:/phones/9971/skern9971.022809R2-9-2-2.sebn alias skern9971.022809R2-9-2-2.sebn
    tftp-server flash:/ringtones/Analog1.raw alias Analog1.raw
    tftp-server flash:/ringtones/Analog2.raw alias Analog2.raw
    tftp-server flash:/ringtones/AreYouThere.raw alias AreYouThere.raw
    tftp-server flash:/ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml
    tftp-server flash:/ringtones/RingList.xml alias RingList.xml
    tftp-server flash:/ringtones/AreYouThereF.raw alias AreYouThereF.raw
    tftp-server flash:/ringtones/Bass.raw alias Bass.raw
    tftp-server flash:/ringtones/CallBack.raw alias CallBack.raw
    tftp-server flash:/ringtones/Chime.raw alias Chime.raw
    tftp-server flash:/ringtones/Classic1.raw alias Classic1.raw
    tftp-server flash:/ringtones/Classic2.raw alias Classic2.raw
    tftp-server flash:/ringtones/ClockShop.raw alias ClockShop.raw
    tftp-server flash:/ringtones/Drums1.raw alias Drums1.raw
    tftp-server flash:/ringtones/Drums2.raw alias Drums2.raw
    tftp-server flash:/ringtones/FilmScore.raw alias FilmScore.raw
    tftp-server flash:/ringtones/HarpSynth.raw alias HarpSynth.raw
    tftp-server flash:/ringtones/Jamaica.raw alias Jamaica.raw
    tftp-server flash:/ringtones/KotoEffect.raw alias KotoEffect.raw
    tftp-server flash:/ringtones/MusicBox.raw alias MusicBox.raw
    tftp-server flash:/ringtones/Piano1.raw alias Piano1.raw
    tftp-server flash:/ringtones/Piano2.raw alias Piano2.raw
    tftp-server flash:/ringtones/Pop.raw alias Pop.raw
    tftp-server flash:/ringtones/Pulse1.raw alias Pulse1.raw
    tftp-server flash:/ringtones/Ring1.raw alias Ring1.raw
    tftp-server flash:/ringtones/Ring2.raw alias Ring2.raw
    tftp-server flash:/ringtones/Ring3.raw alias Ring3.raw
    tftp-server flash:/ringtones/Ring4.raw alias Ring4.raw
    tftp-server flash:/ringtones/Ring5.raw alias Ring5.raw
    tftp-server flash:/ringtones/Ring6.raw alias Ring6.raw
    tftp-server flash:/ringtones/Ring7.raw alias Ring7.raw
    tftp-server flash:/ringtones/Sax1.raw alias Sax1.raw
    tftp-server flash:/ringtones/Sax2.raw alias Sax2.raw
    tftp-server flash:/ringtones/Vibe.raw alias Vibe.raw
    tftp-server flash:/Desktops/CampusNight.png
    tftp-server flash:/Desktops/TN-CampusNight.png
    tftp-server flash:/Desktops/CiscoFountain.png
    tftp-server flash:/Desktops/TN-CiscoFountain.png
    tftp-server flash:/Desktops/CiscoLogo.png
    tftp-server flash:/Desktops/TN-CiscoLogo.png
    tftp-server flash:/Desktops/Fountain.png
    tftp-server flash:/Desktops/TN-Fountain.png
    tftp-server flash:/Desktops/MorroRock.png
    tftp-server flash:/Desktops/TN-MorroRock.png
    tftp-server flash:/Desktops/NantucketFlowers.png
    tftp-server flash:/Desktops/TN-NantucketFlowers.png
    tftp-server flash:Desktops/320x212x16/List.xml
    tftp-server flash:Desktops/320x212x12/List.xml
    tftp-server flash:Desktops/320x216x16/List.xml
    tftp-server flash:/bacdprompts/en_bacd_allagentsbusy.au alias en_bacd_allagentsbusy.au
    tftp-server flash:/bacdprompts/en_bacd_disconnect.au alias en_bacd_disconnect.au
    tftp-server flash:/bacdprompts/en_bacd_enter_dest.au alias en_bacd_enter_dest.au
    tftp-server flash:/bacdprompts/en_bacd_invalidoption.au alias en_bacd_invalidoption.au
    tftp-server flash:/bacdprompts/en_bacd_music_on_hold.au alias en_bacd_music_on_hold.au
    tftp-server flash:/bacdprompts/en_bacd_options_menu.au alias en_bacd_options_menu.au
    tftp-server flash:/bacdprompts/en_bacd_welcome.au alias en_bacd_welcome.au
    tftp-server flash:/bacdprompts/en_bacd_xferto_operator.au alias en_bacd_xferto_operator.au
    radius-server attribute 31 send nas-port-detail
    control-plane
    voice-port 0/0/0
    cptone SG
    station-id number 401
    caller-id enable
    voice-port 0/0/1
    cptone SG
    station-id number 402
    caller-id enable
    voice-port 0/0/2
    cptone SG
    station-id number 403
    caller-id enable
    voice-port 0/0/3
    cptone SG
    station-id number 404
    caller-id enable
    voice-port 0/1/0
    compand-type a-law
    cptone SG
    bearer-cap Speech
    voice-port 0/1/1
    compand-type a-law
    cptone SG
    bearer-cap Speech
    voice-port 0/3/0
    trunk-group ALL_FXO 64
    cptone SG
    connection plar opx 501
    description Configured by CCA 4 FXO-0/3/0-BG
    caller-id enable
    voice-port 0/3/1
    trunk-group ALL_FXO 64
    cptone SG
    connection plar opx 501
    description Configured by CCA 4 FXO-0/3/1-BG
    caller-id enable
    voice-port 0/3/2
    trunk-group ALL_FXO 64
    cptone SG
    connection plar opx 501
    description Configured by CCA 4 FXO-0/3/2-BG
    caller-id enable
    voice-port 0/3/3
    trunk-group ALL_FXO 64
    cptone SG
    connection plar opx 501
    description Configured by CCA 4 FXO-0/3/3-BG
    caller-id enable
    voice-port 0/4/0
    auto-cut-through
    signal immediate
    input gain auto-control -15
    description Music On Hold Port
    sccp local Vlan90
    sccp ccm 172.16.100.1 identifier 1 version 3.1
    sccp
    sccp ccm group 1
    associate ccm 1 priority 1
    dial-peer cor custom
    name internal
    name local
    name local-plus
    name international
    name national
    name national-plus
    name emergency
    name toll-free
    dial-peer cor list call-internal
    member internal
    dial-peer cor list call-local
    member local
    dial-peer cor list call-local-plus
    member local-plus
    dial-peer cor list call-national
    member national
    dial-peer cor list call-national-plus
    member national-plus
    dial-peer cor list call-international
    member international
    dial-peer cor list call-emergency
    member emergency
    dial-peer cor list call-toll-free
    member toll-free
    dial-peer cor list user-internal
    member internal
    member emergency
    dial-peer cor list user-local
    member internal
    member local
    member emergency
    member toll-free
    dial-peer cor list user-local-plus
    member internal
    member local
    member local-plus
    member emergency
    member toll-free
    dial-peer cor list user-national
    member internal
    member local
    member local-plus
    member national
    member emergency
    member toll-free
    dial-peer cor list user-national-plus
    member internal
    member local
    member local-plus
    member national
    member national-plus
    member emergency
    member toll-free
    dial-peer cor list user-international
    member internal
    member local
    member local-plus
    member international
    member national
    member national-plus
    member emergency
    member toll-free
    dial-peer voice 1 pots
    destination-pattern 401
    port 0/0/0
    no sip-register
    dial-peer voice 2 pots
    destination-pattern 402
    port 0/0/1
    no sip-register
    dial-peer voice 3 pots
    destination-pattern 403
    port 0/0/2
    no sip-register
    dial-peer voice 4 pots
    destination-pattern 404
    port 0/0/3
    no sip-register
    dial-peer voice 5 pots
    description ** MOH Port **
    destination-pattern ABC
    port 0/4/0
    no sip-register
    dial-peer voice 6 pots
    description ôcatch all dial peer for BRI/PRIö
    translation-profile incoming nondialable
    incoming called-number .%
    direct-inward-dial
    dial-peer voice 50 pots
    description ** incoming dial peer **
    incoming called-number ^AAAA$
    direct-inward-dial
    port 0/1/0
    dial-peer voice 51 pots
    description ** incoming dial peer **
    incoming called-number ^AAAA$
    direct-inward-dial
    port 0/1/1
    dial-peer voice 150 pots
    description ** incoming dial peer **
    incoming called-number ^AAAA$
    port 0/3/0
    dial-peer voice 151 pots
    description ** incoming dial peer **
    incoming called-number ^AAAA$
    port 0/3/1
    dial-peer voice 152 pots
    description ** incoming dial peer **
    incoming called-number ^AAAA$
    port 0/3/2
    dial-peer voice 153 pots
    description ** incoming dial peer **
    incoming called-number ^AAAA$
    port 0/3/3
    dial-peer voice 154 pots
    description ** FXO pots dial-peer **
    destination-pattern A0
    port 0/3/0
    no sip-register
    dial-peer voice 155 pots
    description ** FXO pots dial-peer **
    destination-pattern A1
    port 0/3/1
    no sip-register
    dial-peer voice 156 pots
    description ** FXO pots dial-peer **
    destination-pattern A2
    port 0/3/2
    no sip-register
    dial-peer voice 157 pots
    description ** FXO pots dial-peer **
    destination-pattern A3
    port 0/3/3
    no sip-register
    dial-peer voice 2000 voip
    description ** cue voicemail pilot number **
    translation-profile outgoing XFER_TO_VM_PROFILE
    destination-pattern 399
    b2bua
    session protocol sipv2
    session target ipv4:10.1.10.1
    voice-class sip outbound-proxy ipv4:10.1.10.1 
    dtmf-relay rtp-nte
    codec g711ulaw
    no vad
    dial-peer voice 52 pots
    trunkgroup ALL_BRI
    corlist outgoing call-emergency
    description **CCA*Singapore*Emergency Services**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 4
    destination-pattern 999[59]
    forward-digits all
    no sip-register
    dial-peer voice 53 pots
    trunkgroup ALL_FXO
    corlist outgoing call-emergency
    description **CCA*Singapore*Emergency Services**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 3
    destination-pattern 999[59]
    forward-digits all
    no sip-register
    dial-peer voice 54 pots
    trunkgroup ALL_BRI
    corlist outgoing call-local
    description **CCA*Singapore*VoIP Services**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 4
    destination-pattern 93.......
    forward-digits all
    no sip-register
    dial-peer voice 55 pots
    trunkgroup ALL_FXO
    corlist outgoing call-local
    description **CCA*Singapore*VoIP Services**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 3
    destination-pattern 93.......
    forward-digits all
    no sip-register
    dial-peer voice 56 pots
    trunkgroup ALL_BRI
    corlist outgoing call-local
    description **CCA*Singapore*Fixed Line Service**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 4
    destination-pattern 96.......
    forward-digits all
    no sip-register
    dial-peer voice 57 pots
    trunkgroup ALL_FXO
    corlist outgoing call-local
    description **CCA*Singapore*Fixed Line Service**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 3
    destination-pattern 96.......
    forward-digits all
    no sip-register
    dial-peer voice 58 pots
    trunkgroup ALL_BRI
    corlist outgoing call-local-plus
    description **CCA*Singapore*Mobile Phones**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 4
    destination-pattern 9[89].......
    forward-digits all
    no sip-register
    dial-peer voice 59 pots
    trunkgroup ALL_FXO
    corlist outgoing call-local-plus
    description **CCA*Singapore*Mobile Phones**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 3
    destination-pattern 9[89].......
    forward-digits all
    no sip-register
    dial-peer voice 60 pots
    trunkgroup ALL_BRI
    corlist outgoing call-toll-free
    description **CCA*Singapore*Freephone Calls**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 4
    destination-pattern 91800.......
    forward-digits all
    no sip-register
    dial-peer voice 61 pots
    trunkgroup ALL_FXO
    corlist outgoing call-toll-free
    description **CCA*Singapore*Freephone Calls**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 3
    destination-pattern 91800.......
    forward-digits all
    no sip-register
    dial-peer voice 64 pots
    trunkgroup ALL_BRI
    description **CCA*Singapore*Alternate Carrier Select**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 4
    destination-pattern 915T
    forward-digits all
    no sip-register
    dial-peer voice 65 pots
    trunkgroup ALL_FXO
    description **CCA*Singapore*Alternate Carrier Select**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 3
    destination-pattern 915T
    forward-digits all
    no sip-register
    dial-peer voice 66 pots
    trunkgroup ALL_BRI
    corlist outgoing call-international
    description **CCA*Singapore*International Calls**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 4
    destination-pattern 90[0123][1-9]T
    forward-digits all
    no sip-register
    dial-peer voice 67 pots
    trunkgroup ALL_FXO
    corlist outgoing call-international
    description **CCA*Singapore*International Calls**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 3
    destination-pattern 90[0123][1-9]T
    forward-digits all
    no sip-register
    dial-peer voice 68 pots
    trunkgroup ALL_BRI
    corlist outgoing call-local
    description **CCA*Singapore*Operator**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 4
    destination-pattern 91[01].
    forward-digits all
    no sip-register
    dial-peer voice 69 pots
    trunkgroup ALL_FXO
    corlist outgoing call-local
    description **CCA*Singapore*Operator**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 3
    destination-pattern 91[01].
    forward-digits all
    no sip-register
    dial-peer voice 70 pots
    trunkgroup ALL_BRI
    corlist outgoing call-local
    description **CCA*Singapore*Service Numbers**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 4
    destination-pattern 913..
    forward-digits all
    no sip-register
    dial-peer voice 71 pots
    trunkgroup ALL_FXO
    corlist outgoing call-local
    description **CCA*Singapore*Service Numbers**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 3
    destination-pattern 913..
    forward-digits all
    no sip-register
    dial-peer voice 72 pots
    trunkgroup ALL_BRI
    corlist outgoing call-local
    description **CCA*Singapore*Service Numbers**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 4
    destination-pattern 916..
    forward-digits all
    no sip-register
    dial-peer voice 73 pots
    trunkgroup ALL_FXO
    corlist outgoing call-local
    description **CCA*Singapore*Service Numbers**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 3
    destination-pattern 916..
    forward-digits all
    no sip-register
    dial-peer voice 74 pots
    trunkgroup ALL_BRI
    corlist outgoing call-local
    description **CCA*Singapore*Service Numbers**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 4
    destination-pattern 917..
    forward-digits all
    no sip-register
    dial-peer voice 75 pots
    trunkgroup ALL_FXO
    corlist outgoing call-local
    description **CCA*Singapore*Service Numbers**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 3
    destination-pattern 917..
    forward-digits all
    no sip-register
    dial-peer voice 76 pots
    trunkgroup ALL_BRI
    corlist outgoing call-local
    description **CCA*Singapore*Service Numbers**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 4
    destination-pattern 918[0-9][1-9].
    forward-digits all
    no sip-register
    dial-peer voice 77 pots
    trunkgroup ALL_FXO
    corlist outgoing call-local
    description **CCA*Singapore*Service Numbers**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 3
    destination-pattern 918[0-9][1-9].
    forward-digits all
    no sip-register
    dial-peer voice 78 pots
    trunkgroup ALL_BRI
    corlist outgoing call-local
    description **CCA*Singapore*Service Numbers**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 4
    destination-pattern 919[1-9][1-9]
    forward-digits all
    no sip-register
    dial-peer voice 79 pots
    trunkgroup ALL_FXO
    corlist outgoing call-local
    description **CCA*Singapore*Service Numbers**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 3
    destination-pattern 919[1-9][1-9]
    forward-digits all
    no sip-register
    dial-peer voice 80 pots
    trunkgroup ALL_BRI
    description **CCA*Singapore*Special Service Code/International Prefixes**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 4
    destination-pattern 91T
    forward-digits all
    no sip-register
    dial-peer voice 81 pots
    trunkgroup ALL_FXO
    description **CCA*Singapore*Special Service Code/International Prefixes**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 3
    destination-pattern 91T
    forward-digits all
    no sip-register
    dial-peer voice 82 pots
    trunkgroup ALL_BRI
    corlist outgoing call-toll-free
    description **CCA*Singapore*Freephone Calls**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 4
    destination-pattern 9800T
    forward-digits all
    no sip-register
    dial-peer voice 83 pots
    trunkgroup ALL_FXO
    corlist outgoing call-toll-free
    description **CCA*Singapore*Freephone Calls**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 3
    destination-pattern 9800T
    forward-digits all
    no sip-register
    dial-peer voice 3150 voip
    description INTERSITE CALLS TO IOM
    translation-profile incoming IOM
    destination-pattern 09..
    session target ipv4:172.16.105.3
    incoming called-number .T
    dtmf-relay h245-alphanumeric
    codec g729br8
    dial-peer voice 3151 voip
    destination-pattern 0977
    session target ipv4:172.16.105.3
    max-redirects 10
    dtmf-relay h245-alphanumeric
    codec g729br8
    no dial-peer outbound status-check pots
    sip-ua
    telephony-service
    video
    fxo hook-flash
    max-ephones 138
    max-dn 600
    ip source-address 172.16.100.1 port 2000
    auto assign 1 to 1 type bri
    calling-number initiator
    service phone videoCapability 1
    service phone ehookenable 1
    service dnis overlay
    service dnis dir-lookup
    service dss
    timeouts interdigit 5
    system message Seaboard
    url services http://10.1.10.1/voiceview/common/login.do
    url authentication http://10.1.10.1/voiceview/authentication/authenticate.do 
    load 7914 S00105000400
    load 7915-12 B015-1-0-4
    load 7915-24 B015-1-0-4
    load 7916-12 B016-1-0-4
    load 7916-24 B016-1-0-4
    load 7906 SCCP11.9-2-1S
    load 7911 SCCP11.9-2-1S
    load 7921 CP7921G-1.4.1SR1
    load 7925 CP7925G-1.4.1SR1
    load 7931 SCCP31.9-1-1SR1S
    load 7936 cmterm_7936.3-3-21-0
    load 7937 apps37sccp.1-4-4-0
    load 7960-7940 P00308010200
    load 7941 SCCP41.9-1-1SR1S
    load 7941GE SCCP41.9-1-1SR1S
    load 7942 SCCP42.9-1-1SR1S
    load 7945 SCCP45.9-1-1SR1S
    load 7961 SCCP41.9-1-1SR1S
    load 7961GE SCCP41.9-1-1SR1S
    load 7962 SCCP42.9-1-1SR1S
    load 7965 SCCP45.9-1-1SR1S
    load 7970 SCCP70.9-1-1SR1S
    load 7971 SCCP70.9-1-1SR1S
    load 7975 SCCP75.9-1-1SR1S
    load 521G-524G cp524g-8-1-17
    load 525G spa525g-7-4-9c
    load 501G spa50x-30x-7-4-9c
    load 502G spa50x-30x-7-4-9c
    load 504G spa50x-30x-7-4-9c
    load 508G spa50x-30x-7-4-9c
    load 509G spa50x-30x-7-4-9c
    load 525G2 spa525g-7-4-9c
    load 301 spa50x-30x-7-4-9c
    load 303 spa50x-30x-7-4-9c
    load 6921 SCCP69xx.9-1-1-2-sr
    load 6941 SCCP69xx.9-1-1-2-sr
    load 6961 SCCP69xx.9-1-1-2-sr
    load 6901 SCCP6901.9-1-1-0
    load 6911 SCCP6911.9-1-1-0
    time-zone 42
    date-format dd-mm-yy
    keepalive 30 auxiliary 4
    voicemail 399
    max-conferences 8 gain -6
    call-forward pattern .T
    call-forward system redirecting-expanded
    multicast moh 239.10.16.16 port 2000
    web admin system name admin secret 5 $1$.BzE$MaR5EV3sF7La6S4Mpk02w1
    dn-webedit
    time-webedit
    transfer-system full-consult dss
    transfer-pattern 9.T
    transfer-pattern .T
    transfer-pattern 6... blind
    secondary-dialtone 9
    night-service day Sun 17:00 09:00
    night-service day Mon 17:00 09:00
    night-service day Tue 17:00 09:00
    night-service day Wed 17:00 09:00
    night-service day Thu 17:00 09:00
    night-service day Fri 17:00 09:00
    night-service day Sat 17:00 09:00
    fac standard
    create cnf-files version-stamp 7960 Sep 27 2013 16:58:13
    ephone-template  15
    url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
    softkeys remote-in-use  Newcall
    softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
    softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
    softkeys connected  Hold Endcall Trnsfer TrnsfVM Confrn Acct Park
    button-layout 7931 2
    ephone-template  16
    url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
    softkeys remote-in-use  Newcall
    softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
    softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
    softkeys connected  Hold Endcall Trnsfer TrnsfVM Confrn Acct Park
    ephone-template  17
    url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
    softkeys remote-in-use  CBarge Newcall
    softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
    softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
    softkeys connected  Hold Endcall Trnsfer TrnsfVM Confrn Acct Park
    ephone-template  18
    url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
    softkeys remote-in-use  CBarge Newcall
    softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
    softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
    softkeys connected  Hold Endcall Trnsfer TrnsfVM Confrn Acct Park
    button-layout 7931 2
    ephone-dn  9
    number BCD no-reg primary
    description MoH
    moh out-call ABC
    ephone-dn  593  dual-line
    ring internal
    number 123 no-reg primary
    pickup-group 1
    label 123
    description Sandra Lee
    name Sandra Lee
    huntstop channel
    ephone-dn  594  dual-line
    ring internal
    number 122 no-reg primary
    pickup-group 1
    label 122
    description JuatFong Kien
    name JuatFong Kien
    huntstop channel
    ephone-dn  595  dual-line
    ring internal
    number 121 no-reg primary
    pickup-group 1
    label 121
    description Brian Wittenborn
    name Brian Wittenborn
    huntstop channel
    ephone-dn  596  dual-line
    ring internal
    number 120 no-reg primary
    pickup-group 1
    label 120
    description Spare Phone
    name Spare Phone
    huntstop channel
    ephone-dn  597  dual-line
    ring internal
    number 119 no-reg primary
    pickup-group 1
    label 119
    description Brian Whilock
    name Brian Whilock
    huntstop channel
    ephone-dn  598
    number 6... no-reg primary
    description ***CCA XFER TO VM EXTENSION***
    call-forward all 399
    ephone-dn  599
    number A801... no-reg primary
    mwi off
    ephone-dn  600
    number A800... no-reg primary
    mwi on
    ephone  1
    device-security-mode none
    mac-address 20BB.C092.04C1
    ephone-template 16
    username "119" password 123456
    type 7945
    no missed-calls
    button  1:597
    ephone  2
    device-security-mode none
    mac-address F029.29E3.1D6E
    ephone-template 16
    username "120" password 123456
    type 7945
    no missed-calls
    button  1:596
    ephone  3
    device-security-mode none
    mac-address F029.29E3.15E8
    ephone-template 16
    username "121" password 123456
    type 7945
    no missed-calls
    button  1:595
    ephone  4
    device-security-mode none
    mac-address C8F9.F9D7.1489
    ephone-template 16
    username "122" password 123456
    type 7945
    no missed-calls
    button  1:594
    ephone  5
    device-security-mode none
    mac-address 20BB.C092.0871
    ephone-template 16
    username "123" password 123456
    type 7945
    no missed-calls
    button  1:593
    alias exec cca_voice_mode PBX
    banner login ^Cbanner login ^Cisco Configuration Assistant. Version: 3.2 (2). Thu Jul 25 15:13:05 SGT 2013^^C
    line con 0
    no modem enable
    line aux 0
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    speed 115200
    line vty 0 4
    transport preferred none
    transport input all
    line vty 5 100
    transport preferred none
    transport input all
    ntp master
    ntp server sg.pool.ntp.org prefer
    webvpn gateway SDM_WEBVPN_GATEWAY_1
    inservice
    webvpn install svc flash:/webvpn/anyconnect-win-3.1.04063-k9.pkg sequence 1
    webvpn context SDM_WEBVPN_CONTEXT_1
    secondary-color white
    title-color #CCCC66
    text-color black
    ssl authenticate verify all
    policy group SDM_WEBVPN_POLICY_1
       functions svc-enabled
       svc address-pool "SDM_WEBVPN_POOL_1" netmask 255.255.255.0
       svc keep-client-installed
       svc split include 172.16.100.0 255.255.255.0
       svc split include 192.168.138.0 255.255.255.0
       svc split include 192.168.104.0 255.255.255.0
       svc split include 172.16.105.0 255.255.255.0
    virtual-template 1
    default-group-policy SDM_WEBVPN_POLICY_1
    aaa authentication list sdm_vpn_xauth_ml_1
    gateway SDM_WEBVPN_GATEWAY_1
    max-users 20
    inservice
    end

    Most of the time this type of symptom is related to a routing issue or ACL.
    I am thinking more codec. 
    your dial-peer 3150 with incoming called number .T will negotiate the codec betweeen IOM and Singapore (g729br8), 
    can you paste a show call active voice   so we
    this way we can at least ascertain what codec is used from IOM to singapore e2e
    and what are the phones in singaport using internally?
    =============================
    Please remember to rate useful posts, by clicking on the stars below.
    =============================

  • Problems calling a method in another class

    I have the following method in a class called recordCalls -
    public static void objectCreated(String type, String name)
            System.out.println("An object of type " + type + " called " + name + " has been created.");
    //       addObjectToPanel(type, name);  
        }I am attempting to call addObjectToPanel(type, name) which is a method inside a class called test.
    I do not want to create an instance of test an call it like test.addObjectToPanel(type, name)
    Is there any other way of doing this.
    Thanks.

    You either have to make the method static, and call
    test.addObjectToPanel or you have to create an
    instance of test and invoke the method on that
    instance.
    I don't know what that class is supposed to do, so I
    don't know which is more appropriate.
    You should name your classes starting with capital
    letters, and Test is a very undescriptive (and hence
    bad) name for that class.I will be chaning the names of everything when the class works.
    Test contains the UI for my program.
    When I run test then my UI is runing, once I run addObjectToPanel from the record calls class it should put images into my UI,
    the problem is that each time the method is run it open up a different UI and adds an image to it instead of just adding the images to the window which is already open.

  • Problem calling applet method using IE

    I've searched through the forum and can't seem to find anything that can help me fix this. I'm trying to call an applet's method using Javascript. This is working fine under Netscape, but not IE. Everything I've read seems to indicate that I'm doing this right, but I'm getting "Object doesn't support this property or method" when I try to call the applet method from IE.
    In this example method, I'm trying to call the applet's countChars method, which should return the length of the string you pass into it. Works under Netscape 6.2, but not IE 6.0
    Here's my applet code:
    import java.lang.String;
    public class test extends java.applet.Applet {
    public static int countChars(String s) {
    return s.length();
    And my HTML
    <HTML>
    <HEAD>
    <script language="Javascript">
    function refreshApplet()
    /*     i = document.forms.myForm.TestApplet.countChars();
         document.forms.myForm.output.value=i; */
         document.forms.myForm.output.value=document.applets["TestApplet"].countChars(document.forms.myForm.input.value);
    </script>
    </HEAD>
    <BODY>
    <APPLET CODE = "test.class" WIDTH = 400 HEIGHT = 400 ALIGN = middle NAME = "TestApplet" scriptable="true">
    </APPLET>
    <br>
    <form name="myForm">
    <input type="text" name="input">
    <input type="button" value="click me" onClick="refreshApplet();">
    <hr>
    <input type="text" name="output">
    </form>
    </BODY>
    </HTML>
    Thanks in advance!
    Craig Drabik
    Sr. Programmer/Analyst
    University at Buffalo

    I have very similar problem, my applet works OK using Netscape (6.2 and 7.0), but with IE 6.0 It only works with windows XP;
    The reported error is "Object doesn't support this property or method"
    Can someone please help me to solve this problem.
    Cheers
    Horus
    This is my code:
    - I call the applet using javaScript and input the method setData with two strings.
    function graphic()
         var dataZenith;
         var dataManual;
         initVariables();
         dataZenith = graphicZENith(); //Call other Javascript functions
         dataManual = graphicManual(); //Call other Javascript functions
         document.AppletOne.setData(dataZenith,dataManual);
    I run the applet with this HTML code:
    <applet NAME="AppletOne" code="Appl.class" width="450" height="450"
    MAYSCRIPT></applet>
    //Applet code/////////////
    import java.awt.*;
    import java.awt.geom.*;
    import java.applet.*;
    import java.util.*;
    public class Appl extends Applet {
         private int [] myArray1 = new int [156];     
         private int [] myArray2 = new int [156];
         private boolean flag = false;
         // maxDataYAxesNumber es usado para dividir el eje de las Y
    public void init()
              setFont(new Font("SansSerif", Font.BOLD, 12));
              setBackground (Color.white);
              setSize(getSize());     
    // Get data and put in an array
    public void setData(String data1, String data2)
              final String DELIMITER = ",";
              final StringTokenizer theTokens1 =
                   new StringTokenizer(data1, DELIMITER);     
              final StringTokenizer theTokens2 =
                   new StringTokenizer(data2, DELIMITER);
              try
                        String dataX = data1;
                        for (int i = 0; i < 156; i++)
                        myArray1[i] = Integer.parseInt(theTokens1.nextToken().trim());
                        myArray2[i] = Integer.parseInt(theTokens2.nextToken().trim());
              catch (NumberFormatException e) {};
              flag = true; //I get the data OK
              repaint();
    public void paint (Graphics g){
    Graphics2D g2d = (Graphics2D)g;
    setData(data1, data2) ;
    if (flag == true)
                   //Call other functions to process the graphic
    else g2d.drawString(" Sorry I can get Data", 100,80);          

  • Problem calling java method from c

    Hi ,
    I'm trying to call a java method from a C program. it gives no error during compilation as well as building the application. but when i tried to create the JVM by running my application it pops up the message "The application failed to start because jvm.dll was not found. Re-installing the application may fix the problem." I tried out setting all the environment variables to include the jvm.dll(PATH set to c:\j2sdk1.4.2_05\bin;c:\j2sdk1.4.2_05\jre\bin). Still got the same message. Then i re-installed java platform once more. Even now i get the same error. I have more than one jvm.dll at locations jre\bin\client and server, oracle has some jvm.dll . Will that be a problem? if so can i remove those? which of them should be removed and how?
    The code i'm using is
    #include <stdio.h>
    #include <jni.h>
    #include <windows.h>
    //#pragma comment (lib,"C:\\j2sdk1.4.2_05\\lib\\jvm.lib")
    JavaVM jvm; / Pointer to a Java VM */
    JNIEnv env; / Pointer to native method interface */
    JDK1_1InitArgs vm_args; /* JDK 1.1 VM initialization requirements */
    int verbose = 1; /* Debugging flag */
    FARPROC JNU_FindCreateJavaVM(char *vmlibpath)
    HINSTANCE hVM = LoadLibrary("jre\\bin\\server\\jvm.dll");
    if (hVM == NULL)
    return NULL;
    return GetProcAddress(hVM, "JNI_CreateJavaVM");
    void main(int argc, char **argv )
    JavaVM jvm = (JavaVM )0;
    JNIEnv env = (JNIEnv )0;
    JavaVMInitArgs vm_args;
    jclass cls;
    jmethodID mid;
    jint res;
    FARPROC pfnCreateVM;
    JavaVMOption options[4];
    // jint (__stdcall pfnCreateVM)(JavaVM *pvm, void **penv, void *args) = NULL;
    options[0].optionString = "-Djava.compiler=NONE"; /* disable JIT */
    options[1].optionString = "-Djava.class.path=c:/j2sdk1.4.2_05/jre/lib/rt.jar"; /* user classes */
    options[2].optionString = "-Djava.library.path=lib"; /* set native library path */
    options[3].optionString = "-verbose:jni"; /* print JNI-related messages */
    /* Setup the environment */
    vm_args.version = JNI_VERSION_1_4;
    vm_args.options = options;
    vm_args.nOptions = 4;
    vm_args.ignoreUnrecognized = 1;
    JNI_GetDefaultJavaVMInitArgs ( &vm_args );
    pfnCreateVM = JNU_FindCreateJavaVM("jre\\bin\\server\\jvm.dll");
    res = (*pfnCreateVM)(&jvm,(void **) &env, &vm_args );
    // res = JNI_CreateJavaVM(&jvm,(void **) &env, &vm_args );
    /* Find the class we want to load */
    cls = (*env)->FindClass( env, "InstantiatedFromC" );
    if ( verbose )
    printf ( "Class: %x" , cls );
    /*jvm->DestroyJavaVM( );*/
    Could anyone help me solve this problem as early as possible, bcoz i'm in an urge to complete the project.
    Thanks in advance.
    Usha.

    You either have to add to the system path of where is your jvm.dll is located or explicitly link to jvm.dll call GetProcAddress to obtain the address of an exported function in the DLL.

  • Re: problem calling a method from another class

    This line here:
    app.computeDiscount(ord,tentativeBill);... You are not capturing the returned amount.
    double d = app.computeDiscount(ord,tentativeBill);

    what kind of problem r u facing?
    plz highlight the code where u r facing the problem

  • Add a column and I can't call a method

    I'm trying to make a small portal app with IBM RAD 6.0 but I'm having a wierd problem calling a method in my page code. Any help would be great.
    Here's the cod I'm using, I've got a bunch of system.outs in it to help me track down what's happening as well as some commented code of some things I'm trying. Any why here goes:
    I start a data table in the jsp like this
    <h:dataTable value="#{pc_MaintainBasisFormView.memberBasisComponents}" var="results"
                             border="0" cellpadding="2" cellspacing="0"
                             columnClasses="columnClass1" headerClass="headerClass"
                             footerClass="footerClass" rowClasses="rowClass1"
                             styleClass="dataTable" id="table1">
    later I build these two columns
    <h:column id="startdatecolumn">
                                  <f:facet name="header">
                                       <h:outputText styleClass="outputText" value="Start Date" id="startdateheader" />
                                  </f:facet>
                                  <h:inputText styleClass="inputText" id="startdate" value="#{results.effectiveDates.effectiveStartDate}"></h:inputText>
                             </h:column>
                             <h:column id="column7">
                                  <f:facet name="header">
                                       <h:outputText styleClass="outputText" value="Remove" id="remove"></h:outputText>
                                  </f:facet>
                                  <h:commandLink styleClass="commandLink" id="removelink" action="#{pc_MaintainBasisFormView.removeBasisComponent}">
                                  <h:outputText id="text6" styleClass="outputText" value=">>"></h:outputText>
                                       <f:param name="krusty" value="#{results.id}"></f:param>
                                  </h:commandLink>
                             </h:column>
    so column startdate calls does this "results.effectiveDates.effectiveStartDate"
    so results has this method
    public EffectiveDates getEffectiveDates() {
              System.out.println("in getEffectiveDates " + effectiveDates);
              //effectiveDates = (effectiveDates == null) ? new EffectiveDates():effectiveDates;
              return effectiveDates;
    and EffectiveDates has this method
    public String getEffectiveStartDate() {
              System.out.println("in getEffectiveStartDate " + effectiveStartDate);
              effectiveStartDate = (effectiveStartDate == null) ? new Date() :effectiveStartDate;
              return "dfgdfG";
    (it's supposed to return a date but I've set it to a string just to try to get it working)
    and that all works fine.
    Now the second column calls "pc_MaintainBasisFormView.removeBasisComponent" with a parameter <f:param name="krusty" value="#{results.id}">
    and removeBasisComponent is defined as
         public String removeBasisComponent() {
              System.out.println("in removeBasisComponent");
              String id = getPortletRequest().getParameter("krusty");
              System.out.println("in krusty " + id);
              return "removeBasisComponent";
    so whats the probelm? When I click the link in the second column, the method that it is tied to is never called. BUT, when I don't have the first column, the link works as I expect it to.
    can anyone point me in the right direction to solve this problem?
    Thanks in advance
    JohnL

    Hi Ruhi
    I hope this answer doesn't come too late, for some reason the forum does not let me in w/ my username & password, and won't allow me to follow the "Forgot password" procedures.
    Anyway:
    I don't have the code but I'll try to explain the problem using the info I posted originally.
    my problems start here:
    <h:inputText styleClass="inputText" id="startdate" value="#{results.effectiveDates.effectiveStartDate}"></h:inputText>
    It generates an input box with the value results.effectiveDates.effectiveStartDate. What I didn't know was that when I tried to submit the form from the link the application was silently failing. By silently I mean there was no error in the log, nothing, not a clue as to what the problem was.
    The problem turned out to be pretty simple. When the form is generated with results.effectiveDates.effectiveStartDate
    it was essentially running results.getEffectiveDates().getEffectiveStartDate() which, from my example, returned a string. That's great, no problem.
    When the form is submitted it was trying to call results.getEffectiveDates().setEffectiveStartDate(), where the method setEffectiveStartDate must take a String argument, setEffectiveStartDate(String EffectiveDate). Remember that in my example I was returning a string to the from...so I needed to accept a string as an argument to the set method.
    I hope this helps.

Maybe you are looking for

  • Error creating OIM Schema with RCU 11.1.1.5

    I am trying to create the OIM schema on Oracle 11g R2 using RCU 11.1.1.5. Both the database and RCU is being ran on Windows Server 2003 x64. The error I am getting is included. The remaining schemas are all created fine. 2011-06-21 14:58:58.321 NOTIF

  • M251nw not being recognized

    Just purchased a brand new m251nw, and I cannot get my computer operating on XP to reconize it.  I have used 2 different USB connectors, and have tried multiple usb ports on my computer.  I have rebooted, tried all kinds of different combinations all

  • MUSIC DELETED - URGENT!

    Help! I was trying to update my iBook with Mac OS 10.4, but needed more room on my HD. I noticed that there were duplicate files of all my downloaded music in a music file. It seemed to be taking up too much space, so I went to delete them and accide

  • Home Security horrible customer service

    Three exculated trouble tickets on the phone with a suppose supervisor he hangs up on me. Now I have to go through another customer service rep that will want me to let them help before I can get to the supervisor I was just hung up from

  • DataGuard Broker in 11gR2 - StaticConnectIdentifier

    Ok, I have read that in 11gR2 you no longer have the requirement of putting in a static entry in your listener.ora file with <SID>_DGMGRL if you use the Dataguard Broker parameter: StaticConnectIdentifier. I have used this new parameter and it was se