Problem in a simple webapplication

Hi
I am trying to create a basic web application where i have following
Myapp/1.jsp: A form which takes the user input
WEB-INF/classes/MyServlet.java: Creates database connection, fetches data, populates a bean and fowards the request to another jsp.
WEB-INF/classes/MyBean.java: Bean that is populated by the servlet and is used to display the data in 2.jsp
2.jsp: jsp which displays the data that has been fetched from the database using the jsp:useBean tag
But i am not able to display the same.
On submitting the form i get the following error
exception
org.apache.jasper.JasperException: Unable to compile class for JSP
Generated servlet error:
The import MyBean cannot be resolved
An error occurred at line: 2 in the jsp file: /2.jsp
Generated servlet error:
MyBean cannot be resolved to a type
An error occurred at line: 2 in the jsp file: /2.jsp
Generated servlet error:
MyBean cannot be resolved to a type
An error occurred at line: 10 in the jsp file: /2.jsp
Generated servlet error:
MyBean cannot be resolved to a type
An error occurred at line: 14 in the jsp file: /2.jsp
Generated servlet error:
MyBean cannot be resolved to a type
Following are the sources files that i m using
1.jsp
<html>
<body>
<form  method = "POST" action="servlet/MyServlet">
<table border="1">
<tr>
<td>Enter First Name</td>
<td><input type ="text" name="fname"></td>
</tr>
<tr>
<td>Enter Last Name</td>
<td><input type ="text" name="lname"></td>
</tr>
<tr>
<td align ="center" colspan ="2"> <input type = "submit" value="Get User Name"/>
</tr>
</table>
<form>
</body>
</html> 2.jsp
<%@ page import="MyBean" %>
<jsp:useBean id="myBean" type="MyBean" scope="request"></jsp:useBean>
<html>
<body>
<%!int  i = 1;%>
<form >
<table border="1">
<tr>
<td>User id</td>
<td><jsp:getProperty name="myBean" property="userid" /></td>
</tr>
<tr>
<td>Password</td>
<td><jsp:getProperty name="myBean" property="computerName" /> </td>
</tr>
<tr>
<td align ="center" colspan ="2"> <input type = "submit" value="Get User Name"/>
</tr>
</table>
<form>
</body>
</html> MyServlet.java
import java.io.*;
import javax.servlet.*;
import javax.servlet.http.*;
import java.util.*;
import java.net.*;
import java.sql.*;
public class MyServlet extends HttpServlet {
     public void doGet(HttpServletRequest request, HttpServletResponse response)   
          throws ServletException, IOException
          doPost(request, response);
     private String dbName;
     private Connection conn;
     public void init(ServletConfig  config)   
          throws ServletException
          super.init(config);
          dbName = config.getInitParameter("dbname");
          if(dbName == null)
               dbName = "PControl32";
          try{
               conn = dbHandler.getConnection(dbName);
          }catch(SQLException sql)
               System.out.println("Error while getting a connection");
          }catch(ClassNotFoundException sql)
               System.out.println("Error while getting a connection");
     public void doPost(HttpServletRequest request, HttpServletResponse response)   
          throws ServletException, IOException
          MyBean myBean = new MyBean(conn,request.getParameter("fname"),request.getParameter("lname"));
          HttpSession session = request.getSession(true);
          request.setAttribute("myBean", myBean);
          RequestDispatcher  rd = request.getRequestDispatcher("/2.jsp");
          rd.forward(request, response);
} MyBean.java
import java.sql.*;
public class MyBean
     private String userid;
     private String computerName;
     public MyBean(Connection con, String fname, String lname)
          retrieveData(con, fname, lname);
     public String getUserid()
          return userid;
     public void setUserid(String userid)
          this.userid = userid;
     public String getComputerName()
          return computerName;
     public void setComputerName(String computerName)
          this.computerName = computerName;
     public void retrieveData(Connection con, String fname, String lname)
          PreparedStatement ps = null;
          ResultSet rs = null;
          try
               ps = con.prepareStatement("select userid, computername from tauser where firstname = ? and lastname = ?");
               ps.setString(1, fname);
               ps.setString(2, lname);
               rs = ps.executeQuery();
               while(rs.next())
                    userid = rs.getString(1);
                    computerName = rs.getString(2);
               rs.close();
               ps.close();
          }catch(SQLException sqlEx)
               System.out.println("Exception occuered here" + sqlEx);
               try
                    if(rs!= null) rs.close();
                    if(ps!= null )ps.close();
               }catch(SQLException ex){}
} Thnks

as a follow up:
i took out JTextPane and put JTextArea back in and it works like a charm. Anyone have any idea how i could get my colored lines without the
lock ups??

Similar Messages

  • My problem is very simple......firefox wont allow me save my downloads to any other location than my c drive....for example i have gone into options and set sav

    ''locking this thread as duplicate, please continue at [https://support.mozilla.org/en-US/questions/986549 /questions/986549]''
    my problem is very simple......firefox wont allow me save my downloads to any other location than my c drive....for example i have gone into options and set save downloads to my e drive....but still firefox keeps saving them to my c drive....i have 4 internal hard drives in my rig....and have tried saving downloads to them all.......why this is happening i cant understand....i have tried lots of suggestions....and have re-installed firefox multiple times

    hello, there's a general regression in firefox 27 that won't allow files to download directly into a root drive. please try to create a subfolder (like ''E:\Downloads'') and set this as default location for downloads...
    also see [https://bugzilla.mozilla.org/show_bug.cgi?id=958899 bug #958899].

  • Problems with a simple stop watch program

    I would appreciate help sorting out a problem with a simple stop watch program. The problem is that it throws up inappropriate values. For example, the first time I ran it today it showed the best time at 19 seconds before the actual time had reached 2 seconds. I restarted the program and it ran correctly until about the thirtieth time I started it again when it was going okay until the display suddenly changed to something like '-50:31:30:50-'. I don't have screenshot because I had twenty thirteen year olds suddenly yelling at me that it was wrong. I clicked 'Stop' and then 'Start' again and it ran correctly.
    I have posted the whole code (minus the GUI section) because I want you to see that the program is very, very simple. I can't see where it could go wrong. I would appreciate any hints.
    public class StopWatch extends javax.swing.JFrame implements Runnable {
        int startTime, stopTime, totalTime, bestTime;
        private volatile Thread myThread = null;
        /** Creates new form StopWatch */
        public StopWatch() {
         startTime = 0;
         stopTime = 0;
         totalTime = 0;
         bestTime = 0;
         initComponents();
        public void run() {
         Thread thisThread = Thread.currentThread();
         while(myThread == thisThread) {
             try {
              Thread.sleep(100);
              getEnd();
             } catch (InterruptedException e) {}
        public void start() {
         if(myThread == null) {
             myThread = new Thread(this);
             myThread.start();
        public void getStart() {
         Calendar now = Calendar.getInstance();
         startTime = (now.get(Calendar.MINUTE) * 60) + now.get(Calendar.SECOND);
        public void getEnd() {
         Calendar now1 = Calendar.getInstance();
         stopTime = (now1.get(Calendar.MINUTE) * 60) + now1.get(Calendar.SECOND);
         totalTime = stopTime - startTime;
         setLabel();
         if(bestTime < totalTime) bestTime = totalTime;
        public void setLabel() {
         if((totalTime % 60) < 10) {
             jLabel1.setText(""+totalTime/60+ ":0"+(totalTime % 60));
         } else {
             jLabel1.setText(""+totalTime/60 + ":"+(totalTime % 60));
         if((bestTime % 60) < 10) {
             jLabel3.setText(""+bestTime/60+ ":0"+(bestTime % 60));
         } else {
             jLabel3.setText(""+bestTime/60 + ":"+(bestTime % 60));
        private void ButtonClicked(java.awt.event.ActionEvent evt) {                              
         JButton temp = (JButton) evt.getSource();
         if(temp.equals(jButton1)) {
             start();
             getStart();
         if(temp.equals(jButton2)) {
             getEnd();
             myThread = null;
         * @param args the command line arguments
        public static void main(String args[]) {
         java.awt.EventQueue.invokeLater(new Runnable() {
             public void run() {
              new StopWatch().setVisible(true);
        // Variables declaration - do not modify                    
        private javax.swing.JButton jButton1;
        private javax.swing.JButton jButton2;
        private javax.swing.JLabel jLabel1;
        private javax.swing.JLabel jLabel2;
        private javax.swing.JLabel jLabel3;
        private javax.swing.JPanel jPanel1;
        // End of variables declaration                  
    }

    Although I appreciate this information, it still doesn't actually solve the problem. I can't see an error in the logic (or the code). The fact that the formatting works most of the time suggests that the problem does not lie there. As well, I use the same basic code for other time related displays e.g. countdown timers where the user sets a maximum time and the computer stops when zero is reached. I haven't had an error is these programs.
    For me, it is such a simple program and the room for errors seem small. I am guessing that I have misunderstood something about dates, but I obviously don't know.
    Again, thank you for taking the time to look at the problem and post a reply.

  • Problem with a simple GRE tunnel

    Hello everyone:
    I have a problem with a simple GRE tunnel, and can not make it work, the problem lies in the instruction "tunnel source loopback-0" if I use this command does not work, now if I use "tunnel source <ip wan >" if it works, someone can tell me why?
    Thanks for your help
    Router 1: 2811
    version 12.4
    no service password-encryption
    hostname cisco2811
    no aaa new-model
    ip cef
    interface Loopback0
    ip address 2.2.2.2 255.255.255.255
    interface Tunnel0
    ip address 10.10.1.1 255.255.255.0
    tunnel source Loopback0
    tunnel destination 217.127.XXX.188
    interface Tunnel1
    ip address 10.10.2.1 255.255.255.0
    tunnel source Loopback0
    tunnel destination 80.32.XXX.125
    interface FastEthernet0/0
    description LOCAL LAN Interface
    ip address 192.168.1.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    duplex auto
    speed auto
    interface FastEthernet0/1
    description WAN Interface
    ip address 195.77.XXX.70 255.255.255.248
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 195.77.XXX.65
    ip route 192.168.3.0 255.255.255.0 Tunnel0
    ip route 192.168.4.0 255.255.255.0 Tunnel1
    ip nat inside source route-map salida-fibra interface FastEthernet0/1 overload
    access-list 120 deny ip 192.168.1.0 0.0.0.255 192.168.3.0 0.0.0.255
    access-list 120 deny ip 192.168.1.0 0.0.0.255 192.168.4.0 0.0.0.255
    access-list 120 permit ip 192.168.1.0 0.0.0.255 any
    route-map salida-fibra permit 10
    match ip address 120
    Router 2: 2811
    version 12.4
    service password-encryption
    ip cef
    no ip domain lookup
    multilink bundle-name authenticated
    username admin privilege 15 password 7 104CXXXXx13
    interface Loopback0
    ip address 4.4.4.4 255.255.255.255
    interface Tunnel0
    ip address 10.10.1.2 255.255.255.0
    tunnel source Loopback0
    tunnel destination 195.77.XXX.70
    interface Ethernet0
    ip address 192.168.3.251 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    hold-queue 100 out
    interface ATM0
    no ip address
    no ip route-cache cef
    no ip route-cache
    no atm ilmi-keepalive
    dsl operating-mode auto
    interface ATM0.1 point-to-point
    ip address 217.127.XXX.188 255.255.255.192
    ip nat outside
    ip virtual-reassembly
    no ip route-cache
    no snmp trap link-status
    pvc 8/32
    encapsulation aal5snap
    ip route 0.0.0.0 0.0.0.0 ATM0.1
    ip route 192.168.1.0 255.255.255.0 Tunnel0
    ip nat inside source route-map nonat interface ATM0.1 overload
    access-list 100 permit ip 192.168.3.0 0.0.0.255 192.168.1.0 0.0.0.255
    access-list 120 deny ip 192.168.3.0 0.0.0.255 192.168.1.0 0.0.0.255
    access-list 120 permit ip 192.168.3.0 0.0.0.255 any
    route-map nonat permit 10
    match ip address 120

    Hello, thank you for the answer, as to your question, I have no connectivity within the tunnel, whether from Router 1, I ping 10.10.1.2 not get response ...
    Now both routers remove the loopback, and the interface tunnel 0 change the tunnel source to "tunnel source " tunnel works perfectly, the problem is when I have to use the loopback. Unfortunately achieved when the tunnel work, this will have to endure multicast, and all the examples found carrying a loopback as' source '... but this is a step back ..
    Tunnel0 is up, line protocol is up
    Hardware is Tunnel
    Internet address is 10.10.1.1/24
    MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation TUNNEL, loopback not set
    Keepalive not set
    Tunnel source 2.2.2.2 (Loopback0), destination 217.127.XXX.188
    Tunnel protocol/transport GRE/IP
    Key disabled, sequencing disabled
    Checksumming of packets disabled
    Tunnel TTL 255
    Fast tunneling enabled
    Tunnel transmit bandwidth 8000 (kbps)
    Tunnel receive bandwidth 8000 (kbps)
    Last input 09:04:38, output 00:00:19, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/0 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    11101 packets output, 773420 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 unknown protocol drops
    0 output buffer failures, 0 output buffers swapped out

  • A small problem while running my webapplication

    Hi all,
    I'm novice to J2EE.
    I've encountered a problem while accessing the deployed module in weblogic 8.1 server.
    I'm sure that the webapplication module is deployed as i saw my module in administration console & also the status said that it is deployed.
    when i access my web application by specifying the proper server and port no and context root it is showing
    either 505 - resource not found error(http://localhost:7001/Suresh-2/Suresh) or 404 - not found error.( http://localhost:7001/Suresh-2/Suresh)
    Now let me elaborate what i've done till now.
    My webapplication folder structure is : C:\bea\user_projects\domains\mydomain\applications\Suresh\WEB-INF\classes\Sai\ServExamp.class
    My servlet is ServExamp.java
    I created a folder called "Suresh".  In that folder created another folder called "WEB-INF".  In WEB-INF created a folder called "Classes".
    Since my servlet is in package "Sai", the .class file reside in \Suresh\WEB-INF\Classes\Sai\ServExamp.class
    The source code is :
    package Sai;
    import javax.servlet.;*
    import javax.servlet.http.;*
    import java.io.;*
    public class ServExamp extends HttpServlet
    public void doPost(HttpServletRequest req,HttpServletResponse res)throws IOException
    PrintWriter out=res.getWriter();
    java.util.Date today=new java.util.Date();
    out.println("<html>"+"<body>"+
    *"<h1 align=center>HF\'s Chapter1 Servlet </h1>"*
    +"<br>"+today+"</body>"+"</html>");
    Now i'm almost done creating a web application.  Next, I constructed a simple web.xml descriptor that gives a web friendly name for my servlet, and points to
    the servlet. I constructed  web.xml descriptor file in the WEB-INF folder (C:\bea\user_projects\domains\mydomain\applications\Suresh\WEB-INF\).
    The web.xml file source is :
    *<!DOCTYPE web-app*
    PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
    *"http://java.sun.com/dtd/web-app_2_3.dtd">*
    *<web-app>*
    *<display-name>Hello World Web Application</display-name>*
    *<description>Test Servlet</description>*
    *<servlet>*
    *<servlet-name>ServExamp</servlet-name>*
    *<servlet-class>Sai.ServExamp</servlet-class>*
    *</servlet>*
    *<servlet-mapping>*
    *<servlet-name>ServExamp</servlet-name>*
    *<url-pattern>/Suresh</url-pattern>*
    *</servlet-mapping>*
    *</web-app>*
    Now I have told Weblogic that the URI /Suresh corresponds to my servlet "Sai.ServExamp".
    My Web Application is ready to be deployed at this point. I logged onto Weblogic's admin console,
    *1) clicked on deployments, then navigated to "Web Application Modules" .*
    *2) Clicked "Deploy new Web Application Module"*
    *3) Navigated to the location of your web application folder (Suresh). There was a radio button next to it indicating that I can select that folder as a*
    valid web application.
    *4) I Clicked that radio button and clicked "Target Module".*
    *5) It informed that my web application "Suresh" will be deployed to myServer.It asked a name for my web application deployment. By default it was "Suresh"*
    I clicked Deploy.
    *6) After deployment, my web application "Suresh" appeared in the "Web Application Modules" tree on the left.*
    I Clicked on "Suresh"( my web application) then clicked the testing tab, then clicked the link shown there(http://localhost:7001/Suresh-2).
    It was not showing  my servlet (showed a 403 error)
    Error - 403
    This status code is commonly used when the server does not wish to reveal exactly why the request has been refused, or when no other response is applicable.
    I think so it came b'coz I don't have an index.html or index.jsp page.
    *7)Instead,I added my servlet on to the URL it provided.*
    http://localhost:7001/Suresh-2/Suresh
    It is showing these error code: Http: 505 resource not allowed
    The page cannot be displayed
    The page you are looking for cannot be displayed because the address is incorrect.
    Please try the following:
    If you typed the page address in the Address bar, check that it is entered correctly.
    Open the localhost:7001 home page and then look for links to the information you want.
    Click  Search to look for information on the Internet.
    when i just type : http://localhost:7001/   -> Error 404 not found error
    it's showing
    Error 404--Not Found
    From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:
    *10.4.5 404 Not Found*
    The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent.
    If the server does not wish to make this information available to the client, the status code 403 (Forbidden) can be used instead. The 410 (Gone) status code
    SHOULD be used if the server knows, through some internally configurable mechanism, that an old resource is permanently unavailable and has no forwarding
    address.
    I want to run my web application & any help would be appreciated.
    Thanks in advance.
    with regards,
    S.SayeeNarayanan.
    Note: I even deployed my war file, which i got by execution of (jar cv0f webapp.war . ) command from the root directory of my web application i.e. Suresh
    Then executed my webapplication it is showing
    error-505 resource not allowed.
    --------------------------------------------------------------------------------------------

    cross posted (amazingly dukes offered in both)

  • Problems deploying a simple EJB on Weblogic 8.1 using JDeveloper

    Hey guys,
    Title says it all. First I had one problem in that I could not test the connection to the Weblogic server. I moved the weblogic.jar file into the lib/ext folder and that test worked then. After that I wrote the EJB...a very simple one...and I followed the http://dev2dev.bea.com/pub/a/2006/01/wls-jdeveloper.html?page=1 tutorial so far. But when it came time to deploy the ejb to the server, I am getting this funky error:
    ERROR: ejbc found errors while processing the descriptor for C:\oracle\jdeveloper\jdev\mywork\WeblogicApp\EchoEJB\deploy\ejb1.jar:
    ERROR: Error from ejbc: Error processing 'META-INF/ejb-jar.xml': XML document does not appear to contain a properly formed DOCTYPE header
    Honestly I am confused now...any one encounter that error?
    Thanks for all replies.
    Cheers

    So I added the DOCTYPE and now I get another error. And that is as follows:
    ERROR: Error from ejbc: Error parsing file 'META-INF/ejb-jar.xml' at line: 5 column: 219. Attribute "xmlns:xsi" must be declared for element type "ejb-jar".
    It seems that when the EJB is created, then it automatically creates the appropriate ejb-jar.xml and for some reason I guess the one it is creating this time is not good enough for Weblogic because first the DOCTYPE was missing and then after inserting the DOCTYPE I am getting the above error. Any help would be appreciated. This is the first time I am using Weblogic and this is a rather disheartening amount of progress I have made since last night! ;(
    Thanks in advance for any help. If I am doing something silly please point it out so I can learn!
    Cheers,
    Surya

  • Problems deploying a simple EJB

    I am trying to deploy a simple EJB on the 8.1.5. The bean only owns a single method that needs a unique parameter.
    No problems with compilation of source bean, home and remote interfaces, whatever the type of this parameter is.
    But when I try to deploy the jar on the server, I only succeed if the parameter of my method is a simple type (int, String ...).
    If I try the same passing a complex type (here a oracle.xml.parser.v2.XMLDocument type), I encounter this message from the deployejb tool :
    Generating EJBHome and EJBObject on the server...
    Compilation errors in oracle/aurora/ejb/gen/test_myFluxInsert/EjbObject_FluxInsert:ORA-29535: source requires recompilationjava/lang/Object: Authorization error for referenced class Oracle/xml/parser/v2/XMLDocument.java/lang/Object: Authorization error for referenced class oracle/xml/parser/v2/XMLDocument.oracle/aurora/ejb/gen/test_myFluxInsert/EjbObject_FluxInsert:50: Class oracle.xml.parser.v2.XMLDocument not found in type declaration.
    public java.lang.String insereFlux (oracle.xml.parser.v2.XMLDocument arg0)
    ^ Info: 3 errors
    And if I use an int instead of the XMLDocument parameter, everithing's right.
    Can anybody submit a no-paranormal solution ?
    Thanks.
    GH

    Parameter passing in EJB must implement Serializable. One way to solve this is:
    1. Define a new class which implements
    Serializable.
    2. Place whatever you want to pass inside
    this class.
    3. Now use the new class as your parameter.
    eg.
    public class Params implements java.io.Serializable {
    String p1;
    XmlDocmuent xdoc;,
    etc, etc
    Your program now have to use the class Params for parameter passing.
    Hope this helps.
    Tam
    null

  • Problems with a simple Midlet

    Hi , i'm trying to run a simple Midlet with a list, but appear the following errors:
    Error running executable C:\WTK22\bin\zayit
    java.net.SocketException: No buffer space available (maximum connections reached?): JVM_Bind
         at java.net.PlainSocketImpl.socketBind(Native Method)
         at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:359)
         at java.net.ServerSocket.bind(ServerSocket.java:319)
         at java.net.ServerSocket.<init>(ServerSocket.java:185)
         at java.net.ServerSocket.<init>(ServerSocket.java:97)
         at com.sun.kvem.Lime.runClient(Unknown Source)
         at com.sun.kvem.KVMBridge.runKVM(Unknown Source)
         at com.sun.kvem.KVMBridge.runKVM(Unknown Source)
         at com.sun.kvem.midp.MIDP$4.run(Unknown Source)
    the code of the Midlet is so simple and i don't know what happen.
    i hope that you can help me
    thanks

    the code is:
    package componentes;
    import javax.microedition.lcdui.*;
    import javax.microedition.midlet.*;
    public class InterfazMid extends MIDlet implements CommandListener {
    private Display display;
    private List menu;
    private List lista;
    private TextBox cajaTexto;
    private Form form;
    private DateField campoFecha;
    private Gauge indicador;
    private TextField campoTexto;
    private Ticker ticker;
    private Alert aviso;
    private Image imagen;
    private Command atras;
    private Command menuPrincipal;
    private Command salir;
    String menuActual = null;
    public InterfazMid() {
    form = new Form( "Formulario" );
    indicador = new Gauge( "Indicador",false,50,20 );
    campoTexto = new TextField( "Campo de texto","abc",40,0 );
    ticker = new Ticker( "Componentes de la intefaz MIDP" );
    aviso = new Alert( "Aviso Sonoro" );
    imagen = Image.createImage( "/error.png" );
    } catch( Exception e ) {}
    atras = new Command( "Atr�s",Command.BACK,0 );
    menuPrincipal = new Command( "Men� Ppal",Command.SCREEN,1 );
    salir = new Command( "Salir",Command.STOP,2 );
    protected void startApp() {
    display = Display.getDisplay( this );
    menu = new List( "Interfaz MIDP",Choice.IMPLICIT );
    menu.append( "Caja de texto",null );
    menu.append( "Fecha",null );
    menu.append( "Lista",null );
    menu.append( "Aviso",null );
    menu.append( "Formulario",null );
    menu.addCommand( salir );
    menu.setCommandListener( this );
    menu.setTicker( ticker );
    mainMenu();
    protected void pauseApp() {}
    protected void destroyApp( boolean flag ) {}
    public void mainMenu() {
    menuActual = "Men� Ppal";
    display.setCurrent( menu );
    public void testTextBox() {
    cajaTexto = new TextBox( "Teclea algo:","",10,TextField.ANY );
    cajaTexto.setTicker( new Ticker("Probando TextBox") );
    cajaTexto.addCommand( atras );
    cajaTexto.setCommandListener( this );
    cajaTexto.setString( "ABC" );
    display.setCurrent( cajaTexto );
    menuActual = "texto";
    public void testList() {
    lista = new List( "Seleciona:",Choice.MULTIPLE );
    lista.setTicker( new Ticker("Probando List") );
    lista.addCommand( atras );
    lista.setCommandListener( this );
    lista.append( "Opci�n 1",null );
    lista.append( "Opci�n 2",null );
    lista.append( "Opci�n 3",null );
    lista.append( "Opci�n 4",null );
    display.setCurrent(lista);
    menuActual = "lista";
    public void testAlert() {
    aviso.setType( AlertType.ERROR );
    aviso.setImage( imagen );
    aviso.setString( " ** ERROR **" );
    display.setCurrent( aviso );
    public void testDate() {
    java.util.Date fecha = new java.util.Date();
    campoFecha = new DateField( "Hoy es: ",DateField.DATE );
    campoFecha.setDate( fecha );
    Form f = new Form( "Fecha" );
    f.append( campoFecha );
    f.addCommand( atras );
    f.setCommandListener( this );
    display.setCurrent( f );
    menuActual = "fecha";
    public void testForm() {
    form.append( campoTexto );
    form.append( indicador );
    form.addCommand( atras );
    form.setCommandListener( this );
    display.setCurrent( form );
    menuActual = "form";
    public void commandAction( Command c,Displayable d ) {
    String label = c.getLabel();
    if( label.equals("Salir") ) {
    destroyApp( true );
    notifyDestroyed();
    else if (label.equals("Atr�s")) {
    if( menuActual.equals( "lista" ) ||
    menuActual.equals( "texto" ) ||
    menuActual.equals( "fecha" ) ||
    menuActual.equals( "form" ) ) {
    mainMenu();
    else {
    List l = (List)display.getCurrent();
    switch( l.getSelectedIndex() ) {
    case 0:
    testTextBox();
    break;
    case 1:
    testDate();
    break;
    case 2:
    testList();
    break;
    case 3:
    testAlert();
    break;
    case 4:
    testForm();
    break;
    the code is so simple. i think that the problem is on the j2me wirless toolkit but i don't know.
    thank you
    bye

  • Problem with XI simple scinario

    Hi Friends,
    I am new in XI, I am working on simple xi scenario. whn i create sales order i wan to send order confirmation . for that i am using ORDRSP. I had done all the ale settings and able to generaet idoc and send it to XI . Now the problem is that,once the idoc is sent from R/3 system, on the XI system I am not able to see it in transaction SXMB_MONI. I am able to c that idoc in transaction WE02,with error in XI system.
    So please let me knw,how to solve this.
    Regards,
    Brij.....

    hi,
    plz once check in idx5 in xi server..
    if u r able to see u r idoc in that then u can confirm u er IDOC reached to XI server..
    if  IDOC is not there in IDX5, plz do check in RFC destination remote connection, if u get the EASY ACCESS MENU of the XI system, then RFC destination is fine.
    and once check port and partner profile also....
    if u check all these things.. hope u r problem will be solved.
    Thanks,
    Madhav
    Note:Points if useful

  • Problems making a simple chart

    Im sure this is quite simple but im trying to produce a simple chart with an x and y value. The x and y's are columbs from a table.
    I have 2 problems:
    Firstly it makes a chart with 2 lines, 1 of which is just along the x axis.
    2 the x axis isnt proportional. The x values are 0.0016, 0.0004, 0.0002, 0.0001 they will be spaced the same distance apart so producing a curved line instead of a straigh line that it should.
    Any help would be really good
    Thank you everyone
    Stuart

    Stuart,
    I'm glad that my answer was helpful. Sorry I didn't have time to elaborate at the time.
    Scatter is for plotting values vs. values. All the other chart types plot a value vs. a text label. New in iWork 09, you can connect the points in a scatter chart, and you can add a best fit curve. In an 09 Scatter chart you can have multiple series, as with 08, and also as with 08, you can have only one Y-Axis. Unfortunately the 2-Axis chart option is a Category Chart.
    Regards,
    Jerry

  • Problems deploying a simple Infobus Applet

    Hi,
    I am testing the infrastructure required to build an Infobus
    Applet for our Web-based application using the Business Component
    Framework in JDeveloper 3.0.
    I have created a simple project based on the Scott schema, which
    uses the Java Business Object framework to define Entity Objects,
    Views, etc. for the Dept and Emp tables.
    I have then created, using the Wizard, an Infobus Data Form to
    create a master-detail Applet to display Employees within a
    Department based on the above mentioned View Object. This works
    fine when running within JDeveloper3.
    However, when I try to deploy the applet to our Oracle
    Application Server as a simple HTML file and JAR file (not using
    EJB, etc. as we currently only have OAS 4.0.7.1 - waiting for OAS
    4.0.8 to be available for download), the applet fails to start.
    I have installed the Java Plug-in 1.2.2 from Sun as documented as
    I'm using Swing controls.
    After much frustration with the online 'Help', I managed to
    create a deployment profile which included the appropriate
    archives (See Packaging Source and Deployment Files in Help -
    still refers to 'Rules' and 'Sources' pages ala JDeveloper 2 NOT
    3.0).
    Using the Console feature of the Java Plug-in, I was able to see
    the progress of the Applets classes being loaded. It gets to the
    point where it's trying to load the ResTable classes in
    dacf.zip as found in the path:
    oracle\dacf\control\swing\find
    At this point, it just stops and nothing else happens.
    Do I need to explicitly localize my Infobus Applet because I'm in
    the United Kingdom and my PC has that as it's Regional Setting?
    That is, do I need to define a ResTable_en_GB version of this
    class?
    Also, in attempting to create a localized version, I had errors
    with JDeveloper stating that the text for the FIND_HELP_MESSAGE
    exceeds the limit of JDeveloper (meaning that it's too long and I
    needed to replace it with a shorter string). Could this be the
    problem in the first place?
    I have not been able to get the Applet to get beyond this point,
    although I'm still trying the localization to Great Britain.
    I know this is already a LONG email, but here is an extract from
    the Java Console after which nothing else happens:
    CacheHandler file name: null
    Opening
    http://dell_server.wsp.co.uk:4005/oracle/dacf/control/swing/find/
    ResTable_en.properties no proxy
    Opening
    http://dell_server.wsp.co.uk:4005/oracle/dacf/control/swing/find/
    ResTable_en.properties with cookie
    "SITESERVER=ID=8e93834f82ef0710b78e5a4b087d6eed".
    Regards
    Gene Schneider
    null

    Parameter passing in EJB must implement Serializable. One way to solve this is:
    1. Define a new class which implements
    Serializable.
    2. Place whatever you want to pass inside
    this class.
    3. Now use the new class as your parameter.
    eg.
    public class Params implements java.io.Serializable {
    String p1;
    XmlDocmuent xdoc;,
    etc, etc
    Your program now have to use the class Params for parameter passing.
    Hope this helps.
    Tam
    null

  • Problem w/saving simple image as .png

    Hello:                                                                                                                            Level: Newbie'ish   OS: Win7 64bit   PS: CS6
    I have been making a simple image of a 300 by 100 rounded rectangle and then adding various layer styles. Basically I am makeing mobile headers which will be used for mobile websites.
    Today I was reviewing  a few that I have made and noticed that when I open them in their .png format and then create a selection around one (Ctrl + Click) that the lower right coner is not being selected as rounded but as a point and so when I copy and then paste it into a new document it has three rounded corners and one somewhat visible pointed corner.  ?? ??
    The file has a BG layer and two shape layers (or sometimes just one shape layer). I select the layers and then merge them together and turn off the BG layer beofore I save them for the web. I have also tried just saving the file as a .png w/out merging the layers but no matter how I go about saving the file(s) most of the time one corner is saved w/that annoying and imperfect sharp corner.
    Any ideas? Your time is greatly appreciated ~ Thanx a Bunch!!

    Hey c.pf...
    sorry for just getting back ~ the holiday season has me run'n Crazy.
    any way, i figured out my problem. i hadn't realized that i accidentally clicked the outer glow option and it was so faint that i couldn't see it all that well or actually ~ at all until i went back through the LS ...
    so, when i would save the image (mobile header) it was including or making room for the outer glow
    funny how something so simple can be overlooked.
    well, sorry for bothering ya over nothing ~ but i really appreciate your willingness to help me out
    hope all is well!! thanx again!

  • Please help! iMac randomly disconnects from internet. Wi-fi via BT hub. I am baffled by all of the suggestions when I google this problem! Any simple solution? Thanks!

    Please Help! My brand new imac randomly disconnects from the internet. We have a BT hub - wi-fi. I have googled this issue and see that it is relatively common and it is incredibly frustrating. sadly, I have been unable to wade through the suggestions others have had as to how to solve the problem as i have no technical knowledge and am basically baffled by the list of suggestions. Please can anyone explain why this happens and what to do? It is fairly simple to reconnect each time but it is driving me mad having to. It generally happens when the computer is asleep but sometimes in the middle of doing something. Thanks!!!!!!

    What frequency, security are you running? It would have been helpful if you specified in the first post.
    Did you create a new Location in System Preferences->Network pane, Location pull-down. Create a new custom named Location. Then after you create that new Location click on the 'Apply' button to save that new custom named Location. See if that helps.
    Lastly a lot of people have reported that WEP in lion is problmatic and it would be better to use WPA2 if you can.

  • Problem building a simple 2x VI application

    Hello,
    After 5 years of pause (LV version 6.1) I tried to build a simple application under version 8.2. the application is consisted of 2 simple VIs - the 1st gathers some keyboard input and passes some strings and a VISA Resource (COM port ID) to the 2nd that should capture single chars from a specified COM port and executes simple command lines. The 1st VI triggers the 2nd by passing the corresponding parameters. The problem is when I build the standalone EXE with the 1st VI as a top - the 2nd one fails to open its window allthough its instance shows up on the task bar!?
    I guess I am messing with the build-settings but can't find a sollution. Can anybody suggest one?
    Thanks in advance,

    Hi golu...,
    have you set the vi properties correctly? The 2nd vi is probably called as simple subvi...
    So in the window appearance properties you have to enable 'show front panel when called' and 'close front panel when finished'!
    Best regards,
    GerdW
    CLAD, using 2009SP1 + LV2011SP1 + LV2014SP1 on WinXP+Win7+cRIO
    Kudos are welcome

  • Problem with a simple Crystal 10 report

    Help please!!
    I am writing what should be a simple report in Crystal 10 which is acting oddly.
    The report is built on 3 tables which sit on a SQL database and are linked through ODBC views. The tables are property, referral and incident and the property table is the one that exists in all cases. All three have a Property ID and the other two tables are linked to the property table through two full outer join connections. A property can have a referral or an incident or both.
    I just want to create a report which lists all the unique properties which have a referral or an incident which has been created within a particular timescale.
    The filter I am using is:
    {est_property.est_address_postalcode} = "AB12 5NX" and
    (({est_referral.CreatedOn}>={?Start date}) and ({est_referral.CreatedOn}<={?End date}))
    or
    (({Incident.CreatedOn}>={?Start date})and ( {Incident.CreatedOn}<={?End date} ))
    Note the 'AB12 5NX' bit is just to speed the testing process up as the databases that I am querying are large.
    The version I am running is 10.0.0.533 although I am currently (very slowly) downloading SP6.
    Thanks,
    John

    I have made some progress on this. I think the problem is because the filter fails when the tables it is querying have Nulls in them.
    I have just tried building the filter again with an "if the 'created on' field in the referral table is NULL then just query on the incident table" type of query:
    if isnull({est_referral.CreatedOn})=FALSE then
        {est_property.est_address_postalcode} = "AB12 5NX" and
        ({?Start date}<={est_referral.CreatedOn} and {est_referral.CreatedOn}<={?End date})
        or
        {est_property.est_address_postalcode} = "AB12 5NX" and
        ({?Start date}<={Incident.CreatedOn}and {Incident.CreatedOn}<={?End date} )
    else
        {est_property.est_address_postalcode} = "AB12 5NX" and
        ({?Start date}<={Incident.CreatedOn}and {Incident.CreatedOn}<={?End date} )
    This seems to work but seems to be very heavy on the processing. It would also require a very complex bit of coding when I start building the proper query which actually requires four sub-tables to be queried rather than ust two!
    So still help required!
    Thanks.

Maybe you are looking for