QoS marking problem

I have a trouble to implement dynamic QoS between two sites (Site A, and site B) across low speed WAN link (512k). On each site I have Cisco 1921 router. Most important app is Oracle. Because of slow speed WAN links, I want to avoid exact bandwith reservation for Oracle. I only reserve 5% bandwith for network control(icmp, ssh, telnet...) and want configure next Qos scenario:
1. If Oracle traffic exist on a network, it must have 70% of link speed guaranteed, all other apps (e.g mail, file share, ftp) use rest of the bandwith.
2. If there isn't Oracle traffic on a network, all other apps can use all available bandwith.
Issue descrtption:
I used all Cisco guides, but when I implemented this on production it simply didn't work. There is no any significant improvement after implementing this (when I start network file sharing accross wan link, Oracle becomes etremly slow.). Do anyone hadsimilar problem?
Here is configuration wich I trying to implement:
ACL-s and class-maps used to mark traffic:
access-list 119 remark ###QoS-MGMT###
access-list 119 permit tcp any any eq 22
access-list 119 permit tcp any any eq telnet
access-list 119 permit icmp any any
access-list 120 remark ###QoS-DB_ORA###
access-list 120 permit ip any host 10.100.40.30
access-list 120 permit tcp any any eq 1521
class-map match-any Oracle
match access-group 120
class-map match-any Mgmt_Traffic
match access-group 119
policy-map LAN
class Mgmt_Traffic
  set dscp 7
class Oracle
  set dscp 5
class class-default
  set dscp default
policy-map WAN
class Oracle
  priority percent 70
class Mgmt_Traffic
  priority percent 5
Implementation of this policy maps (both sites are identical):
interface FastEthernet0/0
description WAN
bandwidth 512
service-policy output WAN
interface FastEthernet0/1
description LAN
bandwidth 512
service-policy input LAN
Thanx for help!

Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
Any other idea?
Yes, several.
First, we might confirm whether CBWFQ is working as configured.  To be precise, when TAC "showed me" shaped/child CBWFQ worked correctly under 15.x, it was a specific 15.x something (I'll have to find what they actually used) and I took their word for it, i.e. I didn't actually confirm it operated correctly as our internal IOS usage standards don't (yet) allow 15.x code.
Easiest way to confirm correct operation, use a traffic generator to push 1 Mbps to the two classes and see if overall rate is limited to 512 Mbps and bandwidth proportions are 70/30.
I note you wrote you did try the 2nd LLQ policy, correct?  Well, it too should be tested to insure your rate is limited to 512 and 70/30 bandwidth split.  (You can also try a variation of the last w/o any FQ.)
If above tests confirm correct operation, then there are numerous reasons why you're not obtaining the performance you expect.  For example, your WAN vendor could have a misconfiguration or even a technical issue they're unaware of (my experience the former is rare, say less than 1% of the time, the latter is very, very rare but I've seen such too [e.g. 3 months of complaining to a tier one vendor, Ethernet performance not quite right, they finally found cause - buggy firmware on one of their line cards]); or the nature of your traffic you're testing with causes "unexpected behavior" (e.g. UDP vs. TCP?); or L2 rates vs. L3 rates (touched on that in my prior post); application sensitivity (e.g. don't know about Oracle, but some earlier version of SAP were extremely "fragile"); or etc.
So, first confirm CBWFQ is working as it should.  If not, you'll need to work with TAC.  If it's working correctly, we can start to eliminate other possible issues.

Similar Messages

  • Has the clip marker problem been resolved in Premiere cs6?

    Has the clip marker problem been resolved in Premiere CS6.  As of early July, it was not!  Navigating, synchronizing clips seems impossible.

    Explain your problems with markers in this feature request form: http://www.adobe.com/go/wish
    Sorry, that's all I can offer you.
    TrueFriction wrote:
    I'd just like to add my voice to the chorus here - namely that Marker functionality for CS6 is extremely lacking, and has made my workflow for various tasks much longer and more tedious.
    In my case I'm trying to match professional footage of a concert with audience-submitted cell phone footage. The pro footage can't be synced with the non-pro footage via Pluraleyes because the cell phone audio is way too high to be analyzed properly. Hence I need to manually sync, which I can't do efficiently because I can't put clip markers on the pro footage once it's synced in pluraleyes and sent back into Premiere, because it only exists in a sequence.
    I have no idea why Adobe would remove a function used daily by its editors, one that was simple and reliable, for no reason.
    And what's puzzling is that there's been not even an acknowledgement of the issue from anyone at Adobe for 8 months.
    This doesn't make any sense. Usually customer service from Adobe is much better than this. Why no action on this one issue?
    BTW, if you want to add Clip Markers to clips in the Timeline, you can set a keyboard shortcut for that.

  • QOS Marking on 9ESW router module

    Has anyone ever tackled marking
    on an 9ESW module that gets installed in a router ?
    Either vlan based or something.  We got a ton's of these for small site and would want to get marking going so that queueing gets done properly on those sites.
    Thanks

    Hi Bruno,
    QoS marking seems supported on that module, see:
    http://www.cisco.com/en/US/prod/collateral/routers/ps5853/prod_white_paper0900aecd8064c9f4_ps5855_Products_White_Paper.html
    There is even an example that attach a service policy to a vlan interface for marking.
    Regards,
    Raphael

  • Trim Mark problem. CS5 Any suggestions?

    I am setting out A4 front and back covers as one piece of (A3+bleed) artwork to be reproduced by digital printing. After printing, the covers will be trimmed on four sides then wire bound.
    I set up artwork with covers side by side with 10mm in centre to allow 5mm trim for each spine. My problem is that Illustrator CS5 adds trims on the proof which do not include a facility to specify centrefold trims or even a centreline. AI assumes all artwork will be an single rectangle and only puts trims on the four corners.
    I can create two covers as two separate pieces of artwork with suitable bleed and trims, but then I must proof front and back separately and the printer must re-position each cover side by side arranging trims with his pre-press software. That is inefficient.
    I simply want to hand over a facsimile proof and a complete .pdf fiIe with correct trims. I tried drawing the spine trims I required, but AI ignored them for proofing, even with the desk top enlarged to accommodate the trim marks. The Print dialogue box trims take priority. Has Adobe missed a trick here or am I overlooking a set-up requirement?
    I considered taking the artwork into InDesign but ID also treats my artwork as one page with or without a centrefold, according to how I specify the pages.
    But for the fold facility, the ID Print dialogue behaves the same as AI, as you might expect.
    Can anyone offer suggestions other than the separate artwork option I have described?

    Dear TerraAustralis,
    I work in CS5 and I am trying to create trim marks so that I can manually adjust it after and create more of them since I have a multiple itmes to trim.
    I get an error message when I try to create the mark:
    I have a rectangle with or with stroke or fill (it does the same error), I selct Object-Trim marks
    and I get this: <The filter cannot complete because of an unknown error>
    NESS
    what can I do to be able to edit the marks without making them all manually like before...
    since the Crop marks command does not allow us to manipulate the marks?
    Thank you in advance for your help.
    cc

  • Trim Mark Problem. AI & ID CS5. Any Suggestions?

    I am setting out A4 front and back covers as one piece of (A3+bleed) artwork to be reproduced by digital printing. After printing, the covers will be trimmed on four sides then wire bound.
    I set up artwork with covers side by side with 10mm in centre to allow 5mm trim for each spine. My problem is that Illustrator CS5 adds trims on the proof which do not include a facility to specify centrefold trims or even a centreline. AI assumes all artwork will be an single rectangle and only puts trims on the four corners.
    I can create two covers as two separate pieces of artwork with suitable bleed and trims, but then I must proof front and back separately and the printer must re-position each cover side by side arranging trims with his pre-press software. That is inefficient.
    I simply want to hand over a facsimile proof and a complete .pdf fiIe with correct trims. I tried drawing the spine trims I required, but AI ignored them for proofing, even with the desk top enlarged to accommodate the trim marks. The Print dialogue box trims take priority. Has Adobe missed a trick here or am I overlooking a set-up requirement?
    I considered taking the artwork into InDesign but ID also treats my artwork as one page with or without a centrefold, according to how I specify the pages.
    But for the fold facility, the ID Print dialogue behaves the same as AI, as you might expect.
    Can anyone offer suggestions other than the separate artwork option I have described?

    TerraAustralis wrote:
    I can create two covers as two separate pieces of artwork with suitable bleed and trims, but then I must proof front and back separately and the printer must re-position each cover side by side arranging trims with his pre-press software. That is inefficient.
    Have you asked your printer about this?  I'm a printer and if you gave me a file laid up on a page with your trim marks  from Illustrator the first thing I'd do it place it in Indesign to strip them off and give me individual pages so I could impose it with my pre press software! 
    Check first...Adobe hasn't missed a trick, it's how the printing world expects it's files.

  • E3000 QoS performance problem

    I am trying to test and document the performance of QoS. I have an E3000 with firmware version 1.0.04.
    I have tried various traffic generators (like Netperf), and settled on D-ITG; It can send, receive, and report on many different traffic streams.
    I have set up QoS rules on the E3000: port 12865 Low priority, port 12875 High priority. The traffic flow is from computers on my LAN, through the internet port on the router to a WAN addressed computer in the same room.
    Cisco documentation states that QoS works only on "upstream" traffic, hence the particular traffic flow.
    My problem is that the QoS appear not to prioritise when enabled.
    Stream 1 on port 12865 achieves ~45Mbps, stream 2 on a seperate computer simultaneously on port 12875 achieves ~45Mbps also.
    I have tried both TCP and UDP traffic.
    Can anyone suggest why? Has anyone else found issues with QoS?

    Do you have a similar set up? Can you tell me how you have approached the problem? Have you got any different results?

  • How to fix exclamation mark problem

    Basically since I updated to iTunes 11 and I went to make a new cd to listen to in the car a lot of my songs have got an exclamation mark next to them and says it can't find the original file so since I HATE the new iTunes i decided to downgrade back to iTunes 10. what ever it was before the update came out to see if that would fix the problem but no that didn't work, so I've since been looking all over Google to try and find a solution to this but everything I found was mostly about moving the iTunes library and how to fix that problem but in my case that isn't the problem at all as I haven't moved the library anywhere, I did find a post about transferring purchases from my iPhone to iTunes so I did that thinking it would fix the problem as all the songs that have the exclamation mark next to them are on my iPhone and play back perfectly fine but iTunes would only transfer my app's not my music, is there a way to change this? Or if anyone else knows how to fix this problem in a different way I would very much appreciate the answer to this problem as it's driving me insane!
    Thanks in advance
    Jordan

    This happens if the files are no longer where iTunes expects to find them. Possible causes are that you or some third party tool has moved, renamed or deleted the files, or that the drive they live on has had a change of drive letter. It is also possible that iTunes has changed from expecting the files to be in the pre-iTunes 9 layout to post-iTunes 9 layout, or vice-versa, and so is looking in slightly the wrong place.
    Select a track with an exclamation mark, use CTRL+I to Get Info, then cancel when asked to try to locate the track. Look on the summary tab for the location that iTunes thinks the file should be. Now take a look around your hard drive(s). Hopefully you can locate the track in question. If a section of your library has simply been moved, or a drive letter has changed, it should be possible to reverse the actions.
    Alternatively, as long as you can find a location holding the missing files, then you should be able to use my FindTracks script to reconnect them to iTunes. See this post for a detailed explanation of what the script does.
    If your media is scattered around you may need to repeat the search using each of the different locations where you have stored things.
    tt2

  • Alv Mark Problem

    Hi ı have problem with alv is_layout when ı set  gs_layo-box_fieldname  = 'MARK' its ok synt. correct and program run healthy but in alv ı want to batch input selected row it goes to dumb. When ı removed 'mark' it is working
    here is the code
    FORM alv.
      gv_repid = sy-repid.
      data: l_cat like line of ct_fieldcat.
      define mac_alv.
        l_cat-col_pos = &1.
        l_cat-fieldname = &2.
        l_cat-seltext_s = l_cat-seltext_m = l_cat-seltext_l = &3.
        append l_cat to ct_fieldcat.
      end-of-definition.
      refresh ct_fieldcat.
      mac_alv: 1  'MATNR' 'MATNR'  ,
               2  'MBRSH' 'MBRSH',
               3  'MTART' 'MTART',
               4  'MAKTX' 'MAKTX',
               5  'MEINS' 'MEINS',
               6  'MATKL' 'MATKL',
               7  'WERKS' 'WERKS',
               8  'MTPOS' 'MTPOS',
               9  'EKGRP' 'EKGRP'.
      gs_layo-zebra = 'X'.
      gs_layo-colwidth_optimize = 'X'.
    gs_layo-box_fieldname  = 'MARK'.
      call function 'REUSE_ALV_GRID_DISPLAY'
        EXPORTING
          i_bypassing_buffer       = 'X'
          i_callback_program       = sy-repid
          is_layout                = gs_layo
          I_CALLBACK_PF_STATUS_SET = 'SET_PF_STATUS'
          I_CALLBACK_USER_COMMAND  = 'USER_COMMAND'(003)
          it_fieldcat              = ct_fieldcat
          it_sort                  = gt_sort[]
          i_grid_settings          = gs_glay
          i_save                   = 'A'
        TABLES
          t_outtab                 = gt_itab[]
        EXCEPTIONS
          program_error            = 1
          others                   = 2.
    ENDFORM.                    " ALV
    *&      Form  standard_fullscreen
    form SET_PF_STATUS using rt_extab type slis_t_extab.
      set pf-status 'GUI'.
    endform.                    "standard_fullscreens
    *&      Form  USER_COMMAND
    FORM USER_COMMAND USING R_UCOMM LIKE SY-UCOMM
                   RS_SELFIELD TYPE SLIS_SELFIELD.
      CASE R_UCOMM.
        WHEN 'BATCH'.
       trigger =  RS_SELFIELD-value.
    IF RS_SELFIELD-SEL_TAB_FIELD eq '1-'.
    perform batch_input.
    ENDIF.
      ENDCASE.
    ENDFORM.

    Hi,
    Please add the 'MARK' field to the catlog as well.  with an additional property of checkbox.
               fieldcat-checkbox  = ' X'.
    Thanks & Regards
    Suresh Nair

  • Question Mark Problem Startup

    my problem is my audio wasnt working and i had stuck cd the i decided to turn the machine off and reset the pram so i did and it was loading with the apple logo and spinning wheel for about 10 min so i decide i would to a force shut down and turn it back on and when i did there was no logo or spinning wheel so i tried the option button button it is just a cursor i got the cd out now but i still have the grey screen for about ten min and the question mark folder logo

    That folder with the question mark icon means that the MacBook can't find the boot directory. That can either mean it can't find the hard drive or the Operating System data on the hard drive is somehow corrupted.
    Put your install DVD into the optical drive (CD/DVD drive) and reboot. As soon as you hear the boot chime, hold down the "c" key on your keyboard (or the Option key until the Install Disk shows up). That will force your MacBook to boot from the install DVD in the optical drive.
    When it does start up, you'll see a panel asking you to choose your language. Choose your language and press the Return key on your keyboard once. It will then present you with an Installation window. Completely ignore this window and click on Utilities in the top menu and scroll down to Disk Utility and click it. When it comes up is your Hard Drive in the list on the left?
    If it is then click on the Mac OS partition of your hard drive in the left hand list. Then select the First Aid Tab and run Repair Disk. The Repair Disk button won't be available until you've clicked on the Mac OS partition on your hard drive. If that repairs any problems run it again until the green OK appears and then run Repair Permissions. After repairing use Startup Disk from the same menu to choose your hard drive for restarting from your hard drive.
    If your hard drive isn’t recognized in Disk Utility then your hard drive is probably dead.

  • Quotation mark problem!

    Hello everyone! I have a unusual problem to address. I have recently gotten into HTML coding, and I am using a navigation menu and it requires quotation marks. As seen in the picture on the top, TextEdit keeps inverting them, thus ruining my code! I need the quotation marks to be like the ones at the bottom of the photo for the code to compile correctly.

    I found a solution! Turn off "smart quotes," in the keyboard settings!

  • InDesign CS4 quotation marks problems in epub

    I use InDesign CS4 to create epub files.  Occassionally I will have what I guess you would call a translation error from the InDesign file to the epub file.  Quotation marks and apostrophe marks do not translate at all.  It doesn't happen with every file.  If I combine the bad export file with another file the quotation marks will be just fine.  I have even tried inserting a special character from the Type menu and it does the same thing.
    Example:
    How it shows in the InDesign file -
    You’re a fool, Grey.
    "Miss Steele. What a pleasant surprise."
    How it shows up in the epub file:
    You’re a fool, Grey.
    “Miss Steele. What a pleasant surprise.”
    Does anyone have any suggestions to keep this from happening?

    My suggestion is to upgrade to CS5.5. The epub capabilities are light years ahead of CS4.
    That said, where are you seeing the problem? ADE? iPad? Kindle?
    Bob

  • Hsqldb quotation mark problem.

    Hi there,
    I am trying to insert some records to hsqldb with jdbc. But there are quotation marks in my string.
    INSERT INTO haber (id, Title) values (1, 'String'withQuotationMark ')I get the error message saying: Unexpected token: withQuotationMark in statement [INSERT INTO haber (id, Title) values (1, 'String'withQuotationMark ']/Error code: -11/state: 37000
    I have changed the sql statement as following:INSERT INTO haber (id, Title) values (1, 'String\'withQuotationMark ')and as following
    INSERT INTO haber (id, Title) values (1, 'String''withQuotationMark ')but i got the same error message.
    what should i do in this case.
    Thanks...

    what should i do in this case.
    Use a prepared statement and let the JDBC driver deal with the problem for you.
    http://java.sun.com/docs/books/tutorial/jdbc/basics/prepared.html

  • Exclamation mark problems - help please

    I deleted my trash because it was 60GB and it's caused me quite a few problems.
    A number of exclamation marks have appeared in iTunes and when trying to search for the original file to mend the broken link, the track is greyed out in Finder. I'm presuming this is because some of the tracks were somehow linked to what was in my trash.
    (1) What is the best way to fix this issue?
    I guess I could use Time Machine to restore iTunes to what it looked like last week (pre-trash deletion) - (2) would that work or would I need to restore the whole of my trash for that too?
    (3) If I try to restore iTunes via Time Machine, what folder do I restore - is it "Music" or something else?
    Thanks.

    not sure it'll work but try this script:
    _*iTunes Track CPR v1.3*_
    This script attempts to locate the files of so-called "dead tracks"--iTunes tracks designated with (!)--that you assume are not actually missing but are still located in the iTunes Music folder in their "iTunes File Order" (Music -> Artist -> Album -> file.xxx)."
    JGG

  • Looking for config example for qos marking on IOS edge router for UCCE

                       I was going through the UCCE SRND for QOS config, and found the following sample, wondering if someone can provide a tested config example to configur the QOS on edge router for UCCE.
    access-list 100 permit tcp host Public_High_IP any
    access-list 100 permit tcp any host Public_High_IP
    access-list 101 permit tcp host Public_NonHigh_IP any
    access-list 101 permit tcp any host Public_NonHigh_IPSecond, classify the traffic using a class map:class-map match-all ICM_Public_High
    match access-group 100
    class-map match-all ICM_Public_Low
    match access-group 101
    policy-map ICM_Public_Marking
    class ICM_Public_High
    set ip dscp af31
    class ICM_Public_Low
    set ip dscp af11Finally, apply the marking policy to the incoming interface:interface mod/port
    service-policy input ICM_Public_Marking

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    If you're going to use only two queues, and if you want to guarantee the one queue 35% of your egress bandwidth, you need to assign your two queues the ratio of 65:35; you'll need to adjust the four queue percentages to provide those two queues the same ratio.  Ideally you'll want something like share 0 65 35 0, but if you cannot assign zero, something like 40 13 7 40, 20 39 21 20, 10 52 28 10 should do.

  • QoS Marking Traffic Generated by Network Device

    I am working on defining QoS configuration standards for Catalyst 3750, 4500 and 6500 platforms. I would like to provide preferred treatment to some of the protocols commonly used for network management (i.e. telnet, ssh, etc...). I have no issues with classifying and marking traffic generated by a NMS or PC connected to a switch but I can not figure out how to classify and mark traffic generated by the switch itself. It won't do any good if traffic from the NMS or PC to the device is preferred but the response from the device is unmarked/best effort.
    The only way that I can see to do this is to apply an input policy on the upstream device to classify and mark the network management traffic. I would prefer to do it on the device itself. Does anyone know if that is possible?
    I'm assuming that any traffic generated by the switch would be ignored by an output policy, similar to the way that traffic generated by the device will by-pass access-lists. Even if this is a bad assumption the 3750 does not support output policies, so I'd still be stuck there.
    It was suggested that I look into applying the policy to the control plane however on the platforms that options is available, policies can only be applied to the input. Which I believe is the wrong direction.
    Anyone have other suggestions on how to accomplish this or is this a lost cause?

    You can use local PBR to do this. Check out the local policy-map
    http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fqos_c/fqcprt1/qcfpbr.htm#wp1001002

Maybe you are looking for

  • Report parameter default value do not default correctly

    Hello Experts, I have a cascading parameters in my report. The first parameter called "Project" will allow to select a single Project Name from the list and based on the Project Name, the second parameters which is a "Date" parameter will give out li

  • TO TRANSFER A REPORT FROM WAS TO R/3 WITH XI

    I ASK INFORMATION, HELP OR HANDBOOK ON AS TO CARRY OUT THE TRANSFER OF A REPORT FROM A SYSTEM WAS TO R/3 SYSTEM WITH THE USE OF SAP XI. THANKS UMBERTO

  • Can't sync with my Palm calender/contacts

    Just bought the iphone 3G and have got it pretty much up and running with music, emial, etc. Problem is when I log in to itunes I can't figure out how to sync with my old palm info. It only provides Yahoo contacts, Google, Outlook, and Windows as con

  • Printing a double to accuracy of 2 decimal places

    Hi, I have a double value and I want to print it to an accuracy of 2 decimal places. Is there any way to do this. I tried using the DecimalFormat by doing the following String str = Double.toString(value); DecimalFormat dec = new DecimalFormat(str);

  • TaskFlow Exception Handler Behavior

    Hi all, I have a question about taskflow exception handler. My customer is using method-call exception handler to display error detail as FacesMessage dialog in their taskflow. And they are now trying to find the way to call exception handler but not