Regexp_substr question

Oracle 10g and Oracle 11g
with mike_test as
(select
'Dont want this Line
Name want this line
Name want this line
Dont want this line
Name want this line' xx
from dual)
select regexp_substr(xx,'Name(.*)') from mike_test
I'm looking to return
Name want this line
Name want this line
Name want this line
but can only get one occurrence. I keep trying to use the matching mode 'm' to search through all lines but I'm not having success.
thanks
Mike

This should also work. As long as the "Name" doesn't include a special char used to do some regexp_conversions. I used the char "§".
with mike_test as
(select
'Dont want this Line
Name want this line
Naem not want this line !
Dont want this line
Name want this line' xx
from dual)
select regexp_substr(xx,'^Name.*$',1,1,'m') first_result
   ,regexp_count(xx, '^Name.*$', 1,'m') number_of_lines
   ,regexp_replace(
       regexp_replace(
           regexp_replace(xx,'(Name)','§',1,0,'m')
           ,'^[^§](.*)$','',1,0,'m')
       ,'§','Name',1,0,'m') all_lines
from mike_test
ALL_LINES
Name want this line
Name want this line"The problem with regexp_substr is that it will deliver only one occurence of the string.
Regexp_replace can eliminate all occurences. However you can't easily say something like: Everthing that is not starting with "Name".
Therefore I first replace the "Name" Part by a single character § and then later used the [^§] not replacement to eliminate the not needed lines. Then replace the substitution character § back to the wanted "Name".
Edited by: Sven W. on Dec 3, 2012 10:56 PM

Similar Messages

  • Regexp_replace and regexp_substr questions

    Hello,
    I am new to regular expressions. Need help with following :
    1. Need to remove duplicate alphanumeric string followed by space character.
    Input : 'SAY HELLO HELLO HELLO WORLD'
    Output: 'SAY HELLO WORLD'
    Input : 'MY STRING STRING HAS DUPLICATES'
    Output: 'MY STRING HAS DUPLICATES'
    2. Parsing.
    Input1 : 'APT D67 1023 MAIN ST BUFFALO NY'
    or
    Input2 : '1023 MAIN ST APT D67 BUFFALO NY'
    Extract the following: 'APT D67 '
    Output: '1023 MAIN ST BUFFALO NY' , 'APT D67'
    How to extract substr using regexp? 'D67' is alphanumeric value might neccesserely appear after APT. Regexp_instr?
    3. Is it solution to use regexpr to eliminate duplicates in the following case ?
    Input : _'APT 789_ 456 FLOWER DR APT 789 VALEJIA CA'
    Output: 'APT 789 456 FLOWER DR VALEJIA CA'
    Thanks in advance.

    REgards salim.
    WITH T AS
         (SELECT  'SAY HELLO HELLO HELLO WORLD'     TXT
                FROM DUAL
        UNION ALL
         SELECT 'APT 789 456 FLOWER DR APT 789 VALEJIA CA'
               FROM DUAL
          UNION ALL
          SELECT      'MY STRING STRING HAS DUPLICATES'
          FROM DUAL
        SELECT TXT|| case when apt is not null then ' ,'|| APT end    txt
      FROM (
             SELECT   distinct  RN,TXT ,rang,apt
             FROM   T
            MODEL
              RETURN UPDATED ROWS
               PARTITION BY ( ROWNUM RN)
               DIMENSION BY (0 POSITION)
             MEASURES     (TXT ,NVL(LENGTH(REGEXP_REPLACE(TXT,'[^ ]+','')),0)+1 NB_MOT, 0 rang,
             REGEXP_SUBSTR(TXT,'^APT [0-9]+') apt)
              RULES
              (TXT[FOR POSITION FROM  1 TO NB_MOT[0] INCREMENT 1]  =
               REGEXP_SUBSTR(TXT[0],'[^ ]+',1,CV(POSITION)) ,
               APT[FOR POSITION FROM  1 TO NB_MOT[0] INCREMENT 1]  =
               REGEXP_SUBSTR(TXT[0],'^APT [0-9]+'),
                rang[position>=1]=  instr(txt[0],txt[cv()],1)) )
      MODEL
      RETURN UPDATED ROWS
    PARTITION BY (  RN,APT )
      DIMENSION BY ( ROW_NUMBER() OVER (PARTITION BY RN ORDER BY rang ASC) AS POSITION)
      MEASURES ( CAST( TXT AS VARCHAR2(1000) ) AS TXT  )
       RULES
      UPSERT
      ITERATE( 1000)
    UNTIL ( PRESENTV(TXT[ITERATION_NUMBER+2],1,0) = 0 )
      (TXT[0] = TXT[0] ||   CASE WHEN ITERATION_NUMBER+1=1 AND TXT[ITERATION_NUMBER+1]='APT' THEN NULL
                             WHEN ITERATION_NUMBER+1=2 AND TXT[ITERATION_NUMBER]  ='APT' THEN NULL
                              ELSE   ' ' || TXT[ITERATION_NUMBER+1] END )
       ORDER BY rn
    SQL> WITH T AS
      2       (SELECT  'SAY HELLO HELLO HELLO WORLD'     TXT
      3              FROM DUAL
      4      UNION ALL
      5       SELECT 'APT 789 456 FLOWER DR APT 789 VALEJIA CA' 
      6             FROM DUAL
      7        UNION ALL
      8        SELECT      'MY STRING STRING HAS DUPLICATES'
      9        FROM DUAL
    10     )
    11      SELECT TXT|| case when apt is not null then ' ,'|| APT end    txt
    12    FROM (
    13           SELECT   distinct  RN,TXT ,rang,apt
    14           FROM   T
    15          MODEL
    16            RETURN UPDATED ROWS
    17             PARTITION BY ( ROWNUM RN)
    18             DIMENSION BY (0 POSITION)
    19           MEASURES     (TXT ,NVL(LENGTH(REGEXP_REPLACE(TXT,'[^ ]+','')),0)+1 NB_MOT, 0 rang,   
    20           REGEXP_SUBSTR(TXT,'^APT [0-9]+') apt)
    21            RULES
    22            (TXT[FOR POSITION FROM  1 TO NB_MOT[0] INCREMENT 1]  =
    23             REGEXP_SUBSTR(TXT[0],'[^ ]+',1,CV(POSITION)) ,
    24             APT[FOR POSITION FROM  1 TO NB_MOT[0] INCREMENT 1]  =
    25             REGEXP_SUBSTR(TXT[0],'^APT [0-9]+'),
    26              rang[position>=1]=  instr(txt[0],txt[cv()],1)) )
    27    MODEL
    28    RETURN UPDATED ROWS
    29   PARTITION BY (  RN,APT )
    30    DIMENSION BY ( ROW_NUMBER() OVER (PARTITION BY RN ORDER BY rang ASC) AS POSITION)
    31    MEASURES ( CAST( TXT AS VARCHAR2(1000) ) AS TXT  )
    32     RULES
    33    UPSERT
    34    ITERATE( 1000)
    35   UNTIL ( PRESENTV(TXT[ITERATION_NUMBER+2],1,0) = 0 )
    36    (TXT[0] = TXT[0] ||   CASE WHEN ITERATION_NUMBER+1=1 AND TXT[ITERATION_NUMBER+1]='APT' THEN N
    ULL
    37                           WHEN ITERATION_NUMBER+1=2 AND TXT[ITERATION_NUMBER]  ='APT' THEN NULL
    38                            ELSE   ' ' || TXT[ITERATION_NUMBER+1] END )
    39     ORDER BY rn
    40  /
    TXT
    SAY HELLO WORLD
    456 FLOWER DR VALEJIA CA ,APT 789
    MY STRING HAS DUPLICATES
    SQL>  Edited by: Salim Chelabi on 2009-04-06 14:05
    Edited by: Salim Chelabi on Apr 6, 2009 4:11 PM

  • Simple regexp_substr question

    hi all ,
    version 10g
    i want to substr the string and get the string atfer(.) dot
    'abcd.xyz1'result
    xyz1
    thanks
    Edited by: new learner on Sep 10, 2010 8:12 AM

    Hi,
    Here's one way:
    REGEXP_SUBSTR ( str
               , '[^.]+$'
               )The . is not a wild-card in this context.
    What if there are several .s in str?
    The expression above will return everything (if anything) after the last one.
    Edited by: Frank Kulash on Sep 10, 2010 11:20 AM
    You specifially asked about REGEXP_SUBSTR.
    Regular expressions tend to be slower than older methods, if both involve about the same amout of code.
    You could get the same results faster using SUBSTR, as Iamaby suggested.
    To get the text (if any) after the last dot:
    SUBSTR ( str
           , 1 + INSTR (str, '.', -1)
           )

  • Quick Question using REGULAR EXPRESSIONS

    Hi Experts,
    BANNER                                                                         
    Oracle Database 11g Enterprise Edition Release 11.1.0.7.0 - Production         
    PL/SQL Release 11.1.0.7.0 - Production                                         
    CORE     11.1.0.7.0     Production                                                     
    TNS for 32-bit Windows: Version 11.1.0.7.0 - Production                        
    NLSRTL Version 11.1.0.7.0 - Production                                         
    5 rows selected.I will be getting multiple values as input which will be separated by "[#|#]"
    I need to identify and splitup values based on it and to do my process.
    I have already asked similar question, but still struggling with that since the values i get in the Text is not restricted to any specific character so that not works on replacing the separator "[#|#]" by some character and using REGEXP_SUBSTR.
    I need to work around some thing like below code,
    DECLARE
        vInfo   VARCHAR2(4000) := 'cropX=42,cropY=0,Text=`$@@@@@@####[##][##][#|#]cropX=42,cropY=0,Text=`$@@@@@@####[##][##]';
        vDet    VARCHAR2(4000);
        vPos    INTEGER := 1;
        LOOP
            * vDet    := REGEXP_SUBSTR(vInfo,'[#|#]',1,vPos); *
            EXIT WHEN vDet IS NULL;
            vPos := vPos+1;
            -- My Process Here based on splitted values here
            DBMS_OUTPUT.PUT_LINE(vDet);
        END LOOP;
    END;  Suggest me to work out this.
    Thanks,
    Dharan V

    B'coz
    Not just one value which i need to split. There are so multiple variables i need to with different separator.
    Thanks for suggestion, I have STR2TBL already installed and working with that.
    But not sure whether i can combine my requirement with that and to work out this ?
    DECLARE
       vId      VARCHAR2(50) := '1,2,3';
       vIdValue INTEGER;
       vName    VARCHAR2(40) := 'Name1,Name2,Name3';
       vInfo    VARCHAR2(4000) := 'cropX=42,cropY=0,Text=`$@@@@@@####[##][##][#|#]cropX=42,cropY=0,Text=`$@@@@@@####[##][##]';
       vDet     VARCHAR2(4000);
       vPos     INTEGER := 1;
    BEGIN  
        LOOP
            * vDet      := REGEXP_SUBSTR(vInfo,'[#|#]',1,vPos); *
            vIdValue    := REGEXP_SUBSTR(vId,',',1,vPos);
            EXIT WHEN vDet IS NULL;
            vPos := vPos+1;
            -- My Process Here based on splitted values here
            DBMS_OUTPUT.PUT_LINE(vDet);
        END LOOP;
    END; 

  • Regexp_substr

    My earlier post was answered by Frank Kulash, thanks Frank.
    However i have few questions
    SELECT  owner_id
    ,    owner_name        AS old_owner_name
    ,    REGEXP_SUBSTR ( owner_name
                  , '^\(([^)]+)'
                  , 1
                  , 1
                  , NULL
                  , 1
                  )        AS legacy_id
    ,    REGEXP_SUBSTR ( owner_name
                  , '-([^(]+)'
                  , 1
                  , 1
                  , NULL
                  , 1
                  )        AS DEPT_ID
    ,    REGEXP_SUBSTR ( owner_name
                  , '\(([^)]+)\) * (\(OLD\))?$'
                  , 1
                  , 1
                  , NULL
                  , 1
                  )        AS NEW_OWNER_NAME
    FROM    stg_wms_setup_owner_unpiv
    ORDER BY  owner_id
    ;The problem i'm encountering is with the 'OWNER_NAME'. The original field in the table has a record '(1104) - (History) FORT HARRISON' under 'OWNER_NAME', in the above query to get the NEW~_OWNER_NAME i have
    REGEXP_SUBSTR ( owner_name
                  , '\(([^)]+)\) * (\(OLD\))?$'
                  , 1
                  , 1
                  , NULL
                  , 1
                  )        AS NEW_OWNER_NAMEBut the above sql takes care when there is '(OLD)' at the end of the record, but i want to get rid of '(History)' as well, please need help , i'm thinking if i change the back reference will that help?
    Thanks

    Hi,
    897837 wrote:
    ... Frank just like using a negative value in SUBSTR can we do a similar thing in back references? How can i copy the resultant dataset as a table and paste , because once i posted the dataset the fields are again getting closer and difficult for the users to read.Is this one question or two completely unrealted questions?
    just like using a negative value in SUBSTR can we do a similar thing in back references? Unfortunately, no. I don't believe there's any good way to tell REGEXP_SUBSTR to return the last matrching pattern, or the next-to-last, or the N-th from the end. Often you can work around that by specifying specify what comes after the part you really want, and anchoring the expression to the end of the string ($). Do you really need to find the N-th-to last expression in this case? You've never explained exactly how you get the new columns from the original owner_name.
    How can i copy the resultant dataset as a table and paste , because once i posted the dataset the fields are again getting closer and difficult for the users to read.Use \ tags, just like you did around the CREATE TABLE statement, and again around the INSERT statements.  (By the way, it looks like an editor or something replaced the single-quotes with some kind of fancy leaning quotes.  I had to edit that out manually.)
    The word "code" in the \ tags means that the text is to be displayed in the style of code; that is, with a fixed-width font and no whitespace compressed. It has nothing to do with the content. You can use \ tags to format query results, or poetry, or graphics, or any other kind of text.
    The query you posted looks pretty close to what you need.  If 'History' is case-insensitive, then use REGEXP_REPLACE instead of REPLACE to get rid of it.  If you're using REGEXP_REPLACE, it's easy to remove any spaces that come before or after '(History)' at the same time.SELECT owner_id
    ,      REGEXP_SUBSTR ( owner_name
         , '^\(([^)]+)'
         , 1
         , 1
         , NULL
    , 1
         ) AS legacy_id
    , REGEXP_SUBSTR ( owner_name
         , '\(([^)]+)\) * (\(OLD\))?$'
         , 1
         , 1
         , NULL
    , 1
         ) AS dept_id
    ,      owner_name     AS old_owner_name
    , REGEXP_SUBSTR ( REGEXP_REPLACE ( owner_name
                        , ' *\(History\ *'
                        , NULL
                        , 1
                        , 1
                        , 'i'     -- Case-insensitive
         , '-([^(]+)'
         , 1
         , 1
         , NULL
    , 1
         ) AS new_owner_name
    FROM t
    ORDER BY owner_id
    This seems to be right except for new_owner_name.  The expression above says there must be a hyphen before new_owner_name, but in your desired results (if I understand them correctly) you way you want new_owner_name to include the only hyphen in one case:2424 PS065413 FW - HM (PS065413) (OLD) FW - HM
    If you can explain the rules about how to find new_owner_name, I can help you find a regular expression to do it.  Apparantly, the rule is not "everything from the hyphen to the next left parenthesis, or the end of the string", but I don't know what the rule is.
    Are there other places where this is not doing what you need?  Point out those places, and explain how you get the correct results in those places.
    Sorry, I'm not at an Oracle 11 database today.  I tested the query above as well as I could using Oracle 10.2.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       

  • Questions on Print Quote report

    Hi,
    I'm fairly new to Oracle Quoting and trying to get familiar with it. I have a few questions and would appreciate if anyone answers them
    1) We have a requirement to customize the Print Quote report. I searched these forums and found that this report can be defined either as a XML Publisher report or an Oracle Reports report depending on a profile option. Can you please let me know what the name of the profile option is?
    2) When I select the 'Print Quote' option from the Actions drop down in the quoting page and click Submit I get the report printed and see the following URL in my browser.
    http://<host>:<port>/dev60cgi/rwcgi60?PROJ03_APPS+report=/proj3/app/appltop/aso/11.5.0/reports/US/ASOPQTEL.rdf+DESTYPE=CACHE+P_TCK_ID=23731428+P_EXECUTABLE=N+P_SHOW_CHARGES=N+P_SHOW_CATG_TOT=N+P_SHOW_PRICE_ADJ=Y+P_SESSION_ID=c-RAuP8LOvdnv30grRzKqUQs:S+P_SHOW_HDR_ATTACH=N+P_SHOW_LINE_ATTACH=N+P_SHOW_HDR_SALESUPP=N+P_SHOW_LN_SALESUPP=N+TOLERANCE=0+DESFORMAT=RTF+DESNAME=Quote.rtf
    Does it mean that the profile in our case is set to call the rdf since it has reference to ASOPQTEL.rdf in the above url?
    3) When you click on submit button do we have something like this in the jsp code: On click call ASOPQTEL.rdf. Is the report called using a concurrent program? I want to know how the report is getting invoked?
    4) If we want to customize the jsp pages can you please let me know the steps involved in making the customizations and testing them.
    Thanks and Appreciate your patience
    -PC

    1) We have a requirement to customize the Print Quote report. I searched these forums and found that this report can be defined either as a XML Publisher report or an Oracle Reports report depending on a profile option. Can you please let me know what the name of the profile option is?
    I think I posted it in one of the threads2) When I select the 'Print Quote' option from the Actions drop down in the quoting page and click Submit I get the report printed and see the following URL in my browser.
    http://<host>:<port>/dev60cgi/rwcgi60?PROJ03_APPS+report=/proj3/app/appltop/aso/11.5.0/reports/US/ASOPQTEL.rdf+DESTYPE=CACHE+P_TCK_ID=23731428+P_EXECUTABLE=N+P_SHOW_CHARGES=N+P_SHOW_CATG_TOT=N+P_SHOW_PRICE_ADJ=Y+P_SESSION_ID=c-RAuP8LOvdnv30grRzKqUQs:S+P_SHOW_HDR_ATTACH=N+P_SHOW_LINE_ATTACH=N+P_SHOW_HDR_SALESUPP=N+P_SHOW_LN_SALESUPP=N+TOLERANCE=0+DESFORMAT=RTF+DESNAME=Quote.rtf
    Does it mean that the profile in our case is set to call the rdf since it has reference to ASOPQTEL.rdf in the above url?
    Yes, your understanding is correct.3) When you click on submit button do we have something like this in the jsp code: On click call ASOPQTEL.rdf. Is the report called using a concurrent program? I want to know how the report is getting invoked?
    No, there is no conc program getting called, you can directly call a report in a browser window, Oracle reports server will execute the report and send the HTTP response to the browser.4) If we want to customize the jsp pages can you please let me know the steps involved in making the customizations and testing them.
    This is detailed in many threads.Thanks
    Tapash

  • Satellite P300D-10v - Question about warranty

    HI EVERYBODY
    I have these overheating problems with my laptop Satellite P300D-10v.
    I did everything I could do to fix it without any success..
    I get the latest update of the bios from Toshiba. I cleaned my lap with compressed air first and then disassembled it all and cleaned it better.(it was really clean insight though...)
    BUT unfortunately the problem still exists...
    So i made a research on the internet and I found out that most of Toshiba owners have the same exactly problem with their laptop.
    Well i guess this is a Toshiba bug for many years now.
    Its a really nice lap, cool sound (the best in laptop ever) BUT......
    So I wanted to make a question. As i am still under warranty, can i return this laptop and get my money back or change it with a different one????
    If any body knows PLS let me know.
    chears
    Thanks in advance

    Hi
    I have already found you other threads.
    Regarding the warranty question;
    If there is something wrong with the hardware then the ASP in your country should be able to help you.
    The warranty should cover every reparation or replacement.
    But I read that you have disasembled the laptop at your own hand... hmmm if you have disasembled the notebook then your warrany is not valid anymore :(
    I think this should be clear for you that you can lose the warrany if you disasemble the laptop!
    By the way: you have to speak with the notebook dealer where you have purchased this notebook if you want to return the notebook
    The Toshiba ASP can repair and fix the notebook but you will not get money from ASP.
    Greets

  • Question regarding NULL and forms

    Hi all, i have a survey that im working on that will be sent via email.
    I'm having an issue though. if i have a multiple choice question, and the user only selects one of the choices, all the unselected choices return as NULL. is there a way i can filter out anytihng that says "NULL" so it only shows the selected options?
    thanks.
    here is the page that retrieves all the data. thanks
    <body>
    <p>1) Is this your first visit to xxxxxxx? <b><%=request.getParameter("stepone") %></b>
    </p>
    <p> </p>
    <p>2) How did You Learn About xxxxxxx?</p>
    <p><b><%=request.getParameter("steptwoOne") %></b>
      <br>
        <b><%=request.getParameter("steptwoTwo") %></b>
      <br>
        <b><%=request.getParameter("steptwoThree") %></b>
      <br>
        <b><%=request.getParameter("steptwoFour") %></b>
      <br>
        <b><%=request.getParameter("steptwoOther") %></b>
    </p>
    <p> </p>
    <p>3) What was your main reason for visiting xxxxx?</p>
    <p><b><%=request.getParameter("stepthreeOne") %></b>
        <br>
          <b><%=request.getParameter("stepthreeTwo") %></b>
        <br>
          <b><%=request.getParameter("stepthreeThree") %></b>
        <br>
          <b><%=request.getParameter("stepthreeFour") %></b>
        <br>
          <b><%=request.getParameter("stepthreeOther") %></b>
    </p>
    <p>4) did you find the information you were looking for on this site?</p>
    <p><b><%=request.getParameter("stepfour") %>
    <br>
    <b><%=request.getParameter("stepfourOther") %></b>
    </b></p>
    <p>5) Do you plan on using this website in the future?</p>
    <p><b><%=request.getParameter("stepfive") %></b></p>
    <p>6) What is your gender</p>
    <p><b><%=request.getParameter("stepsix") %></b></p>
    <p>7) What is your age group</p>
    <p><b><%=request.getParameter("stepseven") %></b></p>
    8) Would you like to take a moment and tell us how we can improve your experience on xxxxxxxxxx?
    <p><b><%=request.getParameter("stepeightFeedback") %></b></p>

    i was messing around and came up with this. it doesnt remove the null, but if it is null it adds ABC beside it. so i think i might be getting close. i just need to figure out how to replace the null.
    code]
    <b><%=request.getParameter("steptwoFour") %></b>
         <% if (request.getParameter("steptwoFour") == null ) {
         %>
         <% out.print("abc"); %>
         <% }
         %>

  • Anyone know how to remove Overdrive books from my iphone that have been transferred from my computer? They do not show up on itunes. I see a lot of answers to this question but they all are based on being able to see the books in iTunes.

    How do I remove Overdrive books from the library that were downloaded onto my computer then transferred to my iphone? The problem is that they do not show up in iTunes.
    I see this question asked a lot when I google, but they always give answers that assumes you can find the books in iTunes either under the books tab, or the audio books tab or in the music. They do not show up anywhere for me. They do not remove from the app like the ones I downloaded directly onto my iphone.the related archived article does not answer it either.  I even asked a guy working at an apple store and he could not help either.   Anybody...?
    Thanks!

    there is an app called daisydisk on mac app store which will help you see exactly where the memory is focused and consumed try using that app and see which folders are using more memory

  • Basic question

    Hello, i have a basic question. if i have defined 2 fields in a cube or a dso:
    Name Quantity
    and from the external flat file i get some characters for my quantity field. would my load fail?  for standard dso and for write optimized?
    NOTE: quantity field is a keyfigure defined as numeric.
    and the load coming in has "VIKPATEL" for Quantity field and not numbers.
    thanks

    Hi Vik,
    Yes, the load will fail.
    May be you coud first load this data into BW (into PSA) and set both fields as characters fields. Then you can create DSO, do transformation from this PSA to the DSO, and put your logic as to what do you want to do with those Quantity that is not number (e.g. convert to 0, or 'Not assgined', etc).
    You can use transfer rule, or a clean up ABAP code in the start routine.
    Hope this helps.

  • Mid 2010 15" i5 Battery Calibration Questions

    Hi, I have a mid 2010 15" MacBook Pro 2.4GHz i5.
    Question 1: I didn't calibrate my battery when I first got my MacBook Pro (it didn't say in the manual that I had to). I've had it for about a month and am doing a calibration today, is that okay? I hope I haven't damaged my battery? The calibration is only to help the battery meter provide an accurate reading of how much life it has remaining, right?
    Question 2: After reading Apple's calibration guide, I decided to set the MacBook Pro to never go to sleep (in Energy Saver System Preference) and leave it on overnight so it would run out of power and go to sleep, then I'd leave it in that state for at least 5 hours before charging it. When I woke up, the light on the front wasn't illuminated. It usually pulsates when in Sleep. Expectedly, it wouldn't wake when pressing buttons on the keyboard. So, what's happened? Is this Safe Sleep? I didn't see any "Your Mac is on reserve battery and will shut down" dialogues or anything similar, as I was asleep! I've left it in this state while I'm at work and will charge it this afternoon. Was my described method okay for calibration or should I have done something different?
    Question 3: Does it matter how quickly you drain your battery when doing a calibration? i.e is it okay to drain it quickly (by running HD video, Photo Booth with effects etc) or slowly (by leaving it idle or running light apps)?
    Thanks.
    Message was edited by: Fresh J

    Fresh J:
    A1. You're fine calibrating the battery now. You might have gotten more accurate readings during the first month if you'd done it sooner, but no harm has been done.
    A2. Your machine has NOT shut down; it has done exactly what it was supposed to do. When the power became critically low, it first wrote the contents of RAM to the hard drive, then went to sleep. When the battery was completely drained some time later, the MBP went into hibernation and the slepp light stopped pulsing and turned off. In that state the machine was using no power at all, but the contents of your RAM were still saved. Once the AC adapter was connected, a press of the power button would cause those contents to be reloaded, and the machine would pick up again exactly where you left off. It is not necessary to wait for the battery to be fully charged before using the machine on AC power, but do leave the AC adapter connected for at least two hours after the battery is fully charged. Nothing that you say you've done was wrong, and nothing that you say has happened was wrong.
    A3. No, it does not matter.

  • Jabber/WebEx Connect SSO Questions

    I've got a few questions around exactly what needs to be done to get SAML working for our Connect accounts to successfully authenticate from Jabber for Windows, Mac, iPhone, and Android.
    We have both a Meeting Center and Connect account under WebEx using Loose Coupled Integration. Just this past week I enabled SAML for our Meeting Center accounts which went off without a hitch with the exception of Meeting Center integration with Jabber, which is now broken with a message about SSO enabled Meeting Sites not being supported (I think this would maybe be fixed if we had Tight Coupled Integration with our two account?).
    Anyway, my questions are...
    For Windows, I understand all clients will need to be reinstalled with the MSI argument for the SSO_ORG_DOMAIN switch I've read about, is that correct? Are there any other switches needed for the reinstall? 
    How will this work with the Mac and mobile clients? There's obviously no command line options to specify for the installations here, will they just know to kick over to my IdP for authentication once they see an email address that falls under an org with SSO enabled? If so, why does the Windows client need to be completely reinstalled and not just know to find the IdP from the Cloud Connect service like Meeting Center does with the Productivity Tools?
    We're just doing this for our Connect Web IM accounts, not attempting any sort of SSO with the phone accounts/UC integration yet.
    Any ideas on getting the Meeting Center integration into Jabber working again?

    I'd suggest posting your question over on the Jabber Pilot forum, as this forum is specific to Jabber Guest questions:
    https://supportforums.cisco.com/community/4551/jabber-pilot-support
    -jim

  • My iPad wont let me download apps bc security questions, but when I try to make them it freezes

    Every time I try to download an app it tells me I need to update my security questions, but once I click to make the questions the box goes white. So I'm not sure how to fix it

    The new questions show on your account on http://appleid.apple.com ? If they do then try logging out and back into your account on your phone (assuming that is where you are trying to purchase from) and see if the new questions then show on it.

  • ASA VPN QUESTION

    Hi All
    The question is pretty simple. I can successfully connect  to my ASA 5505  firewall via cisco vpn client 64 bit , i can ping any ip  address on the LAN behind ASA but none of the LAN computers can see or  ping the IP Address which is assigned to my vpn client from the ASA VPN  Pool.
    The LAN behind ASA is 192.168.0.0 and the VPN Pool for the cisco vpn client is 192.168.30.0
    I would appreciate some help pls
    Here is the config:
    ASA Version 7.2(4)
    hostname ciscoasa
    domain-name default.domain.invalid
    enable password J7NxNd4NtVydfOsB encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    name 192.168.0.11 EXCHANGE
    name x.x.x.x WAN
    name 192.168.30.0 VPN_POOL2
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.0.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address WAN 255.255.255.252
    interface Ethernet0/0
    switchport access vlan 2
    <--- More --->
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    boot system disk0:/asa724-k8.bin
    ftp mode passive
    clock timezone EEST 2
    clock summer-time EEDT recurring last Sun Mar 3:00 last Sun Oct 4:00
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    access-list nk-acl extended permit tcp any interface outside eq smtp
    access-list nk-acl extended permit tcp any interface outside eq https
    access-list customerVPN_splitTunnelAcl standard permit 192.168.0.0 255.255.255.0
    access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 VPN_POOL2 255.255.255.0
    access-list inside_access_in extended permit ip any any
    access-list VPN_NAT extended permit ip VPN_POOL2 255.255.255.0 192.168.0.0 255.255.255.0
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    ip local pool VPN_POOL2 192.168.30.10-192.168.30.90 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-524.bin
    no asdm history enable
    arp timeout 14400
    global (inside) 10 interface
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    nat (outside) 10 access-list VPN_NAT outside
    static (inside,outside) tcp interface smtp EXCHANGE smtp netmask 255.255.255.255
    static (inside,outside) tcp interface https EXCHANGE https netmask 255.255.255.255
    access-group inside_access_in in interface inside
    access-group nk-acl in interface outside
    route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    aaa authentication enable console LOCAL
    aaa authentication http console LOCAL
    aaa authentication serial console LOCAL
    aaa authentication ssh console LOCAL
    aaa authentication telnet console LOCAL
    aaa authorization command LOCAL
    http server enable
    http 192.168.0.0 255.255.255.0 inside
    snmp-server host inside 192.168.0.16 community public
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto dynamic-map outside_dyn_map 20 set pfs group1
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto isakmp nat-traversal  20
    telnet 192.168.0.0 255.255.255.0 inside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcp-client client-id interface outside
    dhcpd dns 217.27.32.196
    dhcpd address 192.168.0.100-192.168.0.200 inside
    dhcpd dns 192.168.0.10 interface inside
    dhcpd enable inside
    group-policy DfltGrpPolicy attributes
    banner none
    wins-server none
    dns-server none
    dhcp-network-scope none
    vpn-access-hours none
    vpn-simultaneous-logins 3
    vpn-idle-timeout 30
    vpn-session-timeout none
    vpn-filter none
    vpn-tunnel-protocol IPSec l2tp-ipsec
    password-storage disable
    ip-comp disable
    re-xauth disable
    group-lock none
    pfs disable
    ipsec-udp disable
    ipsec-udp-port 10000
    split-tunnel-policy tunnelall
    split-tunnel-network-list none
    default-domain none
    split-dns none
    intercept-dhcp 255.255.255.255 disable
    secure-unit-authentication disable
    user-authentication disable
    user-authentication-idle-timeout 30
    ip-phone-bypass disable
    leap-bypass disable
    nem disable
    backup-servers keep-client-config
    msie-proxy server none
    msie-proxy method no-modify
    msie-proxy except-list none
    msie-proxy local-bypass disable
    nac disable
    nac-sq-period 300
    nac-reval-period 36000
    nac-default-acl none
    address-pools none
    smartcard-removal-disconnect enable
    client-firewall none
    client-access-rule none
    webvpn
      functions url-entry
      html-content-filter none
      homepage none
      keep-alive-ignore 4
      http-comp gzip
      filter none
      url-list none
      customization value DfltCustomization
      port-forward none
      port-forward-name value Application Access
      sso-server none
      svc none
      svc keep-installer installed
      svc keepalive none
      svc rekey time none
      svc rekey method none
      svc dpd-interval client none
      svc dpd-interval gateway none
      svc compression deflate
    group-policy customerVPN internal
    group-policy customerVPN attributes
    dns-server value 192.168.0.10
    vpn-tunnel-protocol IPSec
    password-storage enable
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value customerVPN_splitTunnelAcl
    default-domain value customer.local
    username xxx password 8SYsAcRU4s6DpQP1 encrypted privilege 0
    username xxx attributes
    vpn-group-policy TUNNEL1
    username xxx password C6M4Xy7t0VOLU3bS encrypted privilege 0
    username xxx attributes
    vpn-group-policy PAPAGROUP
    username xxx password RU2zcsRqQAwCkglQ encrypted privilege 0
    username xxx attributes
    vpn-group-policy customerVPN
    username xxx password zfP8z5lE6WK/sSjY encrypted privilege 15
    tunnel-group customerVPN type ipsec-ra
    tunnel-group customerVPN general-attributes
    address-pool VPN_POOL2
    default-group-policy customerVPN
    tunnel-group customerVPN ipsec-attributes
    pre-shared-key *
    tunnel-group-map default-group DefaultL2LGroup
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:a4dfbb82008f78756fe4c7d029871ec1
    : end
    ciscoasa#                           

    Well lots of new features have been hinted at for ASA 9.2 but I've not seen anything as far as an Engineering Commit or Customer Commit for that feature.
    Site-site VPN in multiple context mode was added in 9.0(1) and I have customers have been asking for the remote access features as well.
    I will remember to ask about that at Cisco Live next month.

  • New to Apple, questions about using Windows, and other things

    Hello all,
    Today is my first day as an Apple owner. It's funny because I'm also a MCSE, MCSA, and MCP.
    I purchased a 24" iMac, 2.8GHz, 4GB RAM, and 1TB Hard Drive.
    I want to use Windows on my Mac so that I don't have to keep switching over to my PC. My main reason for using Windows is so that I can continue to enjoy my PC Games... mostly racing and D&D games.
    So my question is... how does Windows run on bootcamp? Can I still use all of my USB controllers (like my steering wheels, joysticks, etc?)
    I really havent even turned on my iMac... been too amazed at just looking at it for the first day (and also rearranging my home office).
    I really just want to know from those of you who have PCs AND Macs, if you still find yourself having to go back to your PC because of incompatibilities or performance issues on the iMac?

    Using BootCamp, your Windows experience is no different than if running it on a similarly configured PC. If you went with a VM running under Mac OS X (like VMWare or Parallels), there are a number of differences. However, using BootCamp you have a Mac-branded PC.
    I'd point out that people have been dual-booting operating systems in this fashion for decades. Windows has no obvious in-built support for doing so, but other operating systems (like Linux, FreeBSD, etc.) have always very clearly and explicitly supported dual-booting (on Macs and regular PCs) from the get go.

Maybe you are looking for

  • How do I make my calendar look like a calendar and not a list!

    My calendar is a list...I want it to look like a wall calendar. I switched from Entourage to mail and can not figure out how to change the way the calendar displays.

  • Problem while creating Dimension in AW...

    Hi I m facing error while creating the Dimension in AW. i have done the following steps. 1.I have created the AW name "myfirstaw" and i can see the AW in my DB. 2.I have a DIm table Products. 3.i have attached the AW using below command EXECUTE DBMS_

  • EM for Coherence - Cannot automatically start departed storage enabled nodes

    Hi Guru, I have a cluster with 4 storage enabled nodes. I want EM to monitor those 4 storage enabled nodes and automatically bring up nodes if  down.  So i set the "Nodes Replenish and Entity Discovery Alert Metric -> Cluster Size Change (To Replenis

  • Spooling stops

    When I attempt to print from a Quad G5 Mac w/4 gigs of RAM to an Epson 7600 printer using Photoshop CS3, spooling starts and then almost immediately stops. I am running Leopard 10.5.2 and using the latest driver available for my PPC machine from Epso

  • ITunes 10.5 problem

    Am using a PC here on Windows 7. Recently updated to iTunes 10.5 and after doing that my iTunes couldn't read my iPod and recommended a restore. After trying many ways I still couldn't get working so i restored it but then it couldn't sync my iPod sa