Remote debugging through NAT - VS2013, C#

I need help figuring out how to initiate a remote debugging session when the target computer is across the internet and behind NAT. VS2013 and a C# application, .net 4.5
Remote debugging works great here on my LAN, but now I need to connect to a remote stand alone (not on a domain) PC that is behind NAT; it's WAN IP is different from its LAN IP.  My development PC is also behind NAT.  I do not have access to the
remote firewall/router to configure port forwarding.  Is there any other way I can connect?  Are there any tools that will allow me to connect directly to the remote PC with the remote debugger, similar to how TeamViewer can connect to PC's even
though they're behind NAT? 

Hi Matt_FL,
Like this document here:
http://www.codeproject.com/Tips/618804/Remote-debugging-for-Visual-Studio-from-different
It shared us the detailed steps about how we setup the remote debugging if the Environments are not in the same domain.
So I'm afraid that we would check whether the Environments meet the requirements of remote debugging.
Reference:
https://msdn.microsoft.com/en-us/library/vstudio/bt727f1t%28v=vs.100%29.aspx?f=255&MSPPError=-2147217396#bkmk_setuptheremotecomputer
If the remote computer is protected by a firewall, you must configure the firewall to allow the Remote Debugging Monitor to communicate with the Visual Studio host computer.
If your network requires that communication be performed using IPSec, you must open additional ports in the firewall.
If you are debugging a process on a web server, you must open an additional port.
Other threads I met before:
https://social.msdn.microsoft.com/Forums/vstudio/en-US/0058a97a-8595-4235-88b1-7575aed2e2de/remote-debug-issuevisual-studio-remote-computer-can-not-back-connect-to-remote-computera-firewall?forum=vsdebug
https://social.msdn.microsoft.com/Forums/vstudio/en-US/897782e5-dada-4df1-8ef2-f119cdce7e5e/remote-debugging-over-internetMaybe
you could refer to them, hope it could provide useful information.
But as far as I know, we could remote debugging with WAN even if it has some specific requirements.
Reference:
http://stackoverflow.com/questions/5091207/net-remote-debugging-domain-networking-issues
If I have misunderstood this issue, please feel free to let me know.
Best Regards,
Jack
We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
Click
HERE to participate the survey.

Similar Messages

  • Remote debugging through firewall - debug_jdwp.connect_tcp

    I'm trying to debug in SQL Developer through a firewall.
    Is there a way to have DBMS_DEBUG_JDWP.CONNECT_TCP('<client ip>', '<client port>') initiate the connection from the client side? Our firewall blocks the incoming connection from the DB server. Even if we open the port, the NAT has to use port forwarding since it doesn't know who made the debug request.
    Thanks

    Are you using the package to connect to the debugger
    and then try to debug the procedure in the same
    package?
    YES
    >
    Can you provide us a simple snipplet for us to look
    into?
    Here it is:
    PACKAGE BODY TESTDEBUG_PCK IS
    procedure Test_debug(
    p_param IN varchar2,
    p_outmsg OUT varchar2
    AS
    BEGIN
    DBMS_DEBUG_JDWP.CONNECT_TCP('debughost', '49152');
    p_outmsg := 'Test_debug ' || p_param; -- Breakpoint here
    END Test_debug;
    END TESTDEBUG_PCK;
    Thanks
    Martha

  • How to use Remote Debugging in JDeveloper 3.1 ?

    I am trying to use the Remote Debugging option with EJBs in JDeveloper 3.1 with Oracle8i 8.1.6.
    I checking all steps the online walkthrough for Remote Debugging EJB in 8i and it didn't work.
    I'm using Oracle8i EJB/CORBA debug option in project properties, but it does not stop in my EJB's break points.
    I tried deploying the EJB again ( with break points) and again it didn't work.
    The error message I got in the trace file is:
    Errors in file D:\Oracle\admin\SCT\udump\sctS000.TRC:
    ORA-29516: Aurora assertion failure: Java thread deadlock detected
    Could someone please tell me how to use it?
    null

    Which platform is the database running on ??
    Other things you should check -
    when debugging the EJB, JDev
    3.1 looks through your IIOP connections to find the one to use.
    Make sure that the IIOP connection that JDev is using for the debugging matches the IIOP connection that the EJB client application is using.
    raghu
    null

  • Remote debugging with APEX and SQL Developer

    Hi,
    I have problems concerning breakpoints within my SQL Packages I want to debug.
    I want to force SQL-Developer to suspend execution of a function, so I can get forward step by step.
    The SQL-Developer do not stop executing at the breakpoints I set in the Package.
    The message I get is the following (on SQL-Developer side):
    Debugger accepted connection from remote process on port 4000.
    Processing 110 classes that have already been prepared...
    Finished processing prepared classes.
    Debugger disconnected from remote process.
    Seems to me, that the process runs into the debug-mode but leave without stopping at a given breakpoint??
    Do anybody have an idea how to solve it?
    We use Oracle 10.2.0.3.0, SQL Developer 1.5.1 and APEX 3.1.2.
    The Package-function I want to debug runs on another Oracle database as the APEX application.
    Thanks in advance
    Regards
    Norbert
    Edited by: Norbert2 on Apr 20, 2009 5:47 AM

    Hi Carsten,
    now I have done a further step. I can debug a remote PL/SQL-Package through APEX, but now I get an exception when the program execution jumps back to the APEX PL/SQL-Package.
    My APEX-Page-Process looks like this:
    BEGIN
      dbms_debug_jdwp.connect_tcp(host => 'IP-ADDRESS', port => '4201');
      APEX_TEST_PKG.remoteDebug;
      dbms_debug_jdwp.disconnect;
    END;The procedure APEX_TEST_PKG.remoteDebug looks like this (located on the APEX-DB):
    PROCEDURE startRemoteDebug
      AS 
        v_string    VARCHAR2(50)   := '';
      BEGIN
        [email protected](host => 'IP-ADDRESS', port => '4000',
                 option_flags => dbms_debug_jdwp.connect_defer_suspension);
        v_string := [email protected];
        DBMS_OUTPUT.PUT_LINE(v_string);
        [email protected];
      END remoteDebug; The procedure REMOTE_TEST_PKG.testFunc looks like this (located on the Remote-DB):
    FUNCTION testFunc RETURN VARCHAR2
      AS 
        v_string    VARCHAR2(50)   := '';
      BEGIN        
        v_string := 'Test';
      RETURN v_string;
    END testFunc; When I start the debug session without the option dbms_debug_jdwp.connect_defer_suspension, I get an exception Oracle.EXCEPTION_ORA_604.
    Starting the debug session with the above mentioned option, I am able to debug the remote function.
    But now I get an exception when the executor tries leaving the remote function going back to the invoking function. With the debugger I can step over the return-statment successfully and the debugger steps on the next line END testFunc;. On this line I get the exception above
    Exception breakpoint occurred at line -1 of PBREAK.pls.
    $Oracle.Builtin.EXCEPTION_USER:
    Exception breakpoint occurred at line -1 of PBREAK.pls.
    $Oracle.Builtin.EXCEPTION_USER: I tried another way where I get now exception and where I can step through my functions in APEX, descending to functions in the remote db and going back to APEX.
    For this case I put the debug-statements in remote function:
    FUNCTION testFunc RETURN VARCHAR2
      AS 
        v_string    VARCHAR2(50)   := '';
      BEGIN        
        dbms_debug_jdwp.connect_tcp(host => 'IP-ADDRESS', port => '4000');
        v_string := 'Test';
        dbms_debug_jdwp.disconnect;  
      RETURN v_string;
    END testFunc; But I have no idea why it doesn't work properly starting the remote debug session in the apex procedure.
    Regards
    Michael
    Edited by: user6044915 on 02.09.2009 04:08
    Edited by: user6044915 on 02.09.2009 04:21
    Edited by: user6044915 on 02.09.2009 04:28

  • CF Builder w/ Coldfusion 9 remote debugging problem

    Have coldfusion9 installed on my linux server, everything works fine, can access the admin page, run basic files, etc.
    Have CF Builder Beta installed on mac, can write CF files and run them from linux server.
    Trying to get remote debugging working and following the directions for starting up the Authentication server via adminstart.sh, runs fine, changed security.properties ips to be *.  When I create the server definition in CF Builder I see on the Authentication server:
    error Authentication failed: Login Failed
    Even though I have enabled RDS, Debugging, etc via server config and i enter same name/pw (admin/mypassword) as when I login via web.
    Therefore, I'm unable to control the server and when I try to debug, it says it launches but refuses to stop at any breakpoints.
    Any help appreciated as I've read through as many docs as I can find and haven't been able to resolve this.
    Thanks

    Make sure that the port is not blocked by the firewall. Also, check this : http://forums.adobe.com/message/2636413

  • I need to be able to debug through cfc code

    I need to be able to debug through cfc code being called from a Flex app remote object. I know how to debug straight cfm code using cfeclipse for flex builder but am unable to figure how to get this working for cfc's. If I set a break point in my cfc and start my coldfusion debugging session in Flex Builder and run my flex app and get it to call the cfc the debugger doesn't stop.
    Any ideas? Do i need to modify the Flex-config?

    Write a simple cfm page that invokes the method in question.  Do whatever you have to do to get the cfc working properly.  After that, don't touch it.  Subsequent problems will be due to something else.

  • Remote debugging

    Is it possible to set up IFS to enable remote debugging?
    I'd like to be able to attach JDeveloper debugger to the IFS JVM.
    I run IFS on a remote machine.
    Thanks,
    Roman
    null

    Roman,
    Have you checked the online help in Jdeveloper there is a lot of information on remote debugging.
    If you use 1.1 you should check the following which I've copied from the online help:
    Configuring Apache JServ for Remote Debugging Java Server Pages
    If you are using Apache Jserv, you can debug using either the Oracle Java Virtual Machine (JVM) debugging protocol or the Sun Java Platform Debugging Architecture (JPDA). When you start your remote debugging session, you will have to choose which method to use. Depending on which one you choose, your configuration options are a little different.
    Using Oracle's JVM
    To use Oracle's JVM debugging protocol, you'll need to change the JVM that Apache JServ uses, modify the parameters you send to the JVM, and modify the CLASSPATH for Apache JServ.
    These changes must be made on the computer that is hosting Apache JServ. If you do not have permission to make these changes, talk with your administrator.
    Changing the JVM
    In the jserv.properties file, set the wrapper.bin parameter to the full path of the JDeveloper JVM (java.exe). For example,
    wrapper.bin=C:\Program Files\jdeveloper\java1.2\bin\java.exe
    Setting parameters
    In jserv.properties, set the wrapper.bin parameter to
    wrapper.bin.parameters=-XXdebugondemandquietport4000
    The -XXdebug parameter options are the following:
    ondemand
    Start the java program right away and allow a debugger to connect any time. Without this option, the Java program stays halted until a debugger is connected.
    port4000
    Debugger must connect at the specified port. Without this option, the port is 4000.
    quiet
    Don't print connection messages. Without this option, connection messages are sent to standard error.
    Changing the ApJServerAction entry
    In jserv.conf comment out any existing ApJServAction .jsp entries by putting a # at the beginning of the line.]
    #ApJServAction .jsp /servlets/org.gjt.jsp.JSPServlet
    Add a new ApJServAction .jsp entry
    ApJServAction .jsp /servlets/oracle.jsp.JspServlet
    Adding servlet init parameters
    In the servlet init parameters section of the zone.properties file, add the following lines.
    servlet.oracle.jsp.JspServlet.initArgs=emit_debuginfo=true
    servlet.oracle.jsp.JspServlet.initArgs=jspcompiler=oracle.jdeveloper.jsp.JspOjcCompiler
    servlet.oracle.jsp.JspServlet.initArgs=classpath=C:\Program Files\Oracle\JDeveloper\java1.2\jre\lib\rt.jar
    Setting the CLASSPATH
    In jserv.properties, set wrapper.classpath to
    wrapper.classpath=C:\Program Files\Oracle\JDeveloper\jswdk-1.0\lib\servlet.jar
    Make sure that the location of ApacheJServ.jar is specified.
    wrapper.classpath=C:\Program Files\Apache JServ\ApacheJServ.jar
    Comment out the location of jsdk.jar.
    #wrapper.classpath=C:\jsdk2.0\lib\jsdk.jar
    Using JPDA
    To use JPDA debugging protocol, you'll need to modify the parameters you send to the JVM, tell the server how to find the JDPA library, and modify the CLASSPATH for Apache JServ.
    These changes must be made on the computer that is hosting Apache JServ. If you do not have permission to make these changes, talk with your administrator.
    Setting parameters
    In jserv.properties, set the wrapper.bin parameter to
    wrapper.bin.parameters=-classic -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=4000 -Xdebug -Xnoagent -Djava.compiler=NONE
    To see the invocation options for JPDA, see Sun VM Invocation Options.
    If you are running on Solaris, you may also need to include stdalloc=y as part of the -Xrunjdwp paramater, like the following:
    wrapper.bin.parameters=-classic -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=4000,stdalloc=y -Xdebug -Xnoagent -Djava.compiler=NONE
    Adding the JPDA library
    In jserv.properties, set wrapper.path to include the location of jdwp.dll. This file is is part of the Java Platform Debugging Architecture.
    wrapper.path=D:\jpda\bin
    If Apache JServ is running on Unix,
    setenv LD_LIBRARY_PATH /home/jpda/lib/sparc:$LD_LIBRARY_PATH
    setenv PATH /home/jpda/bin:$PATH
    where home/jpda is the path to your JPDA installation. In addition, you will have to pass that environment variable through Apache to the JVM. To do that, in jserv.properties, add the following line:
    wrapper.env.copy=LD_LIBRARY_PATH
    Setting the CLASSPATH
    In jserv.properties, set wrapper.classpath to
    wrapper.classpath=C:\Program Files\Oracle\JDeveloper\jswdk-1.0\lib\servlet.jar
    Make sure that the location of ApacheJServ.jar is specified.
    wrapper.classpath=C:\Program Files\Apache JServ\ApacheJServ.jar
    Comment out the location of jsdk.jar.
    #wrapper.classpath=C:\jsdk2.0\lib\jsdk.jar
    Let me know if this helps

  • How to make Form builder 10g step into libraries *.pll while remote debug

    How to make Form builder 10g step into libraries *.pll while remote debug. It attaches fine and goes through code located in form but skips pll's. In this case I am interested in debuging CUSTOM.pll. How to step into pll's and is it possible at all?

    Is the library in the same directory or within your FORMS_PATH? Note that the runtime setting in the default.env doesn't work for the builder.
    cheers

  • Debugging through DB link

    Hi guys,
    Anyone knows if it's possible to force debugging through a database link?
    In DB1 I have triggers and procedures that operate on the other DB2. If I debug a procedure in DB1, the debugger won't step into DB2's procedures and triggers. Like this I only get black box results of what really happened :-(
    I can't debug DB2's procedures separately, because the interaction with the triggers will be lost.
    Any ideas?
    Thanks,
    K.

    This is just speculation, I have no idea if this is possible.
    You could try using the remote debugging facility in conjunction with the local debugging.
    To use remote debugging you do the following
    1 Start a debug listener in SQLDeveloper
    2 Connect to the listener from the remote session (using EXEC DBMS_DEBUG_JDWP.CONNECT_TCP('remote1', '4000');)
    In your case you can't do step 2 directly because you don't have a session in the remote database until the triggers call the remote database. You would have to modify your DB2 (if you'll pardon the expession) code to make the call to dbms_debug_jdwp, perhaps in a package initialisation.
    So your steps would be
    Set breakpoints in DB2
    Start a debug listener in sqldeveloper
    Start a local debug session
    Go...
    In theory, when you hit the remote breakpoints, you will get a new debug session in the remote database. I think you will have two debug windows, but that shouldn't be a problem as only one will be "running" at a time.
    I can think of all sorts of reasons why this won't work, but if you get it working, you could post it as a tip on SD exchange
    In theory,

  • Remote Debugging Web App

    I have been trying to get remote debugging working on my web role but it will not connect. It worked once but since then it has not worked. It keeps telling me the following error:
    The Microsoft Visual Studio Remote Debugging Monitor (MSVSMON.EXE) does not appear to be running on remote computer.
    I have tried disabling my firewall and configuring the firewall to allow visual studio through but it has no effect. Remote debugging is enabled in the portal. 

    The website works fine. There were a lot of errors initially which I wanted to remote debug, but now it is going fine. I would just like the capability for the future. I looked into the eventlog.xml file and I found this:
    View Msvsmon's help for more information.</Data><Binary>08005E80</Binary></EventData></Event><Event><System><Provider Name="Visual Studio Remote Debugger"/><EventID>1001</EventID><Level>3</Level><Task>0</Task><Keywords>Keywords</Keywords><TimeCreated
    SystemTime="2015-04-03T00:27:08Z"/><EventRecordID>3804562</EventRecordID><Channel>Application</Channel><Computer>RD000D3A304CD4</Computer><Security/></System><EventData><Data>Msvsmon
    was unable to start a server named '127.0.0.1:49716'. The following error occurred: An instance of the remote debugger is already running on this computer, or another process is already bound to the specified TCP/IP port.
    Any idea what to do about this error?

  • Remote debugging on iPlanet 60sp5

    I'm trying to get remote debugging working on iPlanet (Sun Web Server) version 60sp5 using jdk1.4.1. I think I've set all the setting correctly, but I get the error "Connection refused; Fatal error: Unable to attach to target VM."
    Here are how things are set:
    jvm12.conf for the server contains:
    [JVMConfig]
    jvm.enableDebug=1
    jvm.compiler=NONE
    jvm.option=-classic
    jvm.option=-Xnoagent
    jvm.option=-Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=3999
    The the $ADMIN_SERV/start-jvm file contains:
    # cat start-jvm
    NSES_JDK=/usr/j2sdk1.4.1; export NSES_JDK
    NSES_JRE=${NSES_JDK}/jre; export NSES_JRE
    NSES_JRE_RUNTIME_LIBPATH=${NSES_JRE}/lib/sparc:${NSES_JRE}/lib/sparc/server:${NSES_JRE}/lib/sparc/classic:${NSES_JRE}/lib/sparc/native_threads:${NSES_JDK}/lib/sparc; export NSES_JRE_RUNTIME_LIBPATH
    <snipped the rest>
    I've stopped and restarted the admin server and the server instance I'm trying to debug.
    When I run jdk 1.4 jdb, I get:
    #/usr/j2sdk1.4.1/bin/jdb -attach 3999
    java.net.ConnectException: Connection refused
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    <snip>
    com.sun.tools.example.debug.tty.VMConnection.attachTarget(VMConnection.java:346)
    at com.sun.tools.example.debug.tty.VMConnection.open(VMConnection.java:168)
    at com.sun.tools.example.debug.tty.Env.init(Env.java:63)
    at com.sun.tools.example.debug.tty.TTY.main(TTY.java:829)
    Fatal error:
    Unable to attach to target VM.
    What detail am I missing? Or is JDK remote debugging not supported?
    Thanks in advance.
    Dave

    How to perform remote debugging on windows server under Microsoft Live Account?
    Host PC runs a Windows 8 signed in with a Microsoft Live Account. Target PC runs a Windows server 2012R2.
    I installed Remote tools for Visual Studio 2013.4 on Target PC.
    As I known, Windows server doesn't support Microsoft Live Account.
    Hello,
    Actually, we just need the system user account and the password of target pc, but the microsoft live account is just an account of local pc.
    For more details, you could refer to the following blog which is quite similar to VS2013.
    Running Visual Studio Remote Debugger in Domain Environment
    Regards,
    Carl
    This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites;
    therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure
    that you completely understand the risk before retrieving any software from the Internet.
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click
    HERE to participate the survey.

  • IP lan can't acces remote network through VPN

    hello
    i want my asa 5505 8.2(5) to access my proxy server on remote lan through VPN
    my VPN is OK, all PCs of local network can access to remote network.
    but ASA on local network can't access to remote network.
    i think it's a NAT problem but ....
    local network 192.168.157.0/24 local IP ASA 192.168.157.1
    remote netword 10.28.0.0 /16
    remote proxy 10.28.1.26
    my conf
    ASA Version 8.2(5)
    hostname ASACTM
    enable password GC3gU8Dqv5.xJLCr encrypted
    passwd GC3gU8Dqv5.xJLCr encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.157.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 90.89.245.154 255.255.255.248
    ftp mode passive
    access-list InOutside extended permit icmp any any
    access-list outside_1_cryptomap extended permit ip 192.168.157.0 255.255.255.0 10.28.0.0 255.255.0.0
    access-list inside_nat0_outbound extended permit ip 192.168.157.0 255.255.255.0 10.28.0.0 255.255.0.0
    access-list inside_nat0_outbound extended permit ip 192.168.157.0 255.255.255.0 192.168.57.0 255.255.255.0
    access-list VPNRACTM_splitTunnelAcl standard permit 192.168.157.0 255.255.255.0
    access-list InInside extended permit tcp 192.168.157.0 255.255.255.0 10.28.0.0 255.255.0.0 eq www
    access-list InInside extended deny tcp 192.168.157.0 255.255.255.0 any eq www
    access-list InInside extended permit ip any any
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500ip local pool POOLIPVPNCTM 192.168.57.1-192.168.57.254 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    access-group InInside in interface inside
    access-group InOutside in interface outside
    route outside 0.0.0.0 0.0.0.0 90.89.245.155 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.157.0 255.255.255.0 inside
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map 1 match address outside_1_cryptomap
    crypto map outside_map 1 set pfs
    crypto map outside_map 1 set peer 90.80.215.141
    crypto map outside_map 1 set transform-set ESP-3DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash md5
    group 2
    lifetime 86400
    telnet 192.168.157.0 255.255.255.0 inside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside
    dhcpd address 192.168.157.121-192.168.157.150 inside
    dhcpd dns 10.28.1.16 194.2.0.20 interface inside
    dhcpd wins 10.28.1.16 10.28.1.7 interface inside
    dhcpd domain vignes.local interface inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    group-policy VPNRACTM internal
    group-policy VPNRACTM attributes
    vpn-tunnel-protocol IPSec
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value VPNRACTM_splitTunnelAcl
    default-domain value vignes.local
    username admin password 6QiRA9AlUbU.gFTP encrypted privilege 0
    username admin attributes
    vpn-group-policy VPNRACTM
    username ICS1 password 5nDKAM1RJweYzrBO encrypted privilege 0
    username ICS1 attributes
    vpn-group-policy VPNRACTM
    tunnel-group 90.80.215.141 type ipsec-l2l
    tunnel-group 90.80.215.141 ipsec-attributes
    pre-shared-key *****
    tunnel-group VPNRACTM type remote-access
    tunnel-group VPNRACTM general-attributes
    address-pool POOLIPVPNCTM
    default-group-policy VPNRACTM
    tunnel-group VPNRACTM ipsec-attributes
    pre-shared-key *****
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:e2c2e2223cb7d5d83af808bb0a2b2636
    : end
    thanks a lot

    What do you mean by you would like the ASA to access the proxy server at the remote end?
    What configuration/command have you configured on the ASA for the ASA itself to access the remote proxy server?
    Do you want the PC behind the ASA to access the remote proxy server, or you want the ASA itself to access the remote proxy server?
    How do you want to access the proxy server?

  • How to remote debugging EJB in JDeveloper?

    Here is the procedure I follow
    1. configure weblogic startWebLogic.cmd file according to the instruction and start it
    2. create a EJB project contains HelloWorld.java, HelloWorldBean.java, HelloWorldHome.java and Client.java, Bean has one method hello(), just return a String
    3. in JDeveloper, configure project properties, set RUN/DEBUG to Remote Debugging as the instruction provided by Oracle
    4. Then how should I do next?
    select Client.java --> Debug --> attach it to the target weblogic
    select HelloWorldxxx.java --> Debug --> attach it to the target weblogic
    I tried the above and it attached to weblogic, after that, the program suspend there, nothing happen, no debug message, no outcome...
    I have a question, the project have no EJB Descripter, How Client.java test program find EJB interface through JNDI?
    Thanks
    -- CHENLW --
    Client.java
    ==// Copyright (c) 2000 qingniao
    ==package com.chemuser.ejb.HelloWorld;
    ==import javax.ejb.*;
    ==import javax.naming.*;
    ==import java.rmi.*;
    ==import java.util.Properties;
    ==
    ==/**
    == * A Class class.
    == * <P>
    == * @author chenlw
    == */
    ==public class Client {
    ==
    == public static void main(String[] args) {
    == try {
    == Properties props = System.getProperties();
    ==
    == Context ctx = new InitialContext(props);
    == HelloWorldEJBHome home = (HelloWorldEJBHome)ctx.lookup("HelloHome");
    == HelloWorldEJB hello = home.create();
    ==
    == System.out.println(hello.hello());
    ==
    == hello.remove();
    == } catch (Exception ex)
    == {
    == ex.printStackTrace();
    == }
    ==
    == }
    ==}
    ==
    ==
    null

    Programming EJB with JDeveloper is not as easily as JBuilder4.0.
    I am regret that I must give up JDevelopper which I like most.
    Hope JDev Team will enhance these functions in the future.
    Thanks
    CHENLW

  • TACACS+ requests through NAT device

    Hi everyone.
    I want to Authenticate and Authorize VTY-Access to Cisco devices using TACACS+. The config is pritty "straight forwasrd", BUT:
    I want to forward the TACACS+ Request through a NAT device and on to the "Internet" where the TACAS+ server is located. (ACS 3.3)
    2 Questions in this situation appeares:
    - Does TACACS+ protocol support request through NAT devices?
    - Is it possible to connect different devices begind the NAT device, using only one Outside NAT IP address? (Using the same secret key for all aaa-clients and on the ACS)
    As you see, i want to connect "as many aaa-clients as possible" to a TACACS+ Server with "as easy = less configuration changes, as possible" .
    I know VPN's are options as well, but it is not prefered in my design.
    Best Regards
    Jarle Steffensen

    As far as I know what you propose will work. You are the only one who knows what the local environment is and what the real requirements are and you must decide whether it is a good idea to do it this way.
    I do not see why passing the TACACS request through a NAT device would impact it, so long as the NAT was static or an overload (PAT). The request needs to get to the TACACS server with a consistent source address. If it was a dynamic NAT and one request came with one source address and the next request came with a different source address, it would only work if the TACACS server was configured with ALL of the possible translated addresses. (and part of your requirement is to simplify the config not to complicate it).
    If there are multiple devices sending requests to TACACS through the NAT device, it would look to the TACACS server as if there were a single remote device with lots of users. If you do not care that the TACACS server can not differentiate the remote devices then your solution should work. Do you want to be able to look at the TACACS reports and see that this successful (or that unsuccessful) attempt came from this machine or that machine? If you do not care then your solution should work. If you do care to differentiate the remote activity then you need a solution like VPN which maintains the individuality of the remote devices.
    HTH
    Rick

  • Eclipse Remote Debugging

    Hi all,
    I could not find the right place in the forum to log this error. If anyone knows kindly let me know.
    The issue is given below :-
    I have configured my Eclipse to perform Remote Debugging. I have a Borland Enterprise Server running to which my Eclipse connects at a particular port and
    allows me to debug i.e. Step Over, Step Through, Breakpoints etc.
    Since the calls between the compents of the server and client are basically corba calls i am not able to see the values of the variables when i step through the
    code in the eclipse.
    How do i resolve this.
    Thanks
    Ram

    Sorry!
              the debug option was NOT enabled (seems that my ant script is too
              complex at this stadium...)
              Cheers,
              Jan.
              [email protected] (Jan-Friedrich Mutter) wrote in message news:<[email protected]>...
              > Hi,
              >
              > I'd like to debug my Servlets/EJB's running on a Weblogic 6.1 SP4. My
              > IDE is Eclipse 2.1
              > To enable remote debugging I start Weblogic with that additional JVM
              > options:
              >
              > -classic -Xdebug -Xnoagent
              > -Xrunjdwp:transport=dt_socket,address=5000,suspend=y,server=y
              >
              > and configured my Remote Application in Eclipse accordingly.
              >
              > The connection successes.
              >
              > Problem: When I reach my breakpoint, Eclipse pops up an error message:
              > "Attempting to install a breakpoint in the type
              > com.xxx....
              > that has no line number attributes. The breakpoint cannot be
              > installed. Class files must be generated with the line number
              > attributes.
              > Reason:
              > Absent Line Number Information"
              >
              > I compiled my sources with enabled debug option.
              >
              > Any comments and ideas are appreciated.
              >
              > Cheers,
              > Jan.
              

Maybe you are looking for

  • Safari doesn't open, computer without other web browser

    Safari does not even open, simply quits unexpectedly within a few seconds. I have no other web browsers downloaded.

  • Adding artwork to .wav files

    Why can you not add artwork to .wav files? I am a DJ, and create mix cd's. I have iTunes 7. I wanted to use iTunes to burn the CD's, and I thought it would be nice for my listeners to have a copy of my album artwork for each particular CD. Is there n

  • Authentication fails in Accounts in SysPrefs

    In the Accounts panel in System Preferences, I click the padlock on the lower left to make changes. The label changes to "Authenticating..." and then returns to the state it was just in, namely "Click the lock to make changes" without opening any log

  • Business Packages for Higher Education

    Hi, I am looking for Business packages for Higher Education/Campus Management. I Found only one on SDN. Business Package for SAP Higher Education & Research 1.0 Are any other  Business packages available ? Regards Mark

  • Camera Raw 8.3 Workflow option no longer has a preset drop down to create custom presets.

    I do not know why I am no longer able to assign presets to my Camera Raw workflow.  The drop down in no longer available at the top.  Any suggestions on what I did to hide this, I would appreciate it. Thanks