Reverse Proxy Configuration help Needed

Hi,
What steps should i follow if i have both Sun Web Server 6.1.
Web Server 1 - http://192.168.20.40:768 (Want to use this as reverse proxy)
Web Server 2 - http://201.192.30.20:1010
Can anyone please guide me what changes i should do in obj.conf and magnus.conf.
Add this line in Magnus.conf
Init fn="load-modules" shlib="/appl/sunjs/SUNWwbsvr/plugins/passthrough/libpassthrough.so"
This libpassthrough.so location is in the Server 1.
Add the below line in obj.conf
<Object name="passthrough">
Service fn="service-passthrough" servers="http://team.yahoo.co.nz:1010"
</Object>
Do i need to do any changes to the obj.conf and magnus.conf in the Server 2.
Please let me know if i am going wrong.
Regards,

Hi,
Reverse Proxy Web Server - http://Sol9-dev.uname.yahoo.co.nz:8002
All request Want to redirect to - http://Sol10-dev.uname.yahoo.co.nz:8080
Obj.Conf
<Object name="default">
AuthTrans fn="match-browser" browser="*MSIE*" ssl-unclean-shutdown="true"
NameTrans fn="assign-name" from="/amserver(|/*)" name="reverse-proxy"
NameTrans fn="ntrans-j2ee" name="j2ee"
NameTrans fn=pfx2dir from=/mc-icons dir="/appl/sunjs/SUNWwbsvr/ns-icons" name="es-internal"
NameTrans fn=document-root root="$docroot"
PathCheck fn=unix-uri-clean
PathCheck fn="check-acl" acl="default"
PathCheck fn=find-pathinfo
PathCheck fn=find-index index-names="index.html,home.html,index.jsp"
PathCheck fn=validate_session_policy
ObjectType fn=type-by-extension
ObjectType fn=force-type type=text/plain
Service method=(GET|HEAD) type=magnus-internal/imagemap fn=imagemap
Service method=(GET|HEAD) type=magnus-internal/directory fn=index-common
Service method=(GET|HEAD|POST) type=*~magnus-internal/* fn=send-file
Service method=TRACE fn=service-trace
Error fn="error-j2ee"
AddLog fn=flex-log name="access"
</Object>
<Object name="j2ee">
Service fn="service-j2ee" method="*"
</Object>
<Object name="cgi">
ObjectType fn=force-type type=magnus-internal/cgi
Service fn=send-cgi user="$user" group="$group" chroot="$chroot" dir="$dir" nice="$nice"
</Object>
<Object name="es-internal">
PathCheck fn="check-acl" acl="es-internal"
</Object>
<Object name="send-compressed">
PathCheck fn="find-compressed"
</Object>
<Object name="compress-on-demand">
Output fn="insert-filter" filter="http-compression"
</Object>
<Object ppath="*/dummypost/sunpostpreserve*">
Service type=text/* method=(GET) fn=append_post_data
</Object>
<Object ppath="*/UpdateAgentCacheServlet*">
Service type=text/* method=(POST) fn=process_notification
</Object>
<Object name="reverse-proxy">
Service fn="service-passthrough" servers="http://sol10-dev.uname.yahoo.co.nz:8080"
</Object>
Log Messages
[22/Apr/2008:13:36:11] fine ( 4761): for host 10.112.66.87 trying to GET /amserver/, ntrans-j2ee reports: directory listing for context "/amserver"
[22/Apr/2008:13:36:11] fine ( 4761): GET requests for virtual server https-Sol9-dev-pa.uname.yahoo.co.nz can safely bypass ACL checks
[22/Apr/2008:13:36:11] fine ( 4761): for host 10.112.66.87 trying to GET /amserver/index.html, service-passthrough reports: PASS1022: passing request to http://Sol10-dev.uname.yahoo.co.nz:8080
[22/Apr/2008:13:36:11] fine ( 4761): for host 10.112.66.87 trying to GET /amserver/index.html, service-passthrough reports: PASS1037: not rewriting "Location: http://Sol9-dev.uname.yahoo.co.nz:8002/amserver/index.html" from http://Sol10-dev.uname.yahoo.co.nz:8080
[22/Apr/2008:13:36:11] fine ( 4761): for host 10.112.66.87 trying to GET /amserver/UI/Login, service-passthrough reports: PASS1022: passing request to http://Sol10-dev.uname.yahoo.co.nz:8080
[22/Apr/2008:13:36:11] fine ( 4761): for host 10.112.66.87 trying to GET /amserver/UI/Login, service-passthrough reports: PASS1037: not rewriting "Location: http://Sol10-dev.uname.yahoo.co.nz:8002/amserver/UI/Login" from http://Sol10-dev.uname.yahoo.co.nz:8080
Now i do not have anything in the reverse proxy server /amserver apart from the index.html (http://Sol9-dev.uname.yahoo.co.nz:8002/amserver/index.html)
I guess i do not need to have the same application on the reverse proxy as of the original server where i am redirecting.
Hope to find a solution soon.
Thanks for all your help.
Reagrds,

Similar Messages

  • Reverse Proxy Configuration Help

    I am running OFM 11.1.1.6.
    Web Cache is running on port 8888.
    Portal's OHS (the WebCache origin server) is running on 7777.
    Reports' OHS (for /reports/rwservlet) is running on 8890.
    Non-Oracle Apache 2.2 is running as a reverse SSL proxy for Portal on port 443.
    I want to configure this reverse proxy so that it appears to the end user that the reports server is also running in HTTPS on port 443, instead of on port 8890. Can anyone please give me a tip on how to set this up?
    In my httpd.conf for my Apache reverse proxy server, I have this within my main SSL virtual host:
    ProxyPassReverse / http://hostname:8888/
    ProxyPreserveHost On
    RewriteEngine On
    RewriteRule ^/(.*) http://hostname:8888/$1 [P]Do I need to add an additional virtual host for the proxy to the reports server? Or can I include it in this same virtual host? I've tried the following, but couldn't get it to work:
    ProxyPassReverse /reports/rwservlet/ http://hostname:8890/reports/rwservlet/
    ProxyPassReverse / http://hostname:8888/
    ProxyPreserveHost On
    RewriteEngine On
    RewriteRule ^/reports/rwservlet/(.*) http://hostname:8890/reports/rwservlet/$1 [P]
    RewriteRule ^/(.*) http://hostname:8888/$1 [P]Any guidance is appreciated.

    In case anyone finds this, this is how I got it all working:
    In httpd.conf for the Apache reverse proxy:
    ProxyPreserveHost On
    RewriteEngine On
    RewriteRule ^/reports/(.*) http://hostname:8890/reports/$1 [P]
    ProxyPassReverse /reports http://hostname:8890/reports
    RewriteRule ^/(.*) http://hostname:8888/$1 [P]
    ProxyPassReverse / http://hostname:8888/In the Portal OHS's httpd.conf:
    NameVirtualHost *:7777
    <VirtualHost *:7777>
         ServerName https://hostname
         RewriteEngine On
         RewriteOptions inherit
         UseCanonicalName On
         OssoConfigFile E:/ora11/product/portal_instance/config/OHS/ohs1/osso/osso_ssl.conf
         OssoIpCheck off
         OssoSecureCookies off
         OssoIdleTimeout off
    </VirtualHost>In the reports server's httpd.conf:
    NameVirtualHost *:8890
    <VirtualHost *:8890>
         ServerName https://hostname
         RewriteEngine On
         RewriteOptions inherit
         UseCanonicalName On
         OssoConfigFile E:/ora11/product/reports_instance/config/OHS/ohs1/osso.conf
         OssoIpCheck off
         OssoSecureCookies off
         OssoIdleTimeout off
    </VirtualHost>You can use the same osso.conf for both reports and portal. Make sure to register with SSO specifying https://hostname as the registered URL.

  • SAP Webdispatcher - Reverse Proxy Configuration

    Hi All,
    Need your help in configuration SAP Webdispatcher as reverse proxy. Currently we are using Apache as reverse proxy, but we are facing 400 Bad Request error and not able to solve the issue.
    So We are planning to install Webdispatcher and configure reverse proxy and test.
    Below is the Apache Reverse proxy configuration. Need help in configuring the same parameters in SAP Webdispatcher
    ProxyPass /sap http://srmerver:8000/sap
    ProxyPass /SRM-MDM  http://mdmserver:50100/SRM-MDM
    ProxyPass /mdmimages http://portalserver:8090/mdmimages
    ProxyPass /irj http://portalserver:50100/irj
    ProxyPass /saml2 http://portalserver:50100/saml2
    ProxyPass / http://portalserver:50100/ 
    ProxyPassReverse /sap http://srmserver:8000/sap
    ProxyPassReverse /SRM-MDM  http://mdmserver:50100/SRM-MDM
    ProxyPassReverse /mdmimages http://portalserver:8090/mdmimages
    ProxyPassReverse /irj  http://portalserver:50100/irj
    ProxyPassReverse /saml2 http://portalserver:50100/saml2
    ProxyPassReverse /  http://portalserver:50100/
    Regards
    Ponnusamy

    Hi
    Kindly refer the SCN link
    How to...Configure SAP Webdispatcher as a reverse proxy
    http://basisondemand.com/Documents/Whitepaper_on_SAP_Web_Dispatcher.pdf
    http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/a015cea3-9627-2e10-a792-8f39e3d0b59d?QuickLink=index&…
    Regards
    Sriram

  • Reverse Proxy Configuration - Apache as an SSL reverse-proxy

    Hi,
    We have EP 6.0 SP 14 installed with SSL configured.
    We are in need to open the application to internet.
    For the same we have set up a reverse proxy server (Apache as SSL
    Reverse Proxy).
    Our requirement is to open the application to the internet with
    web address https://abc.domain.com.
    The issue is we are able to access the application from internet only when
    https://abc.domain.com/irj/potal is typed.
    (ie.) Mapping is working fine for
    https://abc.domain.com/irj/portal to
    our EP Portal address https://abc2.domain.com:50001/irj/portal
    And not working for mapping https://abc.domain.com to our EP Portal
    address https://abc2.domain.com:50001/irj/portal
    We have been working on to resolve this issue for days together but have been really unsuccessful
    Kindly help us in resolving the same asap.
    Note : The references we used are:
    1. SAP's document:
    "Apache Reverse Proxy Configuration for J2ee 6.20 and 6.40 Web Applications"
    2. Weblogs:
    The Reverse Proxy Series -- Part 1: Introduction
    The Reverse Proxy Series -- Part 3: Apache as a reverse-proxy
    The Reverse Proxy Series -- Part 3.1: Apache as an SSL reverse-proxy
    Regards,
    venkat.

    Thanks much for the feedback. We're using the default settings on the HTTP rule we have set up for the portal on the ISA server. We'll be looking into the details of what the default rule settings are, however we did find a note in the Microsoft Knowledge base detailing with the ISA server screening high bits in URL strings for Outlook Web Access (OWA). This generates a similar error message. Here is the link to the detailed note on the Microsoft web site:
    http://support.microsoft.com/?scid=kb;en-us;837865
    Also,we are going to be applying the SP1 upgrade to the ISA server (released in March) to see if this might be some type of issue that may have been identified and corrected by the service pack. We'll see what happens with that.
    One area where we can recreate the problem at will is when we set up the system landscape configuration. We can navigate to a system configuration object, however when we attempt to right click to edit the object we get the error. There are other circumstances where we get errors but that is one that occurs for sure. Anyone have any idea as to what might be special about that type of transaction??
    Thanks again.
    Rich

  • Forward parameters in reverse proxy configuration

    Hi,
    Looking at the detailed configuration in a reverse proxy rule in SJSWS, I have derived the following conclusions:
    1) Where the SJSWS listener has SSL-enabled, reverse proxy works on a HTTPS in, HTTP out basis.
    2) Details in the incoming request's SSL header, such as User DN, will be stripped out and remapped into the outgoing request as a custom header, e.g. "Proxy-user-dn".
    Can anybody tell me if I have gotten anything wrong above?
    We are currently switching over from an Apache/mod_proxy/mod_ssl --> Apache/mod_jk --> Apache Tomcat server setup to a hybrid model where SJSWS is the web server reverse proxying to Tomcat (old apps) and SJSAS (new apps).
    My question:
    All our apps use the User DN string as the user ID. Previously, we developed a custom module in Apache to read the DN at the Apache level and then rewrite it into the Basic Auth user name header in the outgoing request. The Tomcat webapp will then authenticate the user based on the Basic Auth user name property. Is it possible for me to remap it into something similar here in the SJSWS reverse proxy configuration?
    Thanks!
    Wong

    I am not a reverse proxy expert, but this Object-type SAF should forward userdn
    http://docs.sun.com/app/docs/doc/820-1062/6ncoqnq3b?l=en&a=view&q=forward-user-dn
    You can look for more such SAFs in this document.

  • 1941W configuration help needed

    Our Deployment Scenario:-
    1941W Gigabit Ethernet 0/0 is connected to the PPOE connection of the ISP.
    Gigabit Ethernet 0/1 is connected to the wired LAN
    I have created 2 wireless radio Cisco_Kamran_BGN which is operating at 2.4 Ghz Devices and Cisco_Kamran_A which is operating at 5Ghz Devices.
    I have created 2 VLans for the Wireless.
    Vlan 10 for Cisco_Kamran_A        192.168.10.x
    Vlan 11 for Cisco _Kamran_BGN   192.168.11.X
    The problem is the Wireless users are not getting the IP address from the respective DHCP server which has been configured on the Router.
    Can please any from the community help me and show me where I am missing the configuration.
    Please find my router  & ap configuration below.
    Router Configuration
    Router#
    sh run
    Building configuration...
    Current configuration : 3022 bytes
    ! No configuration change since last restart
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Router
    boot-start-marker
    boot-end-marker
    enable secret 5 $1$TdQt$npYeaf/W0kRElcfMggzJ31
    no aaa new-model
    service-module wlan-ap 0 bootimage autonomous
    no ipv6 cef
    ip source-route
    ip cef
    ip dhcp excluded-address 192.168.1.1 192.168.1.50
    ip dhcp excluded-address 192.168.10.1 192.168.10.10
    ip dhcp excluded-address 192.168.11.1 192.168.11.10
    ip dhcp pool DHCP
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    dns-server 195.229.241.222 213.42.20.20
    ip dhcp pool Cisco_Kamran_A
    network 192.168.11.0 255.255.255.0
    default-router 192.168.11.1
    dns-server 195.229.241.222 213.42.20.20
    ip dhcp pool Cisco_Kamran_BGN
    network 192.168.10.0 255.255.255.0
    default-router 192.168.10.1
    dns-server 195.225.241.222 213.42.20.20
    multilink bundle-name authenticated
    crypto pki token default removal timeout 0
    license udi pid CISCO1941W-E/K9 sn FCZ1553C1VK
    hw-module ism 0
    redundancy
    bridge irb
    interface Embedded-Service-Engine0/0
    no ip address
    shutdown
    interface GigabitEthernet0/0
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    interface wlan-ap0
    description Service module interface to manage the embedded AP
    ip unnumbered GigabitEthernet0/0
    arp timeout 0
    no mop enabled
    no mop sysid
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    pppoe enable group global
    pppoe-client dial-pool-number 1
    interface Wlan-GigabitEthernet0/0
    description Internal switch interface connecting to the embedded AP
    switchport mode trunk
    no ip address
    interface Vlan1
    no ip address
    interface Vlan10
    ip address 192.168.10.1 255.255.255.0
    ip access-group DSL_ACCESSLIST in
    ip nat inside
    ip virtual-reassembly in
    interface Vlan11
    ip address 192.168.11.1 255.255.255.0
    ip access-group DSL_ACCESSLIST in
    ip nat inside
    ip virtual-reassembly in
    interface Dialer1
    ip address negotiated
    ip nat outside
    ip virtual-reassembly in
    encapsulation ppp
    dialer pool 1
    ppp authentication pap callin
    ppp pap sent-username xxxxxx password 0 xxxxxx
    ppp ipcp route default
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip nat inside source list DSL_ACCESSLIST interface Dialer1 overload
    ip access-list extended DSL_ACCESSLIST
    permit ip 192.168.0.0 0.0.255.255 any
    control-plane
    line con 0
    password xxxxxx
    login
    line aux 0
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line 67
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    line vty 0 4
    password xxxxxx
    login
    transport input all
    scheduler allocate 20000 1000
    end
    Router#
    Router#
    Router#
    Access Point Configuration
    ap#
    ap#
    ap#
    sh run
    Building configuration...
    Current configuration : 2603 bytes
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname ap
    enable secret 5 $1$JxdQ$a2/00bWJuhUKP9QLC94YD/
    no aaa new-model
    dot11 syslog
    dot11 ssid Cisco_Kamran_A
       authentication open
       authentication key-management wpa
       guest-mode
       wpa-psk ascii 7 1045081417161C5A555C7A7B
    dot11 ssid Cisco_Kamran_BGN
       authentication open
       authentication key-management wpa
       guest-mode
       wpa-psk ascii 7 020D05561907017015165949
    username Cisco password 7 14341B180F0B
    bridge irb
    interface Dot11Radio0
    description 802.11bgn radio
    no ip address
    no ip route-cache
    encryption mode ciphers aes-ccm
    broadcast-key change 3600
    ssid Cisco_Kamran_BGN
    antenna gain 0
    station-role root
    bridge-group 11
    bridge-group 11 subscriber-loop-control
    bridge-group 11 block-unknown-source
    no bridge-group 11 source-learning
    no bridge-group 11 unicast-flooding
    bridge-group 11 spanning-disabled
    interface Dot11Radio1
    description 802.11a radio
    no ip address
    no ip route-cache
    encryption mode ciphers aes-ccm
    ssid Cisco_Kamran_A
    antenna gain 0
    no dfs band block
    channel dfs
    station-role root
    bridge-group 10
    bridge-group 10 subscriber-loop-control
    bridge-group 10 block-unknown-source
    no bridge-group 10 source-learning
    no bridge-group 10 unicast-flooding
    bridge-group 10 spanning-disabled
    interface GigabitEthernet0
    description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router
    no ip address
    no ip route-cache
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    interface GigabitEthernet0.10
    description 802.11a bridge
    encapsulation dot1Q 10
    no ip route-cache
    bridge-group 10
    bridge-group 10 subscriber-loop-control
    bridge-group 10 block-unknown-source
    no bridge-group 10 source-learning
    no bridge-group 10 unicast-flooding
    bridge-group 10 spanning-disabled
    interface GigabitEthernet0.11
    description 802.11bgn bridge
    encapsulation dot1Q 11
    no ip route-cache
    bridge-group 11
    bridge-group 11 subscriber-loop-control
    bridge-group 11 block-unknown-source
    no bridge-group 11 source-learning
    no bridge-group 11 unicast-flooding
    bridge-group 11 spanning-disabled
    interface BVI1
    ip address dhcp client-id GigabitEthernet0
    no ip route-cache
    ip http server
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    bridge 1 route ip
    line con 0
    no activation-character
    line vty 0 4
    login local
    end
    ap#
    ap#
    ap#

    Hi Stepehen,
    Did the configuration as per your advice  but i am getting the below mentioned error which i have highlighted it in red. Please advice what needs to be done.
    Home
    Re: 1941W configuration help needed
    created by Stephen Rodriguez in Getting     Started with Wireless - View the full discussion
    conf t
    interface     Dot11Radio0
    no ssid     Cisco_Kamran_BGN
    no encryption mode     ciphers aes-ccm
    exit
    interface     Dot11Radio1
    no encryption mode     ciphers aes-ccm
    no ssid     Cisco_Kamran_A
    exit
    dot11 ssid     Cisco_Kamran_A
    vlan 10
    dot11 ssid     Cisco_Kamran_BGN
    vlan 11
    exit
    interface     Dot11Radio0
    encryption vlan 11     mode ciphers aes
    ssid     Cisco_Kamran_BGN
    exit
    interface     dot11radio0.1
    encapsulation     dot1q 1 native
    bridge-group 1
    interface     dot11radio 0.11
    encapsulation     dot1q 11
    bridge-group 11
    Configuration of     subinterfaces and main interface
    within the same bridge     group is not permitted
    exit
    interface     Dot11Radio1
    encryption vlan 10     mode ciphers aes-ccm
    ssid     Cisco_Kamran_A
    interface     dot11radio1.1
    encapsulation     dot1q 1 native
    bridge-group 1
    interface     dot11radio1.10
    encapuslation     dot1q 10
    bridge-group 10
    Configuration of subinterfaces and main     interface
    within the same bridge     group is not permitted
    end
    wr
    Reply to this message by going to Home
    Start a new discussion in Getting Started with Wireless at Home

  • Multiple ethernet network adaptors + MySQL/php5: configuration help needed

    I would be grateful if someone could give me some advice on how to configure multiple ethernet adapters under OS X 10.5.6
    I have set up my system to work nicely with two ethernet network adapters, each with its own fixed IP. This bit works just fine. The machine supports two separate servers - a mail server and the OS X Apache2 server. I have configured the mail server to only listen to one of the IPs, and the Apache2 server to listen to the other (via httpd.conf). The system also has MySQL and php5 installed / enabled, and these services are only used by the Apache2 server.
    The problem I have is that when I start the machine, initially the php5 system cannot connect reliably to the MySQL database system. The fix I have found is to temporarily make the ethernet adapter connected to the mail server 'inactive'. While this is so, the php5/MySQL connection to Apache2 works. Curiously, once an initial connection between php5 and MySQL has been made, subsequently I can make the mail server's ethernet adapter active again without further problems.
    I initially thought this might be due to 'service order' issues - but changing the service order (e.g. putting the Apache adapter 'above' the mail adapter in the service order does not help. The fix only works by making the mail adapter inactive temporarily.
    I suspect that there is some configuration change I can make to clarify the setup I have. The MySQL and Apache installations only need to talk to the Apache server - but I am not sure how to record this configuration in the OS X system.
    Thanks in advance for any assistance that you can provide.
    Message was edited by: Gavin Lawrie

    Hi Stepehen,
    Did the configuration as per your advice  but i am getting the below mentioned error which i have highlighted it in red. Please advice what needs to be done.
    Home
    Re: 1941W configuration help needed
    created by Stephen Rodriguez in Getting     Started with Wireless - View the full discussion
    conf t
    interface     Dot11Radio0
    no ssid     Cisco_Kamran_BGN
    no encryption mode     ciphers aes-ccm
    exit
    interface     Dot11Radio1
    no encryption mode     ciphers aes-ccm
    no ssid     Cisco_Kamran_A
    exit
    dot11 ssid     Cisco_Kamran_A
    vlan 10
    dot11 ssid     Cisco_Kamran_BGN
    vlan 11
    exit
    interface     Dot11Radio0
    encryption vlan 11     mode ciphers aes
    ssid     Cisco_Kamran_BGN
    exit
    interface     dot11radio0.1
    encapsulation     dot1q 1 native
    bridge-group 1
    interface     dot11radio 0.11
    encapsulation     dot1q 11
    bridge-group 11
    Configuration of     subinterfaces and main interface
    within the same bridge     group is not permitted
    exit
    interface     Dot11Radio1
    encryption vlan 10     mode ciphers aes-ccm
    ssid     Cisco_Kamran_A
    interface     dot11radio1.1
    encapsulation     dot1q 1 native
    bridge-group 1
    interface     dot11radio1.10
    encapuslation     dot1q 10
    bridge-group 10
    Configuration of subinterfaces and main     interface
    within the same bridge     group is not permitted
    end
    wr
    Reply to this message by going to Home
    Start a new discussion in Getting Started with Wireless at Home

  • Help with Apache Reverse Proxy configuration with SAP Portal and SAP Webgui

    Dear Experts,
    I have an issue configuring Apache to work with SAP Portal and ERP webgui. Accessing Portal through Reverse Proxy is working fine. But the problem arises when we try to open an iView ERP webgui transaction page from Portal with the Reverse Proxy. Have anyone implemented similar requirements and could advice on the configuration required on the Apache side? Thank you

    hi,
    pls check the below links for reference:
    https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/docs/library/uuid/24396589-0a01-0010-3c8c-ab2e3acf6fe2
    searchsap.techtarget.com/searchSAP/downloads/chapter-december.pdf
    1)Learn to implement the reverse proxy filter and portal gateway in SAP Enterprise Portal 6.0 on Web Application Server 6.40.
    https:/.../irj/sdn/nw-portalandcollaboration?rid=/webcontent/uuid/006efe7b-1b73-2910-c4ae-f45aa408da5b
    .2 )Configuring the Portal for Your Reverse Proxy Filter Solution . ... This document describes the reverse proxy filter mechanism in SAP Enterprise ...
    https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/32ad9b90-0201-0010-3c8a-c900cd685f8f
    3)have full reverse proxy functionality. Possibly. filter. requests. Internet ... Reverse proxy (optionally with authentication etc.) ...
    https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/docs/library/uuid/c066c390-0201-0010-3cba-cd42dfbcc8be
    Note:please reward points if solution found helpfull
    Regards
    Chandrakanth.k

  • Reverse Proxy Configuration - HPVM (Guest)

    Hello Unix Champs,
    On 11iV3 - Vm Guest -  we want to configure this server as reverse proxy
    Please share step by step procedure/documents to do same.
    Thanks in advance
    Regards,
    Prashant Behal

    Assuming your webserver is apache, you have to make the apache proxy-aware. This can be done statically (while building apache from source with --with-proxy option) or dynamically with a LoadModule directive.
    Once the above is done, you will need to write these directives in the apache httpd.conf:
    ProxyEnable Off
    ProxyPass /localurl remote-url
    ProxyPassReverse....
    In the OAM config, protect /localurl.
    For other webservers, read the documentation of that webserver.
    Hope this helps.

  • Printing Issue from ITS with a Reverse Proxy Configured

    Hi experts,
    We have an enterprise portal landscape which  can be accessed from the internet. The URLs are mapped using apache server as a reverse proxy. Also, we have configured the reverse proxy settings for accessing R/3 systems.
    When the users try to take the print out from the ITS Web GUI accessed through the enterprise portal, the page redirects itself to an only internally resolvable host name of the R/3 ITS.
    Due to this issue, users are not able to take prints from internet.
    I would like to know if there is any way by which i can change this to my externally resolvable reverse proxy host address, which in turn can be mapped internally to the original host name at the reverse proxy level.
    Can any one help me out in this?
    Thanks a lot
    Shobin

    Hi Shobin,
    SAP note 1145306 might provide some help about directives to be used.
    Regards,
    Dieter

  • OHS to Weblogic Reverse Proxy configuration Problem

    Hi,
    Pls go through the following points and suggest.
    1. I have an Access Manager in place and I need to integrate it with Webcenter and Oracle Identity Manager.
    2. I have only one webserver in place which is reverse proxied for both the application servers(OIM as well as Webcenter) and only one webgate installed.
    Can I achieve SSO with this architecture? My doubt is while specifying the challenge parameter in Access Manager,how can i specify it?

    Thanks for the reply. Let me detail you regarding my configuration.
    1. One webserver configured as reverse proxy for two app serrvers(weblogic1 for webcenter and weblogic2 for Identity manager)
    2. My reverse proxy config in httpd.conf file are as follows
    ProxyPass /webcenter http://app1:8888/webcenter
    ProxyPassReverse /webcenter http://app1:8888/webcenter
    ProxyPass /xlWebApp http://app2:7001/xlWebApp
    ProxyPassReverse /xlWebApp http://app2:7001/xlWebApp
    3. Created two policy domains for /webcenter and /xlWebApp and Iam using form based authentication scheme.
    My Challenge parameters as follows:
    form: /am_login/login.html (am_login.war is deployed on both app1 and app2)
    creds:userid password
    action:/dummy.cgi
    Now the problem is whenever http://webserverhost:7777/webcenter is accessed,it should redirect to http://webserverhost:7777/am_login/login.html. But its not happening so reason being,after hitting the url it is not able to find the am_login.war in /webcenter on the appserver.Instead its deployed on the root "/" not inside "/webcenter".
    Samething is happening for /xlWebApp too. Can you suggest some configuration which would make my things work?

  • SAPUI5 app and Reverse proxy configuration

    Hi
    Im trying to configure proxyserver for Cross origin resource sharing issue.
    The below steps i have configured in my machine.
    1. I have developed an application which consumes data through odata.
    2. Download and configured Apache server and enabled proxy module as per this url
    http://scn.sap.com/community/developer-center/front-end/blog/2013/06/29/solving-same-origin-policy-issue-in-different-ways
    3. In httpd.config file added the below reverse proxy setup
    ProxyPass /poodata http://HOSTNAME:8000/sap/opu/odata/sap/Z_PORDER_SRV/
    ProxyPassReverse /poodata http://HOSTNAME:8000/sap/opu/odata/sap/Z_PORDER_SRV/
    4. Changed my service url as
    var serviceUrl = "proxy/http/localhost/poodata";
    5. Also i have added java-property-utils-1.9.jar and cors-filter-1.8.jar then
    in web.xml i have added Eventhough its seems not neccessary.
      <filter>
      <display-name>CacheControlFilter</display-name>
      <filter-name>CacheControlFilter</filter-name>
      <filter-class>com.sap.ui5.resource.CacheControlFilter</filter-class>
      </filter>
      <filter>
      <filter-name>CORS</filter-name>
      <filter-class>com.thetransactioncompany.cors.CORSFilter</filter-class>
      </filter>
    6. Finally when i am executing the application throgh http://localhost:9080/SamplePO/ Its working. But Instead of localhost when im using IP address it shows NO DATA and throws the "500 internal server error - only allowed for local testing"
    also the application is trying to fetch data from 'http://10.130.41.158:9080/SamplePO/proxy/http/localhost/poodata/$metadata' where the location should be 'http/localhost/poodata/$metadata'.
    I want to access this application in my iPAD through WIFI by passing IP address followed by application name (http://10.130.41.158:9080/SamplePO).
    Please help me to fix this issue.
    Regards
    Yokesvaran Kumarasamy

    Hi Michael Herzog /  DJ Adams / Frank Welz,
    It seems you have v.good knowledge on this, can you please help with this issue.
    Thanks in Advance
    Regards
    Yokesvaran Kumarasamy

  • Generic Proxy pattern - help needed.

    Greetings!
    Lately i have been working on some design architecture to work on possible ways of designing message flows in OSB.
    I found one excellent solution called Generic Proxy pattern at: http://javamaster.wordpress.com/tag/osb/ .
    This pattern consists of four proxy services.
    Actually Generic Proxy pattern and proxy service are different. You can read more about pattern at : http://game-engineering.blogspot.com/2010/03/adapter-pattern-vs-proxy-pattern.html
    My problem is interesting and very straight forward.
    1. I have one proxy service which is created on client side WSDL.
    2. I have one business service created on legacy system WSDL.
    Now, if i want to implement this Generic Proxy pattern, I need to create two more proxy services in between my existing proxy service & existing business service.
    On what basis should these two proxy services should be created?
    Options in OSB to create a proxy service are : WSDL Web Service / Messaging Service / Any SOAP Service / Any XML Service / Business Service / Proxy Service
    If anybody has worked in this pattern, please help.
    Any inputs from everyone are welcome.
    Thanks and Regards,
    Swapnil Kharwadkar.

    The generic proxy service will be of type "messaging service" with input/output type as text/XML.

  • Reverse Proxy configuration

    Hi ,
    Shall I know to configure the reverse proxy server in DMZ along with HTTPS to HTTP redirection.
    Regards,
    Satyanarayana

    Please check, this is specific to Oracle EBS, but good doc to understand on Reverse Proxy
    Case History: Implementing a Reverse Proxy Alone in a DMZ Configuration - R12 (Doc ID 726953.1)

  • Reverse Proxy Configuration - (HPVM Guest) - 11iV3

    Hello Unix Champs,
    On 11iV3 - Vm Guest -  we want to configure this server as reverse proxy
    Please share step by step procedure/documents to do same.
    Thanks in advance
    Regards,
    Prashant Behal

    Hi,
    In addition to Luca's comment in order to determine if the farm is actually working correctly in the first instance, did you disable or remove the old server farm?
    Can you also confirm that there are no static routes in place on the IIS ARR box?
    Kind regards
    Ben
    Note: If you find a post informative, please mark it so using the arrow to the left. If it answers a question you've asked, please mark the thread as answered to aid others when they're looking for solutions to similar problems or queries.

Maybe you are looking for