Ruby Python handshake timeout OpenSSL 1.0.1

My development and production server both run Arch Linux.  I have a small ecommerce site which uses Net::HTTP to a remote API to process credit cards.  For some reason I'm getting timeout errors.  I've tested the same API on a Mac OS X machine and there are no issues.  So the issue seems to be with my Ruby installation or Arch Linux?
I've tried both Ruby 1.9.2 and 1.9.3, with no change.  I seems to have happened at some point during a package update as the problem first started on my development machine (which I update sooner), and now with my production machine which I must've updated a week ago.
***WORKAROUND***
This looks to be the same issue as discussed in this thread:
https://bbs.archlinux.org/viewtopic.php?id=138103
Looks like this issue is a result of upgrading to OpenSSL 1.0.1.  This also affects other software.  I tested under Ruby and Python, and had the same problem connecting to: https://esqa.moneris.com
The following versions I had still do work:
openssl-1.0.0.f
openssl-1.0.0.g
openssl-1.0.0.h
openssl-1.0.1-1 (does not work - handshake timeout)
Last edited by jamese (2012-03-28 16:54:41)

I should also note, that Telnet does work, so it may only be a Ruby issue.  The weird thing is that it did work (with Ruby 1.9.2 and Ruby 1.9.3).
I also re-installed Ruby using RVM instead of the Arch package, and still the same problem... so I guess this isn't a package problem?
Perhaps this thread could be moved?
Last edited by jamese (2012-03-27 20:45:07)

Similar Messages

  • WLC 4404 Upgraded to 7.0.235.3 (WPA HandShake Timeout) not availbale

    Greetings,
    Just upgraded my Cisco 4404 WLC's to 7.0.235.3, the upgrade went just fine. My problem is when I either Telnet or SSH to my Lightweight AP's and run the "DOT11 WPA Handshake Timeout 1000" command the AP doesn't recognized this command. This is one of the reasons I upgrade my WLC's.I have several wireless printers that are passive and are heavily used and keep getting disassociated because they don't respond in time.
    Any Help would be greatly appreciated.

    that command is for IOS AP, not for the WLC. 
    Q.    How do you change the Wi-Fi Protected Access (WPA) handshake timeout   value on a Wireless LAN Controller (WLC) through CLI? I know I can do this on   Cisco IOS® Access Points (APs) with the dot11 wpa handshake   timeout value command, but how do you   perform this on a WLC?
    A. The ability to configure the WPA-Handshake timeout through the WLCs was       integrated in software release 4.2 and later. You do not need this option in       earlier WLC software versions.
    These commands can be used to change the WPA Handshake timeout:
        config advanced eap eapol-key-timeout
        config advanced eap eapol-key-retries
    The default values continue to reflect the WLCs current       behavior.
       - the default value for eapol-key-timeout is 1 second.
       - the default value for eapol-key-retries is 2 retries
    Note: On IOS APs, this setting is configurable with the dot11           wpa handshake command.
    HTH,
    Steve
    Please remember to rate useful posts, and mark questions as answered

  • Ruby on Rails and openssl issue

    after a systemupdate ruby on rails isnt working anymore. it seems that the problem is openssl..
    at@at-book ~ $ ruby -ropenssl -rzlib -rreadline -e "puts :Hello"
    /opt/ruby1.8/lib/ruby/1.8/i686-linux/openssl.so: /opt/ruby1.8/lib/ruby/1.8/i686-linux/openssl.so: undefined symbol: each_conf_value_doall_arg - /opt/ruby1.8/lib/ruby/1.8/i686-linux/openssl.so (LoadError)
    from /opt/ruby1.8/lib/ruby/1.8/openssl.rb:17
    building the patched version from abs and downgrading openssl(just kills my system ) didn't work.
    any ideas or hins?
    thx

    ruby -ropenssl -rzlib -rreadline -e "puts :Hello"
    /usr/lib/ruby/1.9.1/openssl.rb:17:in `require': /usr/lib/ruby/1.9.1/i686-linux/openssl.so: undefined symbol: each_conf_value_doall_arg - /usr/lib/ruby/1.9.1/i686-linux/openssl.so (LoadError)
    from /usr/lib/ruby/1.9.1/openssl.rb:17:in `<top (required)>'
    from ruby:0:in `require'
    i also tried but changed nothing

  • What impacts has the extension of WPA Handshake timeout

    Hello folks,
    we use barcode scanner via WLAN. Unfortunately I have trouble with the authentication of the WLAN clients. The manufacturer of the barcode scanner recommended that I should extend the WPA handshake timeout to 2000 ms.
    All the APs in our network are managed by WLAN controller. My investigation shows me that the EAPOL-Key Timeout is already set to 1000 ms. This value is set on all APs which are managed by the controller. I have other SSIDs and applications running via WLAN. I looked for a description about the impacts of the extension of the WPA handshake timeout. But I couldn't find any.
    Has anybody here in the community experiences with the extension of the WPA handshake timeout and the possible impacts (e.g. to roaming)?
    Thanks for your support in advance.
    Peter

    Q. How do you change the Wi-Fi  Protected Access (WPA) handshake timeout value on a Wireless LAN  Controller (WLC) through CLI? I know I can do this on Cisco IOS® Access  Points (APs) with the dot11 wpa handshake timeout value command, but how do you perform this on a WLC?
    A. The ability to configure the WPA-Handshake timeout through  the WLCs was integrated in software release 4.2 and later. You do not  need this option in earlier WLC software versions.
    These commands can be used to change the WPA Handshake timeout:
        config advanced eap eapol-key-timeout
        config advanced eap eapol-key-retries
    The default values continue to reflect the WLCs current behavior.
       - the default value for eapol-key-timeout is 1 second.
       - the default value for eapol-key-retries is 2 retries
    Note: On IOS APs, this setting is configurable with the dot11 wpa handshake command.
    You can also configure the other EAP parameters with the options under the config advanced eap command.
    (Cisco Controller) >config advanced eap ?
    eapol-key-timeout
       Configures EAPOL-Key Timeout in seconds.
    eapol-key-retries
       Configures EAPOL-Key Max Retries.
    identity-request-timeout
       Configures EAP-Identity-Request Timeout in seconds.
    identity-request-retries
       Configures EAP-Identity-Request Max Retries.
    key-index
       Configure the key index used for
       dynamic WEP(802.1x) unicast key (PTK).
    max-login-ignore-identity-response      
       Configure to ignore the same username count
       reaching max in the EAP identity response
    request-timeout
       Configures EAP-Request Timeout in seconds.
    request-retries
       Configures EAP-Request Max Retries.

  • Script support (AppleScript, JavaScript, Ruby, Python, etc...)

    Hello,
    I frequently use Script feature with Audition 3.
    I want to revive the script feature!
    But, I don't like the syntax of past Audition script feature.
    I want to more popular script language support in Audition!
    BTW, I like Ruby language :-)
    Thanks,
    Hiroyuki

    I would obviously vote for Windows Scripting Host, since it gives you access to the .NET CLR, but there's the small caveat of OS lock-in...
    Either way, the ability to do disk operations, write your own GUI, even include network access and third-party API:s like Perforce has proven a godsend when scripting for Vegas. Whenever Vegas doesn't supply me with the tools I need, I can very often write them myself.

  • Building gVim with Ruby and Python support (for Windows)

    I would like to build gVim 7.3 with Ruby (1.8.7) and Python (3.2) support. For 32-bit Windows using 64-bit Linux.
    So, I downloaded everything what I need (ruby, python and vim sources), I installed mingw32 packages. Next, I modified vim makefile src/Make_ming.mak (as described here: http://people.smu.edu/jrobinet/howto/co … indows.asp) by adding ruby and python patches and versions.
    Finally, I tried to compile this:
    cd /tmp/vim/src
    make -f Make_ming.mak gvim.exe
    and I get quite strange result:
    make -f Make_ming.mak gvim.exe
    gcc -c -Iproto -DWIN32 -DWINVER=0x0500 -D_WIN32_WINNT=0x0500 -DHAVE_PATHDEF -DFEAT_BIG -DHAVE_GETTEXT -DHAVE_LOCALE_H -DDYNAMIC_GETTEXT -DFEAT_CSCOPE -DFEAT_NETBEANS_INTG -DFEAT_GUI_W32 -DFEAT_CLIPBOARD -DFEAT_MBYTE -DFEAT_MBYTE_IME -DDYNAMIC_IME -DDYNAMIC_ICONV -pipe -w -march=i386 -Wall -DFEAT_RUBY -I /tmp/ruby/lib/ruby/1.8/i386-mswin32 -I /tmp/ruby/include/ruby-1.8 -I /tmp/ruby/include/ruby-1.8/i386-mswin32 -DDYNAMIC_RUBY -DDYNAMIC_RUBY_DLL=\"msvcrt-ruby18.dll\" -DDYNAMIC_RUBY_VER=18 -DFEAT_PYTHON -DDYNAMIC_PYTHON -O3 -fomit-frame-pointer -freg-struct-return -s blowfish.c -o gobj/blowfish.o
    blowfish.c:1:0: error: CPU you selected does not support x86-64 instruction set
    blowfish.c:1:0: error: CPU you selected does not support x86-64 instruction set
    make: *** [gobj/blowfish.o] Błąd 1
    I'm a little confused, I use 64-bit Linux (C2D E6750 processor), but I want to build 32-bit program using 32-bit compiler, so why I need 64-bit instruction set? Any suggestions?
    I'm not very familiar with compilation. It is a good way to build custom gVim?
    Last edited by n0rv (2012-09-01 21:21:03)

    I was surprised too.
    Is very strange for me that a company like Nokia is currently supporting only 2 operative systems, as Vista and Xp and nothing more.
    I have also Win2000 in a partition and I have no intention to buy new OS from Microsoft. I'm using Linux (Ubuntu) and I hope that Nokia will be really open to support soon also Linux or MacOS etc.
    The market is moving more and more in the open source software and there are lots of advanced big spender users that don't want to use Microsoft software.
    If Nokia will not change the mind I'm expecting many users, as me, will move to Linux based phone instead of Nokia for the future.
    In this particular case I was able to upgrade my phone just in time, using the previous version of NSU but now, to do the same upgrade (same phone, same firmware) I'm forced to use the new NSU version which is not compatible anymore with Win2000.
    Why I cannot continue to use the same version if it can work properly? Will Nokia will consider a patch or some version which can be compatible with Win2000? What about Linux?
    Thank you

  • Ruby-enterprise 1.8.7-12: timeout.rb:60: [BUG] Segmentation fault

    Something in timeout.rb is making gem segfault.  There's discussion around the Internet about glibc 2.14 giving ruby a hard time, so perhaps this is relavant to the issue, being that we're on 2.15 now?
    $ sudo gem update --system
    /opt/ruby-enterprise/lib/ruby/1.8/timeout.rb:60: [BUG] Segmentation fault
    ruby 1.8.7 (2012-02-08 MBARI 8/0x6770 on patchlevel 358) [x86_64-linux], MBARI 0x6770, Ruby Enterprise Edition 2012.02
    Where line 60 lives:
    52 def timeout(sec, klass = nil)
    53 return yield if sec == nil or sec.zero?
    54 raise ThreadError, "timeout within critical session" if Thread.critical
    55 exception = klass || Class.new(ExitException)
    56 begin
    57 x = Thread.current
    58 y = Thread.start {
    59 begin
    60 sleep sec
    61 rescue => e
    62 x.raise e
    63 else
    64 x.raise exception, "execution expired" if x.alive?
    65 end
    66 }
    67 yield sec
    68 # return true
    69 rescue exception => e
    70 rej = /\A#{Regexp.quote(__FILE__)}:#{__LINE__-4}\z/o
    71 (bt = e.backtrace).reject! {|m| rej =~ m}
    72 level = -caller(CALLER_OFFSET).size
    73 while THIS_FILE =~ bt[level]
    74 bt.delete_at(level)
    75 level += 1
    76 end
    77 raise if klass # if exception class is specified, it
    78 # would be expected outside.
    79 raise Error, e.message, e.backtrace
    80 ensure
    81 if y and y.alive?
    82 y.kill
    83 y.join # make sure y is dead.
    84 end
    85 end
    86 end

    Yeah! Solved!
    Install gcc45 from the AUR, compile and install it, then download the ruby-enterprise from the AUR and compile it like so:
    CC=gcc-4.5 makepkg
    Install the compiled Ruby EE package, and wham, it works.

  • Compability problem with Java and Python  RSA algorithm implementation

    I have client server application. Server is writtein in python, client in java. Client receives messages from server encrypted with RSA (http://stuvel.eu/rsa), and I'm unable to decrypt it. It seems that this is RSA algorithm compatibility problem. I'm using algorithm from java.security package, instatinating Cipher object like this: c = Cipher.getInstance("RSA"); . I noticed that this algorithm produces for input blocks of lengtrh <=117 ouput block of length 128. Server I guess uses the most triviall impelentation of RSA ( (1 byte is encrypted to 1 byte) So i want to make my java algorithm compatibile with this one which server uses. How to do that ? Do i have to instatinate Cipher object in different way ? Or use another library ?

    azedor wrote:
    First you said it was no good because it could only handle <= 117 byte inputs, now you say it is no good because it produces a 128-byte output. You're not making sense.First i said that this two RSA implementations are not compatibile, and first reason i noticed firstly is that Python imlementation for input of length N produces cryptogram of the same length. Not true. In general, the RSA encryption of any number of bytes less than the length of the modulus will produce a result of length near that of the modulus. When N is less than the length of the modulus, it is rare that N bytes of cleartext produces N bytes of ciphertext.
    Java implementation for data block of length <=117 produces alwasy 128 bytes of output.Pretty much correct and very much desirable. This is primarily a function of the PKCS1 padding which is used to solve two basic problems. First, as I alluded to in my first response, it is the nature of the algorithm that leading zeros are not preserved and second when the cleartext is very small (a few bytes) the exponentiation does not roll over and it is easy to decrypt the result. Both these problems are addressed by PKCS1 padding.
    >
    >
    After what sabre150 said i think of giving up idea of translating Python code to Java and considering to use another assymetric cryptography algorithms on both sides. Can you recommend me sth what should be compatibile with Python ?This seems to be at odds with your statement in reply #3 "Also have acces only to client code so i have to change sth in java." ! This statement is why I said "I suspect ... you have dug a deep hole".
    In your position I would use the Python bindings for openssl. Once more, Google is your friend.

  • Mac Pro 3.1 (Early 2008) - Shuts down unexpectedly , Shuts down after 5-6 sec, On sleep it shuts down

    My Mac Pro is doing some weird things on random time frames, for example:
    -For 4-6 months it works perfectly, I mean it never shuts down unexpectedly and it goes to sleep mode without a problem but after that it goes back to this weird phase and after 2-3 days back to normal.
    In the last 3 years I have replaced the following components:
    Graphic Card (from Nvidia GeForce 8800GT to ATI Radeon HD 5770)
    Memory (From 10 GB to 32 GB)
    2x New Riser Cards
    New Power Supply
    New HDD
    Logic Board Battery
    With all these replacements I still have this issue, do you think the Logic Board is causing that?
    Please advice !!!

    Boot Mode: Normal
    JEDEC codes:
       0
    USB:
       Hub (D-Link Corporation)
       Ext HDD 1021 (Western Digital Technologies, Inc.)
       USB Receiver (Logitech Inc.)
       WIDI-XU v1.0a (Philips Consumer Lifestyle BV)
    System diagnostics:
       CVMCompiler,CVMCompiler,CVMServer,identityservicesd,launchd,laun 2014-02-03-031214 shutdownStall
    User diagnostics:
       LCCDaemon 2014-02-03-031149 crash
    Kernel messages:
       --- last message repeated 1 time ---
       Jan 28 00:30:18   Auth result for: 98:fc:11:b2:f2:9d Auth timed out
       Jan 28 00:31:13   AirPort: Link Down on en2. Reason 15 (4-Way Handshake timeout).
       Jan 28 00:35:45   USB Sound assertion in AppleUSBAudioDevice at line 286
       --- last message repeated 1 time ---
       Jan 28 00:38:04   USB Sound assertion in AppleUSBAudioDevice at line 286
       Jan 29 00:42:35   USB Sound assertion in AppleUSBAudioDevice at line 286
       --- last message repeated 1 time ---
       Jan 29 01:15:40   USB Sound assertion in AppleUSBAudioDevice at line 286
       Jan 30 00:47:30   USB Sound assertion in AppleUSBAudioDevice at line 286
       --- last message repeated 4 times ---
       Jan 30 20:41:19   USB Sound assertion in AppleUSBAudioDevice at line 286
       Feb 1 00:10:26   USB Sound assertion in AppleUSBAudioDevice at line 286
       --- last message repeated 3 times ---
       Feb 1 00:17:37   com_Logitech_HIPointing::terminate(kIOServiceSynchronous) timeout
       --- last message repeated 1 time ---
       Feb 1 01:58:44   USB Sound assertion in AppleUSBAudioDevice at line 286
       --- last message repeated 5 times ---
       Feb 1 15:48:05   USB Sound assertion in AppleUSBAudioDevice at line 7074
       --- last message repeated 3 times ---
       Feb 2 18:43:08   USB Sound assertion in AppleUSBAudioDevice at line 286
       --- last message repeated 11 times ---
       Feb 2 21:58:11   USB Sound assertion in AppleUSBAudioDevice at line 286
       Feb 2 23:09:31   USB Sound assertion in AppleUSBAudioDevice at line 286
       --- last message repeated 5 times ---
    Loaded extrinsic kernel extensions:
       com.Logitech.Control Center.HID Driver (3.8.1)
       com.Logitech.Unifying.HID Driver (1.3.1)
       com.caiaq.driver.NIUSBMaschineControllerDriver (2.6.0)
       com.paceap.kext.pacesupport.snowleopard (5.9.1)
    Extrinsic system jobs:
       com.paceap.pacesupport
       com.adobe.fpsaud
    Extrinsic agents:
       com.motu.MOTULauncher
       com.Logitech.Control
       com.eastwest.server
    launchd items:
       /Library/LaunchAgents/com.eastwest.server.plist
                 (com.eastwest.server)
       /Library/LaunchAgents/com.Logitech.Control Center.Daemon.plist
                 (com.Logitech.Control Center.Daemon)
       /Library/LaunchAgents/com.motu.MOTULauncher.plist
                 (com.motu.MOTULauncher)
       /Library/LaunchDaemons/com.adobe.fpsaud.plist
                 (com.adobe.fpsaud)
       /Library/LaunchDaemons/PACESupport.plist
                 (com.paceap.pacesupport)
    Startup items:
       /Library/StartupItems/PACESupport/PACESupport
       /Library/StartupItems/PACESupport/Resources/PACESupport.plist
       /Library/StartupItems/PACESupport/StartupParameters.plist
    Extrinsic loadable bundles:
       /System/Library/Extensions/Motu MIDI Driver.kext
                 (com.motu.driver.USBMidiKext)
       /System/Library/Extensions/MOTUFireWireAudio.kext
                 (com.motu.driver.FireWireAudio)
       /System/Library/Extensions/NIUSBMaschineController.kext
                 (com.caiaq.driver.NIUSBMaschineControllerDriver)
       /System/Library/Extensions/PACESupportFamily.kext
                 (com.paceap.kext.pacesupport.master)
       /Library/Audio/MIDI Drivers/Motu MIDI Driver.plugin
                 (com.motu.driver.USBMidi)
       /Library/Audio/MIDI Drivers/NIUSBMaschineControllerMIDIDriver.plugin
                 (No bundle ID)
       /Library/Audio/MIDI Drivers/NIUSBMIDIDriver.plugin
                 (No bundle ID)
       /Library/Audio/MIDI Drivers/YAMAHA-USBMIDIDriver.plugin
                 (jp.co.yamaha.USBMIDIDriver)
       /Library/Audio/Plug-Ins/Components/Absynth 5.component
                 (Absynth 5.MusicDevice.component)
       /Library/Audio/Plug-Ins/Components/Addictive Drums.component
                 (com.xlnaudio.addictivedrumsvstau)
       /Library/Audio/Plug-Ins/Components/Addictive Keys.component
                 (com.xlnaudio.addictivekeys)
       /Library/Audio/Plug-Ins/Components/Battery 3.component
                 (Battery 3.MusicDevice.component)
       /Library/Audio/Plug-Ins/Components/BFD2.component
                 (com.FXpansion.BFD2)
       /Library/Audio/Plug-Ins/Components/Engine.component
                 (com.yellowtools.engine)
       /Library/Audio/Plug-Ins/Components/FM8.component
                 (FM8.MusicDevice.component)
       /Library/Audio/Plug-Ins/Components/Guitar Rig 5.component
                 (Guitar Rig 5.MusicDevice.component)
       /Library/Audio/Plug-Ins/Components/Independence FX.component
                 (com.yellowtools.independence_fx2)
       /Library/Audio/Plug-Ins/Components/Independence.component
                 (com.yellowtools.independence2)
       /Library/Audio/Plug-Ins/Components/iZAlloy2AUHook.component
                 (com.izotope.audioplugins.AU.Alloy2)
       /Library/Audio/Plug-Ins/Components/iZInsightAUHook.component
                 (com.izotope.audioplugins.AU.Insight)
       /Library/Audio/Plug-Ins/Components/iZMeterTapAUHook.component
                 (com.izotope.audioplugins.AU.Meter Tap)
       /Library/Audio/Plug-Ins/Components/iZOzone5AUHook.component
                 (com.izotope.audioplugins.AU.Ozone5)
       /Library/Audio/Plug-Ins/Components/iZOzone5DynamicsAUHook.component
                 (com.izotope.audioplugins.AU.Ozone5DYN)
       /Library/Audio/Plug-Ins/Components/iZOzone5EqualizerAUHook.component
                 (com.izotope.audioplugins.AU.Ozone5EQ)
       /Library/Audio/Plug-Ins/Components/iZOzone5ExciterAUHook.component
                 (com.izotope.audioplugins.AU.Ozone5EXC)
       /Library/Audio/Plug-Ins/Components/iZOzone5ImagerAUHook.component
                 (com.izotope.audioplugins.AU.Ozone5IMG)
       /Library/Audio/Plug-Ins/Components/iZOzone5MaximizerAUHook.component
                 (com.izotope.audioplugins.AU.Ozone5MAX)
       /Library/Audio/Plug-Ins/Components/iZOzone5ReverbAUHook.component
                 (com.izotope.audioplugins.AU.Ozone5RVB)
       /Library/Audio/Plug-Ins/Components/Kontakt 4.component
                 (Kontakt 4.MusicDevice.component)
       /Library/Audio/Plug-Ins/Components/Kontakt 5.component
                 (Kontakt 5.MusicDevice.component)
       /Library/Audio/Plug-Ins/Components/Maschine 2.component
                 (Maschine 2.MusicDevice.component)
       /Library/Audio/Plug-Ins/Components/Maschine.component
                 (Maschine.MusicDevice.component)
       /Library/Audio/Plug-Ins/Components/Massive.component
                 (Massive.MusicDevice.component)
       /Library/Audio/Plug-Ins/Components/Omnisphere.component
                 (com.spectrasonics.Amber)
       /Library/Audio/Plug-Ins/Components/Play.component
                 (com.eastwest.Play)
       /Library/Audio/Plug-Ins/Components/QL Spaces.component
                 (com.eastwest.QL Spaces)
       /Library/Audio/Plug-Ins/Components/Reaktor5.component
                 (Reaktor5.MusicDevice.component)
       /Library/Audio/Plug-Ins/Components/RG_64.component
                 (com.RPCX.RG.component)
       /Library/Audio/Plug-Ins/Components/Solid Bus Comp.component
                 (Solid Bus Comp.MusicDevice.component)
       /Library/Audio/Plug-Ins/Components/Solid Dynamics.component
                 (Solid Dynamics.MusicDevice.component)
       /Library/Audio/Plug-Ins/Components/Solid EQ.component
                 (Solid EQ.MusicDevice.component)
       /Library/Audio/Plug-Ins/Components/StylusRMX.component
                 (com.spectrasonics.StyM)
       /Library/Audio/Plug-Ins/Components/Supercharger.component
                 (Supercharger.MusicDevice.component)
       /Library/Audio/Plug-Ins/Components/Superior Drummer.component
                 (com.toontrack.superior.superior2)
       /Library/Audio/Plug-Ins/Components/SWAM Alto Sax 64bit.component
                 (com.swamengine.SWAM)
       /Library/Audio/Plug-Ins/Components/SWAM Baritone Sax 64bit.component
                 (com.swamengine.SWAM)
       /Library/Audio/Plug-Ins/Components/SWAM Soprano Sax 64bit.component
                 (com.swamengine.SWAM)
       /Library/Audio/Plug-Ins/Components/SWAM Tenor Sax 64bit.component
                 (com.swamengine.SWAM)
       /Library/Audio/Plug-Ins/Components/tonespace.component
                 (com.mucoder.tonespace.au)
       /Library/Audio/Plug-Ins/Components/Transient Master.component
                 (Transient Master.MusicDevice.component)
       /Library/Audio/Plug-Ins/Components/Trilian.component
                 (com.spectrasonics.Ruby)
       /Library/Audio/Plug-Ins/Components/VC 160.component
                 (VC 160.MusicDevice.component)
       /Library/Audio/Plug-Ins/Components/VC 2A.component
                 (VC 2A.MusicDevice.component)
       /Library/Audio/Plug-Ins/Components/VC 76.component
                 (VC 76.MusicDevice.component)
       /Library/Audio/Plug-Ins/Components/WaveShell-AU 9.2.component
                 (com.WavesAudio.WaveShell-AU.9.2.80)
       /Library/Audio/Plug-Ins/MAS/iZMeterTapMASHook.bundle
                 (com.izotope.audioplugins.MAS.Meter Tap)
       /Library/Audio/Plug-Ins/MAS/iZOzone5DynamicsMASHook.bundle
                 (com.izotope.audioplugins.MAS.Ozone5DYN)
       /Library/Audio/Plug-Ins/MAS/iZOzone5EqualizerMASHook.bundle
                 (com.izotope.audioplugins.MAS.Ozone5EQ)
       /Library/Audio/Plug-Ins/MAS/iZOzone5ExciterMASHook.bundle
                 (com.izotope.audioplugins.MAS.Ozone5EXC)
       /Library/Audio/Plug-Ins/MAS/iZOzone5ImagerMASHook.bundle
                 (com.izotope.audioplugins.MAS.Ozone5IMG)
       /Library/Audio/Plug-Ins/MAS/iZOzone5MASHook.bundle
                 (com.izotope.audioplugins.MAS.Ozone5)
       /Library/Audio/Plug-Ins/MAS/iZOzone5MaximizerMASHook.bundle
                 (com.izotope.audioplugins.MAS.Ozone5MAX)
       /Library/Audio/Plug-Ins/MAS/iZOzone5ReverbMASHook.bundle
                 (com.izotope.audioplugins.MAS.Ozone5RVB)
       /Library/Audio/Plug-Ins/MOTU Control Surface/CueMixMackieSurfaces.bundle
                 (com.motu.cuemix.plugin.mackiecontrol)
       /Library/Audio/Plug-Ins/VST/Absynth 5 FX Surround.vst
                 (Absynth 5.FX2x6.vst)
       /Library/Audio/Plug-Ins/VST/Absynth 5 FX.vst
                 (Absynth 5.FX.vst)
       /Library/Audio/Plug-Ins/VST/Absynth 5 Stereo.vst
                 (Absynth 5.Synth2.vst)
       /Library/Audio/Plug-Ins/VST/Absynth 5.vst
                 (Absynth 5.Synth.vst)
       /Library/Audio/Plug-Ins/VST/Addictive Drums.vst
                 (com.xlnaudio.addictivedrumsvstau)
       /Library/Audio/Plug-Ins/VST/Addictive Keys.vst
                 (com.xlnaudio.addictivekeys)
       /Library/Audio/Plug-Ins/VST/Battery 3.vst
                 (Battery 3.Synth.vst)
       /Library/Audio/Plug-Ins/VST/BFD2.vst
                 (com.FXpansion.BFD2)
       /Library/Audio/Plug-Ins/VST/Engine.vst
                 (com.yellowtools.engine)
       /Library/Audio/Plug-Ins/VST/FM8 FX.vst
                 (FM8.FX.vst)
       /Library/Audio/Plug-Ins/VST/FM8.vst
                 (FM8.Synth.vst)
       /Library/Audio/Plug-Ins/VST/Guitar Rig 5.vst
                 (Guitar Rig 5.FX.vst)
       /Library/Audio/Plug-Ins/VST/Independence FX.vst
                 (com.yellowtools.independence_fx2)
       /Library/Audio/Plug-Ins/VST/Independence.vst
                 (com.yellowtools.independence2)
       /Library/Audio/Plug-Ins/VST/iZotope Alloy 2.vst
                 (com.izotope.audioplugins.VST.Alloy2)
       /Library/Audio/Plug-Ins/VST/iZotope Insight.vst
                 (com.izotope.audioplugins.VST.Insight)
       /Library/Audio/Plug-Ins/VST/iZotope Meter Tap.vst
                 (com.izotope.audioplugins.VST.Meter Tap)
       /Library/Audio/Plug-Ins/VST/iZotope Ozone 5 Dynamics.vst
                 (com.izotope.audioplugins.VST.Ozone5DYN)
       /Library/Audio/Plug-Ins/VST/iZotope Ozone 5 Equalizer.vst
                 (com.izotope.audioplugins.VST.Ozone5EQ)
       /Library/Audio/Plug-Ins/VST/iZotope Ozone 5 Exciter.vst
                 (com.izotope.audioplugins.VST.Ozone5EXC)
       /Library/Audio/Plug-Ins/VST/iZotope Ozone 5 Imager.vst
                 (com.izotope.audioplugins.VST.Ozone5IMG)
       /Library/Audio/Plug-Ins/VST/iZotope Ozone 5 Maximizer.vst
                 (com.izotope.audioplugins.VST.Ozone5MAX)
       /Library/Audio/Plug-Ins/VST/iZotope Ozone 5 Reverb.vst
                 (com.izotope.audioplugins.VST.Ozone5RVB)
       /Library/Audio/Plug-Ins/VST/iZotope Ozone 5.vst
                 (com.izotope.audioplugins.VST.Ozone5)
       /Library/Audio/Plug-Ins/VST/Kontakt 4 16out.vst
                 (Kontakt 4.Synth16.vst)
       /Library/Audio/Plug-Ins/VST/Kontakt 4 8out.vst
                 (Kontakt 4.Synth8.vst)
       /Library/Audio/Plug-Ins/VST/Kontakt 4.vst
                 (Kontakt 4.Synth.vst)
       /Library/Audio/Plug-Ins/VST/Kontakt 5 16out.vst
                 (Kontakt 5.Synth16.vst)
       /Library/Audio/Plug-Ins/VST/Kontakt 5 8out.vst
                 (Kontakt 5.Synth8.vst)
       /Library/Audio/Plug-Ins/VST/Kontakt 5.vst
                 (Kontakt 5.Synth.vst)
       /Library/Audio/Plug-Ins/VST/Maschine 2 FX.vst
                 (Maschine 2.FX2x8.vst)
       /Library/Audio/Plug-Ins/VST/Maschine 2.vst
                 (Maschine 2.Synth.vst)
       /Library/Audio/Plug-Ins/VST/Maschine FX.vst
                 (Maschine.FX2x8.vst)
       /Library/Audio/Plug-Ins/VST/Maschine.vst
                 (Maschine.Synth.vst)
       /Library/Audio/Plug-Ins/VST/Massive.vst
                 (Massive.Synth.vst)
       /Library/Audio/Plug-Ins/VST/Omnisphere.vst
                 (com.spectrasonics.Amber)
       /Library/Audio/Plug-Ins/VST/Play.vst
                 (com.eastwest.Play)
       /Library/Audio/Plug-Ins/VST/QL Spaces.vst
                 (com.eastwest.QL Spaces)
       /Library/Audio/Plug-Ins/VST/Reaktor5 FX 2x8.vst
                 (Reaktor5.FX2x8.vst)
       /Library/Audio/Plug-Ins/VST/Reaktor5 FX.vst
                 (Reaktor5.FX.vst)
       /Library/Audio/Plug-Ins/VST/Reaktor5 Surround.vst
                 (Reaktor5.Surround.vst)
       /Library/Audio/Plug-Ins/VST/Reaktor5.vst
                 (Reaktor5.Synth.vst)
       /Library/Audio/Plug-Ins/VST/Rob Papen/RG.vst
                 (com.RPCX.RG.vst)
       /Library/Audio/Plug-Ins/VST/Solid Bus Comp.vst
                 (Solid Bus Comp.FX.vst)
       /Library/Audio/Plug-Ins/VST/Solid Dynamics.vst
                 (Solid Dynamics.FX.vst)
       /Library/Audio/Plug-Ins/VST/Solid EQ.vst
                 (Solid EQ.FX.vst)
       /Library/Audio/Plug-Ins/VST/StylusRMX.vst
                 (com.spectrasonics.StyM)
       /Library/Audio/Plug-Ins/VST/Supercharger.vst
                 (Supercharger.FX.vst)
       /Library/Audio/Plug-Ins/VST/Superior Drummer.vst
                 (com.toontrack.superior.superior2)
       /Library/Audio/Plug-Ins/VST/SWAM Alto Sax 64bit.vst
                 (com.swamengine.SWAM)
       /Library/Audio/Plug-Ins/VST/SWAM Baritone Sax 64bit.vst
                 (com.swamengine.SWAM)
       /Library/Audio/Plug-Ins/VST/SWAM Soprano Sax 64bit.vst
                 (com.swamengine.SWAM)
       /Library/Audio/Plug-Ins/VST/SWAM Tenor Sax 64bit.vst
                 (com.swamengine.SWAM)
       /Library/Audio/Plug-Ins/VST/Transient Master.vst
                 (Transient Master.FX.vst)
       /Library/Audio/Plug-Ins/VST/Trilian.vst
                 (com.spectrasonics.Ruby)
       /Library/Audio/Plug-Ins/VST/VC 160.vst
                 (VC 160.FX.vst)
       /Library/Audio/Plug-Ins/VST/VC 2A.vst
                 (VC 2A.FX.vst)
       /Library/Audio/Plug-Ins/VST/VC 76.vst
                 (VC 76.FX.vst)
       /Library/Audio/Plug-Ins/VST/WaveShell-VST 9.2.vst
                 (com.WavesAudio.WaveShell-VST.9.2.80)
       /Library/Audio/Plug-Ins/VST3/iZotope Alloy 2.vst3
                 (com.izotope.audioplugins.VST.Alloy2)
       /Library/Audio/Plug-Ins/VST3/iZotope Insight.vst3
                 (com.izotope.audioplugins.VST.Insight)
       /Library/Audio/Plug-Ins/VST3/iZotope Meter Tap.vst3
                 (com.izotope.audioplugins.VST.Meter Tap)
       /Library/Audio/Plug-Ins/VST3/iZotope Ozone 5 Dynamics.vst3
                 (com.izotope.audioplugins.VST.Ozone5DYN)
       /Library/Audio/Plug-Ins/VST3/iZotope Ozone 5 Equalizer.vst3
                 (com.izotope.audioplugins.VST.Ozone5EQ)
       /Library/Audio/Plug-Ins/VST3/iZotope Ozone 5 Exciter.vst3
                 (com.izotope.audioplugins.VST.Ozone5EXC)
       /Library/Audio/Plug-Ins/VST3/iZotope Ozone 5 Imager.vst3
                 (com.izotope.audioplugins.VST.Ozone5IMG)
       /Library/Audio/Plug-Ins/VST3/iZotope Ozone 5 Maximizer.vst3
                 (com.izotope.audioplugins.VST.Ozone5MAX)
       /Library/Audio/Plug-Ins/VST3/iZotope Ozone 5 Reverb.vst3
                 (com.izotope.audioplugins.VST.Ozone5RVB)
       /Library/Audio/Plug-Ins/VST3/iZotope Ozone 5.vst3
                 (com.izotope.audioplugins.VST.Ozone5)
       /Library/Audio/Plug-Ins/VST3/WaveShell-VST 9.2.vst3
                 (com.WavesAudio.WaveShell-VST.9.2.80)
       /Library/Extensions/LogitechHIDDevices.kext
                 (com.Logitech.Control Center.HID Driver)
       /Library/Extensions/LogitechUnifying.kext
                 (com.Logitech.Unifying.HID Driver)
       /Library/Extensions/NIUSBAudioDriver.kext
                 (com.caiaq.driver.NIUSBHardwareDriver)
       /Library/Extensions/NIUSBGuitarRigMobile.kext
                 (com.caiaq.driver.NIUSBGuitarRigMobileDriver)
       /Library/Extensions/NIUSBMaschineController.kext
                 (com.caiaq.driver.NIUSBMaschineControllerDriver)
       /Library/Internet Plug-Ins/Flash Player.plugin
                 (com.macromedia.Flash Player.plugin)
       /Library/PreferencePanes/Flash Player.prefPane
                 (com.adobe.flashplayerpreferences)
       /Library/PreferencePanes/Logitech Control Center.prefPane
                 (com.Logitech.Control Center.Preference Pane)
       /Library/PreferencePanes/NIUSBAudio.prefPane
                 (com.caiaq.NIUSBAudioPreferencePane)
       /Library/PreferencePanes/YAMAHA-USBMIDIPatch.prefPane
                 (jp.co.yamaha.USBMIDIPatch)
    Unsigned shared libraries:
       /usr/lib/libgcc_s.10.4.dylib
       /usr/lib/libgcc_s.10.5.dylib
    DNS: 195.34.133.21
    User login items:
       NIHardwareAgent
    Restricted user files: 668
    Elapsed time (s): 145

  • HT5784 Why does Apple only "update" to already outdated versions

    Hi, why can't Apple update to current stable versions of OpenSSL (1.0.1e), Ruby (2.0), Rails (3.2.13), etc. Why can't Apple ship current stable versions of all the command line tools like emacs, vi, zsh, ruby, python, etc. And Rails 2 must be a joke, that's extremely outdated. Why is this?
    I don't understand it. Sure I can upgrade my userland myself with Homebrew, etc. but it would be nice if Apple won't forget the pro users and therefore will ship a modern userland.
    It looks like there was a time when current versions were shipped, but now it's not interesting anymore and only security fixes are released.
    Any thoughts on that?
    Regards,
    Clemens

    clemensg wrote:
    But the majority is still very old.
    The bash version used in Mavericks is 6 years old.
    That is a completely different issue. Bash, and a few other key pieces of open source software, switched to the GPLv3 license sometime in 2007. That license was designed specifically to keep Apple from using the software.
    The version of bash on Mavericks is all that you will ever, ever get unless you build your own. I suggest trying out zsh which is under no such licensing contraints. The lastest version of zsh is included in Mavericks.
    Do you think it helps to create a feature request to update OpenSSL, etc. at radar.apple.com ? (I am thinking about Mac OS X 10.10)
    That would be a good idea. While I understand Apple's approach, it isn't great from a marketing perspective. Apple really does need to switch to the latest OpenSSL, even if only for appearance's sake.

  • HP Wireless Printers cannot connect to WPA2-secured WiFi networks with Cisco/Meraki WAPs

    In the last two months, I've had the displeasure of working with two very different HP printers and attempting to make them work on a WPA2-secured wireless network.  All attempts to authenticate fail with "invalid phassphrase". 
    I'm not the first person to encounter this, it's a problem with many different HP wireless printers (I just happen to have physical access to the OfficeJet Pro 8610 & Deskjet 3511). 
    My equipment is a Cisco ASA 5505 Firewall running ASA 9.1x & Cisco Aironet 1142 running IOS 15.3.x. 
    What does work on the WPA2/AES SSID:  Apple MacBook Air running OSX 10.10.2, Three Windows-Based laptops running Windows 8.1 Update 1, an iPhone 5s, Three Windows Phone 8.1 devices, Roku 2, PlayStation 4, PlayStation 3, Sharp Aquos TV, Amazon Streaming Stick, and an Android Tablet (Jellybean).  Basically, everything. 
    What does not work on the WPA2 network:  OfficeJet Pro 8610 & Deskjet 3511.
    To test the theory there is a problem with HP's implementation of WPA2 with regard to Cisco Aironet IOS, I built out a second SSID that only works in WPA/TKIP mode.  This solution works.  Both HP printers will join the WPA/TKIP network.
    So, I'm able to demonstrate there is a certain connectivity issue.  When i look at AAA Debug on the WAP's console, I can observe the HPs attempt to authenticate "Bind I/F" on the WPA2 SSID, however they do not achieve authentication and do not pass the AAA phase.  However, on the WPA SSID, they bind and authenticate successfully. 
    To help illustrate this, here is my WAP running config.  It's about as simple as it can get.  There is no relevant MAC filtering or ACLs bound to any interface.  Noting that I have an ACL on remote access to the WAP (i.e. Locked down to SSH, disabling telnet).  The main point being that the ASA firewall is not a factor in this problem as the issue is at the WAP before WPA2 authentication can complete, therefore the printers never reach the network / when the printers connect to the WPA network, the operate fully & correctly. 
    If anyone at HP can indicate why this particular config is somehow improper or broken, that would be fantastic.  There should be no reason why Cisco / Meraki WAP owners have to lower wireless encryption standards just for a printer, be forced into wired, create separate SSIDs with lower encryption specifically for a device. 
    Building configuration...
    Current configuration : 6064 bytes
    ! Last configuration change at 12:46:47 UTC Fri Aug 20 1993 by admin
    version 15.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname 10-10-50-1
    logging buffered 1024768
    logging rate-limit console 9
    aaa new-model
    aaa authentication login default local
    aaa authorization exec default local
    aaa session-id common
    no ip source-route
    no ip cef
    ip domain name freedom.local
    dot11 syslog
    dot11 vlan-name inside vlan 50
    dot11 vlan-name inside-wpa-only vlan 70
    dot11 ssid inside
       vlan 50
       band-select
       authentication open
       authentication key-management wpa version 2
       mbssid guest-mode
       wpa-psk ascii 7 xxxxxx
       information-element ssidl
    dot11 ssid inside-wpa-only
       vlan 70
       band-select
       authentication open
       authentication key-management wpa
       mbssid guest-mode
       wpa-psk ascii 7 xxxxxx
       information-element ssidl
    dot11 band-select parameters
       cycle-count 3
       cycle-threshold 200
       expire-supression 20
       expire-dual-band 60
       client-rssi 75
    dot11 wpa handshake timeout 500
    dot11 network-map
    username ADMIN privilege 15 secret 5 xxxxxx
    ip ssh version 2
    bridge irb
    interface Dot11Radio0
     no ip address
     no ip route-cache
     encryption vlan 50 mode ciphers aes-ccm
     encryption vlan 70 mode ciphers aes-ccm tkip
     ssid inside
     ssid inside-wpa-only
     antenna gain 0
     mbssid
     speed  basic-1.0 basic-2.0 basic-5.5 basic-11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.
     channel 2412
     station-role root
     l2-filter bridge-group-acl
    interface Dot11Radio0.50
     encapsulation dot1Q 50 native
     no ip route-cache
     bridge-group 1
     bridge-group 1 subscriber-loop-control
     bridge-group 1 spanning-disabled
     bridge-group 1 block-unknown-source
     no bridge-group 1 source-learning
     no bridge-group 1 unicast-flooding
    interface Dot11Radio0.70
     encapsulation dot1Q 70
     no ip route-cache
     bridge-group 70
     bridge-group 70 subscriber-loop-control
     bridge-group 70 input-address-list 700
     bridge-group 70 output-address-list 700
     bridge-group 70 spanning-disabled
     bridge-group 70 block-unknown-source
     no bridge-group 70 source-learning
     no bridge-group 70 unicast-flooding
    interface GigabitEthernet0
     no ip address
     no ip route-cache
     duplex auto
     speed auto
    interface GigabitEthernet0.50
     encapsulation dot1Q 50 native
     no ip route-cache
     bridge-group 1
     bridge-group 1 spanning-disabled
     no bridge-group 1 source-learning
    interface GigabitEthernet0.70
     encapsulation dot1Q 70
     no ip route-cache
     bridge-group 70
     bridge-group 70 spanning-disabled
     no bridge-group 70 source-learning
    interface BVI1
     mac-address xxxx.xxxx.xxxx
     ip address 10.10.50.1 255.255.255.0
     no ip route-cache
    ip forward-protocol nd
    ip http server
    ip http authentication aaa
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    ip route 0.0.0.0 0.0.0.0 10.10.50.2
    logging history size 100
    access-list 111 permit tcp any any neq telnet
    bridge 1 route ip
    line con 0
     access-class 111 in
    line vty 0 4
     access-class 111 in
     length 0
     transport input ssh
    line vty 5 15
     access-class 111 in
     transport input ssh
    end

    I get the same behavior with a laserjet m451nw. I need to enable tkip to get the printer working, it doesn't support pure aes-ccm (every other device here supports pure aes-ccm, even cheap ones), although it's advertised as working.
    The following snippet of config works, but I still think it should work without the tkip "hack".
    dot11 ssid whatever
    vlan 1
    band-select
    authentication open
    authentication key-management wpa version 2
    interface Dot11Radio0
    encryption vlan 1 mode ciphers aes-ccm tkip

  • Lan connectivity Issue on autonomous AP with throttles

              Hello,
      I encounter a strange problem on several AP 1242 in version 12.4(25d)JA1 of a customer :
      He has 10 autonomous AP covering a factory and is using them for laptop connectivity and TOIP with mainly 7921 Cisco Wifi Phones.
      The phones are configured to use only 802.11a.
      The APs loose LAN connectivity randomly and therefore the clients don't work anymore.
      The AP are connected on a 2960 and a 3560 wich are in turn connected on a 3750 wich route the trafic.
      After checking spanning-tree no loops are present.
      When I check the counters on the AP involved I see the "trhottles" and "ignored" counters incrementing on the fa0 link of the AP impacted wich mean I think it can't handle the incoming traffic. This incoming traffic seems not to be too big however. I can see drops on the switch interface connecting the AP.
    There is a lot of roaming on the AP due to people walking in the factory with their wifi phones.
    Here is a view of the fa0 counters :
    AP1242-LOGIST#sh int fa0
    FastEthernet0 is up, line protocol is up
      Hardware is PowerPCElvis Ethernet, address is 001d.a1ce.26e2 (bia 001d.a1ce.26e2)
      MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Full-duplex, 100Mb/s, MII
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:00, output 00:00:00, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/160/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/40 (size/max)
      5 minute input rate 81000 bits/sec, 53 packets/sec
      5 minute output rate 29000 bits/sec, 26 packets/sec
         7447113 packets input, 674891974 bytes
         Received 286839 broadcasts, 0 runts, 0 giants, 549631 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 549631 ignored
         0 watchdog
         0 input packets with dribble condition detected
         4422100 packets output, 609868806 bytes, 0 underruns
         0 output errors, 0 collisions, 4 interface resets
         1 unknown protocol drops
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
      Here is a small part of logs concerning roaming, i don't see errors or log indicating that something is wrong nor in the switches log :
    Jun  6 12:57:27.007: %DOT11-6-ASSOC: Interface Dot11Radio1, Station SEP001E4A3EE15D 001e.4a3e.e15d Associated KEY_MGMT[WPAv2 PSK]
    Jun  6 12:57:42.499: %DOT11-6-ASSOC: Interface Dot11Radio1, Station SEP588D09D3A92B 588d.09d3.a92b Reassociated KEY_MGMT[WPAv2 PSK]
    Jun  6 12:58:02.620: %DOT11-6-DISASSOC: Interface Dot11Radio1, Deauthenticating Station 588d.09d3.a92b Reason: Sending station has left the BSS
    Jun  6 12:58:03.653: %DOT11-6-ASSOC: Interface Dot11Radio1, Station SEP588D09D3A92B 588d.09d3.a92b Reassociated KEY_MGMT[WPAv2 PSK]
    Jun  6 12:59:15.564: %DOT11-6-ROAMED: Station 588d.09d3.a92b Roamed to 001e.134c.5a50
    Jun  6 12:59:15.564: %DOT11-6-DISASSOC: Interface Dot11Radio1, Deauthenticating Station 588d.09d3.a92b Reason: Sending station has left the BSS
    Jun  6 12:59:41.905: %DOT11-6-DISASSOC: Interface Dot11Radio1, Deauthenticating Station 442b.0355.ab28 Reason: Previous authentication no longer valid
    Jun  6 12:59:54.728: %DOT11-6-ASSOC: Interface Dot11Radio1, Station SEP442B0355AB28 442b.0355.ab28 Associated KEY_MGMT[WPAv2 PSK]
    Jun  6 13:01:12.541: %DOT11-6-ASSOC: Interface Dot11Radio1, Station SEP588D09D3A92B 588d.09d3.a92b Reassociated KEY_MGMT[WPAv2 PSK]
    Jun  6 13:02:35.841: %DOT11-6-DISASSOC: Interface Dot11Radio1, Deauthenticating Station 001e.4a3e.d875 Reason: Previous authentication no longer valid
    Jun  6 13:02:36.489: %DOT11-6-ASSOC: Interface Dot11Radio0, Station   ec85.2f7c.c837 Associated KEY_MGMT[WPAv2 PSK]
    Jun  6 13:03:29.256: %DOT11-6-ROAMED: Station 588d.09d3.a92b Roamed to 001e.134c.5a50
    Jun  6 13:03:29.256: %DOT11-6-DISASSOC: Interface Dot11Radio1, Deauthenticating Station 588d.09d3.a92b Reason: Sending station has left the BSS
    Jun  6 13:04:32.754: %DOT11-6-ASSOC: Interface Dot11Radio1, Station SEP001E4A3ED875 001e.4a3e.d875 Associated KEY_MGMT[WPAv2 PSK]
    Jun  6 13:06:47.858: %DOT11-6-DISASSOC: Interface Dot11Radio1, Deauthenticating Station 001e.4a3e.e15d Reason: Previous authentication no longer valid
    Jun  6 13:07:18.107: %DOT11-6-ROAMED: Station 001f.6c7a.5101 Roamed to 001d.a2bb.15b0
    Jun  6 13:07:18.107: %DOT11-6-DISASSOC: Interface Dot11Radio1, Deauthenticating Station 001f.6c7a.5101 Reason: Sending station has left the BSS
    Jun  6 13:07:38.109: %DOT11-6-ASSOC: Interface Dot11Radio1, Station SEP588D09D3A92B 588d.09d3.a92b Reassociated KEY_MGMT[WPAv2 PSK]
    Jun  6 13:07:42.031: %DOT11-6-ROAMED: Station 588d.09d3.a92b Roamed to 001e.134c.5a50
    Jun  6 13:07:42.031: %DOT11-6-DISASSOC: Interface Dot11Radio1, Deauthenticating Station 588d.09d3.a92b Reason: Sending station has left the BSS
    Jun  6 13:07:46.489: %DOT11-6-ASSOC: Interface Dot11Radio1, Station SEP001F6C7A5101 001f.6c7a.5101 Reassociated KEY_MGMT[WPAv2 PSK]
    Jun  6 13:08:27.712: %DOT11-6-ASSOC: Interface Dot11Radio1, Station SEP588D09D3A92B 588d.09d3.a92b Reassociated KEY_MGMT[WPAv2 PSK]
    Jun  6 13:08:44.502: %DOT11-6-DISASSOC: Interface Dot11Radio1, Deauthenticating Station 588d.09d3.a92b Reason: Sending station has left the BSS
    Jun  6 13:08:44.572: %DOT11-6-ASSOC: Interface Dot11Radio1, Station SEP588D09D3A92B 588d.09d3.a92b Associated KEY_MGMT[WPAv2 PSK]
    Jun  6 13:08:56.778: %DOT11-6-ROAMED: Station 588d.09d3.a92b Roamed to 001e.134c.5a50
    Jun  6 13:08:56.779: %DOT11-6-DISASSOC: Interface Dot11Radio1, Deauthenticating Station 588d.09d3.a92b Reason: Sending station has left the BSS
    Jun  6 13:09:17.874: %DOT11-6-ROAMED: Station 001f.6c7a.5101 Roamed to 003a.9a92.8d70
    Jun  6 13:09:17.874: %DOT11-6-DISASSOC: Interface Dot11Radio1, Deauthenticating Station 001f.6c7a.5101 Reason: Sending station has left the BSS
    The AP are configured as follow :
    Current configuration : 5184 bytes
    ! No configuration change since last restart
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname AP1242-LOGIST
    logging rate-limit console 9
    aaa new-model
    aaa authentication login default local
    aaa authorization exec default local
    aaa session-id common
    clock timezone gmt+1 1
    clock summer-time gmt recurring last Sun Mar 2:00 last Sun Oct 3:00
    dot11 syslog
    dot11 vlan-name Data vlan 11
    dot11 vlan-name Voix vlan 14
    dot11 vlan-name Webguest vlan 5
    dot11 ssid WLAN_data
       vlan 11
       authentication open
       authentication key-management wpa
       mbssid guest-mode
       wpa-psk ascii 7 10600C0E261B173C252203797479633F371A29
    dot11 ssid WLAN_voice
       vlan 14
       authentication open
       authentication key-management wpa
       mbssid guest-mode
       wpa-psk ascii 7 080F49592A1500203B2D25567A7A7622263C0C
    dot11 ssid Webguest
       vlan 5
       authentication open
       mbssid guest-mode
    dot11 wpa handshake timeout 1000
    dot11 arp-cache
    dot11 priority-map avvid
    dot11 phone
    power inline negotiation prestandard source
    class-map match-all _class_voice0
    match ip dscp ef
    class-map match-all _class_voice1
    match ip dscp cs3
    policy-map voice
    class _class_voice0
      set cos 6
    class _class_voice1
      set cos 3
    bridge irb
    interface Dot11Radio0
    no ip address
    no ip route-cache
    encryption vlan 11 mode ciphers aes-ccm
    encryption vlan 14 mode ciphers aes-ccm
    ssid WLAN_data
    ssid WLAN_voice
    ssid Webguest
    mbssid
    power client 17
    channel 2472
    station-role root
    dot11 qos class voice local
        admission-control
        admit-traffic narrowband max-channel 75 roam-channel 6
    dot11 qos class voice cell
        admission-control
    no cdp enable
    infrastructure-client
    interface Dot11Radio0.5
    encapsulation dot1Q 5
    no ip route-cache
    no cdp enable
    bridge-group 5
    bridge-group 5 subscriber-loop-control
    bridge-group 5 block-unknown-source
    no bridge-group 5 source-learning
    no bridge-group 5 unicast-flooding
    bridge-group 5 spanning-disabled
    interface Dot11Radio0.11
    encapsulation dot1Q 11
    no ip route-cache
    no cdp enable
    bridge-group 11
    bridge-group 11 subscriber-loop-control
    bridge-group 11 block-unknown-source
    no bridge-group 11 source-learning
    no bridge-group 11 unicast-flooding
    bridge-group 11 spanning-disabled
    interface Dot11Radio0.14
    encapsulation dot1Q 14
    no ip route-cache
    no cdp enable
    bridge-group 14
    bridge-group 14 subscriber-loop-control
    bridge-group 14 block-unknown-source
    no bridge-group 14 source-learning
    no bridge-group 14 unicast-flooding
    bridge-group 14 spanning-disabled
    interface Dot11Radio1
    no ip address
    no ip route-cache
    encryption vlan 11 mode ciphers aes-ccm
    encryption vlan 14 mode ciphers aes-ccm
    ssid WLAN_data
    ssid WLAN_voice
    ssid Webguest
    no dfs band block
    mbssid
    channel dfs
    station-role root
    interface Dot11Radio1.5
    encapsulation dot1Q 5
    no ip route-cache
    no cdp enable
    bridge-group 5
    bridge-group 5 subscriber-loop-control
    bridge-group 5 block-unknown-source
    no bridge-group 5 source-learning
    no bridge-group 5 unicast-flooding
    bridge-group 5 spanning-disabled
    interface Dot11Radio1.11
    encapsulation dot1Q 11
    no ip route-cache
    no cdp enable
    bridge-group 11
    bridge-group 11 subscriber-loop-control
    bridge-group 11 block-unknown-source
    no bridge-group 11 source-learning
    no bridge-group 11 unicast-flooding
    bridge-group 11 spanning-disabled
    interface Dot11Radio1.14
    encapsulation dot1Q 14
    no ip route-cache
    no cdp enable
    bridge-group 14
    bridge-group 14 subscriber-loop-control
    bridge-group 14 block-unknown-source
    no bridge-group 14 source-learning
    no bridge-group 14 unicast-flooding
    bridge-group 14 spanning-disabled
    interface FastEthernet0
    no ip address
    no ip route-cache
    speed 100
    full-duplex
    no cdp enable
    hold-queue 160 in
    interface FastEthernet0.1
    encapsulation dot1Q 1 native
    no ip route-cache
    no cdp enable
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    interface FastEthernet0.5
    encapsulation dot1Q 5
    no ip route-cache
    no cdp enable
    bridge-group 5
    no bridge-group 5 source-learning
    bridge-group 5 spanning-disabled
    interface FastEthernet0.11
    encapsulation dot1Q 11
    no ip route-cache
    no cdp enable
    bridge-group 11
    no bridge-group 11 source-learning
    bridge-group 11 spanning-disabled
    interface FastEthernet0.14
    encapsulation dot1Q 14
    no ip route-cache
    no cdp enable
    bridge-group 14
    no bridge-group 14 source-learning
    bridge-group 14 spanning-disabled
    service-policy input voice
    service-policy output voice
    interface BVI1
    ip address 10.17.10.5 255.255.255.0
    no ip route-cache
    ip default-gateway 10.17.10.254
    ip http server
    ip http authentication aaa
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    logging trap warnings
    logging 10.15.51.115
    no cdp run
    bridge 1 route ip
    line con 0
    line vty 0 4
    sntp server 10.15.1.50
    sntp broadcast client
    end
    Does someone ever experienced a similar problem ?
    When I shut radio interfaces they're is no more problems on the LAN. Can this be an overlapping coverage issue ?
    Can someone please give me advices on how to troubleshoot this issue ?
    Thank you in advance as I'm a bit stuck.
    Best Regards,

         Hi Scott,
    Thanks for your reply.
    Do you think this can be the origin of the issue my customer encounters or is it only to be standard ? As this change will have to be made on all clients, if there is a chance it solves the problem I will do it ASAP, if not I will delay it in a less busy period :-)
    Can the constant roaming associations and dissasociations overload the AP and make it stop responding on the LAN or is it only a throuhput problem ?
    Thanks in advance for your answer.
    Best Regards,

  • Use Excel to convert to CSV

    I want to do something very simple using Applescript
    given a file name (variable)
    open the in Excel
    tell Excel save as CSV format using the same path and file name, but with csv extension
    Here's what I've got, but it stops on the Save Workbook as method.
    set theFile to choose file
    set theDestinationFolder to choose folder with prompt "Please select a destination folder:"
    tell application "Finder"
    set theInFileName to name of theFile as string
    set theOutFileName to theInFileName & ".csv"
    set theFullFilePath to theDestinationFolder & theOutFileName as string
    end tell
    tell application "Microsoft Excel"
    open alias theFile
    save workbook as filename theFullFilePath file format CSV file format with overwrite
    end tell
    I'm used to coding in Ruby, Python and VBA. There is so little and so baffling documentation about AppleScript that I can find. I there is a book with Office 2008 Apple Script manual, I'd buy it. Yes I can read the dictionary. Yes there are many examples of how to open a file if you know the exact name. I would like a general purpose script that I can call from the terminal via OSAScript. I'll read docs if there are any.
    Thanks....

    Hello
    How does it stop? Throwing an error and terminated or executing the statement without any result?
    A few things I noticed.
    • In your current code, the output file name will be 'a.xsl.csv' if the original file name is 'a.xsl'. I don't think this should cause error in 'save workbook as' command in Excel, but possibly it might.
    • In your current code, theFile is assigned to an alias object and thus 'alias theFile' is a redundant specifier. Also, in a tell application block, the object specifier as 'alias x' may not be resolved properly depending upon the application.
    In general, it's not good practice to use an object specifier such as 'alias x' (whether x is string or alias) in tell application block, because the object specifier must be resolved in the immediate context by the target/told application and should cause error when the application does not know how to resolve it. Use 'x as alias' instead.
    So just in case, try 'open theFile' in lieu of 'open alias theFile' (although I don't think this should be the cause in your case because your script does not throw error in 'open alias theFile' statement).
    • If by any chance 'save workbook as' command expects POSIX path in lieu of HFS path for 'as filename' parameter, you must take care of it accordingly. Such as -
    set theFullFilePath to theDestinationFolder's POSIX path & theOutFileName
    As for language documentation, AppleScript Language Guide is the primary one.
    http://developer.apple.com/documentation/AppleScript/Conceptual/AppleScriptLangG uide/
    Also you may consult the AppleScript references of Office suite.
    http://www.microsoft.com/mac/developers/default.mspx
    Good luck,
    H

  • ACE SSL terminate not working ... please help

    Hello, I configured cisco ace 4710 with ssl-proxy and it is not working, but http://10.1.40.2 and http://10.1.40.3 is OK.  When i put https://10.1.41.20 the output is: "There is a problem with this website's security certificate", so i click in "Continue to this website (not recommended)" and the ace dont balance the output show error "Internet Explorer cannot display the webpage".
    The configuration:
    ace-demo/Admin# sh run
    Generating configuration....
    boot system image:c4710ace-mz.A3_2_4.bin
    boot system image:c4710ace-mz.A3_2_1.bin
    login timeout 0
    hostname ace-demo
    interface gigabitEthernet 1/1
      channel-group 1
      no shutdown
    interface gigabitEthernet 1/2
      channel-group 1
      no shutdown
    interface gigabitEthernet 1/3
      channel-group 1
      no shutdown
    interface gigabitEthernet 1/4
      channel-group 1
      no shutdown
    interface port-channel 1
      switchport trunk allowed vlan 400-401,450
      no shutdown
    crypto csr-params testparams
      country PE
      state Lima
      locality Lima
      organization-name TI
      organization-unit TI
      common-name www.yyy.com
      serial-number 1000
    access-list anyone line 8 extended permit ip any any
    access-list anyone line 16 extended permit icmp any any
    parameter-map type ssl sslparams
      cipher RSA_WITH_RC4_128_MD5
      version SSL3
    rserver host rsrv1
      ip address 10.1.40.2
      inservice
    rserver host rsrv2
      ip address 10.1.40.3
      inservice
    serverfarm host farm-demo
      rserver rsrv1
        inservice
      rserver rsrv2
        inservice
    serverfarm host site-A
      rserver rsrv1
        inservice
    serverfarm host site-B
      rserver rsrv2
        inservice
    ssl-proxy service testssl
      key testkey.key
      cert testcert.pem
      ssl advanced-options sslparams
    class-map type management match-any MGMT
      2 match protocol icmp any
      3 match protocol http any
      4 match protocol https any
      5 match protocol snmp any
      6 match protocol telnet any
      7 match protocol ssh any
    class-map match-any VIP
      6 match virtual-address 10.1.41.10 any
    class-map type generic match-any WAN-site-A
      2 match source-address 192.168.10.106 255.255.255.255
      3 match source-address 192.168.10.125 255.255.255.255
    class-map type generic match-any WAN-site-B
      2 match source-address 192.168.10.96 255.255.255.255
      3 match source-address 192.168.10.93 255.255.255.255
    class-map type management match-any icmp
      2 match protocol icmp any
    class-map match-any vip-ssl-10.1.41.20
      2 match virtual-address 10.1.41.20 tcp eq https
    policy-map type management first-match ICMP
      class icmp
        permit
    policy-map type management first-match MGMT
      class MGMT
        permit
    policy-map type loadbalance first-match vip-ssl-10.1.41.20
      class class-default
        serverfarm farm-demo
    policy-map type loadbalance generic first-match lb-server
      class WAN-site-A
        serverfarm site-A
      class WAN-site-B
        serverfarm site-B
      class class-default
        serverfarm farm-demo
    policy-map multi-match client-side
      class VIP
        loadbalance vip inservice
        loadbalance policy lb-server
    policy-map multi-match lb-vip
      class vip-ssl-10.1.41.20
        loadbalance vip inservice
        loadbalance policy vip-ssl-10.1.41.20
        loadbalance vip icmp-reply
        ssl-proxy server testssl
    interface vlan 400
      description side-server
      ip address 10.1.40.1 255.255.255.0
      access-group input anyone
      service-policy input ICMP
      no shutdown
    interface vlan 401
      description side-client
      ip address 10.1.41.1 255.255.255.0
      access-group input anyone
      access-group output anyone
      service-policy input ICMP
      service-policy input client-side
      service-policy input lb-vip
      no shutdown
    interface vlan 450
      description mgmt
      ip address 10.1.45.1 255.255.255.0
      access-group input anyone
      service-policy input MGMT
      no shutdown
    ip route 192.168.10.0 255.255.255.0 10.1.45.10
    And the proof:
    ace-demo/Admin# sh serverfarm farm-demo
    serverfarm     : farm-demo, type: HOST
    total rservers : 2
                                                    ----------connections-----------
           real                  weight state        current    total      failures
       ---+---------------------+------+------------+----------+----------+---------
       rserver: rsrv1
           10.1.40.2:0           8      OPERATIONAL  0          25         19
       rserver: rsrv2
           10.1.40.3:0           8      OPERATIONAL  0          23         18
    ace-demo/Admin# sh crypto files
    Filename                                 File  File    Expor      Key/
                                             Size  Type    table      Cert
    admin                                    887   PEM     Yes         KEY
    testcert.pem                             709   PEM     Yes        CERT
    testkey.key                              497   PEM     Yes         KEY
    ace-demo/Admin#
    ace-demo/Admin# sh service-policy lb-vip class-map vip-ssl-10.1.41.20
    Status     : ACTIVE
    Interface: vlan 1 401
      service-policy: lb-vip
        class: vip-ssl-10.1.41.20
          ssl-proxy server: testssl
          loadbalance:
            L7 loadbalance policy: vip-ssl-10.1.41.20
            VIP ICMP Reply       : ENABLED
            VIP State: INSERVICE
            Persistence Rebalance: DISABLED
            curr conns       : 0         , hit count        : 38       
            dropped conns    : 18       
            client pkt count : 159       , client byte count: 12576              
            server pkt count : 16        , server byte count: 640                
            conn-rate-limit      : 0         , drop-count : 0        
            bandwidth-rate-limit : 0         , drop-count : 0        
          compression:
            bytes_in  : 0                  
            bytes_out : 0                  
            Compression ratio : 0.00%
    in other time:
    ace-demo/Admin# sh service-policy lb-vip class-map vip-ssl-10.1.41.20
    Status     : ACTIVE
    Interface: vlan 1 401
      service-policy: lb-vip
        class: vip-ssl-10.1.41.20
          ssl-proxy server: testssl
          loadbalance:
            L7 loadbalance policy: vip-ssl-10.1.41.20
            VIP ICMP Reply       : ENABLED
            VIP State: INSERVICE
            Persistence Rebalance: DISABLED
            curr conns       : 0         , hit count        : 170      
            dropped conns    : 89       
            client pkt count : 703       , client byte count: 60089              
            server pkt count : 85        , server byte count: 3400               
            conn-rate-limit      : 0         , drop-count : 0        
            bandwidth-rate-limit : 0         , drop-count : 0        
          compression:
            bytes_in  : 0                  
            bytes_out : 0                  
            Compression ratio : 0.00%
    ace-demo/Admin#
    ace-demo/Admin# sh stats crypto server
    +----------------------------------------------+
    +---- Crypto server termination statistics ----+
    +----------------------------------------------+
    SSLv3 negotiated protocol:                       43
    TLSv1 negotiated protocol:                        0
    SSLv3 full handshakes:                           37
    SSLv3 resumed handshakes:                         0
    SSLv3 rehandshakes:                               0
    TLSv1 full handshakes:                            0
    TLSv1 resumed handshakes:                         0
    TLSv1 rehandshakes:                               0
    SSLv3 handshake failures:                         6
    SSLv3 failures during data phase:                 0
    TLSv1 handshake failures:                         0
    TLSv1 failures during data phase:                 0
    Handshake Timeouts:                               0
    total transactions:                               0
    SSLv3 active connections:                         0
    SSLv3 connections in handshake phase:             0
    SSLv3 conns in renegotiation phase:               0
    SSLv3 connections in data phase:                  0
    TLSv1 active connections:                         0
    TLSv1 connections in handshake phase:             0
    TLSv1 conns in renegotiation phase:               0
    TLSv1 connections in data phase:                  0
    +----------------------------------------------+
    +------- Crypto server alert statistics -------+
    +----------------------------------------------+
    SSL alert CLOSE_NOTIFY rcvd:                      0
    SSL alert UNEXPECTED_MSG rcvd:                    0
    SSL alert BAD_RECORD_MAC rcvd:                    0
    SSL alert DECRYPTION_FAILED rcvd:                 0
    SSL alert RECORD_OVERFLOW rcvd:                   0
    SSL alert DECOMPRESSION_FAILED rcvd:              0
    SSL alert HANDSHAKE_FAILED rcvd:                  0
    SSL alert NO_CERTIFICATE rcvd:                    0
    SSL alert BAD_CERTIFICATE rcvd:                   0
    SSL alert UNSUPPORTED_CERTIFICATE rcvd:           0
    SSL alert CERTIFICATE_REVOKED rcvd:               0
    SSL alert CERTIFICATE_EXPIRED rcvd:               0
    SSL alert CERTIFICATE_UNKNOWN rcvd:               6
    SSL alert ILLEGAL_PARAMETER rcvd:                 0
    SSL alert UNKNOWN_CA rcvd:                        0
    SSL alert ACCESS_DENIED rcvd:                     0
    SSL alert DECODE_ERROR rcvd:                      0
    SSL alert DECRYPT_ERROR rcvd:                     0
    SSL alert EXPORT_RESTRICTION rcvd:                0
    SSL alert PROTOCOL_VERSION rcvd:                  0
    SSL alert INSUFFICIENT_SECURITY rcvd:             0
    SSL alert INTERNAL_ERROR rcvd:                    0
    SSL alert USER_CANCELED rcvd:                     0
    SSL alert NO_RENEGOTIATION rcvd:                  0
    SSL alert CLOSE_NOTIFY sent:                      0
    SSL alert UNEXPECTED_MSG sent:                    0
    SSL alert BAD_RECORD_MAC sent:                    0
    SSL alert DECRYPTION_FAILED sent:                 0
    SSL alert RECORD_OVERFLOW sent:                   0
    SSL alert DECOMPRESSION_FAILED sent:              0
    SSL alert HANDSHAKE_FAILED sent:                  0
    SSL alert NO_CERTIFICATE sent:                    0
    SSL alert BAD_CERTIFICATE sent:                   0
    SSL alert UNSUPPORTED_CERTIFICATE sent:           0
    SSL alert CERTIFICATE_REVOKED sent:               0
    SSL alert CERTIFICATE_EXPIRED sent:               0
    SSL alert CERTIFICATE_UNKNOWN sent:               0
    SSL alert ILLEGAL_PARAMETER sent:                 0
    SSL alert UNKNOWN_CA sent:                        0
    SSL alert ACCESS_DENIED sent:                     0
    SSL alert DECODE_ERROR sent:                      0
    SSL alert DECRYPT_ERROR sent:                     0
    SSL alert EXPORT_RESTRICTION sent:                0
    SSL alert PROTOCOL_VERSION sent:                 47
    SSL alert INSUFFICIENT_SECURITY sent:             0
    SSL alert INTERNAL_ERROR sent:                    0
    SSL alert USER_CANCELED sent:                     0
    SSL alert NO_RENEGOTIATION sent:                  0
    +-----------------------------------------------+
    +--- Crypto server authentication statistics ---+
    +-----------------------------------------------+
    Total SSL client authentications:                 0
    Failed SSL client authentications:                0
    SSL client authentication cache hits:             0
    SSL static CRL lookups:                           0
    SSL best effort CRL lookups:                      0
    SSL CRL lookup cache hits:                        0
    SSL revoked certificates:                         0
    Total SSL server authentications:                 0
    Failed SSL server authentications:                0
    +-----------------------------------------------+
    +------- Crypto server cipher statistics -------+
    +-----------------------------------------------+
    Cipher sslv3_rsa_rc4_128_md5:                    43
    Cipher sslv3_rsa_rc4_128_sha:                     0
    Cipher sslv3_rsa_des_cbc_sha:                     0
    Cipher sslv3_rsa_3des_ede_cbc_sha:                0
    Cipher sslv3_rsa_exp_rc4_40_md5:                  0
    Cipher sslv3_rsa_exp_des40_cbc_sha:               0
    Cipher sslv3_rsa_exp1024_rc4_56_md5:              0
    Cipher sslv3_rsa_exp1024_des_cbc_sha:             0
    Cipher sslv3_rsa_exp1024_rc4_56_sha:              0
    Cipher sslv3_rsa_aes_128_cbc_sha:                 0
    Cipher sslv3_rsa_aes_256_cbc_sha:                 0
    Cipher tlsv1_rsa_rc4_128_md5:                     0
    Cipher tlsv1_rsa_rc4_128_sha:                     0
    Cipher tlsv1_rsa_des_cbc_sha:                     0
    Cipher tlsv1_rsa_3des_ede_cbc_sha:                0
    Cipher tlsv1_rsa_exp_rc4_40_md5:                  0
    Cipher tlsv1_rsa_exp_des40_cbc_sha:               0
    Cipher tlsv1_rsa_exp1024_rc4_56_md5:              0
    Cipher tlsv1_rsa_exp1024_des_cbc_sha:             0
    Cipher tlsv1_rsa_exp1024_rc4_56_sha:              0
    Cipher tlsv1_rsa_aes_128_cbc_sha:                 0
    Cipher tlsv1_rsa_aes_256_cbc_sha:                 0
    ace-demo/Admin# crypto verify testkey.key testcert.pem
    Keypair in testkey.key matches certificate in testcert.pem.
    ace-demo/Admin#
    ace-demo/Admin#  sh conn
    total current connections : 0
    conn-id    np dir proto vlan source                destination           state
    ----------+--+---+-----+----+---------------------+---------------------+------+

    Hello Alvaro,
    The issue here is that your config is missing the clear text port the ACE should use to send the traffic to the backend servers; in this case port 80.
    Remove the rservers from the SF "farm-demo" and then configure them back like this:
    serverfarm host farm-demo
      rserver rsrv1 80
        inservice
      rserver rsrv2 80
        inservice
    That should do the trick =)
    HTH
    Pablo

  • RabbitMQ/AMQP messaging: example for LabVIEW

    RabbitMQ (http://www.rabbitmq.com/) is an open source message broker based on the AMQP protocol (http://www.amqp.org/). I plan to use it to connect data processing modules written in different programming languages (LabVIEW, Ruby, Python and Java) and running on different computers.
    As I couldn't find any LabVIEW wrappers so far, I would like to share my first success with the community. Under the hood of the attached example, I use the .NET client according to the example given at https://github.com/rabbitmq/rabbitmq-tutorials/tree/master/dotnet.
    The example simply sends a string from send.vi to receive.vi, both on localhost (it can be easily modified to send messages from one computer to another). Read the readme.txt to try it out.
    I'll post further examples while working my way deeper into the topic.
    Attachments:
    rabbitmq.zip ‏187 KB

    Good hint (the above file is LV2011)! Here are the LV2009 and LV2010 versions...
    Attachments:
    rabbitmq_LV2009.zip ‏175 KB
    rabbitmq_LV2010.zip ‏175 KB

Maybe you are looking for

  • Help Creating Dynamic Stacked Column Chart with Multiple Criteria

    Hi all. Im new here and hoping you can help.  I have a dashboard Im trying to rebuild from scratch (our computer had a meltdown and we lost all our files). I did not build the dashboard initially so Im trying to recreate it from the flash file we wer

  • How to determine the name or type of a control in a existed VI?

    I got a couple of VIs other engineers created before. There are a couple of controls I can not tell the type or name of that control. I used LabVIEW ctrl-H to try to figure out what control was used but failed. I also tried to use "Edit\Customize Con

  • How can i get the position of my object

    HI,ALL! i get a queation now. when i picking some transfromgroup,and move it.(use picktranslatebehavior),i want to get the position of the transformgroup after it has been moved.so how can i get it?!Apology for my bad english .thanks!:)

  • Count new records from Oracle function.

    Is it possible to count all the new records inserted? I have a script with a couple of insert statements, before I do commit all the actions done in the script I like to read the numbers of new records. I do not have a key that I can use to select th

  • Extend search in cad-desktop view document list

    Hi, is it possible to extend the search in the cad desktop's view DOCUMENT LIST? when i click the button SEARCH i get to some kind of CV04N-Search. Is it possible to implement a new Tab? i want to search by a change service order and select all docum