[SOLVED] Trouble setting up KVM VGA passthrough using vfio

Hi all!
In the past two weeks I've set up my first LFS build using Arch and everything is working great! Well, almost everything.
I'm trying to get a VM set up with vfio for Windows gaming but I'm having trouble and I don't know where to look to fix this... Following this guide: https://bbs.archlinux.org/viewtopic.php?id=162768
I have compiled and am running AUR\linux-vfio, with amd_iommu=on and my processor supports virtualization. pci-stubs holding on to the card to be virtualized.
Cobbled together specs - The 7850 is my host and the 7870 is to be passed to the VM.
OS: Arch Linux
Kernel: x86_64 Linux 4.0.4-2-vfio
CPU: AMD Phenom II X4 955 @ 3.2GHz
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn PRO [Radeon HD 7850] [1002:6819]
01:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series] [1002:aab0]
02:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn XT [Radeon HD 7870 GHz Edition] [1002:6818]
02:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series] [1002:aab0]
When I try to run the test in the linked thread, I get the following:
archdeckstawp% qemu-system-x86_64 -enable-kvm -m 1024 -cpu host,kvm=off \
> -smp 4,sockets=1,cores=4,threads=1 \
> -device vfio-pci,host=02:00.0,x-vga=on -device vfio-pci,host=02:00.1 \
> -vga none
qemu-system-x86_64: -device vfio-pci,host=02:00.0,x-vga=on: vfio: error no iommu_group for device
qemu-system-x86_64: -device vfio-pci,host=02:00.0,x-vga=on: Device initialization failed
qemu-system-x86_64: -device vfio-pci,host=02:00.0,x-vga=on: Device 'vfio-pci' could not be initialized
I checked dmesg and found the following errors, and a patch linked here from Bumblebee, but I don't believe this is the issue so I haven't tried it yet - going to investigate more: https://github.com/Bumblebee-Project/Bu … nt-5804686
archdeckstawp% dmesg | grep vgaarb
[ 0.347409] vgaarb: setting as boot device: PCI:0000:01:00.0
[ 0.347411] vgaarb: device added: PCI:0000:01:00.0,decodes=io+mem,owns=io+mem,locks=none
[ 0.347413] vgaarb: device added: PCI:0000:02:00.0,decodes=io+mem,owns=none,locks=none
[ 0.347415] vgaarb: loaded
[ 0.347416] vgaarb: bridge control possible 0000:02:00.0
[ 0.347417] vgaarb: bridge control possible 0000:01:00.0
[ 17.814588] vgaarb: this pci device is not a vga device
... 22 times ...
[ 17.814761] vgaarb: this pci device is not a vga device
[ 17.814778] vgaarb: device changed decodes: PCI:0000:02:00.0,olddecodes=io+mem,decodes=none:owns=none
[ 17.814794] vgaarb: this pci device is not a vga device
... 3 times ...
[ 17.814848] vgaarb: this pci device is not a vga device
For some strange reason I feel like virtualization isn't working on my machine. I've checked the BIOS, virtualization is enabled... I just can't get iommu turned on. Any ideas?
Last edited by SkySky (2015-06-12 01:14:22)

So after a bit more research, looks like my motherboard doesn't support IOMMU... http://forums.tweaktown.com/gigabyte/39 … witch.html
[ 0.000000] AGP: Please enable the IOMMU option in the BIOS setup
[ 1.949134] AMD IOMMUv2 driver by Joerg Roedel <[email protected]>
[ 1.949136] AMD IOMMUv2 functionality not available on this system
Blah, looks like I have to build a new system (or at least get a new mobo) to get this figured out. I've put in a ticket with gigabyte for my mobo to see if they'll do anything for me, but I doubt it...
I'm hesitant to mark this as solved... would anyone have any ideas on how I could get this working otherwise?

Similar Messages

  • KVM VGA-Passthrough using the new vfio-vga support in kernel = 3.9

    This is intented for people who wish to pass-through a GPU to a virtual machine using the KVM hypervisor, QEMU and vfio-pci
    NOTE: AMD RADEON 5xxx, 6xxx, 7xxx, 2xx and NVIDIA GEFORCE 7, 8, 4xx, 5xx, 6xx, 7xx 9xx have been reported working with this, passing though an intel IGD is not supported YET
    NOTE: THIS IS EXPERIMENTAL SO IT MIGHT NOT WORK ON YOUR SYSTEM
    This is the result on my radeon 6950:
    This is the result on my geforce 470 gtx:
    Recommended reads
    Alex Williamson's blog and FAQ for detailed technical information
    OVMF whitepaper.
    GPU passthrough database by noctavian
    At this moment there are two ways to achieve this using KVM: legacy VGA via Seabios or non-VGA (UEFI) via OVMF
    The main practical advantage of using OVMF is that on intel systems you no longer need the i915 VGA arbiter patch which also disables DRI on the host
    Requirements
    AMD-VI/VT-D enabled and working (On intel systems both your MB and you CPU must support it, to find out if you CPU has VT-D support go here: http://ark.intel.com/, you also need to boot with intel_iommu=on to enable it)
    At least 2 GPU's, one primary boot device and the card you wish to pass-through
    Qemu=>2.0
    Aditional kernel patches might be required if you're using an Intel CPU: ACS override patch and i915 VGA arbiter patch, you can find a kernel package with these patches included on AUR: linux-vfio
    Aditional requirements for OVMF:
    An UEFI compatible GPU (Most modern gpus support this, SEE: Does my graphics card ROM support EFI?
    An UEFI compatible GUEST (ex: Windows 7 and up)
    OVMF:  Gerd Hoffmann's rpms or OVMF-svn from AUR
    If you're building your kernel manually this option is required:
    CONFIG_VFIO_PCI_VGA=y
    Preparing your System
    On intel system the i915 VGA arbiter patch is required if:
    You're using the IGD on your host
    You're doing VGA assignment
    NOTE: Enabling this will disable DRI!
    If you wish to avoid this, then then you should try OVMF
    To enable it add this kernel parameter to your bootloader:
    i915.enable_hd_vgaarb=1
    Next, we need to prepare the GPU for vfio:
    Blacklist radeon or nouveau or nvidia or fglrx on /etc/modprobe.d/blacklist.conf
    Example, blacklisting the opensource radeon module:
    echo "blacklist radeon" >> /etc/modprobe.d/blacklist.conf
    Use pci-stub
    In my case since i have 2 radeon cards blacklisting the radeon module is not an option, so i use pci-stub
    NOTE: If pci-stub was built as a module, you'll need to modify /etc/mkinitcpio.conf and add pci-stub in the MODULES section, after that you need to update your initramfs like this
    mkinitcpio -p linux-mainline
    lspci
    07:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cayman PRO [Radeon HD 6950] <-- radeon 6950
    07:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cayman/Antilles HDMI Audio [Radeon HD 6900 Series] <-- radeon 6950 audio
    lspci -n
    07:00.0 0300: 1002:6719 <-- radeon 6950
    07:00.1 0403: 1002:aa80 <-- radeon 6950 audio
    Now add this kernel parameter to your bootloader:
    pci-stub.ids=1002:6719,1002:aa80
    dmesg | grep pci-stub
    [ 2.096151] pci-stub: add 1002:6719 sub=FFFFFFFF:FFFFFFFF cls=00000000/00000000
    [ 2.096160] pci-stub 0000:07:00.0: claimed by stub
    [ 2.096165] pci-stub: add 1002:AA80 sub=FFFFFFFF:FFFFFFFF cls=00000000/00000000
    [ 2.096174] pci-stub 0000:07:00.1: claimed by stub
    [ 2.096178] pci-stub: add 1B21:1042 sub=FFFFFFFF:FFFFFFFF cls=00000000/00000000
    Setting up vfio and kvm modules
    This is only required if you get this message:
    vfio_iommu_type1_attach_group: No interrupt remapping support. Use the module param "allow_unsafe_interrupts" to enable VFIO IOMMU support on this platform
    If your board doesn't enable interrupt remapping, you need to add this to your bootloader:
    vfio_iommu_type1.allow_unsafe_interrupts=1
    Or if vfio-pci was built as a module ( default on arch )
    echo "options vfio_iommu_type1 allow_unsafe_interrupts=1" > /etc/modprobe.d/vfio_iommu_type1.conf
    Some applications like Passmark Performance Test and SiSoftware Sandra crash the VM without this:
    echo "options kvm ignore_msrs=1" >> /etc/modprobe.d/kvm.conf
    Binding a device to vfio-pci
    We'll use this script to make life easier:
    #!/bin/bash
    modprobe vfio-pci
    for dev in "$@"; do
    vendor=$(cat /sys/bus/pci/devices/$dev/vendor)
    device=$(cat /sys/bus/pci/devices/$dev/device)
    if [ -e /sys/bus/pci/devices/$dev/driver ]; then
    echo $dev > /sys/bus/pci/devices/$dev/driver/unbind
    fi
    echo $vendor $device > /sys/bus/pci/drivers/vfio-pci/new_id
    done
    Save it as /usr/bin/vfio-bind
    chmod 755 /usr/bin/vfio-bind
    Bind the GPU and GPU audio:
    vfio-bind 0000:07:00.0 0000:07:00.1
    Systemd service:
    [Unit]
    Description=Binds devices to vfio-pci
    After=syslog.target
    [Service]
    EnvironmentFile=-/etc/vfio-pci.cfg
    Type=oneshot
    RemainAfterExit=yes
    ExecStart=-/usr/bin/vfio-bind $DEVICES
    [Install]
    WantedBy=multi-user.target
    cat /etc/vfio-pci.cfg
    DEVICES="0000:00:11.0 0000:04:00.0 0000:05:00.0 0000:06:00.0 0000:07:00.0 000:07:00.1"
    Testing if its working out
    Seabios:
    qemu-system-x86_64 -enable-kvm -m 1024 -cpu host,kvm=off \
    -smp 4,sockets=1,cores=4,threads=1 \
    -device vfio-pci,host=07:00.0,x-vga=on -device vfio-pci,host=07:00.1 \
    -vga none
    OVMF:
    qemu-system-x86_64 -enable-kvm -m 1024 -cpu host,kvm=off  \
    -smp 4,sockets=1,cores=4,threads=1 \
    -drive if=pflash,format=raw,readonly,file=/usr/share/ovmf/x64/ovmf_code_x64.bin \
    -drive if=pflash,format=raw,file=/usr/share/ovmf/x64/ovmf_vars_x64.bin \
    -device vfio-pci,host=07:00.0 -device vfio-pci,host=07:00.1 \
    -vga none
    Note:
    kvm=off will hide the kvm hypervisor signature, this is required for NVIDIA cards, since its driver will refuse to work on an hypervisor and result in Code 43 on windows (unless you're using a QUADRO)
    x-vga=on is required for vga assignment
    -vga none disables the default vga device on QEMU, it is also required for vga assignment
    You should see a black qemu window on your main display, and seabios/ovmf ouput on your monitor from your passthru'd card saying it cant find anything to boot
    If you're using an intel cpu and nothing happens try this:
    modprobe -r kvm_intel
    modprobe kvm_intel emulate_invalid_guest_state=0
    NOTE: There might be some problems using nvidia/fglrx/nouveau drivers on the host gpu, see the ISSUES section below on how to solve this
    At this point you're ready to create your vm, you could use libvirt + virt-manager to create your vm using a nice graphical interface, there are
    also some interesting examples in this thread, otherwise if you prefer to use the command line continue reading
    DISK:
    Creating a disk image:
    Create a 30Gb raw image:
    dd if=/dev/zero of=windows.img bs=1M seek=30000 count=0
    Using a VIRTIO controller:
    We create our virtio controller for qemu:
    -device virtio-scsi-pci,id=scsi
    Attaching our hdd:
    -drive file=/home/nbhs/windows.img,id=disk,format=raw,if=none -device scsi-hd,drive=disk
    Attaching a cdrom:
    -drive file=/home/nbhs/windows.iso,id=isocd,if=none -device scsi-cd,drive=isocd
    To install windows, you'll need to download the virtio drivers iso from here
    Attaching the virtio iso:
    -drive file=/home/nbhs/virtio.iso,id=virtiocd,if=none -device ide-cd,bus=ide.1,drive=virtiocd
    Windows will complain it cant find a disk to install to, just click browse, find the folder for your os/arch, select "RED HAT VirtIO pass-through controller" then click next.
    For more info check out the Archlinux wiki's QEMU section
    Using a physical disk or partition:
    -drive file=/dev/sdb,id=disk,format=raw,if=none -device scsi-hd,drive=disk
    You might need to change the bus depending on the controller you use
    If you wish to use a physical partition and be able to read its contents later on, you can follow these guides:
    http://fds-team.de/cms/articles/2013-12 … yer-u.html
    https://wiki.archlinux.org/index.php/QE … disk_image
    Passing a sata disk controller to qemu:
    If you dual boot like me you can pass an entire sata controller (in ahci mode) and all the drives attached, and seabios will boot from them.
    lspci
    00:11.0 SATA controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] (rev 40)
    Make sure all volumes are unmounted, then bind the controller to vfio:
    vfio-bind 0000:00:11.0
    Now we pass the controller to the vm:
    -device vfio-pci,host=00:11.0
    USB:
    Its also possible to passthrough a usb controller, in my case an ASMEDIA USB3 Controller:
    lspci
    04:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
    05:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
    06:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
    Bind them to vfio:
    vfio-bind 0000:04:00.0 0000:05:00.0 0000:06:00.0
    Pass them to the vm:
    -device vfio-pci,host=04:00.0 \
    -device vfio-pci,host=05:00.0 \
    -device vfio-pci,host=06:00.0
    Or a specific device:
    lsusb
    Bus 004 Device 010: ID 045e:00e1 Microsoft Corp. Wireless Laser Mouse 6000 Reciever <-- mouse
    Bus 004 Device 011: ID 045e:074b Microsoft Corp. <-- keyboard
    We pass them to the vm:
    -usb -usbdevice host:045e:00e1 -usbdevice host:045e:074b
    NETWORK:
    Please see https://wiki.archlinux.org/index.php/QEMU#Networking
    AUDIO EMULATION:
    To hear the sound from the vm on your host speakers you'll need to add this lines:
    -soundhw hda
    You might need to start qemu like this:
    QEMU_PA_SAMPLES=128 QEMU_AUDIO_DRV=pa qemu-system-x86_64...
    alsa:
    QEMU_ALSA_DAC_BUFFER_SIZE=512 QEMU_ALSA_DAC_PERIOD_SIZE=170 QEMU_AUDIO_DRV=alsa qemu-system-x86_64...
    Note: these are the settings i found that work great on my system, if you get crackling/skipping audio you might want to try different settings
    To see the available drivers and audio options:
    qemu-system-x86_64 -audio-help
    LOADING YOUR CARD ROM FROM A DUMP/FILE:
    modify this line:
    -device vfio-pci,host=07:00.0,...... \
    change it to this:
    -device vfio-pci,host=07:00.0,......,romfile=/path/to/your/gpu/bios.bin \
    ISSUES:
    Using the latest NVIDIA drivers on the guest will result in code 43, but there's a workarround
    Using the latest NVIDIA drivers on the guest using hv enlightenments will result in code 43, see: https://forums.geforce.com/default/topi … 8/#4314318
    Using AMD proprieraty drivers on the host, see: https://bbs.archlinux.org/viewtopic.php … 2#p1273412 the only solution atm is using the opensource radeon driver
    PERFORMANCE IMPROVEMENTS:
    SEE: https://bbs.archlinux.org/viewtopic.php … 1#p1270311
    Pin vcpu to pcpu, see http://www.linux-kvm.com/content/tip-ru … cific-cpus
    Use cgroups, specifically cpuset, see https://access.redhat.com/site/document … puset.html
    Use Hugepages, see http://pic.dhe.ibm.com/infocenter/lnxin … ttunhp.htm
    Use Hyper-V enlightenments, see: http://blog.wikichoon.com/2014/07/enabl … h-kvm.html
    Last edited by nbhs (2015-04-05 20:01:18)

    nbhs wrote:
    apoapo wrote:
    I finally got some progress.
    After trying mainline kernel and with vbios, I went to bios/uefi and turned the Primary VGA card from onboard to pci-express ...
    Now I see the seabios in passthroughed screen, but with blinking cursor in it, so i will try some things .
    NIce! have you tried running windows with it yet? does it work if you dont load the rom file by hand?
    Hi,
    I tried it again and I captured this error message if I use the PCI-e card es Primary Card:
    qemu-system-x86_64: -device vfio-pci,host=01:00.0,bus=root.1,addr=00.0,multifunction=on,x-vga=on: VFIO 0000:01:00.0 BAR 0 mmap unsupported. Performance may be slow
    This was, when I got some seabios picture.
    After some reboots I wanted to try it again, I was spammed with errors . Dont have them to show you now...  will look for it.
    Now I'm With the onboard as primary Card and I found this in dmesg:
    [ 0.401391] DMAR: No ATSR found
    [ 0.401412] IOMMU 0 0xfed90000: using Queued invalidation
    [ 0.401413] IOMMU 1 0xfed91000: using Queued invalidation
    [ 0.401415] IOMMU: Setting RMRR:
    [ 0.401422] IOMMU: Setting identity map for device 0000:00:02.0 [0xbf800000 - 0xcf9fffff]
    [ 0.402590] IOMMU: Setting identity map for device 0000:00:1d.0 [0xbd568000 - 0xbd59afff]
    [ 0.402606] IOMMU: Setting identity map for device 0000:00:1a.0 [0xbd568000 - 0xbd59afff]
    [ 0.402619] IOMMU: Setting identity map for device 0000:00:14.0 [0xbd568000 - 0xbd59afff]
    [ 0.402628] IOMMU: Prepare 0-16MiB unity mapping for LPC
    [ 0.402635] IOMMU: Setting identity map for device 0000:00:1f.0 [0x0 - 0xffffff]
    [ 0.402717] PCI-DMA: Intel(R) Virtualization Technology for Directed I/O
    [ 0.402782] ------------[ cut here ]------------
    [ 0.402786] WARNING: at drivers/pci/search.c:46 pci_find_upstream_pcie_bridge+0x83/0x90()
    [ 0.402787] Hardware name: To Be Filled By O.E.M.
    [ 0.402788] Modules linked in:
    [ 0.402790] Pid: 1, comm: swapper/0 Not tainted 3.9.2-1-mainline #1
    [ 0.402791] Call Trace:
    [ 0.402796] [<ffffffff81058090>] warn_slowpath_common+0x70/0xa0
    [ 0.402797] [<ffffffff8105817a>] warn_slowpath_null+0x1a/0x20
    [ 0.402799] [<ffffffff8129ea43>] pci_find_upstream_pcie_bridge+0x83/0x90
    [ 0.402802] [<ffffffff813b3c7b>] intel_iommu_add_device+0x4b/0x1f0
    [ 0.402805] [<ffffffff813ab630>] ? bus_set_iommu+0x50/0x50
    [ 0.402806] [<ffffffff813ab65a>] add_iommu_group+0x2a/0x50
    [ 0.402809] [<ffffffff8135bf63>] bus_for_each_dev+0x63/0xa0
    [ 0.402811] [<ffffffff813ab622>] bus_set_iommu+0x42/0x50
    [ 0.402814] [<ffffffff819130b6>] intel_iommu_init+0xa83/0xb7b
    [ 0.402816] [<ffffffff818dd10b>] ? memblock_find_dma_reserve+0x124/0x124
    [ 0.402818] [<ffffffff818dd11d>] pci_iommu_init+0x12/0x3c
    [ 0.402820] [<ffffffff8100210a>] do_one_initcall+0x10a/0x160
    [ 0.402823] [<ffffffff818d5037>] kernel_init_freeable+0x15b/0x1dc
    [ 0.402824] [<ffffffff818d4881>] ? do_early_param+0x88/0x88
    [ 0.402827] [<ffffffff814b55f0>] ? rest_init+0x90/0x90
    [ 0.402828] [<ffffffff814b55fe>] kernel_init+0xe/0x190
    [ 0.402830] [<ffffffff814dad6c>] ret_from_fork+0x7c/0xb0
    [ 0.402832] [<ffffffff814b55f0>] ? rest_init+0x90/0x9

  • Is KVM VGA Passthrough Possible on Macbook Pro Mid 2014?

    I've been using Arch on and off for a couple years on different hardware, and this time I'm trying to get it to work semi-flawlessly on my mid 2014 Macbook Pro. My Linux skills are meager, so I need some help understanding if VGA passthrough is possible on this machine, and if it is, how to set it up. I have hope that it might work after reading this blog and the Arch forums. An outline of my current setup follows. I will also document progress and research for anyone who might want to try this in the future.
    Here are the specifications for this machine:
    Processor: 2.5 GHz Intel Core i7
    Memory: 16 GB 1600 MHz DDR3
    Graphics: Intel Iris Pro 1536 MB, Nvidia GT 750M 2 GB
    I have successfully dual-booted Mac OS X Yosemite and Arch with EFI on a btrfs partition using this blog and the wiki as starting points. Somlo's research also helped. All the basic functionality works (networking, WiFi, etc.), and I am able to boot the physical Arch partition as a Virtualbox VM with the help of the wiki. However, I'm having trouble with getting the integrated Intel graphics to work. The following command:
    lspci | grep VGA
    prints the Nvidia card specifications, and nothing about the Intel graphics.
    Reading this blog, it looks like someone had to apply a "grub gmux" patch to grub to disable the Nvidia card at boot. I feel uncomfortable installing anything other than the official Arch packages, so I have to know if installing a patched grub is still necessary, and if installing it would still allow me to use VGA passthrough in KVM.
    My ambitious to-do list looks like this:
    1. Dual-boot Mac OS X and Arch with btrfs. -done
    2. Setup the physical Arch partition to boot in Virtualbox. -done
    3. Get Intel graphics to work on Arch ideally with OpenGL support. -done
    4. Get Enlightenment working as the desktop environment on Arch. -done
    5. Get Qemu+KVM to boot off the physical Mac OS X partition. -tbd
    6. Enable VGA passthrough for Mac OS X from Qemu+KVM. -tbd
    7. Install Windows as a VM in Qemu+KVM. -tbd
    8. Enable VGA passthrough for Windows from Qemu+KVM. -tbd
    9. Work and do research on Mac OS X from Arch, play hardcore 3D games on WIndows from Arch, play around with Arch, and live happily ever after. -tbd
    Can anyone help me with this? Thanks in advance for any hints/input.
    Edit:
    The Ubuntu forums has something about getting the two graphics cards to be recognised by using `refind` instead of `grub`. I was able to set up `refind` to boot using the `efi-stub`, but:
    $ lspci
    00:00.0 Host bridge: Intel Corporation Crystal Well DRAM Controller (rev 08)
    00:01.0 PCI bridge: Intel Corporation Crystal Well PCI Express x16 Controller (rev 08)
    00:01.1 PCI bridge: Intel Corporation Crystal Well PCI Express x8 Controller (rev 08)
    00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
    00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
    00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
    00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
    00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
    00:1c.3 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #4 (rev d5)
    00:1c.4 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #5 (rev d5)
    00:1f.0 ISA bridge: Intel Corporation HM87 Express LPC Controller (rev 05)
    00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
    01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 750M Mac Edition] (rev a1)
    01:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)
    03:00.0 Network controller: Broadcom Corporation BCM4360 802.11ac Wireless Network Adapter (rev 03)
    04:00.0 Multimedia controller: Broadcom Corporation 720p FaceTime HD Camera
    05:00.0 SATA controller: Samsung Electronics Co Ltd Apple PCIe SSD (rev 01)
    06:00.0 PCI bridge: Intel Corporation Device 156d
    07:00.0 PCI bridge: Intel Corporation Device 156d
    07:03.0 PCI bridge: Intel Corporation Device 156d
    07:04.0 PCI bridge: Intel Corporation Device 156d
    07:05.0 PCI bridge: Intel Corporation Device 156d
    07:06.0 PCI bridge: Intel Corporation Device 156d
    08:00.0 System peripheral: Intel Corporation Device 156c
    still only shows the Nvidia card. The boot options suggested by this blog did not change anything. However, this very helpful discussion led me to this on-going project. I patched the kernel according the instructions in the said project's `readme`, and Arch is now able to see the two graphics cards and an extra Intel audio controller.
    $ lspci
    00:02.0 VGA compatible controller: Intel Corporation Crystal Well Integrated Graphics Controller (rev 08)[/bold]
    00:03.0 Audio device: Intel Corporation Crystal Well HD Audio Controller (rev 08)
    01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 750M Mac Edition] (rev a1)
    Also, I was able to fire up Enlightenment using the Intel graphics card and `0xbb`'s `gpu-switch` script. After using some post-installation tips from this, the computer started getting hot. I followed this thread to get it back to normal.
    Edit:
    So I finally got some time to experiment on this. I ended up installing Gnome 3 after trying out Enlightenment, KDE Plasma 5, and Cinnamon. I thought Gnome 3 and Cinnamon had the best Hi-DPI support of those four. Cinnamon's look was too much trouble for me to configure, so I ended up choosing Gnome 3.
    To achieve the graphics card passthrough, I tried setting up and starting a VM in `virt-manager`, but starting the VM would cause Arch to freeze. Finally, I tried following the instructions on the wiki, this thread, and the Arch forums. I haven't yet tried booting the Windows installer, but the following are the steps I took so far:
    1. Uninstall all `nvidia` drivers from my system.
    2. Blacklist the `nouveau` driver.
    3. Add `pci-stub` to the modules array in `mkinitcpio.conf`.
    4. Recreate the `initramfs`.
    5. Add `intel_iommu=on pci-stub.ids=10de:0fe9,10de:0e1b,8086:156c` to the `refind.conf` `options` line.
    - These three IDs are ones for the Nvidia graphics, Nvidia sound, and the "Intel Corporation Device" (probably the HDMI port, or something related to the
    ethernet card), which belong to the same "IOMMU group". What was curious was that a Gigabit ethernet controller would appear in the IOMMU group iff I had
    an ethernet cable connected to my thunderbolt port. I don't know if I have to add the ID for this, but so far there are no complaints about it in `dmesg`.
    6. Install `ovmf-svn` from the AUR.
    6. Follow the "Binding a device to vfio-pci" section documented at https://bbs.archlinux.org/viewtopic.php?id=162768.
    7. Follow the "Testing if its working out" section documented at https://bbs.archlinux.org/viewtopic.php?id=162768.
    So far, the test at step 7 is failing -- I get a `vfio-pci 0000:01:00.0: Invalid ROM contents` complaint in `dmesg`, and I see a prompt in the `qemu` window. I'm supposed to be getting a black `qemu` window, and a prompt on an external monitor which I haven't connected yet. I read the comments on this blog about graphics card ROM and EFI compatibility, and it looks like my graphics card ROM can't be read. I also read that the graphics card ROM would only be read once by qemu/KVM and saved as a file for later use, so all I need to do to get around that is pass a snapshot of the ROM of the Nvidia GT 750M card to qemu/KVM. Apparently, "You can download the 750m rom files directly from Lenovo's website on the support page" according to this thread, but all I see is this. I will continue hunting around for a ROM file for this graphics card.
    Last edited by rb3 (2015-06-05 02:01:20)

    It`s not beacuse of the case. I have the same problem with a macbook pro retina 15 late 2013 (I7 - 2.3 Ghz, 16 GB, 512 SSD, GT750M) with windows 8.1 on bootcamp. The temperature is higher than yosemite. It gets easily at 80 celsius in a demanding game, while on yosemite it barely reaches 55-60 under heavy load. It`s beacuse of windows, and these are the temperatures, I got the same average 55-60 in windows and 45 celsius in yosemite. I read on the forums and I tried evend with a cooler pad. But it doesn`t seem to be any improvement with lowering the temperature in windows.

  • Trouble Setting "Display PDF in browser using" by MCX

    I want to force the PDF viewer in Safari to Mac OS X v10.6 built-in Preview Application instead of Adobe Acrobat Pro (9.4.0).
    I found that unchecking "Display PDF in browser using:" in Acrobat's Preferences, sets the viewer in Safari to Preview. It seems unchecking this box modifies ~/Library/Preferences/com.adobe.Acrobat.Pro_x86_9.0.plist. by creating the entry root => Originals (dictionary) => BrowserIntegration (array) => item 0 as number with value 0, item 1 as boolean with value 0.
    With that in mind I tried creating a MCX setting in my OD to apply root => Originals (dictionary) => BrowserIntegration (array) => item 0 as number with value 0, item 1 as boolean with value 0. Witch resulted in a grayed out, but checked settings for  "Display PDF in browser using:"
    I was wondering if any one has successfully figured out how to set this setting?

    Hi,
    Firstly during the installation of Reader X, there is an option of Customize Install. You can uncheck the Safari browser plugin from there. But this was possible before install. Now since you have installed in default mode (with above option checked during install) the method to disable plugin is as follows:
    To disable the plugin-
    1. Go to Library > Internet Plug-Ins
    2. You will see AdobePDFViewer.plugin in the list of plugins
    3. Create a new folder called Disabled Plug-Ins
    4. Move the AdobePDFViewer plugin into the Disabled Plug-Ins folder
    5. Restart  Safari
    In future if you want to re-enable this then you can put this plugin back to its original location or Reinstall Reader X (if you have permanently deleted the plug-in from your system). Reinstallation works as installing in repair mode.
    AcrobatX/ReaderX uses MANAGED installation method on Mac(as compared to MANUAL installation method used in earlier versions). In case of manual installation method installation and repair was dependent on "Self heal" mechanism that required the admin privileges each time it was invoked. This raised a bit of concern so to remove this Adobe now uses Managed installation method and discontinued Self Heal mechanism.
    You can check out this link for more information or if you want to track this discussion -
    http://acrobatusers.com/forum/deployment-installation/acrobat-x-installation-installed-saf ari-plugin-without-asking
    Thanks,
    Karan

  • [SOLVED]manually set resolv.conf nameserver when using netcfg

    This is probably simple, but i can't seem to find the answer anywhere (wiki/google/forums), so if someone could point me in  the right direction that would be great!
    When netcfg brings up my wireless connection it automatically overwrites my nameserver settings in /etc/resolv.conf
    how do i set it up so that it keeps my settings?
    Last edited by stevesutt89 (2009-02-23 21:58:27)

    Use DNS=()
    DNS=(192.123.123.123 167.21.51.12)
    There is also SEARCH= and DOMAIN= if needed.
    Last edited by iphitus (2009-02-21 10:22:36)

  • Trouble setting emplID upon account creation using PeopleSoft UM connector

    I am working with the PeopleSoft User Management Connector 9.1.0. I have the connector installed and can provision accounts. However when I try to provision an account and set the EmplID at the same time I get the following:
    ERROR,2010-04-05 15:56:19,249, [ACTIVE] ExecuteThread: '11' for queue: 'weblogic.kernel.Default (self-tuning)'OIMCP.PSFTUM - ====================================================
    ERROR,2010-04-05 15:56:19,249, [ACTIVE] ExecuteThread: '11' for queue: 'weblogic.kernel.Default (self-tuning)'OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getUser : No rows exist for the specified keys. Failed to get the Component Interface
    ERROR,2010-04-05 15:56:19,249, [ACTIVE] ExecuteThread: '11' for queue: 'weblogic.kernel.Default (self-tuning)'OIMCP.PSFTUM - ====================================================
    DEBUG,2010-04-05 15:56:19,249, [ACTIVE] ExecuteThread: '11' for queue: 'weblogic.kernel.Default (self-tuning)'OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::errorHandler:: STARTED
    INFO,2010-04-05 15:56:19,249, [ACTIVE] ExecuteThread: '11' for queue: 'weblogic.kernel.Default (self-tuning)'OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::errorHandler : (91,) : No rows exist for the specified keys. {USER_PROFILE} (91,50)
    INFO,2010-04-05 15:56:19,249, [ACTIVE] ExecuteThread: '11' for queue: 'weblogic.kernel.Default (self-tuning)'OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::errorHandler : (0,) : Failed to execute PSBusComp request
    DEBUG,2010-04-05 15:56:19,249, [ACTIVE] ExecuteThread: '11' for queue: 'weblogic.kernel.Default (self-tuning)'OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::errorHandler:: FINISHED
    INFO,2010-04-05 15:56:19,249, [ACTIVE] ExecuteThread: '11' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::setUser : User = 00000519 not found
    When I look in PeopleSoft, I can find the user (i.e., 00000519). And I can provision an account if I don't attempt to set the EmplID at the same time. Once the account is created I can set the EmplID.
    Edited by: Jay Sundu on Apr 6, 2010 8:18 AM

    Hey Suren, note the "null" return from createUser
    DEBUG,2010-04-08 09:53:12,719, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getConnectionWithTimeout:: STARTED
    INFO,2010-04-08 09:53:12,719, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getConnectionWithTimeout : API.createSession successful
    DEBUG,2010-04-08 09:53:12,773, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getConnectionWithTimeout:: FINISHED
    INFO,2010-04-08 09:53:12,773, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::connect : Connect = true
    DEBUG,2010-04-08 09:53:12,794, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::initializeClasses:: STARTED
    DEBUG,2010-04-08 09:53:12,794, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::initializeClasses:: FINISHED
    DEBUG,2010-04-08 09:53:12,794, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::invoke:: STARTED
    DEBUG,2010-04-08 09:53:12,794, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::invoke:: FINISHED
    INFO,2010-04-08 09:53:12,794, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::connect : Successfully Connected to App server
    DEBUG,2010-04-08 09:53:12,794, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::connect:: FINISHED
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getUnsupportedCharacters:: STARTED
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getUnsupportedCharacters : unsupportedCharacters from ITResource: ,##;## ##:##&##(##)##\##[##]##/##PPLSOFT##>##<##
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getUnsupportedCharacters : PSFT_UNSUPPORTED_CHARS[0]:,
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getUnsupportedCharacters : PSFT_UNSUPPORTED_CHARS[1]:;
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getUnsupportedCharacters : PSFT_UNSUPPORTED_CHARS[2]:
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getUnsupportedCharacters : PSFT_UNSUPPORTED_CHARS[3]::
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getUnsupportedCharacters : PSFT_UNSUPPORTED_CHARS[4]:&
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getUnsupportedCharacters : PSFT_UNSUPPORTED_CHARS[5]:(
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getUnsupportedCharacters : PSFT_UNSUPPORTED_CHARS[6]:)
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getUnsupportedCharacters : PSFT_UNSUPPORTED_CHARS[7]:\
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getUnsupportedCharacters : PSFT_UNSUPPORTED_CHARS[8]:[
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getUnsupportedCharacters : PSFT_UNSUPPORTED_CHARS[9]:]
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getUnsupportedCharacters : PSFT_UNSUPPORTED_CHARS[10]:/
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getUnsupportedCharacters : PSFT_UNSUPPORTED_CHARS[11]:PPLSOFT
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getUnsupportedCharacters : PSFT_UNSUPPORTED_CHARS[12]:>
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getUnsupportedCharacters : PSFT_UNSUPPORTED_CHARS[13]:<
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::getUnsupportedCharacters:: FINISHED
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::createUser:: STARTED
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - getTargetAttributeValueMap:: STARTED
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - getTargetAttributeValueMap:: FINISHED
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - isUserIDValid:: STARTED
    DEBUG,2010-04-08 09:53:12,795, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - isUserIDValid : result ::true
    DEBUG,2010-04-08 09:53:12,796, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - isUserIDValid:: FINISHED
    INFO,2010-04-08 09:53:12,796, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::createUser : Setting the UserID :: 00000522
    INFO,2010-04-08 09:53:12,841, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::createUser : User profile Created
    DEBUG,2010-04-08 09:53:12,841, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::createUser : Target API = setMultiLanguageEnabled
    ERROR,2010-04-08 09:53:12,841, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - ====================================================
    ERROR,2010-04-08 09:53:12,841, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::createUser : null
    ERROR,2010-04-08 09:53:12,841, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - ====================================================
    DEBUG,2010-04-08 09:53:12,841, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - ================================================
    DEBUG,2010-04-08 09:53:12,841, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM -
    DEBUG,2010-04-08 09:53:12,841, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - ===============START OF PRINTSTACKTRACE===========
    DEBUG,2010-04-08 09:53:12,841, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - java.math.BigDecimal.<init>(BigDecimal.java:457)
    DEBUG,2010-04-08 09:53:12,841, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - java.math.BigDecimal.<init>(BigDecimal.java:647)
    DEBUG,2010-04-08 09:53:12,841, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser.createUser(ProvisionPSFTBaseUser.java:491)
    DEBUG,2010-04-08 09:53:12,841, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - sun.reflect.NativeMethodAccessorImpl.invoke0(NativeMethodAccessorImpl.java:-2)
    DEBUG,2010-04-08 09:53:12,841, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - java.lang.reflect.Method.invoke(Method.java:597)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.adapterGlue.ScheduleItemEvents.adpADPPSFTUMCREATEUSER.CREATEUSER(adpADPPSFTUMCREATEUSER.java:379)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.adapterGlue.ScheduleItemEvents.adpADPPSFTUMCREATEUSER.implementation(adpADPPSFTUMCREATEUSER.java:108)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.client.events.tcBaseEvent.run(Unknown Source)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.dataobj.tcDataObj.runEvent(Unknown Source)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.dataobj.tcScheduleItem.runMilestoneEvent(Unknown Source)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.dataobj.tcScheduleItem.eventPostInsert(Unknown Source)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.dataobj.tcDataObj.insert(Unknown Source)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.dataobj.tcDataObj.save(Unknown Source)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.ejb.beansimpl.tcProvisioningOperationsBean.retryTasks(Unknown Source)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.ejb.beans.tcProvisioningOperationsSession.retryTasks(Unknown Source)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.ejb.beans.tcProvisioningOperations_b03yxm_EOImpl.retryTasks(tcProvisioningOperations_b03yxm_EOImpl.java:1286)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - Thor.API.Operations.tcProvisioningOperationsClient.retryTasks(Unknown Source)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - sun.reflect.NativeMethodAccessorImpl.invoke0(NativeMethodAccessorImpl.java:-2)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - java.lang.reflect.Method.invoke(Method.java:597)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - Thor.API.Base.SecurityInvocationHandler$1.run(Unknown Source)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - weblogic.security.service.SecurityManager.runAs(Unknown Source)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - weblogic.security.Security.runAs(Security.java:41)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - Thor.API.Security.LoginHandler.weblogicLoginSession.runAs(Unknown Source)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - Thor.API.Base.SecurityInvocationHandler.invoke(Unknown Source)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - $Proxy64.retryTasks(Unknown Source)
    DEBUG,2010-04-08 09:53:12,842, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.webclient.actions.ResourceProfileProvisioningTasksAction.retryTasks(Unknown Source)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - sun.reflect.NativeMethodAccessorImpl.invoke0(NativeMethodAccessorImpl.java:-2)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - java.lang.reflect.Method.invoke(Method.java:597)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - org.apache.struts.actions.DispatchAction.dispatchMethod(DispatchAction.java:280)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.webclient.actions.tcLookupDispatchAction.execute(Unknown Source)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.webclient.actions.tcActionBase.execute(Unknown Source)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.webclient.actions.tcAction.execute(Unknown Source)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:484)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:274)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - org.apache.struts.action.ActionServlet.process(ActionServlet.java:1482)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:525)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:227)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:125)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:292)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:26)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:42)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.webclient.security.SecurityFilter.doFilter(Unknown Source)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:42)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3496)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - weblogic.security.service.SecurityManager.runAs(Unknown Source)
    DEBUG,2010-04-08 09:53:12,843, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:2180)
    DEBUG,2010-04-08 09:53:12,844, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:2086)
    DEBUG,2010-04-08 09:53:12,844, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1406)
    DEBUG,2010-04-08 09:53:12,844, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
    DEBUG,2010-04-08 09:53:12,844, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - weblogic.work.ExecuteThread.run(ExecuteThread.java:173)
    DEBUG,2010-04-08 09:53:12,844, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - ===============END OF PRINTSTACKTRACE==============
    DEBUG,2010-04-08 09:53:12,844, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::errorHandler:: STARTED
    DEBUG,2010-04-08 09:53:12,844, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::closeSession:: STARTED
    DEBUG,2010-04-08 09:53:12,844, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::createUser:: FINISHED
    DEBUG,2010-04-08 09:53:12,844, [ACTIVE] ExecuteThread: '15' for queue: 'weblogic.kernel.Default (self-tuning)' OIMCP.PSFTUM - com.thortech.xl.um.integration.hostAccess.ProvisionPSFTBaseUser::closeSession:: STARTED

  • HT201250 I am having trouble setting up my time capsule.  the amber light is flashing.  i have a Verizon FIOS network that i use for the internet (WiFi) and do not want to configure the Time Capsule to do that function.  I just want the Time Capsule to ba

    I am having trouble setting up my time capsule.  the amber light is flashing.  i have a Verizon FIOS network that i use for the internet (WiFi) and do not want to configure the Time Capsule to do that function.  I just want the Time Capsule to back up.

    Simple.. bridge the TC.. in the apple utility in the NAT and DHCP area.
    Plug it into the FIOS router.. you can turn off wireless in the TC if you want.. or use it.. it can work faster if you are nearby and can select 5ghz.. but up to you.

  • I purchased a gift card and entered the code to redeem it; however, i never used it.  i initially had trouble setting up my itune account and had to create a new acct.  is this why my gift card is invalid?

    i purchased a gift card and entered the code to redeem it; however, i never used it.  i initially had trouble setting up my itune account and had to create a new acct.  is this why my gift card is invalid?

    Yes.
    You have already redeemed it.  It should be available on the old account.  Why did you make another?

  • [Solved] Help Setting Samba Share In Qemu With XP Guest

    Hello all,
    After getting around all the quirks of setting an XP guest inside qemu, the only (though, pretty important) thing I can't solve is setting a samba share between the Arch host and the XP guest.
    I tried whatever I could think of that's relevant, with no success:
    Qemu is launched with:
    qemu-system-x86_64 -machine type=pc,accel=kvm -cpu host -boot d -m 1024 -net user,smb={my home folder} -net nic,model=virtio -rtc base=localtime -drive file=XP.qcow2,if=virtio -spice port=5900,disable-ticketing,image-compression=off,jpeg-wan-compression=never,zlib-glz-wan-compression=never,playback-compression=off -vga qxl -global qxl-vga.vram_size=67108864 -device virtio-serial-pci -device virtserialport,chardev=spicechannel0,name=com.redhat.spice.0 -chardev spicevmc,id=spicechannel0,name=vdagent -balloon virtio
    I installed samba, added a user, and started the service according to the wiki.
    I allowed the samba ports in UFW (using the CIFS rule).
    Whenever I try accessing the share inside my XP guest (\\10.0.2.4\qemu), I usually end up with a target not found error, or at times, a password prompt that will not accept the samba user/password.
    Anything else I forgot to do?
    Thanks, Adam.
    * EDIT *
    I somehow missed the section regarding the guest OS able to access the host OS normal samba shares at 10.0.2.2.
    Default samba share for home folder works as expected.
    Last edited by adam777 (2013-07-15 16:05:44)

    Thanks.
    I tried toying with the options a bit more, with no success.
    I then decided to try Spice+QXL anyway, and am very happy with it.
    Aside from the lengthy compilation of the Qemu version that supports Spice from the AUR, once I got it set up, installing the guest was a breeze.
    Using the Spice guest tools for windows, everything was set up very conveniently (virtio for network, hdd, qxl driver, mouse integration etc.).
    Responsiveness is much better comparing to previous attempts with "vga std", "vga cirrus" and normal adapter.
    Bottom line, I'm sticking with Spice+QXL, seems to work best for me.

  • I have trouble setting the trash mailbox behavior. I have set it to delete every month but it has been keeping the trash mails for only about 10 days. Please help.

    I have trouble setting the trash mailbox behavior. I have had it set to delete the messages once a month. But lately it has been deleting my messages every 10 days. I have tried choosing different options to set the trash mailbox behavior but has not been successful. Is there anything I can do? Please help.

    Thanks for that advice @randers4.
    I linked through and submitted my info as a "topic not covered" in the iCloud section. After entering the serial number of my MBP it turns out I wasn't eligible for technical support (though I don't think this is hardware related support) and the final suggestion was to take my computer into an Apple store. I called my local Apple reseller and asked for assistance. The customer service rep was very nice but unable to help, so suggested I call Apple Support on 1300 321 456. I did so and, again, spoke to two very polite and helpful customer service people (I was transferred to security services). I didn't have to be on hold to speak to either rep for more than a few seconds! After trying a few different things, he worked out what was happening...
    So, to cut a long story short, to solve the problem in my OP, all I had to do was log out of iCloud in my System Preferences and log back in using my current Apple ID. [Edited to add that I had to sign out of everything I was currently signed in to with my Apple ID before logging out and in again.]
    Problem solved!
    Message was edited by: NotBaconBits

  • Setting up IPsec VPNs to use with Cisco Anyconnect

    So I've been having trouble setting up vpns on our ASA 5510. I would like to use IPsec VPNs so that we don't have to worry about licensing issues, but from what I've read you can do this with and still use Cisco Anyconnect. My knowledge on how to set up VPNs especially in iOS verion 8.4 is limited so I've been using a combination of command line and ASDM.
    I'm finally able to connect from a remote location but once I connect, nothing else works. From what I've read, you can use IPsec for client-to-lan connections. I've been using a preshared key for this. Documentation is limited on what should happen after you connect? Shouldn't I be able to access computers that are local to the vpn connection? I'm trying to set this up from work. If I VPN from home, shouldn't I be able to access all resources at work? I think because I've used the command line as well as ASDM I've confused some of the configuration. Plus I think some of the default policies are confusing me too. So I probably need a lot of help. Below is my current configuration with IP address altered and stuff that is completely non-related to vpns removed.
    NOTE: We are still testing this ASA and it isn't in production.
    Any help you can give me is much appreciated.
    ASA Version 8.4(2)
    hostname ASA
    domain-name domain.com
    interface Ethernet0/0
    nameif inside
    security-level 100
    ip address 192.168.0.1 255.255.255.0
    interface Ethernet0/1
    nameif outside
    security-level 0
    ip address 50.1.1.225 255.255.255.0
    interface Ethernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface Ethernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    no nameif
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    boot system disk0:/asa842-k8.bin
    ftp mode passive
    dns domain-lookup outside
    dns server-group DefaultDNS
    same-security-traffic permit intra-interface
    object network NETWORK_OBJ_192.168.0.224_27
    subnet 192.168.0.224 255.255.255.224
    object-group service VPN
    service-object esp
    service-object tcp destination eq ssh
    service-object tcp destination eq https
    service-object udp destination eq 443
    service-object udp destination eq isakmp
    access-list ips extended permit ip any any
    ip local pool VPNPool 192.168.0.225-192.168.0.250 mask 255.255.255.0
    no failover
    failover timeout -1
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-645.bin
    no asdm history enable
    arp timeout 14400
    nat (inside,outside) source static any any destination static NETWORK_OBJ_192.168.0.224_27 NETWORK_OBJ_192.168.0.224_27 no-proxy-arp route-lookup
    object network LAN
    nat (inside,outside) dynamic interface
    access-group outside_in in interface outside
    route outside 0.0.0.0 0.0.0.0 50.1.1.250 1
    sysopt noproxyarp inside
    sysopt noproxyarp outside
    crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec ikev2 ipsec-proposal DES
    protocol esp encryption des
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal 3DES
    protocol esp encryption 3des
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES
    protocol esp encryption aes
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES192
    protocol esp encryption aes-192
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES256
    protocol esp encryption aes-256
    protocol esp integrity sha-1 md5
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto ca trustpoint ASDM_TrustPoint0
    enrollment self
    subject-name CN=ASA
    crl configure
    crypto ca server
    shutdown
    crypto ca certificate chain ASDM_TrustPoint0
    certificate d2c18c4e
        308201f3 3082015c a0030201 020204d2 c18c4e30 0d06092a 864886f7 0d010105
        0500303e 3110300e 06035504 03130741 53413535 3130312a 30280609 2a864886
        f70d0109 02161b41 53413535 31302e64 69676974 616c6578 7472656d 65732e63
        6f6d301e 170d3131 31303036 31393133 31365a17 0d323131 30303331 39313331
        365a303e 3110300e 06035504 03130741 53413535 3130312a 30280609 2a864886
        f70d0109 02161b41 53413535 31302e64 69676974 616c6578 7472656d 65732e63
        6f6d3081 9f300d06 092a8648 86f70d01 01010500 03818d00 30818902 818100b2
        8acbe1f4 5aa19dc5 d3379bf0 f0e1177d 79b2b7cf cc6b4623 d1d97d4c 53c9643b
        37f32caf b13b5205 d24457f2 b5d674cb 399f86d0 e6c3335f 031d54f4 d6ca246c
        234b32b2 b3ad2bf6 e3f824c0 95bada06 f5173ad2 329c28f8 20daaccf 04c51782
        3ca319d0 d5d415ca 36a9eaff f9a7cf9c f7d5e6cc 5f7a3412 98e71de8 37150f02
        03010001 300d0609 2a864886 f70d0101 05050003 8181009d d2d4228d 381112a1
        cfd05ec1 0f51a828 0748172e 3ff7b480 26c197f5 fd07dd49 01cd9db6 9152c4dc
        18d0f452 50f5d0f5 4a8279c4 4c1505f9 f5e691cc 59173dd1 7b86de4f 4e804ac6
        beb342d1 f2db1d1f 878bb086 981536cf f4094dbf 36c5371f e1a0db0a 75685bef
        af72e31f a1c4a892 d0acc618 888b53d1 9b888669 70e398
      quit
    crypto ikev2 policy 1
    encryption aes-256
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 10
    encryption aes-192
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 20
    encryption aes
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 30
    encryption 3des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 40
    encryption des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 enable outside client-services port 443
    crypto ikev2 remote-access trustpoint ASDM_TrustPoint0
    crypto ikev1 enable outside
    crypto ikev1 policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 65535
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh timeout 10
    console timeout 0
    management-access inside
    ssl trust-point ASDM_TrustPoint0 outside
    webvpn
    enable outside
    anyconnect image disk0:/anyconnect-win-2.5.2014-k9.pkg 1
    anyconnect image disk0:/anyconnect-linux-2.5.2014-k9.pkg 2
    anyconnect image disk0:/anyconnect-macosx-i386-2.5.2014-k9.pkg 3
    anyconnect profiles VPN disk0:/devpn.xml
    anyconnect enable
    tunnel-group-list enable
    group-policy VPN internal
    group-policy VPN attributes
    wins-server value 50.1.1.17 50.1.1.18
    dns-server value 50.1.1.17 50.1.1.18
    vpn-tunnel-protocol ikev1 ikev2 l2tp-ipsec ssl-client
    default-domain value digitalextremes.com
    webvpn
      anyconnect profiles value VPN type user
      always-on-vpn profile-setting
    username administrator password xxxxxxxxx encrypted privilege 15
    username VPN1 password xxxxxxxxx encrypted
    tunnel-group VPN type remote-access
    tunnel-group VPN general-attributes
    address-pool (inside) VPNPool
    address-pool VPNPool
    authorization-server-group LOCAL
    default-group-policy VPN
    tunnel-group VPN webvpn-attributes
    group-alias VPN enable
    tunnel-group VPN ipsec-attributes
    ikev1 pre-shared-key *****
    class-map inspection_default
    match default-inspection-traffic
    class-map ips
    match access-list ips
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect ip-options
      inspect netbios
      inspect rsh
      inspect rtsp
      inspect skinny 
      inspect esmtp
      inspect sqlnet
      inspect sunrpc
      inspect tftp
      inspect sip 
      inspect xdmcp
      inspect http
    class ips
      ips inline fail-open
    class class-default
      user-statistics accounting

    Hi Marvin, thanks for the quick reply.
    It appears that we don't have Anyconnect Essentials.
    Licensed features for this platform:
    Maximum Physical Interfaces       : Unlimited      perpetual
    Maximum VLANs                     : 100            perpetual
    Inside Hosts                      : Unlimited      perpetual
    Failover                          : Active/Active  perpetual
    VPN-DES                           : Enabled        perpetual
    VPN-3DES-AES                      : Enabled        perpetual
    Security Contexts                 : 2              perpetual
    GTP/GPRS                          : Disabled       perpetual
    AnyConnect Premium Peers          : 2              perpetual
    AnyConnect Essentials             : Disabled       perpetual
    Other VPN Peers                   : 250            perpetual
    Total VPN Peers                   : 250            perpetual
    Shared License                    : Disabled       perpetual
    AnyConnect for Mobile             : Disabled       perpetual
    AnyConnect for Cisco VPN Phone    : Disabled       perpetual
    Advanced Endpoint Assessment      : Disabled       perpetual
    UC Phone Proxy Sessions           : 2              perpetual
    Total UC Proxy Sessions           : 2              perpetual
    Botnet Traffic Filter             : Disabled       perpetual
    Intercompany Media Engine         : Disabled       perpetual
    This platform has an ASA 5510 Security Plus license.
    So then what does this mean for us VPN-wise? Is there any way we can set up multiple VPNs with this license?

  • My VGA output using Mini DisplayPort to VGA doesn't work.

    Since I upgraded to Mavericks, my VGA output using Mini DisplayPort to VGA doesn't work. When I was using Mountain Lion, as soon as you plugged in the Mini adaopter into the mini display port, the screen would shrink and format to where it would project via a RGB cable to a projector. No such luck since Mavericks! Also, I had a lot of trouble with the DVD player when I tried to play a DVD and project it via a projector. It all worked seamlessly with Mountain Lion. Can anyone help me?

    I think if you go to System Preferences >> Displays and Option-click on the "Scaled" radio button, it will show you all of the resolutions that you would have had before under Mountain Lion. I just upgraded to Maverick and my resolution preferences (mirrored on a TV using the Mini DisplayPort to VGA adapter, using 1280x768) were completely reset (my display was no longer mirrored, and the resolution on my main iMac screen became 2560x1440). I found my answer here: https://discussions.apple.com/message/23599645#23599645. Hope that helps.

  • Having trouble setting up my website. It's probably a silly mistake.

    So I've registered a domain and hosting plan with A Simple Orange which had a pretty good deal since I had a coupon for 20% off. I've tried using Joomla to manage my website, but I couldn't get the hang of it. So I'm trying out iWeb 09' now and just having trouble setting it up. I've gone to me.com and added my website and added the CNAME correctly I hope. Here is a picture. http://imgur.com/XI8Lw.png
    Next I opened iWeb and setup MobileMe in the preferences panel. I've tried publishing the information from iWeb to my website, but my home page doesn't change. You can see here at RyanSchefer.com that it's just plan

    No. Your CNAME setting is not correct. The CNAME and web.me.com are correct with web.me.com being your host. However, your domain name is incorrect - don't understand why you have put mobileme before it? You just enter either your domain name on its own so domain.com or you need to set up two separate CNAME entries, one being for www, CNAME, web.me.com and then one being @, CNAME, web.me.com. The @ stands for your domain name and the www is your sub domain.
    Try altering this and it should work okay.

  • Having trouble setting up email accounts in the mail app?

    Hi Apple community,
         I am having trouble setting up my email accounts with the osX mail application. I have two accounts, an outlook and my college email through google. When I try to add the outlook account the prompt says that it cannot connect to the server and when I try my college mail i get the following prompt.
    "Trying to log in to the Exchange server “autodiscover-s.outlook.com” failed. Make sure the email address and password you entered are correct, then click Continue."
    Please note that my college account is run by gmail and ends in murraystate.edu
    Thanks, Will.

    Hey will,
    okay for your college email. Heres what you do.
    Try adding your email and wait for the message to come up
    Trying to log in to the Exchange server “autodiscover-s.outlook.com” failed. Make sure the email address and password you entered are correct, then click Continue."
    Once it does, you will notice 2 extra boxes One says username and the other password. You will notice that the username will not have @murraystate.edu
    Add this and continue and this should now be added as an email account and should be able to receive emails as normal.
    For your outlook emails, I would recommend using the following article to set it up. It is fairly straightforward.
    http://howto.cnet.com/8301-11310_39-57602775-285/how-to-set-up-mac-mail-to-use-i map-for-outlook.com/
    Hope that helps.

  • Having trouble setting up FaceTime.   keep giving me Apple ID password

    having trouble setting up FaceTime.  trouble at verifying use I'd.  I have my email setup with different password since I have tw setup email.   my Apple ID has different password.   same email name.

    Hello sangjaimepark,
    Thank you for the details of the issue you are experiencing with activating FaceTime.  I recommend reviewing the article below for FaceTime activation issues.  When trying to activate FaceTime, you will need to use the email address you use for your Apple ID and your Apple ID password and not your email password:
    iOS: Troubleshooting FaceTime and iMessage activation
    http://support.apple.com/kb/ts4268
    Thank you for using Apple Support Communities.
    Best,
    Sheila M.

Maybe you are looking for