Table Trouble

Hi there
I'm having a problem moving tables in Frame docs. Basically, we have a Frame API client which
has to delete all the text in an FM or MIF file, before writing out a translated version of the text back
to the document.
As this process proceeds, non-textual objects in the document such as tables and anchored frames
can be expected to move about the document. What I want to do is move tables back into their pre-text deletion position
after the translated text has been put in place. For the most part it works, but in some documents
strange problems occur, such as a table being written out 12 times successively, one after the other.
Another problem that frequently occurs is that because translated text often uses more characters
than the original, the text ends up wrapping around and below a table, where originally the table
was below the text.
Our current approach is to delete the normal text in the document,
and if we find a table, we wrap the table's
unique ID, object type, text offset and paragraph handle inside
a struct, and pop that struct into a vector.
After all the deletion and re-insertion of text is complete, we iterate through the vector,
and compare the current location of each table in the vector to it's original location.
If they differ, we then cut the table from its current position back to its original.
Im guessing it's a bit more complicated than that to do it right though?
Any comments or suggestions would be very much appreciated! 

As an addendum, the code to reposition the tables is shown below:
int o = 0;
const int nMoveCount((int)m_aObjectsToMove.size());
while(o < nMoveCount)
   Anchor a = m_aObjectsToMove[o];
   F_ObjHandleT hAnchor = F_ApiGetUniqueObject(m_hDocument, a.m_nObjectType, a.m_nUID);
   F_TextRangeT textRange;
   textRange.beg = F_ApiGetTextLoc(m_hDocument, hAnchor, FP_TextLoc);
   /* does the anchor' s current location differ
      from the location it was in when pushed into m_aObjectsToMove?
      If not don't move it!
      Problems will arise if anchors are cut from a paragraph which has no other content
      We never have to worry about this because in an empty paragraph an hAnchor tag cannot be moved
      if (textRange.beg.offset != a.m_nOffset)
         textRange.end.objId = textRange.beg.objId;
         textRange.end.offset = textRange.beg.offset+1;
         // Select the object
        if (a.m_nObjectType == FO_Tbl)
            F_ApiMakeTblSelection(m_hDocument, hAnchor, FF_SELECT_WHOLE_TABLE, 0, 0, 0);
                else F_ApiSetTextRange(FV_SessionId, m_hDocument, FP_TextSelection, &textRange);
        F_ApiCut(m_hDocument, FF_CUT_TBL_CELLS);
        F_TextRangeT newRange;
        newRange.beg.objId = a.m_nPgf;
        newRange.end.objId = a.m_nPgf;
        if (a.m_nOffset > 0)
           newRange.beg.offset = a.m_nOffset-1;
           newRange.end.offset = a.m_nOffset-1;
        else
           newRange.beg.offset = a.m_nOffset;
           newRange.end.offset = a.m_nOffset;
        // Paste the hAnchor into its new position
        F_ApiSetTextRange(FV_SessionId, m_hDocument, FP_TextSelection, &newRange);
        F_ApiPaste(m_hDocument, FF_REPLACE_CELLS);
        o++;

Similar Messages

  • Cannot Sort or Filter

    Strangely, I have done something to my Numbers table that will not allow me to Sort or Filter. For example, even the simplest of sort functions will not work, ie: sort name column, ascending. I have checked everything obvious. I have disabled any filters, and categorization. Why can I not apply any Sorting or Filters?

    Andrew,
    We're just users like you. We'll do our best to help you with tips and guidance based on our experience, but we have little to no influence on how the program may be changed in future releases.
    The first tip I would offer is never merge or split. Numbers offers you many ways to highlight and add notation without having to merge or split cells. So why do we have these options? There are cases where merging and splitting can be harmless: when we know we will never want/need to sort, or categorize, or use equations that reference whole columns/rows of data.
    Second tip. Learn how to build separate tables to summarize the data under your own control. This is fun and effective and if you don't like the result you have no one to blame but yourself.
    All that said, the Check Register template does have a merged cell in the first row and it does operate properly when categorizing the sample data the it comes pre-populated with, even the Date column works just fine here. This proves that while merging and splitting can be the cause of table troubles, it doesn't necessarily cause table corruption. It just improves, or worsens, the odds.
    I'd suggest that you open a fresh template and see if you can do what you want with the sample data. If not, you have a system problem or a problem of understanding the Categories feature. This group can help you work through that. It would be best though if you would open a new topic to discuss it.
    Jerry

  • Download a value

    Hi,
    When we download a value like 12.300 from SAP into an excel sheet, in the excel sheet the value is downloaded as 12.3. It is wrong and it should be 12300. In SAP '.' is considered as comma and ',' is conidered as decimal point.
    How can we download the same into excel sheet without losing the zeros like 12300 instead of 12.3.
    I cannot change the user profile setting. it is client specific.
    Thanks

    hi abhishek,
    check this notes,
    Many SAP reports have direct download function to EXCEL.
    SAP Query and SAP QuickViewer are excellent tools for Downloading (BvdR AO).
    Transaction SE16N allows you to access any sap table and download result to Excel
    SAP RFC functions can be called directly from Excel / VBA.
    Use transaction BAPI in SAP to find your business object and study the function.
      If you know the SAP table the RFC RFC_READ_TABLE offers a SQL query of the table
      Trouble is .. you can not use joins here. you have to put the join in as a query in the SAP database and use the query in RFC_READ_TABLE
    To upload data from Excel into SAP:
    Some of the Business functions (BAPI's / RFC unctions) offer data upload
    The general tool in SAP for data upload is the Batch input / call transactions
    In the batch input file you specify screen by screen and field by field the input to SAP. SAP has a recorder to create the sample file. Just run trans SHDB and within this trans you run a case of the changes you want to do. On exit of the trans you will have a batch input file that you can download and from excel manipulate the file before you call the RFC function RFC_CALL_TRANSACTION.

  • Nested tables causes trouble in RoboHelp FM Import

    May be someone here in this forum knows a solution or a workaround for my trouble with a FrameMaker Import in RoboHelp.
    Background:
    To generate context sensitive Windows HTML-Help a FrameMaker document is imported into RoboHelp.
    There are lots of nested tables (a table cell contains an anchored frame with a text frame and inside of this text frame is a table).
    Problem:
    RoboHelplets all occurrences of these nested tables empty.
    It seems that RoboHelp converts anchored frames into JPG and expects certain formats inside these frames only.
    There are lots of empty (white) JPG files in the RoboHelp project.
    Anchored frames with:
    text frames with text inside
    text appears
    text frames with text and table inside
    text appears, table appears NOT
    Question:
    Is there a workaround in FM to overcome this "absent feature" in RoboHelp.
    We use TSC 2 on Windows XP SP3.
    Thanks
    Norbert

    42,
    It would be a little more productive if you mentioned the rev levels that you're using....
    Depending on the content of the second level of cells (Just sub-divided cells? Discrete table titles? Contrasting formatting? Other stuff?), I'd think about faking it by creating a larger parent table and custom ruling/shading the pseudo-nested tables. And I'd definitely go that way if you have a lot of them and RH is a firm part of your workflow.
    It may also be worth downloading the free eval of MIF2Go and seeing if that handles the nesting any better.
    And finally, one long shot to try... what happens if you nest the tables in Word, then copy them into Frame as RTF (Special Copy)?
    But don't hold your breath... the programs are, after all, created by engineers and they may not push the envelope in test cases as far as writers do. ;-  )  For instance, I'd wonder if the RH coders are aware that you can nest tables in FM this way? It wouldn't come up too often.
    You may also want to visit the Tech Comm Suite Users Group (http://groups.google.com/group/TCS-Users?hl=en) and post there. I don't think there would be a different answer, but...
    Art

  • Trouble writing Query for Pivoting data from a table

    I am having a little trouble writing a query for converting the below table data into a pivot data. I am trying to write a query for which if I give a single valid report_week date as input it should give me the data for that week and also provide two extra columns, one which gives the data of last week for the same countries and the second column which gives the difference of numbers in both the columns(i.e. COUNT - COUNT_LAST_WEEK).
    REPORT_WEEK     DIVISION     COUNT
    9/26/2009     country1     81
    9/26/2009     country2     97
    9/26/2009     country3     12
    9/26/2009     country4     26
    9/26/2009     country5     101
    10/3/2009     country1     85
    10/3/2009     country2     98
    10/3/2009     country3     10
    10/3/2009     country4     24
    10/3/2009     country5     101
    10/10/2009     country1     84
    10/10/2009     country2     98
    10/10/2009     country3     10
    10/10/2009     country4     25
    10/10/2009     country5     102
    For example, if I give input as 10/10/2009, the output should be as give below.
    REPORT_WEEK     DIVISION     COUNT     COUNT_LAST_WEEK     DIFFERENCE
    10/10/2009     country1     84     85     -1
    10/10/2009     country2     98     98     0
    10/10/2009     country3     10     10     0
    10/10/2009     country4     25     24     1
    10/10/2009     country5     102     101     1
    For example, if I give input as 10/3/2009, the output should be as give below.
    REPORT_WEEK     DIVISION     COUNT     COUNT_LAST_WEEK     DIFFERENCE
    10/3/2009     country1     85     81     4
    10/3/2009     country2     98     97     1
    10/3/2009     country3     10     12     -2
    10/3/2009     country4     24     26     -2
    10/3/2009     country5     101     101     0
    Can anyone please shed some light on Query building for the above scenarios.
    Thank you
    SKP
    Edited by: user11343284 on Oct 10, 2009 7:53 AM
    Edited by: user11343284 on Oct 10, 2009 8:28 AM

    I assume there is no gap in report weeks. If so:
    SQL> variable report_week varchar2(10)
    SQL> exec :report_week := '10/10/2009'
    PL/SQL procedure successfully completed.
    with t as (
               select to_date('9/26/2009','mm/dd/yyyy') report_week,'country1' division,81 cnt from dual union all
               select to_date('9/26/2009','mm/dd/yyyy'),'country2',97 from dual union all
               select to_date('9/26/2009','mm/dd/yyyy'),'country3',12 from dual union all
               select to_date('9/26/2009','mm/dd/yyyy'),'country4',26 from dual union all
               select to_date('9/26/2009','mm/dd/yyyy'),'country5',101 from dual union all
               select to_date('10/3/2009','mm/dd/yyyy'),'country1',85 from dual union all
               select to_date('10/3/2009','mm/dd/yyyy'),'country2',98 from dual union all
               select to_date('10/3/2009','mm/dd/yyyy'),'country3',10 from dual union all
               select to_date('10/3/2009','mm/dd/yyyy'),'country4',24 from dual union all
               select to_date('10/3/2009','mm/dd/yyyy'),'country5',101 from dual union all
               select to_date('10/10/2009','mm/dd/yyyy'),'country1',84 from dual union all
               select to_date('10/10/2009','mm/dd/yyyy'),'country2',98 from dual union all
               select to_date('10/10/2009','mm/dd/yyyy'),'country3',10 from dual union all
               select to_date('10/10/2009','mm/dd/yyyy'),'country4',25 from dual union all
               select to_date('10/10/2009','mm/dd/yyyy'),'country5',102 from dual
    select  max(report_week) report_week,
            division,
            max(cnt) keep(dense_rank last order by report_week) cnt_this_week,
            max(cnt) keep(dense_rank first order by report_week) cnt_last_week,
            max(cnt) keep(dense_rank last order by report_week) - max(cnt) keep(dense_rank first order by report_week) difference
      from  t
      where report_week in (to_date(:report_week,'mm/dd/yyyy'),to_date(:report_week,'mm/dd/yyyy') - 7)
      group by division
      order by division
    REPORT_WE DIVISION CNT_THIS_WEEK CNT_LAST_WEEK DIFFERENCE
    10-OCT-09 country1            84            85         -1
    10-OCT-09 country2            98            98          0
    10-OCT-09 country3            10            10          0
    10-OCT-09 country4            25            24          1
    10-OCT-09 country5           102           101          1
    SQL> exec :report_week := '10/3/2009'
    PL/SQL procedure successfully completed.
    SQL> /
    REPORT_WE DIVISION CNT_THIS_WEEK CNT_LAST_WEEK DIFFERENCE
    03-OCT-09 country1            85            81          4
    03-OCT-09 country2            98            97          1
    03-OCT-09 country3            10            12         -2
    03-OCT-09 country4            24            26         -2
    03-OCT-09 country5           101           101          0
    SQL> SY.

  • Troubles editing tables with partitions

    I'm running SQL Developer 1.5.3 against Oracle 10/11 databases and SQL Developer has trouble with my partitioned tables. Both the schema owner and sys users experience the same problems.
    The first time I try to edit a table, I get an "Error Loading Objects" dialog with a NullPointException message. If I immediately turn around and try to edit the table again, I get the Edit Table dialog. That's annoying but there's at least a work-around.
    Next, if I select the Indexes pane, I can view the first index but selecting another one results in an "Index Error on <table>" error dialog. The message is "There are no table partitions on which to define local index partitions". At this point, selecting any of the other panes (Columns, Primary Key, etc.) results in the same dialog. While the main Partitions tab shows my partitions, I cannot see them in the Edit Table dialog. In fact, the Partition Definitions and Subpartition Templates panes are blank.
    Does anyone else see this behavior? Version 1.5.1 behaved the same way so it's not new.
    Of course I've figured out how to do everything I need through SQL but it would be handy if I could just use the tool.
    Thank you.

    Most of my tables are generated from a script so this morning I decided to just create a very basic partitioned table. It contained a NUMBER primary key and a TIMESTAMP(6) column to use with partitioning. That table worked just fine in SQL Developer.
    At that point I tried to figure out what is different about my tables and I finally found the difference... Oracle Spatial. If I add an MDSYS.SDO_GEOMETRY column to my partitioned table, SQL Developer starts having issues.
    I also have the GeoRaptor plugin installed so I had to wonder if it was interfering with SQL Developer. I couldn't find an option to uninstall an extension so I went into the sqldeveloper/extensions directory and removed GeoRaptorLibs and org.GeoRaptor.jar. GeoRaptor doesn't appear to be installed in SQL Developer anymore but I still see the same behavior.
    It appears that there is an issue in SQL Developer with Oracle Spatial and partitioning. Can someone confirm this?

  • Trouble getting internet route table distributet in a VRF

    Hi every one ..
    I'm have some trouble getting distributed the internet routing table between PE routers ...
    CE1 og PE1 works fine, BGP routes all internet routes are shown i en route table, but distributing between PE1 and PE2 is now working .. any one having a clue !!.
    My gold is to move internet access into it's oven VRF, and away from the global routing table
    In the MPLS core aim running the same AS number as our official AS, that we use for peering to the internet..
    snap of configurations
    ***CE1***
    router bgp 65534
    neighbor 172.31.61.55 remote-as 65534
    neighbor 172.31.61.55 description PE-1
    neighbor 172.31.61.55 shutdown
    neighbor 172.31.61.55 update-source Loopback0
    neighbor 172.31.61.55 next-hop-self
    ***MPLS PE1***
    ip vrf NET-INTERNET
    rd 65534:10051
    route-target export 65534:10051
    route-target import 65534:10051
    interface Port-channel1.35
    encapsulation dot1Q 35
    ip vrf forwarding NET-INTERNET
    ip address 172.31.61.55 255.255.255.224
    mpls label protocol ldp
    tag-switching mtu 1546
    tag-switching ip
    router bgp 65534
    neighbor 192.168.0.146 remote-as 65534
    neighbor 192.168.0.146 description PE2
    neighbor 192.168.0.146 update-source Loopback0
    neighbor 192.168.0.146 version 4
    neighbor 192.168.0.146 next-hop-self
    address-family vpnv4
    neighbor 192.168.0.146 activate
    neighbor 192.168.0.146 send-community both
    exit-address-family
    address-family ipv4 vrf NET-INTERNET
    neighbor 172.31.1.2 remote-as 65534
    neighbor 172.31.1.2 activate
    neighbor 172.31.1.2 description CE1
    no auto-summary
    no synchronization
    exit-address-family
    ***MPLS PE2***
    ip vrf NET-INTERNET
    rd 65534:10051
    route-target export 65534:10051
    route-target import 65534:10051
    interface Port-channel1.67
    encapsulation dot1Q 67
    ip vrf forwarding NET-INTERNET
    ip address 172.31.254.1 255.255.255.252
    mpls label protocol ldp
    tag-switching mtu 1546
    tag-switching ip
    router bgp 65534
    neighbor 192.168.0.132 remote-as 65534
    neighbor 192.168.0.132 description PE1
    neighbor 192.168.0.132 update-source Loopback0
    neighbor 192.168.0.132 version 4
    address-family ipv4 vrf NET-INTERNET
    neighbor 172.31.254.2 remote-as 65534
    neighbor 172.31.254.2 activate
    Best regards
    /Peter

    For VPN routes to be exchanged between the two PEs, you first need to configure VPNv4 address family on each one of the PEs.
    Carrying the full Internet routing table over VPNv4 will work but it is not very scalable since all PE routers have to hold the full Internet routing table in the VRF context in addition to potentially full Internet routing table in the global routing table. If you want to exchange full Internet routing table between the two CEs, it would be preferable to use something Carrier Supporting Carrier (CSC).
    Please refer to the following URL for additional information on CSC:
    http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120s/120s23/fscscl23.htm
    Hope this helps,

  • Trouble with RFC table input

    Greetings Experts,
    I'm having trouble with calling an RFC with table input.
    Here is my code so far:
      public void executeZps_Fm_War_Mat_Update_Input( )
        //@@begin executeZps_Fm_War_Mat_Update_Input()
              //$$begin Service Controller(344531631)
              IWDMessageManager manager = wdComponentAPI.getMessageManager();
              try {
                   int size =
                        wdContext
                             .nodeZps_Fm_War_Mat_Prefill_Input()
                             .nodeWarOut()
                             .nodeEx_Warout()
                             .size();
                   for (int i = 0; i < size; i++) {
                        IPublicWARComp.IEx_WaroutElement srcElement =
                             wdContext
                                  .nodeZps_Fm_War_Mat_Prefill_Input()
                                  .nodeWarOut()
                                  .nodeEx_Warout()
                                  .getEx_WaroutElementAt(i);
                        IPublicWARComp.IIm_WarmatinElement trgElement =
                             wdContext.createIm_WarmatinElement(
                                  new com.kaisa.mwci.models.updatezpsmur.Zps_War());
                        WDCopyService.copyCorresponding(srcElement, trgElement);
                        wdContext
                             .nodeZps_Fm_War_Mat_Update_Input()
                             .nodeIm_Warmatin()
                             .addElement(
                             trgElement);
                   wdContext
                        .currentZps_Fm_War_Mat_Update_InputElement()
                        .modelObject()
                        .execute();
                   wdContext.nodeOutWarMatIn().invalidate();
              } catch (WDDynamicRFCExecuteException e) {
                   manager.reportException(e.getMessage(), false);
              //$$end
        //@@end
    I can call the RFC, it actually returns a value, but not one that I expect. I think the table data is not being passed at all?
    Ideas will be greatly appreciated. Thanks!
    Cheers,
    Alfonso

    HI
          try for external debugging of you RFC , and whether you are able to pass you data to the RFC ,
           public void executeZps_Fm_War_Mat_Update_Input( )
        //@@begin executeZps_Fm_War_Mat_Update_Input()
              //$$begin Service Controller(344531631)
              IWDMessageManager manager = wdComponentAPI.getMessageManager();
              try {
                   int size =
                        wdContext
                             .nodeZps_Fm_War_Mat_Prefill_Input()
                             .nodeWarOut()
                             .nodeEx_Warout()
                             .size();
                   for (int i = 0; i < size; i++) {
                        IPublicWARComp.IEx_WaroutElement srcElement =
                             wdContext
                                  .nodeZps_Fm_War_Mat_Prefill_Input()
                                  .nodeWarOut()
                                  .nodeEx_Warout()
                                  .getEx_WaroutElementAt(i);
                        IPublicWARComp.IIm_WarmatinElement trgElement =
                             wdContext.createIm_WarmatinElement(
                                  new com.kaisa.mwci.models.updatezpsmur.Zps_War());
                                              // here instead of creating a element ,  there would be some Class
    created for IIm_Warmatin  , so you can create a instance for this class and set the 
    source data element to the target .
                   ZIIm_Warmatin   target = new IIm_WarmatinElement();
                      target.set(...);
                     wdcontext.nodeIIm_Warmatin.bind(target);
       try this .          or  you can set the source data to the element created for the target .
           hopefully should work
                   wdContext
                        .currentZps_Fm_War_Mat_Update_InputElement()
                        .modelObject()
                        .execute();
                   wdContext.nodeOutWarMatIn().invalidate();
              } catch (WDDynamicRFCExecuteException e) {
                   manager.reportException(e.getMessage(), false);
              //$$end
        //@@end

  • I've got the labview vi written to read my IMU data from a serial port in COM1 and it displays onto the table on the front panel. I'm having trouble getting this data onto an excel spreadshee​t. Any ideas?

    I've got the labview vi written to read my IMU data from a serial port in COM1 and it displays onto the table on the front panel. I'm having trouble getting this data onto an excel spreadsheet. Any ideas? Right now my data will collect one reading instead of continuously reading my IMU which displays data in a continuous stream.
    Thanks
    Attachments:
    Read_IMU_Drew.vi ‏21 KB

    Hi
    Your vi is in 2009 version, which i am unable to open in 8.6
    However, if you want your data to be saved in excel sheet, here is the VI
    Somil Gautam
    Think Weird
    Attachments:
    save to excel.vi ‏12 KB

  • [Trouble] The Report has no tables

    Hi there,
    i have trouble in using Crystal Reports for .NET 2.0.
    I load a CSV file via JetDB Provider as Text database and try to use it as DataSource for my report.
    But it crashes all time, with a error like this "report has no tables".
    Actually i dont really know Crystal Reports well, i got the project from an ex-employment from our Company.
    Of course i readed the PDF documentations "Reporting Off ADO.NET Datasets", "Crystal Reports Guide To ADO.NET", "Connecting the Report Designer Component to a Data Source" but that didnt help me at all.
    So i hope you guys can help me,
    here are the code: http://rafb.net/p/hMon9Z65.html
    with best regards,
    Torsten Sailer

    So if I understand correctly, you are loading data from a CSV file into a DataSet object and passing the DataSet to a report that you have loaded using the ReportDocument object?  Are you using the SetDataSource() method to pass the DataSet to the report?  
    Make sure that the schema of the DataSet isn't changing from when you designed the report.  The report's schema must match the DataSet schema when passing the DataSet to the report. 
    The best way to troubleshoot the issue is when the error occurs, write out the DataSet to an .xml file (with the schema) and then in a simple Windows app, load the same report, and the xml schema/data into a DataSet object (rather than the CSV) and see if the same error occurs.  If it does, open the report in design and do a "Set Database Location" to your xml file and see if it picks up any changes.  If it does, then that might be the reason why it errors....the schemas are not matching and you need you find out why.
    <p>-MJ</p>

  • Having trouble adding information to a join table

    I am building a Proof-of-concept HR application in Apex using the hosted site and having trouble entering information into a join table. There are three tables in my schema: Applicants, Postings, and ApplPostings
    "Applicants" fields: Applicant_ID (PK), Name, Address, City, State, Zip, Phone, Email
    "Postings" fields: Posting_ID(PK), Posting_Number, Item_Number, Posting_Date, Title, Description
    "ApplPostings" fields: Appp_ID (PK), Apply_Date, appl_appl_id (FK), post_post_id (FK)
    I have 5 pages in my application
    1. A Report that shows all Applicants
    2. A Form that shows Applicant details and allows editing
    Contains 3 regions: Applicant Detail, Associated Postings, Available Postings
    3. A Report that shows all Postings
    4. A Form that shows Posting details and allows editing
    5. A Form that allows creating an entry in ApplPostings
    On page #2 (from the list above, it's p3 in my app), the "Associated Postings" region shows data from the Postings table for selected applicant per the ApplPostings table. This is the SQL:
    select jp.posting_number,
    jp.posting_date, jp.title
    from applicants ja,
    applpostings jap,
    postings jp
    where ja.applicant_id = jap.appl_appl_id
    and jp.posting_id = jap.post_post_id
    and ja.applicant_id = (:p3_applicant_ID)
    The "Available Postings" region uses this SQL to show information on the remaining postings:
    select jp2.posting_id, jp2.posting_number, jp2.posting_date, jp2.title
    from postings jp2 where JP2.POSTING_ID
    not in
    (select jp.posting_id
    from applicants ja,
    applpostings jap,
    postings jp
    where ja.applicant_id = jap.appl_appl_id
    and jp.posting_id = jap.post_post_id
    and ja.applicant_id = :p3_applicant_id )
    The Posting ID column in "Available Postings" is set up as link to page #5 (from list above, p7 in my app)
    This page shows three fields: Apply_Date, appl_appl_id, post_post_id
    Source information for appl_appl_id:
    Source used: Always
    Source type: Item
    Source value or expression: p3_applicant_id
    Source information for post_post_id:
    Source used: Always
    Source type: Item
    Source value or expression: p3_posting_id
    Both ID fields populate with inherited values correctly.
    The problem is when I try to use the Apex generated "Apply Changes" button
    Nothing happens, there is not data added to that table.
    I get the "Action Processed" message, but the row is not created in the ApplPostings table.
    Any suggestions on what to do next will be helpful.
    Thanks,
    Jody
    Edited by: user10651585 on Dec 31, 2008 9:41 AM

    Hi,
    On the form, any items that represent database columns must use "Database Column" as the Source Type and the column names as the Source Value or Expression. The "Fetch Row..." and "Process Row..." processes refer to these to determine where to write the data. So your first step is to change the two page items to use these settings. Without these settings, there is nothing to write into the table - the "Action performed" message will be displayed because there is no SQL error.
    Now, on your report, your link should pass in the two values needed. In the Column Link settings for the column you are linking on, you have three pairs of fields headed Item 1, Item 2 and Item 3. Each item has a Name and Value setting. Into the Name setting enter in the page 7 item names. Into the corresponding Value setting enter in the column names that contain the values these items need to receive, surrounded by # symbols (for example, #POSTING_ID#).
    Then, when you click on the item in the report, you are passed to page 7 and the fields are correctly populated. As the form correctly identifies these fields as database columns, when you click Apply Changes, the insert can take place.
    Andy

  • Vlookup-trouble with tables from different sheet?

    I have trouble getting vlookup to work properly, especially when I try to name a table from a different sheet. Being a long time excel user I am used to only click on the top left cell in the lookup table and Excel assumes that the entire table is the area you want to look up. How is this supposed to work in Numbers? There is some irony here:
    I get a #ref error in Numbers when it looks like everything is OK and I try to copy my formula. It looks like this in the first row: =vlookup(B3;[table name]::$A$!:E506;3;0) but when I drag that downwards I get #ref for the lookup table - unable to see what the trouble might be. So I export the file to Excel, and then open the exported Excel-file with Numbers, and it works... Any suggestions?

    Hi aarild,
    Here's a picture that may help:
    Instead of clicking the top left cell of a table as in Excel it works better in Numbers 3.0 to select the entire columns as the range, in my example $Name:$Amount.
    Unlike in Excel, generally you're better off structuring your data in tables with a Header Row (and perhaps Header Column) and then body rows with no blank rows beneath them, and perhaps a Footer Row.
    That way you can refer to the ranges in your formulas similar to the way you would use named ranges in Excel.
    SG

  • Help please.  Trouble with a table

    Hi All.  Hope you can help.  Looked through the Q & A but it's all about CS4 so no good to me as I have CS3.  I am new to DW and trying to start my site.  I inserted a table with 1 x row and 2 x columns.  I first made the left column 160 px wide, and the rest for the main body.  Inserted a graphic at the top of the left column to head the menu.  Then I tried to insert another graphic into the body (right column)  I could not place this graphic at the top because the cursor would only go half way down the image on the left.  I tried doing various things and one image would go up and the other down or vice versa.  It's driving me nuts :-))  Does anyone have any idea what I am doing wrong please?
    Also, does anyone know of a site where I can get good tutorials in CS3 please/, without it costing me a small fortune.  TIA
    Regards
    Jon

    With your cursor in the table cell, set the verical alignment to Top in the properties panel.  That will ensure that any images or text you place within that cell stays at the top no matter how the cell or table expands.
    And not to be disrespectul in any way, this is a pretty basic function of table layouts.  You are sure to run into many more troubles along the way unless you study up on tables and how they work in DW.  So instead, I agree with the above response - you're going into a learning curve anyway, so you may as well apply it to CSS - I think things will even go quicker for you that way and you'll be building sites using the current and better technology.

  • Troubles when trying to transfer a table with hierarchical column to a tree

    In WD for ABAP, I encounter many troubles when trying to transfer a table with hierarchical column to an actual tree. In my UI, the tree is in the left pane and the detail for a node is in the right.
    1. With hierarchical table, I can bind the dataSource of the table directly to the context node in View which is mapped to a context node in component controller which is a DDIC structure. But with a tree, is it possible to map the dataSource of the tree or node in tree to context node in component controller?
    2. With hierarchical table, when lead selection changed, the detail info in the right pane will change automatically. But with a tree, it seems to have to be implemented via action by myself.
    Can anyone give some suggestions to overcome these troubles?

    Wei,
    <i>With tree table, the dataSource of the table is just bound to the context node ORG_UNIT</i>
    Hmmm... You said, that this node resides in component controller, not in view controller. Or does it?
    Any recursive node that can be displayed with tree table can be displayed with tree as well. Period.
    1. Create tree and bind data source to the same node as table data source.
    2. Create tree node type and bind it to the same node again.
    3. Create one additional calculated attribute in forementioned node (type boolean) that inverts/negates attribute for table column "hasChildren" to tree node "isLeaf".
    4. That's all.
    VS

  • Trouble updating multiple rows in table using subquery

    Hi everyone, I'm having trouble updating multiple rows with a subquery. Here's the setup:
    create table mytable (
    col_a number primary key,
    col_b number,
    col_c number,
    col_d number);
    insert into mytable values (1 ,1,1,15);
    insert into mytable values (2 ,1,2,7 );
    insert into mytable values (3 ,1,3,11);
    insert into mytable values (4 ,1,4,23);
    insert into mytable values (5 ,1,5,14);
    insert into mytable values (6 ,2,1,50);
    insert into mytable values (7 ,2,2,41);
    insert into mytable values (8 ,2,3,13);
    insert into mytable values (9 ,2,4,12);
    insert into mytable values (10,2,5,19);
    insert into mytable values (11,3,1,10);
    insert into mytable values (12,3,2,92);
    insert into mytable values (13,3,3,81);
    insert into mytable values (14,3,4,17);
    insert into mytable values (15,3,5,66);
    insert into mytable values (16,4,1,54);
    insert into mytable values (17,4,2,41);
    insert into mytable values (18,4,3,22);
    insert into mytable values (19,4,4,24);
    insert into mytable values (20,4,5,17);For this example, using an update statement (or merge if that's better), say I want to set the values for col_d where col_b = 3 equal to the values for col_d where col_b = 1 and col_c equal each other. Results should look like the following after the update:
    col_a col_b col_c col_d
    1     1     1     15
    2     1     2     7
    3     1     3     11
    4     1     4     23
    5     1     5     14
    6     2     1     50
    7     2     2     41
    8     2     3     13
    9     2     4     12
    10    2     5     19
    11    3     1     15
    12    3     2     7
    13    3     3     11
    14    3     4     23
    15    3     5     14
    16    4     1     54
    17    4     2     41
    18    4     3     22
    19    4     4     24
    20    4     5     17I can see it right there at my fingertips using this query, where I want to set b_col_d = a_col_d, but I'm missing something, as this query returns too many rows when used in the update statement.
    select * from (
      select col_a as a_col_a, col_b as a_col_b, col_c as a_col_c, col_d as a_col_d
      from mytable
      where col_b = 1
      ) a, (
      select col_a as b_col_a, col_b as b_col_b, col_c as b_col_c, col_d as b_col_d
      from mytable
      where col_b = 3
      ) b
    where a.a_col_c = b.b_col_cupdate mytable set column_d = (select ??? where exists ???)
    Can someone help me get there? I'm using 10GR2.
    Thanks!
    Mark

    Hopefully this is what you are looking for:
    SQL > UPDATE mytable myt1
      2  SET    col_d = ( SELECT myt2.col_d
      3                   FROM   mytable myt2
      4                   WHERE  myt2.col_b = 1
      5                   AND    myt1.col_c = myt2.col_c
      6                 )
      7  WHERE  col_b = 3
      8  AND    EXISTS
      9         ( SELECT NULL
    10           FROM   mytable myt2
    11           WHERE  myt2.col_c = myt1.col_c
    12         )
    13  ;
    5 rows updated.
    SQL > SELECT * FROM mytable ORDER BY col_a;
                   COL_A                COL_B                COL_C                COL_D
                       1                    1                    1                   15
                       2                    1                    2                    7
                       3                    1                    3                   11
                       4                    1                    4                   23
                       5                    1                    5                   14
                       6                    2                    1                   50
                       7                    2                    2                   41
                       8                    2                    3                   13
                       9                    2                    4                   12
                      10                    2                    5                   19
                      11                    3                    1                   15
                      12                    3                    2                    7
                      13                    3                    3                   11
                      14                    3                    4                   23
                      15                    3                    5                   14
                      16                    4                    1                   54
                      17                    4                    2                   41
                      18                    4                    3                   22
                      19                    4                    4                   24
                      20                    4                    5                   17
    20 rows selected.Thank you so much for providing the sample data in an easy to consume form, as well as the expected output.

Maybe you are looking for

  • How do i stop it automatically switching to new tab, the setting is not ticked in options. This is annoying when opening several tabs.

    Although I do not have 'switch to new tab immmediately' ticked, when I ask to open in new tab it switches immediately. This is a problem as I open several tabs from my main page and don't want to go to them at once, I'll look at them in order as I ne

  • ContentPane wont be size i want it to be?

    Hi i am having trouble with this program i need to make for an exercise, i just need to create the shape of a calender using GridBagLayout. I know that the code i have works because i had it just in a main method before, but now i am trying to make i

  • Xserve G5 Video Quirk

    Well, I finally got my Xserve G5 up and running, which was an Ebay "spares or repair" job which I resurrected. It has an ATI Radeon 9200, which has both a DVI and VGA output, so I hooked up my 20" Cinema Display, and going into the display settings s

  • InDesign and Scrolling

    Hi, I'm a graphic designer that has to use InDesign and the CS3 suite of programs quite a bit. I added 11 GB of ram to my mac pro and I thought that would really speed up InDesign's scrolling. However, the scrolling through pages in my documents is s

  • Problem Mapping Deep Structure to Flat Structure

    Hello, I hope someone can help me.  My scenario is idoc to file.  I am collecting many idocs with a bpm and writing them out to one file.  My bpm is working great, but my mapping program is not working properly.  My source message is a deep structure