Tag;   Could you explain how it works?

Let?s say, I have dozen of elements (floating point numbers) in a 1-D array. I am planning to do mathematical manipulation and sort it later.
However, I have to keep track of where all the elements have placed.
I wish to add tag to each element in the array such that I know where every element is after sorting. How do you assign tag and retrieve the tag?
After assigning the tag, does it still keep the same type as floating point?
Or I can patiently keep track of every element in multidimensional array, I guess?..

Yes, sir! You are absolutely right.
However, if you are familiar with Don Kanuth's shuffling algorithm which assign random number tag to the sequential deck of card and sort the random number which will shuffle the deck. I am browing the concept and try to implement such idea on my boring and lengthy computation.

Similar Messages

  • HT1284 Can I back up my Mac and my pc to the same external hard drive?  If so, could you explain how? Thanks.

    Can I back up my Mac and my pc to the same external hard drive?  If so, could you explain how? Thanks.  I am a new user with mountain lion.

    You could partition the drive into 2 partitions.  One formatted as HFS+ for Mac OS X back, and one formatted as NTFS for Windows backup.
    You would have to move the drive from system to system to do your backups.  If there are 2 systems, I would suggest just getting separate drives for each, unless they are both laptops, then you will be disconnecting the drives all the time anyway.
    Unless Windows is running in a virtual machine on your Mac.  Then a partitioned drive would be fine.

  • Could you explain how the read-write-backing-map-scheme is configured in...

    Could you explain how the read-write-backing-map-scheme is configured in the following example?
    <backing-map-scheme>
        <read-write-backing-map-scheme>
         <internal-cache-scheme>
          <class-scheme>
           <class-name>com.tangosol.util.ObservableHashMap</class-name>
          </class-scheme>
         </internal-cache-scheme>
         <cachestore-scheme>
          <class-scheme>
           <class-name>coherence.DBCacheStore</class-name>
           <init-params>
            <init-param>
             <param-type>java.lang.String</param-type>
             <param-value>CATALOG</param-value>
            </init-param>
           </init-params>
          </class-scheme>
         </cachestore-scheme>
         <read-only>false</read-only>
         <write-delay-seconds>0</write-delay-seconds>
        </read-write-backing-map-scheme>
    </backing-map-scheme>
    ...Edited by: qkc on 30-Nov-2009 10:48

    Thank you very much for reply.
    In the following example, the cachestore element is not specified in the <read-write-backing-map-scheme> section. Instead, a class-name ControllerBackingMap is designated. What is the result?
    If ControllerBackingMap is a persistence entity, is the result same with that of cachestore-scheme?
    <distributed-scheme>
                <scheme-name>with-rw-bm</scheme-name>
                <service-name>unlimited-partitioned</service-name>
                <backing-map-scheme>
                    <read-write-backing-map-scheme>
                        <scheme-ref>base-rw-bm</scheme-ref>
                    </read-write-backing-map-scheme>
                </backing-map-scheme>
                <autostart>true</autostart>
            </distributed-scheme>
            <read-write-backing-map-scheme>
                <scheme-name>base-rw-bm</scheme-name>
                <class-name>ControllerBackingMap</class-name>
                <internal-cache-scheme>
                    <local-scheme/>
                </internal-cache-scheme>
            </read-write-backing-map-scheme>

  • Could you please explain how to work with Outlier Correction

    could you please explain how to work with Outlier Correction

    Hi sr,
    Actually an outlier correction is an historical value that lies the tolerance lane.
    the apo sys calculate this tolerance lane on the basis of the sigma factor.
    It then correct any historical value that lies outside the upper or lower band of this tolerance lane.
    So, that it corresponds to the calculated ex- post value for that point in time.
    this option is available in Master forecast profile /sapapo/mc96b in Univariate profile( control parameters) tab.
    If you have set the outlier correction indicator, then the sys first calculate an ex-post forecast with the selected forecasting techniques.
    In the next step, the sys calculates a tolerance threshold T.
    where T is calculated as T = sigma * MAD (Mean Absolute Deviation)
    Here the Sigma factor defines the width of the tolerance rangefor automatic outlier correction.
    it defines the permissible number of standard deviations.
    A small sigma factor means a low tolerance, and a large number of outliers that are detected and corrected.
    The default Sigma factor is 1.25.
    If you set the Sigma factor, SAP recommends that you set it betw 0.6 and 2.
    I hope this is helpful for you.
    Regards,
    Pullaiah

  • HI,  I need to jre 1.6 update 26 on my mac system to make some aaplication work. However latest available is jre 1.6 update 29. Could you suggest how I can get jre 1.6 update 26? I tried downloading older version on java. COuldn't find it on your site.

    HI,  I need to jre 1.6 update 26 on my mac system to make some aaplication work. However latest available is jre 1.6 update 29. Could you suggest how I can get jre 1.6 update 26? I tried downloading older version on java. COuldn't find it on your site.

    What are you missing?
    I inherited this app and signing the third party jars is how it was setup, I was wondering the same thing too, why was it necessary to sign the third party jars?
    The applet runs in either JRE 1.6.0_13 or JRE 1.6.0_27 depending on the other Java apps the user uses. JRE 1.6.0_13 does not have the mixed code security (so it is like is disable), but JRE 1.6.0_27 does have the mixed code security and the applet will not launch with mixed code security enable, so we have to disable it. With all the hacking going on in the last two years, is important to improve security; so this is a must.
    Yes, I always clear up the cache.
    Any idea on how to resolve this problem?

  • Hi, I have added on Musique finder my old CD and want now to add them on my iTunes, please, could you explain to me step by step how to do this? Mant tks in advances for your kind help

    Hi, I have added on Musique finder my old CD and want now to add them on my iTunes, please, could you explain to me step by step how to do this? Mant tks in advances for your kind help

    Correct, it will only be one-level, the Photos app doesn't support sub-albums - the sub-folders photos will be included in the parent's album.
    If you select My Pictures at the top of the Photos tab when syncing, then you should get an album for each folder that is directly under it - so if I understand correctly what you described then that would mean an album for 2013, one for 2012 etc. And each of those should include all the photos in the subfolders under it - so 2013 would include the photos from the events and months subfolders under it.
    You can't sync them separately, only the contents of the last sync remains on the iPad, by not including a folder in the next photo sync you are effectively telling iTunes that you no longer want that folder/album on the iPad so it will be removed and be replaced by the contents of the new sync (you can't delete synced photos directly on the iPad, instead they are deleted by not including them in the next sync).
    The app that I use, Photo Manager Pro, allows you to select and copy a folder (via FTP), but you would need to select each subfolder individually, which if you have a lot would be time-consuming (I think that if you select '2013' it would ignore the folders beneath it).

  • Could someone please explain to me how to set-up my Apple ID so that both my password AND security questions have to be answered before access is granted? Is this possible? I am not very computer smart, so could you explain step-by-step!Very Appreciated!

    Could someone please explain to me how to set-up my Apple ID so that both my password AND security questions have to be answered before access is granted? Is this possible? I am not very computer smart, so could you explain step-by-step!Very Appreciated!

    The security questions will only be asked on the first purchase on a computer or device (though people have occasionally posted that they've asked for them when it isn't the first time) - I'm not aware of any way to change that. You can force the password to be required on your iPad via Settings > General > Restrictions > Require Password set to 'Immediately' (the default is a 15 minute period during which it doesn't need re-entering)

  • Could you explain me about TEDS sensor section from NI9233?

    hi
          here is the TEDS sensor part's pic from NI 9233 getting started .Could you explain me about this part ? what does it support to do ?
    thank you
    roxy

    Hi Roxylat,
    TEDS is a compact set of data describing transducer characteristics. This link will give you more information on what a TEDS sensor is and how it works. Hope this helps.
    Ipshita C. 
    National Instruments
    Applications Engineer

  • Please can you explain how to add adobe flash player when using Mozilla ?

    I cannot view videos without them constantly stopping.
    I have been told that I need to use adobe flash player.
    When I try to load this, though, the download will not work.
    A message apprears to say I must turn Mozilla Firefox off.
    Please can you explain how I can get around this ?
    Please note, I am not very good with computers, so it would be good if you can make the instructions as basic as possible.
    Many thanks !
    Trev Stafford
    <sub>edit: removed your mail address from public display, since the only thing it will attract are spam bots. you will be notified per mail once somebody replies to the thread. (philipp)</sub>

    Download the non-IE version of Adobe Flash for your system here:
    https://support.mozilla.org/en-US/kb/keep-flash-up-to-date-and-troubleshoot-problems
    Close the browser, and temporarily disable your anti-virus
    Install the non-IE version of Adobe Flash
    Re-enable anti-virus
    See that you have the current version here
    http://www.adobe.com/software/flash/about/
    replaced unofficial third-party download site link.

  • TS1811 Hi!! I am a user of i Pod 5g 32GB....I got the same problem for which the solution is given above....but the thing is that.......in my laptop I have a windows operating system....that is windows 7....so can you explain how to do settings in Windows

    Hi!! I am a user of i Pod 5g 32GB....I got the same problem for which the solution is given above  "
    iTunes for Mac reports error -50 when trying to authorize iTunes Store purchases
    "....but the thing is that.......in my laptop I have a windows operating system....that is windows 7....so can you explain how to do settings in Windows 4 same

    Archived - iTunes for Mac reports error -50 when trying to authorize iTunes Store purchases
    Products Affected
    iTunes 7 for Mac, iTunes 8 for Mac, iTunes 9 for Mac
    This article has been archived and is no longer updated by Apple. 
    Symptoms
    After installing the Mac OS X 10.4.9 Update, iTunes may be unable to properly authorize your computer to play your iTunes Store purchases.
    Resolution
    The following steps will delete your network preferences. Most broadband connections do not require any special settings to connect, but if your connection does or if you are not sure, please contact your ISP or network administrator for further assistance.
    Important: You must be logged in as an Administrator.
    Click the Finder icon in the Dock.
    Choose Go to Folder from the Go menu.
    Type /Library/Preferences/SystemConfiguration
    Click Go.
    In the Finder window, locate the file named NetworkInterfaces.plist.
    Drag this file to the Trash.
    Restart the computer.
    Once your computer has restarted. You will not be able to connect to the Internet. Now you will need to refresh your network settings to be able to connect again.
    Choose System Preferences from the Apple menu.
    Choose Network from the View menu.
    To refresh your network settings, from the Location pop-up menu, choose New Location.
    Type a name for your location and click OK.
    Click the Apply Now at the bottom right to accept the changes.
    If your network connection requires any special settings, you will need to put them back in at this point. Once you have made these changes you should be able to connect to the Internet again and authorize your computer to play your iTunes Store purchases.

  • Hi, have .pst files on and external hard drive want to import to MBP mail could you advise how?

    Hi, have .pst files on and external hard drive want to import to MBP mail could you advise how?

    http://lmgtfy.com/?q=import+pst+file+to+mac

  • Can anyone explain how this works (vlans and bridge groups)

    Can someone please explain how this works...I have started to have problems but nothing changed. My problems are vlan1 and 1000 getting blocked on the switchport where the root bridge is attached.
    ROOT BRIDGE:
    ssid state
    station-role root bridge
    rts threshold 4000
    concatenation
    interface Dot11Radio0.1
    encapsulation dot1Q 1 native
    no ip route-cache
    no snmp trap link-status
    bridge-group 1
    bridge-group 1 spanning-disabled
    interface Dot11Radio0.911
    encapsulation dot1Q 911
    no ip route-cache
    no snmp trap link-status
    bridge-group 5
    interface Dot11Radio0.1000
    encapsulation dot1Q 1000
    no ip route-cache
    no snmp trap link-status
    bridge-group 2
    bridge-group 2 spanning-disabled
    interface Dot11Radio0.2001
    encapsulation dot1Q 2001
    no ip route-cache
    no snmp trap link-status
    bridge-group 253
    bridge-group 253 spanning-disabled
    interface Dot11Radio0.2120
    encapsulation dot1Q 2120
    no ip route-cache
    no snmp trap link-status
    bridge-group 7
    interface Dot11Radio0.2330
    encapsulation dot1Q 2330
    no ip route-cache
    no snmp trap link-status
    bridge-group 3
    bridge-group 3 spanning-disabled
    interface Dot11Radio0.2336
    encapsulation dot1Q 2336
    no ip route-cache
    no snmp trap link-status
    bridge-group 4
    interface Dot11Radio0.2350
    encapsulation dot1Q 2350
    no ip route-cache
    no snmp trap link-status
    bridge-group 6
    interface Dot11Radio0.2901
    encapsulation dot1Q 2901
    no ip route-cache
    no snmp trap link-status
    bridge-group 255
    bridge-group 255 spanning-disabled
    interface Dot11Radio0.2902
    encapsulation dot1Q 2902
    no ip route-cache
    no snmp trap link-status
    bridge-group 254
    bridge-group 254 spanning-disabled
    interface FastEthernet0
    no ip address
    no ip route-cache
    interface FastEthernet0.1
    encapsulation dot1Q 1
    no ip route-cache
    no snmp trap link-status
    interface FastEthernet0.911
    encapsulation dot1Q 911
    no ip route-cache
    no snmp trap link-status
    bridge-group 5
    interface FastEthernet0.1000
    encapsulation dot1Q 1000 native
    ip address 10.0.32.10 255.255.255.0
    no ip route-cache
    no snmp trap link-status
    bridge-group 1
    interface FastEthernet0.2001
    encapsulation dot1Q 2001
    no ip route-cache
    no snmp trap link-status
    bridge-group 253
    bridge-group 253 spanning-disabled
    interface FastEthernet0.2120
    encapsulation dot1Q 2120
    no ip route-cache
    no snmp trap link-status
    bridge-group 7
    interface FastEthernet0.2330
    encapsulation dot1Q 2330
    no ip route-cache
    no snmp trap link-status
    bridge-group 3
    interface FastEthernet0.2336
    encapsulation dot1Q 2336
    no ip route-cache
    no snmp trap link-status
    bridge-group 4
    interface FastEthernet0.2350
    description 81 River Rd - Labor
    encapsulation dot1Q 2350
    no ip route-cache
    no snmp trap link-status
    bridge-group 6
    interface FastEthernet0.2901
    encapsulation dot1Q 2901
    no ip route-cache
    no snmp trap link-status
    bridge-group 255
    bridge-group 255 spanning-disabled
    interface FastEthernet0.2902
    encapsulation dot1Q 2902
    no ip route-cache
    no snmp trap link-status
    bridge-group 254
    bridge-group 254 spanning-disabled
    interface BVI1
    ip address 10.0.32.10 255.255.255.0
    no ip route-cache
    ip default-gateway 10.0.32.1

    NON-ROOT BRIDGE#2:
    ssid state
    station-role non-root bridge
    rts threshold 4000
    concatenation
    infrastructure-client
    interface Dot11Radio0.1
    encapsulation dot1Q 1 native
    no ip route-cache
    bridge-group 1
    bridge-group 1 spanning-disabled
    interface Dot11Radio0.1000
    encapsulation dot1Q 1000
    no ip route-cache
    bridge-group 254
    bridge-group 254 spanning-disabled
    interface Dot11Radio0.2001
    encapsulation dot1Q 2001
    no ip route-cache
    bridge-group 252
    bridge-group 252 spanning-disabled
    interface Dot11Radio0.2336
    encapsulation dot1Q 2336
    no ip route-cache
    bridge-group 251
    bridge-group 251 spanning-disabled
    interface Dot11Radio0.2901
    encapsulation dot1Q 2901
    no ip route-cache
    bridge-group 253
    bridge-group 253 spanning-disabled
    interface Dot11Radio0.2902
    encapsulation dot1Q 2902
    no ip route-cache
    bridge-group 255
    bridge-group 255 spanning-disabled
    interface FastEthernet0
    no ip address
    no ip route-cache
    hold-queue 80 in
    interface FastEthernet0.1000
    encapsulation dot1Q 1000 native
    no ip route-cache
    bridge-group 1
    interface FastEthernet0.2001
    encapsulation dot1Q 2001
    no ip route-cache
    bridge-group 252
    bridge-group 252 spanning-disabled
    interface FastEthernet0.2336
    encapsulation dot1Q 2336
    no ip route-cache
    bridge-group 251
    bridge-group 251 spanning-disabled
    interface FastEthernet0.2901
    encapsulation dot1Q 2901
    no ip route-cache
    bridge-group 253
    bridge-group 253 spanning-disabled
    interface FastEthernet0.2902
    encapsulation dot1Q 2902
    no ip route-cache
    bridge-group 255
    bridge-group 255 spanning-disabled
    interface BVI1
    ip address 10.0.32.11 255.255.255.0
    no ip route-cache
    ip default-gateway 10.0.32.1

  • Could you explaine me what is the diffternce between APO VMI  Vs  R/3 VMI ?

    Hi Experts,
    could you explaine me what is the diffternce between APO VMI  Vs  R/3 VMI ?
    Thanks
    babu

    Hi,
    VMI is Vendor managed Inventory. APO can plan for VMI scenario. In a situation, when the stock level at the end customer is known to APO , then APO can plan the requirements at the customer level.
    The aim of vendor-managed inventory (VMI) is to integrate key customers in supply chain planning. The customer regularly sends stock and sales data to the vendor, and based on that information, the vendor determines replenishment requirements for the customer
    VMI as a concept must be same in APO and R/3. But, such planning is possible in APO. I am not sure whether it can be done in R/3 system.
    Regards,
    Samir Baruah

  • HT201270 Hi I am using latest version of iPad. Could you advice how the personal hot spot. This iPad I have bought from Singtel singapore

    using latest version of iPad. Could you advice how the personal hot spot. This iPad I have bought from Singtel singapore

    Does Singtel singapore offer this service?
    iOS: Understanding Personal Hotspot
    iOS: System requirements for Personal Hotspot
    Not sure how this is an iphone question

  • Could you explain these terms more?

    Could you explain these terms more?
    PINs
    RELOADs
    INVALIDATIONs
    SQL> desc v$librarycache
    Name                                                                  Null?    Type
    NAMESPACE                                                           VARCHAR2(15)
    GETS                                                                  NUMBER
    GETHITS                                                               NUMBER
    GETHITRATIO                                                                NUMBER
    PINS                                                                       NUMBER
    PINHITS                                                                    NUMBER
    PINHITRATIO                                                                 NUMBER
    RELOADS                                                                    NUMBER
    INVALIDATIONS                                                               NUMBER
    DLM_LOCK_REQUESTS                                                          NUMBER
    DLM_PIN_REQUESTS                                                            NUMBER
    DLM_PIN_RELEASES                                                          NUMBER
    DLM_INVALIDATION_REQUESTS                                                NUMBER
    DLM_INVALIDATIONS                                                          NUMBERFrom the Oracle® Database Reference, I get the following interpretation:
    PINS :      Number of times a PIN was requested for objects of this namespace
    PINHITS:      Number of times all of the metadata pieces of the library object were found in memory
    RELOADS:      Any PIN of an object that is not the first PIN performed since the object handle was created, and which requires loading the object
    from disk
    INVALIDATIONS: The total number of times objects in this namespace were marked invalid because a dependent object was modified
    But I still cannot understand the following these terms clearly. Could you explain them more?
    PINs
    RELOADs
    INVALIDATIONs
    More over, I don't think the previous interpretation of INVALIDATIONs is precise. In my view,the interpretation should be: the times of Library cache misses happened because invalidations occurred due to DDL on the dependant objects.
    What is your opinions?
    Thanks

    Loads - Number of times the object has been loaded. This count also increases when an object has been invalidated.
    # Gets - Number of times the system requests handles to library objects belonging to this namespace
    # Pins - Number of times the system issues pin requests for objects in the cache in order to access them.
    # Reloads - Number of times that library objects have to be reinitialized and reloaded with data because they have been aged out or invalidated.
    Invalidations - Number of times that non-persistent library objects (like shared SQL areas) have been invalidated.
    more information
    http://vsbabu.org/oracle/sect13.html
    OCP Oracle 9i Performance tuning Study guide BPB publications.

Maybe you are looking for