Timeouts on non load balanced traffic thru ACE

I have a backend server creating a connection to a db server outside the ACE environment. This traffic is using the L3 function of the ACE and is not being load balanced. The connection is timing out after 1 hour. I have normalization disabled on the backend server VLAN but not on the front side VLAN of the ACE.
2 Questions:
- With normalization disabled do I still need to change the tcp inactivity timeout for this traffic? Or with normalization disabled shouldn't the non load balanced traffic be L3 routed and not effected by the tcp timeout value?
- Also do I need to disable normalization on the front side VLAN of the ACE?
thanks,
kurt

As per
http://www.cisco.com/en/US/docs/interfaces_modules/services_modules/ace/v3.00_A1/configuration/security/guide/tcpipnrm.html#wp1075741
"Disabling TCP normalization affects only Layer 4 traffic. TCP normalization is always enabled for Layer 7 traffic."
By disabling TCP normalization the following Layer 4 connection parameters are ignored.
exceed-mss-----Configure behavior if a packet exceeds MSS
random-seq-num-disable----Disable TCP sequence number randomization
reserved-bits-----Configure Reserved bits in TCP header
syn-data-----Configure behavior for a SYN packet containing data
tcp-options-----Configure TCP header options
urgent-flag-----Allow/Clear Urgent flag
I think you will need "Set timeout inactivity xxxx" command even if "no normalization" command is defined.
Syed Iftekhar Ahmed

Similar Messages

  • How can ftp service on non-standard port be load balanced using Cisco ACE.

    How can ftp service on non-standard port be load balanced using Cisco ACE.For example ftp service required on tcp 2000 port

    Hi Samarjit,
    you can do this by specifying the port number in the class map that you create . Please find the below mentioend config guide where you can specify the tcp/udp port , range or ports or even the wild card to match the port.
    http://www.cisco.com/en/US/docs/interfaces_modules/services_modules/ace/v3.00_A1/configuration/administration/guide/mapolcy.html#wp1318826
    Regards
    Abijith

  • SIP load balancing issue with ACE 4710

    SIP Load balancing Issue with ACE 4710
    I have a Cisco ace 4710 with vesion Version A4(2.2). i configued simple SIP load balancing first without stickiness. without stikeiness we are having a problem because bye packet at the was not going to the same server all the time that left our port in used even though user hang up the phone. its happen randmly. i have a total 20 licenced ports and its fill out very quickly. so i dicided to use the stickiness with call-ID but still same issue. below is the config
    rserver host CIN-VOX-31
      ip address 172.20.130.31
      inservice
    rserver host CIN-VOX-32
      ip address 172.20.130.32
      inservice
    serverfarm host CIN-VOX
      probe SIP-5060
      rserver CIN-VOX-31
        inservice
      rserver CIN-VOX-32
        inservice
    sticky sip-header Call-ID VOX_SIP_GROUP
      timeout 1
      timeout activeconns
      replicate sticky
      serverfarm CIN-VOX
    class-map match-all CIN_VOX_L4_CLASS
      2 match virtual-address 172.22.12.30 any
    class-map match-all CIN_VOX_SIP_L4_CLASS
      2 match virtual-address 172.22.12.30 udp eq sip
    policy-map type loadbalance sip first-match CIN_VOX_LB_SIP_POLICY
      class class-default
        sticky-serverfarm VOX_SIP_GROUP
    policy-map multi-match GLOBAL_DMZ_POLICY
       class CIN_VOX_SIP_L4_CLASS
        loadbalance vip inservice
        loadbalance policy CIN_VOX_LB_SIP_POLICY
        loadbalance vip icmp-reply
      class CIN_VOX_L4_CLASS
        loadbalance vip inservice
        loadbalance policy CIN_VOX_LB_SIP_POLICY
        loadbalance vip icmp-reply
    interface vlan 20
      description VIP_DMZ_VLAN
      ip address 172.22.12.4 255.255.255.192
      alias 172.22.12.3 255.255.255.192
      peer ip address 172.22.12.5 255.255.255.192
      access-group input PERMIT-ANY-LB
      service-policy input GLOBAL_DMZ_POLICY
    could you please help me on this...
    thanks
    Rakesh Patel

    I mean there should be one more statement-
    class-map type sip loadbalance match-any CIN_VOX_LB_SIP_POLICY 
    match sip header Call_ID header-value sip:
    and that will be called under-
    policy-map multi-match GLOBAL_DMZ_POLICY
       class CIN_VOX_SIP_L4_CLASS
        loadbalance vip inservice
        loadbalance policy CIN_VOX_LB_SIP_POLICY
        loadbalance vip icmp-reply
    is that missing in your config ?

  • GSS act as an authoritative DNS for non-load balanced sites?

    I have a client asking if a GSS can be the authoritative DNS server for their entire domain.  This would include sites that are not load balanced.
    TIA,
    Dan

    Hi Dan,
    Yes, you would just have to create a new domain under the Domain Lists, create an Answer Group associated to that domain and then you can start adding DNS answers. For non-load balanced sites you would just have one answer in your answer group.
    Sincerely,
    Kyle

  • Load balancing imbalance in ACE

    We are facing slowness an http application which is due to connection imbalance. This setup has one set of Load balancer and a proxy in DMZ where the connections gets terminated from the users and a load balancer inside LAN which load balances between the end point servers. All user connections terminate on the DMZ load balancer / proxy and proxy connects back to the internal load balancer VIP. (By collating a number of connections to very few - default proxy behavior) . Internal load balancer VIP does load balancing based on the number of connections in a least loaded manner and this load balancer doesn’t see how many sessions are beneath each connections and it distributes each connection to server underneath. Thus if one connection has around 100 sessions, another may have only a few and each of this gets forwarded to the end server causing the imbalance.
    Is there a way that this imbalance can be tackled in this setup.
    Users --> Proxy ---> Load balancer (Cisco ACE) --> Server 1
                                                                                                    Server 2
                                                                                                    Server 3
    Least Connections predictor
    HTTP Cookie insert sticky

    Hi,
    Persistance rebalance should solve the issue for you.
    The persistent-rebalance function is required if you have proxy users and the proxy shares one TCP connection between multiple users.
    With this behavior, inside a single connection you will see different cookies. Therefore, for each cookie, ACE needs to first detect the new cookie and then loadbalance to the appropriate server.
    this is from the admin Guide :
    The following example specifies the parameter-map type http command to enable HTTP persistence after it has been disabled:
    host1/Admin(config)# parameter-map type http http_parameter_map
    Host1/Admin(config-parammap-http)# persistence-rebalance
    Please refer the following link for more info :
    http://www.cisco.com/en/US/docs/interfaces_modules/services_modules/ace/vA4_2_0/configuration/slb/guide/classlb.html#wp1062907
    hope that helps,
    Ajay Kumar

  • Two isp load balancing on cisco ACE(load balancer)

    I don't know much about load balancer(ACE).
    Is this is possible to load balance two isp's on load balancer (ACE). If so, how i can do so , any configuration example, or cisco document.

    Wrong forum, post in "Datacenter". You can move your posting with the Actions panel on the right.

  • Load balance traffic to a service based on a added field in the HTTP Header

    I am trying to use HTTP Header Load balancing but the field we want to use in order to load balance is "user-defined", example HTTP_TOTO = toto1.
    Do you have any idea on how I could perform this ?
    Thanks in advance

    Load balancing using pre-defined headers is supported. Not sure if load balancing using user defined fields is possible. You could refer to the following document.
    http://www.cisco.com/univercd/cc/td/doc/product/webscale/css/css_710/bsccfggd/httphead.htm
    We would appreciate it if someone could share their experience if they know more about this.

  • Cisco ACE - Firewall load balancing

    I am using two sets of ACE load balancers for load balancing traffic across two firewalls (firewall load balancing).
    The solution works fine. I have a virtual address of 0.0.0.0 in either direction to match traffci going from the internal users to the internet and vice versa.
    The problem is that when I try to manage the load-balanced firewalls (either using SSH (or) HTTPS) from outside, then that connection also gets load balanced and when I try to connect to FW1 then sometimes this connection ends up on FW2 and vice versa and the connection gets dropped. I have a workaround in place where i am using a virtual address per firewall to connect to the real IP address of the firewall.
    Is there any other way of managing firewalls (which are defined as real-servers) in a FWLB setup.
    Attached is the configuration of the external ACE which has the two firewalls defined as the real-servers.
    access-list ALL line 8 extended permit ip any any
    probe icmp ICMP-Probe
      interval 15
      passdetect interval 60
    rserver host FW1-ASA
      ip address 10.11.71.10
      inservice
    rserver host FW2
      ip address 10.11.71.11
      inservice
    serverfarm host Firewalls
      transparent
      predictor leastconns
      rserver FW1-ASA
        inservice
      rserver FW2
        inservice
    serverfarm host Firewalls-NO-LB
      rserver FW1-ASA
        inservice
    serverfarm host Firewalls-NO-LB1
      rserver FW2
        inservice
    sticky ip-netmask 255.255.255.255 address source new-sticky
      timeout activeconns
      serverfarm Firewalls
    This is my workaround for connection to the IP address of the firewalls (for management)
    class-map match-any FW-Real
      2 match virtual-address 10.11.71.254 any
    class-map match-any FW-Real2
      2 match virtual-address 10.11.71.253 any
    class-map type management match-any Remote-Access
      201 match protocol telnet any
      202 match protocol http any
      203 match protocol https any
      204 match protocol ssh any
      205 match protocol snmp any
      206 match protocol icmp any
    class-map match-any fwlb
      2 match virtual-address 0.0.0.0 0.0.0.0 any
    policy-map type management first-match Remote-Management-Policy
      class Remote-Access
        permit
    policy-map type loadbalance first-match FWLB-No-LB
      class class-default
        serverfarm Firewalls-NO-LB
    policy-map type loadbalance first-match FWLB-No-LB1
      class class-default
        serverfarm Firewalls-NO-LB1
    policy-map type loadbalance first-match FWLB-l7slb
      class class-default
        serverfarm Firewalls
    policy-map multi-match Firewall-No-LB
      class FW-Real
        loadbalance vip inservice
        loadbalance policy FWLB-No-LB
    policy-map multi-match Firewall-No-LB1
      class FW-Real2
        loadbalance vip inservice
        loadbalance policy FWLB-No-LB1
    policy-map multi-match int70
      class fwlb
        loadbalance vip inservice
        loadbalance policy FWLB-l7slb
    interface vlan 70
      description "Client side"
      ip address 10.11.70.2 255.255.255.0
      no icmp-guard
      access-group input ALL
      access-group output ALL
      service-policy input Remote-Management-Policy
      service-policy input Firewall-No-LB --> connect to the real IP address of the firewall for management
      service-policy input Firewall-No-LB1  --> connect to the real IP address of the firewall for management
      service-policy input int70
      no shutdown
    interface vlan 71
      description "Firewall side"
      ip address 10.11.71.2 255.255.255.0
      mac-sticky enable
      no icmp-guard
      access-group input ALL
      access-group output ALL
      service-policy input Remote-Management-Policy
      no shutdown

    Hello,
    as i know, there is no others ways.
    You can only reduce your configuration by puting all your class undert the same policy-map:
    policy-map multi-match int70
      class FW-Real
        loadbalance vip inservice
        loadbalance policy FWLB-No-LB
      class FW-Real2
        loadbalance vip inservice
        loadbalance policy FWLB-No-LB1
      class fwlb
        loadbalance vip inservice
        loadbalance policy FWLB-l7slb
    interface vlan 70
      description "Client side"
      ip address 10.11.70.2 255.255.255.0
      no icmp-guard
      access-group input ALL
      access-group output ALL
      service-policy input Remote-Management-Policy
      service-policy input int70
      no shutdown

  • ACE load balancing servers on different subnets...

    Hello,
    I have the following issue.... need to load balance traffic between two servers already working in two different subnets (vlans), at this point is highly desirable to avoid changing IP addresses. Is it possible to accomplish this goal using ACE? routed or bridged mode? is it strictly necessary to have all servers belonging to a serverfarm in the same subnet?
    Thanks in advanced for your support.

    Hi,
    You can do this, but you have to use client-NAT (Source-NAT) to force the return traffic to pass back through the ACE. You also then need static routes in the ACE context to point at each server. PBR is an alternative approach but I have not implemented that in a live network. The important thing is that the ACE sees both sides of the conversation.
    The following extract from a configuration shows the basic principle:
    rserver host master
    ip address 10.199.95.2
    inservice
    rserver host slave
    ip address 10.199.38.68
    inservice
    serverfarm host FARM-web2-Master
    description Serverfarm Master
    probe PROBE-web2
    rserver master
    inservice
    serverfarm host FARM-web2-Slave
    description Serverfarm Slave
    probe PROBE-web2
    rserver slave
    inservice
    class-map match-any L4VIPCLASS
    2 match virtual-address 10.199.80.12 tcp eq www
    3 match virtual-address 10.199.80.12 tcp eq https
    policy-map type management first-match REMOTE-MGMT-ALLOW-POLICY
    class REMOTE-ACCESS
    permit
    policy-map type loadbalance first-match LB-POLICY
    class class-default
    serverfarm FARM-web2-Master backup FARM-web2-Slave
    policy-map multi-match L4POLICY
    class L4VIPCLASS
    loadbalance vip inservice
    loadbalance policy LB-POLICY
    loadbalance vip icmp-reply active
    loadbalance vip advertise
    nat dynamic 1 vlan 384
    service-policy input L4POLICY
    interface vlan 383
    description ACE-web2-Clientside
    ip address 10.199.80.13 255.255.255.248
    alias 10.199.80.12 255.255.255.248
    peer ip address 10.199.80.14 255.255.255.248
    access-group input ACL-IN
    access-group output PERMIT-ALL
    no shutdown
    interface vlan 384
    description ACE-web2-Serverside
    ip address 10.199.80.18 255.255.255.240
    alias 10.199.80.17 255.255.255.240
    peer ip address 10.199.80.19 255.255.255.240
    access-group input PERMIT-ALL
    access-group output PERMIT-ALL
    nat-pool 1 10.199.80.20 10.199.80.20 netmask 255.255.255.240 pat
    no shutdown
    ip route 0.0.0.0 0.0.0.0 10.199.80.9
    ip route 10.199.95.2 255.255.255.255 10.199.80.21
    ip route 10.199.38.68 255.255.255.255 10.199.80.21
    HTH
    Cathy

  • Lync 2010 and ACE load balancing

    Hi there,
    Has anyone deployed [or will be deploying] Lync 2010 utilising the ACE as a hardware load balancer. The ACE is not {yet] on the Microsoft list of supported devices for this product, but I am told this because of lack of documentation from Cisco.
    The consensus from a few colleagues is that it should work as it did for OCS, which we have already deployed, so assuming that the set up and operation is similar, there shouldn't be much difference in the configurations.
    regards,
    Glenne.

    Hey Glenne,
    It seems you got that working already but I wanted to share this simple sample:
    parameter-map type http PARAMETER
      set header-maxparse-length 65535
      set content-maxparse-length 65535
    ============================================
    interface vlan 112
      ip address 10.198.16.71 255.255.255.192
      alias 10.198.16.124 255.255.255.192
      peer ip address 10.198.16.72 255.255.255.192
      mac-sticky enable
      access-group input anyone
      nat-pool 25 10.198.16.125 10.198.16.125 netmask 255.255.255.0 pat
      service-policy input ANS-MGT
      service-policy input VIPS
      no shutdown
    ============================================
    policy-map multi-match VIPS
      class LYNC_VIP
        loadbalance policy  LYNC_POLICY
        ssl-proxy server SSL_LYNC_TERMINATION
        loadbalance vip icmp-reply active
        nat dynamic 25 vlan 112
        appl-parameter http advanced-options  PARAMETER
    ============================================
    class-map match-all LYNC_VIP
      2 match virtual-address 10.198.16.125 tcp eq https
    ============================================
    ssl-proxy service SSL_LYNC_TERMINATION
      key tac-key
      cert tac-cert
      chaingroup tac-chaingroup
    ============================================
    policy-map type loadbalance first-match LYNC_POLICY
      class class-default
        sticky-serverfarm LYNC_COOKIE
    ============================================
    sticky http-cookie ACE_COOKIE LYNC_COOKIE
      timeout 30
      replicate sticky
      serverfarm LYNC_FARM
    ============================================
    serverfarm host LYNC_FARM
      rserver LYNC_SERVER1 80
        inservice
      rserver LYNC_SERVER2 80
        inservice
    ============================================
    rserver host LYNC_SERVER1
    ip address 10.198.16.93
    inservice
    rserver host LYNC_SERVER2
    ip address 10.198.16.113
    inservice
    ===========================================
    Jorge

  • ACE Routing Load-Balance problem

    I'm trying to configure a routing load-balance with Cisco ACE Module based on the following scenario:
    local users has a router (R1) as it default gateway, this router (R1) has a default route to the VIP that represent the serverfarm with two linux servers that should be used for Data Shaping over the WAN. I need to balance the traffic over the two linux servers and not necessary over the WAN.
    The problem is that when I set up the local network router default route to VIP the routing process simply stop work ! If I change the route to the real server ip address everything start working again without any problem.
    Follow the configs:
    Local network Router - Static route
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ip route 0.0.0.0 255.255.255.0 10.0.0.1 (VIP address)
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    Follow the ACE configs:
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    access-list 100 line 8 extended permit ip any any
    rserver host rout001
    ip address 10.0.0.32
    inservice
    rserver host rout002
    ip address 10.0.0.31
    inservice
    serverfarm host BLC_ROUTING
    predictor leastconns
    rserver rout001
    inservice
    rserver rout002
    inservice
    class-map match-any VIP
    2 match virtual-address 10.0.0.1 any
    class-map type management match-any mgmt
    2 match protocol icmp any
    3 match protocol telnet any
    4 match protocol ssh any
    policy-map type management first-match access
    class mgmt
    permit
    policy-map type loadbalance first-match INT_router
    class class-default
    serverfarm BLC_ROUTING
    policy-map multi-match VIP
    class VIP
    loadbalance vip inservice
    loadbalance policy INT_router
    loadbalance vip icmp-reply
    interface vlan 6
    bridge-group 10
    access-group input 100
    service-policy input access
    service-policy input VIP
    no shutdown
    interface vlan 8
    bridge-group 10
    access-group input 100
    service-policy input access
    service-policy input VIP
    no shutdown
    interface bvi 10
    ip address 10.0.0.5 255.255.255.0
    no shutdown
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    I tried to change some parameters like "transparent" at serverfarm config and change the "predictor" method to "hash address source" but there was no good results at all.
    Anyone has any idea why this process is not working ?
    Is there any special configuration for this scenario ?
    Regards,
    Ricardo

    Ricardo,
    What is this route ??
    ip route 0.0.0.0 255.255.255.0 10.0.0.1 (VIP address)
    You can't have 0.0.0.0/24.
    You must be missing something ?
    Also, since the vip is part of a vlan with subnet 10.0.0.0/24 you don't need to add a static route to reach that vip.
    It should normally be directly connected to your router.
    With the static route, do you see traffic coming to the ACE module ?
    Does it loadbalance to the server ?
    'show service-policy detail' check the packet counters
    Gilles.

  • Setting up additional load balancing on ACE 4710

    I recently deployed ACE 4710 to load balance traffic to a group of web servers. I would like to add additional server farm(s) with different applications on them to ACE 4710 for load balancing the traffic. How can I best achieve this goal? I currently use 3 interfaces out of 4 interfaces (Server Side interface, Client side interface, and Failover interface). Do I need to use my last interface to set up for the new VIP address for a new server farm? Is virtualized service a possible solution? Thank you in advance.

    You can configure trunking so that multiple vlans can exist.
    Also note that the vip ip address does not have to belong to a subnet.
    You could configure a static route on the upstream router pointing the traffic for the new vip to the interface ip address.
    Gilles.

  • Regarding ACE load balancing

    Hi,
    I have one server application with two physical servers clustered with one virtual IP address . I have total six ip addresses for one server : details are given below
    Cluster IP’s :
    Node 1 :
    NIC 1 : 10.10.x.x : physical IP address
    NIC 2 : 172.16.x.x : heartbeat address used in between server
    Node 2 :
    NIC 1 : 10.10.x.x : physical ip address
    NIC 2 : 172.16.x.x : heartbeat address used in between server
    Cluster IP : 10.10.x.x : clustered IP address used to access server
    SQL IP : 10.10.x.x : clustered IP address used to access SQL application .
    now i want to achieve server load-balancing using ACE module. Please suggest to me fulfil this requirement. how to do this ?
    whether i need to remove the virtual IP and directly bind two physical ip to ace virtual ip add.
    How do i check ace server load-balancing configuration with live server .... do we have any tool to check the packet behaviour to confirm that load-balancing is happening properly in between two physical servers :
    Please guide me and share the knowledge .....................

    Hi Vinod,
    You are correct. In order to achieve load-balancing with an ACE blade, you need to configure the addresses of the two severs separately. If you look at the documentation page on cisco.com for ACE (http://www.cisco.com/en/US/products/ps6906/tsd_products_support_model_home.html) you will find sample configuration for the most commont topologies.
    As for how to verify if the load-balancing is working correctly, you can use the command "show serverfarm ", which will list you all the servers in a serverfarm, along with the current and total connection numbers for each of them.

  • Load balance based on OS

    Is it possible to load balance incoming requests based on client's operating system on ACE?
    For example, we have different web pages specifically for Blackberry or iPhones.
    Instead of having multiple URL's & VIP's, we'd like to have a single VIP, but load balance traffic to different serverfarms based on client's OS.

    You can loadbalance based on User-Agent header, first you need to quantify what Iphone and blackberry use for user-agent for instance from a regular browser you might see:
    User-AgentT=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727)
    from an iphone you will typically see:
    User-Agent=Mozilla/5.0 (iPhone; U; CPU like Mac OS X; en)
    AppleWebKit/420+ (KHTML, like Gecko) Version/3.0 Mobile/1C25 Safari/419.3
    you can go to http://www.user-agents.org to find out what strings are used
    That being the case you can make classes on the header to match for loadbalancing decisions:
    class-map type http loadbalance match-any mobile
    2 match http header User-Agent header-value .*iphone
    4 match http header Uswer-Agent header-value .*blackberry
    then in LB policy say we want to go to farmA for mobile and farmB for pc's
    policy-map type loadbalance first-match L7POLICY
       class mobile
         serverfarm farmA
        class class-default
        serverfarm farmB
    see:
    http://www.cisco.com/en/US/docs/interfaces_modules/services_modules/ace/v3.00_A2/configuration/slb/guide/classlb.html#wp1021388

  • Dev6 Server Load Balancing

    Hi
    I try to install Load Balancing with Dev6/Patch2 and OAS4.0.7.1
    on 4 Machines with WinNT Server 4 SP 5. I tried to do it as
    described in the documentation. But I did not succeed. It seems
    to be that the Doc is not complete or wrong. Could somebody give
    an example how to set up the LB Servers and Clients as NT
    Services ?
    Thank's in advance
    Charly
    null

    Hi Steven,
    No LACP and SLB are different.
    LACP is the Link Aggregation Control Protocol, which is the protocol used within the IEEE 802.3ad (now 802.1AX) Link Aggregation mechanism to control the bundling and unbundling of the physical links into an aggregate link.
    Server Load Balancing is a feature in IOS to load balance traffic destined to a virtual IP across a group of real IP. From Configuring Server Load Balancing:
    The SLB feature is a Cisco IOS-based solution that provides IP server load balancing. Using the IOS SLB feature, the network administrator defines a virtual server that represents a group of real servers in a cluster of network servers known as a server farm.
    Server Load Balancing is effectively what the Cisco Application Control Engine (ACE) etc., does but in IOS.
    Regards

Maybe you are looking for

  • E Recruiting- Ex employees into Talent pool

    Hi All We want to access left employees in the e Recruiting Talent group. We are following two server architecture. Meaning we are a standalone system for e Rec and using ALE to pull the data of employees data (internal candidates) into e Rec. Is it

  • Aperture 3 doesn't see Network Drive that holds masters of referenced files

    Hi I created a new referenced library with about 35000 images and for the few days it worked fine. The Referenced files are located on a Drobo that is connected to My Mac OS X server. I connect to it Via AFP. About 2 days ago, I opened the library an

  • How to resize image from 40k to 200k?

    I am trying to upload images around 40k to a website but it tells me images must not be less than 200k and to upload higher quality images instead.  I have tried everything including save as and save for web, etc., to no avail. Your help will be much

  • Trouble Syncing Ipod

    I am trying to sync my ipod and keep getting mesage staing ipod cannot be synced because apps on ipod cannot be determined. I have tried restarting my computer, using a usb port on the back.  any other suggestions?

  • Usage advice needed

    Looking to maybe buy a Mac Mini (would prefer the Mac Pro but the wife won't let me!). I can stretch to the Dual Core, with 120Gb disk and can probably stretch to 2Gb memory. Basically would like to hear from anyone as to whether I'll be able to do t