Traffic Shape in ethernet - C3750Metro

I have a scenario where, one hub site which is connected to metro ether MAN at 1Gbps and spoke sites are connected to metro ether MAN at 100Mbps, in these remote sites variable bandwidths are agreed with service provider: 20Mbps, 40Mbps, etc.
I only want to configure "traffic shape" in my Catalysts because if I don't, these Catalyst use max. speed to transmit (100Mbps when 20Mbps is only permitted) and the network drops my excess traffic.
I don't want to configure anymore (different QoS for differents services, etc.)
Which is the best, and more elegant, way to do it?
Thanks.

access-list 1 permit any
class-map match_metro
match access-group 1
policy-map match_metro
class metro_class
police 20000000 2000000 exceed-action drop
interface whatever
service-policy input match_metro
This is a just a sample config to achieve what you want, you should check the following link for a more thorough explanation.
Traffic shaping allows you to shape output traffic (egress traffic) on a per-physical port basis. Ucode monitors output traffic to verify that it conforms to the rate configured on the switch router. When excess traffic comes into the switch, the output side of the processor interface applies back pressure and queues the excess traffic in the switch fabric.
http://www.cisco.com/en/US/products/hw/switches/ps646/products_configuration_guide_chapter09186a0080476087.html

Similar Messages

  • Number of traffic shaper(queues) supported

    All,
    Just want to know what is the max. number of traffic shaper (queues) supported:
    1. ingress shaper / ports
    2. egress shaper / ports
    for the Enhanced 4-port Gigabit Ethernet OSM, datasheet say up to 8000 traffic queues but does not indicate whether it is for shaping or rate limiting. and also ingress or egress.
    thanks,
    Eric

    All,
    Just want to know what is the max. number of traffic shaper (queues) supported:
    1. ingress shaper / ports
    2. egress shaper / ports
    for the Enhanced 4-port Gigabit Ethernet OSM, datasheet say up to 8000 traffic queues but does not indicate whether it is for shaping or rate limiting. and also ingress or egress.
    thanks,
    Eric

  • VLANs and traffic shapping

    Hi, I have:
    Cisco 2800 with HWIC 4ESW module (4 port FE switch), IOS 13.3(8)T8, Feature Set IP. 10 VLANs are defined, 2 assigned directly to 2 4ESW ports, 2 port are trunk.
    How to configure traffic shapping on VLANs? I need shape 10Mbits from one Giga port to 10x 1Mbits for every VLAN.
    When I use this configuration, Giga interface is shapping, but VLAN running without shape.
    It is possible?
    Thank you.
    Libor
    access-list 111 permit ip any any
    class-map match-all class11
    match access-group 111
    policy-map policy11
    class class11
    shape average 1000000
    interface GigabitEthernet0/0
    ip address 192.168.0.222 255.255.255.0
    ip nbar protocol-discovery
    service-policy output policy11
    duplex auto
    speed auto
    interface FastEthernet0/0/0
    switchport access vlan 11
    no ip address
    interface Vlan11
    ip address 10.11.12.1 255.255.255.248
    ip nbar protocol-discovery
    service-policy output policy11

    Hi, put the service-policy command under the FE0/0/0 directly. Since there is only 1 VLAN defined there, you should otain the expected result.
    HTH

  • Traffic Shapping on ESW500 switches

    Hello all,
    I am faily new on the traffic shapping / bandwith control department, and have been asked by a client to be able to do some traffic shapping in their main office.
    I've read some documents on the ESW500 switches and wanted to make sure that my understanding of the technology and product is right.
    My client wants to prioritize bandwith per port depending on the bandwith usage needed. Some users needs a lot of bandwith for critical applications while others
    uses a lot of bandwith for not so critical applications...
    From what I've read, I should be able to replace his switch with an ESW500 switch and do some traffic shaping. He has a pretty basic setup with about 30 computers connected to a switch which is connected to a router. As mentionned, if I replace the switch with an ESW500 switch, will I be able to limit per port bandwith usage both inbound and outbound?
    Is there also some kind of monitoring tool I could use to see how much bandwith used per port (not required but would be a nice to have feature).
    Thanks!
    Matt

    Hello Matt, I hope this finds you doing well.
    The amount of bandwidth you need is directly related to the performance you require.  What performance do you require? 
    Here is one example (for voice)
    150 msec one way delay
    Less than 20 msec jitter
    Less than 1% packet loss 
    With requirements for this, you will have to have the right amount of bandwidth per call and queueing control, or else the call not sound right or may even be dropped.
    Another example might be for Microsoft's RDP:
    Some web posts mention that 30kps is needed, and some say 100kbps is acceptable.
    So this is a bandwidth target, lets say 100kbps per user for this example.  If you have 10 concurrent sessions, then this is a max amount of bandwidth needed around 1Mbps.  With statistical multiplexing, you should not need this much, since not all clients will burst or use the max amount of bandwidth at the same time.  You can probably get by with less ...
    The point I am making with this, is once you know how much bandwidth you need, then you can begin to engineer your network so that critical applications are able to function and user productivity is kept high. User productivity is so very key, and it is very good to see you looking into this as you are Matt.  Good stuff Matt.
    Do the application vendors have suggestions for you for how much bandwidth their apps require?
    If the application vendors do not know how much is needed, then using Cisco devices, you can define the performance you require and the Cisco device will respond with the required bandwith per queue.  This is called 'corvil bandwidth' or bandwidth estimation. Using this bandwidth amount, you can configure your QoS settings on all your devices.
    Here is a link and I would suggest to poke around some:
    http://www.cisco.com/en/US/docs/ios/qos/configuration/guide/qos_bndwidth_est.html
    Application performance is an end to end perspective and consideration.  You need intelligence at the edge, core, and remote edge.
    You can also look at the interface statistics to understand what an end user is using when accessing an application.  This can be an inaccurate method, but it might help you in your understanding.
    With all of this said, most folks do not notice a lot of congestion on the LAN or from one LAN port to another LAN port.  Usually problems occur at bottlenecks and uplinks.  Where are the bottlenecks in your network?
    Once you know where these are, then you can apply a QoS policy to protect the important traffic and ensure application performance meets your needs.  What are your needs?  See the above for some thoughts.
    Does this make sense?
    The ESW is a great switch, and QoS can be easily configured to meet your needs.  I think a harder question is ... what are your needs?
    Here is a link for the ESW switch.  Click on resources to find the docs provided with this switch:
    http://www.cisco.com/cisco/web/solutions/small_business/products/routers_switches/esw_500/index.html
    HTH,
    Andrew Lee Lissitz

  • ME 3400 minimum traffic shape rate

    Hi
    I just implement traffic shape for output traffic on interface FastEthernet:
    policy-map megann-10M-out
    class class-default
    shape average 10485500
    int fa0/5
    switch-2(config-if)#service-policy output megann-10M-out
    QoS: Configuration failed. The configured rate is not achievable in hw within 1% of configuration.
    Closest value(s) are: 11111120 bps, 5882368 bps
    What is "1% of configuration"? It's not an 1% of interface rate?

    Hello,
    this is somewhat odd and looks like only predefined rates are achievable with shaping. The command reference does not mention this at all
    http://www.cisco.com/en/US/products/ps6580/products_command_reference_chapter09186a008051341a.html#wp5979557
    but gives an example with 10000000. Maybe you can try this value?
    I understand the message like this: you are not within 1% of the rate 11111120 bps with your configured value. Have you tried to configure shaping to this rate?
    Hope this helps! Please rate all posts.
    Regards, Martin

  • Can I traffic shape to 200Mbps on ASA5510 inculde security plus license ?

    Hello Expert,
    I have ASA5510. It's include security plus license.
    I want to traffic shape to 200Mbps. But , I checked a CCO.
    CCO said that  a shaping limit is 154400000.
    "Enables traffic shaping, where the average rate argument sets  
        the average rate of traffic in bits per second over a given fixed
        time period, between 64000 and 154400000. "
    It's mean shaping limit 154400000 ?
    Can I shape to 200Mbps ?
    regards,
    takuro.

    Takuro,
    Yes what you found is correct.
    http://www.cisco.com/en/US/docs/security/asa/asa84/command/reference/s1.html#wp1451099
    you can do upto 154.40 Mbps
    -Kureli

  • Traffic-shape removed from intrface automatically

    Hi all,
    I came a cross issue on one of my Csico 1841 router.
    We have configured more than 10 traffic shapes on both fastethernet0/0 and fastethernet0/1 . When I tried to removed a one traffic shape line it'll remove all the othe traffic shapes. Is any one faced this same issue ???
    no traffic-shape group 140 512000 12800 12800 1000
    c1841-advipservicesk9-mz.124-12.bin

    Any help !!!!

  • ACL matching for traffic-shape...bug?

    I am using a C6503-E.
    My goal:  create a traffic-shape rule on an interface (in this case g3/7) which will restrict all traffic between two internal addresses (10.0.0.7 and 10.1.0.6) on port 2152 to 128Kbps, and allow all other traffic to pass unfettered.
    I am aware that the 6500 series ACLs are hardware based, and that some counters will not show up in the normal 'show access-list' display.
    I have created an access list which increments when tagged with a 'log' modifier, so i know that it is hit when placed on the interface, but when referenced in a traffic-shape command, the traffic is not shaped.  Unfortunately, the traffic-shape command will not allow the use of the 'log' modifier, so I'm stuck with my imperfect 'the ACL works in this scenario, but not this scenario' method.
    Extended IP access list 195
        10 permit udp host 10.0.0.7 eq 2152 host 10.1.0.6 eq 2152 log (2822 matches)
    interface GigabitEthernet3/7
     ip address 10.2.0.1 255.255.255.252
     no ip redirects
     traffic-shape group 195 128000 7936 7936 1000
                      Acc. Queue Packets   Bytes     Packets   Bytes     Shaping
    I/F               List Depth                     Delayed   Delayed   Active
    Gi3/7               195 0     0         0         0         0         no
    Any ideas on why an ACL wouldn't get hit in a traffic-shape rule, when it clearly gets hit when used strictly for access?
    Thanks!

    Please post your entire QoS config.
    Your access list is just doing matching; it is not doing any setting for your DSCP values.
    Also, I think the Polycom's are IP precedence aware and set their outgoing VC packets to 5.
    Also, matching protocol 46 (RSVP) isn't really going to help - RSVP does not transport application data. It is only used for requesting resources from the network.
    Also, a Cisco search for QoS and Polycom returns this url: http://www.cisco.com/en/US/tech/tk652/tk701/technologies_tech_note09186a0080111c1b.shtml
    -Eric

  • Frame-relay traffic shapping question

    Dear all.
    i have a question related to the frame-relay traffic shapping question.cir is the commited rate. bc is the traffic which is sent during every ime interval. be is the excess burst.
    example. i have line 128kbps to service provider. 64 is my cir so in the map class frame-relay cir 64000 and bc is 8000 which means 8000 bits will go every interval which is by default 125ms.now about be. excess burst will go only in the first interval or every interval ? if i say frame be 32000. will 4000 additional bits go in every interval ?
    please advice .

    Here's my summary of shaping operation:
    * The token bucket used for shaping has a size of Bc+Be (if Be is zero, this equals Bc)
    * The token bucket starts off full i.e. with a capacity of Bc+Be
    * At the start of every Tc interval, Bc worth of tokens are added to the bucket. If the number of added tokens would result in the capacity of the bucket exceeding Bc+Be, these excess tokens are discarded.
    * After the tokens are added to the bucket, the shaper checks if there are any packets that are waiting to be transmitted. If there are, an equivalent number of bytes of packets as the token bucket contents are transmitted. If there are more packets than tokens, these packets will have to wait until the next Tc.
    * The capacity of the token bucket will approach Bc+Be only of the traffic has been quite for a little while.
    * The maximum amount of traffic that can be sent in any interval is Bc+Be, since that is the size of the token bucket. If the bucket has filled up to Bc+Be, this implies that the connection has been quiet for a little while so that we can allow it a little burst.
    * The long-term average of traffic will never exceed CIR, since the token bucket is filled at a CIR rate.
    Now, applying this to your example, the maximum size of the token bucket will be Bc + Be = 40000 bits. The bucket will fill up to this level only if there are no packets in the queue for a little while, allowing the bucket to fill up. Then, say that that a 1500 byte (12000 bits) packet comes along. It will be transmitted and the token bucket size reduced to 28000 bits. If there are more packets, they will be transmitted as long as the token bucket has sufficient packets. If there are no more packets, the token bucket will be filled with another 8000 bits (Bc) at the next measurement interval, giving a total of 36000 bits. Whether or not all the Be + Bc bits will be used up in the first interval depends on how many packets are waiting in the queue. If there are sufficient packets, they can all get used up. If not, they get carried forward to the next interval.
    Pls do remember to rate posts.
    Paresh

  • Directing traffic to second ethernet port

    Hello,
    What is the process used to direct certain IP addresses or a range of IP addresses to the second ethernet connection on a Mac Pro? I have a set of Mac Pros that use the first connection for internet access and corporate server connections using Samba. But the second ethernet connection is used for a lan between the Mac Pros and printers. It currently works but it take a bit for the "connect to servers" dialog to connect to a Mac Pro on the lan because I think it is searching Connection 1 first which has hundreds of Windows servers attached to it. And it takes several minutes to connect if our service has an interruption on Connection 1. All of the Mac Pros and printers are set up to use a manual IP address (192.168...) The Mac Pro workstations use Snow Leopard and we have a Mac Pro Server running Lion Server that we use to conntrol a network RAID. Thanks for your help.

    Thanks guys.
    First, it seems to me that the service order is already set up correctly. I have Connection 1 on top and that's what we use for internet connection. If I change Connection 2 on top our internet connection is disabled. Also as Grant suggested we do have it set up to use different IPs and subnets. Connection 1 uses DCHP and has a static IP of 172.x.x.x and a subnet ending in 128. Connection 2 is set up manually with an IP address of 192.x.x.x and a subnet ending in 0.
    I would just like to tell each Mac Pro when it trys to connect to a server with an IP of 192.x.x.x to use Connection 2 instead of trying to find it first on Connection 1. The AppleScript within an Automator program that we use to connect to servers is:
    tell application "Finder"
                        open location "afp://[username]:[password]@192.x.x.x:548"
              end tell
    Make sense? It has been suggested to me that I set up persistent routes, but I haven't found a solution online that matches our senario enough to implement it. Any ideas? Thanks again.

  • Traffic using Fast Ethernet, not T-1

    I have two routers at location A. They are connected via a Fa interface. Router A1 has 4 T-1s in a Multilink interface to site B. Router A2 has 1 T-1 to router at site C, which has a T-1 to site B.
    My problem is when sending to site B, it always choose the Fa interface rather than the multilink interface.
    What is the best way to direct traffic for B over the multilink?
    I'm running EIGRP on all the routers.

    Denis
    There are a couple of things that could produce the symptoms that you describe. First I would check to verify that the multilink is being advertised in EIGRP: does router A1 see router B as a neighbor and does router B see router A1 as a neighbor? Does either router have a passive interface statement that could affect routing? Does either router have a distribute list that could affect routing.
    If the multilink is working and routes are being advertised over it then it implies that the router is choosing the path over the T1s based on metrics. Check all of the interfaces and see whether the multilink has a quite low bandwidth or a very high delay and check the T1s for their bandwidth and delay parameters.
    If that has not given us the answer then perhaps some more detail from the routers might help us. Could you post the output of show ip interface from each router? And maybe the output of show ip protocol?
    HTH
    Rick

  • Traffic shape on a switch 3550

    Hi,
    How can I limit bandwidth to 64k for example on the interface 0/1 in a switch 3550?
    Thanx

    Hi Reza,
    I did not include the burst parameter in that config. If you apply the following, it should work - I've justr tried it on a 3550 myself...
    policy-map Policer
    class class-default
    police 64000 8000 exceed-action drop
    interface FastEthernet0/1
    service-policy output Policer
    service-policy input Policer
    Hope that helps - pls rate posts that help.
    Regards,
    Paresh

  • [REQUEST] Pyshaper - Netlimiter like traffic shaper for linux!

    Background on netlimiter: http://www.netlimiter.com/scrshots.php
    Pyshaper:
    http://www.freenet.org.nz/python/pyshaper/
    pyshaper includes a graphical user interface which you can use to conveniently view/change throttle settings in real time. Note that pyshaper runs as a daemon, so can function perfectly in non-graphical environments.
    How I got it to work: http://ubuntuforums.org/showpost.php?p= … ostcount=1
    Last edited by zaggynl (2009-04-01 13:08:48)

    JohnDVD wrote:...Could the author please update pyshaper.
    Any suggestions onto other netlimiter-like software?
    Moderator comment:
    Be aware, this is a two year old thread -- you might not get any satisfaction.  I'll leave this open for now, on the chance you get a response.  If you don't, please open a new thread if you have a current problem.  That helps us keep from muddying the waters with old (stale) information when discussing current issues.
    Thanks,
    ewaller

  • OSPF Equal Cost (multiple links) but unbalanced traffic

    Hi!
    I would like to ask about OSPF.
    We are using 4 links running OSPF point to point with equal cost to load balance MPLS L2 traffic between our two routers.
    And from what we are experiencing right now is that it didnt balance the load the way it should have.
    The first link always catches up the bulk of the traffic, while the remaining 3 links load balances, I would like to inquire on steps to mitigate the issue.
    Appreciate if I could receive some help to solve the issue
    Thank you very much  in advance!
    Best Regards,
    asakurahao

    I do have almost the same problem.
    i have 2 x 20 Mbps Point to Point ethernet links configured with equal ospf cost and both links terminated on the single router at both ends.
    interface FastEthernet0/0/0
     bandwidth 20000
     ip address x.x.x.x y.y.y.y
     load-interval 30
     duplex auto
     speed auto
     traffic-shape rate 20000000 500000 500000 1000
    interface FastEthernet0/0/1
     bandwidth 20000
     ip address x.x.x.x y.y.y.y
     load-interval 30
     duplex auto
     speed auto
     traffic-shape rate 20000000 500000 500000 1000
    FastEthernet0/0/0 is up, line protocol is up
      Internet Address 135.254.193.53/30, Area 0.0.0.1
      Process ID 3435, Router ID 135.254.0.95, Network Type BROADCAST, Cost: 5
    FastEthernet0/0/1 is up, line protocol is up
      Internet Address 135.254.193.45/30, Area 0.0.0.1
      Process ID 3435, Router ID 135.254.0.95, Network Type BROADCAST, Cost: 5
    I see majority of the traffic using the link F0/0/0 and only 30% traffic using the second link F0/0/1.
    I used per-packet load-sharing on these interfaces which caused throughput problems, so i removed that from the interface. Should i add some CEF commands or should try per-destination load sharing to see equal traffic on both links ?

  • Broadcast traffic with LCD Projector

    Hi all,
    Please help...
    how to enable broadcast traffic on WiSM on same VLAN/Interface...
    i have a LCD Projector that when the client do automatic search.. the client will broadcast to 255.255.255.255 and somehow the the LCD Projetor do not respond for the broadcast traffic by the client...
    I already configured the WiSM to forward broadcast traffic...
    i already tested it using cisco autonomous AP and have the LCD Projector and Laptop joining the same ssid and successfully do the automatic search...
    anyone can help...??
    regards
    Robin

    hey... i have good news.....
    the problem is on the AP Multicast Mode...not on the ethernet multicast mode...
    Web Mode.................................... Enable
    Secure Web Mode............................. Disable
    Secure Web Mode Cipher-Option High.......... Disable
    Secure Web Mode Cipher-Option SSLv2......... Enable
    Secure Shell (ssh).......................... Enable
    Telnet...................................... Enable
    Ethernet Multicast Mode..................... Enable   Mode: Ucast
    Ethernet Broadcast Mode..................... Enable
    AP Multicast Mode........................... Unicast
    IGMP snooping............................... Enabled
    IGMP timeout................................ 60 seconds
    User Idle Timeout........................... 300 seconds
    ARP Idle Timeout............................ 300 seconds
    Cisco AP Default Master..................... Disable
    AP Join Priority............................ Disable
    Mgmt Via Wireless Interface................. Enable
    Mgmt Via Dynamic Interface.................. Disable
    Bridge MAC filter Config.................... Disable
    Bridge Security Mode........................ EAP
    Mesh Full Sector DFS........................ Enable
    --More-- or (q)uit
    Apple Talk ................................. Disable
    AP Fallback ................................ Enable
    Web Auth Redirect Ports .................... 80
    Fast SSID Change ........................... Enabled
    802.3 Bridging ............................. Disable
    IP/MAC Addr Binding Check .................. Enabled
    does it mean that the wlc will receiving multicast traffic from the ethernet and will forward the multicast traffic on the wireless side in unicast mode....

Maybe you are looking for

  • Nested AGO function in OBIEE

    Hi , I am not able to understand the reason behind using Nested AGO functions. In one of the logical columns (Sales LastYear LastWeek) the mapping was in the following fashion: Ago(Ago("Core"."Fact - Retail Inventory Receipts"."Receipts Retail" , "Co

  • Using GF 680GTX 4GB with Premiere Pro CS6

    I am thinking in buying the GF 680GTX 4gb to use it with Premiere Pro CS6, but I've just discovered it's not compatible as a GPU Accelerator. Is there any way I can make it work with the program? Thanks in advance!

  • Can't adjust curves in file opened from pdf

    I need to include several pages of pdfs in a book. The pdfs are scanned text documents, image only, with no security applied. When I open the pdf on my mac pro with photoshop cs6, I can make adjustments in the curves dialog, but when I close the dial

  • When I create a bookmark, it is not showing up in the Recent bookmark folder.

    The new bookmark does show up in the new folder I created. But new bookmarks don't show up in the Recent bookmarked folder.

  • Transports in PI System

    Hello All, Can you please suggest me the options for Client and Transports in PI system. Basically we are planning just one client in PI system in all landscapes (Dev-TEST-QAS-PROD). Does PI need some kind of communication or Data from ERP ,CRM ,BI s