Unable to add bing maps to projects references

I am making a windows store app ( 8. 1 ) with visual studio 2013 and I am following this guide https://msdn.microsoft.com/en-us/library/dn456475.aspx .
Now I installed the bing maps sdk
http://i.imgur.com/je6Fxgd.png
But when I want to add it as a reference I do not see it in the reference menu
http://i.imgur.com/VIcD5ol.png
They are also not under any other tab.
But I know that it is installed. When I look under C:\Users\{username}\AppData\Local\Microsoft SDKs\Windows\v8.1\ExtensionSDKs\Bing.Maps.Xaml\1.313.0825.0\ I see a lot of stuff
DesignTime
extension.vsixmanifest
License.rtf
redist
references
SDKManifest.xml
Xaml-200x200.png
Xaml-32x32.png
And some .dll files in the subdirectories. When I try to add those ( in the add-reference window under browse ) I get an error "A reference to ~ could not be added. Please make sure that the file is accessible, and that it is a valid assembly or COM
component."
I really don't know what to do.
Oh and yes, I restarted my visual studio 2013 and computer multiple times and yes, I made everything compile for x86.

That sample and SDK are for Windows 8.1 only...
For Windows Phone 8.1 applications the Map control is part of the base references.
see:
Windows.UI.Xaml.Controls.Maps and
Windows.Services.Maps namespaces.
The "Using Bing Maps in Universal Apps" has examples for both Windows 8.1 and Windows Phone 8.1
Eric Fleck, Windows Store and Windows Phone Developer Support. If you would like to provide feedback or suggestions for future improvements to the Windows Phone SDK please go to http://wpdev.uservoice.com/ where you can post your suggestions and/or cast
your votes for existing suggestions.

Similar Messages

  • Suddenly, I am unable to add photos to my project in Imovie 11. I have an IMac Snow Leopard 10.6.8 and have made several movies where this worked fine but for some reason, it has quit. Everything seems to be working fine except that?

    I'm an oldtimer and have had this Mac for less than 2 yrs and have LOTS to learn - but I've climbed the curve a little.  !'ve made several movies and published to YouTube and burned to disc using IDVD with reasonably good results. Each time I have added stills to my movies it has worked fine - but tonight, I'm suddenly unable to add them. I click "Photos" -     select my photo - left click the photo and drag into the project while holding the click. Have the green "+" and the green highlight and even get the green vertical bar in the project but when I release the click, the photo simply disappears!  One "clue" here may be this:  I was able to add one still to this project and the only diff between it and the other still thumbnails now is that there is a "green check mark" on the thumbnail of the one successfully added.  Any suggestions?  (I do have the "advanced tools" option selected in IMovie Preferences.)
    Thank you so much for any help at all.
    Sam

    Hi
    My first thoughts are
    • iMovie ill behaving - Trash the iMovie pref file - use to set things right
    • in reg. to Photos - Did You change iPhoto Photo Library - Then iMovie get's lost as it peeks into iPhoto on start up to see where photos are stored. Set iPhoto back to first Photo Library (when iMovie is not running) then start iMovie.
    Yours Bengt W

  • Is it actually ok to use bing maps to project onto webgl 3d models?

    See: http://potree.org/demo/experimental/potree_map_projections/examples/viewer_proj.html
    This is just experimental but I'd love to support Bing in the next stable release.
    The project is a webgl point cloud viewer. Open Source and free to use.

    The Bing Maps tile can be used in custom map controls, however the tiles need to be accessed using a specific method. The URL t the map tiles changes from time to time. This can cause your application to break. To prevent this your application should call
    the Bing Maps Imagery Metadata service when it loads to get the current map tile URL. This also serves as a way to authenticate the usage of the Bing Maps data in your application.
    Documentation
    on this service can be found here:
    http://msdn.microsoft.com/en-us/library/ff701716.aspx
    Making a request to the imagery service like this:
    http://dev.virtualearth.net/REST/V1/Imagery/Metadata/Road?output=json&include=ImageryProviders&key=BingMapsKey
    This will return a response that contains an Image URL property. This URL will look something like this:
    http://ecn.{subdomain}.tiles.virtualearth.net/tiles/r{quadkey}.jpeg?g=129&mkt={culture}&shading=hill&stl=H
    You can then replace the different parts of the URL to create each tile. The subdomain can be a value of t0, t1, t2, t3. Using a different one for each tile request you can increase performance by get around browser URL request limits
    i.e. many browsers allow up to 8 concurrent requests to the same domain. Using subdomains allows up to 8 requests per subdomain. The culture value can be any value that is documented under the imagery section here:
    http://msdn.microsoft.com/en-us/library/hh441729.aspx The quadkey value can be calculated based on the zoom level and the tile you wish to render. Information on the tile system along with
    some useful code can be found here:
    http://msdn.microsoft.com/en-us/library/bb259689.aspx
    http://msdn.microsoft.com/en-us/library/aa940990.aspx
    In addition to this, the query will also return information on the imagery providers and copyright information which should be displayed with the imagery.
    Licensing queries can be sent here:
    http://www.microsoft.com/maps/contact-us.aspx
    http://rbrundritt.wordpress.com

  • Unable to add controller to MVC project on Visual studio 2013

    I am trying to add a empty MVC5 controller to the MVC project. I am getting an error as soon as I try and create the controller.
    The system is running on Windows 7 with Visual studio 2013 update 4. I have uninstalled and re installed visual
    studio with no success.
    

    Hi Mahesh.Janardhanan,
    If this issue is related to web app, you could ask this question in the ASP.NET forum:
    http://forums.asp.net. If then, you could get an answer more quickly and professional. Thanks for
    your cooperation.
    Best Regards,
    Jack
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click
    HERE to participate the survey.

  • I've created a hardcover book but cannot add a map box of our trip to a page. Help!!!

    I am unable to add a map box to my hardcover book creation in Aperture 3. Aperture help says some books do not offer this option but it does not tell you what books it's not available in. Any help would be appreciated.

    I found only two predefined themes that offer maps - "Journal" and "Photo Essay". Those are the two themes showing maps in the preview you can see in the theme chooser panel.

  • How to add a bing map with pins to a Siena Project

    Hi
    I just want to add a bing map with the current location and a few nice pins of some nice locations around me. Comming out of a Excel file. Potentially also draw some routing lines into the bing maps.
    Any ideas how I can accomplish that goal?
    Thank you in advance
    wbr.
    Joerg 

    yes you can (there is actaully one on the map, blue square)
    The syntax is listed on
    http://msdn.microsoft.com/en-us/library/ff701724.aspx
    You will however have to build the correct string to included in the image source (which you can do in the source excel or in runtime in siena)
    Concatenate is suitable to do that.
    http://dev.virtualearth.net/REST/v1/Imagery/Map/Road?pp=47.638197,-122.131378;;1&ms=350,500&key=KEYHERE
    the PP indicates the pin actually and the bing map autocenters on that. You have several options listed on the webpage listed above. It's a question of the one fitting you best.
    Please note that your bing key is yours so you need to hide it well enough.
    Regards
    StonyArc

  • Unable to add a Project File in RoboSource Control

    Hi this is Savana Chandra Shekhar,
    I am working on RoboHelp 9 with RoboSource Control 3.
    Scanario 1: There are two users who want to work on the same project file from different location using RoboHelp  and using version control 3. we have a server located in US and i myself located in India. Now, when i am trying to add or load the Project file in Robosource, i am unable to load or add the project file as the file size is around 160 MB.
    Scanario 2: When i am using "add to version control" option after setting up the connection (By Proving : Connection Name, Server, Port No., Port Type), i am getting the as displayed below. Please refer the Image attached.
    I will be greatful to you if you can please provide some firm solution regarding this issue.
    Thanks
    Savana Chandra Shekhar
    Database: MARSHelpSource
    to database,

    I can.  This is a bug you are seeing we will have fixed in a future release.  You are working in a "Local" form (not an online form) and that "Add submit button" should not be shown at all, that is only for an online form.  If you move your form online when signed in, then it would have a Submit button automatically in Web View and in Page View would be able to be turned on and off.
    Thanks,
    Josh

  • PB2 issue Bing Maps says 'Unable to determine your current location'

    PB2 issue Bing Maps says 'Unable to determine your current location'.
    please help..

    That happens if you are indoors and the App canot locate your GPS location.
    You may have to take your PB outside for a minute or so so it can get a fix on your location.
    Have you tried Google Maps or the MapApp from App World that also uses Google Maps?
    They are much better than Bing Map.
    DC-IT

  • Add a Bing Map in O365

    Hello
    I have created a Directions page in my O365 Website but when I click on the Maps command to add a Bing Map, I cannot create the map.  I enter my details and click on Search and nothing happens.  At All.  Can you help?
    Regards
    Doug Fisher
    Doug Fisher

    Can you provide a lot more details? There are a lot of different ways to do what you are doing.
    http://rbrundritt.wordpress.com

  • Unable to add resources to project when building team

    I clicked on the 'Build Team' button to add resources to a project. All of the buttons are greyed out however and I cannot add anybody. See image below.

    You have click the checkboxes besides the resource name that you want to add, to make the buttons in the middle active.
    Cheers,
    Prasanna Adavi, Project MVP
    Blog:
      Podcast:
       Twitter:   
    LinkedIn:
      

  • Snapshots theme- unable to add map box

    Is there a reason I cannot add a map box to the snapshots themed books? Will I have to create it in a different album type either on iPhoto or aperture and create a pdf out of it and then import it in as a full page "image"???

    Maps just aren't a feature of that theme...

  • Cisco ASA 5505 VPN connection issue ("Unable to add route")

    I'm trying to get IPSec VPN working onto a new Cisco ASA5505. Pretty standard configuration.
    Setup:
    * Cisco VPN client on Windows 7 (v5.0.07.0290 x64 on Laptop1 and v5.0.07.0440 x64 on Laptop2)
    * PPPoE/NAT and internal DHCP on the ASA were configured with the Startup Wizard in ASDM
    NATting is working fine - internal PCs get an IP address in the 192.168.2.0/24 range and can all access the Internet.
    I wanted to be able to connect from anywhere to the ASA in order to reach one of the internal servers. Should be pretty basic.
    First I tried with the built-in ASDM IPSec Wizard, instructions found here.
    VPN clients can connect to the ASA, are connected (until they're manually disconnected), but cannot reach the internal network nor the Internet. Note VPN client can connect fine to a different VPN site (not administered by myself).
    Client logs show following error messages:
    1 15:53:09.363 02/11/12 Sev=Warning/3     IKE/0xA300005F
    Firewall, Cisco Intrusion Prevention Security Agent, is not running, the client will not send firewall information to concentrator.
    2 15:53:13.593 02/11/12 Sev=Warning/2     CVPND/0xE3400013
    AddRoute failed to add a route with metric of 0: code 160
    Destination     192.168.1.255
    Netmask     255.255.255.255
    Gateway     172.16.1.1
    Interface     172.16.1.101
    3 15:53:13.593 02/11/12 Sev=Warning/2     CM/0xA3100024
    Unable to add route. Network: c0a801ff, Netmask: ffffffff, Interface: ac100165, Gateway: ac100101.
    4 15:54:30.425 02/11/12 Sev=Warning/2     CVPND/0xA3400015
    Error with call to IpHlpApi.DLL: CheckUpVASettings: Found IPADDR entry addr=172.16.1.101, error 0
    5 15:54:31.433 02/11/12 Sev=Warning/2     CVPND/0xA3400015
    Error with call to IpHlpApi.DLL: CheckUpVASettings: Found IPADDR entry addr=172.16.1.101, error 0
    6 15:54:32.445 02/11/12 Sev=Warning/2     CVPND/0xA3400015
    Error with call to IpHlpApi.DLL: CleanUpVASettings: Was able to delete all VA settings after all, error 0
    7 20:50:45.355 02/11/12 Sev=Warning/3     IKE/0xA300005F
    Firewall, Cisco Intrusion Prevention Security Agent, is not running, the client will not send firewall information to concentrator.
    8 20:50:50.262 02/11/12 Sev=Warning/2     CVPND/0xE3400013
    AddRoute failed to add a route with metric of 0: code 160
    Destination     192.168.1.255
    Netmask     255.255.255.255
    Gateway     172.16.1.1
    Interface     172.16.1.100
    9 20:50:50.262 02/11/12 Sev=Warning/2     CM/0xA3100024
    Unable to add route. Network: c0a801ff, Netmask: ffffffff, Interface: ac100164, Gateway: ac100101.
    I've already tried the suggestions from this link, although the problem is different there (as the user can still access the internet, even without split tunneling, which I cannot).
    A show run shows the following output (note in the below I have tried a different VPN network: 192.168.3.0/24 instead of 172.16.1.0/24 seen in the Client log)
    Result of the command: "sh run"
    : Saved
    ASA Version 8.2(5)
    hostname AsaDWD
    enable password kLu0SYBETXUJHVHX encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.2.254 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    pppoe client vpdn group DW-VPDN
    ip address pppoe setroute
    ftp mode passive
    access-list inside_nat0_outbound extended permit ip any 192.168.3.0 255.255.255.240
    pager lines 24
    logging enable
    logging asdm informational
    mtu outside 1500
    mtu inside 1500
    ip local pool DWD-VPN-Pool 192.168.3.5-192.168.3.15 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.2.0 255.255.255.0 inside
    http 0.0.0.0 0.0.0.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    vpdn group DW-VPDN request dialout pppoe
    vpdn group DW-VPDN localname fa******@SKYNET
    vpdn group DW-VPDN ppp authentication pap
    vpdn username fa******@SKYNET password *****
    dhcpd auto_config outside
    dhcpd address 192.168.2.5-192.168.2.36 inside
    dhcpd domain DOMAIN interface inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    group-policy DWD internal
    group-policy DWD attributes
    vpn-tunnel-protocol IPSec
    username test password ******* encrypted privilege 0
    username test attributes
    vpn-group-policy DWD
    tunnel-group DWD type remote-access
    tunnel-group DWD general-attributes
    address-pool DWD-VPN-Pool
    default-group-policy DWD
    tunnel-group DWD ipsec-attributes
    pre-shared-key *****
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
    message-length maximum client auto
    message-length maximum 512
    policy-map global_policy
    class inspection_default
    inspect dns preset_dns_map
    inspect ftp
    inspect h323 h225
    inspect h323 ras
    inspect rsh
    inspect rtsp
    inspect esmtp
    inspect sqlnet
    inspect skinny
    inspect sunrpc
    inspect xdmcp
    inspect sip
    inspect netbios
    inspect tftp
    inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:3e6c9478a1ee04ab2e1e1cabbeddc7f4
    : end
    I've installed everything using the CLI as well (after a factory reset). This however yielded exactl the same issue.
    Following commands have been entered:
    ip local pool vpnpool 172.16.1.100-172.16.1.199 mask 255.255.255.0
    username *** password ****
    isakmp policy 1 authentication pre-share
    isakmp policy 1 encryption 3des
    isakmp policy 1 hash sha
    isakmp policy 1 group 2
    isakmp policy 1 lifetime 43200
    isakmp enable outside
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto dynamic-map outside_dyn_map 10 set transform-set ESP-3DES-SHA
    crypto dynamic-map outside_dyn_map 10 set reverse-route
    crypto dynamic-map outside_dyn_map 10 set security-association lifetime seconds 288000
    crypto map outside_map 10 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    crypto isakmp nat-traversal
    sysopt connection permit-ipsec
    sysopt connection permit-vpn
    group-policy dwdvpn internal
    group-policy dwdvpn attributes
    vpn-tunnel-protocol IPSec
    default-domain value DWD
    tunnel-group dwdvpn type ipsec-ra
    tunnel-group dwdvpn ipsec-attributes
    pre-shared-key ****
    tunnel-group dwdvpn general-attributes
    authentication-server-group LOCAL
    default-group-policy dwdvpn
    Unfortunately I'm getting the same "AddRoute failed to add a route with metric of 0: code 160" error message.
    I'm very confused as this should be a pretty standard setup. I tried to follow the instructions on the Cisco site to the letter...
    The only "differences" in my setup are an internal network of 192.168.2.0 (with ASA IP address 192.168.2.254) and PPPoE with DHCP instead of no PPPoE at all.
    Does anyone know what's going on?

    Yes, I have tried from a different laptop - same results. Using that laptop I can connect to a different IPSec site without issues.
    Please find my renewed config below:
    DWD-ASA(config)# sh run: Saved:ASA Version 8.2(5) !hostname DWD-ASAenable password ******* encryptedpasswd ****** encryptednames!interface Ethernet0/0 switchport access vlan 2!interface Ethernet0/1!interface Ethernet0/2!interface Ethernet0/3!interface Ethernet0/4!interface Ethernet0/5!interface Ethernet0/6!interface Ethernet0/7!interface Vlan1 nameif inside security-level 100 ip address 192.168.2.254 255.255.255.0 !interface Vlan2 nameif outside security-level 0 pppoe client vpdn group DWD ip address pppoe setroute !ftp mode passiveaccess-list inside_nat0_outbound extended permit ip any 192.168.50.0 255.255.255.224 pager lines 24logging asdm informationalmtu inside 1500mtu outside 1500ip local pool vpnpool 192.168.50.10-192.168.50.20 mask 255.255.255.0icmp unreachable rate-limit 1 burst-size 1no asdm history enablearp timeout 14400global (outside) 1 interfacenat (inside) 0 access-list inside_nat0_outboundnat (inside) 1 0.0.0.0 0.0.0.0timeout xlate 3:00:00timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolutetimeout tcp-proxy-reassembly 0:01:00timeout floating-conn 0:00:00dynamic-access-policy-record DfltAccessPolicyhttp server enablehttp 192.168.2.0 255.255.255.0 insidehttp 0.0.0.0 0.0.0.0 outsideno snmp-server locationno snmp-server contactsnmp-server enable traps snmp authentication linkup linkdown coldstartcrypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac crypto ipsec security-association lifetime seconds 28800crypto ipsec security-association lifetime kilobytes 4608000crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAPcrypto map outside_map interface outsidecrypto isakmp enable outsidecrypto isakmp policy 10 authentication pre-share encryption 3des hash sha group 2 lifetime 86400telnet timeout 5ssh 0.0.0.0 0.0.0.0 outsidessh timeout 5console timeout 0vpdn group DWD request dialout pppoevpdn group DWD localname *****@SKYNETvpdn group DWD ppp authentication papvpdn username *****@SKYNET password ***** dhcpd auto_config outside!dhcpd address 192.168.2.10-192.168.2.40 insidedhcpd enable inside!threat-detection basic-threatthreat-detection statistics access-listno threat-detection statistics tcp-interceptwebvpn enable outside svc enablegroup-policy DfltGrpPolicy attributes vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpngroup-policy dwdipsec internalgroup-policy dwdipsec attributes vpn-tunnel-protocol IPSec default-domain value DWDDOMusername user1 password ***** encrypted privilege 0username user1 attributes vpn-group-policy dwdipsectunnel-group dwdipsec type remote-accesstunnel-group dwdipsec general-attributes address-pool vpnpool default-group-policy dwdipsectunnel-group dwdipsec ipsec-attributes pre-shared-key *****tunnel-group dwdssl type remote-accesstunnel-group dwdssl general-attributes address-pool vpnpool!class-map inspection_default match default-inspection-traffic!!policy-map type inspect dns preset_dns_map parameters  message-length maximum client auto  message-length maximum 512policy-map global_policy class inspection_default  inspect dns preset_dns_map   inspect ftp   inspect h323 h225   inspect h323 ras   inspect rsh   inspect rtsp   inspect esmtp   inspect sqlnet   inspect skinny    inspect sunrpc   inspect xdmcp   inspect sip    inspect netbios   inspect tftp   inspect ip-options !service-policy global_policy globalprompt hostname context no call-home reporting anonymousCryptochecksum:f5c8dd644aa2a27374a923671da1c834: endDWD-ASA(config)#

  • WS-Security and proxy service: Unable to add security token for identity

    What the reason of "Unable to add security token for identity" fault in this situation (10.3.1):
    I did simple "hello word" proxy service and tried to apply custom policy binding.
    WS-Policy is next:
    <wsp:Policy wsu:Id="WS-Policy-Siebel"
         xmlns:sp="http://docs.oasis-open.org/ws-sx/ws-securitypolicy/200702"
         xmlns:wsp="http://schemas.xmlsoap.org/ws/2004/09/policy"
         xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">
         <wssp:Identity
              xmlns:wssp="http://www.bea.com/wls90/security/policy">
              <wssp:SupportedTokens>
                   <wssp:SecurityToken
                        TokenType="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#UsernameToken">
                        <wssp:UsePassword
                             Type="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#PasswordText" />
                   </wssp:SecurityToken>
              </wssp:SupportedTokens>
         </wssp:Identity>
    </wsp:Policy>
    Process WS-Security is setted to "yes".
    While debugging I see that all works fine - I can authenticate with defined credentials and breakpoints in proxy service flow works fine.
    But at the end I get the fault:
    Soap fault:
    <env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/">
    <env:Header/>
    <env:Body>
    <env:Fault>
    <faultcode>env:Server</faultcode>
    <faultstring>Unable to add security token for identity</faultstring>
    </env:Fault>
    </env:Body>
    </env:Envelope>
    In console:
    <09.06.2010 17:39:18 MSD> <Error> <OSB Security> <BEA-387023> <An error ocurred during web service security inbound response processing [error-code: F
    ault, message-id: 1721282272521583996--57dc4ccc.1291cc2282d.-7fab, proxy: OSB Project WS-Security/WSSecurityService, operation: NewOperation]
    --- Error message:
    <env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"><env:Header/><env:Body><env:Fault><faultcode>env:Server</faultcode><faultstring>Un
    able to add security token for identity</faultstring></env:Fault></env:Body></env:Envelope>
    weblogic.xml.crypto.wss.WSSecurityException: Unable to add security token for identity
    at weblogic.wsee.security.wss.SecurityPolicyDriver.processIdentity(SecurityPolicyDriver.java:175)
    at weblogic.wsee.security.wss.SecurityPolicyDriver.processOutbound(SecurityPolicyDriver.java:73)
    at weblogic.wsee.security.wss.SecurityPolicyDriver.processOutbound(SecurityPolicyDriver.java:64)
    at weblogic.wsee.security.WssServerHandler.processOutbound(WssServerHandler.java:88)
    at weblogic.wsee.security.WssServerHandler.processResponse(WssServerHandler.java:70)
    Truncated. see log file for complete stacktrace
    Incoming soap message is:
    <soapenv:Envelope      xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
    <soap:Header      xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
    <wsse:Security      soap:mustUnderstand="1" xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd">
    <wsse:UsernameToken      wsu:Id="unt_TNNp0cBwU7HyPKoq" xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">
    <wsse:Username>testuser</wsse:Username>
    <wsse:Password      Type="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#PasswordText">testuser</wsse:Password>
    </wsse:UsernameToken>
    </wsse:Security>
    </soap:Header>
    <soapenv:Body>
    <wss:NewOperation      xmlns:wss="http://www.troika.ru/Enterprise/WSSecurityService/">
    <in>string</in>
    </wss:NewOperation>
    </soapenv:Body>
    </soapenv:Envelope>
    Edited by: Andrey L. on Jun 9, 2010 5:55 PM

    I thought you were getting that exception when accessing the proxy.
    No. Authentification works fine. Proxy body works fine. But at the end of proxy appears the exception.
    Sorry for my english - I tried to show this situation on image: http://imglink.ru/show-image.php?id=9c0e0c1719f00289faf11696c6703bc3
    Are you getting this exception when routing to a business service which is configured for WS-Security ??
    I don't use business service in this test project - only simple proxy service with all logic inside.
    PS transformation in replace action is very simple too:
    (:: pragma bea:global-element-parameter parameter="$newOperation1" element="ns0:NewOperation" location="WSSecurityService.wsdl" ::)
    (:: pragma bea:global-element-return element="ns0:NewOperationResponse" location="WSSecurityService.wsdl" ::)
    declare namespace ns0 = "http://www.troika.ru/Enterprise/WSSecurityService/";
    declare namespace xf = "http://tempuri.org/OSB%20Project%20WS-Security/Hello/";
    declare function xf:Hello($newOperation1 as element(ns0:NewOperation))
    as element(ns0:NewOperationResponse) {
    <ns0:NewOperationResponse>
    <out>Hello, { data($newOperation1/in) }!</out>
    </ns0:NewOperationResponse>
    declare variable $newOperation1 as element(ns0:NewOperation) external;
    xf:Hello($newOperation1)
    Edited by: Andrey L. on Jun 10, 2010 12:21 PM

  • Unable to add a new printer in 10.5.7 - dialog box "quits"

    Every time I try to add a new printer via System Preferences-->Print&Fax, the dialog box showing available printers briefly opens, and then quits. As a result, I am currently unable to add any new printers.
    Help?? Thank you...

    If you open Console (Applications > Utilities) and look at Console Messages you may see a reference to the Add Printer starting and stopping. This may give some clues as to the cause.
    Still in Console, if you expand /Library/Logs and then expand Crash Reporter, there may be an entry for the Add Printer app.
    If none of that is any help, then you could download the 10.5.7 Combo updater and ran that. If you updated to 10.5.7 using Software Update, then the Combo updater can sometimes repair files that were damaged by the sequential update.
    You could also get a copy of Print Therapy from fixamacsoftware. This utility can help resolve printing system issues.
    PaHu

  • Unable to add a new track in Garageband 10.0.2

    Hi, I'm using the latest version of Mavericks and Garageband 10.0.2. I'm unable to add a new track.
    I repeatedly hit the + button, I go into the menu and hit "add a new track," I try to use keyboard shortcuts, and nothing seems to work.
    Yesterday when I tried to create an "empty project," it wouldn't allow me to start the session, instead it gave me this error code, "The specified number of tracks could not be created. Reduce the number of tracks to create, then try again."
    I restarted my computer and tried again today, and I don't get the same error, but am still not able to add tracks. Not sure what's going on. Restarted it a couple of times and I'm still getting the same issue.
    Any help would be awesome.

    'musical typing keys'
    The musical typing is a legacy instrument from GarageBand '11.  You can use it, and drop samples to the keys, but GarageBand 10.0 does not save the patch.   If you still have GarageBand '11 installed, create the custom sampler instrument in GarageBand '11 and save it there. It will appear in the library in the "User Channel Strip Section" category.

Maybe you are looking for

  • How to set transceiver mode to 2-wire TXRDY Auto from Visual Basic

    I am using a PCMCIA-485 adapter to interface to some RS-485 sensors. The sensors are connected using a 2-wire interface. I have developed an application in Visual Basic to control the various sensors. However, the application is dependent on the PCMC

  • Error message 4850 when trying to burn a playlist to disc

    I have recently upgraded my laptop to a dell E6500, and have downloaded the latest version of itunes. Since I have had this new laptop, and new version of itunes, I have been unable to burn discs from playlists. It starts to write a track, and then i

  • Remove Attachments fails to leave notation of attachment removed

    In most e-mail programs, if you remove an attachment from any e-mail, in your Sent box, in your In box, wherever, the file or image is replaced with a notation: "appletree.jpg removed by John Smith at 8:30 a.m. on 9/25/09" It seems like under Snow Le

  • Cheating the Released date in order to be listed on top

    My book is in the iBookstore, just released this week. But if you search by "Released Date", it doesnt show up in the first 100 listings. The first 100+ listings are publishers who are cheating the release date, putting things like January 5, 2025, o

  • F.08- error Message no. GLT0002

    Dear all, i am getting error wile reversing document, at the time posting the document the g/l is not activated as open item managed, but after some time we have activated it and also document open item, now i am not able to reverse document getting