Using Desktop Filter IDs with WPC Content

Hi All-
I'm migrating our 7.0 WPC content to Portal 7.31 and have run into an issue with one of our roles. We have a desktop that uses Filter IDs to control the entry points. When I create a connection to a WPC area inside this role, and add the filter ID to the connection the WPC Area content does not show in the navigation. If I add a new folder to the role as an entry point with the filter ID, then add a WPC connection to that folder the folder shows in the navigation but the WPC content does not render. The error is "
Page not found. Refresh the page or try again later. If the problem persists, contact your Portal administrator for assistance.
Here are the scenarios I tried:
#1:
Role
>New connection to WPC Area (set as entry point and filter ID assigned)
[no navigation node gets displayed here]
#2:
Role
>New folder (set as entry point and filter ID assigned)
>>New WPC connection (not set as entry point)
[folder displays in navigation but errors on WPC content]
#3:
Role
>New folder (not set as entry point but filter ID assigned)
>>New connection to WPC Area (set as entry point and filter ID assigned)
[no navigation node gets displayed]
Can someone tell me how to accomplish using filter IDs with WPC content?
thanks in advance.
Tim

It turns out this has nothing to do with the FilterIDs. The fix is to assign end user permissions on the Area in Area Management. Once that is set the role that contains the filterID works as expected.

Similar Messages

  • Can I use multiple apple ids with iTunes Match?

    My family has multiple apple ids although we share many devices.  If we subscribe to iTunes Match, will it pull all the content from all the devices or just one apple id?

    iTunes Match is associated with one, and only one, iTunes Store account. To use iTM on multiple devices all those devices must be signed into the mobile iTunes Store with the same AppleID.

  • HT204053 Can I use two apple ids with 1 iTunes library ??

    Both myself and my partner have apple products phones iPads Apple TV ... Can we both have separate apple ids and still share the same library and photo stream??

    Yes, you can mingle content from multiple IDs in the same iTunes content library. You just need to authorize the computer to use content from each ID.

  • Re: not exists SQL using ! filter expression with a variable

    This is still not producing the correct result set in Kodo JDO 3.0.0RC4. I
    see the following SQL statement in the log.
    DEBUG ExecuteThread: '10' for queue: 'default' kodo.jdbc.SQL - <t 7720801,
    conn 5232795> [10 ms] executing prepstmnt 1654874 SELECT DISTINCT t0.pk,
    t0.JDOCLASS, t0.JDOVERSION, t0.AEndPoint, t0.AEndPointType, t0.DS0, t0.DS1,
    t0.DS2, t0.DS3, t0.DS4, t0.ZEndPoint, t0.ZEndPointType, t0.adminState,
    t0.creationDate, t0.speckey, t0.spectype, t0.description,
    t0.lastModifiedDate, t0.lastModifiedUserId, t0.lastupdate, t0.name, t0.note,
    t0.previousVersion, t0.resourceBusinessName, t0.signalType, t0.supporting,
    t0.direction, t0.validForEnd, t0.validForStart FROM dschannel t0 CROSS JOIN
    channelsegment t1 WHERE (NOT (t0.pk = t1.channel AND t0.supporting = ? AND
    (t1.validForEnd > ? OR t1.validForStart < ?))) [params=(String)
    101/DS3/LOC01/LOC02, (Timestamp) 2001-07-24 20:29:14.0, (Timestamp)
    2038-01-18 22:14:07.0]
    INFO ExecuteThread: '10' for queue: 'default' com.metasolv.oss.inventory -
    resultSet size=0
    It looks to me like the CROSS JOIN is not the right join to be using. ---
    unless I am doing something altogether incorrect in the JDO Query itself,
    which is highly likely.
    Ben
    "Ben Eng" <[email protected]> wrote in message news:...
    Using Kodo JDO 2.5.3, I am attempting to do queries of the following form:
    select * from dschannel as c
    where not exists (select pk from channelsegment as s
    where c.pk = s.channel and
    c.supporting = ? and
    (s.validForEnd > ? or
    s.validForStart < ?));
    select * from dschannel as c
    left join channelsegment as s
    on c.pk = s.channel and
    c.supporting = ? and
    (s.validForEnd > ? or
    s.validForStart < ?)
    where s.channel is null;
    The code looks like this:
    extent = pm.getExtent( ChannelValue.class, true );
    query = pm.newQuery( this.extent );
    query.declareImports( "import
    com.metasolv.resources.entity.connection.ChannelSegmentValueImpl; import
    java.util.Date;" );
    query.declareParameters( "String pConn, Date pStart, Date pEnd" );
    query.declareVariables( "ChannelSegmentValueImpl assign" );
    String filter = "! (key == assign.channel && supportingConnection == pConn
    && (assign.validForEnd > pStart || assign.validForStart < pEnd))";
    query.setFilter( filter );
    resultSet = (java.util.Collection) query.execute( connection,
    interval.getStartDateTime(), interval.getEndDateTime() );
    I am seeing the following Exception with mysql 4.0.15 and mysql connector
    JDBC driver 3.0.8:
    com.solarmetric.kodo.runtime.DataStoreException:
    com.solarmetric.kodo.impl.jdbc.sql.SQLExceptionWrapper:
    [SQL=SELECT DISTINCT t0.PK, t0.JDOCLASSX, t0.JDOLOCKX, t0.AEndPoint,
    t0.AEndPointType, t0.DS0, t0.DS1, t0.DS2, t0.DS3, t0.DS4, t0.ZEndPoint,
    t0.ZEndPointType, t0.adminState, t0.creationDate, t0.SPECKEY, t0.SPECTYPE,
    t0.description, t0.lastModifiedDate, t0.lastModifiedUserId, t0.LASTUPDATE,
    t0.name, t0.note, t0.previousVersion, t0.resourceBusinessName,
    t0.signalType, t0.supporting, t0.direction, t0.validForEnd,
    t0.validForStart> FROM DSChannel t0 LEFT OUTER JOIN ChannelSegment t1 WHERE NOT (t0.PK => t1.channel AND t0.supporting = '101/DS3/LOC01/LOC02' AND (t1.validForEnd >> {ts '2001-07-24 20:59:49.0' OR t1.validForStart < {ts '2038-01-18
    22:14:07.0'}))]
    [PRE=SELECT DISTINCT t0.PK, t0.JDOCLASSX, t0.JDOLOCKX, t0.AEndPoint,
    t0.AEndPointType, t0.DS0, t0.DS1, t0.DS2, t0.DS3, t0.DS4, t0.ZEndPoint,
    t0.ZEndPointType, t0.adminState, t0.creationDate, t0.SPECKEY, t0.SPECTYPE,
    t0.description, t0.lastModifiedDate, t0.lastModifiedUserId, t0.LASTUPDATE,
    t0.name, t0.note, t0.previousVersion, t0.resourceBusinessName,
    t0.signalType, t0.supporting, t0.direction, t0.validForEnd,
    t0.validForStart> FROM DSChannel t0 LEFT OUTER JOIN ChannelSegment t1 WHERE NOT (t0.PK => t1.channel AND t0.supporting = ? AND (t1.validForEnd > ? ORt1.validForStart> < ?))
    Syntax error or access violation, message from server: "You have an error
    in your SQL syntax. Check the manual that corresponds to your MySQLserver
    version for the right syntax to use near 'WHERE NOT (t0.PK = t1.channelAND
    t0.supporting = '101/DS3/LOC0" [code=1064;state=42000]
    NestedThrowables:
    com.solarmetric.kodo.impl.jdbc.sql.SQLExceptionWrapper:
    [SQL=SELECT DISTINCT t0.PK, t0.JDOCLASSX, t0.JDOLOCKX, t0.AEndPoint,
    t0.AEndPointType, t0.DS0, t0.DS1, t0.DS2, t0.DS3, t0.DS4, t0.ZEndPoint,
    t0.ZEndPointType, t0.adminState, t0.creationDate, t0.SPECKEY, t0.SPECTYPE,
    t0.description, t0.lastModifiedDate, t0.lastModifiedUserId, t0.LASTUPDATE,
    t0.name, t0.note, t0.previousVersion, t0.resourceBusinessName,
    t0.signalType, t0.supporting, t0.direction, t0.validForEnd,
    t0.validForStart> FROM DSChannel t0 LEFT OUTER JOIN ChannelSegment t1 WHERE NOT (t0.PK => t1.channel AND t0.supporting = '101/DS3/LOC01/LOC02' AND (t1.validForEnd >> {ts '2001-07-24 20:59:49.0' OR t1.validForStart < {ts '2038-01-18
    22:14:07.0'}))]
    [PRE=SELECT DISTINCT t0.PK, t0.JDOCLASSX, t0.JDOLOCKX, t0.AEndPoint,
    t0.AEndPointType, t0.DS0, t0.DS1, t0.DS2, t0.DS3, t0.DS4, t0.ZEndPoint,
    t0.ZEndPointType, t0.adminState, t0.creationDate, t0.SPECKEY, t0.SPECTYPE,
    t0.description, t0.lastModifiedDate, t0.lastModifiedUserId, t0.LASTUPDATE,
    t> 0.name, t0.note, t0.previousVersion, t0.resourceBusinessName,t0.signalType,> t0.supporting, t0.direction, t0.validForEnd, t0.validForStart FROMDSChannel> t0 LEFT OUTER JOIN ChannelSegment t1 WHERE NOT (t0.PK = t1.channel AND> t0.supporting = ? AND (t1.validForEnd > ? OR t1.validForStart < ?))
    Syntax error or access violation, message from server: "You have an error
    in your SQL syntax. Check the manual that corresponds to your MySQLserver
    version for the right syntax to use near 'WHERE NOT (t0.PK = t1.channelAND
    t0.supporting = '101/DS3/LOC0"
    at
    com.solarmetric.kodo.impl.jdbc.runtime.SQLExceptions.throwDataStore(SQLExcep
    tions.java:64)
    at
    com.solarmetric.kodo.impl.jdbc.runtime.JDBCStoreManager.executeQuery(JDBCSto
    reManager.java:1167)
    at
    com.solarmetric.kodo.impl.jdbc.query.JDBCQuery.executeQuery(JDBCQuery.java:1
    26)
    at
    com.solarmetric.kodo.query.QueryImpl$DatastoreQueryExecutor.executeQuery(Que
    ryImpl.java:1565)
    at
    com.solarmetric.kodo.query.QueryImpl$AggregateQueryExecutor.executeQuery(Que
    ryImpl.java:1401)
    at
    com.solarmetric.kodo.query.QueryImpl.executeQueryWithMap(QueryImpl.java:685)
    >
    atcom.solarmetric.kodo.query.QueryImpl.executeWithMap(QueryImpl.java:545)
    >
    at
    com.solarmetric.kodo.query.QueryImpl.executeWithArray(QueryImpl.java:531)
    at com.solarmetric.kodo.query.QueryImpl.execute(QueryImpl.java:513)
    at
    com.metasolv.resources.queries.ChannelAvailabilityQueryBean.execute(ChannelA
    vailabilityQueryBean.java:55)
    at
    com.metasolv.oss.inventory.InventorySessionBean.queryInventory(InventorySess
    ionBean.java:1343)
    at
    com.metasolv.oss.inventory.InventorySessionBean_xf0gis_EOImpl.queryInventory
    (InventorySessionBean_xf0gis_EOImpl.java:3998)
    at
    com.metasolv.oss.inventory.InventorySessionBean_xf0gis_EOImpl_WLSkel.invoke(
    Unknown Source)
    at weblogic.rmi.internal.BasicServerRef.invoke(BasicServerRef.java:362)
    at
    weblogic.rmi.cluster.ReplicaAwareServerRef.invoke(ReplicaAwareServerRef.java
    :114)
    at weblogic.rmi.internal.BasicServerRef$1.run(BasicServerRef.java:313)
    at
    weblogic.security.service.SecurityServiceManager.runAs(SecurityServiceManage
    r.java:821)
    at
    weblogic.rmi.internal.BasicServerRef.handleRequest(BasicServerRef.java:308)
    >
    at
    weblogic.rmi.internal.BasicExecuteRequest.execute(BasicExecuteRequest.java:3
    0)
    at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:213)
    at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:189)
    NestedThrowablesStackTrace:
    java.sql.SQLException: Syntax error or access violation, message from
    server: "You have an error in your SQL syntax. Check the manual that
    corresponds to your MySQL server version for the right syntax to use near
    'WHERE NOT (t0.PK = t1.channel AND t0.supporting = '101/DS3/LOC0"
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:1651)
    at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:889)
    at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:956)
    at com.mysql.jdbc.Connection.execSQL(Connection.java:1874)
    at
    com.mysql.jdbc.PreparedStatement.executeQuery(PreparedStatement.java:1538)
    at
    com.solarmetric.datasource.PreparedStatementWrapper.executeQuery(PreparedSta
    tementWrapper.java:93)
    at
    com.solarmetric.kodo.impl.jdbc.SQLExecutionManagerImpl.executePreparedQueryI
    nternal(SQLExecutionManagerImpl.java:707)
    at
    com.solarmetric.kodo.impl.jdbc.SQLExecutionManagerImpl.executeQueryInternal(
    SQLExecutionManagerImpl.java:600)
    at
    com.solarmetric.kodo.impl.jdbc.SQLExecutionManagerImpl.executeQuery(SQLExecu
    tionManagerImpl.java:355)
    at
    com.solarmetric.kodo.impl.jdbc.ormapping.ClassMapping.selectPrimaryMappings(
    ClassMapping.java:1743)
    at
    com.solarmetric.kodo.impl.jdbc.runtime.JDBCStoreManager.executeQuery(JDBCSto
    reManager.java:1136)
    at
    com.solarmetric.kodo.impl.jdbc.query.JDBCQuery.executeQuery(JDBCQuery.java:1
    26)
    at
    com.solarmetric.kodo.query.QueryImpl$DatastoreQueryExecutor.executeQuery(Que
    ryImpl.java:1565)
    at
    com.solarmetric.kodo.query.QueryImpl$AggregateQueryExecutor.executeQuery(Que
    ryImpl.java:1401)
    at
    com.solarmetric.kodo.query.QueryImpl.executeQueryWithMap(QueryImpl.java:685)
    >
    atcom.solarmetric.kodo.query.QueryImpl.executeWithMap(QueryImpl.java:545)
    >
    at
    com.solarmetric.kodo.query.QueryImpl.executeWithArray(QueryImpl.java:531)
    at com.solarmetric.kodo.query.QueryImpl.execute(QueryImpl.java:513)
    at
    com.metasolv.resources.queries.ChannelAvailabilityQueryBean.execute(ChannelA
    vailabilityQueryBean.java:55)
    at
    com.metasolv.oss.inventory.InventorySessionBean.queryInventory(InventorySess
    ionBean.java:1343)
    at
    com.metasolv.oss.inventory.InventorySessionBean_xf0gis_EOImpl.queryInventory
    (InventorySessionBean_xf0gis_EOImpl.java:3998)
    at
    com.metasolv.oss.inventory.InventorySessionBean_xf0gis_EOImpl_WLSkel.invoke(
    Unknown Source)
    at weblogic.rmi.internal.BasicServerRef.invoke(BasicServerRef.java:362)
    at
    weblogic.rmi.cluster.ReplicaAwareServerRef.invoke(ReplicaAwareServerRef.java
    :114)
    at weblogic.rmi.internal.BasicServerRef$1.run(BasicServerRef.java:313)
    at
    weblogic.security.service.SecurityServiceManager.runAs(SecurityServiceManage
    r.java:821)
    at
    weblogic.rmi.internal.BasicServerRef.handleRequest(BasicServerRef.java:308)
    >
    at
    weblogic.rmi.internal.BasicExecuteRequest.execute(BasicExecuteRequest.java:3
    0)
    at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:213)
    at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:189)
    INFO ExecuteThread: '10' for queue: 'default' com.metasolv.oss.inventory -
    ignoring exception
    javax.oss.IllegalArgumentException:
    com.solarmetric.kodo.runtime.DataStoreException:
    com.solarmetric.kodo.impl.jdbc.sql.SQLExceptionWrapper:
    [SQL=SELECT DISTINCT t0.PK, t0.JDOCLASSX, t0.JDOLOCKX, t0.AEndPoint,
    t0.AEndPointType, t0.DS0, t0.DS1, t0.DS2, t0.DS3, t0.DS4, t0.ZEndPoint,
    t0.ZEndPointType, t0.adminState, t0.creationDate, t0.SPECKEY, t0.SPECTYPE,
    t0.description, t0.lastModifiedDate, t0.lastModifiedUserId, t0.LASTUPDATE,
    t0.name, t0.note, t0.previousVersion, t0.resourceBusinessName,
    t0.signalType, t0.supporting, t0.direction, t0.validForEnd,
    t0.validForStart> FROM DSChannel t0 LEFT OUTER JOIN ChannelSegment t1 WHERE NOT (t0.PK => t1.channel AND t0.supporting = '101/DS3/LOC01/LOC02' AND (t1.validForEnd >> {ts '2001-07-24 20:59:49.0' OR t1.validForStart < {ts '2038-01-18
    22:14:07.0'}))]
    [PRE=SELECT DISTINCT t0.PK, t0.JDOCLASSX, t0.JDOLOCKX, t0.AEndPoint,
    t0.AEndPointType, t0.DS0, t0.DS1, t0.DS2, t0.DS3, t0.DS4, t0.ZEndPoint,
    t0.ZEndPointType, t0.adminState, t0.creationDate, t0.SPECKEY, t0.SPECTYPE,
    t0.description, t0.lastModifiedDate, t0.lastModifiedUserId, t0.LASTUPDATE,
    t0.name, t0.note, t0.previousVersion, t0.resourceBusinessName,
    t0.signalType, t0.supporting, t0.direction, t0.validForEnd,
    t0.validForStart> FROM DSChannel t0 LEFT OUTER JOIN ChannelSegment t1 WHERE NOT (t0.PK => t1.channel AND t0.supporting = ? AND (t1.validForEnd > ? ORt1.validForStart> < ?))
    Syntax error or access violation, message from server: "You have an error
    in your SQL syntax. Check the manual that corresponds to your MySQLserver
    version for the right syntax to use near 'WHERE NOT (t0.PK = t1.channelAND
    t0.supporting = '101/DS3/LOC0" [code=1064;state=42000]
    NestedThrowables:
    com.solarmetric.kodo.impl.jdbc.sql.SQLExceptionWrapper:
    [SQL=SELECT DISTINCT t0.PK, t0.JDOCLASSX, t0.JDOLOCKX, t0.AEndPoint,
    t0.AEndPointType, t0.DS0, t0.DS1, t0.DS2, t0.DS3, t0.DS4, t0.ZEndPoint,
    t0.ZEndPointType, t0.adminState, t0.creationDate, t0.SPECKEY, t0.SPECTYPE,
    t0.description, t0.lastModifiedDate, t0.lastModifiedUserId, t0.LASTUPDATE,
    t0.name, t0.note, t0.previousVersion, t0.resourceBusinessName,
    t0.signalType, t0.supporting, t0.direction, t0.validForEnd,
    t0.validForStart> FROM DSChannel t0 LEFT OUTER JOIN ChannelSegment t1 WHERE NOT (t0.PK => t1.channel AND t0.supporting = '101/DS3/LOC01/LOC02' AND (t1.validForEnd >> {ts '2001-07-24 20:59:49.0' OR t1.validForStart < {ts '2038-01-18
    22:14:07.0'}))]
    [PRE=SELECT DISTINCT t0.PK, t0.JDOCLASSX, t0.JDOLOCKX, t0.AEndPoint,
    t0.AEndPointType, t0.DS0, t0.DS1, t0.DS2, t0.DS3, t0.DS4, t0.ZEndPoint,
    t0.ZEndPointType, t0.adminState, t0.creationDate, t0.SPECKEY, t0.SPECTYPE,
    t0.description, t0.lastModifiedDate, t0.lastModifiedUserId, t0.LASTUPDATE,
    t0.name, t0.note, t0.previousVersion, t0.resourceBusinessName,
    t0.signalType, t0.supporting, t0.direction, t0.validForEnd,
    t0.validForStart> FROM DSChannel t0 LEFT OUTER JOIN ChannelSegment t1 WHERE NOT (t0.PK => t1.channel AND t0.supporting = ? AND (t1.validForEnd > ? ORt1.validForStart> < ?))
    Syntax error or access violation, message from server: "You have an error
    in your SQL syntax. Check the manual that corresponds to your MySQLserver
    version for the right syntax to use near 'WHERE NOT (t0.PK = t1.channelAND
    t0.supporting = '101/DS3/LOC0"
    at
    com.metasolv.resources.queries.ChannelAvailabilityQueryBean.execute(ChannelA
    vailabilityQueryBean.java:61)
    at
    com.metasolv.oss.inventory.InventorySessionBean.queryInventory(InventorySess
    ionBean.java:1343)
    at
    com.metasolv.oss.inventory.InventorySessionBean_xf0gis_EOImpl.queryInventory
    (InventorySessionBean_xf0gis_EOImpl.java:3998)
    at
    com.metasolv.oss.inventory.InventorySessionBean_xf0gis_EOImpl_WLSkel.invoke(
    Unknown Source)
    at weblogic.rmi.internal.BasicServerRef.invoke(BasicServerRef.java:362)
    at
    weblogic.rmi.cluster.ReplicaAwareServerRef.invoke(ReplicaAwareServerRef.java
    :114)
    at weblogic.rmi.internal.BasicServerRef$1.run(BasicServerRef.java:313)
    at
    weblogic.security.service.SecurityServiceManager.runAs(SecurityServiceManage
    r.java:821)
    at
    weblogic.rmi.internal.BasicServerRef.handleRequest(BasicServerRef.java:308)
    >
    at
    weblogic.rmi.internal.BasicExecuteRequest.execute(BasicExecuteRequest.java:3
    0)
    at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:213)
    at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:189)
    Ben

    Ben-
    Is the SQL statement that is being executed returning incorrect results,
    or is it causing an exception with the MySQL server?
    If the former, can you describe the results you are seeing? If the
    latter, can you post the stack trace?
    In article <[email protected]>, Ben Eng wrote:
    This is still not producing the correct result set in Kodo JDO 3.0.0RC4. I
    see the following SQL statement in the log.
    DEBUG ExecuteThread: '10' for queue: 'default' kodo.jdbc.SQL - <t 7720801,
    conn 5232795> [10 ms] executing prepstmnt 1654874 SELECT DISTINCT t0.pk,
    t0.JDOCLASS, t0.JDOVERSION, t0.AEndPoint, t0.AEndPointType, t0.DS0, t0.DS1,
    t0.DS2, t0.DS3, t0.DS4, t0.ZEndPoint, t0.ZEndPointType, t0.adminState,
    t0.creationDate, t0.speckey, t0.spectype, t0.description,
    t0.lastModifiedDate, t0.lastModifiedUserId, t0.lastupdate, t0.name, t0.note,
    t0.previousVersion, t0.resourceBusinessName, t0.signalType, t0.supporting,
    t0.direction, t0.validForEnd, t0.validForStart FROM dschannel t0 CROSS JOIN
    channelsegment t1 WHERE (NOT (t0.pk = t1.channel AND t0.supporting = ? AND
    (t1.validForEnd > ? OR t1.validForStart < ?))) [params=(String)
    101/DS3/LOC01/LOC02, (Timestamp) 2001-07-24 20:29:14.0, (Timestamp)
    2038-01-18 22:14:07.0]
    INFO ExecuteThread: '10' for queue: 'default' com.metasolv.oss.inventory -
    resultSet size=0
    It looks to me like the CROSS JOIN is not the right join to be using. ---
    unless I am doing something altogether incorrect in the JDO Query itself,
    which is highly likely.
    Ben
    "Ben Eng" <[email protected]> wrote in message news:...
    Using Kodo JDO 2.5.3, I am attempting to do queries of the following form:
    select * from dschannel as c
    where not exists (select pk from channelsegment as s
    where c.pk = s.channel and
    c.supporting = ? and
    (s.validForEnd > ? or
    s.validForStart < ?));
    select * from dschannel as c
    left join channelsegment as s
    on c.pk = s.channel and
    c.supporting = ? and
    (s.validForEnd > ? or
    s.validForStart < ?)
    where s.channel is null;
    The code looks like this:
    extent = pm.getExtent( ChannelValue.class, true );
    query = pm.newQuery( this.extent );
    query.declareImports( "import
    com.metasolv.resources.entity.connection.ChannelSegmentValueImpl; import
    java.util.Date;" );
    query.declareParameters( "String pConn, Date pStart, Date pEnd" );
    query.declareVariables( "ChannelSegmentValueImpl assign" );
    String filter = "! (key == assign.channel && supportingConnection == pConn
    && (assign.validForEnd > pStart || assign.validForStart < pEnd))";
    query.setFilter( filter );
    resultSet = (java.util.Collection) query.execute( connection,
    interval.getStartDateTime(), interval.getEndDateTime() );
    I am seeing the following Exception with mysql 4.0.15 and mysql connector
    JDBC driver 3.0.8:
    com.solarmetric.kodo.runtime.DataStoreException:
    com.solarmetric.kodo.impl.jdbc.sql.SQLExceptionWrapper:
    [SQL=SELECT DISTINCT t0.PK, t0.JDOCLASSX, t0.JDOLOCKX, t0.AEndPoint,
    t0.AEndPointType, t0.DS0, t0.DS1, t0.DS2, t0.DS3, t0.DS4, t0.ZEndPoint,
    t0.ZEndPointType, t0.adminState, t0.creationDate, t0.SPECKEY, t0.SPECTYPE,
    t0.description, t0.lastModifiedDate, t0.lastModifiedUserId, t0.LASTUPDATE,
    t0.name, t0.note, t0.previousVersion, t0.resourceBusinessName,
    t0.signalType, t0.supporting, t0.direction, t0.validForEnd,
    t0.validForStart>> FROM DSChannel t0 LEFT OUTER JOIN ChannelSegment t1 WHERE NOT (t0.PK =>> t1.channel AND t0.supporting = '101/DS3/LOC01/LOC02' AND (t1.validForEnd >>> {ts '2001-07-24 20:59:49.0' OR t1.validForStart < {ts '2038-01-18
    22:14:07.0'}))]
    [PRE=SELECT DISTINCT t0.PK, t0.JDOCLASSX, t0.JDOLOCKX, t0.AEndPoint,
    t0.AEndPointType, t0.DS0, t0.DS1, t0.DS2, t0.DS3, t0.DS4, t0.ZEndPoint,
    t0.ZEndPointType, t0.adminState, t0.creationDate, t0.SPECKEY, t0.SPECTYPE,
    t0.description, t0.lastModifiedDate, t0.lastModifiedUserId, t0.LASTUPDATE,
    t0.name, t0.note, t0.previousVersion, t0.resourceBusinessName,
    t0.signalType, t0.supporting, t0.direction, t0.validForEnd,
    t0.validForStart>> FROM DSChannel t0 LEFT OUTER JOIN ChannelSegment t1 WHERE NOT (t0.PK =>> t1.channel AND t0.supporting = ? AND (t1.validForEnd > ? OR> t1.validForStart>> < ?))
    Syntax error or access violation, message from server: "You have an error
    in your SQL syntax. Check the manual that corresponds to your MySQLserver
    version for the right syntax to use near 'WHERE NOT (t0.PK = t1.channelAND
    t0.supporting = '101/DS3/LOC0" [code=1064;state=42000]
    NestedThrowables:
    com.solarmetric.kodo.impl.jdbc.sql.SQLExceptionWrapper:
    [SQL=SELECT DISTINCT t0.PK, t0.JDOCLASSX, t0.JDOLOCKX, t0.AEndPoint,
    t0.AEndPointType, t0.DS0, t0.DS1, t0.DS2, t0.DS3, t0.DS4, t0.ZEndPoint,
    t0.ZEndPointType, t0.adminState, t0.creationDate, t0.SPECKEY, t0.SPECTYPE,
    t0.description, t0.lastModifiedDate, t0.lastModifiedUserId, t0.LASTUPDATE,
    t0.name, t0.note, t0.previousVersion, t0.resourceBusinessName,
    t0.signalType, t0.supporting, t0.direction, t0.validForEnd,
    t0.validForStart>> FROM DSChannel t0 LEFT OUTER JOIN ChannelSegment t1 WHERE NOT (t0.PK =>> t1.channel AND t0.supporting = '101/DS3/LOC01/LOC02' AND (t1.validForEnd >>> {ts '2001-07-24 20:59:49.0' OR t1.validForStart < {ts '2038-01-18
    22:14:07.0'}))]
    [PRE=SELECT DISTINCT t0.PK, t0.JDOCLASSX, t0.JDOLOCKX, t0.AEndPoint,
    t0.AEndPointType, t0.DS0, t0.DS1, t0.DS2, t0.DS3, t0.DS4, t0.ZEndPoint,
    t0.ZEndPointType, t0.adminState, t0.creationDate, t0.SPECKEY, t0.SPECTYPE,
    t0.description, t0.lastModifiedDate, t0.lastModifiedUserId, t0.LASTUPDATE,
    t>> 0.name, t0.note, t0.previousVersion, t0.resourceBusinessName,> t0.signalType,>> t0.supporting, t0.direction, t0.validForEnd, t0.validForStart FROM> DSChannel>> t0 LEFT OUTER JOIN ChannelSegment t1 WHERE NOT (t0.PK = t1.channel AND>> t0.supporting = ? AND (t1.validForEnd > ? OR t1.validForStart < ?))
    Syntax error or access violation, message from server: "You have an error
    in your SQL syntax. Check the manual that corresponds to your MySQLserver
    version for the right syntax to use near 'WHERE NOT (t0.PK = t1.channelAND
    t0.supporting = '101/DS3/LOC0"
    at
    com.solarmetric.kodo.impl.jdbc.runtime.SQLExceptions.throwDataStore(SQLExcep
    tions.java:64)
    at
    com.solarmetric.kodo.impl.jdbc.runtime.JDBCStoreManager.executeQuery(JDBCSto
    reManager.java:1167)
    at
    com.solarmetric.kodo.impl.jdbc.query.JDBCQuery.executeQuery(JDBCQuery.java:1
    26)
    at
    com.solarmetric.kodo.query.QueryImpl$DatastoreQueryExecutor.executeQuery(Que
    ryImpl.java:1565)
    at
    com.solarmetric.kodo.query.QueryImpl$AggregateQueryExecutor.executeQuery(Que
    ryImpl.java:1401)
    at
    com.solarmetric.kodo.query.QueryImpl.executeQueryWithMap(QueryImpl.java:685)
    atcom.solarmetric.kodo.query.QueryImpl.executeWithMap(QueryImpl.java:545)
    at
    com.solarmetric.kodo.query.QueryImpl.executeWithArray(QueryImpl.java:531)
    at com.solarmetric.kodo.query.QueryImpl.execute(QueryImpl.java:513)
    at
    com.metasolv.resources.queries.ChannelAvailabilityQueryBean.execute(ChannelA
    vailabilityQueryBean.java:55)
    at
    com.metasolv.oss.inventory.InventorySessionBean.queryInventory(InventorySess
    ionBean.java:1343)
    at
    com.metasolv.oss.inventory.InventorySessionBean_xf0gis_EOImpl.queryInventory
    (InventorySessionBean_xf0gis_EOImpl.java:3998)
    at
    com.metasolv.oss.inventory.InventorySessionBean_xf0gis_EOImpl_WLSkel.invoke(
    Unknown Source)
    at weblogic.rmi.internal.BasicServerRef.invoke(BasicServerRef.java:362)
    at
    weblogic.rmi.cluster.ReplicaAwareServerRef.invoke(ReplicaAwareServerRef.java
    :114)
    at weblogic.rmi.internal.BasicServerRef$1.run(BasicServerRef.java:313)
    at
    weblogic.security.service.SecurityServiceManager.runAs(SecurityServiceManage
    r.java:821)
    at
    weblogic.rmi.internal.BasicServerRef.handleRequest(BasicServerRef.java:308)
    at
    weblogic.rmi.internal.BasicExecuteRequest.execute(BasicExecuteRequest.java:3
    0)
    at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:213)
    at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:189)
    NestedThrowablesStackTrace:
    java.sql.SQLException: Syntax error or access violation, message from
    server: "You have an error in your SQL syntax. Check the manual that
    corresponds to your MySQL server version for the right syntax to use near
    'WHERE NOT (t0.PK = t1.channel AND t0.supporting = '101/DS3/LOC0"
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:1651)
    at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:889)
    at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:956)
    at com.mysql.jdbc.Connection.execSQL(Connection.java:1874)
    at
    com.mysql.jdbc.PreparedStatement.executeQuery(PreparedStatement.java:1538)
    at
    com.solarmetric.datasource.PreparedStatementWrapper.executeQuery(PreparedSta
    tementWrapper.java:93)
    at
    com.solarmetric.kodo.impl.jdbc.SQLExecutionManagerImpl.executePreparedQueryI
    nternal(SQLExecutionManagerImpl.java:707)
    at
    com.solarmetric.kodo.impl.jdbc.SQLExecutionManagerImpl.executeQueryInternal(
    SQLExecutionManagerImpl.java:600)
    at
    com.solarmetric.kodo.impl.jdbc.SQLExecutionManagerImpl.executeQuery(SQLExecu
    tionManagerImpl.java:355)
    at
    com.solarmetric.kodo.impl.jdbc.ormapping.ClassMapping.selectPrimaryMappings(
    ClassMapping.java:1743)
    at
    com.solarmetric.kodo.impl.jdbc.runtime.JDBCStoreManager.executeQuery(JDBCSto
    reManager.java:1136)
    at
    com.solarmetric.kodo.impl.jdbc.query.JDBCQuery.executeQuery(JDBCQuery.java:1
    26)
    at
    com.solarmetric.kodo.query.QueryImpl$DatastoreQueryExecutor.executeQuery(Que
    ryImpl.java:1565)
    at
    com.solarmetric.kodo.query.QueryImpl$AggregateQueryExecutor.executeQuery(Que
    ryImpl.java:1401)
    at
    com.solarmetric.kodo.query.QueryImpl.executeQueryWithMap(QueryImpl.java:685)
    atcom.solarmetric.kodo.query.QueryImpl.executeWithMap(QueryImpl.java:545)
    at
    com.solarmetric.kodo.query.QueryImpl.executeWithArray(QueryImpl.java:531)
    at com.solarmetric.kodo.query.QueryImpl.execute(QueryImpl.java:513)
    at
    com.metasolv.resources.queries.ChannelAvailabilityQueryBean.execute(ChannelA
    vailabilityQueryBean.java:55)
    at
    com.metasolv.oss.inventory.InventorySessionBean.queryInventory(InventorySess
    ionBean.java:1343)
    at
    com.metasolv.oss.inventory.InventorySessionBean_xf0gis_EOImpl.queryInventory
    (InventorySessionBean_xf0gis_EOImpl.java:3998)
    at
    com.metasolv.oss.inventory.InventorySessionBean_xf0gis_EOImpl_WLSkel.invoke(
    Unknown Source)
    at weblogic.rmi.internal.BasicServerRef.invoke(BasicServerRef.java:362)
    at
    weblogic.rmi.cluster.ReplicaAwareServerRef.invoke(ReplicaAwareServerRef.java
    :114)
    at weblogic.rmi.internal.BasicServerRef$1.run(BasicServerRef.java:313)
    at
    weblogic.security.service.SecurityServiceManager.runAs(SecurityServiceManage
    r.java:821)
    at
    weblogic.rmi.internal.BasicServerRef.handleRequest(BasicServerRef.java:308)
    at
    weblogic.rmi.internal.BasicExecuteRequest.execute(BasicExecuteRequest.java:3
    0)
    at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:213)
    at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:189)
    INFO ExecuteThread: '10' for queue: 'default' com.metasolv.oss.inventory -
    ignoring exception
    javax.oss.IllegalArgumentException:
    com.solarmetric.kodo.runtime.DataStoreException:
    com.solarmetric.kodo.impl.jdbc.sql.SQLExceptionWrapper:
    [SQL=SELECT DISTINCT t0.PK, t0.JDOCLASSX, t0.JDOLOCKX, t0.AEndPoint,
    t0.AEndPointType, t0.DS0, t0.DS1, t0.DS2, t0.DS3, t0.DS4, t0.ZEndPoint,
    t0.ZEndPointType, t0.adminState, t0.creationDate, t0.SPECKEY, t0.SPECTYPE,
    t0.description, t0.lastModifiedDate, t0.lastModifiedUserId, t0.LASTUPDATE,
    t0.name, t0.note, t0.previousVersion, t0.resourceBusinessName,
    t0.signalType, t0.supporting, t0.direction, t0.validForEnd,
    t0.validForStart>> FROM DSChannel t0 LEFT OUTER JOIN ChannelSegment t1 WHERE NOT (t0.PK =>> t1.channel AND t0.supporting = '101/DS3/LOC01/LOC02' AND (t1.validForEnd >>> {ts '2001-07-24 20:59:49.0' OR t1.validForStart < {ts '2038-01-18
    22:14:07.0'}))]
    [PRE=SELECT DISTINCT t0.PK, t0.JDOCLASSX, t0.JDOLOCKX, t0.AEndPoint,
    t0.AEndPointType, t0.DS0, t0.DS1, t0.DS2, t0.DS3, t0.DS4, t0.ZEndPoint,
    t0.ZEndPointType, t0.adminState, t0.creationDate, t0.SPECKEY, t0.SPECTYPE,
    t0.description, t0.lastModifiedDate, t0.lastModifiedUserId, t0.LASTUPDATE,
    t0.name, t0.note, t0.previousVersion, t0.resourceBusinessName,
    t0.signalType, t0.supporting, t0.direction, t0.validForEnd,
    t0.validForStart>> FROM DSChannel t0 LEFT OUTER JOIN ChannelSegment t1 WHERE NOT (t0.PK =>> t1.channel AND t0.supporting = ? AND (t1.validForEnd > ? OR> t1.validForStart>> < ?))
    Syntax error or access violation, message from server: "You have an error
    in your SQL syntax. Check the manual that corresponds to your MySQLserver
    version for the right syntax to use near 'WHERE NOT (t0.PK = t1.channelAND
    t0.supporting = '101/DS3/LOC0" [code=1064;state=42000]
    NestedThrowables:
    com.solarmetric.kodo.impl.jdbc.sql.SQLExceptionWrapper:
    [SQL=SELECT DISTINCT t0.PK, t0.JDOCLASSX, t0.JDOLOCKX, t0.AEndPoint,
    t0.AEndPointType, t0.DS0, t0.DS1, t0.DS2, t0.DS3, t0.DS4, t0.ZEndPoint,
    t0.ZEndPointType, t0.adminState, t0.creationDate, t0.SPECKEY, t0.SPECTYPE,
    t0.description, t0.lastModifiedDate, t0.lastModifiedUserId, t0.LASTUPDATE,
    t0.name, t0.note, t0.previousVersion, t0.resourceBusinessName,
    t0.signalType, t0.supporting, t0.direction, t0.validForEnd,
    t0.validForStart>> FROM DSChannel t0 LEFT OUTER JOIN ChannelSegment t1 WHERE NOT (t0.PK =>> t1.channel AND t0.supporting = '101/DS3/LOC01/LOC02' AND (t1.validForEnd >>> {ts '2001-07-24 20:59:49.0' OR t1.validForStart < {ts '2038-01-18
    22:14:07.0'}))]
    [PRE=SELECT DISTINCT t0.PK, t0.JDOCLASSX, t0.JDOLOCKX, t0.AEndPoint,
    t0.AEndPointType, t0.DS0, t0.DS1, t0.DS2, t0.DS3, t0.DS4, t0.ZEndPoint,
    t0.ZEndPointType, t0.adminState, t0.creationDate, t0.SPECKEY, t0.SPECTYPE,
    t0.description, t0.lastModifiedDate, t0.lastModifiedUserId, t0.LASTUPDATE,
    t0.name, t0.note, t0.previousVersion, t0.resourceBusinessName,
    t0.signalType, t0.supporting, t0.direction, t0.validForEnd,
    t0.validForStart>> FROM DSChannel t0 LEFT OUTER JOIN ChannelSegment t1 WHERE NOT (t0.PK =>> t1.channel AND t0.supporting = ? AND (t1.validForEnd > ? OR> t1.validForStart>> < ?))
    Syntax error or access violation, message from server: "You have an error
    in your SQL syntax. Check the manual that corresponds to your MySQLserver
    version for the right syntax to use near 'WHERE NOT (t0.PK = t1.channelAND
    t0.supporting = '101/DS3/LOC0"
    at
    com.metasolv.resources.queries.ChannelAvailabilityQueryBean.execute(ChannelA
    vailabilityQueryBean.java:61)
    at
    com.metasolv.oss.inventory.InventorySessionBean.queryInventory(InventorySess
    ionBean.java:1343)
    at
    com.metasolv.oss.inventory.InventorySessionBean_xf0gis_EOImpl.queryInventory
    (InventorySessionBean_xf0gis_EOImpl.java:3998)
    at
    com.metasolv.oss.inventory.InventorySessionBean_xf0gis_EOImpl_WLSkel.invoke(
    Unknown Source)
    at weblogic.rmi.internal.BasicServerRef.invoke(BasicServerRef.java:362)
    at
    weblogic.rmi.cluster.ReplicaAwareServerRef.invoke(ReplicaAwareServerRef.java
    :114)
    at weblogic.rmi.internal.BasicServerRef$1.run(BasicServerRef.java:313)
    at
    weblogic.security.service.SecurityServiceManager.runAs(SecurityServiceManage
    r.java:821)
    at
    weblogic.rmi.internal.BasicServerRef.handleRequest(BasicServerRef.java:308)
    at
    weblogic.rmi.internal.BasicExecuteRequest.execute(BasicExecuteRequest.java:3
    0)
    at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:213)
    at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:189)
    Ben
    Marc Prud'hommeaux [email protected]
    SolarMetric Inc. http://www.solarmetric.com

  • Make portal instance anonymous with WPC content

    Hello,
    We have portal instance running our intranet site. Currently we allow user to access this by login to it using LDAP authetication mechanism.
    Our plan is to make it Anonymous. But we also have Wep Page Composer content and for that we want user to login first before editing any page.
    So basically we want anonymous instance but allow login for editing WPC pages.
    We are using Portal 7.0 SP16.
    Thanks for your help/suggestion.
    regards,
    Jaish

    Hi,
    and where is the problem?
    You'll have anonymous content and the WPC role is only assigned to a user / group.
    br,
    Tobias

  • How to use ora:parseEscapedXML() Function with String Content

    Hello,
    I am receiving a ResponseMessage that returns a string, but the content of the string is actually XML. I have tried to use the ora:parseEscapedXML() function to parses the string (see XML Fragment below) to return structured XML data that can be assigned to typed BPEL variables. The documentation is very limited for this (I've looked in the Developer Guide draft that is available at the OraBPEL site).
    2 customer records from XML literal fragment copied from string result:
    <?xml version="1.0" encoding="ISO-8859-1"?>
    <recordset>
    <customer>
    <CustNum>AROUT</CustNum>
    <CustLName>Hardy</CustLName>
    <CustFname>Thomas</CustFname>
    <CustEmail>[email protected]</CustEmail>
    <CustAddress>120 Hanover Sq.</CustAddress>
    <CustCity>London</CustCity>
    <CustRegion></CustRegion>
    <CustPostalCode>WA1 1DP</CustPostalCode>
    <CustCountry>UK</CustCountry>
    </customer>
    <customer>
    <CustNum>BSBEV</CustNum>
    <CustLName>Ashworth</CustLName>
    <CustFname>Victoria</CustFname>
    <CustEmail>Victoria.Ashworth@B&apos;s.com</CustEmail>
    <CustAddress>Fauntleroy Circus</CustAddress>
    <CustCity>London</CustCity>
    <CustRegion></CustRegion>
    <CustPostalCode>EC2 5NT</CustPostalCode>
    <CustCountry>UK</CustCountry>
    </customer>
    The copy rule for assigning CustNum to accountnumber that fails:
    <copy>
    <from expression="ora:parseEscapedXML(bpws:getVariableData('DataService_OutputVariable','invokeSpecMsgReturn','/recordset/customer/CustNum'))"/>
    <to variable="outputVariable" part="payload" query="/client:QueryResult/client:customer/client:accountNumber"/>
    </copy>
    Any help would be greatly appreciated.
    Thanks,
    Sean

    Hello,
    I am attempting to provide more information in order to hopefully get some better guidance here.
    1) The BPEL process I built receives input from a client that is one of city name or region name or postal code or country name and returns a list of customer records with their AccountNumber, LastName, FirstName, Email, Address, City, Region, PostalCode and Country. The BPEL flow invokes a packaged integration Web Service that retuns the records in a string whose content is XML (see XML fragment below).
    2) The string content returned is vaiable based on the input (i.e. city name="London")
    Two customer records from XML literal fragment copied from string result:
    <?xml version="1.0" encoding="ISO-8859-1"?>
    <recordset>
    <customer>
    <CustNum>AROUT</CustNum>
    <CustLName>Hardy</CustLName>
    <CustFname>Thomas</CustFname>
    <CustEmail>[email protected]</CustEmail>
    <CustAddress>120 Hanover Sq.</CustAddress>
    <CustCity>London</CustCity>
    <CustRegion></CustRegion>
    <CustPostalCode>WA1 1DP</CustPostalCode>
    <CustCountry>UK</CustCountry>
    </customer>
    <customer>
    <CustNum>BSBEV</CustNum>
    <CustLName>Ashworth</CustLName>
    <CustFname>Victoria</CustFname>
    <CustEmail>Victoria.Ashworth@B&apos;s.com</CustEmail>
    <CustAddress>Fauntleroy Circus</CustAddress>
    <CustCity>London</CustCity>
    <CustRegion></CustRegion>
    <CustPostalCode>EC2 5NT</CustPostalCode>
    <CustCountry>UK</CustCountry>
    </customer>
    I want to <assign> each record from the packaged integration service result (the string whose content is XML) to a complexType variable defined within the BPEL Process WSDL (see example below).
    XML fragment from BPEL WSDL:
    <element name="QueryResult" type="client:recordType"/>>
    <complexType name="recordType">
    <sequence>
    <element name="customer" type="client:customerType" maxOccurs="unbounded"/>
    </sequence>
    </complexType>
    <complexType name="customerType">
    <sequence>
    <element name="accountNumber" type="string"/>
    <element name="lastName" type="string"/>      
    <element name="firstName" type="string"/>
    <element name="email" type="string"/>
    <element name="address" type="string"/>
    <element name="city" type="string"/>
    <element name="region" type="string"/>
    <element name="postalcode" type="string"/>
    <element name="country" type="string"/>
    </sequence>                         
    </complexType>
    I have read through the tutorial and reviwed the XPath Funtion example in the reference (C:\OraBPELPM_1\integration\bpelpm\orabpel\samples\references\XPathFunction), but I am stsill very unclear as to how to handle this. I would appreciate any and all help.
    Thanks,
    Sean

  • Two SharePoint server Farms using different configuration databases with same content DB's

    Hi everyone,
    I am having strange problem while cloning the environments for SharePoint 2007 farm. We cloned the WFE and DB servers with different names. When the configuration wizard has run pointing to the new DB server for complete the new FARM, The config is pointed
    to the new Database server but the content databases remains same as old. This makes the production and cloned sites pointed to the same content.
    How can this be possible to have a SharePoint farms with separate config DB's and same content DB's. Please advise and now the search service in the production is also broken.
    Thanks keshav,Share point Developer

    Hi,
    This is one reason  why you should always use SQL Aliases when configuring SharePoint 
    Stop the SharePoint Services, you can use Server Manager on the WFE
    From the command line
    Enter CLICONFG
    Highlight TCPIP, Click Enable
    Click on the Alias Tab, and Click Add
    Click the TCPIP Radio Button
    Enter the (Old Database Server Name) in the Server Alias Box
    Enter the (Cloned Database Server Name) Server Name in the Server Name Box
    Uncheck, Dynamically Assign
    Enter Port 1433, and Click OK. Make sure on your new SQL Server that you don't have an inbound rule blocking Port 1433.
    On the new Cloned Server WFE start the SharePoint Services
    Run IISReset
    On The WFE and the App Server. Start the SharePoint Services, you can use Server Manager
    I would normally test this by stopping the SQL Service on the Old Server and login to SharePoint on the Cloned Server...
    Cheers,
    -Ivan

  • Using Desktop 4.2 with torch 9800

    I'm looking at a new torch 9800.  I have to be able to use DM 4.2 because nothing newer will sync with "lotus Organizer 6.0" so I have two questions.
    1. Will I still be able to use DM 4.2 to sync with the torch 9800 from computer #1?
    2. Assuming I am still abe to use DM 4.2, can I also use DM 6 from another computer for other things?
    d

    According to this article, KB26181, there is an issue using DTM 5.0.1 and older wiht phones that were released with 6.0 as their initial OS.

  • Module processor enhancement with file content conversion

    Hi All,
      I have a bean (module processor) that converts the a PDF doc to text. I need to use the same bean with file content conversion. Module processor processing sequence is as follows:
    1) My Bean: localejbs/myBean
    2) Default: localejbs/CallSapAdapter (Bean for file content conversion).
    When I tried the same (myBean + File adapter with file content conversion) , it was not working as expected. But the same bean works fine with normal file adapter (myBean + File adapter without file content conversion).
    Couldn't figure out the reason. Please help.
    Regards,
    Ajay.

    As the content conversion of the file adapter is done before calling the customer module, it is not possible to use both.
    As workaround you can do the file content conversion with help of the MessageTransformBean. In the module chain you put the MessageTransformBean after your module.
    Note that the configuration of the MessageTransformBean has to be done like the J2SE sender file adapter:
    http://help.sap.com/saphelp_nw04/helpdata/en/0d/00453c91f37151e10000000a11402f/frameset.htm
    You find an example here:
    https://websmp206.sap-ag.de/~sapdownload/011000358700001186732005E/HowToConveModuleJMS.pdf
    Regards
    Stefan

  • Unable to create content properly in UCM 11G using validateStandard filter

    Hi All,
        We have used validateStandard filter to assign content id with 16 digits in UCM 10G and it worked well, we deployed this component in UCM 11G but it is not working properly. When we click on Check In button content is getting created and displaying  Check_In Confirmation with 16 digit Content ID, upon clicking on Content Info it is displaying the complete info page. When we try to search the content it is not displaying in search results, also when tried to export it using Archiver it is not creating batch file. When we see logs in View Server out put it is displaying
    Unable to lock content with dDocName: 6322932684534064
    File to be removed: D:/oracle/ucm/cs/oracle/ucm/cs/vault/~temp/6322932684534064_meta.htm
    Below is the code and its corresponding log after check In is performed
    trace("=====Set 16 digit random number as ContentId=====");
                 String contId = databinder.getLocal("dDocName");
                 trace("=====value of contId====="+ contId);
            if("".equals(contId))
            //trace("=====Inside ContentId generetion=====");
            int maxdigits = 16;
            StringBuilder result = new StringBuilder();
            Random r = new Random();
            for (int i = 0; i<maxdigits; i++)
            result.append(r.nextInt(10));
            databinder.putLocal("dDocName", result.toString());
            trace("=====Generated ContentId is====="+ result.toString());
    View Server O/P:
    =====Set 16 digit random number as ContentId=====
    =====value of contId=====001885
    =====Generated ContentId is=====6322932684534064
    >(internal)/6 07.08 15:09:28.273 IdcServer-968 Unable to lock content with dDocName: 6322932684534064
    >(internal)/6 07.08 15:09:29.476 IdcServer-968 File to be removed: D:/oracle/ucm/cs/oracle/ucm/cs/vault/~temp/6322932684534064_meta.htm
    Thanks,
    Ashok

    Its a bug. References BUG:16231709 - OBIA7964:ERROR WHILE CREATING DATA WAREHOUSE TABLES USING DAC 11G
    So far the workaround is to use one Container Name at a time when creating the Warehouse.
    If helps mark and update back

  • Content Query not producing results when using [Me] filter

    Hi
    I'm using a Content Query web part and I'm trying to show the most recent document modified by each site user by applying it across the site collection and using the Filter, Modified By [_Hidden] equals [Me]. However, this doesn't seem to work for any user
    - the web part is always blank. I have tried different combinations such changing equals to contains, and using the Modified By field etc - nothing gives me the correct results. If I instead take the [Me] out and instead use the "people chooser"
    and set to a specific person then I seem to get the results I would expect - however I cannot hard code a given user.
    Does anyone know how to use [Me] correctly?
    Thanks

    Hi  sjb500,
    According to your description, please take steps as below to meet your demand:
    With the page layout open in Design view, double-click the Content Query Web Part.
    In the Content Query Web Part dialog box, click the plus sign (+) next to Query to expand it.
    In the Source section, click Show items from all sites in this site collection.
    In List Type section, in the Show items from this list type, click Document Library.
    In the Content Type section, in the Show items of this content type group list, click Document
    Content Types.
    In the Content Type section, in the Show items of this content type list, click Document.
    In the Additional Filters section, under Show Items When, click Modified By [_Hidden] in
    the first box, click Is Equal To in the second box, and then click [Me].
    In the Content Query Web Part dialog box, click the plus sign (+) next to Presentation to expand it.
    In the Grouping and Sorting section, in the Sort items by list, click Modified
    and Select Show items in descending order.
    Click OK.
    Reference:http://office.microsoft.com/en-us/sharepoint-designer-help/display-data-from-multiple-lists-with-the-content-query-web-part-HA010174134.aspx
    [Me] is a variable that stands for the user who is currently viewing the page that contains the Content Query Web Part in the browser.
    Here is some scenarios using [Me] in Content Query Web Part:
    http://social.technet.microsoft.com/Forums/en-US/346ffbe6-d7ba-467e-b7f5-6d6e289677a1/user-tasks-web-part
    Please inform me freely if you have any questions.
    Thanks

  • How to Use and Filter Table contents after execution of Bapi

    Can anybody guide me how to Use and Filter the table Contents which i got after successful execution of a Bapi
    I used Component Controller in my Project
    Ex: My table contains Redundant data for a single column but i want to display the column contents with out Redundancy
    Name
    Raghu
    Raghu
    Raghu
    Debasish
    Debasish
    I want to filter the table contents and i want to display the table with out Redundancy
    and Even when i am using a Dropdown i selected a Column  from a Table as the values for that Dropdown  but that table is having redundant data and the same data is getting displayed in that Dropdown i want the Dropdown to display data with out redundancy
    Thanks

    I also got that problem recently and after debuging for a while I figured out, that it was resulting from an error in my table's model: When the model received new items to display I
    1.) Fired an delete event for the old items
    2.) Fired an insert event for the new items
    Problem was that when firing the delete event I didn't already assigned the new items to the model. Therefore it had still the old row count.
    Maybe you have also a faulty table model?...

  • Unable to refer to custom resource bundle in WPC content rendered with xslt

    Hi,
    I need to use the resource bundle messages inside WPC content.
    When rendered by standard xsl templates the  call to XSLTHelper class is done to retrieve message from the standard SAP resource bundle com.sap.nw.wpc.bundles.core.properties, like this:
    <xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
                         xmlns:wpc="com.sap.nw.wpc.km.service.editor.hslt.XsltHelperCore">
    <xsl:value-of select="wpc:getString([key defined in sap bundle], string(/document/@locale))"/>
    The problem is that helper class doesn't provide any API to use custom bundles.
    I tried to create xslt helper (including config in KM), but that didn't succeed neither. It would return with error NoClassDefFound.
    Could you please help on configuring xslt helper and registering it with xslt rendering engine for Web Page Composer? I could not find any how-to guides on xslt helpers for WPC.
    Thanks in advance.
    Ruslan

    Hi
    Did you find a solution?
    Christof

  • Really Slow web surfing through ZBF with IOS Content filter

    Edited: attached partial output of "sh policy-map type inspect zone-pair urlfilter"   
    Hey, all
    We have a 1921 router with IOS Content filter subscribsion and it is also configured as ZBF running latest IOS v15.1. End-user keep complaining about slow web surfing. I connected to network and tested myself and found intermittent surfing experience.
    For example, access to www.ibm.com or www.cnn.com hangs 7 times of 10 attempts and maybe only loads reasonablly quick in 1-2 time of the 3. This also affects the speed of download from websites.
    I have the case openned with Cisco TAC and CCIE checked my configure but nothing caught his eyes...
    I decide to post the issue here in case we both missed something:
    Current configuration : 18977 bytes
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname abc_1921
    boot-start-marker
    boot system flash:/c1900-universalk9-mz.SPA.151-4.M4.bin
    boot-end-marker
    aaa new-model
    aaa authentication login default local
    aaa authentication login NONE_LOGIN none
    aaa authorization exec default local
    aaa session-id common
    clock timezone AST -4 0
    clock summer-time ADT recurring 3 Sun Mar 2:00 2 Sun Nov 2:00
    no ipv6 cef
    ip source-route
    ip auth-proxy max-login-attempts 5
    ip admission max-login-attempts 5
    ip cef
    ip dhcp excluded-address 192.168.1.1 192.168.1.9
    ip dhcp excluded-address 192.168.1.111 192.168.1.254
    ip dhcp pool DHCPPOOL
    import all
    network 192.168.1.0 255.255.255.0
    domain-name abc.local
    dns-server 192.168.10.200 192.168.10.202
    netbios-name-server 4.2.2.4
    default-router 192.168.1.150
    option 202 ip 192.168.1.218
    lease 8
    ip domain name abc.locol
    ip name-server 8.8.8.8
    ip name-server 4.2.2.2
    ip port-map user-port-1 port tcp 5080
    ip port-map user-port-2 port tcp 3389
    ip inspect log drop-pkt
    multilink bundle-name authenticated
    parameter-map type inspect global
    log dropped-packets enable
    parameter-map type urlfpolicy trend cprepdenyregex0
    allow-mode on
    block-page message "The website you have accessed is blocked as per corporate policy"
    parameter-map type urlf-glob cpaddbnwlocparapermit2
    pattern www.alc.ca
    pattern www.espn.com
    pattern www.bestcarriers.com
    pattern www.gulfpacificseafood.com
    pattern www.lafermeblackriver.ca
    pattern 69.156.240.29
    pattern www.tyson.com
    pattern www.citybrewery.com
    pattern www.canadianbusinessdirectory.ca
    pattern www.homedepot.ca
    pattern ai.fmcsa.dot.gov
    pattern www.mtq.gouv.qc.ca
    pattern licenseinfo.oregon.gov
    pattern www.summitfoods.com
    pattern www.marine-atlantic.ca
    pattern www.larway.com
    pattern www.rtlmotor.ca
    pattern *.abc.com
    pattern *.kijiji.ca
    pattern *.linkedin.com
    pattern *.skype.com
    pattern toronto.bluejays.mlb.com
    pattern *.gstatic.com
    parameter-map type urlf-glob cpaddbnwlocparadeny3
    pattern www.facebook.com
    pattern www.radiofreecolorado.net
    pattern facebook.com
    pattern worldofwarcraft.com
    pattern identityunknown.net
    pattern static.break.com
    pattern lyris01.media.com
    pattern www.saltofreight.com
    pattern reality-check.com
    pattern reality-check.ca
    parameter-map type ooo global
    tcp reassembly timeout 5
    tcp reassembly queue length 128
    tcp reassembly memory limit 8192
    parameter-map type trend-global global-param-map
    cache-size maximum-memory 5000
    crypto pki token default removal timeout 0
    crypto pki trustpoint Equifax_Secure_CA
    revocation-check none
    crypto pki trustpoint NetworkSolutions_CA
    revocation-check none
    crypto pki trustpoint trps1_server
    revocation-check none
    crypto pki trustpoint TP-self-signed-3538579429
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-3538579429
    revocation-check none
    rsakeypair TP-self-signed-3538579429
    !! CERTIFICATE OMITED !!
    redundancy
    ip ssh version 2
    class-map type inspect match-any INCOMING_VPN_TRAFFIC_MAP
    match access-group name REMOTE_SITE_SUBNET
    class-map type inspect match-all PPTP_GRE_INSPECT_MAP
    match access-group name ALLOW_GRE
    class-map type inspect match-all INSPECT_SKINNY_MAP
    match protocol skinny
    class-map type inspect match-all INVALID_SOURCE_MAP
    match access-group name INVALID_SOURCE
    class-map type inspect match-all ALLOW_PING_MAP
    match protocol icmp
    class-map type urlfilter match-any cpaddbnwlocclasspermit2
    match  server-domain urlf-glob cpaddbnwlocparapermit2
    class-map type urlfilter match-any cpaddbnwlocclassdeny3
    match  server-domain urlf-glob cpaddbnwlocparadeny3
    class-map type urlfilter trend match-any cpcatdenyclass2
    class-map type inspect match-all cpinspectclass1
    match protocol http
    class-map type inspect match-any CUSTOMIZED_PROTOCOL_216
    match protocol citriximaclient
    match protocol ica
    match protocol http
    match protocol https
    class-map type inspect match-any INSPECT_SIP_MAP
    match protocol sip
    class-map type urlfilter trend match-any cptrendclasscatdeny1
    match  url category Abortion
    match  url category Activist-Groups
    match  url category Adult-Mature-Content
    match  url category Chat-Instant-Messaging
    match  url category Cult-Occult
    match  url category Cultural-Institutions
    match  url category Gambling
    match  url category Games
    match  url category Illegal-Drugs
    match  url category Illegal-Questionable
    match  url category Internet-Radio-and-TV
    match  url category Joke-Programs
    match  url category Military
    match  url category Nudity
    match  url category Pay-to-surf
    match  url category Peer-to-Peer
    match  url category Personals-Dating
    match  url category Pornography
    match  url category Proxy-Avoidance
    match  url category Sex-education
    match  url category Social-Networking
    match  url category Spam
    match  url category Tasteless
    match  url category Violence-hate-racism
    class-map type inspect match-any INSPECT_PROTOCOLS_MAP
    match protocol pptp
    match protocol dns
    match protocol ftp
    match protocol https
    match protocol imap
    match protocol pop3
    match protocol netshow
    match protocol shell
    match protocol realmedia
    match protocol rtsp
    match protocol smtp
    match protocol sql-net
    match protocol streamworks
    match protocol tftp
    match protocol vdolive
    match protocol tcp
    match protocol udp
    match protocol icmp
    class-map type urlfilter trend match-any cptrendclassrepdeny1
    match  url reputation ADWARE
    match  url reputation DIALER
    match  url reputation DISEASE-VECTOR
    match  url reputation HACKING
    match  url reputation PASSWORD-CRACKING-APPLICATIONS
    match  url reputation PHISHING
    match  url reputation POTENTIALLY-MALICIOUS-SOFTWARE
    match  url reputation SPYWARE
    match  url reputation VIRUS-ACCOMPLICE
    class-map type inspect match-all CUSTOMIZED_NAT_MAP_1
    match access-group name CUSTOMIZED_NAT_1
    match protocol user-port-1
    class-map type inspect match-all CUSTOMIZED_NAT_MAP_2
    match access-group name CUSTOMIZED_NAT_2
    match protocol user-port-2
    class-map type inspect match-any INSPECT_H323_MAP
    match protocol h323
    match protocol h323-nxg
    match protocol h323-annexe
    class-map type inspect match-all INSPECT_H225_MAP
    match protocol h225ras
    class-map type inspect match-all CUSTOMIZED_216_MAP
    match class-map CUSTOMIZED_PROTOCOL_216
    match access-group name CUSTOMIZED_NAT_216
    policy-map type inspect OUT-IN-INSPECT-POLICY
    class type inspect INCOMING_VPN_TRAFFIC_MAP
      inspect
    class type inspect PPTP_GRE_INSPECT_MAP
      pass
    class type inspect CUSTOMIZED_NAT_MAP_1
      inspect
    class type inspect CUSTOMIZED_NAT_MAP_2
      inspect
    class type inspect CUSTOMIZED_216_MAP
      inspect
    class class-default
      drop
    policy-map type inspect urlfilter cppolicymap-1
    description Default abc Policy Filter
    parameter type urlfpolicy trend cprepdenyregex0
    class type urlfilter cpaddbnwlocclasspermit2
      allow
    class type urlfilter cpaddbnwlocclassdeny3
      reset
      log
    class type urlfilter trend cptrendclasscatdeny1
      reset
      log
    class type urlfilter trend cptrendclassrepdeny1
      reset
      log
    policy-map type inspect IN-OUT-INSPECT-POLICY
    class type inspect cpinspectclass1
      inspect
      service-policy urlfilter cppolicymap-1
    class type inspect INSPECT_PROTOCOLS_MAP
      inspect
    class type inspect INVALID_SOURCE_MAP
      inspect
    class type inspect INSPECT_SIP_MAP
      inspect
    class type inspect ALLOW_PING_MAP
      inspect
    class type inspect INSPECT_SKINNY_MAP
      inspect
    class type inspect INSPECT_H225_MAP
      inspect
    class type inspect INSPECT_H323_MAP
      inspect
    class class-default
      drop
    zone security inside
    description INTERNAL_NETWORK
    zone security outside
    description PUBLIC_NETWORK
    zone-pair security INSIDE_2_OUTSIDE source inside destination outside
    service-policy type inspect IN-OUT-INSPECT-POLICY
    zone-pair security OUTSIDE_2_INSIDE source outside destination inside
    service-policy type inspect OUT-IN-INSPECT-POLICY
    crypto isakmp policy 10
    encr 3des
    authentication pre-share
    group 2
    crypto isakmp key password address 11.22.3.1
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec transform-set TunnelToCold esp-3des
    crypto map TunnelsToRemoteSites 10 ipsec-isakmp
    set peer 11.22.3.1
    set transform-set TunnelToCold
    match address TUNNEL_TRAFFIC2Cold
    interface Embedded-Service-Engine0/0
    no ip address
    shutdown
    interface GigabitEthernet0/0
    description OUTSIDE_INTERFACE
    ip address 1.1.1.186 255.255.255.248
    ip nat outside
    ip virtual-reassembly in
    zone-member security outside
    duplex full
    speed 1000
    crypto map TunnelsToRemoteSites
    crypto ipsec df-bit clear
    interface GigabitEthernet0/1
    description INSIDE_INTERFACE
    ip address 192.168.1.150 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    zone-member security inside
    duplex full
    speed 1000
    ip forward-protocol nd
    ip http server
    ip http access-class 10
    ip http authentication local
    ip http secure-server
    ip nat inside source static tcp 192.168.1.217 5080 interface GigabitEthernet0/0 5080
    ip nat inside source route-map NAT_MAP interface GigabitEthernet0/0 overload
    ip nat inside source static tcp 192.168.1.216 80 1.1.1.187 80 extendable
    ip nat inside source static tcp 192.168.1.216 443 1.1.1.187 443 extendable
    ip nat inside source static tcp 192.168.1.216 1494 1.1.1.187 1494 extendable
    ip nat inside source static tcp 192.168.1.216 2598 1.1.1.187 2598 extendable
    ip nat inside source static tcp 192.168.1.213 3389 1.1.1.187 3390 extendable
    ip nat inside source static tcp 192.168.1.216 5080 1.1.1.187 5080 extendable
    ip route 0.0.0.0 0.0.0.0 1.1.1.185
    ip access-list standard LINE_ACCESS_CONTROL
    permit 192.168.1.0 0.0.0.255
    ip access-list extended ALLOW_ESP_AH
    permit esp any any
    permit ahp any any
    ip access-list extended ALLOW_GRE
    permit gre any any
    ip access-list extended CUSTOMIZED_NAT_1
    permit ip any host 192.168.1.217
    permit ip any host 192.168.1.216
    ip access-list extended CUSTOMIZED_NAT_2
    permit ip any host 192.168.1.216
    permit ip any host 192.168.1.212
    permit ip any host 192.168.1.213
    ip access-list extended CUSTOMIZED_NAT_216
    permit ip any host 192.168.1.216
    ip access-list extended INVALID_SOURCE
    permit ip host 255.255.255.255 any
    permit ip 127.0.0.0 0.255.255.255 any
    ip access-list extended NAT_RULES
    deny   ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255
    deny   ip 192.168.1.0 0.0.0.255 192.168.3.0 0.0.0.255
    deny   ip 192.168.1.0 0.0.0.255 192.168.4.0 0.0.0.255
    deny   ip 192.168.1.0 0.0.0.255 192.168.5.0 0.0.0.255
    deny   ip 192.168.1.0 0.0.0.255 192.168.6.0 0.0.0.255
    deny   ip 192.168.1.0 0.0.0.255 192.168.7.0 0.0.0.255
    deny   ip 192.168.1.0 0.0.0.255 192.168.8.0 0.0.0.255
    deny   ip 192.168.1.0 0.0.0.255 192.168.9.0 0.0.0.255
    deny   ip 192.168.1.0 0.0.0.255 192.168.10.0 0.0.0.255
    permit ip 192.168.1.0 0.0.0.255 any
    ip access-list extended REMOTE_SITE_SUBNET
    permit ip 192.168.2.0 0.0.0.255 192.168.1.0 0.0.0.255
    permit ip 192.168.3.0 0.0.0.255 192.168.1.0 0.0.0.255
    permit ip 192.168.4.0 0.0.0.255 192.168.1.0 0.0.0.255
    permit ip 192.168.5.0 0.0.0.255 192.168.1.0 0.0.0.255
    permit ip 192.168.6.0 0.0.0.255 192.168.1.0 0.0.0.255
    permit ip 192.168.7.0 0.0.0.255 192.168.1.0 0.0.0.255
    permit ip 192.168.8.0 0.0.0.255 192.168.1.0 0.0.0.255
    permit ip 192.168.9.0 0.0.0.255 192.168.1.0 0.0.0.255
    permit ip 192.168.10.0 0.0.0.255 192.168.1.0 0.0.0.255
    ip access-list extended TUNNEL_TRAFFIC2ABM
    permit ip 192.168.1.0 0.0.0.255 192.168.10.0 0.0.0.255
    ip access-list extended TUNNEL_TRAFFIC2Bridgewater
    permit ip 192.168.1.0 0.0.0.255 192.168.8.0 0.0.0.255
    ip access-list extended TUNNEL_TRAFFIC2ColdbrookDispatch
    permit ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255
    ip access-list extended TUNNEL_TRAFFIC2ColdbrookETL
    permit ip 192.168.1.0 0.0.0.255 192.168.7.0 0.0.0.255
    ip access-list extended TUNNEL_TRAFFIC2ColdbrookTrailershop
    permit ip 192.168.1.0 0.0.0.255 192.168.3.0 0.0.0.255
    ip access-list extended TUNNEL_TRAFFIC2Moncton
    permit ip 192.168.1.0 0.0.0.255 192.168.6.0 0.0.0.255
    ip access-list extended TUNNEL_TRAFFIC2MountPearl
    permit ip 192.168.1.0 0.0.0.255 192.168.4.0 0.0.0.255
    ip access-list extended TUNNEL_TRAFFIC2Ontoria
    permit ip 192.168.1.0 0.0.0.255 192.168.5.0 0.0.0.255
    ip access-list extended WEB_TRAFFIC
    permit tcp 192.168.1.0 0.0.0.255 any eq www
    access-list 10 permit 192.168.1.0 0.0.0.255
    route-map NAT_MAP permit 10
    match ip address NAT_RULES
    snmp-server community 1publicl RO
    control-plane
    line con 0
    logging synchronous
    login authentication NONE_LOGIN
    line aux 0
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line vty 0 4
    access-class LINE_ACCESS_CONTROL in
    exec-timeout 30 0
    logging synchronous
    transport input all
    scheduler allocate 20000 1000
    ntp server 0.ca.pool.ntp.org prefer
    ntp server 1.ca.pool.ntp.org
    end

    Hi,
    I know this is for a different platform but have a look at this link:
    https://supportforums.cisco.com/thread/2089462
    Read through it to get some idea of the similarity, but in particular note the last entry almost a year after the original post.
    I too am having trouble with http inspection, if I do layers 3 & 4 inspection there is no issue whatsoever, but as soon as I enable layer 7 inspection then I have intermittent browsing issues.
    The easy solution here is to leave it at layers 3 & 4, which doesn't give you the flixibility to do cool things like blocking websites, IM, regex expression matching etc...  but in my opinion I just don't think these routers can handle it.
    It appears to be a hit and miss affair, and going on the last post from the above link, you might be better off in having the unit replaced under warranty.
    The alternative is wasting a lot of time and effort and impacting your users to get something up and running that in the end is so flaky that you have no confidence in the solution and you are then in a situation where ALL future issues users are facing MIGHT be because of this layer 7 inspection bug/hardware issue etc?
    I would recommend you use the router as a frontline firewall with inbound/outbound acl's (no inspection), and then invest a few $ in getting an ASA dedicated firewall (but that's just me )

  • I am unable to open encrypted emails using webmail and a CAC reader.  It says "content can't be displayed because the S/MIME control isn't available."  I'm using a Macbook Pro with 10.10 OS and have tried both Safari and Chrome.

    I am using a Macbook Pro with OS X Yosemite 10.10.2.  I am unable to open encrypted emails using webmail.  I have verified my certificates are loaded in the keychain for my military common access card while using a CAC reader.  When I try to view the message it gives me the error saying "content can't be displayed because the S/MIME control isn't available." 

    I am using a Macbook Pro with OS X Yosemite 10.10.2.  I am unable to open encrypted emails using webmail.  I have verified my certificates are loaded in the keychain for my military common access card while using a CAC reader.  When I try to view the message it gives me the error saying "content can't be displayed because the S/MIME control isn't available." 

Maybe you are looking for