Using FCoE connection to non Cisco switches

Hello,
does anyone know what port configuration needs to be configured on a Nexus switch that is connected to say Brocade switch or any other vendor that supports FCoE. I have created VLAN to VSAN mapping, i assume next step is to create a vfc device ? Since this is not connection to an initiator or a target but another FCoE capable switch, how do i need to configure this vfc ?  Any tips ?
Thanks

Hi,
Looks like from the document that you referenced that this switch runs in NPV mode for FCoE:
FCoE features
Fibre Channel over Ethernet (FCoE*)
FIP & FCoE packets are all forwarded when DCB is configured
* FCoE frames as defined by T11 Committee
So, I would configure the Cisco Nexus switch for FCoE and NPIV
Configure the Nexus 5000 for FCoE and NPIV
There are several procedures that are required in order to configure the Nexus 5000 for FCoE and NPIV:
    Enable Feature FCoE
    Enable N Port Identifier Virtualization (NPIV) on the Nexus 5000
    Enable Nexus 5000 Quality of Service (QoS) for FCoE
    Enable Link Layer Discovery Protocol (LLDP)
    Configure VLAN
    Configure VSAN
    Map the VLAN to VSAN
Example:
feature lldp
feature fcoe
feature npiv
interface vfc130
  bind interface Ethernet1/30
  switchport mode F
  no shutdown
interface Ethernet1/30
  switchport mode trunk
  switchport trunk allowed vlan 1,100
  spanning-tree port type edge trunk
vsan database
  vsan 100 interface vfc130
vlan 100
  fcoe vsan 100
Example of QOS:
 system qos
  service-policy type qos input fcoe-default-in-policy
  service-policy type queuing input fcoe-default-in-policy
  service-policy type queuing output fcoe-default-out-policy
  service-policy type network-qos fcoe-default-nq-policy
Best regards,
Jim

Similar Messages

  • WLC4402 connect to non-cisco switch?

    I have 2 WLC4402-50 connected to an Extreme Black Diamond chassis, using GLC-T. I have configured LAG on the controllers to support the number of AP's needed and I have configured the ports on the switch to use LaCP aggregation because that is what is available. Is this a supported configuration or do I just need to leave those ports as non-LaCP ports?

    just to help out anyone else using extreme, here is how I got it to work
    first I define the src-dst ip load sharing like this
    Switch#. configure sharing address-based L2_L3_CHK_SUM
    and then I configure sharing on the ports (the port number between the sharing and grouping is just the master port number for the share)
    Switch#. enable sharing 3:26 grouping 3:26, 3:56 algorithm address-based
    Switch#. enable sharing 3:28 grouping 3:28, 3:58 algorithm address-based
    and then I do the vlan config like
    Switch#. create vlan "Wireless"
    Switch#. configure vlan Wireless tag 250
    Switch#. config vlan "default" add ports 3:26, 3:28 untagged
    Switch#. config vlan "Wireless" add ports 3:26, 3:58 tag

  • Ce 500 non-cisco switch

    How should I configure the smartport on a catalyst express 500 switch if I am connecting a non-cisco switch like a small linksys. I dont think I can make the smartport a switch because it tries to trunk?? right??
    And if I leave it as a PC it complains abouting having to many devices connected to it.
    Would having it configured as something like an access point work??

    Now, I noticed something very odd, I kept the switch option selected on the port on the ce 500 that the linksys was plugged in to and the devices plugged in downstream behind the linksys all kept the correct VLAN assignment. Phones were in the voice vlan and PC's were in the data vlan. Does not really make sense to me how this is working??

  • Interconnecting cisco switches with non-cisco switches

    I need help concerning interconnecting two Cisco switches (3550’s) using a non-Cisco switch or hub on the LAN. I have noticed that the two Cisco switches connected using a non-Cisco switch are able to communicate well, however a PC connected to the non-Cisco switch/hub can not ping any device on the LAN. The non-Cisco device is a working one. When the two Cisco switches are connected using a Cisco switch, PCs connected to the interconnecting switch are able to ping. What’s the explanation? Please help.

    Building configuration...
    Current configuration : 3342 bytes
    ! No configuration change since last restart
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    clock timezone GMT -2
    ip subnet-zero
    ip rcmd rcp-enable
    ip rcmd remote-username cwuser
    spanning-tree mode pvst
    spanning-tree extend system-id
    interface FastEthernet0/1
    switchport mode dynamic desirable
    interface FastEthernet0/2
    switchport mode dynamic desirable
    interface FastEthernet0/3
    switchport mode dynamic desirable
    interface FastEthernet0/4
    switchport mode dynamic desirable
    interface FastEthernet0/5
    switchport mode dynamic desirable
    interface FastEthernet0/6
    switchport mode dynamic desirable
    interface FastEthernet0/7
    switchport mode dynamic desirable
    interface FastEthernet0/8
    switchport mode dynamic desirable
    interface FastEthernet0/9
    switchport mode dynamic desirable
    interface FastEthernet0/10
    switchport mode dynamic desirable
    interface FastEthernet0/11
    switchport mode dynamic desirable
    interface FastEthernet0/12
    switchport mode dynamic desirable
    interface FastEthernet0/13
    switchport mode dynamic desirable
    interface FastEthernet0/14
    switchport mode dynamic desirable
    interface FastEthernet0/15
    switchport mode dynamic desirable
    interface FastEthernet0/16
    switchport mode dynamic desirable
    interface FastEthernet0/17
    switchport mode dynamic desirable
    interface FastEthernet0/18
    switchport mode dynamic desirable
    interface FastEthernet0/19
    switchport mode dynamic desirable
    interface FastEthernet0/20
    switchport mode dynamic desirable
    interface FastEthernet0/21
    switchport mode dynamic desirable
    interface FastEthernet0/22
    switchport mode dynamic desirable
    interface FastEthernet0/23
    switchport mode dynamic desirable
    interface FastEthernet0/24
    switchport mode dynamic desirable
    interface GigabitEthernet0/1
    switchport mode dynamic desirable
    interface GigabitEthernet0/2
    switchport mode dynamic desirable
    interface Vlan1
    ip address
    ip default-gateway
    ip classless
    ip http server
    snmp-server community
    snmp-server community
    snmp-server location
    snmp-server system-shutdown
    snmp-server enable traps snmp authentication warmstart linkdown linkup coldstart
    snmp-server enable traps config
    snmp-server enable traps entity
    snmp-server enable traps flash insertion removal
    snmp-server enable traps bridge
    snmp-server enable traps stpx
    snmp-server enable traps rtr
    snmp-server enable traps port-security
    snmp-server enable traps vtp
    snmp-server enable traps vlancreate
    snmp-server enable traps vlandelete
    snmp-server enable traps envmon fan shutdown supply temperature status
    snmp-server enable traps MAC-Notification
    snmp-server enable traps hsrp
    snmp-server enable traps cluster
    snmp-server enable traps copy-config
    snmp-server enable traps syslog
    snmp-server enable traps vlan-membership
    line con 0
    line vty 0 4
    login
    line vty 5 15
    login
    ntp clock-period 17180064
    end

  • Non Cisco Switches

    Dear ALL,
    I am an IT Potfessional, Doing Network + . I have a questions:
    1) Do Non Cisco Switches have Access and Trunk ports. What i mean is do non cisco switches distinguish between ethernet prots as trunk and access.
    2) Do we need Cross talk cable for Connectine two non cisco switches preferably D-Link . Also How to interconnect a Cisco switch wioth non cisco switch.
    Regards
    Haseeb

    Disclaimer
    The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.
    Liability Disclaimer
    In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.
    Posting
    As Daniel noted "decent" switches, i.e. manageable and supporting VLANs, will generally support VLAN tagging ports using the 801.2q standard.  (NB: this standard allows VLAN tagging between different vendors.)  Switches that support VLANs will distinguish between untagged (edge) ports (e.g. Cisco access) and the tagged ports (e.g. a Cisco trunk), but as Daniel also noted, their terminology might be different.
    As Leo noted, many switches offer auto MDI/MDI-X.  Surprisingly, this feature was often seen on unmanageable switches before it was seen on manageable switches.  Also on older unmanageable switches, you might find a pair of physical ports that are the same logical port, one wired MDI and other wired MDI-X or you might find some button to change one port's MDI to/from MDI-X.  Such "special" ports are often the "uplink" port.  (NB: the purpose of the "uplink" port was to allow connecting it to another switch whether you had a straight through or cross over cable.)
    If you do have a switch supporting auto MDI/MDI-X, or one with the earlier physical MDI/MDI-X options, you only need one switch, not both with such a feature, to support either a straight through or cross over cable.  Of course, both switches might have such an option, which is fine too.  Only if both switches are "hard wired", you'll need a cross over cable for a switch to switch connection.

  • SIP 7960 to non-Cisco Switch

    Does anyone know if a 7960 (SIP) phone can connect to a non-Cisco switch and separate the Voice traffic from the access port traffic?
    I tried connecting a 7960 to a baystack 450T, configuring the switchport as a "tagged trunk", and then changing the Admin Vlan ID on the phone to the desired voice vlan. It looks as though the switch wants the access port traffic to be tagged as well.
    Any help would be greatly appreciated!
    Thanks,
    Darin

    Hi !
    You need to configure a 802.1q trunk on your non-cisco switch. The 802.1q native vlan should be the one the PC is in. The voice vlan will be tagged.
    Configure all parameters (like voice-vlan-id etc) on the phone manually (obviously CDP does not work). I have done it and it works fine (but i never tried on the switch you mentioned).
    Inline Power will also not work because the 7960 is not 802.3af compliant (yet).
    Mike

  • Passing Voice VLAN through a non-Cisco switch

    Hi All,
    Will a non-Cisco switch (no 802.1q support) that is putted beetween Cisco IP Telephone and Cisco Catalyst switch (which is configured with auxilary Voice Vlan) pass voice vlan frames and CDP?

    Any switch should pass on either ISL(which is cisco properitary and hence not supported on non-Cisco) or IEEE 802.1Q frames or else it cannot support voice vlan support . And non-Cisco switches do not support CDP as it is once again Cisco proprietary protocol.

  • Using 802.1X and non-Cisco IP Phones

    Hi there,
    Having some questions about an 802.1x/non-Cisco ip phone setup and was hoping to find some answers/user-experience with this setup.
    Main questions i'm facing:
    1) When using non-Cisco ip phones (eg Nortel or Siemens) and a previous authorized client connected behind this ip phone gets disconnected. What will this action do with the authorized state of 802.1X on the switch port? WIll it stay authorized until the reauth timer expires or does it reject communication from any other device?
    2) What about EAPOL-Logoff messages from the ip phone to the switch. Are these only used by Cisco phones when they experience a link-status change on data ports?
    Thanks for sharing your thoughts

    Overall, you need to try and deal with the fact that a machine can disappear from the network and the network may not know about it directly (i.e. Link doesn't go down).
    I have no idea what other phones do, but Cisco phones send an EAPOL-Logoff when something is unplugged. This lets the switch know directly, and 1X session start is torn down immediately, closing what would be a security hole.
    Fundamentally, re-auth is a workaround only, and this is not the reason to enable re-auth to begin with.
    If your phone doesn't send an EAPOL-Logoff in this case, the switch might be left thinking an attack is underway when someone else tries to plug in (with presumably a different MAC). You do NOT want this to occur.
    Hope this helps,

  • Stacking a non-Cisco Switch with a Catalyst Express 500 switch

    We are using a Cisco Catalyst Express 500 Ethernet switch and need to add another switch to get a few more ports. Is is possible to stack a Catalyst Express 500 Ethernet switch with a non-Cisco Ethernet switch. If so, is there any Cisco documentation telling how to do this?

    If by stack, you mean connect the two switches via Ethernet ports, yes you should be able to do that. Depending on the port capabilities of the switches, and whether they have any special uplink ports, you might need to use a different Ethernet connecting cable (cross-over vs. straight thru).

  • ISE web auth for non-cisco switch(D-link 3528)

    Is it possible to use ISE(inline posture node) to redirect the wired users to ISE guest portal ?
    And the wired users will get full network access after they pass the web auth.

    you can use ISE ln-line posture node with 3rd part switches
    RADIUS access device must supply the following RADIUS attributes:
        Calling-Station-Id (for MAC_ADDRESS)
        User-Name
        NAS-Port-Type
        RADIUS accounting message must have the Framed-IP-Address attribute
    VLAN, DACL features can be used  but again it depends on switch models let us know  specific switch  models . Certain advanced use cases, such as those that involve posture assessment, profiling, and web authentication, are not consistently available with non-Cisco devices or may provide limited functionality,

  • Find IP address/machine connected to a cisco switch port

    hello,
    I need to know which IP/device is connecetd to a cisco Switch port.
    I can get the mac-address of that switch port using sh mac-add command, but with the mac address how can i find that which ip belongs to this mac.
    is there way i can do this, i know i can do the other way meaning with IP i can find to which port its connected ,but dont know how to find this MAC to IP with switch without the need for additional tools

    Hey Anantha ,
    Hop u r doing good,
    If u dont know ip address of devices present on specific vlan and wanted to track end device ip address please try
    follow this below
    steps 1:ping it to brodcast ip address of subnet
    for ex
    R1--SW1--SW2--(H1
                                 --H2
    R1..1.1.1.1/24
    H1..1.1.1.2/24
    H2.1.1.1.3/24
    So u r brodacast ip is 1.1.1.255
    ping  1.1.1.255
    Sending 1000, 100-byte ICMP Echos to 1.1.1.255, timeout is 2 seconds:
    Reply to request 8 from 1.1.1.2, 28 ms
    Reply to request 9 from 1.1.1.3, 64 ms
    u will get reply from all host present on that segment and ur arp table will get flood with ip and respective mac on
    your L3 device...(R1 in this example)
    Step2: then u can use command
    sh ip arp ..to see ip and respective mac associate with it
    R1#sh ip arp
    Protocol  Address          Age (min)  Hardware Addr   Type   Interface
    Internet  1.1.1.1                 -   c000.2498.0000  ARPA   Vlan2
    Internet  1.1.1.2                 0   c003.2498.0000  ARPA   Vlan2
    Step3: see the mac learned from specific port
    R1#sh mac address c003.2498.0000
    Destination Address  Address Type  VLAN  Destination Port
    c003.2498.0000          Dynamic       2     FastEthernet1/1
    Step4:If  u have all cisco devices then u can use CDP
    to check wht device connect to ur interface
    R1#sh cdp ne fa1/1 detail
    Device ID: SW1.lab.local
    Follow this way, hop u will trace devices present on ur network
    Hop this informative,
    Regards,
    Ashish shirkar

  • What connection/cable could I buy to connect to my Cisco switch?

    I'm in a purchase project of a new Gigabit switch for my company.
    Currently my company has a "Catalyst 3560G-48TS". It has four additional ports called SFP that I supposed can be used to connect to another switch to constitute a sort of "backbone", right? I want to connect the current switch to the new one with as much transfer rate as possible. Ideally at least 5Gbps (yeah, if I use a single 1gbps cable, it's certainly not enough). Both switches will be separated at a distance of about 15m.
    I know nothing about this SFP. Could someone tell me what are supported or supporting this? What cables should I buy? Optical fibers? What's the transfer rate could I expect from EACH SFP port?
    Of course, I'm more interested to not so expensive solution, or at least a good quality/price ratio solution.
    Thanks in advance.

    SFP is a small form factor pluggable interface module (transceiver). The SFP port on the switch allows a user to insert a SFP module to meet the distance requirements between the interconnecting equipment.
    According to the 3860 datasheet, the SFP ports are 1Gbps. The ports can be outfitted with a copper-based SFP module (100m maximum distance) or optical modules (short reach and long-reach, with wavelength dependent options as well). The copper-based SFP uses standard CAT 5 cabling with RJ45s. The optical SFPs will use optical jumpers with LC-type connectors, either with single- or multi-mode types of fiber, depending on the selected SFP.
    The list of supported SFP modules is listed in the data sheet (link below).
    Your network could use the CAT5 copper module (probably the lowest cost).
    Hope this helps!
    3560 Data Sheet:
    http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps5528/product_data_sheet09186a00801f3d7d.html
    SFP Data Sheet
    http://www.cisco.com/en/US/prod/collateral/modules/ps5455/ps6577/product_data_sheet09186a008014cb5e.html

  • OID to find IP Address of devices connected to a Cisco Switch

    Hi All,
         Right now dot1dTpFdbPort(.1.3.6.1.2.1.17.4.3.1.2) OID is being used to find the mac address of the devices connected to a particular switch. It is being found out by passing the VLAN ID and dot1dTpFdbPort OID in the community string.(This is done using sharpsnmp , a C# Library). Is it possible to find the IP address of the devices connected to the switch in a similar manner?... Can specific OID be used for this purpose..
         When we have the mac address we can use ARP method to get the device IP but then is it possible to get the IP address using OID?
    Thanks in Advance.

    I generally use either
    WakeOnLan gives local network IP and MAC addresses
    <http://www.macupdate.com/info.php/id/15779/wakeonlan>
    or
    Bonjour Browser
    <http://www.macupdate.com/app/mac/13388/bonjour-browser>
    These utilities tend to show the devices on the network.

  • Connecting a managed Cisco switch to a smark Netgear switch via fiber

    I'm racking my brain about what the issue could be. Very basic configurations, one vlan, the link lights are up on the fiber connection but there is no activity. Below is the Cisco config and the Netgear has the default configurations on it.version 12.1no service padservice timestamps debug uptimeservice timestamps log uptimeno service password-encryption!hostname NewBldg!enable secret 5 $1$MD5t$bylDlzLn0TWDZRMt5Y1Ck.enable password ***!ip subnet-zero!vtp mode transparent!spanning-tree mode pvstno spanning-tree optimize bpdu transmissionspanning-tree extend system-id!!!!interface FastEthernet0/1 switchport mode access spanning-tree portfast!interface FastEthernet0/2 switchport mode access spanning-tree portfast!interface FastEthernet0/3 switchport mode access spanning-tree portfast!interface FastEthernet0/4 switchport mode access...
    This topic first appeared in the Spiceworks Community

    I found this link very useful for connecting another router with an existing working router .........

  • Can we use JCo connection with non-Web Dynpro J2EE project in NW

    With Web Dynpro, we have the RFC wizard to call RFCs using JCo connection.  I am wondering, if I create a J2EE project in NW development studio, can I and how to use JCo connection to call RFCs?
    Thanks.

    yes, of course.
    Add jar sapjco.jar then
    import com.sap.mw.jco.*;
    public class Bapi1 extends Object {
       JCO.Client mConnection;
       JCO.Repository mRepository;
       public Bapi1() {
          try {
             // Change the logon information to your own system/user
             mConnection =
                JCO.createClient("001", // SAP client
                  "<userid>", // userid
                  "****", // password
                  null, // language
                  "<hostname>", // application server host name
                  "00"); // system number
            mConnection.connect();
            mRepository = new JCO.Repository("SAPJCo", mConnection);
          catch (Exception ex) {
            ex.printStackTrace();
            System.exit(1);
          JCO.Function function = null;
          JCO.Table codes = null;
          try {
             function = this.createFunction("BAPI_COMPANYCODE_GETLIST");
             if (function == null) {
               System.out.println("BAPI_COMPANYCODE_GETLIST" +
                                  " not found in SAP.");
               System.exit(1);
             mConnection.execute(function);
             JCO.Structure returnStructure =
               function.getExportParameterList().getStructure("RETURN");
             if (! (returnStructure.getString("TYPE").equals("") ||
                    returnStructure.getString("TYPE").equals("S")) ) {
               System.out.println(returnStructure.getString("MESSAGE"));
               System.exit(1);
             codes =
               function.getTableParameterList().getTable("COMPANYCODE_LIST");
             for (int i = 0; i < codes.getNumRows(); i++) {
               codes.setRow(i);
               System.out.println(codes.getString("COMP_CODE") + '\t' +
                                  codes.getString("COMP_NAME"));
          catch (Exception ex) {
            ex.printStackTrace();
            System.exit(1);
          try {
            codes.firstRow();
            for (int i = 0; i < codes.getNumRows(); i++, codes.nextRow()) {
              function = this.createFunction("BAPI_COMPANYCODE_GETDETAIL");
              if (function == null) {
                System.out.println("BAPI_COMPANYCODE_GETDETAIL" +
                                   " not found in SAP.");
                System.exit(1);
         function.getImportParameterList().
           setValue(codes.getString("COMP_CODE"), "COMPANYCODEID");
         function.getExportParameterList().
           setActive(false, "COMPANYCODE_ADDRESS");
         mConnection.execute(function);
         JCO.Structure returnStructure =
           function.getExportParameterList().getStructure("RETURN");
         if (! (returnStructure.getString("TYPE").equals("") ||
                returnStructure.getString("TYPE").equals("S") ||
                returnStructure.getString("TYPE").equals("W")) ) {
            System.out.println(returnStructure.getString("MESSAGE"));
         JCO.Structure detail =
           function.getExportParameterList().
           getStructure("COMPANYCODE_DETAIL");
         System.out.println(detail.getString("COMP_CODE") + '\t' +
                            detail.getString("COUNTRY") + '\t' +
                            detail.getString("CITY"));
      catch (Exception ex) {
        ex.printStackTrace();
        System.exit(1);
      mConnection.disconnect();
    public JCO.Function createFunction(String name) throws Exception {
       try {
         IFunctionTemplate ft =
            mRepository.getFunctionTemplate(name.toUpperCase());
         if (ft == null)
           return null;
         return ft.getFunction();
       catch (Exception ex) {
         throw new Exception("Problem retrieving JCO.Function object.");
    public static void main (String args[]) {
       Bapi1 app = new Bapi1();
    Link: [http://help.sap.com/saphelp_nw04/helpdata/en/35/42e13d82fcfb34e10000000a114084/frameset.htm]

Maybe you are looking for

  • What is radix where it will be used.

    Hi All, Could you interpret this, this is in java.lang.Character class The maximum radix available for conversion to and from Strings. The largest maximum value that a radix can have is 36. As i know radix is base how can we construct a character or

  • Frustrating HDMI/HDCP issues with ATV and Onkyo receiver

    After two frustrating weeks of trouble shooting, I would like to share with you my situation. Two weeks ago I upgraded our living room HT to a new Onkyo TX-SR707 receiver and a new ATV (connected by HDI). The system includes a ComcastHD DVR (connecte

  • How can Tiger open Microsoft Word documents sent by e-mail?

    I recently upgraded to Tiger and use Appleworks 6, which is unable to read the Microsoft Word documents I frequently receive by e-mail. Is there any way I could read such documents, or should I get Microsoft Word? If so, which number/level would you

  • Is it possible to brust report using data template?

    I fail to do this with many trials. Can anyone give me a guide? Thank a lot!

  • Best Practice restart HyperV host with WinSrv 2012 R2 virtualized DC

    I would like to know if restarting a HyperV host with a virtual 2012 DC on it is supported with the standard Hyperv VM settings: Automatic Stop Option "Save the Virtual Machine state" Automatic Start Option "Automatically start if it was running when