Using non-standard libraries

Hi. I have an applet. It uses two libraries which arent in the standard jre/jdk. What do i have to do for java read them.
I packaged all .class to a jar file. And then, i try loading the applet. Everything seems to go fine, but when the code uses a class which is contained in that libraries, the applet crashed, giving me an error "NoClassDefFound". Exactly: "java.lang.NoClassDefFoundError: org/jdom/input/SAXBuilder". So what i do? Put .jar files on the same directory that the applet? It didnt work. What can i do? Im very confused.
This occurs if i run the applet on appletviewer.
On the other hand, if i try running applet on a website, i get another confusing error: "java.lang.NoClassDefFoundError: MyApplet" where MyApplet is the main class of my applet. I dont know why appletviewer show it, but the browser dont.

Hi,
You must have the org/jdom/input/SAXBuilder on your classpath for your jre to find it. You said you are using the Appletviewer, the best thing to do is get an integrated development environment. A great one to start with and completely free is Eclipse. This will sort out most of your problems in fact. If you are going to be doing a lot of Applets then Visual Age for Java (VAJ) fro IBM is very good for that sort of thing, I think you can get a community version for free, or get a trial version.
If you don't want to do that then you need to set your classpath, you'll have to check the documentation to see exactly how, and when you package your applet into a .jar file (it will be easirs that way) then put the extra libraries in with your applet. This way the necessary libraries get loaded along with your applet to the client browser. If you get MyApplet no class def found then the code base of the applet is wrong in the html page. Be kind to yourself get an IDE, sort all that out, no worrying about all that stuff that you don't need to worry about when you begin.
Here are the links
VAJ: http://www-106.ibm.com/developerworks/websphere/zones/vajava/
Eclipse: http://www.eclipse.org/downloads/index.php
See ya
Michael

Similar Messages

  • Isakmp peers using non-standard port 4500

    Hello,
    I have a remote site using the Internet to access corporate networks over IPSEC. Set-up is as below:
    Remote Router uses public IP across internet --> hits corporate untrusted nework FW --> NAT'ed to private 10.x.x.x IP --> reaches trusted network router.
    The problem is that the peer keeps hanging and the only way to reset it is to issue 'clear crypto session' on the central trusted router. I have added isakmp keepalives with the aim of forcing some keepalive traffic:
    crypto isakmp keepalive 90 30 periodic
    ...and this works to some degree (with DPD are u there keepalives). However I have noticed that the far end router uses non-standard ports when trying to set up phase-1 tunnel:
    BEVRLY_D_CR184_01#sh crypto isa pee
    Peer: 161.x.x.x Port: 4500 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10456 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10554 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10557 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10580 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10589 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10596 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10600 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    These ports (non-4500) will be blocked by our firewalls. Why does it use these, and is there a way of stopping the router using anything other than port 4500?
    Thanks
    Phil

    Hello,
    Yes - there's NAT at the trusted central router end our side of the firewall... the config used is below:
    Remote Router end:
    crypto isakmp policy 10
    encr 3des
    hash md5
    authentication pre-share
    group 2
    lifetime 180
    crypto isakmp key address
    crypto isakmp invalid-spi-recovery
    crypto isakmp keepalive 90 30 periodic
    crypto ipsec security-association idle-time 300
    crypto ipsec transform-set BEVERLEY_Transform esp-3des esp-md5-hmac
    crypto ipsec profile VTI
    set security-association lifetime seconds 1800
    set transform-set BEVERLEY_Transform
    interface Tunnel1
    description BEVRLY_CC296_01 F0/8 (10.30.45.29)
    ip address x.x.x.x 255.255.255.252
    ip helper-address 10.91.6.30
    ip helper-address 10.4.162.92
    ip mtu 1400
    ip ospf message-digest-key 1 md5
    load-interval 30
    tunnel source Dialer1
    tunnel destination
    tunnel mode ipsec ipv4
    tunnel protection ipsec profile VTI
    Central Router:
    crypto isakmp policy 10
    encr 3des
    hash md5
    authentication pre-share
    group 2
    lifetime 180
    crypto isakmp key address
    crypto isakmp invalid-spi-recovery
    crypto isakmp keepalive 90 30 periodic
    crypto ipsec security-association idle-time 300
    crypto ipsec transform-set BEVERLEY_Transform esp-3des esp-md5-hmac
    crypto ipsec profile VTI
    set security-association lifetime seconds 1800
    set transform-set BEVERLEY_Transform
    interface Tunnel1
    description link to Beverley via internet (BEVERLY_CR184_01 Tun1)
    ip address x.x.x.x 255.255.255.252
    ip mtu 1400
    ip ospf message-digest-key 1 md5
    load-interval 30
    tunnel source FastEthernet0/1
    tunnel destination
    tunnel mode ipsec ipv4
    tunnel protection ipsec profile VTI
    I believe the DPD keepalives ensure NAT is known and compatible (crypto isakmp keepalive 90 30 periodic) between the peers....
    Any help gladly appreciated....
    thanks
    Phil

  • CFHTTP GET using non-standard ports

    I have an application which goes out and checks links on
    various servers to verify that the link still exists, however I
    have a few links on servers that use non-standard ports (ie 8001,
    7072, 8080, etc). When I dump CFHTTP I get the following:
    struct
    Charset [empty string]
    ErrorDetail I/O Exception: Premature EOF encountered
    Filecontent Connection Failure
    Header [undefined struct element]
    Mimetype Unable to determine MIME type of file.
    Responseheader struct [empty]
    Statuscode Connection Failure. Status code unavailable.
    Text YES
    Any ideas?
    Thanks.
    Mike

    Yup, FaceTime was set up on all devices using my home network. It functions correctly pretty much everywhere except on my internal network at the office.
    I'm pretty sure this is a firewall issue, not a basic FaceTime problem.

  • Using non-standard sshd port after 10.8 upgrade

    After spending hours tracking down this solution as a result of losing my ssh settings after the upgrade to Mountain Lion, I thought it might be useful to post the steps taken to restore the configuration I used with Snow Leopard.
    Changing the sshd default listening port
    Disclaimer: This tutorial is specific to Mountain Lion (OS X 10.8). I was able to accomplish this using Snow Leopard (OS X 10.6) in fewer steps, but upgrading required this more involved solution. 
    Steps:
    1.) You must first enable the root user account in order to change the relevant files. This can be done from the terminal, or by going to System Preferences --> Users & Groups. Once there, click on 'Login Options' at the bottom of the Current User list, and 'Join' where it says 'Network Account Server'.
    This will bring up a smaller window. Click on 'Open Directory Utility' at the bottom. You will be prompted for your admin password. Now go to the 'Edit' tab at the top of the screen and toggle down to 'Enable Root User'.  You will be prompted to enter your admin password twice.
    2.) Log out of your regular user account. At the log in screen you will now see an additional entry for 'other'. Click on that and log in with the username 'root' and your admin password. If are inexperienced as a root-level user, be careful as you can cause problems to your system can be difficult to undo.
    Once in your root account, the first step is to create a new 'service definition' in the etc/services file. Open the file with text editor of choice and scroll to the current entry for sshd listening port, which will look like this:
    ssh    22/udp    # SSH Remote Login Protocol
    ssh    22/tcp     # SSH Remote Login Protocol
    Overwrite the '22' with the port number you would like sshd to listen on:
    ssh    12345/udp   # SSH Remote Login Protocol
    ssh    12345/tcp    # SSH Remote Login Protocol
    *12345 being our hypothetical, non-standard port.
    It is important to note that the new port number will not take by simply adding a new uncommented line to the file (I tried), unless of course you comment the original ssh entries. Easiest way is just to overwrite what is there already. Save changes.
    3.) You now need to edit the ssh.plist file, which is located at /System/Library/LaunchDaemons/ssh.plist. A word to those familiar with Linux/BSD environments: changing the default port in the sshd_config file, which exists in OS X, does NOT change the listening port. Simply changing the default port, saving the config file, and restarting the server (the sensible way) won't work. The OS X sshd server (openssh) is configured to get launch instructions from the ssh.plist file, as opposed to sshd_config. If you are more interested in this aspect of OS X, read up on LaunchDaemons (e.g. launchd).
    Before altering the ssh.plist file, you should save a backup copy in case of mistakes, or if you need to revert back to it in the future. Name your backup file something like original.ssh.plist, etc.
    In the ssh.plist file, locate the SocksServiceName entry and change it from the default:
    <key>SockServiceName</key>
    <string>ssh</string>
    To the following:
    <key>SockServiceName</key>
    <string>$alternate port number</string>
    In our example from above this value would be 12345.
    4.) Save your changes, and exit ssh.plist. You now need to move the backup file you created (original.ssh.plist) out of the System/Library/LaunchDaemons path.
    The updated sshd port will not take until you have only one ssh.plist file in the LaunchDaemons directory - this has to do with how launchd is configured to load files which is outside the scope of the current discussion.  (*If you've found a way around this, please share.) 
    5.) Restart the sshd server. Easiest way to accomplish this is going to System Preferences --> Sharing and clicking off 'Remote Login', then clicking back on it. 
    6.) Test the configuration by logging into the machine running the sshd server from another host using:
    ssh username@ipaddress -p 12345
    There are a few good tutorials out there that capture some of these steps, but many are dated and/or incomplete. If you are running a standard setup of OS X 10.8, this should work for you.
    Of course, don't be fooled into thinking that changing the default listening port from the ubiquitously-probed 22 equates to actual security. At best, it will cut down on the number of dubious connection attempts and probing.

    Hi all, above helped me change the sshd port number, thank you very much.
    Just upgraded to OS X 10.9.3 on my macbook pro.
    My findings were:
    Step 1(become a root user or sudo)
    Step 2 (/etc/services)
    This may not be required unless you want ssh to work without the "-p XXXX" option to connect to other ssh hosts.  I favor such as "ssh -p 2222 user@hostname" just to be sure I know what I am doing and also to leave ssh known port as its default "22".
    Step 3 (/System/Library/LaunchDaemons/ssh.plist)
    This is required if you want to change the sshd port number, I changed both "ssh" to "2222" in this file.
    Step 4 (launchctl)
    Below is a must as I understood:
    launchctl unload /System/Library/LaunchDaemons/ssh.plist
    launchctl load /System/Library/LaunchDaemons/ssh.plist
    it should be already working with the new port number.
    You can "ssh -p 2222 user@localhost" in the console terminal and see if its working.
    Since I am no expert on MacOS X, and it is a macbook pro that I am using, I also rebooted the system and changes were reflected permanantly.
    Thank you guys!

  • How to use non-standard port for vnc?

    Our Windows users who use RDC to connect to their desktops from off-site come in on a non-standard port number. Part of our security setup.
    I'd like to do the same with Mac users who use screen sharing and vnc to connect remotely.
    How can I specify another port number at both ends to accomplish this?
    I can find nothing in the Network Utility app, or in the KB.
    Surely there's a short sequence of Terminal commands that will do this?

    I haven't tried this so don't know whether it will work. But I think it will. Presuming the target machine is a Mac, see if editing its /etc/services file will do it. Find the two lines that start with "vnc-server" and change the port number there. Launch Terminal.app as an administratively privileged user, sudo pico /etc/services, ^w to search for vnc-server, make the changes, ^x to exit, y to save and overwrite. Also, you will need to have screen sharing enabled in the target machine's System Preferences' Sharing, and the authorized users defined there, too. Reboot. Now, on the remote client, assuming it is also a Mac, the user would type ⌘k in the Finder (or mouse to Finder > Go > Connect to Server), and enter something like vnc://123.45.67.89:55900 where you substitute the actual IP address or host name for where I have entered 123.45.67.89, and where you substitute the actual alternate port number where I have entered 55900. Of course, in the clients' Screen Sharing's Preferences, they should choose to encrypt the entire session, not just the login. Like I said, I haven't tried this because I just tunnel my vnc stuff through ssh, but I'm thinking that this should work.

  • CSS 11501 ftp server setup problem using non-standard port

    Dear Expert,
    we would like to setup FTP server over CSS where our member sever use non-std-port to open both control/data channel (i.e. 6370 as ctrl and 6369 as data this case.) but seems we only get Passive mode FTP mode work only but not for Active mode FTP case for data channel establishement for server back to client...is there any professional advise can help on this case...? here is our setup info FYI
    #  sh ver
    Version:               sg0820501 (08.20.5.01)
    Flash (Locked):        08.10.1.06
    Flash (Operational):   08.20.5.01
    Type:                  PRIMARY
    Licensed Cmd Set(s):   Standard Feature Set
                           Secure Management
    CVDM Version:          cvdm-css-1.0_K9
    !*************** Global
    ftp data-channel-timeout 10
      ftp non-standard-ports
    !************************** SERVICE **************************
    service ftp_ftpgtw
      keepalive maxfailure 2
      keepalive frequency 15
      keepalive retryperiod 2
      keepalive type tcp
      ip address 192.168.52.170
      protocol tcp
      keepalive port 6370
      port 6370
      active
    # sh run group drfusegtwftp_grp 
    !*************************** GROUP ***************************
    group gtwftp_grp
      vip address 192.168.52.28
      add service ftp_ftpgtw
      active
      content ftp_gtwpkg-ftpgtw
        add service ftp_ftpgtw
        vip address 192.168.52.28
        port 21
        protocol tcp
        application ftp-control
        active

    Thanks for your confirmation on no prob found in config level 1st..:P..as to save us a lot of time in isolating problem at this level.
    What we can notice is seems the data port connection is fail to open  for server back to client....for our general sense..... the flow expected should be:
    TCP session A -- Client:1234 --> VIP:21 --> member svr:6370
    TCP session B -- Client: 5678 <--> VIP:20 <--> member Svr: 6379 [on demand generated between server/client]
    but we can only see session B fail  to setup when client side access VIP site on CSS..even we try to put the most standard case as below
    TCP session A -- Client:1234 --> VIP:21 --> member svr:21
    TCP session B -- Client: 5678 <--> VIP:20 <--> member Svr: 20
    we still unable to make the Active mode FTP access work either...hence we got no idea on how CSS handle FTP access when it involve services over multiple tcp ports..
    and from CSS xlate view...the problem is we can only see what NAT IP that used in CSS connect to client...but no way to confirm for which port for VIP using outgoing to client. neither it is dropped by CSS..nor it is never setup from VIP to Client side.

  • Mailserver using non-standard smtp port

    how do i set SMTP to accept connections on a non-standard port (i.e. 2525 or something)?
    i'm running a mail server and my residential isp (comcast) after ten years of peaceful coexistence decided that they need to block port 25. so i am setting up a commercial store/forward mail relay service. all i need to do is set up my snow leopard server to accept incoming connections on a port other than 25. sounds easy. it is mentioned in the docs thusly:
    "By default SMTP is enabled on port 25. If port 25 is blocked in your environment,
    you need to change the port SMTP uses."
    ... but that's all i can find. specifically, it doesn't say exactly how to change the port.
    any help appreciated.

    following up to my own post. hoping this info may be useful for others who face the same issue who are running a server and then having email ports blocked by their ISP's.
    i worked around this by signing up for a mail relay service (i use the one provided by dnydns.com). they forward incoming mail for my domain over a nonstandard port.
    since i never received an answer to my question about how to make SnowLeopardServer email server accept SMTP connections on other ports, i simply used port mapping in my router (Airport Extreme) to redirect this port (i used 2525) on my WAN address to port 25 on my server - an acceptable workaround.
    i also did the same port redirection for the other "standard alternative" smtp ports, 465 and 587.
    since my ISP blocks port 25 in both directions, i also needed to find a work-around for outgoing mail as well. previously, my mail server simply forwarded to my ISP's smtp server (using the default port 25). here the Server Admin interface worked but with one "trick": under Mail>Settings>General, i left the box for "Relay outgoing mail through host:" checked, and in the field there i put "[smtp.myispdomain.net]:587" (that is with square brackets, and a colon, but no double-quotes - and of course, use your own smtp server's domain name). afaik this is not documented anywhere in the apple-provided docs, but i found the corresponding docs for postfix, and reverse-engineered it.
    so now i can read (via IMAP) and send (via SMTP) mail from my home server, both when i am on my LAN and when i am accessing remotely, and effectively work around the bi-directional block of port 25 imposed by my ISP.
    i'd still like to know if there is a method of configuring smtp to accept connections on ports other than 25. i can see how to do it by editing /etc/postfix/master.cf, but afaik that file gets overwritten by Server Admin...

  • Microsoft Websites using non-standard URL lengths to libraries causing firewall exceptions which prevent service usability

    Hi,
    Myself and
    other Microsoft customers have been experiencing a problem behind our corporate firewalls with accessing Microsoft services (Microsoft.com, most Microsoft Support pages, Microsoft Downloads, etc.). I previously had the same problem early August with SharePoint
    Online but that appears to have been corrected (at least for now).
    The symptom:
    Microsoft Webpage contents load but then the whole pages appear blank (in Chrome and IE 11). The body style is set to "visibility:hidden;".
    The cause:
    Many Microsoft websites use scripts/libraries from http://ots.optimize.webtrends.com and these particular URL's are extremely long and in a bizarre way. In this instance, it's sending Chrome and IE 11 webclients to a URL that is 3472 characters in length (that's
    over 3.3KB for just the URL) and the URL retrieves a JS function call that's 157 characters in length.
    Our corporate firewall is blocking HTTP GET requests to URL lengths greater than a particular length (to prevent infected web-clients from exploiting external web servers). I believe it's set to 2048 characters by default.
    The workaround:
    Set useragent string to IE 10 or lower. It doesn't serve pages that include such long URL lengths in these cases.
    Modify the style of the page in developer mode and set visibility:visible on the body. Works in IE or Chrome then.
    Convince IT to change our corporate firewall to ignore URL Path Length restrictions
    I'm convinced that this is a bug from Microsoft for many reasons: 
    Microsoft claims IE's maximum URL length is 2083 characters. See
    here.
    It's arguably poor form to be requiring kilobytes of data just to locate a resource(such as a .js file)
    It's wasting Microsoft's bandwidth. Using 3472 bytes to retrieve 157 bytes that run a function (in another .js file from MS) that sets the body style.
    It's preventing Microsoft customers that are using IE11 on Windows 7/8, who are behind firewalls that check URL Path Length's, from using Microsoft services.
    It does appear to serve content that is unique to the request but there's got to be a better way to accomplish whatever it is MS is actually trying to accomplish with the contents:
    WTOptimize.fireEvent(new WTEvent(WTEvent.CONTROL_PART, WTEvent.STATUS_SUCCESS, {control:"WT3VtgdmLPVOceeXKd8U15PFuYs7rn2UxwpN_67li21nuTEqahNZFhhiLz-KXk~"}));
    Is it trying to display the content on modern browsers only after the page has successfully loaded? I'm not sure, but that's what it's looking like to me.

    Hi,
    I do need more time to make test for your problem. Please be patient.
    Thanks for your understanding.
    Roger Lu
    TechNet Community Support

  • MSI, please stop using non-standard keyboard layouts.

    God dam it MSI, why do you insist on messing with layout of the bottom row of the keyboard?
    You get everything else right, but for some reason when it comes to the bottom row of keys you want to say "Industry standards? 20 years of tradition? Fack that, we're gonna move things around for no facking reason."
    Explain to me why you feel the need to put a superfluous "\" key on the keyboard to the right of the space bar. Nobody wanted that, nobody was asking for that, nobody needs that. Why the hell did you do that?
    Explain why the Menu key is missing in action.
    Explain why you put the Windows key on the wrong side. And while you're at it, explain why you thought this clusterfack of having that second "\" key there in combination with the missing menu key being not where it is on top of the Windows key being in the wrong place was a good idea.
    Bottom row of a standard keyboard layout goes like this:
    Ctrl, Fn, Alt, Win, Space bar, Alt, Win, Menu, Ctrl.
    MSI layout goes like.
    Ctrl, Fn, Alt Space Bar, \, Alt Gr, Win, Ctrl!
    WHY?!   
    MSI seems to think that having the keys in the right place so my fingers will know where they are without having to learn key placement all over again is a horrible idea. Instead they seem to think that my fingers should need to relearn the god dam keyboard all over again for no reason at all.
    But hey, at least the kept the numpad the same, right?
    GOD DAM IT MSI!
    Aparantly MSI logic works like this:
    Everyone uses the numpad.
    Nobody uses the trackpad to game.
    Delete that numpad that everyone uses, insert fancy trackpad that nobody will use.
    Profit?
    What the hell are you people smoking?
    Seriously, when is the last time you gamed on a PC with anything other than a mouse in your right* hand? Do you ever use the trackpad when you game? Ever? I own two laptops and I never, ever use the useless trackpad. I hate trackpads. First thing I do when I buy a new laptop? I plug in a mouse. Second thing I do? Disable the god dam trackpad.
    *Some left-handed use of mice can occur. See nearest lefties for details. May contain nuts. For external use only.

    I had a Gateway FX years ago that was a great laptop, but the "fn" key was at the bottom left instead of ctrl. I used that laptop for years and I was never able to become accustomed to it for gaming (group select ctrl+# ffs) or word processing, so I feel your pain.
    That being said, you should be able to re-bind your keys without any problem, and possibly pop off the keys themselves and move them to their new locations if they're the same size and you like that consistency. You can rebind via the registry, or certain bios, or w/ a third party application.
    The track pad is essential if you've got limited space and/or aren't a twitch gamer. For non-real time games, there is hardly any advantage to using a mouse over a good track pad.

  • Can I use Non-standard XSD Data Types in my XSD; if so how?

    Please help if you can, this is a complex question, so bear with me.
    Also note that I am in Livecycle 8.2 ES (not ES2 or higher).
    I am working on creating XSD schemas to map to form objects.
    I have created one master schema document that is wired into multiple forms, and I have one separate schema for reusable form objects, that I refer to as a "common node".
    All of my individual form schemas are brought together in this one Master Schema via the use of include statements.
    EXAMPLE: This is like my Master Schema
    <?xml version="1.0" encoding="UTF-8"?>
    <!--W3C Schema written by Benjamin P. Lyons - Twin Technologies July 2010-->
    <xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema" elementFormDefault="qualified" attributeFormDefault="unqualified" >
    <xs:include schemaLocation="./commonElementsNode.xsd" />
    <xs:include schemaLocation="./form1111.xsd" />
    <xs:include schemaLocation="./form2222.xsd" />
    <xs:include schemaLocation="./form3333.xsd" />
    <xs:element name="form">
    <xs:complexType>
      <xs:sequence>
       <xs:element ref="commonElementsNode" />
       <xs:element ref="form1111" />
       <xs:element ref="form2222" />
       <xs:element ref="form3333" />
      </xs:sequence>
    </xs:complexType>
    </xs:element>
    </xs:schema>
    This works fine.
    I can load this up in Designer in the Data View and everything appears in the Data View hierarchy correctly, with "form" as the top node.
    And as long as I use standard "xs:" data types - everything works great.  So if I go into LiveCycle Designer and I go to File --> Form Properties --> Preview --> Generate Preview Data and generate dummy XML data - it respects my XSD conventions.
    Now here is where the problem arises:
    In these schemas, I need to define the data types.
    The client I am working for needs me to use their data types.
    These data types are not standard xs: data types, like "xs:string" or "xs:date".
    Rather, the data types are ones that have been defined in other schemas and reserved to a namespace.
    For instance, rather than use xs:date I need to use something like:  "myns:DateType"
    This "myns:DateType" is defined as:
    <xs:complexType name="DateType">
      <xs:simpleContent>
       <xs:extension base="xs:date">
        <xs:attribute name="format" type="xs:string" use="optional">
         <xs:annotation>
          <xs:documentation xml:lang="en">
           <mydoc:Name>Date Format Text</mydoc:Name>
           <mydoc:Definition>The format of the date content</mydoc:Definition>
           <mydoc:PrimitiveType>string</mydoc:PrimitiveType>
          </xs:documentation>
         </xs:annotation>
        </xs:attribute>
       </xs:extension>
      </xs:simpleContent>
    </xs:complexType>
    Note that I have redacted this data type slightly and changed the namespace to protect the anonymity of my client, but we can assume that their data type is valid and currently in use with other systems.
    It conforms to W3 standards.
    Note also how this type is an enumeration of the base type "xs:date".
    This is defined in a schema called something like "MyCoreTypes.xsd"
    There is a namespace reservation in this file that looks something like this:
    <xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema" elementFormDefault="qualified" attributeFormDefault="unqualified"
    xmlns:myns="http://clinetname.com/schemas/mycoretypes" >
    So there is a name space reservation there.
    In my aforementioned "Master Schema" file, I have an include statement that looks like this:
    <xs:include namespace="http://clinetname.com/schemas/mycoretypes" schemaLocation="./MyCoreTypes.xsd" />
    (let's assume that the schema is in the same folder, as the Master Schema, so we can use the "./" relative path.)
    Now the problems is that in all my forms, where I have a myns:DateType (e.g.:  in form1111, a "Date of Birth" element that looks like this: <xs:element name="OwnerBirthDt" type="myns:DateType"/> ) the XSD is not respected when the XML dummy data is generated in LiveCycle Designer implying that the XSD's data types are not being recognized properly.
    Has anyone had this problem before?
    Is there a solution?
    Is it even possible to use these kind of include or import references in LiveCycle to define a data type other that the standard "xs:" data types?
    Please let me know - it would be greatly appreciated.
    I am more than willing to clarify the question further if others are willing to help.
    Thanks -
    Ben Lyons

    prf.kishorekumar wrote:
    i came here with a hope that I would definitely get some help.
    pls.. some one reply1) You got some help. No where do I see thanks or acknowledgment for the information given.
    2) Please remember that people on the forum help others voluntarily, it's not their job.
    3) Google can often help you here if the forum can't. Using Google I found this interesting link:
    http://today.java.net/pub/a/today/2004/05/24/html-pt1.html
    It discusses the Swing HTML EditorKit as well as some other free HTML renderers.
    Edited by: petes1234 on Oct 24, 2007 7:29 PM

  • FaceTime using non-standard ports?

    FaceTime will not work on my internal network. I can place a call from one iOS device to another, and the receiving device can connect...but the caller doesn't complete the connection.
    I've opened the ports on my firewall listed in Apple's KnowledgeBase article (http://support.apple.com/kb/ht4245):
    443 (TCP) - already open for HTTPS traffic
    3478 through 3497 (UDP)
    5223 (TCP) - already open for Apple Push Notification Service traffic
    16384 through 16387 (UDP)
    16393 through 16402 (UDP)
    In my WatchGuard Firebox firewall's logs, however, when I place a FaceTime call I'm seeing 3 packets blocked with destination ports in the 50000-60000 range - well outside the ranges Apple lists, for example:
    Deny     10.50.1.155     [outside]     49350/udp -> 59491
    Deny     10.50.1.155     [outside]     49351/udp -> 59491
    Deny     10.50.1.155     [outside]     21487/udp -> 59491
    or
    Deny     10.50.1.155     [outside]     25000/udp -> 60232
    Deny     10.50.1.155     [outside]     51137/udp -> 60232
    Deny     10.50.1.155     [outside]     51138/udp -> 60232
    or
    Deny     10.50.1.155     [outside]     27814/udp -> 59060
    Deny     10.50.1.155     [outside]     10839/udp -> 59060
    Deny     10.50.1.155     [outside]     10840/udp -> 59060
    As mentioned, I place the call, the receiver rings, the receiver answers and says "connecting...", but the caller keeps ringing.
    Any ideas?

    Yup, FaceTime was set up on all devices using my home network. It functions correctly pretty much everywhere except on my internal network at the office.
    I'm pretty sure this is a firewall issue, not a basic FaceTime problem.

  • IPSEC crypto peers using non-standard ports

    Hello,
    I have a remote site that is using port 4500 for within the isakmp phase of creating a IPSEC tunnel, but for some reason it is also using random port numbers constantly (in bold):
    BEVRLY_D_CR184_01#sh crypto isa peer
    Peer: x.x.x.x Port: 4500 Local: x.x.x.x
    Phase1 id: 10.2.0.92
    Peer: x.x.x.x Port: 10456 Local: x.x.x.x
    Phase1 id: 10.2.0.92
    Peer: x.x.x.x Port: 10554 Local: x.x.x.x
    Phase1 id: 10.2.0.92
    Peer: x.x.x.x Port: 10557 Local: x.x.x.x
    Phase1 id: 10.2.0.92
    Peer: x.x.x.x Port: 10580 Local: x.x.x.x
    Phase1 id: 10.2.0.92
    These are all blocked by the firewall when trying to communicate with our central router in the trusted network. The central router does not display the same symptoms, it only uses port 4500.
    Is there a way of preventing the remote router from using random port numbers and only allowed to use 4500??
    Thanks
    Phil

    Hello,
    Yes - there's NAT at the trusted central router end our side of the firewall... the config used is below:
    Remote Router end:
    crypto isakmp policy 10
    encr 3des
    hash md5
    authentication pre-share
    group 2
    lifetime 180
    crypto isakmp key address
    crypto isakmp invalid-spi-recovery
    crypto isakmp keepalive 90 30 periodic
    crypto ipsec security-association idle-time 300
    crypto ipsec transform-set BEVERLEY_Transform esp-3des esp-md5-hmac
    crypto ipsec profile VTI
    set security-association lifetime seconds 1800
    set transform-set BEVERLEY_Transform
    interface Tunnel1
    description BEVRLY_CC296_01 F0/8 (10.30.45.29)
    ip address x.x.x.x 255.255.255.252
    ip helper-address 10.91.6.30
    ip helper-address 10.4.162.92
    ip mtu 1400
    ip ospf message-digest-key 1 md5
    load-interval 30
    tunnel source Dialer1
    tunnel destination
    tunnel mode ipsec ipv4
    tunnel protection ipsec profile VTI
    Central Router:
    crypto isakmp policy 10
    encr 3des
    hash md5
    authentication pre-share
    group 2
    lifetime 180
    crypto isakmp key address
    crypto isakmp invalid-spi-recovery
    crypto isakmp keepalive 90 30 periodic
    crypto ipsec security-association idle-time 300
    crypto ipsec transform-set BEVERLEY_Transform esp-3des esp-md5-hmac
    crypto ipsec profile VTI
    set security-association lifetime seconds 1800
    set transform-set BEVERLEY_Transform
    interface Tunnel1
    description link to Beverley via internet (BEVERLY_CR184_01 Tun1)
    ip address x.x.x.x 255.255.255.252
    ip mtu 1400
    ip ospf message-digest-key 1 md5
    load-interval 30
    tunnel source FastEthernet0/1
    tunnel destination
    tunnel mode ipsec ipv4
    tunnel protection ipsec profile VTI
    I believe the DPD keepalives ensure NAT is known and compatible (crypto isakmp keepalive 90 30 periodic) between the peers....
    Any help gladly appreciated....
    thanks
    Phil

  • Anyone using non Apple ram with standard heatspreaders?

    Hi,
    Is anyone using non standard Apple ram with normal sized heatsink/heatspreaders and if so have you had any problems?
    I can find ram for the same spec that works but they only have the standard thin silver heatspreader attached and am concerned about running temps etc.
    If anyones using these modules without problems, please post here!
    Thanks.

    Might want to read this article and it has some good information to help you decide.

  • Non-standard Remote Desktop port - Outbound

    I am having problems using non-standard RDP  port from  the local network to the remote terminal server accepting requests only on port 32123  at the Internet.
    Example:  69.159.24.1:32123  
    Eveything working fine if i use  the direct connection to the internet OR the standard RDP port  (3389) through the Lynksys.
    When I try to go through the Linksys WRT300N v1.1 (latest firmware) client just times out.
    Any ideas ?

    Try to forward any specific range of the ports ..... & also check that Remote desktop setting is enabled or not ....

  • Non standard baudrate setting

    Dear All,
    I'm new in java programming and using Linux as my platform. Currently I want to connect some device with a non standard baudrate. Then something happens, everytime I set the baudrate in the code when I run it, the baudrate always changing into default baudrate (9600). Is there any other way to use non standard baudrate in Java?
    Regards

    Those standard baud rates don't just exist for the fun of it. Devices,
    especially simple devices, use a clock crystal to derive their baud rates.
    Even 'baud rate friendly clock crystals' exist for this very purpose.
    If you have to deal with a device that uses a non-standard baud rate,
    return it to the shop, complain and demand a 100% refund.
    kind regards,
    Jos

Maybe you are looking for