Webservice Client is not working in OIM 11gR2

Hi,
We have created a web client using Axis 1.6.2 and using it in OIM 11gR2 for Request Validator Plugin. But we are getting issue that org.apache.axiom.om.OMAbstractFactory. getOMFactory() is not found. When we checked the JARs in class path we found that OIM Already has lower version of axiom1.2.5 in its class path under oim.ear which doesn't contain this method however Axis1.6.2 contains the newer version which contain this method. Does anybody has any idea how to override OIM default classpath JAR file and force it to read the library files available under plugin?

Hi
I am facing similar issue but with Custom Adapter . I copied the axis jars under the JavaTasks folder but it does not help.
I then copied them under the oim.ear/APP_INF/lib and restarted the OIM managed server but somehow even that does not help.
I get following error.
Caused by: java.lang.NoSuchMethodError: org/apache/axiom/om/OMAbstractFactory.getMetaFactory()Lorg/apache/axiom/om/OMMetaFactory;
        at org.apache.axiom.om.OMXMLBuilderFactory.createOMBuilder(OMXMLBuilderFactory.java:150)
        at org.apache.axiom.om.OMXMLBuilderFactory.createOMBuilder(OMXMLBuilderFactory.java:133)
        at org.apache.axiom.om.OMXMLBuilderFactory.createOMBuilder(OMXMLBuilderFactory.java:104)
        at org.apache.axis2.util.XMLUtils.toOM(XMLUtils.java:590)
        at org.apache.axis2.util.XMLUtils.toOM(XMLUtils.java:575)
        at org.apache.axis2.deployment.DescriptionBuilder.buildOM(DescriptionBuilder.java:97)
        at org.apache.axis2.deployment.AxisConfigBuilder.populateConfig(AxisConfigBuilder.java:90)
        at org.apache.axis2.deployment.DeploymentEngine.populateAxisConfiguration(DeploymentEngine.java:857)
        at org.apache.axis2.deployment.FileSystemConfigurator.getAxisConfiguration(FileSystemConfigurator.java:116)
        at org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContext(ConfigurationContextFactory.java:64)
        at org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContextFromFileSystem(ConfigurationContextFactory.java:210)
        at org.apache.axis2.client.ServiceClient.configureServiceClient(ServiceClient.java:151)
Any pointer on how I can try to resolve it.
Regards
Abhinav

Similar Messages

  • Webservice client is not working for secured service

    Hi Experts,
    Currently i am facing issue when i try to access the secured webservice,
    I used jdeveloper 11.1.2.1.0 to create the webservice client proxy and found the following error if i invoke the service,
    I am using the following code to access the service,
    URL url = new URL(".", wsdl_url);
    MyService myservice = new MyService(url, new QName("urn:drs.test.com",
    "MyService"));
    myTester = myservice .getTester();
    Map<String, Object> reqContext = ((BindingProvider) myTester ).getRequestContext();
    reqContext.put(BindingProvider.USERNAME_PROPERTY, "user name");
    reqContext.put(BindingProvider.PASSWORD_PROPERTY, "password");
    May i know the reason for this issue?
    javax.wsdl.WSDLException: WSDLException: faultCode=INVALID_WSDL: Invalid XML in source with PublicId: null: oracle.xml.parser.v2.XMLParseException: Whitespace required.
         at oracle.j2ee.ws.wsdl.xml.WSDLReaderImpl.readWSDL(WSDLReaderImpl.java:344)
         at oracle.j2ee.ws.wsdl.xml.WSDLReaderImpl.readWSDL(WSDLReaderImpl.java:294)
         at oracle.j2ee.ws.wsdl.xml.WSDLReaderImpl.readWSDL(WSDLReaderImpl.java:278)
         at oracle.jdeveloper.webservices.wsdl.CachedWSDLReader.readWSDLInternal(CachedWSDLReader.java:531)
         at oracle.jdeveloper.webservices.wsdl.CachedWSDLReader.readWSDL(CachedWSDLReader.java:484)
         at oracle.jdeveloper.webservices.wsdl.CachedWSDLReader.readWSDL(CachedWSDLReader.java:455)
         at oracle.jdevimpl.webservices.wizard.jaxrpc.common.SpecifyWsdlPanel.fetchWSDL(SpecifyWsdlPanel.java:1050)
         at oracle.jdevimpl.webservices.wizard.jaxrpc.common.SpecifyWsdlPanel$1.run(SpecifyWsdlPanel.java:364)
         at oracle.ide.dialogs.ProgressBar.run(ProgressBar.java:655)
         at java.lang.Thread.run(Thread.java:662)
    Caused by: oracle.xml.parser.v2.XMLParseException: Whitespace required.
         at oracle.xml.parser.v2.XMLError.flushErrors1(XMLError.java:323)
         at oracle.xml.parser.v2.XMLReader.scanQuotedString(XMLReader.java:1831)
         at oracle.xml.parser.v2.XMLReader.scanQuotedString(XMLReader.java:1939)
         at oracle.xml.parser.v2.NonValidatingParser.parseDoctypeDecl(NonValidatingParser.java:489)
         at oracle.xml.parser.v2.NonValidatingParser.parseProlog(NonValidatingParser.java:363)
         at oracle.xml.parser.v2.NonValidatingParser.parseDocument(NonValidatingParser.java:321)
         at oracle.xml.parser.v2.XMLParser.parse(XMLParser.java:226)
         at oracle.xml.jaxp.JXDocumentBuilder.parse(JXDocumentBuilder.java:155)
         at oracle.j2ee.ws.wsdl.xml.WSDLReaderImpl.readWSDL(WSDLReaderImpl.java:337)

    Hi
    I am facing similar issue but with Custom Adapter . I copied the axis jars under the JavaTasks folder but it does not help.
    I then copied them under the oim.ear/APP_INF/lib and restarted the OIM managed server but somehow even that does not help.
    I get following error.
    Caused by: java.lang.NoSuchMethodError: org/apache/axiom/om/OMAbstractFactory.getMetaFactory()Lorg/apache/axiom/om/OMMetaFactory;
            at org.apache.axiom.om.OMXMLBuilderFactory.createOMBuilder(OMXMLBuilderFactory.java:150)
            at org.apache.axiom.om.OMXMLBuilderFactory.createOMBuilder(OMXMLBuilderFactory.java:133)
            at org.apache.axiom.om.OMXMLBuilderFactory.createOMBuilder(OMXMLBuilderFactory.java:104)
            at org.apache.axis2.util.XMLUtils.toOM(XMLUtils.java:590)
            at org.apache.axis2.util.XMLUtils.toOM(XMLUtils.java:575)
            at org.apache.axis2.deployment.DescriptionBuilder.buildOM(DescriptionBuilder.java:97)
            at org.apache.axis2.deployment.AxisConfigBuilder.populateConfig(AxisConfigBuilder.java:90)
            at org.apache.axis2.deployment.DeploymentEngine.populateAxisConfiguration(DeploymentEngine.java:857)
            at org.apache.axis2.deployment.FileSystemConfigurator.getAxisConfiguration(FileSystemConfigurator.java:116)
            at org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContext(ConfigurationContextFactory.java:64)
            at org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContextFromFileSystem(ConfigurationContextFactory.java:210)
            at org.apache.axis2.client.ServiceClient.configureServiceClient(ServiceClient.java:151)
    Any pointer on how I can try to resolve it.
    Regards
    Abhinav

  • Process Trigger is not working in OIM 11gR2

    Hi Experts,
    The Lookup.USR_PROCESS_TRIGGERS is not working. Assigned some process task on user attribute changes but it is not working as of now. Earlier it was working fine. Even I am not able to update the existing lookup value in Lookup.USR_PROCESS_TRIGGERS as we are getting below errror:
    The security level for this data item indicates that it cannot be updated.
    We are not able to figure out what is the issue behind this. might be some sandbox issue or some database value problem.
    Please provide me pointer to solve my problem.
    Thanks,

    Select LKV.LKV_DATA_LEVEL from LKU LKU, LKV LKV where LKU.LKU_KEY = LKV.LKU_KEY AND LKU.LKU_TYPE_STRING_KEY='Lookup.USR_PROCESS_TRIGGERS'
    If it is 1, make it 0 and try again. No need to change it for OOTB tasks/rows.

  • BPC 7.5 Admin Client Links Not Working

    I am working in BPC 7.5 SP15 NW. I have recently upgraded to Windows 7 64-bit and now the links in the action pane in the desktop admin client are not working.  The cursor does not change from the nornal pointer to the hand.  That would indicate that the admin client is no longer recognizing them as links.  The links work fine in the desktop Excel client.  I am using 32-bit Excel 2010 with no other version of Office installed.
    Has anyone heard of this behavior and how to correct for it?

    Hi Kannan,
    i think this is a Osoft web site configuration issue, the error indicates that you have one duplicate section in the web site configuration file (web.config).
    If you didn't alter the web.config file then the problem may occur because when you use framework 4.0, the machine config already has some of the sections defined that were used in previous ASP.NEt versions.
    You should check which version of the MS Framework is configured for the application pool of the web site, change it to v2.
    Let me know if this solves the issue. Or if you need more help to resolve it.
    Kindest regards,

  • [solved] NFS client will not work correctly

    I have all my $HOME on an NFS Server. So long I used suse and debian, now I want switch to arch but the nfs-client ist not working correctly:
    I start "portmap nfslock nfsd netfs" over rc.conf. When I do a "rpcinfo -p <ip-arch-system>" I got the following
    stefan:/home/stefan # rpcinfo -p 192.168.123.3
       Program Vers Proto   Port
        100000    2   tcp    111  portmapper
        100000    2   udp    111  portmapper
        100021    1   udp  32768  nlockmgr
        100021    3   udp  32768  nlockmgr
        100021    4   udp  32768  nlockmgr
        100003    2   udp   2049  nfs
        100003    3   udp   2049  nfs
        100003    4   udp   2049  nfs
        100021    1   tcp  48988  nlockmgr
        100021    3   tcp  48988  nlockmgr
        100021    4   tcp  48988  nlockmgr
        100003    2   tcp   2049  nfs
        100003    3   tcp   2049  nfs
        100003    4   tcp   2049  nfs
        100005    3   udp    891  mountd
        100005    3   tcp    894  mountd
    As you see "status" is missing, so the statd is not running. It sould look like the result on my suse box:
    stefan:/home/stefan # rpcinfo -p 192.168.123.2
       Program Vers Proto   Port
        100000    2   tcp    111  portmapper
        100000    2   udp    111  portmapper
        100024    1   udp  32768  status
        100021    1   udp  32768  nlockmgr
        100021    3   udp  32768  nlockmgr
        100021    4   udp  32768  nlockmgr
        100024    1   tcp  35804  status
        100021    1   tcp  35804  nlockmgr
        100021    3   tcp  35804  nlockmgr
        100021    4   tcp  35804  nlockmgr
    There is the "status" line and so the statd is running.
    How can I fix that problem, so that statd ist running on my arch box too?
    Last edited by stka (2007-06-10 15:59:48)

    The Problem ist solved.
    I use ldap for authentication. During the setup of the ldapclient I copied the nsswitch.ldap to nsswitch.conf. But the line for "hosts:" was:
    hosts:          dns ldap
    but in my dns ist no localhost entry. After I changed this line to:
    hosts:          files dns ldap
    everything was ok. The statd is now running and I can start to migrate to archlinux ;-)

  • Flex 4, Webservice client doesn't work after publishing in a web.

    Hi,
    I have a webservice written using gSoap and c.
    I'm using Flex 4 as a client to this webserivce.
    They both hosted on a same server and under the same domain.
    Flex client works fine under both debug and release builds running locally on my development PC.
    If I copy a relese build to www - webservice stops working.
    "onLoad" event never fires.
    After calling any method of mx:Webservice nothing happends, not "result" nor "fault".
    I didn't receive any error messages or other hints.
    Any help's suggested.
    Thanks.

    AUUUGH! Same issue for me.
    I try testing in the simulator and I can skip ahead or back to previous menus... but once I burn the project to a physical DVD, I get the "NOT PERMITTED" warning when I try to skip a story or go back. I basically have to wait. All buttons except SELECT and MENU are disabled.
    WHAT THE #&$% IS GOING ON...???
    I am in DVDSP 4.1.2 on a MacPro.
    This is URGENT. My client is coming TOMORROW to get the changes and I cannot get them to be controlled...!!!

  • Logout does not work in OIM after enabling OAM SSO

    We have installed a webgate to protect xlWebApp in OIM. Once the SSO is enabled, the logout does not work in the OIM user interface. How to solve this issue?
    Metalink has a solution where we need to add document.location="http://host:port/access/oblix/lang/en-us/logout.html"; in xlWebApp\tiles\tjspLogoffTiles.jsp. This is the logout URL of OAM. Is there any other way so we can have a logout page in the OIM application/server itself?
    Thanks.

    Kevin,
    I did what you suggested and initially it looked like it is working but there is slight issue. When I click Logout, it redirects to the logout screen. After logging out when I try to access xlWebApp it prompts for the login (i am using basic authentication). If I cancel it and again try to access xlWebApp, it lets me in without any prompt. This issue is in IE only but not in Firefox. Not sure what's the issue.
    Btw, to make the logout screen work, I had to unprotect the following with None Authentication:
    - /xlWebApp/pages/logout.html      (logout page)
    - /xlWebApp/images
    - /xlWebApp/css/Xellerate.css
    - /xlWebApp/css/style.css
    Thanks.
    Edited by: user504421 on Mar 16, 2009 9:52 AM
    Edited by: user504421 on Mar 16, 2009 10:00 AM
    Edited by: user504421 on Mar 16, 2009 10:01 AM

  • Connect a Client Computer Not Working At All

    I have a new Windows 7 clean install with updates that is not able to connect to SBS 2011 at all.
    In the past (about 2 years ago) I ran into the same problem and by following the simple steps outlined here - http://blog.ronnypot.nl/?p=594 - it worked no problem. Now it does not help at all.
    For a test, I took a spare machine and did a clean install of SBS 2011, applied the updates (except NET 4.5.1). When I tried to connect the new Windows 7 machine to the new SBS 2011 machine - this also has failed.

    Server's ipconfig /all
    Windows IP Configuration
       Host Name . . . . . . . . . . . . : BLAH-1
       Primary Dns Suffix  . . . . . . . : BLAH.local
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : Yes
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : BLAH.local
    Ethernet adapter Local Area Connection:
       Connection-specific DNS Suffix  . : BLAH.local
       Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Controller
       Physical Address. . . . . . . . . : REMOVED
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : REMOVED (Preferred)
       Link-local IPv6 Address . . . . . : REMOVED (Preferred)
       Link-local IPv6 Address . . . . . : REMOVED (Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.1.12(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : REMOVED
                                           192.168.1.1
       DHCPv6 IAID . . . . . . . . . . . : REMOVED
       DHCPv6 Client DUID. . . . . . . . : REMOVED
       DNS Servers . . . . . . . . . . . : REMOVED
                                           192.168.1.12
       NetBIOS over Tcpip. . . . . . . . : Enabled
       Connection-specific DNS Suffix Search List :
                                           BLAH.local
    Tunnel adapter isatap.{REMOVED}:
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : BLAH.local
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    Tunnel adapter Teredo Tunneling Pseudo-Interface:
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    Workstation's ipconifg /all
    Windows IP Configuration
       Host Name . . . . . . . . . . . . : BLAH-1
       Primary Dns Suffix  . . . . . . . : BLAH.local
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : Yes
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : BLAH.local
    Ethernet adapter Local Area Connection:
       Connection-specific DNS Suffix  . : aspa2.local
       Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Controller
       Physical Address. . . . . . . . . : REMOVED
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : REMOVED (Preferred)
       Link-local IPv6 Address . . . . . : REMOVED (Preferred)
       Link-local IPv6 Address . . . . . : REMOVED (Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.1.12(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : REMOVED
                                           192.168.1.1
       DHCPv6 IAID . . . . . . . . . . . : REMOVED
       DHCPv6 Client DUID. . . . . . . . : REMOVED
       DNS Servers . . . . . . . . . . . : REMOVED
                                           192.168.1.12
       NetBIOS over Tcpip. . . . . . . . : Enabled
       Connection-specific DNS Suffix Search List :
                                           BLAH.local
    Tunnel adapter isatap.{REMOVED}:
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : BLAH.local
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    Tunnel adapter Teredo Tunneling Pseudo-Interface:
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    HCI3 - I tried the steps you have listed and it did not work.

  • Self Registration and Attestation is not working in OIM 9.1.0.4

    Hi,
    i have setup a new OIM environment using OC4J. I am able to create users and provision IT resource but self registration and attestation is not working. not sure it is OC4J issue or OIM issue. For self registration it says request is submitted but when I login as xelsysadm and dlon't see any pending request and same thing happens for attestation. It dowsn't display any error but never gets completed and don't see this also in pending request list. If anybody has idea to debug the issue then let me know and thanks for help.
    Thanks,
    HC

    As per given bug it is looking for jars which is missing
    have you install connector using deployment manager?? if yes it copy required jars at target location. verify if not there copy jars in Scheduled Task folder.
    Check the document if any external jars required and same put at ThirdParty folder

  • SOAP Axis adapter_Encryption via Client Certificate not working

    Dear Experts,
    Could anyone please share the steps to enable encryption via client certificate in SOAP AXIS receiver adapter.
    I am able to do the same using normal SOAP adapter but with AXIS framework the steps are not working.
    I have come across few sdn links to configure axis framework for authentication using wsse security standard but this seems to be different as it requires user and password whereas with certificates we are not given any user/password.
    Please provide some valuable inputs.
    Thanks.

    Hi Shikha,
    see the -
    Advanced Usage Questions
        8. How can I configure a channel to use the encryption and ....
    of the FAQ attached to the note -
    1039369 - FAQ XI Axis Adapter
    Regards
    Kenny

  • Document library open in client application not working for img,pdf,txt files

    In an office 365 sharepoint site i have enabled open in client applicartion for document library but it is not working for image/txt/pdf files for word and excel files it is working fine. I have even turned on the feature open document in client application
    by default from site collection features also but there is no change.
    Please advice.
    Regards,
    Chaitanya

    Hi Chaitanya,
    The feature is currently designed to be used with HTTPS, and will not work as expected with the HTTP connection available on Office 365 for professionals and
    small businesses sites.
    To take advantage of this update, do the following steps:
    Wait for the update to the SharePoint Online service, which is in progress now.
    Upgrade Adobe Reader to the version 10.1.2 client.
    Add your SharePoint Online root URL/domain to the Trusted Sites security zone in Internet Explorer1 (e.g., 
    https://contoso.sharepoint.com).
    Check the Keep me signed in box when you log in to a SharePoint Online site.
    This
    SharePoint Online update is currently
    being rolled out worldwide along with several other new features.
    Best regards.
    Thanks
    Victoria Xia
    TechNet Community Support

  • Java FTP client do not work in Solaris 10

    We just upgrade our Solaris 8.0 system to Solaris10. A java FTP client don't work anymore when I try to download a remote file. It worked nicely in Solaris8. Specifically, this java program is using JDK FtpClient, the command that downloading a file is something like this:
    TelnetInputStream in = ftpClient.get(remotefilename);
    However, I still can send a file to a remote machine. Anyone knows this?
    Thnak you very much!

    Hello Community,
    the problem is solved. The VM on the workstation is very slow. The Java EE server use more than one hour to start. No problem with the hardware key or anything else, only a problem of my patience. It seems that the configuration file of the VM stores special entrys of the basic physical machine to run optimal. And which is optimal for the notebook is not optimal for the workstation.
    Cheers
    Stefan
    Edited by: Stefan Schnell on Mar 4, 2008 2:10 PM

  • Client variables not working in Apache and CF8

    I have Apache and CF8 set up with multiple virtual hosts
    locally for development(win xp pro, apache 2.2.4)
    Client variables are not working. I can log into CF
    administrator fine(not sure if authentication uses client variables
    or not). Any site that I work on that uses client variables behaves
    as if the variable is not defined after setting it then going to
    another page that checks for its existence. I have verified that
    client variables are set up in cf administrator.
    Thanks for any help

    Thanks a lot. I understood the mistake. Pls do not spend time on this.
    Thanks,
    Swarna

  • Cisco 1841 as PPTP client Does not work

    Dear All,
    I have Cisco 1841 router running the below roles       
    1) SSL VPN Server
    2) PPTP Server
    3) Site to Site Connection with Sonicwall router
    I want the router to be configured a pptp client to internet vpn server (so that i will get a fixed public ip )
    Once i get this ip address i want to use this connection to accept in coming connection and forward ports to internal host,
    I went through below
    http://www.mreji.eu/content/cisco-router-pptp-client
    https://supportforums.cisco.com/thread/2167562
    But it does not work as i do not have the option for the below 2 commands in vpdn-group 2 section.(Please see section in blue)
    protocol pptp
      rotary-group 4
    Please Advise and Help
    Regards
    Hasan Reza
    My Current Config is as below
    =~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2013.06.09 17:55:23 =~=~=~=~=~=~=~=~=~=~=~=
    exit
    Gateway#show run |      
    Building configuration...
    Current configuration : 25109 bytes
    ! Last configuration change at 13:33:57 UTC Sun Jun 9 2013 by admin
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname Gateway
    boot-start-marker
    boot system flash c1841-advsecurityk9-mz.151-2.T1.bin
    boot-end-marker
    logging buffered 4096
    no logging console
    enable secret 5 $1$SciF$TlX1tR5qaG9ZE7pdZHcRJ/
    no aaa new-model
    dot11 syslog
    ip source-route
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.236.5.1 10.236.5.20
    ip dhcp excluded-address 10.236.5.21 10.236.5.50
    ip dhcp excluded-address 172.21.51.2 172.21.51.50
    ip dhcp pool ContosoPool
       network 10.236.5.0 255.255.255.0
       default-router 10.236.5.254
       dns-server 213.42.20.20 195.229.241.222
    ip dhcp pool DMZ
       network 172.21.51.0 255.255.255.0
       dns-server 172.21.51.10
       default-router 172.21.51.1
       domain-name contoso.local
    ip cef
    ip domain name contoso.local
    ip name-server 213.42.20.20
    ip name-server 195.229.241.22
    ip name-server 195.229.241.222
    ip ddns update method dyndns
    HTTP
      add http://xxxxxx:[email protected]/nic/update?system=dyndns&hostname=<h>&myip=<a>
      remove http://xxxxxx:yyyyy@@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
    interval maximum 0 1 0 0
    multilink bundle-name authenticated
    vpdn enable
    vpdn-group 2
    request-dialin
      protocol l2tp
    initiate-to ip 173.195.0.42
    vpdn-group RAS-VPN
    ! Default PPTP VPDN group
    accept-dialin
      protocol pptp
      virtual-template 1
    l2tp tunnel timeout no-session 15
    crypto pki token default removal timeout 0
    crypto pki trustpoint TP.StartSSL.CA
    enrollment terminal pem
    revocation-check none
    crypto pki trustpoint TP.StartSSL-vpn
    enrollment terminal pem
    usage ssl-server
    serial-number none
    fqdn ssl.spktelecom.com
    ip-address none
    revocation-check crl
    rsakeypair RSA.StartSSL-vpn
    crypto pki trustpoint TP-self-signed-1981248591
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1981248591
    revocation-check none
    rsakeypair TP-self-signed-1981248591
    crypto pki trustpoint VMWare
    enrollment terminal
    revocation-check crl
    crypto pki trustpoint OWA
    enrollment terminal pem
    revocation-check crl
    crypto pki certificate chain TP.StartSSL.CA
    certificate ca 01
      (removed the certificate info for clarity)
       quit
    crypto pki certificate chain TP.StartSSL-vpn
    certificate 0936E1
        (removed the certificate info for clarity)9
       quit
    certificate ca 18
      (removed the certificate info for clarity)
       quit
    crypto pki certificate chain TP-self-signed-1981248591
    certificate self-signed 01
        (removed the certificate info for clarity)
       quit
    crypto pki certificate chain VMWare
    certificate ca 008EDCE6DBCE6B
        (removed the certificate info for clarity)
       quit
    crypto pki certificate chain OWA
       (removed the certificate info for clarity)
    license udi pid CISCO1841 sn FCZ122191TW
    archive
    log config
      hidekeys
    username admin privilege 15 password 7 1304131F02023B7B7977
    username ali password 7 06070328
    redundancy
    crypto isakmp policy 10
    encr 3des
    authentication pre-share
    group 2
    lifetime 84000
    crypto isakmp key admin_123 address 0.0.0.0 0.0.0.0
    crypto isakmp keepalive 10
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec transform-set vpnset esp-3des esp-sha-hmac
    crypto ipsec transform-set strongsha esp-3des esp-sha-hmac
    crypto dynamic-map mydyn 10
    set transform-set strongsha
    crypto map Dxb-Auh 1000 ipsec-isakmp dynamic XXXXXXXXXX
    interface FastEthernet0/0
    description Internal Network (Protected Interface)
    ip address 10.236.5.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    pppoe enable group global
    pppoe-client dial-pool-number 1
    interface ATM0/0/0
    no ip address
    shutdown
    no atm ilmi-keepalive
    interface BRI0/1/0
    no ip address
    encapsulation hdlc
    shutdown
    interface Virtual-Template1
    ip unnumbered Dialer1
    peer default ip address dhcp-pool ContosoPool
    ppp encrypt mppe auto required
    ppp authentication ms-chap ms-chap-v2 eap
    interface Dialer1
    ip ddns update hostname XXXXXXX.dyndns.org
    ip ddns update dyndns
    ip address negotiated
    ip nat outside
    ip virtual-reassembly in
    encapsulation ppp
    ip tcp adjust-mss 1450
    dialer pool 1
    ppp pap sent-username vermam password 7 13044E155E0913323B
    crypto map Dxb-Auh
    interface Dialer2
    mtu 1460
    ip address negotiated
    ip nat outside
    ip virtual-reassembly in
    encapsulation ppp
    dialer in-band
    dialer idle-timeout 0
    dialer string 123
    dialer vpdn
    dialer-group 2
    ppp pfc local request
    ppp pfc remote apply
    ppp encrypt mppe auto
    ppp authentication ms-chap ms-chap-v2 callin
    ppp eap refuse
    ppp chap hostname hasanreza
    ppp chap password 7 070E2541470726544541
    interface Dialer995
    no ip address
    ip local pool webssl 10.236.6.10 10.236.6.30
    ip forward-protocol nd
    ip http server
    ip http secure-server
    ip nat inside source list nat interface Dialer1 overload
    ip nat inside source static tcp 10.236.5.12 25 interface Dialer1 25
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 172.21.51.0 255.255.255.0 10.236.5.253
    ip access-list extended internal
    permit ip any 10.236.5.0 0.0.0.255
    ip access-list extended nat
    deny   ip 10.236.5.0 0.0.0.255 172.31.1.0 0.0.0.255
    deny   ip 10.236.5.0 0.0.0.255 172.19.19.0 0.0.0.255
    permit ip 10.236.5.0 0.0.0.255 any
    ip access-list extended nonat
    permit ip 10.236.5.0 0.0.0.255 172.19.19.0 0.0.0.255
    permit ip 10.236.5.0 0.0.0.255 172.31.1.0 0.0.0.255
    ip access-list extended sslacl
    ip access-list extended webvpn
    permit tcp any any eq 443
    logging esm config
    access-list 101 permit ip 10.236.5.0 0.0.0.255 172.31.1.0 0.0.0.255
    control-plane
    line con 0
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    login local
    transport preferred ssh
    transport input telnet ssh
    line vty 5 15
    exec-timeout 0 0
    login local
    transport preferred ssh
    transport input telnet ssh
    scheduler allocate 20000 1000
    webvpn gateway gateway1
    ip interface Dialer1 port 443
    ssl encryption rc4-md5
    ssl trustpoint TP.StartSSL-vpn
    inservice
    webvpn install svc flash:/webvpn/anyconnect-win-3.1.00495-k9.pkg sequence 1
    webvpn install csd flash:/webvpn/sdesktop.pkg
    webvpn context webvpn
    ssl authenticate verify all
    url-list "Webservers"
       heading "SimpleIT Technologies NBNS Servers"
       url-text "Google" url-value "www.google.com"
       url-text "Mainframe" url-value "10.236.5.2"
       url-text "Mainframe2" url-value "https://10.236.5.2"
    nbns-list "ContosoServer"
       nbns-server 10.236.5.10
       nbns-server 10.236.5.11
       nbns-server 10.236.5.12
    port-forward "PortForwarding"
       local-port 3389 remote-server "10.236.5.10" remote-port 3389 description "Server-DC01"
    policy group policy1
       url-list "Webservers"
       port-forward "PortForwarding"
       nbns-list "ContosoServer"
       functions file-access
       functions file-browse
       functions file-entry
       functions svc-enabled
       svc address-pool "webssl"
       svc default-domain "Contoso.Local"
       svc keep-client-installed
       svc split include 10.236.5.0 255.255.255.0
       svc split include 10.236.6.0 255.255.255.0
       svc split include 172.31.1.0 255.255.255.0
       svc split include 172.21.51.0 255.255.255.0
       svc dns-server primary 172.21.51.10
    default-group-policy policy1
    gateway gateway1
    inservice
    end
    Gateway#          

    Dear All,
    I have Cisco 1841 router running the below roles       
    1) SSL VPN Server
    2) PPTP Server
    3) Site to Site Connection with Sonicwall router
    I want the router to be configured a pptp client to internet vpn server (so that i will get a fixed public ip )
    Once i get this ip address i want to use this connection to accept in coming connection and forward ports to internal host,
    I went through below
    http://www.mreji.eu/content/cisco-router-pptp-client
    https://supportforums.cisco.com/thread/2167562
    But it does not work as i do not have the option for the below 2 commands in vpdn-group 2 section.(Please see section in blue)
    protocol pptp
      rotary-group 4
    Please Advise and Help
    Regards
    Hasan Reza
    My Current Config is as below
    =~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2013.06.09 17:55:23 =~=~=~=~=~=~=~=~=~=~=~=
    exit
    Gateway#show run |      
    Building configuration...
    Current configuration : 25109 bytes
    ! Last configuration change at 13:33:57 UTC Sun Jun 9 2013 by admin
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname Gateway
    boot-start-marker
    boot system flash c1841-advsecurityk9-mz.151-2.T1.bin
    boot-end-marker
    logging buffered 4096
    no logging console
    enable secret 5 $1$SciF$TlX1tR5qaG9ZE7pdZHcRJ/
    no aaa new-model
    dot11 syslog
    ip source-route
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.236.5.1 10.236.5.20
    ip dhcp excluded-address 10.236.5.21 10.236.5.50
    ip dhcp excluded-address 172.21.51.2 172.21.51.50
    ip dhcp pool ContosoPool
       network 10.236.5.0 255.255.255.0
       default-router 10.236.5.254
       dns-server 213.42.20.20 195.229.241.222
    ip dhcp pool DMZ
       network 172.21.51.0 255.255.255.0
       dns-server 172.21.51.10
       default-router 172.21.51.1
       domain-name contoso.local
    ip cef
    ip domain name contoso.local
    ip name-server 213.42.20.20
    ip name-server 195.229.241.22
    ip name-server 195.229.241.222
    ip ddns update method dyndns
    HTTP
      add http://xxxxxx:[email protected]/nic/update?system=dyndns&hostname=<h>&myip=<a>
      remove http://xxxxxx:yyyyy@@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
    interval maximum 0 1 0 0
    multilink bundle-name authenticated
    vpdn enable
    vpdn-group 2
    request-dialin
      protocol l2tp
    initiate-to ip 173.195.0.42
    vpdn-group RAS-VPN
    ! Default PPTP VPDN group
    accept-dialin
      protocol pptp
      virtual-template 1
    l2tp tunnel timeout no-session 15
    crypto pki token default removal timeout 0
    crypto pki trustpoint TP.StartSSL.CA
    enrollment terminal pem
    revocation-check none
    crypto pki trustpoint TP.StartSSL-vpn
    enrollment terminal pem
    usage ssl-server
    serial-number none
    fqdn ssl.spktelecom.com
    ip-address none
    revocation-check crl
    rsakeypair RSA.StartSSL-vpn
    crypto pki trustpoint TP-self-signed-1981248591
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1981248591
    revocation-check none
    rsakeypair TP-self-signed-1981248591
    crypto pki trustpoint VMWare
    enrollment terminal
    revocation-check crl
    crypto pki trustpoint OWA
    enrollment terminal pem
    revocation-check crl
    crypto pki certificate chain TP.StartSSL.CA
    certificate ca 01
      (removed the certificate info for clarity)
       quit
    crypto pki certificate chain TP.StartSSL-vpn
    certificate 0936E1
        (removed the certificate info for clarity)9
       quit
    certificate ca 18
      (removed the certificate info for clarity)
       quit
    crypto pki certificate chain TP-self-signed-1981248591
    certificate self-signed 01
        (removed the certificate info for clarity)
       quit
    crypto pki certificate chain VMWare
    certificate ca 008EDCE6DBCE6B
        (removed the certificate info for clarity)
       quit
    crypto pki certificate chain OWA
       (removed the certificate info for clarity)
    license udi pid CISCO1841 sn FCZ122191TW
    archive
    log config
      hidekeys
    username admin privilege 15 password 7 1304131F02023B7B7977
    username ali password 7 06070328
    redundancy
    crypto isakmp policy 10
    encr 3des
    authentication pre-share
    group 2
    lifetime 84000
    crypto isakmp key admin_123 address 0.0.0.0 0.0.0.0
    crypto isakmp keepalive 10
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec transform-set vpnset esp-3des esp-sha-hmac
    crypto ipsec transform-set strongsha esp-3des esp-sha-hmac
    crypto dynamic-map mydyn 10
    set transform-set strongsha
    crypto map Dxb-Auh 1000 ipsec-isakmp dynamic XXXXXXXXXX
    interface FastEthernet0/0
    description Internal Network (Protected Interface)
    ip address 10.236.5.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    pppoe enable group global
    pppoe-client dial-pool-number 1
    interface ATM0/0/0
    no ip address
    shutdown
    no atm ilmi-keepalive
    interface BRI0/1/0
    no ip address
    encapsulation hdlc
    shutdown
    interface Virtual-Template1
    ip unnumbered Dialer1
    peer default ip address dhcp-pool ContosoPool
    ppp encrypt mppe auto required
    ppp authentication ms-chap ms-chap-v2 eap
    interface Dialer1
    ip ddns update hostname XXXXXXX.dyndns.org
    ip ddns update dyndns
    ip address negotiated
    ip nat outside
    ip virtual-reassembly in
    encapsulation ppp
    ip tcp adjust-mss 1450
    dialer pool 1
    ppp pap sent-username vermam password 7 13044E155E0913323B
    crypto map Dxb-Auh
    interface Dialer2
    mtu 1460
    ip address negotiated
    ip nat outside
    ip virtual-reassembly in
    encapsulation ppp
    dialer in-band
    dialer idle-timeout 0
    dialer string 123
    dialer vpdn
    dialer-group 2
    ppp pfc local request
    ppp pfc remote apply
    ppp encrypt mppe auto
    ppp authentication ms-chap ms-chap-v2 callin
    ppp eap refuse
    ppp chap hostname hasanreza
    ppp chap password 7 070E2541470726544541
    interface Dialer995
    no ip address
    ip local pool webssl 10.236.6.10 10.236.6.30
    ip forward-protocol nd
    ip http server
    ip http secure-server
    ip nat inside source list nat interface Dialer1 overload
    ip nat inside source static tcp 10.236.5.12 25 interface Dialer1 25
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 172.21.51.0 255.255.255.0 10.236.5.253
    ip access-list extended internal
    permit ip any 10.236.5.0 0.0.0.255
    ip access-list extended nat
    deny   ip 10.236.5.0 0.0.0.255 172.31.1.0 0.0.0.255
    deny   ip 10.236.5.0 0.0.0.255 172.19.19.0 0.0.0.255
    permit ip 10.236.5.0 0.0.0.255 any
    ip access-list extended nonat
    permit ip 10.236.5.0 0.0.0.255 172.19.19.0 0.0.0.255
    permit ip 10.236.5.0 0.0.0.255 172.31.1.0 0.0.0.255
    ip access-list extended sslacl
    ip access-list extended webvpn
    permit tcp any any eq 443
    logging esm config
    access-list 101 permit ip 10.236.5.0 0.0.0.255 172.31.1.0 0.0.0.255
    control-plane
    line con 0
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    login local
    transport preferred ssh
    transport input telnet ssh
    line vty 5 15
    exec-timeout 0 0
    login local
    transport preferred ssh
    transport input telnet ssh
    scheduler allocate 20000 1000
    webvpn gateway gateway1
    ip interface Dialer1 port 443
    ssl encryption rc4-md5
    ssl trustpoint TP.StartSSL-vpn
    inservice
    webvpn install svc flash:/webvpn/anyconnect-win-3.1.00495-k9.pkg sequence 1
    webvpn install csd flash:/webvpn/sdesktop.pkg
    webvpn context webvpn
    ssl authenticate verify all
    url-list "Webservers"
       heading "SimpleIT Technologies NBNS Servers"
       url-text "Google" url-value "www.google.com"
       url-text "Mainframe" url-value "10.236.5.2"
       url-text "Mainframe2" url-value "https://10.236.5.2"
    nbns-list "ContosoServer"
       nbns-server 10.236.5.10
       nbns-server 10.236.5.11
       nbns-server 10.236.5.12
    port-forward "PortForwarding"
       local-port 3389 remote-server "10.236.5.10" remote-port 3389 description "Server-DC01"
    policy group policy1
       url-list "Webservers"
       port-forward "PortForwarding"
       nbns-list "ContosoServer"
       functions file-access
       functions file-browse
       functions file-entry
       functions svc-enabled
       svc address-pool "webssl"
       svc default-domain "Contoso.Local"
       svc keep-client-installed
       svc split include 10.236.5.0 255.255.255.0
       svc split include 10.236.6.0 255.255.255.0
       svc split include 172.31.1.0 255.255.255.0
       svc split include 172.21.51.0 255.255.255.0
       svc dns-server primary 172.21.51.10
    default-group-policy policy1
    gateway gateway1
    inservice
    end
    Gateway#          

  • DHCP client does not work poperly after systemd and Gnome 3.6 upgrade

    Upgraded my system today from Gnome 3.4 to 3.6 (and systemd was updated as well), and since then acquiring an IP address using DHCP does not work anymore.
    I am using IPv4 only internally, but neither dhclient or dhcpcd manages to get an IPv4 address.
    It seems like IPv6 is priority one, and beacuse there is no IPv6 DHCP server available NetworkManager aborts the whole setup process.
    To make sure that IPv6 should not be considered, I have changed "method" in NetworkManager to "Ignore" for IPv6.
    I have also tried to downgrade NM to 0.9.6.0 from 0.9.6.4 (since that version works on another, not upgraded, machine), without any result.
    Also switched dhclient to dhcpcd, without any result.
    The machine is a "pure" systemd machine.
    DHCP works for other devices in the network.
    Versions:
    systemd 195-2
    NetworkManager 0.9.6.4
    isc-dhclient-4.2.3-P2
    I have no issues on a system where following versions are running:
    systemd 189-4
    NetworkManager 0.9.6.0
    dhcpcd 5.6.2
    Log: http://pastebin.com/2wMC0JLe

    Think I have identified the issue now.
    Neither dhcpcd or dhclient is sending the host name properly to the DHCP server anymore. I had an IP address reserved in the DHCP server for my host and after deleting this reservation my host is able to acquire an IP (dynamic) address. The reserved static address could never be acquired.
    Conclusion: dhclient and dhcpcd is not sending the host name as before, causing the DHCP server to get stuck (while waiting for the host name) whenever a NIC with a reserved IP address is requesting an IP address.
    Downgrading the dhcp clients has not yet worked, so there might be some underlying component that is causing the problem. ath5k? systemd?

Maybe you are looking for

  • Function module to read the directory list and also run in background

    Hi All, I need to read few files from a folder in the server and upload the data in the file using a BDC. This process has to happen in the background as I am going to schedule the program. I had used the function module "EPS_GET_DIRECTORY_LISTING" t

  • Excel Multi Value Parameter fails

    I have a stored proc that i pas through multiple values to one parameter. In SSMS this works perfectly. From excel i have a range of ids that i put into one cell as csv's. If i put 21 ids this works perfectly, if i exceed 21 i receive the following e

  • How do I determine what needs attention on my Apple RAID card?

    Every time I turn on the computer, I get a message that says," The Apple RAID Card installed in your system requires your attention." This is what I have: RAID 065-7214 Mac Pro RAID Card Why do I keep getting this message? I am not sure what needs to

  • Problem in transferring a PDS

    Hi All: I am trying to transfer a PDS to APO - I have a BOM, Routing and created a Production Version.  When I run the PDS_MAINT, I see the PDS but I do not see any data in <Component Data> tab and in <Operat. Data> tab.  When I activate the CIF mode

  • ITunes purchases on iPhone will not sync to PC

    Recent iTunes Store music purchases made on iPhone are not syncing to iTunes on PC. The Album Warpaint - Warpaint was pre-ordered and only the 'advanced release' song "Love is to Die" has synced to iTunes. The rest of the album has now been purchased