Why is the GUI not showing when i run it

Why is it not showing the container
import java.awt.*;
import java.awt.event.*;
import java.util.*;
import javax.swing.*;
public class Progress extends JFrame {
     private String path;
     private JPanel topLeftPanel;
     private JPanel labelPanel;
     private JTextField pathField;
     public Progress()
          this.setTitle("PROGRESS Message Viewer");
          this.setSize(800, 600);
          Container contentPane = this.getContentPane( );
          // Technique for centering a frame on the screen.
          Dimension frameSize = this.getSize();
          Dimension screenSize = Toolkit.getDefaultToolkit().getScreenSize();
          this.setLocation((screenSize.width - frameSize.width)/2,
                           (screenSize.height - frameSize.height)/2);
          topLeftPanel = new JPanel();
          topLeftPanel.setLayout(new GridLayout(1, 2));
          labelPanel = new JPanel();
          labelPanel.setLayout(new GridLayout(4, 1));
          JLabel l = new JLabel("Please enter the path to log file:  ");
          l.setForeground(Color.black);
          labelPanel.add(l);
          topLeftPanel.add(labelPanel);
          pathField = new JTextField(80);
          ActionListener aListener = new ActionListener() {
               public void actionPerformed(ActionEvent e) {
                    // Retrieve the path.
                    char[] pathFieldText = pathField.getText().toCharArray();
                    path = new String(pathFieldText).trim();
          pathField.addActionListener(aListener);
          contentPane.add(topLeftPanel);
          contentPane.add(pathField);
     public static void main(String []args){
          Progress p = new Progress();
}

Swing related questions should be posted in the Swing forum.
Read the BoderLayout API documentation. If you don't specify a constraint then by default the component is added to the "CENTER". However only a single component can be displayed in any given area of the BorderLayout. So the second add(...) method replaces the first component added.
Read the Swing tutorial on [url http://java.sun.com/docs/books/tutorial/uiswing/layout/visual.html]How to Use Layout Managers for more information.

Similar Messages

  • Why did the trace NOT show the other switches in between?

    I have a PC that is connected to a switch (A) in a network. Switch A has many switches in between and connects to another switch B. When I did a trace to the server, the last switch I see in the result is switch B. Also, when I checked to which port of switch B that the server was connected, It showed as Po1. When I did a show cdp neighbor for the interfaces for the interfaces involved inthe bundle, I get a switch and then another. Why did the trace NOT show the other switches in between? Why did I get an arp on Switch B? Could some one explain?

    It's hard to tell, but if you have L2 switches, the addresses on those L2 switches are for management purposes only and you won't see a response from a trace. The only time you'll see a response is when the packet is routed between devices and not switched. You'll get an arp request/response across a single vlan. If you have vlan 10 across 10 switches, all 10 switches will see an arp request because they're broadcasted throughout the whole vlan.
    HTH,
    John
    *** Please rate all useful posts ***

  • Why does the alarm not work when the iphone 4 is turned off

    why does the alarm not work when the iphone 4 for is  turned  off works fine when on most other phones work when off

    The only phone I've ever had that would turn on and sound the alarm is a Blackberry. So, I'd hardly say "most phones" have this function.

  • Why does the mail not work when i updated my 5s to iOs 8?

    why does the mail not work when i updated my 5s to iOs 8?

    Thank you for the reply. But can you tell me what this configuration is about and how I should do this?

  • I've just started using the App Tabs. I think this feature could be handy but why are the sites not updated when I start Firefox. Now I have to manually update the site which is somewhat of a downer. Does any of you know where I'm going wrong?

    I've just started using the App Tabs. I think this feature could be handy but why are the sites not updated when I start Firefox. Now I have to manually update the site which is somewhat of a downer. Does any of you know where I'm going wrong?

    To answer the post title FireFox save all downloads automatically in the download folder, which you can find in the Documents folder. If you want to choose where to save your downloads go to tools>options>check always ask me where to save files.
    Secondly, I am assuming you have IE 8 installed as this is the only version that supports this fix that is currently not in beta. Go to control panel>internet options>advanced tab and reset the settings at the bottom. This may or may not fix the problem but it is a good first step.

  • Why does the picture not show?

    when I view with Safari
    http://macdailynews.com/2013/06/18/see-how-apples-stunning-new-mac-pro-is-extrud ed-from-a-solid-aluminum-puck-with-video/
    the pic of the Pro does not show
    when I view with Chrome it does show
    when I view with Firefox it does not show
    what am I doing wrong?
    thank you

    Not necessarily something you are doing wrong ...
    From your Safari menu bar click Safari > Preferences then select the Extensions tab.
    If there are any installed, turn that OFF, quit and relaunch Safari to test.
    If it's not an extension issue, back to the menu bar click Safari > Reset Safari
    Select the top 6 boxes then click Reset.
    Quit and relaunch Safari.
    If that didn't help, press Command + Option + E on your keyboard to empty the Safari cache and try that link again.
    If that didn't help, try a different DNS.
    Open System Preferences > Network > Advanced > DNS
    Click + and type in these numbers:
    208.67.222.222
    Click + again and do the same.
    208.67.220.220
    Click Ok.
    Try Safari.

  • Why is the Counter Not Showing on my Blog Front Page?

    Anyone know why me blog is not showing on my blog's main page:
    http://web.me.com/quathletics/QuinnipiacMidnight_Madness_2009/2009_Quinnipiac_Midnight_Madness/2009_Quinnipiac_MidnightMadness.html
    I can see it in iWeb, but after publishing site, it does not show?
    Any suggestions.
    Thx Much

    OT,
    Thx Much.
    Did all you suggested with the footer and still no counter visible:
    http://web.me.com/quathletics/QuinnipiacMidnight_Madness_2009/2009_Quinnipiac_Midnight_Madness/2009_Quinnipiac_MidnightMadness.html
    Had similar issues with another iWeb blog...something is not right with this and any help would be appreciated.

  • Why does the iTunes not show "Photos"

    Why does the new iTunes not show "Photos" after it is synced, and why does iCloud not show Photos also?

    Ralph9430 offers a good suggestion.  But you may need to do this before taking his advice:
    Check in iPhoto's Preferences (which you can open from the iPhoto menu).  Look in General, and make sure "Connecting Camera Opens" is set to "Image Capture").
    If it is set to "iPhoto", you won't be able to get to Image Capture easily.

  • I am trying to put a caption on a photo. Why does the caption not show in the photo?

    In iPhoto, I would like to insert a CAPTION in the photo. When i enter my caption, it shows on the screen on top, but does not show in my slide show pictures.
    Can you help?

    Adding a caption will add metadata tags to the photo, but not write the text as a graphics annotation overlay to the picture. The slideshow themes do not include the metadata tags. If you want to present the photos with captions, swipe them nanually and not as a slideshow.
    You would need to find a different app to add graphic overlays to the photos for text written onto the photo.

  • Why is the CME not showing pls

    The phones are all ringing one another with the router 2620XM but am unable to open the CME when l typed http://172.168.1.1/cme.html on the internet explorer (error message is) 404 not found. Can so one pls help me thanks
    Router#sh run
    Building configuration...
    Current configuration : 1777 bytes
    ! Last configuration change at 10:23:50 UTC Mon Oct 3 2011
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 172.168.1.1 172.168.1.10
    ip dhcp pool VOICE
       network 172.168.1.0 255.255.255.0
       default-router 172.168.1.1
       option 150 ip 172.168.1.1
       lease 5
    interface FastEthernet0/0.1
    encapsulation dot1Q 1 native
    ip address 20.20.20.1 255.255.255.0
    interface FastEthernet0/0.5
    encapsulation dot1Q 5
    ip address 172.168.1.1 255.255.255.0
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 162.168.1.1 255.255.255.0
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http path flash:
    telephony-service
    load 7960-7940 P0030702T023
    max-ephones 4
    max-dn 5
    ip source-address 172.168.1.1 port 2000
    max-conferences 4 gain -6
    web admin system name ojay password cisco1
    dn-webedit
    transfer-system full-consult
    create cnf-files version-stamp 7960 Oct 03 2011 09:31:24
    ephone-dn  1  dual-line
    number 1000
    ephone-dn  2  dual-line
    number 1001
    ephone  1
    device-security-mode none
    mac-address 0006.5356.AC92
    button  1:1
    ephone  2
    device-security-mode none
    mac-address 0014.6A87.8E91
    button  1
    End
    System flash directory:
    File  Length   Name/status
      1   32062316  c2600-adventerprisek9-mz.124-9.t2.bin
      2   4668     admin_user.html
      3   667582   admin_user.js
      4   1602     CiscoLogo.gif
      5   639      CME_GUI_README.TXT
      6   331483   CP7902080001SCCP051117A.sbin
      7   338840   CP7905080001SCCP051117A.sbin
      8   338424   CP7905080001SCCP051117A.zup
      9   340631   CP7912080001SCCP051117A.sbin
    10   953      Delete.gif
    11   497      DistinctiveRingList.xml
    12   16948    dom.js
    13   864      downarrow.gif
    14   6315     ephone_admin.html
    15   4658     logohome.gif
    16   3831     normal_user.html
    17   81600    normal_user.js
    18   129476   P0030702T023.bin
    19   459      P0030702T023.loads
    20   685334   P0030702T023.sb2
    21   129880   P0030702T023.sbn
    22   349794   P00405000700.bin
    23   350198   P00405000700.sbn
    24   1347     Plus.gif
    25   4000     Ring1.raw
    26   4000     Ring2.raw
    27   4000     Ring3.raw
    28   4000     Ring4.raw
    29   4000     Ring5.raw
    30   497      RingList.xml
    31   843      sxiconad.gif
    32   843      Tab.gif
    33   2451     telephony_service.html
    34   870      uparrow.gif
    35   3493     xml.template
    36   10230    xml-test.html
    [35894376 bytes used, 14437268 available, 50331644 total]
    49152K bytes of processor board System flash (Read/Write)
    when l typed http://172.168.1.1/cme.html on the internet explorer
    error message is 404 not found

    There are several problems here:
    The URl is http://172.168.1.1/ccme.html  not cme.html
    You do not have the GUI HTML files loaded to flash. I suggest you download these from CCO; they are version-specific to the IOS you are running so be sure they match.
    The CME Admin Guide has a chapter on Enabling the GUI. It is a good place to check that you've covered all your bases.
    Please rate helpful replies.

  • Why do the Screensaver not show pictures from my Aperture Library?

    Hello,
    I have a new MacBook Retina and everything is fine, but the screensaver. When I choose a screensaver with photos (like Ken Burns) and an Aperture folder, the screensaver only shows "Fotos laden..." (German for "Loading pictures..."). When I choose the folder, I see all the pictures in the dialogue, but the saver itself don't shows them.
    Using Aperture pictures for the desktop work by the way.
    Any ideas? I already repaired (new database and stuff) the Aperture library, but it doen't helped.
    One more hint: when I tried choosing an Aperture folder, the screensaver even don't work with the preinstalled pictures or normal picture folder on the HDD.
    Thanks for helping me!
    Volker

    Connecting from one computer to another is one thing. The iTunes sharing feature is something completely different and is meant as a way for people to allow others to listen to their library from other computers on the same network that also run iTunes. It isn't meant as a direct connection from one iTunes library to another.
    Think of it sort of like turning on the "Broadcast" or "Radio Station" feature of your iTunes to allow others to listen in on your library if they are interested. But you wouldn't want those people going in and making changes.
    Patrick

  • So, I just purchased, apple TV and the latest Mountain Lion 10.8.5. I can mirror my IPad and Iphone with no problems, so why is the icon not showing up on my top bar like all the youtube tutorials?

    why is the airplay icon not appearing in the top bad like all the tutorial videos?

    I assume that you did not check before buying, if you had you would have seen that your Mac is too old for Airplay Mirroring to work:
    Supported Macs
    AirPlay Mirroring in OS X Mountain Lion takes advantage of the hardware video encoding capabilities of 2nd and 3rd Generation Intel Core processors. Hardware video encoding allows AirPlay Mirroring to efficiently deliver high frame rates while maintaining optimal system performance. The following Mac models have processors that support AirPlay Mirroring:
    iMac (Mid 2011 or newer)
    Mac mini (Mid 2011 or newer)
    MacBook Air (Mid 2011 or newer)
    MacBook Pro (Early 2011 or newer)
    And if you bought ML solely for that function you should remove it from your machine and get a refund.

  • Why do my notifications not show when I swipe down anymore?

    please tell me how to re-start my notifications they are not available when I swipe down from the top of the screen

    Hi kellygreenthumb,
    If you are having an issue with Notifications not being available on your iPhone, I would suggest that you troubleshoot using the steps in this article -
    Understanding notifications on iPhone, iPad, and iPod touch - Apple Support
    The section most relevant is -
    Get help
    Push notifications require an active Wi-Fi or cellular connection.
    Notifications use Wi-Fi only when a cellular connection is unavailable. Firewalls and proxy servers may affect your ability to receive notifications. For more information, see Unable to use Apple Push Notification service (APNs).
    If you're not receiving notifications for a specific app, try these steps:
    Verify that the app supports notifications.
    After installing an app or restoring a backup to a different iOS device, open the app to begin receiving notifications. If the app requires entering or logging in to an account, you will need to do this before receiving notifications.
    Check Settings > Notification Center to ensure that the app is configured for notifications. If notifications do not appear in the Notification Center, verify that the Notification Center setting for the app is enabled.
    Thanks for using Apple Support Communities.
    Best,
    Brett L

  • When I open a pages doc why does the text not show but the preview in Finder shows the text?

    Doc shows a blank page but shows the number of pages at the bottom and flickers the text when I click on Outline icon.

    In most cases it is because you have not updated Pages to the current version.
    Peter

  • Why does the speedtest not show the all Speeds?

    I keep being told that I am getting 8MPS downstream when I am not. It is always under 2 MPS. I have tested every socket with a wired connection to the Hub. Always the same result. Why doesn't the test show the speed from the Server to the Exchange, and the Exchange to the Hub as separate calculations? - and for normal traffic, not a magic ping that might bypass any throttling or capping. How can I lose 6MPS between my Hub and my PC?   I simply don't believe the downstream stats are true, or are truly indicative of the bandwidth delivered to the hub.  The service is nearly a month old, the "2 days" is from testing every possible fix suggested on the website.
    Here are the Home Hub stats:
    ADSL Line Status
    Connection Information
    Line state:
    Connected
    Connection time:
    2 days, 11:32:32
    Downstream:
    7.938 Mbps
    Upstream:
    448 Kbps
    ADSL Settings
    VPI/VCI:
    0/38
    Type:
    PPPoA
    Modulation:
    G.992.1 Annex A
    Latency type:
    Fast
    Noise margin (Down/Up):
    10.5 dB / 27.0 dB
    Line attenuation (Down/Up):
    10.3 dB / 5.5 dB
    Output power (Down/Up):
    15.9 dBm / 11.9 dBm
    FEC Events (Down/Up):
    0 / 0
    CRC Events (Down/Up):
    247 / 1
    Loss of Framing (Local/Remote):
    0 / 0
    Loss of Signal (Local/Remote):
    0 / 0
    Loss of Power (Local/Remote):
    0 / 0
    HEC Events (Down/Up):
    336 / 0
    Error Seconds (Local/Remote):
    228 / 1

    If it has not rest automatically ater your hub stats show 3days then use this link to the forum mods who can reset it manually for you http://bt.custhelp.com/app/contact_email/c/4951
    They normally reply by email or phone directly to you within 3 working days they will take personal ownership of your problem until resolved and will keep you informed of progress
    They are a UK based BT specialist team who have a good record at getting problems solved
    This is a customer to customer self help forum the only BT presence here are the forum moderators
    If you want to say thanks for a helpful answer,please click on the Ratings star on the left-hand side If the reply answers your question then please mark as ’Mark as Accepted Solution’

Maybe you are looking for

  • I am unable to join my home network after updating my 3gs to ios 5.1

    I updated yesterday to ios 5.1 and now I am unable to join my home network. I have reset network connections, restarted, entered correct name and passwords and get the message "unable to join ____".  i didn't have this problem until the update. Any o

  • How do I cancel a recent subscription?

    I recently signed up for Acrobat (1 year 10/9/2014).  When I contacted your organization regarding a problem I was having--converting PDF images to DOC, you were  unable to help me with my problem.   The person I talked to finally transferred me to h

  • Field name (free item) in ME21N

    Hi All, I have a small issue hear in ME21N I wan the table and the field which will be updated when the we check the check box for free item in the line items, I tried to find that using CDHDR, CDPOS, using ST05 and other methods but I was unable to

  • Should I give up on Mac's?

    I'm a professional photographer and so my computer is obviously a big part of my job. I've had my 12 inch powerbook for about 2 years and I've just about had it. It crashes at least twice a day, the prefences reset in photoshop at least 3 or 4 times

  • (MP) BGP recursive lookups

    Hi colleague, have a question here about MP-BGP (iBGP) updates sent to PE or RR. You know, when BGP prepares the update, put the source and destination IP which a Loopback address, then it has to lookup for the next hop to send the update. The next h