How to apply Qos in the precedence of cache server

m in an isp  and iwant to apply the QOS to enhance my network internet performance
actually i  have two requests , i will start with showing brief topology about my network and start asking the questions .
here is the topology below :
from the topology above , my access is only on R1 which is BGP internet gateway router and R2 is my ISP router.
1- i want to apply Qos on R1 so that a subnet of 32 ips to have gurantee bandwidth of 30M .
assume  the subnet  is 10.20.30.0/27  that need to be bw gurantee .
2- i want the download traffic by idman or ftp on my Router R1 dont exceed 50 % of my total bw .
i mean that i have 450M bandwith from my isp , & sometimes we have a  slow in browsing , so i want to enhance the browsing quality because  its more important that downloading files from internet.
here is my two requests above , i dont know how it will work with the precedence of the cache server .
anyway , i will paste my config of router and i will replace my puplic ips with xxx for privacy .
7200Gateway#sh run
Building configuration...
Current configuration : 10149 bytes
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
hostname 7200Gateway
boot-start-marker
boot-end-marker
logging message-counter syslog
logging buffered 50000
enable secret xxxxxxxxxxxxxx
no aaa new-model
ip source-route
ip wccp 80 redirect-list CACHE80
ip wccp 90 redirect-list CACHE90
ip cef
no ip domain lookup
ip accounting-threshold 4294967295
login block-for 180 attempts 3 within 60
login quiet-mode access-class telnet
login on-failure log
login on-success log
no ipv6 cef
multilink bundle-name authenticated
username xxxxxx password xxxxx
archive
log config
  hidekeys
interface GigabitEthernet0/1
description LAN
bandwidth 230000
ip address 10.160.150.2 255.255.255.0
ip wccp 80 redirect in
ip policy route-map CACHE-REDIRECT
load-interval 30
duplex auto
speed auto
media-type rj45
negotiation auto
interface FastEthernet0/2
no ip address
shutdown
duplex auto
speed auto
interface GigabitEthernet0/2
description Cache
bandwidth 150000
ip address x.x.x.x 255.255.255.248
ip wccp redirect exclude in
load-interval 30
duplex auto
speed 1000
media-type rj45
negotiation auto
interface GigabitEthernet0/3
description Internet
bandwidth 230000
ip address x.x.x.x 255.255.255.252
ip wccp 90 redirect in
load-interval 30
duplex full
speed 1000
media-type sfp
negotiation auto
router bgp zzzzzzz
no synchronization
bgp log-neighbor-changes
network xxxx mask xxxxx
network xxxx mask xxxx
network xxxx mask xxxxx
network xxxx mask xxxx
network xxxx mask xxxxx
network xxxx mask xxxx
redistribute connected
redistribute static
neighbor zzzzzzzz remote-as zzzzzzz
neighbor zzzzzzz password zzzzzzz
neighbor zzzzzz route-map Pipo out
no auto-summary
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 xxxxxxxxxxx
ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
no ip http server
no ip http secure-server
ip flow-top-talkers
top 200
sort-by bytes
cache-timeout 5000
ip access-list extended bb
permit ip xxxx.xxxx.xx.0 0.0.1.255 any
ip access-list extended CACHE80
permit tcp xxxxxxx any eq www
ip access-list extended CACHE90
permit tcp any xxxxx.0 0.0.0.255
ip access-list extended pipo
permit ip xxxxx xxxxxxx any
  permit ip xxxxx xxxxxxx any
ip access-list extended private
permit tcp 172.16.0.0 0.0.255.255 any eq www
permit ip 10.20.30.0 0.0.0.255 any
ip access-list extended telnet
permit ip xxxxxx xxxxxxx.255.255 any log
permit ip xxxx xxxxx 0.0.0.255 any log
ip prefix-list bb seq 5 permit xxxxx
ip prefix-list bbseq 10 permit xxxxxx
logging history size 500
no cdp run
route-map pipo permit 10
match ip address prefix-list pipo1
route-map pipo permit 20
match ip address prefix-list newsubnet
set metric 500
set origin incomplete
set as-path prepend xxxxxxxxx
route-map permit 10
match ip address prefix-list bibo
route-map CACHE-REDIRECT permit 10
match ip address  private
set ip next-hop 1vvvvvv
route-map CACHE-REDIRECT permit 20
match ip address bibo e1
set ip next-hop vvvvvv
route-map CACHE-REDIRECT permit 30
match ip address pipo
set ip next-hop vvvvvvvvvv
route-map CACHE-REDIRECT permit 100
snmp-server community xxxxxx RO
control-plane
dial-peer cor custom
line con 0
password xxxxxxxx
logging synchronous
login
stopbits 1
line aux 0
stopbits 1
line vty 0 4
exec-timeout 60 0
password xxxxxxxxxxxxxxxxx
logging synchronous
login local
end

Hi Vinay,
Please check the program. I have used the replace statement but it is not working.
IF NOT v_sap_bom_rec IS INITIAL.
Spliting the records at '~' delimiter
    SPLIT v_sap_bom_rec AT c_del INTO  wa_bom_file-model_name
                                       wa_bom_file-product_code
                                       wa_bom_file-description
                                       wa_bom_file-product_type
                                       wa_bom_file-mfg_part_num
                                       wa_bom_file-mfg_part_desc.
    REPLACE cl_abap_char_utilities=>horizontal_tab IN wa_bom_file-mfg_part_desc WITH space .
    wa_bom_file-status = c_status.
    APPEND wa_bom_file  TO i_bom_file.
But it is not working.
Please help me..
Thanks
Neelima

Similar Messages

  • How can i get all the users from weblogic server?

    how can i get all the users from weblogic server?
    i have configurated a LDAP server using iPlanet and
    in weblogic server console i see those users from LDAP
    server. but how can i get all the users in my program
    from weblogic server instead of LDAP server?
    BTW,how to configure a RDBMSAuthenticator and what should i do
    in Oracle? which tables should i create? and how are their architectures?
    Thanks
    Daniel

    BTW, i use weblogic platform 8.1
    "Daniel" <[email protected]> дÈëÓʼþ
    news:[email protected]..
    how can i get all the users from weblogic server?
    i have configurated a LDAP server using iPlanet and
    in weblogic server console i see those users from LDAP
    server. but how can i get all the users in my program
    from weblogic server instead of LDAP server?
    BTW,how to configure a RDBMSAuthenticator and what should i do
    in Oracle? which tables should i create? and how are their architectures?
    Thanks
    Daniel

  • How do I clean out the flash player cache?

    How do I clean out the flash player cache?  I'm told by zynga to clean it out...I play games. I don't know how to do it.  Thanks in advance

    i-phony wrote:
    Thanks for your helpful reply. If most of my website visitors are using Safari browser (( iPhone, iPad devices )) what type of flash should we use in the headers?
    www.i-phony.com
    I hope to use my previous flash designs.
    Best regards
    Since Apple designed iOS (per Steve Jobs' insistence) to be specifically incompatible with Flash, I wouldn't worry about what Flash content to use in headers for devices that can never, and will never, be able to see it.
    I stopped using Flash for anything in my websites about six months ago, converting what I had to HTML5 (MP4) and any new content that would have previously been done in Flash is going the be the same.

  • How to delete/drop all the tables from SQL Server Database without using Enterprise Manager?

    How to delete/drop all the tables from SQL Server Database without using Enterprise Manager?
    I tried using DROP Tables, Truncate Database, Delete and many more but it is not working.  I want to delete all tables using Query Analyzer, i.e. through SQL Query.
    Please help me out in this concern.
    Nishith Shah

    Informative thread indeed. Wish I saw it early enough. Managed to come up with the code below before I saw this thread.
    declare @TTName Table
    (TableSchemaTableName
    varchar
    (500),
    [status] int
    default 0);
    with AvailableTables
    (TableSchemaTableName)
    as
    (select
    QUOTENAME(TABLE_SCHEMA)
    +
    +
    QUOTENAME(TABLE_NAME)
    from
    INFORMATION_SCHEMA.TABLES)
    insert into @TTName
    (TableSchemaTableName)
    select *
    from AvailableTables
    declare @TableSchemaTableName varchar
    (500)
    declare @sqlstatement nvarchar
    (1000)
    while 1=1
    begin
    set @sqlstatement
    =
    'DROP TABLE '
    + @TableSchemaTableName
    exec
    sp_executeSQL
    @sqlstatement
    print
    'Dropped Table : '
    + @TableSchemaTableName
    update @TTName
    set [status]
    = 1
    where TableSchemaTableName
    = @TableSchemaTableName
    if
    (select
    count([Status])
    from @TTName
    where [Status]
    = 0)
    = 0
    break
    end

  • When using the OS X caching server, after the first update is made, do the rest of the computers have to enter the Apple ID to download the cached update

    Hello,
    I have a question that I had not found an answer to yet. I would like to use the OS X caching server, and I know that it caches a software update as soon as the first computer downloads it. If an application requires authentication using an Apple ID, and the first computer authenticates and downloads that update, do the rest of the computers have to authenticate as well, even though the update is downloaded from the caching server?
    I am looking for a solution in that regard. For the company that I work, I would like a solution for users to be able to download software updates (OS or Application), without having to authenticate with the company Apple ID, for security reasons.
    Would anybody be able to help?

    Yes.  You still need to authenticate on the subsequent machines if you are interactively applying the updates.  Caching server stores the application data, not the App Store authorization information.
    You have some alternatives.
    1:  If you are using a single "corporate" Apple ID to claim your free apps (iMovie, iPhoto, etc), then you can download them on your master machine and then user ARD, JAMF, or other tool to push the full application packages out to all the clients.  They will already be tagged to the Apple ID and since the push is happening in the background, as long as the user is not using the application, they will not know you are updating.  Remember, App Store updates are the entire application, not update packages.  So pushing the entire .app bundle is effective.
    2:  If you are looking to distribute purchased apps, you really should look at the VPP (volume purchase plan) from Apple (http://www.apple.com/business/vpp/) (there is also one for education but you mentioned company).  This allows you as the organization to purchase the correct number of copies and then control the distribution of the apps to your end users.  They can use their own Apple ID to claim the apps but you can reclaim the license should the user leave the organization.
    Reid
    Apple Consultants Network
    Apple Professional Services
    Author "Mavericks Server – Foundation Services" :: Exclusively available in Apple's iBooks Store

  • How do I install (just the required assembles without server licence) client library to a client machine so that I can invoke SSIS/SSAS 2012 remotely?

    We are trying to figure the easiest way to install client lib on a machine to call SSIS/SSAS remotely (to a SQL Server 2012).
    We have some .net code referencing SMO/AMO and Microsoft.SqlServer.Management.IntegrationServices.
    1) For SMO, I found out this and it is quite clear about how to install on a client machine:
    Installing SMO (SQL Server Management Objects (SMO))
    http://msdn.microsoft.com/en-us/library/ms162189(v=sql.110).aspx
    2) For AMO (analysis management object), I found out this but I did not see a clear instruciton of what and how to install on the client machine:
    http://technet.microsoft.com/en-us/library/ms124924(v=sql.110).aspx
    3) For SSIS call, I did not find anything talking about the client installation.
    Can someone help us?
    Thanks.

    Hi Sofiya,
    Thank you so much for your help.
    For SSIS call, we are using 
    Microsoft.SqlServer.Management.IntegrationServices.dll
    to call package deployed to SSISDB catalog at remote server using some .net codes.
    I have few questions:
    1) What is the difference between
    Microsoft.SqlServer.Management.IntegrationServices.dll
    and the dll you mentioned:
    Microsoft.SqlServer.IntegrationServices.Server.dll
    2) If we install SSMS, can we also get Microsoft.SqlServer.Management.IntegrationServices.dll? Put another way, if we install SSMS, will Microsoft.SqlServer.Management.IntegrationServices.dll be registeredin GAC?
    3) If we install  Microsoft.SqlServer.Management.IntegrationServices.dll at client machine, I assume we don't need to licence it. (Note: SSIS package itself will be running from the remote server, NOT the client machine which is used to invoke
    the SQL 2012 packages).
    Best regards,
    Steven Rao
    Hi Steven Rao,
    Yes, you are right. When you want to start a SSIS 2012 package from a .Net application,
     you need to reference the assembly of Microsoft.SqlServer.Management.IntegrationServices .dll. The Microsoft.SqlServer.Management.IntegrationServices namespace contains the classes and interfaces to manage the Integration Services catalog
    on an instance of SQL Server. It is only available in the GAC. For more information, see:
    http://microsoft-ssis.blogspot.com/2013/01/call-ssis-2012-package-within-net.html
    I also do a test, if you  install the media of SQL Server Management Studio, usually, these assemblies are located in following folder as screenshot.
    In the folder,  C:\Windows\assembly
    Regards,
    Sofiya Li
    Sofiya Li
    TechNet Community Support

  • How to install Soap on the (Apache) Oracle HTTP Server

    Hi,
    Does anyone know how to install SOAP on the Oracle HTTP Server? I downloaded a soap version (it seems that the standard version comes without SOAP) from the xml.apache.org site and followed the installation instructions as far as I could (only Tomcat is described). However, no 'soaping'!!! Maybe I'm overlooking something because I cannot imagine that it should be difficult.
    Thanks in advance!
    Hans

    Hans, the SOAP implementation is part of OC4J. You get it out of the box. Check out how to use the out-of-the-box implementation in the tutorials on Web services with Oracle9i JDeveloper at:
    http://otn.oracle.com/tech/webservices/htdocs/series/content.html
    These tutorials/samples use the implementation of SOAP/WSDL that Oracle calls J2EE Web Services and this is the long term direction of Oracle's Web services implementation. This implementation is what Oracle will be evolving to Sun's Java Web Services Developer Pack as it finalizes into J2EE 1.4.
    If you want to use Oracle/Apache SOAP, this too is included in OC4J but its support is being deprecated in future releases of Oracle9iAS in favour of the J2EE Web Services implementation. To find it, check out the OC4J/soap/webapps/ directory for the soap.ear file (it is in a slightly different spot if you are using the full Oracle9iAS R2 but still within the soap directory structure. Simply add <application name="soap" path="../../../soap/webapps/soap.ear" auto-start="true"/> to your OC4J server.xml and <web-app application="soap" name="soap" root="/soap" /> to your OC4J http-web-site.xml, re-start and away you go.
    Finally, just to be sure, SOAP support in Oracle9iAS did not appear until 1.0.2.2.x and higher. If using 1.0.2.1 or less, you are correct, there is no SOAP support.
    Mike.
    Most folks that try out the J2EE Web Services find it is pretty easy to use so

  • How to apply ontology on the existing RDF model

    Hi,
    I am new to Semantic web technologies.I am facing following issue.
    I have installed Oracle 11g with semantic support.
    I have few tables which stores customer,products information. eg :CUSTOMER_MASTER,PRODUCT_MASTER.
    Now used d2rq client and generated N-TRIPLE files by connecting to the above scheme i.e converted the tuples to triples generated RDF content.
    I could store the RDF data into Oracle 11g using the jena APIs. I was successfull till this point.
    Now , I have defined an ontology for the above entities using protege. I was able to store the model to Oracle 11g using Jena APIs.
    But I am confused with following issues.
    1. How can I apply my ontology definition to my existing RDF model.
    i.e. - I have created a ontology definition MyOntology.owl and loaded into Oracle 11g name MyOntologyModel.
    I already have another RDF model which got generated from the relational table i.e. CustomerRDFModel .
    Now, how can I apply MyOntologyModel to CustomerRDFModel and execute meaningfull queries.
    While defining the ontology, shall I use the same class names which are used in the CustomerRDFModel ? How can I link my ontology and RDF content ?
    eg:- I have a entities such as CUSTOMER_MASTER and PRODUCT_MASTER .Now in my ontology, if I need to bring some ontology definitions , shall I use the same entity names while defining Ontology.
    Otherwise, how we can apply ontology on existing relational tables ?
    Is it not required to convert the tuples(relational data) to RDF data for running the semantic queries ?
    Please provide me some pointers on these issues .
    Thanks
    Aneesh K

    Let me explain it like this:
    The triples (data) you automatically generated using D2RQ must conform to some ontology definition (lets use ontology schema in place of ontology definition for easier understanding). I believe D2RQ generates ontology schema/definition also, along with data. Please check once. But if it does not then it is your responsibility to either manually/automatically generate a ontology definition/schema that has the same class & property names (URIs) as what your data (generated thru D2RQ) has.
    Once you have a ontology schema and ontology data (that conforms to our schema), you have two options to link them:
    1) Load both schema and data to a single ontology model in oracle database.
    2) Load them into separate models and while querying you can mention both the models in the query.
    But I believe that the database does not do any kind of validation of data against schema in any of the above case (probably because that is what is intended in the W3C OWL specification - no distinction btwn data & schema) . But if you have schema in the database you can actually do a lot if inferencing (RDFS inferencing, OWL inferencing etc..)
    Thanks,
    Rajesh.
    PS: All those Ontology pundits, correct me if I am wrong.
    Edited by: rajesh narni on Jul 9, 2010 4:30 AM

  • How to apply branding in the Flash object

    Hello everyone,
    How we can apply the CSS to the flash object in Nakisa 3.0 (orgchart). for example changing colors fonts, etc..
    Br

    Hi Ibrahim,
    These elements cannot be changed without an enhancement from Nakisa. They have to include your new fonts/colours into the flash module. You must contact them directly to findout if/how/when this can be done and for what cost.
    Best regards,
    Luke

  • How to apply Xsl to the xml value stored in ResultSet

    String url = "jdbc:msql://200.210.220.1:1114/Demo";
    Connection conn = DriverManager.getConnection(url,"","");
    Statement stmt = conn.createStatement();
    ResultSet rs;
    rs = stmt.executeQuery("SELECT Lname FROM Customers for auto xml");
    // I want to convert the content of this rs into a String or StringBuffer and apply sxlt to format the data. Can anyone help me.
    Thanks

    In your view you could do something like that:
    foreach (var field in Model.FormStruture.fields)
    <div class="editor-label">
    <label for="@field.Name">@field.Descricao</label>
    </div>
    <div class="editor-field">
    <input class="text-box single-line" id="@field.Name" name="@field.Name" type="text" value="@field.Valor" data-rules-required="@field.Mandatory.ToString().ToLower()" data-rule-number="@field.Tipo.Equals(SiB.OCR.Documentos.Modelo.TipofieldDocumento.Numerico).ToString().ToLower()" title="@field.Descricao" />
    </div>
    if (!String.IsNullOrEmpty(field.Format))
    @:<script type="text/javascript">$("[email protected]").mask("@field.Format");</script>

  • How to apply patch 118833-36 on a containerized server?

    We have a V890 running Solaris 10 that has two zones (containers) running instances
    of Oracle database. `smpatch' won't install patch 118833-36 in the normal manner
    because it's flagged as an interactive patch. The recommended procedure is to shut
    the server down, boot it in single-user mode and then apply the patch this way:
    # cd /var/sadm/spool
    # smpatch add -i 118833-36
    Then, you are supposed to shut it down again, do a reconfiguration boot, and finally
    run smpatch again to apply the remaining patches.
    Will this procedure work for a server with containers? I understand that the zones have
    to be running for the patch upgrade to succeed. Is there a way to boot the zones into
    single-user mode as well? We need to ensure that Oracle doesn't start during the
    patch procedures.

    Log into the global zone and run :
    # shutdown -y -g0 -is
    This should bring down the global zone to su mode and halt the other zones (notice Halt)
    However I believe there is a bug presently where this does not always happen and you are still able to telnet to the local zones.
    Local zone admin could always run zoneadm -z <zone-name> halt on each zone (notice halt not single-user).
    Once global zone in in single-user mode install the patch as normal, when the global is done it will bring up each local zone to single-user mode to add the patch too.
    118833-36 may need patch add and -G option as this patch also has been experiencing some issues, in which case I believe you would need to do the patch add process on each zone manually
    Once the global zone is brought back up again it should bring up the local zones as well.
    Let us know if you experience the locals not being halted as mentioned above and need to do it manually.

  • How can i manually discover the database and AP server ?

    My original agent is named by domain name,i want to name it by host name.So i remove it from grid control.But when i upload the agent again,only host and agent will show up in grid control.I try to manully add database,but encounter this exception:
    oracle.sysman.emSDK.emd.comm.CommException: IOException in sending Request :: Connection timed out: connect
    Can anyone tell me what's the problem?And how to resolve it?
    Thanks!

    while posting please specify os ,Problem seem to agent is not running on that box
    emctl start agent, emctl upload and check targets.xml what are the targets monitored by agent

  • [solved] How to install Linux on the Fujitsu Scaleo Home Server 2205

    Hello!
    I am currently thinking about buying a Fujitsu Scaleo Home Server 2205.
    The according datasheet can be found here.
    The default installation includes Windows Home Server, which is why I have to find a way to install Linux on it (still thinking about which distribution).
    But since it doesn't offer regular installation interfaces, I don't know how to do it without having to buy extra equipment.
    I thought about just swapping one hard disk, and installing using a regular PC, but figured that this would cause problems with RAID afterwards.
    What do you suggest?
    Thanks!
    Last edited by jazz.arch (2009-05-11 16:40:13)

    lucke wrote:That's an interesting point. Do you have any data? I'd guess that pre-P4-era components are consuming less power than most modern ones. My PII with S3 GPU, 2 NICs and one HDD drains 50W in idle, you'd have to go with Atom or Goede or Via offerings to go much lower than that.
    I remember having a 300W PSU in my Celeron Mendocino-based PC but I never bothered to measure the actual power consumption at the wall socket. Did you measure that 50W at the socket?
    For comparison, TS-109 idles at 14W while Linksys NSLU2 at just 8W.
    Of course, 266MHz ARM/32MB RAM in NSLU2 will not be enough for most applications. I am personally really excited about Marvell's Kirkwood platform, Sheevaplug drains only 4W idle / 7W full load (!) and actually sports a 1.2GHz processor / 512MB RAM. If only they made a proper NAS solution using this platform... edit: they did, there's TS-119 but QNAP is traditionally overpriced.
    Last edited by fijam (2009-05-11 07:17:07)

  • How to get rid of the iPod Photo Cache?

    When exploring the iPhoto folder using Finder, there is a folder called "iPod Photo Cache"
    I barely have any photo's stored on my iPod and yet the folder is 6GB! this is because i used to sync my entire library to my Ipod, but not anymore, yet the folder is still huge
    i tried to remove it once, but that messed up my ipod and wouldnt let me sync any photos at all
    how do it remove this folder or at least reduce its size without messing up my ipod?

    andy
    The only way to do it is to drag it out of there and into the trash.
    Next time you sync it will take longer as the cache is re-created.
    Standard Warning: Back Up First!
    This file does get out of hand on some folks machines, and it removing it will not affect syncing.
    Standard Warnng: Don't change anything in the iPhoto Library Folder via the Finder or any other application. iPhoto depends on the structure as well as the contents of this folder. Moving things, renaming things or otherwise making changes will prevent iPhoto from working and could even cause you to damage or lose your photos.
    Removing the iPod cache is one of the exceptions.
    Regards
    TD

  • What is the best way to apply QoS to CAD

    The CAD agent that are working remotely are seeing performance issues.  Hence, would it really be better to apply QOS to the CAD workers for better performance or would it just be better to give the remote workers a VMachine and have all the CAD application run locally?

    Enterprise
    all the teleworkers have business class cable connection with a Cisco 800 router.  I know big companies are seeing the same issue latancy that is probably caused by convergence time) maybe from a WAN hiccup.  in reference to the VMare -Citrix, was just idea to throw out as a better solution for a more stable enviornment, but the service control messages maybe see a lag over the WAN ...its trading one evil for another...I know CIsco mobile workers are using the CVO solution...(similar to our setup)...thoughts?

Maybe you are looking for