Access another host on same subnet through Nat'd IP address

I appreciate any help in advance, I have a requirement to monitor a host's external IP address, the monitoring host (host A) initiating the request is located in the same DMZ subnet as the destination host (host B) I want to monitor, both are NAT'd to external IP addresses, I was expecting to see a request going out from host A, getting NAT'd to its respective external IP address and then coming back in through the external interface to reach the Nat'd IP address of host B. is this how NAT will be handled by the ASA or am I missing something here? thanks again.

Borman,
Its more complicated than that, consider the following scenario:
                            20.20.20.0/24
               ASA------------------------------Internet
                  | (DMZ)
             Switch
     Host A          Host B
   10.1.1.10      10.1.1.100
                      20.20.20.20 (Nat outside address)
Basically you want to monitor your host B using its public IP address, normally your NAT configuration (in case of version 8.2 and prior) would be something like this:
nat (DMZ,outside) 20.20.20.20 10.1.1.100
nat (DMZ) 1 0.0.0.0 0.0.0.0
global (outside) 1 interface
When going from Host A to host B, two translations should occur, first is the Unstranslate from 20.20.20.20 to 10.1.1.100 (By internal process of the ASA), then once it is unstranslated, the route-lookup comes in game. Firewall notices that is on the same interface as the source of the packet so we reach our first impass. The ASA does not support same security traffic by default. So we overcome this issue with the following command:
same-security-traffic permit intra-interface
Now that is done, so we move to the next packet process, the ASA tries to check if there is any NAT translation for a packet coming from the DMZ and going to the same DMZ. As you can see there is a "nat (DMZ) 1 0.0.0.0 0.0.0.0", that tells the firewall that everything coming from the DMZ should be translated, we hit that NAT and since the outgoing interface is the same as the source interface (DMZ) there is no global command, hence you will see an error that states, No translation group found. Here is how we overcome that issue
Global (DMZ) 1 interface
This will translate requests from the DMZ interface going to that same interface to the DMZ IP address, on the server 10.1.1.100, the connection will be seeing as it came from the firewall, the packets will be sent to the firewall again, hence avoiding asymmetric routing.
If running version 8.3 or higher, the concept is the same, but the commands change a bit.
8.3
same-security-traffic permit intra-interface
object network Server_Public
host 20.20.20.20
object network Server_Private
host 10.1.1.100
object network Any
subnet 0.0.0.0 0.0.0.0
Nat (DMZ,DMZ) source dynamic Any interface destination static Server_Public Server_Private
So bottom line, configuration needed on 8.2
global (outside) 1 interface
same-security-traffic permit intra-interface
Configuration for 8.3
same-security-traffic permit intra-interface
object network Server_Public
host 20.20.20.20
object network Server_Private
host 10.1.1.100
object network Any
subnet 0.0.0.0 0.0.0.0
Nat (DMZ,DMZ) source dynamic Any interface destination static Server_Public Server_Private
Hope this helps a bit.
Mike

Similar Messages

  • Trouble accessing another SSID on same controller

    I recently inherited a Wi-Fi network that's having a number of issues however I bring you one today.
    I currently have 5 SSID's on a Cisco 5508, the problem is I can join just one of those SSID's.  When I switch to one of the other SSID and enter the password I get this error message "Network Security Key Mismatch".  I am toll "All SSID's" have worked in the pass but one day they started having an issue connecting to all except one.  I am also told by someone who's memory fails them that 3 engineers or so more before me told them it had to do with either the user MAC was tied too long to the DHCP address it was issued and they had to go in and manually clear/remove before they could rollover...  Or that they had to issue some release command to be able to then access the other SSID and then the same thing to go back to the original SSID...  Anyone have such and issue and have a fix?

    Hi Rohan,
    Do you know if Fast SSID change is enabled ?
    if not, you can enable it controller > Fast SSID Change 
    See below:
    Fast SSID change
                  Disabled              Enabled        
    Also, as a rule of thumb, please restrict number of SSIDs to 3 or less unless it is really required.
    By reducing the number of SSIDs the available air quality can be improved and hence better wireless performance.
    Also, you can validate your WLC configuration using Cisco WLC configuration Analyser to make sure all the recommended features are enabled/disabled on your WLC.
    https://supportforums.cisco.com/document/7711/wlc-config-analyzer
    Hope the above helps to fix your wireless issue!
    Cheers,
    VB

  • ACE module client and real servers on same subnet

    I am working on a ACE load balancing implementation,which has following requirement? Can someone let me know if this can be implemented and how?
    Configuration
    test context
    real server vlan 233
    real server subnet - 167.6.233.x
    VIP vlan - 539
    VIP subnet - 167.6.238.128/25
    production context
    real server vlan 232
    real server subnet - 167.6.232.x
    VIP vlan - 538
    VIP subnet - 167.6.238.0/25
    Load balancing is coinfigured in routed mode with ACE as gateway for test and prod real sever subnets (233 and 232 subnets).
    Test and production servers are mixed in these subnets. So we need to configure source NAT to access the test servers in the production subnet (232) and vis versa.
    Here are the scenarios and questions
    1. clients need to access the real servers in prod subnet (232) through VIP configured in test context (vlan 539) - this is done by SNAT at vlan 539 and working.
    2. real servers in test subnet (233) needs to access real servers in same subnet (233) through VIP configured in test context (vlan 539) - this is done by SNAT at vlan 233 and working
    3. real servers in prod subnet (232) need to access the real servers in test subnet (233) through VIP configured in test context (vlan 539) - this appears to be working fine without any additional configuration
    4. real servers in test subnet (233) needs to access another real servers in prod subnet (232) through VIP configured in test context (539)  - this is not working
    5. real servers in test subnet (233) needs to access another real server which is not on one of the subnet (167.6.56.x) behind ace - this is not working.
    Can we implement the scenarios 4 and 5?

    Hi Suresh,
    I see it's a bit complex and we do not have the config at hand.
    However for the scenario 4 if you apply the policy already applied on vlan 539 on the interface vlan233 then the ACE should catch the packets and apply the policy (i.e. forward the packets to the serverfarm you want)
    Alessandro
    If  this helps you and/or answers your question please mark the question as  "answered" and/or rate it, so other users can easily find it.

  • Accessing another class

    A have my "main" class (a JPanel) and the thing I want to do is simply to access another class' data and methods through my main class (That class also extending JPanel and is added together with the main class to a JFrame in a third class). The thing is i have this JTextPane that i wished to edit from my main class. Like:
    //Main class
    public class Main extends JPanel {
         private class Listener implements KeyListener{
              public void keyPressed(KeyEvent ke) {
                   if (ke.getKeyCode() == foo){
                        //Do like:
                        Log.appendLogText(bar);
    }//My JTextPane handling class
    public class Log extends JPanel {
         private JTextPane logText;
         public Log(){
              logText = new JTextPane();
              logText.setContentType("text/html");
         public void appendLogText(String str){
              String text = str;
              Document textDoc = tempLogText.getDocument();
              int end = textDoc.getLength();
              try {
                   textDoc.insertString(end, text, logText.getLogicalStyle());
                   logText.setText(textDoc.getText(0, textDoc.getLength()));
              } catch (BadLocationException e) {}
    }This is just scraps of code, if there is a better way to do it please tell me, what i want is (again) simply one JPanel displaying something where you can edit the JTextPane in another JPanel (and class).

    public class Main extends JPanel {
        private Log log;
        public void setLog(Log log) {
            this.log = log;
        log.appendLogText(bar);
    }It's up to the builder code that instantiates Main and Log classes to call:
    tehMain.setLog(tehLog);For an extra schmear of abstraction, you can do this variant:
    public interface ILog {
        void appendLogText(String s);
    public class Main extends JPanel {
        private ILog log;
        public void setLog(ILog log) {
            this.log = log;
        log.appendLogText(bar);
    public class Log extends JPanel implements ILog {...}That way, you can pass Main other ILogs -- for testing Main, for example.

  • Unable to open forms when Launching another application on same browser.

    Hi,
    I have a server with configuration Oracle EBS 12.1.1 on RHEL 5.5, Database 11.1.0.7. On client machine we use Internet explorer, Firefox and Chrome to access the EBS and forms.
    We are able to open the forms from all browsers, but problem arise when we access another application on same browser, resulting in not opening of oracle forms.
    This is a java application using the same database on the server. This application works fine but Our Oracle Forms has to face the problems.
    When we try to launch the forms, it results in FRM-92101 error. I read the MOS documents for
    R12: "FRM-92101:There was a failure in the Forms Server during startup" Error When Attempting to Launch Forms [ID 454427.1]
    Then I checked the application log file, it says that:
    13/08/12 18:47:41.891 formsweb: Forms session <207> failed during startup: no response from runtime process
    13/08/12 18:50:43.704 formsweb: Forms session <209> aborted: runtime process failed during startup with errors
    Unable to switch to Working Directory: /oracle/TEST/apps/tech_st/10.1.3/forms
    When I further investigate I found there is no such "forms" directory under "/oracle/TEST/apps/tech_st/10.1.3".
    Then I read Oracle Notes:
    FRM-92101 : Unable To Switch To Working Directory. (Doc ID 1434888.1)
    FRM-92101 Error in Application.log: Unable to Switch to Working Directory (Doc ID 432708.1)
    But no luck with all these. Please suggest something. Can't open both application simultaneously on same browser.
    Regards,
    Prashant Namdeo

    Hi,
    Please state whether the application was working fine before.
    Please provide log file  of:
    --$LOG_HOMEora/10.1.3/j2ee/forms/forms_default_group_1/application.log
    --DB alert logfile --check whether you can find any valuable information.
    Please have a look at the following MOS notes:
    FRM-92050 java.lang.UnsatisfiedLinkError: no frmjsl in java.library.path [ID 438522.1]
    Troubleshooting FRM-92XXX Errors in Oracle Applications [ID 365529.1]
    And have a look at:
    http://oracleared.blogspot.com/2012/11/frm-92191-there-was-failure-in-form.html
    Best Regards,

  • Problem accessing another public ip in same subnet

    Hi,
    I have searched around for a previous post regarding this but can't find an issue similar to mine (or I'm just too stupid to understand that it is )
    I have a Cisco 5505 at a small business that I help. The problem is that the ISP are providing public IPs to multiple customers in a /24 subnet. The ASA has a single public IP configured 8.8.8.8 (not really, just for the examples sake) with a subnet mask of 255.255.255.0.
    The webserver I have to access is not managed by me and is located in a different location (same town though) has 8.8.8.115, it is located in the same subnet as the ASA.
    How would I make this work? I have tried to configure a static arp entry for the web server but it just won't work. If i place a computer directly on the outside interface I have no problem accessing the web server.
    I am running ASA version 8.2, but I could upgrade if it would help me solve the problem.
    Any help with this issue is much appreciated.

    The ISP only specify one gateway in that range and that is 8.8.8.1 so any other would not let me access internet.
    Once again thank you for your time.
    : Saved
    ASA Version 8.2(1)
    hostname ciscoasa
    domain-name XXXXXXX
    enable password XXXXXXX encrypted
    passwd XXXXXXX encrypted
    names
    name 8.8.8.8 Outside_IP
    name 192.168.20.2 Server
    name 192.168.20.11 rav-dc01
    name 192.168.20.12 rav-ms01
    name 192.168.20.13 rav-rds01
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.20.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address Outside_IP 255.255.255.0
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    boot system disk0:/asa821-k8.bin
    ftp mode passive
    dns server-group DefaultDNS
    domain-name XXXXXXX
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    access-list inside_nat0_outbound extended permit ip any 192.168.25.0 255.255.255.0
    access-list RemoteVPNSplittunnel standard permit 192.168.20.0 255.255.255.0
    access-list outside_access_in extended permit tcp host 100.100.100.228 interface outside eq 3389
    access-list outside_access_in extended permit tcp any interface outside eq smtp
    access-list outside_access_in extended permit udp any interface outside eq 4125
    access-list outside_access_in extended permit tcp any interface outside eq 4125
    access-list outside_access_in extended permit tcp any interface outside eq https
    access-list outside_access_in extended permit tcp any interface outside eq pptp
    access-list outside_access_in extended permit tcp any interface outside eq 444
    access-list outside_access_in extended permit gre any interface outside
    access-list outside_access_in extended permit udp any interface outside eq 444
    access-list outside_access_in extended permit tcp any interface outside eq www
    access-list inside_access_in extended permit tcp host rav-ms01 any eq smtp
    access-list inside_access_in extended deny tcp any any eq smtp
    access-list inside_access_in extended permit ip any any
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    ip local pool RemoteVPNPool 192.168.25.100-192.168.25.200 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-621.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) udp interface 4125 Server 4125 netmask 255.255.255.255
    static (inside,outside) tcp interface 4125 Server 4125 netmask 255.255.255.255
    static (inside,outside) tcp interface https rav-ms01 https netmask 255.255.255.255  dns
    static (inside,outside) tcp interface pptp Server pptp netmask 255.255.255.255
    static (inside,outside) tcp interface 3389 rav-rds01 3389 netmask 255.255.255.255  dns
    static (inside,outside) tcp interface smtp rav-ms01 smtp netmask 255.255.255.255
    static (inside,outside) udp interface 444 Server 444 netmask 255.255.255.255
    static (inside,outside) tcp interface 444 Server 444 netmask 255.255.255.255
    static (inside,outside) tcp interface www Server www netmask 255.255.255.255  dns
    access-group inside_access_in in interface inside
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 8.8.8.1 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server rav_Intern protocol radius
    aaa-server rav_Intern (inside) host rav-dc01
    key CiscoAsa5505RAV2012
    radius-common-pw CiscoAsa5505RAV2012
    http server enable 8080
    http 192.168.20.0 255.255.255.0 inside
    http 192.168.25.0 255.255.255.0 inside
    http 100.100.101.128 255.255.255.192 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    sysopt connection timewait
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map outside_dyn_map 20 set pfs
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    telnet 192.168.20.0 255.255.255.0 inside
    telnet timeout 5
    ssh 192.168.20.0 255.255.255.0 inside
    ssh timeout 5
    console timeout 0
    management-access inside
    dhcpd auto_config outside
    dhcpd address 192.168.20.190-192.168.20.200 inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ntp server rav-dc01 source inside
    webvpn
    group-policy RemoteVPN internal
    group-policy RemoteVPN attributes
    wins-server value 192.168.20.11
    dns-server value 192.168.20.11
    vpn-tunnel-protocol IPSec
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value RemoteVPNSplittunnel
    default-domain value rav.nu
    split-dns value rav.nu
    username SupportVPN password XXXXXXX encrypted privilege 0
    username SupportVPN attributes
    vpn-group-policy RemoteVPN
    tunnel-group RemoteVPN type remote-access
    tunnel-group RemoteVPN general-attributes
    address-pool RemoteVPNPool
    authentication-server-group rav_Intern
    accounting-server-group rav_Intern
    default-group-policy RemoteVPN
    tunnel-group RemoteVPN ipsec-attributes
    pre-shared-key *
    class-map inspection_default
    match default-inspection-traffic
    policy-map global_policy
    class inspection_default
      inspect pptp
      inspect icmp
      inspect icmp error
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:8481ab3aa01b23bad17bacb2aca7197a
    : end
    asdm image disk0:/asdm-621.bin
    no asdm history enable

  • Nat inside to outside, IP not in same subnet as outside IP

    I already posted this but cant seem to find the post now, so re-posting.
    We have 10 IP's being NAT'd, all working ok.  I need a servers outbound source address to be translated to an IP that is not in the same subnet as the outside IP:
    Outside IP = 193.xxx.xxx.99/23
    Translated IP = 195.xxx.xxx.64/24
    I have created the NAT rule to translate traffic source address from 192.168.2.55 to 195.xxx.xxx.64 packet trace shows it getting through, but this is not working in practice.  The host that I have set the NAT rule up for can no longer access wan.
    Is this possible on an ASA?  

    It should work. I'd run capture on the outside and see if the packet is leaving the ASA and it's coming back or not. If it is, then it's ASA config within the NAT, and you need to look at proxy-arp parameter. If the packet doesn't come back, then it's maybe the router outside the ASA. You might need to take care of manual arp (ASA outside MAC and the new translate IP) and the routing to the new subnet back to ASA outside IP.

  • No ping between host in the same subnet

    Hello,
    I have a question about the ASA and the ARP traffic in IOS 9.1.2 for ASA 5585-X and multicontext. I have discovered a curious behaviour about the traffic ARP in the my CLUSTER of ASA's. When I try to send a ping between host in the  same subnet and these host have as Gateway the interface of the ASA (ASA is his router) don't works, if I mark the check to enable the comunications between host connected to the same interface this cotinues without work. The only way to get my aim (ping between host), I need to implement and Access Rule allowing the traffic IP between my origin network and destination the same network.
    I think that this is some feature of ASA that filter the ARP Request but I don't understand!!! Can I help me, please?
    Thanks.

    Hi,
    Your firewall should not see any traffic between the hosts on the same subnet.
    If it is seeing traffic between the hosts then its likely that Proxy ARP on the ASA is the problem. Proxy ARP is enabled on the ASA by default on all interfaces. This essentially means that when the host connecting to the other host on the same subnet sends an ARP request the ASA might reply to that ARP request instead of the actual destination host. This is why traffic might get forwarded to the ASA instead of the actual host.
    If you want to disable the Proxy ARP on some ASA interface then you can use
    sysopt norpoxyarp
    Where you replace the with the actual name you have given to the interface on the ASA. This disables the Proxy ARP
    - Jouni

  • Can a hosts be in the same subnet yet not be link local (trouble with Bonjour) ?

    I'm trying to print through a D-Link DVA G3810 BN from the wireless side with a Macbook Pro to the wired side HP C6280 . Apparently mDNS (Bonjour} communicates with hosts that are link-local and on the same subnet ? Is there an assumption that hosts on the same subnet are link-local ? My testing suggests to me that connections from the wireless to the wired side of the D-Link are routed and the hosts are NOT link-local . It will only allow me to add hosts , regardless of being fixed or via DHCP , within the same address range and subnet . I found a statement that for hosts to be link-local , their communications cannot be routed (pass thru a router) . I can't see the HP printer in trying to set it up and always get the 'Network host is busy ; will retry in X seconds'  state if I do configure it as an IP type . I can't figureout a way around this issue with the hardware that I have to work with .

    Link-local addresses are usually the self assigned IP address that a device will set when a DHCP server cannot be found. These are the addresses with 169.254.x.x subnet.
    If the router is assigning IP addresses for your network, then they will usually have a different IP subnet, possibly 192.168.0 for D-Link. And this subnet would be for the wired and wireless connections. So it would be more a case of bridging the two network topolgies rather than routing them.
    The network host is busy message could be more to do with the driver and the IP protocol selected when creating the queue than the connection being broken between the Mac and printer. If you were to open Network Utility and select the Ping tab, enter the IP address of the HP and set the pings to 4, pressing the Ping button will soon show if there is a path through the wireless to the printer.
    If you get a response to the ping you could then open Safari and type the ip address as the URL. This would then connect to the internal web page of the printer and possibly let you enable an IP protocol like LPR so that you can use LPD on the Mac instead of Bonjour to connect to the printer.
    As for the driver, you could look at using a Gutenprint driver instead of the HP driver or the hpijs package to get past the limitations that some printer drivers have with network connections.

  • Policy based routing to host in same vlan/subnet

    Hello i have nexus 7k that i have a policy based routing setup as follows for 2 vlans, 802 and 803, to set default route out to a host in vlan 802. i have applied my policy to the vlans and everything works fine for a host in vlan 803, it routes over and out properly. However when im in vlan 802 my host traffic never gets to 172.21.1.237 when pointed at the gateway 172.21.1.1. I can see the pbr statistics incrementing indicating that i am initially hitting the policy but im not sure where my traffic goes after that. I can talk to .237 direct in the vlan but i would like this to work through pbr to utilize all of my other routes and default gateway.
    vlans 802
    172.21.1.1/24
    ip policy route-map West
    vlan 803
    172.21.17.1/24
    ip policy route-map West
    route-map West permit 10
      match vlan 802-803
      set ip default next-hop 172.21.1.237
    Im thinking there is some kind of hairpinning problem or maybe im creating some kind of blackhole.
    any help is appreciated.
    thanks, scott

    Scott
    If the destination IP is in the same subnet as source IP then it won't be routed it will be L2 switched so it would never use the default gateway ie.
    src IP 172.21.1.10 255.255.255.0
    dst IP 172.21.1.237 255.255.255.0
    src compares it's own IP with it's subnet mask and sees it is on the 172.21.1.x network. src then compares the destination IP with it's own subnet mask and sees it is also on the 172.21.1.x network so it simply arps out for that address and when it gets the mac address it sends it direct to the destination. It would only use the default gateway if the destination IP was on a different network.
    So i don't see how you will be able to do this and i'm not sure why you are seeing hits in your PBR acl for the host in the 172.21.1.x network.
    Edit - what exactly do you mean when you say -
    However when im in vlan 802 my host traffic never gets to 172.21.1.237 when pointed at the gateway 172.21.1.1.
    How are you doing this ie. pointing it to the default gateway because as i say it should always be able to communicate with 172.21.1.237 as it is in the same subnet.
    Jon

  • We have created shared folder on multiple client machine in domain environment on different 2 OS like-XP,Vista, etc. from some day's When we facing problem when we are access from host name that shared folder is accessible but same time same computer when

    Hello All,
    we have created shared folder on multiple client machine in domain environment on different 2 OS like-XP,Vista, etc.
    from some day's When we facing problem when we are access from host name that shared folder is accessible but same time same computer when we are trying to access the share folder with IP it asking for credentials i have type again and again
    correct credential but unable to access that. If i re-share the folder then we are access it but when we are restarted the system then same problem is occurring.
    I have checked IP,DNS,Gateway and more each & everything is well.
    Pls suggest us.
    Pankaj Kumar

    Hi,
    According to your description, my understanding is that the same shared folder can be accessed by name, but can’t be accessed be IP address and asks for credentials.
    Please try to enable the option below on the device which has shared folder:
    Besides, check the Advanced Shring settings of shared folder and confrim that if there is any limitation settings.
    Best Regards,
    Eve Wang
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact [email protected]

  • DUPLICATE DATABASE IN ANOTHER HOST WITH THE SAME DATABASE NAME

    Hi all.
    I want duplicate a database(dbteste1 host:wander) to another host(magda) with the same database name.
    My tnsnames in host wander is this:
    DBTESTE1 =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = wander)(PORT = 1521))
    (CONNECT_DATA =
    (SERVICE_NAME = dbteste1)
    DBTEST1 =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = magda)(PORT = 1521))
    (CONNECT_DATA =
    (SERVICE_NAME = dbteste1)
    Tnsping is ok !!!
    Follow the rman command;
    RMAN> run
    duplicate target database to dbtest1 nofilenamecheck;
    and i get the following message:
    RMAN-06136: ORACLE error from auxiliary database: ORA-01503: CREATE CONTROLFILE falhou
    ORA-01504: o nome 'dbtest1' do banco de dados nÒo corresponde ao parÔmetro db_name 'dbteste1'
    If i run this command:
    RMAN> run
    duplicate target database to dbteste1 nofilenamecheck;
    and i get the following message:
    RMAN-03015: error occurred in stored script Memory Script
    RMAN-06136: ORACLE error from auxiliary database: RMAN-20021: database not set
    RMAN-06031: could not translate database keyword
    I´m using oracle 9.2.0.7 on Windows

    Wrong procedure and connection command,
    check Oracle document,
    Duplicating a Database with Recovery Manager
    http://download.oracle.com/docs/cd/B10501_01/server.920/a96566/rcmdupdb.htm#RCMUG012
    Follow all steps listed.

  • How to set another instance of same live app as test app sharepoint 2013 provider hosted

    Hi
    I have SharePoint 2013 provider hosted app published in azure now i need to deploy another instance on same app as separate app for testing purposes, i have created another site in azure and done all profile adding packaging the app with visual studio to
    deploy .App file to SharePoint catalog.  problem is that .app file is same name and when i going to add,  it replace with same version witch deploy as live instance.
    Any one can give solution how to handle this greatly appreciated ...
    Kind Regards
    Radika

    Hi Radika,
    According to your description, there is already an app deployed in your site, you want to deploy another instance of it to the same site for testing purpose.
    As a common practice, when developing an app, for not overriding the previous version, it is recommended to create another project for testing used only with another
    name.
    By doing this, we can keep the development in the testing project, when it is done, migrate the newly customization to the original project and deploy it with a new
    version number.
    Thanks
    Patrick Liang
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support,
    contact [email protected]
    Patrick Liang
    TechNet Community Support

  • No translation group for a statically nat'd ip connecting to an external IP of a device in the same subnet

    Hi, 
    I've currently got an issue where I have a device configured with static nat that is trying to communicate to a nat'd ip address of a device in the same subnet.
    I'm getting "No translation grou found for tcp src sourceip/80 dst destip/80.
    I'm not 100% which areas of the config to post.
    Cheers,
    Neil

    Did you set the interface binding order correctly or to match the previous server?
    DNS: Valid network interfaces should precede invalid interfaces in the binding order
    http://technet.microsoft.com/en-us/library/dd391967(v=WS.10).aspx
    Modify the protocol bindings and network provider order
    http://technet.microsoft.com/en-us/library/cc732472(v=WS.10).aspx
    An incorrect IP address is returned when you ping a server by using its NetBIOS name in Windows Server 2008 or in Windows Server 2008 R2
    http://support2.microsoft.com/kb/981953
    You can view your current binding order by using this script, but please note, that I haven't tried this script, yet:
    Show NIC Binding Order
    http://gallery.technet.microsoft.com/scriptcenter/Get-NIC-Binding-Order-a2dc8087
    Also, prior to setting up the teams, make sure that the NIC is set to obtain IP automatically and not have a static entry on it. I've seen this cause problems in the past.
    If you have any unused NICs, such as Local Area Connection 2, don't just unplug them. You must disable them, otherwise they will try to register the APIPA in DNS and that will cause problems.
    Make sure that the correct DNS are on the interfaces that you need to use, too.
    Ace Fekay
    MVP, MCT, MCSE 2012, MCITP EA & MCTS Windows 2008/R2, Exchange 2013, 2010 EA & 2007, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services
    Complete List of Technical Blogs: http://www.delawarecountycomputerconsulting.com/technicalblogs.php
    This posting is provided AS-IS with no warranties or guarantees and confers no rights.

  • I recently converted from my Blackberry Torch to the Z10.  I travel a lot and use the VZ Access manager through my Torch.  Can I do the same thing through my new Z10?  I don't see that as an option on the software sight.

    I recently converted from my Blackberry Torch to the Z10.  I travel a lot and use the VZ Access manager through my Torch.  Can I do the same thing through my new Z10?  I don't see that as an option on the software sight.

        Hi Atepastt,
    Congrats on your new Z10! I know having the right features is important. The Z10 uses Blackberry link software. The device uses the mobile hotspot feature to non-cord tether the device. The mobile hotspot feature is an additional cost. You can add this feature online http://vz.to/1di2TlT .
    Thanks,
    PamelaF_VZW
    Tweet us @vzwsupport

Maybe you are looking for

  • HELP! External MIDI is playing EARLY compared to the audio tracks!

    Hi Guys I have a project in L9 which has about 12 audio tracks, each running a few effects (fairly basic ones, nothing too heavy). Tonight I am recording a rhythm part on an external MIDI device (my Kurzweil synth). I'm quantising this part to 1/8 no

  • Send view/ table in email

    Am trying to send an email from apex with a view, but I dont know how to include it in the mail body... This what I use as process when click on button... DECLARE CURSOR EMP_CURSOR IS SELECT email FROM employee; l_id NUMBER; BEGIN FOR Emp_REC IN EMP_

  • Exchange DB Recovery

    Hi, While discussing some of the points with folks we just got in to a topic of Exchange DB recovery. If i am running a Exchange 2007/2010 and if my Disk drive where DB is resided is crashed completely and do not have any backup. Now i am left with o

  • XMP confusion

    I just can't get my head around this xmp thing. Some basic info: I use DNG files I back-up my Lightroom catalogue every time Lightroom exits and under catalogue settings >metadata I have ticked: Include develop settings in metadata inside jpeg, tiff

  • HELP!! Oracle Files workflow definition needed! Please read!

    Dear friends, Please read the following and help me if you can. It is really a very important and urgent issue. We're in the middle of the OCS installation (precisely in the end of the storage layer). We have now to configure workflow, since this has