Accessing textInput's inside a panel

Okay, so I'm creating a panel with a form inside it to force a user to log into my application.
It's pretty simple to login, but I'm having trouble getting at the info inside the username and password boxes.
Here's my panel code...
private function createLoginScreen():void {
     var vb:VBox = new VBox();
     var label:Label = new Label();
     var user:TextInput = new TextInput();
     user.text = "Username";
     user.addEventListener(Event.CHANGE, setUsername);
     var pass:TextInput = new TextInput();
     pass.text = "Password";
     pass.addEventListener(Event.CHANGE, setPassword);
     var cb:ControlBar = new ControlBar();
     var s:Spacer = new Spacer();
     var b1:Button = new Button();
     s.percentWidth = 100;
     b1.label = "Submit";
     b1.addEventListener(MouseEvent.CLICK, processLogin);
     cb.addChild(s);
     cb.addChild(b1);
     vb.setStyle("paddingBottom", 5);
     vb.setStyle("paddingLeft", 5);
     vb.setStyle("paddingRight", 5);
     vb.setStyle("paddingTop", 5);
     user.width = 228;
     pass.width = 228;
     vb.addChild(user);
     vb.addChild(pass);
     panel = new Panel();
     panel.title = "Login to the Easy Lead Finder";
     panel.width = 240;
     panel.height = 140;
     panel.addChild(vb);
     panel.addChild(cb);
     PopUpManager.addPopUp(panel, this, true);
     PopUpManager.centerPopUp(panel)
Since this is all done in AS, and inside a function, I can't just do user.text to get the username's text value.
In processLogin, I need access to these so I can check them against a database I have and allow log in.
How can I access these without overly complicated CHANGE text events?

When it's set back to Event.CHANGE, I'm getting this error still.
TypeError: Error #1034: Type Coercion failed: cannot convert spark.components::TextInput@be0b479 to flash.text.TextField.
Here's the exact code I'm using.
function setUsername(e:Event){
     trace(TextField(e.currentTarget).text);
private function createLoginScreen():void {
     var vb:VBox = new VBox();
     var label:Label = new Label();
     var user:TextInput = new TextInput();
     user.text = "Username";
     user.addEventListener(Event.CHANGE, setUsername);
     var pass:TextInput = new TextInput();
     pass.text = "Password";
     pass.addEventListener(Event.CHANGE, setPassword);
     var cb:ControlBar = new ControlBar();
     var s:Spacer = new Spacer();
     var b1:Button = new Button();
     s.percentWidth = 100;
     b1.label = "Submit";
     b1.addEventListener(MouseEvent.CLICK, processLogin);
     cb.addChild(s);
     cb.addChild(b1);
     vb.setStyle("paddingBottom", 5);
     vb.setStyle("paddingLeft", 5);
     vb.setStyle("paddingRight", 5);
     vb.setStyle("paddingTop", 5);
     user.width = 228;
     pass.width = 228;
     vb.addChild(user);
     vb.addChild(pass);
     panel = new Panel();
     panel.title = "Login to the Easy Lead Finder";
     panel.width = 240;
     panel.height = 140;
     panel.addChild(vb);
     panel.addChild(cb);
     PopUpManager.addPopUp(panel, this, true);
     PopUpManager.centerPopUp(panel)

Similar Messages

  • Trying to get components inside a panel in content pane

    Hello,
    I am trying to update the combo boxes inside a panel with a list of values(list is stored as an array).
    My heirarchy of components is as follows:
    frame-->contentpane-->gamepanel-->combopanel-->combobox
    i am able pass my frame into my code. now i have to get the combobox to update it.
    frame.getcontentpane()this returns to me my contentpane - RIGHT/WRONG???
    if right, after this how do i reach the combopanel and get the combobox such that I am able to write
    combobox.addItem(array)HELP PLEASEEEEEEEEEEEEE
    Thanks,
    Manju

    Be patient. 30 minutes is not a long time to wait for answers, especially on the weekend. Instead of waiting impatiently why don't you try reading sections from the Swing Tutorial. For example, How to Use Combo Boxes:
    http://java.sun.com/docs/books/tutorial/uiswing/components/combobox.html
    so how do i keep the reference?Define a class variable for the combo box:
         This works on non editable combo boxes
    import java.awt.*;
    import java.awt.event.*;
    import javax.swing.*;
    import javax.swing.text.*;
    public class ComboBoxAction extends JFrame implements ActionListener
         JComboBox comboBox;
         public ComboBoxAction()
              comboBox = new JComboBox();
              comboBox.addActionListener( this );
              comboBox.addItem( "Item 1" );
              comboBox.addItem( "Item 2" );
              comboBox.addItem( "Item 3" );
              comboBox.addItem( "Item 4" );
              //  This prevents action events from being fired when the
              //  up/down arrow keys are used on the dropdown menu
              comboBox.putClientProperty("JComboBox.isTableCellEditor", Boolean.TRUE);
              getContentPane().add( comboBox );
         public void actionPerformed(ActionEvent e)
              System.out.println( comboBox.getSelectedItem() );
              //  make sure popup is closed when 'isTableCellEditor' is used
              comboBox.hidePopup();
         public static void main(String[] args)
              final ComboBoxAction frame = new ComboBoxAction();
              frame.setDefaultCloseOperation( EXIT_ON_CLOSE );
              frame.pack();
              frame.setVisible( true );
    }Even though the combo box is created in the constructor, the actionPerformed() method can still access the combo box because it was defined as a class variable.

  • Can I access a label inside of an MC and then go back to the main time line

    Here is my current set up.
    I have a labeled section on main time line which has icons of 12 different videos. Each icon acts as a button and brings a user to a labeled section with a FLV Video Playback component impemented to play the corresponding video. These labeled sections are located on the main time.
    This methog makes my main time line very long. Is there a way to make an additional MC which will hold all the video buttons and then have this MC separated into labeled sections.
    In other words can I access a label inside of an MC and then go back to the main time line?
    My present code for accessing the label located on the main timeline is:
    HowTo_maininfo_mc.theArrangement_btn.addEventListener(MouseEvent.CLICK, theArrangement_btn_amimated_btnDown);
    function theArrangement_btn_amimated_btnDown(event:MouseEvent):void {
    gotoAndPlay("theArrangement");
    How would it look if my label "theArrangement" would be located inside of an MC?
    Is there any specific code if I want to have a close button located on the label inside of an MC and it needs to fire out to a label located on the main timeline?

    Oh, WOW! It is working perfectly now.
    My mistake was that I was specifiying the var sourceVar:String;
    for every single button. It was not clear to me from the first example that it has to be specified only once.
    I made a small test Flash file and everything works now. It still doesn't work on my big flash file, I guess some other code messes it up and I can' not figure what it is exactly.
    I would like to include the OUTPUT error message in hopes that you can spot right away what a mistake could be:
    VideoError: 1000: Unable to make connection to server or to find FLV on server
              at fl.video::VideoPlayer/stop()
              at fl.video::FLVPlayback/stop()
              at acolyteVideos_fla::mainsite_mc_2/stopF2()[acolyteVideos_fla.mainsite_mc_2::frame484:21]
              at flash.display::MovieClip/gotoAndPlay()
              at acolyteVideos_fla::mainsite_mc_2/onClick_GoBackToHowTo2()[acolyteVideos_fla.mainsite_mc_2 ::frame484:13]
    If there is no immediate cure for it, I will go through code line by line. Since it is working on the test it must be something wrong with my main file.
    Additiona question (please let me know if I should paste it as a new thread)
    I have similar set up with UILoader. Where different buttons set up to bring a user to individual labeled sections with individual UILoader. Should it be arranged in the same way that it is only one loader and "var sourceVar:String;" code is the one which brings up different content for each button?

  • Access session variable inside AM module

    Is there any way to access session variable inside AM module custom function?
    I created one client interface function in AM and want to access one session variable value inside AM custom function.
    Please suggest.
    Thanks

    Hi
    here i need help to find out right approach,my use case are below
    1.User will login thorough SSO .
    2.Based on used id i need to display user data in table form.
    3.User-id will need to display in right corner of page template ( JSF page with this page template)
    4.user can update/create new table data by pressing update/createinsert button.
    5.Once user press the create new request button,one empty row will popup which have user-id filled automatically (used-id who logged in) and will read only ,so that once user commit the data,DB can update/insert the data with that user-id
    so far i have done point 1,2,4 and 5 like
    1.i created AM preparesession and store the use id.
    2.i have putted whereclause in AM for particular VO and run execute query and able to see particular user data,who logged in.
    4.created servicemethod for createinsert in AM and exposed it ,and set used-is table attribute which i got in AM preparession .Now i am able to see new row with user-id in one column in read only form when
    Is this the right approach ? and now i am not able to do step 3 so how to display same user-id in pagetemplate as this value is available in AM only.

  • TABbing between controls inside a panel to controls outside a Panel

    Hi,
    I have a C# winform with few controls inside a Panel control and few outside it.The TABbing order traverse from controls inside a panel to controls outside a panel.
    Do we have any way to accomplish this.
    Thanks,
    sami

    If you set the TabIndex of the Panel control itself to for example 77, the outside control with TabIndex 78 will be focused when you tab out from the control within the Panel with the highest TabIndex. Also make sure that you set the Tabstop property
    of the Panel to true.
    So basically the controls inside the Panel have their own TabIndex series (starting from 0) and the Panel itself is part of the Form's (or parent control's) TabIndex series.
    It is just a matter of setting the values of the TabIndex properties correctly (and setting the Tabstop property to true for the Panel control).
    The other option is to replace the Panel with a UserControl.
    Please remember to close your threads by marking helpful as answer and then start a new thread if you have a new question.

  • Access Session variable inside Transaction

    Hi All,
    Is it possible to access session variables inside Transaction.
    Create session variable.
    Update session variable value
    acccess Session variable.
    (user session)
    Regards,
    Sachin

    Hi Sachin,
    Here is the snapshot:
    1. Take session variable in a local JS variable in HTML page.
    2. Create a transaction with a input type variable in Transaction Properties.
    3. Create a Xacute query and link the above transaction.
    4. Creata a iCommand applet on HTML page and link the query template:
    <PARAM NAME="QueryTemplate" VALUE=".../QueryName">
    Call the function in the below way in HTML:
    Applet.getQueryObject().setParam(1,vaiable)
    So, the session variable will go to TRX (BLT) and perform the operations as per your need..
    You can pass it to other TRX by the same way.
    To fetch the value: Create output type variable in TRX 2. Create Xacute query.
    Get the value with : Applet.getValue(1,1)
    Hope it is useful.
    Best Regards,
    Kedar

  • Webpage inside a panel

    Hi all,
    Can I open a webpage inside a panel, is there is a control that I can put it on the panel and then open a website into it.
    Thanks

    Your response surprised me, so I did a little test:
    Using this tiny bit of code, I was able to load HTML and drag images from an HTML element into an InDesign document.
    To handle different data types, you'll obviously have to do a bit more work, but it's definitely doable!
    <?xml version="1.0" encoding="utf-8"?>
    <mx:Application xmlns:mx="http://www.adobe.com/2006/mxml" layout="absolute" historyManagementEnabled="false">
        <mx:Script>
            <![CDATA[
                [Bindable]
                private var hostName:String = HostObject.mainExtension;
                private function onNativeDragStart(e:NativeDragEvent):void{
            ]]>
        </mx:Script>
        <mx:HTML width="100%" height="100%" location="http://in-tools.com" nativeDragStart="onNativeDragStart(event)"/>
    </mx:Application>
    Harbs

  • Can't access TextInput's text from inside the parent class

    Hi
    i have a really strange problem here:
    When I add a TextInput to the stage I can access it with instanceName.text. this works.
    Now I have one Movieclip with one TextInput inside (the textinput's instance name is testetxt). This MovieClip has a corresponding class and its code is the following:
    class com.sck.testeT extends MovieClip
         public var testetxt:MovieClip;
         public function testeT()
              testetxt._alpha=50;
              testetxt.text="test";
    The textinput gets transparent but the text isn't changed... I realized it was because the textinput wasn't initialized yet. so I have to wait a while, but how can I know that it was initialized and I can set the initial text by code?
    thanks a lot!

    the usual work-around is to start an onEnterFrame loop that you terminate after one loop and after that one loop everything created in that first frame is initialized.

  • Can't Ping or access via SNMP Inside interface of 5505

    I have a remote site I'm trying to setup monitoring on and I can't get the inside interface to respond to a ping or SNMP requests.  I have tried everything I can find in the forums and on the web but this location will not cooperate.  I have full access to the ASA and to the inside network behind it.  IPSEC VPN tunnel is working perfectly.  I see the ping requests in the log on the ASA.  I turned on ICMP debugging and only see the echo request.. never an echo reply.  Below is a partial configuration.  If you need any more information, let me know.
    names
    name 192.168.0.0 Domain
    name 1.1.1.2 MCCC_Outside
    name 172.31.10.0 VLAN10
    interface Ethernet0/0
     switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
     nameif inside
     security-level 100
     ip address 192.168.23.1 255.255.255.0
    interface Vlan2
     nameif outside
     security-level 0
     ip address 1.1.1.1 255.255.255.0
    boot system disk0:/asa847-k8.bin
    ftp mode passive
    clock timezone EST -5
    clock summer-time EDT recurring
    dns server-group DefaultDNS
     domain-name mtcomp.org
    object network obj-192.168.23.0
     subnet 192.168.23.0 255.255.255.0
    object network Domain
     subnet 192.168.0.0 255.255.0.0
    object network 172.31.0.0
     subnet 172.31.0.0 255.255.0.0
    access-list outside_1_cryptomap extended permit ip 192.168.23.0 255.255.255.0 any
    access-list outside_1_cryptomap extended permit ip 192.168.23.0 255.255.255.0 object Domain
    access-list inside_nat0_outbound extended permit ip 192.168.23.0 255.255.255.0 192.168.1.0 255.255.255.0
    access-list inside_nat0_outbound extended permit ip 192.168.23.0 255.255.255.0 object Domain
    access-list Outside_NAT0_inbound extended permit ip object Domain 192.168.23.0 255.255.255.0
    access-list inside_access_in extended permit ip 192.168.23.0 255.255.255.0 any
    access-list inside_access_in extended permit ip any 192.168.23.0 255.255.255.0 inactive
    no pager
    logging enable
    logging timestamp
    logging buffered debugging
    logging trap informational
    logging asdm informational
    logging device-id hostname
    logging host inside 192.168.x.x 17/1514
    mtu inside 1500
    mtu outside 1500
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit any inside
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    nat (inside,any) source static obj-192.168.23.0 obj-192.168.23.0 destination static Domain Domain no-proxy-arp route-lookup
    route outside MCCC_Outside 255.255.255.255 1.1.1.1 1
    route outside 172.31.0.0 255.255.0.0 192.168.1.1 1
    route outside VLAN10 255.255.255.0 MCCC_Outside 1
    route outside Domain 255.255.0.0 192.168.1.1 1
    route outside 192.168.1.0 255.255.255.0 MCCC_Outside 1
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    aaa authentication ssh console LOCAL
    aaa authentication enable console LOCAL
    http server enable
    http 192.168.1.81 255.255.255.255 inside
    http 192.168.1.0 255.255.255.0 inside
    http 192.168.23.0 255.255.255.0 inside
    snmp-server host inside 172.x.x.x community ***** version 2c
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto map outside_map 1 match address outside_1_cryptomap
    crypto map outside_map 1 set pfs group1
    crypto map outside_map 1 set peer MCCC_Outside
    crypto map outside_map 1 set ikev1 transform-set ESP-3DES-SHA
    crypto map outside_map 1 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
    crypto map outside_map interface outside
    management-access inside
    class-map inspection_default
     match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
     parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
     class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect ip-options
      inspect netbios
      inspect rsh
      inspect rtsp
      inspect skinny 
      inspect esmtp
      inspect sqlnet
      inspect sunrpc
      inspect tftp
      inspect sip 
      inspect xdmcp
      inspect icmp
    policy-map global-policy
    service-policy global_policy global
    prompt hostname context

    Hi,
    First of all let me clarify your trial.
    Where is your monitoring server?
    Is it behind inside or outside interface (please share ip adress)?
    From config it seems, it can be reach via outside interface. Then you have to make snmp check on outside interface, not on inside (cannot make a snmp/ping check on inside interface with request comming through outside inteface - it simply won't work).
    From the first check of routing table, I would suggest:
    delete : route outside MCCC_Outside 255.255.255.255 1.1.1.1 1 - doesn't make a sense route host address, when it's directly connected network (and more, route 1.1.1.2 to 1.1.1.1, when 1.1.1.1 is vlan2 interface)
    change : route outside 172.31.0.0 255.255.0.0 192.168.1.1 1; route outside Domain 255.255.0.0 192.168.1.1 1 - you should consider route it to 1.1.1.2 (if this is your next hop address at WAN).
    route outside VLAN10 255.255.255.0 MCCC_Outside 1 - why?
    I would use default route to somewhere at 1.1.1.0/24 range - next hop (router).
    HTH,
    Pavel

  • Master detail inside collapsible panel

    I am using Spry's Master Detail to display an image gallery... thumbnails stacked vertically and floated on the left side of a large image.  This Master Detail gallery sits inside a collapsible panel.  When I click on a image thumbnail that's taller than it is wide the large image pushes the content below it down into the panel below.  The gallery's collapsible panel doesn't expand.  Instead the content is pushed into, and sits behind the panel below.  The panels are then overlapping.  Any idea how I be sure the panel expands and pushes the panels below down accordingly?
    Thanks,
    Patrick

    Hi Patrick,
    To set the height of a collapsible panel, add a height property to the CollapsiblePanelContent rule or the CollapsiblePanel rule.
    In the SpryCollapsiblePanel.css file, add a height property and value to the CollapsiblePanelContent rule, for example, height: 300px;. Note: Setting the height of the CollapsiblePanel rule sets the height of the entire widget, independent of the content panel size.
    I hope this helps.
    Ben

  • Can't access EWS and front printer panel options all locked

    The web services icon and Network icons are disabled. All the options on the front panel to connect to the network are locked so I can't do anything from the printer panel.
    I printed the Network configuration and obtained the ip address but the EWS does not come up. It says it can't connect.
    I tried the ip address that i previously used to connect with and that won't come up either.
    How do i get the printer connected to the Network again? HELP!

    Thanks for the response.
    I tried unplugging the plug but that did not reset the printer.
    I found another post that explained how to access a hidden Suppot menu.
    I was able to find the option that performs a partial reset and that restored all the functionality
    to connect to the network.
    The printer is on the network and I can now access the EWS. I also modified the admin settings
    to not lock the printer panel again!

  • Problem with Accordion Widget INSIDE Sliding Panel Widget

    Hello,
    perhaps I should not do this, but I nested an Accordion
    Widget inside a Sliding Panels Widget:
    - There are eight Panels.
    - Each one contains a complete Accordion.
    The sliding works fine, and so does the Accordion animation,
    but the text inside the Accordion Panel Tabs won't move along, when
    a tab is activated. I need to hover the mouse over the accordion to
    make the panel texts appear again.
    Of course, when I un-nest the widgets and move the Accordion
    widget out of the Sliding Panel widget, everything is fine.
    My question is:
    - am I demanding "too much" by nesting the widgets?
    - or should this basically work, and the problem arises from
    rivalling scripts?
    Here is a link:
    Nested
    widgets Test
    The horizontal top menu will activate the sliding panels, but
    as of now only the leftmost menu item contains an Accordion (I know
    the CSS does not look nice yet).
    Is there anything I can optimise to get this to work?
    Thank you so much,
    Greetings, Jensen
    Edit: The problem does NOT occur in Firefox, but in
    Safari.

    Hi John,
    That is the expected behavior if the "Overlap items below" is unchecked. Please refer to the following link http://screencasteu.worldsecuresystems.com/aish/2013-08-21_1947.png. If you don't want the page to wiggle up and down, please check the box shown in the screenshot.
    Regards,
    Aish

  • OS X accessing iTunes Library inside Parallels-Windows

    Hello,
    over the last year I have built up quite a big iTunes library with content from the iTunes store (950GB, + approx. 25GB each month).
    (Its a family library, no addicts at work here )
    Now I need a way to securely store my files, since they have outgrown my iMac's HDD.
    I want full redundancy (all data must exist on at least two drives) and adequate speed (should allow FullHD streaming over Gigabit Ethernet) at the lowest cost possible.
    However, I dont need off-site redundancy. If my house burns down, I dont care about my movies.
    Since I am not aware of a software solution for MacOS X, I had one crazy idea.
    Use the oldest Intel Mac Pro, run an iTunes Server in Windows Home Server in Parallels and: Voila.
    My reasoning here is this:
    The old Intel Mac Pro's are available fairly cheap.
    They have plenty of SATA-connectors (I want at least 3TB, not possible in Mac Mini or iMac).
    They deliver great streaming performance.
    Windows Home Server stores each file on two different physical drives.
    However, they are all combined to one big logical drive and all the "cloning" happens in the background.
    Almost like RAID 5, just at file-level and not KB-level.
    Exclusions and rules can be specified, too. Its just what I need.
    I could not find another solution that promised the same bang for the buck.
    OS X does not support software RAID 5.
    When hardware RAID 5 controller-card fails all data goes out the window, unless a compatible card is installed... Thats a No-Go.
    The reason for a Mac OS host system would be to allow for remote access via the internet (screen sharing).
    Also, WHS could just run in the background inside Parallels and the Mac OS could be used as an AppleTV replacement.
    (Nice AppleTV GUI's for Frontrow are available)
    Does this sound like it would work?
    Are there any solutions that are more straightforward and dont require Windows?
    The only thing that worries me is this:
    WHS stores everything on NTFS partitions.
    If I want to add data (say, a movie) to the central library, how could I get it into Windows without using USB-drives or other crazy solutions?
    And also: Would Mac OS be able to acces the library directly, or would it have to go through the network (two network cards would be no problem).
    Thanks for any comments.
    Message was edited by: Jokener

    I ran into an issue with the "Choose Library" step.
    When I went into the folders to find the iTunes Library file, it wasn't there. So, re-started in Mac just to make sure I hadn't messed with that file location. Sure enough, the file was actually there, but the filename extension is different in Windows 7 and Mac - I think that's why it's not visible for me to select. I think the Mac is *.itdb, and the file type that it was looking for in Windows was *.itl
    I was unable to get Windows to search for another file type.
    So, then I tried to create a new library, but that didn't work because there was no music in the new location, and I couldn't save a new library into that folder.
    I'm going to go play with it now to see if I can just copy the actual music files into the default location in Windows and create a new library.
    Your post was really helpful, and it got me started!
    Thanks!
    Message was edited by: TheBeBlend

  • Auto-select field after clicking link inside Appearance panel

    Before Illustrator CC 2014, when I clicked on a link inside the appearance window, the corresponding field would auto select. This made for a more efficient workflow. But now for some reason this has disappeared and I miss it! Hey Illustrator team, can you guys add it back in the next release?
    How to reproduce:
    Click on Opacity in the Appearance panel > "mini" opacity panel opens.
    Opacity field should be selected so all the user has to do is click up or down arrows on their keyboard.
    Just something small I noticed after I upgraded to CC 2014. Not a big deal honestly, but a small regression.

    You might try the steps in this Knowledge Base article;
    http://docs.info.apple.com/article.html?artnum=304482
    Dah•veed

  • Is it possible to access an object inside a Captivate movie from Javascript?

    For example, my JavaScript performs some processing, based on which a particular button inside the movie needs to be hidden. Can I access a particular button from JavaScript to be able to do this? If not, then is it possible to be notified inside the Captivate movie, when a variable has been set by JavaScript?  I notice that the JavaScript interface in Captivate 8 provides an event (CPAPI_VARIABLEVALUECHANGED) which fires when the value of a variable inside the Captivate movie changes. If there was a similar event which would fire inside the Captivate movie, when a variable changes then I could have set a variable using JavaScript and hidden a particular button using an advanced action, when the event for that variable changing fires inside the Captivate movie.
    Articulate Storyline has an event which gets triggered when the value of a variable changes (either because of JavaScript executing or otherwise). If something similar was possible in Captivate, it would open up many possibilities.
    I am evaluating Captivate 8.
    Thanks in advance for any help.

    hi
    Yes. its possible but its not recom
    you can set in production system to allow changes to obj rsa1->transport connection->click 'object changeability', and look for object type , and set to changeable.
    pls refer these below posts
    transport a query backwards, from production to development
    Re: Transporting Process Chains from Production DOWN to QA and Dev
    assign points if useful.....
    Shreya

Maybe you are looking for