ACE - timeout inactivity problem

Hi All,
I've got a strange problem with session counts and timeout on an ACE (2.1.3).
I created a connection parameter-map to an existing configuration, added it to the load-balance configuration and then removed and re-added the service policy. The context is in bridge mode.
parameter-map type connection FINJAN
set timeout inactivity 60
set tcp timeout half-closed 60
policy-map multi-match Finjan-04-LB-policy
class VIP-production_class
loadbalance vip inservice
loadbalance policy production-8080_LB_policy
loadbalance vip icmp-reply
connection advanced-options FINJAN
class VIP-beta_class
loadbalance vip inservice
loadbalance policy beta-8080_LB_policy
loadbalance vip icmp-reply
connection advanced-options FINJAN
interface vlan 396
description slb vlan
bridge-group 396
access-group input BPDU
access-group input PERMIT-ALL
service-policy input Finjan-04-LB-policy
no shutdown
But I'm still seeing sessions with idle times of minutes.
For example:
27344 1 in TCP 397 10.199.253.103:3563 61.143.251.173:80 ESTAB
[ idle time : 00:16:47, byte count : 975 ]
[ elapsed time: 00:20:30, packet count: 14 ]
Is there anything else I need to do to make the timeout effective? I need to get this working before I can limit the number of connections to each real server.
Also the output of "sh serverfarm" shows many more current connections than a "sh conn de" command. Is this expected?
E.g:
ace2/finjan# sh serverfarm beta-farm-8080
serverfarm : beta-farm-8080, type: HOST
total rservers : 7
----------connections-----------
real weight state current total failures
---+---------------------+------+------------+----------+----------+---------
rserver: beta_blade-1
10.199.253.111:0 8 OPERATIONAL 44982 39669799 45323
rserver: beta_blade-2
10.199.253.112:0 8 OPERATIONAL 49594 42955799 60246
rserver: beta_blade-3
10.199.253.113:0 8 OPERATIONAL 51545 46098331 49868
rserver: beta_blade-4
10.199.253.114:0 8 OPERATIONAL 51659 46260307 57544
rserver: production_blade-2
10.199.253.102:0 8 OPERATIONAL 720 540878 41145
rserver: production_blade-3
10.199.253.103:0 8 OPERATIONAL 51270 45832507 45670
rserver: production_blade-4
10.199.253.104:0 8 OPERATIONAL 51870 45779920 47624
when the "sh conn de" reports about 14000 sessions.
Any help appreciated.
Thank you
Cathy

I moved the service policy from the client vlan to the global config - in the hope of being able to apply the connection parameter-map. Just after I did that the whole ACE reloaded (failure in arp_mgr). Hopefully unrelated.
I do see unbalanced flows;
5078 1 in TCP 397 10.199.253.112:6005 211.166.10.66:80 ESTAB
[ idle time : 00:16:56, byte count : 1644 ]
[ elapsed time: 00:19:17, packet count: 29 ]
35 1 out TCP 396 211.166.10.66:80 10.199.253.112:6005 CLOSED
[ conn in reuse pool : FALSE]
[ idle time : 00:19:14, byte count : 28504 ]
[ elapsed time: 00:19:17, packet count: 21 ]
Is there anything I can do about this or is it dependent on the server-side doing something?
Thank you
Cathy

Similar Messages

  • ACE dropped conns problem (Bridged mode)

    Dear all,
    I configured an ACE in bridged mode (inside vlan: 2012, outside vlan: 2021) and I apply the L4 policy on the 2 VLAN interface to loadbalance HTTP incoming request (Virtual IP: 172.22.22.130).
    interface vlan 2112
      bridge-group 1
      access-group input BPDU-Allow
      service-policy input POLICY-LB-HMC-2112
      no shutdown
    interface vlan 2122
      bridge-group 1
      access-group input BPDU-Allow
      service-policy input POLICY-LB-HMC-2112
      no shutdown
    But I need also that some other server connected to the same vlan 2112 and having to send HTTP request on the same VIP but this failed and I get dropped conns.
    Can anyone helps?
    Regards
    Abdelaziz

    Hi Olivier,
    This below the full config, and my need is to make a server in the inside VLAN 2112 (172.22.22.121) to open HTTPS connexion on the VIP (172.22.22.130 for rserver .131 & .132). Trafic from the outside is working well.
    Thanx,
    Abdealziz
    Generating configuration....
    access-list BPDU-Allow ethertype permit bpdu
    probe tcp HTTPS
      port 443
      interval 15
      passdetect interval 15
      passdetect count 1
    probe icmp PING
      interval 5
    rserver host CASHUB131
      ip address 172.22.22.131
      inservice
    rserver host CASHUB132
      ip address 172.22.22.132
      inservice
    serverfarm host SFARM-EXCAS130
      probe HTTPS
      rserver CASHUB131
        inservice
      rserver CASHUB132
        inservice
    parameter-map type connection TCP_IDLE_30min
      set timeout inactivity 1800
    class-map match-all CLASS-L4-VIP-EXCAS130
      2 match virtual-address 172.22.22.130 any
    class-map type management match-any REMOTE-ACCESS
      description management ACE
      10 match protocol telnet any
      20 match protocol ssh any
      30 match protocol icmp any
      31 match protocol https any
      32 match protocol snmp any
    policy-map type management first-match REMOTE-MGT
      class REMOTE-ACCESS
        permit
    policy-map type loadbalance first-match POLICY-L7-VIP-EXCAS130
      class class-default
        serverfarm SFARM-EXCAS130
    policy-map multi-match POLICY-LB-HMC-2112
      class CLASS-L4-VIP-EXCAS130
        loadbalance vip inservice
        loadbalance policy POLICY-L7-VIP-EXCAS130
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
    interface vlan 2112
      bridge-group 1
      access-group input BPDU-Allow
      service-policy input POLICY-LB-HMC-2112
      no shutdown
    interface vlan 2122
      bridge-group 1
      access-group input BPDU-Allow
      service-policy input POLICY-LB-HMC-2112
      no shutdown
    interface bvi 1
      ip address 172.22.22.250 255.255.255.0
      peer ip address 172.22.22.251 255.255.255.0
      no shutdown
    ip route 0.0.0.0 0.0.0.0 172.22.22.254

  • Ace ssl-proxy problem, Online store.

    Hello!
    I have a problem with moving our online store loadbalancing to a Cisco ACE solution from Windows NLB that it runs on now. And also relive the servers from the ssl encrypt and decrypting of sessions.
    The load balancing works', as long the session is Http, but when the "customer" comes to the point that i is going to pay. Our shop is jumping over to HTTPs and this is where the problem appear.
    The "customer" is getting the certificate right but the site is not displayed = the session to the shop seems to die.
    If i have missed something in the config or if someone have any other idea why this dont work for me..
    Appreciate any help!
    My config:
    (at the moment only web5 is in use)
    ACE-1/CO-WEB1# show run
    access-list ANY line 10 extended permit ip any any
    access-list icmp line 8 extended permit icmp any any
    probe http PROBE-HTTP
    interval 3
    passdetect interval 10
    passdetect count 2
    expect status 200 200
    expect status 300 323
    parameter-map type ssl SSLPARAMS
    cipher RSA_WITH_RC4_128_MD5
    rserver host vmware-server1
    description testserver1
    ip address 219.222.4.180
    probe PROBE-HTTP
    inservice
    rserver host vmware-server2
    description testserver 2
    ip address 219.222.4.181
    probe PROBE-HTTP
    inservice
    rserver host web5
    description testserver from windows nlb
    ip address 219.222.4.185
    probe PROBE-HTTP
    inservice
    ssl-proxy service SSL-PROXY-SE
    key cert-se.key
    cert cert-se.pem
    ssl advanced-options SSLPARAMS
    serverfarm host WM-ware_servers
    rserver vmware-server1
    inservice
    serverfarm host webtest
    description testserver-farm
    predictor leastconns
    rserver vmware-server1 80
    rserver vmware-server2 80
    rserver web5
    inservice
    sticky ip-netmask 255.255.255.0 address source STICKY-GROUP1
    timeout 60
    serverfarm webtest
    class-map match-all VIP-HTTP
    2 match virtual-address 219.222.4.178 tcp eq www
    class-map match-all VIP-HTTPS
    2 match virtual-address 219.222.4.178 tcp eq https
    class-map type management match-any icmp
    description for icmp reply
    2 match protocol icmp any
    policy-map type management first-match icmp
    class icmp
    permit
    policy-map type loadbalance first-match VIP-HTTP
    class class-default
    sticky-serverfarm STICKY-GROUP1
    policy-map type loadbalance first-match VIP-SSL
    class class-default
    serverfarm webtest
    policy-map multi-match SLB-VIP-HTTP
    class VIP-HTTP
    loadbalance vip inservice
    loadbalance policy VIP-HTTP
    loadbalance vip icmp-reply
    class VIP-HTTPS
    loadbalance vip inservice
    loadbalance policy VIP-SSL
    loadbalance vip icmp-reply
    ssl-proxy server SSL-PROXY-SE
    interface vlan 21
    description ### ACE OUTSIDE mot FW ###
    ip address 219.222.4.171 255.255.255.240
    access-group input ANY
    access-group output ANY
    service-policy input icmp
    service-policy input SLB-VIP-HTTP
    no shutdown
    interface vlan 22
    description ### ACE INSIDE Gateway for Web-servers ###
    ip address 219.222.4.177 255.255.255.240
    access-group input ANY
    access-group output ANY
    service-policy input icmp
    no shutdown
    ip route 0.0.0.0 0.0.0.0 219.222.4.161
    ACE-1/CO-WEB1#
    as seen in "show conn" the sessions is established, first when i enter site, and go to payment (jumping over to SSL):
    ACE-1/CO-WEB1# show conn
    total current connections : 4
    conn-id np dir proto vlan source destination state
    ----------+--+---+-----+----+---------------------+---------------------+------+
    4 1 in TCP 21 219.222.0.2:49972 219.222.4.178:443 ESTAB
    14 1 out TCP 22 219.222.4.185:443 219.222.0.2:49972 ESTAB
    11 2 in TCP 21 219.222.0.2:49923 219.222.4.178:80 ESTAB
    3 2 out TCP 22 219.222.4.185:80 219.222.0.2:49923 ESTAB
    ACE-1/CO-WEB1#

    Hello Krille
    i had the same problem.
    The HTT Probe you define will do a check if
    the return code is
    expect status 200 200
    expect status 300 323
    Now if a user is accessing the hppts site, in the flow there will be an expect status like 404, the ACE now is not establish an sticky connection, cause it think that the flow is not ok.
    The only output after ther Certificates is a blank site.
    If you change the Probing to ICMP you will be able to access the https site and the connection is sticky. With a litte tool like IE Watch you will be able to see the wrong Status codes.
    regards
    eberhard

  • ACE Load Balancing Problem

    Hi,
    I have ACE 4701 with c4710ace-mz.A3_2_2.bin image. In the current setup ACE is located in the center of network where all the WAN, Intenret and LAN is connected and ACE has default towards Internet and All other segment has default route towards ACE appliance. ACe is only redirecting the port 80 traffic to my Proxy server and bypass my lan subnet on port 80.
    Internet
    i
    i
    i
    i
    i
    ACE--------------------------------WAN
    i
    i
    i
    i
    LAN
    I want to use ACE for the load balancing of two servers. Today I did the load balancing configuration but as soon as I applied the policy map on the interface vlan 200 and 300, my complete network reachability went down. When I remove the policy my network came back to normal.
    192.168.200.66  FAX Server-1
    192.1168.200.67 FAX Server-2
    192.168.200.65   Virtual IP address
    Attached is the configuration that I did on ACE for the load balancing and below is the current configuration of the ACE appliance.
    access-list acl-in remark ACCESS LIST FOR ACE-INSIDE
    access-list acl-in line 1 extended permit ip any any
    access-list acl-out remark ACCESS LIST FOR ACE-OUTSIDE
    access-list acl-out line 1 extended permit ip any any
    access-list acl-proxy remark ACCESS LIST FOR PROXY SEGMENT
    access-list acl-proxy line 1 extended permit ip any any
    access-list acl-wan remark ACCESS LIST FOR WAN SEGMENT
    access-list acl-wan line 1 extended permit ip any any
    probe tcp PROBE_5050
    port 5050
    interval 15
    passdetect interval 60
    open 1
    probe tcp PROBE_5101
    port 5101
    interval 15
    passdetect interval 60
    open 1
    probe tcp PROBE_TCP
    port 80
    interval 15
    passdetect interval 60
    open 1
    parameter-map type http PARAMAP_CASE
    case-insensitive
    no persistence-rebalance
    rserver host RS_BCPR01
    ip address 192.168.0.103
    inservice
    rserver host RS_BCPR02
    ip address 192.168.0.104
    inservice
    rserver host RT_fax1
    description Right Fax Server-1
    ip address 192.168.200.66
    rserver host RT_fax2
    description Right Fax Server-2
    ip address 192.168.200.67
    serverfarm host SF_BCPR
    transparent
    probe PROBE_5050
    probe PROBE_5101
    probe PROBE_TCP
    rserver RS_BCPR01
    inservice
    rserver RS_BCPR02
    inservice
    serverfarm host SF_RT_fax
    rserver RT_fax1
    rserver RT_fax2
    sticky ip-netmask 255.255.255.255 address source STICKY-SOURCE
    replicate sticky
    serverfarm SF_BCPR
    sticky ip-netmask 255.255.255.255 address source FAX-STICKY
    replicate sticky
    serverfarm SF_RT_fax
    class-map type management match-any CM_ALL
    2 match protocol snmp any
    3 match protocol http any
    4 match protocol https any
    5 match protocol icmp any
    6 match protocol telnet any
    class-map match-any CM_BYPASS_FOR_LAN
    3 match virtual-address 100.1.1.0 255.255.255.0 tcp eq www
    8 match virtual-address 10.0.0.0 255.0.0.0 tcp eq www
    9 match virtual-address 172.16.0.0 255.255.0.0 tcp eq www
    10 match virtual-address 192.168.0.0 255.255.0.0 tcp eq www
    class-map match-any CM_BYPASS_SUBNET
    9 match virtual-address 100.0.0.0 255.0.0.0 tcp eq www
    13 match virtual-address 10.0.0.0 255.0.0.0 tcp eq www
    14 match virtual-address 172.16.0.0 255.255.0.0 tcp eq www
    15 match virtual-address 192.168.0.0 255.255.0.0 tcp eq www
    class-map match-any CM_IM
    2 match virtual-address 0.0.0.0 0.0.0.0 tcp eq 5050
    3 match virtual-address 0.0.0.0 0.0.0.0 tcp eq 1080
    4 match virtual-address 0.0.0.0 0.0.0.0 tcp eq 5101
    class-map match-all CM_SF_BCPR
    255 match virtual-address 0.0.0.0 0.0.0.0 tcp eq www
    class-map match-any RT_FAX
    2 match virtual-address 192.168.200.65 0.0.0.0 any
    policy-map type management first-match PM_ALL
    class CM_ALL
    permit
    policy-map type loadbalance http first-match PM_L7_BYPASS_FOR_LAN_HTTP
    class class-default
    forward
    policy-map type loadbalance http first-match PM_L7_BYPASS_HTTP
    class class-default
    forward
    policy-map type loadbalance first-match PM_LB_RT_FAX
    class class-default
    sticky-serverfarm FAX-STICKY
    policy-map type loadbalance http first-match PM_LB_SF_BCPROXY
    class class-default
    sticky-serverfarm STICKY-SOURCE
    policy-map multi-match PM_BYPASS_FOR_LAN_HTTP
    class CM_BYPASS_FOR_LAN
    loadbalance vip inservice
    loadbalance policy PM_L7_BYPASS_FOR_LAN_HTTP
    policy-map multi-match PM_BYPASS_HTTP
    class CM_BYPASS_SUBNET
    loadbalance vip inservice
    loadbalance policy PM_L7_BYPASS_HTTP
    policy-map multi-match PM_MAIN_BCPROXY
    class CM_SF_BCPR
    loadbalance vip inservice
    loadbalance policy PM_LB_SF_BCPROXY
    loadbalance vip icmp-reply active
    appl-parameter http advanced-options PARAMAP_CASE
    class CM_IM
    loadbalance vip inservice
    loadbalance policy PM_LB_SF_BCPROXY
    policy-map multi-match PM_RT_FAX
    class RT_FAX
    loadbalance vip inservice
    loadbalance policy PM_LB_RT_FAX
    service-policy input PM_ALL
    interface vlan 100
    description FW-INSIDE CONTEXT RACK1
    ip address 192.168.0.5 255.255.255.224
    alias 192.168.0.11 255.255.255.224
    peer ip address 192.168.0.6 255.255.255.224
    mac-address autogenerate
    no icmp-guard
    access-group input acl-out
    no shutdown
    interface vlan 200
    description WAN-VLAN CONTEXT RACK1
    ip address 192.168.0.33 255.255.255.224
    alias 192.168.0.43 255.255.255.224
    peer ip address 192.168.0.34 255.255.255.224
    mac-address autogenerate
    access-group input acl-wan
    service-policy input PM_BYPASS_HTTP
    service-policy input PM_MAIN_BCPROXY
    no shutdown
    interface vlan 300
    description ACE-INSIDE CONTEXT RACK1
    ip address 192.168.0.65 255.255.255.224
    alias 192.168.0.73 255.255.255.224
    peer ip address 192.168.0.66 255.255.255.224
    mac-address autogenerate
    access-group input acl-in
    service-policy input PM_BYPASS_FOR_LAN_HTTP
    service-policy input PM_BYPASS_HTTP
    service-policy input PM_MAIN_BCPROXY
    no shutdown
    interface vlan 301
    description BC-VLAN CONTEXT RACK1
    ip address 192.168.0.97 255.255.255.224
    alias 192.168.0.107 255.255.255.224
    peer ip address 192.168.0.98 255.255.255.224
    mac-address autogenerate
    access-group input acl-proxy
    no shutdown
    ft track interface TRACKING_FOR_FT_VLAN
    track-interface vlan 300
    peer track-interface vlan 300
    priority 255
    peer priority 255
    ip route 0.0.0.0 0.0.0.0 192.168.0.1
    Please help me out what i am missing. Is there any limitation on policy map or my bypass subnet list is creating problem. 

    I did these changes this time nothing disconnected but I am not able to do the Remote desktop on the virtual IP address. Real IP has Remote desktop enabled even VIP is not ping able for me.
    rserver host RT_fax1
      description Right Fax Server-1
      ip address 192.168.200.66
      inservice
    rserver host RT_fax2
      description Right Fax Server-2
      ip address 192.168.200.67
      inservice
    serverfarm host SF_RT_fax
      rserver RT_fax1
        inservice
      rserver RT_fax2
        inservice
    policy-map type loadbalance rdp first-match PM_LB_RT_FAX
      class class-default
        serverfarm SF_RT_fax
    policy-map multi-match PM_RT_FAX
      class RT_FAX
        loadbalance vip inservice
        loadbalance policy PM_LB_RT_FAX
        loadbalance vip icmp-reply active
    interface vlan 200
      description WAN-VLAN CONTEXT RACK1
      ip address 192.168.0.33 255.255.255.224
      alias 192.168.0.43 255.255.255.224
      peer ip address 192.168.0.34 255.255.255.224
      mac-address autogenerate
      access-group input acl-wan
      service-policy input PM_BYPASS_HTTP
      service-policy input PM_MAIN_BCPROXY
      service-policy input PM_RT_FAX
      no shutdown
    interface vlan 300
      description ACE-INSIDE CONTEXT RACK1
      ip address 192.168.0.65 255.255.255.224
      alias 192.168.0.73 255.255.255.224
      peer ip address 192.168.0.66 255.255.255.224
      mac-address autogenerate
      access-group input acl-in
      service-policy input PM_BYPASS_FOR_LAN_HTTP
      service-policy input PM_BYPASS_HTTP
      service-policy input PM_MAIN_BCPROXY
      service-policy input PM_RT_FAX
      no shutdown
    But nothing is working for me. Please help me out. This time i didnt configure the sticky. But in real I will go with sticky and complete IP protocol will be use a VIP. Please help me out.

  • Oracle 10g - Set Operator Union Causing Timeout Network problem

    Purpose is to get all of the customers not contacted given a starting date and current date(sysdate). The problem is a timeout issue because the query is inefficient. Example: A salesman has 6,946 rows returned from the cust table where his salesid =1163. Then the inner query:
    ‘SELECT count(Customer_ID) FROM cust_info WHERE info_type_id = 32’
    returns 225505 rows just based on this info_type_record.
    Next, ‘SELECT c.customer_id
      FROM customer c,
        event e
      WHERE c.salesperson_id = 1163
      AND e.eventdate BETWEEN '10-Feb-2010' AND TRUNC(SYSDATE)
      AND c.customer_id = e.customer_id
      GROUP BY c.customer_id’
    Returns 231 rows
    Finally, ‘SELECT c.customer_id
      FROM customer c,
        note n
      WHERE c.salesperson_id = 1163
      AND n.created_date_time BETWEEN '10-Feb-2010' AND TRUNC(SYSDATE)
      AND n.note_type_id IN (1,3,4)
      AND c.customer_id   = n.pk_id
      AND n.table_name    = 'CUSTOMER'
      GROUP BY c.customer_id’
    Returns 399 rows.
    How can I improve the structure of this query(see bottom)? The following is a sample data structure:
      CREATE TABLE "CUST "
       (     "CUST_ID" NUMBER,
         "SSN" VARCHAR2(9),
                      "SSN_TYP" NUMBER(1,0),
         "CREATED_DTE_TME" DATE,
         "FULLNAME" VARCHAR2(110),
         "F_NAME" VARCHAR2(35),
         "L_NAME" VARCHAR2(40),
         "BDTE" DATE,
         "DCEASED_DTE" DATE,
         "SALES_ID" NUMBER DEFAULT NULL,
         "BRNCH_ID" NUMBER,
         "HOME_BRNCH_ID" NUMBER,
         "TTL_ASSETS" NUMBER,
         "TTL_ASSETS_DTE" DATE,
         "NO_MAILINGS" NUMBER(1,0),
         "NO_CALLS" NUMBER(1,0) ) ;
      CREATE TABLE "CUST_INFO"
       (     "CUST_INFO_ID" NUMBER,
         "CUST_ID" NUMBER,
         "INFO_TYPE_ID" NUMBER ) ;
    CREATE TABLE "EVENT"
       (     "EVENT_ID" NUMBER,
         "EVENTDATE" DATE,
         "CUST_ID" NUMBER,
         "SALES_ID" NUMBER,     
                      "EVENT_INFO" VARCHAR2(4000)  )
    ENABLE ROW MOVEMENT ;
    CREATE TABLE “NOTE"
       (     "NOTE_ID" NUMBER,
         "NOTE_TYPE_ID" NUMBER DEFAULT 0,
         "TABLE_NAME" VARCHAR2(50),
         "PK_ID" NUMBER,
         "CREATED_DTE_TME" DATE ) ;
    INSERT INTO CUST VALUES(20151,'009529433',1,'01-MAY-5','FRENCH','D','M','01-DEC-01', '05-JUN-05',1163,
    NULL,0,NULL,NULL,NULL,NULL)
    INSERT INTO CUST_INFO VALUES (15,1001,32)
    INSERT INTO EVENT VALUES (5,'05-MAY-05',1001,1163,'NONE')
    INSERT INTO NOTE VALUES (100,2,'CUST',1001,TRUNC(SYSDATE))
    SELECT CUST.CUST_ID,
      SSN,
      F_NAME,
      L_NAME,
      CREATED_DTE_TME ,
      TTL_ASSETS,
      BRNCH_ID,
      SALES_ID ,
      BDTE,
      SSN_TYP,
      FULLNAME,
      Home_BRNCH_ID ,
      No_Mailings,
      No_Calls,
      DCEASED_DTE,
      TTL_ASSETS_DTE
    FROM CUST
    WHERE SALES_ID          = 1163
    AND CUST.CUST_ID NOT IN (
      (SELECT CUST_ID FROM cust_info WHERE info_type_id = 32
    UNION
      (SELECT c.CUST_ID
      FROM CUST c,
        event e
      WHERE c.SALES_ID = 1163
      AND e.eventdate BETWEEN '10-Feb-2010' AND TRUNC(SYSDATE)
      AND c.CUST_ID = e.CUST_ID
      GROUP BY c.CUST_ID
    UNION
      (SELECT c.CUST_ID
      FROM CUST c,
        note n
      WHERE c.SALES_ID = 1163
      AND n.CREATED_DTE_TME BETWEEN '10-Feb-2010' AND TRUNC(SYSDATE)
      AND n.note_type_id IN (1,3,4)
      AND c.CUST_ID   = n.pk_id
      AND n.table_name    = 'CUST'
      GROUP BY c.CUST_ID
    AND CUST.ssn           IS NOT NULL
    AND CUST.DCEASED_DTE IS NULL
    {code}
    Any guidance is appreciated!                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   

    It’s not problem with SET operator. while you are using date field in where clause, U must use date conversion function, otherwise it will stuck there
    Here is the right sql, U can try with this
    SELECT cust.cust_id, ssn, f_name, l_name, created_dte_tme, ttl_assets,
    brnch_id, sales_id, bdte, ssn_typ, fullname, home_brnch_id,
    no_mailings, no_calls, dceased_dte, ttl_assets_dte
    FROM cust
    WHERE sales_id = 1163
    AND cust.cust_id NOT IN (
    (SELECT cust_id
    FROM cust_info
    WHERE info_type_id = 32)
    UNION
    ((SELECT c.cust_id
    FROM cust c, event e
    WHERE c.sales_id = 1163
    AND e.eventdate BETWEEN to_date('10-Feb-2010','dd-mon-rrrr') AND TRUNC (SYSDATE)
    AND c.cust_id = e.cust_id
    GROUP BY c.cust_id)
    UNION
    (SELECT c.cust_id
    FROM cust c, note n
    WHERE c.sales_id = 1163
    AND n.created_dte_tme BETWEEN to_date('10-Feb-2010','dd-mon-rrrr') AND TRUNC
    (SYSDATE)
    AND n.note_type_id IN (1, 3, 4)
    AND c.cust_id = n.pk_id
    AND n.table_name = 'CUST'
    GROUP BY c.cust_id)))
    AND cust.ssn IS NOT NULL
    AND cust.dceased_dte IS NULL;

  • Timeout Object Problem: Can't recreate scaling error

    In my movie there is a function that scales 3D objects over
    time using a timeout object. The 3D objects are in an array that is
    shuffled each round, and based on the outcome of the array shuffle,
    some 3D objects are scaled and some are not.
    I have been testing this for a while and it almost always
    works as I anticipate, however I have encountered some events
    wherein unexpected 3D objects are scaled. To track down the error,
    I have been tracing the results of the array shuffle, as this is
    what drives the scaling. When I encountered an event where
    unexpected objects were scaled I recorded what I thought was a
    “bad” array shuffle. Then, disabling the array shuffle
    function, I set the shuffle result to my “bad” array. I
    expected it would recreate the problem (unexpectedly scaled
    objects) however it worked accurately this time around.
    Are there any rules regarding timeout objects that are
    commonly broken that may be causing this? Does a timeout object
    behave any differently in the Director environment than it does in
    a published projector? Any broad or general tips (sorry I
    can’t post the code) are appreciated.

    Hi
    In the "fShrink", function the variable called "sTimeout" is
    a string:
    sTimeout = String("ShrinkTimeOut"+(_system.milliseconds));
    in the function "fShrinkLoop", the second parameter being
    passed in is the timeout object. Therefore in this function, the
    variable called "sTimeout" is a timeout object.
    The thing to remember is the object that sends the message
    determines what the parameter is (it doesn't matter what you name
    the parameter).
    In the case of Timeout objects, the first parameter is the
    object that Director sends the timeout callback message to (in this
    case, your model object... and since your model doesn't have a
    method for handling the response, Direct tries the global name
    space instead - but still conveniently sends the reference to the
    'callback object' as the first parameter). The second parameter is
    always a reference to the timeout object itself.
    (on a side note - you have taken advantage of a quirk with
    timeout objects that let you pass parameters with timeout callbacks
    by using the 'callback target' but letting a movie script handle
    the callback). If you want to send more than one parameter, you
    have to bundle them together into a single paremeter object).
    -- Luke

  • Oracle Timeout (update problem 8i)

    Hi,
    I am updating on row in emp.
    update emp set sal = 29 where empno=7369;
    and again trying to update same row with same empno from different console. With out giving commit to the first statement. Second console is getting hanged, waiting for lock. I dont want the second user to get hanged. It has to come out from the hang, by giving some error or message (..i.e You cant updated or something). I want to set some timeout for that. I tried with distributed_lock_timeout but it is obsolute in 8i. Do we have some global parameter to get this problem solve.
    Help me...

    I don't know of any other initialization parameter for that (if someone else knows more, then welcome).
    The best way would be "SELECT FOR UPDATE NOWAIT", but, since you can't modify your application, we have to rely on DISTRIBUTED_LOCK_TIMEOUT.
    You could rename your table, for example :
    SQL> rename emp to emptab;
    and, referring to my previous posting, create a synonym for that :
    SQL> create synonym emp for emptab@LOCAL;
    If you want to change the value of DISTRIBUTED_LOCK_TIMEOUT, you can add a line like this in your initSID.ora :
    DISTRIBUTEDLOCK_TIMEOUT = <what you want in seconds>
    BTW, if you can't modify your code, how do you manage the error conditions ?

  • How to debug ACE FT Sync Problems ?

    Hello,
    in one of our contexts we have a sync problem on the standby unit.
    "sh ft group detail" gives
    "Running cfg sync status : Error on Standby device when applying configuration file replicated from active", while "Startup cfg sync status" is OK.
    "sh crypto files" and "dir disk0:" produce the same output on both ACE units.
    How can we analyze the problem ?

    Hi Gilles,
    unfortunately I can not see a meaningful message. Can you please have a look at the attachments (taken from the standby machine) ?
    Thank you very much in advance.

  • ACE timeout for different Serverfarms

    I have a Business unit that publishes an application that is externally available. We Reverse Proxy the VIP to allow the connection externally. They would like to impose different application timeouts for internal users (1 hour) and external users (30 Minutes) . The application can not differentiate between an external or internal source so our option is either seperate serverfarms with seperate real servers with different configuration files.
    My question is, is there any other way to do this within the ACE so that we don't have to spin up seperate Servers with different configuration files.
    I would also like  to maintain one VIP address if possible.

    You can maintain 1 VIP but you'll have to use header rewrite and work with dev. team of your application.
    It's related to the session state tracked by a cookie the application sends (either as a Set-Cookie or a token embedded in URLs)
    Make two different serverfarms (with the same set of real servers).
    Make a class-map matching the IP addresses of internal users (RFC 1918 ?)
    For this class-map, add a field in each HTTP request coming in
    "X-Internal:YES"
    apply this on each request with the option
    header-rewrite per-request
    The application team just has to parse each header for the pattern you've just added and then changing the timeout value to the one they want.
    For the class-default (external users) you can add "X-Internal:NO", it's cleaner but not strictly necessary.

  • Timeout PJC - Problem exiting when Message box or LOV is displayed.

    I'm trying to integrate the Timeout PJC into my Oracle Forms. During testing, I noticed that although the timeout expires and Form A displays an expiry message, Form B will not exit if a Message Box or LOV is present requiring a response by a user. Once the user responds and these windows are closed, the user is returned to Form A and the timeout works as expected.
    All the code for the Timeout PJC including the Java Bean is in Form A. On Form
    B, I'm using the WHEN-TIMER-EXPIRED, WHEN-WINDOW-ACTIVATED and
    ON-ERROR triggers to handle the problem with the error message 41355
    (Cannot navigate to Form ...) which works fine. Any suggestions will be greatly appreciated.

    Does anyone have any suggestion to my question below?. Is there a way to exit a Form when the Timeout PJC expires and a Message Box or List of Value (LOV) requires a response by the user. I would like to exit the form and the application when there is no activity after a specified time but I'm having this issue. Thanks for you assistance.

  • SOAP receiver inactive problem

    Hi Gurus,
    I am using a SOAP receiver channel, I actived this SOAP CC in ID , but when I go to RWB and goto Communication Channel monitor, found the SOAP receiver channel status is "Channel started but inactive" with a yellow triangle.
    Our XI version is PI7.0 SP11.

    Hi,
    send the first message with it and check again
    Regards,
    michal
    <a href="/people/michal.krawczyk2/blog/2005/06/28/xipi-faq-frequently-asked-questions"><b>XI / PI FAQ - Frequently Asked Questions</b></a>

  • ACE - Timeout application

    Hi,
    we have ACE 4700 installed for load balancing.
    We are facing an issue with one of our application.
    When client tries to communicate with VIP of load balancer we get the response as timed out. Also on the client in netstat connections observed some are established and some are in Fin-Wait-2 state.
    But when we point the client to physical IP address of the server its able to connect properly.
    All other applications are working properly via load balancer.
    Thanks And Regards
    Pushpak

    Hi Pushpak,
    The information is too less to say anything. What does "show conn" output show? Can you get the pcaps from the client itself to see where exactly the connection is failing? Is it layer4 or layer 7 loadbalancing? Was it working before? Please get me the configuration along with vip details and i will have a look. Also, ensure that server is not reaching the client directly. The return traffic should also go back through ACE.
    Regards,
    Kanwal
    Note: Please mark answers if they are helpful.

  • ACE on VSS problem

    I have a VSS cluster 2x6509 and an ACE blade in each I had to upgrade(ACE A2) the software so it could be recognised by the VSS. I have connectivity to the newtork from the first ACE ,but the second cannot arp it's default gatetway both ACE blade are on the same management vlan.
    any help will be appreciated following is the config
    svclc multiple-vlan-interfaces
    svclc switch 1 module 1 vlan-group 1
    svclc switch 2 module 1 vlan-group 1
    svclc vlan-group 1 88
    access-list ANY line 8 extended permit ip any any
    policy-map type management first-match remote-access
    class remote-mgmt
    permit
    interface vlan 88
    description Axfood MGMT-LAN
    ip address 194.132.91.239 255.255.255.128
    access-group ANY
    no shutdown
    ip route 0.0.0.0 0.0.0.0 194.132.91.254
    show arp
    ================================================================================
    IP ADDRESS MAC-ADDRESS Interface Type Encap NextArp(s) Status
    ================================================================================
    194.132.91.238 00.21.a0.82.8e.e9 vlan88 LEARNED 519 12340 sec up
    194.132.91.239 00.21.a0.82.8e.39 vlan88 INTERFACE LOCAL _ up
    194.132.91.251 00.25.46.21.c8.00 vlan88 LEARNED 518 4807 sec up
    194.132.91.254 00.00.00.00.00.00 vlan88 GATEWAY - * 3 req dn
    sho interface
    switch/Admin# show int
    vlan88 is up
    Hardware type is VLAN
    MAC address is 00:21:a0:82:8e:39
    Mode : routed
    IP address is 194.132.91.239 netmask is 255.255.255.128
    FT status is non-redundant
    Description:Axfood MGMT-LAN
    MTU: 1500 bytes
    Last cleared: never
    Alias IP address not set
    Peer IP address not set
    Assigned from the Supervisor, up on Supervisor
    45822 unicast packets input, 553642216 bytes
    8022597 multicast, 218206 broadcast
    0 input errors, 0 unknown, 0 ignored, 0 unicast RPF drops
    301 unicast packets output, 33548570 bytes
    0 multicast, 523889 broadcast
    0 output errors, 0 ignored

    It looks like you don't have FT (alias & peer IP's) set up.
    If the second ACE still can't ARP or ping the gateway after you get that taken care of, check w/ TAC to see if you're hitting bug CSCsz50968.
    We ran into it when we were doing a bunch of failover tests between the two VSS chassis.

  • Samsung Galaxy Ace - Mountain Lion problem

    Hello,
    Ive recently downloaded Mountain Lion for my Macbook Pro. I have been happy with the program itself however i have a slight issue. When i tried connecting my Samsung Galaxy Ace to my phone it did not estblish a connection. This is quite perculiar as previously it used to work perfectly but post update not so well. I find this quite frustrating now as i can not put any music on my phone! So i was hoping that somebody would be nice enough to suggest some solutions. Ive already tried using a different wire, rebooting my phone, restarting my mac but i have no luck! Hopefully somebody can help me.
    Thanks Junaid
    ( I need to listen to my Jay-Z songs!! ) 

    In my experience with Android Gingerbread, ICS, and Jelly Bean: once you enable USB data/sharing/tethering in the phone settings, then connect a USB cable to the Mac, it just connects and mounts the internal and external SD cards as folders on the Mac desktop. Then you can drag and drop files both ways. You should eject each mounted device to preserve your phone data.

  • ACE port redirection problem

    I am using standard http port 80 in front end (between the end user and ACE module ) and I am using port 9080 for backend (between the ACE and servers).
    I don't want the port number 9080 to show up in the url
    http://www.Trading.com:9080/ANTOnline
    how can i hide the port 9080 from the end user

    Try this config:
    rserver host Server001
    ip address 10.1.1.1
    inservice
    rserver host Server002
    ip address 10.1.1.2
    inservice
    serverfarm host SF001
    probe CHECK.HTML
    rserver Server001 9080
    inservice
    rserver Server002 9080
    inservice
    class-map match-all R001
    2 match virtual-address 1.1.1.1 tcp eq www
    policy-map type loadbalance first-match P001
    class class-default
    serverfarm SV001
    policy-map multi-match L4-LB
    class R001
    loadbalance vip inservice
    loadbalance policy P001
    loadbalance vip icmp-reply
    It should solve your problems

Maybe you are looking for

  • Is it possiblle to integrate non-sap to non-sap using XI?

    hi, is it possible to integrate non-sap to non-sap system using SAP XI? ex. File to JDBC scenario regards Ruban

  • Can no longer login to Blackberry App World or get a password reset, please help!

    I cannot login to My Blackberry App World on https://blackberryid.blackberry.com/bbid/login/ I have entered my email and password but it is rejected. When I ask for a password reset I am prompted to answer a security question. The security question I

  • Portal Upgrade Failure

    Hi! I ran the portal upgrade script against a copy of my production database to bring it up from 3.0.8.9.8 to 3.0.9. About an hour after the script was running, the database abruptly came down. When I looked in the altert log, there were numerous ORA

  • Remote File Not Deleted

    During any "Put" operation I am usually getting a failure for some or all the files I am trying to upload. When this happens the progress bar zips through, regenerates and then progresses very slowly on the same file. The log records the error " The

  • Is it the N85, the Sony Ericsson, Orange or O2 tha...

    Hi All I have searched through the threads to see if I can find a previous answer to the problem I have but I couldn't find anything that quite matched all the facts, so here goes. A Nokia N85 that is on O2 WILL received Pics but WILL NOT receive vid