ACE port redirection problem

I am using standard http port 80 in front end (between the end user and ACE module ) and I am using port 9080 for backend (between the ACE and servers).
I don't want the port number 9080 to show up in the url
http://www.Trading.com:9080/ANTOnline
how can i hide the port 9080 from the end user

Try this config:
rserver host Server001
ip address 10.1.1.1
inservice
rserver host Server002
ip address 10.1.1.2
inservice
serverfarm host SF001
probe CHECK.HTML
rserver Server001 9080
inservice
rserver Server002 9080
inservice
class-map match-all R001
2 match virtual-address 1.1.1.1 tcp eq www
policy-map type loadbalance first-match P001
class class-default
serverfarm SV001
policy-map multi-match L4-LB
class R001
loadbalance vip inservice
loadbalance policy P001
loadbalance vip icmp-reply
It should solve your problems

Similar Messages

  • ACE port redirection message to client

    Hi,
    I need to configure a new VIP so that if the requests come on port 80 it sends a redirection message to clients saying to try on port HTTPS://*:9443, is the configuration below correct?
    rserver host server1
      description host1
      ip address 1.1.1.1
      probe probe-http
      inservice
    rserver host server2
      description host2
      ip address 1.1.1.2
      probe probe-http
      inservice
    serverfarm host sfarm1
      rserver server1
        inservice
      rserver server2
        inservice
    rserver redirect sfarm1_redirect_9443
      webhost-redirection https://%h:9443%p 301
      inservice
    serverfarm redirect sfarm_redirect_9443
      rserver sfarm1_redirect_9443
        inservice
    class-map match-all VIP_HTTP
      description Match HTTP
      2 match virtual-address 2.2.2.2 tcp eq www
    class-map match-all VIP_HTTPS
      description Match HTTPS
      2 match virtual-address 2.2.2.2 tcp eq 9443
    policy-map type loadbalance first-match http_Redirect_Policy
      class class-default
        serverfarm sfarm_redirect_9443
    policy-map type loadbalance first-match https_9443
      class class-default
        serverfarm sfarm1
    policy-map multi-match VIPS
    class VIP_HTTP
        loadbalance vip inservice
        loadbalance policy http_Redirect_Policy
        loadbalance vip icmp-reply active
    class VIP_HTTPS
        loadbalance vip inservice
        loadbalance policy https_9443
        loadbalance vip icmp-reply active

    Hi,
    %h and %p are usually used when host and path remain same as is the case in redirection from http to https.
    You can also use the actual hostname and path if the above doesn't work. I think it should work but i haven't tested it before.
    You can try something like below:
    webhost-redirection https://test.com:9443 301
    Let me know how it goes.
    Regards,
    Kanwal

  • ACE Port redirection

    Hi,
    I am configuring load balancing for my web server which running on port 3636. But for users I want to give only http://172.23.15.87. not http://172.23.15.87:3636
    Earlier I was having CSS in which I am able to achive this by creating two content rules one for the port 80 and one for port 3636. But here I dont know how to achieve it.
    rserver MOSS_1
      ip address 192.168.200.38
    inser
    rserver MOSS_2
      ip address 192.168.200.40
    inservice
    serverfarm host SF_MYEM
      probe  PROBE_3636
    rserver MOSS_1
    inservice
      rserver MOSS_2
        inservice
    sticky ip-netmask 255.255.255.255 address source SF_MYEM_STICK
      replicate sticky
      serverfarm SF_MYEM
    class-map match-any MYEM
      2 match virtual-address 172.23.15.87 tcp eq 3636
    policy-map type loadbalance first-match PM_LB_MYEM
      class class-default
        sticky-serverfarm SF_MYEM_STICK
    policy-map multi-match PM_ENOC_Servers
      class MYEM
        loadbalance vip inservice
        loadbalance policy PM_LB_MYEM
        loadbalance vip icmp-reply active
    Please let me know how to configure it so that users in the browser only put the VIP without the port 3636.

    Hi,
    I have tried the configuration but only port 80 is working I am not able to open the page
    on port 3636.
    rserver host MOSS_1
      ip address 192.168.200.38
      inservice
    rserver host MOSS_2
      ip address 192.168.200.40
      inservice
    serverfarm host SF_EM
      probe PROBE_3636
      rserver MOSS_1 3636
        inservice
      rserver MOSS_2 3636
        inservice
    serverfarm host SF_MY
      probe PROBE_TCP
      rserver MOSS_1
        inservice
      rserver MOSS_2
        inservice
    sticky ip-netmask 255.255.255.255 address source SF_MY_STICK
      replicate sticky
      serverfarm SF_MY
    sticky ip-netmask 255.255.255.255 address source SF_MYEM_STICK
      replicate sticky
      serverfarm SF_MYEM
    class-map match-any MYEM
      3 match virtual-address 172.23.15.87 tcp eq www
    class-map match-any MY
      2 match virtual-address 172.23.15.86 tcp eq www
    policy-map type loadbalance first-match PM_LB_MYEM
      class class-default
        sticky-serverfarm SF_MYEM_STICK
    policy-map type loadbalance first-match PM_LB_MY
      class class-default
        sticky-serverfarm SF_MY_STICK
    policy-map multi-match PM_ENOC_Servers
    class MYEM
        loadbalance vip inservice
        loadbalance policy PM_LB_MYENOC
        loadbalance vip icmp-reply active
    class MY
        loadbalance vip inservice
        loadbalance policy PM_LB_MYENOC
        loadbalance vip icmp-reply active
    interface vlan 200
    service-policy input PM_ENOC_Servers
    I can ping the VIP and I can telnet on port 3636 successfully. But Web page is not showing for port 3636 but the website on port 80 is working fine.
    Please assist me what I am missing.

  • ACE 4170 port redirection in Bridged mode

    Hi Friends,
    Is it possible to do port redirection on ACE while it is configured on Bridged Mode. For example. a user is accessing the Loadbalancer VIP on port 80 and this is redirected to port 8080 on backend servers?
    I have attached a diagram for easier understanding. Is there a need to configure NAT in such cases?
    Any help will be appreciated. Thanks in advance guys.

    Hi,
    if you want to allow ping to the VIP address, you only need to apply this command in your L3-4 policy map:
    loadbalance vip icmp-reply
    example:
    policy-map multi-match L4-TEST-VIPS
    class WWW-TEST
    loadbalance vip inservice
    loadbalance policy WWW_POLICY
    loadbalance vip icmp-reply
    more info can be found here:
    http://www.cisco.com/en/US/docs/interfaces_modules/services_modules/ace/v3.00_A2/configuration/slb/guide/classlb.html#wp1000929
    If you want ICMP to pass through the ACE tp reach the real servers, you need to allow it in an ACL.
    Hope this helps,
    Dario

  • RV180W - problems on rules and port redirections

    Hello,
    I installed a RV180W router a month ago.
    Our production server has to retreive informations on a remote server so I set up the rules and port redirections accordingly on the firewall.
    I noticed that some times the rules didn't work anymore and I had to reboot the RV to fix it.
    The rules are still active on the router's admin panel as well as the services and the port redirection. The last firmware is installed.
    Does anyone experienced the same problem and found a fix?
    Thanks in advance,
    Best regards

    I hate to say it, but there are issues like this with the rv series.  Have you replace the router with another one?  That's the first thing I would try since you can probably exchange it easily right now.
    Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com

  • ACE: URL redirect - not working

    Hi,
    I've to do url redirection from port 80 to port 443. I've following configured:
    rserver redirect url.test.com-rd
      webhost-redirection https://url.test.com/
      inservice
    serverfarm redirect url.test.com:80
      description url.test.com - port 80 redirect ***
      rserver url.test.com-rd
        inservice
    class-map match-any url.test.com:80
      2 match virtual-address 192.168.1. tcp eq www
    policy-map type loadbalance first-match url.test.com:80
      class class-default
        serverfarm url.test.com:80
      policy-map multi-match LOAD_BALANCE
       class url.test.com:80
        loadbalance vip inservice
        loadbalance policy url.test.com:80
        loadbalance vip icmp-reply active
    ===
    with above configuration, ACE is redirection port 80 to port 443 but it also rewrites the header.  i.e. ACE send me to
    "https://url.test.com/" if I type "http://url.test.com/abc" in the browser. It should have redirected to  "https://url.test.com/abc" ( it shouldn't have removed "/abc")
    could you advice how to accomplish it.
    Thanks in advance...

    Hi,
    thanks pablo. but that isn't expected response. redirected url shows the load balanced server. i.e. for the following serverfarm of port 443:
    serverfarm host url.test.com:443
      description url.test.com - Port 7777 ***
      failaction purge
      probe url.test.com:7777
      rserver server1.test.com 7777
        inservice
    redirected url comes as "http://server1.test.com:7777/abc/" ...instead of what I expect .i.e. i expect "
    https://url.test.com/abc/"

  • ACE Port Monitoring

    I have four servers in my network. Users access two web servers 192.168.200.161, 192.168.200.162 on Port 80.
    These two servers communicate with back end servers APP1, APP2  192.168.200.165, 192.168.200.165 on port 3005.
    I want whenever port 80 on Web server 1 or port 3005 on Application Server 1 goes down. Traffic redirect to Web server 2 and Application Server 2.
    probe tcp ITSMWeb_PROBE_80
      port 80
      interval 15
      passdetect interval 60
      open 1
    probe tcp ITSMAPP_PROBE_3005
      port 3005
      interval 15
      passdetect interval 60
      open 1
    rserver host ITSMWeb_1
      description ITSMWeb-1
      ip address 192.168.200.161
      inservice
    rserver host ITSMWeb_2
    description ITSMWeb-2
    probe tcp ITSMWeb_PROBE_80
    ip address 192.168.200.162
      inservice
    rserver host ITSMMAPP_1
      description ITSMMAPP_1
      probe tcp ITSMAPP_PROBE_3005
    ip address 192.168.200.165
      inservice
    rserver host ITSMMAPP_2
      description ITSMMAPP_2
      ip address 192.168.200.166
      inservice
    serverfarm host SF_ITSM_Web_Server
      rserver ITSMWeb_1
        inservice
      rserver ITSMWeb_2
        inservice
    serverfarm host SF_ITSM_MAPP_Server
      rserver ITSMMAPP_1
        inservice
      rserver ITSMMAPP_2
        inservice
    class-map match-any ITSM_Web_Server
      2 match virtual-address 172.23.15.163 any
    class-map match-all clas-default
    class-map match-any ITSM_MAPP_Server
      2 match virtual-address 172.23.15.167 any
    class-map match-all clas-default
    policy-map type loadbalance first-match PM_LB_ITSM_Web_Server
      class class-default
        serverfarm SF_ITSM_Web_Server
    policy-map type loadbalance first-match PM_LB_ITSM_MAPP_Server
      class class-default
        serverfarm SF_ITSM_MAPP_Server
    policy-map multi-match PM_ITSM_Web_Server
      class ITSM_Web_Server
        loadbalance vip inservice
        loadbalance policy PM_LB_ITSM_Web_Server
        loadbalance vip icmp-reply active
    interface vlan 200
    service-policy input PM_ITSM_Web_Server
    interface vlan 200
    service-policy input PM_ITSM_MAPP_Server
    interface vlan 300
    service-policy input PM_ITSM_Web_Server
    nat-pool 3 172.23.16.3 172.23.16.3 netmask 255.255.255.255 pat
    interface vlan 300
    service-policy input PM_ITSM_MAPP_Server
    nat-pool 4 172.23.16.4 172.23.16.4 netmask 255.255.255.255 pat
    Please let me know will that configuration will able to give me my goal. this is my production time and I will not have enough time to troubleshoot. This ACE is my core where all traffic is terminated. So this activity is critical for me. Please help me out. IF i am missing something.

    access-list acl-in remark ACCESS LIST FOR ACE-INSIDE
    access-list acl-in line 1 extended permit ip any any
    access-list acl-out remark ACCESS LIST FOR ACE-OUTSIDE
    access-list acl-out line 1 extended permit ip any any
    access-list acl-proxy remark ACCESS LIST FOR PROXY SEGMENT
    access-list acl-proxy line 1 extended permit ip any any
    access-list acl-wan remark ACCESS LIST FOR WAN SEGMENT
    access-list acl-wan line 1 extended permit ip any any
    access-list fax line 8 extended permit ip any host 192.168.200.65
    access-list fax line 16 extended permit ip any host 192.168.200.66
    access-list fax line 24 extended permit ip any host 192.168.200.67
    probe tcp ITSMAPP_PROBE_30005
    port 30005
    interval 15
    passdetect interval 60
    open 1
    probe tcp ITSMWeb_PROBE_80
    port 80
    interval 15
    passdetect interval 60
    open 1
    probe tcp PROBE_5050
    port 5050
    interval 15
    passdetect interval 60
    open 1
    probe tcp PROBE_5101
    port 5101
    interval 15
    passdetect interval 60
    open 1
    probe tcp PROBE_TCP
    port 80
    interval 15
    passdetect interval 60
    open 1
    parameter-map type http PARAMAP_CASE
    case-insensitive
    no persistence-rebalance
    rserver host ITSMMAPP_1
    description ITSMMAPP_1
    ip address 192.168.200.165
    inservice
    rserver host ITSMMAPP_2
    description ITSMMAPP_2
    ip address 192.168.200.166
    inservice
    rserver host ITSMWeb_1
    description ITSMWeb-1
    ip address 192.168.200.161
    inservice
    rserver host ITSMWeb_2
    description ITSMWeb-2
    ip address 192.168.200.162
    inservice
    rserver host RS_BCPR01
    ip address 192.168.0.103
    inservice
    rserver host RS_BCPR02
    ip address 192.168.0.104
    inservice
    rserver host RT_fax1
    description Right Fax Server-1
    ip address 192.168.200.66
    inservice
    rserver host RT_fax2
    description Right Fax Server-2
    ip address 192.168.200.67
    inservice
    serverfarm host SF_BCPR
    transparent
    probe PROBE_5050
    probe PROBE_5101
    probe PROBE_TCP
    rserver RS_BCPR01
    inservice
    rserver RS_BCPR02
    inservice
    serverfarm host SF_ITSM_MAPP_Server
    probe ITSMAPP_PROBE_30005
    rserver ITSMMAPP_1
    inservice
    rserver ITSMMAPP_2
    inservice
    serverfarm host SF_ITSM_Web_Server
    probe ITSMWeb_PROBE_80
    rserver ITSMWeb_1
    inservice
    rserver ITSMWeb_2
    inservice
    serverfarm host SF_RT_fax
    rserver RT_fax1
    inservice
    rserver RT_fax2
    inservice
    sticky ip-netmask 255.255.255.255 address source STICKY-SOURCE
    replicate sticky
    serverfarm SF_BCPR
    class-map type management match-any CM_ALL
    2 match protocol snmp any
    3 match protocol http any
    4 match protocol https any
    5 match protocol icmp any
    6 match protocol telnet any
    class-map match-any CM_BYPASS_FOR_LAN
    3 match virtual-address 100.1.1.0 255.255.255.0 tcp eq www
    8 match virtual-address 10.0.0.0 255.0.0.0 tcp eq www
    9 match virtual-address 172.16.0.0 255.255.0.0 tcp eq www
    10 match virtual-address 192.168.0.0 255.255.0.0 tcp eq www
    11 match virtual-address 172.20.0.0 255.255.0.0 tcp eq www
    12 match virtual-address 172.23.15.0 255.255.255.0 tcp eq www
    class-map match-any CM_BYPASS_SUBNET
    9 match virtual-address 100.0.0.0 255.0.0.0 tcp eq www
    13 match virtual-address 10.0.0.0 255.0.0.0 tcp eq www
    15 match virtual-address 192.168.0.0 255.255.0.0 tcp eq www
    16 match virtual-address 172.20.0.0 255.255.0.0 tcp eq www
    17 match virtual-address 172.16.0.0 255.255.0.0 tcp eq www
    18 match virtual-address 172.23.15.0 255.255.255.0 tcp eq www
    class-map match-any CM_IM
    2 match virtual-address 0.0.0.0 0.0.0.0 tcp eq 5050
    3 match virtual-address 0.0.0.0 0.0.0.0 tcp eq 1080
    4 match virtual-address 0.0.0.0 0.0.0.0 tcp eq 5101
    class-map match-all CM_SF_BCPR
    255 match virtual-address 0.0.0.0 0.0.0.0 tcp eq www
    class-map match-any ITSM_MAPP_Server
    2 match virtual-address 172.23.15.167 any
    class-map match-any ITSM_Web_Server
    2 match virtual-address 172.23.15.163 any
    class-map match-any RT_FAX
    2 match virtual-address 172.23.15.65 any
    class-map match-all clas-default
    policy-map type management first-match PM_ALL
    class CM_ALL
    permit
    policy-map type loadbalance http first-match PM_L7_BYPASS_FOR_LAN_HTTP
    class class-default
    forward
    policy-map type loadbalance http first-match PM_L7_BYPASS_HTTP
    class class-default
    forward
    policy-map type loadbalance first-match PM_LB_ITSM_MAPP_Server
    class class-default
    serverfarm SF_ITSM_MAPP_Server
    policy-map type loadbalance first-match PM_LB_ITSM_Web_Server
    class class-default
    serverfarm SF_ITSM_Web_Server
    policy-map type loadbalance first-match PM_LB_RT_FAX
    class class-default
    serverfarm SF_RT_fax
    policy-map type loadbalance http first-match PM_LB_SF_BCPROXY
    class class-default
    sticky-serverfarm STICKY-SOURCE
    policy-map multi-match PM_BYPASS_FOR_LAN_HTTP
    class CM_BYPASS_FOR_LAN
    loadbalance vip inservice
    loadbalance policy PM_L7_BYPASS_FOR_LAN_HTTP
    policy-map multi-match PM_BYPASS_HTTP
    class CM_BYPASS_SUBNET
    loadbalance vip inservice
    loadbalance policy PM_L7_BYPASS_HTTP
    policy-map multi-match PM_ITSM_MAPP_Server
    class ITSM_MAPP_Server
    loadbalance vip inservice
    loadbalance policy PM_LB_ITSM_MAPP_Server
    loadbalance vip icmp-reply active
    nat dynamic 4 vlan 300
    policy-map multi-match PM_ITSM_Web_Server
    class ITSM_Web_Server
    loadbalance vip inservice
    loadbalance policy PM_LB_ITSM_Web_Server
    loadbalance vip icmp-reply active
    nat dynamic 3 vlan 300
    policy-map multi-match PM_MAIN_BCPROXY
    class CM_SF_BCPR
    loadbalance vip inservice
    loadbalance policy PM_LB_SF_BCPROXY
    loadbalance vip icmp-reply active
    appl-parameter http advanced-options PARAMAP_CASE
    class CM_IM
    loadbalance vip inservice
    loadbalance policy PM_LB_SF_BCPROXY
    policy-map multi-match PM_RT_FAX
    class RT_FAX
    loadbalance vip inservice
    loadbalance policy PM_LB_RT_FAX
    loadbalance vip icmp-reply active
    nat dynamic 1 vlan 300
    service-policy input PM_ALL
    interface vlan 100
    description FW-INSIDE CONTEXT RACK1
    ip address 192.168.0.5 255.255.255.224
    alias 192.168.0.11 255.255.255.224
    peer ip address 192.168.0.6 255.255.255.224
    mac-address autogenerate
    no icmp-guard
    access-group input acl-out
    no shutdown
    interface vlan 200
    description WAN-VLAN CONTEXT RACK1
    ip address 192.168.0.33 255.255.255.224
    alias 192.168.0.43 255.255.255.224
    peer ip address 192.168.0.34 255.255.255.224
    mac-address autogenerate
    access-group input acl-wan
    service-policy input PM_BYPASS_HTTP
    service-policy input PM_MAIN_BCPROXY
    service-policy input PM_RT_FAX
    service-policy input PM_ITSM_Web_Server
    service-policy input PM_ITSM_MAPP_Server
    no shutdown
    interface vlan 300
    description ACE-INSIDE CONTEXT RACK1
    ip address 192.168.0.65 255.255.255.224
    alias 192.168.0.73 255.255.255.224
    peer ip address 192.168.0.66 255.255.255.224
    mac-address autogenerate
    access-group input acl-in
    nat-pool 1 172.23.16.2 172.23.16.2 netmask 255.255.255.255 pat
    nat-pool 3 172.23.16.3 172.23.16.3 netmask 255.255.255.255 pat
    nat-pool 4 172.23.16.4 172.23.16.4 netmask 255.255.255.255 pat
    service-policy input PM_BYPASS_FOR_LAN_HTTP
    service-policy input PM_BYPASS_HTTP
    service-policy input PM_MAIN_BCPROXY
    service-policy input PM_RT_FAX
    service-policy input PM_ITSM_Web_Server
    service-policy input PM_ITSM_MAPP_Server
    no shutdown
    interface vlan 301
    description BC-VLAN CONTEXT RACK1
    ip address 192.168.0.97 255.255.255.224
    alias 192.168.0.107 255.255.255.224
    peer ip address 192.168.0.98 255.255.255.224
    mac-address autogenerate
    access-group input acl-proxy
    no shutdown
    ft track interface TRACKING_FOR_FT_VLAN
    track-interface vlan 300
    peer track-interface vlan 300
    priority 255
    peer priority 255
    My ACE is redirecting the port 80 traffic to my proxy server. But I have exclude teh VIP and real IP from this port 80 redirection towards. proxy server
    Everything is fine except the port 80. I can do the RDP, ping, telnet on 30005. Please let me know what I am missing.

  • Proxy redirect problem

    I'm having a redirect problem going through a weblogic proxy. An app I was using appears to be redirecting the browser always to localhost:7121 which won't work with access via the my domain.
    To explain fully I set up a test JSP page which outputs request.getRequestURL().toString() so I could trace what was happening. The weblogic configuration is explained below:
    I'm using Weblogic 8.1 sp5. I've setup a 4 instances: a proxy (port 7120), redirector (port 7121) and cluster (two instances running on 7131, 7132)
    If I navigate to:
    http://localhost:7120/myapp/test.jsp my test page outputs: request.getRequestURL().toString() : http://localhost:7121/myapp/test.jsp
    and again to:
    http://localhost:7131/myapp/test.jsp my test page outputs: request.getRequestURL().toString() : http://localhost:7121/myapp/test.jsp
    or
    http://localhost:7132/myapp/test.jsp my test page outputs: request.getRequestURL().toString() : http://localhost:7121/myapp/test.jsp
    The output is always the same ... it always says the requestURL is from localhost:7121 the redirector?
    Can anyone help explain why I always get the same output? It is completely baffling me.
    Thanks,
    Matt
    Edited by: user5673380 on Oct 15, 2008 3:52 PM

    The problem was caused by incorrect configuration of FrontEndHttpPort and FrontEndListener and FrontEndHost in the cluster configuration. These values were incorrectly during config wizard install.

  • Can't run form from Form Builder 10g - Port configuration problem?

    Hi,
    I have installed the Database (10.2.0.1.0) and the Developer Suite (10.1.2.0.2) on two Linux machines (Red Hat Enterprise Linux ES 4 Basic).
    If I enter the frmservlet-URL manually everything seems to be fine.
    In one case I enter http://127.0.0.1:8890/forms/frmservlet, in the other http://127.0.0.1:8889/forms/frmservlet; in BOTH cases I get eventually a dark square and the status bar says "Applet oracle.forms.engine.Main started".
    HOWEVER, if I create a simple form with Form Builder and click on the Button with the green traffic light ("Run Form"), the form runs only on the machine where frmservlet listens on port 8890.
    On the other machine (frmservlet configured to listen on port 8889) Firefox pops up, the URL "http://127.0.0.1:32979/6dOrpwghCqnp8PhMT7KVT533m3IaArqFbPqPBOztZXWYSsNy" gets called, and nothing else happens. The screen displays the string "ORACLE FORMS." and the status bar says "Waiting for 127.0.0.1...", and it stays like this forever.
    I assume this is a port configuration problem, but I don't have a clue where to start.
    Any suggestions how I should proceed are greatly appreciated.
    Thank you very much in advance!

    Hi Frank,
    Thank you for your reply.
    I doublechecked my configuration.
    In the dialog Edit --> Preferences --> Runtime the Application Server URL is set to "127.0.0.1:8889/forms/frmservlet".
    However, when I attempt to run the form, the URL "http://127.0.0.1:33140/W2dwbV9eXS2fPkuKlxNhCxFWdEihwDviat2uV7ycrSotqwDN" gets called.
    The screen displays the string "ORACLE FORMS." and the status bar says "Waiting for 127.0.0.1...", and that's it.
    I wonder how the port number 33140 got selected. Interestingly, this time it is a different number; last time it was port 32979. In fact, the port number seems to change each time; I tried again and now it is 33189.
    I will now try to set the port number for the frmservlet to 8890.
    I choose Edit --> Preferences --> Runtime and set the application server URL to "127.0.0.1:8890/forms/frmservlet".
    I stop the container, open /home/oracle/OraHome_1/j2ee/DevSuite/config/default-web-site.xml and change the port number to 8890:
    <?xml version="1.0" standalone='yes'?>
    <!DOCTYPE web-site PUBLIC "Oracle Application Server 10g XML Web-site" "http://xmlns.oracle.com/ias/dtds/web-site.dtd">
    <!-- change the host name below to your own host name. Localhost will -->
    <!-- not work with clustering -->
    <!-- also add cluster-island attribute as below
    <web-site host="localhost" port="0" protocol="ajp13"
    display-name="Default Oracle Application Server 10g Java WebSite" cluster-island="1" >
    -->
    <web-site port="8890" protocol="http"
    display-name="Oracle Developer Suite 10g instance of Oracle Containers for J2EE Web Site">
    <!-- Uncomment the following line when using clustering -->
         <!-- <frontend host="your_host_name" port="80" /> -->
         <!-- The default web-app for this site, bound to the root -->
         <default-web-app application="default" name="defaultWebApp" root="/j2ee" />
    <!-- Do not delete this line. -->
    <web-app application="forms" name="formsweb" root="/forms" />
    <!-- -->
    <!-- <web-app application="forms" name="formsweb" root="/forms" /> -->
    <web-app application ="reports" name="web" root="/reports" />
    <web-app application = "reports" name="demo" root="/repdemo" />
         <!-- Access Log, where requests are logged to -->
         <access-log path="../log/default-web-access.log" />
    </web-site>
    I restart the container, start Form Builder, connect to the database, and open my test form.
    When attempting to run the form, the URL "http://127.0.0.1:33437/Pl0n3ky9vmU5z37A7ScBnQhsGwq3jwuzJpgTAKWPMOYIzT8K" gets called (again a new port number, apparently picked radomly within a certain range) and nothing happens: "Waiting for 127.0.0.1...".
    However, when I enter the URL http://127.0.0.1:8890/forms/frmservlet I do (eventually, after confirming that I trust the certificate etc.) get a darc rectangle and the status message "Applet oracle.forms.engine.Main started", which tells me that my setup can't be that far off target.
    Here is the output of netstat:
    [root@localhost ~]# netstat -anp --tcp
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 0.0.0.0:32769 0.0.0.0:* LISTEN 2779/rpc.statd
    tcp 0 0 0.0.0.0:23910 0.0.0.0:* LISTEN 5269/java
    tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 2759/portmap
    tcp 0 0 0.0.0.0:1521 0.0.0.0:* LISTEN 4265/tnslsnr
    tcp 0 0 0.0.0.0:113 0.0.0.0:* LISTEN 2983/xinetd
    tcp 0 0 127.0.0.1:7830 0.0.0.0:* LISTEN 4429/spamd --port 7
    tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 2928/cupsd
    tcp 0 0 0.0.0.0:9240 0.0.0.0:* LISTEN 5269/java
    tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 3002/sendmail: acce
    tcp 0 0 0.0.0.0:8890 0.0.0.0:* LISTEN 5269/java
    tcp 0 0 0.0.0.0:32795 0.0.0.0:* LISTEN 4231/ora_d000_orcl
    tcp 0 0 127.0.0.1:1521 127.0.0.1:32817 ESTABLISHED 4265/tnslsnr
    tcp 0 0 127.0.0.1:32817 127.0.0.1:1521 ESTABLISHED 4209/ora_pmon_orcl
    tcp 0 0 127.0.0.1:33425 127.0.0.1:1521 ESTABLISHED 5298/frmbld
    tcp 0 0 127.0.0.1:1521 127.0.0.1:33425 ESTABLISHED 5311/oracleorcl
    tcp 1 0 80.133.127.83:33485 209.132.177.100:443 CLOSE_WAIT 4060/python
    tcp 1 0 80.133.127.83:33484 209.132.177.100:443 CLOSE_WAIT 4060/python
    tcp 1 0 80.133.127.83:33494 209.132.177.100:443 CLOSE_WAIT 4060/python
    tcp 1 0 80.133.127.83:33520 209.132.177.100:443 CLOSE_WAIT 4060/python
    tcp 0 0 80.133.127.83:33529 209.132.177.100:443 ESTABLISHED 4060/python
    tcp 0 0 80.133.127.83:33528 209.132.177.100:443 ESTABLISHED 4060/python
    tcp 1 0 80.133.127.83:33460 209.132.177.100:443 CLOSE_WAIT 4060/python
    tcp 1 0 80.133.127.83:33470 209.132.177.100:443 CLOSE_WAIT 4060/python
    tcp 0 0 :::22 :::* LISTEN 2968/sshd
    tcp 0 0 ::ffff:127.0.0.1:33437 :::* LISTEN 5298/frmbld
    tcp 697 0 ::ffff:127.0.0.1:33437 ::ffff:127.0.0.1:33439 CLOSE_WAIT -
    tcp 348 0 ::ffff:127.0.0.1:33437 ::ffff:127.0.0.1:33440 CLOSE_WAIT -
    [root@localhost ~]#
    The question remains: Where do those port numbers come from?
    Regards,
    jme

  • Port Mapping Problem with AEX

    I have a new Airport Extreme and a problem that did not exist with the Airport. I connect a Toshiba network camera to an Airport Express, set as a WDS remote, with the netcam connected to the wired ethernet port of the Express. I can see the netcam, which also functions as a web server, on the internal 10.x.x.x address, and have reserved a discrete 10.x.x.x address via the MAC/DHCP reservation function of the Extreme. Just like the older Airport which did this without a hiccup, I should be able to map a port (e.g. 1200) on the public IP to port 80 of the internal 10.x.x.x address, then access the netcam on the internal network from any browser (http://67.x.x.x:1200). My cable modem is just that: no router involved other than the Airport Extreme. I'm using the latest Extreme and Express firmware, and am either missing something with the new Leopard firewall, overlooking something else, or dealing with a product flaw. Any help is appreciated and Happy Holidays.

    I have forwarded the port (have tried several different ports actually) in what I think it the correct way: using the Airport Utility, connected to the Airport Extreme, and, under advanced options, selected port mapping, entered the public TCP port of 1200, then the private 10.x.x.x IP address of the netcam (which I can access from the internal network with no problem), coupled with the private TCP port of 80. I then attempt to access the netcam from the Internet by entering http://my cable modem IP address:1200 (or another port to which I've attempted to map). This method worked for two years with the Airport, but, with the Extreme and Leopard (simultaneous transition), I'm stumped. After reading other about other port mapping problems, I reserved an IP address for the netcam based on its MAC with no positive results. I also set the firewall through the Security icon in System Preferences to allow all incoming connections. Thanks for taking the time to respond.

  • Wrt54gs V4 FWv1.06.1 - Port Redirection not supported? Any workarounds?

    My office does not allow any outbound traffic except for port 80 and 443. On my home network I have VNCServer listening on port 5900. I'd like to have the incoming port 443 to go 192.168.1.102 port 5900. I'm able to successfully 'port range forward' port 443 to go to 192.168.1.102 port 443 ( I modified my VNC Server to listen on port 443 ). I am having difficulty when my VNC Server listens on it's normal port of 5900 as no matter what I do in ' port triggering ' it doesn't allow for port redirection, not that I see. Any help would be appreciated.

    I does not support port redirection. I think none of the Linksys routers supports that.

  • Virtual Hosts & Port Redirections

    Hi guys,
    In 10.6 i used to be able to setin the Server Admin GUI settings for the web service. This included Virtual Hosts & Port Redirections. How do i go about doing this on 10.7?
    For example, I need myserver.mycompany.com:80 to redirect to myserver.mycompany.com:8088 & mygreatsite.company.com:80 to redirect to mygreatsite.company.com:9006.
    Both of which are hosted on myserver.mycompany.com.
    Links apprecaited.. i'm guessing i'm in for an Apache lesson?

    I hope that article helps you, maybe you can figure it out and post back for the rest of us!
    I haven't actually read it yet, I just saved it to my Pinboard page for later, because I know eventually I will have to deal with vhosts in Lion.

  • Dynamic form "Cancel" redirect  problem in frames - bugfix?

    My question: Is there a "long run" down side to my implementing this modification to style.js?
    The below post by Ionut:MX Division Support Specialist worked for me as a solution to a current form "click cancel" redirect navigation problem:
    When a DWtoolbox dynamic form wizard form is placed on a page within frames, clinking on cancel does not return a user to the list that sent them to the form. The user is sent somewhere else.
    Begin Ionut post-------------
    If you don't need to add extra parameters to the "Edit" button, you can solve the redirect problem by editing the "/includes/skins/style.js" file and replace:
    nxt_list_edit_link_form(this, myinput.previousSibling.href);
    with:
    nxt_list_edit_link_form(this, a.href);
    End----------------------
    Thanks Ionut for the tip and anyone in support for letting me know if this is a safe mod for the long run,
    Steve M

    Hi Marny,
    Hello Steve. I am new to Adobe & very confused. You seem to grasp the program very nicely, please help Me?
    I´m not not Steve, however -- what problem do you have exactly, and is this problem related to the "Adobe Dreamweaver Developer Toolbox" extension or related to Dreamweaver ?
    If it´s related to ADDT, please describe your problem by starting a new thread -- if it´s related to Dreamweaver, please post your questions in the general Dreamweaver forums.
    Cheers,
    Günter Schenk
    Adobe Community Expert, Dreamweaver

  • Photosmart printer D110A CN732A How do I solve a port match problem?

    operating system: windows 7
    Error message: port match
    Any changes made to your system before the issue: No
    When I go to print something It tells me it's printing, but then never does. The explanation is always just the simple "error". I've used troubleshoot, re-started everything and ran the diagnostic test which told me it was a port match problem. My printer will still copy.

    Hi there,
    Try downloading and running the print and scan doctor located here:
    http://h10025.www1.hp.com/ewfrf/wc/document?docname=c03275041&cc=us&dlc=en&lc=en
    It can fix a lot on its own and if not give a better idea of what is going on.
    Best of Luck!
    You can say thanks by clicking the Kudos Star in my post. If my post resolves your problem, please mark it as Accepted Solution so others can benefit too.

  • System Control msg "Get Configuration port has problems

    Hello !
    1) Do you know what the System control manager is doing and where I can find some information about the program?
    2) Do you know what the message " Get confirmation port has problems" means that comes up every time I start the computor since I installed the System control manager ?
    Best regards Namretto

    Comments:                      My system/Namretto
    >>
        Model:                         AMD Athlon(tm) XP 3200+
        Speed:                         2.19GHz
        Model Number:                  3200 (estimated)
        Performance Rating:            PR3177 (estimated)
        Type:                          Standard
        L2 On-board Cache:             512kB ECC Synchronous Write-Back (16-way, 64
                                       byte line size)
        Bus(es):                       ISA AGP PCI USB i2c/SMBus
        MP Support:                    No
        MP APIC:                       No
        System BIOS:                   Phoenix Technologies, LTD 6.00 PG
        Mainboard:                     MICRO-STAR INTERNATIONAL CO., LTD MS-6570
        Total Memory:                  511MB DDR-SDRAM
        Model:                         Nvidia Corp nForce2 AGP Controller
        Front Side Bus Speed:          2x 199MHz (398MHz data rate)
        Total Memory:                  512MB DDR-SDRAM
        Memory Bus Speed:              2x 199MHz (398MHz data rate)
        Monitor/Panel:                 Dell 1501FP (analog)
        Adapter:                       RADEON 9600 SERIES  
        Adapter:                       RADEON 9600 SERIES - Secondary  
        Removable Drive:               Diskettenhet
        Hard Disk:                     ST312002 6AS SCSI Disk Device
        CD-ROM/DVD:                    Memorex 40MAXX 1248AJ
        CD-ROM/DVD:                    _NEC DVD_RW ND-2500A
        1.44MB 3.5" (A:):              N/A
        Hard Disk (C:):                29.3GB (19.2GB, 65% Free) (NTFS)
        Hard Disk (D:):                82.5GB (71.3GB, 86% Free) (NTFS)
        CD-ROM/DVD (E:):               N/A
        CD-ROM/DVD (F:):               N/A
        Serial/Parallel Port(s):       2 COM / 1 LPT
        USB Controller/Hub:            Standard OpenHCD USB Host Controller
        USB Controller/Hub:            Standard OpenHCD USB Host Controller
        USB Controller/Hub:            Standard Enhanced PCI to USB Host Controller
        USB Controller/Hub:            USB-rotnav (hub)
        USB Controller/Hub:            USB-rotnav (hub)
        USB Controller/Hub:            USB-rotnav (hub)
        Keyboard:                      Standard 101/102-Key or Microsoft Natural PS/
                                       2 Keyboard
        Mouse:                         HID-compliant Cordless Mouse
        Human Interface:               Logitech Cordless USB Mouse
        Device:                        NVIDIA(R) nForce(TM) Audio Codec Interface
        Model:                         HP DeskJet 670C
        Model:                         \\HEMPC\SKRIVARE 6
        Model:                         \\HEMPC\SKRIVARE 3
        Model:                         \\HEMPC\SKRIVARE
        Model:                         \\HEMPC\PRINTER
        AC Line Status:                On-Line
        Windows System:                Microsoft Windows XP/2002 Home (Win32 x86)
                                       5.01.2600 (Service Pack 1)
        Adapter:                       NVIDIA nForce MCP Networking Controller
        Adapter:                       Realtek RTL8139/810x Family Fast Ethernet NIC

Maybe you are looking for