Adding users programmatically -- almost there

... getting close...
Create this procedure in the PORTAL schema.
It works if you call it when connected as PORTAL, but not when connected as anyone else.
It is throwing a user-defined exception frmo inside WWCTX_SSO, so I am guessing that it is looking at the session context and deciding that the SESSION_USER shouldn't be adding users.
Perhaps a true PL/SQL wiz can pick up the ball and figure out what is going on.
FYI this is sandbox code at its grittiest, so don't even think of pasting it into your application 8^)
create or replace procedure ci_add_portal_user
(uname in varchar2,pwd in varchar2, email in varchar2,lname in varchar2,fname in varchar2,clr_lvl in integer)
as
l_guid varchar2(32);
p_user_id number;
sess dbms_ldap.session;
err_code number;
err_msg varchar2(300);
INVALID_GRP_NAME_EXCEPTION exception;
INVALID_SITE_EXCEPTION exception;
VALUE_ERROR_EXCEPTION exception;
DUPLICATE_GROUP_EXCEPTION exception;
GROUP_NOT_FOUND_EXCEPTION exception;
GROUP_MEMBER_EXCEPTION exception;
GROUP_NOT_UNIQUE_EXCEPTION exception;
USER_NOT_FOUND_EXCEPTION exception;
USER_EXISTS_EXCEPTION exception;
APP_NOT_FOUND_EXCEPTION exception;
NO_MANAGER_EXCEPTION exception;
DUPLICATE_GRANTEE_EXCEPTION exception;
NO_ACCESSIBLE_OBJECT_EXCEPTION exception;
ORG_NOT_EXIST_EXCEPTION exception;
INVALID_PERSON_ID_EXCEPTION exception;
ACCESS_DENIED_EXCEPTION exception;
CIRCULAR_REFERENCE_EXCEPTION exception;
UNEXPECTED_EXCEPTION exception;
USER_NOT_DELETABLE_EXCEPTION exception;
INVALID_ARGUMENT_EXCEPTION exception;
INVALID_AUTH_FUNC_EXCEPTION exception;
LDAP_CONNECTION_EXCEPTION exception;
DEPRECATED_API_EXCEPTION exception;
INVALID_ARGUMENT_EXCEPTION exception;
BEGIN
/* Create SSO User */
begin
l_guid := portal.wwsec_oid.create_user_entry
p_base => portal.wwsec_oid.get_user_search_base,
p_user_name => uname,
p_password => pwd,
p_email => email,
p_first_name => fname,
p_last_name => lname,
p_create_state => null,
p_bind_as_user => false
exception when others then
err_code:=SQLCODE;
err_msg:=SQLERRM;
dbms_output.put_line(' Exception :'||err_code||' '||err_msg);
end;
/* Create Portal User */
begin
p_user_id:=portal.wwsec_api.id_sso(p_username=>uname);
dbms_output.put_line('USER ==>'||p_user_id||' '||portal.wwsec_api.user_name(p_user_id));
exception when others then
err_code:=SQLCODE;
err_msg:=SQLERRM;
dbms_output.put_line(' Exception :'||err_code||' '||err_msg);
end;
begin
portal.wwsec_api.add_user_to_list(p_user_id,portal.wwsec_api.group_id('CI_USR'),0);
portal.wwsec_api.set_defaultgroup(portal.wwsec_api.group_id('CI_USR'),uname);
exception when others then
err_code:=SQLCODE;
err_msg:=SQLERRM;
dbms_output.put_line(' Exception :'||err_code||' '||err_msg);
end;
begin
portal.wwsec_api.add_user_to_list(p_user_id,portal.wwsec_api.group_id('CI_CLR_'||clr_lvl),0);
exception when others then
err_code:=SQLCODE;
err_msg:=SQLERRM;
dbms_output.put_line(' Exception :'||err_code||' '||err_msg);
end;
END ci_add_portal_user;

Andrew,
to add a user to a specific group in the FileRealm, try doing the following:
import java.security.acl.Group;
import weblogic.security.acl.BasicRealm;
import weblogic.security.acl.ManageableRealm;
import weblogic.security.acl.Security;
// Create a user in WebLogic
BasicRealm bRealm = Security.getRealm();
ManageableRealm mRealm = (ManageableRealm)bRealm;
if (null == mRealm) { throw new SecurityException("Security Realm is null");
weblogic.security.acl.User oNewUser = mRealm.newUser("username", "password",
null);
// -- Put the new user into the selected group
Enumeration eGroups = mRealm.getGroups();
Group oGroup = mRealm.getGroup("group name you want to add to");
if (null != oGroup) {
oGroup.addMember(oNewUser);
try { mRealm.save("FileRealm.Properties"); } catch (IOException e) { }
Andrew Dunn <[email protected]> wrote:
Thanks, Mike.
I'm trying to use the Default realm in WLS7.0 (which uses LDAP), so
I'm looking for the classes specific to the Default realm - I assume
BEA provides some, but I can't find them in the docs.
On 2 Dec 2002 10:15:18 -0800, "mike" <[email protected]>
wrote:
You will not find implementing classes in general. The thing is thatthey (classes)
are specific to particular implementation of realm you are using (assumingyou
use 6.x or below, but that is logically true for 7). So you need tofind what
are the classes used in your realm and work with those. If you are usingan implementation
shipped with WLS (eg. FIleRealm or LDAP) you will have to use reflection...
Andrew Dunn <[email protected]> wrote:
How can I add users/groups via the Weblogic API? All I can find in
the documenattion is interfaces, but no implementation classes. How
can I instantiate the classes?
Thanks, Andrew

Similar Messages

  • Adding users programmatically to WLS 10

    I've blogged a little about it [url http://internna.blogspot.com/2007/04/create-users-programmatically-in.html]here. Hope it helps!

    Hi ,
    Dont add the weblogic.jar file in your application explicitly then check the error you get,and also dont specify the location of the class in your application.
    Let me know if you face any errors after the above suggestions.
    Regards,
    Rohit Jaiswal

  • Adding users programmatically

    How can I add users/groups via the Weblogic API? All I can find in
    the documenattion is interfaces, but no implementation classes. How
    can I instantiate the classes?
    Thanks, Andrew

    Andrew,
    to add a user to a specific group in the FileRealm, try doing the following:
    import java.security.acl.Group;
    import weblogic.security.acl.BasicRealm;
    import weblogic.security.acl.ManageableRealm;
    import weblogic.security.acl.Security;
    // Create a user in WebLogic
    BasicRealm bRealm = Security.getRealm();
    ManageableRealm mRealm = (ManageableRealm)bRealm;
    if (null == mRealm) { throw new SecurityException("Security Realm is null");
    weblogic.security.acl.User oNewUser = mRealm.newUser("username", "password",
    null);
    // -- Put the new user into the selected group
    Enumeration eGroups = mRealm.getGroups();
    Group oGroup = mRealm.getGroup("group name you want to add to");
    if (null != oGroup) {
    oGroup.addMember(oNewUser);
    try { mRealm.save("FileRealm.Properties"); } catch (IOException e) { }
    Andrew Dunn <[email protected]> wrote:
    Thanks, Mike.
    I'm trying to use the Default realm in WLS7.0 (which uses LDAP), so
    I'm looking for the classes specific to the Default realm - I assume
    BEA provides some, but I can't find them in the docs.
    On 2 Dec 2002 10:15:18 -0800, "mike" <[email protected]>
    wrote:
    You will not find implementing classes in general. The thing is thatthey (classes)
    are specific to particular implementation of realm you are using (assumingyou
    use 6.x or below, but that is logically true for 7). So you need tofind what
    are the classes used in your realm and work with those. If you are usingan implementation
    shipped with WLS (eg. FIleRealm or LDAP) you will have to use reflection...
    Andrew Dunn <[email protected]> wrote:
    How can I add users/groups via the Weblogic API? All I can find in
    the documenattion is interfaces, but no implementation classes. How
    can I instantiate the classes?
    Thanks, Andrew

  • Adding users as contributors in change management

    Hi everyone,
    I am facing some issues in adding some users as contributors in change management.
    The users have almost all the required privileges like
    REPO.MODIFY_FOREIGN_CONTRIBUTION.
    REPO.MODIFY_OWN_CONTRIBUTION.
    REPO.MODIFY_CHANGE
    When I click NEW CONTRIBUTOR , I am unable to see the User in the list.
    Is there any other special privileges that are required. I have gone through the developer guide also to resolve the issue but couldn't find any missing privileges.

    Hey:
    Sorry,I don't have a document or deliverable written up to do that.  But I have found a few weblogs on related subject matter on this forum.  I would suggest you search for this. 
    However, I will write up a high level process for this here:
    Log into your Primary Domain Controller (Non Solution Manager)
           So, if your trying to modify the routes in ECC, log into the Domain Controller of ECC
    Transaction: STMS
    Overview - Transport Routes (Shift + F7)
    Go into Change Mode (Pencil and Glasses Icon)
    You now need to modify the Transport Group for example: /QASGRP/ or /CUSGRP/
            All transport groups begin and end with the "/"
    You will see two or three groups in the consolidation route (Between DEV and QAS)
    You need to be careful and modify the Customizing Group.
    Once completed, you will save and activate changes. 
    Let me know if you have any other questions
    Imran

  • What is the difference between using the command "dsmgmt" and the "Managed By" tab when adding users to the local administrators Account on a Read-Only Domain Controller?

    When I use the
    "dsmgmt" command to add a user to the local administrators account of a RODC I can actually see the user when I use the "Show Role Administrators" parameter. However, I can't see the members of the
    group added to the "Managed By" tab of the RODC object in AD. Even though, the users added using
    "dsmgmt" and by the "Managed By" tab can all log in locally and have admin rights to the RODC. Are there any differences between these two ways of adding users to the local administrators account? 

    Hi,
    For groups, managedBy is an administrative convenience to designate “group admins”. Whatever principal listed in
    managedBy gets permission to update a group’s membership (the actual security is updated on the group’s AD object to allow this).
    In Win2008 and later managedBy also became the way you delegated local administration on an RODC, allowing branch admins to install patches, manage shares, etc. (http://technet.microsoft.com/en-us/library/cc755310(WS.10).aspx). 
    On the RODC, this is updating the RepairAdmin registry value within RODCRoles.
    So the difference between them should be only the way they do the same thing.
    For more details, please refer to the below article:
    http://blogs.technet.com/b/askds/archive/2011/06/24/friday-mail-sack-wahoo-edition.aspx
    We
    are trying to better understand customer views on social support experience, so your participation in this
    interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

  • SP 2010-After adding user from IIS is not found in central admin

    Hi Experts,
    I am trying to configure my SP 2010 with Form Based Authentication.
    After configuring WebSite, STS and Central Admin I added the user from IIS , But not able to found from central admin in Form Authentication.
    I checked in database the user is added.
    I followed the below blog .
    http://jasear.wordpress.com/2012/03/16/sharepoint-2010-setting-up-form-based-authentication-fba-using-asp-net-sql-membership-provider/
    Can experts help me how to get the added user to central admin.
    Thanks
    AshisK

    I was finally able to get the FBA working. After many failed attempts, I knew there was a configuration issue which was causing the error.
    I provided connection string and provider details at 4 places, instead of the 3 mentioned  in various blogs around ->
    1. Sharepoint Central Admin
    2. Sharepoint Web Services
    3. SecurityTokenServiceApplication
    4. And finally the web application itself.
    The connection string for 2nd and 3rd will remain same however, provider details need to be added.
    After completing this step, I was able to login using Form Based Authentication without an issue.
    AshisK

  • Rmi almost there

    rmi almost there
    I did a version 1.1
    javac -tareget 1.1 ct277/*.class
    rmic -v1.1 rImp
    put everything in a jar
    compiled OK (so the class is seen in the build process)
    but on execution I got:
    Exception Details: javax.faces.el.EvaluationException
    java.lang.NoClassDefFoundError: cts77/rInterface (wrong name: rInterface)
    Possible Source of Error:
    Class Name: com.sun.faces.el.ValueBindingImpl
    File Name: ValueBindingImpl.java
    Method Name: getValue
    Line Number: 206
    Source not available. Information regarding the location of the exception can be identified using the exception stack trace below.
    Stack trace:
    com.sun.faces.el.ValueBindingImpl.getValue(ValueBindingImpl.java:206)
    com.sun.faces.el.ValueBindingImpl.getValue(ValueBindingImpl.java:154)
    com.sun.faces.application.ApplicationImpl.createComponent(ApplicationImpl.java:389)
    javax.faces.webapp.UIComponentTag.createComponent(UIComponentTag.java:1018)
    javax.faces.webapp.UIComponentTag.createChild(UIComponentTag.java:1045)
    javax.faces.webapp.UIComponentTag.findComponent(UIComponentTag.java:742)
    javax.faces.webapp.UIComponentTag.doStartTag(UIComponentTag.java:423)
    etc etc...
    ps I posted this yesterday but it is not there now
    maybe
    1) I posted to some other forum by mistake
    2) SUN moderators removed my post because they think rmi topic is exhausted
    3) SUN moderators removed my post because they have had enough of me.
    if 2) or 3) could the moderator please email me so I dont go on posting in vain?
    cheers
    CTSkinner

    I followed the stripped down example in
    http://patriot.net/~tvalesky/easyrmi.html
    then renamed Implementation rImp
    and interface rInterface
    server rServ
    and replaced the method with a String function that returns "fred"
    - as simple as I could make it
    - it works with java Client from the command line.
    When I put all the classes in a jar, and include the jar in a Creator project, the rImplementation class is found at Build time, but causes an immediate exception at execution time
    (could there be a security problem? even though the error is ClassDef not found? I have my win2K user set at java allow all - which I hope is safe while I'm testing on 127.0.0.1)
    I put this code in a button:
    public String button1_action() {
    String serverName = "127.0.0.1";
    String cs = "ccc";
    try
    {     //bind server object to object in client
    rInterface Servo = (rInterface) Naming.lookup("rmi://"+serverName+"/rImpInst");
    cs = Servo.getSlug();
    catch(Exception e)
    cs = "Slug catch";
    // Vanilla van = new Vanilla();
    // cs = van.fudge();
    FacesContext fc = javax.faces.context.FacesContext.getCurrentInstance();
    fc.addMessage(null, new FacesMessage(cs, ""));
    return null;
    but note: the project raises exception immediately, before the button is painted
    [the commented Vanilla.fudge is an ordinary non-rmi class which displays OK if
    Servo is not defined]
    note: cts77 is the package name. I get the same error if I explicitely say
    cts77.rInterface.
    I would be happier if no packages were involved, because rmic may not understand packages.

  • Error when manually adding user to project workspace

    I am currently using Project Server 2010.  I have a requirement for Business Users to have access to the project workspaces in Sharepoint but not be users of the PWA.  Similar to as it is outlined in this Microsoft Documentation (http://technet.microsoft.com/en-us/library/cc197668(v=office.14).aspx) 
    There might be a circumstance where you want to grant people who are not members of the project access to the project workspace site. Anyone assigned to the Web Administrator group can create new users for a project workspace site. In addition to the
    four groups that were mentioned earlier, there are four default SharePoint Server 2010 groups. They are as follows:
    Full Control   Has all personal, site, and list permissions.
    Design   Can edit lists, document libraries, and pages in the Web site.
    Contribute   Can view pages and edit list items and documents.
    Read   Can view pages, list items, and documents.
    I have added the user to the Contributor group but when they try to contribute to the space, ie add documents or an issue/risk, they recieve an error, similar to as is documented in the following article (http://pwmather.wordpress.com/2011/07/11/manually-adding-users-to-project-workspace-project-site-in-projectserver-ps2010-ps2007-epm/) 
    What has been identified in this article makes sense.  I am just wondering why Microsoft documentation states that it can be done.
    Any thoughts?

    Chris,
    The Microsoft article says, users who are not part of the project. It does not say not part of project server. 
    However, as far as I can remember, this scenario could work if the "Synchronization" is turned off between Project Server and Project Sites. I will run a test and confirm, later today.
    Prasanna Adavi,PMP,MCTS,MCITP,MCT TWitter: @prasannaadavi Blog: http://www.prasannaadavi.com

  • I keep on getting this error message on my Yahoo mail. You're almost there, but your web browser doesn't support the newest version of Yahoo! Mail

    I keep on getting this error message on my Yahoo mail all of a sudden;
    You're almost there, but your web browser doesn’t support the newest version of Yahoo! Mail
    The links it gives to upgrade are blocked
    I have latest version of FireFox 19 and Snow Leopard. I get the same error message on Safari and Google Crome aI even downloaded another Browser for Mac still got he same error message ! I have used the Disk Utility to repair files and rest Safari. I have deleted Firefox then downloaded a fresh version, still the same error messages ! Please help it's driving me nuts.

    You can check for problems caused by a possibly corrupted user agent.
    See:
    *https://support.mozilla.org/kb/Finding+your+Firefox+version
    *https://support.mozilla.org/kb/websites-say-firefox-outdated-or-incompatible
    *http://kb.mozillazine.org/Resetting_your_useragent_string_to_its_compiled-in_default

  • Relocating LDAP user programmatically

    Hi,
    Is there an API to relocate a user programmatically, in much the same way as ldapmoddn ?

    use directoryContext.rename(pOldDN,pNewDN)to move the user

  • You're almost there, but your web browser doesn't support the newest version of Yahoo! Mail

    You're almost there, but your web browser doesn’t support the newest version of Yahoo! Mail
    I have the latest Mozilla Firefox 19.0.2 but the newest version of Yahoo Mail don't work,what can' i do?

    your useragent (the information the browser sends to websites to identify its version) go overwritten probably by some sort of toolbar/adware. please refer to this article in order to reset the user-agent settings in firefox: [[Websites say that Firefox is outdated or incompatible even though it's the latest version]]

  • VLAN inter communication - almost there!

    I have been working on this for a few days.  Im almost there!
    I want my Management Vlan to be able to ping Computers in the DMZ vlan.   Im not sure if its NAT issue or ACL issue.
    Specifically im ping from 192.168.0.5(management comp) to 10.10.10.5(DMZ comp)
    Packet tracer shows no errors and says it should be working.
    I pick up a weird error in the log that says: Routing failed to locate next hop for ICMP from Management:192.168.0.5/256 to inside:10.10.10.5/0
    Why is it saying the 10.10.10.5 is on the inside, when its on the DMZ?
    name 10.10.10.0 DMZ description Public Computers
    name 192.168.10.0 Inside description CPL Staff Network
    name 192.168.0.0 Management description Cisco equipment  Access only
    name 192.168.1.0 default description Not in use
    name 192.168.10.2 CPLServer description win3k server
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    switchport trunk allowed vlan 11-13
    switchport mode trunk
    interface Ethernet0/2
    switchport access vlan 11
    interface Ethernet0/3
    switchport access vlan 12
    interface Ethernet0/4
    switchport access vlan 13
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    shutdown
    nameif default
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address dhcp setroute
    interface Vlan11
    description Inside
    nameif inside
    security-level 100
    ip address 192.168.10.1 255.255.255.0
    interface Vlan12
    description DMZ
    nameif DMZ
    security-level 100
    ip address 10.10.10.1 255.255.255.0
    interface Vlan13
    description Management
    nameif Management
    security-level 100
    ip address 192.168.0.1 255.255.255.0
    ftp mode passive
    dns server-group DefaultDNS
    domain-name CPL
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object-group network obj-10.0.1.0
    object-group network obj-10.0.2.0
    access-list DMZtoInside extended permit ip host DMZ host CPLServer
    access-list InsidetoDMZ extended permit ip Inside 255.255.255.0 host DMZ
    access-list ManagementtoDMZ extended permit ip Management 255.255.255.0 DMZ 255.255.255.0
    pager lines 24
    logging enable
    logging timestamp
    logging asdm-buffer-size 512
    logging buffered debugging
    logging asdm debugging
    mtu default 1500
    mtu outside 1500
    mtu inside 1500
    mtu DMZ 1500
    mtu Management 1500
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit any inside
    icmp permit any DMZ
    icmp permit any Management
    no asdm history enable
    arp timeout 14400
    nat-control
    global (outside) 1 interface
    global (inside) 1 interface
    global (DMZ) 1 interface
    global (Management) 1 interface
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,Management) 0.0.0.0 0.0.0.0 netmask 0.0.0.0
    static (inside,DMZ) 0.0.0.0 0.0.0.0 netmask 0.0.0.0
    route outside 0.0.0.0 0.0.0.0 192.168.1.1 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http Management 255.255.255.240 Management
    http Management 255.255.255.0 Management
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    anyconnect-essentials
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
      inspect icmp
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous

    Hi,
    I think the problem most likely is the NAT configuration.
    Is there a specific reason you are using Dynamic PAT from one interface to another ("nat" and "global" between local interfaces)? If this is not required I would suggest a different type of configuration for the whole NAT if you want to try it out. This would involve removing some of the existing configurations and will naturally effect the network operation while you do it.
    Removing old ones
    no global (inside) 1 interface
    no global (DMZ) 1 interface
    no global (Management) 1 interface
    no static (inside,Management) 0.0.0.0 0.0.0.0 netmask 0.0.0.0
    no static (inside,DMZ) 0.0.0.0 0.0.0.0 netmask 0.0.0.0
    Adding new configurations
    Existing ones
    !global (outside) 1 interface
    !nat (inside) 1 0.0.0.0 0.0.0.0
    access-list INSIDE-NAT0 remark NO NAT between Local Networks
    access-list INSIDE-NAT0 permit ip 192.168.10.0 255.255.255.0 10.10.10.0 255.255.255.0
    access-list INSIDE-NAT0 permit ip 192.168.10.0 255.255.255.0 192.168.0.0 255.255.255.0
    nat (inside) 0 access-list INSIDE-NAT0
    access-list DMZ-NAT0 remark NO NAT between Local Networks
    access-list DMZ-NAT0 permit ip 10.10.10.0 255.255.255.0 192.168.0.0 255.255.255.0
    access-list DMZ-NAT0 permit ip 10.10.10.0 255.255.255.0 192.168.10.0 255.255.255.0
    nat (DMZ) 0 access-list DMZ-NAT0
    access-list MANAGEMENT-NAT0 remark NO NAT between Local Networks
    access-list MANAGEMENT-NAT0 permit ip 192.168.0.0 255.255.255.0 10.10.10.0 255.255.255.0
    access-list MANAGEMENT-NAT0 permit ip 192.168.0.0 255.255.255.0 192.168.10.0 255.255.255.0
    nat (Management) 0 access-list MANAGEMENT-NAT0
    And naturally attach ACLs to interfaces to control traffic if needed
    Hope this helps
    - Jouni

  • Error while Adding user to  'SunAccessManager' Resource

    Hi,
    I configured SAM Resource adapter in SIM 6.0. When I create a user and assign SAM Resource getting the following Error,
    com.waveset.util.WavesetException: An error occurred adding user 'uid=SIMUser2,ou=People,o=Employee,dc=nl,dc=dap,dc=com' to resource 'SunAccessManager'. com.waveset.util.WavesetException: An error occurred creating user. java.lang.IllegalArgumentException: Invalid parameters
    Pls help me to resolve this issue
    Thanks,
    Deva

    Hi Satish,
    The problem is that you added the table and the objetc that you used to add the table is not freed properly. You need to free the object and then the reference count to that table will be 0 - which will enable you to add the fields
    e.g
    Dim pUTables As SAPbobsCOM.UserTablesMD
    'Do your stuff
    Set pUTables = Nothing
    Dim pUFields As SAPbobsCOM.UserFieldsMD
    'Do your stuff
    Set pUFields = Nothing

  • I have a macbook and when I power it on and then select myself as a user...It won't power up. It stays in the white screen with the apple logo. I am online currently under 'guest user'. Is there anything I can do from the keyboard to fix this??? Help!!!

    I have a macbook and when I power it on and then select myself as a user...It won't power up. It stays in the white screen with the apple logo. I am online currently under 'guest user'. Is there anything I can do from the keyboard to fix this??? Help!!!

    Could you specify the model of MacBook and the OS X it's running, please? Some of the advice or references vary along with the system, so this could be helpful to formulate a reply. I've never used a Guest User selection, but do have more than one User.
    If the computer does not have an optical drive, you may be able to boot it into a recovery disk mode or something; in an attempt to see what is wrong and maybe fix it.
    Good luck & happy computing!

  • How to set "Allow external users who accept sharing invitations and sign in as authenticated users" programmatically?

    Sharepoint 2013 online/office 365.
    I am creating site collection programmatically using sharepoint Auto hosted app.
    Now i want to set "Allow external users who accept sharing invitations and sign in as authenticated users" programmatically after site collection creation.
    Is it possible through code? If yes please let me know how to do it?
    Najitha Sidhik

    For SharePoint 2013 Online, check below links:
    http://office.microsoft.com/en-us/office365-sharepoint-online-small-business-help/manage-sharing-with-external-users-HA102849862.aspx
    http://office.microsoft.com/en-us/office365-sharepoint-online-enterprise-help/manage-external-sharing-for-your-sharepoint-online-environment-HA102849864.aspx
    https://www.nothingbutsharepoint.com/sites/eusp/Pages/SharePoint-Online-2013-Sharing-with-External-Users.aspx
    http://blogs.office.com/2013/11/21/sharepoint-online-improves-external-sharing/
    Please ensure that you mark a question as Answered once you receive a satisfactory response.

Maybe you are looking for