ADF 11: dvt:schedulingGantt : phase lag between resources and tasks

I am using dvt:schedulingGantt in my ADF BC application.
When I don't have simultaneous tasks in the same resource, the visualization in good.
But when I have simultaneous tasks in the same resource, in many resorces. the height of in the part of the resources does not coincide exactly with the height with the part of the tasks.
I you are using a lot of resources, in the last resources, it is posible the tasks of a resource are horizontally on another resource

Hi Frank,
If you use the demo rcfDvtDemo and create more tasks in the SampleModelFactory.java you can see the delay between resources and tasks.
In the last resource "Sue Morgan" The tasks "Hewitt Pacific" and "Johnson" are 10 px below the resource
This delay increase when you work with a lot of resources. The user might make an mistake.
I paste here the code from the method getSchedulingGanttModel, from the file: dsstools/modules/dvt-faces-demo/src/oracle/adfdemo/view/feature/rich/gantt/data/SampleModelFactory.java
public static TreeModel getSchedulingGanttModel()
Employee _r1 = new Employee("r1", "PRS-1", "Celula 1", "06:00", "15:00", null);
Task t11 = new Task("t11", "Ped.1560 L1", r1.getResourceId(), _r1.getResourceName(), parseDate("12/21/2006 14:00"), parseDate("12/21/2006 15:30"), "blue");
t11.setLabel(t11.getTaskName());
r1.addTask(t11);
Task t12 = new Task("t12", "Ped.1560 L2", r1.getResourceId(), _r1.getResourceName(), parseDate("12/22/2006 10:00"), parseDate("12/22/2006 14:30"), "blue");
t12.setLabel(t11.getTaskName());
r1.addTask(t12);
Employee _r2 = new Employee("r2", "PRS-2", "Celula 2", "07:00", "16:00", null);
Task t21 = new Task("t21", "Cymer Inc.", r2.getResourceId(), _r2.getResourceName(), parseDate("12/21/2006 09:00"), parseDate("12/21/2006 10:30"), "gold");
t21.setLabel(t21.getTaskName());
_t21.setStartupTime(30);
r2.addTask(t21);
Task t21b = new Task("t21b", "Cymer Inc.", r2.getResourceId(), _r2.getResourceName(), parseDate("12/21/2006 09:00"), parseDate("12/21/2006 10:30"), "gold");
t21b.setLabel(t21b.getTaskName());
r2.addTask(t21b);
Task t21c = new Task("t21c", "Cymer Inc.", r2.getResourceId(), _r2.getResourceName(), parseDate("12/21/2006 09:00"), parseDate("12/21/2006 10:30"), "gold");
t21c.setLabel(t21c.getTaskName());
r2.addTask(t21c);
Task t22 = new Task("t22", "Ped 1561 L1", r2.getResourceId(), _r2.getResourceName(), parseDate("12/22/2006 08:00"), parseDate("12/22/2006 11:30"), "gold");
t22.setLabel(t22.getTaskName());
_t22.setStartupTime(30);
r2.addTask(t22);
Task t23 = new Task("t23", "Ped 1562 L1", r2.getResourceId(), _r2.getResourceName(), parseDate("12/22/2006 14:00"), parseDate("12/22/2006 16:30"), "gold");
t23.setLabel(t23.getTaskName());
r2.addTask(t23);
Employee _r3 = new Employee("r3", "BELSO", "Celula 3", "14:00", "16:00", null);
Task t31 = new Task("t31", "Ped 1568 L1", r3.getResourceId(), _r3.getResourceName(), parseDate("12/21/2006 10:30"), parseDate("12/21/2006 11:15"), "grey");
t31.setLabel(t31.getTaskName());
_t31.setStartupTime(20);
Task t32 = new Task("t32", "Ped 1569 L1", r3.getResourceId(), _r3.getResourceName(), parseDate("12/21/2006 12:30"), parseDate("12/21/2006 13:30"), "tan");
t32.setLabel(t32.getTaskName());
_t32.setStartupTime(20);
r3.addTask(t31);
r3.addTask(t32);
Task t33 = new Task("t33", "Hibbings West", r3.getResourceId(), _r3.getResourceName(), parseDate("12/22/2006 9:30"), parseDate("12/22/2006 11:15"), "grey");
t33.setLabel(t33.getTaskName());
_t33.setStartupTime(15);
Task t34 = new Task("t34", "Hibbings West", r3.getResourceId(), _r3.getResourceName(), parseDate("12/22/2006 14:30"), parseDate("12/22/2006 17:30"), "tan");
t34.setLabel(t34.getTaskName());
r3.addTask(t33);
r3.addTask(t34);
Employee _r4 = new Employee("r4", "Joe Block", "Consulting", "06:00", "15:00", null);
Task t41 = new Task("t41", "Harwell", r4.getResourceId(), _r4.getResourceName(), parseDate("12/21/2006 09:30"), parseDate("12/21/2006 10:30"), "purple");
t41.setLabel(t41.getTaskName());
Task t42 = new Task("t42", "Service.com", r4.getResourceId(), _r4.getResourceName(), parseDate("12/21/2006 15:00"), parseDate("12/21/2006 16:30"), "aqua");
t42.setLabel(t42.getTaskName());
_t42.setStartupTime(15);
r4.addTask(t41);
r4.addTask(t42);
Task t43 = new Task("t43", "Harwell", r4.getResourceId(), _r4.getResourceName(), parseDate("12/22/2006 11:30"), parseDate("12/22/2006 12:30"), "purple");
t43.setLabel(t43.getTaskName());
Task t44 = new Task("t44", "Service.com", r4.getResourceId(), _r4.getResourceName(), parseDate("12/22/2006 15:30"), parseDate("12/22/2006 16:30"), "aqua");
t44.setLabel(t44.getTaskName());
_t43.setStartupTime(15);
r4.addTask(t43);
r4.addTask(t44);
Employee _r5 = new Employee("r5", "Stacey Edwards", "Support", "06:00", "15:00", null);
Task t51 = new Task("t51", "HewWWWitt Pacific", r5.getResourceId(), _r5.getResourceName(), parseDate("12/21/2006 13:00"), parseDate("12/21/2006 14:30"), "red");
t51.setLabel(t51.getTaskName());
r5.addTask(t51);
Task t52 = new Task("t52", "Hewitt Pacific", r5.getResourceId(), _r5.getResourceName(), parseDate("12/22/2006 13:00"), parseDate("12/22/2006 15:30"), "green");
t52.setLabel(t52.getTaskName());
Task t53 = new Task("t53", "Hewitt Pacific", r5.getResourceId(), _r5.getResourceName(), parseDate("12/22/2006 16:00"), parseDate("12/22/2006 17:30"), "green");
t53.setLabel(t53.getTaskName());
_t53.setStartupTime(30);
r5.addTask(t52);
r5.addTask(t53);
Employee _r6 = new Employee("r6", "Jimmy Jones", "Support", "06:00", "15:00", null);
Task t61 = new Task("t61", "900414 29,5º BLA BLA BLA", r6.getResourceId(), _r6.getResourceName(), parseDate("12/21/2006 10:00"), parseDate("12/21/2006 11:00"), "orange");
t61.setLabel(t61.getTaskName());
r6.addTask(t61);
Task t61B = new Task("t61B", "XXX414 29,5º BLA BLA BLA", r6.getResourceId(), _r6.getResourceName(), parseDate("12/21/2006 10:00"), parseDate("12/21/2006 11:00"), "orange");
t61B.setLabel(t61B.getTaskName());
r6.addTask(t61B);
Task t61c = new Task("t61c", "XXX414 29,5º BLA BLA BLA", r6.getResourceId(), _r6.getResourceName(), parseDate("12/21/2006 10:00"), parseDate("12/21/2006 11:00"), "orange");
t61c.setLabel(t61c.getTaskName());
r6.addTask(t61c);
Task t61d = new Task("t61d", "XXX414 29,5º BLA BLA BLA", r6.getResourceId(), _r6.getResourceName(), parseDate("12/21/2006 10:00"), parseDate("12/21/2006 11:00"), "orange");
r6.addTask(t61d);
Employee _r7 = new Employee("r7", "Dominique Monstratelli", "Technical Staff", "06:00", "15:00", null);
Task t71 = new Task("t71", "wwwState Machine", r7.getResourceId(), _r7.getResourceName(), parseDate("12/21/2006 13:00"), parseDate("12/21/2006 15:30"), "blue");
t71.setLabel(t71.getTaskName());
Task t72 = new Task("t72", "Johnson", r7.getResourceId(), _r7.getResourceName(), parseDate("12/21/2006 15:00"), parseDate("12/21/2006 16:30"), "aqua");
t72.setLabel(t72.getTaskName());
r7.addTask(t71);
r7.addTask(t72);
Task t73 = new Task("t73", "State Machine", r7.getResourceId(), _r7.getResourceName(), parseDate("12/22/2006 10:00"), parseDate("12/22/2006 11:30"), "levander");
t73.setLabel(t73.getTaskName());
Task t74 = new Task("t74", "Johnson", r7.getResourceId(), _r7.getResourceName(), parseDate("12/22/2006 15:00"), parseDate("12/22/2006 16:30"), "blue");
t74.setLabel(t74.getTaskName());
r7.addTask(t73);
r7.addTask(t74);
Employee _r8 = new Employee("r8", "Sue Morgan", "Technical Staff", "06:00", "15:00", null);
Task t81 = new Task("t81", "Hewitt Pacific", r8.getResourceId(), _r8.getResourceName(), parseDate("12/21/2006 11:15"), parseDate("12/21/2006 12:30"), "gold");
t81.setLabel(t81.getTaskName());
Task t82 = new Task("t82", "Hewitt Pacific", r8.getResourceId(), _r8.getResourceName(), parseDate("12/21/2006 13:30"), parseDate("12/21/2006 15:00"), "grey");
t82.setLabel(t82.getTaskName());
_t82.setStartupTime(15);
Task t83 = new Task("t83", "Johnson", r8.getResourceId(), _r8.getResourceName(), parseDate("12/21/2006 15:15"), parseDate("12/21/2006 16:00"), "tan");
t83.setLabel(t83.getTaskName());
r8.addTask(t81);
r8.addTask(t82);
r8.addTask(t83);
Task t84 = new Task("t84", "Johnson", r8.getResourceId(), _r8.getResourceName(), parseDate("12/22/2006 14:15"), parseDate("12/22/2006 16:00"), "lime");
t84.setLabel(t84.getTaskName());
_t84.setStartupTime(30);
r8.addTask(t84);
ArrayList _resources = new ArrayList(10);       
resources.add(r1);
resources.add(r2);
resources.add(r3);
resources.add(r4);
resources.add(r5);
resources.add(r6);
resources.add(r7);
resources.add(r8);
return ModelUtils.toTreeModel(_resources);
}

Similar Messages

  • Dvt:schedulingGantt - How to hide "Resource"  and "Task" menus

    I am using JDev 11.1.1.2.0 ADF.
    In the schedulingGantt component two menus "Resource" and "Task" on top left of the chart are displayed at runtime by default. These menus always remain disabled so there is no use for them.
    Is there a way to hide these menus? I tried using Firebug but so far I have not been able to find a way to hide these menus.
    Thanks
    Mitesh.

    Repost.

  • What is the difference between thread and task

    hi ,this is guruvulu bojja
    what is the diff between thread and task .
    can u give me the example for distinguish a thread and a task .
    How can i know thread is better than a task .
    please tell me what is the task in o/s level and task.
    <b>how the o/s distinguish a therad and task.</b>

    Hi Guruvulu,
    <b>Threads</b> enhance performance and functionality by allowing a program to efficiently perform multiple <b>tasks</b> simultaneously.
    In the case of <i><b>common memory</b></i> <b>threads</b> naturally have shared data regions while it has to be specially created and initialized for <b>tasks</b>.
    Simply put, a <b>thread</b> is a program's path of execution. It allows execution of two or more sections of a program at the same time.
    Regards,
    Pooja.

  • Difference between Resource and Workcenter

    Hello guys,
      i know this question is addresed before, but i am not satisfied with their answers, and even i looked in SAP HELP but i didn' get the answer.
       I know some of the differences that they use different category, and in resource we use phases instead of suboperation,and in resource we can use secondary resource.
        So guys could u help in finding the differences between them.

    WorKCenter is the terminology used in Production (ex. Automotive, High-Tech) Industries.
    Resource is analogous to WorkCenter, but the terminology is used more in Process Industries (Ex. Chemical, Pharma etc.)
    To Clarify futher,  at SAP functionality perspective Sub-Operations & Phases are the functionalities that come with Routings &  Recipes which are used in PP & PI Industries repectively.  
    Hope this helps.
    Regards,
    Bharat.

  • Measuring lag between input and output sine waves...

    Hi,
    I am using a Labview VI to control an array of servo motors, each receiving a sine wave input (with different phase offsets for each servo). I'm using a NI USB-6229 DAQ system to monitor their movement via a wire that I've soldered onto each servo's potentiometer. I've written another VI that recieves both the initial sent signal and the returned DAQ signal and plots both on a waveform chart. Both signals show up on the plot as expected, with an obvious phase shift between them. I'm having problems accurately measuring the phase shift, and I'd rather have an automatic method that gives accurate numerical values instead of a more qualitative visual method.
    So far I've tried to use triggers and peak to peak comparisons, but I've been having problems getting results in real time. My incoming signals are time stamped, if that helps. Is there a quick and easy method to extract phase shift data from two sine waves on a waveform chart?
    Thanks for the help...

    Since I work with lock-in amplifiers I came up with this. I guess it will work in your case. This method has some limitations. It will work up to 180 degree. It also measure absolute phase lag. You can not say if the signal is leading or lagging. But in your case it will always be lagging. I posted a VI showing the method in another discussion. Here is the link. http://forums.ni.com/ni/attachments/ni/170/409516/1/demo_v2.vi. Since your DAQ unit do not have simultaneous sampling you will get a small phase error due to inter-channel delay. This is also true if you use the FFT method. What is your signal frequency and which samplerate do you use?
    Besides which, my opinion is that Express VIs Carthage must be destroyed deleted
    (Sorry no Labview "brag list" so far)

  • HT204370 why is there a lag between sound and the film

    can anyone help me my films in i tunes have a lag between the sound and the picture. They worked fine when i purchased them but have now developed this time delay, Very annoying when their lips move but out of time to thier spoken word.

    Hey ben.brittain,
    There's an article that helps troubleshoot video playback issues within iTunes for Windows 7. It specifically mentions audio that is out of sync with the image on-screen. You can check it out here:
    Troubleshooting iTunes for Windows Vista or Windows 7 video playback performance issues
    http://support.apple.com/kb/TS1718
    Cheers,
    David

  • LAG between SG300 and Windows server on VMware ESXi 5.5

    Hello,
    I'm trying to setting up a LAG of 2 x 1GB between a Windows 2012 server on VMware 5.5 and a SG300-52 switch, but without any success till now.
    The SG300 is configured as follow :
    config-file-header
    SG300-52
    v1.4.0.88 / R800_NIK_1_4_194_194
    CLI v1.0
    set system mode router
    file SSD indicator encrypted
    ssd-control-start
    ssd config
    ssd file passphrase control unrestricted
    no ssd file integrity control
    ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
    port jumbo-frame
    vlan database
    vlan 10,20,30,40,50,60,70,99
    exit
    voice vlan id 40
    voice vlan oui-table add 0001e3 Siemens_AG_phone________
    voice vlan oui-table add 00036b Cisco_phone_____________
    voice vlan oui-table add 00096e Avaya___________________
    voice vlan oui-table add 000fe2 H3C_Aolynk______________
    voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
    voice vlan oui-table add 00d01e Pingtel_phone___________
    voice vlan oui-table add 00e075 Polycom/Veritel_phone___
    voice vlan oui-table add 00e0bb 3Com_phone______________
    port-channel load-balance src-dst-mac-ip
    ip dhcp pool network DHCP-VLAN1
    address low 192.168.2.120 high 192.168.2.139 255.255.255.0
    default-router 192.168.2.1
    exit
    ip dhcp pool network DHCP-Internal
    address low 172.16.0.40 high 172.16.0.79 255.255.255.0
    default-router 172.16.0.1
    exit
    ip dhcp pool network DHCP-Management
    address low 10.0.0.120 high 10.0.0.139 255.255.255.0
    default-router 10.0.0.1
    exit
    ip dhcp pool network DHCP-Phone
    address low 10.0.2.80 high 10.0.2.99 255.255.255.0
    default-router 10.0.2.1
    exit
    ip dhcp pool network DHCP-Pro
    address low 10.0.1.140 high 10.0.1.199 255.255.255.0
    default-router 10.0.1.1
    exit
    ip dhcp relay address 10.0.0.60
    ip dhcp relay enable
    ip dhcp information option
    bonjour interface range vlan 1,10,20,30
    qos trust cos
    hostname SG300-52
    username cisco password encrypted c464af817287343305cbd6493c593885695df531 privilege 15
    ip ssh server
    ip telnet server
    interface vlan 1
     ip address 192.168.2.1 255.255.255.0
     no ip address dhcp
    interface vlan 10
     name Management
     ip address 10.0.0.1 255.255.255.0
     ip dhcp relay enable
    interface vlan 20
     name Pro
     ip address 10.0.1.1 255.255.255.0
     ip dhcp relay enable
    interface vlan 30
     name Internal
     ip address 172.16.0.1 255.255.255.0
     ip dhcp relay enable
    interface vlan 40
     name Phone
     ip address 10.0.2.1 255.255.255.0
     ip dhcp relay enable
    interface vlan 50
     name TV
    interface vlan 60
     name "Exchange DB Replication"
     ip address 10.0.100.1 255.255.255.0
    interface vlan 70
     name Test
    interface vlan 99
     name WAN
     ip address 192.168.0.2 255.255.255.224
    interface gigabitethernet1
     switchport mode access
     switchport access vlan 10
    interface gigabitethernet2
     switchport trunk allowed vlan add 10,30,40
     no cdp enable
    interface gigabitethernet3
     switchport trunk allowed vlan add 20
    interface gigabitethernet4
     switchport mode access
     switchport access vlan 60
    interface gigabitethernet5
     switchport mode access
     switchport access vlan 10
    interface gigabitethernet6
     switchport mode access
     switchport access vlan 20
    interface gigabitethernet7
     switchport mode access
     switchport access vlan 20
    interface gigabitethernet8
     switchport mode access
     switchport access vlan 30
    interface gigabitethernet9
     switchport trunk allowed vlan add 10
    interface gigabitethernet25
     switchport mode access
     switchport access vlan 10
    interface gigabitethernet26
     channel-group 2 mode on
    interface gigabitethernet27
     channel-group 2 mode on
    interface gigabitethernet28
     switchport trunk native vlan 60
    interface gigabitethernet29
     switchport mode access
     switchport access vlan 20
    interface gigabitethernet30
     switchport mode access
     switchport access vlan 30
    interface gigabitethernet32
     qos cos 5
     switchport mode access
     switchport access vlan 10
    interface gigabitethernet45
     spanning-tree link-type point-to-point
     switchport mode access
     switchport access vlan 50
     macro description switch
     !next command is internal.
     macro auto smartport dynamic_type unknown
    interface gigabitethernet46
     switchport mode access
     switchport access vlan 50
    interface gigabitethernet47
     switchport mode access
     switchport access vlan 50
    interface gigabitethernet48
     switchport mode access
     switchport access vlan 50
    interface gigabitethernet49
     switchport mode access
     switchport access vlan 99
    interface gigabitethernet51
     spanning-tree link-type point-to-point
     switchport trunk allowed vlan add 10,20,30,40,50,60,70,99
     macro description switch
     !next command is internal.
     macro auto smartport dynamic_type switch
    interface Port-channel2
     description HBAIP-VM2
     switchport trunk allowed vlan add 10,20,30,40
    exit
    ip default-gateway 192.168.0.1
    ip route 10.0.0.0 /24 192.168.0.1
    ip route 10.0.1.0 /24 192.168.0.1
    ip route 10.0.2.0 /24 192.168.0.1
    ip route 172.16.0.0 /24 192.168.0.1
    GE26 & GE27 have been added in LAG2
    VLAN 1UP, 10T, 20T, 30T & 40T have joined the LAG
    In VMware, a vswitch has been created, using the 2 NIC connected to the LAG; and a Virtual Machine Port Group has been created for each VLAN member of the LAG
    In Windows 2012, the 4 Network adapters have been added (1 for each VLAN), but they cannot ping their gayeway
    However, the interfaces receives correctly thei IP addresses (and options) from the DHCP server, via the DHCP relay of the SG300
    I also following the configuration described in this link (http://it-erate.com/setting-lag-vmware-esxi-5-cisco-sg300/) but without any success.
    Do you have any idea ?
    Thanks in advance for your help.

    Please make sure the load balance mode in VMware is Route based on IP Hash.
    The default value is virtual switch port ID, which cannot work together with port-channel in upstream switch, as explained in: 
    http://www.vmware.com/files/pdf/virtual_networking_concepts.pdf
    "Note: If you select either srcPortID or srcMAC hash, you should
    not configure the physical switch ports as any type of team or
    bonded group."

  • I have a major lag between typing and the letters appearing on my screen? Any suggestions?

    When the key board appears on the screen I start typing, but there appears to be a major pause between the typing and the letters appearing on the screen.  It started after updating my system some time ago.  I have an ipad1. 

    Try reset all settings
    Settings>General>Reset>Reset All Settings
    Note: Data will not be affected but settings will be reset.

  • How to syncronize data between resource and IdM?

    I created a form (assign to proxy administrator) for reconciliation, and it gets executed when I imported new user into IdM through full reconciliation. In this way I can assign email of user to waveset.email.
    But later when the email gets updated in resource directly, how can I propagate the new value to IdM (without activeSync). By running a full reconciliation again doesn't seem to re-run the proxy administrator's form. I always thought full reconciliation would do the trick, but only now I realize it does not work at all !!?
    What should I do then to synchronize the data?

    Recon was not really designed to automatically synchronize attributes. Typically, this is implemented via ActiveSync. With that said, there is an option in Recon to "Attribute-Level Reconciliation". This allows you to provide a list of resource attributes to watch and if there is a change, Recon calls a workflow, where you can execute any changes you would like.
    I believe this workflow is called "Audit Native Change To Account Attributes". Look at wfrecon.xml located in /sample.
    Edited by: R1100SLA on Dec 21, 2007 12:12 AM

  • When watching Youtube, there is a lag between sound and video. Does anyone know how to fix this. It only seems to happen on Youtube.

    Youtube starts ok, but there is a sound/video lag which becomes greater as the video continues. This doesnt happen on other sites which use video.

    Try:
    - Reset the iOS device. Nothing will be lost       
    Reset iOS device: Hold down the On/Off button and the Home button at the same time for at
    least ten seconds, until the Apple logo appears.
    - Go to Settings>Messages>Send and Receive and sign out of the ID and sign back in. Note this will delete all old Messages from the iPod.
    - Reset all settings      
    Go to Settings > General > Reset and tap Reset All Settings.
    All your preferences and settings are reset. Information (such as contacts and calendars) and media (such as songs and videos) aren’t affected.
    - Restore from backup. See:                                                
    iOS: How to back up                                                                                     
    - Restore to factory settings/new iOS device.             

  • Lags between app and back button

    I just experienced this problem lately. When I pressed the app button to go into the app pages, it takes about 3 seconds for the 1st app page to appear. Following this, when I want to return to the home screen, I press the back button, and the icons in the home screen also takes 3 seconds to appear.
    I've checked my phone memory, RAM, uptime, all are fine. I don't overflow my phone with apps, and I don't play games.
    May I know why is this happening? It has never happened before. Please help. Thank you.

    It'll be wise to reinstall the latest update with PCC and stay away from antivirus or taskillers 
    PC Companion (PCC)
    Bridge (for Mac)
    Alternatives on How to backup Xperias
    http://talk.sonymobile.com/thread/36355
    "I'd rather be hated for who I am, than loved for who I am not." Kurt Cobain (1967-1994)

  • 2.1 RC1 - Performance problem, typing lag in EA2 and RC1

    Hi!
    I have searched and searched the forum but cannot find any reference to this specific issue.. Please accept my apologies if this has already been posted as I can't believe there are no other occurences of this out there
    On moving from 1.5.5 to either 2.1 EA2 or RC1, I experience massive performance issues making SQL Developer unusable.
    Basically, just typing into a SQL worksheet consumes most of my machine CPU and results in a huge amount of lag: typing a simple SELECT statement will take 10 to 20 seconds just for the text to catch up with my typing! It's infuriating!
    I've disabled all of the Code Insight options, ensure the 'Select default path to look for scripts' field is empty and I've tried both the JRE inclusive and exclusive versions all with the same result. If I fire up 1.5.5 I'm immediately back in business with no lag between typing and the display.
    My laptop is well spec'd - XP Pro, 2Ghz dual core, 2 GB RAM
    Any thoughts other than what I've tried above?
    Many thanks in advance!
    Edited by: user4523743 on 07-Dec-2009 03:21

    Okay, this is weird. I can get around this by setting the 'Select default path for scripts' preference to something other than blank!
    I'm wondering if this is because a group policy sets the default homedrive / My Documents folder to something on a network share. Could it be that having this value blank is causing SQL Developer to poll this share, and therefore the network, causing the performance issue?
    As it is, setting the value to something on the local drive (C:\) seems to fix it - contrary to what other posts have had to say on the matter of this preference!

  • What si the difference between crete and create insert operations.

    Hi
    In ADF 11g,what is the difference between create and createinsert operations.
    if anyone knows plz tell me.Any document about this plz provide me.
    Any help is appreciated.
    Sailaja.

    Hi,
    CreateInsert: Creates a new row that becomes the current row, and inserts the
    new blank row into the data source.
    Create: Creates a new row that becomes the current row, but does not insert it.
    --> normaly you would use createinsert
    Doc you can find here (search for Createinsert): http://download.oracle.com/docs/cd/E12839_01/web.1111/b31974.pdf
    br
    Peter

  • Dvt:schedulingGantt : to show current date directly with the week

    Hello everyone,
    i use Jdeveloper 11g and ADF.
    I use this component: "dvt:schedulingGantt" and
    Q1: I would like to know if I can show directly when I'm going on this page the current week.
    Q2: Is it possible to put on "Start time" field the current date minus one month? and "End time" field the current date plus one year?
    Thank you
    Regards

    Are you sure you haven't committed one of the cardinal sins of the Java-ignorant by confusing it with Javascript?

  • How does Order Analysis measure phase lag, particularly super-sync amplitudes?

    In recent testing of a high speed gear box, an 8X amplitude was observed (on the radial displacement probes) as the gear passed through a certain speed range. An NI4472 pci card and vi's written in 7 Express, w/ Order Analysis tool kit were configured with radial displacement probes and keyphasor as input signals. The behavior of the phase lag measurement is significant. If the phase lag of the 8X amplitude rolled as the gear passed through a particular speed range then this could suggest one particular problem, but if the phase lag remained constant then this could indicate a different problem. So, someone asked: How does the system measure phase lag of supersynchronous amplitudes?

    See attached file for figure 1,2,3
    The Phase measurement in the LabVIEW Order Analysis Toolkit uses the phase lag convention. Phase is defined as the angle difference measured from the peak of a vibration signal backward in time to the reference trigger point. This means the directions of numerically increasing angles are always set against the shaft rotation. The trigger point here is the tachometer pulses.
     Figure 1 shows the relationship of the vibration signal and reference signal to zero degree phase. The shaft has a heavy spot and a keyway slot. When the keyway slot passes the tachometer, the tachometer detects a trigger pulse. The heavy spot causes the shaft to vibrate as the shaft rotates. When the heavy spot passes the proximity probe, the vibration reaches a peak. When the heavy spot passes the proximity probe and the keyway slot passes the tachometer simultaneously, the peak of the vibration does not lag or lead the reference trigger point. At this point the phase is zero degrees.
     The other part of the convention dictates that 90 degrees means that the peak of vibration lags 90 degrees behind the trigger point. Figure 2 1illustrates the 90 degree phase. When the vibration signal reaches the peak, rotate the shaft backward (counter the rotation direction) until the keyway slot passes the tachometer. The number of degrees you rotate is the phase lag, or the phase value in machinery vibration measurement. Figure 2 shows the relationship of the vibration signal and reference signal to the 90 degrees phase convention.
    For the 8x phase, the measurement is conducted in the similar way. The difference is that the 8x order component go 8 times faster than the trigger pulses. Figure 3 shows the 90 degree phases ( tacho pulse in rising edge) of the 8x order components. The phase measurement is still conducted through calculating the delay between the peak in the 8x vibration components and the trigger pulses and comparing the delay to one cycle of the 8x components. In figure 3, the signals between the two green grid lines are used to output one phase results.

Maybe you are looking for

  • How can I revert to 10.4.9 from 10.4.10

    I use Dolbe Ditigal Edition for work and ever since I updated from 10.4.9 to 10.4.10 it crashes every time I try to open a file. When I look at the system requierments on the adobe page, http://www.adobe.com/products/digitaleditions/systemreqs/ it sa

  • XML parsing failed because ""

    Hi ,      I am facing issue while building composite in jdeveloper.It is showing below error.Please Suggest how to proceed further. Error: XML parsing failed because "" Buildfile: C:\Oracle\Middleware\jdeveloper\bin\ant-sca-compile.xml scac:      [sc

  • I tunes & I Photo not recognising my I Phone. Help!

    Hi just updated my mac and I tunes to version 11.0.4. and now it doesn't recognise my i phone (which is up to date re: software). Tried all the tips on Apples website but just can't get it recognised in either iPhoto or i tunes. Help please!

  • Using Mail with Exchange Servers

    My office, which is all PC except for my iMac, recently set up a Microsoft Exchange Server. I've set up my exchange account on Mail, however, when I log in using Outlook on a PC I can go into the advance settings and add additional shared mailboxes.

  • Issue in generating "XSL" file from excel template

    Hi, I am trying to genreate "XSL" file using ExcelProcessor class using below code snippet. FileInputStream fIs = new FileInputStream("D:\\Test.XLS"); //input excel template FileOutputStream fOs = new FileOutputStream("D:\\Test_OUT.XSL"); // output x