Announce route with BGP

Hi,
how can i announce in router C with BGP, the VLAN 2 to the router A, and VLAN 3 to router B?
The router B can't know the VLAN 2 and router A can't know the VLAN 3
thanks for the help

Hello
following on from richards post - below is an example of the config he is refering to -
conf t
access-list 2  permit 192.168.2.0 0.0.0.255
access-list 3  permit 192.168.3.0 0.0.0.255
ip as=path access-list 1 permit ^$
route-map Vlan2 permit 10
match ip address 2
route-map Vlan3 permit 10
match ip address 3
router bgp 11111
network 192.168.2.0
network 192.168.3.0
neighbour 10.10.1.x route-map Vlan2 out
neighbour 10.10.1.x filter-list 1 out ( prohibit transit routes Between isp A and B)
neighbour 10.10.2.x route-map Vlan3 out
neighbour 10.10.2.x filter-list 1 out ( prohibit transit routes between isp B and A)
res
Paul

Similar Messages

  • Difference between sh ip bgp & sh ip route? BGP tables and main routing table.

    Difference between sh ip bgp & sh ip route?
    sh ip bgp :::: loc-rib ?
    sh ip bgp nei x.x.x.x advertised-routes : adj-rib-in.
    sh ip bgp nei x.x.x.x recieved-routes : adj-rib-out.
    sh ip bgp nei x.x.x.x routes : loc-rib ?
    sh ip route = rib ? if yes does it mean its loc-rib ?
    so in a given router with bgp running, will there be 5 tables (sh ip bgp; adj-rib-in; loc-rib;adj-rib-out; sh ip route) ? if yes where are they saved ?

    sh ip bgp
    shows the BGP table (where are stored info coming from BGP update) 
    sh ip bgp nei x.x.x.x advertised-routes 
    shows networks that your router will advertise to a specific neighbor
    sh ip bgp nei x.x.x.x recieved-routes 
    shows advertisement received from a specific neighbor;  networks (NLRI) filtered with route-map distribute-list,... are included  (Inbound soft reconfiguration must be enabled)
    sh ip bgp nei x.x.x.x routes 
    shows only routes sent by a specific neighbor and not filtered or discarded (i.s accepted)
    sh ip route 
    show routing table; it contains the best route for each network (best is first of all the lowest administrative distance, then the lowest metric)
    Bye,
    enrico.
    PS please rate if useful

  • Help routing with dual connections to 1 ISP, 2 routers, 2 firewalls

    My company is moving to a new office building and has ordered redundant Internet connections through the same ISP.  I have not had the chance to speak to the ISP vendor, but from what I have been told they expect us to participate in BGP since we will require load-balancing and high availability for inbound web traffic.  My limited experience with BGP has been in a lab environment.  The company has already purchased the two routers and two ASAs.  We have a block of public IP addresses. 
    My objectives are to
    1.  Allow internal users to get out to the Internet
    2.  Allow outside users to browse our public web site.
    3.  Configure the routers and ASAs in such a way that if any one device fails or one of the Internet connections goes down, business will continue as usual.
    Below are just some of my questions to help me ensure I am heading down the correct path:
    --Will the IP addresses on the point-to-point links between our routers and the ISP come from our block of IP addresses, or will they be separate /30 links that the ISP provides?  (Again, I have not had a chance to speak to the vendor) 
    --Will the iBGP link "A" require the use of public IP addresses or can private IPs be used?  Besides configuring iBGP on these routers, is a First Hop Redundancy Protocol configured here as well?
    --Should there be routed links between R1 and FW2, and R2 and FW1?  Does that overly complicate the design without any real value added?
    --Would OSPF or EIGRP typically be configured for links B, C & D to enable the redundancy desired between the firewalls and routers?
    --What is the best practice for determining outbound traffic flow from the layer 3 switches (6509s configured as a VSS) to the two ASAs?
    Any assistance is greatly appreciated.
    Mike

    Hi there
    first of all you need in your design to me sure that traffic flow inbound  and outbound to be aligned end to end
    answeres to your questions are per below:
    --Will the IP addresses on the point-to-point links between our routers and the ISP come from our block of IP addresses, or will they be separate /30 links that the ISP provides?  (Again, I have not had a chance to speak to the vendor)
    No dose not need and ask the ISP to provide you with their own IPs for the p2p links ( to avoid wasting your public IPs )
    --Will the iBGP link "A" require the use of public IP addresses or can private IPs be used?  Besides configuring iBGP on these routers, is a First Hop Redundancy Protocol configured here as well?
    No you can use private IPs
    --Should there be routed links between R1 and FW2, and R2 and FW1?  Does that overly complicate the design without any real value added?
    it is better here to use a L2 shared VLAN ( switch ) for those interfaces to get FHRP of the routers and failover of the FWs working as expected
    --Would OSPF or EIGRP typically be configured for links B, C & D to enable the redundancy desired between the firewalls and routers?
    if you are using HSRP/VRRP between the routers and using failover between the FWs then using a shared L2 vlan as suggested above will be required without IGP such as EIGRP also the link between the firewalls used for FW failover is not like the one used between the routers "dose not need routing"
    --What is the best practice for determining outbound traffic flow from the layer 3 switches (6509s configured as a VSS) to the two ASAs?
    if you put the ASA FWs in failover mode then the IP address of th eprimary/active ASA FW will be used for your static routes in the L3 switches to point to and this IP will be used by the secondary FW in the case of failover situation "transparent and automatic "
    hope this help
    if helpful rate

  • Partitioned-MDT MP2MP with BGP-AD/mLDP in XR 4.3

    I've been working on trying to get LSM working between a couple of A9Ks to support a SSM based IPTV application.
    After ingesting a bunch of content on the subject, I think what I want is Partitioned MDT, MP2MP with BGP-AD/mLDP (PIM-free core).  I'm wondering if anyone has any links to working configuration examples for this type of MVPN or some good troubleshooting guides for this type of MVPN specifically.
    The XR 4.3 configuration guide seems to provide either a broken or an incomplete example, so what I've managed to work out from it, doesn't seem to work.
    By 'doesn't seem to work', I mean I have a SSM based join-group configured on a CE with a PIM adjacency to XR PE1.  XR PE1 sees the (S,G) from the CE, but the adjacent XR PE2 (config below) doesn't see it.
    Thanks in advance for any pointers.
    interface Loopback0
    ipv4 address 72.15.48.4 255.255.255.255
    interface Loopback2022
    vrf tv
    ipv4 address 172.16.0.32 255.255.255.255
    interface TenGigE0/0/0/15
    description Facing Source
    vrf tv
    ipv4 address 172.16.1.1 255.255.255.0
    interface TenGigE0/0/0/0
    description Facing Core
    cdp
    mtu 9216
    ipv4 address 72.15.49.80 255.255.255.254
    carrier-delay up 0 down 0
    dampening
    router bgp 21949
    address-family ipv4 unicast
    address-family vpnv4 unicast
    address-family ipv4 mvpn
    neighbor-group P-MVPN
    remote-as 21949
    update-source Loopback0
    address-family vpnv4 unicast
    address-family vpnv6 unicast
    address-family ipv4 mvpn
    neighbor 72.15.48.10
    use neighbor-group P-MVPN
    vrf tv
    rd 21949:2022
    address-family ipv4 unicast
      redistribute connected route-policy SOURCE--INTERNAL-CONNECTED
      redistribute static route-policy SOURCE--INTERNAL-STATIC
    address-family ipv4 mvpn
    multicast-routing
    address-family ipv4
    interface TenGigE0/0/0/0
      enable
    nsf
    mdt source Loopback0
    rate-per-route
    accounting per-prefix
    vrf tv
    address-family ipv4
      mdt source Loopback2022
      mdt partitioned mldp ipv4 mp2mp
      rate-per-route
      interface all enable
      bgp auto-discovery mldp
      accounting per-prefix
    mpls ldp
    router-id Loopback0
    graceful-restart
    session protection
    log
    neighbor
    graceful-restart
    session-protection
    mldp
    logging notifications
    interface TenGigE0/0/0/0
    router pim
    vrf tv
    address-family ipv4
      rpf topology route-policy MLDP-TV
      interface TenGigE0/0/0/15
       enable
    route-policy MLDP-TV
    set core-tree mldp-partitioned-mp2mp
    end-policy

    Hi Jason,
    As we have worked on this already. The resolution of this issue is by putting Loopback0 under multicast-routing.
    multicast-routing
    address-family ipv4
    interface TenGigE0/0/0/0
      enable
    interface loopback 0
    enable
    Thanks,
    Rivalino

  • External route with Down Bit set by CE router

    I have a question regarding the Down Bit. All the documentation I see concentrates on the redistribution of the MP-BGP into OSPF but I want to know more about the OSPF redistribution into MP-BGP. I think the rule is different for Type3 and Type5 LSAs.
    Lets say the CE redistributes a RIP route into OSPF, creating an LSA Type 5 route sent to the PE router - with the Down Bit set.
    Will this PE router redistribute this route into MP-BGP?
    I know that LSA Type 3 summary routes will not be redistributed into MP-BGP if the Down Bit is set but I am wondering about external OSPF routes with the Down Bit set????
    I am assuming that redistribution of RIP into OSPF at the CE does infact set this Down Bit before passing on to the PE router?

    How can step 2 in the sequence description say that PE2-AS1 receives an OSPF route with the Down Bit already set? This comes from the CE.
    I find this all very confusing when I check out these sequences - I thought only the PE router assigns Down Bit to LSA Type 3 routes?
    All the other references I see show how PE1-AS1 would normally set the Down Bit as it is redistributed back into OSPF?
    Thanks for your help - I feel I am getting closer. It is just this second step that is throwing me!
    Cheers
    Walter

  • Cisco 3925 router with an ATM E3 card that never goes down!

    Hi all,
    We a Cisco 3925 router with an ATM E3 card (NM-1A-T3/E3) configured as below with 1 PVC. we see that the ATM subinterface we created for the PVC never goes down! not even when the WAN link is down! The problem with this is we are tracking the line protocol of the ATM sub interface to have VRRP failover to standby router. But because of this issue only BGP goes down whenever the WAN is down & line-protocol of the Subinterface remains up, the failover never happens & site is down. We can configure VRRP to track reachability of a BGP route as workaround but I would like an explanation or troubleshooting steps to check whats the trouble with current setup?
    Cisco IOS Software, C3900 Software (C3900-UNIVERSALK9-M), Version 15.1(2)T4.1, MAINTENANCE INTERIM SOFTWARE
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2011 by Cisco Systems, Inc.
    Compiled Tue 30-Aug-11 08:44 by prod_rel_team
    card type e3 1
    interface ATM1/0
     description Link to PE
     mtu 1500
     bandwidth 34010
     no ip address
     no ip proxy-arp
     logging event subif-link-status
     no atm ilmi-keepalive
     no atm enable-ilmi-trap
    end
    interface ATM1/0.101 point-to-point
     description PVC to MPLS PE
     mtu 1500
     bandwidth 2500
     ip address a.b.c.d 255.255.255.252
     no ip proxy-arp
     ip flow monitor FMforIP4in sampler ata1to100 input
     ip flow monitor FMforIP4out sampler ata1to100 output
     ip nat outside
     ip virtual-reassembly in
     no atm enable-ilmi-trap
     snmp trap link-status
     pvc 1/101
      vbr-nrt 8192 8192 1
      vc-hold-queue 2048
      oam-pvc manage
      oam retry 3 5 1
      oam ais-rdi 15 3
      encapsulation aal5snap
      protocol ip inarp
      queue-depth 5 3
      service-policy out Edge_Queueing
    end
    Thanks a lot in advance!

    Your router has some configuration on it already and it would help us give you better advice if we knew what is already in the configuration. So would you post the output of show running-config (if there is sensitive information like addresses and passwords you can mask them out.
    Changing the configuration register was a good start. I have a couple questions/observations that may help you get started. I notice what appears to be the same public IP address on Gig0/0 and on multilink. Did you get that address from your ISP? If so what kind of connection do you have to the ISP?
    In your description you tell us that Gig0/0 is connected to a small switch, which I assume is for the LAN of your network. But that also is the interface where the public address is configured. So I am confused whether this interface is for LAN or for connecting to the ISP. Can you clarify this?
    HTH
    Rick

  • Vpls signaling with BGP

    Hi
    If i have in the mpls NET cisco routers that acts as route-reflector witch platforn and IOS support vpls sig with BGP?
    Tnx
    Sent from Cisco Technical Support Android App

    Hi David,
    Selected IOS versions indeed support VPLS signalling with BGP. Read more about the details in the following document:
    http://www.cisco.com/en/US/docs/ios/mpls/configuration/guide/mp_vpls_auto_bgp.html
    To find out which IOS releases and which platforms support VPLS signalling with BGP, visit the following URL:
    http://tools.cisco.com/ITDIT/CFN/jsp/by-feature.jsp
    Then search for VPLS as the search filter. There will be two relevant features: one displayed at the beginning will be the BGP VPLS Auto Discovery Support on Route Reflector, the one around row 14 will be VPLS Autodiscovery, BGP based. Select the feature you are interested in, add it to the right window and then click on the Continue button. You will then be presented with the list of platforms and IOSes supporting this feature.
    Best regards,
    Peter

  • I am trying to connect a Windows 7 / 64 bit to an Epson printer on my Mac.  The printer is hooked into the Mac via USB; the Mac is networked to a Linksys wireless router with an ethernet cable, as is the Windows box. Any tips on how to do this?

    I am trying to connect a Windows 7 / 64 bit to an Epson printer on my Mac.  The printer is hooked into the Mac via USB; the Mac is networked to a Linksys wireless router with an ethernet cable, as is the Windows box. I installed the current Bonjour printer services software on the Windows machine, and separately installed the driver software for the Epson printer on the WIndows machine.  Running the bonjour wizard, I get an alert saying 'I don't have sufficient access to my computer to connect to the selected printer'.
    The printer has 'sharing' turned on from the Mac end; this works with a Powerbook via the wireless connection.  Sharing is also turned on in the Windows printer control panel for this printer (under properties).  The Mac is a G5 running 10.5.8.  When I try to print a page from the Windows machine it gets hung in the print queue.
    Any advice how to proceed would be appreciated!
    thx,

    I am trying to connect a Windows 7 / 64 bit to an Epson printer on my Mac.  The printer is hooked into the Mac via USB; the Mac is networked to a Linksys wireless router with an ethernet cable, as is the Windows box. I installed the current Bonjour printer services software on the Windows machine, and separately installed the driver software for the Epson printer on the WIndows machine.  Running the bonjour wizard, I get an alert saying 'I don't have sufficient access to my computer to connect to the selected printer'.
    The printer has 'sharing' turned on from the Mac end; this works with a Powerbook via the wireless connection.  Sharing is also turned on in the Windows printer control panel for this printer (under properties).  The Mac is a G5 running 10.5.8.  When I try to print a page from the Windows machine it gets hung in the print queue.
    Any advice how to proceed would be appreciated!
    thx,

  • My wife and i have an iPhone 5 6.1.2 firmware.. We both are having horrible wifi signals.  We have done everything we can.. What update will fix this? I get full bars on my iPad 2 through my whole house.. Be standing right beside the router with iPhone NO

    My wife and i have an iPhone 5 6.1.2 firmware.. We both are having horrible wifi signals.  We have done everything we can.. What update will fix this? I get full bars on my iPad 2 through my whole house.. Be standing right beside the router with iPhones and it cuts in and out.. Drops from 3 wifi bars to 1

    I am having the same problem with brand new Ipad Mini at my house.
    It connects to the WiFi fine - but will not pull an IP address in DHCP mode, or if I set all the IP info statically - it still will not get any network access.
    This doesn't look like a WiFi issue, as it does connect and is seen by the WiFi Access Point.  All the normal WiFi fix stuff doesn't help.
    - Using a Dlink DAP-2553 which is less than 2 months old. 
    Other devices connect fine, including Ipad 2.
    This same Mini worked fine at another house and also connected to a mobile hotspot fine....so seems to be some weird IP issue with maybe this Access Point or maybe the older Router that I have (older Netgear)?
    I am actually a network engineer and still have not been able to find a solution.  Both the Ipad Mini and the Dlink WAP have the latest firmware loaded.
    Wondering if anyone has found a solution to this problem.

  • Having trouble setting up a linksys WRT54GS router with v...

    Having trouble setting up a linksys WRT54GS router with verizon DSL using a westell 6100F modem. the modem works fine by its self  but the router will not connect  to the internet when installed like the cd tells you to.
    online help and phone help has been less than helpful,  anyone have any Ideas?

    Ok I found " Installing the liksys wireless router with a westell 6100 modem" in the verizon troubleshooting guides. printed the instructions so I would'nt forget. step 1 open your web browser and enter http://192.168.1.1 in the address field.  PROBLEM it comes up with a login screen that I don't know how to sign into. tried the obvious stuff. cannot get past the login screen. I knew this sounded to easy to be true. anyone have any ideas? 

  • How to extend a wifi network of third party router with TC 4th generation?

    After searching the communities for a while, I did not find a definitive answer on the following question:
    - I recently bought a 4th generation Time Capsule 2TB (MD0322/A), that I also want to use as an extension for our existing wifi network.
    - This wifi network is maintained by a Sitecom Wireless 300N XR Gigabit Router. Router is set to work over 2.4 GHz (B+G+N) because of several non-N-wifi devices in the network. The channel in use is currently 11.
    - This router provides so called WDS functionality, i.e. the ability for other wifi access points to act as a seamless extension of the basic wifi network (using the same SSID).
    - The security settings in the router are WPA2 Mixed, with a password in plain ASCII.
    - There seems to be no way to set different security levels for WDS-connections versus normal AP (access point) connections. If WDS is enabled, the security settings of the AP-mode are extended to the WDS connection.
    I have set the Sitecom router to enable WDS, and added the MAC-address of the TC in the configuration of this router.
    When configuring the Time Capsule, with Airport Utility 5.5.3, I can select the option to use TC to extend an existing network, and I can select the network of choice using the WPA personal or WPA/WPA personal security. However, the TC does not succeed in extending the network, and reports this back. If I manually configure the TC and select the network of choice, Airport Utility reports back that the selected network cannot be extended.
    I have read several times in other posts that Time Capsule can only connect to third party routers via WDS using WEP-authentication, but these posts were quite old. I was wondering if this is still the case, or that Apple has updated this functionality in newer versions of TC, and thus there could exist a trick to connect to a WDS using WPA.
    I really would appreciate suggestions
    Bram Bos

    gilles13 wrote:
    I have a mac and pc (win7) both are connected thru a network with wifi and allready two access pt.
    Airport can not be used to extend a WiFi created by a non-Apple box.
    You need to turn off the radio in the router (shut down the existing WiFi).  Purchase TWO Airport Express units.  Connect one to the router with an Ethernet cable.  Configure that one as your primary WiFi network and then use the second Express as the extender.
    You need to locate the second Express where it receives a decent WiFi signal.  Too far away and it has nothing to extend.  Too close and it doesn't buy you anything.  Before you plug in the second Express, check to see where the primary WiFi disappears completely.  My personal WAG is that you want to locate the second Express 2/3 the distance to that point.
    If you use Airport Utility to configure the units, it's a snap.  In fact, if you configure the primary first and the extender second, AU will default to exactly the settings that you want.
    By the way, I refereed to the Express because it's less expensive than the Extreme and you didn't indicate any need for the Extreme features.

  • How can I set up a guest access point with a Time Capsule and an Airport Extreme? I am using a Telus router with the Time Capsule used as a wireless access point (bridge mode). I don't want the guest access point to have access to my network.

    How can I set up a guest access point with a Time Capsule and an Airport Extreme? I am using a Telus router with the Time Capsule used as a wireless access point (bridge mode). I don't want the guest access point to have access to my network.

    The Guest Network function of the Time Capsule and AirPort Extreme cannot be enabled when the device is in Bridge Mode. Unfortunately, with another router...the Telus...upstream on your network, Bridge Mode is indicated as the correct setting for all other routers on the network.
    If you can replace the Telus gateway with a simple modem (that performs no routing functions), you should be able to configure either the Time Capsule or the AirPort Extreme....whichever is connected to the modem....to provide a Guest Network.

  • I recently replaced my dead airport router with a netgear91-5g router and synced it successfully to my Lexmark Pro 915 printer and my computer and yet when I try to print wirelessly I get the message: "printer not connected; printer offline".

    I recently replaced my dead airport router with a Netgear91-5g router and synced it successfully to my Lexmark Pro 915 printer and my computer; yet when I try to print wirelessly I get the message: "printer not connected; printer offline". Lexmark support verified that my printer was connected to the new router and the problem was with the computer's printer configuration and they could reconfigure it online if I paid for their "Premium Support" services ($119 for one year, 3 fixes). I declined, feeling sure that this is something I could do if I knew how. Could it be an incompatability issue with OS 10.8.3?

    You saved me $$$ that I can ill afford on my fixed income. I was very unhappy with the "support" from Lexmark... what a rip off!  Thank you dwb!

  • Can you use an external antenna with the 4G LTE Router with Voice?

    I live in a black hole of cell service - very rural, in a valley surrounded by trees, no DSL, no cable, no other options except satellite internet which I did for 15 years and will never do again. My current data setup is a Pantech UML290 USB modem connected to a Cellphone-Mate full band outdoor Omni 3G/4G antenna on the roof. I just ordered an amplifier to boost the 4G LTE connection. The modem is plugged into a Cradlepoint MBR900 router, which then provides my home internet (way more than 10 devices, and mostly wired).
    Is there a way to add the antenna and amplifier setup to the broadband router with voice so I can be assured of the signal? If so, could I then use this router to feed the Cradlepoint and continue using multiple wired devices?
    I was set to order this router last night, but the CSR through chat told me that you cannot attach antenna to the router with voice - only to the one with data. This really doesn't make any sense to me, but she was firm about it. If I can attach, can I use the cables I have or will I need a different adapter?
    There is so little information about this particular router. My current setup is doing fairly well, but I would love the option to drop my landline and increase signal strength for both voice and data. With no antenna, the modem gets around -125 db, and can't connect at all. With the antenna mounted on the roof, and routed through the Cradlepoint, I consistently get -85 db. 4G LTE speeds are around 15-19 Mb/s down and very inconsistent 2.5-4.0 Mb/s up. However, the 4G drops and resets multiple times a day, so I usually sacrifice the speed to get a more stable 4.5-5 Mb/s down and 0.5 Mb/s up through forced 3G.
    Voice calls are spotty if received at all, and frequently drop immediately if there is any connection. And of course, the data limit has been a nightmare. I could potentially save some money by porting my landline to Verizon, but not if there is no way to boost the signals. The Omni antenna will boost all, but not sure if there's any way to route the existing antenna setup to feed both the voice and data sides, or if it would be enough to allow me to do this. This router also says it's 4G LTE only, but the specs on the antenna they sell say it boosts 3G for failover, so not sure if it will grab anything else. Any help or advice GREATLY appreciated! Thanks for reading through the whole thing.

    No, not directly. You would need to transfer your data from your iPad to your Mac and then back it up to an external drive.
    Pete

  • Frustrated - Can't connect to router with laptop after disconnect, other devices work fine.

    I have a RevI Actiontec router with dual antennas(not sure of firmware as I am not at home). My wife can be on her laptop all day, then when I come home with my IPad, it make her lose connection to the router. The router still connects to my iPhone 4 and iPad (both with iOS 6.0.1), but she is unable to connect to router at all. Everything continues to function normally on my Apple devices, so we are still connected to the internet. I have a laptop as well, and when this is happening, both of the laptops stop connecting, but the apple devices and our Toshiba TV and BluRay players continue to function normally. As a temp fix, I disconnect internet from my iPad and restart the router. It works until we try to run both at the same time.
    I am mildly computer literate, though I know little about network setups beyond security, MAC filtering, and other slightly advanced setup stuff.
    This is really frustrating and seems to be getting worse. We used it like this in our new house for several months before this started happening.

    Also check to make sure neither of the devices are set to use a static IP address.
    If a forum member gives an answer you like, give them the Kudos they deserve. If a member gives you the answer to your question, mark the answer as Accepted Solution so others can see the solution to the problem.
    "All knowledge is worth having."

Maybe you are looking for