BGP allowas-in and split horizon problem.

Hi,
I need some help. I can't understand why R2 advertises back the same networks to the neighbor from that received.
My topology is:
R1 is in AS1, R2 is in AS2 and R3 is in AS3, I've eBGP R1-R2, and eBGP R2-R3.
R1 and R3 has configured allowas-in to permit routes with their own AS.
The problem is with eBGP Updates. The router R1 advertise 1.1.1.1/32 to R2, and R2 sent back to R1 the same route 1.1.1.1/32.
I think that should not happen according the BGP split horizon rules. R2 should not advertise those networks who learned from R1, unless R2 has a route with better metric.
The same behavior happens between R2 and R3.
Thanks in advance.
All the router had the same IOS: c7200-is-mz.123-14.T1.bin
R1 Configuration
R1#sh run | sec router
router bgp 1
no synchronization
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
neighbor 172.28.1.1 remote-as 2
neighbor 172.28.1.1 allowas-in 10
neighbor 172.28.1.1 soft-reconfiguration inbound
no auto-summary
R1#
R2 Configuration
router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor 172.28.1.2 remote-as 1
neighbor 172.28.1.2 soft-reconfiguration inbound
neighbor 172.28.2.2 remote-as 3
neighbor 172.28.2.2 soft-reconfiguration inbound
no auto-summary
R2#
R3 Configuration
router eigrp 200
redistribute connected
redistribute bgp 3 metric 100000 10 255 100 1500
network 192.168.3.0 0.0.0.3
no auto-summary
router bgp 3
no synchronization
bgp log-neighbor-changes
redistribute connected
redistribute eigrp 200
neighbor 172.28.2.1 remote-as 2
neighbor 172.28.2.1 allowas-in 10
neighbor 172.28.2.1 soft-reconfiguration inbound
no auto-summary
R3#
R1 BGP Table, Advertised Route, Received Routes
R1#sh ip bgp
BGP table version is 6, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*  1.1.1.1/32       172.28.1.1                             0 2 1 i
*>                  0.0.0.0                  0         32768 i
*> 3.3.3.3/32       172.28.1.1                             0 2 3 ?
*> 4.4.4.4/32       172.28.1.1                             0 2 3 ?
*> 172.28.2.0/30    172.28.1.1                             0 2 3 ?
*> 192.168.3.0/30   172.28.1.1                             0 2 3 ?
R1#
R1#sh ip bgp neighbors 172.28.1.1 advertised-routes
BGP table version is 6, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       0.0.0.0                  0         32768 i
Total number of prefixes 1
R1#
R1#sh ip bgp neighbors 172.28.1.1 received-routes
BGP table version is 6, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*  1.1.1.1/32       172.28.1.1                             0 2 1 i
*> 3.3.3.3/32       172.28.1.1                             0 2 3 ?
*> 4.4.4.4/32       172.28.1.1                             0 2 3 ?
*> 172.28.2.0/30    172.28.1.1                             0 2 3 ?
*> 192.168.3.0/30   172.28.1.1                             0 2 3 ?
Total number of prefixes 5
R1#
R2 BGP Table, Advertised Route, Received Routes
R2#sh ip bgp
BGP table version is 7, local router ID is 172.28.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       172.28.1.2               0             0 1 i
*> 3.3.3.3/32       172.28.2.2               0             0 3 ?
*> 4.4.4.4/32       172.28.2.2          156160             0 3 ?
r> 172.28.2.0/30    172.28.2.2               0             0 3 ?
*> 192.168.3.0/30   172.28.2.2               0             0 3 ?
R2#
R2#
R2 Received routes from R1
R2#sh ip bgp neighbors 172.28.1.2 received-routes
BGP table version is 7, local router ID is 172.28.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       172.28.1.2               0             0 1 i
Total number of prefixes 1
R2#
R2 Advertised routes to R1
R2#sh ip bgp neighbors 172.28.1.2 advertised-routes
BGP table version is 7, local router ID is 172.28.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       172.28.1.2               0             0 1 i
*> 3.3.3.3/32       172.28.2.2               0             0 3 ?
*> 4.4.4.4/32       172.28.2.2          156160             0 3 ?
r> 172.28.2.0/30    172.28.2.2               0             0 3 ?
*> 192.168.3.0/30   172.28.2.2               0             0 3 ?
Total number of prefixes 5
R2#
R2 Received routes from R3
R2#sh ip bgp neighbors 172.28.2.2 received-routes
BGP table version is 7, local router ID is 172.28.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 3.3.3.3/32       172.28.2.2               0             0 3 ?
*> 4.4.4.4/32       172.28.2.2          156160             0 3 ?
r> 172.28.2.0/30    172.28.2.2               0             0 3 ?
*> 192.168.3.0/30   172.28.2.2               0             0 3 ?
Total number of prefixes 4
R2#
R2 Advertised routes to R3
R2#sh ip bgp neighbors 172.28.2.2 advertised-routes
BGP table version is 7, local router ID is 172.28.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       172.28.1.2               0             0 1 i
*> 3.3.3.3/32       172.28.2.2               0             0 3 ?
*> 4.4.4.4/32       172.28.2.2          156160             0 3 ?
r> 172.28.2.0/30    172.28.2.2               0             0 3 ?
*> 192.168.3.0/30   172.28.2.2               0             0 3 ?
Total number of prefixes 5
R2#
R3 BGP Table, Advertised Route, Received Routes
R3#sh ip bg
BGP table version is 7, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       172.28.2.1                             0 2 1 i
*  3.3.3.3/32       172.28.2.1                             0 2 3 ?
*>                  0.0.0.0                  0         32768 ?
*  4.4.4.4/32       172.28.2.1                             0 2 3 ?
*>                  192.168.3.2         156160         32768 ?
*  172.28.2.0/30    172.28.2.1                             0 2 3 ?
*>                  0.0.0.0                  0         32768 ?
*  192.168.3.0/30   172.28.2.1                             0 2 3 ?
*>                  0.0.0.0                  0         32768 ?
R3#
R3#sh ip bgp neighbors 172.28.2.1 advertised-routes
BGP table version is 7, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 3.3.3.3/32       0.0.0.0                  0         32768 ?
*> 4.4.4.4/32       192.168.3.2         156160         32768 ?
*> 172.28.2.0/30    0.0.0.0                  0         32768 ?
*> 192.168.3.0/30   0.0.0.0                  0         32768 ?
Total number of prefixes 4
R3#
R3#sh ip bgp neighbors 172.28.2.1 received-routes
BGP table version is 7, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       172.28.2.1                             0 2 1 i
*  3.3.3.3/32       172.28.2.1                             0 2 3 ?
*  4.4.4.4/32       172.28.2.1                             0 2 3 ?
*  172.28.2.0/30    172.28.2.1                             0 2 3 ?
*  192.168.3.0/30   172.28.2.1                             0 2 3 ?
Total number of prefixes 5
R3#

I agree with the previous posters.  What you could do is look at show bgp ipv4 unicast 1.1.1.1 on R2.  You will find that the prefix is associated with an update group.  An update group is an optimisation within the router BGP process to reduce the processing overhead for generating updates to peers.  If two peers have exactly the same outbound routing policy they would be in the same update group. If you looked at the update group show bgp ipv4 unicast update-group <number> you would probabably find that it would contain the peers 172.28.1.2 and 172.28.2.2.
This would mean that the 1.1.1.1 would be replicated to R1 and R3.  Without remoteas-in configured R1 would reject the prefix due the AS path containing AS1 - you can see this if you look at the output from show bgp ipv4 unicast neighbor 172.28.1.1 towards the bottom you will see the quantity of prefixes that have been rejected and why - use debug ip bgp updates if you want to see this in real time.
When remoteas-in is configured the prefix from R2 is accepted into the BGP table - however this is irrelevant as it will never become the best-path due to the weight 32768 for the local origination. If R1 peered with R4 via eBGP for example only this best path would advertised and hence nothing is broken.
HTH

Similar Messages

  • VPN and Split-DNS problem connecting 851 to 3030 Concentrator

    I have configured a Cisco 851 (IOS 12.4(11)T) to connect to the Cisco 3000 Concentrator (v4.72G). I am having multiple problems:
    1. On the concentrator I have specified multiple domain names for split DNS "hq.portablesunlimited.com,hq.cellfonestore.com". However I see only the first name created for the dns views.
    2. We have a static WAN IP address with a fixed DNS Server name given by our ISP. I am using the same DNS name on the client PCs connected to the 851. I am able to resolve any external names for e.g. "www.google.com". When I try to resolve a DNS address (Split-DNS) for e.g. server.hq.portablesunlimited.com, it fails to resolve the address. I tried to specify the address of 815 (10.0.0.1) as the DNS server for the clients, in this case the clients do not resolve any address. However if I go to the 851 console and ping say "www.yahoo.com" it works and then I can resolve that address "www.yahoo.com" from the client PCs also.
    I don't have any firewall or NAT enabled on the 851.
    Here is the 851 config file:
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname firewall
    boot-start-marker
    boot-end-marker
    logging buffered 51200 warnings
    enable secret 5 xxxxxxxxxxxx
    no aaa new-model
    clock timezone PCTime -5
    clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.220.1.1 10.220.1.99
    ip dhcp excluded-address 10.220.1.201 10.220.1.254
    ip dhcp pool sdm-pool1
    import all
    network 10.220.1.0 255.255.255.0
    dns-server 129.x.x.80
    default-router 10.220.1.1
    ip cef
    ip domain name mydomain.com
    ip name-server 129.x.x.80
    crypto pki trustpoint TP-self-signed-3072999871
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-3072999871
    revocation-check none
    rsakeypair TP-self-signed-3072999871
    crypto ipsec client ezvpn VPN1
    connect auto
    group xyz key xyz
    mode network-extension
    peer x.x.x.x
    username xyz password xyz
    xauth userid mode local
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    interface FastEthernet3
    interface FastEthernet4
    description $FW_OUTSIDE$$ES_WAN$
    ip address 129.34.x.x.255.255.240
    duplex auto
    speed auto
    crypto ipsec client ezvpn VPN1
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
    ip address 10.220.1.1 255.255.255.0
    ip tcp adjust-mss 1452
    crypto ipsec client ezvpn VPN1 inside
    ip route 0.0.0.0 0.0.x.x.34.7.82
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip dns view ezvpn-internal-view
    domain name-server 10.128.1.10
    ip dns view-list ezvpn-internal-viewlist
    view ezvpn-internal-view 10
    restrict name-group 1
    view default 20
    ip dns name-list 1 permit HQ.PORTABLESUNLIMITED.COM
    ip dns server view-group ezvpn-internal-viewlist
    no cdp run
    end

    Someone please reply to the post as this issue is critical for us to decide the purchase of the above equipment for our 40 remote locations.
    Thanks
    Srikant

  • Adobe X-Pro redaction and splitting doc problems

    Having problems with Adobe X Pro. For some reason the program seems to be applying permanent redactions to my documents when I split the bookmarks into separate files. Not sure why this is happening, wondering if anyone can advise.

    No, the redactions can be a two part process, they're being applied
    permanently vbefore  I apply them, it's bizzare .

  • I have an Ipad 2 and are having problems sending out emails in one of my email address. I always get a message reading the email was not sent because the server does not allow relaying. This is an email account POP3. I have no such problem with gmail.

    I have an Ipad 2 and are having problems sending out emails in one of my email address. This is a POP3 email Account? I always get a message reading that the email was not sent because the server does not allow relaying. I have no such problem with gmail. What could be the problem and how do I resolve this. Is it about settings?
    Richard.

    Welcome to the Apple community.
    If you are unable to remember your password, security questions, don’t have access to your rescue address or are unable to reset your password for whatever reason, your only option is to contact Apple ID Support, upon speaking to an operator you should explain that your problem is related to your Apple ID, this way you will not be charged for assistance, even if you don’t have an AppleCare plan.
    The operator will take you through some steps you may have already tried, however they need to be sure they have exhausted all usual approaches before trying to reset your account, so you should try to be helpful and show patience with the procedure.
    The operator will need to verify they are speaking to the account holder and may ask you some questions that only the account holder could know, and you will need to answer them if the process is to proceed.
    Once the operator has verified your identity they will send a message through to your device which contains an alpha numeric code, which you will need to read back to them.
    Once this has been completed they will send an email to your iCloud email address after a period of 24 hours, so you should check that mail is enabled in your devices iCloud settings.
    Upon receipt of the email, use the reset link provided to reset your password, after which you should be able to make the adjustments to iCloud that you wish to do.

  • BPM giving problem in Merging and Splitting

    Hi Gurus,
    Im trying to BPM scenarios,
    First i tried to Merging Two message and send to one receiver system. In that both Sender and Receiver communication channel are wokring fine.. all are showing green light.. and the files also got processed from sender side but i cant get result  the output side. i checked my abstract interfaces , interfacing mapping and Container variables in IP everthing is right.. Even  this is not 1:N or N:1 mapping , all message types are having occurance of 1:1 only. when i checked using SXMB_moni... there my two sender are succesfully sending the messages and ip getting the message.. after IP should act as a sender right. that msg not there... what would be the problem... even correlation also correct using the common filed's xpath i was combing the msg. In IP im getting the Yellow color warnin like correlating not used in sender step but no error. but i activated the correlation in sender  step and assigned the xpath of the common field.
    After that i tried to do splitting same problem occuring.. no message in receiver side.. i double checked my abstract interfaces, inbound , outbound interfaces, interface mapping and container variable everthing was assigned properly. In IP Only a blue color waring i getting like receiver determination initialized but not used but no error , but when i checked the interface determination it was fine.. i created receiver type local variabled with multiline . this is not 1;N or N;1 mapping... a simple mapping
    Please help me experts,
    Regards,
    Balaji

    Hiii experts ,
    Please help me.. i have tried many times.. still the same problem exits...
    source msg type having 5 elemtn.. first 2 element mapped first target msg type and remaining fields mapped to receiver 2 target msg type.
    IP step are configured as below
    Container Variables: send,recv1, recv2, 2 receiver type msg for receiver determination (Receiver1, Receiver2) both are multilined.
    Receiver step : sender msg type (sender abs interface type)
    Transformation : Has the interface mapping and one source msg and 2 target msg
    In fork
    Branch1:
    receiver determination1 :receiver msgtype (recv1) and  the multiline element (receiver1) type of receiver.
    sender1 step: receiver msg type (recv1) and Receiver from-> Receiver List : Receiver->Receiver1
    Branch2:
    receiver determination2 :receiver msgtype (recv2) and  the multiline element (receiver2) type of receiver.
    sender2: step.. receiver msg type (recv2) and Receiver from-> Receiver List : Receiver->Receiver2.
    But msg going to IP.. after that IP not start to send msg...
    Please tell me.. what im doing wrong here?
    Regards,
    Balaji

  • I updated to Firefox 5 and now have problems with it not responding ALOT and also even though I have certian sites listed to allow popups they dont work on several sites I use daily. What can I do about this?

    I dont know what else to say about it. I updated and now all this is happening and it didnt before my update to Firefox5. I have several site I use daily and I have gone in and marked them to allow popups and they just dont work. The sites are My Yearbook...Kia Financeing...and a few more. And also I am finding that I get a no response a lot!

    I am sorry you are not in a position to replace the iPad. It is stating the obvious, but nothing lasts forever - especially something like an original iPad. IMHO, there is nothing you can do to address the issues you have posted about.
    Barry

  • Setting advertisement / split horizon direction in EIGRP routing

    Hello all,
    I am trying to work out if I am being a bit rubbish or if split horizon is my new worst enemy.
    Below is a diagram of my (simplified) problem scenario using EIGRP.
    The solution I am looking for is that Router R3 learns of the 10.0.0.0/8 network from both R1 and R2, then does not advertise it to either. Simple with split horizon enabled.
    But when either R1 or R2 are rebooted, a decision somehow takes place, and may well determine that R3 should advertise 10/8 to the new (rebooted) neighbour, at which point split horizon prevents it from being advertised back again. This means the topology table on R3 doesn't contain this route for this neighbour and is slow to converge if the other neighbour is lost.
    Is there a way to control in which direction routes are advertised first on a neighbour link? and then I can let split horizon do its thing
    Or is there something I am not thinking of...
    many thanks,
    Paul

    This is what i think would work.
    Two assuptions i'm making -
    1)  R1 and R2 have full routes in terms of the remote branch subnets which from what we have talked about seems to be the case.
    2) R1 will advertise the specific subnets it is primary for (see below) to R3 which then advertises them to R2 and R2 will do the same for it's primary subnets.
    R1 is primary for 32 - 63 summary address 192.168.32.0 255.255.224.0
    R2 is primary for 64 - 95 summary address 192.168.64.0 255.255.224.0
    Each router is secondary for the other router's primary subnets.
    on R1 configure a summary address for R2's subnets on the interface connecting to R3 -
    ip summary-address eigrp <AS no> 192.168.64.0 255.255.224.0
    on R2 do the same for R1's subnets -
    ip summary-address eigrp <AS no> 192.168.32.0 255.255.224.0
    So now -
    R1 points to R3 and R3 points to R2 for 192.168.32.0/19
    R2 points to R3 and R3 points to R1 for 192.168.64.0/19
    Because you have used a summary address this suppresses the advertisement of the more specific routes within that summary range.
    R1 will therefore advertises it's specific subnets for which it is primary to R3 and a summary address only for R2's subnets.
    And R2 does the same ie. it advertises it's specific subnets and a summary for R1's.
    R3 then obviously passes these summaries via EIGRP to R1 and R2.
    R3's routing table will have specific branch routes pointing to the respective
    primary router but only a summary route for the same subnets pointing to the secondary router.
    Because a router will always pick the longest match it will use the more specific subnets unless there isn't a matching route.
    Which means no need to use metrics to load balance traffic.
    In addition the summary route is already in the routing table so no need for either R1 or R2 to send a query to R3 if one of their branch links fail.
    I may well have overlooked something so let me know whether you think this will work for you or not.
    Jon

  • Cisco WebEx Meetings Server-Internal IRP vs Split Horizon

    Hi,
    We are planning to install CWMS 1.1 but not able to decide among below two topology -
    a.Internal Internet Reverse Proxy with all virtual machines including IRP in same internal network(ie no IRP in DMZ).
    b.Split Horizon with IRP in DMZ network.
    I would prefer option a.(all VM in internal network) as fewer changes on the firewall(allow potrt 80 & 443 from external to internal) but not sure how risky it is as will be allowing all external internet traffic directly to IRP internal on port 80 & 443.Will we be compromising on security if we go with this option?
    Please suggest which option is recommended .I have gone through the pros & cons mentioned in CWMS planning guide 1.1.
    Thanks
    KMS

    Srdjan, KMS,
    Appologies  to jump in, but I am  also doing a 50 port installation. I am leaning towards  internal topology as well as it appears to be less complex and best preforming.
    Srjdan,
    +5  for the info. Can you please confirm if below applies to 50 port  systems as well? Do we need to have a minimum of two boxes to install  split-horizon-topology?
    "On another hand for that deployment you need 2 HW box's."
    I  was under the impression we can patch the physical CWMS server onto a  DMZ switch and can do split-horizon-topology with only one hadware box.  Can you please confirm if thats possible at all?
    I tried to raise a request with PDI and was rejected that PDI at the moment is not supporting this product.
    I have same queries - let me know I can open a separate thread if you want.
    1)  How much of a security risk it invloves doing Internal IRP?
    2) Is there any additional Cisco device we can recommend to the customer to add extra layer of security to the solution?
    3) We have only one hardware box - what would be the best design in that scenario? (50 port installation)
    Terry

  • RA VPN on ASA and Split Tunneling

    Hello Forum,
    I'm having an issue with RA VPN and split tunneling. Our company doesn't allow split tunneling.
    I have the following....
    ASA 5520 - ASA Version - 8.0(3)
    Group Policies defined for different groups. My test group, I thought I disabled split tunneling but they are still able to surf the net.
    For Split Tunneling Policy...
    Inherit is unchecked
    I have "Tunnel Network List Below"
    Testing_splitTunnelAcl is my acl. I have a bunch of host IPs in the list. I don't have any or 0.0.0.0 in the list.
    But they can still surf the net.
    I would like to block access to net. No hairpinning or internet u-turns.
    How do I do this?
    Any help greatly appreciated.
    Regards,

    What does your Testing_spliTunnelAcl have?
    To disable split tunneling, your Testing_spliTunnelAcl should only have this...
    access-list Testing_splitTunnelAcl standard permit any
    ...which means all traffic will be encrypted and will be sent to ASA no matter what. If you add any IP Address, only those traffic destined to the IP Address in the list will be encrypted and send to ASA, everything else will go to internet from the client.
    It may be confusing but try and see what happens.

  • Acrobat Pro 6 Average Daily Production and Math.round problem

    Acrobat Pro 6 Average Daily Production and Math.round problem
    (Production.0) (154) (whole units) . (Production.1) (90) (fractional) / (divided by) 31 (days) results in (Average.0) (4)(whole units) . (Average.1) (10) (fractional) using :Math.round.� Noticed that 154 (whole units) . 85 through 99 (fractional) also show 4.10. (without Math.round : 5.00)
    Method:
    �Production.0� (whole units) . �Production .1� (fractional) / Days = (Average Daily Production) (�Average.0� (whole units) . (Average.1) (fractional)
    � Production.0 (value not calculated)�, � Production 1 (calculated) (event.value = util.printx("0099", (event.value)).substr(-2,2); � �Average.0 (value not calculate)�, and �Average.1 has following calculation:
    var punits = this.getField("Production.0");
    var pfrac = this.getField("Production.1");
    var average = 0.0;
    average = (punits.value + pfrac.value / 100) / this.getField("Days").value;
    this.getField("Average.0").value = average - average % 1;
    this.getField("Average.1").value = util.printx("0099", Math.round((average % 1 * 100))).substr(-2,2);
    �Math.round� appears to be a problem. Also, could you explain the purpose of �0099� . Anyway, why would 154.85 through 154.90 divided by 31 give 4,10. Also, their must be a better way, to find the average daily production. All you have to do is divided the production (whole. fractional) by the days, and display the average daily production as (whole. fractional). Any suggestions??

    There are a many loose ends in your question.
    First, I have never seen before a variable type called 'var'. Is it a java primitive or a class?
    Next, I cannot seem to find any class that has the printx method.
    When it comes to substr(-2,2), I get confused. First, I thought that it was a method of the String class, but I only got as far as substring(beginIndex, endIndex).
    If you really must break the production and average into pieces, try this:
    float average = (punits + pfrac/100) / days;
    int avg_units = (int)average;
    int avg_frac = (int)( (average - avg_units) * 100 );My guess is that util.printx("0099", x) formats x having two optional digits and two mandatory digits, showing 0-99 as 00-99, but allows to show numbers with three and four digits.
    154.85/31 = 4,9951612903225806451612903225806
    154.99/31= 4,9996774193548387096774193548387
    If you round the fraction of theese numbers multiplied by 100 ( = 99.51.. and 99.968...) you get 100, and this will be the output of printx. My guess for "4.10" is that substr(-2,2) returns the two first characters of the string, because the start index should not be zero. (According to java docs, substring throws an exception on a negative index, so what kind of class are you really using ??????)

  • Setting Up DNS - Making Sure I'm Not Running Split Horizon

    Hello everyone - I'm wanting to make sure I am running my DNS correctly and that it isn't split horizon.
    I purchased a domain name (johnsonsfromtyler.com). I have public "@" and "mail" A host names pointing to my public IP address, have a MX for johnsonsfromtyler.com pointing to mail.johnsonsfromtyler.com, and have a reverse lookup setup all via public DNS.
    On my SLS running the private DNS I have the primary zone name set as johnsonsfromtyler.com. For the nameserver I have the zone johnsonsfromtyler.com. pointing to server.johnsonsfromtyler.com which has a static IP of 10.0.1.10. I also have a mail exchanger hostname of mail.johnsonsfromtyler.com with a priority of 10. I also have an alias for mail.johnsonsfromtyler.com pointed to server.johnsonsfromtyler.com. I also have forwarder IP addresses pointing to the OpenDNS servers.
    I have my router setup to use the private DNS server located at 10.0.1.10 and the search domain as johnsonsfromtyler.com. server.johnsonsfromtyler.com is running DNS and all other server services.
    So am I running DNS correctly and is this setup a split horizon setup? Also, do I need to have forwarder IP addresses pointing to external DNS servers?

    As Mr Hoffman writes if your "reuse" a public IP domain name in an internal private IP only LAN DNS your are using a "split horizon" DNS (where did that "designation" come from?).
    To reach pubic IP servers using the same domain name from your LAN using only the internal DNS, you need to put also the pubic IP servers in your internal DNS with their public IPs. The reverse zone for any "remote" public IPs that Server Admin creates should be removed to let the DNS responsible for that zone answer those lookups - probably not too important for most configurations though.
    BIND views can be used to give answers to lookups depending on where (what IP) the query comes from. The same DNS could be setup with different views where public and private IPs are in separate views so that private name -> IP lookups only gets answered when the query comes from the private IP LAN. If you can have a different response (IP) for the same name -> IP lookup? - probably(?) - if the private IP view is listed before the public one in the DNS config.
    And I think a DNS is always caching lookups (?) not depending on if forwarders is used or not. Forwarders can speed up lookups but can also make trouble if they stop working/starting refusing answering recursive lookup queries. Without forwarders the DNS has to go "the long way" via root DNS servers (you should update /var/named/named.ca regularly especially if not using forwarders).

  • Hi, when I upload music into itunes from a cd it sometimes appears in itunes as two different albums and split up the music in 2 or even three albums....how can i merge these albums...this is particularly true when one album may have different composers?

    Hi, when I upload music into itunes from a cd it sometimes appears in itunes as two different albums and split up the music in 2 or even three albums....how can i merge these albums...this is particularly true when one album may have different composers?

    Generally setting a common Album title and Album Artist will fix things.
    For compilations that aren't, select all tracks, Get Info, and on the option tab set Part of a Compilation to No. If it already says No tick the box alongside, then click OK.
    For deeper problems see Grouping tracks into albums.
    tt2

  • How do I print a interactive form out? It allows printing and filling.

    Hi, I'm trying to print out an interactive form that I filled out and then saved on my hard drive. The author allows printing and filling out of the PDF when it was created. I'm running Windows 7 64-bit and have Adobe Reader XI (11.0.06) installed along with the current drivers for my compatible printer. Within the same PDF the first sheet "instruction sheed" is an all text flat form, which prints just fine. The problem lies when I try to print other sections of the PDF, When I try to print it all I get is the header and a footer that the author created, but all the spaces where questions/ text and my fill in answers don't show up on the print preview image or when the printed sheet comes out of my printer.
         I have tried to print as an image without success. I don't think its an author issuse because it was released out of a California Department for several houndred/thousands of others. Please if you have any ideas or questions i look forward to any advice.

    Sorry I forgot to add that the PDF is devided by a "Chapter" style cover face that devided multiple sets of forms in to categories. At the bottome of these categories is a "Print whole document" which can only be clicked once the whole thing has been filled out. Do to some information over lap some dates don't follow the (time line order) it requirest to fill in the data so two of the categories show up as incomplete. Take a look at the document yourself, maybe I NEED to rewrite the information and see if that works.
    *Edit* Looks like I CAN print a blank form at the begining when it asked me if i want a blank form, will try to rearange dates so it will show as all COMPLET.
    PDF file can be found at the California government website:
    http://www.chp.ca.gov/recruiting/pdf/Chp446.pdf
    http://www.chp.ca.gov/recruiting/pdf/Chp446.pdf

  • How come my external hard drive is no longer visible in finder even after ticking it in preferences? it shows in the disk utilities but does not allow me to find a problem or fix the problem? Please help.

    it shows in the disk utilities but does not allow me to find a problem or fix the problem? Please help. also my external hard drive is a seagate free agent go, 500GB. it is visible on my tv but has no files in it… i'm scared i've lost everything?

    Honestly i cannot remember sorry, i got it like 5 maybe 6 yrs ago and just started downloading things to it as the memory on the computer started filling up and when i wanted to see photos/videos on my TV.
    My wife did tell me after i had written this post that she did try and record TV to it as it was plugged in. I think by doing so somehow has deleted everything.   It reads on my TV yet has no files in it but won't show up on my computer. hope this helps.
    Starting to think it is going to cost more to retrieve files on it than it will be to buy a newer and larger one.

  • Would love Steve Jobs to contact me for in setting screen tinting orange for seizures as OK WE HAVE DONE IT AN ORANGE PROTECTIVE SCREEN OVERLAY FOR IPOD AND IPAD STOPPING JOHN'S photosensitivity SEIZURES AND STOPPING EYE PROBLEMS WITH USAGE

    OK WE HAVE DONE IT AN ORANGE PROTECTIVE SCREEN OVERLAY FOR IPOD AND IPAD STOPPING JOHN'S SEIZURES AND STOPPING EYE PROBLEMS WITH USAGE ABLE TO CUT ANY SIZE FOR PHONES EG
    Contact me Steve the idea is great and the pictures are reveal a better depth perception of colour call me a Mum that created a diffence for her son and kept him communicating on his ipod and his ipad proffessors were amazed at childrens hospital and would love to show you my ideas in making it built in to your ipod and ipads or any computer for that matter everyone i show is blown away not only that but a wider customer level will be reached from a Mum that made a difference for her son that was unable to communicate and then had seizures so developed my own cover that allows him to chat all day without having any eye problems.
    So we now sell the covers on ebay to help others access technology that they need in order to survive and live happily as without his ipod or ipad and him telling us what was wrong he would of died he had respritory lung disease photosensitive epilepsy a metabolic condition that could of killed him anytime from stroke or seizure battled with using all types of technology but now is a dream come true.
    Would love for this to be enabled in the setup of all computers alike to protect eyes and allow more users to speak and communicate a big thankyou to the creators and designers fabulous but please can you call me as this could make you even better i mean will and also give me more time.
    From one praying God fearing Mum
    Nadine
    Call me i do have better pics they were too big to upload orange covering on right hand side

    Going through the feedback and support pages will be a waste of your time. Apple won't respond to feedback, and support can't do anything regarding product suggestions, particularly not from a company with an existing product they wish to sell. The only attention you might get from Apple would be possible interest in selling your product through the Apple Stores, and I don't know how Apple chooses the third-party products they sell. All I could suggest would be writing to Apple's corporate headquarters:
    Apple
    1 Infinite Loop
    Cupertino, CA 95014
    with perhaps "Attention: Retail Sales Division" and telling them about your product and your interest in it being sold through the Apple Stores.
    Regards.

Maybe you are looking for