BGP not advertising routes

I have two routers with BGP configured: 
C2921:
router bgp 65014
 bgp router-id 192.168.54.190
 bgp log-neighbor-change
 neighbor 192.168.54.150 remote-as 65011
 neighbor 192.168.54.150 description Loud backup
 neighbor 192.168.54.150 route-map Backup out
C1841:
router bgp 65011
 no synchronization
 bgp router-id 10.10.35.1
 bgp log-neighbor-changes
 neighbor 192.168.54.149 remote-as 65014
 neighbor 192.168.54.149 description Cubus backup
 neighbor 192.168.54.149 prefix-list Loudenia out
 neighbor 192.168.54.149 route-map Backup out
ip prefix-list Loudenia seq 5 permit 10.10.35.0/24 le 32
ip prefix-list Loudenia seq 10 permit 192.168.111.0/24 le 32
ip prefix-list Loudenia seq 15 permit 10.25.15.0/24 le 32
ip prefix-list Loudenia seq 20 permit 192.168.44.0/24 le 32
ip prefix-list Loudenia seq 25 permit 192.168.45.0/24 le 32
ip prefix-list Loudenia seq 30 permit 192.168.46.0/28 le 32
ip prefix-list Loudenia seq 35 permit 192.168.49.196/30 le 32
ip prefix-list Loudenia seq 40 permit 192.168.49.225/32
ip prefix-list Loudenia seq 45 permit 192.168.49.229/32
route-map Backup permit 10
 set as-path prepend 65011 65011
I have added:
ip prefix-list Loudenia seq 50 permit 192.168.48.225/32 
made:
clear ip bgp 192.168.54.149 soft
but nothing changed route to 192.168.48.225 not advertised:
C1841-Loudenia#show ip bgp neighbors 192.168.54.149 advertised-routes
BGP table version is 137998, local router ID is 10.10.35.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.35.0/24    0.0.0.0                  0         32768 i
*> 10.25.15.0/24    192.168.111.10           0         32768 i
*> 192.168.44.0     192.168.49.26                          0 65005 i
*> 192.168.45.0     192.168.49.26                          0 65005 i
*> 192.168.46.0/28  192.168.49.26                          0 65005 i
*> 192.168.49.196/30
                    192.168.49.26                          0 65005 i
*> 192.168.49.225/32
                    192.168.49.26            0             0 65005 i
*> 192.168.49.229/32
                    192.168.49.26                          0 65005 i
*> 192.168.111.0    0.0.0.0                  0         32768 i
C1841 knows 192.168.48.225/32 via bgp 
*  192.168.48.225/32
                    192.168.49.58                          0 65005 65005 65005 65006 65013 i
*>                  192.168.49.26                          0 65005 65006 65013 i
I will be grateful for your advice

Hello, thanks for reply.
The route is on the route table
C1841-Loudenia#show ip route | i 192.168.48.225
B       192.168.48.225/32 [20/0] via 192.168.49.26, 3w6d
C1841-Loudenia#show ip bgp | i 192.168.48.225
*  192.168.48.225/32
                    192.168.49.58                          0 65005 65005 65005 65006 65013 i
*>                  192.168.49.26                          0 65005 65006 65013 i

Similar Messages

  • Sh bgp: received & advertised routes

    Dear all:
    In reference at the commands:
    - sh bgp neighbor A.B.C.D
    - sh bgp neighbor A.B.C.D received routes
    - sh bgp neighbor A.B.C.D advertised-routes
    For example:
    ROUTER#sh bgp neighbor A.B.C.D
      Policy for incoming advertisements is PEERING-IN
      Policy for outgoing advertisements is PEERING-OUT
      1 accepted prefixes, 0 are bestpaths
      Cumulative no. of prefixes denied: 8974070. 
        No policy: 0, Failed RT match: 0
        By ORF policy: 0, By policy: 8974070
      Prefix advertised 77, suppressed 0, withdrawn 2
    In output this command we have # Prefixes: 
    1 accepted & 0 are bestpaths (after policy) 
    advertised 77, suppressed 0, withdrawn 2 (after policy)
    8974070 prefix are deny
    But, when you execute the next command:
    ROUTER#sh bgp neighbor A.B.C.D received routes 
    Processed 503233 prefixes, 503233 paths
    In output this command we have# Prefixes = 503233 
    And when you execute the next command:
    ROUTER#sh bgp neighbor A.B.C.D advertised-routes
    Processed 73 prefixes, 73 paths
    In output this command we have:
    73 prefixes advertised at peer
    The question is:
    What's the different between  counter 8974070  and 503233 (prefix received before apply policy)?
    What's the different between  counter 77 (or 75 = 77 - 2 withdrawn) and  73 (prefix advertised before apply policy)?
    Exist only one command that help at see total prefix received/advertised (different a sh bgp neighbor A.B.C.D received routes) ?
    Thanks.

    Not really because OSPF does not advertise routes it sends LSAs to it's peers.
    So you need to look at the OSPF database ie. -
    "sh ip ospf database"
    which will show you all the LSAs the router is aware of.
    In terms of all the LSAs the router has received it will show all of those but it will also show you LSAs that were generated by the router itself although the advertising router IP will point to that being the case.
    In terms of all the LSAs the router advertises again it depends on the area and how that has been configured.
    So for example an ABR might well have external LSAs (which aren't tied to any area in the OSPF database) but that doesn't necessarily mean it is advertising them to peers within an area as it could have been configured not to.
    So it gives you a good idea but you need to also work out a few things for yourself as well.
    Jon

  • BGP not advertised

    I have two routers with BGP configured: 
    C2921:
    router bgp 65014
     bgp router-id 192.168.54.190
     bgp log-neighbor-change
     neighbor 192.168.54.150 remote-as 65011
     neighbor 192.168.54.150 description Loud backup
     neighbor 192.168.54.150 route-map Backup out
    C1841:
    router bgp 65011
     no synchronization
     bgp router-id 10.10.35.1
     bgp log-neighbor-changes
     neighbor 192.168.54.149 remote-as 65014
     neighbor 192.168.54.149 description Cubus backup
     neighbor 192.168.54.149 prefix-list Loudenia out
     neighbor 192.168.54.149 route-map Backup out
    ip prefix-list Loudenia seq 5 permit 10.10.35.0/24 le 32
    ip prefix-list Loudenia seq 10 permit 192.168.111.0/24 le 32
    ip prefix-list Loudenia seq 15 permit 10.25.15.0/24 le 32
    ip prefix-list Loudenia seq 20 permit 192.168.44.0/24 le 32
    ip prefix-list Loudenia seq 25 permit 192.168.45.0/24 le 32
    ip prefix-list Loudenia seq 30 permit 192.168.46.0/28 le 32
    ip prefix-list Loudenia seq 35 permit 192.168.49.196/30 le 32
    ip prefix-list Loudenia seq 40 permit 192.168.49.225/32
    ip prefix-list Loudenia seq 45 permit 192.168.49.229/32
    route-map Backup permit 10
     set as-path prepend 65011 65011
    I have added:
    ip prefix-list Loudenia seq 50 permit 192.168.48.225/32 
    made:
    clear ip bgp 192.168.54.149 soft
    but nothing changed route to 192.168.48.225 not advertised:
    C1841-Loudenia#show ip bgp neighbors 192.168.54.149 advertised-routes
    BGP table version is 137998, local router ID is 10.10.35.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
       Network          Next Hop            Metric LocPrf Weight Path
    *> 10.10.35.0/24    0.0.0.0                  0         32768 i
    *> 10.25.15.0/24    192.168.111.10           0         32768 i
    *> 192.168.44.0     192.168.49.26                          0 65005 i
    *> 192.168.45.0     192.168.49.26                          0 65005 i
    *> 192.168.46.0/28  192.168.49.26                          0 65005 i
    *> 192.168.49.196/30
                        192.168.49.26                          0 65005 i
    *> 192.168.49.225/32
                        192.168.49.26            0             0 65005 i
    *> 192.168.49.229/32
                        192.168.49.26                          0 65005 i
    *> 192.168.111.0    0.0.0.0                  0         32768 i
    C1841 knows 192.168.48.225/32 via bgp 
    *  192.168.48.225/32
                        192.168.49.58                          0 65005 65005 65005 65006 65013 i
    *>                  192.168.49.26                          0 65005 65006 65013 i
    I will be grateful for your advice

    That is you mean?
    C1841 knows 192.168.48.225/32 via bgp 
    *  192.168.48.225/32
                        192.168.49.58                          0 65005 65005 65005 65006 65013 i
    *>                  192.168.49.26                          0 65005 65006 65013 i

  • Can you display routes advertised and/or received in OSPF, similar to BGP command sh ip bgp neighbors x.x.x.x advertised-routes?

    TOC-BP-SWa#sh ip bgp neighbors 10.14.0.3 advertised-routes
    BGP table version is 1674320, local router ID is 10.14.0.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
       Network          Next Hop            Metric LocPrf Weight Path
    *> 10.14.0.1/32     0.0.0.0                  0         32768 i
    *> 147.249.37.0/24  172.20.18.1                   120      0 2001 65015 65016 64823 7381 64681 i
    *> 147.249.38.0/24  172.20.18.1                   120      0 2001 65015 65016 64823 7381 64681 i
    *> 147.249.46.0/24  172.20.18.1                   120      0 2001 65015 65016 64823 7381 12159 12159 i
    *> 147.249.196.0/24 172.20.18.1                   120      0 2001 65015 65016 64823 64870 65124 i
    *> 147.249.237.0/24 172.20.18.1                   120      0 2001 65015 65016 64823 7381 64681 i
    TOC-BP-SWa#sh ip bgp neighbors 10.14.0.3 received-r       
    Total number of prefixes 0 
    TOC-BP-SWa#sh ip bgp neighbors 10.14.0.2 received-r
    BGP table version is 1674320, local router ID is 10.14.0.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
       Network          Next Hop            Metric LocPrf Weight Path
    *>i10.14.0.2/32     10.14.0.2                0    100      0 i
    * i147.249.37.0/24  10.14.0.2                0    120      0 2001 65015 65016 64823 7381 64681 i
    * i147.249.38.0/24  10.14.0.2                0    120      0 2001 65015 65016 64823 7381 64681 i
    * i147.249.46.0/24  10.14.0.2                0    120      0 2001 65015 65016 64823 7381 12159 12159 i
    * i147.249.196.0/24 10.14.0.2                0    120      0 2001 65015 65016 64823 64870 65124 i
    * i147.249.237.0/24 10.14.0.2                0    120      0 2001 65015 65016 64823 7381 64681 i
    Can this output be duplicated with an OSPF command? 

    Not really because OSPF does not advertise routes it sends LSAs to it's peers.
    So you need to look at the OSPF database ie. -
    "sh ip ospf database"
    which will show you all the LSAs the router is aware of.
    In terms of all the LSAs the router has received it will show all of those but it will also show you LSAs that were generated by the router itself although the advertising router IP will point to that being the case.
    In terms of all the LSAs the router advertises again it depends on the area and how that has been configured.
    So for example an ABR might well have external LSAs (which aren't tied to any area in the OSPF database) but that doesn't necessarily mean it is advertising them to peers within an area as it could have been configured not to.
    So it gives you a good idea but you need to also work out a few things for yourself as well.
    Jon

  • BGP: Customer network announcing error (not advertised)

    Hi to all.
    Our company - is small business ISP. We have two BGP upstreams, and some customers who connect with us via BGP. Day ago, our customer opened a case that we don't announce his network to the "global network". I can see, that he announce me his network, and BGP add this prefix to the routing table. But when i open prefix detail - i see that prefix not advertised to any peer.
    Here is sh run :
    router bgp xxx
    bgp router-id xx.xx.xx.xx
    bgp log-neighbor-changes
    neighbor xx.xx.xx.xx remote-as xxxx
    neighbor xx.xx.xx.xx description Customer
    neighbor yy.yy.yy.yy remote-as yyyy
    neighbor yy.yy.yy.yy description Uplink
    address-family ipv4
      neighbor xx.xx.xx.xx activate
      neighbor xx.xx.xx.xx default-originate
      neighbor xx.xx.xx.xx soft-reconfiguration inbound
      neighbor xx.xx.xx.xx prefix-list DEFAULT out
      neighbor xx.xx.xx.xx prefix-list Deny-Default in
    neighbor yy.yy.yy.yy activate
      neighbor yy.yy.yy.yy prefix-list BizTel out
      neighbor yy.yy.yy.yy filter-list 1 out
    exit-address-family
    ip as-path access-list 1 permit ^$
    ip as-path access-list 1 permit ^xxxx$
    ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0
    ip prefix-list Deny-Default seq 10 deny 0.0.0.0/32
    ip prefix-list Deny-Default seq 15 permit 0.0.0.0/0 le 32
    sh ip bgp neighbors xx.xx.xx.xx received-routes:
       Network          Next Hop            Metric LocPrf Weight Path
    *> 0.0.0.0          xx.xx.xx.xx                         0 xxxx xxxx yyyy i
    *> zz.zz.zz.zz/24    xx.xx.xx.xx           0             0 xxxx xxxx i
    sh ip bgp neigh xx.xx.xx.xx adv routes:
       Network          Next Hop            Metric LocPrf Weight Path
    *> 0.0.0.0          xx.xx.xx.xx                         0 xxxx xxxx yyyy i
    sh ip bgp  zz.zz.zz.zz /24:
    BGP routing table entry for zz.zz.zz.zz/24, version 6503140
    Paths: (3 available, best #1, table default)
      Not advertised to any peer
      xxxx xxxx, (received & used)
        xx.xx.xx.xx from xx.xx.xx.xx (cc.cc.cc.cc)
          Origin IGP, metric 0, localpref 100, valid, external, best
    Can somebody help me with this question?

    The outputs are very confusing ie.
    sh ip bgp neighbors xx.xx.xx.xx received-routes:
       Network          Next Hop            Metric LocPrf Weight Path
    *> 0.0.0.0          xx.xx.xx.xx                         0 xxxx xxxx yyyy i
    *> zz.zz.zz.zz/24    xx.xx.xx.xx           0             0 xxxx xxxx i
    presumably these are the routes received from the customer ?  If so -
    1) why are you receiving a default from the customer with yyyy in the AS PATH ?
    2) why are there two instances of xxxx in AS PATH for both routes in the AS PATH ?
    also -
    sh ip bgp neigh xx.xx.xx.xx adv routes:
       Network          Next Hop            Metric LocPrf Weight Path
    *> 0.0.0.0          xx.xx.xx.xx                         0 xxxx xxxx yyyy i
    if you are looking at routes advertised upstream why are you looking at advertised routes to the customer ?
    It is difficult to say what is happening because you have blanked out all the information.
    Finally you have -
    neighbor yy.yy.yy.yy prefix-list BizTel out
    but there is no such prefix list in the config you posted
    Can you clarify by answering the above and perhaps explain how this is all setup ie. is x.x.x.x the customer and y.y.y.y your upstream provider.
    The more information you can give the more we can help.
    Jon

  • BGP Advertised Routes two Peering

    Dear all
    I have issue with BGP behaviour. I have two BGP peering; from both I receive default route, but one of them,
    AS 65472 is primary so I setup local preference in 200; it is because I want to use AS 65472 as internet
    provider. The another one, AS 65472 is used as secundary internet access, but for internal network (private) is
    used as primary. The issue is when try ping from LAN, can not reach internal network, seems to be that
    becuase Local preference is setup within AS65472 and the packet try to go thru AS 65472 because local prefeence 200,
    but I need that internal network go thru AS 65471.
    I am sure that I am advertising network as I expect, but when is running BGP for both peering, it fails.
    Here are go output for this situation:
    7204VXR-SCT#sh ip bgp neighbors 172.16.40.37 received-routes
       Network          Next Hop            Metric LocPrf Weight Path
    * i0.0.0.0          172.16.40.37             0    100      0 i
    Total number of prefixes 1
    7204VXR-SCT#sh ip bgp neighbors 172.16.40.37 advertised-routes
       Network          Next Hop            Metric LocPrf Weight Path
    *> 10.10.200.0/30   0.0.0.0                  0         32768 i
    *> 10.30.24.0/21    172.16.40.4              0         32768 i
    *> 172.16.17.0/24   172.16.40.5              0         32768 i
    *> 172.16.211.0/24  0.0.0.0                  0         32768 i
    *> 172.18.56.16/29  0.0.0.0                  0         32768 i
    *> 172.30.100.18/32 0.0.0.0                  0         32768 i
    *> 172.31.0.20/30   0.0.0.0                  0         32768 i
    7204VXR-SCT#sh ip bgp neighbors 190.97.254.241 received-routes
       Network          Next Hop            Metric LocPrf Weight Path
    *  0.0.0.0          190.97.254.241                         0 65472 i
    Total number of prefixes 1
       Network          Next Hop            Metric LocPrf Weight Path
    *> 190.153.116.0/22 172.16.40.4              0         32768 i
    *> 190.153.120.0/22 172.16.40.4              0         32768 i
    *> 190.153.124.0/24 172.16.40.37            10         32768 i
    router bgp 65471
     bgp log-neighbor-changes
     neighbor externalBGP peer-group
     neighbor externalBGP remote-as 65472
     neighbor externalBGP version 4
     neighbor internalBGP-SCT peer-group
     neighbor internalBGP-SCT remote-as 65471
     neighbor internalBGP-SCT version 4
     neighbor 172.16.40.37 peer-group internalBGP-SCT
     neighbor 190.97.254.241 peer-group viginet
     address-family ipv4
     neighbor externalBGPsoft-reconfiguration inbound
     neighbor externalBGProute-map viginet-in in
     neighbor externalBGProute-map viginet-out out
     neighbor internalBGP-SCT soft-reconfiguration inbound
     neighbor internalBGP-SCT route-map internalBGP-SCT-out out
     neighbor 172.16.40.37 activate
     neighbor 190.97.254.241 activate
     no auto-summary
     no synchronization
     network 10.10.200.0 mask 255.255.255.252
     network 10.30.24.0 mask 255.255.248.0
     network 172.16.17.0 mask 255.255.255.0
     network 172.16.40.0 mask 255.255.255.0
     network 172.16.211.0 mask 255.255.255.0
     network 172.18.56.16 mask 255.255.255.248
     network 172.30.100.18 mask 255.255.255.255
     network 172.31.0.20 mask 255.255.255.252
     network 190.153.116.0 mask 255.255.252.0
     network 190.153.120.0 mask 255.255.252.0
     network 190.153.124.0 mask 255.255.255.0
     exit-address-family
    ip route 172.16.40.36 255.255.255.252 Null0 250
    ip route 190.153.116.0 255.255.252.0 172.16.40.4
    ip route 190.153.120.0 255.255.252.0 172.16.40.4
    ip prefix-list invalidas seq 10 permit 172.16.40.0/24
    ip prefix-list invalidas seq 15 permit 10.30.24.0/21
    ip prefix-list invalidas seq 20 permit 172.16.211.0/24
    ip prefix-list invalidas seq 25 permit 172.18.56.16/29
    ip prefix-list invalidas seq 30 permit 172.30.100.18/32
    ip prefix-list invalidas seq 35 permit 10.10.200.0/30
    ip prefix-list invalidas seq 40 permit 172.16.17.0/24
    ip prefix-list invalidas seq 45 permit 172.31.0.20/30
    ip access-list standard viginet-100
     permit 190.153.116.0 0.0.3.255
     permit 190.153.120.0 0.0.3.255
     permit 190.153.124.0 0.0.0.255
    route-map externalBGP-out permit 10
     match ip address viginet-100
    route-map externalBGP-in permit 10
     set local-preference 200
    route-map internalBGP-SCT-out permit 10
     match ip address prefix-list invalidas

    Hello.
    If you want your internal network to go through peer 65471 (to 0.0.0.0/0), then why do you need AS 65472?
    Could you please provide "show ip bgp 0.0.0.0/0"?

  • Receiving but not sending routes to BGP established nei.

    In my home lab, I am running BGP over OSPF and EIGRP. The peering is establsihed between the routers, but one of them is not forearding the routes it receives fromits neighbour.
    Where to look for the problem.

    Hi,
    I presume you are talking about the fact that R6 is not sending any routes to R2. There is a good reason for this. If you look at the 'sh ip bgp' output for R6, you will see that all routes marked with a '>' sign were learned from R2. Therefore, these are selected as the best routes. There is not a single route that was not learned from R2. BGP will not advertise out routes that it learned from a neighbor back to that neighbor. Also, BGP will only adveritse the routes it itself uses (in this case, the ones marked with >). Since all of these routes were learned from R2, R6 has nothing to advertise to R2.
    This is correct behaviour. If you really want to see something being advertised, do somethink like creating a loopback interface on R6 and then do 'redistribute connected' under your BGP process on R6.
    Hope that helps - pls rate the post if it does.
    Paresh

  • BGP advertised routes

    Hi All,
    Is it possible to find since how long a route being advertised to BGP neighbor?
    To elaborate, if EBGP neighbors are up since 24 hours and among 10 routes advertised, at receiving router, 5 routes show the uptime as 12 hours, whereas other 5 routes show the uptime as 24 hours.
    All 10 routes were present in advertising router's routing table for more than 24 hours.
    Regards,
    Nagabhushan

    Hi,
    when you issue on the advertising router
    sh ip route x.x.x.x
    for one particular prefix among those showing  the uptime as 12 hours on the other router, do you see any " Last update from ... xxx ago"?
    That should show you the last time the routing was changed on the advertising router (and BGP should have advertised the change that time).
    Best regards,
    Milan

  • Difference between sh ip bgp & sh ip route? BGP tables and main routing table.

    Difference between sh ip bgp & sh ip route?
    sh ip bgp :::: loc-rib ?
    sh ip bgp nei x.x.x.x advertised-routes : adj-rib-in.
    sh ip bgp nei x.x.x.x recieved-routes : adj-rib-out.
    sh ip bgp nei x.x.x.x routes : loc-rib ?
    sh ip route = rib ? if yes does it mean its loc-rib ?
    so in a given router with bgp running, will there be 5 tables (sh ip bgp; adj-rib-in; loc-rib;adj-rib-out; sh ip route) ? if yes where are they saved ?

    sh ip bgp
    shows the BGP table (where are stored info coming from BGP update) 
    sh ip bgp nei x.x.x.x advertised-routes 
    shows networks that your router will advertise to a specific neighbor
    sh ip bgp nei x.x.x.x recieved-routes 
    shows advertisement received from a specific neighbor;  networks (NLRI) filtered with route-map distribute-list,... are included  (Inbound soft reconfiguration must be enabled)
    sh ip bgp nei x.x.x.x routes 
    shows only routes sent by a specific neighbor and not filtered or discarded (i.s accepted)
    sh ip route 
    show routing table; it contains the best route for each network (best is first of all the lowest administrative distance, then the lowest metric)
    Bye,
    enrico.
    PS please rate if useful

  • Show ip bgp not showing all BGP Paths

    Hi,
    We've setup BGP as shown in the diagram.
    Now Router Router A and B are peers of each other. Router A peers with ISP A and Router B peers with Router B.
    The issue we have is that Router B knows how to get to router C via eBGP connection to ISP B router or via ISP A, which is advertised via iBGP from Router A.
    But ....
    Router A only shows in "show ip bgp" about network Router C via ISP A.
    If I do a soft clear of bgp information on Router A I then see both paths to Router C via ISP A or ISPB, but once BGP is converged im only seeing best path via ISP A. Can anyone explain why the path via ISP B is not shown on Router A? we are using local preference in a route map to say prefer router A over Router B to exit the network to get to router C.
    Synchronisation is disabled. Router A and B are running the same code of IOS and also have similiar configs.
    My assumption is that becuase of the local preference Router A stops listing path via Router B in the BGP table. This thought doesnt make complete sense to me ???? In my test lab I always see all paths to exit the AS.
    router#show ip bgp 192.168.100.0     
    BGP routing table entry for 192.168.100.0/22, version 40
    Paths: (2 available, best #2, table default)
      Not advertised to any peer
      65530 64514, (aggregated by 64514 10.x.x.246)
        10.x.x.30 from 10.x.x.30 (202.x.x.x)
          Origin IGP, localpref 80, valid, external, atomic-aggregate
      65530 64514, (aggregated by 64514 10.202.103.246)
        10.x.x.22 from 10.x.x.78 (10.x.x.78)
          Origin IGP, metric 0, localpref 120, valid, internal, atomic-aggregate, best
    Thanks
    B

    I've just lab'd this and it is the local preference.
    If I remove my route map I see all paths as expected. Once I apply my route-map which matches ips and assigns the local preference then I see the shown behaviour.
    Note to self - lab first before posting on cisco support forum

  • BGP not communicating with 4th Hop

    Hi All,
    PFA...I'm beginner to BGP & designed network like in attachment.
    I'm unable to ping R5 from R1.
    R1:
    interface Serial1/0
     ip address 20.0.0.1 255.255.255.0
     serial restart-delay 0
    router bgp 200
     no synchronization
     bgp log-neighbor-changes
     network 20.0.0.0 mask 255.255.255.0
     network 20.0.2.0 mask 255.255.255.0
     network 20.0.2.0
     network 20.0.0.0 mask 20.0.0.0
     neighbor 20.0.0.2 remote-as 400
     neighbor 20.0.0.2 ebgp-multihop 255
     neighbor 20.0.2.2 remote-as 400
     neighbor 20.0.2.2 ebgp-multihop 255
    =====================================
    R2:
    interface Serial1/0
     ip address 30.0.0.1 255.255.255.0
     serial restart-delay 0
    router bgp 300
     bgp log-neighbor-changes
     neighbor 30.0.0.2 remote-as 400
     neighbor 30.0.0.2 ebgp-multihop 255
    =====================================
    R3:
    interface FastEthernet0/0
     ip address 40.0.0.1 255.255.255.0
     duplex auto
     speed auto
    interface Serial1/0
     ip address 20.0.0.2 255.255.255.0
     serial restart-delay 0
    interface Serial1/1
     ip address 30.0.0.2 255.255.255.0
     serial restart-delay 0
    interface Serial1/2
     ip address 20.0.1.1 255.255.255.0
     serial restart-delay 0
    interface Serial1/3
     ip address 30.0.1.1 255.255.255.0
     serial restart-delay 0
    router bgp 400
     no synchronization
     bgp log-neighbor-changes
     network 20.0.0.0 mask 255.255.255.0
     network 20.0.1.0 mask 255.255.255.0
     network 30.0.0.0 mask 255.255.255.0
     network 30.0.1.0 mask 255.255.255.0
     network 30.0.2.0 mask 255.255.255.0
     network 40.0.0.0 mask 255.255.255.0
     neighbor 20.0.0.1 remote-as 200
     neighbor 20.0.0.1 ebgp-multihop 255
     neighbor 20.0.1.2 remote-as 400
     neighbor 20.0.1.2 ebgp-multihop 255
     neighbor 30.0.0.1 remote-as 300
     neighbor 30.0.0.1 ebgp-multihop 255
     neighbor 30.0.1.2 remote-as 400
     neighbor 40.0.0.2 remote-as 400
    ======================================
    R4:
    interface Serial1/0
     ip address 20.0.1.2 255.255.255.0
     serial restart-delay 0
    interface Serial1/1
     ip address 20.0.2.1 255.255.255.0
     serial restart-delay 0
    interface Serial1/2
     ip address 20.0.3.1 255.255.255.0
     serial restart-delay 0
    interface Serial1/3
     no ip address
     shutdown
     serial restart-delay 0
    router bgp 400
     no synchronization
     bgp log-neighbor-changes
     network 20.0.0.0 mask 255.255.255.0
     network 20.0.1.0 mask 255.255.255.0
     network 20.0.2.0 mask 255.255.255.0
     network 20.0.3.0 mask 255.255.255.0
     neighbor 20.0.0.1 remote-as 200
     neighbor 20.0.0.1 ebgp-multihop 2
     neighbor 20.0.1.1 remote-as 400
     neighbor 20.0.1.1 ebgp-multihop 255
     neighbor 20.0.1.1 next-hop-self
     neighbor 20.0.2.2 remote-as 400
     neighbor 20.0.2.2 ebgp-multihop 255
     neighbor 20.0.3.2 remote-as 400
     neighbor 20.0.3.2 ebgp-multihop 255
    ======================================
    R5:
    interface Serial1/0
     ip address 20.0.2.2 255.255.255.0
     serial restart-delay 0
    interface Serial1/1
     ip address 30.0.2.2 255.255.255.0
     serial restart-delay 0
    router bgp 400
     no synchronization
     bgp log-neighbor-changes
     network 20.0.0.0 mask 255.255.255.0
     network 20.0.2.0 mask 255.255.255.0
     network 30.0.0.0 mask 255.255.255.0
     network 30.0.2.0 mask 255.255.255.0
     network 40.0.0.0 mask 255.255.255.0
     neighbor 20.0.0.1 remote-as 200
     neighbor 20.0.0.1 ebgp-multihop 255
     neighbor 20.0.2.1 remote-as 400
     neighbor 20.0.2.1 ebgp-multihop 255
     neighbor 30.0.2.1 remote-as 400
     neighbor 30.0.2.1 ebgp-multihop 255
    ======================================
    R6:
    interface Serial1/1
     ip address 30.0.1.2 255.255.255.0
     serial restart-delay 0
    interface Serial1/2
     ip address 20.0.3.2 255.255.255.0
     serial restart-delay 0
    interface Serial1/3
     ip address 30.0.3.1 255.255.255.0
     serial restart-delay 0
    router bgp 400
     no synchronization
     bgp log-neighbor-changes
     network 20.0.3.0 mask 255.255.255.0
     network 30.0.0.0 mask 255.255.255.0
     network 30.0.1.0 mask 255.255.255.0
     network 30.0.2.0 mask 255.255.255.0
     network 30.0.3.0 mask 255.255.255.0
     neighbor 20.0.3.1 remote-as 400
     neighbor 20.0.3.1 ebgp-multihop 255
     neighbor 30.0.0.1 remote-as 300
     neighbor 30.0.0.1 ebgp-multihop 255
     neighbor 30.0.1.1 remote-as 400
     neighbor 30.0.1.1 ebgp-multihop 255
     neighbor 30.0.2.2 remote-as 400
     neighbor 30.0.2.2 ebgp-multihop 255
     neighbor 30.0.3.2 remote-as 400
     neighbor 30.0.3.2 ebgp-multihop 255
    =====================================
    R7:
    interface FastEthernet0/0
     ip address 40.0.0.2 255.255.255.0
     duplex auto
     speed auto
    interface Serial1/3
     ip address 30.0.3.2 255.255.255.0
     serial restart-delay 0
    router bgp 400
     no synchronization
     bgp log-neighbor-changes
     network 30.0.3.0 mask 255.255.255.0
     network 40.0.0.0 mask 255.255.255.0
     neighbor 30.0.3.1 remote-as 400
     neighbor 40.0.0.1 remote-as 400
    =====================================
    Thanks.,
    Prakalathan.k

    Hi,
    there is one general BGP rule:
    A BGP router will not advertise any prefix received via iBGP to another iBGP neighbor.
    So neither R4 nor R6 will not advertise your R1 prefix received via iBGP to from R3 to another iBGP neighbor R5.
    There are several basic possibilities to fix the issue:
    a) Configure iBGP full-mesh.
    I.e., add a iBGP session between R5 and R3.
    b) Try to configure route-reflector.
    c) Or think about confederations.
    IMHO, a) is the easiest way.
    Best regards,
    Milan

  • Diffenrence between sh ip bgp & sh ip route

    I am reading up on BGP and a bit confused as to the difference between sh ip bgp & sh ip route...Does BGP maintain its own table? - if it does, how does it correlate with the routing table?
    Thanks

    Greg
    Yes indeed BGP does maintain its own table. In that sense it is a bit simmilar to OSPF with its link state data base or EIGRP with its topology table, all of these maintain their own table of what they have learned and route information from their table may or may not be used in the routing table.
    In the case of BGP there are several reasons why a prefix may be present in the BGP table but not present in the routing table: if it is an IBGP route there is the possibility that it may not satisfy the synchronization condition, or there may be issues with reachability of the next hop address, there is a possibility that a different route with a better administrative distance may exist, there may be other but this is enough to make the point about routes that may exist in the BGP table but not be used in the routing table.
    HTH
    Rick

  • Advertise route as OSPF, but I see it as "EIGRP" ?

    Sorry if this is a stupid question but I don't understand well why I am able to see route
    D 152.1.1.4/30 on RouterD.
    Basically the network 152.1.1.4/30 has been advertised via OSPF on RouterC interface. However, that was not advertised there as an EIGRP route...
    How come I am able to see it on RouterD as EIGRP ?
    Please find attached complete run config.
    Please note I am doing one-way redistribution EIGRP->OSPF. Therefore in my view that doesn't justify the EIGRP route for 152.1.1.4/30 on RouterD.
    RouterB so]===[s0 RouterC s01]===[s0 RouterD]
    RouterB s0=152.1.1.5/30
    RouterB S1=152.1.1.6/30
    RouterD S0=152.1.2.2/24
    From RouterD:
    Gateway of last resort is not set
    152.1.0.0/16 is variably subnetted, 3 subnets, 2 masks
    C 152.1.3.0/24 is directly connected, Loopback0
    C 152.1.2.0/24 is directly connected, Serial0/0
    D 152.1.1.4/30 [90/2681856] via 152.1.2.1, 00:01:58, Serial0/0

    Just one correction here.
    network 152.1.1.5 0.0.0.0 area 0 is CORRECT, if the interface IP is 152.1.1.5.
    The main misunderstanding encountered is: the network statement and especially the wildcard mask determine the routing updates sent. Wrong.
    The only purpose the network statement serves in OSPF is to identify the IP interfaces where to send hellos and include the networks with configured mask into routing updates (LSAs).
    So f.e.
    router ospf 10
    network 0.0.0.0 0.0.0.0 area 0
    has nothing to do with a default route. it just means: "Include any active IP interface into OSPF and send hellos." Still configured network/mask would be announced correctly.
    Writing this I would even recommend instead of 0.0.0.0 0.0.0.0 to use
    network 152.1.1.1 0.0.0.0 area 0
    because you will not unintentionally enable OSPF on an interface, where it should not start (f.e. towards ISP).
    Hope this helps! Please rate all posts.
    Regards, Martin

  • ACE VIPs not advertising or visible

    Hi,
    The VIPs on my ACE configuration are not advertising themselves. They don't show up in the ARP table in the upstream router/firewall.
    The VIPs are configured to be "Inservice". I have probes that are successful. I can access the real servers behind the ACE successfully via pings, ssh, http, etc.
    Here's part of my config:
    policy-map multi-match int204-n2
    class SMTP_Inbound_LB
    loadbalance vip inservice
    loadbalance policy SMTP_Inbound_LB-l7slb
    loadbalance vip icmp-reply active
    Is there anything else I need to add? The VIPs aren't responding to pings. The VIPs aren't showing up in the arp table of the upstream router/firewall.
    I know there used to be a "loadbalance vip advertise" command, but that command is no longer valid or available.
    I am running code version A1.8(0) on the ACE 4710 appliance.
    I have this ACE also configured as a bridge. Is there something special I need to add to make the VIPs advertise themselves, respond to pings, etc.?
    Any help would be appreciated.
    Thank you.

    Hi Gilles,
    Yes, the policy is assigned to both VLAN interfaces of the bridge-group.
    Yes, all VIPs show INSERVICE when I run the command "show service-policy int204-n2"
    None of the VIPs are responding to pings or showing up in arp table of the upstream router/firewall.
    The VIPs are part of the local subnet. I can't ping the local interface (BVI interface) of the bridge-group from the upstream firewall/router.
    Yes, the ACE has an arp entry for the upstream router/firewall. The upstream firewall is also the ACE's default-gateway for this context.
    Thanks,
    Herman

  • Connecting computer to tv for viewing EPIX,ETC.. but not through router?????

    I need to start connecting computer to tv for viewing EPIX,ETC.. but not through router?????  I have a workroom with a TV but without cable connection, so I thought I would connect my computer to my TV.  I have an Acer Aspire laptop. and a 27" tv.  Please can anyone tell me how to get this to work.  I need something to watch while I am working.

    I'm a little confused here as to what you're looking for. Are you simply trying to get Internet Connectivity to the computer using the best method possible or are you looking to try and send a signal to the TV without a cable connection going to it? The computer's Internet portion is easy if that is the case. If we can just get some additional information on that, we'll figure out how to approach it.
    1: Does this Workroom have any Coaxial cabling going to it that can be connected back to the cabling the FiOS equipment is using?
    2: Is Ethernet cabling available and running to the location of the router, or nearby?
    3: Would Wireless work for you (as much as it is not ideal)?
    4: Are you looking for a Physical connection to the network?
    Now if what you're trying to accomplish is the actual connection between the Computer and the TV, check to see what inputs the TV supports (HDMI, VGA, DVI, Component, Composite) and see what the laptop supports (DisplayPort, VGA, HDMI, DVI). More than likely the Laptop would have a VGA connection along with the TV. Your best bet would be to honestly just connect a VGA Cable between the two machines, and then for audio, just use a 3.5" to Composite connection for the TV (Unless the TV has a 3.5" Input jack for the PC Input). If HDMI is available on both devices, by all means use that. Same with DVI as both give better picture quality over a VGA Cable.
    If you can give us exact model numbers, that would help.
    ========
    The first to bring me 1Gbps Fiber for $30/m wins!

Maybe you are looking for

  • Can I change thePhoto Downloader sort order in PSE11

    The default sort for the Photo Downloader seems be by date and time. I recently purchased a camera the does up to 10 fps and the Downloader does not seems to have resolution to sort the micro-second or even second. I batch download the images and als

  • TS2755 IPad went black!

    I have an IPad first version and it went black last night.  I assume it has a battery.  Do these need to be replaced and if so, how much is  replacement cost? the Thank you!

  • [Solved]Installed AMD Catalyst drivers. Are they activated?

    This must be a really stupid question. I have installed the Catalyst drivers from the repo, but in KinfoCenter I'm getting something else: It's not a VMware installation, it's alongside Windows. So, am I using the Catalyst drivers or not? Thanks. Las

  • Lightroom web photo templates

    Hi, ive been looking into using lightroom to design a photo gallery for my website. The problem is ive noticed that most of the templates used by lightroom (especially LRG) require PHP. My web hosting only supports ASP (MS server), does anyone know i

  • Getting photos from my iDisk to my iPad (Photos)

    I have loaded a batch of photos from my camera up to my iDisk. How can I get them down onto my iPad, into the Photos app? I have wifi - I do not have my notebook (or iTunes) with me. I have the iDisk app on my iPad and it will let me open and view th