Sh bgp: received & advertised routes

Dear all:
In reference at the commands:
- sh bgp neighbor A.B.C.D
- sh bgp neighbor A.B.C.D received routes
- sh bgp neighbor A.B.C.D advertised-routes
For example:
ROUTER#sh bgp neighbor A.B.C.D
  Policy for incoming advertisements is PEERING-IN
  Policy for outgoing advertisements is PEERING-OUT
  1 accepted prefixes, 0 are bestpaths
  Cumulative no. of prefixes denied: 8974070. 
    No policy: 0, Failed RT match: 0
    By ORF policy: 0, By policy: 8974070
  Prefix advertised 77, suppressed 0, withdrawn 2
In output this command we have # Prefixes: 
1 accepted & 0 are bestpaths (after policy) 
advertised 77, suppressed 0, withdrawn 2 (after policy)
8974070 prefix are deny
But, when you execute the next command:
ROUTER#sh bgp neighbor A.B.C.D received routes 
Processed 503233 prefixes, 503233 paths
In output this command we have# Prefixes = 503233 
And when you execute the next command:
ROUTER#sh bgp neighbor A.B.C.D advertised-routes
Processed 73 prefixes, 73 paths
In output this command we have:
73 prefixes advertised at peer
The question is:
What's the different between  counter 8974070  and 503233 (prefix received before apply policy)?
What's the different between  counter 77 (or 75 = 77 - 2 withdrawn) and  73 (prefix advertised before apply policy)?
Exist only one command that help at see total prefix received/advertised (different a sh bgp neighbor A.B.C.D received routes) ?
Thanks.

Not really because OSPF does not advertise routes it sends LSAs to it's peers.
So you need to look at the OSPF database ie. -
"sh ip ospf database"
which will show you all the LSAs the router is aware of.
In terms of all the LSAs the router has received it will show all of those but it will also show you LSAs that were generated by the router itself although the advertising router IP will point to that being the case.
In terms of all the LSAs the router advertises again it depends on the area and how that has been configured.
So for example an ABR might well have external LSAs (which aren't tied to any area in the OSPF database) but that doesn't necessarily mean it is advertising them to peers within an area as it could have been configured not to.
So it gives you a good idea but you need to also work out a few things for yourself as well.
Jon

Similar Messages

  • BGP not advertising routes

    I have two routers with BGP configured: 
    C2921:
    router bgp 65014
     bgp router-id 192.168.54.190
     bgp log-neighbor-change
     neighbor 192.168.54.150 remote-as 65011
     neighbor 192.168.54.150 description Loud backup
     neighbor 192.168.54.150 route-map Backup out
    C1841:
    router bgp 65011
     no synchronization
     bgp router-id 10.10.35.1
     bgp log-neighbor-changes
     neighbor 192.168.54.149 remote-as 65014
     neighbor 192.168.54.149 description Cubus backup
     neighbor 192.168.54.149 prefix-list Loudenia out
     neighbor 192.168.54.149 route-map Backup out
    ip prefix-list Loudenia seq 5 permit 10.10.35.0/24 le 32
    ip prefix-list Loudenia seq 10 permit 192.168.111.0/24 le 32
    ip prefix-list Loudenia seq 15 permit 10.25.15.0/24 le 32
    ip prefix-list Loudenia seq 20 permit 192.168.44.0/24 le 32
    ip prefix-list Loudenia seq 25 permit 192.168.45.0/24 le 32
    ip prefix-list Loudenia seq 30 permit 192.168.46.0/28 le 32
    ip prefix-list Loudenia seq 35 permit 192.168.49.196/30 le 32
    ip prefix-list Loudenia seq 40 permit 192.168.49.225/32
    ip prefix-list Loudenia seq 45 permit 192.168.49.229/32
    route-map Backup permit 10
     set as-path prepend 65011 65011
    I have added:
    ip prefix-list Loudenia seq 50 permit 192.168.48.225/32 
    made:
    clear ip bgp 192.168.54.149 soft
    but nothing changed route to 192.168.48.225 not advertised:
    C1841-Loudenia#show ip bgp neighbors 192.168.54.149 advertised-routes
    BGP table version is 137998, local router ID is 10.10.35.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
       Network          Next Hop            Metric LocPrf Weight Path
    *> 10.10.35.0/24    0.0.0.0                  0         32768 i
    *> 10.25.15.0/24    192.168.111.10           0         32768 i
    *> 192.168.44.0     192.168.49.26                          0 65005 i
    *> 192.168.45.0     192.168.49.26                          0 65005 i
    *> 192.168.46.0/28  192.168.49.26                          0 65005 i
    *> 192.168.49.196/30
                        192.168.49.26                          0 65005 i
    *> 192.168.49.225/32
                        192.168.49.26            0             0 65005 i
    *> 192.168.49.229/32
                        192.168.49.26                          0 65005 i
    *> 192.168.111.0    0.0.0.0                  0         32768 i
    C1841 knows 192.168.48.225/32 via bgp 
    *  192.168.48.225/32
                        192.168.49.58                          0 65005 65005 65005 65006 65013 i
    *>                  192.168.49.26                          0 65005 65006 65013 i
    I will be grateful for your advice

    Hello, thanks for reply.
    The route is on the route table
    C1841-Loudenia#show ip route | i 192.168.48.225
    B       192.168.48.225/32 [20/0] via 192.168.49.26, 3w6d
    C1841-Loudenia#show ip bgp | i 192.168.48.225
    *  192.168.48.225/32
                        192.168.49.58                          0 65005 65005 65005 65006 65013 i
    *>                  192.168.49.26                          0 65005 65006 65013 i

  • Can you display routes advertised and/or received in OSPF, similar to BGP command sh ip bgp neighbors x.x.x.x advertised-routes?

    TOC-BP-SWa#sh ip bgp neighbors 10.14.0.3 advertised-routes
    BGP table version is 1674320, local router ID is 10.14.0.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
       Network          Next Hop            Metric LocPrf Weight Path
    *> 10.14.0.1/32     0.0.0.0                  0         32768 i
    *> 147.249.37.0/24  172.20.18.1                   120      0 2001 65015 65016 64823 7381 64681 i
    *> 147.249.38.0/24  172.20.18.1                   120      0 2001 65015 65016 64823 7381 64681 i
    *> 147.249.46.0/24  172.20.18.1                   120      0 2001 65015 65016 64823 7381 12159 12159 i
    *> 147.249.196.0/24 172.20.18.1                   120      0 2001 65015 65016 64823 64870 65124 i
    *> 147.249.237.0/24 172.20.18.1                   120      0 2001 65015 65016 64823 7381 64681 i
    TOC-BP-SWa#sh ip bgp neighbors 10.14.0.3 received-r       
    Total number of prefixes 0 
    TOC-BP-SWa#sh ip bgp neighbors 10.14.0.2 received-r
    BGP table version is 1674320, local router ID is 10.14.0.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
       Network          Next Hop            Metric LocPrf Weight Path
    *>i10.14.0.2/32     10.14.0.2                0    100      0 i
    * i147.249.37.0/24  10.14.0.2                0    120      0 2001 65015 65016 64823 7381 64681 i
    * i147.249.38.0/24  10.14.0.2                0    120      0 2001 65015 65016 64823 7381 64681 i
    * i147.249.46.0/24  10.14.0.2                0    120      0 2001 65015 65016 64823 7381 12159 12159 i
    * i147.249.196.0/24 10.14.0.2                0    120      0 2001 65015 65016 64823 64870 65124 i
    * i147.249.237.0/24 10.14.0.2                0    120      0 2001 65015 65016 64823 7381 64681 i
    Can this output be duplicated with an OSPF command? 

    Not really because OSPF does not advertise routes it sends LSAs to it's peers.
    So you need to look at the OSPF database ie. -
    "sh ip ospf database"
    which will show you all the LSAs the router is aware of.
    In terms of all the LSAs the router has received it will show all of those but it will also show you LSAs that were generated by the router itself although the advertising router IP will point to that being the case.
    In terms of all the LSAs the router advertises again it depends on the area and how that has been configured.
    So for example an ABR might well have external LSAs (which aren't tied to any area in the OSPF database) but that doesn't necessarily mean it is advertising them to peers within an area as it could have been configured not to.
    So it gives you a good idea but you need to also work out a few things for yourself as well.
    Jon

  • BGP Advertised Routes two Peering

    Dear all
    I have issue with BGP behaviour. I have two BGP peering; from both I receive default route, but one of them,
    AS 65472 is primary so I setup local preference in 200; it is because I want to use AS 65472 as internet
    provider. The another one, AS 65472 is used as secundary internet access, but for internal network (private) is
    used as primary. The issue is when try ping from LAN, can not reach internal network, seems to be that
    becuase Local preference is setup within AS65472 and the packet try to go thru AS 65472 because local prefeence 200,
    but I need that internal network go thru AS 65471.
    I am sure that I am advertising network as I expect, but when is running BGP for both peering, it fails.
    Here are go output for this situation:
    7204VXR-SCT#sh ip bgp neighbors 172.16.40.37 received-routes
       Network          Next Hop            Metric LocPrf Weight Path
    * i0.0.0.0          172.16.40.37             0    100      0 i
    Total number of prefixes 1
    7204VXR-SCT#sh ip bgp neighbors 172.16.40.37 advertised-routes
       Network          Next Hop            Metric LocPrf Weight Path
    *> 10.10.200.0/30   0.0.0.0                  0         32768 i
    *> 10.30.24.0/21    172.16.40.4              0         32768 i
    *> 172.16.17.0/24   172.16.40.5              0         32768 i
    *> 172.16.211.0/24  0.0.0.0                  0         32768 i
    *> 172.18.56.16/29  0.0.0.0                  0         32768 i
    *> 172.30.100.18/32 0.0.0.0                  0         32768 i
    *> 172.31.0.20/30   0.0.0.0                  0         32768 i
    7204VXR-SCT#sh ip bgp neighbors 190.97.254.241 received-routes
       Network          Next Hop            Metric LocPrf Weight Path
    *  0.0.0.0          190.97.254.241                         0 65472 i
    Total number of prefixes 1
       Network          Next Hop            Metric LocPrf Weight Path
    *> 190.153.116.0/22 172.16.40.4              0         32768 i
    *> 190.153.120.0/22 172.16.40.4              0         32768 i
    *> 190.153.124.0/24 172.16.40.37            10         32768 i
    router bgp 65471
     bgp log-neighbor-changes
     neighbor externalBGP peer-group
     neighbor externalBGP remote-as 65472
     neighbor externalBGP version 4
     neighbor internalBGP-SCT peer-group
     neighbor internalBGP-SCT remote-as 65471
     neighbor internalBGP-SCT version 4
     neighbor 172.16.40.37 peer-group internalBGP-SCT
     neighbor 190.97.254.241 peer-group viginet
     address-family ipv4
     neighbor externalBGPsoft-reconfiguration inbound
     neighbor externalBGProute-map viginet-in in
     neighbor externalBGProute-map viginet-out out
     neighbor internalBGP-SCT soft-reconfiguration inbound
     neighbor internalBGP-SCT route-map internalBGP-SCT-out out
     neighbor 172.16.40.37 activate
     neighbor 190.97.254.241 activate
     no auto-summary
     no synchronization
     network 10.10.200.0 mask 255.255.255.252
     network 10.30.24.0 mask 255.255.248.0
     network 172.16.17.0 mask 255.255.255.0
     network 172.16.40.0 mask 255.255.255.0
     network 172.16.211.0 mask 255.255.255.0
     network 172.18.56.16 mask 255.255.255.248
     network 172.30.100.18 mask 255.255.255.255
     network 172.31.0.20 mask 255.255.255.252
     network 190.153.116.0 mask 255.255.252.0
     network 190.153.120.0 mask 255.255.252.0
     network 190.153.124.0 mask 255.255.255.0
     exit-address-family
    ip route 172.16.40.36 255.255.255.252 Null0 250
    ip route 190.153.116.0 255.255.252.0 172.16.40.4
    ip route 190.153.120.0 255.255.252.0 172.16.40.4
    ip prefix-list invalidas seq 10 permit 172.16.40.0/24
    ip prefix-list invalidas seq 15 permit 10.30.24.0/21
    ip prefix-list invalidas seq 20 permit 172.16.211.0/24
    ip prefix-list invalidas seq 25 permit 172.18.56.16/29
    ip prefix-list invalidas seq 30 permit 172.30.100.18/32
    ip prefix-list invalidas seq 35 permit 10.10.200.0/30
    ip prefix-list invalidas seq 40 permit 172.16.17.0/24
    ip prefix-list invalidas seq 45 permit 172.31.0.20/30
    ip access-list standard viginet-100
     permit 190.153.116.0 0.0.3.255
     permit 190.153.120.0 0.0.3.255
     permit 190.153.124.0 0.0.0.255
    route-map externalBGP-out permit 10
     match ip address viginet-100
    route-map externalBGP-in permit 10
     set local-preference 200
    route-map internalBGP-SCT-out permit 10
     match ip address prefix-list invalidas

    Hello.
    If you want your internal network to go through peer 65471 (to 0.0.0.0/0), then why do you need AS 65472?
    Could you please provide "show ip bgp 0.0.0.0/0"?

  • BGP advertised routes

    Hi All,
    Is it possible to find since how long a route being advertised to BGP neighbor?
    To elaborate, if EBGP neighbors are up since 24 hours and among 10 routes advertised, at receiving router, 5 routes show the uptime as 12 hours, whereas other 5 routes show the uptime as 24 hours.
    All 10 routes were present in advertising router's routing table for more than 24 hours.
    Regards,
    Nagabhushan

    Hi,
    when you issue on the advertising router
    sh ip route x.x.x.x
    for one particular prefix among those showing  the uptime as 12 hours on the other router, do you see any " Last update from ... xxx ago"?
    That should show you the last time the routing was changed on the advertising router (and BGP should have advertised the change that time).
    Best regards,
    Milan

  • Difference between sh ip bgp & sh ip route? BGP tables and main routing table.

    Difference between sh ip bgp & sh ip route?
    sh ip bgp :::: loc-rib ?
    sh ip bgp nei x.x.x.x advertised-routes : adj-rib-in.
    sh ip bgp nei x.x.x.x recieved-routes : adj-rib-out.
    sh ip bgp nei x.x.x.x routes : loc-rib ?
    sh ip route = rib ? if yes does it mean its loc-rib ?
    so in a given router with bgp running, will there be 5 tables (sh ip bgp; adj-rib-in; loc-rib;adj-rib-out; sh ip route) ? if yes where are they saved ?

    sh ip bgp
    shows the BGP table (where are stored info coming from BGP update) 
    sh ip bgp nei x.x.x.x advertised-routes 
    shows networks that your router will advertise to a specific neighbor
    sh ip bgp nei x.x.x.x recieved-routes 
    shows advertisement received from a specific neighbor;  networks (NLRI) filtered with route-map distribute-list,... are included  (Inbound soft reconfiguration must be enabled)
    sh ip bgp nei x.x.x.x routes 
    shows only routes sent by a specific neighbor and not filtered or discarded (i.s accepted)
    sh ip route 
    show routing table; it contains the best route for each network (best is first of all the lowest administrative distance, then the lowest metric)
    Bye,
    enrico.
    PS please rate if useful

  • BGP received-only Question

    Hi
    From what I understand in the show ip bgp x.x.x.x/x output the received-only would be present when soft-reconfiguration inbound is configured and the route has been rejected by a policy i.e. a route map
    What i have also found is that on many outputs i can see the exact same route in the output twice, one which has the received-only keyword and one doesn't.
    Now for a specified neighbor we have a route map configured inbound which will change the weight based on the community value. It seems as though when a route map is configured and an attribute is changed that route appears in the output twice, one being modified and one which is unchanged. But this contradicts what is said on the Cisco website its states 'the received-only keyword will only show up if the route is denied by a policy', but its not.. it's just changed.
    Has anyone had this discussion before? I would like to hear people's thoughts on the matter.
    Thanks
    Andre
    corerouter#show ip bgp | b 10.141.54.0
    * 10.141.54.0/23 10.199.10.18 0 64000 34406 65502 ?
    *> 10.199.10.18 0 64000 34406 65502 ?
    corerouter#sho ip bgp 10.141.54.0/23
    BGP routing table entry for 10.141.54.0/23, version 1219279
    Paths: (4 available, best #3, table Default-IP-Routing-Table)
    Advertised to update-groups:
    2 3 4 5 6 7
    34406 65502
    10.199.10.18 from 10.199.10.20 (82.196.60.60)
    Origin incomplete, metric 0, localpref 100, weight 64000, valid, external
    Community: 10199111
    34406 65502, (received-only)
    10.199.10.18 from 10.199.10.20 (82.196.60.60)
    Origin incomplete, metric 0, localpref 100, valid, external
    Community: 10199111
    34406 65502
    10.199.10.18 from 10.199.10.19 (82.196.60.1)
    Origin incomplete, metric 0, localpref 100, weight 64000, valid, external, best
    Community: 10199111
    34406 65502, (received-only)
    10.199.10.18 from 10.199.10.19 (82.196.60.1)
    Origin incomplete, metric 0, localpref 100, valid, external
    Community: 10199111

    show ip bgp neighbor x.x.x.x received-routes
    show ip bgp neighbor x.x.x.x routes
    sho ip bgp a.b.c.d
    If you found this page, like I did, while searching for "received-only" - that means that the route has only been received, but not entered in the routing table. This is good if you meant to block that route.  But if that route is actually also installed in the routing table and you meant to block it, check your route-map, specifically your prefix-lists and you will likely find that you have an error with wither the IP address or the CIDR mask, resulting in a non-match condition. The inverse is also true if you intend to allow a route but you only see the "received-only" route, you probably have a typo in your route-map or prefix list.  Below are some examples that might help.
    Here are some BGP with route-map and prefix-list examples, although the data is not meaningful. 
    router bgp 1234
      neighbor CARRIER1 peer-group
      neighbor CARRIER1 route-map PROVIDER1-IN in
      neighbor 6.7.8.9 peer group CARRIER1
    route-map PROVIDER1-IN deny 5
      match ip address prefix-list MyIPs
    route-map PROVIDER1-IN permit 10
      match ip address prefix-list GOOG APPL
    ip prefix-list GOOG seq 5 permit 8.8.8.0/24 le 32
    ip prefix-list GOOG seq 10 permit 8.8.4.4/32
    ip prefix-list APPL seq 5 per 17.142.160.59/32
    ip prefix-list APPL seq 10 per 17.178.96.0/24 le 32
    ip prefix-list MyIPs seq 5 per 1.2.0.0/16 le 24
    ip prefix-list MyIPs seq 10 per 2.3.4.0/24 le 32
    ip prefix-list MyIPs seq 15 per 4.5.6.7/32

  • BGP not advertised

    I have two routers with BGP configured: 
    C2921:
    router bgp 65014
     bgp router-id 192.168.54.190
     bgp log-neighbor-change
     neighbor 192.168.54.150 remote-as 65011
     neighbor 192.168.54.150 description Loud backup
     neighbor 192.168.54.150 route-map Backup out
    C1841:
    router bgp 65011
     no synchronization
     bgp router-id 10.10.35.1
     bgp log-neighbor-changes
     neighbor 192.168.54.149 remote-as 65014
     neighbor 192.168.54.149 description Cubus backup
     neighbor 192.168.54.149 prefix-list Loudenia out
     neighbor 192.168.54.149 route-map Backup out
    ip prefix-list Loudenia seq 5 permit 10.10.35.0/24 le 32
    ip prefix-list Loudenia seq 10 permit 192.168.111.0/24 le 32
    ip prefix-list Loudenia seq 15 permit 10.25.15.0/24 le 32
    ip prefix-list Loudenia seq 20 permit 192.168.44.0/24 le 32
    ip prefix-list Loudenia seq 25 permit 192.168.45.0/24 le 32
    ip prefix-list Loudenia seq 30 permit 192.168.46.0/28 le 32
    ip prefix-list Loudenia seq 35 permit 192.168.49.196/30 le 32
    ip prefix-list Loudenia seq 40 permit 192.168.49.225/32
    ip prefix-list Loudenia seq 45 permit 192.168.49.229/32
    route-map Backup permit 10
     set as-path prepend 65011 65011
    I have added:
    ip prefix-list Loudenia seq 50 permit 192.168.48.225/32 
    made:
    clear ip bgp 192.168.54.149 soft
    but nothing changed route to 192.168.48.225 not advertised:
    C1841-Loudenia#show ip bgp neighbors 192.168.54.149 advertised-routes
    BGP table version is 137998, local router ID is 10.10.35.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
       Network          Next Hop            Metric LocPrf Weight Path
    *> 10.10.35.0/24    0.0.0.0                  0         32768 i
    *> 10.25.15.0/24    192.168.111.10           0         32768 i
    *> 192.168.44.0     192.168.49.26                          0 65005 i
    *> 192.168.45.0     192.168.49.26                          0 65005 i
    *> 192.168.46.0/28  192.168.49.26                          0 65005 i
    *> 192.168.49.196/30
                        192.168.49.26                          0 65005 i
    *> 192.168.49.225/32
                        192.168.49.26            0             0 65005 i
    *> 192.168.49.229/32
                        192.168.49.26                          0 65005 i
    *> 192.168.111.0    0.0.0.0                  0         32768 i
    C1841 knows 192.168.48.225/32 via bgp 
    *  192.168.48.225/32
                        192.168.49.58                          0 65005 65005 65005 65006 65013 i
    *>                  192.168.49.26                          0 65005 65006 65013 i
    I will be grateful for your advice

    That is you mean?
    C1841 knows 192.168.48.225/32 via bgp 
    *  192.168.48.225/32
                        192.168.49.58                          0 65005 65005 65005 65006 65013 i
    *>                  192.168.49.26                          0 65005 65006 65013 i

  • Diffenrence between sh ip bgp & sh ip route

    I am reading up on BGP and a bit confused as to the difference between sh ip bgp & sh ip route...Does BGP maintain its own table? - if it does, how does it correlate with the routing table?
    Thanks

    Greg
    Yes indeed BGP does maintain its own table. In that sense it is a bit simmilar to OSPF with its link state data base or EIGRP with its topology table, all of these maintain their own table of what they have learned and route information from their table may or may not be used in the routing table.
    In the case of BGP there are several reasons why a prefix may be present in the BGP table but not present in the routing table: if it is an IBGP route there is the possibility that it may not satisfy the synchronization condition, or there may be issues with reachability of the next hop address, there is a possibility that a different route with a better administrative distance may exist, there may be other but this is enough to make the point about routes that may exist in the BGP table but not be used in the routing table.
    HTH
    Rick

  • BGP Conditional Advertisement With 2 Subnets

    Is it possible to trigger conditional advertisement of a Border Gateway Protocol (BGP) prefix based upon the non-existence of two subnets? I can only get this to work with one subnet.
    My customer has parallel links to a provider (one BGP session).
    The command reference mentions one subnet in the description of the non-exist-map.
    Perhaps I should just identify one network from this Internet Service Provider (ISP) to focus on as the indicator of the failure.

    An IP address match is mandatory for a non-exist-map. The access-list specified should be a simple access-list and contains only one prefix. If the condition requires multiple prefixes, multiple access-list can be used, for example:
    route-map ISP1-backbone permit 10
    match ip address 2 3 4

  • Advertise route as OSPF, but I see it as "EIGRP" ?

    Sorry if this is a stupid question but I don't understand well why I am able to see route
    D 152.1.1.4/30 on RouterD.
    Basically the network 152.1.1.4/30 has been advertised via OSPF on RouterC interface. However, that was not advertised there as an EIGRP route...
    How come I am able to see it on RouterD as EIGRP ?
    Please find attached complete run config.
    Please note I am doing one-way redistribution EIGRP->OSPF. Therefore in my view that doesn't justify the EIGRP route for 152.1.1.4/30 on RouterD.
    RouterB so]===[s0 RouterC s01]===[s0 RouterD]
    RouterB s0=152.1.1.5/30
    RouterB S1=152.1.1.6/30
    RouterD S0=152.1.2.2/24
    From RouterD:
    Gateway of last resort is not set
    152.1.0.0/16 is variably subnetted, 3 subnets, 2 masks
    C 152.1.3.0/24 is directly connected, Loopback0
    C 152.1.2.0/24 is directly connected, Serial0/0
    D 152.1.1.4/30 [90/2681856] via 152.1.2.1, 00:01:58, Serial0/0

    Just one correction here.
    network 152.1.1.5 0.0.0.0 area 0 is CORRECT, if the interface IP is 152.1.1.5.
    The main misunderstanding encountered is: the network statement and especially the wildcard mask determine the routing updates sent. Wrong.
    The only purpose the network statement serves in OSPF is to identify the IP interfaces where to send hellos and include the networks with configured mask into routing updates (LSAs).
    So f.e.
    router ospf 10
    network 0.0.0.0 0.0.0.0 area 0
    has nothing to do with a default route. it just means: "Include any active IP interface into OSPF and send hellos." Still configured network/mask would be announced correctly.
    Writing this I would even recommend instead of 0.0.0.0 0.0.0.0 to use
    network 152.1.1.1 0.0.0.0 area 0
    because you will not unintentionally enable OSPF on an interface, where it should not start (f.e. towards ISP).
    Hope this helps! Please rate all posts.
    Regards, Martin

  • BGP for policy routing ?

    Hi
    I have a vpn box with only one ip address, assuming the ip address - public ip address, assuming it is a.a.a.a
    if there is any possible, I can policy route using BGP to let vpn communication with internal with one route and vpn communication with external go to another route?
    Any comments will be appreciated
    Thanks in advance
    Julxu

    Hi,
    you may find this reference useful that talks about inline vs named lists when it comes to RPL.
    named lists are easier to edit and preferred when the lists are long, but inline sets are faster to process.
    When stating faster, you should think in usec improvements.
    One improvement I see is that you can change this:
    route-policy client-in
      if (as-path in aspath_Client) then
        pass
      elseif (as-path in aspath_Other) then
        drop
      endif
    end-policy
    to this:
    route-policy client-in
      if (as-path in aspath_Client) then
        pass
      else
        drop
      endif
    end-policy
    Considering the aspath other is a catch all it is a waste of cycles to invoke regex to make sure that it is matches any.
    On the topic of using prefix sets vs AS paths there are probably different opinions about it.
    If your client originates prefixes that are not theirs your policy still accepts them and will result in rogue routing and hijacking of prefixes.
    So with that I would recomment using a prefix set to accept prefixes from my client, just to make sure that we accept legimate prefixes. You dont want to be the guy that sourced rogue prefixes because of a client misconfiguration.
    regards
    xander

  • Prevent EIGRP advertising routes

    Hello friends,
    Imagine I have the following SVI's configured locally on a Nexus 5548...
    int vlan 10
    ip address 10.0.0.1/24
    int vlan 20
    ip address 20.0.0.1/24
    int vlan 30
    ip address 30.0.0.1/24
    How would I temporarily prevent EIGRP from advertising vlan 20 / 20.0.0.0/24 to its EIGRP neighbors
    Thanks in advance.
    Semaj

    Hi Jon,
    Yes I do. Your solution makes sense. I've done some reading since my original post.
    Could i also use an access list / prefix list to accomplish this? I have a bunch of SVI's and would like to do this as elegantly as possible. Most of the SVI's can be summarized.
    On an IOS router I'd probably do something like this...
    ip access list standard BLOCK
    deny 20.0.0.0 0.0.0.0
    permit any
    router eigrp 1
    distribute-list BLOCK out
    Can i accomplish something similar on the Nexus

  • BGP on 2600 router

    Hi All,
    Can i run BGP on a 2600 series router with 64MB ram ?
    Regards,
    Madan.

    Madan,
    If you mean, can you run it at all, the answer is probably yes - just try "router ?" in config mode and see if BGP is listed. If it is, try "router BGP 65111" and see if it accepts the command without error. If it does, you can probably configure BGP.
    If you mean, can you run it to peer with an ISP, that depends. I don't think 64Mb is near enough RAM for peering with someone who is going to send you the whole list of networks. You would want to discuss it with your provider to get the real answer.
    John

  • Has anyone received advertising for software called "Mackeeper".  Does anyone know if this is supported by Mac, and has anyone used this software?

    Has anyone reveived advertising for software called "Mackeeper".  Does anyone know if this software is supported by Mac, and has anyone used this software?

    Thanks Kappy, I let it do the scan and when it stopped halfway through and demanded registration I stopped and deleted it.  I still have the icon in the menu bar at the top of the screen and don't know how to remove it.  If this is not possible I can live with it.  I am new to Mac and have trouble divorcing myself from my old PC habits!

Maybe you are looking for