Can a netui:template include another template?

I have a case where I want to have 2 different templates (myTemplate.jsp and myTemplate2.jsp). Both use almost all of the exact same code, with a minor exception. I didn't want to have to just copy one and modify the one section that is different, b/c if I have to update the common code in the template, then I will have to do it in both places.
          Basically, my JSPs will reference the template named "myTemplate" or "myTemplate2", and each of these references the template named "baseTemplate". Can this be done?
          I have tried, but I get an error saying "No Sections defined, 'xxx' not included in template.", but I have no idea why this is happening, because I thought I was defining a section.
          This is the code I have:
          baseTemplate.jsp
          <pre>
          <netui-template:includeSection name="baseBodySection" />
          </pre>
          myTemplate.jsp
          <pre>
          <netui-template:template templatePage="baseTemplate.jsp">
          <netui-template:section name="baseBodySection">
          <netui-template:includeSection name="bodySection" />
          <%-- template specific code --%>
          </netui-template:section>
          </netui-template:template>
          </pre>
          myTemplate2.jsp
          <pre>
          <netui-template:template templatePage="baseTemplate.jsp">
          <netui-template:section name="baseBodySection">
          <netui-template:includeSection name="bodySection" />
          <%-- template specific code --%>
          </netui-template:section>
          </netui-template:template>
          </pre>
          myPage.jsp
          <pre>
          <netui-template:template templatePage="myTemplate.jsp">
          <netui-template:section name="bodySection">
          <%-- page specific code --%>
          </netui-template:section>
          </netui-template:template>
          </pre>
          myPage2.jsp
          <pre>
          <netui-template:template templatePage="myTemplate2.jsp">
          <netui-template:section name="bodySection">
          <%-- page specific code --%>
          </netui-template:section>
          </netui-template:template>
          </pre>
          When I either myPage.jsp or myPage2.jsp is rendered, I don't see any of the content from myPage.jsp or myPage2.jsp. In its place I see the error in the netui error table with the following message: "No Sections defined, 'bodySection' not included in template", and below it I see the template specific code I added in myTemplate or myTemplate2 rendered without errors.
          Is there something else I have to do in baseTemplate to tell it that the baseBodySection will have template code in it?
          Any help on this issue will be greatly appreciated.

I can sympathize with you as far as the readability goes.
I know that Tomcat 4 provides a GUI that's intended to make editing server and container level XML files a lot easier, but I'm not certain if it handles application level XMLs too. I think it's safe to say that version 5 will probably either support modifying web.xml files through the GUI or someone will make that feature available through an add-on module.
In the meantime, the length of the XML doesn't affect Tomcat. I would just put up with it until the tool comes along.

Similar Messages

  • Can a web.xml include another web.xml ?

    The application i am working at has alot of servlets and i was wondering if i can put some order in my web-app by separating my web.xml in different smaller web.xml's ?

    I can sympathize with you as far as the readability goes.
    I know that Tomcat 4 provides a GUI that's intended to make editing server and container level XML files a lot easier, but I'm not certain if it handles application level XMLs too. I think it's safe to say that version 5 will probably either support modifying web.xml files through the GUI or someone will make that feature available through an add-on module.
    In the meantime, the length of the XML doesn't affect Tomcat. I would just put up with it until the tool comes along.

  • Netui: template embedded in another template

    How to embed one netui template within another template:
              templte2
              template1
              jsp: will use template2, which in turn uses template1.

    Hi
    I recommend you to use a scheduled powershells cript which will do the job for you
    Romeo Donca, Orange Romania (MCSE, MCITP, CCNA) Please Mark As Answer if my post solves your problem or Vote As Helpful if the post has been helpful for you.

  • netui-template integration with frames

    Greetings,
    Is there any integration between <netui-template and HTML frames ? For example, I need to define several frames in all the JSPs of a webapp. I'm using a template which declares something like:
    <framest colums="25%,75%>
    <frame src="leftTemplate.jsp" name="left"/>
    <frame src="rightTemplate.jsp" name="right"/>
    </frameset>
    where leftTemplate.jsp and rightTemplate.jsp are templates. This raises an exception saying that there is no template context due to the fact that templates are used directly, which is right.
    I tried to use <netui-template:section instead of frames but the target option of <netui-html don't seem to be integrated with sections. For example, I need to click an anchor in a section and produce a visual feed-back in another one. If I use the target option of the <netui:anchor to specify the second section name, it doesn't work. If the name specified by the target option of the <netui:anchor is a frame name, then it works. So I need either to be able to use templates in conjunction with frames or to have target-aware sections.
    Any suggestion would be higly apreciated.
    Many thanks in advance.
    Nicolas

    Hello
    Which URL are you using in your Communication Channels? Make sure you use the appropriate URL as listed in note 1953125.
    Also, make sure proper credentials are stored in the IMG.
    Hope this helps.
    Sridhar

  • I18N and netui-template:setAttribute ..

    Hi,
    In my jsp I am using setAttribute tag as follows
    <b><netui-template:setAttribute name="title" value="My Page title"></netui-template:setAttribute>
    </b>
    I want to read the "value" attribute from a Application Resource.
    So I did the following:
    <i> <netui-template:setAttribute name="title" value="<bean:message key="my.value.title"/>"></netui-template:setAttribute></i>
    But it does not compile, wondering if you can help.
    Thanks in advance
    Jaan

    You can also decalre the bundle in your JSP, when you don't use a pageflow:
    JSP:
    <netui-data:declareBundle name="labels" bundlePath="bundle.test" />
    Submit Button:     <netui:button value="{bundle.labels.submit}"/>
    Cancel Button:     <netui:button value="{bundle.labels.cancel}"/>
    Bundle file:
    submit=Submit
    cancel=Reset
    Thomas Cook wrote:
    If you're using page flows you can do the following...
    In your page flow in the class comment:
    @jpf:message-resources resources="messages"
    In your JSP:
    <netui:label value="{bundle.default.nameLabel}"/>
    In your /WEB-INF/classes/messages.properties file:
    nameLabel=Name
    Alternately, if you're using the "key" attribute on your
    message-resources annotation you'd do the following...
    In your page flow in the class comment:
    @jpf:message-resources key="foo" resources="messages"
    In your JSP:
    <netui:label value="{bundle['foo/jpfDirectory'].nameLabel}"/>
    In your /WEB-INF/classes/messages.properties file:
    nameLabel=Name:
    Where your .jpf file is /jpfDirectory/Controller.jpf.
    I hope this helps.
    Thomas
    Claus Ljunggren wrote:
    Hi,
    I want to i18n my netui:button. Does it have to be this uggly?
    <i18n:getMessage messageName="labelCreateContact"
    id="createContact"/>
    <netui:button type="submit" value="<%=createContact%>"/>
    btw, workshop claims that it doesn't know the createContact inside <%=%>,
    but it works when run.
    TIA,
    Claus Ljunggren

  • In a jsp page how can i include another page from differenct web context

    Hi,
    i want to include a page from another web content to my page. How is it possible. For example in a jsp page i want to include "http://www.google.com". How is it possible. can i use <jsp:include tage for this purpose? any idea?
    Edited by: JavaHeroPrince on Apr 2, 2009 12:05 AM

    I'm afraid you cannot do that using <jsp:include/> tag.
    However, you can achive this using <c:import/> tag which comes with JSTL core tags.
    Please find the below example of how to go about.
    <%@ taglib uri = "http://java.sun.com/jstl/core" prefix = "c"%>
    <c:import url = "http://www.google.com/search">
      <c:param name="q" value="c%3Aimport+jstl"/>
      <c:param name="rls" value="com.microsoft:en-us"/>
      <c:param name="ie" value="UTF-8"/>
      <c:param name="oe" value="UTF-8"/>
      <c:param name="startIndex" value=""/>
      <c:param name="startPage" value="1"/>
    </c:import>
    -------------------------------------------------------------------------for more info
    [http://java.sun.com/developer/technicalArticles/javaserverpages/faster/]
    Hope that helps :)
    REGARDS,
    RaHuL

  • How can I get templates for Avery Labels to use with Pages.

    Prior to getting Pages I always used Word.  Word seems to bomb out on my new imac.  I need to be able to use Avery Labels, but I can't find a template for labels in Pages.  Suggestions?

    Pages doesn't have label templates built in. You can use Word templates in Pages, but I do believe that Avery now has Pages templates although I only see "holiday" ones.

  • How i can fetch the template greater than 32000 k size into reach text editor

    how i can fetch the template greater than 32000 k size into reach text editor

    Would this help you?
    - Dynamic Action Plugin - Enkitec CLOB Load

  • How can I include another iphone to Find my iphone?

    How can I include another iphone to Find my iphone?

    same way you included the first
    you can add as many as you like got both my ipad and iphone on it
    http://www.maclife.com/article/howtos/set_find_my_iphone_multiple_iphones_one_mo bileme_account

  • Where can I find templates for Dreamweaver?

    Does Dreamweaver CS6 have predefined templates?  If not where can I find templates?

    For pre-built CSS layouts in DW, go to File > New > Blank page > HTML > Layouts. 
    Select one from the right panel & hit Create.
    For Commercial CSS Layouts, look at Project Seven's offerings.
    http://www.projectseven.com/
    To customize the above, add your own text, images, CSS styles and backgrounds.
    Nancy O.

  • Is there any drag & drop website builder where you can load a template ?

    Is there any drag & drop website builder where you can load a template ?
    I have a themeforest template which is great in html which I like to adjust, but I need a drag & drop website builder that automatically changes the codes and scripts as I can't program....
    I tested some like Bluevoda & wysiwyg webbuilders, but there you can only load their files (.bvd ,...) extensions, not a full site or index.html

    Muse is drag & drop but I'm not sure how well it would work with Themeforest templates.  Muse could very well make a mess of it.
    You might want to ask about this in the Muse discussion forum.
    http://forums.adobe.com/community/muse/help_with_using_adobe_muse?view=discussions
    Nancy O.

  • How can I delete templates from MY TEMPLATES in Pages?

    How can I delete templates from MY TEMPLATES i Pages?

    Pages stores those you created & saved as templates in (your account) > Library > Application Support > iWork > Pages > Templates > My Templates. The user's Library is hidden in Lion & Mountain Lion but it is easy to open. In Finder, hold down the Option key while clicking on the Go menu & your user Library will appear about halfway down the list. Or you can choose Go to Folder from Go menu in Finder & paste this line in the box:
    ~/Library/Application Support/iWork/Numbers/Templates/My Templates/

  • Can PDF files be included with a movie on iDVD?

    I'm using iMovie to create a movie of a presentation recorded by video camcorder, and that effort looks to be promising so far. When the iMovie editing is finished, I want to burn the presentation on iDVD as a digital seminar.
    My hope is to provide copies of the handout (six pages of A4 text and images) that accompany the presentation on the same DVD recording. I'm thinking that if PDF documents of the handout could be included on the DVD, they could be simply opened and printed out. I've discovered that PDF files can be imported to iPhoto, but it appears only to produce single-page images, and I'm not sure how they could be printed out to full size A4 (which I would prefer). The original documents were created on AppleWorks 6.2.9, if that's helpful.
    1) Can PDF documents be included in an iDVD recording?
    2) Can they be printed out as full size (A4) documents?
    3) Is there another way of going about this?
    4) Would providing a separate CD with 'print these' documents be simpler?
    Thank you in advance, Isshi.

    1. Yes. You can add these PDF's to the dvd-rom section of the dvd and can be accessed from your mac or pc. But they will not play back on most set top dvd players or TV's.
    2. Yes.
    3. Yes but it is more costly. One could also use apple's FCS / DVDSP.
    4. Not necessary. Just do it on the same dvd using iDvd.
    (Btw, you may want to consider using Pages as opposed to AW 6. I too use AW 6 but sometimes have issues opening an older document. Pages does not have these same issues).
    Hope this helps but if not just come on back.
    Message was edited by: SDMacuser

  • Cisco 1941 Router-on-a-Stick w/ 11VLANs trunked to a Cisco 2960: Can Ping a device in another VLAN, that device cannot ping back

    Cisco 1941 Router-on-a-Stick w/ 11VLANs trunked to a Cisco 2960: From the Switch I can Ping a device in another VLAN, that device cannot ping back. Some devices can ping devices in other VLANs and the device in the other VLAN can successfully return the Ping. Have a look at the attached diagram.
    Router Config:
    show run
    Building configuration...
    Current configuration : 7224 bytes
    ! Last configuration change at 09:05:48 EDT Wed Aug 6 2014
    version 15.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname ROUTER
    boot-start-marker
    boot-end-marker
    no aaa new-model
    clock timezone EDT -8 0
    ip cef
    ip name-server 8.8.8.8
    no ipv6 cef
    multilink bundle-name authenticated
    license udi pid CISCO1941/K9
    object-group network Net_Obj_Group1 
     description This network group allows all 10.0.0.0 and Email Forwarder server through to the Plt PCs
     205.191.0.0 255.255.0.0
     10.0.0.0 255.0.0.0
    object-group network Net_Obj_Group2 
     description This Network Group includes the Host IPs allowed through the Plant Router
     host 10.194.28.23
     host 10.194.28.25
     host 10.194.28.26
     host 10.194.28.27
     host 10.194.28.28
     host 10.194.28.29
     host 10.194.28.37
     host 10.194.28.39
     host 10.194.28.40
     host 10.194.28.70
     host 10.194.28.130
     host 10.194.28.131
     host 10.194.28.132
     host 10.194.28.133
     host 10.194.28.134
     host 10.194.28.135
     host 10.194.28.136
     host 10.194.28.137
     host 10.194.28.138
     host 10.194.28.139
     host 10.194.28.140
     host 10.194.28.141
    interface Embedded-Service-Engine0/0
     no ip address
     shutdown
    interface GigabitEthernet0/0
     description Port Ge0/0 to IT Enterprise network Switch GE1/0/38
     ip address 10.194.28.111 255.255.255.0
     ip access-group 105 in
     ip access-group 106 out
     ip nat outside
     ip virtual-reassembly in
     shutdown
     duplex full
     speed auto
     no mop enabled
    interface GigabitEthernet0/1
     description Port to Plant PCN-K/L24 Sw1 Port 0/24
     no ip address
     duplex auto
     speed auto
     no mop enabled
    interface GigabitEthernet0/1.102
     description Port to VLAN 102
     encapsulation dot1Q 102
     ip address 192.168.102.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
    interface GigabitEthernet0/1.104
     description Port to VLAN 104
     encapsulation dot1Q 104
     ip address 192.168.104.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
    interface GigabitEthernet0/1.105
     description Port to VLAN 105
     encapsulation dot1Q 105
     ip address 192.168.105.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
    interface GigabitEthernet0/1.106
     description Port to VLAN 106
     encapsulation dot1Q 106
     ip address 192.168.106.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
    interface GigabitEthernet0/1.107
     description Port to VLAN 107
     encapsulation dot1Q 107
     ip address 192.168.107.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
    interface GigabitEthernet0/1.111
     description Port to VLAN 111
     encapsulation dot1Q 111
     ip address 192.168.111.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
    interface GigabitEthernet0/1.117
     description Port to VLAN 117
     encapsulation dot1Q 117
     ip address 192.168.117.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
    interface GigabitEthernet0/1.121
     description Port to VLAN 121
     encapsulation dot1Q 121
     ip address 192.168.121.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
    interface GigabitEthernet0/1.125
     description Port to VLAN 125
     encapsulation dot1Q 125
     ip address 192.168.125.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
    interface GigabitEthernet0/1.150
     description Port to to VLAN 150
     encapsulation dot1Q 150
     ip address 192.168.150.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
    interface GigabitEthernet0/1.999
     description Port to VLAN 999
     encapsulation dot1Q 999
     ip address 192.168.0.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
    ip forward-protocol nd
    ip http server
    no ip http secure-server
    ip nat inside source static 192.168.102.201 10.194.28.23
    ip nat inside source static 192.168.121.201 10.194.28.25
    ip nat inside source static 192.168.106.251 10.194.28.26
    ip nat inside source static 192.168.107.245 10.194.28.27
    ip nat inside source static 192.168.102.251 10.194.28.28
    ip nat inside source static 192.168.150.201 10.194.28.29
    ip nat inside source static 192.168.107.179 10.194.28.37
    ip nat inside source static 192.168.111.201 10.194.28.39
    ip nat inside source static 192.168.105.201 10.194.28.40
    ip nat inside source static 192.168.106.21 10.194.28.70
    ip nat inside source static 192.168.107.146 10.194.28.130
    ip nat inside source static 192.168.107.156 10.194.28.131
    ip nat inside source static 192.168.107.161 10.194.28.132
    ip nat inside source static 192.168.107.181 10.194.28.133
    ip nat inside source static 192.168.107.191 10.194.28.134
    ip nat inside source static 192.168.106.202 10.194.28.135
    ip nat inside source static 192.168.106.212 10.194.28.136
    ip nat inside source static 192.168.117.190 10.194.28.137
    ip nat inside source static 192.168.117.100 10.194.28.138
    ip nat inside source static 192.168.106.242 10.194.28.139
    ip nat inside source static 192.168.125.100 10.194.28.140
    ip nat inside source static 192.168.125.99 10.194.28.141
    ip nat outside source static 10.194.28.23 10.194.28.23
    ip nat outside source static 10.194.28.25 10.194.28.25
    ip nat outside source static 10.194.28.26 10.194.28.26
    ip nat outside source static 10.194.28.27 10.194.28.27
    ip nat outside source static 10.194.28.28 10.194.28.28
    ip nat outside source static 10.194.28.29 10.194.28.29
    ip nat outside source static 10.194.28.37 10.194.28.37
    ip nat outside source static 10.194.28.39 10.194.28.39
    ip nat outside source static 10.194.28.40 10.194.28.40
    ip nat outside source static 10.194.28.70 10.194.28.70
    ip nat outside source static 10.194.28.130 10.194.28.130
    ip nat outside source static 10.194.28.131 10.194.28.131
    ip nat outside source static 10.194.28.132 10.194.28.132
    ip nat outside source static 10.194.28.133 10.194.28.133
    ip nat outside source static 10.194.28.134 10.194.28.134
    ip nat outside source static 10.194.28.135 10.194.28.135
    ip nat outside source static 10.194.28.136 10.194.28.136
    ip nat outside source static 10.194.28.137 10.194.28.137
    ip nat outside source static 10.194.28.138 10.194.28.138
    ip nat outside source static 10.194.28.139 10.194.28.139
    ip nat outside source static 10.194.28.140 10.194.28.140
    ip nat outside source static 10.194.28.141 10.194.28.141
    ip route 0.0.0.0 0.0.0.0 10.194.28.1
    access-list 105 permit ip object-group Net_Obj_Group1 object-group Net_Obj_Group2
    access-list 106 permit ip object-group Net_Obj_Group2 object-group Net_Obj_Group1
    dialer-list 1 protocol ip permit
    control-plane
    banner login ^CC
    Login banner for Plant Router #01^C
    banner motd ^CC
    MOTD Banner for Plant Router^C
    line con 0
     password XXXXXXXXX
     logging synchronous
     login
    line aux 0
    line 2
     no activation-character
     no exec
     transport preferred none
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
    line vty 0 4
     password XXXXXXXXX
     logging synchronous
     login
     transport input all
    scheduler allocate 20000 1000
    ntp server 10.199.100.92
    end
    Switch Config:
    sh ru
    Building configuration...
    Current configuration : 6513 bytes
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log datetime localtime show-timezone
    service password-encryption
    hostname K24Sw01
    boot-start-marker
    boot-end-marker
    no aaa new-model
    clock timezone EDT -5
    clock summer-time EDT recurring
    udld aggressive
    crypto pki trustpoint TP-self-signed-593746944
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-593746944
     revocation-check none
     rsakeypair TP-self-signed-593746944
      4B58BCE9 44
      quit
    spanning-tree mode pvst
    spanning-tree extend system-id
    vlan internal allocation policy ascending
    interface FastEthernet0
     no ip address
    interface GigabitEthernet0/1
     description Trunk port for vlans 105, 111, 125 and 999 from K24Sw01 port Ge0/1 to P22Sw01 port Ge0/24
     switchport trunk allowed vlan 105,111,125,999
     switchport mode trunk
    interface GigabitEthernet0/2
     description Trunk port for vlans 150 and 999 from K24Sw01 port Ge0/2 to N25Sw01 port Ge0/26
     switchport trunk allowed vlan 150,999
     switchport mode trunk
    interface GigabitEthernet0/3
     description Trunk port for vlans 102, 104, 106, 107, 117 and 999 from K24Sw01 port Ge0/3 to K28Sw01 port Ge0/26
     switchport trunk allowed vlan 102,104,106,107,117,999
     switchport mode trunk
    interface GigabitEthernet0/4
     description Trunk port for vlans 102, 106, 107 and 999 from K24Sw01 port Ge0/4 to H23Sw01 port Ge0/26
     switchport trunk allowed vlan 102,106,107,999
     switchport mode trunk
    interface GigabitEthernet0/5
     description Trunk port for vlans 121, 125 and 999 from K24Sw01 port Ge0/5 to M21Sw01 port Ge0/24
     switchport trunk allowed vlan 121,125,999
     switchport mode trunk
    interface GigabitEthernet0/6
     description OPEN
     spanning-tree portfast
    interface GigabitEthernet0/7
     description OPEN
     spanning-tree portfast
    interface GigabitEthernet0/8
     description OPEN
     spanning-tree portfast
    interface GigabitEthernet0/9
     description OPEN
     spanning-tree portfast
    interface GigabitEthernet0/10
     description VLan 102 access port
     switchport access vlan 102
     spanning-tree portfast
    interface GigabitEthernet0/11
     description - VLan 104 access port
     switchport access vlan 104
     spanning-tree portfast
    interface GigabitEthernet0/12
     description - VLan 105 access port
     switchport access vlan 105
     spanning-tree portfast
    interface GigabitEthernet0/13
     description - VLan 106 access port
     switchport access vlan 106
     spanning-tree portfast
    interface GigabitEthernet0/14
     description - VLan 107 access port
     switchport access vlan 107
     spanning-tree portfast
    interface GigabitEthernet0/15
     description - VLan 111 access port
     switchport access vlan 111
     spanning-tree portfast
    interface GigabitEthernet0/16
     description - VLan 117 access port
     switchport access vlan 117
     spanning-tree portfast
    interface GigabitEthernet0/17
     description - VLan 121 access port
     switchport access vlan 121
     spanning-tree portfast
    interface GigabitEthernet0/18
     description - VLan 125 access port
     switchport access vlan 125
     spanning-tree portfast
    interface GigabitEthernet0/19
     description - VLan 150 access port
     switchport access vlan 150
     spanning-tree portfast
    interface GigabitEthernet0/20
     description - VLan 999 access port
     switchport access vlan 999
     spanning-tree portfast
    interface GigabitEthernet0/21
     description OPEN
     spanning-tree portfast
    interface GigabitEthernet0/22
     description OPEN
     spanning-tree portfast
    interface GigabitEthernet0/23
     description OPEN
     spanning-tree portfast
    interface GigabitEthernet0/24
     description From ROUTER Gw ge0/1
     switchport trunk allowed vlan 102,104-107,111,117,121,125,150,999
     switchport mode trunk
    interface GigabitEthernet0/25
    interface GigabitEthernet0/26
    interface Vlan1
     no ip address
     no ip route-cache
     shutdown
    interface Vlan102
     ip address 192.168.102.253 255.255.255.0
    interface Vlan104
     no ip address
     no ip route-cache
    interface Vlan105
     no ip address
     no ip route-cache
    interface Vlan106
     no ip address
     no ip route-cache
    interface Vlan107
     no ip address
     no ip route-cache
    interface Vlan111
     no ip address
     no ip route-cache
    interface Vlan117
     no ip address
     no ip route-cache
    interface Vlan121
     no ip address
     no ip route-cache
    interface Vlan125
     no ip address
     no ip route-cache
    interface Vlan150
     no ip address
     no ip route-cache
    interface Vlan999
     no ip address
     no ip route-cache
    ip default-gateway 192.168.102.1
    ip http server
    ip http secure-server
    snmp-server engineID local 00000009020000019634C2C0
    snmp-server community public RO
    snmp-server location 
    snmp-server contact 
    banner motd ^CCC ADMIN USE ONLY! ^C
    line con 0
     session-timeout 10 
     password xxxxxx
     logging synchronous
     login
     stopbits 1
    line vty 0 4
     session-timeout 10 
     password xxxxxxx
     login
    line vty 5 15
     session-timeout 10 
     password xxxxxxxx
     login
    ntp server 10.199.100.92
    end
    K24Sw01#

    HI Mark,
    Here is the my config:
    Create sub-interfaces, set 802.1Q trunking protocol and ip address on each sub-interface
    Router(config)#interface f0/0
    Router(config-if)#no shutdown
    (Note: The main interface f0/0 doesn’t need an IP address but it must be turned on)
    Router(config)#interface f0/0.10
    Router(config-subif)#encapsulation dot1q 10
    Router(config-subif)#ip address 192.168.10.1 255.255.255.0
    Router(config-subif)#interface f0/0.20
    Router(config-subif)#encapsulation dot11 20
    Router(config-subif)#ip address 192.168.20.1 255.255.255.0
    (Note: In the “encapsulation dot1q 10″ command, 10 is the VLAN ID this interface operates in)
    Configure VLAN
    Switch(config)#vlan 10
    Switch(config-vlan)#name SALES
    Switch(config-vlan)#vlan 20
    Switch(config-vlan)#name TECH
    Set ports to access mode & assign ports to VLAN
    Switch(config)#interface range fa0/1
    Switch(config-if)#no shutdown
    Switch(config-if)# switchport mode access
    Switch(config-if)# switchport access vlan 15
    Switch(config-if)#interface range fa0/3
    Switch(config-if)#no shutdown
    Switch(config-if)#switchport mode access
    Switch(config-if)# switchport access vlan 20
    Switch(config-if)#interface range fa0/5
    Switch(config-if)#no shutdown
    Switch(config-if)#switchport mode trunk
    1. Please check all your port are up.
    2. Check the config once again.
    3. Make sure the swicth and router connection port configured as trunk and it should be up.
    This config is working for me,
    Regards
    Dont forget to rate helpful posts.

  • IWeb Can soundfiles be played by another player than Quicktime?

    iWeb Can soundfiles be played by another player than Quicktime? Some Windows users are not allowed to install Quicktime for Windows (e.i. a workcomputer with limitations) and they cannot play the soundexamples on my webpage! Is it possible to change the player in iWeb?

    Its not something that iWeb does. You need to upload the player assets (song files and any other required scripts) to the server and use some code in an HTML Snippet.
    Computers running older versions of Windows usually have flash installed and you can use a player like this...
    http://www.iwebformusicians.com/Website-Music-Players/Wordpress-Flash-Player.htm l
    Flash players are not so good a choice nowadays since they won't work on mobile devices like iPhone/iPad.
    All modern browsers support HTML5 audio including Internet Explorer V 9....
    http://www.iwebformusicians.com/Website-Music-Players/HTML5-Audio.html
    To ensure playback in older browsers its necessary to add flash fallback...
    http://www.iwebformusicians.com/Website-Music-Players/HTML5-Audio-In-A-Box.html
    If you want to put more than one or two audio tracks on a web page its better to use a playlist style player. Again, flash used to be the way to go...
    http://www.iwebformusicians.com/Website-Music-Players/Flash-Audio-Jukebox.html
    Modern playlist players with flash fallback are not so easy and most of them use jQuery. Some examples...
    http://www.ezmacwebdesign.com/Audio-Playlist-Players/audio-playlist.html
    The Yahoo playlist player is relatively simple but lacks some essential features...
    http://www.iwebformusicians.com/Website-Music-Players/Yahoo-Media-Player.html

Maybe you are looking for

  • Mail 4.5 Message Encryption Does Not Work per Articles

    Apple's various articles and help files on how to send encrypted mail do not work for my currently installed Mail 4.5 on my 10.6.8 OS; "An Encrypt (closed lock) icon appears next to the Signed icon if you have a personal certificate for a recipient i

  • Iphone and Outlook pop3 email

    Hello, I know there's a known issue with having outlook open and the iphone on at the same time with pop3 email accounts. is there another way around this issue besides creating an additional email account and forwarding those emails to the iphone? t

  • Import and Export Script

    Hello All Readers, Here I want to know all the parameters of Database Import and Export Command and all the possible methods of Imp/Exp. Please help me to find those. Thanks in Advance.......

  • CSS11000 global v. local and remote load balancing?

    I understand the practice of local LB on the CSS. I do not understand the same for remote LB. I have two mutually exclusive DMZs, but with the same content at each site. How does the CSS at site A know if content at site B? Site B's CSS tells it via

  • Acrhiving Files

    Hi Expert, I am doing File to File scenario. Scenario is working fine, but the problem is at sender communication i set the processing mode parameter as Archive. I specified correct path for Archive directory. Files are not archiving in the archive d