Can You Help Me ABout getSelectedRow in JTable

Can you help me on how to solve my problem about the getSelectedRow .....
I have one JComboBox and a SearchButton
... Once I selected an Item in a JComboBox, I will press the SearchButton
and then it will look up to the database and display it in the JTable..........
i used the getSelectedRow to print the value that I selected in the table...
like this...
public void mouseClicked(MouseEvent e) {
// Ilabas yung form
if(e.getClickCount() == 1 ) {
System.out.println(table1.getSelectedRow());
In the first press in the SearchButton and then clicking the row
, It will print the selected row...... but when i press again the SearchButton then clicking a row again........
there is a problem occured....... selectedRow is always -1, can you help me to solve this.....

import java.awt.*;
import java.awt.event.*;
import javax.swing.*;
import java.sql.*;
import java.util.*;
import javax.swing.plaf.metal.*;
import javax.swing.border.*;
import javax.swing.table.*;
import java.text.*;
import java.beans.*;
public class OpenProject extends JDialog {
     ResultSet rs, rs1, rs2, rs3;
     JFrame JFParentFrame; // create a JFrame
     JFrame OwnerFrame; // create a JFrame
     public JLabel proj_name;
     public JLabel proj = new JLabel("Project Name:");
     public JLabel form = new JLabel("Form Name");
     public JLabel lang = new JLabel("Language");
     public JComboBox form_lang = new JComboBox();
     public JComboBox form_name = new JComboBox();
     public JButton edit = new JButton("Edit");
     public JButton reload = new JButton("Search");
     public JButton def = new JButton("Set Text Default");
     public JButton langs = new JButton("Add Language");
     public JButton exit = new JButton("Exit");
     public JPanel panel1 = new JPanel ();
     public JTable table1, table2, table3,table4;
     public JScrollPane scrollPane1, scrollPane2, scrollPane3, scrollPane4;
     public JTabbedPane UITab,UITab1;
     Container c = getContentPane();
     Dimension screen = Toolkit.getDefaultToolkit().getScreenSize();
     public String column[][];
     public String strRow;
     public String strCol;
     public String strForm;
     public String strGetProj_id;
     public String strForm_lang;
     public String strForm_name;
     private boolean DEBUG = false;
     public int getLang;
     public int getForm;
     public int getDef_id;
     public int count2 = 0,count3 = 0,count4 = 0;
     public int row2 = 0,row3 = 0,row4 = 0;
     public int selectedRow1 = 0, selectedRow2 = 0;
     public DbBean db = new DbBean();
     public OpenProject(JFrame OwnerForm, String getProj_id) {
          super(OwnerForm,true);
               strGetProj_id = getProj_id;
          try{
               db.connect();
          } catch(SQLException sqlex) {
          } catch(ClassNotFoundException cnfex) {
          try {
               UIManager.setLookAndFeel(UIManager.getSystemLookAndFeelClassName());
          } catch(Exception e) {
          // Para ito sa paglalagay sa dalawang combo box ng value.......
          try {
               rs = db.execSQL("Select * from mst_form where form_proj_id = "+strGetProj_id+"");
               while(rs.next()) {
                    form_name.addItem(rs.getString("form_name"));
                    //System.out.println(strForm);
          } catch(SQLException sqlex) {
          try {
               rs = db.execSQL("Select distinct from mst_form where form_proj_id = "+strGetProj_id+"");
               while(rs.next()) {
                    form_name.addItem(rs.getString("form_name"));
                    //System.out.println(strForm);
          } catch(SQLException sqlex) {
          try {
               int counts;
               rs = db.execSQL("Select * from mst_project where proj_id = "+strGetProj_id+"");
               while(rs.next()) {
                    counts = rs.getInt("proj_lang_id");
                    System.out.println(counts);
                    rs1 = db.execSQL("Select * from mst_language where lang_id = "+counts+"");
                    while (rs1.next()) {
                         form_lang.addItem(rs1.getString("lang_name"));     
          } catch(SQLException sqlex) {
          edit.setActionCommand("edit");
          edit.addActionListener(actions);
          reload.setActionCommand("load");
          reload.addActionListener(actions);
          def.setActionCommand("default");
          def.addActionListener(actions);
          langs.setActionCommand("lang");
          langs.addActionListener(actions);
          exit.setActionCommand("exit");
          exit.addActionListener(actions);
          proj_name = new JLabel();     
          proj_name.setBackground(new Color(255,255,255));
          form_name.setMaximumRowCount(5);
          form_name.setBackground(new Color(255,255,255));
          form_lang.setMaximumRowCount(5);
          form_lang.setBackground(new Color(255,255,255));
          proj.setBounds(20, 20,100,20);
          proj_name.setBounds(120, 20,250,20);
          form.setBounds(20, 50,100,20);
          form_name.setBounds(120, 50,150,20);
          lang.setBounds(300, 50,100,20);     
          form_lang.setBounds(380, 50,150,20);
          reload.setBounds(560,50,80, 20);
          edit.setBounds(110,360,115,20);
          def.setBounds(230,360,115,20);
          langs.setBounds(350,360,115,20);
          exit.setBounds(470,360,115,20);
          panel1.add(getTable());
          panel1.setLayout(null);     
          panel1.setBackground(Color.white);     
          panel1.add(proj);
          panel1.add(proj_name);
          panel1.add(form);
          panel1.add(form_name);
          panel1.add(lang);
          panel1.add(form_lang);
          panel1.add(reload);     
          panel1.add(def);
          panel1.add(langs);
          panel1.add(exit);
          panel1.add(edit);
          c.add(panel1);
          setSize(680,420);
          setTitle("Open Project");
          setLocation((screen.width - 590)/2,((screen.height - 280)/2) - 45);
     public JTabbedPane getTable() {
          UITab = new JTabbedPane();
          strForm_lang = form_lang.getSelectedItem().toString();
          strForm_name = form_name.getSelectedItem().toString();
          int count1=0;
          int row1=0;
          try {
               rs = db.execSQL("Select * from mst_default where def_proj_id = '"+strGetProj_id+"' AND def_category = 'Title'" );
               while(rs.next()) {
                    count1 += 1;
                    getDef_id = rs.getInt("def_id");
               column = new String[count1][2];
               rs1 = db.execSQL("Select form_id from mst_form WHERE form_name = '"+strForm_name+"'");
               while(rs1.next()) {
                    getForm = rs1.getInt("form_id");
                    System.out.println("getForm");
               rs2 = db.execSQL("Select lang_id from mst_language WHERE lang_name = '"+strForm_lang+"'");
               while(rs2.next()) {
                    getLang = rs2.getInt("lang_id");
                    System.out.println("getLang");
               rs3 = db.execSQL("Select * from mst_default a, mst_translation b WHERE a.def_form_id = '"+getForm+"' AND b.trans_lang_id = '"+getLang+"' AND a.def_proj_id = '"+strGetProj_id+"' AND b.trans_def_id = '"+getDef_id+"' AND a.def_category = 'Title' " );
               while(rs3.next()) {
                    column[row1][0] = "" + rs3.getString("display_name");          // rowNum ay kung ilan ang row na ilalabas
               column[row1][1] = "" + rs3.getString("translation"); // Default yung isang array ng column ko, kaya fixed
                    row1++;
               row1 = 0;
          } catch(SQLException sqlex) {
               sqlex.printStackTrace();
               System.exit(1);
          // End
          table1 = new JTable(new MyTableModel()){
          scrollPane1 = new JScrollPane(table1);
          UITab.setBounds(30,100,610,250);
          UITab.add("Title",scrollPane1);
          return UITab;
     class MyTableModel extends AbstractTableModel {     
               // Pagawa ng header Coloumn
               String ColumnHeaderName[] = {
                    "Default Text",""+strForm_lang+" Translation"
               //End
               public int getColumnCount() {     
                    //System.out.println("The Column Count is" + ColumnHeaderName.length);
     return ColumnHeaderName.length;
     public int getRowCount() {
          //System.out.println("The Row Count is" + column.length);
     return column.length;
     public String getColumnName(int col) {
                    //System.out.println("The Column Name is" + ColumnHeaderName[col]);     
     return ColumnHeaderName[col];
     public Object getValueAt(int row,int col) {
          System.out.println("The value at row and column = " + column[row][col]);
     return column[row][col];
     public int getSelectedRow() {
          System.out.println("Integer" + column.length);
          return column.length;
     ActionListener actions = new ActionListener() {
          public void actionPerformed(ActionEvent ae) {
               String source = ae.getActionCommand();
               if (source == "load") {
                    table1.clearSelection();
                    panel1.add(getTable());
                    table1.addNotify();
                    repaint();
               } else if (source == "default") {
                    dispose();
                    TextDefaultForm form = new TextDefaultForm(OwnerFrame,JFParentFrame);
                    form.setVisible(true);
               } else if (source == "lang") {
                    dispose();
                    CreateProject lang = new CreateProject(JFParentFrame);
                    lang.setVisible(true);
               } else if (source == "exit") {
                    dispose();
               } else if (source == "edit") {
                    if (table1.getValueAt(table1.getSelectedRow(),table1.getSelectedColumn()) != null){
                         formLang lang = new formLang(OwnerFrame,strCol,strRow, strGetProj_id);
                         lang.setVisible(true);
     MouseListener MouseTableListener = new MouseListener() {
               public void mouseClicked(MouseEvent e) {
                    // Ilabas yung form
                    if(e.getClickCount() == 2 ) {
                         dispose();
                         int col_a = 0;
                         int col_b = 1;
                         selectedRow1 = table1.getSelectedRow();     
                         Object objColumn1 = table1.getValueAt(selectedRow1, col_a);
                         Object objRow1 = table1.getValueAt(selectedRow1, col_b);
                         strCol = objColumn1.toString();
                         strRow = objRow1.toString();
                         formLang lang = new formLang(OwnerFrame,strCol,strRow,strGetProj_id);
                         System.out.println(selectedRow1);
                         System.out.println(strCol);
                         System.out.println(strRow);
                         lang.txtProj.setText(strCol);
                         lang.txtLang.setText(strRow);
                         lang.show();
                    } else if (e.getClickCount() == 1) {
                         table1.setSelectionBackground(Color.blue);
                         table1.setColumnSelectionAllowed(false);
                    table1.setRowSelectionAllowed(true);
                    table1.setFocusable(true);
                         int a = table1.getRowCount();
                         System.out.println("Row Count = " + a);
                         int sel = table1.getSelectedRow();     
                         //if (sel == -1) return;
                         System.out.println("Selected Row = " + sel);
                         System.out.println(table1.isRowSelected(sel));
               public void mouseReleased(MouseEvent e) {
               public void mouseExited(MouseEvent e) {
               public void mouseEntered(MouseEvent e) {
               public void mousePressed(MouseEvent e) {
     //public static void main(String leo[]) {
          //OpenProject open = new OpenProject();
}

Similar Messages

  • Can you help me about change data captures in 10.2.0.3

    Hi,
    I made research about Change Data Capture and I try to implement it between two databases for two small tables in 10g release 2.MY CDC implementation uses archive logs to replicate data.
    Change Data Capture Mode Asynchronous autolog archive mode..It works correctly( except for ddl).Now I have some questions about CDC implementation for large tables.
    I have one senario to implement but I do not find exactly how can I do it correctly.
    I have one table (name test) that consists of 100 000 000 rows , everyday 1 000 000 transections occurs on this table and I archive the old
    data more than one year manually.This table is in the source db.I want to replicate this table by using Change Data Capture to other stage database.
    There are some questions about my senario in the following.
    1.How can I make the first load operations? (test table has 100 000 000 rows in the source db)
    2.In CDC, it uses change table (name test_ch) it consists of extra rows related to opearations for stage table.But, I need the orjinal table (name test) for applicaton works in stage database.How can I move the data from change table (test_ch) to orjinal table (name test) in stage database? (I don't prefer to use view for test table)
    3.How can I remove some data from change table(name test_ch) in stage db?It cause problem or not?
    4.There is a way to replicate ddl operations between two database?
    5. How can I find the last applied log on stage db in CDC?How can I find archive gap between source db and stage db?
    6.How can I make the maintanence of change tables in stage db?

    Asynchronous CDC uses Streams to generate the change records. Basically, it is a pre-packaged DML Handler that converts the changes into inserts into the change table. You indicated that you want the changes to be written to the original table, which is the default behavior of Streams replication. That is why I recommended that you use Streams directly.
    <p>
    Yes, it is possible to capture changes from a production redo/archive log at another database. This capability is called "downstream" capture in the Streams manuals. You can configure this capability using the MAINTAIN_* procedures in DBMS_STREAMS_ADM package (where * is one of TABLES, SCHEMAS, or GLOBAL depending on the granularity of change capture).
    <p>
    A couple of tips for using these procedures for downstream capture:
    <br>1) Don't forget to set up log shipping to the downstream capture database. Log shipping is setup exactly the same way for Streams as for Data Guard. Instructions can be found in the Streams Replication Administrator's Guide. This configuration has probably already been done as part of your initial CDC setup.
    <br>2) Run the command at the database that will perform the downstream capture. This database can also be the destination (or target) database where the changes are to be applied.
    <br>3) Explicitly define the parameters capture_queue_name and apply_queue_name to be the same queue name. Example:
    <br>capture_queue_name=>'STRMADMIN.STREAMS_QUEUE'
    <br>apply_queue_name=>'STRMADMIN.STREAMS_QUEUE'

  • Problem with http, can you help me about this exception(JSPX)?

    Somwone could tell me what's this http error when i try to get data from jspx aplication?
    HTTP Status 500 -
    exception
    javax.servlet.ServletException: Problem accessing the absolute URL "http://localhost:8080/livros/people.jspx". java.io.IOException: Server returned HTTP response code: 500 for URL: http://localhost:8080/livros/people.jspx
         org.apache.jasper.runtime.PageContextImpl.doHandlePageException(PageContextImpl.java:827)
         org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:763)
         org.apache.jsp.Resposta_jsp._jspService(Resposta_jsp.java:95)
         org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:105)
         javax.servlet.http.HttpServlet.service(HttpServlet.java:860)
         org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:336)
         org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:301)
         org.apache.jasper.servlet.JspServlet.service(JspServlet.java:251)
         javax.servlet.http.HttpServlet.service(HttpServlet.java:860)
         sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         java.lang.reflect.Method.invoke(Method.java:585)
         org.apache.catalina.security.SecurityUtil$1.run(SecurityUtil.java:249)
         java.security.AccessController.doPrivileged(Native Method)
         javax.security.auth.Subject.doAsPrivileged(Subject.java:517)
         org.apache.catalina.security.SecurityUtil.execute(SecurityUtil.java:282)
         org.apache.catalina.security.SecurityUtil.doAsPrivilege(SecurityUtil.java:165)
    root cause
    java.io.IOException: Server returned HTTP response code: 500 for URL: http://localhost:8080/livros/people.jspx
         sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1133)
         org.apache.taglibs.standard.tag.common.core.ImportSupport.acquireReader(ImportSupport.java:331)
         org.apache.taglibs.standard.tag.common.core.ImportSupport.acquireString(ImportSupport.java:241)
         org.apache.taglibs.standard.tag.common.core.ImportSupport.doEndTag(ImportSupport.java:158)
         org.apache.jsp.Resposta_jsp._jspx_meth_c_import_0(Resposta_jsp.java:115)
         org.apache.jsp.Resposta_jsp._jspService(Resposta_jsp.java:68)
         org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:105)
         javax.servlet.http.HttpServlet.service(HttpServlet.java:860)
         org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:336)
         org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:301)
         org.apache.jasper.servlet.JspServlet.service(JspServlet.java:251)
         javax.servlet.http.HttpServlet.service(HttpServlet.java:860)
         sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         java.lang.reflect.Method.invoke(Method.java:585)
         org.apache.catalina.security.SecurityUtil$1.run(SecurityUtil.java:249)
         java.security.AccessController.doPrivileged(Native Method)
         javax.security.auth.Subject.doAsPrivileged(Subject.java:517)
         org.apache.catalina.security.SecurityUtil.execute(SecurityUtil.java:282)
         org.apache.catalina.security.SecurityUtil.doAsPrivilege(SecurityUtil.java:165)

    Hi
    Please try looking at following lines.
    org.apache.jsp.Resposta_jsp._jspx_meth_c_import_0(Resposta_jsp.java:115)
         org.apache.jsp.Resposta_jsp._jspService(Resposta_jsp.java:68)
    and
    org.apache.jsp.Resposta_jsp._jspService(Resposta_jsp.java:95)
    This is in generated servlet file. Then try to find out in your JSP.
    HTTP Status 500 indicates an internal server error.
    HTH
    VJ

  • The product I bought its not working as i expected, it doesn´t translate the exact information from pdf to excel, how can you help me or how can you return my money back....

    how can you help me

    What about adobé export PDF. ?
    Enviado desde mi iPhone
    El 07/05/2014, a las 23:00, Claudio González <[email protected]> escribió:
    The product I bought its not working as i expected, it doesn´t translate the exact information from pdf to excel, how can you help me or how can you return my money back....
    created by Claudio González in Adobe Reader - View the full discussion
    If you bought Reader, you were swindled, because it's a free program. And it has never been able of converting PDF files to any other format.
    Please note that the Adobe Forums do not accept email attachments. If you want to embed a screen image in your message please visit the thread in the forum to embed the image at https://forums.adobe.com/message/6363992#6363992
    Replies to this message go to everyone subscribed to this thread, not directly to the person who posted the message. To post a reply, either reply to this email or visit the message page:
    To unsubscribe from this thread, please visit the message page at . In the Actions box on the right, click the Stop Email Notifications link.
    Start a new discussion in Adobe Reader by email or at Adobe Community
    For more information about maintaining your forum email notifications please go to http://forums.adobe.com/thread/416458?tstart=0.

  • HT1212 my ipad is disabled, how can I fix it . can you help me please!!!1

    can you help me about it

    How can I unlock my iPad if I forgot the passcode?
    http://www.everymac.com/systems/apple/ipad/ipad-troubleshooting-repair-faq/ipad- how-to-unlock-open-forgot-code-passcode-password-login.htmlhttp://www.everymac.com/systems/apple/ipad/ipad-troubleshooting-repair-faq/ipad- how-to-unlock-open-forgot-code-passcode-password-login.html
    iOS: Device disabled after entering wrong passcode
    http://support.apple.com/kb/ht1212http://support.apple.com/kb/ht1212
    How can I unlock my iPad if I forgot the passcode?
    http://tinyurl.com/7ndy8tbhttp://tinyurl.com/7ndy8tb
    How to Reset a Forgotten Password for an iOS Device
    http://www.wikihow.com/Reset-a-Forgotten-Password-for-an-iOS-Devicehttp://www.wikihow.com/Reset-a-Forgotten-Password-for-an-iOS-Device
    Using iPhone/iPad Recovery Mode
    http://ipod.about.com/od/iphonetroubleshooting/a/Iphone-Recovery-Mode.htmhttp://ipod.about.com/od/iphonetroubleshooting/a/Iphone-Recovery-Mode.htm
    You may have to do this several times.
    Saw this solution on another post about an iPad in a school environment. Might work on your iPad so you won't lose everything.
    ~~~~~~~~~~~~~
    ‘iPad is disabled’ fix without resetting using iTunes
    Today I met my match with an iPad that had a passcode entered too many times, resulting in it displaying the message ‘iPad is disabled – Connect to iTunes’. This was a student iPad and since they use Notability for most of their work there was a chance that her files were not all backed up to the cloud. I really wanted to just re-activate the iPad instead of totally resetting it back to our default image.
    I reached out to my PLN on Twitter and had some help from a few people through retweets and a couple of clarification tweets. I love that so many are willing to help out so quickly. Through this I also learned that I look like Lt. Riker from Star Trek (thanks @FillineMachine).
    Through some trial and error (and a little sheer luck), I was able to reactivate the iPad without loosing any data. Note, this will only work on the computer it last synced with. Here’s how:
    1. Configurator is useless in reactivating a locked iPad. You will only be able to completely reformat the iPad using Configurator. If that’s ok with you, go for it – otherwise don’t waste your time trying to figure it out.
    2. Open iTunes with the iPad disconnected.
    3. Connect the iPad to the computer and wait for it to show up in the devices section in iTunes.
    4. Click on the iPad name when it appears and you will be given the option to restore a backup or setup as a new iPad (since it is locked).
    5. Click ‘Setup as new iPad’ and then click restore.
    6. The iPad will start backing up before it does the full restore and sync. CANCEL THE BACKUP IMMEDIATELY. You do this by clicking the small x in the status window in iTunes.
    7. When the backup cancels, it immediately starts syncing – cancel this as well using the same small x in the iTunes status window.
    8. The first stage in the restore process unlocks the iPad, you are basically just canceling out the restore process as soon as it reactivates the iPad.
    If done correctly, you will experience no data loss and the result will be a reactivated iPad. I have now tried this with about 5 iPads that were locked identically by students and each time it worked like a charm.
    ~~~~~~~~~~~~~
    Try it and good luck. You have nothing more to lose if it doesn't work for you.
     Cheers, Tom

  • HT5312 I don't have a rescue email option and i want to reset the security questions , so what shall i do?? I have been trying to do so for about 2 weeks , please can you  help???

    I don't have a rescue email option and i want to reset the security questions , so what shall i do?? I have been trying to do so for about 2 weeks , please can you  help???

    You will need to contact Support in your country to get the questions reset : http://support.apple.com/kb/HT5699
    When they've been reset you can then use steps 1 to 7 half-way down the HT5312 page that you posted from to add a rescue email address for potential future use

  • I have two graphics cards in my PC . after I had to reinstall windows again has been slower pc and stuff not play 4k footage . Can you help me find out about it " Raks " graphics card has stopped working ?

    I have two graphics cards in my PC . after I had to reinstall windows again has been slower pc and stuff not play 4k footage . Can you help me find out about it " Raks " graphics card has stopped working ?

    I'm not aware of any, not to say that there aren't any issues.
    it may have nothing to do with ntpd, there are a lot of things running.
    ntpd just happen to make the log entry at the same time as the panic.
    I would check to see if there are any updates available for you system.
    if this is the first time that this has happened. it may be (pick one):
    cosmic rays
    sun spots
    the trilateral commission
    if this happens more frequently and that traces look the same, then
    there may be a real problem that needs to be looked into further.

  • Apple care i want your help . i got a new that someone stock of iphone5s about battery problem . My ip5s is decrese batterry so fast . Can you help me please? you can check to IME ? plz

    Apple care i want your help . i got a new that someone stock of iphone5s about battery problem . My ip5s is decrese batterry so fast . Can you help me please? you can check to IME ? plz

    Apple representatives don't respond to anyone in this forum. It's just user-to-user. Go here to check support options (going to Apple store, calling Apple support, etc.): https://getsupport.apple.com/ProductSelector.action

  • HT202916 what is the type A adapter? can you help to send some picture and information about it

    hi,
    my name is Xue Wenzong, the EFB manager from Xiamen Airlines from China. we find that APPLE reliese released approval for their consumer product chargers to be plugged into a 115 VAC 400 hertz receptacle, you can see this link"https://support.apple.com/en-us/HT202916", my question is what is the type A adapter? can you help to send some picture and information about it?
    thanks!
    <Email Edited by Host>

    See here: http://www.iec.ch/worldplugs/typeA.htm

  • My macbook pro 2010 extremely noisy and a warning flashed on the screen about a power or battery issue- can you help please?

    My macbook pro 2010 has started getting extremely noisy in the last few months and I had a strange warning flash up on the screen a month or so ago about a power or battery issue… can you help please?

    Calibrating a 2010 MBP is not required.  All it will achieve is putting an unnecessary cycle on it and shortening its life:
    http://support.apple.com/kb/ht1490
    You may try a SMC reset:
    http://support.apple.com/kb/HT3964
    Open System Information>Power and post the following from your MBP:
    (Make certain that the charger is connected)
    Ciao.

  • When I first load Firefox, it comes up with an error message about "script". Can you help me?

    <blockquote>Locking duplicate thread.<br>
    Please continue here: [[/questions/846741]]</blockquote>
    I just double click on the Icon, and it seems it takes forever to load.
    After this action, an error message comes up with a statement that it is trying to read some sort of script. Next it tells me to press continue to go ahead. At this time, it loads up normally. Can you help?

    This issue can be caused by an extension that isn't working properly.
    Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).
    *Don't make any changes on the Safe mode start window.
    *https://support.mozilla.com/kb/Safe+Mode
    *https://support.mozilla.com/kb/Troubleshooting+extensions+and+themes

  • Yesterday, as today's deadline for filing tax returns approached, I was paralyzed by the inability to create new IRS PDF forms and to retrieve archived ones from a year ago. My computer went crazy. 24 hours later, I am still paralyzed. Can you help?

    My computer went crazy yesterday on two occasions involving PDF documents. One dealt with attachments to an email from a bona fide corporation. The other dealt with IRS PDF forms & schedules needed for today's submission.
    As both dealt with PDF and had nothing else in common, I suspected my PC had a virus. When I asked a local store technician, he agreed. I turned to Norton, which protects my PC from viruses, and after a few hours of really thorough searching, the computer was found to have no viruses.
    Before describing what I call "crazy" computer behavior, you need to know that I have long had IE8 as my default browser but a few weeks ago switched to Mozilla Firefox because IE8 had beome incompatible with some websites from which I get information.
    When I received the email from AT&T email service and clicked the first of four icons representing attachments, there was figuratively an explosion on my monitor: a series of new tabs, each called New Tab, burst onto the monitor--but no text or picture. The new tabs appeared faster than I coul kill them. I finally decided just to shut down the computer, hoping they would not reappear when I restarted. I was wrong. After 2 repeats, I decided to forget about the attachments and asked the sender to send them to me by regular mail.
    That was no solution for my IRS PDFs. I wanted to complete filling in the various forms and schedules that I had begun months ago so that I could mail them today to the IRS (without having to copy them all in ink). When I tried to open the first one, BOOM. The same thing happened: the blizzard of New Tabs atop blank pages; my IRS form or schedule did not show up. Did the same shutdown/restart routine with the same results.
    When I looked at the list of current forms that had to be completed, I noticed something very strange: the icons that began the listing of the documents' names were replaced one by one by Mozilla icons. When I moused over them, they said Firefox HTML. Why?
    Starting the day today, I had the same experience. What's more, when I started to retrieve 2012 IRS PDFs from a year ago, the same New Tab tabs appeared and had to be killed, and Mozilla icons replaced whatever icon was there before.
    Assuming that the problem arose with Adobe Reader's reading of the PDFs, I contacted Adobe but got no helpful phone number because PDFs are a free service and was directed to use this Forum to get help.
    What do I have to do to (a) read and use PDFs in the normal way and (b) remove the Mozilla icon from those that have appeared on icon documents. If Mozilla is the source of the problem, shall I go back to IE8? (In my 80s, I want eventually to replace my old computer but for the time being I must continue using it. It will not take an IE9. Anther possible default browser would be Google Chrome, but I have unfavorable impressions of it because of its intrusiveness, loading my PC with stuff I do not need.
    Can you help?

    The problem is absolutely not Reader. The problem is that FireFox has stepped in front of Reader and handles all the PDF stuff - wrongly in your case. FireFox is DESIGNED to take over PDF files. But it is not capable of doing IRS forms!
    To start with go back to IE for these forms. When you save them to disk DO NOT DOUBLE CLICK ON THEM until this is fixed. Just open the in the normal way - start Adobe Reader and use Open from the File menu.

  • Can you help me with this ( vlan,accesslist,management )

    here's the scenario I have two vlan 10 & 20
    I have 2 switch and 1 router
    the target of this setup is that vlan 10 can ping or reach vlan 20 but vlan 20 cannot be reach or ping vlan 10 it is that possible
    Here's the setup
    In SW0
    vlan 10
    name Management
    interface FastEthernet0/1
    switchport access vlan 10
    switchport mode access
    interface FastEthernet0/2
    switchport trunk allowed vlan 10
    switchport mode trunk
    In SW1
    interface FastEthernet0/1
    switchport trunk allowed vlan 20
    switchport mode trunk
    interface FastEthernet0/2
    switchport access vlan 20
    switchport mode access
    interface FastEthernet0/3
    switchport access vlan 20
    switchport mode access
    In Router
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 192.168.10.1 255.255.255.0
    ip access-group 1 out
    interface FastEthernet0/0.20
    no ip address
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    interface FastEthernet0/1.20
    encapsulation dot1Q 20
    ip address 192.168.20.1 255.255.255.0
    ip access-group 1 out
    interface Vlan1
    no ip address
    shutdown
    ip classless
    access-list 1 deny 192.168.20.0 0.0.0.255
    access-list 1 permit 192.168.10.0 0.0.0.255
    access-list 1 deny host 192.168.20.11
    access-list 1 permit host 192.168.10.11
    access-list 1 deny any
    access-list 1 permit any
    Im new so i dont know if my setup is correct ...
    can any1 help me about this,,,
    thanks.

    Hi,
    let's suppose PC0(Vlan 10) wants to communicate with PC1(Vlan 20):
    -traffic enters f0/0.10 with src 10.11 and dst 20.11 and it is forwarded out f0/1.20 where there is an egress ACL
    -this is a standard ACL so it matches on source only and there is a hit for second entry permit 192.168.10.0 0.0.0.255
    -now PC1 replies and traffic enters f0/1.20 and is forwarded out f0/0.10 where there is egress ACL
    -there is a hit on first entry  deny 192.168.20.0 0.0.0.255( packet src is 20.11 and dst 10.11)
    So end result is that Vlan 10 cannot reach Vlan 20.
    I don't think this is what you wanted
    Now of course traffic sourced from any PC in Vlan 20 destined to PC0 is filtered as you wanted because  it is filtered on f0/0.10 outbound as above.
    ACLs are stateless and communication in TCP/IP is bidirectional so the best way to achieve what you want to do if you want to filter more than Pings would be to use CBAC or ZBF or reflexive ACLs
    Regards
    Alain
    Don't forget to rate helpful posts.

  • Can you help me explain this crash log?

    My system just crashed, but I don't understand why. Here is the log from the event viewer. What can you tell me about this?
    Log Name:      System
    Source:        Microsoft-Windows-Kernel-Power
    Date:          2/6/2014 3:38:39 PM
    Event ID:      41
    Task Category: (63)
    Level:         Critical
    Keywords:      (2)
    User:          SYSTEM
    Computer:      MYPC
    Description:
    The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-Kernel-Power" Guid="{331C3B3A-2005-44C2-AC5E-77220C37D6B4}" />
        <EventID>41</EventID>
        <Version>2</Version>
        <Level>1</Level>
        <Task>63</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000000002</Keywords>
        <TimeCreated SystemTime="2014-02-06T21:38:39.748002200Z" />
        <EventRecordID>30668</EventRecordID>
        <Correlation />
        <Execution ProcessID="4" ThreadID="8" />
        <Channel>System</Channel>
        <Computer>MYPC</Computer>
        <Security UserID="S-1-5-18" />
      </System>
      <EventData>
        <Data Name="BugcheckCode">0</Data>
        <Data Name="BugcheckParameter1">0x0</Data>
        <Data Name="BugcheckParameter2">0x0</Data>
        <Data Name="BugcheckParameter3">0x0</Data>
        <Data Name="BugcheckParameter4">0x0</Data>
        <Data Name="SleepInProgress">false</Data>
        <Data Name="PowerButtonTimestamp">0</Data>
      </EventData>
    </Event>

    We do need the actual DMP file as it contains the only record of the sequence of events leading up to the crash, what drivers were loaded, and what was responsible.  
    We prefer at least 2 DMP files to spot trends and confirm the cause.
    Please follow our instructions for finding and uploading the files we need to help you fix your computer. They can be found here
    If you have any questions about the procedure please ask
    Wanikiya and Dyami--Team Zigzag

  • Can you help me interpret the following lines in UPDATE rule?

    Hi,
    Can you help me interpret the following lines in UPDATE rule?
    1. What is the role of role of u201CCHANGING RESULT.u201D and u201CCHANGING lc_local_value.u201D?
    2. What is the role of the CALL FUNCTION 'CONVERT_TO_LOCAL_CURRENCY', in particular the Exporting and Importing parts?
    3. Can I say that u201CCOMM_STRUCTURE-ORDER_VALu201D in the subroutine is passed to u201Clc_document_valueu201D in the u201CFORM loc_curr_convertu201D; and further passed to u201Cforeign_amountu201D in the u201CCALL FUNCTION 'CONVERT_TO_LOCAL_CURRENCY'u201D?
    4. Finally, what becomes of my original u201CActual Goods receipt quantityu201D( 0GR_QTY ) which I am writing the routine for? I donu2019t see any where in the code that it is being referred to? Do any of these codes affect the value of 0GR_QTY?
    5. Also, if there are 3 different subroutines in the INCLUDE and I am making the change described in #4 above, how do I know which of the 3 subroutines to call?
    ===============================
    ===============================
    So I am reviewing a transfer routine in for u201CActual Goods receipt quantityu201D and routine an INCLUDE statement: INCLUDE RS_BCT_MM_UPDATE_RULES.
    The update rule also includes the following properties to run the following subroutine in the Include:
    IF u2026..
    perFORM LOC_CURR_CONVERT
               USING    COMM_STRUCTURE-ORDER_VAL
                        COMM_STRUCTURE-DOC_DATE
                        COMM_STRUCTURE-ORDER_CURR
                        COMM_STRUCTURE-LOC_CURRCY
                        COMM_STRUCTURE-EXCHG_RATE
               CHANGING RESULT.
    I verified in the INCLUDE (RS_BCT_MM_UPDATE_RULES) and the subroutine is as follows:
    FORM loc_curr_convert
      USING    lc_document_value
               lc_date
               lc_document_currency
               value(lc_local_currency)
               lc_rate
      CHANGING lc_local_value.
    conversion of lc_rate from floating-point to decimal. Necessary for *
    call of CONVERT_TO_LOCAL_CURRENCY.
    data lc_rate_dec type p decimals 5.
    lc_rate_dec = lc_rate.
      IF lc_document_currency = lc_local_currency
      no conversion necessary -> Main case 1
        AND NOT ( lc_document_currency IS INITIAL
               OR lc_local_currency IS INITIAL ) .
        lc_local_value = lc_document_value.
      ELSEIF NOT ( lc_document_currency IS INITIAL
      OR lc_local_currency IS INITIAL OR lc_date IS INITIAL ) .
      conversion necessary with lc_date -> Normally not possible
        CALL FUNCTION 'CONVERT_TO_LOCAL_CURRENCY'
          EXPORTING
            date                 = lc_date
            foreign_amount       = lc_document_value
            foreign_currency     = lc_document_currency
            local_currency       = lc_local_currency
            rate                 = lc_rate_dec
          IMPORTING
          EXCHANGE_RATE        =
            local_amount         = lc_local_value
          EXCEPTIONS
            NO_RATE_FOUND        = 1
            OVERFLOW             = 2
            NO_FACTORS_FOUND     = 3
            NO_SPREAD_FOUND      = 4
            DERIVED_2_TIMES      = 5.
        IF sy-subrc NE 0.
      message a802 with lc_date lc_document_currency lc_local_currency
                        sy-subrc.
        ENDIF.
      ELSE.
      if conversion not possible -> assign target values
        lc_local_value = lc_document_value.
        lc_local_currency = lc_document_currency.
      ENDIF.
    ENDFORM.

    HI,
    Thanks so much the explanations.
    I just verified again on our dev system and the update rule for 0GR_QTY (Actual goods receipt quantity) include the following:
        perFORM QUANTITY_CONVERT
           USING    COMM_STRUCTURE-CPQUAOU
                    COMM_STRUCTURE-po_UNIT
                    COMM_STRUCTURE-base_uom
                    COMM_STRUCTURE-numerator
                    COMM_STRUCTURE-denomintr
           CHANGING RESULT
    Now, in the include, I also found:
    FORM QUANTITY_CONVERT
      USING    QC_SOURCE_VALUE
               QC_SOURCE_UNIT
               VALUE(QC_TARGET_UNIT)
               QC_UMREZ
               QC_UMREN
      CHANGING QC_TARGET_VALUE.
    i.  Does it mean it actually does quantity conversion?
    ii. If you have access to the INCLUDE I will appreciate some hints on what the subroutine QUANTITY_CONVERT is doing. It does not appear do to be saying anything about quantity conversion; but it is supposed to be doing something with the parameters being passed from the update routine.
    iii. In your response to #5, after all the computation in the INCLUDE, what comes back to the Update rule  i.e. what comes back to become the value of 0GR_QTY?
    Is it the u201CRESULT.u201D in the update rule or u201CQC_TARGET_VALUE.u201D in the subroutine in the INCLUDE.
    iv. So, am to create an Update rule for 0PSTNG_DATE and the source is BUDAT; and I need to write a routine using the include INCLUDE RS_BCT_MM_UPDATE_RULES.
    I looked through the INCLUDE and identified all the subroutines in this INCLUDE as follows:
    QUANTITY_CONVERT
    LOC_CURR_CONVERT
    GET_WEEK
    WEEK_DAY
    QUARTER_DAY
    --Does it mean that to use this subroutine, I can only use the USING parameters of one of these listed subroutines?
    --Also, does it mean that because 0PSTNG_DATE is a date, I can only use one of
    GET_WEEK
    WEEK_DAY
    QUARTER_DAY
    --Or, are there other includes to be used for 0PSTNG_DATE
    Thanks

Maybe you are looking for