Classpath setting "unable to access jarfile"

Hi
when i run $java -jar batik-squiggle.jar the error message on screen is
"unable to acces jarfile batik-squiggle.jar" and the path of the jar file is edited with the $CLASSPATH variable in the ~/.bash_profile
if i execute $java -jar /usr/share/batik-1.7/batik-squiggle.jar there is not problem
if i execute $java -cp /usr/share/batik-1.7/batik-squiggle.jar -jar batik-1.7.jar the error message is the above one.
the java virtual machine is sun jdk6
the application file is
-rw-r--r-- 1 root root 553671 2008-01-06 11:11 /usr/share/batik-1.7/batik-squiggle.jar
This is the content of batik-squiggle.jar file about Main-Class paremeter in the MANIFEST.MF file
root@izar:/usr/share/batik-1.7# jar xf batik-squiggle.jar META-INF/MANIFEST.MF && cat META-INF/MANIFEST.MF | grep Main-Class | awk '{ print $2}'
org.apache.batik.apps.svgbrowser.Main
root@izar:/usr/share/batik-1.7# jar tf batik-squiggle.jar | grep org/apache/batik/apps/svgbrowser/Main.class
org/apache/batik/apps/svgbrowser/Main.class
This is my .bash_profile file content
#Fichero de configuración que se ejecuta al:
# entrar en SESION y
# al ejecutar source ~/.bash_profile
#configuracion de imagemagick . /usr/bin ya esta en el path
export MAGICK_HOME="$HOME/imagemagick"
export LD_LIBRARY_PATH="/usr/lib"
#Configuración del PATH para:
#java,xmlmind editor
export PATH=$PATH:$JAVA_HOME/bin:/usr/share/xxe-perso-4_5_0/bin
#instalacion de la maquina virtual java-6-sun
#configuración de JAVA_HOME
export JAVA_HOME="/usr/lib/jvm/java-6-sun"
export JAR_HOME="/usr/share/java"
#configuracion de la validacion de documentos xml con saxon
export CLASSPATH=.:$JAVA_HOME/lib/tools.jar:$JAR_HOME/saxon.jar:$JAR_HOME/docbook-xsl-saxon.jar:$JAR_HOME/xercesImpl.jar
#configuracion para batik:
export CLASSPATH=$CLASSPATH:/usr/share/batik-1.7/batik-squiggle.jar
#configuración para xalan
export CLASSPATH=$CLASSPATH:$JAR_HOME/xalan2.jar:$JAR_HOME/xml-apis.jar:$JAR_HOME/docbook-website-xalan2.jar
#configuración para fop
export CLASSPATH=$CLASSPATH:$JAR_HOME/fop.jar:$JAR_HOME/avalon-framework.jar:$JAR_HOME/batik.jar:$JAR_HOME/commons-io.jar:$JAR_HOME/commons-logging.jar:$JAR_HOME/jai_core.jar:$JAR_HOME/jai_codec.jar:$JAR_HOME/fop-hyph.jar:$JAR_HOME/serializer.jar:$JAR_HOME/xmlgraphics-commons.jar
#configuracion para los samples de xeres apache. Synaptic no instala xercesSamples.jar
export CLASSPATH=$CLASSPATH:$JAR_HOME/xerces.jar:/usr/share/xerces-1_4_4/xercesSamples.jar
so the $CLASSPATH is ok no?
Whats the configuration error?
THANKS IN ADVANCE

c_aramburu wrote:
Hi
when i run $java -jar batik-squiggle.jar the error message on screen is
"unable to acces jarfile batik-squiggle.jar" and the path of the jar file is edited with the $CLASSPATH variable in the ~/.bash_profileThe CLASSPATH doesn't locate .jar files. It locates +.class+ files, usually inside .jar files. java -jar needs the full path name of the .jar file.

Similar Messages

  • AIRSDK update mxmlc Unable to access jarfile /../lib/mxmlc-cli.jar

    I have just updated the Flash Builder AIRSDK to 17, and now when I try to compile from the command line I get this error.
    usage: dirname path
    Unable to access jarfile /../lib/mxmlc-cli.jar
    Instead if I use the previous versions of the AIRSDK which I saved as a backup the mxmlc is working perfectly.
    Does anybody know how to solve this issue?

    Answering my own question.
    When the Adobe AIRSDK is installed by root in a common location such as /usr/local the result is that the SDK does not work without adjusting some bad permissions that were present in the tarball.
    The top AIRSDK tarball installation directory has permissions 700 which locks everyone but root out.
    The adt.jar file in lib has permissions 700 as well which means it cannot be launched by anyone but root since root installed the tarball.
    Once I fixed these permission problems then everything worked.
    $ su -
    # cd [AIRSDK install directory]
    # chmod -R go+rx *

  • Launchd unable to access jarfile

    I have a script which runs the following command:
    java -jar j2ee/home/oc4j.jar
    This works fine when I run it manually, but now I want it to be run under launchd at startup. The script runs, but gives me the following error:
    Unable to access jarfile j2ee/home/oc4j.jar
    What does the permission/ownership have to be to get this file to run or is it something else?

    Okay, I've actually figured out that launchd runs the script in the root directory so that if I put in the full path from root, it will run the jar file. However this acutally then messes up the jar file since all of the paths it uses are made relative to root as well. So I wanted to change the directory everything runs in and tried:
    <key>RootDirectory</key>
    <string>/Applications/oc4j/</string>
    but that does not seem to work. How can I get launchd to run the script in the specified directory?

  • Unable to access jarfile

    Hi,
    I've installed Saxon and JRE on winnt:
    java -version
    java -versionjava version "1.4.2_08"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_08-b03)
    Java HotSpot(TM) Client VM (build 1.4.2_08-b03, mixed mode)
    Exit code: 0and have set the system's environment variable classpath to:
    CLASSPATH C:\Programme\Saxon\saxon8.jar
    Now, if I start the application without the full path, I get
    java -jar saxon8.jar
    java -jar saxon8.jarUnable to access jarfile saxon8.jar
    Exit code: 1But with the fully qualified jar file, it works fine, e.g.:
    java -jar C:\Programme\Saxon\saxon8.jar
    java -jar C:\Programme\Saxon\saxon8.jarNo source file name
    Saxon 8.4 from Saxonica
    ... some more output ...
    Exit code: 2What did I miss?
    Best regards, Manfred Staudinger, Vienna

    But it still neccessary to specify the jarfile in the classpath and why?
    "When running Saxon, the principal JAR file should be on the class path. The class path is normally represented by an environment variable named CLASSPATH: see your Java documentation for details. Note that the JAR file itself (not the directory that contains it) should be named on the class path."
    http://www.saxonica.com/documentation/documentation.html (see Installation)
    Manfred

  • Please help! I'm unable to access content on my iPod Classic while it is connected to iTunes. The iPod itself shows up and is set to manual management, but I am unable to view or play any of the content on it (music, movies, podcasts etc.).

    I'm unable to access content on my iPod Classic while it is connected to iTunes.
    The iPod itself shows up and is set to manual management, but I am unable to view or play any of the content on it (music, movies, podcasts etc.).
    I can click the tabs Music, Movies etc. but I can't see anywhere to access the files themselves, no music or movies are listed, I only have the option to 'Sync' with the iTunes, which I don't want to do as there is no content on the iTunes!!! 
    I just downloaded the iTunes program.
    Very confused, pleaseee help ...

    Here is what worked for me:
      My usb hub, being usb2, was too fast. I moved the wire to a usb port directory on my pc. That is a usb1 port which is slow enough to run your snyc.

  • Unable to access application set in admin console after upgrade to 7.0 M

    Hi Experts
    I am unable to access the Application Set through BPC Administration after upgrading our development server to version 7.0 SP3. I followed the instructions as per the Upgrade guide, and there was no issues during the installation. But when trying to access the application set i receive the following error message on step 9  ( 9/10) of during the connection.
    Error message: Subquery returned more than 1 value. This is not
    permitted when the subquery follows =, !=, <, <= , >, >= or when the
    subquery is used as an expression.
    I have done all of the steps outlined as per SAP Note 1242962, but i still receive the error message. I tried to do a SQL Profiler trace, but i have been unable to find the query which returns more than one record.
    Any help is appreciated
    Kind Regards
    Daniel

    Interesting that you ask about upgrade vs uninstall/reinstall.
    We were running BPC 5.1
    We have also re-installed the Admin client to be the new version.
    We have been working with an outside consulting firm to manage our system upgrade/install.
    Our dev and qa environments were uninstalled then reinstalled.
    When we went to production, our system was intially upgraded.  I do not know why this route was chosen when that was not what was completed on dev/qa.  On our production 'upgrade', we are still working through issues. We then uninstalled iis, sqlserver reporting services, both .net 1.1 and 2.0, and the BPC application. Then reinstall everything and we were getting the same errors. 
    Our error was at Progress 10/10 Create Database Schema and check Application server collation.
    Error Message: Object Reference not set to an instance of an object.
    We are able to access the appShell and test copies of the appShell, we were not able to access any custom appSets which were created prior to the upgrade, nor are we able to access any appSets that were created as a copy of the custom appSet after the upgrade.
    When logged with SAP, we were directed toward note Note 1331040 - Cannot log into 7M Admin console after restore from version5 noting that we needed to do the following changes:
    Note that you will need to change the following:
    INSERT INTO tblDefaults VALUES ('_GLOBAL','Prev_AppSet_Version','','','7.0.112')
    INSERT INTO tblDefaults VALUES ('_GLOBAL','Curr_AppSet_Version','','','7.0.112')
    to
    INSERT INTO tblDefaults VALUES ('_GLOBAL','Prev_AppSet_Version','','','7.0.113')
    INSERT INTO tblDefaults VALUES ('_GLOBAL','Curr_AppSet_Version','','','7.0.113')
    The reason is because '7.0.113' means 7 MS SP04 while '7.0.112' means SP03.
    There are 8 steps in this note, for us, only the first 2 were needed. I have asked SAP to create new note/update existing accordingly.
    With the table entry, we were able to successfully access our app set.
    Hope our experiences can help you out.
    Thanks,
    Becky Zick

  • HT1267 HAVE SET UP AN INCORRECT EMAIL ADDRESS. The call centre set up a new email address as the Username. I am unable to access the new account because the default on my phone is the email that is incorrect. How do I get the correct email as default

    I HAVE SET UP AN INCORRECT EMAIL ADDRESS. The call centre set up a new email address as the Username. I am unable to access the new account because the default on my phone is the email that is incorrect. How do I get the correct email as default??

    Thank you for your help, much appreciated
    Regards
    Geoff

  • TS2621 Since my setting were updated I have been unable to access my emails. Any ideas why?

    My setting were updated yesterday and since then I have been unable to access my emails. Any ideas why this has happened and how I can resolve the problem? I have checked my settings and they are all fine.

    Since your settings were updated? Do you mean the iOS? Try this.
    Quit the mail app completely. Go to the home screen first by tapping the home button. Double tap the home button and the task bar will appear with all of your recent/open apps displayed at the bottom. Tap and hold down on any app icon until it begins to wiggle. Tap the minus sign in the upper left corner of the app that you want to close. Tap the home button or anywhere above the task bar.
    Launch the mail app again.

  • Unable to Access BI InfoSet in Crystal Reports using SAP Info sets driver

    Hi,
    I am looking to develop a report on top of BI InfoSet in Crystal Reports. However using the the SAP InfoSets driver I am only able to visualize 'Classic InfoSet' and 'SAP Query'. It does not show the option to import the regular InfoSet as a datasource. I am unable to access the InfoSet built by the db join on InfoCubes that is available in SAP BW System.
    Can anybody help.
    Thanks,
    Amogh

    Hi all,
    i know this discussion is abaout 2 years old, but i faced a similar problem. I try to get access to the regular InfoSets (SQ02) within a direct connection between SAP and Crystal Reports. Which components and tools did i need to get a connection?
    look here: http://scn.sap.com/thread/3365060
    Thanx for your help!
    Best Regards
    David

  • Unable to access applications in workspace,shared services

    Hi ,
    I am Unable to access applications in workspace and shared services on EPM 11.1.1.3. It happened after normal shutdown/startup scripts were run.
    But when I reconfigure the Weblogic web server and run the services again I can access the applications.This is happening frequently now.
    Is this anything related to user profiles on the server as we are migrating these to other server.
    Can any one help me with this .
    Please find the Shared services log below:
    <22-Oct-2010 10:25:19 o'clock BST> <Notice> <WebLogicServer> <BEA-000395> <Following extensions directory contents added to the end of the classpath:
    D:\bea\weblogic92\platform\lib\p13n\p13n-schemas.jar;D:\bea\weblogic92\platform\lib\p13n\p13n_common.jar;D:\bea\weblogic92\platform\lib\p13n\p13n_system.jar;D:\bea\weblogic92\platform\lib\wlp\netuix_common.jar;D:\bea\weblogic92\platform\lib\wlp\netuix_schemas.jar;D:\bea\weblogic92\platform\lib\wlp\netuix_system.jar;D:\bea\weblogic92\platform\lib\wlp\wsrp-common.jar>
    <22-Oct-2010 10:25:21 o'clock BST> <Info> <WebLogicServer> <BEA-000377> <Starting WebLogic Server with BEA JRockit(R) Version R27.4.0-90_CR358515-94243-1.5.0_12-20080118-1154-windows-ia32 from BEA Systems, Inc.>
    <22-Oct-2010 10:25:25 o'clock BST> <Info> <Management> <BEA-141107> <Version: WebLogic Server 9.2 MP3 Mon Mar 10 08:28:41 EDT 2008 1096261 >
    <22-Oct-2010 10:25:29 o'clock BST> <Emergency> <Management> <BEA-141151> <The admin server could not be reached at http://localhost:7001.>
    <22-Oct-2010 10:25:29 o'clock BST> <Info> <Configuration Management> <BEA-150018> <This server is being started in managed server independence mode in the absence of the admin server.>
    <22-Oct-2010 10:25:29 o'clock BST> <Info> <WebLogicServer> <BEA-000215> <Loaded License : D:\bea\license.bea>
    <22-Oct-2010 10:25:29 o'clock BST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to STARTING>
    <22-Oct-2010 10:25:29 o'clock BST> <Info> <WorkManager> <BEA-002900> <Initializing self-tuning thread pool>
    <22-Oct-2010 10:25:30 o'clock BST> <Notice> <Log Management> <BEA-170019> <The server log file D:\Hyperion\deployments\WebLogic9\servers\SharedServices9\logs\SharedServices9.log is opened. All server side log events will be written to this file.>
    <22-Oct-2010 10:25:47 o'clock BST> <Notice> <Security> <BEA-090082> <Security initializing using security realm myrealm.>
    <22-Oct-2010 10:25:57 o'clock BST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to STANDBY>
    <22-Oct-2010 10:25:57 o'clock BST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to STARTING>
    log dir isD:\Hyperion\logs\SharedServices9
    urlManifest zip:D:/Hyperion/deployments/temp/servers/SharedServices9/tmp/_WL_user/interop/tthmcu/war/WEB-INF/lib/interop-mmc.jar!/META-INF/MANIFEST.MF
    Shared Services Version: 11.1.1.3.24
    Shared Services Drop Number: 6
    Attempting to verify the database configuration
    Attempting to verify the database configuration
    Database configuration test passed.
    22 Oct 2010 10:26:38 - org.apache.slide.common.Domain - INFO - Auto-Initializing Domain
    22 Oct 2010 10:26:38 - org.apache.slide.common.Domain - INFO - Configuration found in classpath
    22 Oct 2010 10:26:38 - org.apache.slide.common.Domain - INFO - Domain configuration : {org.apache.slide.lock=true, org.apache.slide.versioncontrol=true, org.apache.slide.debug=false, org.apache.slide.search=true, org.apache.slide.security=true, org.apache.slide.urlEncoding=UTF-8, org.apache.slide.domain=D:/Hyperion/deployments/WebLogic9/SharedServices9/config/Domain.xml}
    configURL: file:///D:/Hyperion/deployments/WebLogic9/SharedServices9/config/CSS.xml
    Done initialize: com.hyperion.css.CSSAPIImpl@283baf
    connection pool registered:dbcpPool-org.apache.commons.pool.impl.GenericObjectPool@27efaa
    connection pool registered:dbcpPool-org.apache.commons.pool.impl.GenericObjectPool@454a3b
    CMSOfflineServlet Initialized
    Adding audit listener
    Shared Services Initialized Successfully
    <22-Oct-2010 10:26:56 o'clock BST> <Warning> <Log Management> <BEA-170011> <The LogBroadcaster on this server failed to broadcast log messages to the admin server. The Admin server may not be running. Message broadcasts to the admin server will be disabled.>
    <22-Oct-2010 10:26:56 o'clock BST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to ADMIN>
    <22-Oct-2010 10:26:56 o'clock BST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to RESUMING>
    <22-Oct-2010 10:26:57 o'clock BST> <Notice> <Security> <BEA-090171> <Loading the identity certificate and private key stored under the alias hyperion from the jks keystore file D:\hyperion_SSL_Repository\hyperion.jks.>
    <22-Oct-2010 10:26:58 o'clock BST> <Notice> <Security> <BEA-090169> <Loading trusted certificates from the jks keystore file D:\bea\JROCKI~1\jre\lib\security\cacerts.>
    <22-Oct-2010 10:26:58 o'clock BST> <Notice> <Server> <BEA-002613> <Channel "DefaultSecure" is now listening on 10.86.57.43:28443 for protocols iiops, t3s, ldaps, https.>
    <22-Oct-2010 10:26:58 o'clock BST> <Notice> <Server> <BEA-002613> <Channel "DefaultSecure[1]" is now listening on 10.87.248.108:28443 for protocols iiops, t3s, ldaps, https.>
    <22-Oct-2010 10:26:58 o'clock BST> <Notice> <Server> <BEA-002613> <Channel "DefaultSecure[2]" is now listening on 127.0.0.1:28443 for protocols iiops, t3s, ldaps, https.>
    <22-Oct-2010 10:26:58 o'clock BST> <Warning> <Server> <BEA-002611> <Hostname "127.0.0.1", maps to multiple IP addresses: 10.86.57.43, 10.87.248.108, 127.0.0.1>
    <22-Oct-2010 10:26:58 o'clock BST> <Warning> <Server> <BEA-002611> <Hostname "LGWHYPWEB.uk.baa.com", maps to multiple IP addresses: 10.86.57.43, 10.87.248.108, 127.0.0.1>
    <22-Oct-2010 10:26:58 o'clock BST> <Notice> <WebLogicServer> <BEA-000358> <Started WebLogic Independent Managed Server "SharedServices9" for domain "WebLogic9" running in Production Mode>
    <22-Oct-2010 10:26:58 o'clock BST> <Warning> <Server> <BEA-002611> <Hostname "LGWWEB026.uk.baa.com", maps to multiple IP addresses: 10.86.57.43, 10.87.248.108, 127.0.0.1>
    <22-Oct-2010 10:26:58 o'clock BST> <Warning> <JMX> <BEA-149510> <Unable to establish JMX Connectivity with the Adminstration Server AdminServer at <JMXServiceURL:null>.>
    <22-Oct-2010 10:26:58 o'clock BST> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to RUNNING>
    <22-Oct-2010 10:26:58 o'clock BST> <Notice> <WebLogicServer> <BEA-000360> <Server started in RUNNING mode>
    <22-Oct-2010 10:27:08 o'clock BST> <Warning> <Security> <BEA-090475> <Plaintext data for protocol HTTP was received from peer LGWHYPWEB.uk.baa.com - 10.86.57.43 instead of an SSL handshake.>
    <22-Oct-2010 10:28:36 o'clock BST> <Warning> <Security> <BEA-090475> <Plaintext data for protocol HTTP was received from peer lgwdbs026.uk.baa.com - 10.86.41.33 instead of an SSL handshake.>
    22-Oct-2010 10:28:38, /files, HEAD, 401 "Unauthorized", 125 ms, %v
    22-Oct-2010 10:28:38, /files, HEAD, 200 "OK", 266 ms, %v
    22-Oct-2010 10:28:40, /files, HEAD, 401 "Unauthorized", 16 ms, %v
    22-Oct-2010 10:28:41, /files, HEAD, 200 "OK", 94 ms, %v
    22-Oct-2010 10:28:42, /files, HEAD, 401 "Unauthorized", 0 ms, %v
    22-Oct-2010 10:28:42, /files, HEAD, 200 "OK", 93 ms, %v
    22-Oct-2010 10:28:43, /files, HEAD, 401 "Unauthorized", 0 ms, %v
    22-Oct-2010 10:28:43, /files, HEAD, 200 "OK", 94 ms, %v
    22-Oct-2010 10:28:44, /files, HEAD, 401 "Unauthorized", 0 ms, %v
    22-Oct-2010 10:28:44, /files, HEAD, 200 "OK", 78 ms, %v
    22-Oct-2010 10:28:45, /files, HEAD, 401 "Unauthorized", 0 ms, %v
    22-Oct-2010 10:28:45, /files, HEAD, 200 "OK", 93 ms, %v
    22-Oct-2010 10:28:47, /files, HEAD, 401 "Unauthorized", 0 ms, %v
    22-Oct-2010 10:28:47, /files, HEAD, 200 "OK", 78 ms, %v
    22-Oct-2010 10:28:48, /files, HEAD, 401 "Unauthorized", 0 ms, %v
    22-Oct-2010 10:28:48, /files, HEAD, 200 "OK", 78 ms, %v
    <22-Oct-2010 10:29:40 o'clock BST> <Warning> <Security> <BEA-090475> <Plaintext data for protocol HTTP was received from peer lgwapp026.uk.baa.com - 10.86.51.104 instead of an SSL handshake.>
    <22-Oct-2010 10:30:16 o'clock BST> <Warning> <Security> <BEA-090475> <Plaintext data for protocol HTTP was received from peer lgwapp026.uk.baa.com - 10.86.51.104 instead of an SSL handshake.>
    <22-Oct-2010 10:32:25 o'clock BST> <Warning> <Security> <BEA-090475> <Plaintext data for protocol HTTP was received from peer LGWHYPWEB.uk.baa.com - 10.86.57.43 instead of an SSL handshake.>
    22-Oct-2010 10:32:43, /files, HEAD, 401 "Unauthorized", 0 ms, %v
    22-Oct-2010 10:32:43, /files, HEAD, 200 "OK", 78 ms, %v
    22-Oct-2010 10:32:44, /files, HEAD, 401 "Unauthorized", 0 ms, %v
    22-Oct-2010 10:32:44, /files, HEAD, 200 "OK", 63 ms, %v
    22-Oct-2010 10:32:45, /files, HEAD, 401 "Unauthorized", 0 ms, %v
    22-Oct-2010 10:32:45, /files, HEAD, 200 "OK", 63 ms, %v
    <22-Oct-2010 10:32:46 o'clock BST> <Warning> <Security> <BEA-090475> <Plaintext data for protocol HTTP was received from peer LGWHYPWEB.uk.baa.com - 10.86.57.43 instead of an SSL handshake.>
    <22-Oct-2010 10:34:00 o'clock BST> <Warning> <Security> <BEA-090475> <Plaintext data for protocol HTTP was received from peer LGWHYPWEB.uk.baa.com - 10.86.57.43 instead of an SSL handshake.>
    <22-Oct-2010 10:35:28 o'clock BST> <Warning> <Security> <BEA-090475> <Plaintext data for protocol HTTP was received from peer LGWHYPWEB.uk.baa.com - 10.86.57.43 instead of an SSL handshake.>
    log dir isD:\Hyperion\logs\SharedServices9
    urlManifest zip:D:/Hyperion/deployments/temp/servers/SharedServices9/tmp/_WL_user/interop/tthmcu/war/WEB-INF/lib/interop-mmc.jar!/META-INF/MANIFEST.MF
    Shared Services Version: 11.1.1.3.24
    Shared Services Drop Number: 6
    Populating Application Info
    Getting LCM callback info from Registry for product: HUB
    LCM Callback: https://LGWWEB026.uk.baa.com:28443/interop/framework/lcm/HSSMigration
    Populating Product Info
    Thanks in advance
    Edited by: 790426 on 25-Oct-2010 06:17

    You must first check if you have configured the web server to include the hfm/planning products.
    Then you can refer to the thread below:
    Not able to see Consolidation Administration
    The latter definitely applies to version 9.3.1, but it could be helpful.

  • Unable to access jar file error !

    hello,
    i have built my netbeans project and obtained the hequalifies.jar file . unfortunately when i'm trying to run this jar file from the prompt command I'mgetting the error: unable to access jar file
    here is the command i'm typing:
    C:\Users\User\Documents\NetBeansProjects\hEqUALIFIES\dist>java -jar " C:\Users\U
    ser\Documents\NetBeansProjects\hEqUALIFIES\dist hequalifies.jar "
    anyone has any clue?
    10x!

    ok i'm gonna make it easier on you.
    i gess i found what is the problem but have no idea how to solve it.
    when i obtained the .jar file i also obtained a README.txt file in which it is written the following phrase:
    ** If a library on the projects classpath also has a Class-Path element*
    specified in the manifest,the content of the Class-Path element has to be on the projects runtime path.
    I'M SORRY BUT I DID NOT UNDERSTAND WHAT IS MEANT BY: what is "the projects runtime path"?
    the content of my manifest is:
    Manifest-Version: 1.0
    Ant-Version: Apache Ant 1.7.1
    Created-By: 10.0-b23 (Sun Microsystems Inc.)
    Main-Class: hequalifies.ui.HeQualifies
    Class-Path: lib/PlugIn
    X-COMMENT: Main-Class will be added automatically by build
    I'm having problem with lib/plugin.

  • Unable to access values from database in login page..

    Hey all,
    Friends I have a login.jsp page and I want if i enter username and password then it will be accessed from database and after verifying the details it will open main.jsp.I made a database as "abc" and created DSN as 1st_login having table 1st_login. But the problem is that I am unable to access values from database.
    So Please help me.
    Following is my code:
    <HTML>
    <body background="a.jpg">
    <marquee>
                        <CENTER><font size="5" face="times" color="#993300"><b>Welcome to the"<U><I>XYZ</I></U>" of ABC</font></b></CENTER></marquee>
              <br>
              <br>
              <br>
              <br><br>
              <br>
         <form name="login_form">
              <CENTER><font size="4" face="times new roman">
    Username          
              <input name="username" type="text" class="inputbox" alt="username" size="20"  />
              <br>
         <br>
              Password          
              <input type="password" name="pwd" class="inputbox" size="20" alt="password" />
              <br/>
              <input type="hidden" name="option" value="login" />
              <br>
              <input type="SUBMIT" name="SUBMIT" class="button" value="Submit" onClick="return check();"> </CENTER>
              </td>
         </tr>
         <tr>
              <td>
              </form>
              </table>
    <%
    try {
    Class.forName("sun.jdbc.odbc.JdbcOdbcDriver");
    Connection connection = DriverManager.getConnection("jdbc:odbc:1st_login");
    Statement statement = connection.createStatement();
    String query = "SELECT username, password FROM 1st_login WHERE username='";
    query += request.getParameter("username") + "' AND password='";
    query += request.getParameter("password") + "';";
    ResultSet resSum = statement.executeQuery(query);
    //change: you gotta move the pointer to the first row of the result set.
    resSum.next();
    if (request.getParameter("username").equalsIgnoreCase(resSum.getString("username")) && request.getParameter("password").equalsIgnoreCase(resSum.getString("password")))
    %>
    //now it must connected to next page..
    <%
    else
    %>
    <h2>You better check your username and password!</h2>
    <%
    }catch (SQLException ex ){
    System.err.println( ex);
    }catch (Exception er){
    er.printStackTrace();
    %>
    <input type="hidden" name="op2" value="login" />
         <input type="hidden" name="lang" value="english" />
         <input type="hidden" name="return" value="/" />
         <input type="hidden" name="message" value="0" />
         <br>
              <br><br>
              <br><br>
              <br><br><br><br><br>
              <font size="2" face="arial" color="#993300">
         <p align="center"> <B>ABC &copy; PQR</B>
    </BODY>
    </HTML>
    and in this code i am getting following error
    C:\Project\SRS\build\generated\src\org\apache\jsp\loginjsp.java:93: cannot find symbol_
    C:\Project\SRS\build\generated\src\org\apache\jsp\loginjsp.java:93: cannot find symbol_
    C:\Project\SRS\build\generated\src\org\apache\jsp\loginjsp.java:94: cannot find symbol_
    C:\Project\SRS\build\generated\src\org\apache\jsp\loginjsp.java:95: cannot find symbol_
    4 errors
    C:\Project\SRS\nbproject\build-impl.xml:360: The following error occurred while executing this line:
    C:\Project\SRS\nbproject\build-impl.xml:142: Compile failed; see the compiler error output for details.
    BUILD FAILED (total time: 6 seconds)

    As long as you're unable to compile Java code, please use the 'New to Java' forum. This is really trival.
    To ease writing, debugging and maintenance, I highly recommend you to write Java code in Java classes rather than JSP files. Start learning Servlets.

  • Unable to access/lan2lan ping from VPN Fortigate to Cisco ASA 5505

    Problem : Unable to access user A to user B
    User A --- router A (122, fortigate 80c) --- (Site to Site VPN between fortigate & cisco asa) --- router B (93, cisco Asa 5505{in front asa got cisco800[81] before to internet} )  --- User B
    After using wizard to configure the cisco ASA site to site VPN, the site-to-site tunnel is up.
    Ping is unsuccessful from user A to user B
    Ping is successful from user B to user A, data is accessable
    After done the packet tracer from user A to user B,
    Result :
    Flow-lookup
    Action : allow
    Info: Found no matching flow, creating a new flow
    Route-lookup
    Action : allow
    Info : 192.168.5.203 255.255.255.255 identity
    Access-list
    Action : drop
    Config Implicit Rule
    Result - The packet is dropped
    Input Interface : inside
    Output Interface : NP Identify Ifc
    Info: (acl-drop)flow is denied by configured rule
    Below is Cisco ASA 5505's show running-config
    ASA Version 8.2(1)
    hostname Asite
    domain-name ssms1.com
    enable password ZZZZ encrypted
    passwd WWWW encrypted
    names
    name 82 B-firewall description Singapore office firewall
    name 192.168.1.0 B-inside-subnet description Singapore office internal LAN IP
    name 192.168.200.0 A-inside-VLAN12 description A-inside-VLAN12 (fortinet)
    name 192.168.2.0 fw-inside-subnet description A office internal LAN IP
    name 122 A-forti
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.5.203 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 93 255.255.255.240
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/7
    ftp mode passive
    dns server-group DefaultDNS
    domain-name ssms1.com
    object-group network obj_any
    network-object 0.0.0.0 0.0.0.0
    access-list inside_nat0_outbound extended permit ip any 80 255.255.255.240
    access-list inside_nat0_outbound extended permit ip fw-inside-subnet 255.255.255.0 B-inside-subnet 255.255.255.0
    access-list inside_nat0_outbound extended permit ip 192.168.5.0 255.255.255.0 A-inside-VLAN12 255.255.255.0
    access-list outside_cryptomap extended permit ip fw-inside-subnet 255.255.255.0 B-inside-subnet 255.255.255.0
    access-list Outside_nat-inbound extended permit ip A-inside-VLAN12 255.255.255.0 192.168.5.0 255.255.255.0
    access-list Outside_nat-inbound extended permit ip host A-forti 192.168.5.0 255.255.255.0
    access-list outside_1_cryptomap extended permit ip 192.168.5.0 255.255.255.0 A-inside-VLAN12 255.255.255.0
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-631.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 101 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 101 0.0.0.0 0.0.0.0
    route outside 0.0.0.0 0.0.0.0 81 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http B-inside-subnet 255.255.255.0 inside
    http fw-inside-subnet 255.255.255.0 inside
    http 0.0.0.0 255.255.255.255 outside
    http 0.0.0.0 0.0.0.0 outside
    http 192.168.5.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto map outside_map 1 match address outside_1_cryptomap
    crypto map outside_map 1 set pfs
    crypto map outside_map 1 set peer A-forti
    crypto map outside_map 1 set transform-set ESP-3DES-SHA
    crypto map outside_map 2 match address outside_cryptomap
    crypto map outside_map 2 set peer B-firewall
    crypto map outside_map 2 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 20
    authentication pre-share
    encryption aes-192
    hash md5
    group 2
    lifetime 86400
    crypto isakmp policy 30
    authentication pre-share
    encryption aes-256
    hash md5
    group 2
    lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside
    dhcpd address 192.168.5.10-192.168.5.20 inside
    dhcpd dns 165 165 interface inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    group-policy DfltGrpPolicy attributes
    vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
    username admin password XXX encrypted privilege 15
    tunnel-group 122 type ipsec-l2l
    tunnel-group 122 ipsec-attributes
    pre-shared-key *
    class-map inspection_default
    match default-inspection-traffic
    class-map outside-class
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
      message-length maximum client auto
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect icmp
    policy-map outside-policy
    description ok
    class outside-class
      inspect dns
      inspect esmtp
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect icmp
      inspect icmp error
      inspect netbios
      inspect rsh
      inspect rtsp
      inspect sip
      inspect skinny
      inspect sqlnet
      inspect sunrpc
      inspect tftp
      inspect xdmcp
    service-policy global_policy global
    service-policy outside-policy interface outside
    prompt hostname context
    Cryptochecksum: XXX
    : end
    Kindly need your expertise&help to solve the problem

    any1 can help me ?

  • Unable to Access Web Site (with same name) outside of Local Network

    Hi everyone,
    I have my web site (and some other services) hosted outside of my network by my hosting provider, but handle all other items using OS X Server on my network (i.e. Wiki and so forth).
    The problem is now that I am unable to access my website at www.mydomain.com from within the network. I have external DNS set up for www.mydomain.com to point to my website, while mydomain.com points to my OS X Server (static IP address). Internally in OS X Server's DNS settings this used to work when I had www.mydomain.com resolving to the IP address of my web host, in addition to the default domain settings that OS X had set up. For some reason this is no longer working, and I am unable to figure out why.
    Using latest version of OS X Server 3.0.2.
    Any help is greatly appreciated. Thanks!
    Update: this ended up being a redirect issue on the web host. I added another subdomain that was hosted externally, and it worked fine. For some reason my web host is redirecting www.mydomain.com to domain.com.

    I am in Texas and cannot get to that site either. Do you know for sure the site is up and working? It could just be down (for days, a site I support was down for almost 4 full days a few weeks ago due to a virus problem).
    This may (again, may) be your problem: I see you have a173.48.x.x (you really should x-out the last two octets of your IP address for privacy reasons), I am on a 173.74.x.x address; I know some people have had problems with getting to some sites now that they have a 173.x.x.x address. I think Verizon obtained addresses in that range and some of the addresses apparently previously belonged to spammers or some malicious folks.Some sites (web sites, intermeidate routers, etc.) blocked those addresses, and may not have updated their filters to remove the block on those addresses because they don't know that Verizon now owns them. If this is the problem, eventually those filters will get updated and you will be able to access the site, but this could be a fairly long time.
    If you know how to contact that site I suggest you email them about the problem. You can also try turning off your router overnight and when you turn it back on the next day you may find that you have a different address (one that doesn't start with 173) that will allow you to get to the site.
    I don't think there is much Verizon can do to help, it is not their site that is blocking your address (at least I don't think it is).
    Hope this helps.
    Justin
    Verizon FiOS TV, Internet, and phone
    IMG 1.6.2, Build 08.58
    Keller, TX 76248

  • Hi, I recently left my computer on my car and drove into heavy traffic.  After several hundred cars ran it over, I noted than I was unable to access my previously purchased copy of Photoshop Elements 10.  How can I download a replacement copy?

    It's true.  I was loaded down like a mule, approaching my car, needing a free hand, and thinking "I'll just set this on the roof for a moment..."
    I drove about 1/2 mile and turned left into rush-hour traffic.  No sound, no horns, no frantic hand gestures from fellow drivers, and no sinking feeling whatsoever for several minutes.  And then like that sudden stop at the end of long fall, it hit me.  I quickly turned around as though haste may matter - and it did.  Had five more minutes passed, there'd have been nothing larger than a grain-of-sand-sized evidence that my computer had once existed.  For the next 30 minutes, I dodged many hundreds of cars in my firm commitment to gather every last one of the 2,653 pieces that I would need for a successful reassembling.
    At some point during my repair attempt, I noted that I was unable to access my previously purchased copies of Photoshop Elements 10 and Premiere Elements 10.
    And since Dell.com's record of this purchase was apparently destroyed that day as well, I'm at a loss.  Unless... "Ok, maybe I actually registered this purchase at Adobe.com...  But that would be weird as I never do such things in the name of maintaining privacy at every chance I encounter... But, I'll try... yep, 'Forgot your password,' Click... of, 'Follow this link,' Click... Minor rush that it might work... Hope fading fast... Gone!"
    When the only proof of purchase I can present is my promise that I did once purchase, is it possible for me to download these two programs without having to re-purchase?
    I lost a lot of things that day... money, work, memories, la la la.  Apparently I've now lost my dignity as well as I plead with some faceless corporation for a freebie.
    Does anyone at Adobe have a heart?  If so, I would invest my gratitude towards your benefit for the remainder of my years.

    As long as you know your serial number you can download PSE from here:
    Download Photoshop Elements products | 11, 10
    If you don't know your serial number:
    Find your serial number quickly

Maybe you are looking for

  • How do I save all tracks as one and create one file/mp3?

    I have logic pro 8 and I am a rapper. I created a song, which is about 6 tracks long. Now that I have finished the song, I want to save the COMPLETE product as one file, a file type that can be played in Itunes. When I try to save it, it only saves e

  • Ssis - move files from one directory to another and rename destination file if present

    Hello, How is it possible to move files from one directory to another directory and if the file already exists in destination directory then rename it? Thanks

  • Constrain-Drag in Piano Roll?

    Before I send this one in as a feature-request, I wanted to make sure it wasn't an already-implemented feature which I just hadn't figured out yet: When dragging a selection in the Piano Roll (aka Matrix) view, is there any way (presumably via a modi

  • Problemas con photoshop CS5

    He instalado bien el Photoshop CS5, pero al registrarlo no acepta mi clave del ID de adobe (me sale un mensaje que dice que lo intente nuevamente màs tarde) ya han pasado los 30 días de prueba y se ha deshabilitado el programa, y no puedo habilitarlo

  • Regarding Call Transformation

    Hi experts, Can any one tell what is call transformation used for and all also the use of  'id' given in the syntax below. CALL TRANSFORMATION id SOURCE (Internal table) RESULT (XML string ) Thanks&regards, Karthik.