Client-side handler: static config?

I would like to provide a client-side JAX-RPC handler that would
be invoked without any modification to existing client code.
The idea is that user's would only need to modify a config file
(something like the web-services.xml file, but on the client-
side) to use our handler.
We are already doing this in axis (uses a client-side deployment
descriptor: client_deploy.wsdd), but based on another thread
("Client Handler Chain - help ??"), it looks like there is
currently no equivalent in WLS?
Are there plans to add the ability to statically configure
client-side handlers in WLS via some sort of client-side config
file/descriptor, or is the programmatic method of modifying
the HandlerRegistry in the client code the only way?
Any help/ideas would be greatly appreciated!
--Terry

In 7.0, you can do this in a handler:
import weblogic.webservice.binding.soap.HttpClientBinding;
String url = http://my/new/address/;
sslAdapter = null; //only needed for ssl
Binding binding = new HttpClientBinding( url, sslAdapter );
context.setProperty( WLMessageContext.BINDING_PROP,
binding );
HTHs
-manoj
http://manojc.com
"William Cassidy" <[email protected]> wrote in message
news:[email protected]...
>
Is there a similar way to set the endPointAddress.
"manoj cheenath" <[email protected]> wrote:
Ok, I will add this as a feature request.
If you are ok with using WLS internal APIs (This APIs may change in
the future), try this:
weblogic.webservice.Operation operation
=
((weblogic.webservice.WLMessageContext)messageContext).getOperation();
>>
weblogic.webservice.Port port = operation.getPort();
String endPointAddress = port.getAddress();
regards,
-manoj
"Terry Martin" <[email protected]> wrote in message
news:[email protected]...
Manoj, thanks for the response.
We'd definitely like to see a client side dd at some point, but
can work with the API's for now. Thanks much for adding this as
a feature request.
On another subject:
I need to determine the target/endpoint URL from my client-side
request handler. Again, this was something we were able to do in
axis, but is currently not part of the JAX-RPC standard (JSR101).
I could be missing something, but haven't seen any way of
determining the target URL given only the SOAPMessageContext.
The only way seems to be if it were passed as a "standard"
property in the SOAPMessageContext (this is one way it is done
in axis).
I imagine this will someday be standardized in JAX-RPC (I can
think of many uses for this feature, other than our own). In the
meantime, could you also add this as a feature request for WLS?
Thanks again,
-Terry
"manoj cheenath" <[email protected]> wrote:
True. In WLS 7.0 there are no client side dd in which you can specify
the handler chain. We did not comeup with ourown client side dd,
hopeing that JSR109 will define the dd.
It is quite easy to register the handlers through APIs. Let us know
if
that will not help you.
I will add client side dd as a feature requst for the next release.
regards,
-manoj
"Terry Martin" <[email protected]> wrote in message
news:[email protected]...
I would like to provide a client-side JAX-RPC handler that would
be invoked without any modification to existing client code.
The idea is that user's would only need to modify a config file
(something like the web-services.xml file, but on the client-
side) to use our handler.
We are already doing this in axis (uses a client-side deployment
descriptor: client_deploy.wsdd), but based on another thread
("Client Handler Chain - help ??"), it looks like there is
currently no equivalent in WLS?
Are there plans to add the ability to statically configure
client-side handlers in WLS via some sort of client-side config
file/descriptor, or is the programmatic method of modifying
the HandlerRegistry in the client code the only way?
Any help/ideas would be greatly appreciated!
--Terry

Similar Messages

  • Query: creating client side handler

    how can I create a client side handler for a webservice on weblogic 9.2 workshop

    Take a peek at edocs for some examples and code you can get started with:
    http://edocs.bea.com/wls/docs92/webserv/client.html#client_handlers
    Best of luck,
    -Jacobd
    Mihir Khanwalkar wrote:
    how can I create a client side handler for a webservice on weblogic 9.2 workshop

  • Client side handling of exceptions thrown by a webservice

    I have a webservice that is deployed in Tomcat 5.5 running on Windows XP, Java version is 1.5, using jwsdp 1.5. My client, when run as an applet in a browser (have tried IE 6 and FireFox 1), seems to be unable to parse any exception thrown from the webservice. Instead the following exception is caught by the client:
    ==========================================================
    Checking the security service exception that occurred [Runtime exception; nested exception is:
    XML parsing error: com.sun.xml.rpc.sp.ParseException:1: Document root element is missing]
    com.irista.security.services.data.SecurityServiceException: Runtime exception; nested exception is:
    XML parsing error: com.sun.xml.rpc.sp.ParseException:1: Document root element is missing
    at com.irista.security.services.webclient.SecurityServiceProxy.removeAuthenticatio nProfile(SecurityServiceProxy.java:1276)
    at com.irista.security.ui.applet.AuthenticationProfilesListPanel.deleteAction(Auth enticationProfilesListPanel.java:131)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.irista.ui.webapp.framework.WebAppletPane.performAction(WebAppletPane.java:1 80)
    at com.irista.ui.webapp.framework.WebAppletPane.performAction(WebAppletPane.java:1 51)
    at com.irista.ui.webapp.framework.WebAppToolbar$ButtonActionListener.actionPerform ed(WebAppToolbar.java:368)
    at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
    at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
    at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
    at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
    at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
    at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
    at java.awt.Component.processMouseEvent(Unknown Source)
    at javax.swing.JComponent.processMouseEvent(Unknown Source)
    at java.awt.Component.processEvent(Unknown Source)
    at java.awt.Container.processEvent(Unknown Source)
    at java.awt.Component.dispatchEventImpl(Unknown Source)
    at java.awt.Container.dispatchEventImpl(Unknown Source)
    at java.awt.Component.dispatchEvent(Unknown Source)
    at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
    at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
    at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
    at java.awt.Container.dispatchEventImpl(Unknown Source)
    at java.awt.Component.dispatchEvent(Unknown Source)
    at java.awt.EventQueue.dispatchEvent(Unknown Source)
    at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.run(Unknown Source)
    ==========================================================
    If I run the client outside of a browser it catches the exception that is actually thrown by the webservice.
    Is there possibly a problem with the java 5 plugin handling exceptions thrown by webservices?
    I have not found any bug reports or forumn posts regarding this so any assistance would be greatly appreciated.
    thanks,
    scott

    Thanks for the reply, here is what the printStackTrace() output:
    java.rmi.RemoteException: Runtime exception; nested exception is:
         XML parsing error: com.sun.xml.rpc.sp.ParseException:1: Document root element is missing
         at com.sun.xml.rpc.client.StreamingSender._handleRuntimeExceptionInSend(StreamingSender.java:318)
         at com.sun.xml.rpc.client.StreamingSender._send(StreamingSender.java:300)
         at com.irista.security.services.webservice.SecurityServiceIF_Stub.removeAuthenticationProfile(SecurityServiceIF_Stub.java:1963)
         at com.irista.security.services.webclient.SecurityServiceProxy.removeAuthenticationProfile(SecurityServiceProxy.java:1266)
         at com.irista.security.ui.applet.AuthenticationProfilesListPanel.deleteAction(AuthenticationProfilesListPanel.java:131)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
         at java.lang.reflect.Method.invoke(Unknown Source)
         at com.irista.ui.webapp.framework.WebAppletPane.performAction(WebAppletPane.java:180)
         at com.irista.ui.webapp.framework.WebAppletPane.performAction(WebAppletPane.java:151)
         at com.irista.ui.webapp.framework.WebAppToolbar$ButtonActionListener.actionPerformed(WebAppToolbar.java:368)
         at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
         at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
         at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
         at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
         at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
         at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
         at java.awt.Component.processMouseEvent(Unknown Source)
         at javax.swing.JComponent.processMouseEvent(Unknown Source)
         at java.awt.Component.processEvent(Unknown Source)
         at java.awt.Container.processEvent(Unknown Source)
         at java.awt.Component.dispatchEventImpl(Unknown Source)
         at java.awt.Container.dispatchEventImpl(Unknown Source)
         at java.awt.Component.dispatchEvent(Unknown Source)
         at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
         at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
         at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
         at java.awt.Container.dispatchEventImpl(Unknown Source)
         at java.awt.Component.dispatchEvent(Unknown Source)
         at java.awt.EventQueue.dispatchEvent(Unknown Source)
         at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
         at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
         at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
         at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
         at java.awt.EventDispatchThread.run(Unknown Source)
    Caused by: XML parsing error: com.sun.xml.rpc.sp.ParseException:1: Document root element is missing
         at com.sun.xml.rpc.streaming.XMLReaderImpl.next(XMLReaderImpl.java:120)
         at com.sun.xml.rpc.streaming.XMLReaderBase.nextContent(XMLReaderBase.java:23)
         at com.sun.xml.rpc.streaming.XMLReaderBase.nextElementContent(XMLReaderBase.java:41)
         at com.sun.xml.rpc.client.StreamingSender._send(StreamingSender.java:123)
         ... 34 more

  • How to handle text of iframe to send to remote printer in client side?

    Hello everybody,
    I am having problem to handle the printing text of iframe to send to remote printer. I am using JDK 1.5, JSP and JBOSS. My clients have to print the information displayed in iframe to their remote Printer. I am using javascript code below to print:
    /* CODE IS IN JAVASCRIPT */
         document.frames[frameName].focus();
         document.frames[frameName].print(); But the main problem is that it takes a lot of times about 2 mins. Why is the above code taking so long time? Is it due to javascript code or the printing process? Is there any method or function to send printing text of iframe to printer faster?
    can anyone help me to solve this problem.....
    Thank You.
    Edited by: ritesh163 on Aug 20, 2008 2:45 PM

    ritesh163 wrote:
    Hello stevejluke,
    I am seeking for the suggestion whether it can be done through javascript or there is any other function or method in JSP that can replay javascript code and also work faster.
    Thank you.But JSP has nothing to do with it. JSP lives on the server, not the client. If can't control the client printer, can't know about it, and can't print to it. This is purely client-side, which means not JSP.

  • Client-Side Caching of Static Objects

    Hi,
    We just installed SPS12 for NWs.  I learned of this new client-side caching of static objects while reading through the release notes, and I went in to our portal to check it out.  I went to the location where the <a href="http://help.sap.com/saphelp_nw04s/helpdata/en/45/7c6336b6e5694ee10000000a155369/content.htm">release notes</a> (and an <a href="https://www.sdn.sap.com/irj/sdn/weblogs?blog=/pub/wlg/6622">article in the blog</a>) specified, System Administration > System Configuration > Knowledge Management > Content Management > Global Services.
    Problem is that I do not see Client Cache Service and Client Cache Patterns.  I enabled "Show Advanced Options," but I do not see those two configuration items.
    Does anyone know why I am not seeing those two configuration items and how I can get to those?
    Thank you.

    Hi,
    We are using SPS 12.
    KMC-CM  7.00 SP12 (1000.7.00.12.0.20070509052145) 
    KMC-BC  7.00 SP12 (1000.7.00.12.0.20070509052008) 
    CAF-KM  7.00 SP12 (1000.7.00.12.0.20070510091043) 
    KMC-COLL  7.00 SP12 (1000.7.00.12.0.20070509052223) 
    KM-KW_JIKS  7.00 SP12 (1000.7.00.12.0.20070507080500)

  • Use of category filters in client side GWI

    Hi
    With help from the forums, I am now experimenting with client side GWI but I cannot find any documentation that describes the use of the category filter field in the Sync properties tab of the options.
    I have already reviewed the documentation at : [http://help.sap.com/saphelp_crm50/helpdata/en/74/49af3ab73dc363e10000000a114084/frameset.htm]
    I am using MSA 5.0 SP11 and MS Outlook 2007
    Can anyone help?
    Alternatively, can anyone point me in the direction of any more advanced config guides?
    Thanks
    James
    Edited by: James Preston on Feb 8, 2009 6:48 PM

    Thanks Rashmi
    My investigation leads me to believe that there is a bit more too it than that if I want to use this filter effectively.
    If I do not put a filter that is in both my Outlook Master Categroy list AND maintained in SPRO, it deletes the activity in the MSA Calendar. If I do not use the filter field at all it works just fine, but we need to restrict the activities flowing in the direction Mail >> Mobile
    I will keep experimenting and update this post with my findings.
    FYI - I have also found an issue with the conflict resolution which I will be raising an OSS for.
    Scenario: On the conflict resolution tab, in the Ask for confirmation when area, ALL of the boxes are UNCHECKED.
    In the Conflict handling section, SAP CRM has priority is selected.
    I would expect, therefore, if I were to delete an appointment in Outlook, it should NOT delete it automatically from MSA...but it does!
    This is just for info, but if you know anything about this, let me know and I can raise another forum thread so that the correct points can be awarded
    Regards
    James

  • STRUTS: client-side validation in jsp using  DynaValidatorForm

    I am supposed to work on struts on as project and it is like learning a crash course and work the next day.
    In Struts 1.1 enviroment, I am using DynaValidatorForm to create a bean form and then perform validation.
    1. I write a DynaValidatorForm definition in struts-config.xml
    2. I write xml for action so that when /getQuotes.do in invoked by a jsp form, the form data is put into the QuoteDetailsBean.
    3. add the plugin script for ValidatorPlugIn
    xml fragment from struts-config:
    //form bean
    <form-beans>
    <form-bean name="QuoteDetailsBean" type="org.apache.struts.validator.DynaValidatorForm">
        <form-property name="forename" type="java.lang.String"/>
       <form-property name="surname" type="java.lang.String"/>
    <form-bean>
    </form-beans>
    <action
            path="/getQuotes"
            type="com.kainos.quickquotes.struts.QQGetQuotesAction"
            validate="true"
            name="QuoteDetailsBean"
            input="/userform1.do"
            parameter="save"
            scope="session">
            <forward name="success" path="/pages/jsp/result.jsp"/>
            <forward name="back" path="/userform1.do"/>
    </action>
    <plug-in className="org.apache.struts.validator.ValidatorPlugIn">
         <set-property
             property="pathnames"
             value="/WEB-INF/validator-rules.xml,/WEB-INF/validation.xml"/>
      </plug-in>Now I write a validation code for getQuotes.do. note that I can write the validation code with
    <form name="QuoteDetailsBean"> but this form bean is shared by many jsp, so i am using the name of the action
    (getQuotes) as the name of the form in the validation.xml.
    So far this looks okay, as I am going by some example.
    xml fragment from validation.xml:
    <formset>
              <form name="/getQuotes">
                 <field property="forename" depends="required,minlength">
                    <arg0 key="QuoteDetailsBean.forename" />
                    <arg1 name="minlength" key="${var:minlength}" resource="false"/>
                    <var>
                       <var-name>minlength</var-name>
                       <var-value>2</var-value>
                    </var>
                 </field>
                 <field property="surname" depends="required,minlength">
                <arg0 key="QuoteDetailsBean.surname" />
                <arg1 name="minlength" key="${var:minlength}" resource="false"/>
                <var>
                   <var-name>minlength</var-name>
                   <var-value>2</var-value>
                </var>
                 </field>
    </formset>Now I write the JSP. I use the <html:javascript> tag to allow front-end validation based on the xml in validation.xml.
    The jsp code:
    <%@ taglib uri="/tags/struts-bean" prefix="bean" %>
    <%@ taglib uri="/tags/struts-html" prefix="html" %>
    <%@ taglib uri="/tags/struts-logic" prefix="logic" %>
    <html:html locale="true">
    <head>
    <title><bean:message key="welcome.title"/></title>
    <html:base/>
    <html:javascript formName="/getQuotes"
                method="validateForm"
                dynamicJavascript="true"
                staticJavascript="false"
                cdata="false" />
    </head>
    <body bgcolor="#FFCC9F">
    <html:errors />
    <html:form action="getQuotes.do" onsubmit="return validateForm(this);" >
    Forename:</td> <td>���<html:text property="forename"/></td></tr>
    <tr> <td>Surname:</td> <td>���<html:text property="surname"/></td></tr>
    <html:submit value="Quotes" /></td></tr>
    </html:form>
    </body>
    </html:html>Does this looks okay. I wrote so far based on some tutorials n help online.
    Now when I open the JSP and then do a submit, there is no validation (I tried by submitting with empty forename and surname. I mean i could invoke the action class and the invoke class
    redirects(forwards) to the appropriate path. so the code works fine except validation is not done
    Q1. So what should i do more to get client-side validation?
    What actually happens in client-side validation? does a pop up alert appears?
    nothing happens so far in my case.
    Q2. What should I do more for server side validation. Since the form is incomplete, what happens?
    I thought the same form returns and the error messages are printed in the jsp page since i have the <html:errors />
    tag just below the <body> tag.
    The action class is pretty simple so far:
    public class QQGetQuotesAction extends Action {
        public QQGetQuotesAction(){
    public ActionForward execute(ActionMapping mapping,
                 ActionForm form,
                 HttpServletRequest request,
                 HttpServletResponse response)
        throws Exception {
            DynaValidatorForm dynaform = (DynaValidatorForm)form;
            System.out.println("forename:"+dynaform.get("forename");
            System.out.println("surname:"+dynaform.get("surname");
            return forward=mapping.findForward("back");
    }Please help me out. I think I am missing something which i need to do
    thanks
    Tanveer

    I think the validations are to be declared on the form
    name and not the action path.
    Your formName is QuoteDetailsBean but your are using
    the action path(/getQuotes) both in the validation
    rules and the jsp tags. Use the formName on both the
    places.
    Also your html:javascript tag will not generate the
    static javascript to validate the fields. For this you
    will have to add code like below.
    <html:javascript dynamicJavascript="false"
    staticJavascript="true"/>
    Other options is to set the attribute
    staticJavascript="true" in your html:javascript tag.
    Hope it helps.hi
    staticJavascript="true" did the trick. :)
    I think the validations are to be declared on the form name and not the action path.It is not necessary. You can declare the validation on the action class. This is essential if a form bean is shared by several JSPs having its own action class. This is as per as I read in a tutorial and it works.

  • How can i load file into database from client-side to server-side

    i want to upload file from client-side to server-side, i use the following code to load blob into database.
    if the file is in the server-side, it can work, but if it in the client-side, it said that the system cannot find the file. i think it only will search the file is in the server-side or not, it will not search the client-side.
    how can i solve it without upload the file to the server first, then load it into database??
    try
    ResultSet rset = null;
    PreparedStatement pstmt =
    conn.prepareStatement ("insert into docs values (? , EMPTY_BLOB())");
    pstmt.setInt (1, docId);
    pstmt.execute ();
    // Open the destination blob:
    pstmt.setInt (1, docId);
    rset = pstmt.executeQuery (
    "SELECT content FROM docs WHERE id = ? FOR UPDATE");
    BLOB dest_lob = null;
    if (rset.next()) {
    dest_lob = ((OracleResultSet)rset).getBLOB (1);
    // Declare a file handler for the input file
    File binaryFile = new File (fileName);
    FileInputStream istream = new FileInputStream (binaryFile);
    // Create an OutputStram object to write the BLOB as a stream
    OutputStream ostream = dest_lob.getBinaryOutputStream();
    // Create a tempory buffer
    byte[] buffer = new byte[1024];
    int length = 0;
    // Use the read() method to read the file to the byte
    // array buffer, then use the write() method to write it to
    // the BLOB.
    while ((length = istream.read(buffer)) != -1)
    ostream.write(buffer, 0, length);
    pstmt.close();
    // Close all streams and file handles:
    istream.close();
    ostream.flush();
    ostream.close();
    //dest_lob.close();
    // Commit the transaction:
    conn.commit();
    conn.close();
    } catch (SQLException e) {

    Hi,
    Without some more details of the configuration, its difficult to know
    what's happening here. For example, what do you mean by client side
    and server side, and where are you running the upload Java application?
    If you always run the application on the database server system, but can't
    open the file on a different machine, then it sounds like a file protection
    problem that isn't really connected with the database at all. That is to
    say, if the new FileInputStream (binaryFile) statement fails, then its not
    really a database problem, but a file protection issue. On the other hand,
    I can't explain what's happening if you run the program on the same machine
    as the document file (client machine), but you can't write the data to the
    server, assuming the JDBC connection string is set correctly to connect to
    the appropriate database server.
    If you can provide some more information, we'll try to help.
    Simon
    null

  • Looking for a client side JAXP-RPC HandlerChain example

    I would like to add a handler to the client side of a RPC call using 7.0.1. I
    can’t find any examples to follow for this logic in WebLogic or at Sun’s site.
    Does anyone know of some sample code I can browse to?
    I believe I want to add some files as attachments to a RPC call. To add them
    to the message, it looks like I should add them as an attachment in the handler.
    I see how this is done in the handler. However, I can’t find any useful documentation
    on setting the HandlerChain. I attempted this by following the Javadocs (HandlerRegistry,
    QName, HandlerInfo), but I must have left something out.
    Any suggestions for examples to follow?
    Thanks,
    Dave

    An example attached:
    regards,
    -manoj
    "Dave Lyons" <[email protected]> wrote in message
    news:3d9b508f$[email protected]..
    >
    >
    I would like to add a handler to the client side of a RPC call using7.0.1. I
    can't find any examples to follow for this logic in WebLogic or at Sun'ssite.
    Does anyone know of some sample code I can browse to?
    I believe I want to add some files as attachments to a RPC call. To addthem
    to the message, it looks like I should add them as an attachment in thehandler.
    I see how this is done in the handler. However, I can't find any usefuldocumentation
    on setting the HandlerChain. I attempted this by following the Javadocs(HandlerRegistry,
    QName, HandlerInfo), but I must have left something out.
    Any suggestions for examples to follow?
    Thanks,
    Dave
    [filetransfer.jar]

  • How can i look up a EJB residing in different machine from client side?

    hai ,
    How can i look up a EJB residing in different machine from client side?
    this is my code...........i don't know what should i use as Initial Context Factory...................i am using a sun appserver 8............
    package com.parx.lms.lmsdelegate;
    import com.parx.lms.exception.LMSException;
    import javax.naming.Context;
    import javax .ejb.CreateException;
    import javax.naming.InitialContext;
    import javax.naming.NamingException;
    import javax.rmi.PortableRemoteObject;
    import java.rmi.RemoteException;
    import com.parx.lms.controller.*;
    import com.parx.lms.vo.UserVo;
    import com.parx.lms.exception.BusinessException;
    import java.util.Hashtable;
    import java.lang.*;
    public class LmsDelegate{
    private final static String JNDI_NAME="LmsBean";
    private static String url="http://localhost:4848";
    public static Lms lms = null;
    public void getController() throws CreateException,
    NamingException,RemoteException{
    if(lms == null){
    Hashtable h=new Hashtable();
    h.put(Context.INITIAL_CONTEXT_FACTORY," ********what should i use here???????*************************");
    h.put(Context.PROVIDER_URL,url);
    System.out.println("Before Loading Context in Delegate");
    Context ctx=new InitialContext(h);
    System.out.println("Loaded Context in Delegate");
    Object obj=ctx.lookup(JNDI_NAME);
    System.out.println("Loaded Object in Delegate");
    System.out.println("Before Loading Home in Delegate");
    LmsHome home = (LmsHome )PortableRemoteObject.narrow(obj,com.parx.lms.controller.LmsHome.class);
    System.out.println("Loaded Home in Delegate");
    lms = home.create();
    System.out.println("Loaded remote in Delegate");
    public void addUserDelegate(UserVo vo) throws BusinessException{
    try{
    getController();
    System.out.println("Before calling the addUser of Session");
    lms.addUser(vo);
    }catch(CreateException e){
    System.out.println("Create Exception in Delegate due to--->"+e);
    e.printStackTrace();
    throw new BusinessException(e);
    }catch(NamingException e){
    System.out.println("Naming Exception in Delegate due to--->"+e);
    e.printStackTrace();
    throw new BusinessException(e);
    catch(RemoteException e){
    System.out.println("Remote Exception in Delegate due to--->"+e);
    e.printStackTrace();
    throw new BusinessException(e);
    }catch(LMSException e){
    System.out.println("duplicate user name--->"+e);
    e.printStackTrace();
    throw new BusinessException(e);
    pls help me..........

    h.put(Context.INITIAL_CONTEXT_FACTORY," ********what should i use here???????*************************")
    Each app server provides their own jndi factory class. For ex for weblogic it is weblogic.jndi.WLInitialContextFactory. SInce you are using sun app server, check if there are any examples to find out or the docs.
    private static String url="http://localhost:4848
    Since the client is in a different machine the localhost is not going to work here. provide the url or the machine name of the system in which ur sunapp server is running. In addition u will need to have the stubs of the remote interfaces in ur client machine.

  • How to Install SSIS COM Component on Client side

    Hi,
    I am new to BPC.
    I can't install SSIS COM Component on Client side.
    and i guess,  it lead BPC Excel , Data Manager is not working.
    Because all the user are local user on server side, no domain
    I have run OSoftSetup.exe,  but the result is
    Error (Login failed for user ". The user is not associated with a trusted SQL Server connection.)
    i have tried to change the OutlookSoft.config in OSoftSSIS_Client\Bin Folder
    and the config doesn't take any effect.
    How to How to Install SSIS COM Component on Client side?
    thx
    It is client side PC_MS\Logging\Log
    #ERROR#CustomXMLClt##EPM-BPC-MS##e17c2022-c7d4-4a0b-8515-b719441e3dbf###XMLParser : GetTagValue#hostname
    user########Plain##[LOG ID:22]System.NullReferenceException: Object reference not set to an instance of an object.
       at OSoft.Consumers.Common.CustomXML50.XMLParser.GetAttributeValue(String strKeyValue, String strAttKeyValue, String strSubKeyValue)#
    thx
    John

    But the problem is...in client side
    When opening Office 2007 Excel -> eTool -> Data Manager
    There have no option showed.
    and in C:\Documents and Settings\<user>\My Documents\PC_MS\Logging\Log
    it has following error.
    2010 08 21 17:15:35:875#+8:00#ERROR#CustomXMLClt##EPM-BPC-MS##51cea66a-13cd-49fc-afdd-7b492566bd12###XMLParser : GetTagValue#<HOSTNAME>
    BPCADM########Plain##[LOG ID:346]System.NullReferenceException: Object reference not set to an instance of an object.
       at OSoft.Consumers.Common.CustomXML50.XMLParser.GetAttributeValue(String strKeyValue, String strAttKeyValue, String strSubKeyValue)#
    2010 08 21 17:15:35:875#+8:00#ERROR#DMClientTools##EPM-BPC-MS##7aec1fbe-5fda-4c91-9c4a-1eec5e59911b###DMTools::ErrCheck#<HOSTNAME>
    BPCADM########Plain##[LOG ID:347]System.Exception: 91: Object reference not set to an instance of an object.
       at OSoft.Consumers.DataMgr.DMClientTools50.DMTools.ErrCheck(String strRtn)#
    2010 08 21 17:15:35:875#+8:00#ERROR#DMClientTools##EPM-BPC-MS##48f5a612-a046-4ef9-a56c-db565ef489d2###DMTools::GetServerInfo#<HOSTNAME>
    BPCADM########Plain##[LOG ID:348]System.Exception: 91: Object reference not set to an instance of an object.
       at OSoft.Consumers.DataMgr.DMClientTools50.DMTools.ErrCheck(String strRtn)
       at OSoft.Consumers.DataMgr.DMClientTools50.DMTools.GetServerInfo(String strContext, String strFilter, String strSecurity)#
    2010 08 21 17:15:35:890#+8:00#ERROR#DMConsole##EPM-BPC-MS##af7f7343-1cb2-4802-a667-2adbb1b8e2fd###basClientTools::ChangeClientSiteList#<HOSTNAME>
    BPCADM########Plain##[LOG ID:349]Subscript out of range#

  • How to implement server side methods in client side player from main.asc?

    Hi,
    I am developing video player using RTMP NetConnection and NetStream object but it is giving me below Error. Can you please tell me how can I handle this. I have main.asc file form FMS server side but I don't know how to use it. 
    Async Error found = <br>Error #2095: flash.net.NetConnection was unable to invoke callback setUserID.
    Async Error found = <br>Error #2095: flash.net.NetConnection was unable to invoke callback syncChat.
    Async Error found = <br>Error #2095: flash.net.NetConnection was unable to invoke callback playingNotComplete.
    Async Error found = <br>Error #2095: flash.net.NetConnection was unable to invoke callback nowPlaying.
    Can anyone please help me ot solve this issue?
    Best regards,
    Sunil kumar

    javascript are run on the client side.. but i think what you actually mean is getting some validation to your database without submitting the form?. yes it doesn't consumes time and memory of server.. why not use ajax so you can only submit a little request.. rather than submitting the whole page..

  • How can i lookup a session bean from the client side

    how can i lookup a session bean from the client side...........i am using sun appserver..............
    this is my code.................[B]
    private final static String JNDI_NAME="ejb/LmsBean";
    private static String url="ldap://localhost:4848";
    Hashtable h=new Hashtable();
    h.put(Context.INITIAL_CONTEXT_FACTORY,"com.sun.jndi.ldap.LdapCtxFactory");
    h.put(Context.PROVIDER_URL,url);
    System.out.println("Before Loading Context in Delegate");
    Context ctx=new InitialContext(h);
    System.out.println("Loaded Context in Delegate");
    Object obj=ctx.lookup(JNDI_NAME);
    System.out.println("Loaded Object in Delegate");
    System.out.println("Before Loading Home in Delegate");
    LmsHome home = (LmsHome )PortableRemoteObject.narrow(obj,com.parx.lms.controller.LmsHome.class);
    System.out.println("Loaded Home in Delegate");
    lms = home.create();
    System.out.println("Loaded remote in Delegate");
    [B]and i got the exception........
    Inside Client before calling delegate
    Before Loading Context in Delegate
    javax.naming.CommunicationException: Request: 1 cancelled
    javax.naming.CommunicationException: Request: 1 cancelled
    at com.sun.jndi.ldap.LdapRequest.getReplyBer(LdapRequest.java:60)
    at com.sun.jndi.ldap.Connection.readReply(Connection.java:405)
    at com.sun.jndi.ldap.LdapClient.ldapBind(LdapClient.java:340)
    at com.sun.jndi.ldap.LdapClient.authenticate(LdapClient.java:171)
    at com.sun.jndi.ldap.LdapCtx.connect(LdapCtx.java:2640)
    at com.sun.jndi.ldap.LdapCtx.<init>(LdapCtx.java:290)
    at com.sun.jndi.ldap.LdapCtxFactory.getUsingURL(LdapCtxFactory.java:175)
    at com.sun.jndi.ldap.LdapCtxFactory.getUsingURLs(LdapCtxFactory.java:193
    at com.sun.jndi.ldap.LdapCtxFactory.getLdapCtxInstance(LdapCtxFactory.ja
    va:136)
    at com.sun.jndi.ldap.LdapCtxFactory.getInitialContext(LdapCtxFactory.jav
    a:66)
    at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:6
    62)
    at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:243
    at javax.naming.InitialContext.init(InitialContext.java:219)
    at javax.naming.InitialContext.<init>(InitialContext.java:195)
    at com.parx.lms.lmsdelegate.LmsDelegate.getController(LmsDelegate.java:3
    0)
    at com.parx.lms.lmsdelegate.LmsDelegate.addUserDelegate(LmsDelegate.java
    :50)
    at com.parx.lms.client.consoleClient.Client.main(Unknown Source)
    pls go tru the exception and pls help.........

    That url string should be having the server name or ip instead of localhost.

  • Open Oracle Form in client side from BPEL Process

    Hello,
    I'm new in BPEL and I'm trying to do a Process who open a Form before it finish. I do that with a Java embedding with the next code:
    try {                     
    Runtime.getRuntime().exec("rundll32.exe url.dll,FileProtocolHandler http://dl380:8890/forms/frmservlet?config=atender&otherparams=CLIENTE="+variable );
    } catch (Exception e) {                                                
    e.printStackTrace();
    But this code open a form in the server side and I need that it be open in the client side. Someone know what's can I do?
    I hope you help me in this!
    Thanks in advance!
    Alejandra

    Hi Sreedhar,
    Probably there are simpler options, but one thing you can do is to create a new function in Oracle to access the same form (Service Contracts Authoring), and include this in the Form Parameters:
    QUERY_ONLY="YES"
    That will make the function read only (in theory). Now you can call that function from the OAF Page instead of OKS_OKSAUDET.
    Hope it helps.

  • ACE in one-arm model. VIP on Client Side, servers in other vlan

    Hello All
    i have a LAN whit many servers,but only 2 need to be balanced. So i think in one-arm model, due to the higth trafic that not be pass trought ACE.
    i have a vlan 900 where is the client side and the VIP also. (10.0.9.64/26)
    the servers are in vlan 503 (10.12.3.0/24)
    it mi first design with ONE-arm but i thinks something is missing, because doesn't work.
    the configuration is the next:
    MSFC:
    svclc module 1 vlan-group 1,2,
    svclc vlan-group 1 503,900-902
    svclc vlan-group 2 511
    interface Vlan503
    description OSS_&_Otros
    ip address 10.12.3.253 255.255.255.0
    standby 10 ip 10.12.3.254
    standby 10 priority 150
    standby 10 preempt delay minimum 305
    interface Vlan900
    description MSF_<->_ACE
    ip address 10.0.9.126 255.255.255.192
    end
    access-list 101 permit ip 10.12.3.0 0.0.0.255 10.0.9.64 0.0.0.63
    access-list 101 deny ip any any
    route-map From_Server_OSS_to_ACE permit 10
    match ip address 101
    set ip next-hop 10.0.9.125
    ACE_1/admin#
    ip route 0.0.0.0 0.0.0.0 10.0.9.126
    context OSS
    allocate-interface vlan 511
    allocate-interface vlan 900
    allocate-interface vlan 902
    member Max20
    ACE_1/OSS# sh run
    Generating configuration....
    access-list EVERYONE line 10 extended permit ip any any
    access-list EVERYONE line 20 extended permit icmp any any
    rserver host OSS_FES_1
    description OSS_Front_End_Server_1
    ip address 10.12.3.140
    inservice
    rserver host OSS_FES_2
    description OSS_Front_End_Server_2
    ip address 10.12.3.150
    inservice
    serverfarm host SERVER_farm_OSS
    rserver OSS_FES_1
    inservice
    rserver OSS_FES_2
    inservice
    class-map match-all VIP-OSS
    2 match virtual-address 10.0.9.66 any
    policy-map type loadbalance first-match OSS-LB-POLICY
    class class-default
    serverfarm SERVER_farm_OSS
    policy-map multi-match OSS-POLICY-MAP
    class VIP-OSS
    loadbalance vip inservice
    loadbalance policy OSS-LB-POLICY
    loadbalance vip icmp-reply
    interface vlan 900
    description Clients-side
    ip address 10.0.9.125 255.255.255.192
    access-group input EVERYONE
    access-group output EVERYONE
    service-policy input OSS-POLICY-MAP
    no shutdown
    ip route 0.0.0.0 0.0.0.0 10.0.9.126
    maybe a i need to allocate the vlan 503 in OSS Context, any advice?
    Thanks in advace,
    Gianni From Chile

    Since you server are not behind the ACE in either bridge or routed mode add the follwoing to your config and use nat to get the traffic back to the ace.
    This is how one-armed mode works.
    ACE_1/OSS# sh run
    Generating configuration....
    access-list EVERYONE line 10 extended permit ip any any
    access-list EVERYONE line 20 extended permit icmp any any
    rserver host OSS_FES_1
    description OSS_Front_End_Server_1
    ip address 10.12.3.140
    inservice
    rserver host OSS_FES_2
    description OSS_Front_End_Server_2
    ip address 10.12.3.150
    inservice
    serverfarm host SERVER_farm_OSS
    rserver OSS_FES_1
    inservice
    rserver OSS_FES_2
    inservice
    class-map match-all VIP-OSS
    2 match virtual-address 10.0.9.66 any
    policy-map type loadbalance first-match OSS-LB-POLICY
    class class-default
    serverfarm SERVER_farm_OSS
    policy-map multi-match OSS-POLICY-MAP
    class VIP-OSS
    loadbalance vip inservice
    loadbalance policy OSS-LB-POLICY
    loadbalance vip icmp-reply
    nat dynamic 10 vlan 900
    interface vlan 900
    description Clients-side
    ip address 10.0.9.125 255.255.255.192
    nat-pool 10 0.9.126 10 0.9.126 netmask 255.255.255.192 pat
    access-group input EVERYONE
    access-group output EVERYONE
    service-policy input OSS-POLICY-MAP
    no shutdown

Maybe you are looking for

  • Can't create a group contact on iPhone in iOS 7

    hi guys, its really irritating. i don;t know if u guys have the same problem or not. or only me don't know how to create the group on any idevices in ios 7. this is happens to me. i want to create a group on my iphone contact so i can organize all my

  • The iPod ___ cannot be updated. The disk could not be read or written to...

    I have tried updating, reseting and restoring how do I fix this problem?

  • Cannot add role to CAS

    We are have expanded a (2012 r2) primary site into a CAS and would now like to add the asset intelligence synchronization point and reporting services point to the CAS. When I right-click on the server name under \Administration\Overview\Site Configu

  • Why Won't it Export to Word ?

    I just bought one year of this Export PDF thing for $20 just for the sake of one file I want to convert. The prog goes about uploading it - takes forever (It's 66megabytes) - and then closes with a curt, fleeting message that there was an unexpected

  • Changing text in a selection drop down

    Hi all, Does anyone know how to change the text(not value) that is displayed in a single line selection drop down box from a javascript function.? ie. <select name="companyMenu" size="1" > <option value=" ">Want to change this text</option> </select>