Cluster/load balance weblogic using L4 switch like Alteon

Can I install weblogic as a standalone server on 2 or more server and
          cluster/load balance weblogic using a hardware balancer like Alteon Layer4
          switch (of course I will use a centralised storage to maintain a single copy
          of data which will eliminate syncronizing problem among servers)?
          BTW, Alteon can support persistent binding. The reason to use a Layer 4
          switch is that it is very fast, and this will make the application server
          layer transparent to client, the client can think this is a single server
          (it don't need to know whether there are 5 weblogic servers or 20 weblogic
          servers behind switch), and hardware are more reliable, sacalable and fast.
          I am not sure whether the normal weblogic clustered servers need to
          share/exchange info on the running memory, if it does, this approach will
          fail.
          

So My understanding is:
          Alteon with WL 6.0 can do load balancing for:
          entity bean
          stateless session bean
          but can't do load balancing for:
          stateful session bean (will persistent/sticky binding solve part of the
          problem except fail-over)
          in-memory replication
          am I right?
          Pao Wan
          "Don Ferguson" <[email protected]> wrote in message
          news:[email protected]...
          > It is possible to configure Alteon to understand the WebLogic 6.0 cookie
          format
          > and have a proxy-less cluster configuration that performs load balancing
          and
          > fail over of session state.
          >
          > It is also possible to configure Alteon's hardware-based SSL decryption
          for really
          > fast HTTPS processing.
          >
          > We are working on a white paper that describes how to configure Alteon for
          use
          > with WebLogic Server 6.0.
          >
          > -Don
          >
          >
          > Robert Patrick wrote:
          >
          > > Cameron,
          > >
          > > I believe that BEA tested their new proxy-less web clustering solution
          with
          > > load-balancing products from Alteon and several other vendors
          (Arrowpoint ?--
          > > which is now Cisco). However, it was my understanding that these
          products do
          > > not understand how to decrypt our cookies and extract IP addresses but
          rather
          > > these products are capable of doing sticky load balancing based on the
          Session
          > > ID contained in our cookie.
          > >
          > > If this is correct, then what this means is that when the primary server
          fails,
          > > the request will be routed to "some other server" in the cluster but not
          > > necessarily the one that holds the secondary copy of the user's session.
          The
          > > change in WLS 6.0 is that WLS will accept these misdirected requests and
          it will
          > > go out to the correct server and "migrate" the session to the server
          that
          > > received the request making that server the new primary (and
          regenerating the
          > > Session ID).
          > >
          > > I am sure if this is wrong that our product manager or one of our
          engineers will
          > > correct me (please?)...
          > >
          > > Hope this helps,
          > > Robert
          > >
          > > Cameron Purdy wrote:
          > >
          > > > Hi Robert,
          > > >
          > > > FWIW - There are several vendors (Primeon? Arrowpoint?) who claim to
          > > > understand WL cookies and parse the IPs out. (I haven't verified it
          myself
          > > > though.)
          > > >
          > > > --
          > > > Cameron Purdy
          > > > Tangosol, Inc.
          > > > http://www.tangosol.com
          > > > +1.617.623.5782
          > > > WebLogic Consulting Available
          > > >
          > > > "Robert Patrick" <[email protected]> wrote in message
          > > > news:[email protected]...
          > > > > There are not any hardware vendors (yet) that can understand
          WebLogic's
          > > > session
          > > > > ID. While you might be able to use the load balancer without the
          proxy on
          > > > 5.1,
          > > > > you would not be able to take advantage of in-memory replication
          failover
          > > > unless
          > > > > you only had two machines in the cluster. Like you said, everything
          will
          > > > work
          > > > > with 6.0 regardless of how the load balancer works (though you
          really,
          > > > really
          > > > > want to minimize the number of times the requests come into the
          wrong
          > > > server by
          > > > > utilizing sticky load balancing).
          > > > >
          > > > > Hope this helps,
          > > > > Robert
          > > > >
          > > > > Cameron Purdy wrote:
          > > > >
          > > > > > Rajesh,
          > > > > >
          > > > > > I meant that it would work in lieu of a proxy (such as Apache or
          NES)
          > > > with
          > > > > > 5.1, but only if both the hw load balancer and WL were set up to
          use
          > > > > > cookies. Some hw load balancers rely on IP and that doesn't
          work -- AOL
          > > > > > connections for example can change the source IP on the fly.
          Others
          > > > produce
          > > > > > their own cookies, that will work. Some even can use WL cookies
          and
          > > > parse
          > > > > > them to determine where to go. According to what I've read, with
          6.0 if
          > > > the
          > > > > > WL primary dies or for some other reason the request shows up at
          the
          > > > "wrong"
          > > > > > server, it will be handled correctly. That means you are pretty
          safe
          > > > with
          > > > > > hw load balancers and 6.0, almost regardless of the sticky
          > > > implementation
          > > > > > that they use.
          > > > > >
          > > > > > --
          > > > > > Cameron Purdy
          > > > > > Tangosol, Inc.
          > > > > > http://www.tangosol.com
          > > > > > +1.617.623.5782
          > > > > > WebLogic Consulting Available
          > > > > >
          > > > > > "Rajesh" <[email protected]> wrote in message
          > > > > > news:[email protected]...
          > > > > > >
          > > > > > > Hi Cameron,
          > > > > > > Can you elaborate on how it would work with WL5.1 since no in
          memory
          > > > > > replication
          > > > > > > would happen if the servers are standalone.
          > > > > > >
          > > > > > > "Cameron Purdy" <[email protected]> wrote:
          > > > > > > >Yes, this will work fine with WL6. (WL5.1 will work fine as
          long as
          > > > > > cookies
          > > > > > > >are used by the load balancer.)
          > > > > > > >
          > > > > > > >--
          > > > > > > >Cameron Purdy
          > > > > > > >Tangosol, Inc.
          > > > > > > >http://www.tangosol.com
          > > > > > > >+1.617.623.5782
          > > > > > > >WebLogic Consulting Available
          > > > > > > >
          > > > > > > >
          > > > > > > >"paowan" <[email protected]> wrote in message
          > > > > > > >news:[email protected]...
          > > > > > > >> Can I install weblogic as a standalone server on 2 or more
          server
          > > > and
          > > > > > > >> cluster/load balance weblogic using a hardware balancer like
          Alteon
          > > > > > Layer4
          > > > > > > >> switch (of course I will use a centralised storage to
          maintain a
          > > > single
          > > > > > > >copy
          > > > > > > >> of data which will eliminate syncronizing problem among
          servers)?
          > > > > > > >>
          > > > > > > >> BTW, Alteon can support persistent binding. The reason to use
          a
          > > > Layer
          > > > > > > >4
          > > > > > > >> switch is that it is very fast, and this will make the
          application
          > > > > > server
          > > > > > > >> layer transparent to client, the client can think this is a
          single
          > > > > > server
          > > > > > > >> (it don't need to know whether there are 5 weblogic servers
          or 20
          > > > > > weblogic
          > > > > > > >> servers behind switch), and hardware are more reliable,
          sacalable
          > > > and
          > > > > > > >fast.
          > > > > > > >>
          > > > > > > >> I am not sure whether the normal weblogic clustered servers
          need to
          > > > > > > >> share/exchange info on the running memory, if it does, this
          > > > approach
          > > > > > will
          > > > > > > >> fail.
          > > > > > > >>
          > > > > > > >>
          > > > > > > >
          > > > > > > >
          > > > > > >
          > > > >
          >
          

Similar Messages

  • Cluster / Load balancing and no. of user

    Hi
    Just wondering what kind of cluster / load balancing setup is need for e.g. 50 concurrent users ? and what's the deciding factor that will justify additional presentation service / BI server to be added to an existing cluster farm ?
    Or maybe if you guys could share what's the cluster setup that you have and the number of users that would greatly help me to get a rough idea of the kind of setup needed. E.g. 2x presentation services and 2x BI server with 100 users, estimated 50 concurrent users, etc..
    Thanks in advance !

    If there are 50 concurrent users, I don't think that you need to go for clustering. You can use more resources like increasing the RAM size and increasing th CPU count.
    If you opt for 64 bit operating system ,it would give you better performance.
    Regards
    Rajesh J

  • Cluster (Load balancing) implementation in obiee 10g

    Hi All,
    We need to implement clustering (Active-Active for Load balancing) in our project. We use both analytics and bi publisher. We also need to deploy analytics/bipublisher in to weblogic server for SSO purpose.
    Now we have two machines.
    As of now We did the installation of obiee10g (while installing we selected "Complete" button) in both machines. Could any body tell us how to implement clustering w.r.t to weblogic.
    To proceed futher we need to know..
    +1. Did normal clusrtering method in 10g with oc4j server differs when we deploy application in weblogic server..?+
    +2. Can I use any of the two machines to create a shared folder and place rpd to give the path in REPOSITORY_PUBLISHING_DIRECTORY or should I use third machine other than these two machine..???+
    Any help is greatly apprciated.
    Thanks & Regards,

    Hi User,
    Did you configured clustering wrt to OC4j or WLS..?
    A. Weblogic.
    2. Can you tell me how it differs wrt WLS..??
    A. We can't explain here please refer the following link.
    http://www.iwarelogic.com/2010/01/supply-chain-management-w-r-t-oracle-applications-312/
    http://docs.oracle.com/cd/E23943_01/upgrade.1111/e10126/wls_oc4j_comparisons.htm
    3.On top of these two machines we have a virtual IP?
    A. You can use virtual Ip's.
    In your project Weblogic also clustering mode am I write?
    What could be the process.. First we need to follow the clustering method as if there was no WLS and later deploy the application and need to do the changes wrt to WLServer (or) First we need to deploy the application in WLServer and for clustering need to do changes in/wrt to WLServer..??
    A . First we need to deploy the application in WLServer and for clustering need to do changes in/wrt to WLServe.
    Note: As per my knowledge please implement this way.
    1. Deploy analytic.war in your weblogc.
    2. If it is possible please implement Weblgoc clustering also.
    3. SSO implementation.
    4. Cluster implementation.
    This is the way am implemented in my project.
    My project tool details.
    1. Weblogic
    2. OBIEE 10.1.3.4.1
    3. Oracle 11g
    4. OS - AIX
    If you have any concerns please post me.
    Award points it is useful.
    Thanks,
    Satya
    Edited by: satya R on Apr 1, 2012 9:03 PM

  • IIS WLS6.1 SP3 and cluster load balancing

    I am setting up an installation with IIS, WLS6.1 SP3 using a cluster. Monitoring
    the instances in the cluster the entire load is going to one instance. If that
    instance is stopped the other takes over, no problem. If I set DynamicServerList
    to off in the iisproxy.ini file the load balances correctly.
    Is there a way to ensure WLS sends the dynamic server list as advertised? Failing
    that what are the problems that may arrise from not using the Dynamic Server List?

    I would like to see the entries in your iisproxy.ini file?
    Can you post 'em?
    Kumar
    Danny Newman wrote:
    I am setting up an installation with IIS, WLS6.1 SP3 using a cluster. Monitoring
    the instances in the cluster the entire load is going to one instance. If that
    instance is stopped the other takes over, no problem. If I set DynamicServerList
    to off in the iisproxy.ini file the load balances correctly.
    Is there a way to ensure WLS sends the dynamic server list as advertised? Failing
    that what are the problems that may arrise from not using the Dynamic Server List?

  • Cluster load balancing problems under heavy load.

              Hi,
              I am running 2 WLS 5.1 sp6 application servers on Solaris 7.
              2 Apache 1.3.12/Raven SSL webservers using the Raven proxy (also
              Solaris).
              My problem is this:
              The application appears to be load balancing and replicating
              session information fine under regular load. But when a heavy
              load is put on the system, load balancing seems to stop.
              One of the application servers processes all of the sessions
              while the other is just replicating session info. The CPU
              usage on the server doing all of the work was 60%, and on the
              secondary server it was only 2.5%.
              Do I have something set incorrect? I would think that if load
              balancing works for a small load on the system, it should be
              the same for a large load.
              Has anyone seen this type of behavior before?
              Thanks
              

    1.5G of heap is quite huge. Take a thread dump when you see the slow down.
              Does each clients start a new session and maintain it for the duration of the test.
              There is no property called weblogic.cluster.bindAddr
              -- Prasad
              Nick Barbato wrote:
              > Hi,
              >
              > There are no 'timed out server" messages in the log. I don't think
              >
              > that is the problem because I can see the secondary server
              >
              > replicating session information.
              >
              > It is jdk1.2.2_005a. The java options I am using are:
              >
              > java $THREAD_ARG \
              > -ms1536m -mx1536m \
              > -classpath "$CYGENT_SYS_CP" \
              > -Dweblogic.class.path="$CYGENT_WLS_CP" \
              > -Dweblogic.system.home=$CYGENT_ROOT/runtime \
              > -Dweblogic.system.propertiesFile=$CYGENT_ROOT/runtime/conf/weblogic/weblogic.properties
              >
              > \
              > -Djava.security.manager \
              > -Djava.security.policy==$CYGENT_ROOT/runtime/conf/cygent.policy
              > \
              > -Dcygent.root=$CYGENT_ROOT/runtime \
              > -Dweblogic.cluster.enable=true \
              > -Dweblogic.cluster.name=mycluster \
              > -Dweblogic.cluster.bindAddr=166.37.216.142 \
              > -Dweblogic.cluster.multicastAddress=237.0.1.0 \
              > cygent.Server $CYGENT_ROOT/runtime/conf/
              >
              > Thanks,
              > Nick
              >
              > "Mike Reiche" <[email protected]> wrote:
              > >
              > >I've seen this before - when one WL instance drops out
              > >of the
              > >cluster.
              > >
              > >Look for 'Timed out server' messages in weblogic.log.
              > >
              > >What JDK are you using? What JVM options.
              > >
              > >Mike
              > >
              > >"Nick Barbato" <[email protected]> wrote:
              > >>
              > >>Hi,
              > >>
              > >>I am running 2 WLS 5.1 sp6 application servers on Solaris
              > >>7.
              > >>2 Apache 1.3.12/Raven SSL webservers using the Raven
              > >proxy
              > >>(also
              > >>Solaris).
              > >>
              > >>My problem is this:
              > >>The application appears to be load balancing and replicating
              > >>session information fine under regular load. But when
              > >>a heavy
              > >>load is put on the system, load balancing seems to stop.
              > >>One of the application servers processes all of the sessions
              > >>while the other is just replicating session info. The
              > >>CPU
              > >>usage on the server doing all of the work was 60%, and
              > >>on the
              > >>secondary server it was only 2.5%.
              > >>
              > >>Do I have something set incorrect? I would think that
              > >>if load
              > >>balancing works for a small load on the system, it should
              > >>be
              > >>the same for a large load.
              > >>
              > >>Has anyone seen this type of behavior before?
              > >>
              > >>Thanks
              > >
              

  • Load balancing weirdness using NAT and same-metric route

    Hi.
    I'm trying to set up a double-WAN load-balancing scenario:
    I decided to attempt the "multiple same-metric routes with NAT" approach so I went for the example used in the IOS NAT Load-Balancing for Two ISP Connections Configuration Guide [1].
    I decided to use an upside-down Cisco 871-SEC/K9: use Vlan1 and Vlan2 for the routers and Fa4 for the LAN. I am hoping this is not an issue.
    There is this weirdness with some connections, particularly FTP. I pinpointed the problem to the following scenario: if I do a couple of pings to 100.1.1.1 using the FastEthernet4 as the source address, this is what I get in the logs:
    === PING 1 ECHO REQUEST ===
    *Mar 3 04:38:43.521: IP: tableid=0, s=192.168.60.4 (FastEthernet4), d=100.1.1.1 (Vlan1), routed via RIB
    *Mar 3 04:38:43.521: NAT: s=192.168.60.4->10.129.124.2, d=100.1.1.1 [14152]
    *Mar 3 04:38:43.521: IP: s=10.129.124.2 (FastEthernet4), d=100.1.1.1 (Vlan1), g=10.129.124.1, len 60, forward
    *Mar 3 04:38:43.521: ICMP type=8, code=0
    === PING 1 ECHO REPLY ===
    *Mar 3 04:38:45.589: NAT*: s=100.1.1.1, d=10.129.124.2->192.168.60.4 [19824]
    *Mar 3 04:38:45.589: IP: tableid=0, s=100.1.1.1 (Vlan1), d=192.168.60.4 (FastEthernet4), routed via RIB
    *Mar 3 04:38:45.589: IP: s=100.1.1.1 (Vlan1), d=192.168.60.4 (FastEthernet4), g=192.168.60.4, len 60, forward
    *Mar 3 04:38:45.589: ICMP type=0, code=0
    === (something else) ===
    *Mar 3 04:38:52.353: RT: SET_LAST_RDB for 0.0.0.0/0
    OLD rdb: via 10.129.124.33, Vlan2
    NEW rdb: via 10.129.124.1, Vlan1
    === PING 2 ECHO REQUEST ===
    *Mar 3 04:38:52.353: IP: tableid=0, s=192.168.60.4 (FastEthernet4), d=100.1.1.1 (Vlan2), routed via RIB
    *Mar 3 04:38:52.353: NAT: s=192.168.60.4->10.129.124.2, d=100.1.1.1 [14159]
    *Mar 3 04:38:52.353: IP: s=10.129.124.2 (FastEthernet4), d=100.1.1.1 (Vlan2), g=10.129.124.33, len 60, forward
    *Mar 3 04:38:52.353: ICMP type=8, code=0
    === PING 2 ECHO REPLY ===
    *Mar 3 04:38:53.029: NAT*: s=100.1.1.1, d=10.129.124.2->192.168.60.4 [19825]
    *Mar 3 04:38:53.029: IP: tableid=0, s=100.1.1.1 (Vlan1), d=192.168.60.4 (FastEthernet4), routed via RIB
    *Mar 3 04:38:53.033: IP: s=100.1.1.1 (Vlan1), d=192.168.60.4 (FastEthernet4), g=192.168.60.4, len 60, forward
    *Mar 3 04:38:53.033: ICMP type=0, code=0
    In the section "Ping 2 Echo Request" line 2 shows the NAT translating the packet to the address for the first provider but line 3 shows it routing it through the second one.
    In this case, the ICMP packet goes through but it is problematic if the ISP restricts the service by source-address (like RPF) or there is some acceleration mechanism inside the provider cloud, other than just plain routing.
    What am I missing? Here is the relevant part of the configuration. I deliberately disabled CEF to be able to debug the messages, but I *think* this may be altering the actual router behavior. This router does not have a "debug ip cef packet" command.
    no ip cef
    ip dhcp pool lan-side
    import all
    network 192.168.60.0 255.255.255.0
    default-router 192.168.60.1
    domain-name doublewan.local
    dns-server 8.8.8.8 8.8.4.4
    lease infinite
    ip domain name doublewan
    interface FastEthernet0
    !doesn't appear on running-config: vlan 1 is the default access vlan
    !switchport access vlan 1
    interface FastEthernet1
    switchport access vlan 2
    interface FastEthernet2
    shutdown
    interface FastEthernet3
    shutdown
    interface FastEthernet4
    ip address 192.168.60.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    no ip route-cache
    duplex auto
    speed auto
    interface Vlan1
    ip address 10.129.124.2 255.255.255.224
    ip nat outside
    ip virtual-reassembly
    no ip route-cache
    interface Vlan2
    ip address 10.129.124.35 255.255.255.224
    ip nat outside
    ip virtual-reassembly
    no ip route-cache
    ip route 0.0.0.0 0.0.0.0 Vlan1 10.129.124.1
    ip route 0.0.0.0 0.0.0.0 Vlan2 10.129.124.33
    ip nat inside source route-map nat1 interface Vlan1 overload
    ip nat inside source route-map nat2 interface Vlan2 overload
    ip access-list standard acl4-nexthop-vlan1
    permit 10.129.124.1
    ip access-list standard acl4-nexthop-vlan2
    permit 10.129.124.33
    route-map nat2 permit 10
    match ip address 102
    match ip next-hop acl4-nexthop-vlan2
    match interface Vlan2
    route-map nat1 permit 10
    match ip address 101
    match ip next-hop acl4-nexthop-vlan1
    match interface Vlan1
    control-plane
    Of course, there is some configuration pending for redundancy and stuff.
    Thanks a lot in advance.
    [1] http://www.cisco.com/c/en/us/support/docs/ip/network-address-translation-nat/100658-ios-nat-load-balancing-2isp.html

    Hello.
    This might be a bug in debug command or the IOS (without ip cef) you use; as routing is done before NAT (inside to outside).
    To make sure it works fine with ip cef, just enable strict uRPF (or just ACL) on .1 and .33 interfaces and see if you see any packet sent over wrong interface.
    PS: please check "sh ip cef 100.1.1.1"; I guess ip cef would tell you "per-destination sharing".

  • Question Cluster/Load balancing

    Question about iplanet load balancing/Cluster:
    Following discussion are based on iAS C++ engine(kcs).
    We have four web servers and two iAS servers:
    Web1, Web2, Web3, Web4
    iAS1, iAS2
    All machines run Solaris 8, web server is iWS4.1 SP6,
    Application server is iAS6.0 SP2, and both iAS boxes have
    same hardware configuration.
    1. What's the best load balancing method for this structure?
    Per Server Response Time(Web Connector Driven)
    Per Component Response Time(Web Connector Driven)
    Round Robin(Web Connector Driven)
    User Defined Criteria(iAS Driven)
    2. What's the criteria for the kxs engine to choose the kcs
    engine to sent request if we set Web Connector Driven
    load balancing?
    3. If we set iAS driven load balancing, what's the criteria
    for the web connector used to choose kxs?
    4. We got a problem when run load testing for an AppLogic
    in this cluster, one iAS CPU average usage got almost
    100%, but the other one is just 70%.
    We used Per Server Response Time load balancing method.
    Thanks.
    Heng

    see answers inline
    hcao wrote:
    Question about iplanet load balancing/Cluster:
    Following discussion are based on iAS C++ engine(kcs).
    We have four web servers and two iAS servers:
    Web1, Web2, Web3, Web4
    iAS1, iAS2
    All machines run Solaris 8, web server is iWS4.1 SP6,
    Application server is iAS6.0 SP2, and both iAS boxes have
    same hardware configuration.
    1. What's the best load balancing method for this structure?
    Per Server Response Time(Web Connector Driven)
    Per Component Response Time(Web Connector Driven)
    Round Robin(Web Connector Driven)
    User Defined Criteria(iAS Driven)
    it depends on the characteristics and behaviour of your application
    >
    2. What's the criteria for the kxs engine to choose the kcs
    engine to sent request if we set Web Connector Driven
    load balancing?
    kxs always does round robin to the kjs or kcs engines. The webconnector
    selects the kxs to which to send to.
    >
    3. If we set iAS driven load balancing, what's the criteria
    for the web connector used to choose kxs?
    as specified by your criteria in the iAS driven section.
    The ias instance will send its current list of preferences for ias
    intances it got from the criteria to the webconnector. This information
    is dynamic and updated constantly.
    >
    4. We got a problem when run load testing for an AppLogic
    in this cluster, one iAS CPU average usage got almost
    100%, but the other one is just 70%.
    We used Per Server Response Time load balancing method.
    again, this can be a valid result depending on the way your applogics
    are written. Are they CPU bound, I/O bound or DB bound? Since individual
    components execute differently and you specified to use the average of
    those results to determine load balancing this can be a valid result
    because differences in execution times of your applogics.
    >
    Thanks.
    Hengregards
    Han-Dat
    Consulting Project Engineer
    iPlanet Professional Services - ANZ
    iPlanet e-commerce Solutions
    - A Sun|Netscape Alliance
    Sun Microsystems Australia Pty Ltd

  • Load Balancing OBIEE using OC4J

    Hi All,
    I would like to know if there is a way of load balancing 2 instances of OBIEE using OC4J.
    Please advice if possible and the steps required to achieve that.
    A small correction ... we have 2 instance of OBIEE and 2 of stand alone of OC4J
    Is there any way we can attempt to load balance the two???
    Regards,
    maabajaber
    Edited by: maabajaber on Sep 22, 2010 4:19 AM

    Hi All,
    A small correction ... we have 2 instance of OBIEE and 2 of stand alone of OC4J.
    I believe OC4J stand alone can do this but i dont know how
    Is there any way we can attempt to load balance the two.
    Regards,
    maabajaber

  • Ironport Cluster Load Balancing

    Anyone knows if it is possible to configure a load balancing of two C100 in a cluster.
    I configured the second machine in the cluster two weeks ago. when I look in the stats, the second machine does nothing. the first machine is on 3% CPU and whe have about 120000 mail per day.
    is there any way to configure the cluster that the two machine share their work ? or is the cluster only for fail-safe ?

    Hello,
    Most mail admins know how to use MX records for load balancing (and redundancy) on their mail servers.
    Less people know you can use MX also for your outgoing mail traffic.
    Just add a MX record to your local DNS and specify a name for the record. (i.e. outgoingMX.local.domain) put the IP's or hostnames of your internal Ironport card in the data and configure your internal mail system to deliver it’s outgoing mail to smarthost outgoingMX.local.domain
    Works for most mail systems. I'm sure it is working for Exchange (5.5. and higher) and Domino (5 and higher)
    Regards, Steven

  • Issue in setting flex app in load balanced environment using SSL

    I have developed the dashboard in my application using flex 3.0. For this I have used JSP wrapper around the flex application. My application runs on JBoss application server. for communication between flex app and my application i am using LCDS. HTTPService component is being used to receive data from the server. Channel definitions are given in service-config.xml for amf and http channels and for both secure secure and not secure mode. In my proxy-config.xml i have defined Channels and destinations.
    services-config.xml
    <channel-definition id="my-amf" class="mx.messaging.channels.AMFChannel">
        <endpoint url="http://{server.name}:{server.port}/{context.root}/messagebroker/amf" class="flex.messaging.endpoints.AMFEndpoint"/>
        <properties>
              <polling-enabled>false</polling-enabled>
        </properties>
    </channel-definition>
    <channel-definition id="my-secure-amf" class="mx.messaging.channels.SecureAMFChannel">
        <endpoint url="https://{server.name}:{server.port}/{context.root}/messagebroker/amfsecure" class="flex.messaging.endpoints.SecureAMFEndpoint"/>
        <properties>
              <add-no-cache-headers>false</add-no-cache-headers>
        </properties>
    </channel-definition>
    <channel-definition id="my-http" class="mx.messaging.channels.HTTPChannel">
        <endpoint url="http://{server.name}:{server.port}/{context.root}/messagebroker/http" class="flex.messaging.endpoints.HTTPEndpoint"/>
    </channel-definition>
    <channel-definition id="my-secure-http" class="mx.messaging.channels.SecureHTTPChannel">
        <endpoint url="https://{server.name}:{server.port}/{context.root}/messagebroker/httpsecure" class="flex.messaging.endpoints.SecureHTTPEndpoint"/>
        <properties>
            <add-no-cache-headers>false</add-no-cache-headers>
        </properties>
    </channel-definition>
    proxy-config.xml
    <default-channels>
        <channel ref="my-http"/>
        <channel ref="my-amf"/>
        <channel ref="my-secure-http"/>
        <channel ref="my-secure-amf"/>
    </default-channels>
    <destination id="dashboardService">
        <properties>
    <url>/kr/servlet/DashboardServlet</url>
        </properties>
    </destination>
    <destination id="dashboardJSPService">
        <properties>
    <url>/kr/krportal/dashboardJSPService.jsf</url>
        </properties>
    </destination>
    In my development environment both secure and non secure mode were working fine. Now when I have deployed it behind the load balancer(which accepts secure requests only and if the request is not secure it redirects it to secure url) there is no response from the message broker servlet. One thing more I have observed is when the environment is non load balanced there are request like 'http://{server.name}:{server.port}/{context.root}/messagebroker/http'. and these requests are post request. But in load balanced environment with ssl the request is again like 'http://{server.name}:{server.port}/{context.root}/messagebroker/http' which is a post request and it is redirected to 'https://{server.name}:{server.port}/{context.root}/messagebroker/http' which is a get request. The content returned by this get request is null.
    Looking for some comments
    Thanks
    Abhishek Gupta

    if the load balancing environment is already well configured, thes rest is very easy, there is no difference between a configuration of load balancing environment and a simple one, for you that is transparent, except the manual deployment and manual copying
    of files in the directory 15

  • Load balancing with use of router 881.

    Hello,
    I have two MPLS line and i want load balancing with the help of CISCO router 881. is it necessary that i require two router on both location.? if one location have firewall and one location have cisco router 881 then can i do a load balancing or i require two router each on both location ? What are the basic requirement that i need.
    Thanks,
    Kuntal

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    An 881 should be able to load share across multiple ports.  Many routing protocol support ECMP, including BGP, but you need "special" hidden/secret commands to enable.  EIGRP also supports unequal cost load sharing.
    If an 881 supports OER or PfR, those too will do unequal load sharing, dynamically.

  • ACE: load balancing servers using DMZ ports on FWSM

    devices; (2 core with the ff config)
    6500
    fwsm
    idsm
    msfc
    SETUP;
    Servers are connected to the dmzs on the core
    REQUIREMENT;
    to load balance the servers
    QUESTION;
    Using the ACE module, is it possibe to load balance the servers which are connected to the port which is configured as DMZ?
    Thanks

    does not matter where the servers are connected.
    However, be aware that the flows from client to server needs to go through the loadbalancer BUT also the flows server to client.
    So, you should be careful where you attach the ACE module.
    The easier would be to attach to the DMZ as well between the FW and the servers.
    Gilles.

  • EIGRP load balancing when using HSRP on LAN

    Hi 
    I have a question about my topology. I have two routers  with EIGRP on both of them connected through 2 ISPs to other site. On those routers i have HSRP runing. Now my question is: HSRP is standby/active protocol so when one router act as active will it send data to other site only through one ISP??? will load balancing work on WAN side? will routers use both ISPs or just one- the one which is active in HSRP when sending data???

    Hi sotiris_pafitis, may be I didn't understand what you mean but if the idea is to configure one static on each router  (pointing it's ISP) and redistribute it in EGRIP, I disagree: is useless because the other router will prefer the static route due to its better administrative distance. Using EIGRP unequal load balancing is useless because  it balanced EIGRP path with different metric, not different Administrative distance. Isn't it ?
    If you want to use static route simply configure two static route on each router: one though WAN interface and the other through the LAN.
    For example:
    R1#conf t
    ip route 0.0.0.0 0.0.0.0 192.168.13.3
    ip route 0.0.0.0 0.0.0.0 192.168.12.2
    The result is:
    R1#sh ip route 0.0.0.0
    Routing entry for 0.0.0.0/0, supernet
      Known via "static", distance 1, metric 0, candidate default path
      Redistributing via eigrp 100
      Advertised by eigrp 100
      Routing Descriptor Blocks:
      * 192.168.13.3
          Route metric is 0, traffic share count is 1
        192.168.12.2
          Route metric is 0, traffic share count is 1
    In any case I think static router is not a good choice: in case of a fault on ISP 1, WAN interface can remain up producing a routing blackhole. If possible it's better to have a dynamic routing protocol between router and ISP, receving the default route and changing delay on interf to have the same metric for both  the path 
    Bye,
    enrico

  • Mysql cluster load balancing

    Hi there ! Could somebody guide me a bit on how to load balance Mysql servers ? Actually we can do read-only querys but on other operations the Mysql client we use says that "can't lock file". I think the balancer send that stream to one Mysql server but then when It goes back it doesn't know what is the correct place to send it. Thanks. We are doing it with a CSS, and we have two Mysql servers to process the queries.

    There are a couple of ways of scaling out using Mysql clusters and load balancing. The most common is to create a pool of read only servers, and then on the initiator split ro and rw transactions to seperate vips in your load balancer.
    For redundant RW transactions you can either do a Hot Hot setup on your mysql servers, or do a publisher subscriber, where you have a hard failover. In that case you need to configure your loadbalancers to only use the publisher, and to only use the subscriber if the publisher is dead.
    --Colin

  • Load-balance / autofailover using 2 ISPs

    Good morning.
    we have a T1 installed at our site and recently purchased a broadband connection from a different ISP. Our plan is to utilize both ISPs  to Load-balance our Internet and setup auto-failover in case either one fails.  We run exchange 2007 and host an ASP application so we can't afford to have our Internet disrupted.
    currently we have a 1841 cisco router for the T1 and we're trying to figure-out if we need to purchase an ASA Firewall to setup the auto fail-over / load balance system.
    Can you tell me which is the best way to do this and what equipment / model of cisco routers/  Firewalls do you recommend to implement this?
    Thanks,
    Collin

    Hi Collin -- We appreciate your post but, as this pertains to ISR 1841, think you'd be better served in the Cisco NetPro Forums.
    Here's the link:http://forums.cisco.com/eforum/servlet/NetProf;jsessionid=37FE634C9B9344028C695A694C4E3971.SJ2A?page=netprof&forum=Small%20and%20Medium%20Business&topic=Technologies%20for%20Small%20Medium%20Businesses&CommCmd=MB%3Fcmd%3Ddisplay_messages%26mode%3Dnew%26location%3D.1ddbf5a7.
    Thanks,
    Stephanie

Maybe you are looking for

  • Question re: audio when importing AVCHD footage

    Hi everyone, I use a Panasonic AF-100 which records using the AVCHD codec and uncompressed PCM audio.  When using the Log and Transfer function to transcode my footage, I see that in the Preferences menu of Log and Transfer, under "AVCHD", audio is s

  • Why does it keep telling me that youtube is a blocked plug in?

    I am trying to put a youtube video on a page of my website but it wont do it? It keeps saying plug in blocked I bought a plug in from the adobe add ons but cant find it and still cant upload a video?

  • Ssl soap disabled - data sync setup

    Setting up data sync. On the gw server (sles11sp2-oes for nss only) I use C1 and set Internal SOAP with ssl enabled. I attempt to connect to the SOAP securely during the Data Sync install (Grpwise connector settings part of install) - it fails. I un-

  • Apple TV can't find Xfinity wireless router

    Hello, we have a Mac Book Pro, 2 Iphone's, 2 IPad's and 2 Apple TV's. All devices are connected wireless to the router ACCEPT 1 Apple TV!! I can't figure out why it's not working. Well it was for a few weeks...after an update for the Apple TV is wasn

  • ATV2 stops working a lot

    While I am looking at contents of my iTunes on the ATV2, I often get a black (blank) screen which can only be solved by rebooting the device. The white light is still on and it registers my remote clicks, but nothing happens. This happens quite often