Load balancing weirdness using NAT and same-metric route

Hi.
I'm trying to set up a double-WAN load-balancing scenario:
I decided to attempt the "multiple same-metric routes with NAT" approach so I went for the example used in the IOS NAT Load-Balancing for Two ISP Connections Configuration Guide [1].
I decided to use an upside-down Cisco 871-SEC/K9: use Vlan1 and Vlan2 for the routers and Fa4 for the LAN. I am hoping this is not an issue.
There is this weirdness with some connections, particularly FTP. I pinpointed the problem to the following scenario: if I do a couple of pings to 100.1.1.1 using the FastEthernet4 as the source address, this is what I get in the logs:
=== PING 1 ECHO REQUEST ===
*Mar 3 04:38:43.521: IP: tableid=0, s=192.168.60.4 (FastEthernet4), d=100.1.1.1 (Vlan1), routed via RIB
*Mar 3 04:38:43.521: NAT: s=192.168.60.4->10.129.124.2, d=100.1.1.1 [14152]
*Mar 3 04:38:43.521: IP: s=10.129.124.2 (FastEthernet4), d=100.1.1.1 (Vlan1), g=10.129.124.1, len 60, forward
*Mar 3 04:38:43.521: ICMP type=8, code=0
=== PING 1 ECHO REPLY ===
*Mar 3 04:38:45.589: NAT*: s=100.1.1.1, d=10.129.124.2->192.168.60.4 [19824]
*Mar 3 04:38:45.589: IP: tableid=0, s=100.1.1.1 (Vlan1), d=192.168.60.4 (FastEthernet4), routed via RIB
*Mar 3 04:38:45.589: IP: s=100.1.1.1 (Vlan1), d=192.168.60.4 (FastEthernet4), g=192.168.60.4, len 60, forward
*Mar 3 04:38:45.589: ICMP type=0, code=0
=== (something else) ===
*Mar 3 04:38:52.353: RT: SET_LAST_RDB for 0.0.0.0/0
OLD rdb: via 10.129.124.33, Vlan2
NEW rdb: via 10.129.124.1, Vlan1
=== PING 2 ECHO REQUEST ===
*Mar 3 04:38:52.353: IP: tableid=0, s=192.168.60.4 (FastEthernet4), d=100.1.1.1 (Vlan2), routed via RIB
*Mar 3 04:38:52.353: NAT: s=192.168.60.4->10.129.124.2, d=100.1.1.1 [14159]
*Mar 3 04:38:52.353: IP: s=10.129.124.2 (FastEthernet4), d=100.1.1.1 (Vlan2), g=10.129.124.33, len 60, forward
*Mar 3 04:38:52.353: ICMP type=8, code=0
=== PING 2 ECHO REPLY ===
*Mar 3 04:38:53.029: NAT*: s=100.1.1.1, d=10.129.124.2->192.168.60.4 [19825]
*Mar 3 04:38:53.029: IP: tableid=0, s=100.1.1.1 (Vlan1), d=192.168.60.4 (FastEthernet4), routed via RIB
*Mar 3 04:38:53.033: IP: s=100.1.1.1 (Vlan1), d=192.168.60.4 (FastEthernet4), g=192.168.60.4, len 60, forward
*Mar 3 04:38:53.033: ICMP type=0, code=0
In the section "Ping 2 Echo Request" line 2 shows the NAT translating the packet to the address for the first provider but line 3 shows it routing it through the second one.
In this case, the ICMP packet goes through but it is problematic if the ISP restricts the service by source-address (like RPF) or there is some acceleration mechanism inside the provider cloud, other than just plain routing.
What am I missing? Here is the relevant part of the configuration. I deliberately disabled CEF to be able to debug the messages, but I *think* this may be altering the actual router behavior. This router does not have a "debug ip cef packet" command.
no ip cef
ip dhcp pool lan-side
import all
network 192.168.60.0 255.255.255.0
default-router 192.168.60.1
domain-name doublewan.local
dns-server 8.8.8.8 8.8.4.4
lease infinite
ip domain name doublewan
interface FastEthernet0
!doesn't appear on running-config: vlan 1 is the default access vlan
!switchport access vlan 1
interface FastEthernet1
switchport access vlan 2
interface FastEthernet2
shutdown
interface FastEthernet3
shutdown
interface FastEthernet4
ip address 192.168.60.1 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip route-cache
duplex auto
speed auto
interface Vlan1
ip address 10.129.124.2 255.255.255.224
ip nat outside
ip virtual-reassembly
no ip route-cache
interface Vlan2
ip address 10.129.124.35 255.255.255.224
ip nat outside
ip virtual-reassembly
no ip route-cache
ip route 0.0.0.0 0.0.0.0 Vlan1 10.129.124.1
ip route 0.0.0.0 0.0.0.0 Vlan2 10.129.124.33
ip nat inside source route-map nat1 interface Vlan1 overload
ip nat inside source route-map nat2 interface Vlan2 overload
ip access-list standard acl4-nexthop-vlan1
permit 10.129.124.1
ip access-list standard acl4-nexthop-vlan2
permit 10.129.124.33
route-map nat2 permit 10
match ip address 102
match ip next-hop acl4-nexthop-vlan2
match interface Vlan2
route-map nat1 permit 10
match ip address 101
match ip next-hop acl4-nexthop-vlan1
match interface Vlan1
control-plane
Of course, there is some configuration pending for redundancy and stuff.
Thanks a lot in advance.
[1] http://www.cisco.com/c/en/us/support/docs/ip/network-address-translation-nat/100658-ios-nat-load-balancing-2isp.html

Hello.
This might be a bug in debug command or the IOS (without ip cef) you use; as routing is done before NAT (inside to outside).
To make sure it works fine with ip cef, just enable strict uRPF (or just ACL) on .1 and .33 interfaces and see if you see any packet sent over wrong interface.
PS: please check "sh ip cef 100.1.1.1"; I guess ip cef would tell you "per-destination sharing".

Similar Messages

  • Cluster/load balance weblogic using L4 switch like Alteon

    Can I install weblogic as a standalone server on 2 or more server and
              cluster/load balance weblogic using a hardware balancer like Alteon Layer4
              switch (of course I will use a centralised storage to maintain a single copy
              of data which will eliminate syncronizing problem among servers)?
              BTW, Alteon can support persistent binding. The reason to use a Layer 4
              switch is that it is very fast, and this will make the application server
              layer transparent to client, the client can think this is a single server
              (it don't need to know whether there are 5 weblogic servers or 20 weblogic
              servers behind switch), and hardware are more reliable, sacalable and fast.
              I am not sure whether the normal weblogic clustered servers need to
              share/exchange info on the running memory, if it does, this approach will
              fail.
              

    So My understanding is:
              Alteon with WL 6.0 can do load balancing for:
              entity bean
              stateless session bean
              but can't do load balancing for:
              stateful session bean (will persistent/sticky binding solve part of the
              problem except fail-over)
              in-memory replication
              am I right?
              Pao Wan
              "Don Ferguson" <[email protected]> wrote in message
              news:[email protected]...
              > It is possible to configure Alteon to understand the WebLogic 6.0 cookie
              format
              > and have a proxy-less cluster configuration that performs load balancing
              and
              > fail over of session state.
              >
              > It is also possible to configure Alteon's hardware-based SSL decryption
              for really
              > fast HTTPS processing.
              >
              > We are working on a white paper that describes how to configure Alteon for
              use
              > with WebLogic Server 6.0.
              >
              > -Don
              >
              >
              > Robert Patrick wrote:
              >
              > > Cameron,
              > >
              > > I believe that BEA tested their new proxy-less web clustering solution
              with
              > > load-balancing products from Alteon and several other vendors
              (Arrowpoint ?--
              > > which is now Cisco). However, it was my understanding that these
              products do
              > > not understand how to decrypt our cookies and extract IP addresses but
              rather
              > > these products are capable of doing sticky load balancing based on the
              Session
              > > ID contained in our cookie.
              > >
              > > If this is correct, then what this means is that when the primary server
              fails,
              > > the request will be routed to "some other server" in the cluster but not
              > > necessarily the one that holds the secondary copy of the user's session.
              The
              > > change in WLS 6.0 is that WLS will accept these misdirected requests and
              it will
              > > go out to the correct server and "migrate" the session to the server
              that
              > > received the request making that server the new primary (and
              regenerating the
              > > Session ID).
              > >
              > > I am sure if this is wrong that our product manager or one of our
              engineers will
              > > correct me (please?)...
              > >
              > > Hope this helps,
              > > Robert
              > >
              > > Cameron Purdy wrote:
              > >
              > > > Hi Robert,
              > > >
              > > > FWIW - There are several vendors (Primeon? Arrowpoint?) who claim to
              > > > understand WL cookies and parse the IPs out. (I haven't verified it
              myself
              > > > though.)
              > > >
              > > > --
              > > > Cameron Purdy
              > > > Tangosol, Inc.
              > > > http://www.tangosol.com
              > > > +1.617.623.5782
              > > > WebLogic Consulting Available
              > > >
              > > > "Robert Patrick" <[email protected]> wrote in message
              > > > news:[email protected]...
              > > > > There are not any hardware vendors (yet) that can understand
              WebLogic's
              > > > session
              > > > > ID. While you might be able to use the load balancer without the
              proxy on
              > > > 5.1,
              > > > > you would not be able to take advantage of in-memory replication
              failover
              > > > unless
              > > > > you only had two machines in the cluster. Like you said, everything
              will
              > > > work
              > > > > with 6.0 regardless of how the load balancer works (though you
              really,
              > > > really
              > > > > want to minimize the number of times the requests come into the
              wrong
              > > > server by
              > > > > utilizing sticky load balancing).
              > > > >
              > > > > Hope this helps,
              > > > > Robert
              > > > >
              > > > > Cameron Purdy wrote:
              > > > >
              > > > > > Rajesh,
              > > > > >
              > > > > > I meant that it would work in lieu of a proxy (such as Apache or
              NES)
              > > > with
              > > > > > 5.1, but only if both the hw load balancer and WL were set up to
              use
              > > > > > cookies. Some hw load balancers rely on IP and that doesn't
              work -- AOL
              > > > > > connections for example can change the source IP on the fly.
              Others
              > > > produce
              > > > > > their own cookies, that will work. Some even can use WL cookies
              and
              > > > parse
              > > > > > them to determine where to go. According to what I've read, with
              6.0 if
              > > > the
              > > > > > WL primary dies or for some other reason the request shows up at
              the
              > > > "wrong"
              > > > > > server, it will be handled correctly. That means you are pretty
              safe
              > > > with
              > > > > > hw load balancers and 6.0, almost regardless of the sticky
              > > > implementation
              > > > > > that they use.
              > > > > >
              > > > > > --
              > > > > > Cameron Purdy
              > > > > > Tangosol, Inc.
              > > > > > http://www.tangosol.com
              > > > > > +1.617.623.5782
              > > > > > WebLogic Consulting Available
              > > > > >
              > > > > > "Rajesh" <[email protected]> wrote in message
              > > > > > news:[email protected]...
              > > > > > >
              > > > > > > Hi Cameron,
              > > > > > > Can you elaborate on how it would work with WL5.1 since no in
              memory
              > > > > > replication
              > > > > > > would happen if the servers are standalone.
              > > > > > >
              > > > > > > "Cameron Purdy" <[email protected]> wrote:
              > > > > > > >Yes, this will work fine with WL6. (WL5.1 will work fine as
              long as
              > > > > > cookies
              > > > > > > >are used by the load balancer.)
              > > > > > > >
              > > > > > > >--
              > > > > > > >Cameron Purdy
              > > > > > > >Tangosol, Inc.
              > > > > > > >http://www.tangosol.com
              > > > > > > >+1.617.623.5782
              > > > > > > >WebLogic Consulting Available
              > > > > > > >
              > > > > > > >
              > > > > > > >"paowan" <[email protected]> wrote in message
              > > > > > > >news:[email protected]...
              > > > > > > >> Can I install weblogic as a standalone server on 2 or more
              server
              > > > and
              > > > > > > >> cluster/load balance weblogic using a hardware balancer like
              Alteon
              > > > > > Layer4
              > > > > > > >> switch (of course I will use a centralised storage to
              maintain a
              > > > single
              > > > > > > >copy
              > > > > > > >> of data which will eliminate syncronizing problem among
              servers)?
              > > > > > > >>
              > > > > > > >> BTW, Alteon can support persistent binding. The reason to use
              a
              > > > Layer
              > > > > > > >4
              > > > > > > >> switch is that it is very fast, and this will make the
              application
              > > > > > server
              > > > > > > >> layer transparent to client, the client can think this is a
              single
              > > > > > server
              > > > > > > >> (it don't need to know whether there are 5 weblogic servers
              or 20
              > > > > > weblogic
              > > > > > > >> servers behind switch), and hardware are more reliable,
              sacalable
              > > > and
              > > > > > > >fast.
              > > > > > > >>
              > > > > > > >> I am not sure whether the normal weblogic clustered servers
              need to
              > > > > > > >> share/exchange info on the running memory, if it does, this
              > > > approach
              > > > > > will
              > > > > > > >> fail.
              > > > > > > >>
              > > > > > > >>
              > > > > > > >
              > > > > > > >
              > > > > > >
              > > > >
              >
              

  • After loading the internet using Firefox AND then selecting NEWS and a delay the Error "The MSN toolbar has encountered an error. etc" occurs. Also, when browsing some searches are "REDIRECTED"!

    After loading the internet using Firefox AND then selecting NEWS and a delay the Error "The MSN toolbar has encountered an error. etc" occurs. Also, when browsing some searches are "REDIRECTED"!
    == This happened ==
    Every time Firefox opened
    == Hard to say but have been trying to diagnose for at least a week.

    Original message wouldnt post with attachments - trying again....
    Attachments:
    secondclickheredialog.jpg ‏40 KB
    FirstDialog.jpg ‏19 KB
    Firstclickheredialog.jpg ‏16 KB

  • Dual ISP load balancing with 2 routers and 2 FW without using BGP

    Hi all,
    Based on the attachment diagram, is the design viable?
    Do anyone has a similar deployment before and can you share with me the config guide to this because I'm at lost on a few configs:
    1. On core switch A and B, I understood we need to have a default route pointing to the firewall interface. For this case, I have different IPs for the same context on both the firewalls.
    So, how should the config be?
    CoreSW_A(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.110
    CoreSW_A(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.111
    I don't think the above will work as the core switch will load balance the traffic to both firewalls even if one of the context is on standby mode?
    2. The area from the firewall to the internet would all be public IP. Thus, if i put a switch in between the firewall and the router, then i would waste some public IP addresses but if i remove the switch, I would not have enough ports on the ASA firewall. What is the best recommended solution for this?
    3. How do I load balance traffic to both R1 and R2 to their respective ISPs without using BGP? I may be using only a 2811 router.
    Thanks alot!!.. really much looking forward for some guidance and tips on this as I havent found any guides on this deployment yet.. mostly are LAN HA.

    For policy based routing, I would need to create route maps on the core switch itself right?
    Correct me if I'm wrong, if i use route-maps, i would be assigning e.g. internal network A to go through firewall context A and internal network B to go through firewall context B.
    Context A will only have path to Router A and context B will only have path to Router B. But if router B goes down, network B won't be able to access the Internet, right?
    I'm not sure whether it's a PI or PA for this as the ISP will assign us a block of IP address, for example 202.111.1.8/29 (these IPs can be used for webservers, etc). There will also be a public IP of /30 on the serial interface to connect to their router.
    Thanks alot..

  • ACE30 Load balancing based on IP and using x-forward-for header

    Hi Guys,
    We currently have a load balancing policy setup to direct traffic to say FARM-A based on a particular range of source (client) IP addresses, and the default FARM-B for all the other traffic.
    We are now looking to introduce a web application firewall (WAF) before the ACE.  The WAF will be inserting the client IP address into the x-forward-for http header.  Now I was wondering how best can be achieve the load balancing based on source IP given that we'll have to parse the HTTP header for this x-forward-for field?  Are there any examples that anyone can point me to? 
    let me know if you have any questions.
    thanks
    Sheldon

    Hi Sheldon,
    You might try creating a class map that matches on the XFF header. Then use that as the L7 load balance criteria (based on the hash value of the XFF header), using the predictor hash header.
    -Alex

  • EIGRP load balancing when using HSRP on LAN

    Hi 
    I have a question about my topology. I have two routers  with EIGRP on both of them connected through 2 ISPs to other site. On those routers i have HSRP runing. Now my question is: HSRP is standby/active protocol so when one router act as active will it send data to other site only through one ISP??? will load balancing work on WAN side? will routers use both ISPs or just one- the one which is active in HSRP when sending data???

    Hi sotiris_pafitis, may be I didn't understand what you mean but if the idea is to configure one static on each router  (pointing it's ISP) and redistribute it in EGRIP, I disagree: is useless because the other router will prefer the static route due to its better administrative distance. Using EIGRP unequal load balancing is useless because  it balanced EIGRP path with different metric, not different Administrative distance. Isn't it ?
    If you want to use static route simply configure two static route on each router: one though WAN interface and the other through the LAN.
    For example:
    R1#conf t
    ip route 0.0.0.0 0.0.0.0 192.168.13.3
    ip route 0.0.0.0 0.0.0.0 192.168.12.2
    The result is:
    R1#sh ip route 0.0.0.0
    Routing entry for 0.0.0.0/0, supernet
      Known via "static", distance 1, metric 0, candidate default path
      Redistributing via eigrp 100
      Advertised by eigrp 100
      Routing Descriptor Blocks:
      * 192.168.13.3
          Route metric is 0, traffic share count is 1
        192.168.12.2
          Route metric is 0, traffic share count is 1
    In any case I think static router is not a good choice: in case of a fault on ISP 1, WAN interface can remain up producing a routing blackhole. If possible it's better to have a dynamic routing protocol between router and ISP, receving the default route and changing delay on interf to have the same metric for both  the path 
    Bye,
    enrico

  • Static NAT and same IP address for two interfaces

    We have a Cisco ASA 5520 and in order to conserve public IP addresses and configuration (possibly) can we use the same public IP address for a static NAT with two different interfaces? Here is an example of what I'm refering too where 10.10.10.10 would be the same public IP address.
    static (inside,Outside) 10.10.10.10  access-list inside_nat_static_1
    static (production,Outside) 10.10.10.10  access-list production_nat_static_1
    Thanks for any help.
    Jeff

    Hi Jeff,
    Unfortunately this cannot be done, on the ASA packet classification is done on the basis of mac-address, destination nat and route, and here you are confusing the firewall, to which interface does the ip belong to. I haven't ever tried to do it, but it should cause you issues.
    Thanks,
    Varun Rao
    Security Team,
    Cisco TAC

  • Best Option (if any) for Load Balancing Distribution Point(s) on Same LAN

    Hey Guys - 
    I've got a simple question this time.  We use SCCM 2012 R2, manage ~800 systems at 3 locations, but perform most work at our main office where this scenario takes place.  Here, we have a single DP on-site which is a separate VM than our Primary
    which is also local.
    Recently, our PC Lab tried running our OSD TS on 16 systems which were each started 1-2 minutes apart.  When run on a single  brand new PC connected via GB network, the OSD TS takes a couple of hours to complete so with 16 it really caused some
    issues.  We had a couple of Programs/Packages/Applications which actually timed out due to the default 120 minute max run time.  We don't usually image 16 at a time, but often do 2-3 at once so are looking to find a solution to speed things up anyways.
    My Question
    What is the best solution / method for implementing any type of load balancing on a single LAN?  I'm not asking for true load balancing, but simply any solution where multiple systems running a TS can pull from more than a single local source if possible.
    We do not use multicasting and from what I've been told it will not be a possibility as it causes havoc on networks so it's out. I know that some clients can share content depending on deployment configuration, but don't know how / if this applies to OSD
    Task Sequences.
    Any suggestions or ideas?  Thanks! 
    Ben K.

    Agree, 16 machines is not a lot. I would normally go for about 2000 machines per DP depending on pkg/img size etc. Whats the size of that rebuild? Image + packages? Do you do a full DL before starting or is it started from WinPE?
    Our BranchCache tools will of course help, regardless of how fast your gig link is since data will be pulled from more sources, but think your issue is more network related? If the images is 5 gig and you add another 5 gig of packges in the sequence a 1Gb/s
    link should pull that 16 * 10GB=160GB in about half an hour. So think dont think you are having 1Gb/s from server to clients.
    //Andreas
    http://2pintSoftware.com

  • Load-balancing issues with iPlanet and multiple clusters

    We're in performance test of a large-scale clustered deployment based on WLS 5.1sp10.
    Due to scalability/functionality issues, some of which we've seen firsthand and
    some of which we've been informed of by associates as well as BEA representatives,
    we've chosen to implement multiple clusters with a maximum of three nodes each.
    These clusters will be fronted by a web server tier consisting of iPlanet servers
    using the proxy plugin.
    Due to hardware constraints (both in test and in production), however, we've configured
    the iPlanet servers to route across the multiple clusters. In our test environment,
    for instance, we've got a single iPlanet server routing across two 3-node clusters,
    and the configuration in obj.conf is as follows:
    <Object name="application" ppath="*/application">
    Service fn="wl-proxy" \
    WebLogicCluster="clusterA_1:9990,clusterB_1:9991,clusterA_2:9990,clusterB_2:9991,clusterA_3:9990,
    clusterB_3:9991" \
    CookieName="ApplicationSession"
    </Object>
    Our issue is that the load-balancing doesn't appear to work across the clusters.
    We're seeing one cluster get about 90% of the load, while the other receives
    only 10%.
    So, the question (finally!) is: Is this configuration correct (i.e., will it
    work according to the logic of the proxy plugin), and is it appropriate for this
    situation? Are there other alternative approaches that anyone can recommend?
    Thanks in advance,
    cramer

    I use weblogic6.1 with sp2+windows 2000.I develop a web application and deploy
    it to cluster.Through HttpClusterServlets proxy of weblogic I found that a server
    in cluster almost get 95% of requests but another only get 5% of requests.Why???
    I don't set any special parameter.And the weight of the two clustered server is
    equal.I use round-robin arithmetic.
    Thanks!
    "cramer" <[email protected]> wrote:
    >
    We're in performance test of a large-scale clustered deployment based
    on WLS 5.1sp10.
    Due to scalability/functionality issues, some of which we've seen firsthand
    and
    some of which we've been informed of by associates as well as BEA representatives,
    we've chosen to implement multiple clusters with a maximum of three nodes
    each.
    These clusters will be fronted by a web server tier consisting of iPlanet
    servers
    using the proxy plugin.
    Due to hardware constraints (both in test and in production), however,
    we've configured
    the iPlanet servers to route across the multiple clusters. In our test
    environment,
    for instance, we've got a single iPlanet server routing across two 3-node
    clusters,
    and the configuration in obj.conf is as follows:
    <Object name="application" ppath="*/application">
    Service fn="wl-proxy" \
    WebLogicCluster="clusterA_1:9990,clusterB_1:9991,clusterA_2:9990,clusterB_2:9991,clusterA_3:9990,
    clusterB_3:9991" \
    CookieName="ApplicationSession"
    </Object>
    Our issue is that the load-balancing doesn't appear to work across the
    clusters.
    We're seeing one cluster get about 90% of the load, while the other
    receives
    only 10%.
    So, the question (finally!) is: Is this configuration correct (i.e.,
    will it
    work according to the logic of the proxy plugin), and is it appropriate
    for this
    situation? Are there other alternative approaches that anyone can recommend?
    Thanks in advance,
    cramer

  • What is load balancer in fms cluster and how to configure it and testing fms clustering

    Hey guys,
                I am new to fms and clustering the fms server in origin-edge mode.But i am confused actually what is load balancer and how to configure it .
    After configuring , how to test and confirm that fms clustering is working.Is there any one can help me, plz....................
                                                                                                   thanks in Advance........

    Flash Media Server does not come bundled with a load balancer.  In theory, one deploys FMS in an edge/origin configuration like this
    1 Origin ----> N Edges ------> Customer Traffic
    The idea here is that N edges shoulder the load for most customers with a single origin coordinating resources like VOD content or script access.  The issue that remains is "how do I spread customers over the N edges" and that's where load balancing comes in.  Most customers use a prepackaged load balancing solution - as an Adobe staffer I can't recommend any of them over the other, but you should be able to get some recommendations here along with just googling for it.  The short answer contained here though is, you're going to have to find one outside of FMS if that's needed for your setup.
    Asa

  • Load Balancing with ASR9000 vN and multiple ISPs

    Hi,
    we will deploy a new DC as Active/Active.
    We will have ISPA and ISP B in each DC. Internet users are anybody in the internet coming to our e-commerce DC application.
    How could we do load balancing between ISPs using the ASR9001 and nV feature ?
    There is any IOS-XR feature that could help us about to do load balancing between ISPs?
    Thanks a lot.
    Regards,
    J

    You have 2 options here Jordi, either you can use BGP loadbalancing, this requires multipath as BGP by default would only install one route from the BGP table to the RIB hence FIB.
    But this may result in excessive IRL (inter rack link) usage in the cluster when traffic coming in on rack0 wants to take the bGP path out on rack1
    You could also use ABF (access-list based forwarding) to forcelly push traffic received on rack0 out on the link on rack0 and use an ipsla tracker to fallback to rack1 in case the uplink is gone.
    Alternatively to extend this by IGP signaling to redirect traffic preferably to rack1 to start with to minimize the IRL usage.
    And then you also have the ability to use RPL in the uplink path to make one link more preferred on teh internet then the other in case you want to control a bit which link is preferably used on rack0 or rack1
    regards
    xander

  • Load balancing between application server and database

    Hi,
    is there any load balancing between the application server and the database? Consider we have a single instance of an application server that sends database queries from different clients to the database. Are the requests queued in some way at the application server, allowing to control the flow of the queries (e.g. queries from "more important" clients might be sent with a higher priority)?
    Thanks for your help!

    Hi Victor/Jim/Volker,
    Thanks a lot for all the responses..
    Just wanted to let you guys know that my installation finished successfully.
    The thing which confused me was that my Qtime, Qdate and everything else was showing correct values..
    Well, my problem I set the environmental variable PASE_TZ to the EST time zone on a SYS level using WRKENVVAR>F4>SYS and added the variable. I logged off and the sidofr logged off, but one user which should have logged off and didn't was the "SAPINST"(my installation user) which was logged in the subsystem TMKSVR00.
    Even when I had closed the SAPINST installlation program, the user doesn't log off...it just sits there until and unless u shut him out of the system using the option 4 on wrkactjob for ending the JOB(SAPINST logged in the system below the TMKSVR00 subsystem)
    So since the SAPISNT user never logged of, his environmental variables were not initilized properly, even after the changes...
    This thought came to me almost after a 6 hours of wasting my time searching for notes here and there...
    I think when u end/stop the install in SAPINST, the SAPINST user should log off the AS400 system, but I have noticed, it never does...although when u restart the installation, if u have noticed it shows you the log on for the SAPINST user in the TMKSVR screen...
    Its kind of buggy, I would say...
    I have noticed, that even when I log on to AS400 from home or from a remote PC using Emulator, it shows me logged in the subsystem and even after i have logged of, it still shows me there...
    Anyway, thanks a lot guys...for all your responses..
    Just wanted to let you know all.
    Thanks
    Abhi

  • Load balancing SMA web service and SMA end point URL

    Hi,
    We have set up the recommended 3 servers with Azure Pack, SMA Web Service and Runbook Worker.  We are now wanting to configure the Azure pack portal to setup the SMA endpoint url for the web service.  Before we do that, we are assuming we should
    load balance the web services to answer on 1 url (ie, smaws.domainname.com).
    1. Is there any guidance or things to consider when load balancing the 3 web services to answer to 1 url.  We will probably use f5 since that is what we use.
    2. The end point url that we configure for Azure Pack automation should be this load balanced URL correct?
    3. Should we have the Azure pack installed on just one of the servers or all 3.  We did all 3 but it seems like server2 and 3 just redirect to 1 anyway so I am assuming the URL for Azure pack is stored in a db somewhere.
    4. Are there any other components of SMA/Azure Pack that should also be load balanced?
    Thanks
    Thanks Lance

    So in this case you need to register the SMA Runbook Workers (do this on machine 1):
    $webService
    = "https://localhost"
    $workers
    = (Get-SmaRunbookWorkerDeployment
    -WebServiceEndpoint
    $webService).ComputerName
    if($workers
    -isnot [system.array]) {$workers
    = @($workers)}
    $workers
    += "MachineName2"
    $workers += "MachineName3"
    New-SmaRunbookWorkerDeployment
    -WebServiceEndpoint
    $webService -ComputerName
    $workers

  • ESXi 4.1 NIC Teaming's Load-Balancing Algorithm,Nexus 7000 and UCS

    Hi, Cisco Gurus:
    Please help me in answering the following questions (UCSM 1.4(xx), 2 UCS 6140XP, 2 Nexus 7000, M81KR in B200-M2, No Nexus 1000V, using VMware Distributed Switch:
    Q1. For me to configure vPC on a pair of Nexus 7000, do I have to connect Ethernet Uplink from each Cisco Fabric Interconnect to the 2 Nexus 7000 in a bow-tie fashion? If I connect, say 2 10G ports from Fabric Interconnect 1 to 1 Nexus 7000 and similar connection from FInterconnect 2 to the other Nexus 7000, in this case can I still configure vPC or is it a validated design? If it is, what is the pro and con versus having 2 connections from each FInterconnect to 2 separate Nexus 7000?
    Q2. If vPC is to be configured in Nexus 7000, is it COMPULSORY to configure Port Channel for the 2 Fabric Interconnects using UCSM? I believe it is not. But what is the pro and con of HAVING NO Port Channel within UCS versus HAVING Port Channel when vPC is concerned?
    Q3. if vPC is to be configured in Nexus 7000, I understand there is a limitation on confining to ONLY 1 vSphere NIC Teaming's Load-Balancing Algorithm i.e. Route Based on IP Hash. Is it correct?
    Again, what is the pro and con here with regard to application behaviours when Layer 2 or 3 is concerned? Or what is the BEST PRACTICES?
    I would really appreciate if someone can help me clear these lingering doubts of mine.
    God Bless.
    SiM

    Sim,
    Here are my thoughts without a 1000v in place,
    Q1. For me to configure vPC on a pair of Nexus 7000, do I have to connect Ethernet Uplink from each Cisco Fabric Interconnect to the 2 Nexus 7000 in a bow-tie fashion? If I connect, say 2 10G ports from Fabric Interconnect 1 to 1 Nexus 7000 and similar connection from FInterconnect 2 to the other Nexus 7000, in this case can I still configure vPC or is it a validated design? If it is, what is the pro and con versus having 2 connections from each FInterconnect to 2 separate Nexus 7000?   //Yes, for vPC to UCS the best practice is to bowtie uplink to (2) 7K or 5Ks.
    Q2. If vPC is to be configured in Nexus 7000, is it COMPULSORY to configure Port Channel for the 2 Fabric Interconnects using UCSM? I believe it is not. But what is the pro and con of HAVING NO Port Channel within UCS versus HAVING Port Channel when vPC is concerned? //The port channel will be configured on both the UCSM and the 7K. The pro of a port channel would be both bandwidth and redundancy. vPC would be prefered.
    Q3. if vPC is to be configured in Nexus 7000, I understand there is a limitation on confining to ONLY 1 vSphere NIC Teaming's Load-Balancing Algorithm i.e. Route Based on IP Hash. Is it correct? //Without the 1000v, I always tend to leave to dvSwitch load balence behavior at the default of "route by portID". 
    Again, what is the pro and con here with regard to application behaviours when Layer 2 or 3 is concerned? Or what is the BEST PRACTICES? UCS can perform L2 but Northbound should be performing L3.
    Cheers,
    David Jarzynka

  • Load balancing with use of router 881.

    Hello,
    I have two MPLS line and i want load balancing with the help of CISCO router 881. is it necessary that i require two router on both location.? if one location have firewall and one location have cisco router 881 then can i do a load balancing or i require two router each on both location ? What are the basic requirement that i need.
    Thanks,
    Kuntal

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    An 881 should be able to load share across multiple ports.  Many routing protocol support ECMP, including BGP, but you need "special" hidden/secret commands to enable.  EIGRP also supports unequal cost load sharing.
    If an 881 supports OER or PfR, those too will do unequal load sharing, dynamically.

Maybe you are looking for

  • While executing the query in the web template I am  facing below issue

    Hello SAP geniuses, Please help me on my issue  , while executing the query in the web template i am  facing below issue. The variable for characteristic (region) is appearing but this characteristic (region) is not appearing in the free characterist

  • Is Aperature doing Vintage...not in old ...but slide show?

    Hi, I use the Vintage Theme in autmatic slideshows in Iphoto all the time and my customers love then although the easiest.  Videos on the newest version of Aperature do not show VIntage as a selection when creating a slide show but good old Ken Burns

  • Got error when i try to install sqlCE

    hi i try to run my C# program on Windows-CE 7.0 and gto this error: a nativ exception has occurred in MyProg.exe .....ExceptionCode: 0xc0000005..... i try to install sqlCE  - sqlce.dev.ENU.wce5.armv4i.CAB   and i got this error: The program is not co

  • MRS (Multi Resource Scheduling) - Integrating HR with MRS

    The way I read page 14 of the MRS Implementation Documentation (version 1.5...MRS610 SP05) I should not have to move HR mini-masters into my ERP box where my customer will run MRS. All we should have to do to take advantage of the HR records is to: 1

  • TabNavigator change

    I employ a TabNavigator container in my site and there are three tabs; T1, T2 and T3. When T1 is clicked, I change the currentState to S1 and in that window, I have a button "play" which when I click, starts a video window and plays a file. Midway th