Communication problem between Adobe Form and WebDynpro

Hi all,
I have the following problem and am thankful for any help I can get from you in order to solve it:
I created an Adobe Form in WebDynpro. In both the WebDynpro as well as in the Adobe Form, I created a Submit Button (which I binded to the same method) as well as a text field (which I binded to the same context attribute). When I do changes in WebDynpro, everything works fine and the changes are displayed in the Adobe Form as well.
But when I do changes in the Adobe Form, these changes are not submitted. Also the Submit button in the Adobe Form is not working.
I send the project to a colleague and she could deploy and run my project without any problems. So I think it is a problem with my settings or installation. I already did a reinstallation of the NW Developer Studio as well as the Adobe Lifecycle Designer. But it did not help.
Did anyone have a similar problem or has a suggestions what else I could do?
Thanks in advance,
Thorsten

Hi Thorsten,
If the submit button doesn't do anything, it usually means there's something wrong with your client software.
Are you using NW04s or NW04? NW04 only supports ACF (Active Component Framework) forms, whereas NW04s also supports ZCI (Zero Client Installation) forms (there're different Submit buttons in Adobe LiveCycle Designer). Reader 7.0.9 should definitely work in all cases, but Reader 8.0 (and Reader 8.1, released yesterday) doesn't work properly with ACF forms (there's an SAP note on this subject).
To use ZCI forms, all you need is Adobe Reader at client side. To use ACF forms, you also need some other client software: either (the correct version!) SAP Active Component Framework (stand alone software that you can download from SAP Marketplace; it's part of some SAP note; search for xACF and select the correct version of the note). A better option is not to install xACF manually (uninstall it if present, using Control Panel > Add/Remove programs), but to use the ActiveX control instead (reinstall it in your case because of the problem you have). First kill the AcroRd32.exe process, if it is running. Then go to "C:\WINDOWS\Downloaded Program Files" and delete the file AdobeControl(s) (NW04) or AcfControls (something similar; NW04s) if present. Then access your form in your Web Dynpro application using IE (Firefox doesn't support ActiveX; the only option is to use ZCI forms with non-IE browsers). If all goes well, prior to displaying the form, IE should ask to install an ActiveX control (it will only be asked if you have sufficient privileges, that is belong to the local Administrators group).
Kind regards,
Sigiswald

Similar Messages

  • What is the relation between adobe forms and web dynpro

    hi
    what is the relation between adobe forms and web dynpro

    Hi Jyothsna,
    Adobe forms are advanced to smartforms and scripts.
    Adobe forms are much easier than smartforms they are online forms.
    they can be developed online.
    Adobe forms : This is another SAP tool designed to create your own forms. The transaction for this is SFP.
    How to use them: You can create a sales order form in adobe form and send to the sales reps. Sales reps can fill this form when they are not connected to internet / SAP system. Once they connect to SAP just send an e-mail to a specific user id in outlook. You got to customize and code how do you want to process once you receive this form. This enables you to create orders even when you are not connected to the system. Hence no data loss. This is not how i used though :-). This is just my idea.
    What is the difference between Adobe forms and smart forms / scripts.
    Smart forms / scripts are used to show the data in SAP. Most likely you will use these to print / display some kind of reciepts / forms. Many companies must be using this for hard copies / ALE / EDI or to transfer data from SAP to others.
    Adobe forms are used to post data into SAP from SAP too.  So this has an additional feature compared to smartforms.
    Please check this link
    http://www.erpgenie.com/index.php?option=com_content&task=view&id=600&Itemid=77
    Web dynpro in one of the component in NETWEAVER.
    Web Dynpro is the SAP NetWeaver programming model for user interfaces and provides support when developing the Web representation of business applications. The Web Dynpro model is based on the Model View Controller paradigm, and has the following features that build on the classic dynpro model:
    ·        Clear separation of business logic and display logic
    ·        Uniform metamodel for all types of user interfaces
    ·        Execution on a number of client platforms.
    ·        Extensive platform independence of interfaces
    please check this link
    http://help.sap.com/saphelp_nw04/helpdata/en/a5/1a1e3e7181b60ae10000000a114084/content.htm
    http://help.sap.com/saphelp_nw04s/helpdata/en/77/3545415ea6f523e10000000a155106/frameset.htm
    Best regards,
    raam

  • PDF Attachment problem in Adobe form and send mail is not working

    Dear Experts,
                         Recently i'm facing a problem regarding Adobe form PDF attachment and sending an e-mail along with the PDF attachment to customer mail id.But when i execute the RFC Function module, in customer side no mail is comming. And when i check the transaction SBWP then i found that the PDF attachment hold only 1KB of data which is not right.For that i'm sending my code which i was declared in my program.Can anybody please help me to overcome this problem?
    Warm Regards,
    sameek.
    CLASS cl_bcs DEFINITION LOAD.
      DATA:
      lo_send_request TYPE REF TO cl_bcs VALUE IS INITIAL.
      lo_send_request = cl_bcs=>create_persistent( ).
      data: t_att_content_hex type SOLIX_TAB.
      DATA: lx_document_bcs TYPE REF TO cx_document_bcs VALUE IS INITIAL.
      DATA: lo_sender TYPE REF TO if_sender_bcs VALUE IS INITIAL,
            l_send type ADR6-SMTP_ADDR value 'Already provided an e-mail address here'.
      DATA: lo_recipient TYPE REF TO if_recipient_bcs VALUE IS INITIAL.
      DATA: lv_sent_to_all(1) TYPE c VALUE IS INITIAL.
    Message body and subject*
      DATA:
      lt_message_body TYPE bcsy_text VALUE IS INITIAL,
      lo_document TYPE REF TO cl_document_bcs VALUE IS INITIAL.
      APPEND 'Dear,' TO lt_message_body.
      append ' ' to lt_message_body.
      APPEND 'Please fill the attached form and send it back to us.'
      TO lt_message_body.
      append ' ' to lt_message_body.
      APPEND 'Thank You,' TO lt_message_body.
      lo_document = cl_document_bcs=>create_document(
      i_type = 'RAW'
      i_text = lt_message_body
      i_subject = 'Customer Information Form').
      TRY.
          lo_document->add_attachment(
          EXPORTING
          i_attachment_type = 'PDF'
          i_attachment_subject = 'Customer Information Form'
    I_ATTACHMENT_SIZE =*
    I_ATTACHMENT_LANGUAGE = SPACE*
    I_ATT_CONTENT_TEXT =*
    I_ATTACHMENT_HEADER =*
          i_att_content_hex = t_att_content_hex ).
        CATCH cx_document_bcs INTO lx_document_bcs.
      ENDTRY.
    Add attachment*
    Pass the document to send request*
      lo_send_request->set_document( lo_document ).
    Create sender*
      lo_sender = cl_cam_address_bcs=>create_internet_address( l_send ).
    lo_sender = cl_sapuser_bcs=>create( sy-uname ).*
    Set sender*
      lo_send_request->set_sender(
      EXPORTING
      i_sender = lo_sender ).
    Create recipient*
      lo_recipient = cl_sapuser_bcs=>create( sy-uname ).
    lo_recipient = cl_cam_address_bcs=>create_internet_address( l_send ).*
    Set recipient*
      lo_send_request->add_recipient(
      EXPORTING
      i_recipient = lo_recipient
      i_express = 'X' ).
    lo_send_request->add_recipient(*
    EXPORTING*
    i_recipient = lo_recipient*
    i_express = 'X' ).*
    Send email*
      lo_send_request->send(
      EXPORTING
      i_with_error_screen = 'X'
      RECEIVING
      result = lv_sent_to_all ).
      COMMIT WORK.
      message 'The Customer Information form has been emailed to the Employee' type 'I'.

    I am also facing issue with email send .
    apex 4.1.1 oracle 11g
    create or replace procedure email ( p_email  in    varchar2)
    is
        l_workspace_id      number;
        l_subject           varchar2(2000);
        l_body              clob;
        l_body_html         clob;
         l_email varchar2(40);
    begin
        l_workspace_id := apex_util.find_security_group_id (p_workspace => 'xyz');
        apex_util.set_security_group_id (p_security_group_id => l_workspace_id);
    l_email:= p_email;
        l_body := ' ';
        l_subject := 'You have new tasks';
        --if l_email=:P3_CONFIRM_EMAIL_ADDRESS is not null then
       -- email( l_email =>:P3_CONFIRM_EMAIL );
    -- end if;
            l_body_html := '<p />The following tasks have been added.';
         apex_mail.send (
                p_to        => l_email ,
                p_from      => '[email protected]',
                p_body      => l_body,
                p_body_html => l_body_html,
                p_subj      => l_subject );
      APEX_MAIL.PUSH_QUEUE;
    end; I also check the log and queue but both are empty,
    select * from
    apex_mail_queue
    select * from
    apex_mail_log Kindly suggest what to do ?
    I also created a process in apex , which call this procedure and pass the email address entered by user.

  • Communication problem between ASA 5510 and Cisco 3750, L2 Decode drops

    Having problem with communication between ASA 5510 an Cisco Catalyst 3750.
    Here is the Cisco switch port facing the ASA 5510 configuration:
    interface FastEthernet2/0/6
    description Trunk to ASA 5510
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 50
    switchport trunk allowed vlan 131,500
    switchport mode trunk
    switchport nonegotiate
    And here is the ASA 5510 port configuration:
    interface Ethernet0/3
    speed 100
    no nameif
    no security-level
    no ip address
    interface Ethernet0/3.500
    vlan 500
    nameif outside
    security-level 0
    ip address X.X.X.69 255.255.255.0
    There is a default route on ASA to X.X.X.1.
    When I try to ping from ASA X.X.X.1 i get:
    Sending 5, 100-byte ICMP Echos to 31.24.36.1, timeout is 2 seconds:
    Also in the output of show interface eth 0/3 on the ASA i can see that the L2 Decode drop counter increases.
    I have also changed the ports on the Switch and ASA but the same error stays.
    Any thoughts?

    I don't see anything wrong with your trunk configuration; I have a similar one working between an ASA 5520 and a Catalyst 3750G.
    Maybe you should adjust the "speed 100"?  In my experience, partial autoconfiguration results in duplex mis-matches, which results in dropped packets.
    I'd try removing the "speed 100" and letting the ASA port autonegotiate with the switch.  Alternatively, have both sides set
       speed 100
       duplex full
    and see if things improve.
    -- Jim Leinweber, WI State Lab of Hygiene

  • Communication problem between FPGA VI and Host-PC VI

    Dear,
    I am trying to set up communication between an FPGA an the host-PC using FPGA FIFO's.
    The communication still has some problems and I don't know what would cause them.
    Labview gives me the following reason "The transfer did not complete within the timeout period or within the specified number of retries."
    What is wrong with my labview program? How can i solve this?
    The Project can be found in attachment.
    Best regards,
    Jasper Beurms
    Solved!
    Go to Solution.
    Attachments:
    CEC20_02.zip ‏150 KB

    Hello Jasper,
    Are you fully familiar with how DMA FIFOs work on a cRIO?
    Some general questions:
    - Is there a specific reason that you need to use DMA FIFOs?
      You seem to only require a 10 msec acquisition rate?
    - Wouldn't it be easier to just use the Scan Engine in the case you don't need to go below 10 msec?
    The Scan Engine should allow you to do acquisitions at this rate without even having to implement FPGA code yourself.
    Another benefit is that the Shared Variables created/published by the Scan Engine are also by default visible over the network/
    If want to use DMA FIFOs, then I would suggest you take a look at the Compact RIO Developer's Guide: http://www.ni.com/compactriodevguide/
    I would advise that you read out the DMA FIFOs on a VI that is running on the RT Controller (RT VI) and then send those values from the RT VI over the network to your Windows VI.
    You could use for example Shared variables to sent values from the RT VI to the Windows Host VI.
    Another solution might be to use network streams or more custom TCP/IP communication.
    If these concepts are new to you, then please have look at the Compact RIO Developer's Guide: http://www.ni.com/compactriodevguide/
    This Guide should explain you all the basics you need to know.
    If something is unclear or requires further explanation, then please let me know.
    Kind Regards,
    Thierry C - Applications Engineering Specialist Northern European Region - National Instruments
    CLD, CTA
    If someone helped you, let them know. Mark as solved and/or give a kudo.

  • Communication Problem between RTD,Pt1000 and MAX

    Bonjour,
    J'ai un probleme de communication entre MAX et un Agilent,
    Je dispose d'un agilent 34970A, d'un GPIB et d'une carte insere dans l'agilent (34901A).
    Avec MAX je communique avec "communicate with instrument" en language SCPI,
    J'ai reussit a connaitre les temperature de mes Pt100 4 fils et des thermocouples dont les commandes sont:
    Thermocouples de type J: MEAS:TEMP? TC, J, (@203)
    Pt 100, 4 fils: MEAS:TEMP? FRTD, (@201)
    Mon probleme est de communiquer avec la Pt1000 sur le port CH6
    J'ai essayer:
             MEAS:TEMP? RTD, 85,1, 3E-06, (@206) mais on a par default la valeur d'une Pt100 2 fls
             Lorsque l'on configure la resistance avec TEMP:TRAN:RTD:RES 1000, (@206) cela fonctionne car si on lui demande TEMP:TRAN:RTD:RES? (@206) on a bien les 1.0000E+03 ohms. Mais je ne peut pas demander la temperature par la suite.
    Merci d'avance pour vos reponse.
    If you don't understand French I can translate.

    About this two kind exemple they are working:
    MEAS:TEMP? TC, J, (@203) and MEAS:TEMP? FRTD, (@201) for the measure of Thermocouple and RTD 4W,Pt100.
    But for the RTD 2W, Pt1000 it doesn't work.
    Could you give me an exemple of measurment  for this Pt1000 please ?

  • Communication problem between Cisco 3560 and Cisco SG300.

    Dear Support,
    I have a Cisco SG300 and Cisco 3560 switches.
    3560 is my Core Switch and SG300 is access switch.
    From 3560 VLAN information is not passed to SG300.
    3560 Configuration:
    interface GigabitEthernet0/23
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,2,10,11
    switchport mode trunk
    SG300 Configuration:
    interface gigabitethernet49
    spanning-tree link-type point-to-point
    switchport mode general
    switchport general allowed vlan add 2,10-11 tagged
    macro description switch
    Please suggest how this issue is resolve.
    Regards,
    JItesh Mahajan.

    Dear Aleksandra,
    Below Configuration is right or wrong for 3560 and SG300.
    3560 Configuration:
    interface GigabitEthernet0/23
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan remove VLAN 1
    switchport native vlan 1
    switchport trunk allowed vlan 1,2,10,11
    switchport mode trunk
    SG300 Configuration:
    interface gigabitethernet49
    spanning-tree link-type point-to-point
    switchport mode general
    switchport general allowed vlan add 2,10-11 tagged
    macro description switch
    Regards,
    JItesh Mahajan.

  • Diff  bet Adobe forms and smart forms?

    Hi Friends
    What is the diff between Adobe forms and Smart Forms
    Thanks & Regards
    Kanni

    Hello,
    Smartform:
    To create and maintain forms for mass printing in SAP systems. Besides using the printer for standard output you can also select the Internet (by using a generated HTML output), a fax, or e-mail as the output medium. Smart Forms allows you to execute simple modifications to the form and in the form logic by using simple graphical tools
    http://help.sap.com/saphelp_srm70/helpdata/EN/16/a369b1800e4bdda978ee0fe3b7bd2c/frameset.htm
    Adobe Form:
    Interactive forms in PDF format that allow users to fill out the form on the screen and save their entries in XML format in the form. When the SAP system receives the PDF form, it extracts the data saved in the form, and can process it further.
    http://help.sap.com/saphelp_srm70/helpdata/EN/f2/21021b911f4c0cae11459a4ce0bc62/frameset.htm
    Links will provide more information.
    Thanks
    Ashutosh

  • Communication problem between NetBeans and Tomcat

    hi!
    i got a quite mysterious problem. here is what happens:
    - i start NetBeans 5.5.1 (the first time)
    - i want to debug my JSF-Project, the Debugger starts
    - After a few seconds the debugger waits for tomcat (it sais: "Waiting for Tomcat...") and tomcat starts
    - Again after a few seconds the tomcat-debugger-output sais "Tomcat startet in 3333 ms".
    okay.
    when i enter http://localhost:8084/ in my browser i get the tomcat homepage, so the server has definitely started! But nothing happens in NetBeans and nothing happens with my project....
    In the lower-right corner i see this blue working-bar that sais "deploying project" but nothing happens. The Project-Debugger-Output still sais "Waiting for Tomcat..." but nothing happens...
    And after something around 3 minutes (i guess it's a timeout) i get the error "Starting of Tomcat failed." But is HAS started, i can login to the Administration-Area in my browser!
    so i guess there is a communication problem between netbeans an tomcat. Netbeans waits for a message from tomcat but tomcat doesn't send it..or netbeans doesn't understand it.
    But the story goes on:
    When i press the debug-button a second time it takes only a few seconds till i get the message: "Tomcat server port 8084 already in use". OF COURSE! Because Tomcat has already startet and can't be stoped by NetBeans.
    i'm trying to solve this problem for 4 days now, so i would be very happy if anyone has an idea where to start/continue the search...
    thanks,
    flo.
    some system-info:
    - windows vista business 32-bit
    - no firewall is running
    - AntiVir Personal Edition IS running
    - Yahoo Widgets Engine IS running
    - no other software is running
    and finally the tomcat-log:
    Using CATALINA_BASE: C:\Users\Administrator\.netbeans\5.5.1\apache-tomcat-5.5.17_base
    Using CATALINA_HOME: C:\Program Files\NetBeans\enterprise3\apache-tomcat-5.5.17
    Using CATALINA_TMPDIR: C:\Users\Administrator\.netbeans\5.5.1\apache-tomcat-5.5.17_base\temp
    Using JRE_HOME: C:\Program Files\Java\jdk1.5.0_12
    Listening for transport dt_shmem at address: tomcat_shared_memory_id
    21.09.2007 18:27:50 org.apache.catalina.core.AprLifecycleListener lifecycleEvent
    INFO: The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\Java\jdk1.5.0_12\bin;.;C:\Windows\system32;C:\Windows;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Program Files\QuickTime\QTSystem\;C:\Program Files\ThinkPad\ConnectUtilities;C:\Program Files\Common Files\Teleca Shared;C:\Program Files\Common Files\Adobe\AGL;C:\Program Files\MySQL\MySQL Server 5.0\bin;C:\Program Files\cvsnt;
    21.09.2007 18:27:50 org.apache.coyote.http11.Http11BaseProtocol init
    INFO: Initializing Coyote HTTP/1.1 on http-8084
    21.09.2007 18:27:50 org.apache.catalina.startup.Catalina load
    INFO: Initialization processed in 1862 ms
    21.09.2007 18:27:50 org.apache.catalina.core.StandardService start
    INFO: Starting service Catalina
    21.09.2007 18:27:50 org.apache.catalina.core.StandardEngine start
    INFO: Starting Servlet Engine: Apache Tomcat/5.5.17
    21.09.2007 18:27:50 org.apache.catalina.core.StandardHost start
    INFO: XML validation disabled
    21.09.2007 18:27:53 org.apache.coyote.http11.Http11BaseProtocol start
    INFO: Starting Coyote HTTP/1.1 on http-8084
    21.09.2007 18:27:54 org.apache.jk.common.ChannelSocket init
    INFO: JK: ajp13 listening on /0.0.0.0:8009
    21.09.2007 18:27:54 org.apache.jk.server.JkMain start
    INFO: Jk running ID=0 time=0/31 config=null
    21.09.2007 18:27:54 org.apache.catalina.storeconfig.StoreLoader load
    INFO: Find registry server-registry.xml at classpath resource
    21.09.2007 18:27:54 org.apache.catalina.startup.Catalina start
    INFO: Server startup in 3626 ms

    As i wrote before, the same problem occured for me. I have found a solution which is : Go to tools menu and then select options . In the proxy info, select No Proxy.
    I hope this help you

  • Difference between Smart Forms and Adobe Form

    Hi all,
    What are disadvantages of Smart form in SAP ,
    What is difference between Smart Forms and Adobe interactive Form.
    I heard from someone that in future Adobe interactive Form will repalce smart forms. Is it true or not
    Best Regards
    Srikanth

    Hi,
    Companies depend on formal documents that reflect their corporate identities and contain critical business information from live systems. SAP and Adobe partnered for automating and streamlining forms-based communication to support customers who create reusable forms for their business processes.
    SAP Interactive Forms by Adobe will be used more and more as a way of simplifying and automating manual processes.
    There are various advantages of Adobe forms.
    SAP Interactive Forms by Adobe provides all the features and functions you need to create form-based output, such as order confirmations, invoices, or pay slips. You can either print such documents or send them by email or FAX.
    <b>Online Interactive Forms</b>
    A user logs on to the company intranet to fill in a form required by the HR department (for example, a Non-Disclosure Agreement to be signed by a new employee). The form is displayed in the browser.
    As the user is logged on in the background to the company's HR system, his master data is displayed in the form. The user enters the required information in the fillable fields of the interactive form, and sends the data back to the system by pushing a button. The system extracts the data from the form and saves it in the database.
    <b>Offline Interactive Forms</b>
    The purchasing department of a company creates a bid in its Enterprise Resource Planning (ERP) system and selects the potential vendors. Based upon this data, the system automatically creates interactive bidding forms with specific vendor information, such as the address or contact person.
    The forms are transmitted to the vendors by email. The vendors can fill out the forms offline (without being connected to the system that created the forms) and transmit them back to the company. The company then processes the forms automatically, and the data provided by the vendors is written to the ERP system. The purchasing department uses the data to evaluate the quotation and then issues an order.
    <b>With the integration of Adobe PDF technology into its solutions, SAP will be able to further extend its offerings of end-to-end business solutions by:</b>
    Providing for the first time the capabilities of Adobe's interactive PDF-based forms.
    Integrating PDF documents into business processes that are driven by SAP applications.
    Automating the process of moving XML data from SAP applications into interactive forms and vice versa.
    Reducing time to design, manage, and maintain extended forms-based processes through easy-to-use forms design and deployment tools.
    Offering its customers enhanced printing capabilities, in particular for interactive Web applications.
    The focus of new forms technology from SAP is interactive PDF-based forms that can be created in SAP systems as a result of the <b>integration of Adobe technology with Web Dynpro and the SAP NetWeaver Developer Studio.</b> This integration means that adobe is the future technology.
    Regards,
    Kate

  • Communication problem with Adobe 9.0 and HP Printer when I scan

    I'm having a problem getting a .pdf file to come up when I scan from a HP 5610 All-in-one printer. Have uninstalled and reinstalled HP software three times but when I scan and want a pdf file it won't communicate with Adobe 9.0 reader for some reason. Is there a setting in Adobe reader that's a problem?
    Thanks.

    Thanks...found out that an HP5610xi All-in-One will not completely communicate with Adobe 9.0   Had to go to Adobe 6.0
    Date: Thu, 17 Dec 2009 03:19:49 -0700
    From: [email protected]
    To: [email protected]
    Subject: Communication problem with Adobe 9.0 and HP Printer when I scan
    May be that the HP software doesn't support Adobe Reader 9.
    >

  • Printing Adobe Form in Webdynpro

    Hi Experts,
    I need one help  from all of you , its quite urgent.
    Actually I am trying to print Adobe form in webdynpro method like below:
       "----- Take the Adobe fprm -------------------"
          lv_form_name = 'ZHR_SAP_FORM'.
          CALL FUNCTION 'FP_FUNCTION_MODULE_NAME'
            EXPORTING
              i_name     = lv_form_name
            IMPORTING
              e_funcname = lv_fm_name.
          lfs_output_params-nodialog = 'X'.
          lfs_output_params-getpdf   = 'X'.
          lfs_output_params-device   = 'TR5T'.
          lfs_output_params-connection   = 'ADS'.
          CALL FUNCTION 'FP_JOB_OPEN'
            CHANGING
              ie_outputparams = lfs_output_params
            EXCEPTIONS
              cancel          = 1
              usage_error     = 2
              system_error    = 3
              internal_error  = 4
              OTHERS          = 5.
          IF sy-subrc <> 0.
    * Implement suitable error handling here
          ENDIF.
    *---Form language
          lfs_doc_params-langu = 'E'.
    *---Call Adobe form.
          CALL FUNCTION lv_fm_name  
            EXPORTING
             /1bcdwb/docparams         = lfs_doc_params
              gt_item                  = lit_zhrauth_item
              gs_hrauth                = lwa_zhrauth
           IMPORTING
             /1bcdwb/formoutput       =  lwa_output
           EXCEPTIONS
             usage_error              = 1
             system_error             = 2
             internal_error           = 3
             OTHERS                   = 4
          IF sy-subrc <> 0.
    * Implement suitable error handling here
          ENDIF.
    *---Job Close
          CALL FUNCTION 'FP_JOB_CLOSE'
    * IMPORTING
    *   E_RESULT             =
           EXCEPTIONS
             usage_error          = 1
             system_error         = 2
             internal_error       = 3
             OTHERS               = 4
          IF sy-subrc <> 0.
    * Implement suitable error handling here
          ENDIF.
    Here , the funtion module name is coming correctly.
    But when calling function CALL FUNCTION 'FP_JOB_OPEN' ,
    It is giving sy-subrc = 2 , i.e. usage error (An Exception).
    Similarily , due to this i am getting same exception in 
    CALL FUNCTION  lv_fm_name
    So some one please help me , what should i do ,
    am i supposed to pass some other parameter in  CALL FUNCTION 'FP_JOB_OPEN'
    Hopefully , waiting for responds.
    Thanks & Regards;
    Gaurav Singh

    HI Sikka,
    Thanx for the reply ,
    With your solution CALL FUNCTION 'FP_JOB_OPEN' is done.
    but the same  problem is still happening with
    CALL FUNCTION  lv_fm_name and it is giving sy-subrc = 2.
    i.e.   system_error             =  2
    Thanx !!!

  • Adobe forms in webdynpro abap

    which is better to use adobe forms . whether webdynpro with abap or java?

    The capabilities around the usage of the Adobe Forms is pretty equal between WDA and WDJ now.  In the earlier support packages when we only had ACF based forms, WDA did lack some of the UI elemetns supported by WDJ when using Adobe Forms. However with the addition of ZCI (Zero-Client Installation) based forms in WDA, the features are quite equal.
    To me the better question is: where is your data and what programming language do you want to use.  These are the main deciding factors between using WDA or WDJ in this situation.

  • To integrate the Adobe form in webdynpro ABAP

    Hi Experts,
                    How to use the adobe form in Webdynpro ABAP?
    Thanks & regads
        Vino

    That is quite the general question and I think if you search SCN you will find many resources - such as videos, tutorials, how-to guides, documentation - on the subject.  Perhaps just starting with the online Help and the associated links form the help article will get you started:
    http://help.sap.com/saphelp_nw70ehp1/helpdata/en/0f/128841e8231709e10000000a155106/frameset.htm

  • Problem  in Adobe Form

    Hi,
    I have some problem in adobe form.................................
    I have to design  my adobe form in  ADOBE DESIGNER layout.
    and in the another end i have make my application programe in which i picke
    some data from the sap tables. now my problem is that how can i send the data in
    my adobe form from my programe  i want to print that data on the form.
    and always my programe is going to be  notresponding.

    CALL FUNCTION 'FP_FUNCTION_MODULE_NAME'
          EXPORTING
            i_name     = 'Adobe form name'
          IMPORTING
            e_funcname = lv_funcname.
        IF sy-subrc = 0.
    u will get the fm name here.....
    use fb_job_open
        CALL FUNCTION 'FP_JOB_OPEN'
          CHANGING
            ie_outputparams = gs_output
          EXCEPTIONS
            cancel          = 1
            usage_error     = 2
            system_error    = 3
            internal_error  = 4
            OTHERS          = 5.
        IF sy-subrc <> 0.
    MESSAGE ID SY-MSGID TYPE SY-MSGTY NUMBER SY-MSGNO
            WITH SY-MSGV1 SY-MSGV2 SY-MSGV3 SY-MSGV4.
        ENDIF.
    CALL FUNCTION lv_funcname
          EXPORTING
            /1bcdwb/docparams  = gs_outputpara
            wa_data            = <> pass value here....as per u r requirement.(interface)
            PATH             = <>
          IMPORTING
            /1bcdwb/formoutput = ls_return
          EXCEPTIONS
            OTHERS             = 1.
                          FP_JOB_CLOSE
        CALL FUNCTION 'FP_JOB_CLOSE'
          IMPORTING
            e_result       = result
          EXCEPTIONS
            usage_error    = 1
            system_error   = 2
            internal_error = 3
            OTHERS         = 4.
        IF sy-subrc <> 0.
    regards
    Anbu B

Maybe you are looking for