Compare Host Configurations via custom script

I have a verification shell script that I have on my servers. The script goes off and responds with COTS versions, deployment versions, software bundles, and various other pedigree information about that server. It is beneficial to me, in that I can quickly analyze what software is sitting on a specific server. I can run this script from OEM 12c, using the run Host command and see the results in a clean GUI fashion.
My dilemma is this: I would like to be able to save or store a process to leverage OEM to automate this procedure...on multiple servers, and then do a comparison of the two results. So basically, run the script on server 1 and server 2...and show a comparison (somewhat like the configuration comparison tool) of the results of the two server scripts...showing what is identical and what is different on each server. Is something like this possible?
One idea I had was to design a plugin to create a new target type, that stores all of the results of this script in a target. Then doing a comparison of those targets would show me the differences. That is a long drawn out process and I am not really familiar with it. So I am looking for some additional ideas from other users...Thank you ahead of time.

Guinea,
What you need is custom configuration collection. This feature will allow you to register your script for scheduled execution. the output of this script is parsed and stored in the EM repository and can be used for comparisons, searching, report generation, etc.
Refer to the following documentation:
http://docs.oracle.com/cd/E24628_01/em.121/e27046/config_mgmt.htm#BABBDHCB

Similar Messages

  • Dynamic filename configuration via custom EJB

    Hi Experts,
                        We are doing a poc on whether we can do the dynamic filename configuration,i.e. set the file name dynamically in a custom EJB deployed on the server and called in the sender comm. channel of any J2EE based adapter.
    The requirement is for some interfaces, there is no mapping requirement other then setting the filename dynamically, which maybe based on a certain value of the input file or a specific portion of string in the payload.
    The custom EJB takes the namespace and attribute as input parameters along with other string manupulation parameters to determine the receiver file name. That is if we are using sender JMS adapter, we can have namespace = http://sap.com/xi/XI/System/JMS and attribute as DCJMSMessageProperty1. The bean would read the value and perform the manipulation based on certain other input parameters and set the file.
    There is one particular bean : AF_Modules/DynamicConfigurationBean but it does not allow us to manipulate the filename.
    Any help would be much appreciated.
    Regards,
    Shiladitya

    Hi,
    please refer to the following links for your reference
    Re: Reading Dynamic Configuration information in side adapter module.
    Re: Dynamic Filename in File adapter
    Regards,
    Bhanu

  • How to fetch data into my custom script configured in qc02 transaction

    Hi All,
    I configured the custom SAP-Script in place of standard script name in QC02 tcode.In my requirement when I execute QC22
    transaction the custom script will be triggered along with some data based on material number,batch number and plant.I need to fetch QALS-KTEXTMAT , QALS-CHARG, MCH1-HSDAT and MCH1-VFDAT.Please help me how to fetch this data.Any Enahancement need to use or any spot is there Please specify.
    Thanks in advance.
    Regards,
    Satya.
    Edited by: satyareddygade on Sep 8, 2011 2:13 PM

    Hi Satya,
    Try like this in your Script window text element.
    /: PERFORM FETCH_KTEXTMAT IN PROGRAM <Z Subroutine Pool program>                                                                               
    /: USING &QALS-PRUEFLOS&                                                                               
    /: CHANGING &GV_KTEXTMAT&                                                                               
    /: ENDPERFORM
    in Z Subroutine Pool program
    FORM fetch_ktextmat TABLES  intab  STRUCTURE itcsy
                                outtab STRUCTURE itcsy.
      DATA:
        lv_prueflos TYPE qals-prueflos,
        lv_ktextmat TYPE qals-ktextmat.
    *---Get Inspection Lot Number
      READ TABLE intab WITH KEY 'QALS-PRUEFLOS'.
      CHECK sy-subrc = 0.
      lv_prueflos = intab-value.
      SELECT SINGLE ktextmat FROM qals INTO lv_ktextmat WHERE prueflos EQ lv_prueflos.
      outtab-value = lv_ktextmat.
      MODIFY outtab FROM outtab TRANSPORTING value WHERE
      name = 'GV_KTEXTMAT'.
      CLEAR : intab,outtab.
    ENDFORM.                    "FETCH_KTEXTMAT
    /: PERFORM FETCH_HSDAT IN PROGRAM <Z Subroutine Pool program>    
    /: USING &*VBDPL-MATNR&
    /: USING &VBDPL-CHARG&
    /: CHANGING &GV_HSDAT&
    FORM fetch_hsdat TABLES  intab  STRUCTURE itcsy
                                outtab STRUCTURE itcsy.
      DATA:
        lv_matnr TYPE vbdpl-matnr,
        lv_charg TYPE vbdpl-charg,
        lv_hsdat TYPE mch1-hsdat.
    *---Get Material Number
      READ TABLE intab WITH KEY '*VBDPL-MATNR'.
      CHECK sy-subrc = 0.
      lv_matnr = intab-value.
    *---Get Batch Number
      READ TABLE intab WITH KEY 'VBDPL-CHARG'.
      CHECK sy-subrc = 0.
      lv_charg = intab-value.
      SELECT SINGLE hsdat FROM mch1 INTO lv_hsdat WHERE matnr EQ lv_matnr
                                                    AND charg EQ lv_charg.
      outtab-value = lv_hsdat.
      MODIFY outtab FROM outtab TRANSPORTING value WHERE
      name = 'GV_HSDAT'.
      CLEAR : intab,outtab.
    ENDFORM.                    "FETCH_HSDAT
    Use the following program symbols where you want to print.
    &GV_KTEXTMAT& &QALS-CHARG& &GV_HSDAT& and &MCH1-VFDAT&
    Regards,
    Surya.

  • Quick and dirty powershell script to backup esx 4.1 host configuration.

    Hi, I am trying to achieve the following objective.
    Login to each esx 4.1 host and backup its configuration.
    My script is as follows:
    When I step through, it fails line 14. I get the following error:
    I can see that for some reason the $s variable is not being passed through the command. It leaving it as $s.
    I can see that the variable is working fine for other lines 11, 12, and 16
    Any help would be welcomed.

    Hi,
    You cannot pass the ip address to Get-VMHostFirmware -VMHost. Instead you need to pass the hostname and it will work like charm.
    thanks,
    Rohith

  • Configuring a custom fax cover page to send via SMTP

    Hi,
    Does anyone know how we can configure  a custom fax cover page in the case of sending fax via SMTP, for instance in the process of sending the payment advice, associated with transaction F110? I have a situation where a fax cover page that clearly was developed (maybe SAPSCRIPT) is being sent along with the document (wich was created as an attachment to the email), but don´t understand where it came from and i want to inhibit it from being sent.
    Thanks,
    Bruno

    Hi Hasan,
    I have similar requirement. I see your post is pretty old and hope you would have found the solution at that time.
    Could you please share it with me?
    Thanks
    Puneet

  • How to fetch Signature in to my custom script configured in qc02 from DSAL

    Hi All,
    In my requirement I need to get the signature from DSAL tcode for a particular material(may be BULK or FINISHED) while executing QC22 tcode.I already got the remaining data in to the form like QALS-KTEXTMAT , QALS-CHARG,MCH1-VFDAT and MCH1-HSDAT
    by writing subroutine pool program in my script.Only thing left is need to fetch Digital Signature(signature for a material who certifies).
    Help me if anyone knows.Thanks in advance.
    Regrads,
    Satya.

    Hi Satya,
    Implement USER EXIT to link the signature to your custom script.
    Refer following link it may be useful...
    http://wiki.sdn.sap.com/wiki/display/SAPMDM/E-SIGNATUREforMaintenancePlants-MasterData(ECC6.0)
    Regards,
    Surya.

  • How do you configure a VM image to run a custom script ONCE on startup?

    Hello,
    I am creating a Windows image that will be deployed to the VM depot:
    https://vmdepot.msopentech.com/List/Index
    When the image is run for the first time, I'd like to run a custom script.  However, I only want this script to run the first time the VM is run (and never again).
    How would I do this?
    Thanks!
    Matt

    Hi,
    Please see SetupComplete.cmd at
    http://technet.microsoft.com/en-us/library/dd744268(v=ws.10).aspx
    Anders Bengtsson | Microsoft PFE | blog at http://www.contoso.se

  • Webserver on DMZ cannot send email via php script using SMTP (cisco firewall pix 515e)

    Hello,
    I have two web servers that are sitting in a DMZ behind a Cisco Firewall PIX 515e. The webservers appear to be configured correctly as our website and FTP website are up. On two of our main website, we have two contact forms that use a simple html for to call a php script that uses smtp as its mailing protocol. Since, I am not the network administrator, I don't quite understand how to  read the current configurations on the firewall, but I suspect that port 25 is blocked, which prevents the script from actually working or sending out emails.  What I've done to narrow the problem done is the following: I used a wamp server to test our scripts with our smtp servers settings, was able to successfully send an email out to both my gmail and work place accounts. Currently, we have backupexec loaded on both of these servers, and when I try to send out an alert I never receive it. I think because port 25 is closed on both of those servers.  I will be posting our configuration. if anyone can take a look and perhaps explain to me how I can change our webservers to communicate and successfully deliver mail via that script, I would gladly appreciate it. our IP range is 172.x.x.x, but it looks like our webservers are using 192.x.x.x with NAT in place. Please someone help.
    Thanks,
    Jeff Mateo
    PIX Version 6.3(4)
    interface ethernet0 100full
    interface ethernet1 100full
    interface ethernet2 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    nameif ethernet2 DMZ security50
    enable password GFO9OSBnaXE.n8af encrypted
    passwd GFO9OSBnaXE.n8af encrypted
    hostname morrow-pix-ct
    domain-name morrowco.com
    clock timezone EST -5
    clock summer-time EDT recurring
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    no fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    name 12.42.47.27 LI-PIX
    name 172.20.0.0 CT-NET
    name 172.23.0.0 LI-NET
    name 172.22.0.0 TX-NET
    name 172.25.0.0 NY-NET
    name 192.168.10.0 CT-DMZ-NET
    name 1.1.1.1 DHEC_339849.ATI__LEC_HCS722567SN
    name 1.1.1.2 DHEC_339946.ATI__LEC_HCS722632SN
    name 199.191.128.105 web-dns-1
    name 12.127.16.69 web-dns-2
    name 12.3.125.178 NY-PIX
    name 64.208.123.130 TX-PIX
    name 24.38.31.80 CT-PIX
    object-group network morrow-net
    network-object 12.42.47.24 255.255.255.248
    network-object NY-PIX 255.255.255.255
    network-object 64.208.123.128 255.255.255.224
    network-object 24.38.31.64 255.255.255.224
    network-object 24.38.35.192 255.255.255.248
    object-group service morrow-mgmt tcp
    port-object eq 3389
    port-object eq telnet
    port-object eq ssh
    object-group network web-dns
    network-object web-dns-1 255.255.255.255
    network-object web-dns-2 255.255.255.255
    access-list out1 permit icmp any any echo-reply
    access-list out1 permit icmp object-group morrow-net any
    access-list out1 permit tcp any host 12.193.192.132 eq ssh
    access-list out1 permit tcp any host CT-PIX eq ssh
    access-list out1 permit tcp any host 24.38.31.72 eq smtp
    access-list out1 permit tcp any host 24.38.31.72 eq https
    access-list out1 permit tcp any host 24.38.31.72 eq www
    access-list out1 permit tcp any host 24.38.31.70 eq www
    access-list out1 permit tcp any host 24.38.31.93 eq www
    access-list out1 permit tcp any host 24.38.31.93 eq https
    access-list out1 permit tcp any host 24.38.31.93 eq smtp
    access-list out1 permit tcp any host 24.38.31.93 eq ftp
    access-list out1 permit tcp any host 24.38.31.93 eq domain
    access-list out1 permit tcp any host 24.38.31.94 eq www
    access-list out1 permit tcp any host 24.38.31.94 eq https
    access-list out1 permit tcp any host 24.38.31.71 eq www
    access-list out1 permit tcp any host 24.38.31.71 eq 8080
    access-list out1 permit tcp any host 24.38.31.71 eq 8081
    access-list out1 permit tcp any host 24.38.31.71 eq 8090
    access-list out1 permit tcp any host 24.38.31.69 eq ssh
    access-list out1 permit tcp any host 24.38.31.94 eq ftp
    access-list out1 permit tcp any host 24.38.31.92 eq 8080
    access-list out1 permit tcp any host 24.38.31.92 eq www
    access-list out1 permit tcp any host 24.38.31.92 eq 8081
    access-list out1 permit tcp any host 24.38.31.92 eq 8090
    access-list out1 permit tcp any host 24.38.31.93 eq 3389
    access-list out1 permit tcp any host 24.38.31.92 eq https
    access-list out1 permit tcp any host 24.38.31.70 eq https
    access-list out1 permit tcp any host 24.38.31.74 eq www
    access-list out1 permit tcp any host 24.38.31.74 eq https
    access-list out1 permit tcp any host 24.38.31.74 eq smtp
    access-list out1 permit tcp any host 24.38.31.75 eq https
    access-list out1 permit tcp any host 24.38.31.75 eq www
    access-list out1 permit tcp any host 24.38.31.75 eq smtp
    access-list out1 permit tcp any host 24.38.31.70 eq smtp
    access-list out1 permit tcp any host 24.38.31.94 eq smtp
    access-list dmz1 permit icmp any any echo-reply
    access-list dmz1 deny ip any 10.0.0.0 255.0.0.0
    access-list dmz1 deny ip any 172.16.0.0 255.240.0.0
    access-list dmz1 deny ip any 192.168.0.0 255.255.0.0
    access-list dmz1 permit ip any any
    access-list dmz1 deny ip any any
    access-list nat0 permit ip CT-NET 255.255.0.0 192.168.220.0 255.255.255.0
    access-list nat0 permit ip host 172.20.8.2 host 172.23.0.2
    access-list nat0 permit ip CT-NET 255.255.0.0 LI-NET 255.255.0.0
    access-list nat0 permit ip CT-NET 255.255.0.0 NY-NET 255.255.0.0
    access-list nat0 permit ip CT-NET 255.255.0.0 TX-NET 255.255.0.0
    access-list vpn-split-tun permit ip CT-NET 255.255.0.0 192.168.220.0 255.255.255
    .0
    access-list vpn-split-tun permit ip CT-DMZ-NET 255.255.255.0 192.168.220.0 255.2
    55.255.0
    access-list vpn-dyn-match permit ip any 192.168.220.0 255.255.255.0
    access-list vpn-ct-li-gre permit gre host 172.20.8.2 host 172.23.0.2
    access-list vpn-ct-ny permit ip CT-NET 255.255.0.0 NY-NET 255.255.0.0
    access-list vpn-ct-ny permit ip CT-DMZ-NET 255.255.255.0 NY-NET 255.255.0.0
    access-list vpn-ct-tx permit ip CT-NET 255.255.0.0 TX-NET 255.255.0.0
    access-list vpn-ct-tx permit ip CT-DMZ-NET 255.255.255.0 TX-NET 255.255.0.0
    access-list static-dmz-to-ct-2 permit ip host 192.168.10.141 CT-NET 255.255.248.
    0
    access-list nat0-dmz permit ip CT-DMZ-NET 255.255.255.0 192.168.220.0 255.255.25
    5.0
    access-list nat0-dmz permit ip CT-DMZ-NET 255.255.255.0 LI-NET 255.255.0.0
    access-list nat0-dmz permit ip CT-DMZ-NET 255.255.255.0 NY-NET 255.255.0.0
    access-list nat0-dmz permit ip CT-DMZ-NET 255.255.255.0 TX-NET 255.255.0.0
    access-list static-dmz-to-ct-1 permit ip host 192.168.10.140 CT-NET 255.255.248.
    0
    access-list static-dmz-to-li-1 permit ip CT-DMZ-NET 255.255.255.0 CT-NET 255.255
    .248.0
    access-list vpn-ct-li permit ip CT-NET 255.255.0.0 LI-NET 255.255.0.0
    access-list vpn-ct-li permit ip CT-DMZ-NET 255.255.255.0 LI-NET 255.255.0.0
    access-list vpn-ct-li permit ip host 10.10.2.2 host 10.10.1.1
    access-list in1 permit tcp host 172.20.1.21 any eq smtp
    access-list in1 permit tcp host 172.20.1.20 any eq smtp
    access-list in1 deny tcp any any eq smtp
    access-list in1 permit ip any any
    access-list in1 permit tcp any any eq smtp
    access-list cap4 permit ip host 172.20.1.82 host 192.168.220.201
    access-list cap2 permit ip host 172.20.1.82 192.168.220.0 255.255.255.0
    access-list in2 deny ip host 172.20.1.82 any
    access-list in2 deny ip host 172.20.1.83 any
    access-list in2 permit ip any any
    pager lines 43
    logging on
    logging timestamp
    logging buffered notifications
    logging trap notifications
    logging device-id hostname
    logging host inside 172.20.1.22
    mtu outside 1500
    mtu inside 1500
    mtu DMZ 1500
    ip address outside CT-PIX 255.255.255.224
    ip address inside 172.20.8.1 255.255.255.0
    ip address DMZ 192.168.10.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool ctpool 192.168.220.100-192.168.220.200
    ip local pool ct-thomson-pool-201 192.168.220.201 mask 255.255.255.255
    pdm history enable
    arp timeout 14400
    global (outside) 1 24.38.31.81
    nat (inside) 0 access-list nat0
    nat (inside) 1 CT-NET 255.255.0.0 2000 10
    nat (DMZ) 0 access-list nat0-dmz
    static (inside,DMZ) CT-NET CT-NET netmask 255.255.0.0 0 0
    static (inside,outside) 24.38.31.69 172.20.8.2 netmask 255.255.255.255 0 0
    static (DMZ,outside) 24.38.31.94 192.168.10.141 netmask 255.255.255.255 0 0
    static (inside,outside) 24.38.31.71 172.20.1.11 dns netmask 255.255.255.255 0 0
    static (DMZ,outside) 24.38.31.93 192.168.10.140 netmask 255.255.255.255 0 0
    static (DMZ,inside) 24.38.31.93 access-list static-dmz-to-ct-1 0 0
    static (DMZ,inside) 24.38.31.94 access-list static-dmz-to-ct-2 0 0
    static (inside,outside) 24.38.31.92 172.20.1.56 netmask 255.255.255.255 0 0
    static (DMZ,outside) 24.38.31.91 192.168.10.138 netmask 255.255.255.255 0 0
    static (DMZ,outside) 24.38.31.90 192.168.10.139 netmask 255.255.255.255 0 0
    static (inside,outside) 24.38.31.72 172.20.1.20 netmask 255.255.255.255 0 0
    static (inside,outside) 24.38.31.73 172.20.1.21 netmask 255.255.255.255 0 0
    static (inside,outside) 24.38.31.70 172.20.1.91 netmask 255.255.255.255 0 0
    static (DMZ,outside) 24.38.31.88 192.168.10.136 netmask 255.255.255.255 0 0
    static (DMZ,outside) 24.38.31.89 192.168.10.137 netmask 255.255.255.255 0 0
    static (inside,outside) 24.38.31.74 172.20.1.18 netmask 255.255.255.255 0 0
    static (inside,outside) 24.38.31.75 172.20.1.92 netmask 255.255.255.255 0 0
    access-group out1 in interface outside
    access-group dmz1 in interface DMZ
    route outside 0.0.0.0 0.0.0.0 24.38.31.65 1
    route inside 10.10.2.2 255.255.255.255 172.20.8.2 1
    route inside CT-NET 255.255.248.0 172.20.8.2 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    aaa-server ct-rad protocol radius
    aaa-server ct-rad max-failed-attempts 2
    aaa-server ct-rad deadtime 10
    aaa-server ct-rad (inside) host 172.20.1.22 morrow123 timeout 7
    aaa authentication ssh console LOCAL
    aaa authentication http console LOCAL
    aaa authentication serial console LOCAL
    aaa authentication telnet console LOCAL
    http server enable
    http 173.220.252.56 255.255.255.248 outside
    http 65.51.181.80 255.255.255.248 outside
    http 208.65.108.176 255.255.255.240 outside
    http CT-NET 255.255.0.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community m0rroW(0
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    sysopt connection permit-pptp
    crypto ipsec transform-set 3des-sha esp-3des esp-sha-hmac
    crypto ipsec transform-set 3des-md5 esp-3des esp-md5-hmac
    crypto dynamic-map dyn_map 20 match address vpn-dyn-match
    crypto dynamic-map dyn_map 20 set transform-set 3des-sha
    crypto map ct-crypto 10 ipsec-isakmp
    crypto map ct-crypto 10 match address vpn-ct-li-gre
    crypto map ct-crypto 10 set peer LI-PIX
    crypto map ct-crypto 10 set transform-set 3des-sha
    crypto map ct-crypto 15 ipsec-isakmp
    crypto map ct-crypto 15 match address vpn-ct-li
    crypto map ct-crypto 15 set peer LI-PIX
    crypto map ct-crypto 15 set transform-set 3des-sha
    crypto map ct-crypto 20 ipsec-isakmp
    crypto map ct-crypto 20 match address vpn-ct-ny
    crypto map ct-crypto 20 set peer NY-PIX
    crypto map ct-crypto 20 set transform-set 3des-sha
    crypto map ct-crypto 30 ipsec-isakmp
    crypto map ct-crypto 30 match address vpn-ct-tx
    crypto map ct-crypto 30 set peer TX-PIX
    crypto map ct-crypto 30 set transform-set 3des-sha
    crypto map ct-crypto 65535 ipsec-isakmp dynamic dyn_map
    crypto map ct-crypto client authentication ct-rad
    crypto map ct-crypto interface outside
    isakmp enable outside
    isakmp key ******** address LI-PIX netmask 255.255.255.255 no-xauth no-config-mo
    de
    isakmp key ******** address 216.138.83.138 netmask 255.255.255.255 no-xauth no-c
    onfig-mode
    isakmp key ******** address NY-PIX netmask 255.255.255.255 no-xauth no-config-mo
    de
    isakmp key ******** address TX-PIX netmask 255.255.255.255 no-xauth no-config-mo
    de
    isakmp identity address
    isakmp nat-traversal 20
    isakmp policy 10 authentication pre-share
    isakmp policy 10 encryption 3des
    isakmp policy 10 hash sha
    isakmp policy 10 group 2
    isakmp policy 10 lifetime 86400
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    isakmp policy 30 authentication pre-share
    isakmp policy 30 encryption 3des
    isakmp policy 30 hash md5
    isakmp policy 30 group 1
    isakmp policy 30 lifetime 86400
    vpngroup remotectusers address-pool ctpool
    vpngroup remotectusers dns-server 172.20.1.5
    vpngroup remotectusers wins-server 172.20.1.5
    vpngroup remotectusers default-domain morrowny.com

    Amit,
    I applaud your creativity in seeking to solve your problem, however, this sounds like a real mess in the making. There are two things I don't like about your approach. One, cron -> calling Java -> calling PHP -> accessing database, it's just too many layers, in my opinion, where things can go wrong. Two it seems to me that you are exposing data one your website (with the PHP) that you may not want expose and this is an important consideration when you are dealing with emails and privacy and so on.
    I think the path of least resistance would be to get a new user account added to the MySQL database that you can access remotely with your Java program. This account can be locked down for read only access and be locked down to the specific IP or IP range that your Java program will be connecting from.
    Again I applaud your creativity but truly this seems like a hack because of the complexity and security concerns you are introducing and I think is a path to the land of trouble. Hopefully you will be able to get a remote account set up.

  • Issue with FDMEE custom script

    Hi All,
    I have written a custom script in FDMEE which pulls data from Oracle DB and writes it to a file in FDMEE App Inbox folder. This script is working perfectly in FDM where in I see file getting generated in Inbox folder. But, when I try to execute the same script in FDMEE, it is not working even though it is not giving any error.
    All I changed in the script is API syntax which is specific to FDMEE. Can any one please let me know what is that I am missing here..I am using this script to test FDMEE connectivity to DB.
    Below is the script:
    Sub TEST_MAPS()
    'Oracle Hyperion FDM Custom Script:
    'Purpose:      
    'Variable Declaration
    Dim SQLRes
    Dim objfso
    Dim strFile
    Dim strLoadFile
    Const ForReading = 1
    Const ForWriting = 2
    Const adVarChar = 200
    Const MaxCharacters = 255
    Const adFldIsNullable = 32
    'Initialize objects
    Set cnSS = CreateObject("ADODB.Connection")
    Set rs = CreateObject("ADODB.Recordset")
    'Connect to Oracle database
    cnss.open "Provider=ORAOLEDB.ORACLE;Data Source=ds1;User ID=app;Password=xxxx"
    SQLRes = "Select * from ENTITY_MAP"
    'command for executing the query
    cnss. Execute SQLRes
    'Creates a .tra file in the below mentioned path
    strFile= fdmAPI.API.DataWindow.Connection.PstrDirInbox & "\Entity.tra"
    rs.open SQLRes,cnSS
    'Copy data from table to text file
    'Initialize the object for opening a text file for writing
    Set objfso = CreateObject("Scripting.FileSystemObject")
    Set objWFile = objfso.OpenTextFile(strFile, ForWriting,True)
    'Loop
    With rs
    'Open the file for writing, overwriting if it exists
      Do While Not .EOF
          objWFile.Write .GetString(2,,",",vbCrLf)' Write the records to file
      Loop
      'End If
    .Close
    End With
    End Sub
    Below is the log:
    2015-02-24 15:41:38,991 INFO  [AIF]: FDMEE Process Start, Process ID: 13,949
    2015-02-24 15:41:38,991 INFO  [AIF]: FDMEE Logging Level: 5
    2015-02-24 15:41:38,991 INFO  [AIF]: FDMEE Log File: \\app\FDMEEData\HFMCA\\outbox\logs\HFMCA_13949.log
    2015-02-24 15:41:38,991 INFO  [AIF]: User:502376825
    2015-02-24 15:41:38,991 INFO  [AIF]: Location:null (Partitionkey:null)
    2015-02-24 15:41:38,991 INFO  [AIF]: Period Name:null (Period Key:null)
    2015-02-24 15:41:38,991 INFO  [AIF]: Category Name:null (Category key:null)
    2015-02-24 15:41:38,991 INFO  [AIF]: Rule Name:TEST_MAPS (Rule ID:10,162)
    2015-02-24 15:41:41,003 INFO  [AIF]: Jython Version: 2.5.1 (Release_2_5_1:6813, Sep 26 2009, 13:47:54)
    [Oracle JRockit(R) (Oracle Corporation)]
    2015-02-24 15:41:41,003 INFO  [AIF]: Java Platform: java1.6.0_37
    2015-02-24 15:41:41,003 INFO  [AIF]: Log File Encoding: US-ASCII
    2015-02-24 15:41:41,440 DEBUG [AIF]: CommProcess.executeCustomScript - START
    2015-02-24 15:41:41,440 DEBUG [AIF]: customScriptName: TEST_MAPS.vbs
    2015-02-24 15:41:41,456 DEBUG [AIF]:
        INSERT INTO AIF_PROCESS_DETAILS (
          PROCESS_ID
          ,ENTITY_TYPE
          ,ENTITY_ID
          ,ENTITY_NAME
          ,ENTITY_NAME_ORDER
          ,TARGET_TABLE_NAME
          ,EXECUTION_START_TIME
          ,EXECUTION_END_TIME
          ,RECORDS_PROCESSED
          ,STATUS
          ,LAST_UPDATED_BY
          ,LAST_UPDATE_DATE
        ) VALUES (
          13949
          ,'PROCESS_CUSTOM_SCRIPT'
          ,NULL
          ,'TEST_MAPS.vbs'
          ,NULL
          ,NULL
          ,CURRENT_TIMESTAMP
          ,NULL
          ,NULL
          ,'RUNNING'
          ,'458790678'      ,CURRENT_TIMESTAMP
    2015-02-24 15:41:41,487 DEBUG [AIF]: Comm.doScriptInit - START
    2015-02-24 15:41:41,768 DEBUG [AIF]: fdmContext: {BATCHSCRIPTDIR=E:\Oracle\Middleware\user_projects\app\FinancialDataQuality, SCRIPTFILE=TEST_MAPS.vbs, INBOXDIR=\\app\FDMEEData\HFMCA\\inbox, TARGETAPPDB=NA, TARGETAPPNAME=HFMCA, APPID=57, RULENAME=TEST_MAPS, OUTBOXDIR=\\app\FDMEEData\HFMCA\\outbox, SCRIPTSDIR=\\app\FDMEEData\HFMCA\\data\scripts, EPMORACLEHOME=E:\Oracle\Middleware\EPMSystem11R1, RULEID=10162, EPMORACLEINSTANCEHOME=E:\Oracle\Middleware\user_projects\app, LOADID=13949}
    2015-02-24 15:41:41,768 DEBUG [AIF]: The EpmOracleHome is set to: E:\Oracle\Middleware\EPMSystem11R1
    2015-02-24 15:41:41,768 DEBUG [AIF]: The EpmOracleInstance is set to: E:\Oracle\Middleware\user_projects\app
    2015-02-24 15:41:41,768 DEBUG [AIF]: The JavaHome is set to: %EPM_ORACLE_HOME%/../jdk160_35
    2015-02-24 15:41:41,768 DEBUG [AIF]: The executeEventScript is set to: YES
    2015-02-24 15:41:41,768 DEBUG [AIF]: The OleDatabaseProvider is set to: ORAOLEDB.ORACLE
    2015-02-24 15:41:41,768 DEBUG [AIF]: The AppRootFolder is set to: \\app\FDMEEData\HFMCA\
    2015-02-24 15:41:41,768 DEBUG [AIF]: Comm.doScriptInit - END
    2015-02-24 15:41:41,768 DEBUG [AIF]: Comm.executeCustomScript - START
    2015-02-24 15:41:41,799 DEBUG [AIF]: Comm.executeVBScript - START
    2015-02-24 15:41:41,799 DEBUG [AIF]: The WindowsTempFolder is set to: c:\users\r00257~1\appdata\local\temp
    2015-02-24 15:41:41,799 INFO  [AIF]: Executing the following script: \\app\FDMEEData\HFMCA\\data\scripts\custom\TEST_MAPS.vbs
    2015-02-24 15:41:41,799 DEBUG [AIF]: The command to be executed is:
    cscript \\app\FDMEEData\HFMCA\\data\scripts\custom\TEST_MAPS.vbs "13949" "****" "E%3A%5COracle%5CMiddleware%5Cuser_projects%5Capp" "%25EPM_ORACLE_HOME%25%2F..%2Fjdk160_35" "ORAOLEDB.ORACLE"
    Microsoft (R) Windows Script Host Version 5.8
    Copyright (C) Microsoft Corporation. All rights reserved.
    2015-02-24 15:41:41,939 DEBUG [AIF]: Comm.executeVBScript - END
    2015-02-24 15:41:41,939 DEBUG [AIF]: Comm.executeCustomScript - END
    2015-02-24 15:41:41,939 DEBUG [AIF]:
        UPDATE AIF_PROCESS_DETAILS
        SET STATUS = 'SUCCESS'
        ,RECORDS_PROCESSED = CASE
          WHEN RECORDS_PROCESSED IS NULL THEN 0
          ELSE RECORDS_PROCESSED
        END + NULL
        ,EXECUTION_END_TIME = CURRENT_TIMESTAMP
        ,LAST_UPDATED_BY = CASE
          WHEN ('502376825' IS NULL) THEN LAST_UPDATED_BY
          ELSE '502376825'
        END
        ,LAST_UPDATE_DATE = CURRENT_TIMESTAMP
        WHERE PROCESS_ID = 13949
        AND ENTITY_TYPE = 'PROCESS_CUSTOM_SCRIPT'
        AND ENTITY_NAME = 'TEST_MAPS.vbs'
    2015-02-24 15:41:41,939 DEBUG [AIF]: CommProcess.executeCustomScript - END

    Hi,
    If you're using CUE, there is a step called "Dial By Extension Menu", this should solve your problem.
    If you're using UCCX (or CUE and don't have this step) you can do the following:
    In the Get Digit String branch Timeout, use an If statement that check if the Number entered was "1" then Call Redirect to Technical Departement Number, else Call Redirect to Operator Extension.
    It should appear like this:
    Extension = Get Digit String
    Timeout
        if (Extension == "1")
            True
                Call Redirect to Technical
            False
                Call Redirect to Operator
    Hope This Helps,

  • Possible to set shortcut for file scripts custom script ?

    i have some custom scripts in file > scripts. i'd like to set a shortcut key for them, but you can't do that thru edit > keyboard shortcuts because the custom ones don't show up, only "other script F12" shows up.
    is there a way to set a shortcut to execute a custom script? i am using Ai CS3 version 13.0.2
    some work arounds i tried that didn't seem to work:
    - setting the script as an action - didn't work, the script does a bunch of stuff that can't be solved by actions
    - setting an action and inserting a menu item, then setting a shortcut to run the action - doesn't help because menu item (the script) gets disassocated from the action every time you shut down Ai. sometimes it disassociates itself. tried to save the actions and reload them, but the scripts were still disassociated
    thanks

    As it sounds like you have already discovered, you should be able to define an Action with but one InsertMenuCommand step in it. That menu command would be the selection of your script from the File Menu.
    However, that functionality has been broken for four full versions now. The Menu Command step goes vacant after quitting and re-launching Illustrator.
    I keep an Action in my Actions palette titled CurrentScript. I can at least, at the beginning of a work session in which I know I will need to call a particular script repeatedly, re-do the Insert Menu Item step and have it survive during the work session. (It will, of course, be gone if I quit & relauch.)
    If Actions could reliably call scripts from the File menu, one could do some very cool things. Many operations in the standard UI are not available via the scripting model, and of course vice-versa. Simply being able to reliably call scripts as individual steps of an Action would open the door for elaborate automations that perform both scripted functions and those available in the UI.
    But alas, users have been complaining about this bug for four versions now.
    I think it is conceivable that one could build a Javascript that employs the ScriptUI functionality, and have that script run automatically at launch. That script could simply be a "dashboard" palette from which to call other scripts. But one should not have to go to such ridiculous lengths to work around a bug that has gone unaddressed for so long.
    JET

  • Custom Script Code to create multi-Location files from Master File

    Hi,
    I currently have a custom script that loads a master file (which contains all Entities data). I would like to do the following;
    1. Generate multiple files from the master files, one file per location for all locations.
    2. Each location file should contain data only data relevant to that Location defined by Validation Entity definitions.
    Does anyone have a sample code to do the above?
    Essentially, we want to run this Master Custom Script every hour or so and generate all the Locations' files and have users load them ad-hoc.
    Please let me know.
    Thanks

    Your requirement is quite sepcific so you will have to write the script for this yourself (or hire someone to do it for you). What I will say is that via vbscript and the FDM API all the components you require to do this are there and it can be scheduled with FDM's Task Manager.

  • [Services and Systems]Custom script .bat for testing Avaibility for Service

    Hi,
    I am trying to create a Service in grid control.
    For the step - Create Generic Service: Service Test, I use custom script test type.
    I've already done this kind of service with a custom script stored on Unix system (script sh -> OK). However, this time, I can only use a script stored on Windows server.
    I tested with a *.bat* file but I got this error :
    Error encountered while executing test.:Beacon-Test
    Here my configuration :
    Grid Control 10.2.0.5
    Windows Server 2005
    My script .bat :
    echo 1
    What type of file do I have to use under Windows so that the test of service works?
    Thanks
    Related links :
    http://www.oracle.com/technology/obe/obe10gEMR2/Quick_Start/system_services/system_services.htm
    http://download.oracle.com/docs/cd/B16240_01/doc/user.102/b28678/services.htm#CHDCAIJC
    Oliver

    Hi,
    here the results of my searchs :
    1 - All .BAT files must begin with : @ECHO OFF
    2 - All scripts have to send only numbers
    Oliver

  • Load an Advanced Print Setting in Acrobat via Java-Script

    Hi there,
    I'd like to know, if there's a way to load an advanced print setting in the Acrobat via Java Script or some other way? (See Screenshot)
    Or is it possible to set an created setting as default-setting? (also via Java or something)
    Or can somebody tell me, where these created print settings are saved? (in Acrobat X)
    Thank you very much for your help and sorry for my english, I hope you understand me. :-)
    Kind regards
    Mankro

    Why wouldn't you want to set itas part of an input/output parameter?
    This is really the right way ofdoing this. Otherwise you'll end up with hardcoded variable name in your customcomponent and that not ideal.
    If you're trying to define a default value for it coming from a properties file, you can just make it a "Configuration" variable and set the value from adminui.
    Jasmin

  • How to Invoke Oracle Configurator via URL Outside the APPS Firewall

    Hi Gurus,
    We would like to invoke Oracle Configurator via URL same as Oracle iStore. Please let me know the process/steps to meet the requirement.
    Thanks in Advance,
    Venky.

    There is no restriction that Oracle Configurator may only be executed from within an Oracle hosting application. Configurator may be invoked from any application that has the ability to call Configurator's UI servlet. As an example, Astec (now part of Emerson Network Power) has had a Configurator application they call their "Power Wizard" on their public website for nearly eight years (http://www.powerconversion.com/powerwizard/).
    Venky, I would recommend you search My Oracle Support for articles containing 'configurator firewall' or 'configurator ssl', and then filter the results to just EBS articles. If what you find there is not helpful, opening a Support Request to get information more tailored to your particular scenario may be advisable.
    Eogan

  • Create Oracle OCI JDBCConnectionPool via silent script

    Hi there,
    I'm currently trying to create a JDBCConnectionPool via silent script that uses the Oracle OCI thick driver. My silent script looks like this:
    create JDBCConnectionPool "MyPool" as jdbcpool;
    set jdbcpool.DbmsHost "myhost";
    set jdbcpool.DbmsPort "1521";
    set jdbcpool.Password "user";
    set jdbcpool.URL "jdbc:oracle:oci:@//myhost:1521/mysid";
    set jdbcpool.DriverName "oracle.jdbc.pool.OracleDataSource";
    set jdbcpool.Properties "user=user;portNumber=1521;SID=mysid;serverName=myhost;dll=ocijdbc9;protocol=oci";
    The log of the silent script says everything was set successfully. Unfortunately when I take a look at the "Connection Pools" at the GUI admin console, the URL for the jdbcpool has been changed to "jdbc:bea:oracle:///myhost:1521" !
    I'm using WebLogic 8.1SP3 with Oracle 9.2.0.5!
    Can anyone help me with this? Any hint/help is appreciated!
    - raze

    Hi Joe,
    I've done a demo script that produces the described "error". Would be great if you (or anybody else) could check if the same behaviour occurs.
    [... start script ...]
    read template from "/opt/bea/8.1.SP3/user_home/common/templates/domains/wls.jar";
    create Cluster "MyCluster" as c1;
    set c1.ClusterAddress "127.0.0.1:59251";
    set c1.MulticastAddress "237.0.0.1";
    set c1.MulticastPort "59251";
    find Server "myserver" as s1;
    set s1.Name "AdminServer";
    set s1.ListenAddress "";
    set s1.ListenPort "59261";
    set s1.HostnameVerificationIgnored "true";
    set s1.SSL.Enabled "true";
    set s1.SSL.ListenPort "59262";
    create Server "ManagedServer" as n1;
    set n1.ListenAddress "";
    set n1.ListenPort "59251";
    set n1.Cluster "MyCluster";
    set n1.HostnameVerificationIgnored "true";
    set n1.Machine "MyMachine";
    set n1.SSL.Enabled "false";
    create UnixMachine "MyMachine" as machine1;
    set machine1.NodeManager.ListenPort "59255";
    set machine1.NodeManager.Name "MyMachine";
    create JDBCConnectionPool "MyPool" as jdbcpool;
    set jdbcpool.DbmsName "user";
    set jdbcpool.Password "user";
    set jdbcpool.Properties "user=user;portNumber=1521;SID=db-sid;serverName=db-host;dll=ocijdbc9;protocol=oci";
    set jdbcpool.URL "jdbc:oracle:oci:@//db-host:1521/db-sid";
    set jdbcpool.DriverName "oracle.jdbc.pool.OracleDataSource";
    assign JDBCConnectionPool "*" to target "MyCluster";
    find User "weblogic" as u1;
    set u1.password "weblogic";
    set OverwriteDomain "true";
    write domain to "/home/user/BeaDomain";
    close template;
    [... end script ...]
    Setting the URL succeeds as the log says:
    [runScript] com.bea.plateng.domain.script.ScriptExecutor - set jdbcpool attribute URL to "jdbc:oracle:oci:@//db-host:1521/db-sid"
    [runScript] com.bea.plateng.domain.script.ScriptExecutor - succeed: set jdbcpool attribute URL to "jdbc:oracle:oci:@//db-host:1521/db-sid"
    But nevertheless the "config.xml" of the created domain contains the following entry:
    <JDBCConnectionPool Name="MyPool" Targets="MyCluster"
    DriverName="oracle.jdbc.pool.OracleDataSource"
    Password="{3DES}Zlf46kqr6QE=" Properties="" URL="jdbc:bea:oracle:///db-host:1521"/>
    Thus I assume when writing the domain, the URL gets changed for some reason. I also tried to increase the log level by executing the script with the options "-log_priority=debug -silent_priority=debug", but that did not help to find out why the URL got changed.
    Is there maybe someone already using the Oracle OCI thick driver successfully and could post/email me the used silent script?
    Greetings,
    raze

Maybe you are looking for