Connecting two Socket together

Hi everyone !
Here is my little problem :
I have two objects in a software. Each of them have a Socket, and i need to connect them together.
How can i do that ? it seems i could with a ServerSocket, but ... is there an other way ?
If anyone has an idea ...
Thanks.

Here are more precisions :
I've just made a try on something. Here is a little piece of code :
<pre>
<font color="#a020f0">import</font> java.io.*;
<font color="#a020f0">import</font> java.net.*;
<font color="#2e8b57"><b>class</b></font> Obj{
<font color="#2e8b57"><b>public</b></font> InetSocketAddress address;
Socket s;
String name;
<font color="#2e8b57"><b>public</b></font> Obj(String n, <font color="#2e8b57"><b>int</b></font> port) <font color="#2e8b57"><b>throws</b></font> Exception {
name = n;
address = <font color="#a52a2a"><b>new</b></font> InetSocketAddress(<font color="#ff00ff">"127.0.0.1"</font>,port);
System.out.println(name + <font color="#ff00ff">" : port "</font> + address.getPort());
s = <font color="#a52a2a"><b>new</b></font> Socket();
<font color="#2e8b57"><b>public</b></font> <font color="#2e8b57"><b>void</b></font> connect(Obj o) <font color="#2e8b57"><b>throws</b></font> Exception {
s.connect(o.address);
<font color="#2e8b57"><b>public</b></font> <font color="#2e8b57"><b>static</b></font> <font color="#2e8b57"><b>void</b></font> main(String[] args) <font color="#2e8b57"><b>throws</b></font> Exception {
Obj obj1 = <font color="#a52a2a"><b>new</b></font> Obj(<font color="#ff00ff">"objet1"</font>,<font color="#ff00ff">2001</font>);
Obj obj2 = <font color="#a52a2a"><b>new</b></font> Obj(<font color="#ff00ff">"objet2"</font>,<font color="#ff00ff">2002</font>);
obj1.connect(obj2);
</pre>
And the result is :
Exception in thread "main" java.net.ConnectException: Connection refused
Well, i guess this comes from the fact that my Socket in Obj1 is not ready to recieve a connection ... is there something similar to the method accept() of ServerSocket for the sockets ?

Similar Messages

  • Connecting two computers together using an intermediate server.

    I'm trying to write a program that allows users to connect to a server and then pairs off users to chat. I setup the connections between the two clients and that works fine, but as soon as the server disconnects from the two clients the connection between the two is lost. The server is always runnning, it sets up sockets that are global to the clients, what am I missing?

    I am not very sure how are you trying to do the job. Is it
    client1 <-----> server <----> client2
    i.e. all message from client1 is send to server which passes them on to client2 and vice versa. If yes, you will loose connectivity when server goes down. Instead, try a an connection client1 directlyt to client2. for this you might need to run a socket server on client2
    the pseudo code might look like this
    1. client1 connect to server.
    2. client1 check client2 is logged in and convays interest to connect to client2
    3. client1 gets IP address and port of client2 from server. This info has been convayed to sever when client 2 logged in.
    4. client1 opens socket connection to client2
    5. client2 has ServerSocket with establishes recieves connection, opens socket and starts chat seesion.
    Note that after step 5, client1 and client2 are directly connected and server no longer comes into picture. It only acts as repository for IP address and port of client2.
    hope it helps
    Amitabh

  • Connecting Two ASAs together via local interface

    Hi
    I have two cisco ASA routers & wish to connect them together so that traffic between is permitted with out going outside interface.
    Two asa are located at in ONE office and two have separate internet connection (ISP) configured.
    So here is what I did so far.
    configure one of the interface on each ASA with some IP adddress.
    ASA 1  ------- interface 0/6   10.1.1.1  (ASA X 1512)
    ASA 2 --------- interface 0/5  10.2.2.2  (ASA 5055)
    now connected a Ethernet cable to these inferface.
    I was able to addd a route on asa 2.
    route add interface0/5 10.1.1.0/24  10.2.2.2
    but when I add route on ASA 1 I get the following error.
    route add interface0/6 10.2.2.2/24  10.1.1.1
    %invalid next hop address it belongs to one of our interface.

    Sorry if I was not clear
    I have two separate ISPs connecting two two separate ASAs.. Two asa are now connecting separate LANs.
    Now I want to communicate between LANs.
    So I connected an ethernet cable bw ASAs and trying to configure the route.
    But not able to establish
    Here is the configuration of ASA where I am faceing problem, while trying to add route
    route add voice-interface 10.1.1.1/24  255.255.255.0  10.2.2.2 1
    I get error says
    route already exsists
    interface GigabitEthernet0/0
    nameif outside0
    security-level 0
    ip address 0.2.5.2 255.255.255.252
    interface GigabitEthernet0/1
    shutdown
    no nameif
    no security-level
    no ip address
    interface GigabitEthernet0/2
    nameif inside2
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    interface GigabitEthernet0/5
    nameif voice-interface
    security-level 100
    ip address 10.1.1.1 255.255.255.0
    object network NETWORK_OBJ_12.1.3.0_2
    subnet 12.1.3.0 255.255.255.0
    object network NETWORK_OBJ_192.168.1.0_24
    subnet 192.168.1.0 255.255.255.0
    object network OBJ_ALL_NETWORK
    subnet 0.0.0.0 0.0.0.0
    description Any Network
    object network voice-asa-network
    subnet 10.2.2.0 255.255.255.0
    object network 10.1.1.1
    host 10.1.1.1
    access-list outside0_cryptomap extended permit ip 192.168.1.0 255.255.255.0 12.1.3.0 255.255.255.0
    access-list inside2_access_in extended permit ip 192.168.1.0 255.255.255.0 any
    nat (inside2,outside0) source static NETWORK_OBJ_192.168.1.0_24 NETWORK_OBJ_192.168.1.0_24 destination static NETWORK_OBJ_12.1.3.0_24 NETWORK_OBJ_12.1.3.0_24 no-proxy-arp route-lookup
    object network OBJ_ALL_NETWORK
    nat (any,outside0) dynamic interface
    route outside0 0.0.0.0 0.0.0.0 0.2.5.2 1
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS mode transport
    crypto ipsec security-association pmtu-aging infinite
    crypto map outside0_map 1 match address outside0_cryptomap
    crypto map outside0_map 1 set pfs
    crypto map outside0_map 1 set peer 9.2.5.1
    crypto map outside0_map 1 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside0_map 1 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
    crypto map outside0_map interface outside0
    crypto ca trustpool policy
    crypto ikev2 policy 1
    encryption aes-256
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 10
    encryption aes-192
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 20
    encryption aes
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 30
    encryption 3des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    threat-detection basic-threat
    threat-detection scanning-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ssl encryption aes128-sha1 3des-sha1
    group-policy GroupPolicy_6.2.5.1 internal
    group-policy GroupPolicy_6.2.5.1 attributes
    vpn-tunnel-protocol ikev1 ikev2
    class-map inspection_default
    match default-inspection-traffic

  • How do I connect two lines together.

    I have two lines at an angle but where the corner of the angle is supposed to be there is a little triangle missing. I tried joining the two lines together but when I hit join one line goes past the other.
    Before Joining:
    After Joining:

    There is no need to lock one of the paths, because you do not have to tediously select endpoints just to join paths. Doing so was necessary in Illustrator for most of its history, but it finally (decades behind other drawing programs) gained the ability to join paths at their nearest endpoints by just selecting the paths.
    Undo (or cut) the unwanted join.
    Black pointer: Select the left and right paths.
    Join.
    Alternativley, when drawing line art, it is not uncommon to set your default Graphic Style to use rounded endcaps. That negates the problem of the "missing triangle" (as you call it) appearance of coincident straight end caps.
    JET

  • To save my life I can't connect two computers together.

    I have a G5 and an iBook G45.
    They both connect to the Internet easily using my cable connection. There is a DLink router that allows both Macs to use the Internet at the same time.
    But these two computers can't see each other. I've turned on file sharing and done everything else under the sun I can think of. Sometimes the IBook can see the G5 but today it has decided that the G5 server is running on the Ibook and I should access files locally.
    The G5 can't see the Ibook ever.
    I can use Firewire to connect easily.

    Hi Stu,
    Can you connect from one using the ip address of the other? The Finder command cmd-k brings up a dialog for you to enter the URI of the other machine. The first part is the protocol (e.g. http, ftp, afp) the next two parts are so unused I forget what they are. The third part is the host name or address and the last part is the filesystem or file.
    So if the machine you wanted to connect to was 192.168.1.10, and it had appletalk filing protocol turned on (personal file sharing) and you wanted to mount Applications, you'd enter
    afp://192.168.1.10/Applications
    You can leave the filesystem off. If that works, then you can connect. That means you only have the problem of seeing. Each computer is supposed to announce its services using Bonjour. There's a great utility called Bonjour Browser (free on versiontracker) which will show you what's being advertised. I have noticed that it sometimes takes a very long time before file sharing is advertised.

  • Connect two SPA8800 together

    Hi,
    I have two Cisco SPA8800 and I want to make them work together to transport an analog line throught an IP network. I searched on the net and the admin guide and I've found anything that could help me so I'm asking you some help.
    So, I have one analog line in my first SPA8800 (in the line 1). I have another SPA8800 on the same network and I want to be able to pick up the phone (phone 1) and take the analog line on the first gateway. I also want to be able to call the phone number of the analog line and answer with the phone.
    I tried to work with Dial Plan, I tried many things but nothings worked.
    I've already did it a few month ago between two Multitech device but it was a lot easier than the Cisco.
    Thanks for your help.

    this Is making me crazy...
    Picking up Line 1 On the remote box - 192.168.16.2 -
    trying to call the line 1 on the Other box... i get invalid call...
    i have checked all the setting 10 times..  is there something with the registration? Proxy? 
    Phone 1 Status
    Hook State:
    Off
    Registration State:
    Not Registered
    Last Registration At:
    Next Registration In:
    Message Waiting:
    No
    Call Back Active:
    No
    Last Called Number:
    Last Caller Number:
    Mapped SIP Port:
    Call 1 State:
    Invalid
    Call 2 State:
    Idle
    Call 1 Tone:
    Reorder
    Call 2 Tone:
    None
    Call 1 Encoder:
    Call 2 Encoder:
    Call 1 Decoder:
    Call 2 Decoder:
    Call 1 FAX:
    Call 2 FAX:
    Call 1 Type:
    Outbound
    Call 2 Type:
    Call 1 Remote Hold:
    No
    Call 2 Remote Hold:
    Call 1 Callback:
    No
    Call 2 Callback:
    Call 1 Peer Name:
    Call 2 Peer Name:
    Call 1 Peer Phone:
    192.168.26.2:5061
    Dial Plan
    Dial Plan:
    Enable IP Dialing:
    yesno
    Emergency Number:
    Phone 1 Settings.
    Dial Plan
    Dial Plan:
    Enable IP Dialing:
    yesno
    Emergency Number:

  • Connect two wrt54G together

    Hello,
    I have of the same routers WRT54G. The fisrt one is connected to the internet, wired connected to my main computer.
    I use it to get connected to the internet wireless no problem with the laptop.
    I have a network printer on a other room and I need create a wireless connection with the second router. I "d like to use this second router as a wireless access point just for the printer.
    How to make my first router talk to the second router and be able to print with my main computer and laptop using the first router connection??
    Thank you
    Ludo

    Well you need to connect the printer to the Print Server using the USB Cable & then accordingly you need to connect the router to the pc & the Print Server & the printer configuration to the router & configure your print server.

  • Connecting two macs together to increase render speed.......

    hello edit land. i am writting from chili where we are trying to produce a trailer and finish production. Time and money are not around. I need to figure a way to increase the render time while i am collor correcting. i am a novice jack of all trades master of none type, and i have never explored quark, shake all that stuff and perhaps the answer lies there. Anyway i have an i book g4 with out fcp on it and a power book g4 that is doing the work right now, and 380 gig external drive (g raid). is there any way to use the three of these together to process render files faster? thanks kellam

    Sorry. Currently the answer is no. Shake and DVDSP4 and Compressor can benefit from a network of computers, but not FCP...
    Patrick

  • Connecting two GUI together.

    Hi everyone, the attached is my GUI. im trying to create two mode of the system. the first ( running by optimization) which will be done using this GUI.
    the second (manual mode) which i want to be moving to another GUI when i choose it PLUS stopping the first GUI (running by optimization).and when i move back to the (running optimization mode) i want the ( manual mode GUI) to stop.
    will that be possible?
    please help me out.
    thanks alot
    Solved!
    Go to Solution.
    Attachments:
    Copy of finalizedGUIMODlast.vi ‏223 KB
    optimization_result.txt ‏3 KB
    try1.txt ‏14 KB

    There are several ways you can achieve this. First off, you will want to have a single shell of a VI which loads the subpanel with the desired GUI. Through the shell the user can select which GUI to view and interact with. Your process tasks can either run as background tasks and use messaging via queues, notifiers or user event to control when they start and stop. The other alternative would be to have your shell VI dynamically load the appropriate GUI when needed. When you need to switch you would stop the running GUI and load the other one.
    Mark Yedinak
    "Does anyone know where the love of God goes when the waves turn the minutes to hours?"
    Wreck of the Edmund Fitzgerald - Gordon Lightfoot

  • Connecting two macs together wirelessly

    I have no clue if this is posible but I would like to be able to connect to my imac down stairs from my macbook up stairs to send documents instantly.
    I currently use an app called gdisk. Up loud my files (mostly documents) then come downstairs turn on gdisk on my imac download the files then print the files I need.
    I believe I need my ip address which I got here
    http://www.ipchicken.com/
    then I went to find and said connect to finder. But I have no clue after that.
    Is it posible to have my imac down stairs as an icon on my sidebar my macbook? Where I can just dobule click and have acess to transfer files.
    if so is there any videos or step by step websites to help with this.
    Thanks.

    Not sure I understand your network problem, but to answer at least a part of your question - (Is it possible to have my imac down stairs as an icon on my sidebar my macbook? Where I can just double click and have access to transfer files.) - once you do get a network connection, a globe icon, representing your other Mac (the source you want to send data from), should appear on your desktop (the target or Mac you want to transfer the data to). Before logging out or quiting connection to server on the target, drag that globe icon of the source Mac to your dock of the target Mac; place it immediately to the left of your trash. Then, next time you need to connect to the source (i.e., connect to upstairs from downstairs), you should be able to click that globe icon on the dock of the target/downstairs Mac and be linked to the other (source/upstairs) computer.
    Hope this helps a little bit! It works flawlessly with Airport.

  • Connecting two HH3 together

    Hi there,
    I am in a sticky situation...
    I've used up all the ethernet ports on my main HH3 (the one connected to the Openreach modem), now that more devices are entering my household and WiFi is pretty unreliable due to all the interferances around us, we all like to use ethernet. I currently have a spare HH3 laying around (Type A I believe) and was wondering if it was possible to use this HH as a ethernet switch. Sometime I did look into this and found a useful guide on how to do this, but when I connected my Xbox to the 2nd HH, my NAT was strict and gave up. Now that time has passed, I am hoping that someone with a bit more technical knowledge than myself can help me with this situation as the fight for ethernet ports in my house is becomming a bit of a nuisance (please do not judge )
    Thanks,
    Majed

    Hi
    I had a similar problem and so I have run a Cat5 cable from one of the ports upstairs and then used Keith's instruction web page to link 2 hubs togther.
    http://forumhelp.dyndns.info/wireless/hh3link.html
    This has given me a wireless repeater and 3 more ports at the same time.
    Regards
    Tim

  • Networking Best Practices - Connecting Two Switches

    Connecting two switches together is an easy task, which makes it so frustrating when it doesn’t work. Here we will outline a basic scenario of connecting two switches and achieving connectivity. In these scenarios we will be using commands and settings that will work for most modern PowerConnect switches. However this does not cover all possible scenarios and the commands may differ slightly from switch to switch.
    For instance, in most cases you can use General or Trunk mode when connecting two switches. However, on the PowerConnect 62xx series switches, you must use General mode if you want to allow management traffic onto the switch over the PVID.  If you use Trunk mode, you will not have the default VLAN on those ports.  The ports will only allow tagged traffic.
    For more details on the difference between Access, General, and Trunk modes, follow this link.
    http://en.community.dell.com/support-forums/network-switches/f/866/p/19445142/20089157.aspx#20089157
    It is always a good idea to have the user and CLI guide for your switch, to reference any possible changes in command syntax.
    http://support.dell.com/support/edocs/network/
    Layer 2
    Layer 2 switches operate at the data link layer of the OSI model. Layer 2 is responsible for error checking and transmitting data across the physical media. MAC addressing sources and destination protocols are layer 2 protocols. Layer 2 switches use the MAC address of data packets to determine where those packets should go. It learns the MAC addresses of all devices and creates a segment/forwarding table.
    When a switch receives a frame with a destination address that isn't in its forwarding table, the switch forwards the frame to all other ports. If the destination machine responds to the server, the switch will listen to the reply and learn which port the destination machine is attached to. It then adds that MAC address to the forwarding table.
    The Dell PowerConnect Layer 2 switches have ports that all operate in VLAN 1 by default. If it is acceptable to have all traffic on the same broadcast domain, then you can simply leave the default alone, connect the two switches and traffic will flow.
     If you do not want all traffic on the same broadcast domain, then we need to look at adding additional broadcast domains through the use of VLANs.
     We will use 3 VLANs for the following scenario.
    VLAN 1=Management
    VLAN 2=Client
    VLAN 3=Server
    To create these VLANs we do the following commands (VLAN 1 is already created by default)
    console(config)# vlan database
    console(config-vlan)# VLAN 2
    console(config-vlan)# VLAN 3
    console(config-vlan)# exit
    We can then name the VLANs to help keep things organized.
    console(config)# interface vlan 2
    console(config-vlan)# name Client
    console(config-vlan)# exit
    console(config)# interface vlan 3
    console(config-vlan)# name Server
    console(config-vlan)# exit
    Once we have the VLANs created we can place a device in that VLAN by placing the port it plugs into, in access mode for the specific VLAN.
    So we have a workstation on port e2 we want to be placed in VLAN 2, we would issue the following commands.
    console(config)# interface ethernet 1/e2
    console(config-if)# switchport mode access
    console(config-if)# switchport access vlan 2
    console(config-if)# exit
    The next port plugs into a server on port e3 we want on VLAN 3, we would issue these commands.
    console(config)# interface ethernet 1/e3
    console(config-if)# switchport mode access
    console(config-if)# switchport access vlan 3
    console(config-if)# exit
    For the ports connecting the two switches together, we place the ports in trunk mode and specify the native VLAN and allowed VLANs.
    For the port e1 that connect the two switches to each other would be configured like this.
    console(config)# interface ethernet 1/e1
    console(config-if)# switchport mode general
    console(config-if)# switchport general allowed vlan add 2,3 tagged
    console(config-if)# switchport general pvid 1
    console(config-if)# exit
    Once these VLANs and port settings are made on both switches. A server connected to switch A on VLAN 3 should be able to communicate with another Server connected to switch B that is also in VLAN 3.  Without the use of a router the devices in VLAN 3 will not be able to communicate with devices that are outside of their broadcast domain (i.e. VLAN 2 devices could not reach VLAN 3 devices)
    Layer 3 + Layer 2
     Until recently, routers were the only devices capable of layer 3 protocols. Switches capable of routing are now available and in widespread use. In most cases we will connect our layer 2 switches to a Layer 3 capable switch to perform our routing for us.
     On the layer 3 switches we will use the same VLANs and setup that we did with the layer 2 switches.  Then we will add to the configuration.
     We can assign an IP address to each switch with the following command.
    Switch A
    console(config)#ip address 172.16.1.1 255.255.255.0
    Switch B
    console(config)#ip address 172.16.2.1 255.255.255.0
    Then we will enable routing only on Switch A
    console(config)# ip routing
    Switch A we assign an IP address to VLAN 2 and enabling routing on the VLAN.
    console(config)# interface vlan 2
    console(config-if-vlan2)# Routing
    console(config-if-vlan2)# ip address 172.16.20.1 255.255.255.0
    console(config-if-vlan2)# exit
    Switch A we assign an IP address to VLAN 3 and enabling routing on the VLAN.
    console(config)# interface vlan 3
    console(config-if-vlan2)# Routing
    console(config-if-vlan2)# ip address 172.16.30.1 255.255.255.0
    console(config-if-vlan2)# exit
    On both switch A and switch B we will keep things simple and use interface 1/e1 for the connection between each switch. Setting both switches 1/e1 to general mode, allowing the additional VLAN 2,3, and keeping the PVID of 1.
    console(config)# interface ethernet 1/e1
    console(config-if)# switchport mode general
    console(config-if)# switchport general allowed vlan add 2,3 tagged
    console(config-if)# switchport general pvid 1
    console(config-if)# exit
    We will have one client computer connect to switch A on port 1/e2 and one client connect to switch B on port 1/e2. These ports will be in access mode for VLAN 2, and the config should look like this on both switches.
    console(config)# interface ethernet 1/e2
    console(config-if)# switchport mode access
    console(config-if)# switchport access vlan 2
    console(config-if)# exit
    We will have another client computer connect to switch A on port 1/e3 and one client connect to switch B on port 1/e3. These ports will be in access mode for VLAN 3, and the config should look like this on both switches.
    console(config)# interface ethernet 1/e3
    console(config-if)# switchport mode access
    console(config-if)# switchport access vlan 3
    console(config-if)# exit
    On Clients connected to Switch A we will assign an IP address and gateway based on the VLAN they are in access mode for.
    Client connected to access port for VLAN 2.
    IP Address:172.16.20.11
    Default Gateway:172.16.20.1
    Client connected to access port for VLAN 3.
    IP Address:172.16.30.11
    Default Gateway:172.16.30.1
    On Clients connected to Switch B we will assign an IP address and gateway based on the VLAN they are in access mode for.
    Client connected to access port for VLAN 2.
    IP Address:172.16.20.12
    Default Gateway:172.16.20.1
    Client connected to access port for VLAN 3.
    IP Address:172.16.30.12
    Default Gateway:172.16.30.1
    External Connection
    At some point we may want traffic to have an external connection. To do this we can create a new VLAN for our point to point connection from Switch A to our router. We will use VLAN 7 for this and assign an IP address.
    console(config)# vlan database
    console(config-vlan)# VLAN 7
    console(config-vlan)# exit
    console(config)# interface vlan 7
    console(config-vlan)# name WAN
    console(config-if-vlan2)# Routing
    console(config-if-vlan2)# ip address 10.10.10.2 255.255.255.0
    console(config-if-vlan2)# exit
    On our router we will assign an IP address of 10.10.10.1
    Then place the port connecting the switch and router into access mode for VLAN 7.  In this case we use port e4.
     console(config)# interface ethernet 1/e4
    console(config-if)# switchport mode access
    console(config-if)# switchport access vlan 7
    console(config-if)# exit
    We will then need to put in a default route with the next hop as the router IP address.  This allows the switch to know where to route traffic not destined for VLANs 2, 3, or 7.
    console(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.1
    Next on the router we’ll need to add a route back so the router knows about the networks attached to switch A.  Generally adding a static route on most routers is done with the following command: 
    ip route {Network} {Wildcard Mask} {Next Hop-IP}
    In our case here are the 2 static routes we could use.
    Ip route 172.16.20.0 0.0.0.255 10.10.10.2
    Ip route 172.16.30.0 0.0.0.255 10.10.10.2
    The routing that we enabled on Switch A will enable traffic from the other VLANs to traverse over port 1/e4 to the router, connecting us to external traffic. The routes we added to the router allow the traffic to flow back to the switch over port 1/e4.
    Layer 3 + Layer 3
    In some situations we have two switches, each setup to route for its own broadcast domain, which we want to connect together. In this situation we no longer have a need to use Trunk or General mode between the switches. Instead we can create a common VLAN that will be used for the connection between the two switches.
    To create this VLAN we will run the following commands on both switch A and B
    console(config)# vlan database
    console(config-vlan)# vlan 6
    console(config-vlan)# exit
    console(config)# interface vlan 6
    console(config-vlan)# name Connection
    console(config-vlan)# exit
    On switch A we assign an IP address to VLAN 6 and enable routing on the VLAN.
    console(config)# interface vlan 6
    console(config-if-vlan2)# Routing
    console(config-if-vlan2)# ip address 172.16.60.1 255.255.255.0
    console(config-if-vlan2)# exit
    On switch B we assign an IP address to VLAN 6 and enable routing on the VLAN.
    console(config)# interface vlan 6
    console(config-if-vlan2)# Routing
    console(config-if-vlan2)# ip address 172.16.60.2 255.255.255.0
    console(config-if-vlan2)# exit
    On both switch A and B we place the connecting ports into Access mode for VLAN 6.
    console(config)# interface ethernet 1/e1
    console(config-if)# switchport mode access
    console(config-if)# switchport access vlan 6
    console(config-if)# exit
    We then need to make some changes to switch B now that it is layer 3 and not layer 2 and has its own broadcast domain.
    We will enable routing on Switch B
    console(config)# ip routing
    What used to be VLAN 2 and 3 will now be VLAN 4 and 5 for our separate broadcast domains.
    Switch B we assign an IP address to VLAN 4 and enabling routing on the VLAN.
    console(config)# interface vlan 4
    console(config-if-vlan2)# Routing
    console(config-if-vlan2)# ip address 172.16.40.1 255.255.255.0
    console(config-if-vlan2)# exit
    Switch B we assign an IP address to VLAN 5 and enabling routing on the VLAN.
    console(config)# interface vlan 5
    console(config-if-vlan2)# Routing
    console(config-if-vlan2)# ip address 172.16.50.1 255.255.255.0
    console(config-if-vlan2)# exit
    On Clients connected to Switch B we will assign an IP address and gateway based on the VLAN they are in access mode for.
    Client connected to access port for VLAN 4.
    IP Address:172.16.40.11
    Default Gateway:172.16.40.1
    Client connected to access port for VLAN 5.
    IP Address:172.16.50.11
    Default Gateway:172.16.50.1
    The end result should look like this.
     Troubleshooting
    If we are having issues with connectivity, we may need to place some static routes in place to help traffic to the next hop in the network.
    On switch A we configure a static route to help traffic to the next hop in the network, which is the router.
    console(config)# ip route 0.0.0.0 0.0.0.0 10.10.10.1
    The external router will also need a path defined back to all networks/VLANs.
    To check the status of a port we can use the command. Show interfaces detail, this will help us see the port status. For example to check the status of port 48, we would run this command.
    console# show interfaces detail ethernet 1/g48
     To check routing paths:
    console# show ip route
    The IP address of the network for each VLAN should be listed as C – Connected. Then also a path or default route to your upstream router.
    We can use basic ping commands from a client to help test where connectivity is dropping off at. By doing this we can narrow down where in the network to start troubleshooting.
    -Ping from client to default gateway, being the VLAN the client is in access mode for. If this fails then we may need to double check our client settings making sure the proper IP and gateway are being used.
    -Ping from client to the ip address of the switch the client plugs into. If this fails we may not have VLAN routing enabled on the VLAN the client is in.
    -Ping from client to another client on same VLAN, same switch. If this fails we need to check on client settings, IP address and gateway.
    -ping from client to another client on different VLAN, same switch. If this fails we need to double check the VLAN routing commands are in place.
    -ping from client to the ip address of the next switch in the network. If this fails then check Trunk port configuration from switch to switch, ensuring the VLAN is added to the Trunk port.
    -ping from client to another client on same VLAN, different switch. If this fails, check Trunk port settings.
    -ping from client to another client on different VLAN, different switch. If this fails then check trunk settings and VLAN routing configuration.

    Derek,
    I tried to draw my prefered setup for this network configuration.
    I would create a Team with the two 1 GBit NICs and use it for Domain, DNS, Backup and any SystemCenter Agents.
    I would also Team the two 10 GBit NICs and than assign it to a Hyper-V Switch for the VMs. In Windows Server 2012 it is posible to create vNICs for the Management OS that use this Hyper-V Switch (Converged Network Design). I would create two vNICs SMB1
    and SMB2 to use them for Cluster and Livemigration traffic with SMB Multichannel. If your storage system supports SMB Multichannel you can also use both as storage NICs (but this depends wich vendor you have).
    Hope this helps.
    Grüße/Regards Carsten Rachfahl | MVP Virtual Machine | MCT | MCITP | MCSA | CCA | Husband and Papa |
    www.hyper-v-server.de | First German Gold Virtualisation Kompetenz Partner ---- If my answer is helpful please mark it as answer or press the green arrow.

  • Connecting two LANs

    Please,
    I plan on connecting two LANs together via. the internet (public resource). The LANs are across town.
    The computers on each LAN will be able to access other(some) computers on the other LAN (and vice-versa), they will still be able to connect to the internet. Basically, they will be able to share resources (files, application etc.)
    Undergone some research regarding this, was able to find out that having a VPN connection will be a good way to go. But I have no full knowledge on what hardware I will need. How to start exactly.
    If VPN is actually a good way to go, please let me know (maybe some other alternatives).
    If I can get a good picture of what to do, will be very happy.
    Please, can someone lead me in a good direction. Thank you.

    Hi
    First of all lets focus on the end points connectivity part.What is the internet terminating onto?Say if its a leased line or a Ethernet or ADSL, then you can directly terminate it onto a cisco router.If its a ethernet connectivity, then I would recommend PIX or ASA.
    Secondary we come to the tunnels,i.e, the link between both the offices which should be encrypted.This tunnel will be your pipe.Though a PIX/ASA by default support VPN tunnels and encryptions,you need to have that K9 IOS into the router.
    Pls eleborate on the connectivity medium, then it will be easier to suggest you something.
    Pls read the text at following link...it will give you a better picture...
    http://www.cisco.com/en/US/products/ps5743/Products_Sub_Category_Home.html
    Pls rate helpful posts.
    Regards
    JD

  • Connecting two WAP4410N

    Dear Friends
    I have TWO simple questions and I hope you will help me to find answers
    Q1:
    I have 2 WAP4410 , in two floors in a building,
    some computer clients connect to one of them.
    other clients connect to other one.
    I want to connect both of 4410N together without cable.
    I read ,if I set one of them as REPEATER, it will not acceibble for clients to connect !
    I dont want it !
    I need clients to be able  connect to each one , and both of them connects together normally.
    please help me how to do that ? (the exact config please)
    Q2:
    In another building , I want to put 6 of 4410N to 6 floors.
    do u suggest to connect all of to a 8 port gigabit switch via cable ?
    or connect all of them exactly as above question (wireless) ?
    which one is better ?
    THANK YOU VERY VERY VERY MUCH FOR YOU HELP
    MRR

    /* Style Definitions */
    table.MsoNormalTable
    {mso-style-name:"Table Normal";
    mso-tstyle-rowband-size:0;
    mso-tstyle-colband-size:0;
    mso-style-noshow:yes;
    mso-style-priority:99;
    mso-style-qformat:yes;
    mso-style-parent:"";
    mso-padding-alt:0cm 5.4pt 0cm 5.4pt;
    mso-para-margin-top:0cm;
    mso-para-margin-right:0cm;
    mso-para-margin-bottom:10.0pt;
    mso-para-margin-left:0cm;
    line-height:115%;
    mso-pagination:widow-orphan;
    font-size:11.0pt;
    font-family:"Calibri","sans-serif";
    mso-ascii-font-family:Calibri;
    mso-ascii-theme-font:minor-latin;
    mso-fareast-font-family:"Times New Roman";
    mso-fareast-theme-font:minor-fareast;
    mso-hansi-font-family:Calibri;
    mso-hansi-theme-font:minor-latin;}
    Hello MRR,
    I am not quite sure your question (Q1). Why do you need to connect two AP together without cable? Usually we can provide end-users with ESS solution which can provide users roaming from one area to another if you have two or more APs. Anyway on the backend of AP generally connect to wire-network to give user scalability of network access.  It may also solve your Q2.
    Repeater is only needed if your provided area is too far away from wire-network or out of reachable of wire-network and signal is too weak at that area.

  • I downloaded the latest iOS7 to my iPad and then the screen went blank and would not respond.   I have tried pressing the two buttons together and briefly get the Apple logo but still can not start up, the logo disappears.   I have tried connecting the iP

    I downloaded the latest iOS7 to my iPad and then the screen went blank and would not respond.   I have tried pressing the two buttons together and briefly get the Apple logo but still can not restart, the logo disappears.   I have tried connecting to my iMac to restore the iPad but the device does not show up (I have an old iMac).   What else can I do?

    You need to be running Snow Leopard 10.6.8 at the very least in order to sync your iPad with iTunes so you could update your Mac, if it can be updated, and if you care to do so.
    If that's not an option, you will have to find someone that can restore the device for you with their computer running iTunes or make an appointment at an Apple Store and ask them to restore the device for you.
    I hope that you have an iCloud backup, because you will lose everything on the device when it is restored.
    Snow Leopard can still be purchased in the U.S. Apple Online Store.
    http://store.apple.com/us/product/MC573Z/A/mac-os-x-106-snow-leopard
    Also, I would not give up on the reset technique....holding down on the sleep and home buttons at the same time until the Apple logo appears. It takes about 10-15 seconds and sometimes just a little longer to get the logo to appear.

Maybe you are looking for