Contexts - Simple yet I can't get it to work

Hi Guys,
A simple question on my behalf, but one that has got me stuck.
In my source structure I have this
<root>
  <context1>data</context1>
  <context2>data</context2>
  <context3>data</context3>
  <context4>data</context4>
</root>
What I am trying to do is this:
For each of the first 3 contexts, I need a to transform context4. In my target structure I need this:
<context1> and <context4>
<context2> and <context4>
<context3> and <context4>
Can anyone point me in the right direction with this? I cannot get <context4> to map each time, it only maps with the <context1> and then it does not map with the other contexts.
Can anyone help?
Thanks!

> What I am trying to do is this:
> For each of the first 3 contexts, I need a to transform context4. In my target structure I need this:
> <context1> and <context4>
> <context2> and <context4>
> <context3> and <context4>
>
Can you describe the above thing in more technical way. I mean how exactly your target data will look like. For Ex.
Let's say your source data is
=======
data1
=======
data2
=======
data3
=======
data4
=======
Now are you looking for a result something like this...
==============
data1 + data4
==============
data2 + data4
==============
data3 + data4
==============
If YES, then simply concatenate "data4" with each data... Otherwise let us know what exaclty you are looking for.. Also let us know the occurrence of source & target data.
Regards,
Sarvesh

Similar Messages

  • Making a join seems simple but I can't get it to work

    Hi All,
    I have 2 tables LUGallery and LUSubGallery, the tables are related by the GalleyID field
    LUGallery
    Gallery ID
    ClientID
    GalleryName
    5
    50
    Australia
    8
    50
    Weddings
    12
    33
    Portraits
    4
    33
    Landscapes
    LUSubGallery
    SubGalleryID
    GalleryID
    GalleryName
    67
    5
    NSW
    68
    5
    QLD
    69
    8
    Reception
    70
    8
    Location
    87
    8
    Ceromony
    97
    4
    Rain Forest
    What I am try to do seems simple but I can't get it to work the way I want it.
    I am trying to write a query to display Galleries from the LUGallery tbl that have a Sub Gallery attached to them (ie. It's GalleryID appears in the LUSubGallery tbl)
    So the query for the above example would list Australia, Weddings & Landscapes
    I have tried to write code both with inner joins and nested queries but just can't get it right,
    Any help would be greatly appreciated.
    Thanks in advance
    Kris

    I just want to
    display the GalleryNames from the LUGallery tbl once
    Then you probably do not want include all the extra columns from the LUSubGallery table.
    It returns all of the records from both tables that Have
    the same GalleryID
    That is the way this type of JOIN works. It will return one record for each matched GalleryID. If you only want to display the unique gallery names you can either:
    1) Use an EXISTS clause.  It will return the distinct records from the main gallery table IF a matching record exists in the LUSubGallery table
    --- Not tested ---
    SELECT  LUGallery.GalleryID,
    LUGallery.GalleryName
    FROM    LUGallery
    WHERE   EXISTS (
            SELECT  *
            FROM LUSubGallery
            WHERE LUGallery.GalleryID = LUSubGallery.GalleryID
    http://www.techonthenet.com/sql/exists.php
    ... OR ....
    2) Use the DISTINCT operator to return only the unique combinations of the selected columns. Note: DISTINCT considers all columns in the SELECT list . So if you only want unique galleries, do not include the LUSubGallery columns in the SELECT list.
    http://www.w3schools.com/SQl/sql_distinct.asp
    Message was edited by: -==cfSearching==-

  • Port 8080: I know this is simple, I just can't get it to work.

    I'm trying something that I'm sure is relatively simple. But I just can't get it to work. I have OSX Server 10.4.10. I currently have my company site (www.example.com) hosted on it. But I'm trying to get another site hosted on it at port 8080. When I enter my company domain, www.example.com:8080, the page can't be displayed. But when I enter the IP address, such as 192.168.xxx.xxx:8080 from within my network, the correct site shows up. How can I get a website displayed at port 8080 from outside my network? I'm running DD-WRT on my router and have ports 80 and 8080 directed to the IP address of my server.
    Thanks in advance for any help.

    Hi WiFiNetGuy-
    I am a tad confused, which isn't new, but I need to get a grasp on exactly what it is that you are trying to do.
    Do you have both websites (i.e. www.example1.com and www.example2.com) both pointed at the same ip address? How many unique domain names and ip addresses are we talking about?
    From what you describe it sounds like a routing issue but I need more info (:>)
    Luck-
    -DaddyPaycheck

  • SO SIMPLE, yet I can't get MIDI recognition (Warning: Logic newbie)

    Hi all,
    Ok, this could be so simple, and you guys are the best, so PLEASE helpe me out! In brief, I have a lot of experience with Garageband: recording many software and real instruments with great results. I just got Logic Express v7.0.1, and I CANNOT get it to recognize MIDI or Line-In sound!
    Here's what I'm using (same exact equipment I am able to successfully record with on GB2):
    1. Logic Express
    2. Powerbook G4 15" w/ 1.5MB RAM
    3. M-Audio Fast Track Pro
    4. M-Audio Keystation 49e for a controller
    5. Rokit Monitors
    IT'S BEING RECOGNIZED BUT I DONT HEAR ANYTHING:
    1. When I hit the keys on the controller, I am able to see that the signal is coming through. The main level lights up and the transport shows midi recognition (exact keys im hitting, etc). My interface shows the MIDI signal is coming through also.
    2. I CAN hear the metronome when I hit record.
    3. I have even imported a .wav sample to test output, and THAT DOES WORK - I CAN HEAR THE AUDIO TRACK.
    4. I manually wrote in notes when I created a new Grand Piano track and can see them but they do not make a sound. BUT they do light up the levels when i hit play!
    5. I disconnected the interface and ran off of Built-In Audio because I thought maybe it was the interface's problem. Still cant hear anything.
    I have tried so many different ways to open a new track and record something, anything, but can't get any sound. I've searched preferences in both my system and Logic to make sure the interface is selected, have restarted, etc.
    Can you guys respond and give me a quick rundown of possible troubleshooting techniques? Or even start me from the beginning, from adding the new MIDI track and going from there.
    THANK YOU SO MUCH IN ADVANCE!

    forgive my dumb questions for being obvious...
    have you selected an instrument track and instrument for the midi controller?
    did you bring up the fader on that track?
    are the outputs set to your interfaces outputs?
    do the midi notes appear on the track after recording?

  • I am using Numbers on my iPhone5 and cannot get the app to do a simple (SUM) calculation.  It shows the formula correctly in the cell, but all I get for my long list of numbers to add is 0.  How can I get this to work?

    I am using Numbers on my iPhone5 and cannot get the app to do a simple (SUM) calculation.  It shows the formula correctly in the cell, but all I get for my long list of numbers to add is 0.  How can I get this to work?

    Oaky, at least we got that far.  Next step is to determine if all those "numbers" are really numbers.  Changing the format to "number" doesn't necessarily change the string to a number. The string has to be in the form of a number.  Some may appear to you and me as numbers but will not turn into "numbers" when you change the formatting from Text to Number. Unless you've manually formatted the cells to be right justified, one way to tell if it is text or a number is the justification. Text will be justified to the left, numbers will be justified to the right.
    Here are some that will remain as strings:
    +123
    123 with a space after it.
    .123

  • I updated my OS from 10.6.4., to 10.8.2 I want to buy iDVD and I Movie, but bought iPhoto and can't get it to work yet.  Hesistant to buy the others without now having the original applications on my laptop. Do I need to buy the older versions first?

    I updated my OS from 10.6.4., to 10.8.2.  I want to buy iDVD and iMovie, but I bought iPhoto and can't get it to work yet.  I'm hesitant to buy the others without now having the original applications on my laptop. Do I need to buy the older versions first?  They are probably on my Snow Leopard install disc, but I am now running Mt Lion that I bought, and downloaded a few days ago...so I don't want to insert the old OS disc, thinking it might want to reinstall the old OS...  Thanks,
    KathyH-P

    Download iPhoto Library Manager and use its rebuild function. (In Library Manager it's the FIle -> Rebuild command)
    This will create an entirely new library. It will then copy (or try to) your photos and all the associated metadata and versions to this new Library, and arrange it as close as it can to what you had in the damaged Library. It does this based on information it finds in the iPhoto sharing mechanism - but that means that things not shared won't be there, so no slideshows, books or calendars, for instance - but it should get all your events, albums and keywords, faces and places back.
    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one.  

  • I have Elements 12. I can't get it to work. I bought it in April nand havent used it yet.

    The person on Chat told me to come here for a solution. Apparently I need some sort of an upgrade because it is a "technical issue." What do I do?

    calamity janie wrote:
    The person on Chat told me to come here for a solution. Apparently I need some sort of an upgrade because it is a "technical issue." What do I do?
    You need to tell us more.  When you say "I can't get it to work" what exactly do you mean.  Can you launch it and get to the welcome screen?  Alternatively, tell us how far can you go when you launch the product.

  • ACE - Can not get it to work

    All,
    I am trying to configure simple load balancing to 4 servers on a ACE (ver 3.0.0A13B), but I can't get it to work.
    See config below. I have L3 vlan interfaces on my Cat6513 for vlan 22, 29 and 121.
    Can anyone spot the issue?
    Thanks, Pieter-Jon
    probe tcp TCP
    description TCP PROBE
    interval 2
    faildetect 2
    passdetect interval 2
    connection term forced
    open 2
    parameter-map type connection IDLE
    set timeout inactivity 600
    rserver host INFO-Realserver-1
    ip address 38.22.175.1
    probe TCP
    inservice
    rserver host INFO-Realserver-2
    ip address 38.22.175.2
    probe TCP
    inservice
    rserver host INFO-Realserver-3
    ip address 38.22.175.3
    probe TCP
    inservice
    rserver host INFO-Realserver-4
    ip address 38.22.175.4
    probe TCP
    inservice
    serverfarm host INFO2008
    predictor leastconns slowstart 15
    probe TCP
    rserver INFO-Realserver-1
    inservice
    rserver INFO-Realserver-2
    inservice
    rserver INFO-Realserver-3
    inservice
    rserver INFO-Realserver-4
    inservice
    class-map match-all L4_VIP_ADDRESS_CLASS
    2 match virtual-address 38.29.250.250 tcp any
    class-map type management match-any MGMT-Class
    2 match protocol icmp any
    3 match protocol ssh any
    4 match protocol telnet any
    class-map type management match-all SNMP_ALLOW_CLASS
    2 match protocol snmp any
    class-map type management match-all TELNET_ALLOW_ALL
    2 match protocol telnet any
    policy-map type management first-match MGMT-Policy
    class MGMT-Class
    permit
    policy-map type management first-match REMOTE_MGMT_ALLOW_POLICY
    class TELNET_ALLOW_ALL
    permit
    policy-map type management first-match SNMP_ALLOW_POLICY
    class SNMP_ALLOW_CLASS
    permit
    policy-map type loadbalance first-match L7_VIP_LB_ORDER_POLICY
    class class-default
    serverfarm INFO2008
    policy-map multi-match L4_LB_VIP_POLICY
    class L4_VIP_ADDRESS_CLASS
    loadbalance vip inservice
    loadbalance policy L7_VIP_LB_ORDER_POLICY
    loadbalance vip icmp-reply
    loadbalance vip advertise
    interface vlan 22
    description Info Servers vlan
    ip address 38.22.1.250 255.255.0.0
    no shutdown
    interface vlan 29
    description Info Front End vlan
    ip address 38.29.1.250 255.255.0.0
    service-policy input L4_LB_VIP_POLICY
    service-policy input REMOTE_MGMT_ALLOW_POLICY
    no shutdown
    interface vlan 121
    ip address 38.121.6.1 255.255.0.0
    service-policy input REMOTE_MGMT_ALLOW_POLICY
    service-policy input SNMP_ALLOW_POLICY
    no shutdown
    ip route 0.0.0.0 0.0.0.0 38.121.1.1

    > I have L3 vlan interfaces on my Cat6513 for vlan 22, 29 and 121.
    That is your problem first of all.
    If i get it right from your config.
    VLAN 121 is your transfer network / or client side vlan
    VLAN 22 and VLAN 29 are Server VLANS?
    What you should keep in mind is that you define the server side vlans only on the ACE contexts with L3. You don't define them on the supervisor.
    If you use the ACE in routed mode you have to assign networks exclusive to the ace like routing networks to a layer 3 device in your network. If you use those vlans (22,29) on other parts of your net you should subnet them or take another network.
    Your setup should look like this.
    6513
    L3 ~ VLAN 121
    L2 ~ VLAN 22,29,121
    ACE Module
    L3 ~ VLAN 22,29,121
    You assign the 3 vlans or any other to a vlan group and assign this group to the ace module.
    Create a new context -> assign the vlan 22,29 and 121 to this context.
    6513(L3) <-- vlan 121 --> ACE (L3) /Admin Context
    6513(L3) <-- vlan 121 --> ACE(L3) / Server Context --> VLAN 22,29
    ACE Admin Context (VLAN121)
    ACE Server Context (VLAN 121,22,29)
    After you have a working L2/L3 setup start troubleshooting the ace config itself. :)
    Hope it helps
    Roble

  • I have 2 ipad minis and I can't get headphones to work on either one.

    I have 2 ipad minis and I can't get headphones to work in either one. I have tried to push plug into the jack hard. All the headphones work in my ipod. Music still plays outside the headphones but not inside. Please help, I have 2 frustrated children because they can't use their headphones.

    Never mind figured it out. Things are so simple, but yet so hard :)

  • I have signed up for adobe conversion to microsoft word and i can't get it to work - can you help me

    I have signed up for adobe conversion to microsoft word and I can not get it to work -  can you help me?

    Hi Mike,
    I've checked your account. I see that you just purchased the subscription this morning. The order is still pending processing, which is why you haven't yet been able to log in an use your subscription. It can take 24-48 hours for a subscription to process fully. Once it does, you'll be able to log in and convert files.
    I apologize for the inconvenience.
    Best,
    Sara

  • Cisco 1812 wireles setup, can't get it to work

    Hello everyone,
    I've read trough the "871 wireless setup" topic, which I found very helpful, but I still can't get my wireless working. Basically I have a Cisco 1812W and I would like both wireless and wired to be on the same subnet. We aren't using DHCP, so the IP's are all static (even for the wireless clients). I can connect to my wireless SSID, but ping doesn't go trough either way. Wired connections are working fine. So the wireless client is connected, but has no IP address as far as the router goes (show Dot11 associations shows it's IP as 0.0.0.0) , but the wireless client does have an IP set up.
    I guess I'm overlooking something in my config, so here it is (i took out the firewall rules and aaa setup, they aren't relevant if i'm not mistaken and there's a limit to post size):
    ip cef
    ip tcp synwait-time 10
    no ip bootp server
    ip name-server <removed>
    ip name-server <removed>
    crypto pki trustpoint TP-self-signed-1358229530
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1358229530
    revocation-check none
    rsakeypair TP-self-signed-1358229530
    crypto pki certificate chain TP-self-signed-1358229530
    certificate self-signed <removed>
    quit
    username <removed>
    bridge irb
    interface Null0
    no ip unreachables
    interface FastEthernet0
    description $ETH-WAN$$FW_OUTSIDE$
    ip address extip extsubnet
    ip access-group 101 in
    ip verify unicast reverse-path
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat outside
    ip inspect sdm_ins_in_100 in
    ip inspect SDM_MEDIUM out
    ip virtual-reassembly
    ip route-cache flow
    duplex auto
    speed auto
    interface FastEthernet1
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    shutdown
    duplex auto
    speed auto
    interface BRI0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    encapsulation hdlc
    ip route-cache flow
    shutdown
    interface FastEthernet2
    interface FastEthernet3
    interface FastEthernet4
    interface FastEthernet5
    interface FastEthernet6
    interface FastEthernet7
    interface FastEthernet8
    interface FastEthernet9
    interface Dot11Radio0
    description 802.11g
    no ip address
    encryption mode ciphers tkip
    ssid <removed>
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii 7 <removed>
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    station-role root
    bridge-group 1
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    interface Dot11Radio1
    description 802.11a
    no ip address
    shutdown
    encryption key 1 size 40bit 7 1ED10A3EC0C5 transmit-key
    encryption mode wep mandatory
    speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
    station-role root
    interface Vlan1
    description $FW_INSIDE$
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip virtual-reassembly
    ip route-cache flow
    bridge-group 1
    interface BVI1
    ip address <internal router ip> <subnet>
    ip access-group 100 in
    ip nat inside
    ip virtual-reassembly
    ip route 0.0.0.0 0.0.0.0 <external router IP> permanent
    ip flow-top-talkers
    top 5
    sort-by bytes
    ip http server
    ip http access-class 1
    ip http authentication local
    ip http secure-server
    <bunch of static nats>
    <access rules>
    no cdp run
    radius-server attribute 32 include-in-access-req format %h
    radius-server vsa send accounting
    control-plane
    bridge 1 protocol ieee
    bridge 1 route ip
    line con 0
    line aux 0
    line vty 0 4
    access-class 102 in
    password 7 <removed>
    transport input ssh
    scheduler allocate 4000 1000
    webvpn context Default_context
    ssl authenticate verify all
    no inservice
    end

    Okay, I've somewhat figured it out. Apparently my WPA-PSK configuration doesn't work with the integrated Broadcom adapter found in the laptop I was testing it with.
    Either that or my WPA-PSK configuration is broken.
    I switched over to an open network with no encrpytion and everything works now.

  • How can i get hotmail to work in mail?

    So in hotmail it finally lets me select if I use POP to download Hotmail messages to another program, that program could make it so I can't read my messages on Hotmail. (For example, this might happen if you use Mac Mail or Mozilla Thunderbird).
    I have the "Do what my other program says-if it says to delete messages, then delete them." box selected.
    however my mail on my it mac says
    "There may be a problem with the mail server or network. Verify the settings for account “[email protected] ” or try again. The server returned the error: The connection to the server “pop” on port 110 timed out."
    yet it works on my itouch with mail and hotmail. what is going on? how can i get mail to work with hotmail on my mac?

    By doing a Google search for their phone number and their support website.

  • Using airport extreme in china - can't get it to work

    I just moved to china and have been trying to set up a new Airport Extreme dual band to my high speed internet connection but can't get it to work (bought the AE in the US and worked fine there). I have a Green light on the physical AE, and in Network Status section under Network Diagnostics I get green lights on Airport, Network Settings and ISP, but yellow/red on Internet and Server. The type of internet connection is direct, supplied by China Telecom with no router/modem in my unit, but with ethernet cable running directly to the phone room connection. I manually set up the AE using the same IP address, subnet, DNS as shows up when I plug the ethernet cable directly into my computer, with the internet working fine with a direct connection to computer and no AE.

    What you did makes complete sense Mike, but if you don't have access to the router you may have to get your ISP to recognize your Extreme's MAC address:
    AirPort Base Station: ISP provisioning may prevent Internet connection via broadband (cable or DSL)
    For example: Suppose that you have a computer connected to a cable modem before purchasing an AirPort Base Station. Your Internet service provider might recognize your computer's MAC address as the correct one for your account. Your new base station then takes the position on your network that was formerly occupied by your computer, but you have not taken any action to let your Internet service provider (or its hardware) know the new address. The base station then sends packets to your Internet service provider that do not contain the required MAC address, and the packets are ignored.
    It may be as simple as leaving everything disconnected from your service provider for a period of time. You might also try turning Connection Sharing "off" (bridge mode).

  • Can't get slideshow to work!

    Sorry about yet another basic question, but I can't get slideshow to work.
    I have created a My Photos page template, dragged an Album into it. That looks OK, but when I click on play slideshow, nothing happens.
    Enable Slideshow is ticked in Inspector.
    Any help on this?

    What's the URL of your site so we can examine it first hand? How are you uploading the files? Maybe not all files are getting to the server. Wouldn't be the first time that happened.
    OT

  • I recently downloaded the iTunes 11.0.5 for Mac OS X and the iTunes store comes up as a blank page. I have already tried re-downloading iTunes and that didn't work... How can I get it to work?

    I recently downloaded the iTunes 11.0.5 for Mac OS X and the iTunes store comes up as a blank page. I have already tried re-downloading iTunes and that didn't work... How can I get it to work?

    I was able to fix mine. I went to software update and updated a few things. I did not update everything, but only what I thought were the essentials, which I believe was Safari, a security update, and a firmware update.
    Then I deleted and reinstalled Itunes yet another time. Now the itunes store is back up again.

Maybe you are looking for

  • Ipod nano compatibility with ipod accessories

    Is the ipod nano compatible with other ipod accessories? Will it work with my Bose speaker system built for the ipod? Will the car charger and battery backups that I have purchased for my ipods work with the nano? thanks

  • Exchange server 2010 console not opening, inialization failed

    hi, exchange server 2010 console not opening, inialization failed when i have upgraded service pack to sp1. please suggest asap or u can reach me @ [email protected] [email protected] +918750003544

  • Dlsw+ problem with SNI connection

    We have a cisco 1603 router using dlsw+ to peer with a Nortel ASN. at the cisco end it is x21 connection from the FEP at the Nortel end it is token ring to an OSA when we try and start a JES node we get an IBM sense code 800A0000 and the session drop

  • Error deploying java stored procedure

    Anyway, I've got a really simple java function that takes an XML document in a CLOB as a parameter and simply returns whether or not it's a valid document. Works fine in JDeveloper, but when I try to load it into the database, I get: Errors in cdh_j_

  • Does CC14 offer downgrade rights

    I am a licensing specialist and I am trying to find out if CC14 offers downgrade rights meaning if you buy a CC14 subscription but use an older version of creative suite under this license. I can see that the users dashboard offers the possiblity to