Count total no of ip addresses from a database

how can we count total number of ip addresses from a database using jsp
Edited by: 863765 on Jun 6, 2011 7:26 PM

863765 wrote:
yes IP addresses are in database, so I need to count the total number of ip addressesIs the issue connecting to the database containing the IP addresses? Or writing the SQL to query the database to get the count of IP addresses? Also, do you need a count of unique IP's or just all IP's in the database even if there are duplicates?

Similar Messages

  • Accessing a user email address from the database

    Hi,
    I really need help with the following.
    I am adding functionality where users can set reminders that will then be sent to them by email when the reminder is due. I am going to utilise dbms_job to do this. My problem is that I am using apex authentication and users for the rest of the application and I need to retrieve the email address from apex. I cannot use wwv_flow_users as the email will be sent from a job in the database therefore there will be no current logged in user / workspace / session.
    There must be some way of accessing an internal apex table / view or something that can tell me what the email addresses of my users are without being signed into an apex session.
    Please help, this is quite urgent.
    Thank you in advance.
    Lee

    Hi,
    Glad to see that you've found.
    However would be very interesting to know how to retrieve user list without being in an Apex workspace.
    i would do as follows:
    When the first user of the day log into apex you could update a static table containig the email (taken select into from www_flow_user once a day).
    Then via a trigger you could start your batch proc, that needs updated email.
    Is not clean at all, but probably if your firm isn't too big this approach could work.
    By the way if you find how to retrieve the email not using www_flow_user, would be very nice to know.
    Message was edited by:
    Marcello Nocito

  • E-mail address from ACCESS database

    Hello!
    I have created an enrollment form using DW + an Access db.
    On this form the user registers his e-mail address and I
    would like to know how I can generate a newsletter that will get
    this address from the Access database and e-mail to all users
    registered there.
    It is like a monthly newsletter.
    One additional question, if I may.
    The users have filled out a "yes" or "no" question for
    receiving the Newsletter, so all of them have a "Yes" or "No" field
    under the newsletter heading on the database.
    Can anyone point me in the right direction?
    thanks guys!

    How many users do you have on your database?

  • PowerShell Exchange 2007 Question To count up the total number of email addresses (view/hidden) per GAL

    Hello All:
    I am very new to Power Shell and need some help:
    I have 224 GAL's on our Exchange System (Ex 2007) where, I need to count the total number of email addresses/display names assigned to each GAL.  I am not sure how to set up a for-next loop in PowerShell.  I am not sure how to set a  input
    file/variable, with the names of each GAL.  (GAL is Global Address List)
    I think it's $GALLIST = 'NameofGal1, NameofGal2, etc thru to NameofGaln' where n is the last GAL in the list.
    So I need to now a command which would get all the gal names (Get-AddressList(?) for all the GAL's in the Exchange System and then pipe them into a function to count the number of email addresses.
    In making a start with the following code and got stuck:
    Get-Mailbox | Where {$_.GlobalAddressList -eq “GAL” -and $_.} | Select-Object Displayname, EmailAddresses, count
    Missing or invalid property reference or expression.
    At line:1 char:71
    + Get-Mailbox | Where {$_.GlobalAddressList -eq "GAL" -and $_.} <<<<  | Select-Object Displayname, EmailAddresses, count
    I think I know how to pipe the results to a csv file - with - Export-Csv  -path c:\filename.csv - NoTypeInformation.
    Please can someone advise.  Please help.
    Thanks in advance
    PS - is there a way to access, read and display variable name and value which stores the number of email addresses/per GAL in exchange 2007 database so you don't have carry out a count exercise.  Because this metadata will be in the Exchange DB? 
    Would this be easier to get?
    Started building conditional statement:
    Get-Mailbox | Where {$_.GlobalAddressList -eq "GAL" AND {{HiddenFromAddressListsEnabled -eq $True} OR {HiddenFromAddressListsEnabled -eq $False}} |
    If {{HiddenFromAddressListsEnabled -eq $True} | Select-Object Displayname, EmailAddresses, count ELSE {HiddenFromAddressListsEnabled -eq $False}} | Select-Object Displayname, EmailAddresses, count
    ENDIF
    Export-Csv -path c:\test.csv -NoTypeInformation
    Will this work?  Checking to see how to do a for-next loop.
    $GAL = Get-GlobalAddressList
    foreach($GAL IN $GAL)
    Get-Mailbox | Where {$_.GlobalAddressList -eq $GAL AND {{HiddenFromAddressListsEnabled -eq $True} OR {HiddenFromAddressListsEnabled -eq $False}} |
    If {{HiddenFromAddressListsEnabled -eq $True} | Select-Object Displayname, EmailAddresses, count AS "Count of Hidden Addresses" ELSE {HiddenFromAddressListsEnabled -eq $False}} | Select-Object Displayname, EmailAddresses, count AS "Count of 
    Visible Addresses" |
    Export-Csv -path c:\test.csv -NoTypeInformation |
    not sure if this works and looks spaghetti -like!

    Hi Everton,
    In addition, If you want to export GlobalAddressList, please refer to the script below:
    $filter = (Get-GlobalAddressList 'Default Global Address List').RecipientFilter
    #filter HiddenFromAddressListsEnabled is ture
    Get-Recipient -RecipientPreviewFilter $filter | Where-Object {$_.HiddenFromAddressListsEnabled -eq $ture} | Select-Object Name,PrimarySmtpAddress
    #filter HiddenFromAddressListsEnabled is false
    Get-Recipient -RecipientPreviewFilter $filter | Where-Object {$_.HiddenFromAddressListsEnabled -eq $false} | Select-Object Name,PrimarySmtpAddress
    Refer to:
    How to Export the Exchange 2010 Default Global Address List (GAL)
    If there is anything else regarding this issue, please feel free to post back.
    Best Regards,
    Anna Wang
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact [email protected]

  • Powershell: Count total messages to and from external domain

    Hi All,
    I'm attempting to get a count of total messages to and from our clients domains.  For example, @customer1.com 23.
    So far, I have the following code
    get-messagetrackinglog -start (Get-Date).adddays(-1) -resultsize unlimited |where-object {$_.EventID -eq
    Send" -or $_.EventID -eq "Receive"}
    What I'm looking for is the following:
    If the Sender or the Recipient is NOT @ourcompanydomain.com, count total messages either sent or received from the domain.  Output to csv.
    123.com, 53
    456.com, 32
    Any help would be greatly appreciated.
    Brian
    Syncronet

    Ok, so I've made some progress and now have it so I get an accurate count of total messages.  Now I need to group them by @recipientdomain.com and have totals for each recipientdomain.com.  I also need to get the output correct.  
    Add-PSSnapin Microsoft.Exchange.Management.Powershell.E2010 -ea silentlyContinue
    [long]$IntSent=0
    [long]$IntRec=0
    [long]$IntTotal=0
    $domain="extdomain.com"
    get-messagetrackinglog -start (Get-Date).adddays(-1) -resultsize unlimited -Eventid Send| ForEach{$IntSent++}
    get-messagetrackinglog -start (Get-Date).adddays(-1) -resultsize unlimited -EventID Receive |Where {[String]$_.recipients -notlike "*@mydomain.com*"}|ForEach{$IntRec++}
    #write-host ($IntSent)
    #Write-host ($IntRec)
    $IntTotal=$IntSent + $IntRec
    write-host ($IntTotal)
    $table=@"
    Domain,Messages
    $domain,$IntTotal
    $Table |set-content c:\temp\messages.csv
    Any help is greatly appreciated.
    Thanks
    Brian
    Syncronet
    Directly loading in the snap in for Exchange 2010 and 2013 is not supported.
    Please update scripts to use remoting:
    http://blogs.technet.com/b/rmilne/archive/2015/01/28/directly-loading-exchange-2010-or-2013-snapin-is-not-supported.aspx
    Cheers,
    Rhoderick
    Microsoft Senior Exchange PFE
    Blog:
    http://blogs.technet.com/rmilne 
    Twitter:   LinkedIn:
      Facebook:
      XING:
    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

  • Cisco ASA 5505 - problem with negotiating IP address from PPPoE

    Hi all,
    I have problem with negotiating IP address from PPPoE. There is following design: ISP providing vDSL ending on VDSL modem in bridge mode. Behind brigde modem is ASA 5505 terminting PPPoE on OUTSIDE. Everything works fine except  negotiating IP address from PPPoE server.
    I have configured ASA 5505 with (ASA Version 9.2(2)4) for PPPoE like this [1.]. But If i try to "show" IP address on OUTSIDE interface a get this [2.], ok strange but let's continue. If list "show vpdn pppinterface id 1"  i get this [3.]. Seems that I got public IP addres what was right, but this IP address was not associated with interface OUTSIDE?
    Well, if I set IP address manually like this [4.] and also set a default route everything works fine but what will happen when ISP change reservation for my IP address or default gateway. 
    I have tried different version of ASA OS like 8.4, 9.1 but without luck. 
    Can anybody help me. Thanks a lot.
    Regards
    Karel
    [1.]
    interface Vlan100
    description >>VLAN pro pripojeni do internetu<<
    nameif OUTSIDE
    security-level 0
    pppoe client vpdn group O2
    ip address pppoe setroute
    vpdn group O2 request dialout pppoe
    vpdn group O2 localname O2
    vpdn group O2 ppp authentication chap
    vpdn username O2 password *****
    interface Ethernet0/0
    description >>uplink O2 vDSL<<
    switchport access vlan 100
    [2.]
    ciscoasa(config-if)# show ip address vlan 100 pppoe
    ciscoasa(config-if)#  0.0.0.0 255.255.255.255 on Interface: OUTSIDE
    ciscoasa(config-if)# show interface vlan 100 detail
    Interface Vlan2 "OUTSIDE", is up, line protocol is up
     Hardware is EtherSVI, BW 100 Mbps, DLY 100 usec
            Description: >>VLAN pro pripojeni do internetu<<
            MAC address f44e.05d0.6c17, MTU 1492
            IP address unassigned
      Traffic Statistics for "OUTSIDE":
            28 packets input, 1307 bytes
            31 packets output, 721 bytes
            0 packets dropped
          1 minute input rate 0 pkts/sec,  3 bytes/sec
          1 minute output rate 0 pkts/sec,  1 bytes/sec
          1 minute drop rate, 0 pkts/sec
          5 minute input rate 0 pkts/sec,  0 bytes/sec
          5 minute output rate 0 pkts/sec,  0 bytes/sec
          5 minute drop rate, 0 pkts/sec
      Control Point Interface States:
            Interface number is 15
            Interface config status is active
            Interface state is active
    [3.]
    ciscoasa(config-if)# show vpdn pppinterface id 1
    PPP virtual interface id = 1
    PPP authentication protocol is CHAP
    Server ip address is 88.103.200.41
    Our ip address is 85.71.188.158
    Transmitted Pkts: 20, Received Pkts: 16, Error Pkts: 0
    MPPE key strength is None
      MPPE_Encrypt_Pkts: 0,  MPPE_Encrypt_Bytes: 0
      MPPE_Decrypt_Pkts: 0,  MPPE_Decrypt_Bytes: 0
      Rcvd_Out_Of_Seq_MPPE_Pkts: 0
    ciscoasa(config-if)# show vpdn session state
    %No active L2TP tunnels
    %No active PPTP tunnels
    PPPoE Session Information (Total tunnels=1 sessions=1)
    SessID TunID Intf     State       Last Chg
    22298      2 OUTSIDE  SESSION_UP  561 secs
    [4.]
    interface Vlan100
     description >>VLAN pro pripojeni do internetu<<
     nameif OUTSIDE
     security-level 0
     pppoe client vpdn group O2
     ip address 85.71.188.158 255.255.255.255 pppoe setroute
     route OUTSIDE 0.0.0.0 0.0.0.0 88.103.200.41 1

    You're right that the ACL should not affect otherwise allowed communications to the interface address.
    Try disabling the ip audit feature on your outside interface.
    no ip audit interface OUTSIDE AP_OUTSIDE_INFO
    no ip audit interface OUTSIDE AP_OUTSIDE_ATTACK

  • A work flow to extract email address from mail

    Can anyone help me. I have a bunch of emails that contain text information including an email address. I want a Automator workflow that will extract the email addresses from the emails and then save them as a comma separated text file.

    Hi,
    Try this workflow:
    1) Get Selected Mail Items
    2) Run AppleScript
    In the "Run AppleScript", paste the following in:
    on run {input, parameters}
    set the output to {}
    repeat with i from 1 to count of the input
    set theMessage to item i of the input
    set theContent to ""
    tell application "Mail"
    set theContent to the content of theMessage
    end tell
    if theContent is not equal to "" then
    set output to (output & theContent)
    end if
    end repeat
    return output
    end run
    3) Run Shell Script
    In "Run Shell Script", select "/usr/bin/perl" in the shell popup and "to stdin" in the pass input popup. Then paste the following in:
    $input = join("", );
    @emails = ($input =~ /\b[A-Z0-9._%-]@[A-Z0-9.-]\.[A-Z]{2,4}\b/ig);
    while( @emails > 1 ) {
    print shift(@emails) . ", ";
    print @emails[0];
    4) New TextEdit Document
    If you select the mail messages that have the email information in them, then you can run the workflow and hopefully it does the right thing.
    Hope it helps!

  • How can I delete unwanted/inaccurate email addresses from the iPhone cache?

    How can I delete old / unwanted / inaccurate email addresses from the "suggestions cache" that keep popping up the moment I type in the first letter in on a fresh email address box?
    This is driving me mad! The London Store Apple Genius can only suggest either deleting my email account and then recreating it or totally reseting the iPhone to the original factory settings and then resynching it to my MacBook Pro to get everything back into the iPhone. However, he's not sure that this cache is not stored on the MacBook Pro during synching somewhere so I may well end up where I started! Allan Sampson answered my last "Help" topic, so I'm hoping he can beat the Apple Store Genius again!
    Over to the Forum and Allan.

    Hi Kelvin and everyone with the same problem.
    This used to be me and the painful solution ( for PC users ) is:
    Buy a Mac!
    Everything "talks" to each other and it all interfaces fine with the business world.
    Once you've adjusted to the ( much better ) Mac "culture" it all becomes clear and the
    backup service and advice is second to none. Not only that, everything works!
    Hope this helps......

  • Count total number of rows present in the schema

    Count total number of rows present in the schema including table, sequence, view
    Desirable Output
    table          Sequence     Views
    1000          20          1000

    You mean You need to count the No of Tables, View and Sequence Present in the Schema ??
    Hi Some thing like this,
    SELECT a.view_cnt AS "View Count", b.tab_cnt AS "Table Count",
           c.seq_cnt AS "Sequence Count"
      FROM (SELECT COUNT (*) view_cnt
              FROM USER_VIEWS) a,
           (SELECT COUNT (*) tab_cnt
              FROM USER_TABLES) b,
           (SELECT COUNT (*) seq_cnt
              FROM USER_SEQUENCES) cWhich give you,
    View Count      Table Count      Sequence Count
           153              878                   32Thanks,
    Shankar
    Edited by: Shankar Viji on Aug 28, 2012 3:03 AM

  • Count total rows?

    Hello,
    In some function of my program, I need to count total number of rows but, I don't need to fetch results. Only the number of rows.
    Is there any way to count the total number of result rows without fetch?
    In OCI ver.7, it was very simple.
    Just Call ofen() (OCIStmtFetch() in ver.8) without defining, but it's impossible that fetch without defining in Ver.8
    Is there any idea to solve this situation?
    I can defining and fetching just like normal process, but customer can send any SQL statement so, it can include LOBs.. and so on.
    It's very waste source codes and memory for just counting rows.
    Thank you

    One possibility is to execute a different statement
    (i.e. select count(*) from foo;) to get the number of
    rows directly. This would probably be the most efficient
    way to get the row count (since no row data is shipped
    with this statement).
    Unfortunately, I was unable to fetch rows w/o defining
    in OCI either (I got an ORA-24374), so I am not sure how
    you can get around this.
    Incidentallly, when fetching LOBs, I don't think that
    the entire lob is fetched, only the LOB locator. In this
    case, there is very little over head associated with the
    data transfer.
    Also, I believe that ofen() was doing roundtrips in the
    past, and my impression was that the latency of the
    roundtrip to the server (and not the associated latency
    of transferring the data) was the bottleneck here. Hence,
    there may not be as much of a performance penalty as
    expected for doing the extra client define with OCI
    v8. So you still might be able to use your old ofen logic
    (after replacing with OCIStmtExecute/OCIDefine) and not
    see a very high performance hit.
    Hope that helps out somewh

  • Clients not receiving addresses from DHCP

    I have a Cisco 2811 router and have configured it to be a DHCP server at a remote site.  It seems like it should be pretty straight forward to configure DHCP.  Apparently I'm missing something because I can't get clients to receive an address.  Below are the applicable parts of the config.  I also have tried associating the DHCP pool with the Claims vrf and that did not work either.
    ip dhcp excluded-address 10.10.30.0 10.10.30.99
    ip dhcp excluded-address 10.10.30.201 10.10.30.255
    ip dhcp pool Claims_Office
       network 10.10.30.0 255.255.255.0
       domain-name fmi.com
       default-router 10.10.30.253
       dns-server 10.10.10.191
       lease 7
    interface FastEthernet0/0
    description Claims Office
    vrf forwarding Claims
    ip address 10.10.30.253 255.255.255.0
    duplex auto
    speed auto
    no mop enabled
    interface FastEthernet0/0/0.1205
    description Claims Office
    vrf forwarding Claims
    encapsulation dot1Q 1205
    ip address 192.168.103.2 255.255.255.252

    Unfortunately that didn't work.  Here is the output before:
    Pool Claims_Office :
     Utilization mark (high/low)    : 100 / 0
     Subnet size (first/next)       : 0 / 0
     Total addresses                : 254
     Leased addresses               : 0
     Pending event                  : none
     1 subnet is currently in the pool :
     Current index        IP address range                    Leased addresses
     10.10.30.1           10.10.30.1       - 10.10.30.254      0
    And after:
    Pool Claims_Office :
     Utilization mark (high/low)    : 100 / 0
     Subnet size (first/next)       : 0 / 0
     Total addresses                : 254
     Leased addresses               : 0
     Pending event                  : none
     1 subnet is currently in the pool :
     Current index        IP address range                    Leased addresses
     10.10.30.1           10.10.30.1       - 10.10.30.254      0
    What I want is for it to assign addresses from 10.10.30.100-199

  • Counting Total No.of Idocs received in BPM

    Hi Experts,
                   My scenario is " I am getting three different Idocs from three interfaces. Now i want to count total number of idocs from all the interfaces and compare this count with the one of the idoc field(Which contains the total number of idocs send from the sender) if the count matches then i have to send this idocs to the receivers."
                   I have done the configuration as follows
    1.Fork step with three branches
    2.Loop, inside the loop Receive step,Container operation step with the property Assign for counting and one more container operation step for Appending.
    3.Transformation step
    4.Send step
            While doing this i am getting individual idoc counts but i want the sum of these three interfaces count. How can i get the count of all three interfaces.
            Can you please let me know.
    Thanks & Regards,
    Purushotham
    Edited by: Purshothamm Thenepalli on Aug 5, 2008 5:32 AM

    If you want to count every time u get an IDoc irrespective of the sender, you need to use multiple receiver steps for receiving each type of idoc and then count.
    It will be almost like a collect pattern at the receiving part in BPM.
    VJ
    Edited by: VijayaShankar Konam on Aug 4, 2008 11:53 PM

  • When I select an email address from the dropdown menu and hit return, Thunderbird then fills in a different email address. Yosemite upgrade?

    I just upgraded to OS X Yosemite and this new "feature" appeared. I often have several email addresses that contain the same set of characters. I just type the first few characters and then select the appropriate email address from the dropdown menu that appears. But if I hit return afterwards to enter another email address, the first address gets switched back automatically to the first one that appeared in the dropdown menu. The more characters I type, the more accurate it is, but it totally defeats the purpose of autofill if I have to type the entire email address! Anyone else having this problem? And can you guys please fix it? If you select something from the dropdown menu, it should stay selected.
    Thanks!

    This forum is filled with this same complaint. There is a bug reported on it. If and when they fix it is another question.
    Version 24.6 works if you want to go back to a working version.

  • Address Book imported all of my email addresses from Mail without warning

    My Address Book suddenly was full of new contacts, every single email I got in the past had it's sender copied to my address book without me importing anything. They were just there. A total mess. I now have to manually erase all the contacts I don't want
    How can I prevent this from happening again?

    I have no clue. Just opened Address Book today and there they were. stuff like [email protected], mails that I got only once, or five different email addresses from the same contact, each as a single contact file. I am no stranger to isync and address book, never experienced anything like that.
    cheers 1pic

  • Rating - Play count totals question ...

    Hi,
    I'd like to transfer the Rating & Play count totals to another computer (that has hopefully the same play list).
    How do I do this?
    Thanks.

    As you probably know, the rating and playcount are not stored in the song file itself; they are stored in the library and will be lost if you move the songs separately from the entire library.
    So, to preserve them, first consolidate your library (if it isn't already) using the command File > Library > Organize Library... > Consolidate Files, and then copy the entire iTunes folder to the new machine.

Maybe you are looking for

  • Itunes 7.1.1.5 will not execute.  Major Problem

    I've been using Itunes since 2005. Recently, for reasons I can't explain, it stopped working. I did not download or install any new programs, it just would no longer execute. I unistalled, and downloaded the most recent itunes 7.1.1.15, setup, and it

  • Need help on how to revert a backup

    By mistake just did an backup on an older version. My only problem is that the version did not had all my contacts. does anybody know  a way to revert the backup done? Please and Many thanks to all the community

  • Upgradation from 4.6C to ECC 6.0, FM RV_PRICE_PRINT_HEAD

    Hi SAP guys, Function module RV_PRICE_PRINT_HEAD is calling in 4.6c version with out unicode check and it's working fine.     CALL FUNCTION 'RV_PRICE_PRINT_HEAD'          EXPORTING               COMM_HEAD_I = KOMK               COMM_ITEM_I = KOMP    

  • How can I visit busy website without problem?

    Hello, I would like to visit this website http://indianvisa-bangladesh.nic.in/visa/Reprint.jsp but 6 to 10 am GMT+6 I can't visit it . Always busy or problem loading page. So, how can i visit this website without any problem or how can I visit this w

  • How does the decoder retrieve the quantized samples in this loop?

    please check the block diagram loop.  Attachments: Decoder.vi ‏23 KB