Debugging issue with WPF

Hello,
  I am trying to debug some of my code for a set of WPF buttons.   I am stuck with an issue that I cannot get around.  When I launch the debugger from Visual Studio 2013, I get the following in the web browser:
An error occurred in the application you were using
You can try the following:
Restart the application.
Click the "More Information" link below for
details about this error.
Less Information
<textarea cols="1" id="errorInfo" readonly="readonly" rows="1" style="width:752px;height:650px;display:block;" wrap="off">Startup URI: \\mrm2inc.com\Users\Michael.Mastro2\Documents\Visual
Studio 2013\Projects\HomeInventoryWebForms\HomeInventoryWebForms\bin\Debug\HomeInventoryWebForms.xbap Application Identity: file://mrm2inc.com/Users/Michael.Mastro2/Documents/Visual%20Studio%202013/Projects/HomeInventoryWebForms/HomeInventoryWebForms/bin/Debug/HomeInventoryWebForms.xbap#HomeInventoryWebForms.xbap,
Version=1.0.0.0, Culture=neutral, PublicKeyToken=fc075058c6cf26e0, processorArchitecture=msil/HomeInventoryWebForms.exe, Version=1.0.0.0, Culture=neutral, PublicKeyToken=fc075058c6cf26e0, processorArchitecture=msil, type=win32 System.Security.Policy.PolicyException:
Execution permission cannot be acquired. at System.Runtime.Hosting.ApplicationActivator.CreateInstanceHelper(AppDomainSetup adSetup) at System.Runtime.Hosting.ApplicationActivator.CreateInstance(ActivationContext activationContext, String[] activationCustomData)
at System.Windows.Interop.PresentationApplicationActivator.CreateInstance(ActivationContext actCtx) at System.Activator.CreateInstance(ActivationContext activationContext) at System.Windows.Interop.ApplicationLauncherXappDebug.Initialize() at System.Windows.Interop.DocObjHost.MS.Internal.AppModel.IBrowserHostServices.Run(String
path, String fragment, MimeType mime, String debugSecurityZoneURL, String applicationId, Object streamContainer, Object ucomLoadIStream, HostingFlags hostingFlags, INativeProgressPage nativeProgressPage, String progressAssemblyName, String progressClassName,
String errorAssemblyName, String errorClassName, IHostBrowser hostBrowser) ----------------------- PresentationHost.exe v4.0.41210.0 built by: Main - C:\Windows\SysWOW64\PresentationHost.exe ntdll.dll v6.3.9600.17031 (winblue_gdr.140221-1952) - C:\Windows\SYSTEM32\ntdll.dll
KERNEL32.DLL v6.3.9600.17031 (winblue_gdr.140221-1952) - C:\Windows\SYSTEM32\KERNEL32.DLL KERNELBASE.dll v6.3.9600.17031 (winblue_gdr.140221-1952) - C:\Windows\SYSTEM32\KERNELBASE.dll ADVAPI32.dll v6.3.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\ADVAPI32.dll
USER32.dll v6.3.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\USER32.dll msvcrt.dll v7.0.9600.17415 (winblue_r4.141028-1500) - C:\Windows\SYSTEM32\msvcrt.dll ole32.dll v6.3.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\ole32.dll OLEAUT32.dll
v6.3.9600.17415 - C:\Windows\SYSTEM32\OLEAUT32.dll mscoree.dll v6.3.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\mscoree.dll SHLWAPI.dll v6.3.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\SHLWAPI.dll WININET.dll v11.00.9600.16384
(winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\WININET.dll urlmon.dll v11.00.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\urlmon.dll SHELL32.dll v6.3.9600.17031 (winblue_gdr.140221-1952) - C:\Windows\SYSTEM32\SHELL32.dll sechost.dll v6.3.9600.16384
(winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\sechost.dll RPCRT4.dll v6.3.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\RPCRT4.dll GDI32.dll v6.3.9600.17415 (winblue_r4.141028-1500) - C:\Windows\SYSTEM32\GDI32.dll combase.dll v6.3.9600.16384
(winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\combase.dll iertutil.dll v11.00.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\iertutil.dll USERENV.dll v6.3.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\USERENV.dll SspiCli.dll v6.3.9600.17415
(winblue_r4.141028-1500) - C:\Windows\SYSTEM32\SspiCli.dll profapi.dll v6.3.9600.17415 (winblue_r4.141028-1500) - C:\Windows\SYSTEM32\profapi.dll CRYPTBASE.dll v6.3.9600.17415 (winblue_r4.141028-1500) - C:\Windows\SYSTEM32\CRYPTBASE.dll bcryptPrimitives.dll
v6.3.9600.17415 (winblue_r4.141028-1500) - C:\Windows\SYSTEM32\bcryptPrimitives.dll IMM32.DLL v6.3.9600.17415 (winblue_r4.141028-1500) - C:\Windows\system32\IMM32.DLL MSCTF.dll v6.3.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\MSCTF.dll shcore.dll
v6.3.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\shcore.dll PresentationHost_v0400.dll v4.0.30319.33440 built by: FX45W81RTMREL - C:\Windows\Microsoft.NET\Framework\v4.0.30319\WPF\PresentationHost_v0400.dll MSVCR120_CLR0400.dll v12.00.51670.34230
built by: FX452RTMGDR - C:\Windows\SYSTEM32\MSVCR120_CLR0400.dll VERSION.dll v6.3.9600.17415 (winblue_r4.141028-1500) - C:\Windows\SYSTEM32\VERSION.dll PSAPI.DLL v6.3.9600.17415 (winblue_r4.141028-1500) - C:\Windows\SYSTEM32\PSAPI.DLL kernel.appcore.dll v6.3.9600.17415
(winblue_r4.141028-1500) - C:\Windows\SYSTEM32\kernel.appcore.dll uxtheme.dll v6.3.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\system32\uxtheme.dll ltc_help32-91954.dll v1, 0, 0, 1 - C:\PROGRA~2\Raptr\ltc_help32-91954.dll WINTRUST.dll v6.3.9600.17415
(winblue_r4.141028-1500) - C:\Windows\SYSTEM32\WINTRUST.dll CRYPT32.dll v6.3.9600.16431 (winblue_gdr.131015-2301) - C:\Windows\SYSTEM32\CRYPT32.dll MSASN1.dll v6.3.9600.17415 (winblue_r4.141028-1500) - C:\Windows\SYSTEM32\MSASN1.dll clbcatq.dll v2001.12.10530.17415
(winblue_r4.141028-1500) - C:\Windows\SYSTEM32\clbcatq.dll CRYPTSP.dll v6.3.9600.17415 (winblue_r4.141028-1500) - C:\Windows\SYSTEM32\CRYPTSP.dll rsaenh.dll v6.3.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\system32\rsaenh.dll bcrypt.dll v6.3.9600.16384
(winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\bcrypt.dll ieproxy.dll v11.00.9600.17496 (winblue_r5.141121-1500) - C:\Program Files (x86)\Internet Explorer\ieproxy.dll PROPSYS.dll v7.00.9600.17031 (winblue_gdr.140221-1952) - C:\Windows\SYSTEM32\PROPSYS.dll
dfshim.dll v6.3.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\dfshim.dll mscoreei.dll v4.0.30319.34209 built by: FX452RTMGDR - C:\Windows\Microsoft.NET\Framework\v4.0.30319\mscoreei.dll clr.dll v4.0.30319.34209 built by: FX452RTMGDR - C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr.dll
Secur32.dll v6.3.9600.17415 (winblue_r4.141028-1500) - C:\Windows\SYSTEM32\Secur32.dll dwmapi.dll v6.3.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\system32\dwmapi.dll msxml3.dll v8.110.9600.17415 - C:\Windows\System32\msxml3.dll actxprxy.dll v6.3.9600.17416
(winblue_r4.141030-1500) - C:\Windows\SYSTEM32\actxprxy.dll sxs.dll v6.3.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\sxs.dll PresentationHostProxy.dll v6.3.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\PresentationHostProxy.dll
comctl32.dll v6.10 (winblue_rtm.130821-1623) - C:\Windows\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.9600.17415_none_a9ed7f470139b3c1\comctl32.dll mscorlib.ni.dll v4.0.30319.34209 built by: FX452RTMGDR - C:\Windows\assembly\NativeImages_v4.0.30319_32\mscorlib\d03a3ddcd6a395878751c5e90fa16915\mscorlib.ni.dll
System.ni.dll v4.0.30319.34239 built by: FX452RTMGDR - C:\Windows\assembly\NativeImages_v4.0.30319_32\System\1a6b5095c4416a37f9ca4cf4436d1311\System.ni.dll WindowsBase.ni.dll v4.0.30319.34209 built by: FX452RTMGDR - C:\Windows\assembly\NativeImages_v4.0.30319_32\WindowsBase\bb26d987467eca70ebc4beec29158d67\WindowsBase.ni.dll
PresentationCore.ni.dll v4.0.30319.34209 built by: FX452RTMGDR - C:\Windows\assembly\NativeImages_v4.0.30319_32\PresentationCore\24f6c80242420a1cea5cc254bf420027\PresentationCore.ni.dll PresentationFramework.ni.dll v4.0.30319.34209 - C:\Windows\assembly\NativeImages_v4.0.30319_32\Presentatio5ae0f00f#\4136b9a7a05c8f0e2c7e15600bc20b1b\PresentationFramework.ni.dll
dwrite.dll v6.3.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\dwrite.dll wpfgfx_v0400.dll v4.0.30319.34209 built by: FX452RTMGDR - C:\Windows\Microsoft.NET\Framework\v4.0.30319\WPF\wpfgfx_v0400.dll PresentationNative_v0400.dll v4.0.30319.33440
built by: FX45W81RTMREL - C:\Windows\Microsoft.NET\Framework\v4.0.30319\WPF\PresentationNative_v0400.dll System.Xaml.ni.dll v4.0.30319.34209 built by: FX452RTMGDR - C:\Windows\assembly\NativeImages_v4.0.30319_32\System.Xaml\d626184834dde3f4906aff139d4e5bbf\System.Xaml.ni.dll
clrjit.dll v4.0.30319.34209 built by: FX452RTMGDR - C:\Windows\Microsoft.NET\Framework\v4.0.30319\clrjit.dll System.Xml.ni.dll v4.0.30319.34230 built by: FX452RTMGDR - C:\Windows\assembly\NativeImages_v4.0.30319_32\System.Xml\9a349fb029581f4752d2c6cfcfeab816\System.Xml.ni.dll
System.Drawing.ni.dll v4.0.30319.34209 built by: FX452RTMGDR - C:\Windows\assembly\NativeImages_v4.0.30319_32\System.Drawing\d91798a9a9fcb450351fe8e49026a69f\System.Drawing.ni.dll System.Windows.Forms.ni.dll v4.0.30319.34209 built by: FX452RTMGDR - C:\Windows\assembly\NativeImages_v4.0.30319_32\System.Windows.Forms\a4d2243df4af8ab65ff74d436d449789\System.Windows.Forms.ni.dll
System.Security.ni.dll v4.0.30319.34209 built by: FX452RTMGDR - C:\Windows\assembly\NativeImages_v4.0.30319_32\System.Security\d72f65a6622be86134ba8c534acc10e5\System.Security.ni.dll System.Core.ni.dll v4.0.30319.34209 built by: FX452RTMGDR - C:\Windows\assembly\NativeImages_v4.0.30319_32\System.Core\794a3d83e77a53d6fc029c389f9cc408\System.Core.ni.dll
System.Deployment.ni.dll v4.0.30319.34243 built by: FX452RTMGDR - C:\Windows\assembly\NativeImages_v4.0.30319_32\System.Deployment\84fa9fa9c4be29612f8d268246a0353c\System.Deployment.ni.dll System.Configuration.ni.dll v4.0.30319.34209 built by: FX452RTMGDR
- C:\Windows\assembly\NativeImages_v4.0.30319_32\System.Configuration\b5b80f1284dfa1b883da48ed58ecbc47\System.Configuration.ni.dll gpapi.dll v6.3.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\gpapi.dll ncrypt.dll v6.3.9600.16384 (winblue_rtm.130821-1623)
- C:\Windows\SYSTEM32\ncrypt.dll NTASN1.dll v6.3.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\SYSTEM32\NTASN1.dll diasymreader.dll v12.0.20806.33440 built by: FX45W81RTMREL - C:\Windows\Microsoft.NET\Framework\v4.0.30319\diasymreader.dll uiautomationcore.dll
v7.2.9600.16384 (winblue_rtm.130821-1623) - C:\Windows\System32\uiautomationcore.dll </textarea>
Anyone have any ideas how to get around this issue, or fix the issue?
Michael R. Mastro II

You need to be able to debug your code.
This is a key ability.
So key that this is the first thing you should be thinking about with any development ( which isn't trivial. ).
Work out how to debug your application.
Stick break points in there and explore what is going on.
https://nirajrules.wordpress.com/2008/06/11/debugging-an-xbap-wcf-application-%E2%80%93-windows-vista-vsnet-2008/
Hope that helps.
Recent Technet articles:
Property List Editing ;  
Dynamic XAML

Similar Messages

  • IOS/AIR Running and Debugging Issues with Flash Builder

    I'm having very frustrating intermittent issues running and debugging Flex applications on an iPad 3rd generation retina with Flash Builder 4.7.
    Until this morning, launching on device using both standard and fast packaging worked pretty well. Every now and again, I'd get a dialog saying the packaging had completed successfully, but it hadn't. A quick change of the USB cable to another port on my iMac and it started working again. I'd also randomly get a "Error occurred while installing the application: Invalid <device> specified" error, which quickly went away.
    This morning, with the same code base, the same certificate and provisioning profiles, Flash Builder has only managed to successfully package and run my application on my iPad twice and I must have attempted to launch fifty or so times. Standard packaging, fast packaging and with and without the useLegacyAOT.
    Does this sound like a Flash Builder issue? Is my iMac USB driver dodgy? Has anybody else experienced this?
    Any help greatly welcomed!
    Thanks,
    Simon

    Hi I have had this problem sometimes. With my Mac Book Pro.
    Try making a new flex application and see if you have the same result.
    When I had this problem I created a new Application and copied every thing from my other application.
    This my be a hard solution but I don't no any others.

  • Debug issue with maven eclipse

    Hi,
    I am trying to debug my web application with eclipse.I am using maven as a build tool.
    I found this error:
    set INT_MAVEN_OPTS=-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,address=4000,server=y,suspend=y -Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=y,address=8000
    Preparing to Execute Maven in Debug Mode
    ERROR: JDWP unable to get necessary JVMTI capabilities. ["debugInit.c",L279]I am using:
    jdk1.5.0_15
    eclipse 3.3.0
    apache-maven-2.0.9
    Can anyone please tell me where is the problem?
    Thanks,

    Hello,
    Have you tried to generate Web Services using OracleAS using the Java command or Ant task to create services or clients?
    You can then compile and package the application.
    Take a look to the Oracle Web Service Assembler tools
    Regards
    Tugdual Grall

  • Debugging issues with one of my methods

    public Elevator selectFloor()
        Scanner stdIn = new Scanner(System.in);
        int newFloor;
        newFloor = stdIn.nextInt();
        System.out.print("Enter the floor that you'd like to go to ==> ");
        If((newFloor >= 0 && newFloor <= 100)) //determines if the new floor is valid
           If(newFloor>this.floor)       //determines if the new floor is higher
              do
              newFloor--;
              System.out.print(newFloor + " ");
              } while (newFloor>this.floor)
           } //end if statement
           else
              do
              newFloor++;
              System.out.print(newFloor + " ");
              } while(newFloor<this.floor) //end do loop
           } // end else
        this.floor = newFloor;
        } // end if statement (input validification)
        else
           System.out.println
           ("Invalid floor selection - must be between 1 and 100.");
        } // end else
           return this;
    } // end Elevator selectFloor class--------------------------------------------------------------------------------------------------------------------------------------------------
    .\Elevator.java:24: ';' expected
    If((newFloor >= 0 && newFloor <= 100)) //determines if the new floor is valid
    ^
    .\Elevator.java:26: ';' expected
    If(newFloor>this.floor) //determines if the new floor is higher
    ^
    .\Elevator.java:32: ';' expected
    } while (newFloor>this.floor)
    ^
    .\Elevator.java:34: 'else' without 'if'
    else
    ^
    .\Elevator.java:40: ';' expected
    } while(newFloor<this.floor) //end do loop
    ^
    .\Elevator.java:44: 'else' without 'if'
    else
    ^
    .\Elevator.java:24: cannot find symbol
    symbol : method If(boolean)
    location: class Elevator
    If((newFloor >= 0 && newFloor <= 100)) //determines if the new floor is valid
    ^
    .\Elevator.java:26: cannot find symbol
    symbol : method If(boolean)
    location: class Elevator
    If(newFloor>this.floor) //determines if the new floor is higher
    ^
    8 errors
    Tool completed with exit code 1
    I've spent massive amounts of time trying to resolve the issues. I do not understand exactly why the program is giving me issues about requiring a boolean and why I would want a print statement at the end of a while loop, or what's deal is with the if statements. These are the error messages I get when I try to compile the driver I wrote for it.

    Java is case sensitive. Keywords (like 'if') are not capitalized.
    Do While loops require a semicolon after the while.
    Sun provides tutorials on all of this.

  • Issue with WPF validation(IDataErrorInfo) and loading User control Dynamically

    I have a user control and i use (IDataErrorInfo) for validation the problem is when i load User control Dynamically the validation not appears for the first time but when i load it in design time it works what is the problem ? here is the user control
    <UserControl x:Class="WeaponLibrary.WeaponUserControl"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"
    xmlns:d="http://schemas.microsoft.com/expression/blend/2008"
    xmlns:local="clr-namespace:WeaponLibrary"
    xmlns:controls="http://metro.mahapps.com/winfx/xaml/controls"
    xmlns:ad="clr-namespace:DataAccessClassLibrary.ValidationRules;assembly=DataAccessClassLibrary"
    mc:Ignorable="d"
    d:DataContext="{d:DesignInstance local:WeaponUserControlViewModel}"
    Height="700" Width="730" FlowDirection="RightToLeft" Loaded="UserControl_Loaded" >
    <AdornerDecorator>
    <Expander IsExpanded="True" >
    <DockPanel>
    <WrapPanel DockPanel.Dock="Top" DataContext="{Binding Path=SelectedWeapon}">
    <StackPanel Width="315" Margin="20,0,10,0">
    <ComboBox x:Name="CmbWeaponType" IsReadOnly="True" IsEditable="True"
    ItemsSource="{Binding RelativeSource={RelativeSource FindAncestor,
    AncestorType={x:Type UserControl}}, Path=DataContext.WeaponTypeList,ValidatesOnNotifyDataErrors =True,ValidatesOnDataErrors=True,
    NotifyOnValidationError=True,UpdateSourceTrigger=PropertyChanged}" DisplayMemberPath="weaponTypeName" SelectedValuePath="ID" >
    <ComboBox.SelectedValue>
    <Binding Path="weaponTypeID" Mode="TwoWay"
    UpdateSourceTrigger="PropertyChanged" ValidatesOnNotifyDataErrors="True" NotifyOnValidationError="True">
    </Binding>
    </ComboBox.SelectedValue>
    </ComboBox>
    </StackPanel>
    <StackPanel Width="315" Margin="20,0,10,0" >
    <TextBox x:Name="TxtWeaponNumber" Width="315" Text="{Binding weaponNumber,UpdateSourceTrigger=PropertyChanged, NotifyOnValidationError=True ,ValidatesOnNotifyDataErrors=True,ValidatesOnDataErrors=True,NotifyOnSourceUpdated=True,NotifyOnTargetUpdated=True,ValidatesOnExceptions=True}" >
    <!--<TextBox.Text>
    <Binding Path="weaponNumber">
    <Binding.ValidationRules >
    <ad:RequiredRule ValidatesOnTargetUpdated="True" />
    </Binding.ValidationRules>
    </Binding>
    </TextBox.Text>-->
    </TextBox>
    </StackPanel>
    <StackPanel Width="315" Margin="20,0,10,0">
    <TextBox x:Name="TxtOwnership" Width="315"
    controls:TextBoxHelper.IsWaitingForData="True"
    Text="{Binding Path=ownership}" />
    </StackPanel>
    <StackPanel Width="315" Margin="20,0,10,0">
    <TextBox x:Name="TxtMagazineNumber" Width="315"
    controls:TextBoxHelper.IsWaitingForData="True"
    Text="{Binding Path=magazineNumber}" />
    </StackPanel>
    <StackPanel>
    <TextBox x:Name="TxtNotes" Margin="20,0,10,0" Width="660" Height="100"
    controls:TextBoxHelper.IsWaitingForData="True" Text="{Binding Path=note}" />
    </StackPanel>
    <StackPanel Width="660" Margin="10,10,10,0">
    <TextBlock Text="{Binding AllErrors}" Foreground="Red" >
    </TextBlock>
    </StackPanel >
    </WrapPanel>
    <DataGrid x:Name="DgvWeapons" Margin="0,10,0,10" VerticalContentAlignment="Center" ItemsSource="{Binding WeaponsList, Mode=OneWay,ValidatesOnNotifyDataErrors=False,NotifyOnValidationError=False}"
    HorizontalContentAlignment="Center" IsReadOnly="True" AlternatingRowBackground="{DynamicResource AccentColorBrush4}" SelectionMode="Single"
    CanUserDeleteRows="False" CanUserAddRows="False" AutoGenerateColumns="False" Width="657" SelectedItem="{Binding SelectedWeapon,ValidatesOnNotifyDataErrors=False,NotifyOnValidationError=False}" MouseLeftButtonDown="DgvWeapons_MouseLeftButtonDown">
    <DataGrid.Columns>
    <DataGridTextColumn Width="100" Binding="{Binding Path=WeaponTypeName}" />
    <DataGridTextColumn Width="100" Binding="{Binding Path=weaponNumber}"/>
    <DataGridTextColumn Width="100" Binding="{Binding Path=ownership}"/>
    <DataGridTextColumn Width="100" Binding="{Binding Path=magazineNumber}"/>
    <DataGridTextColumn Width="100" Binding="{Binding Path=note}"/>
    </DataGrid.Columns>
    </DataGrid>
    </DockPanel>
    </Expander>
    </AdornerDecorator>
    </UserControl>
    here is the code:
    var tabItem = new TabItem { Header = item.FormName };
    var adornerDecorator = new AdornerDecorator();
    var stackPanel = new StackPanel();
    stackPanel.Children.Add(item.MainForm);
    adornerDecorator.Child = stackPanel;
    tabItem.Content = adornerDecorator;
    tabItem.SetValue(ControlsHelper.HeaderFontSizeProperty, 18.0);
    MainTabControl.Items.Add(tabItem);

    hi
    i tried your way to know if there is an error
    the result is yes
    for the implementation of IDataErrorInfo
    here is the code :
    public string Error
                get
                    if (string.IsNullOrEmpty(weaponNumber))
                        return "error 1";
                    if (weaponTypeID == null || weaponTypeID == new Guid())
                        return "error2";
                    return string.Empty;
            public string this[string columnName]
                get
                    if (columnName == "weaponNumber")
                        bool valid = !string.IsNullOrEmpty(weaponNumber);
                        if (!valid)
                            return "error1";
                    if (columnName == "weaponTypeID")
                        bool valid = weaponTypeID != null && weaponTypeID != new Guid();
                        if (!valid)
                            return "error2";
                    return null;

  • Issue with CHECKIN_SEL_SUB

    Folks, are there any good ways to debug issues with the internal UCM services?
    I have a custom component that has a service where if we have a FILE with associated attached files, and we do an update of the metadata, it not only updates the MAIN file, but also finds/updates the metadata for any of those associated attached file.
    For the associated files, it checks out the current file version, copies it, updates the metadata (keeps the same acutal document), and then does a checkin using CHECKIN_SEL_SUB.
    When it gets to that service call, I get an error in the logs:
    caught throwable: intradoc.common.ServiceException: Unable to execute service CHECKIN_SEL_SUB and function addFiles.
    Stack:
    intradoc.server.ServiceRequestImplementor.buildServiceException(ServiceRequestImplementor.java:2115)
    intradoc.server.Service.buildServiceException(Service.java:2260)
    intradoc.server.Service.createServiceExceptionEx(Service.java:2254)
    intradoc.server.Service.createServiceException(Service.java:2249)
    intradoc.server.ServiceRequestImplementor.handleActionException(ServiceRequestImplementor.java:1766)
    intradoc.server.ServiceRequestImplementor.doAction(ServiceRequestImplementor.java:1716)
    intradoc.server.Service.doAction(Service.java:477)
    intradoc.server.ServiceRequestImplementor.doActions(ServiceRequestImplementor.java:1458)
    intradoc.server.Service.doActions(Service.java:472)
    intradoc.server.ServiceRequestImplementor.executeSubServiceCode(ServiceRequestImplementor.java:1322)
    intradoc.server.Service.executeSubServiceCode(Service.java:3866)
    intradoc.server.ServiceRequestImplementor.executeServiceEx(ServiceRequestImplementor.java:1200)
    intradoc.server.Service.executeServiceEx(Service.java:3861)
    intradoc.server.Service.executeService(Service.java:3845)
    moodys.epicm.MyDocServiceHandler.myMakeNewRevision(MyEpicmDocServiceHandler.java:440)
    There is no other information about this, and I don't have the 11g source code for the intradoc.jar file, so I can't step into the call.
    I also don't really have any good references to the UCM service calls, or any info about what to add to the tracing to watch the internal service calls.
    I have full verbose tracing setup with:
    system, idocscript, requestaudit, resourceloader
    It doesn't show anything more than the log file does:
         MY_META_ONLY [dID=817055][dDocName=EPICM_366100][dDocTitle=NNNNNN, LLC 345][dUser=xxxxxxxxxxxxx][xCollectionID=0][StatusCode=-32][StatusMessage=Unable to execute service CHECKIN_SEL_SUB and function addFiles.
    requestaudit/6     08.02 16:44:55.073     IdcServer-65     The error was caused by an internally generated issue. The error has been logged.] 28.65958023071289(secs)
    Any help greatly appreciated. BTW, this code used to work in 7.1.1 without errors (we have just upgraded to 11gr5).

    Thanks Jonathan for the help.
    I have added the "services" to the tracing., but it's not showing much for the CHECKIN_SEL_SUB:
    services/3     08.03 11:43:58.705     IdcServer-2     *ScriptStack CHECKIN_SEL_SUB
    services/3     08.03 11:43:58.705     IdcServer-2     3:myVisitAttachmentsByNames,dID=817058,dDocName=MY_366099MY_META_ONLY_SUB,dID=817058,dDocName=MY_3661003:myMakeNewRevision,dID=817057,dDocName=MY_366100CHECKIN_SEL_SUB,dID=817057,dDocName=MY_3661003:addFiles,dID=817059,dDocName=MY_366100
    services/3     08.03 11:43:58.705     IdcServer-2     at co.my.MYServiceHandler.myVisitAttachmentsByNames(MYServiceHandler.java:416)
    services/3     08.03 11:43:58.705     IdcServer-2     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    services/3     08.03 11:43:58.705     IdcServer-2     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    services.....
    As for why CHECKIN_SEL_SUB instead of CHECKIN_SEL, I don't really know. I inherited this code which was written in 2004 for Stellent 7.1.1 and I'm trying to get it to work in 11g. I can try to use the CHECKIN_SEL instead to see if that helps -- are there any changes required to call this vs CHECKIN_SEL_SUB?
    Also, for the m_binder.ToString(), a strange thing -- it throws a NullPointerException if I do this just before the call to the service. If I do it further up the stack, I get the values.
    Here is a snippet of the code:
                   // restore certain fields in LocalData that have been copied up
                   // from the previous revision
                   String[] fieldNamesToRestore = {
                        "dDocAuthor",
                        "dDocType",
                        "dSecurityGroup"
                   for (int i = 0; i < fieldNamesToRestore.length; ++i) {
                        String fieldName = fieldNamesToRestore;
                        String givenValue = myLocalDataGetSavedValue(fieldName);
                        if (givenValue != null) { // may be empty string
                             m_binder.putLocal(fieldName, givenValue);
                        } else {
                             m_binder.removeLocal(fieldName); // so it will get default value
                   myLocalDataSetDefaults();
    //DEBUG ONLY
                   String binderToString = m_binder.toString(); //<===== THIS WORKS
                   // clear out DOC_INFO's settable metadata fields, which came from the previous revision
                   // (walk the columns of the resultset to blank them out)
                   for (int fieldIndex = 0; fieldIndex < drsDocInfo.getNumFields(); ++fieldIndex)
                        String fieldName = drsDocInfo.getFieldName(fieldIndex);
                        if (myIsCustomMetadataField(fieldName) ||
                        myIsSettableBuiltinField(fieldName))
                             //DebugUtils.debugMsg(methodName + ": clearing from DOC_INFO: " + fieldName);
                             drsDocInfo.setCurrentValue(fieldIndex, null);
              //DEBUG
                   String tmpdrsDocInfoLastDID = ResultSetUtils.getValue(drsDocInfo, "dID");
                   String tmpBinderLastDID = m_binder.get("dID");
    //NullPointerException HERE:
                   //String binderToString = m_binder.toString(); //<====== NOTE do this here gives NullPointerException!
                   DebugUtils.debugMsg(methodName + ": calling CHECKIN_SEL_SUB");
                   m_service.executeService("CHECKIN_SEL_SUB");
              catch (Throwable th) {
                   errMsg = methodName + ": caught throwable: " + th + "\r\nStack:\r\n";
                   errMsg += DebugUtils.stackTraceToString(th.getStackTrace());
                   DebugUtils.debugMsg(errMsg);
              if (errMsg != null) {
                   // undo the checkout
                   try {
                        DebugUtils.debugMsg(methodName + ": undoing checkout.");
                        m_service.executeService("MY_UNDO_CHECKOUT_BY_NAME_SUB");
                   catch (Throwable th1) {
                        errMsg += "\n\n**and**\n\n UNDO_CHECKOUT_BY_NAME failed: " + th1;
                        errMsg += DebugUtils.stackTraceToString(th1.getStackTrace());
                        DebugUtils.debugMsg(errMsg);
                   throw new ServiceException(errMsg);

  • Performance Issues with Debugging even in Display Mode

    Hi not certain if this would sit in Security, ABAP or Basis, but lets start here as it is security related.
    S_DEVELOP with any activity on DEBUG on a production system is a concern, but what are the performance related issues when a super user has to go into debug in display only on a production system because of a really complex issue?
    I've heard in the past of a scenario where system performance was impacted, and we have notes around the allocation of S_DEVELOP display DEBUG access to this point. (I've summarised these below)
    The risk with debug is associated with the length of time that the actual debugging process is being performed.
    u2022     Work processes are dedicated solely to the users for the duration of the debug. If these are being performed for a long time, these can cause issues with not enough work processes being available.
    u2022     It can cause DB2 locks. If the debug session last awhile, DB2 locks are not released. This impacts the availability of tablespaces, thus, affecting various transactions running across the system.
    Even with these concerns, security will often get asked for debug display access.
    As security is about risk identification, assessment and then controlled access what do other organisations do?
    Options (not exhaustive) are "No Debug ever" or "Debug display only via a fire fight or super user on a time limited basis".
    We are currently in the "debug display only via fire fight" camp, but would like to canvas opinion on this.
    As one of the concepts of security is Availability of data (and to an extent ensuring the systems are up and running) do the performance risks push the security function to the "No Debug Ever" stance.

    If you need to debug in production, then 9 times out of 10 you need to do root-cause analysis: The developer is the problem.
    Writing sloppy code and not testing properly should not be an excuse for debugging in production.
    But of course, there are exceptions even when you do try to keep them to a minimum.
    To add to Jurjen's comments, also note that the debugger only has a limited capability of doing a rollback. So you can quite easily and unintentionally create inconsistencies in the system - also in display mode - which is an integrity problem, and typically more critical than availability problems or even potential confidentiality concerns.
    Cheers,
    Julius
    Edited by: Julius Bussche on May 15, 2009 10:50 AM

  • X99S GAMING 9 AC Not booting - Debug 94 code - Issue with GTX 980 SLI in WoW

    Hello, I bought the X99S GAMING 9 AC motherboard but have ran into some issues.
    The computer won't boot when I put my second MSI GTX 980 Gaming 4 GB card in the last PCEI 3.0 port (PCIE port 5) and I get the debug LED message 94 on the motherboard. I have a SLI setup.
    The first card I have in the second PCIE 3.0 port due to the Noctua U14S CPU fan takes up space for the first slot. So I have been running my grafic cards in PCIE slot 2 and 4 with some issues.
    First the card in slot 2 gets really warm over 86 celsius. And second: SLI runs really poorly in World of Warcraft. I get a lot higher performance with just one card activated. I am not sure if it's cause I am not running my cards in the recommended PCIE 3.0 ports or because WoW has some issues with SLI, but I heard other people have no issues at all with WoW in SLI.
    I got the same issue with 3Dmark firestrike, the cards perform really poor in SLI. I get higher score with SLI turned off..
    Though SLI seems to run pretty well in 3dmark 11 and Diablo 3 Reaper of Souls.
    But the main issue right now, is that the computer won't boot with the grafic cards in PCIE port 2 and 5. The solution to run them next to each other is not good, cause it gets really hot and I get bad performance in WoW and Firestrike.
    Picture of my setup before I switched places with the grafic cards as you can see, it is really tight:
    Any upcoming bios updates (got v1.3) that will solve this issue on the horization? Hopefully this get sorted out really soon..
    My whole computer setup:
    Intel i7 5820K | MSI X99S Gaming 9 AC (bios 1.3) | SLI MSI GTX 980 Gaming 4GB | Samsung 850 Pro 512 GB | WD Red 4TB | G.Skill Ripjaws DDR4 3000MHz 4x4GB | EVGA SuperNOVA P2 1000W | Noctua NH-U14S PnP | Fractal Design Define XL R2 | 5 Noctua NF-A14 PWM 140mm fans | Windows 7 Pro 64 bit

    You must use the recommended PCIE slots as the manual says for your CPU type, PCIE #1 and PCIE #4 if I remember, just open the manual :P for optimal 2Way SLI, also your 5820k will limit to 28 pcie lanes only if you plan to add more vgas...the other problem is your giant CPU air cooler blocking PCIE#1, do a favor to yourself, buy a watercooler for your 5820k and your problems are gone, add some overclock in your system, low noise and better temps.
    Here I use 3x980 in SLI with X99S Gaming 9 AC, going soon to WC the VGAs with EK blocks.....3way is far more temperature critical than 2way spaced one.
    Cheers

  • Issue with Multithreading and vertical scroll bar - help needed to debug!!!

    I have been working on a desktop Visual Studio 2010 application for quite a few years. It is written in C++ and MFC. This code is a combination of code I have written and code I inherited. It worked great for years on Windows XP, but when I ported
    it to Windows 7, a tricky problem has come up that I am having the darnest time trying to figure out
    In summary, it is a single .exe desktop application. There is the main thread (thread A), which launches another thread (thread B). Both threads share a pointer to a single window object which displays events. This window also implements a vertical and horizontal
    scroll bar. 
    The interaction and message processing between the threads seems a little sticky to me. Both threads A and B call the same member function of the CWnd object. BUT, Thread B ALSO posts messages to thread A's queue.
    So, in thread B, you will see code like this, which makes a direct call to the output window object, AND THEN it also posts a message to Thread A's mainframe window like this...
    if( m_pEventLog )
    pOutputWindow->AddLine("Some test...");
    if( m_phNotifyWnd[RECEIVE] && m_puiEventWMsg[RECEIVE] ) {
    ::PostMessage( m_phNotifyWnd[RECEIVE], m_puiEventWMsg[RECEIVE], 0, (LPARAM) pPkt );
    WHEN thread A receives the message that thread B posted above, it only does the following:
    LRESULT CMainFrame::OnSocketReceive( WPARAM, LPARAM lParam )
    CSPkt* pPkt;
    CRWPkt* pRWPkt;
    CSPktSocket* pSocket;
    ULONG ulType;
    CString csTemp;
    CBSWords bsWords;
    CSSSWords sssWords;
    CRWPkt* pLoopBackRWMsg; // used if we have to send a loopback msg back to sender
    CLMsg lmsg;
    m_wndTextWindow.AddLine("Test message");
    return 0;
    So both threads are writing to the output window via the .AddLine() member function.
    void COutputWnd::AddLine( CString& strLine, COLORREF crColor )
    UpdateVScroll();
    return;
    And this function then makes a call to :UpdateVScroll().  The problem seems to arise because thread B does a
    post to thread A, where thread A in turn writes to the output window. Eventually, the program
    HANGS in the call to
    SetScrollInfo() below...
    void COutputWnd::UpdateVScroll()
    CSingleLock lock( &m_CSVertScrollLock ); // lock things up while we are in here
    BOOL bok = lock.Lock();
    if (lock.IsLocked() == TRUE)
    int iMax = m_FifoIndices.GetHighestIndex();
    if( iMax < ( m_iMaxViewableLines - 1 ) )
    iMax = 0;
    //SetScrollRange( SB_VERT, 0, iMax, FALSE );
    //SetScrollRange( SB_VERT, 0, 9, FALSE );
    SCROLLINFO scrollinfo;
    scrollinfo.cbSize = sizeof(SCROLLINFO);
    scrollinfo.fMask = SIF_RANGE;
    scrollinfo.nMin=0;
    scrollinfo.nMax= iMax;
    SetScrollInfo(SB_VERT, &scrollinfo, FALSE);
    lock.Unlock();
    It doesn't take long for the program to hang...maybe about 10 seconds. 
    When I hit DEBUG->BREAK ALL, I get the output below in the CALL STACK WINDOW.
    ntdll.dll!770070f4()
    [Frames below may be incorrect and/or missing, no symbols loaded for ntdll.dll]
    user32.dll!76c0cde0()
    user32.dll!76c018d9()
    >
    mfc100d.dll!AfxInternalPumpMessage()  Line 153 + 0x13 bytes
    C++
    mfc100d.dll!CWinThread::PumpMessage()  Line 900
    C++
    mfc100d.dll!CWinThread::Run()  Line 629 + 0xd bytes
    C++
    mfc100d.dll!_AfxThreadEntry(void * pParam=0x0022f6a4)  Line 122 + 0x13 bytes
    C++
    msvcr100d.dll!_callthreadstartex()  Line 314 + 0xf bytes
    C
    msvcr100d.dll!_threadstartex(void * ptd=0x004f97c0)  Line 297
    C
    kernel32.dll!762cee1c()
    ntdll.dll!770237eb()
    ntdll.dll!770237be()
    NOTE: If I never make the call to SetScrollInfo(), the program never HANGS.
    Sooo....I am trying to determine if there is a fundamental issue with the way the threads are communicating that is causing the issue, or if maybe I have a memory overwrite. It always hangs in ::SetScrollInfo(), no matter what I comment and uncomment. This
    makes me think that scroll bat behavior is different in Windows 7 than on XP, but I have not been able to find any documentation about it. 
    Can anyone provide any insight as to what may be the cause of the program hanging>

    It might look like working but it will crash eventually. The windows are thread affine and other thread must never touch other threads windows. Sometimes you might get along but usually it just crashes.
    Thread B must use PostMessage ( or SendMessage if suncronous action is require) to thread A's windows to achieve correct updating. Some very basic calls are implemented directly with SendMessage so they are safe to use but then you must individually check
    which ones are safe.
    Also having multiple SendMessage calls from B to A require rendezvous which might cause other problems ( thread B stalls or program deadlocks, depending on other program structure).
    So PostMessage is the way to do it ( or create yourself another inter-thread mechanism, possible but usually too much troble)

  • Issue with java_g and -debug

    Is there an issue with the -debug option when running Weblogic 4.51 with
    the java_g command.
    Each time we include the -debug option we experience
    weblogic.common.LicenseCorruptException (s)
    The same error is experienced using java 1.1.7 on NT, Solaris(x86)2.7
    and Solaris (Sparc)2.7
    We are very keen to find out if there is a way of resolving this to
    allow us to do remote debugging.
    regards
    Duncan Alexander

    For some reason, using the custom classloaders in WLS causes unpredictable VM
    behavior in those VMs. For instance, you point out the LicenseCorruptError which
    occurs due to a io read error which doesn't occur when the same environment is
    run in non remote mode.
    There are some things you can do.
    First of all, use 1.2.2 instead of 1.1.7. That VM appears more stable.
    If you have to use 1.1.7 then:
    On NT, make sure you've updated to the 1.1.7_005.
    On Solaris 2.7, run the server in static mode. (You may also try 1.1.7_008, I
    haven't had a chance to check that version yet.)
    I don't know about Solaris x86.
    The VM problem occurs when using custom classloaders so run the server in static
    mode. You won't be able to hot deploy ejbs, but you will be able to remotely
    debug.
    Debuggers don't work well with custom classloaders anyway, especially on 1.1.7.
    Gets a little better on 1.2.2 but there's still holes in the JDI in this area.
    To run in static mode don't use weblogic.class.path, everything goes on the
    classpath. Make sure that /weblogic/classes/boot appears before
    /weblogic/classes.
    Also add -Dweblogic.system.disableWeblogicClassPath=true=true if you're using
    5.1.0.
    Dana Jeffries
    BEA Systems
    Duncan Alexander wrote:
    >
    Is there an issue with the -debug option when running Weblogic 4.51 with
    the java_g command.
    Each time we include the -debug option we experience
    weblogic.common.LicenseCorruptException (s)
    The same error is experienced using java 1.1.7 on NT, Solaris(x86)2.7
    and Solaris (Sparc)2.7
    We are very keen to find out if there is a way of resolving this to
    allow us to do remote debugging.
    regards
    Duncan Alexander

  • Issue with java_g and -debug (Response would be appreciated this time).

    Is there an issue with the -debug option when running Weblogic 4.51 with
    the java_g command.
    Each time we include the -debug option we experience
    weblogic.common.LicenseCorruptException (s)
    The same error is experienced using java 1.1.7 on NT, Solaris(x86)2.7
    and Solaris (Sparc)2.7
    We are very keen to find out if there is a way of resolving this to
    allow us to do remote debugging.
    regards
    Duncan Alexander

    For some reason, using the custom classloaders in WLS causes unpredictable VM
    behavior in those VMs. For instance, you point out the LicenseCorruptError which
    occurs due to a io read error which doesn't occur when the same environment is
    run in non remote mode.
    There are some things you can do.
    First of all, use 1.2.2 instead of 1.1.7. That VM appears more stable.
    If you have to use 1.1.7 then:
    On NT, make sure you've updated to the 1.1.7_005.
    On Solaris 2.7, run the server in static mode. (You may also try 1.1.7_008, I
    haven't had a chance to check that version yet.)
    I don't know about Solaris x86.
    The VM problem occurs when using custom classloaders so run the server in static
    mode. You won't be able to hot deploy ejbs, but you will be able to remotely
    debug.
    Debuggers don't work well with custom classloaders anyway, especially on 1.1.7.
    Gets a little better on 1.2.2 but there's still holes in the JDI in this area.
    To run in static mode don't use weblogic.class.path, everything goes on the
    classpath. Make sure that /weblogic/classes/boot appears before
    /weblogic/classes.
    Also add -Dweblogic.system.disableWeblogicClassPath=true=true if you're using
    5.1.0.
    Dana Jeffries
    BEA Systems
    Duncan Alexander wrote:
    >
    Is there an issue with the -debug option when running Weblogic 4.51 with
    the java_g command.
    Each time we include the -debug option we experience
    weblogic.common.LicenseCorruptException (s)
    The same error is experienced using java 1.1.7 on NT, Solaris(x86)2.7
    and Solaris (Sparc)2.7
    We are very keen to find out if there is a way of resolving this to
    allow us to do remote debugging.
    regards
    Duncan Alexander

  • An issue with authentication and authorization on ISE 1.2

    Hi, I'm new to ISE.
    I have an issue with authentication and authorization.
    I have ISE 1.2 plus patch 6 installed on VMware.
    I have built-in Windows XP supplicant and 2960 cisco switch with IOS c2960-lanbasek9-mz.150-2.SE5.bin
    On supplicant I use EAP(PEAP) with EAP-MSCHAP v2.
    I created  authentication and authorization rules with Active Directory  as External Identity Source. Also I applied  authorization profile with DACL.I login on Windows XP machine under different Active Directory accounts. Everything works fine (authentication, authorization ), but only for several hours. After several hours passed , authentication and authorization stop working . I can see that ISE trying authenticate and authorize users, but ISE always use only one account for  authentication and authorization . Even if I login under different accounts ISE continue to use only one last account.
    I traied to reboot switch and PC,but it didn’t help. Only rebooting of ISE helps. After ISE rebooting, authentication and authorization start to work properly for several hours.
    I don’t understand is it a glitch or I misconfigured ISE or switch, supplicant?
    What  should I do to resolve this issue?
    Switch configuration:
     testISE#sh runn
    Building configuration...
    Current configuration : 7103 bytes
    ! Last configuration change at 12:20:15Tue Apr 15 2014
    ! NVRAM config last updated at 10:35:02  Tue Apr 15 2014
    version 15.0
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname testISE
    boot-start-marker
    boot-end-marker
    no logging console
    logging monitor informational
    enable secret 5 ************
    enable password ********
    username radius-test password 0 ********
    username admin privilege 15 secret 5 ******************
    aaa new-model
    aaa authentication dot1x default group radius
    aaa authorization network default group radius
    aaa authorization auth-proxy default group radius
    aaa accounting update periodic 5
    aaa accounting dot1x default start-stop group radius
    aaa server radius dynamic-author
     client 172.16.0.90 server-key ********
    aaa session-id common
    clock timezone 4 0
    system mtu routing 1500
    authentication mac-move permit
    ip dhcp snooping vlan 1,22
    ip dhcp snooping
    ip domain-name elauloks
    ip device tracking probe use-svi
    ip device tracking
    epm logging
    crypto pki trustpoint TP-self-signed-1888913408
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-1888913408
     revocation-check none
     rsakeypair TP-self-signed-1888913408
    crypto pki certificate chain TP-self-signed-1888913408
    dot1x system-auth-control
    spanning-tree mode pvst
    spanning-tree extend system-id
    vlan internal allocation policy ascending
    ip ssh version 2
    interface FastEthernet0/5
     switchport mode access
     ip access-group ACL-ALLOW in
     authentication event fail action next-method
     authentication event server dead action reinitialize vlan 1
     authentication event server alive action reinitialize
     authentication host-mode multi-auth
     authentication open
     authentication order dot1x mab
     authentication priority dot1x mab
     authentication port-control auto
     authentication periodic
     authentication timer reauthenticate server
     authentication violation restrict
     mab
     dot1x pae authenticator
     dot1x timeout tx-period 10
     spanning-tree portfast
    interface FastEthernet0/6
     switchport mode access
     ip access-group ACL-ALLOW in
     authentication event fail action next-method
     authentication event server dead action reinitialize vlan 1
     authentication event server alive action reinitialize
     authentication order dot1x mab
     authentication priority dot1x mab
     authentication port-control auto
     authentication periodic
     authentication timer reauthenticate server
     authentication violation restrict
     mab
     dot1x pae authenticator
     dot1x timeout tx-period 10
     spanning-tree portfast
    interface FastEthernet0/7
    interface Vlan1
     ip address 172.16.0.204 255.255.240.0
     no ip route-cache
    ip default-gateway 172.16.0.1
    ip http server
    ip http secure-server
    ip access-list extended ACL-ALLOW
     deny   icmp any host 172.16.0.1
     permit ip any any
    ip radius source-interface Vlan1
    logging origin-id ip
    logging source-interface Vlan1
    logging host 172.16.0.90 transport udp port 20514
    snmp-server community public RO
    snmp-server community ciscoro RO
    snmp-server trap-source Vlan1
    snmp-server source-interface informs Vlan1
    snmp-server enable traps snmp linkdown linkup
    snmp-server enable traps mac-notification change move
    snmp-server host 172.16.0.90 ciscoro
    radius-server attribute 6 on-for-login-auth
    radius-server attribute 6 support-multiple
    radius-server attribute 8 include-in-access-req
    radius-server attribute 25 access-request include
    radius-server dead-criteria time 5 tries 3
    radius-server vsa send accounting
    radius-server vsa send authentication
    radius server ISE-Alex
     address ipv4 172.16.0.90 auth-port 1812 acct-port 1813
     automate-tester username radius-test idle-time 15
     key ******
    ntp server 172.16.0.1
    ntp server 172.16.0.5
    end

    Yes. Tried that (several times) didn't work.  5 people in my office, all with vers. 6.0.1 couldn't access their gmail accounts.  Kept getting error message that username and password invalid.  Finally solved the issue by using Microsoft Exchange and "m.google.com" as server and domain and that the trick.  Think there is an issue with imap.gmail.com and IOS 6.0.1.  I'm sure the 5 of us suddently experiencing this issue aren't the only ones.  Apple will figure it out.  Thanks.

  • Routing Issue with 3550 Switch

    I am having an issue with routing with one of my Cisco 3550 switches.  I know the 3550s are EoL but some of us have to work with what we have.
    I am using a 3550 on either side of a Layer 2 link.  The Layer 2 link is 2 Extreme Summit X-440 switches with Microwave between the switches.  I have a VLAN configured on both switches and tagged on the ports connected to the Microwave.  The 3550 switch on each end is configured for IP routing but I cannot pass traffic between the switches.  If I unplug the switch on the local end and plug in a laptop, I can ping the switch on the remote end and access devices at the remote end. 
    I know this should work because I am doing the same thing over another Microwave link and Layer 2 link using another 3550 and a HP ProCurve at the remote end.
    Here are the configs for each 3550:
    Local end;  Port Fa0/23 goes to the Remote Side.  Port Fa0/24 goes to the rest of the network
    Current configuration : 5417 bytes
    ! No configuration change since last restart
    version 12.2
    no service pad
    service timestamps debug datetime localtime show-timezone
    service timestamps log datetime localtime show-timezone
    no service password-encryption
    service sequence-numbers
    hostname Brindley3550
    enable secret 5 $1$3A.n$lzBUQg.fn4hJ7f0jEOqe71
    no aaa new-model
    clock timezone UTC -6
    clock summer-time UTC recurring 1 Sun Apr 2:00 1 Sun Nov 2:00
    mls qos map cos-dscp 0 8 16 26 32 46 48 56
    mls qos min-reserve 5 170
    mls qos min-reserve 6 10
    mls qos min-reserve 7 65
    mls qos min-reserve 8 26
    mls qos
    ip subnet-zero
    ip routing
    ip domain-name morgan911.net
    ip name-server 1.2.150.11
    ip name-server 1.2.150.5
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    vlan internal allocation policy ascending
    interface FastEthernet0/1
     switchport access vlan 18
     switchport mode dynamic desirable
     spanning-tree portfast
    {Removed for Brevity}
    |
    interface FastEthernet0/7
     switchport access vlan 13
     switchport mode dynamic desirable
     spanning-tree portfast
    interface FastEthernet0/8
     switchport access vlan 13
     switchport mode dynamic desirable
     spanning-tree portfast
    {Removed for Brevity}
    interface FastEthernet0/23
     description To Gum Springs via Extreme P10
     no switchport
     ip address 1.2.147.1 255.255.255.252
     speed 100
     duplex full
    interface FastEthernet0/24
     description To Flint via Ceragon Eth 2
     switchport trunk encapsulation dot1q
     switchport mode trunk
     speed 100
     duplex full
     mls qos trust cos
     auto qos voip trust
     wrr-queue bandwidth 20 1 80 1
     wrr-queue min-reserve 1 5
     wrr-queue min-reserve 2 6
     wrr-queue min-reserve 3 7
     wrr-queue min-reserve 4 8
     wrr-queue cos-map 1 0 1 2 4
     wrr-queue cos-map 3 3 6 7
     wrr-queue cos-map 4 5
     priority-queue out
     spanning-tree link-type point-to-point
    interface GigabitEthernet0/1
     switchport trunk encapsulation dot1q
     switchport mode trunk
    interface GigabitEthernet0/2
     switchport access vlan 10
     switchport trunk native vlan 50
     switchport mode dynamic desirable
     spanning-tree portfast trunk
    interface Vlan1
     ip address 1.2.145.2 255.255.255.0
    ip default-gateway 1.2.145.1
    ip classless
    ip route 0.0.0.0 0.0.0.0 1.2.145.1
    ip route 1.2.165.0 255.255.255.240 1.2.147.2
    ip route 1.2.166.0 255.255.255.240 1.2.147.2
    ip http server
    snmp-server community public RO
    snmp-server community public/RO RO
    snmp-server location Brindlee Mountain Tower Site
    snmp-server contact Jamey Wright
    snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
    snmp-server enable traps cluster
    snmp-server enable traps entity
    snmp-server enable traps envmon fan shutdown supply temperature
    snmp-server enable traps vtp
    snmp-server enable traps vlancreate
    snmp-server enable traps vlandelete
    snmp-server enable traps flash insertion removal
    snmp-server enable traps port-security
    snmp-server enable traps config
    snmp-server enable traps syslog
    snmp-server enable traps mac-notification
    snmp-server enable traps vlan-membership
    snmp-server host 1.2.150.100 public  tty envmon syslog snmp
    control-plane
    ntp clock-period 17180143
    ntp server 1.2.150.21
    end
    And this is the config for the remote end.  Port Fa0/24 is the port for the link back to the local end.
    Current configuration : 5058 bytes
    version 12.2
    no service pad
    service timestamps debug datetime localtime show-timezone
    service timestamps log datetime localtime show-timezone
    no service password-encryption
    service sequence-numbers
    hostname GS3550
    enable secret 5 $1$3A.n$lzBUQg.fn4hJ7f0jEOqe71
    no aaa new-model
    clock timezone UTC -6
    clock summer-time UTC recurring
    mls qos map cos-dscp 0 8 16 24 32 46 46 56
    udld aggressive
    ip subnet-zero
    ip routing
    ip domain-name morgan911.net
    ip name-server 1.2.150.11
    spanning-tree mode pvst
    spanning-tree extend system-id
    vlan internal allocation policy ascending
    interface FastEthernet0/1
     switchport access vlan 21
     switchport mode dynamic desirable
     spanning-tree portfast
    interface FastEthernet0/2
     switchport access vlan 21
     switchport mode dynamic desirable
     power inline delay shutdown 20 initial 300
     spanning-tree portfast
    {Removed for Brevity}
    interface FastEthernet0/23
     switchport access vlan 22
     switchport trunk encapsulation dot1q
     switchport mode trunk
     speed 100
     duplex full
     spanning-tree portfast
    interface FastEthernet0/24
     description To Brindlee via Extreme P10
     switchport mode dynamic desirable
    (Is a member of VLAN 1)
     speed 100
     spanning-tree portfast
    interface GigabitEthernet0/1
     switchport trunk encapsulation dot1q
     switchport mode trunk
    interface GigabitEthernet0/2
     switchport mode dynamic desirable
     spanning-tree portfast
    interface Vlan1
     ip address 1.2.147.2 255.255.255.252
    interface Vlan21
     ip address 1.2.165.1 255.255.255.240
     ip helper-address 1.2.150.11
     ip helper-address 1.2.150.5
    interface Vlan22
     ip address 1.2.166.1 255.255.255.240
     ip helper-address 1.2.150.5
     ip helper-address 1.2.150.11
    ip default-gateway 1.2.147.1
    ip classless
    ip route 0.0.0.0 0.0.0.0 1.2.147.1 10
    ip http server
    snmp-server community public RO
    snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
    snmp-server enable traps cluster
    snmp-server enable traps entity
    snmp-server enable traps envmon fan shutdown supply temperature
    snmp-server enable traps vtp
    snmp-server enable traps vlancreate
    snmp-server enable traps vlandelete
    snmp-server enable traps flash insertion removal
    snmp-server enable traps port-security
    snmp-server enable traps config
    snmp-server enable traps hsrp
    snmp-server enable traps bridge newroot topologychange
    snmp-server enable traps syslog
    snmp-server enable traps mac-notification
    snmp-server enable traps vlan-membership
    snmp-server host 1.2.150.100 public  envmon syslog snmp
    control-plane
    ntp clock-period 17180192
    ntp server 1.2.150.21 key 0 prefer
    Ideas?  Anything stand out as grossly wrong?  I have worked on this for 2 days and am at a loss.
    Thanks
    Jamey

    Sorry for the delay in replying.  Other items at the office took priority over this project.  I tried that and no change.  I pulled the switch from the remote site and took it back to the local end and connected the switches with a crossover cable and everything works fine.  I have pretty much determined that it is an issue with the config in one of the Extreme switches.  The config in those look pretty normal but there are a few things I am unsure of.  Guess I'll see if there is a similar site for Extreme gear.
    Thanks
    Jamey

  • Issue with LPCOR on CME 10.5

    Dear All,
    I am facing issues with LPCOR configuration on CME 10.5. For International calls the Authentication Prompts triggers some times and some times doen not.
    Also when a local call is dialed the Authentication Prompt is triggered some times.Below is the config and debug logs. Need your help to resolve this.
    voice lpcor enable
    voice lpcor custom
     group 10 endusers
     group 11 pstn
    voice lpcor policy endusers
     service fac
     accept endusers fac
     accept pstn fac
    voice lpcor policy pstn
     service fac
     accept endusers fac
     accept pstn fac
    application
     package auth
      param passwd-prompt flash:enter_pin.au
      param max-retries 0
      param abort-digit *
      param term-digit #
      param user-prompt flash:enter_account.au
      param passwd 12345
      param max-digits 32
    interface GigabitEthernet0/1.1
     encapsulation dot1Q 1 native
     ip address 10.25.76.1 255.255.255.0
    interface GigabitEthernet0/1.201
     encapsulation dot1Q 201
     ip address 10.25.77.1 255.255.255.0
    voice-port 0/0/0
     lpcor outgoing pstn
     trunk-group ALL_FXO 1
     supervisory disconnect dualtone mid-call
     supervisory custom-cptone 2n-gsm
     no battery-reversal
     input gain -6
     output attenuation -3
     cptone SA
     timeouts call-disconnect 1
     timeouts wait-release 1
     timing sup-disconnect 50
     connection plar 5040
     caller-id enable
     cable-detect
    dial-peer cor custom
     name local
     name longdistance
     name 911
     name Internal
     name fac-int
     name user-fac
    dial-peer cor list local
     member local
    dial-peer cor list call-local
     member local
    dial-peer cor list call-longdistance
     member longdistance
    dial-peer cor list user1
     member local
     member 911
    dial-peer cor list user2
     member local
     member longdistance
     member 911
     member user-fac
    dial-peer cor list user3
     member 911
    dial-peer cor list call-911
     member 911
    dial-peer cor list call-internal
     member Internal
    dial-peer cor list fac-int
     member local
     member 911
     member fac-int
    dial-peer cor list user-fac
     member user-fac
    dial-peer voice 96 pots
     trunkgroup ALL_FXO
     corlist outgoing call-911
     destination-pattern 9[2-6]......
     forward-digits 7
    dial-peer voice 901 pots
     trunkgroup ALL_FXO
     corlist outgoing call-911
     destination-pattern 901[2-4,6-8].......
     forward-digits 10
    dial-peer voice 800 pots
     trunkgroup ALL_FXO
     destination-pattern 9800T
     prefix 800
    dial-peer voice 900 pots
     destination-pattern 9T
     port 0/0/3
     prefix 9
    dial-peer voice 11 pots
     destination-pattern 901........
     port 0/0/3
     forward-digits 10
    dial-peer voice 9051 pots
     trunkgroup ALL_FXO
     corlist outgoing call-local
     destination-pattern 905........
     forward-digits 10
    dial-peer voice 19 pots
     trunkgroup ALL_FXO
     corlist outgoing fac-int
     destination-pattern 900T
     translate-outgoing called 1
     forward-digits all
    dial-peer voice 20 voip
     description International calling
     service clid_authen_collect
     destination-pattern 900T
     lpcor outgoing pstn
     session target ipv4:10.25.76.1
     incoming called-number 9T
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    ephone-dn  1
     number 4121
     name John
     corlist incoming fac-int
    ephone  1
     lpcor type local
     lpcor incoming endusers
     mac-address E0D1.730A.21DE
     ephone-template 2
     type 7942
     button  1:1
    voice register dn  33
     number 4163
     call-forward b2bua busy 5000 
     call-forward b2bua noan 5000 timeout 20
     call-forward b2bua unregistered 5000 
     allow watch
     name Joseph
     mwi
    voice register pool  33
     busy-trigger-per-button 4
     id mac BC67.1C31.C8AA
     type 7821
     number 1 dn 33
     cor incoming fac-int 1 4163
     dtmf-relay rtp-nte
     codec g711ulaw
     transfer max-length 4
    Debug Logs
    DAMAC-CME-ANOUD#DEBUg VOIce lpcor all
    voip lpcor all debugging is on
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#term
    DAMAC-CME-ANOUD#terminal i
    DAMAC-CME-ANOUD#terminal i
    Apr 12 16:22:39.825: %VOIPAAA-5-VOIP_CALL_HISTORY: CallLegType 1, ConnectionId F692C420E06611E4BB0CE7FDC5486EA5, SetupTime 16:22:35.615 UTC Sun Apr 12 2015, PeerAddress 4130, PeerSubAddress , DisconnectCause 10  , DisconnectText normal call clearing (16), ConnectTime 16:22:39.825 UTC Sun Apr 12 2015, DisconnectTime 16:22:39.825 UTC Sun Apr 12 2015, CallOrigin 2, ChargedUnits 0, InfoType 2, TransmitPackets 0, TransmitBytes 0, ReceivePackets 0, ReceiveBytes 0
    Apr 12 16:22:39.825: %VOIPAAA-5-VOIP_FEAT_HISTORY: FEAT_VSA=fn:TWC,ft:04/12/2015 16:22:35.609,cgn:4130,cdn:,frs:0,fid:2599,fcid:F692C420E06611E4BB0CE7FDC5486EA5,legID:284C,bguid:F692C420E06611E4BB0CE7FDC5486EA5mon
    DAMAC-CME-ANOUD#terminal imon
                              ^
    % Invalid input detected at '^' marker.
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    Apr 12 16:22:44.089: //-1/xxxxxxxxxxxx/LPCOR/lpcor_get_index_by_name:
       lpcor endusers
    Apr 12 16:22:44.089: //-1/xxxxxxxxxxxx/LPCOR/lpcor_get_index_by_name:
       lpcor endusers index 10
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#show debug
    VOIP LPCOR:
      debug voip lpcor error call is ON (filter is OFF)
      debug voip lpcor error call informational is ON (filter is OFF)
      debug voip lpcor error software is ON
      debug voip lpcor error software informational is ON
      debug voip lpcor detail is ON (filter is OFF)
      debug voip lpcor function is ON (filter is OFF)
      debug voip lpcor inout is ON (filter is OFF)
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    Apr 12 16:23:22.889: %VOIPAAA-5-VOIP_CALL_HISTORY: CallLegType 1, ConnectionId FBA1532AE06611E4BB10E7FDC5486EA5, SetupTime 16:22:44.089 UTC Sun Apr 12 2015, PeerAddress 4130, PeerSubAddress , DisconnectCause 10  , DisconnectText normal call clearing (16), ConnectTime 16:23:02.009 UTC Sun Apr 12 2015, DisconnectTime 16:23:22.889 UTC Sun Apr 12 2015, CallOrigin 2, ChargedUnits 0, InfoType 2, TransmitPackets 0, TransmitBytes 0, ReceivePackets 1038, ReceiveBytes 166080
    Apr 12 16:23:22.889: %VOIPAAA-5-VOIP_FEAT_HISTORY: FEAT_VSA=fn:TWC,ft:04/12/2015 16:22:44.093,cgn:4130,cdn:,frs:0,fid:2600,fcid:FBA1532AE06611E4BB10E7FDC5486EA5,legID:284D,bguid:FBA1532AE06611E4BB10E7FDC5486EA5
    Apr 12 16:23:22.905: %VOIPAAA-5-VOIP_CALL_HISTORY: CallLegType 1, ConnectionId FBA1532AE06611E4BB10E7FDC5486EA5, SetupTime 16:22:57.795 UTC Sun Apr 12 2015, PeerAddress 0097150107659, PeerSubAddress , DisconnectCause 10  , DisconnectText normal call clearing (16), ConnectTime 16:23:02.015 UTC Sun Apr 12 2015, DisconnectTime 16:23:22.905 UTC Sun Apr 12 2015, CallOrigin 1, ChargedUnits 0, InfoType 2, TransmitPackets 1038, TransmitBytes 174384, ReceivePackets 1043, ReceiveBytes 166880
    Apr 12 16:23:22.905: %VOIPAAA-5-VOIP_FEAT_HISTORY: FEAT_VSA=fn:TWC,ft:04/12/2015 16:22:57.785,cgn:4130,cdn:0097150107659,frs:0,fid:2601,fcid:FBA1532AE06611E4BB10E7FDC5486EA5,legID:284E,bguid:FBA1532AE06611E4BB10E7FDC5486EA5
    Apr 12 16:23:25.317: //-1/xxxxxxxxxxxx/LPCOR/lpcor_get_index_by_name:
       lpcor endusers
    Apr 12 16:23:25.317: //-1/xxxxxxxxxxxx/LPCOR/lpcor_get_index_by_name:
       lpcor endusers index 10
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#un all
    All possible debugging has been turned off
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#
    DAMAC-CME-ANOUD#!ok just send me these logs
    DAMAC-CME-ANOUD#!i have to move from here
    Apr 12 16:24:02.153: %VOIPAAA-5-VOIP_CALL_HISTORY: CallLegType 1, ConnectionId 14343755E06711E4BB16E7FDC5486EA5, SetupTime 16:23:25.323 UTC Sun Apr 12 2015, PeerAddress 4130, PeerSubAddress , DisconnectCause 10  , DisconnectText normal call clearing (16), ConnectTime 16:23:43.393 UTC Sun Apr 12 2015, DisconnectTime 16:24:02.153 UTC Sun Apr 12 2015, CallOrigin 2, ChargedUnits 0, InfoType 2, TransmitPackets 0, TransmitBytes 0, ReceivePackets 930, ReceiveBytes 148800
    Apr 12 16:24:02.153: %VOIPAAA-5-VOIP_FEAT_HISTORY: FEAT_VSA=fn:Tnow
    DAMAC-CME-ANOUD#\WC,ft:04/12/2015 16:23:25.321,cgn:4130,cdn:,frs:0,fid:2602,fcid:14343755E06711E4BB16E7FDC5486EA5,legID:2850,bguid:14343755E06711E4BB16E7FDC5486EA5
    Apr 12 16:24:02.169: %VOIPAAA-5-VOIP_CALL_HISTORY: CallLegType 1, ConnectionId 14343755E06711E4BB16E7FDC5486EA5, SetupTime 16:23:39.169 UTC Sun Apr 12 2015, PeerAddress 0097150107659, PeerSubAddress , DisconnectCause 10  , DisconnectText normal call clearing (16), ConnectTime 16:23:43.389 UTC Sun Apr 12 2015, DisconnectTime 16:24:02.169 UTC Sun Apr 12 2015, CallOrigin 1, ChargedUnits 0, InfoType 2, TransmitPackets 930, TransmitBytes 156240, ReceivePackets 937, ReceiveBytes 149920
    Apr 12 16:24:02.169: %VOIPAAA-5-VOIP_FEAT_HISTORY: FEAT_VSA=fn:TWC,ft:04/12/2015 16:23:39.169,cgn:4130,cdn:0097150107659,frs:0,fid:2603,fcid:14343755E06711E4BB16E7FDC5486EA5,legID:2851,bguid:14343755E06711E4BB16E7FDC5486EA5

    We have come across this issue today in 10.9.5 (so affects 10.9.4 as well) but it was occurring in Sydney as well with a client and for me in Melbourne.

  • Issue with Apex and IE , losing data for items on submit

    Hi All,
    I am facing one problem in APEX when i run my page on IE 8. When i submit the page i lose the data for all my items while the same does not happen on Firefox mozila and Google chorme.
    Actually i have one select list which has one dynamic action associated with it when i select the options from this list other object become enable and disable with that action and page get submit.
    but when i select this list in IE page get submit and my value which i selected also get lost.
    Please let me know if this is some issue with IE or Apex as soon as possible.
    This is bit urgent.
    Thanks

    Modify your code as below and run the page in debug mode and note the value shown for p610_x DECLARE
    l_vc_arr2 APEX_APPLICATION_GLOBAL.VC_ARR2;
    BEGIN
    wwv_flow.debug('value for p610_x is ' || :p610_x);
    l_vc_arr2 := APEX_UTIL.STRING_TO_TABLE(:P610_X,'~');
    FOR z IN 1..l_vc_arr2.count LOOP
    htp.p(l_vc_arr2(z) || '
    END LOOP;
    END;varad

Maybe you are looking for

  • Problem w/ HP 2575 after upgrade to Snow Leopard

    Upgraded to Snow Leopard last weekend. My HP Photosmart 2575 works fine with the Mac via the USB, but now is "not found" on the wireless network when my kids try to print from their PC (I know, switch them to a Mac - not happening right now!). The pr

  • Mirror iPod display to apple tv?

    If not already possible this would be a great use!! Imagine sharing your apps on the tv with family & friends

  • IMac/iPod Problems

    I have no idea if this is a problem with my iMac or with my iPod. I have an iMac G5 (no cam) and an iPod w/click wheel (40GB). Two weeks ago I connected my iPod to my Mac for the first time in a while in order to update it. I received an error from i

  • Downloading itunes 10.6

    I cant install iTunes latest version 10.6 on windows xp, anyone have any ideas? Ive removed old version as much as i can and anything apple related, it kept coming up, unable to remove old version at first, now it says it cant verify the signature. W

  • Automatically read last backup date

    I've noticed that whether or not the Time Machine volume is mounted, the icon in the menu bar displays the last backup date. Is there any way I can read this data from the command line? I found the excellent tms utility (http://fernlightning.com/doku